cc/td/doc/product/access/mar_3200
hometocprevnextglossaryfeedbacksearchhelp
PDF

Table Of Contents

Modems in a Mobile Environment

Roaming with External Wireless Modems

Configuration Example

Initialization Strings


Modems in a Mobile Environment


This chapter describes roaming with external wireless modems.

Roaming with External Wireless Modems

General Packed Radio Service/Code Division Multiplex Access (GPRS/CDMA) modems provide the mobile access router with a Layer 2 roaming interface. The Mobile IP stack allows layer 3 roaming IP connectivity for the mobile access router. External modems are connected to a serial interface of the mobile access router. The serial interface should be running in asynchronous mode. Figure 13-1 shows a sample scenario in which the serial port of the mobile access router is connected to a CDMA modem.

Figure 13-1 Modem to Mobile Access Router Connection

The mobile access router supports the following modems:

Airlink Raven

AnyDATA I-Port

Wavecom

Configuration Example

The example configurations shown in Figure 13-2 and Figure 13-3 demonstrate the router's ability to roam back and forth between 802.11b and Cellular technologies. The browser-based applications and video move dynamically to and from the different technologies. The 1X technology provides approximately 60 Kbps. The Nextel provides approximately 20 Kbps, but the network provides for static IP addresses and private links back to the headquarters. Implementing IPsec VPN in the mobile access router provides a secure connection back to the headquarters through 802.11b technology.

Figure 13-2 IPsec VPN Connection

Figure 13-3 Wireless Internet Connection

Example of a Mobile Access Router with Dialer Interface and GRE Mobile IP Tunneling

chat-script airlink-cdma "" "AT&C1&D2" TIMEOUT 30 OK "ATDT#19788" TIMEOUT 30 CONNECT
!
interface Loopback0
ip address 15.4.1.2 255.255.255.0
!
interface FastEthernet0/0
ip address 10.20.1.1 255.255.255.0
!
interface Serial1/0
physical-layer async
no ip address
encapsulation ppp
dialer in-band
dialer pool-member 1
dialer-group 1
!
interface Dialer0
ip address negotiated
ip nat outside
ip mobile router-service roam
ip mobile router-service collocated
encapsulation ppp
dialer pool 1
dialer idle-timeout 0
dialer string 1
dialer persistent
dialer-group 1
!
ip mobile secure home-agent 64.161.107.162 spi 100 key hex 12345678123456781234567812345678 algorithm md5 mode prefix-suffix
ip mobile router
address 15.4.1.2 255.255.255.0
home-agent 64.161.107.162
reverse-tunnel
tunnel mode gre
!
line 1
exec-timeout 0 5
flush-at-activation
script dialer airlink-cdma
modem InOut
no exec
transport input all
stopbits 1
speed 115200
flowcontrol hardware
line aux 0
exec-timeout 0 0
speed 115200
line vty 0 4
exec-timeout 0 0
password cisco
logging synchronous
login

Example of a Mobile Access Router Without Dialer Interface

hostname 3200
!
chat-script airlink-cdma "" "AT&C1&D0" TIMEOUT 30 OK "ATDT#19788" TIMEOUT 30 CONNECT
!
interface Loopback0
ip address 15.4.1.2 255.255.255.0
!
interface Serial1/0
physical-layer async
mtu 1450
bandwidth 115200
ip address negotiated
ip mobile router-service roam
ip mobile router-service collocated
encapsulation ppp
keepalive 900
dialer in-band
dialer idle-timeout 0
dialer string airlink-cdma
dialer-group 1
async default routing
async mode interactive
no peer default ip address
no fair-queue
no ppp lcp fast-start
!
router mobile
!
ip mobile secure home-agent 64.161.107.162 spi 100 key hex 12345678123456781234567812345678 algorithm md5 mode prefix-suffix
ip mobile router
address 15.4.1.2 255.255.255.0
home-agent 64.161.107.162
!
dialer-list 1 protocol ip permit
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
!
line 1
exec-timeout 0 0
flush-at-activation
script dialer airlink-cdma
login
modem InOut
no exec
transport input all
autoselect during-login
autoselect ppp
stopbits 1
speed 115200
flowcontrol hardware
!
line aux 0
exec-timeout 0 0
speed 115200
line vty 0 4
exec-timeout 0 0
password cisco
logging synchronous
login

Example of a Mobile Access Router with Multiple Wireless Connections

ip dhcp excluded-address 10.10.10.1
!
ip dhcp pool testpool
import all
network 10.10.10.0 255.255.255.0
default-router 10.10.10.1 255.255.255.0
dns-server 204.117.214.10
!
ip cef
chat-script airlink-cdma2 "" "ATDT#19788" TIMEOUT 60 "CONNECT"
chat-script tmobile "" "AT" TIMEOUT 5 OK "ATE0V1" TIMEOUT 5 OK "ATS0=0" TIMEOUT 5 OK "AT+CGATT=1" TIMEOUT 5 OK "AT+CGACT=1,1" TIMEOUT 5 OK "ATD*99***1#" TIMEOUT 10 CONNECT
chat-script anydata "" "AT&C1&D0" TIMEOUT 30 OK "ATDT#777" TIMEOUT 30 CONNECT
!
interface FastEthernet0/0
ip address 10.10.10.1 255.255.255.0
!
interface Serial2/0
physical-layer async
no ip address
encapsulation ppp
dialer in-band
dialer pool-member 1
dialer-group 1
no keepalive
!
interface Serial2/1
physical-layer async
no ip address
encapsulation ppp
shutdown
dialer in-band
dialer pool-member 2
no keepalive
!
interface Dialer0
ip address negotiated
ip mobile router-service roam priority 130
ip mobile router-service collocated registration retry 3
ip mobile router-service collocated
encapsulation ppp
dialer pool 1
dialer idle-timeout 0
dialer string 1
dialer persistent
dialer-group 1
ppp authentication pap callin optional
!
interface Dialer1
ip address negotiated
ip mobile router-service roam
ip mobile router-service collocated registration retry 3
ip mobile router-service collocated
encapsulation ppp
dialer pool 2
dialer idle-timeout 0
dialer string 2
dialer persistent
dialer-group 2
ppp chap hostname 4082029572
ppp chap password 0 vzw
!
ip mobile secure home-agent 64.161.107.162 spi 100 key ascii hello algorithm md5 mode prefix-suffix
ip mobile router
address 20.20.20.1 255.255.255.0
collocated single-tunnel
home-agent 64.161.107.162
mobile-network FastEthernet0/0
reverse-tunnel
tunnel mode gre
!
line 5
exec-timeout 0 5
flush-at-activation
script dialer airlink-cdma2
modem InOut
no exec
transport input all
stopbits 1
speed 115200
flowcontrol hardware
line 6
exec-timeout 0 5
flush-at-activation
script dialer anydata
modem InOut
no exec
transport input all
stopbits 1
speed 115200
flowcontrol hardware

Example of a Home Agent Configuration

hostname HomeAgent
!
ip subnet-zero
!
no ip domain-lookup
!
ip audit notify log
ip audit po max-events 100
!
fax interface-type fax-mail
mta receive maximum-recipients 0
!
interface Loopback0
ip address 10.10.100.1 255.255.255.0
!
interface FastEthernet0/0
ip address 64.161.107.162 255.255.255.248
duplex auto
speed auto
!
ip classless
ip route 0.0.0.0 0.0.0.0 64.161.107.161
ip http server
ip pim bidir-enable
ip mobile home-agent
ip mobile virtual-network 15.4.0.0 255.255.0.0
ip mobile host 15.4.1.2 virtual-network 15.4.0.0 255.255.0.0
ip mobile secure host 15.4.1.2 spi 100 key hex 12345678123456781234567812345678
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
exec-timeout 0 0
password cisco
logging synchronous
login
!
end

Initialization Strings

Recommended initialization strings for some common modems are provided in Table 13-1, but be aware that Cisco does not warrant that they are suitable or current. When in doubt, refer to the modem vendor's documentation or technical support.

Table 13-1 Modem Chat Scripts 

Modem
Network
Script

Airlink Raven

Sprint

chat-script airlink-cdma "" "ATDT#19788" TIMEOUT 60 "CONNECT"

Airlink Raven

Verizon

chat-script airlink-cdma "" "ATDT#19788" TIMEOUT 60 "CONNECT"

AnyDATA I-Port EMIII

Verizon

chat-script anydata "" "AT&C1&D0" TIMEOUT 30 OK "ATDT#777" TIMEOUT 30 CONNECT

Sony/Ericsson T68i Handset

AT&T

chat-script ericsson-gprs "" "AT" TIMEOUT 30 OK "ATE0Q0&C1&D2V1" TIMEOUT 60 OK "AT" TIMEOUT 30 OK "ATS0=0" TIMEOUT 30 OK "AT" TIMEOUT 30 OK "ATE0Q0&C1&D2V1" TIMEOUT 60 OK "AT" TIMEOUT 30 OK "ATDT*99***1#" TIMEOUT 30 CONNECT

Wavecom

T-Mobile or AT&T

chat-script tmobile "" "AT" TIMEOUT 5 OK "ATE0V1" TIMEOUT 5 OK "ATS0=0" TIMEOUT 5 OK "AT+CGATT=1" TIMEOUT 5 OK "AT+CGACT=1,1" TIMEOUT 5 OK "ATD*99***1#" TIMEOUT 10 CONNECT

Motorola i90c

Nextel

chat-script ModemTech "" "ATZ2" OK "AT&C1&D2" OK "ATDT" TIMEOUT 60 CONNECT



hometocprevnextglossaryfeedbacksearchhelp

Posted: Wed Nov 1 10:35:20 PST 2006
All contents are Copyright © 1992--2006 Cisco Systems, Inc. All rights reserved.
Important Notices and Privacy Statement.