cc/td/doc/product/access/ap/apm
hometocprevnextglossaryfeedbacksearchhelp
PDF

Table of Contents

Default Configuration Templates

Default Configuration Templates

This appendix provides the default configuration templates that are included with Cisco AccessPath Manager (APM).

These APM templates are text files that contain Cisco IOS command-line interface (CLI) commands and template variables. APM creates configuration files to download to the devices in your AccessPath system by substituting data for the template variables based on your entries:

You can also create custom configuration templates for your specific needs—see Chapter 5, "Managing Configuration Templates with APM."

If you want to download configuration files from APM to an AccessPath-LS3 system, you will need to create a custom configuration template for the Cisco 3640. See the section "ExampleConfiguring a Cisco AccessPath-LS3 System" in Chapter 5.


Note The configuration variables that APM modifies based on your input are in uppercase and are preceded by a pound sign (#). In addition, these variables are printed in bold in this appendix.

If you need additional information on Cisco IOS commands to help you use the templates, refer to the following documents:

Table C-1 lists the standard configuration templates for each type of AccessPath platform.


Table C-1: APM Standard Configuration Templates
System Template Supports

Cisco AccessPath-TS

Cisco 2511 (2511-default)

Cisco 2511

Cisco 7206 (7206-default)

Cisco 7206 using a Catalyst 5000 for switching

Cisco AS5200 (as5200-default-channelized)

Cisco AS5200s using channelized T1 or E1

Cisco AS5200 (as5200-default-pri)

Cisco AS5200s using PRI

Catalyst 5000 (cat5k-default)

Catalyst 5000

Cisco AccessPath-TS3

Cisco 3640 (3640-default)

Cisco 3640

Cisco 7206 without Catalyst 5002 (7206-default-entry)

Cisco 7206 using two Switch Blade cards for switching

Cisco 7206 with Catalyst 5002 (7206-default-midhigh)

Cisco 7206 using a Catalyst 5002 for its primary switching path

Cisco AS5300 (as5300-default-channelized)

Cisco AS5300s using channelized T1 or E1

Cisco AS5300 (as5300-default-pri)

Cisco AS5200s using PRI

Catalyst 5002 (cat5002-default)

Catalyst 5002

Templates for Use with Cisco AccessPath-TS Systems

Cisco 2511 (2511-default)

!
no service finger
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname #HOST_NAME
!
aaa new-model
aaa authentication login CONSOLE none
aaa authentication login ADMIN #AAA_AUTHEN_LOGIN_ADMIN local
aaa authentication ppp ADMIN if-needed #AAA_AUTHEN_PPP_ADMIN local
aaa accounting network start-stop #AAA_ACCOUNT
aaa accounting connection start-stop #AAA_ACCOUNT
aaa accounting exec start-stop #AAA_ACCOUNT
enable secret #SECRET
#EN_PASSWD
!
! for rcp
ip rcmd remote-username #R_USER_NAME
!
username #APM_USER password #APM_PASSWORD
ip subnet-zero
no ip source-route
no ip domain-lookup
ip #AAA_TYPE source-interface #MGMT_INTERFACE
#IP_NAME_SERVER
chat-script reset "" "AT&F2"
chat-script CLEARPORT "" "exit" "" "exit" "" "exit"
clock timezone #TIME_ZONE
#IF_SUMMER_TIME
clock summer-time #SUMMER_TIME
!
interface Loopback1
description "MGMT Network and Async17"
ip address #LB1_IP #LB1_NET_MASK
!
interface Ethernet0
description "MGMT LAN via Cat5k"
ip address #E0_IPADDR #E0_NET_MASK
no shutdown
no ip mroute-cache
no cdp enable
no mop enabled
!
interface Serial0
description "MGMT Backdoor to Offload01"
ip unnumbered Loopback1
no shutdown
no ip mroute-cache
no fair-queue
no cdp enable
!
interface Serial1
description "To optional MGMT WAN or Offload02"
! may assign ip address for Serial1
#SERIAL1_UP
no ip mroute-cache
no fair-queue
no cdp enable
!
interface Async17
description "OSS Modem Incoming Call"
ip unnumbered Loopback1
no ip mroute-cache
encapsulation ppp
async dynamic address
async mode interactive
peer default ip address #TERM_SVR_ASYNC17_IP
no fair-queue
no cdp enable
ppp authentication chap callin ADMIN
!
router eigrp #EIGRP_NO
#EIGRP_NETWORK
!
ip classless
#IF_LOGGING logging trap #LOGGING_LEVEL
#IF_LOGGING
logging facility #LOGGING_FACILITY
! logging source uses logging IP
#LOGGING_SRC
no access-list 10
access-list 10 permit #WS_IPADDR
!
no cdp run
!
snmp-server community #SNMP_READ RO
snmp-server community #SNMP_WRITE RW 10
snmp-server trap-source #MGMT_INTERFACE
snmp-server host #WS_IPADDR public
snmp-server location #SNMP_LOCATION
snmp-server contact #SNMP_CONTACT
snmp-server system-shutdown
#AAA_RADIUS_HOST_ADDR
#AAA_TACACS_HOST_ADDR
#AAA_RADIUS_TYPE-server
key #AAA_RADIUS_KEY
#AAA_TACACS_TYPE-server
key #AAA_TACACS_KEY
!
line con 0
session-timeout 45
exec-timeout 45 0
login authentication CONSOLE
line 1 16
script reset CLEARPORT
session-timeout 15
no exec
login authentication ADMIN
modem DTR-active
transport input all
flowcontrol hardware
line aux 0
exec-timeout 15 0
autoselect during-login
autoselect ppp
script startup reset
script reset reset
login authentication ADMIN
modem InOut
transport preferred none
transport input none
autohangup
rxspeed 38400
txspeed 38400
flowcontrol hardware
line vty 0 63
session-timeout 45
exec-timeout 45 0
password #LINE_PASSWD
login authentication ADMIN
!
#NTP_SERVERS
end

Cisco 7206 (7206-default)

!
!
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname #HOST_NAME
!
aaa new-model
aaa authentication login CONSOLE none
aaa authentication login ADMIN #AAA_AUTHEN_LOGIN_ADMIN local
#IF_MMPaaa authentication ppp USERS #AAA_AUTHEN_PPP_USERS
! uncomment the following line to use modem on AUX port
! aaa authentication ppp ADMIN if-needed #AAA_AUTHEN_PPP_ADMIN local
aaa authorization network #AAA_AUTHOR
aaa accounting network start-stop #AAA_ACCOUNT
aaa accounting connection start-stop #AAA_ACCOUNT
aaa accounting exec start-stop #AAA_ACCOUNT
#EN_PASSWD
enable secret #SECRET
!
! for copy rcp config file
username #APM_USER password #APM_PASSWORD
ip rcmd remote-username #R_USER_NAME
ip routing
!
username #SGBP_STACK_ID password #STACK_PWD
ip subnet-zero
no ip source-route
no ip domain-lookup
#IP_NAME_SERVER
ip #AAA_TYPE source-interface #MGMT_INTERFACE
#IF_MMP
multilink virtual-template #TEMPL_NO
!
#IF_MMPno sgbp group #SGBP_STACK_ID
!
#IF_MMPsgbp group #SGBP_STACK_ID
#IF_MMP
sgbp seed-bid offload
#IF_MMP sgbp source-ip #LB0_IP
!
! sgbp member will be built at run time.
! There is one per AS5200 neighbor member.
! Example: sgbp member nas01 4.2.1.1
#SGBP_MEMBER
! uncomment the following line to use modem on AUX port
! chat-script reset "" "AT&F2"
clock timezone #TIME_ZONE
#IF_SUMMER_TIME
clock summer-time #SUMMER_TIME
!
interface Loopback0
description "L2F tunnel Offload pseudo interface"
ip address #LB0_IP #LB0_NET_MASK
!
interface Loopback1
description "Management (SNMP & AAA) Offload pseudo interface"
ip address #LB1_IP #LB1_NET_MASK
!
interface FastEthernet0/0
description "Offload01 to Offload02 Backdoor Link"
#FE_BACK_DOOR_IP
!if mmp then generate ip summary address commands
#IP_SUMMARY_ADDR
full-duplex
media-type MII
no ip mroute-cache
! when 7206 fast switching is supported, the route-cache needs ! to be turned on
! for all interfaces.
ip route-cache
no lat enabled
no cdp enable
no mop enabled
no keepalive
no fair-queue
!
interface FastEthernet#FAST_ETHERNET_NO
description "To Stack via Cat5K"
ip address #FE_10_FIRST_IP #FE_10_FIRST_NET_MASK
ip address #FE_10_MGMT_IP #FE_10_MGMT_NET_MASK secondary
!if mmp then generate ip summary address commands
#IP_SUMMARY_ADDR
no ip mroute-cache
ip route-cache
default keepalive
full-duplex
no cdp enable
no mop enabled
no shutdown
!
! Serail config. Generate at run time.
! for example:
!interface Serial2/0
! description "Sync Serial backup to NAS01"
! ip unnumbered Loopback1
! clock rate 2000000
! if mmp then generate ip summary address commands
! *IP_SUMMARY_ADDR
! no fair-queue
! no ip mroute-cache
! ip route-cache
! no shutdown
#SERIAL_7206_1
#SERIAL_7206_2
#SERIAL_7206_3
#SERIAL_7206_4
#SERIAL_7206_5
#SERIAL_7206_6
#SERIAL_7206_7
#SERIAL_7206_8
#SERIAL_7206_9
#SERIAL_7206_a
#SERIAL_7206_b
#SERIAL_7206_c
#SERIAL_7206_d
#SERIAL_7206_e
!
! If dual offloads, the first offload Serial3/3 is for 2511,
! If single offload, the offload Serial5/3 is for 2511,
! for example:
!interface Serial3/3
! description "To CMS2511 Serial0"
! ip unnumbered Loopback1
! clock rate 2000000
! if mmp then generate ip summary address commands
! *IP_SUMMARY_ADDR
! no shutdown
! no ip mroute-cache
! ip route-cache
! no fair-queue
! no cdp enable
#SERIAL_CMS2511
!
! WAN slot
!
! if MMP then it needs virtual-Template, for example:
!interface virtual-Template#TEMPL_NO
! ip unnumbered Loopback0
! no ip mroute-cache
! ip route-cache
! no cdp enable
! peer default ip address pool default
! ppp authentication chap callin USERS
! ppp chap hostname #STACK_EXTERNAL_PWD
! ppp multilink
#RPS_VIRTUAL_TEMPLATE1
!
! uncomment the following 12 lines to use modem on AUX port
!interface Async 1
! description "OSS Modem Incoming Call"
! ip unnumbered Loopback1
! no ip mroute-cache
! encapsulation ppp
! async dynamic address
! async mode interactive
! peer default ip address #RPS_AUX_ASYNC1_IP
! no cdp enable
! no fair-queue
! ppp authentication chap callin ADMIN
!
router eigrp #EIGRP_NO
redistribute connected
passive-interface Loopback0
passive-interface Loopback1
#IF_MMP passive-interface Virtual-Template 1
redistribute static
#EIGRP_NETWORK
no auto-summary
!
#IF_MMPip local pool default #IP_LOCAL_BEGIN #IP_LOCAL_END
ip classless
ip route 0.0.0.0 0.0.0.0 #RPS_DEFAULT_ROUTE_IP
! ip http server
#IF_LOGGING logging trap #LOGGING_LEVEL
#IF_LOGGING
logging facility #LOGGING_FACILITY
! logging source uses logging IP
#LOGGING_SRC
no access-list 10
access-list 10 permit #WS_IPADDR
!no access-list 43
!access-list 43 deny #MGMT_NET_ADDR 0.0.0.31
!access-list 43 permit any
!no access-list 44
!access-list 44 0.0.0.0
!access-list 44 deny #MGMT_NET_ADDR 0.0.0.31
!access-list 44 permit any
!no access-list 46
!access-list 46 deny #MGMT_NET_ADDR 0.0.0.31
!access-list 46 permit any
!no access-list 47
!access-list 47 permit #MGMT_NET_ADDR 0.0.0.31
!access-list 47 deny any
no cdp run
!
snmp-server community #SNMP_READ RO
snmp-server community #SNMP_WRITE RW 10
! if in-band mgmt trap-source=Loopback0, oob mgmt trap-source=Loopback1
snmp-server trap-source #MGMT_INTERFACE
snmp-server host #WS_IPADDR public
snmp-server location #SNMP_LOCATION
snmp-server contact #SNMP_CONTACT
snmp-server system-shutdown
#AAA_RADIUS_HOST_ADDR
#AAA_TACACS_HOST_ADDR
#AAA_RADIUS_TYPE-server
key #AAA_RADIUS_KEY
#AAA_TACACS_TYPE-server
key #AAA_TACACS_KEY
!
line con 0
session-timeout 30
exec-timeout 15 0
logout-warning 60
login authentication CONSOLE
line aux 0
! uncomment the following aux lines to use modem on AUX port
! exec-timeout 15 0
! autoselect during-login
! autoselect ppp
! script startup reset
! script reset reset
! login authentication ADMIN
! modem InOut
! transport preferred none
! transport input none
! autohangup
! rxspeed 38400
! txspeed 38400
! flowcontrol hardware
line vty 0 4
session-timeout 45
exec-timeout 45 0
login authentication ADMIN
!
#NTP_SERVERS
#IF_NO_NTP
ntp source #MGMT_INTERFACE
#IF_2ND_OFFLOAD
ntp peer #PEER_OFFLOAD_YBD_IP
end

Cisco AS5200 (as5200-default-channelized)

!
!
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname #HOST_NAME
!
aaa new-model
aaa authentication login CONSOLE none
aaa authentication login ADMIN #AAA_AUTHEN_LOGIN_ADMIN local
aaa authentication login USERS #AAA_AUTHEN_LOGIN_USERS
aaa authentication ppp USERS&TUNNELS if-needed #AAA_AUTHEN_PPP_UT
! uncomment the following line to use modem on AUX port
! aaa authentication ppp ADMIN if-needed #AAA_AUTHEN_PPP_ADMIN local
aaa authorization network #AAA_AUTHOR if-authenticated
aaa accounting network start-stop #AAA_ACCOUNT
aaa accounting exec start-stop #AAA_ACCOUNT
aaa accounting connection start-stop #AAA_ACCOUNT
enable secret #SECRET
#EN_PASSWD
!
! for copy rcp config file
ip rcmd remote-username #R_USER_NAME
ip routing
username #APM_USER password #APM_PASSWORD
!
username #SGBP_STACK_ID password #STACK_PWD
ip subnet-zero
no ip source-route
no ip domain-lookup
#IP_NAME_SERVER
ip #AAA_TYPE source-interface #MGMT_INTERFACE
!
#ASYNC_DNS_SVR_ADDR
#ASYNC_NBNS_SVR_ADDR
#IF_VPDN vpdn enable
chat-script reset "" "AT&F2"
clock timezone #TIME_ZONE
#IF_SUMMER_TIME
clock summer-time #SUMMER_TIME
!
controller #T1_OR_E1 0
framing #FRAMING
#IF_FRAMING_ESF
fdl ansi
clock source line primary
linecode #LINECODE
! if North American no of isdn channel=24, European=31
cas-group 1 timeslots 1-#TIME_SLOTS type #CHANNEL_SIGNALLING
no shutdown
!
controller #T1_OR_E1 1
framing #FRAMING
#IF_FRAMING_ESF
fdl ansi
clock source line secondary
linecode #LINECODE
! if North American no of isdn channel=24, Europe=31
cas-group 1 timeslots 1-#TIME_SLOTS type #CHANNEL_SIGNALLING
no shutdown
!
interface Loopback0
description "L2F tunnel NAS pseudo interface"
ip address #LB0_IP #LB0_NET_MASK
!
interface Loopback1
description "Management (SNMP & AAA) NAS pseudo interface"
ip address #LB1_IP #LB1_NET_MASK
!
interface Ethernet0
description "To Offload Servers via Cat5k"
ip address #E0_IPADDR #E0_NET_MASK
#IP_SUMMARY_ADDR
no shutdown
no ip mroute-cache
ip route-cache
no lat enabled
no cdp enable
no mop enabled
default keepalive
no fair-queue
hold-queue 1000 in
hold-queue 1000 out
!
interface Serial0
description "Sync-Serial cable to Offload Server"
ip unnumbered Loopback1
#IP_SUMMARY_ADDR
no shutdown
no ip mroute-cache
ip route-cache
no fair-queue
no cdp enable
!
interface Serial1
no ip address
shutdown
!
interface Group-Async1
description "Async Incoming Call"
ip unnumbered Loopback0
encapsulation ppp
async dynamic address
!if token card, IF_TOKEN_CARD=interactive, otherwise =dedicated
async mode #ASYNC_MODE
no snmp trap link-status
peer default ip address pool default
no ip tcp header-compression
no ip mroute-cache
no mop enabled
no lat enabled
default keepalive
no fair-queue
no cdp enable
ppp authentication chap callin USERS&TUNNELS
ppp chap hostname #STACK_EXTERNAL_PWD
! US = 48, Roupean = 60
group-range 1 #INSTALLED_MODEMS
!
! uncomment the following 12 lines to use modem on AUX port
! US AUX_ASYNC_MODEM = 49, Eoupean AUX_ASYNC_MODEM = 61
!interface Async #AUX_ASYNC_MODEM
! description "OSS Modem Incoming Call"
! ip unnumbered Loopback1
! no ip mroute-cache
! encapsulation ppp
! async dynamic address
! async mode interactive
! peer default ip address pool default
! no cdp enable
! no fair-queue
! ppp authentication chap callin ADMIN
!
router eigrp #EIGRP_NO
redistribute connected
redistribute static
passive-interface Loopback0
passive-interface Loopback1
#EIGRP_NETWORK
no auto-summary
!
ip local pool default #IP_LOCAL_BEGIN #IP_LOCAL_END
ip classless
! ip http server
#IF_LOGGING logging trap #LOGGING_LEVEL
#IF_LOGGING
logging facility #LOGGING_FACILITY
! logging source uses logging ip
#LOGGING_SRC
no access-list 10
access-list 10 permit #WS_IPADDR
! no access-list 43
! access-list 43 deny #MGMT_NET_ADDR 0.0.0.31
! access-list 43 permit any
no cdp run
!
snmp-server community #SNMP_READ RO
snmp-server community #SNMP_WRITE RW 10
! if in-band mgmt trap-source=Loopback0, oob mgmt trap-source=Loopback1
snmp-server trap-source #MGMT_INTERFACE
snmp-server host #WS_IPADDR public
snmp-server location #SNMP_LOCATION
snmp-server contact #SNMP_CONTACT
snmp-server system-shutdown
dialer-list 1 protocol ip permit
#AAA_RADIUS_HOST_ADDR
#AAA_TACACS_HOST_ADDR
#AAA_RADIUS_TYPE
-server key #AAA_RADIUS_KEY
#AAA_TACACS_TYPE
-server key #AAA_TACACS_KEY
!
line con 0
session-timeout 30
exec-timeout 15 0
logout-warning 60
login authentication CONSOLE
line 1 #INSTALLED_MODEMS
script startup reset
script reset reset
#IF_GROUP_ASYNC_EXEC autoselect during-login
#IF_GROUP_ASYNC_EXEC autoselect ppp
login authentication USERS
modem InOut
transport preferred none
autohangup
line aux 0
! uncomment the following aux lines to use modem on AUX port
! exec-timeout 15 0
! autoselect during-login
! autoselect ppp
! script startup reset
! script reset reset
! login authentication ADMIN
! modem InOut
! transport preferred none
! transport input none
! autohangup
! rxspeed 38400
! txspeed 38400
! flowcontrol hardware
line vty 0 4
session-timeout 45
exec-timeout 45 0
login authentication ADMIN
!
#NTP_SERVERS
end

Cisco AS5200 (as5200-default-pri)

!
!
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname #HOST_NAME
!
aaa new-model
aaa authentication login CONSOLE none
aaa authentication login ADMIN #AAA_AUTHEN_LOGIN_ADMIN local
aaa authentication login USERS #AAA_AUTHEN_LOGIN_USERS
aaa authentication ppp USERS&TUNNELS if-needed #AAA_AUTHEN_PPP_UT
! uncomment the following line to use modem on AUX port
! aaa authentication ppp ADMIN if-needed #AAA_AUTHEN_PPP_ADMIN local
aaa authorization network #AAA_AUTHOR if-authenticated
aaa accounting network start-stop #AAA_ACCOUNT
aaa accounting exec start-stop #AAA_ACCOUNT
aaa accounting connection start-stop #AAA_ACCOUNT
enable secret #SECRET
#EN_PASSWD
!
! for copy rcp config file
ip rcmd remote-username #R_USER_NAME
ip routing
username #APM_USER password #APM_PASSWORD
!
username #SGBP_STACK_ID password #STACK_PWD
ip subnet-zero
no ip source-route
no ip domain-lookup
#IP_NAME_SERVER
ip #AAA_TYPE source-interface #MGMT_INTERFACE
!
#IF_MMPno sgbp group #SGBP_STACK_ID
!
#IF_MMPsgbp group #SGBP_STACK_ID
#IF_MMP
sgbp seed-bid forward-only
#IF_MMP sgbp source-ip #LB0_IP
! sgbp member will be built at run time. There is one per off-load server.
! Example: sgbp member offload01 4.2.1.1
#SGBP_MEMBER
#ASYNC_DNS_SVR_ADDR
#ASYNC_NBNS_SVR_ADDR
#IF_VPDN
vpdn enable
isdn switch-type #ISDN_SWITCH_TYPE
chat-script reset "" "AT&F2"
clock timezone #TIME_ZONE
#IF_SUMMER_TIME
clock summer-time #SUMMER_TIME
!
controller #T1_OR_E1 0
framing #FRAMING
#IF_FRAMING_ESF
fdl ansi
clock source line primary
linecode #LINECODE
! if North American no of isdn channel=24, European=31
pri-group timeslots 1-#TIME_SLOTS
no shutdown
!
controller #T1_OR_E1 1
framing #FRAMING
#IF_FRAMING_ESF
fdl ansi
clock source line secondary
linecode #LINECODE
! if North American no of isdn channel=24, Europe=31
pri-group timeslots 1-#TIME_SLOTS
no shutdown
!
interface Loopback0
description "L2F tunnel NAS pseudo interface"
ip address #LB0_IP #LB0_NET_MASK
!
interface Loopback1
description "Management (SNMP & AAA) NAS pseudo interface"
ip address #LB1_IP #LB1_NET_MASK
!
interface Ethernet0
description "To Offload Servers via Cat5k"
ip address #E0_IPADDR #E0_NET_MASK
#IP_SUMMARY_ADDR
no shutdown
no ip mroute-cache
ip route-cache
no lat enabled
no cdp enable
no mop enabled
default keepalive
no fair-queue
hold-queue 1000 in
hold-queue 1000 out
!
interface Serial0
description "Sync-Serial cable to Offload Server"
ip unnumbered Loopback1
#IP_SUMMARY_ADDR
no shutdown
no ip mroute-cache
ip route-cache
no fair-queue
no cdp enable
!
interface Serial1
no ip address
shutdown
!
! if North American isdn d channel=23, European=15
interface Serial0:#PRI_D_CHANNEL
description "PRI D channel"
ip unnumbered Loopback0
no ip mroute-cache
encapsulation ppp
isdn incoming-voice modem
peer default ip address pool default
no fair-queue
no cdp enable
no shutdown
dialer-group 1
ppp authentication chap callin USERS&TUNNELS
ppp chap hostname #STACK_EXTERNAL_PWD
#IF_MMP
ppp multilink
!
interface Serial1:#PRI_D_CHANNEL
description "PRI D channel"
ip unnumbered Loopback0
no ip mroute-cache
encapsulation ppp
isdn incoming-voice modem
peer default ip address pool default
no fair-queue
no cdp enable
no shutdown
dialer-group 1
ppp authentication chap callin USERS&TUNNELS
ppp chap hostname #STACK_EXTERNAL_PWD
#IF_MMP
ppp multilink
!
interface Group-Async1
description "Async Incoming Call"
ip unnumbered Loopback0
encapsulation ppp
async dynamic address
!if token card, IF_TOKEN_CARD=interactive, otherwise =dedicated
async mode #ASYNC_MODE
no snmp trap link-status
peer default ip address pool default
no ip tcp header-compression
no ip mroute-cache
no mop enabled
no lat enabled
default keepalive
no fair-queue
no cdp enable
ppp authentication chap callin USERS&TUNNELS
ppp chap hostname #STACK_EXTERNAL_PWD
! US = 48, Roupean = 60
group-range 1 #INSTALLED_MODEMS
!
! uncomment the following 12 lines to use modem on AUX port
! US AUX_ASYNC_MODEM = 49, Eoupean AUX_ASYNC_MODEM = 61
!interface Async #AUX_ASYNC_MODEM
! description "OSS Modem Incoming Call"
! ip unnumbered Loopback1
! no ip mroute-cache
! encapsulation ppp
! async dynamic address
! async mode interactive
! peer default ip address pool default
! no cdp enable
! no fair-queue
! ppp authentication chap callin ADMIN
!
router eigrp #EIGRP_NO
redistribute connected
redistribute static
passive-interface Loopback0
passive-interface Loopback1
passive-interface Serial0:#PRI_D_CHANNEL
passive-interface Serial1:#PRI_D_CHANNEL
#EIGRP_NETWORK
no auto-summary
!
ip local pool default #IP_LOCAL_BEGIN #IP_LOCAL_END
ip classless
! ip http server
#IF_LOGGING logging trap #LOGGING_LEVEL
#IF_LOGGING
logging facility #LOGGING_FACILITY
! logging source uses logging ip
#LOGGING_SRC
no access-list 10
access-list 10 permit #WS_IPADDR
! no access-list 43
! access-list 43 deny #MGMT_NET_ADDR 0.0.0.31
! access-list 43 permit any
no cdp run
!
snmp-server community #SNMP_READ RO
snmp-server community #SNMP_WRITE RW 10
! if in-band mgmt trap-source=Loopback0, oob mgmt trap-source=Loopback1
snmp-server trap-source #MGMT_INTERFACE
snmp-server host #WS_IPADDR public
snmp-server location #SNMP_LOCATION
snmp-server contact #SNMP_CONTACT
snmp-server system-shutdown
dialer-list 1 protocol ip permit
#AAA_RADIUS_HOST_ADDR
#AAA_TACACS_HOST_ADDR
#AAA_RADIUS_TYPE
-server key #AAA_RADIUS_KEY
#AAA_TACACS_TYPE
-server key #AAA_TACACS_KEY
!
line con 0
session-timeout 30
exec-timeout 15 0
logout-warning 60
login authentication CONSOLE
line 1 #INSTALLED_MODEMS
script startup reset
script reset reset
#IF_GROUP_ASYNC_EXEC autoselect during-login
#IF_GROUP_ASYNC_EXEC autoselect ppp
login authentication USERS
modem InOut
transport preferred none
autohangup
line aux 0
! uncomment the following aux lines to use modem on AUX port
! exec-timeout 15 0
! autoselect during-login
! autoselect ppp
! script startup reset
! script reset reset
! login authentication ADMIN
! modem InOut
! transport preferred none
! transport input none
! autohangup
! rxspeed 38400
! txspeed 38400
! flowcontrol hardware
line vty 0 4
session-timeout 45
exec-timeout 45 0
login authentication ADMIN
!
#NTP_SERVERS
end

Catalyst 5000 (cat5k-default)

!
!begin
set prompt #SGBP_STACK_ID>
set length 24 default
set logout 20
!
#system
set system baud 9600
set system modem disable
set system name #SGBP_STACK_ID
set system location #SNMP_LOCATION
set system contact #SNMP_CONTACT
!
#snmp
set snmp community read-only #SNMP_READ
set snmp community read-write #SNMP_WRITE
set snmp community read-write-all #SNMP_ALL
set snmp rmon disable
set snmp trap enable module
set snmp trap enable chassis
set snmp trap disable bridge
set snmp trap disable repeater
set snmp trap enable vtp
set snmp trap enable auth
!
#vtp
set vtp domain #SGBP_STACK_ID mode server
set vlan 1 name default type ethernet mtu 1500 said 100001 state active
set vlan 11 name VLAN0011 type ethernet mtu 1500 said 100011 state active
set vlan 22 name VLAN0022 type ethernet mtu 1500 said 100022 state active
set vlan 1002 name fddi-default type fddi mtu 1500 said 101002 state active parent 0 ring 0
set vlan 1003 name token-ring-default type token_ring mtu 1500 said 101003 state active parent 0 ring 0
set vlan 1004 name fddinet-default type fddi_net mtu 1500 said 101004 state active bridge 0 stp ieee
set vlan 1005 name trnet-default type tr_net mtu 1500 said 101005 state active bridge 0 stp ieee
!
#ip
set interface sc0 1 #SC0_IP #SCO_NET_MASK #MGMT_NET_BCAST_IP

set interface sl0 0.0.0.0 0.0.0.0
set arp agingtime 1200
set ip redirect enable
set ip unreachable enable
set ip fragmentation enable
set ip route 0.0.0.0 #OFLD1_10MGMT_IP 1
set ip alias default 0.0.0.0
!
#Command alias
!
#switch port analyzer
set span 1 1/1 both
set span disable
!
#bridge
set bridge ipx snaptoether 8023raw
set bridge ipx 8022toether 8023
set bridge ipx 8023rawtofddi snap
!
#vlan
set vlan 1 3/12
set vlan 1 1/1-2
set vlan 1 2/1-12
set vlan 1 3/1-11
!
#syslog
set logging console enable
set logging server enable
! use logging ip for the logging server address, for example:
! set logging server 192.168.10.1
#CAT_LOGGING_SERVER
set logging level cdp 2 default
set logging level cgmp 2 default
set logging level disl 5 default
set logging level dvlan 2 default
set logging level earl 2 default
set logging level fddi 2 default
set logging level ip 2 default
set logging level pruning 2 default
set logging level snmp 2 default
set logging level spantree 2 default
set logging level sys 5 default
set logging level tac 2 default
set logging level tcp 2 default
set logging level telnet 2 default
set logging level tftp 2 default
set logging level vtp 2 default
set logging level vmps 2 default
!
#ntp
set ntp broadcastclient disable
set ntp broadcastdelay 3000
set ntp client enable

! use offload's Loopback1 IP for ntp server address, for example:
!set ntp server 192.168.1.25
!set ntp server 192.168.1.26
#NTP_SERVERS
!set timezone EST -5 0
set timezone #TIME_ZONE 0
!set summertime enable EDT
#IF_SUMMER_TIMEset summertime enable #SUMMER_TIME
!
#cam
set cam agingtime 1 300
set cam agingtime 11 300
set cam agingtime 22 300
!
#cdp
set cdp enable 1/1-2
set cdp disable 2/1-12
set cdp disable 3/1-12
set cdp interval 1/1-2 60
!
#trunks
set trunk 1/1 auto 1-1000
set trunk 1/2 auto 1-1000
!
#spantree
#vlan 1
set spantree enable 1
set spantree fwddelay 15 1
set spantree hello 2 1
set spantree maxage 20 1
set spantree priority 32768 1
#vlan 11
set spantree enable 1
set spantree fwddelay 15 1
set spantree hello 2 1
set spantree maxage 20 1
set spantree priority 32768 1
#vlan 22
set spantree enable 1
set spantree fwddelay 15 1
set spantree hello 2 1
set spantree maxage 20 1
set spantree priority 32768 1
!
#trunk
set spantree portfast 1/1-2 enable
set spantree portfast 2/1-12 disable
set spantree portfast 3/1-12 disable
!
#module 1
set module name 1
set port enable 1/1-2
set port level 1/1-2 high
set port duplex 1/1-2 full
set port trap 1/1-2 enable
set port name 1/1 Ofld-01
set port name 1/2 Ofld-02
!
#module 2
set module name 2
set module enable 2
set port enable 2/1-12
set port speed 2/1-12 auto
set port level 2/1-12 normal
set port duplex 2/1-12 half
set port trap 2/1-12 enable
set port name 2/1 nas01
set port name 2/2 nas03
set port name 2/3 nas05
set port name 2/4 nas07
set port name 2/5 nas09
set port name 2/6 nas11
set port name 2/7 nas13
!
#module 3
set module name 3
set module enable 3
set port enable 3/1-12
set port level 3/1-12 normal
set port speed 3/1-12 auto
set port duplex 3/1-12 half
set port trap 3/1-12 enable
set port name 3/1 nas02
set port name 3/2 nas04
set port name 3/3 nas06
set port name 3/4 nas08
set port name 3/5 nas10
set port name 3/6 nas12
set port name 3/7 nas14
set port name 3/12 cms2511
!
#module 4 empty
!
#module 5 empty
!end

Templates for Use with Cisco AccessPath-TS3 Systems

Cisco 3640 (3640-default)

! Document Number ENG-17216
! Revision 2.5
! Copyright 1997 Cisco Systems, Inc. -- Company Confidential
!
!
no service finger
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname #HOST_NAME
!
aaa new-model
aaa authentication login CONSOLE none
aaa authentication login ADMIN #AAA_AUTHEN_LOGIN_ADMIN local
aaa authentication ppp ADMIN if-needed #AAA_AUTHEN_PPP_ADMIN local
aaa authorization network #AAA_AUTHOR
aaa accounting network start-stop #AAA_ACCOUNT
aaa accounting connection start-stop #AAA_ACCOUNT
aaa accounting exec start-stop #AAA_ACCOUNT
#EN_PASSWD
enable secret #SECRET
!
! for copy rcp config file
username #APM_USER password #APM_PASSWORD
ip rcmd remote-username #R_USER_NAME
ip routing
!
ip subnet-zero
no ip source-route
#IP_NAME_SERVER
ip #AAA_TYPE source-interface Loopback1
clock timezone #TIME_ZONE
#IF_SUMMER_TIME
clock summer-time #SUMMER_TIME
!
interface Loopback 1
description "MGMT Network and Async129"
ip address #LB1_IP #LB1_NET_MASK
!
interface Ethernet1/0
description "To Failover switch"
ip address #3640_ETH_1_0_IP #3640_ETH_1_0_NET_MASK
no ip directed-broadcast
no shutdown
!
interface Ethernet1/1
description "To Primary switch"
ip address #3640_ETH_1_1_IP #3640_ETH_1_1_NET_MASK
no ip directed-broadcast
no shutdown
!
interface Async 129
description "OSS Modem Incoming Call"
ip unnumbered Loopback1
encapsulation ppp
async dynamic address
async mode interactive
peer default ip address #TERM_SVR_ASYNC17_IP
no cdp enable
no fair-queue
ppp authentication chap callin ADMIN
!
router eigrp #EIGRP_NO
#EIGRP_NETWORK
!
ip classless
! ip http server
#IF_LOGGING logging trap #LOGGING_LEVEL
#IF_LOGGING
logging facility #LOGGING_FACILITY
! logging source uses logging IP
#LOGGING_SRC
no access-list 10
access-list 10 permit #WS_IPADDR
!
snmp-server community #SNMP_READ RO
snmp-server community #SNMP_WRITE RW 10
snmp-server trap-source Loopback1
snmp-server host #WS_IPADDR #HOST_NAME
snmp-server location #SNMP_LOCATION
snmp-server contact #SNMP_CONTACT
snmp-server system-shutdown
#AAA_RADIUS_HOST_ADDR
#AAA_TACACS_HOST_ADDR
#AAA_RADIUS_TYPE
-server key #AAA_RADIUS_KEY
#AAA_TACACS_TYPE
-server key #AAA_TACACS_KEY
!
line con 0
session-timeout 45
exec-timeout 45 0
login authentication CONSOLE
transport preferred none
line 1 32
session-timeout 60
no exec
login authentication ADMIN
modem InOut
transport input all
flowcontrol hardware
line aux 0
exec-timeout 15 0
autoselect during-login
autoselect ppp
login authentication ADMIN
modem InOut
transport preferred none
transport input none
flowcontrol hardware
speed 115200
line vty 0 63
session timeout 45
exec timeout 45
password #LINE_PASSWD
transport preferred none
login authentication ADMIN
!
#NTP_SERVERS
#IF_NO_NTP
ntp source Loopback1
end

Cisco 7206 without Catalyst 5002 (7206-default-entry)

This configuration is used with Cisco AccessPath-TS3 systems that use the Switch Blade as their primary switching path.

! Document Number ENG-17218
! Revision 2.5
! Copyright 1997 Cisco Systems, Inc. -- Company Confidential
!
!
no service finger
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname #HOST_NAME
!
aaa new-model
aaa authentication login CONSOLE none
aaa authentication login ADMIN #AAA_AUTHEN_LOGIN_ADMIN local
aaa authorization network #AAA_AUTHOR
aaa accounting network start-stop #AAA_ACCOUNT
aaa accounting connection start-stop #AAA_ACCOUNT
aaa accounting exec start-stop #AAA_ACCOUNT
#EN_PASSWD
enable secret #SECRET
!
! for copy rcp config file
username #APM_USER password #APM_PASSWORD
ip rcmd remote-username #R_USER_NAME
ip routing
!
ip subnet-zero
no ip source-route
#IP_NAME_SERVER
ip #AAA_TYPE source-interface Loopback1
!
clock timezone #TIME_ZONE
#IF_SUMMER_TIME
clock summer-time #SUMMER_TIME
clock calendar-valid
!
interface Loopback1
description "Management (SNMP & AAA) pseudo interface"
ip address #LB1_IP #LB1_NET_MASK
!
interface FastEthernet0/0
description "To Eth switch FastE3/0"
ip address #7206_FE_0_0_IP #7206_FE_0_0_NET_MASK
full-duplex
media-type MII
no shutdown
no ip directed-broadcast
ip route-cache
no keepalive
no fair-queue
!
interface FastEthernet 3/0
description "To FastE0/0"
no ip address
bridge-group 1
default keepalive
full-duplex
no shutdown
!
interface FastEthernet 3/1
description "To CMS01 E1/1"
no ip address
bridge-group 1
default keepalive
half-duplex
no shutdown
!
interface Ethernet 3/2
description "To AS01 FastE0"
no ip address
bridge-group 1
default keepalive
full-duplex
no shutdown
!
interface Ethernet 3/3
description "To AS02 FastE0"
no ip address
bridge-group 1
default keepalive
full-duplex
no shutdown
!
interface Ethernet 3/4
description "To AS03 FastE0"
no ip address
bridge-group 1
default keepalive
full-duplex
no shutdown
!
interface Ethernet 3/5
description "To AS04 FastE0"
no ip address
bridge-group 1
default keepalive
full-duplex
no shutdown
!
interface Ethernet 3/6
description "To AS05 FastE0"
no ip address
bridge-group 1
default keepalive
full-duplex
no shutdown
!
interface Ethernet 3/7
description "To AS06 FastE0"
no ip address
bridge-group 1
default keepalive
full-duplex
no shutdown
!
interface Ethernet 3/8
description "To AS07 FastE0"
no ip address
bridge-group 1
default keepalive
full-duplex
no shutdown
!
interface Ethernet 3/9
no ip address
bridge-group 1
default keepalive
!
interface Ethernet 3/10
no ip address
bridge-group 1
!
interface Ethernet 3/11
no ip address
bridge-group 1
default keepalive
!
interface Ethernet 3/12
no ip address
bridge-group 1
default keepalive
!
interface Ethernet 3/13
no ip address
bridge-group 1
default keepalive
!
interface FastEthernet 5/0
no ip address
bridge-group 2
default keepalive
full-duplex
no shutdown
!
interface FastEthernet 5/1
no ip address
bridge-group 2
default keepalive
full-duplex
no shutdown
!
interface Ethernet 5/2
description "To AS01 E0"
no ip address
bridge-group 2
default keepalive
half-duplex
no shutdown
!
interface Ethernet 5/3
description "To AS02 E0"
no ip address
bridge-group 2
default keepalive
half-duplex
no shutdown
!
interface Ethernet 5/4
description "To AS03 E0"
no ip address
bridge-group 2
default keepalive
half-duplex
no shutdown
!
interface Ethernet 5/5
description "To AS04 E0"
no ip address
bridge-group 2
default keepalive
no shutdown
!
interface Ethernet 5/6
description "To AS05 E0"
no ip address
bridge-group 2
default keepalive
half-duplex
no shutdown
!
interface Ethernet 5/7
description "To AS06 E0"
no ip address
bridge-group 2
default keepalive
half-duplex
no shutdown
!
interface Ethernet 5/8
description "To AS07 E0"
no ip address
bridge-group 2
default keepalive
half-duplex
no shutdown
!
interface Ethernet 5/9
no ip address
bridge-group 2
default keepalive
!
interface Ethernet 5/10
no ip address
bridge-group 2
default keepalive
!
interface Ethernet 5/11
no ip address
bridge-group 2
default keepalive
!
interface Ethernet 5/12
no ip address
bridge-group 2
default keepalive
!
interface Ethernet 5/13
description "To CMS01 E1/0"
no ip address
bridge-group 2
default keepalive
no shutdown
!
interface BVI 2
description "Bridge-group Virtual Interface for bridge 2"
ip address #BVI_2_IP #BVI_2_NET_MASK
no ip directed-broadcast
!
router eigrp #EIGRP_NO
redistribute connected
passive-interface Loopback1
#EIGRP_NETWORK
no auto-summary
!
bridge irb
bridge 1 protocol ieee
bridge 1 priority 1
bridge 2 protocol ieee
bridge 2 priority 1
bridge 2 route ip
!
ip classless
ip route 0.0.0.0 0.0.0.0 #RPS_DEFAULT_ROUTE_IP
! ip http server
#IF_LOGGING logging trap #LOGGING_LEVEL
#IF_LOGGING
logging facility #LOGGING_FACILITY
! logging source uses logging IP
#LOGGING_SRC
no access-list 10
access-list 10 permit #WS_IPADDR
!
snmp-server community #SNMP_READ RO
snmp-server community #SNMP_WRITE RW 10
snmp-server trap-source Loopback1
snmp-server host #WS_IPADDR #HOST_NAME
snmp-server location #SNMP_LOCATION
snmp-server contact #SNMP_CONTACT
snmp-server system-shutdown
#AAA_RADIUS_HOST_ADDR
#AAA_TACACS_HOST_ADDR
#AAA_RADIUS_TYPE
-server key #AAA_RADIUS_KEY
#AAA_TACACS_TYPE
-server key #AAA_TACACS_KEY
!
line con 0
session-timeout 30
exec-timeout 15 0
logout-warning 60
login authentication CONSOLE
transport preferred none
line aux 0
line vty 0 4
session-timeout 45
exec-timeout 45 0
login authentication ADMIN
transport preferred none
!
#NTP_SERVERS
end

Cisco 7206 with Catalyst 5002 (7206-default-midhigh)

! Document Number ENG-17217
! Revision 2.5
! Copyright 1997 Cisco Systems, Inc. -- Company Confidential
!
!
no service finger
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname #HOST_NAME
!
aaa new-model
aaa authentication login CONSOLE none
aaa authentication login ADMIN #AAA_AUTHEN_LOGIN_ADMIN local
aaa authorization network #AAA_AUTHOR
aaa accounting network start-stop #AAA_ACCOUNT
aaa accounting connection start-stop #AAA_ACCOUNT
aaa accounting exec start-stop #AAA_ACCOUNT
#EN_PASSWD
enable secret #SECRET
!
! for copy rcp config file
username #APM_USER password #APM_PASSWORD
ip rcmd remote-username #R_USER_NAME
ip routing
!
ip subnet-zero
no ip source-route
#IP_NAME_SERVER
ip #AAA_TYPE source-interface Loopback1
clock timezone #TIME_ZONE
#IF_SUMMER_TIME
clock summer-time #SUMMER_TIME
clock calendar-valid
!
interface Loopback1
description "Management (SNMP & AAA) pseudo interface"
ip address #LB1_IP #LB1_NET_MASK
!
interface FastEthernet0/0
description "To Failover path Switch"
ip address #7206_FE_0_0_IP #7206_FE_0_0_NET_MASK
full-duplex
media-type MII
no shutdown
bandwidth 10000
delay 100
no ip directed-broadcast
ip route-cache
no keepalive
no fair-queue
!
interface FastEthernet1/0
description "To Stack via SW01"
ip address #FE_10_FIRST_IP #FE_10_FIRST_NET_MASK
no ip directed-broadcast
ip route-cache
default keepalive
full-duplex
no shutdown
!
interface FastEthernet 5/0
description "To FastE0/0"
no ip address
bridge-group 2
default keepalive
full-duplex
no shutdown
!
interface FastEthernet 5/1
! description "Reserved for link to RS02 Eswitch FastE5/1" ! RS01
! description "To RS01 Eswitch FastE5/1" ! RS02
no ip address
bridge-group 2
default keepalive
full-duplex
no shutdown
!
interface Ethernet 5/2
! description "To AS01 E0" ! RS01
! description "To AS12 E0" ! RS02
no ip address
bridge-group 2
default keepalive
half-duplex
no shutdown
!
interface Ethernet 5/3
! description "To AS02 E0" ! RS01
! description "To AS13 E0" ! RS02
no ip address
bridge-group 2
default keepalive
half-duplex
no shutdown
!
interface Ethernet 5/4
! description "To AS03 E0" ! RS01
! description "To AS14 E0" ! RS02
no ip address
bridge-group 2
default keepalive
half-duplex
no shutdown
!
interface Ethernet 5/5
! description "To AS04 E0" ! RS01
! description "To AS15 E0" ! RS02
no ip address
bridge-group 2
default keepalive
half-duplex
no shutdown
!
interface Ethernet 5/6
! description "To AS05 E0" ! RS01
! description "To AS16 E0" ! RS02
no ip address
bridge-group 2
default keepalive
half-duplex
no shutdown
!
interface Ethernet 5/7
! description "To AS06 E0" ! RS01
! description "To AS17 E0" ! RS02
no ip address
bridge-group 2
default keepalive
half-duplex
no shutdown
!
interface Ethernet 5/8
! description "To AS07 E0" ! RS01
! description "To AS12 E0" ! RS02
no ip address
bridge-group 2
default keepalive
half-duplex
no shutdown
!
interface Ethernet 5/9
! description "To AS08 E0" ! RS01
! description "To AS19 E0" ! RS02
no ip address
bridge-group 2
default keepalive
half-duplex
no shutdown
!
interface Ethernet 5/10
! description "To AS09 E0" ! RS01
! description "To AS20 E0" ! RS02
no ip address
bridge-group 2
default keepalive
no shutdown
!
interface Ethernet 5/11
! description "To AS10 E0" ! RS01
! description "To AS21 E0" ! RS02
no ip address
bridge-group 2
default keepalive
half-duplex
no shutdown
!
interface Ethernet 5/12
! description "To AS11 E0" ! RS01
no ip address
bridge-group 2
default keepalive
half-duplex
no shutdown
!
interface Ethernet 5/13
! description "To CMS01 E1/0" ! RS01
no ip address
bridge-group 2
default keepalive
half-duplex
no shutdown
!
router eigrp #EIGRP_NO
redistribute connected
passive-interface Loopback1
#EIGRP_NETWORK
no auto-summary
!
bridge irb
bridge 2 protocol ieee
! RS01 has priority 1, RS02 has priority 2
bridge 2 priority #7206_BRIDGE_IRB_PRIORITY
!
ip classless
ip route 0.0.0.0 0.0.0.0 #RPS_DEFAULT_ROUTE_IP
! ip http server
#IF_LOGGING logging trap #LOGGING_LEVEL
#IF_LOGGING
logging facility #LOGGING_FACILITY
! logging source uses logging IP
#LOGGING_SRC
no access-list 10
access-list 10 permit #WS_IPADDR
!
snmp-server community #SNMP_READ RO
snmp-server community #SNMP_WRITE RW 10
snmp-server trap-source Loopback1
snmp-server host #WS_IPADDR #HOST_NAME
snmp-server location #SNMP_LOCATION
snmp-server contact #SNMP_CONTACT
snmp-server system-shutdown
#AAA_RADIUS_HOST_ADDR
#AAA_TACACS_HOST_ADDR
#AAA_RADIUS_TYPE
-server key #AAA_RADIUS_KEY
#AAA_TACACS_TYPE
-server key #AAA_TACACS_KEY
!
line con 0
session-timeout 30
exec-timeout 15 0
logout-warning 60
login authentication CONSOLE
transport preferred none
line aux 0
line vty 0 4
session-timeout 45
exec-timeout 45 0
login authentication ADMIN
transport preferred none
!
#NTP_SERVERS
end

Cisco AS5300 (as5300-default-channelized)

! Document Number ENG-17219
! Revision 2.7
! Copyright 1997 Cisco Systems, Inc. -- Company Confidential
!
!
no service finger
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname #HOST_NAME
!
aaa new-model
aaa authentication login CONSOLE none
aaa authentication login ADMIN #AAA_AUTHEN_LOGIN_ADMIN local
aaa authentication login USERS #AAA_AUTHEN_LOGIN_USERS
aaa authentication ppp USERS&TUNNELS if-needed #AAA_AUTHEN_PPP_UT
aaa authorization network #AAA_AUTHOR if-authenticated
aaa accounting network start-stop #AAA_ACCOUNT
aaa accounting exec start-stop #AAA_ACCOUNT
aaa accounting connection start-stop #AAA_ACCOUNT
enable secret #SECRET
#EN_PASSWD
!
! for copy rcp config file
ip rcmd remote-username #R_USER_NAME
ip routing
username #APM_USER password #APM_PASSWORD
!
! username #SGBP_STACK_ID password #STACK_PWD
ip subnet-zero
no ip source-route
#IP_NAME_SERVER
ip #AAA_TYPE source-interface Loopback1
!
#ASYNC_DNS_SVR_ADDR
#ASYNC_NBNS_SVR_ADDR
#IF_VPDN
vpdn enable
#IF_VPDN vpdn source-ip #LB0_IP
clock timezone #TIME_ZONE
#IF_SUMMER_TIME
clock summer-time #SUMMER_TIME
!
controller #T1_OR_E1 0
framing #FRAMING
#IF_FRAMING_ESF
fdl ansi
clock source line primary
linecode #LINECODE
! if T1, no of isdn channel=24, E1=31
cas-group 1 timeslots 1-#TIME_SLOTS type #CHANNEL_SIGNALLING
#IF_E1_R2_CUSTOM
cas-custom 1
#IF_E1_R2_CUSTOM country #E1_R2_COUNTRY use-defaults
no shutdown
!
controller #T1_OR_E1 1
framing #FRAMING
#IF_FRAMING_ESF
fdl ansi
clock source line secondary
linecode #LINECODE
! if T1, no of isdn channel=24, E1=31
cas-group 1 timeslots 1-#TIME_SLOTS type #CHANNEL_SIGNALLING
#IF_E1_R2_CUSTOM
cas-custom 1
#IF_E1_R2_CUSTOM country #E1_R2_COUNTRY use-defaults
no shutdown
!
controller #T1_OR_E1 2
framing #FRAMING
#IF_FRAMING_ESF
fdl ansi
clock source internal
linecode #LINECODE
! if T1, no of isdn channel=24, E1=31
cas-group 1 timeslots 1-#TIME_SLOTS type #CHANNEL_SIGNALLING
#IF_E1_R2_CUSTOM
cas-custom 1
#IF_E1_R2_CUSTOM country #E1_R2_COUNTRY use-defaults
no shutdown
!
controller #T1_OR_E1 3
framing #FRAMING
#IF_FRAMING_ESF
fdl ansi
clock source internal
linecode #LINECODE
! if T1, no of isdn channel=24, E1=31
cas-group 1 timeslots 1-#TIME_SLOTS type #CHANNEL_SIGNALLING
#IF_E1_R2_CUSTOM
cas-custom 1
#IF_E1_R2_CUSTOM country #E1_R2_COUNTRY use-defaults
no shutdown
!
interface Loopback0
description "L2F tunnel NAS pseudo interface"
ip address #LB0_IP #LB0_NET_MASK
!
interface Loopback1
description "Management (SNMP & AAA) NAS pseudo interface"
ip address #LB1_IP #LB1_NET_MASK
!
interface Ethernet0
description "To Failover path via Switch port on 7206"
ip address #E0_IPADDR #E0_NET_MASK
#IP_SUMMARY_ADDR
no shutdown
no ip directed-broadcast
ip route-cache
no lat enabled
no mop enabled
delay 101
default keepalive
no fair-queue
!
interface FastEthernet0
description "To Primary path via SW01"
ip address #FA0_IPADDR #FA0_NET_MASK
#IP_SUMMARY_ADDR
no shutdown
duplex auto
speed auto
#IF_ENTRY_STACKspeed 10
#IF_ENTRY_STACKduplex full
no ip directed-broadcast
ip route-cache
no lat enabled
no mop enabled
default keepalive
no fair-queue
!
interface Group-Async1
description "Async Incoming Call"
ip unnumbered Loopback0
encapsulation ppp
async dynamic address
!if token card, IF_TOKEN_CARD=interactive, otherwise =dedicated
async mode #ASYNC_MODE
no snmp trap link-status
peer default ip address pool default
ip tcp header-compression passive
default keepalive
no fair-queue
no cdp enable
ppp authentication chap callin USERS&TUNNELS
ppp chap hostname #STACK_EXTERNAL_PWD
! T1 = 96, E1 = 120
group-range 1 #HALF_MODEMS
group-range 1 #INSTALLED_MODEMS
!
router eigrp #EIGRP_NO
redistribute connected
passive-interface Loopback0
passive-interface Loopback1
#EIGRP_NETWORK
no auto-summary
!
ip local pool #HOST_NAME #IP_LOCAL_BEGIN #IP_LOCAL_END
ip classless
! ip http server
#IF_LOGGING logging trap #LOGGING_LEVEL
#IF_LOGGING
logging facility #LOGGING_FACILITY
! logging source uses logging ip
#LOGGING_SRC
no access-list 10
access-list 10 permit #WS_IPADDR
!
snmp-server community #SNMP_READ RO
snmp-server community #SNMP_WRITE RW 10
snmp-server trap-source Loopback1
snmp-server host #WS_IPADDR #HOST_NAME
snmp-server location #SNMP_LOCATION
snmp-server contact #SNMP_CONTACT
snmp-server system-shutdown
dialer-list 1 protocol ip permit
#AAA_RADIUS_HOST_ADDR
#AAA_TACACS_HOST_ADDR
#AAA_RADIUS_TYPE
-server key #AAA_RADIUS_KEY
#AAA_TACACS_TYPE
-server key #AAA_TACACS_KEY
!
line con 0
session-timeout 30
exec-timeout 15 0
logout-warning 60
transport preferred none
login authentication CONSOLE
line aux 0
line vty 0 4
session-timeout 45
exec-timeout 45 0
login authentication ADMIN
transport preferred none
line 1 #HALF_MODEMS
#IF_GROUP_ASYNC_EXEC
autoselect during-login
#IF_GROUP_ASYNC_EXEC autoselect ppp
login authentication USERS
modem InOut
transport preferred none
autohangup
line 1 #INSTALLED_MODEMS
#IF_GROUP_ASYNC_EXEC
autoselect during-login
#IF_GROUP_ASYNC_EXEC autoselect ppp
login authentication USERS
modem InOut
transport preferred none
autohangup
!
#NTP_SERVERS
end

Cisco AS5300 (as5300-default-pri)

! Document Number ENG-17220
! Revision 2.7
! Copyright 1997 Cisco Systems, Inc. -- Company Confidential
!
!
no service finger
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname #HOST_NAME
!
aaa new-model
aaa authentication login CONSOLE none
aaa authentication login ADMIN #AAA_AUTHEN_LOGIN_ADMIN local
aaa authentication login USERS #AAA_AUTHEN_LOGIN_USERS
aaa authentication ppp USERS&TUNNELS if-needed #AAA_AUTHEN_PPP_UT
aaa authorization network #AAA_AUTHOR if-authenticated
aaa accounting network start-stop #AAA_ACCOUNT
aaa accounting exec start-stop #AAA_ACCOUNT
aaa accounting connection start-stop #AAA_ACCOUNT
enable secret #SECRET
#EN_PASSWD
!
! for copy rcp config file
ip rcmd remote-username #R_USER_NAME
ip routing
username #APM_USER password #APM_PASSWORD
!
username #SGBP_STACK_ID password #STACK_PWD
ip subnet-zero
no ip source-route
#IP_NAME_SERVER
ip #AAA_TYPE source-interface Loopback1
!
#IF_MMPno sgbp group #SGBP_STACK_ID
!
#IF_MMPsgbp group #SGBP_STACK_ID
#IF_MMP
sgbp seed-bid default
#IF_MMP sgbp source-ip #LB0_IP
! sgbp members will be built at run time.
! There is one per peer NAS, fully meshed.
! Example: sgbp member Nas02 4.2.1.2
#SGBP_MEMBER
#ASYNC_DNS_SVR_ADDR
#ASYNC_NBNS_SVR_ADDR
#IF_VPDN
vpdn enable
#IF_VPDN vpdn source-ip #LB0_IP
isdn switch-type #ISDN_SWITCH_TYPE
clock timezone #TIME_ZONE
#IF_SUMMER_TIME
clock summer-time #SUMMER_TIME
!
controller #T1_OR_E1 0
framing #FRAMING
#IF_FRAMING_ESF
fdl ansi
clock source line primary
linecode #LINECODE
! if T1, no of isdn channel=24, E1=31
pri-group timeslots 1-#TIME_SLOTS
no shutdown
!
controller #T1_OR_E1 1
framing #FRAMING
#IF_FRAMING_ESF
fdl ansi
clock source line secondary
linecode #LINECODE
! if T1, no of isdn channel=24, E1=31
pri-group timeslots 1-#TIME_SLOTS
no shutdown
!
controller #T1_OR_E1 2
framing #FRAMING
#IF_FRAMING_ESF
fdl ansi
clock source internal
linecode #LINECODE
! if T1, no of isdn channel=24, E1=31
pri-group timeslots 1-#TIME_SLOTS
no shutdown
!
controller #T1_OR_E1 3
framing #FRAMING
#IF_FRAMING_ESF
fdl ansi
clock source internal
linecode #LINECODE
! if T1, no of isdn channel=24, E1=31
pri-group timeslots 1-#TIME_SLOTS
no shutdown
!
interface Loopback0
description "L2F tunnel NAS pseudo interface"
ip address #LB0_IP #LB0_NET_MASK
!
interface Loopback1
description "Management (SNMP & AAA) NAS pseudo interface"
ip address #LB1_IP #LB1_NET_MASK
!
interface Ethernet0
description "To Failover path via Switch port on 7206"
ip address #E0_IPADDR #E0_NET_MASK
#IP_SUMMARY_ADDR
no shutdown
no ip directed-broadcast
ip route-cache
no lat enabled
no mop enabled
delay 101
default keepalive
no fair-queue
!
interface FastEthernet0
description "To Primary Switch path"
ip address #FA0_IPADDR #FA0_NET_MASK
#IP_SUMMARY_ADDR
no shutdown
duplex auto
speed auto
#IF_ENTRY_STACKspeed 10
#IF_ENTRY_STACKduplex full
no ip directed-broadcast
ip route-cache
no lat enabled
no mop enabled
default keepalive
no fair-queue
!
! if North American isdn d channel=23, European=15
interface Serial0:#PRI_D_CHANNEL
description "PRI D channel"
ip unnumbered Loopback0
encapsulation ppp
isdn incoming-voice modem
peer default ip address pool #HOST_NAME
dialer rotary-group 1
no fair-queue
no cdp enable
no keepalive
no shutdown
dialer-group 1
!
interface Serial1:#PRI_D_CHANNEL
description "PRI D channel"
ip unnumbered Loopback0
encapsulation ppp
isdn incoming-voice modem
peer default ip address pool #HOST_NAME
dialer rotary-group 1
no fair-queue
no cdp enable
no keepalive
no shutdown
dialer-group 1
!
interface Serial2:#PRI_D_CHANNEL
description "PRI D channel"
ip unnumbered Loopback0
encapsulation ppp
isdn incoming-voice modem
peer default ip address pool #HOST_NAME
dialer rotary-group 1
no fair-queue
no cdp enable
no keepalive
no shutdown
dialer-group 1
!
interface Serial3:#PRI_D_CHANNEL
description "PRI D channel"
ip unnumbered Loopback0
encapsulation ppp
isdn incoming-voice modem
peer default ip address pool #HOST_NAME
dialer rotary-group 1
no fair-queue
no cdp enable
no keepalive
no shutdown
dialer-group 1
!
! Delete the entire Group-Async1 if no modems are installed in stack
!
interface Group-Async1
description "Async Incoming Call"
ip unnumbered Loopback0
encapsulation ppp
async dynamic address
!if token card, IF_TOKEN_CARD=interactive, otherwise =dedicated
async mode #ASYNC_MODE
no snmp trap link-status
peer default ip address pool #HOST_NAME
ip tcp header-compression passive
default keepalive
no fair-queue
no cdp enable
ppp authentication chap callin USERS&TUNNELS
ppp chap hostname #STACK_EXTERNAL_PWD
! T1 = 96, E1 = 120
group-range 1 #HALF_MODEMS
group-range 1 #INSTALLED_MODEMS
! T1 = 48, E1 = 60
!
interface Dialer1
ip unnumbered Loopback0
encapsulation ppp
peer default ip address pool #HOST_NAME
#IF_MMP
ppp multilink
ppp authentication chap callin USERS&TUNNELS
ppp chap hostname #STACK_EXTERNAL_PWD
dialer-group 1
dialer in-band
no keepalive
no cdp enable
!
router eigrp #EIGRP_NO
redistribute connected
passive-interface Loopback0
passive-interface Loopback1
passive-interface Serial0:#PRI_D_CHANNEL
passive-interface Serial1:#PRI_D_CHANNEL
passive-interface Serial2:#PRI_D_CHANNEL
passive-interface Serial3:#PRI_D_CHANNEL
#EIGRP_NETWORK
no auto-summary
!
ip local pool #HOST_NAME #IP_LOCAL_BEGIN #IP_LOCAL_END
ip classless
! ip http server
#IF_LOGGING logging trap #LOGGING_LEVEL
#IF_LOGGING
logging facility #LOGGING_FACILITY
! logging source uses logging ip
#LOGGING_SRC
no access-list 10
access-list 10 permit #WS_IPADDR
!
snmp-server community #SNMP_READ RO
snmp-server community #SNMP_WRITE RW 10
snmp-server trap-source Loopback1
snmp-server host #WS_IPADDR #HOST_NAME
snmp-server location #SNMP_LOCATION
snmp-server contact #SNMP_CONTACT
snmp-server system-shutdown
dialer-list 1 protocol ip permit
#AAA_RADIUS_HOST_ADDR
#AAA_TACACS_HOST_ADDR
#AAA_RADIUS_TYPE
-server key #AAA_RADIUS_KEY
#AAA_TACACS_TYPE
-server key #AAA_TACACS_KEY
!
line con 0
session-timeout 30
exec-timeout 15 0
logout-warning 60
transport preferred none
login authentication CONSOLE
line aux 0
line vty 0 4
session-timeout 45
exec-timeout 45 0
transport preferred none
login authentication ADMIN
line 1 #HALF_MODEMS
#IF_GROUP_ASYNC_EXEC
autoselect during-login
#IF_GROUP_ASYNC_EXEC autoselect ppp
login authentication USERS
modem InOut
transport preferred none
autohangup
line 1 #INSTALLED_MODEMS
#IF_GROUP_ASYNC_EXEC
autoselect during-login
#IF_GROUP_ASYNC_EXEC autoselect ppp
login authentication USERS
modem InOut
transport preferred none
autohangup
!
#NTP_SERVERS
end

Catalyst 5002 (cat5002-default)

! Document Number ENG-17221
! Revision 2.5
! Copyright 1997 Cisco Systems, Inc. -- Company Confidential
!
!begin
set prompt #HOST_NAME>
set length 24 default
set logout 20
! Security: Use either enablepass or tacacs+
! set enablepass
! set authentication enable tacacs
! set authentication enable tacacs
! set tacacs server
! set tacacs key
!
#system
set system baud 9600
set system modem disable
set system name #SGBP_STACK_ID
set system location #SNMP_LOCATION
set system contact #SNMP_CONTACT
!
#snmp
set snmp community read-only #SNMP_READ
set snmp community read-write #SNMP_WRITE
set snmp community read-write-all #SNMP_ALL
set snmp rmon disable
set snmp trap enable module
set snmp trap enable chassis
set snmp trap disable bridge
set snmp trap disable repeater
set snmp trap enable vtp
set snmp trap enable auth
!
#vtp
set vtp domain #SGBP_STACK_ID mode server
set vlan 1 name default type ethernet mtu 1500 said 100001 state active
!
#ip
set interface sc0 1 #SC0_IP #SCO_NET_MASK #MGMT_NET_BCAST_IP
set interface sl0 0.0.0.0 0.0.0.0
set arp agingtime 1200
set ip redirect enable
set ip unreachable enable
set ip fragmentation enable
set ip route 0.0.0.0 #OFLD1_10MGMT_IP 1
set ip alias default 0.0.0.0
!
#Command alias
!
#switch port analyzer
set span 1 2/24 both
set span disable
!
#bridge
set bridge ipx snaptoether 8023raw
set bridge ipx 8022toether 8023
set bridge ipx 8023rawtofddi snap
!
#vlan
set vlan 1 1/1-2
set vlan 1 2/1-24
!
#syslog
set logging console enable
set logging server enable
! use logging ip for the logging server address, for example:
! set logging server 192.168.10.1
#CAT_LOGGING_SERVER
set logging level cdp 2 default
set logging level cgmp 2 default
set logging level disl 5 default
set logging level dvlan 2 default
set logging level earl 2 default
set logging level fddi 2 default
set logging level ip 2 default
set logging level pruning 2 default
set logging level snmp 2 default
set logging level spantree 2 default
set logging level sys 5 default
set logging level tac 2 default
set logging level tcp 2 default
set logging level telnet 2 default
set logging level tftp 2 default
set logging level vtp 2 default
set logging level vmps 2 default
!
#ntp
set ntp broadcastclient disable
set ntp broadcastdelay 3000
set ntp client enable
#NTP_SERVERS
set timezone #TIME_ZONE 0
#IF_SUMMER_TIMEset summertime enable #SUMMER_TIME
!
#cam
set cam agingtime 1 300
!
#cdp
set cdp enable 1/1-2
set cdp enable 2/1-24
!
#trunks
set trunk 1/1 auto 1-1000
set trunk 1/2 auto 1-1000
!
#spantree
#vlan 1
set spantree enable 1
set spantree fwddelay 15 1
set spantree hello 2 1
set spantree maxage 20 1
set spantree priority 32 1
!
#trunk
set spantree portfast 1/1-2 enable
set spantree portfast 2/1-24 enable
!
#module 1
set module name 1
set port enable 1/1-2
set port level 1/1-2 high
set port duplex 1/1-2 full
set port trap 1/1-2 enable
set port name 1/1 RS01
set port name 1/2 RS02
!
#module 2
set module name 2
set module enable 2
set port enable 2/1-24
set port speed 2/1 10
set port speed 2/2-24 100
set port level 2/1-24 normal
set port duplex 2/1 half
set port duplex 2/2-24 full
set port trap 2/1-24 enable
set port name 2/1 CMS01
set port name 2/2 AS01
set port name 2/3 AS02
set port name 2/4 AS03
set port name 2/5 AS04
set port name 2/6 AS05
set port name 2/7 AS06
set port name 2/8 AS07
set port name 2/9 AS08
set port name 2/10 AS09
set port name 2/11 AS10
set port name 2/12 AS11
set port name 2/13 AS12
set port name 2/14 AS13
set port name 2/15 AS14
set port name 2/16 AS15
set port name 2/17 AS16
set port name 2/18 AS17
set port name 2/19 AS18
set port name 2/20 AS19
set port name 2/21 AS20
set port name 2/22 AS21
!
!end

hometocprevnextglossaryfeedbacksearchhelp
Posted: Wed Jul 17 05:17:57 PDT 2002
All contents are Copyright © 1992--2002 Cisco Systems, Inc. All rights reserved.
Important Notices and Privacy Statement.