cc/td/doc/solution/vodsols/geopt2
hometocprevnextglossaryfeedbacksearchhelp
PDF

Table Of Contents

Sample Configurations for Dhub Switches

DHub_Sw_A Configuration

DHub_Sw_B Configuration

DHub_Sw_C Configuration


Sample Configurations for Dhub Switches


This appendix presents sample configurations for the following Cisco Catalyst 6509 Dhub switches in Figure 3-1, in Dhub A, Dhub B, and Dhub C, respectively:

DHub_Sw_A Configuration

DHub_Sw_B Configuration

DHub_Sw_C Configuration

DHub_Sw_A Configuration

version 12.2
service timestamps debug datetime localtime
service timestamps log datetime localtime
no service password-encryption
service internal
!
hostname DHub_Sw_A
!
boot system bootflash:s72033-jk9o3sv-mz.122-17d.SXB1.bin
logging snmp-authfail
enable password cisco123
!
clock timezone PST -8
clock summer-time PDT recurring
vtp mode transparent
ip subnet-zero
!
!
no ip domain-lookup
!
ip vrf Video
description Video traffic received from Headend
rd 1000:2
!
mpls ldp logging neighbor-changes
no mls flow ip
no mls flow ipv6
mls qos map dscp-cos 32 to 5
mls qos
mls cef error action freeze
!
!
power redundancy-mode combined
!
spanning-tree mode pvst
spanning-tree portfast bpduguard default
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
no spanning-tree vlan 1690,1694
port-channel load-balance dst-port
diagnostic cns publish cisco.cns.device.diag_results
diagnostic cns subscribe cisco.cns.device.diag_commands
!
redundancy
mode rpr-plus
main-cpu
auto-sync running-config
auto-sync standard
!
vlan internal allocation policy ascending
vlan access-log ratelimit 2000
!
vlan 1690,1694
!
class-map match-all class_high_speed_data
match access-group name acl_high_speed_data
!
!
policy-map setDSCP
description Mark DSCP values for the different types of traffic.
class class_high_speed_data
set dscp default
!
!
interface Loopback1
description Endpoint for Tunnel1
ip address 11.11.11.11 255.255.255.255
!
interface Loopback2
description Endpoint for Tunnel2
ip address 12.12.12.12 255.255.255.255
!
interface Port-channel1
description Video traffic to/from QAM_Sw_A (Gig3/1,Gig4/14)
ip vrf forwarding Video
ip address 192.168.160.1 255.255.255.240
!
interface Tunnel1
description Vlan1690 Tx to Headend_S3
ip vrf forwarding Video
no ip address
tunnel source Loopback1
tunnel destination 10.10.10.10
tunnel udlr send-only Vlan1690
tunnel udlr address-resolution
!
interface Tunnel2
description Vlan1694 Rx from DHub_Sw_B
ip vrf forwarding Video
no ip address
tunnel source Loopback2
tunnel destination 13.13.13.13
tunnel udlr receive-only Vlan1694
!
interface TenGigabitEthernet1/1
description UDL1 Rx from Headend, UDL2 Tx to DHub_Sw_B
no ip address
no wrr-queue random-detect 2
mls qos trust dscp
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1690,1694
switchport mode trunk
switchport nonegotiate
!
interface TenGigabitEthernet1/2
no ip address
shutdown
!
interface TenGigabitEthernet1/3
no ip address
shutdown
!
interface TenGigabitEthernet1/4
no ip address
shutdown
!
interface GigabitEthernet3/1
description BDL1: Non-video traffic to/from Headend (Gig2/15)
ip address 192.168.168.2 255.255.255.252
mls qos trust dscp
!
interface GigabitEthernet3/2
description BDL2: Non-video traffic to/from DHub_Sw_B (Gig3/2)
ip address 192.168.168.5 255.255.255.252
mls qos trust dscp
!
interface GigabitEthernet3/3
no ip address
shutdown
!
interface GigabitEthernet3/4
description BDL42: High speed data
ip address 192.168.168.17 255.255.255.252
no cdp enable
service-policy input setDSCP
!
interface GigabitEthernet3/5
no ip address
shutdown
!
interface GigabitEthernet3/6
description BDL51: Video traffic to/from QAM_Sw_A (Gig3/1)
ip vrf forwarding Video
no ip address
channel-group 1 mode on
!
interface GigabitEthernet3/7
description BDL52: Video traffic to/from QAM_Sw_A (Gig4/14)
ip vrf forwarding Video
no ip address
channel-group 1 mode on
!
interface GigabitEthernet3/8
description BDL53: Video traffic to/from uMG9820
ip vrf forwarding Video
ip address 192.168.160.17 255.255.255.252
no ip redirects
no ip unreachables
speed nonegotiate
!
interface GigabitEthernet5/1
no ip address
shutdown
!
interface GigabitEthernet5/2
no ip address
media-type rj45
shutdown
!
interface Vlan1
no ip address
shutdown
!
interface Vlan1690
description Video traffic to/from Headend
ip vrf forwarding Video
ip address 192.168.169.2 255.255.255.252
!
interface Vlan1694
description Video traffic to/from DHub_Sw_B
ip vrf forwarding Video
ip address 192.168.169.5 255.255.255.252
!
router ospf 100 vrf Video
log-adjacency-changes
capability vrf-lite
network 192.168.160.0 0.0.0.255 area 0
network 192.168.169.0 0.0.0.7 area 0
!
router ospf 101
log-adjacency-changes
passive-interface default
no passive-interface Vlan1690
no passive-interface Vlan1694
no passive-interface GigabitEthernet3/1
no passive-interface GigabitEthernet3/2
network 1.1.1.2 0.0.0.0 area 0
network 11.11.11.11 0.0.0.0 area 0
network 12.12.12.12 0.0.0.0 area 0
network 192.168.168.0 0.0.0.31 area 0
!
ip classless
no ip http server
!
!
ip access-list extended acl_high_speed_data
remark Identify high speed data traffic.
permit ip 192.168.168.16 0.0.0.3 any
!
!
dial-peer cor custom
!
!
line con 0
exec-timeout 0 0
password cisco123
logging synchronous
login
line vty 0 4
exec-timeout 0 0
password cisco123
logging synchronous
login
!
scheduler runtime netinput 300
!
end

DHub_Sw_B Configuration

version 12.2
service timestamps debug datetime localtime
service timestamps log datetime localtime
no service password-encryption
!
hostname DHub_Sw_B
!
boot system bootflash:s72033-jk9o3sv-mz.122-17d.SXB1.bin
logging snmp-authfail
enable password cisco123
!
clock timezone PST -8
clock summer-time PDT recurring
vtp mode transparent
ip subnet-zero
!
!
no ip domain-lookup
!
ip vrf Video
description Video traffic received from Headend
rd 1000:3
!
mpls ldp logging neighbor-changes
mls ip cef load-sharing full
no mls flow ip
no mls flow ipv6
mls qos map dscp-cos 32 to 5
mls qos
mls cef error action freeze
!
!
power redundancy-mode combined
!
spanning-tree mode pvst
spanning-tree portfast bpduguard default
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
no spanning-tree vlan 1694
port-channel load-balance dst-port
diagnostic cns publish cisco.cns.device.diag_results
diagnostic cns subscribe cisco.cns.device.diag_commands
!
redundancy
mode sso
main-cpu
auto-sync running-config
auto-sync standard
!
vlan internal allocation policy ascending
vlan access-log ratelimit 2000
!
vlan 164,166,1694
!
class-map match-all class_VoIP
match access-group name acl_VoIP
class-map match-all class_high_speed_data
match access-group name acl_high_speed_data
class-map match-all class_VoD_OOB
match access-group name acl_VoD_OOB
!
!
policy-map setDSCP
description Mark DSCP values for the different types of traffic
class class_VoIP
set dscp ef
class class_VoD_OOB
set dscp cs3
class class_high_speed_data
set dscp default
!
!
interface Loopback2
description Endpoint for Tunnel2
ip address 13.13.13.13 255.255.255.255
!
interface Port-channel2
description Video traffic to/from QAM_Sw_B (Gig3/2,Gig5/14)
ip vrf forwarding Video
ip address 192.168.161.1 255.255.255.240
!
interface Tunnel2
description UDL2 Tx to DHub_Sw_A
ip vrf forwarding Video
no ip address
tunnel source Loopback2
tunnel destination 12.12.12.12
tunnel udlr send-only Vlan1694
tunnel udlr address-resolution
!
interface TenGigabitEthernet1/1
description UDL2: Video traffic from DHub_Sw_A (TenGig1/1)
no ip address
no keepalive
mls qos trust dscp
unidirectional receive-only
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1694
switchport mode trunk
switchport nonegotiate
!
interface TenGigabitEthernet1/2
no ip address
shutdown
!
interface TenGigabitEthernet1/3
no ip address
shutdown
!
interface TenGigabitEthernet1/4
no ip address
shutdown
!
interface GigabitEthernet3/1
no ip address
shutdown
!
interface GigabitEthernet3/2
description BDL2: Non-video traffic to/from DHub_Sw_A (Gig3/2)
ip address 192.168.168.6 255.255.255.252
mls qos trust dscp
!
interface GigabitEthernet3/3
description BDL4: Non-video traffic to/from DHub_Sw_C (Gig3/3)
ip address 192.168.168.9 255.255.255.252
mls qos trust dscp
!
interface GigabitEthernet3/4
description BDL43: High speed data
ip address 192.168.168.21 255.255.255.252
no cdp enable
service-policy input setDSCP
!
interface GigabitEthernet3/5
no ip address
shutdown
!
interface GigabitEthernet3/6
description BDL54: Video traffic to/from QAM_Sw_B (Gig3/2)
ip vrf forwarding Video
no ip address
channel-group 2 mode on
!
interface GigabitEthernet3/7
description BDL55: Video traffic to/from QAM_Sw_B (Gig5/14)
ip vrf forwarding Video
no ip address
channel-group 2 mode on
!
interface GigabitEthernet3/8
description BDL56: Video traffic to/from uMG9820
ip vrf forwarding Video
ip address 192.168.161.17 255.255.255.252
no ip redirects
no ip unreachables
!
interface FastEthernet4/1
no ip address
shutdown
!
! omitted interfaces FastEthernet4/2 - 42
!
!
interface FastEthernet4/43
no ip address
shutdown
!
interface FastEthernet4/44
description BDL44: VoIP traffic
no ip address
switchport
switchport access vlan 164
switchport mode access
spanning-tree portfast
service-policy input setDSCP
!
interface FastEthernet4/45
no ip address
shutdown
!
interface FastEthernet4/46
no ip address
shutdown
!
interface FastEthernet4/47
no ip address
shutdown
!
interface FastEthernet4/48
description BDL55: VoD OOB traffic
no ip address
speed 100
duplex full
switchport
switchport access vlan 166
switchport mode access
no cdp enable
spanning-tree portfast
service-policy input setDSCP
!
interface GigabitEthernet5/1
no ip address
shutdown
!
interface GigabitEthernet5/2
no ip address
media-type rj45
shutdown
!
interface Vlan1
no ip address
shutdown
!
!
interface Vlan164
description VoIP traffic
ip address 192.168.164.1 255.255.255.0
!
interface Vlan166
description VoD OOB traffic
ip address 192.168.166.1 255.255.255.0
!
interface Vlan1694
description Video traffic to/from DHub_Sw_A
ip vrf forwarding Video
ip address 192.168.169.6 255.255.255.252
no ip redirects
no ip unreachables
!
router ospf 100 vrf Video
log-adjacency-changes
capability vrf-lite
network 192.168.161.0 0.0.0.255 area 0
network 192.168.169.0 0.0.0.15 area 0
!
router ospf 101
log-adjacency-changes
passive-interface default
no passive-interface Vlan1694
no passive-interface GigabitEthernet3/2
no passive-interface GigabitEthernet3/3
network 13.13.13.13 0.0.0.0 area 0
network 192.168.164.0 0.0.0.255 area 0
network 192.168.166.0 0.0.0.255 area 0
network 192.168.168.0 0.0.0.63 area 0
!
ip classless
no ip http server
!
!
ip access-list extended acl_VoD_OOB
remark Identify VoD OOB traffic.
permit ip 192.168.166.0 0.0.0.255 any
ip access-list extended acl_VoIP
remark Identify VoIP traffic.
permit ip 192.168.164.0 0.0.0.255 any
ip access-list extended acl_high_speed_data
remark Identify high speed data.
permit ip 192.168.168.20 0.0.0.3 any
!
!
dial-peer cor custom
!
!
line con 0
exec-timeout 0 0
password cisco123
logging synchronous
login
line vty 0 4
exec-timeout 0 0
password cisco123
logging synchronous
login
!
end

DHub_Sw_C Configuration

version 12.2
service timestamps debug datetime localtime
service timestamps log datetime localtime
no service password-encryption
!
hostname DHub_Sw_C
!
boot system bootflash:s72033-jk9o3sv-mz.122-17d.SXB1.bin
logging snmp-authfail
enable password cisco123
!
clock timezone PST -8
clock summer-time PDT recurring
vtp mode transparent
ip subnet-zero
!
!
no ip domain-lookup
!
ip vrf Video
description Video traffic received from Headend
rd 1001:4
!
mpls ldp logging neighbor-changes
no mls flow ip
no mls flow ipv6
mls qos map dscp-cos 32 to 5
mls qos
mls cef error action freeze
!
!
power redundancy-mode combined
spanning-tree mode pvst
spanning-tree portfast bpduguard default
no spanning-tree optimize bpdu transmission
diagnostic cns publish cisco.cns.device.diag_results
diagnostic cns subscribe cisco.cns.device.diag_commands
!
redundancy
mode rpr-plus
main-cpu
auto-sync running-config
auto-sync standard
!
vlan internal allocation policy ascending
vlan access-log ratelimit 2000
!
vlan 165
!
class-map match-all class_VoIP
match access-group name acl_VoIP
!
!
policy-map setDSCP
description Mark DSCP values for the VoIP traffic.
class class_VoIP
set dscp ef
!
!
interface Loopback3
description Endpoint for Tunnel 3
ip address 15.15.15.15 255.255.255.255
!
interface Tunnel3
description UDL3 Tx to Headend
ip vrf forwarding Video
no ip address
tunnel source Loopback3
tunnel destination 14.14.14.14
tunnel udlr send-only TenGigabitEthernet1/1
tunnel udlr address-resolution
!
interface TenGigabitEthernet1/1
description UDL3: Video traffic from Headend (TenGig7/3)
ip vrf forwarding Video
ip address 192.168.169.10 255.255.255.252
mls qos trust dscp
unidirectional receive-only
!
interface TenGigabitEthernet1/2
no ip address
shutdown
!
interface TenGigabitEthernet1/3
no ip address
shutdown
!
interface TenGigabitEthernet1/4
no ip address
shutdown
!
interface GigabitEthernet3/1
description BDL3: Non-video traffic to/from Headend (Gig2/16)
ip address 192.168.168.14 255.255.255.252
mls qos trust dscp
!
interface GigabitEthernet3/2
no ip address
shutdown
!
interface GigabitEthernet3/3
description BDL4: Non-video traffic to/from DHub_Sw_B (Gig3/3)
ip address 192.168.168.10 255.255.255.252
mls qos trust dscp
!
interface GigabitEthernet3/4
no ip address
shutdown
!
! omitted interfaces GigabitEthernet3/5 - 15
!
interface GigabitEthernet3/16
no ip address
shutdown
!
interface GigabitEthernet4/1
description BDL57: Video traffic to QAM_Sw_C (Gig6/13)
ip vrf forwarding Video
ip address 192.168.162.1 255.255.255.248
!
interface GigabitEthernet4/3
description BDL59: VoD traffic to uMG9820
ip vrf forwarding Video
ip address 192.168.162.17 255.255.255.252
no ip redirects
no ip unreachables
!
interface GigabitEthernet4/4
no ip address
!
! omitted interfaces GigabitEthernet4/5 - 44
!
interface GigabitEthernet4/45
no ip address
shutdown
!
interface GigabitEthernet4/46
description BDL48: VoIP traffic
no ip address
switchport
switchport access vlan 165
switchport mode access
spanning-tree portfast
service-policy input setDSCP
!
interface GigabitEthernet4/47
no ip address
shutdown
!
interface GigabitEthernet4/48
no ip address
shutdown
!
interface GigabitEthernet5/1
no ip address
shutdown
!
interface GigabitEthernet5/2
no ip address
media-type rj45
shutdown
!
interface Vlan1
no ip address
shutdown
!
!
interface Vlan165
description VoIP traffic
ip address 192.168.165.1 255.255.255.0
!
router ospf 100 vrf Video
log-adjacency-changes
capability vrf-lite
network 192.168.162.0 0.0.0.255 area 0
network 192.168.169.0 0.0.0.31 area 0
!
router ospf 101
log-adjacency-changes
passive-interface default
no passive-interface TenGigabitEthernet1/1
no passive-interface GigabitEthernet3/1
no passive-interface GigabitEthernet3/3
network 15.15.15.15 0.0.0.0 area 0
network 192.168.165.0 0.0.0.255 area 0
network 192.168.168.8 0.0.0.7 area 0
!
ip classless
no ip http server
!
!
ip access-list extended acl_VoIP
remark Identify VoIP traffic.
permit ip 192.168.165.0 0.0.0.255 any
!
!
dial-peer cor custom
!
!
line con 0
exec-timeout 0 0
password cisco123
logging synchronous
login
line vty 0 4
exec-timeout 0 0
password cisco123
logging synchronous
login
!
end


hometocprevnextglossaryfeedbacksearchhelp

Posted: Mon Mar 13 09:11:49 PST 2006
All contents are Copyright © 1992--2006 Cisco Systems, Inc. All rights reserved.
Important Notices and Privacy Statement.