cc/td/doc/solution/vodsols/geopt2
hometocprevnextglossaryfeedbacksearchhelp
PDF

Table Of Contents

Sample Configuration for a Headend Switch


Sample Configuration for a Headend Switch


This appendix presents a sample configuration for the Cisco 7609 labeled Headend in Figure 3-1.


version 12.2
service timestamps debug datetime localtime
service timestamps log datetime localtime
no service password-encryption
!
hostname Headend
!
boot system bootflash:s72033-jk9o3sv-mz.122-17d.SXB1.bin
logging snmp-authfail
enable password cisco123
!
clock timezone PST -8
clock summer-time PDT recurring
vtp mode transparent
ip subnet-zero
!
no ip domain-lookup
!
ip vrf Video
description Video traffic destined for DHubs
rd 1000:1
!
mpls ldp logging neighbor-changes
no mls flow ip
no mls flow ipv6
mls qos map dscp-cos 32 to 5
mls qos
mls cef error action freeze
!
!
spanning-tree mode pvst
spanning-tree portfast bpduguard default
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
no spanning-tree vlan 1690
diagnostic cns publish cisco.cns.device.diag_results
diagnostic cns subscribe cisco.cns.device.diag_commands
!
redundancy
mode rpr-plus
main-cpu
auto-sync running-config
auto-sync standard
!
vlan internal allocation policy ascending
vlan access-log ratelimit 2000
!
vlan 50,65-67,1690
!
class-map match-all class_video_high
match access-group name acl_video_high
class-map match-all class_VoIP
match access-group name acl_VoIP
class-map match-all class_high_speed_data
match access-group name acl_high_speed_data
class-map match-all class_VoD_OOB
match access-group name acl_VoD_OOB
class-map match-all class_video_low
match access-group name acl_video_low
!
!
policy-map setDSCP
description Mark DSCP values for the different types of traffic
class class_video_high
set dscp cs4
class class_video_low
set dscp af41
class class_VoIP
set dscp ef
class class_VoD_OOB
set dscp cs3
class class_high_speed_data
set dscp default
!
!
interface Loopback1
description Endpoint for Tunnel1
ip address 10.10.10.10 255.255.255.255
!
interface Loopback3
description Endpoint for Tunnel3
ip address 14.14.14.14 255.255.255.255
!
interface Tunnel1
description Vlan1690 Rx from DHub_Sw_A
ip vrf forwarding Video
no ip address
tunnel source Loopback1
tunnel destination 11.11.11.11
tunnel udlr receive-only Vlan1690
!
interface Tunnel3
description UDL3 Rx from DHub_Sw_C
ip vrf forwarding Video
no ip address
tunnel source Loopback3
tunnel destination 15.15.15.15
tunnel udlr receive-only TenGigabitEthernet7/3
!
interface GigabitEthernet2/1
no ip address
shutdown
!
interface GigabitEthernet2/2
no ip address
shutdown
!
interface GigabitEthernet2/3
no ip address
shutdown
!
interface GigabitEthernet2/4
no ip address
shutdown
!
interface GigabitEthernet2/5
no ip address
shutdown
!
interface GigabitEthernet2/6
no ip address
shutdown
!
interface GigabitEthernet2/7
no ip address
shutdown
!
interface GigabitEthernet2/8
no ip address
shutdown
!
interface GigabitEthernet2/9
description BDL32: High speed data
no ip address
switchport
switchport access vlan 65
switchport mode access
no cdp enable
spanning-tree portfast
service-policy input setDSCP
!
interface GigabitEthernet2/10
description BDL33: High speed data
no ip address
switchport
switchport access vlan 65
switchport mode access
no cdp enable
spanning-tree portfast
service-policy input setDSCP
!
interface GigabitEthernet2/11
no ip address
shutdown
!
interface GigabitEthernet2/12
no ip address
shutdown
!
interface GigabitEthernet2/13
no ip address
shutdown
!
interface GigabitEthernet2/14
no ip address
shutdown
!
interface GigabitEthernet2/15
description BDL1: Non-video traffic to/from DHub_Sw_A (Gig3/1)
ip address 192.168.168.1 255.255.255.252
mls qos trust dscp
!
interface GigabitEthernet2/16
description BDL3: Non-video traffic to/from DHub_Sw_C (Gig3/1)
ip address 192.168.168.13 255.255.255.252
mls qos trust dscp
!
interface GigabitEthernet3/1
description BDL34: VoIP traffic
no ip address
switchport
switchport access vlan 66
switchport mode access
no cdp enable
spanning-tree portfast
service-policy input setDSCP
!
interface GigabitEthernet3/2
description BDL35: VoIP traffic
no ip address
switchport
switchport access vlan 66
switchport mode access
no cdp enable
spanning-tree portfast
service-policy input setDSCP
!
interface GigabitEthernet3/3
no ip address
shutdown
!
interface GigabitEthernet3/4
no ip address
shutdown
!
interface GigabitEthernet3/5
no ip address
shutdown
!
interface GigabitEthernet3/6
no ip address
shutdown
!
interface GigabitEthernet3/7
no ip address
shutdown
!
interface GigabitEthernet3/8
description BDL52: VoD OOB
no ip address
speed 100
duplex full
switchport
switchport access vlan 67
switchport mode access
no cdp enable
spanning-tree portfast
service-policy input setDSCP
!
interface GigabitEthernet3/9
no ip address
shutdown
!
! omitted interfaces GigabitEthernet3/10 - 35
!
interface GigabitEthernet3/36
no ip address
shutdown
!
interface GigabitEthernet3/37
description BDL6: Concurrent VoD server ingress (MH-4000-1)
no ip address
speed 1000
duplex full
switchport
switchport access vlan 50
switchport mode access
no cdp enable
spanning-tree portfast
service-policy input setDSCP
!
interface GigabitEthernet3/38
description BDL7: SeaChange VoD server ingress (ITVDemo1)
no ip address
speed 1000
duplex full
switchport
switchport access vlan 50
switchport mode access
no cdp enable
spanning-tree portfast
service-policy input setDSCP
!
interface GigabitEthernet3/39
description BDL8: Concurrent VoD server ingress (MH-4000-6)
no ip address
speed 1000
duplex full
switchport
switchport access vlan 50
switchport mode access
no cdp enable
spanning-tree portfast
service-policy input setDSCP
!
interface GigabitEthernet3/40
no ip address
shutdown
!
! omitted interfaces GigabitEthernet3/41 - 47
!
interface GigabitEthernet3/48
no ip address
shutdown
!
interface GigabitEthernet5/1
no ip address
shutdown
!
interface GigabitEthernet5/2
no ip address
media-type rj45
shutdown
!
interface TenGigabitEthernet7/1
description UDL1: Video traffic to DHub_Sw_A (TenGig1/1)
no ip address
no wrr-queue random-detect 2
unidirectional send-only
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1690
switchport mode trunk
switchport nonegotiate
!
interface TenGigabitEthernet7/2
no ip address
shutdown
!
interface TenGigabitEthernet7/3
description UDL3: Video traffic to DHub_Sw_C (TenGig1/1)
ip vrf forwarding Video
ip address 192.168.169.9 255.255.255.252
no wrr-queue random-detect 2
unidirectional send-only
!
interface TenGigabitEthernet7/4
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
interface Vlan50
description VoD servers
ip vrf forwarding Video
ip address 192.168.50.2 255.255.255.0
no ip unreachables
standby 50 ip 192.168.50.1
!
interface Vlan65
description High speed data
ip address 192.168.65.1 255.255.255.0
!
interface Vlan66
description VoIP traffic
ip address 192.168.66.1 255.255.255.0
!
interface Vlan67
description VoD OOB traffic
ip address 192.168.67.1 255.255.255.0
!
interface Vlan1690
description Video traffic to/from DHub_Sw_A
ip vrf forwarding Video
ip address 192.168.169.1 255.255.255.252
no ip unreachables
!
router ospf 100 vrf Video
log-adjacency-changes
capability vrf-lite
network 192.168.50.0 0.0.0.255 area 0
network 192.168.169.0 0.0.0.3 area 0
network 192.168.169.8 0.0.0.3 area 0
network 192.168.169.32 0.0.0.3 area 0
network 192.168.169.36 0.0.0.3 area 0
!
router ospf 101
log-adjacency-changes
passive-interface default
no passive-interface Vlan1690
no passive-interface GigabitEthernet2/15
no passive-interface GigabitEthernet2/16
no passive-interface TenGigabitEthernet7/3
network 10.10.10.10 0.0.0.0 area 0
network 14.14.14.14 0.0.0.0 area 0
network 192.168.65.0 0.0.0.255 area 0
network 192.168.66.0 0.0.0.255 area 0
network 192.168.67.0 0.0.0.255 area 0
network 192.168.168.0 0.0.0.3 area 0
network 192.168.168.12 0.0.0.3 area 0
!
ip classless
no ip http server
!
!
ip access-list extended acl_VoD_OOB
remark Identify VoD OOB traffic.
permit ip 192.168.67.0 0.0.0.255 any
ip access-list extended acl_VoIP
remark Identify VoIP traffic.
permit ip 192.168.66.0 0.0.0.255 any
ip access-list extended acl_high_speed_data
remark Identify high speed data.
permit ip 192.168.65.0 0.0.0.255 any
ip access-list extended acl_video_high
remark Identify high priority VoD server traffic.
permit udp 192.168.48.0 0.0.7.255 192.168.160.0 0.0.3.255 range 3329 6399
ip access-list extended acl_video_low
remark Identify low priority VoD server traffic.
permit udp 192.168.48.0 0.0.7.255 192.168.160.0 0.0.3.255 range 257 3327
!
dial-peer cor custom
!
!
line con 0
exec-timeout 0 0
password cisco123
logging synchronous
login
line vty 0 4
exec-timeout 0 0
password cisco
logging synchronous
login
!
end



hometocprevnextglossaryfeedbacksearchhelp

Posted: Mon Mar 13 09:09:27 PST 2006
All contents are Copyright © 1992--2006 Cisco Systems, Inc. All rights reserved.
Important Notices and Privacy Statement.