cc/td/doc/solution/vodsols/geopt1_1
hometocprevnextglossaryfeedbacksearchhelp
PDF

Table Of Contents

Switch in Dhub:
Sample Redundancy Configurations for
Cisco Catalyst 4500 Series Switches

HSRP without UDLR

Active Headend: HSRP without UDLR

Standby Headend: HSRP without UDLR

Dhub: HSRP without UDLR

HSRP with UDLR

Active Headend: HSRP with UDLR

Standby Headend: HSRP with UDLR

Dhub: HSRP with UDLR

HSRP with Interface Tracking

Active Headend: HSRP with Interface Tracking

Standby Headend: HSRP with Interface Tracking

Dhub: HSRP with Interface Tracking

Layer 3 1+1 Protection

Headend: Layer 3 Protection

Dhub: Layer 3 Protection


Switch in Dhub:
Sample Redundancy Configurations for
Cisco Catalyst 4500 Series Switches


This appendix presents sample redundancy configurations for the following switch-in-Dhub scenarios:

Active Headend: HSRP without UDLR

Standby Headend: HSRP without UDLR

Dhub: HSRP without UDLR

Active Headend: HSRP with UDLR

Standby Headend: HSRP with UDLR

Dhub: HSRP with UDLR

Active Headend: HSRP with Interface Tracking

Standby Headend: HSRP with Interface Tracking

Dhub: HSRP with Interface Tracking

Headend: Layer 3 Protection

Dhub: Layer 3 Protection



Note See Using and Monitoring HSRP, and HSRP Redundancy Scenarios.


HSRP without UDLR

The following configurations are related in this series of examples:

Active Headend: HSRP without UDLR

Standby Headend: HSRP without UDLR

Dhub: HSRP without UDLR

For topology and discussion, see Switch in Dhub: HSRP without UDLR.

Active Headend: HSRP without UDLR

Current configuration : 3484 bytes
!
version 12.1
service nagle
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname HeadEnd
!
!
clock timezone pst -8
qos
ip subnet-zero
ip cef load-sharing algorithm original
no ip domain-lookup
!
ip multicast-routing
!
class-map match-all class_video
match access-group name acl_video
!
!
policy-map setDSCP
description Mark all video traffic with DSCP of EF
class class_video
set ip dscp 46
!
!
spanning-tree extend system-id
no spanning-tree vlan 151
port-channel load-balance dst-ip
!
redundancy
mode rpr
main-cpu
auto-sync standard
!
process-max-time 20
!
interface Port-channel1
description Primary Asymmetric EtherChannel to DHub_Z
ip address 10.10.10.1 255.255.255.252
ip ospf cost 100
ip ospf hello-interval 1
ip ospf dead-interval 3
load-interval 30
no keepalive
!
interface Port-channel2
description Backup Link to Standby Switch
ip address 10.10.20.1 255.255.255.252
ip ospf cost 200
ip ospf hello-interval 1
ip ospf dead-interval 3
load-interval 30
!
interface GigabitEthernet1/1
description Trunk to Headend for VLAN151
switchport access vlan 151
speed nonegotiate
!
interface GigabitEthernet1/2
!
interface GigabitEthernet2/1
!
interface GigabitEthernet2/2
!
interface GigabitEthernet3/1
description Bidirectional Link of P1
no switchport
no ip address
logging event link-status
load-interval 30
speed nonegotiate
tx-queue 3
priority high
channel-group 1 mode on
!
interface GigabitEthernet3/2
description Unidirectional Link of P1
no switchport
no ip address
load-interval 30
no keepalive
unidirectional send-only
channel-group 1 mode on
!
interface GigabitEthernet3/3
!
interface GigabitEthernet3/4
!
interface GigabitEthernet3/5
!
interface GigabitEthernet3/6
!
interface GigabitEthernet4/1
description Bidirectional Link to P2
no switchport
no ip address
load-interval 30
speed nonegotiate
tx-queue 3
priority high
channel-group 2 mode on
!
interface GigabitEthernet4/2
description Bidirectional Link to P2
no switchport
no ip address
speed nonegotiate
tx-queue 3
priority high
channel-group 2 mode on
!
interface GigabitEthernet4/3
!
interface GigabitEthernet4/4
!
interface GigabitEthernet4/5
!
interface GigabitEthernet4/6
description VOD server input
switchport access vlan 151
switchport mode access
load-interval 30
speed nonegotiate
unidirectional receive-only
!
interface Vlan1
no ip address
!
interface Vlan151
description VOD Server Inputs
ip address 192.168.151.100 255.255.255.0
no ip redirects
service-policy input setDSCP
standby ip 192.168.151.2
standby timers 1 2
standby priority 100
standby preempt
!
router ospf 100
log-adjacency-changes
passive-interface Vlan151
network 10.10.0.0 0.0.255.255 area 0
network 192.168.0.0 0.0.255.255 area 0
!
ip classless
no ip http server
!
!
ip access-list extended acl_video
remark Identify video traffic (UDP ports 257-33023 for QAM)
permit udp any any range 257 33032
!
!
!
line con 0
stopbits 1
line vty 0 4
login
!
!
monitor session 1 source interface Gi2/1
monitor session 1 destination interface Gi3/5
end

Standby Headend: HSRP without UDLR

Current configuration : 3198 bytes
!
version 12.1
service nagle
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service compress-config
!
hostname HE_Standby
!
logging buffered 65536 debugging
!
clock timezone pst -8
ip subnet-zero
no ip domain-lookup
!
ip multicast-routing
!
spanning-tree extend system-id
no spanning-tree vlan 151
!
process-max-time 20
!
interface Port-channel1
description Asymmetric EC to DHub_Y
ip address 10.10.15.1 255.255.255.252
ip ospf cost 100
ip ospf hello-interval 1
ip ospf dead-interval 3
load-interval 30
!
interface Port-channel2
description Backup Link to Primary
ip address 10.10.20.2 255.255.255.252
ip ospf cost 200
ip ospf hello-interval 1
ip ospf dead-interval 3
load-interval 30
!
interface Tunnel0
no ip address
!
interface GigabitEthernet1/1
description Link for VLAN 151 standby messages
switchport access vlan 151
ip access-group acl_standby_link out
speed nonegotiate
!
interface GigabitEthernet1/2
!
interface GigabitEthernet2/1
description Bidirectional Link of P1
no switchport
no ip address
load-interval 30
speed nonegotiate
tx-queue 3
priority high
channel-group 1 mode on
!
interface GigabitEthernet2/2
description Bidirectional Link of P1
no switchport
no ip address
load-interval 30
tx-queue 3
priority high
unidirectional send-only
channel-group 1 mode on
!
interface GigabitEthernet2/3
load-interval 30
!
interface GigabitEthernet2/4
load-interval 30
speed nonegotiate
!
interface GigabitEthernet2/5
load-interval 30
speed nonegotiate
!
interface GigabitEthernet2/6
description Standby interface for VOD Servers
switchport access vlan 151
load-interval 30
speed nonegotiate
unidirectional receive-only
!
interface GigabitEthernet3/1
description Bidirectional Link of P2
no switchport
no ip address
load-interval 30
speed nonegotiate
channel-group 2 mode on
!
interface GigabitEthernet3/2
description Bidirectional Link of P2
no switchport
no ip address
load-interval 30
speed nonegotiate
channel-group 2 mode on
!
interface GigabitEthernet3/3
!
interface GigabitEthernet3/4
!
interface GigabitEthernet3/5
description Bidirectional Link of P2
no switchport
no ip address
!
interface GigabitEthernet3/6
description Bidirectional link of p2
no switchport
no ip address
!
interface Vlan1
no ip address
!
interface Vlan150
no ip address
!
interface Vlan151
ip address 192.168.151.101 255.255.255.0
no ip redirects
standby ip 192.168.151.2
standby timers 1 2
standby priority 10
!
router ospf 100
log-adjacency-changes
passive-interface Vlan151
network 10.10.0.0 0.0.255.255 area 0
network 192.168.0.0 0.0.255.255 area 0
!
ip classless
no ip http server
!
!
ip access-list extended acl_standby_link
remark Stop video traffic on standby_link (g1/1)
permit icmp any any
!
!
!
line con 0
stopbits 1
line vty 0 4
login
!
!
monitor session 1 source interface Gi2/5
end

Dhub: HSRP without UDLR

Current configuration : 2482 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service compress-config
!
hostname Dhub_Y
!
!
ip subnet-zero
no ip domain-lookup
!
spanning-tree extend system-id
!
process-max-time 20
!
interface Port-channel1
description Asymmetric EC from Primary
ip address 10.10.10.2 255.255.255.252
ip ospf cost 100
ip ospf hello-interval 1
ip ospf dead-interval 3
load-interval 30
!
interface Port-channel2
description Asymmetric EC from Secondary
ip address 10.10.15.2 255.255.255.252
ip ospf hello-interval 1
ip ospf dead-interval 3
load-interval 30
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface GigabitEthernet2/1
description Bidirectional Link for P1
no switchport
no ip address
load-interval 30
speed nonegotiate
tx-queue 3
priority high
channel-group 1 mode on
!
interface GigabitEthernet2/2
description Unidirectional link for P1
no switchport
no ip address
load-interval 30
speed nonegotiate
tx-queue 3
priority high
unidirectional receive-only
channel-group 1 mode on
!
interface GigabitEthernet2/3
!
interface GigabitEthernet2/4
!
interface GigabitEthernet2/5
!
interface GigabitEthernet2/6
!
interface GigabitEthernet3/1
description Bidirectional link for P2
no switchport
no ip address
load-interval 30
speed nonegotiate
channel-group 2 mode on
!
interface GigabitEthernet3/2
description Unidirectional link for P2
no switchport
no ip address
load-interval 30
unidirectional receive-only
channel-group 2 mode on
!
interface GigabitEthernet3/3
!
interface GigabitEthernet3/4
!
interface GigabitEthernet3/5
description Output to Marquis
switchport access vlan 150
load-interval 30
speed nonegotiate
!
interface GigabitEthernet3/6
description QAM1
switchport access vlan 150
load-interval 30
speed nonegotiate
!
interface Vlan1
no ip address
!
interface Vlan150
description VLAN for Edge QAM devices
ip address 192.168.150.2 255.255.255.0
arp timeout 150
!
router ospf 100
log-adjacency-changes
network 10.10.0.0 0.0.255.255 area 0
network 192.168.0.0 0.0.255.255 area 0
!
ip classless
no ip http server
!
!
!
!
line con 0
stopbits 1
line vty 0 4
login
!
end

HSRP with UDLR

The following configurations are related in this series of examples:

Active Headend: HSRP with UDLR

Standby Headend: HSRP with UDLR

Dhub: HSRP with UDLR

For topology and discussion, see Switch in Dhub: HSRP with UDLR.

Active Headend: HSRP with UDLR

Current configuration : 3716 bytes
!
version 12.1
service nagle
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname HeadEnd
!
!
clock timezone pst -8
qos
ip subnet-zero
ip cef load-sharing algorithm original
no ip domain-lookup
!
ip multicast-routing
!
class-map match-all class_video
match access-group name acl_video
!
!
policy-map setDSCP
description Mark all video traffic with DSCP of EF
class class_video
set ip dscp 46
!
!
spanning-tree extend system-id
no spanning-tree vlan 151
port-channel load-balance dst-ip
!
redundancy
mode rpr
main-cpu
auto-sync standard
!
process-max-time 20
!
interface Port-channel1
description Primary Asymmetric EtherChannel to DHub_Z
ip address 10.10.10.1 255.255.255.252
ip ospf cost 100
ip ospf hello-interval 1
ip ospf dead-interval 3
load-interval 30
no keepalive
!
interface Port-channel2
description Backup Link to Standby Switch
ip address 10.10.20.1 255.255.255.252
ip ospf cost 200
ip ospf hello-interval 1
ip ospf dead-interval 3
load-interval 30
!
interface GigabitEthernet1/1
description Trunk to Headend for VLAN151
switchport access vlan 151
speed nonegotiate
!
interface GigabitEthernet1/2
!
interface GigabitEthernet2/1
!
interface GigabitEthernet2/2
!
interface GigabitEthernet3/1
description Send Only Link of P1
no switchport
no ip address
load-interval 30
tx-queue 3
priority high
unidirectional send-only
channel-group 1 mode on
!
interface GigabitEthernet3/2
description Unidirectional Link of P1
no switchport
no ip address
load-interval 30
no keepalive
unidirectional send-only
channel-group 1 mode on
!
interface GigabitEthernet3/3
description Rec Only link of P1
no switchport
no ip address
load-interval 30
tx-queue 3
priority high
unidirectional receive-only
channel-group 1 mode on
!
interface GigabitEthernet3/4
!
interface GigabitEthernet3/5
!
interface GigabitEthernet3/6
!
interface GigabitEthernet4/1
description Bidirectional Link to P2
no switchport
no ip address
load-interval 30
speed nonegotiate
tx-queue 3
priority high
channel-group 2 mode on
!
interface GigabitEthernet4/2
description Bidirectional Link to P2
no switchport
no ip address
speed nonegotiate
tx-queue 3
priority high
channel-group 2 mode on
!
interface GigabitEthernet4/3
!
interface GigabitEthernet4/4
!
interface GigabitEthernet4/5
!
!
interface GigabitEthernet4/6
description VOD server input
switchport access vlan 151
switchport mode access
load-interval 30
speed nonegotiate
unidirectional receive-only
!
interface Vlan1
no ip address
!
interface Vlan151
description VOD Server Inputs
ip address 192.168.151.100 255.255.255.0
no ip redirects
service-policy input setDSCP
standby ip 192.168.151.2
standby timers 1 2
standby priority 100
standby preempt
standby track GigabitEthernet3/3 100
!
router ospf 100
log-adjacency-changes
passive-interface Vlan151
network 10.10.0.0 0.0.255.255 area 0
network 192.168.0.0 0.0.255.255 area 0
!
ip classless
no ip http server
!
!
ip access-list extended acl_video
remark Identify video traffic (UDP ports 257-33023 for QAM)
permit udp any any range 257 33032
!
!
!
line con 0
stopbits 1
line vty 0 4
login
!
!
monitor session 1 source interface Gi2/1
monitor session 1 destination interface Gi3/5
end

Standby Headend: HSRP with UDLR

Current configuration : 3321 bytes
!
version 12.1
service nagle
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service compress-config
!
hostname HE_Standby
!
!
clock timezone pst -8
ip subnet-zero
no ip domain-lookup
!
ip multicast-routing
!
spanning-tree extend system-id
no spanning-tree vlan 151
!
process-max-time 20
!
interface Port-channel1
description Asymmetric EC to DHub_Y
ip address 10.10.15.1 255.255.255.252
ip ospf cost 100
ip ospf hello-interval 1
ip ospf dead-interval 3
load-interval 30
!
interface Port-channel2
description Backup Link to Primary
ip address 10.10.20.2 255.255.255.252
ip ospf cost 200
ip ospf hello-interval 1
ip ospf dead-interval 3
load-interval 30
!
interface Tunnel0
no ip address
tunnel source 10.10.20.2
tunnel destination 10.10.10.2
tunnel udlr receive-only Port-channel1
!
interface GigabitEthernet1/1
description Link for VLAN 151 standby messages
switchport access vlan 151
ip access-group acl_standby_link out
speed nonegotiate
!
interface GigabitEthernet1/2
!
interface GigabitEthernet2/1
description Bidirectional Link of P1
no switchport
no ip address
load-interval 30
speed nonegotiate
tx-queue 3
priority high
unidirectional send-only
channel-group 1 mode on
!
interface GigabitEthernet2/2
description Bidirectional Link of P1
no switchport
no ip address
load-interval 30
tx-queue 3
priority high
unidirectional send-only
channel-group 1 mode on
!
interface GigabitEthernet2/3
load-interval 30
!
interface GigabitEthernet2/4
load-interval 30
speed nonegotiate
!
interface GigabitEthernet2/5
load-interval 30
speed nonegotiate
!
interface GigabitEthernet2/6
description Standby interface for VOD Servers
switchport access vlan 151
load-interval 30
speed nonegotiate
unidirectional receive-only
!
interface GigabitEthernet3/1
description Bidirectional Link of P2
no switchport
no ip address
load-interval 30
speed nonegotiate
channel-group 2 mode on
!
interface GigabitEthernet3/2
description Bidirectional Link of P2
no switchport
no ip address
load-interval 30
speed nonegotiate
channel-group 2 mode on
!
interface GigabitEthernet3/3
!
interface GigabitEthernet3/4
!
interface GigabitEthernet3/5
description Bidirectional Link of P2
no switchport
no ip address
!
interface GigabitEthernet3/6
description Bidirectional link of p2
no switchport
no ip address
!
interface Vlan1
no ip address
!
interface Vlan150
no ip address
!
interface Vlan151
ip address 192.168.151.101 255.255.255.0
no ip redirects
standby ip 192.168.151.2
standby timers 1 2
standby priority 10
!
router ospf 100
log-adjacency-changes
passive-interface Vlan151
network 10.10.0.0 0.0.255.255 area 0
network 192.168.0.0 0.0.255.255 area 0
!
ip classless
no ip http server
!
!
ip access-list extended acl_standby_link
remark Stop video traffic on standby_link (g1/1)
permit icmp any any
!
!
!
line con 0
stopbits 1
line vty 0 4
login
!
!
monitor session 1 source interface Gi2/5
end

Dhub: HSRP with UDLR

Current configuration : 2836 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service compress-config
!
hostname Dhub_Y
!
!
ip subnet-zero
no ip domain-lookup
!
spanning-tree extend system-id
!
process-max-time 20
!
interface Port-channel1
description Uni+Bidirectional EC from Primary
ip address 10.10.10.2 255.255.255.252
ip ospf cost 100
ip ospf hello-interval 1
ip ospf dead-interval 3
load-interval 30
!
interface Port-channel2
description Asymmetric EC from Secondary
ip address 10.10.15.2 255.255.255.252
ip ospf cost 300
ip ospf hello-interval 1
ip ospf dead-interval 3
load-interval 30
!
interface Tunnel0
no ip address
tunnel source 10.10.10.2
tunnel destination 10.10.20.2
tunnel udlr send-only Port-channel2
tunnel udlr address-resolution
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface GigabitEthernet2/1
description Bidirectional Link for P1
no switchport
no ip address
load-interval 30
tx-queue 3
priority high
unidirectional receive-only
channel-group 1 mode on
!
interface GigabitEthernet2/2
description Unidirectional link for P1
no switchport
no ip address
load-interval 30
tx-queue 3
priority high
unidirectional receive-only
channel-group 1 mode on
!
interface GigabitEthernet2/3
no switchport
no ip address
load-interval 30
tx-queue 3
priority high
unidirectional send-only
channel-group 1 mode on
!
interface GigabitEthernet2/4
!
interface GigabitEthernet2/5
!
interface GigabitEthernet2/6
!
interface GigabitEthernet3/1
description Bidirectional link for P2
no switchport
no ip address
load-interval 30
speed nonegotiate
unidirectional receive-only
channel-group 2 mode on
!
interface GigabitEthernet3/2
description Unidirectional link for P2
no switchport
no ip address
load-interval 30
unidirectional receive-only
channel-group 2 mode on
!
interface GigabitEthernet3/3
!
interface GigabitEthernet3/4
!
interface GigabitEthernet3/5
description Output to Marquis
switchport access vlan 150
load-interval 30
speed nonegotiate
!
interface GigabitEthernet3/6
description QAM1
switchport access vlan 150
load-interval 30
speed nonegotiate
!
interface Vlan1
no ip address
!
interface Vlan150
description VLAN for Edge QAM devices
ip address 192.168.150.2 255.255.255.0
arp timeout 150
!
router ospf 100
log-adjacency-changes
network 10.10.0.0 0.0.255.255 area 0
network 192.168.0.0 0.0.255.255 area 0
!
ip classless
no ip http server
!
!
!
!
line con 0
stopbits 1
line vty 0 4
login
!
end

HSRP with Interface Tracking

The following configurations are related in this series of examples:

Active Headend: HSRP with Interface Tracking

Standby Headend: HSRP with Interface Tracking

Dhub: HSRP with Interface Tracking

For topology and discussion, see Switch in Dhub: HSRP with Interface Tracking.

Active Headend: HSRP with Interface Tracking

Current configuration : 3899 bytes
!
version 12.1
service nagle
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname HeadEnd
!
!
clock timezone pst -8
qos
ip subnet-zero
ip cef load-sharing algorithm original
no ip domain-lookup
!
ip multicast-routing
!
class-map match-all class_video
match access-group name acl_video
!
!
policy-map setDSCP
description Mark all video traffic with DSCP of EF
class class_video
set ip dscp 46
!
!
spanning-tree extend system-id
no spanning-tree vlan 151
port-channel load-balance dst-ip
!
redundancy
mode rpr
main-cpu
auto-sync standard
!
process-max-time 20
!
interface Port-channel1
description Primary Asymmetric EtherChannel to DHub_Z
ip address 10.10.10.1 255.255.255.252
ip ospf cost 100
ip ospf hello-interval 1
ip ospf dead-interval 3
load-interval 30
no keepalive
!
interface Port-channel2
description Backup Link to Standby Switch
ip address 10.10.20.1 255.255.255.252
ip ospf cost 200
ip ospf hello-interval 1
ip ospf dead-interval 3
load-interval 30

!
interface GigabitEthernet1/1
description Trunk to Headend for VLAN151
switchport access vlan 151
ip access-group acl_standby_link out
speed nonegotiate
!
interface GigabitEthernet1/2
!
interface GigabitEthernet2/1
!
interface GigabitEthernet2/2
!
interface GigabitEthernet3/1
description Send Only Link of P1
no switchport
no ip address
load-interval 30
tx-queue 3
priority high
channel-group 1 mode on
!
interface GigabitEthernet3/2
description Unidirectional Link of P1
no switchport
no ip address
load-interval 30
no keepalive
unidirectional send-only
channel-group 1 mode on
!
interface GigabitEthernet3/3
!
interface GigabitEthernet3/4
!
interface GigabitEthernet3/5
!
interface GigabitEthernet3/6
!
interface GigabitEthernet4/1
!
interface GigabitEthernet4/2
!
interface GigabitEthernet4/3
!
interface GigabitEthernet4/4
!
interface GigabitEthernet4/5
!
interface GigabitEthernet4/6
description VOD server input
switchport access vlan 151
switchport mode access
load-interval 30
speed nonegotiate
unidirectional receive-only
!
interface Vlan1
no ip address
!
interface Vlan151
description VOD Server Inputs
ip address 192.168.151.100 255.255.255.0
no ip redirects
service-policy input setDSCP
standby ip 192.168.151.2
standby timers 1 2
standby priority 100
standby preempt
standby track GigabitEthernet3/1 100
!
router ospf 100
log-adjacency-changes
passive-interface Vlan151
network 10.10.0.0 0.0.255.255 area 0
network 192.168.0.0 0.0.255.255 area 0
!
ip classless
no ip http server
!
!
ip access-list extended acl_standby_link
remark Stop video traffic on standby_link (g1/1)
permit icmp any any
ip access-list extended acl_video
remark Identify video traffic (UDP ports 257-33023 for QAM)
permit udp any any range 257 33032
!
!
!
line con 0
stopbits 1
line vty 0 4
login
!
!
monitor session 1 source interface Gi2/1
monitor session 1 destination interface Gi3/5
end

Standby Headend: HSRP with Interface Tracking

Current configuration : 3180 bytes
!
version 12.1
service nagle
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service compress-config
!
hostname HE_Standby
!
!
clock timezone pst -8
ip subnet-zero
no ip domain-lookup
!
ip multicast-routing
!
spanning-tree extend system-id
no spanning-tree vlan 151
!
process-max-time 20
!
interface Port-channel1
description Asymmetric EC to DHub_Y
ip address 10.10.15.1 255.255.255.252
ip ospf cost 100
ip ospf hello-interval 1
ip ospf dead-interval 3
load-interval 30
!
interface Port-channel2
description Backup Link to Primary
ip address 10.10.20.2 255.255.255.252
ip ospf cost 200
ip ospf hello-interval 1
ip ospf dead-interval 3
load-interval 30
!
interface GigabitEthernet1/1
description Link for VLAN 151 standby messages
switchport access vlan 151
ip access-group acl_standby_link out
speed nonegotiate
!
interface GigabitEthernet1/2
!
interface GigabitEthernet2/1
description Bidirectional Link of P1
no switchport
no ip address
load-interval 30
speed nonegotiate
tx-queue 3
priority high
channel-group 1 mode on
!
interface GigabitEthernet2/2
description Bidirectional Link of P1
no switchport
no ip address
load-interval 30
tx-queue 3
priority high
unidirectional send-only
channel-group 1 mode on
!
interface GigabitEthernet2/3
load-interval 30
!
interface GigabitEthernet2/4
load-interval 30
speed nonegotiate
!
interface GigabitEthernet2/5
load-interval 30
speed nonegotiate
!
interface GigabitEthernet2/6
description Standby interface for VOD Servers
switchport access vlan 151
load-interval 30
speed nonegotiate
unidirectional receive-only
!
interface GigabitEthernet3/1
description Bidirectional Link of P2
no switchport
no ip address
load-interval 30
speed nonegotiate
channel-group 2 mode on
!
interface GigabitEthernet3/2
description Bidirectional Link of P2
no switchport
no ip address
load-interval 30
speed nonegotiate
channel-group 2 mode on
!
interface GigabitEthernet3/3
!
interface GigabitEthernet3/4
!
interface GigabitEthernet3/5
description Bidirectional Link of P2
no switchport
no ip address
!
interface GigabitEthernet3/6
description Bidirectional link of p2
no switchport
no ip address
!
interface Vlan1
no ip address
!
interface Vlan150
no ip address
!
interface Vlan151
ip address 192.168.151.101 255.255.255.0
no ip redirects
standby ip 192.168.151.2
standby timers 1 2
standby priority 10
standby preempt
!
router ospf 100
log-adjacency-changes
passive-interface Vlan151
network 10.10.0.0 0.0.255.255 area 0
network 192.168.0.0 0.0.255.255 area 0
!
ip classless
no ip http server
!
!
ip access-list extended acl_standby_link
remark Stop video traffic on standby_link (g1/1)
permit icmp any any
!
!
!
line con 0
stopbits 1
line vty 0 4
login
!
!
monitor session 1 source interface Gi2/5
end

Dhub: HSRP with Interface Tracking

This configuration is the same as that for Dhub: HSRP without UDLR.

Layer 3 1+1 Protection

The following configurations are related in this series of examples:

Headend: Layer 3 Protection

Dhub: Layer 3 Protection

For topology and discussion, see Layer 3 1+1 Protection Scheme.

Headend: Layer 3 Protection

Current configuration : 4209 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service compress-config
!
hostname HeadEnd
!
no logging console
!
qos
ip subnet-zero
no ip domain-lookup
!
!
class-map match-all class_video
match access-group name acl_video
!
!
policy-map setDSCP
description Mark all video traffic with DSCP of EF
class class_video
set ip dscp 46
!
spanning-tree extend system-id
port-channel load-balance dst-port
!
redundancy
mode rpr
main-cpu
auto-sync standard
!
process-max-time 20
!
interface Port-channel1
description Primary Asymmetric EtherChannel to DHub_Z
ip address 192.168.169.1 255.255.255.252
ip ospf hello-interval 1
ip ospf dead-interval 3
load-interval 30
!
interface Port-channel2
description Secondary Asymmetric EtherChannel to Dhub_Z
ip address 192.168.170.1 255.255.255.252
ip ospf hello-interval 1
ip ospf dead-interval 3
load-interval 30
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface GigabitEthernet2/1
!
interface GigabitEthernet2/2
!
interface GigabitEthernet3/1
description Bidirectional Link to P1 1554.13nm
no switchport
no ip address
load-interval 30
tx-queue 3
priority high
channel-group 1 mode on
!
interface GigabitEthernet3/2
description Unidirectional Link to P1 1554.94nm
no switchport
no ip address
load-interval 30
unidirectional send-only
channel-group 1 mode on
!
interface GigabitEthernet3/3
!
interface GigabitEthernet3/4
!
interface GigabitEthernet3/5
!
interface GigabitEthernet3/6
!
interface GigabitEthernet4/1
description Bidirectional Link to P2 1550.12nm
no switchport
no ip address
load-interval 30
tx-queue 3
priority high
channel-group 2 mode on
!
interface GigabitEthernet4/2
description Unidirectional Line to P2 1550.92nm
no switchport
no ip address
tx-queue 3
priority high
unidirectional send-only
channel-group 2 mode on
!
interface GigabitEthernet4/3
!
interface GigabitEthernet4/4
!
interface GigabitEthernet4/5
!
interface GigabitEthernet4/6
description VOD server input
switchport access vlan 50
switchport mode access
load-interval 30
!
interface GigabitEthernet5/1
description VOD server input
switchport access vlan 50
switchport mode access
load-interval 30
speed 1000
!
interface GigabitEthernet5/2
!
interface GigabitEthernet5/3
!
interface GigabitEthernet5/4
!
<---output omitted--->
!
interface GigabitEthernet5/47
!
interface GigabitEthernet5/48
!
interface Vlan1
no ip address
!
interface Vlan50
description VOD servers
ip address 192.168.50.150 255.255.255.0
no ip redirects
no ip unreachables
service-policy input setDSCP
!
router ospf 100
log-adjacency-changes
network 192.168.0.0 0.0.255.255 area 0
!
ip classless
no ip http server
!
!
!
!
line con 0
stopbits 1
line vty 0 4
login
!
end

Dhub: Layer 3 Protection

Current configuration : 2415 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service compress-config
!
hostname DHUB_Z
!
no logging console
!
ip subnet-zero
no ip domain-lookup
!
spanning-tree extend system-id
!
process-max-time 20
!
interface Port-channel1
description Primary Asymmetric EtherChannel from Headend
ip address 192.168.169.2 255.255.255.252
ip ospf hello-interval 1
ip ospf dead-interval 3
load-interval 30
!
interface Port-channel2
description Secondary Asymmetric Etherchannel from Headend
ip address 192.168.170.2 255.255.255.252
ip ospf hello-interval 1
ip ospf dead-interval 3
load-interval 30
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface GigabitEthernet2/1
description Bidirectional Link of P1
no switchport
no ip address
load-interval 30
tx-queue 3
priority high
channel-group 1 mode on
!
interface GigabitEthernet2/2
description Unidirectional Link of P1
no switchport
no ip address
load-interval 30
tx-queue 3
priority high
unidirectional receive-only
channel-group 1 mode on
!
interface GigabitEthernet2/3
!
interface GigabitEthernet2/4
speed nonegotiate
!
interface GigabitEthernet2/5
description QAM1
switchport access vlan 160
load-interval 30
speed nonegotiate
!
interface GigabitEthernet2/6
description QAM2
switchport access vlan 160
load-interval 30
speed nonegotiate
!
interface GigabitEthernet3/1
!
interface GigabitEthernet3/2
!
interface GigabitEthernet3/3
!
interface GigabitEthernet3/4
!
interface GigabitEthernet3/5
description Bidirectional Link of P2
no switchport
no ip address
load-interval 30
channel-group 2 mode on
!
interface GigabitEthernet3/6
description Unidirectional Link of P2
no switchport
no ip address
load-interval 30
unidirectional receive-only
channel-group 2 mode on
!
interface Vlan1
no ip address
!
interface Vlan160
description QAM Devices
ip address 192.168.150.1 255.255.255.0
no ip unreachables
!
router ospf 100
log-adjacency-changes
network 192.168.0.0 0.0.255.255 area 0
!
ip classless
no ip http server
!
!
!
!
line con 0
stopbits 1
line vty 0 4
login
!
mac-address-table static 0090.f000.7268 vlan 160 interface GigabitEthernet2/5
!
monitor session 1 source interface Gi2/5
monitor session 1 destination interface Gi2/4
end

hometocprevnextglossaryfeedbacksearchhelp

Posted: Mon Mar 13 11:08:37 PST 2006
All contents are Copyright © 1992--2006 Cisco Systems, Inc. All rights reserved.
Important Notices and Privacy Statement.