cc/td/doc/solution/vodsols/geopt1_1
hometocprevnextglossaryfeedbacksearchhelp
PDF

Table Of Contents

Switch in Dhub:
Sample Configurations for
Cisco Catalyst 4500 Series Switches

Single EtherChannel

Single EtherChannel: Headend Switch to Dhub Switch

Single EtherChannel: Dhub Switch to Headend Switch

Multiple EtherChannels

Multiple EtherChannels: Headend Switch to Dhub Switch

Multiple EtherChannels: Dhub Switch to Headend Switch

Subtended Control Path

Subtended Control Path: Headend Switch to Two Dhubs

Subtended Control Path: Dhub A to Headend Switch

Subtended Control Path: Dhub B to Headend Switch


Switch in Dhub:
Sample Configurations for
Cisco Catalyst 4500 Series Switches


This appendix illustrates the following switch-in-Dhub configuration examples:

Single EtherChannel: Headend Switch to Dhub Switch

Single EtherChannel: Dhub Switch to Headend Switch

Multiple EtherChannels: Headend Switch to Dhub Switch

Multiple EtherChannels: Dhub Switch to Headend Switch

Subtended Control Path: Headend Switch to Two Dhubs

Subtended Control Path: Dhub A to Headend Switch

Subtended Control Path: Dhub B to Headend Switch


Single EtherChannel

Single EtherChannel: Headend Switch to Dhub Switch

This switch-in-Dhub example illustrates a configuration on a Cisco Catalyst 4500 series switch in the headend connected to a Dhub switch through a single EtherChannel (Port-channel). Refer to Figure 3-1. For the corresponding configuration, see Single EtherChannel: Dhub Switch to Headend Switch.

Current configuration : 8157 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service compress-config
!
hostname Headend
!
!
qos
ip subnet-zero
no ip domain-lookup
!
!
class-map match-all class_video
match access-group name acl_video
!
!
policy-map setDSCP
description Mark all video traffic with DSCP of EF
class class_video
set ip dscp 46
!
spanning-tree extend system-id
port-channel load-balance dst-port
!
redundancy
mode rpr
main-cpu
auto-sync standard
!
process-max-time 20
!
interface Port-channel1
description Asymmetric EtherChannel to DHub_A
ip address 192.168.169.1 255.255.255.252
load-interval 30
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface GigabitEthernet2/1
!
interface GigabitEthernet2/2
!
interface GigabitEthernet3/1
description Bidirectional Link of EtherChannel
no switchport
no ip address
load-interval 30
tx-queue 3
priority high
channel-group 1 mode on
!
interface GigabitEthernet3/2
description Unidirectional Link of EtherChannel
no switchport
no ip address
load-interval 30
tx-queue 3
priority high
unidirectional send-only
channel-group 1 mode on
!
interface GigabitEthernet3/3
description Unidirectional Link of EtherChannel
no switchport
no ip address
load-interval 30
tx-queue 3
priority high
unidirectional send-only
channel-group 1 mode on
!
interface GigabitEthernet3/4
description Unidirectional Link of EtherChannel
no switchport
no ip address
load-interval 30
tx-queue 3
priority high
unidirectional send-only
channel-group 1 mode on
!
interface GigabitEthernet3/5
!
interface GigabitEthernet3/6
!
interface GigabitEthernet4/1
!
interface GigabitEthernet4/2
!
interface GigabitEthernet4/3
!
interface GigabitEthernet4/4
!
interface GigabitEthernet4/5
!
<---output omitted---> !
interface GigabitEthernet6/1
!
interface GigabitEthernet6/2
!
interface GigabitEthernet6/3
!
interface GigabitEthernet6/4
!
interface GigabitEthernet6/5
!
interface GigabitEthernet6/6
!
interface GigabitEthernet7/1
description VODserver1 GigE0
switchport access vlan 50
 switchport mode access
load-interval 30
 no cdp enable
!
interface GigabitEthernet7/2
!
interface GigabitEthernet7/3
!
interface GigabitEthernet7/4
!
interface GigabitEthernet7/5
 description VODserver1 GigE1
switchport access vlan 50
 switchport mode access
load-interval 30
speed 1000
 no cdp enable
!
interface GigabitEthernet7/6
!
interface GigabitEthernet7/7
!
interface GigabitEthernet7/8
!
interface GigabitEthernet7/9
description VODserver2 GigE0
switchport access vlan 50
 switchport mode access
load-interval 30
speed 1000
 no cdp enable
!
interface GigabitEthernet7/10
!
interface GigabitEthernet7/11
!
interface GigabitEthernet7/12
!
interface GigabitEthernet7/13
description VODserver2 GigE1
switchport access vlan 50
 switchport mode access
load-interval 30
speed 1000
 no cdp enable
!
interface GigabitEthernet7/14
!
interface GigabitEthernet7/15
!
interface GigabitEthernet7/16
!
interface GigabitEthernet7/17
description VODserver3
switchport access vlan 50
 switchport mode access
load-interval 30
speed 1000
 no cdp enable
!
interface GigabitEthernet7/18
!
<---output omitted--->
!
interface GigabitEthernet7/22
!
interface GigabitEthernet7/23
!
interface GigabitEthernet7/24
!
interface Vlan1
no ip address
!
interface Vlan50
description VoD Servers
ip address 192.168.50.2 255.255.255.0
no ip redirects
no ip unreachables
 load-interval 30
service-policy input setDSCP
standby 50 ip 192.168.50.1
!
router ospf 100
log-adjacency-changes
network 192.168.0.0 0.0.255.255 area 0
!
ip classless
no ip http server
!
!
ip access-list extended acl_video
remark Identify video traffic (UDP ports 257-33023).
permit udp any any range 257 33032
!
!
!
line con 0
exec-timeout 0 0
stopbits 1
line vty 0 4
login
!
end

Single EtherChannel: Dhub Switch to Headend Switch

This switch-in-Dhub example illustrates a configuration on a Cisco Catalyst 4500 series switch in the Dhub connected to a headend switch through a single EtherChannel (Port-channel). Refer to Figure 3-1. For the corresponding configuration, see Single EtherChannel: Headend Switch to Dhub Switch.

Current configuration : 5752 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service compress-config
!
hostname Dhub_A
!
!
ip subnet-zero
no ip domain-lookup
!
spanning-tree extend system-id
!
redundancy
mode rpr
main-cpu
auto-sync standard
!
process-max-time 20
!
interface Port-channel1
description Asymmetric EtherChannel from Headend
ip address 192.168.169.2 255.255.255.252
load-interval 30
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface GigabitEthernet2/1
!
interface GigabitEthernet2/2
!
interface GigabitEthernet3/1
description Bidirectional Link of EtherChannel
no switchport
no ip address
load-interval 30
channel-group 1 mode on
!
interface GigabitEthernet3/2
description Unidirectional Link of EtherChannel
no switchport
no ip address
load-interval 30
unidirectional receive-only
channel-group 1 mode on
!
interface GigabitEthernet3/3
description Unidirectional Link of EtherChannel
no switchport
no ip address
load-interval 30
unidirectional receive-only
channel-group 1 mode on
!
interface GigabitEthernet3/4
description Unidirectional Link of EtherChannel
no switchport
no ip address
load-interval 30
unidirectional receive-only
channel-group 1 mode on
!
interface GigabitEthernet3/5
!
interface GigabitEthernet3/6
!
interface GigabitEthernet4/1
description QAM1
switchport access vlan 160
 switchport mode access
load-interval 30
speed nonegotiate
!
interface GigabitEthernet4/2
description QAM2
switchport access vlan 160
 switchport mode access
load-interval 30
!
interface GigabitEthernet4/3
description QAM3
switchport access vlan 160
 switchport mode access
load-interval 30
!
interface GigabitEthernet4/4
description QAM4
switchport access vlan 160
 switchport mode access
load-interval 30
!
interface GigabitEthernet4/5
description QAM5
switchport access vlan 160
 switchport mode access
load-interval 30
!
interface GigabitEthernet4/6
!
interface GigabitEthernet5/1
!
interface GigabitEthernet5/2
!
interface GigabitEthernet5/3
!
interface GigabitEthernet5/4
!
interface GigabitEthernet5/5
!
interface GigabitEthernet5/6
!
interface GigabitEthernet6/1
!
interface GigabitEthernet6/2
!
interface GigabitEthernet6/3
!
interface GigabitEthernet6/4
!
interface GigabitEthernet6/5
!
interface GigabitEthernet6/6
!
interface GigabitEthernet7/1
!
interface GigabitEthernet7/2
!
<---output omitted--->
!
interface GigabitEthernet7/23
!
interface GigabitEthernet7/24
!
interface Vlan1
no ip address
!
interface Vlan160
description QAM Devices
ip address 192.168.160.1 255.255.255.0
 no ip redirects
 no ip unreachables
 load-interval 30
!
router ospf 100
log-adjacency-changes
passive-interface Vlan160
network 192.168.0.0 0.0.255.255 area 0
!
ip classless
no ip http server
!
!
arp 192.168.160.100 0020.a300.92aa ARPA
!
!
line con 0
exec-timeout 0 0
stopbits 1
line vty 0 4
login
!
mac-address-table static 0020.a300.92aa vlan 160 interface GigabitEthernet4/1
!
end

Multiple EtherChannels

Multiple EtherChannels: Headend Switch to Dhub Switch

This switch-in-Dhub example illustrates a configuration on a Cisco Catalyst 4500 series switch in the headend connected to a Dhub switch through two EtherChannels (Port-channels). Refer to Figure 3-2. For the corresponding configuration, see Multiple EtherChannels: Dhub Switch to Headend Switch.

Current configuration : 8157 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service compress-config
!
hostname Headend
!
qos
ip subnet-zero
ip cef load-sharing algorithm include-port destination
no ip domain-lookup
!
!
class-map match-all class_video
match access-group name acl_video
!
!
policy-map setDSCP
description Mark all video traffic with DSCP of EF
class class_video
set ip dscp 46
!
spanning-tree extend system-id
port-channel load-balance dst-port
!
redundancy
mode rpr
main-cpu
auto-sync standard
!
process-max-time 20
!
interface Loopback3
description Endpoint of Tunnel3
ip address 1.1.1.13 255.255.255.255
!
interface Port-channel3
description Unidirectional EtherChannel to DHub_D
ip address 192.168.169.13 255.255.255.252
load-interval 30
!
interface Port-channel4
description Asymmetric EtherChannel to DHub_D
ip address 192.168.169.17 255.255.255.252
load-interval 30
!
interface Tunnel3
description Return Path for Unidirectional EtherChannel 3
no ip address
tunnel source 1.1.1.13
tunnel destination 2.2.2.14
tunnel udlr receive-only Port-channel3
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface GigabitEthernet2/1
!
interface GigabitEthernet2/2
!
interface GigabitEthernet3/1
description Unidirectional Link of EtherChannel 3
no switchport
no ip address
load-interval 30
tx-queue 3
priority high
unidirectional send-only
channel-group 3 mode on
!
interface GigabitEthernet3/2
description Unidirectional Link of EtherChannel 3
no switchport
no ip address
load-interval 30
tx-queue 3
priority high
unidirectional send-only
channel-group 3 mode on
!
interface GigabitEthernet3/3
description Unidirectional Link of EtherChannel 3
no switchport
no ip address
load-interval 30
tx-queue 3
priority high
unidirectional send-only
channel-group 3 mode on
!
interface GigabitEthernet3/4
description Unidirectional Link of EtherChannel 3
no switchport
no ip address
load-interval 30
tx-queue 3
priority high
unidirectional send-only
channel-group 3 mode on
!
interface GigabitEthernet3/5
description Bidirectional Link of EtherChannel 4
no switchport
no ip address
load-interval 30
tx-queue 3
priority high
channel-group 4 mode on
!
interface GigabitEthernet3/6
description Unidirectional Link of EtherChannel 4
no switchport
no ip address
load-interval 30
tx-queue 3
priority high
unidirectional send-only
channel-group 4 mode on
!
interface GigabitEthernet4/1
description Unidirectional Link of EtherChannel 4
no switchport
no ip address
load-interval 30
tx-queue 3
priority high
unidirectional send-only
channel-group 4 mode on
!
interface GigabitEthernet4/2
description Unidirectional Link of EtherChannel 4
no switchport
no ip address
load-interval 30
tx-queue 3
priority high
unidirectional send-only
channel-group 4 mode on
!
<---output omitted--->
!
interface GigabitEthernet7/1
description VODserver1 GigE0
switchport access vlan 50
 switchport mode access
load-interval 30
 no cdp enable
!
interface GigabitEthernet7/2
!
interface GigabitEthernet7/3
!
interface GigabitEthernet7/4
!
interface GigabitEthernet7/5
description VODserver1 GigE1
switchport access vlan 50
 switchport mode access
load-interval 30
speed 1000
 no cdp enable
!
interface GigabitEthernet7/6
!
interface GigabitEthernet7/7
!
interface GigabitEthernet7/8
!
interface GigabitEthernet7/9
description VODserver2 GigE0
switchport access vlan 50
 switchport mode access
load-interval 30
speed 1000
 no cdp enable
!
interface GigabitEthernet7/10
!
interface GigabitEthernet7/11
!
interface GigabitEthernet7/12
!
interface GigabitEthernet7/13
description VODserver2 GigE1
switchport access vlan 50
 switchport mode access
load-interval 30
speed 1000
 no cdp enable
!
interface GigabitEthernet7/14
!
interface GigabitEthernet7/15
!
interface GigabitEthernet7/16
!
interface GigabitEthernet7/17
description VODserver3 GigE0
switchport access vlan 50
 switchport mode access
load-interval 30
speed 1000
 no cdp enable
!
interface GigabitEthernet7/18
!
<---output omitted--->
!
interface GigabitEthernet7/23
!
interface GigabitEthernet7/24
!
interface Vlan1
no ip address
!
interface Vlan50
description VoD Servers
ip address 192.168.50.2 255.255.255.0
no ip redirects
no ip unreachables
load-interval 30
service-policy input setDSCP
standby 50 ip 192.168.50.1
!
router ospf 100
log-adjacency-changes
passive-interface Vlan50
network 1.1.1.0 0.0.0.255 area 0
network 192.168.0.0 0.0.0.255 area 0
!
ip classless
no ip http server
!
!
ip access-list extended acl_video
remark Identify video traffic (UDP ports 257-33023).
permit udp any any range 257 33032
!
!
line con 0
exec-timeout 0 0
stopbits 1
line vty 0 4
password cisco123
login
!
end

Multiple EtherChannels: Dhub Switch to Headend Switch

This switch-in-Dhub example illustrates a configuration on a Cisco Catalyst 4500 series switch in the Dhub connected to a headend switch through two EtherChannels (Port-channels). Refer to Figure 3-2; this configuration is on Dhub D. For the corresponding configuration, see Multiple EtherChannels: Headend Switch to Dhub Switch.

Current configuration : 6812 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service compress-config
!
hostname DHub_D
!
no logging console
!
ip subnet-zero
no ip domain-lookup
!
spanning-tree extend system-id
!
redundancy
mode rpr
main-cpu
auto-sync standard
!
process-max-time 20
!
interface Loopback3
description Endpoint of Tunnel3
ip address 2.2.2.14 255.255.255.255
!
interface Port-channel3
description Unidirectional EtherChannel from Headend
ip address 192.168.169.14 255.255.255.252
ip ospf cost 666
load-interval 30
!
interface Port-channel4
description Asymmetric EtherChannel from Headend
ip address 192.168.169.18 255.255.255.252
load-interval 30
!
interface Tunnel3
description Return Path for Unidirectional EtherChannel 3
no ip address
tunnel source 2.2.2.14
tunnel destination 1.1.1.3
tunnel udlr send-only Port-channel3
tunnel udlr address-resolution
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface GigabitEthernet2/1
!
interface GigabitEthernet2/2
!
interface GigabitEthernet3/1
description Unidirectional EtherChannel from Headend
no switchport
no ip address
load-interval 30
unidirectional receive-only
channel-group 3 mode on
!
interface GigabitEthernet3/2
description Unidirectional EtherChannel from Headend
no switchport
no ip address
load-interval 30
unidirectional receive-only
channel-group 3 mode on
!
interface GigabitEthernet3/3
description Unidirectional EtherChannel from Headend
no switchport
no ip address
load-interval 30
unidirectional receive-only
channel-group 3 mode on
!
interface GigabitEthernet3/4
description Unidirectional EtherChannel from Headend
no switchport
no ip address
load-interval 30
unidirectional receive-only
channel-group 3 mode on
!
interface GigabitEthernet3/5
description Bidirectional Link of Uni+Bidirectional EtherChannel from Headend
no switchport
no ip address
load-interval 30
channel-group 4 mode on
!
interface GigabitEthernet3/6
description Unidirectional Link of Uni+Bidirectional EtherChannel from Headend
no switchport
no ip address
load-interval 30
unidirectional receive-only
channel-group 4 mode on
!
interface GigabitEthernet4/1
description Unidirectional Link of Uni+Bidirectional EtherChannel from Headend
no switchport
no ip address
load-interval 30
unidirectional receive-only
channel-group 4 mode on
!
interface GigabitEthernet4/2
description Unidirectional Link of Uni+Bidirectional EtherChannel from Headend
no switchport
no ip address
load-interval 30
unidirectional receive-only
channel-group 4 mode on
!
interface GigabitEthernet4/3
!
interface GigabitEthernet4/4
!
interface GigabitEthernet4/5
!
interface GigabitEthernet4/6
!
interface GigabitEthernet5/1
description QAM1
switchport access vlan 163
 switchport mode access
load-interval 30
speed nonegotiate
!
interface GigabitEthernet5/2
description QAM2
switchport access vlan 163
 switchport mode access
load-interval 30
speed nonegotiate
!
<---output omitted--->
!
interface GigabitEthernet7/1
!
interface GigabitEthernet7/2
!
interface GigabitEthernet7/3
!
interface GigabitEthernet7/4
!
interface GigabitEthernet7/5
!
interface GigabitEthernet7/6
!
interface GigabitEthernet7/7
!
interface GigabitEthernet7/8
!
interface GigabitEthernet7/9
!
interface GigabitEthernet7/10
!
interface GigabitEthernet7/11
!
interface GigabitEthernet7/12
!
interface GigabitEthernet7/13
!
interface GigabitEthernet7/14
!
interface Vlan1
no ip address
!
interface Vlan163
description QAM VLAN
ip address 192.168.163.1 255.255.255.0  no ip redirects
 no ip unreachables
load-interval 30
!
router ospf 100
log-adjacency-changes
passive-interface Vlan163
network 192.168.0.0 0.0.0.255 area 0
!
ip classless
no ip http server
!
arp 192.168.163.100 0020.a300.92aa ARPA
!
!
line con 0
exec-timeout 360 0
stopbits 1
line vty 0 4
login
!
mac-address-table static 0020.a300.92aa vlan 163 interface GigabitEthernet5/1
!
end

Subtended Control Path

Subtended Control Path: Headend Switch to Two Dhubs

This switch-in-Dhub example illustrates a configuration on a Cisco Catalyst 4500 series switch in the headend connected to two Dhub switches through two EtherChannels (Port-channels) and a tunnel. Refer to Figure 3-3. For the corresponding configurations, see Subtended Control Path: Dhub A to Headend Switch and Subtended Control Path: Dhub B to Headend Switch.

Current configuration : 7852 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service compress-config
!
hostname Headend
!
enable password cisco123
!
qos
ip subnet-zero
no ip domain-lookup
!
!
class-map match-all class_video
match access-group name acl_video
!
!
policy-map setDSCP
description Mark all video traffic with DSCP of EF
class class_video
set ip dscp 46
!
spanning-tree extend system-id
port-channel load-balance dst-port
!
redundancy
mode rpr
main-cpu
auto-sync standard
!
process-max-time 20
!
interface Loopback2
description Endpoint of Tunnel2
ip address 1.1.1.5 255.255.255.255
!
interface Port-channel1
description Asymmetric EtherChannel to DHub_A
ip address 192.168.169.1 255.255.255.252
load-interval 30
!
interface Port-channel2
description Unidirectional EtherChannel to DHub_B
ip address 192.168.169.5 255.255.255.252
load-interval 30
no keepalive
!
interface Tunnel2
no ip address
tunnel source 1.1.1.5
tunnel destination 2.2.2.6
tunnel udlr receive-only Port-channel2
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
!
interface GigabitEthernet2/1
!
interface GigabitEthernet2/2
!
interface GigabitEthernet3/1
description Bidirectional Link of EtherChannel 1
no switchport
no ip address
load-interval 30
tx-queue 3
priority high
channel-group 1 mode on
!
interface GigabitEthernet3/2
description Unidirectional Link of EtherChannel 1
no switchport
no ip address
load-interval 30
tx-queue 3
priority high
unidirectional send-only
channel-group 1 mode on
!
interface GigabitEthernet3/3
description Unidirectional Link of EtherChannel 1
no switchport
no ip address
load-interval 30
tx-queue 3
priority high
unidirectional send-only
channel-group 1 mode on
!
interface GigabitEthernet3/4
description Unidirectional Link of EtherChannel 1
no switchport
no ip address
load-interval 30
tx-queue 3
priority high
unidirectional send-only
channel-group 1 mode on
!
interface GigabitEthernet3/5
description Unidirectional Link of EtherChannel 2
no switchport
no ip address
load-interval 30
tx-queue 3
priority high
unidirectional send-only
channel-group 2 mode on
!
interface GigabitEthernet3/6
description Unidirectional Link of EtherChannel 2
no switchport
no ip address
load-interval 30
tx-queue 3
priority high
unidirectional send-only
channel-group 2 mode on
!
interface GigabitEthernet4/1
!
<---output omitted--->
!
interface GigabitEthernet6/4
!
interface GigabitEthernet6/5
!
interface GigabitEthernet6/6
!
interface GigabitEthernet7/1
description VODserver1 GigE0
switchport access vlan 50
 switchport mode access
load-interval 30
 no cdp enable
!
interface GigabitEthernet7/2
!
interface GigabitEthernet7/3
!
interface GigabitEthernet7/4
!
interface GigabitEthernet7/5
description VODserver1 GigE1
switchport access vlan 50
 switchport mode access
load-interval 30
speed 1000
 no cdp enable
!
interface GigabitEthernet7/6
!
interface GigabitEthernet7/7
!
interface GigabitEthernet7/8
!
interface GigabitEthernet7/9
description VODserver22 GigE0
switchport access vlan 50
 switchport mode access
load-interval 30
speed 1000
 no cdp enable
!
interface GigabitEthernet7/10
!
interface GigabitEthernet7/11
!
interface GigabitEthernet7/12
!
interface GigabitEthernet7/13
description VODserver2 GigE1
switchport access vlan 50
 switchport mode access
load-interval 30
speed 1000
 no cdp enable
!
interface GigabitEthernet7/14
!
interface GigabitEthernet7/15
!
interface GigabitEthernet7/16
!
interface GigabitEthernet7/17
description VODserver3
switchport access vlan 50
 switchport mode access
load-interval 30
speed 1000
!
<---output omitted--->
!
interface GigabitEthernet7/23
!
interface GigabitEthernet7/24
!
interface Vlan1
no ip address
!
interface Vlan50
description VoD Servers
ip address 192.168.50.2 255.255.255.0
no ip redirects
no ip unreachables
service-policy input setDSCP
standby 50 ip 192.168.50.1
!
router ospf 100
log-adjacency-changes
passive-interface Vlan50
network 1.1.1.0 0.0.255.255 area 0
network 192.168.0.0 0.0.255.255 area 0
distribute-list 1 in Port-channel1
distribute-list 2 in Port-channel2
!
ip classless
no ip http server
!
ip access-list extended acl_video
remark Identify video traffic (UDP ports 257-33023).
permit udp any any range 257 33032
!
access-list 1 remark Only Allow Incoming VLAN160 OSPF Advertisements
access-list 1 permit 192.168.160.0 0.0.0.255
access-list 2 Only Allow Incoming VLAN161 OSPF Advertisements
access-list 2 permit 192.168.161.0 0.0.0.255
!
!
line con 0
exec-timeout 0 0
stopbits 1
line vty 0 4
password cisco123
login
!
end

Subtended Control Path: Dhub A to Headend Switch

This switch-in-Dhub example illustrates a configuration on a Cisco Catalyst 4500 series switch in the Dhub connected to a headend switch through a single EtherChannel (Port-channel). Refer to Figure 3-3. Dhub A also has a Layer 3 connection to Dhub B. For the corresponding configuration, see Subtended Control Path: Headend Switch to Two Dhubs, and Subtended Control Path: Dhub B to Headend Switch.

Current configuration : 6002 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service compress-config
!
hostname Dhub_A
!
ip subnet-zero
no ip domain-lookup
!
spanning-tree extend system-id
!
redundancy
mode rpr
main-cpu
auto-sync standard
!
process-max-time 20
!
interface Port-channel1
description Asymmetric EtherChannel from Headend
ip address 192.168.169.2 255.255.255.252
load-interval 30
!
interface GigabitEthernet1/1
description Bidirectional Link for Tunnel
no switchport
ip address 192.168.169.9 255.255.255.252
!
interface GigabitEthernet1/2
!
interface GigabitEthernet2/1
!
interface GigabitEthernet2/2
!
interface GigabitEthernet3/1
description Bidirectional Link of EtherChannel
no switchport
no ip address
load-interval 30
channel-group 1 mode on
!
interface GigabitEthernet3/2
description Unidirectional Link of EtherChannel
no switchport
no ip address
load-interval 30
unidirectional receive-only
channel-group 1 mode on
!
interface GigabitEthernet3/3
description Unidirectional Link of EtherChannel
no switchport
no ip address
load-interval 30
unidirectional receive-only
channel-group 1 mode on
!
interface GigabitEthernet3/4
description Unidirectional Link of EtherChannel
no switchport
no ip address
load-interval 30
unidirectional receive-only
channel-group 1 mode on
!
interface GigabitEthernet3/5
!
interface GigabitEthernet3/6
!
interface GigabitEthernet4/1
description QAM1
switchport access vlan 160
switchport mode access
load-interval 30
speed nonegotiate
!
<---output omitted--->
!
interface GigabitEthernet5/3
!
interface GigabitEthernet5/4
!
interface GigabitEthernet5/5
!
interface GigabitEthernet5/6
!
interface GigabitEthernet6/1
!
interface GigabitEthernet6/2
!
<---output omitted--->
!
interface GigabitEthernet7/1
!
interface GigabitEthernet7/2
!
<---output omitted--->
!
interface GigabitEthernet7/23
!
interface GigabitEthernet7/24
!
interface Vlan1
no ip address
!
interface Vlan160
description QAM Devices
ip address 192.168.160.1 255.255.255.0
 no ip redirects
no ip unreachables
!
router ospf 100
log-adjacency-changes
passive-interface Vlan160
network 192.168.0.0 0.0.255.255 area 0
!
ip classless
no ip http server
!
!
arp 192.168.160.100 0020.a300.92aa ARPA
!
!
line con 0
exec-timeout 0 0
stopbits 1
line vty 0 4
password cisco123
login
!
mac-address-table static 0020.a300.92aa vlan 160 interface GigabitEthernet4/1
end

Subtended Control Path: Dhub B to Headend Switch

This switch-in-Dhub example illustrates a configuration on a Cisco Catalyst 4500 series switch in the Dhub connected to a headend switch through a single EtherChannel (Port-channel) and a tunnel. Refer to Figure 3-3. Dhub B also has a Layer 3 connection to Dhub A. For the corresponding configurations, see Subtended Control Path: Headend Switch to Two Dhubs, and Subtended Control Path: Dhub A to Headend Switch.

Current configuration : 3281 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service compress-config
!
hostname Dhub_B
!
!
ip subnet-zero
no ip domain-lookup
!
spanning-tree extend system-id
!
process-max-time 20
!
interface Loopback2
description Endpoint of Tunnel2
ip address 2.2.2.6 255.255.255.255

!
interface Port-channel2
description Unidirectional EtherChannel from Headend
ip address 192.168.169.6 255.255.255.252
ip ospf cost 666
load-interval 30
no keepalive
!
interface Tunnel2
no ip address
tunnel source 2.2.2.6
tunnel destination 1.1.1.5
tunnel udlr send-only Port-channel2
tunnel udlr address-resolution
!
interface GigabitEthernet1/1
description Bidirectional Link for Tunnel
no switchport
ip address 192.168.169.10 255.255.255.252
load-interval 30
!
interface GigabitEthernet1/2
!
interface GigabitEthernet2/1
description Unidirectional Link of EtherChannel
no switchport
no ip address
load-interval 30
unidirectional receive-only
channel-group 2 mode on
!
interface GigabitEthernet2/2
description Unidirectional Link of EtherChannel
no switchport
no ip address
load-interval 30
unidirectional receive-only
channel-group 2 mode on
!
interface GigabitEthernet2/3
!
interface GigabitEthernet2/4
!
interface GigabitEthernet2/5
!
interface GigabitEthernet2/6
!
interface GigabitEthernet3/1
description QAM1
switchport access vlan 161
 switchport mode access
load-interval 30
speed nonegotiate
!
interface GigabitEthernet3/2
description QAM2
switchport access vlan 161
 switchport mode access
load-interval 30
!
interface GigabitEthernet3/3
description QAM3
switchport access vlan 161
 switchport mode access
load-interval 30
!
interface GigabitEthernet3/4
description QAM4
switchport access vlan 161
 switchport mode access
load-interval 30
!
interface GigabitEthernet3/5
description QAM5
switchport access vlan 161
 switchport mode access
load-interval 30
!
interface GigabitEthernet3/6
!
interface Vlan1
no ip address
!
interface Vlan161
description QAM Devices
ip address 192.168.161.1 255.255.255.0
 no ip redirects
no ip unreachables
!
router ospf 100
log-adjacency-changes
passive-interface Vlan161
network 192.168.0.0 0.0.255.255 area 0
!
ip classless
no ip http server
!
!
arp 192.168.161.100 0020.a300.92aa ARPA
!
!
line con 0
exec-timeout 0 0
stopbits 1
line vty 0 4
login
!
mac-address-table static 0020.a300.92aa vlan 161 interface GigabitEthernet3/1
!
end


hometocprevnextglossaryfeedbacksearchhelp

Posted: Mon Mar 13 11:07:50 PST 2006
All contents are Copyright © 1992--2006 Cisco Systems, Inc. All rights reserved.
Important Notices and Privacy Statement.