cc/td/doc/solution/vobbsols/vob1
hometocprevnextglossaryfeedbacksearchhelp
PDF

Table Of Contents

Sample DER and AR Switch Configurations for the 10-GE Symmetric Topology

Configuration for DER

Configuration for AR1

Configuration for AR2

Configuration for AR3


Sample DER and AR Switch Configurations for the 10-GE Symmetric Topology


This appendix presents sample distribution edge router (DER) and aggregation router (AR) switch configurations for the symmetric 10-GE topology described in Configuration 1: 10-GE Layer 3 Symmetric Ring. The following configurations are presented:

Configuration for DER

Configuration for AR1

Configuration for AR2

Configuration for AR3


Note Refer to Configuring the 10-GE Symmetric Topology.


Configuration for DER

upgrade fpd auto
version 12.2
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
no service password-encryption
service counters max age 10
!
hostname DER
!
boot system disk1:s72033-adventerprisek9_wan-mz.122-18.SXE1.bin
logging snmp-authfail
enable password cisco123
!
no aaa new-model
clock timezone PST -8
clock summer-time PDT recurring
ip subnet-zero
!
!
!
ip cef load-sharing algorithm original
ip multicast-routing
ip igmp ssm-map enable
ip domain multicast conronado.net
no ip domain-lookup
ip domain-name coronado.net
ip name-server 192.168.10.101
ip name-server 192.168.11.101
ipv6 mfib hardware-switching replication-mode ingress
vtp mode transparent
mls ip cef load-sharing full
mls ip multicast flow-stat-timer 9
no mls flow ip
no mls flow ipv6
mls qos map dscp-cos 36 to 2
mls qos map dscp-cos 38 to 1
mls qos
no mls acl tcam share-global
mls cef error action freeze
no scripting tcl init
no scripting tcl encdir
!
!
!
!
!
!
!
!
!
!
redundancy
mode sso
main-cpu
auto-sync startup-config
auto-sync running-config
auto-sync standard
!
spanning-tree mode rapid-pvst
spanning-tree portfast bpduguard default
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
no spanning-tree vlan 800,824,900,924
spanning-tree vlan 90 priority 24576
diagnostic cns publish cisco.cns.device.diag_results
diagnostic cns subscribe cisco.cns.device.diag_commands
!
vlan internal allocation policy ascending
vlan access-log ratelimit 2000
!
vlan 10
name VLAN_10_Management
!
vlan 11
name VLAN_11_Management
!
vlan 60
name VLAN_60_Unicast_Video
!
vlan 70
name VLAN_70_Multicast_Video
!
vlan 80
name VLAN_80_VoIP
!
vlan 90
name VLAN_90_HSD
!
vlan 800
name VLAN_800_VoIP_to/from_AR1
!
vlan 824
name VLAN_824_VoIP_to/from_AR3
!
vlan 900
name VLAN_900_Video_to/from_AR1
!
vlan 924
name VLAN_924_Video_to/from_AR3
!
class-map match-all class_VoIP
match access-group name acl_VoIP
class-map match-all class_video_VoD_high
match access-group name acl_video_VoD_high
class-map match-all class_video_VoD_low
match access-group name acl_video_VoD_low
class-map match-all class_video_broadcast
match access-group name acl_video_broadcast
class-map match-all class_VoD_signaling
match access-group name acl_VoD_signaling
class-map match-all class_HSD
match access-group name acl_HSD
!
!
policy-map setDSCP
description Mark DSCP values for ingress traffic
class class_VoIP
set dscp ef
class class_HSD
set dscp default
class class_VoD_signaling
set dscp cs3
class class_video_broadcast
set dscp af41
class class_video_VoD_high
set dscp af42
class class_video_VoD_low
set dscp af43
!
!
!
interface GigabitEthernet1/1
description High speed data ingress/egress port
switchport
switchport access vlan 90
switchport mode access
no ip address
load-interval 30
no cdp enable
spanning-tree portfast
spanning-tree bpduguard enable
service-policy input setDSCP
!
interface GigabitEthernet1/2
no ip address
shutdown
!
interface GigabitEthernet1/3
no ip address
shutdown
!
! <------ interfaces GigabitEthernet1/4 - 14 omitted ------->
!
interface GigabitEthernet1/15
no ip address
shutdown
!
interface GigabitEthernet1/16
no ip address
shutdown
!
interface GigabitEthernet2/1
description VoIP traffic ingress/egress
switchport
switchport access vlan 80
switchport mode access
no ip address
load-interval 30
no cdp enable
spanning-tree portfast
spanning-tree bpduguard enable
service-policy input setDSCP
!
interface GigabitEthernet2/2
no ip address
shutdown
!
interface GigabitEthernet2/3
no ip address
shutdown
!
! <------ interfaces GigabitEthernet2/4 - 6 omitted ------->
!
interface GigabitEthernet2/7
no ip address
shutdown
!
interface GigabitEthernet2/8
no ip address
shutdown
!
interface GigabitEthernet2/9
description Broadcast video source (multicast 232.1.1.1 - 232.1.1.10)
switchport
switchport access vlan 70
switchport mode access
no ip address
load-interval 30
no cdp enable
spanning-tree portfast
spanning-tree bpduguard enable
service-policy input setDSCP
!
interface GigabitEthernet2/10
no ip address
shutdown
!
interface GigabitEthernet2/11
no ip address
shutdown
!
! <------ interfaces GigabitEthernet2/12 - 14 omitted ------->
!
interface GigabitEthernet2/15
no ip address
shutdown
!
interface GigabitEthernet2/16
no ip address
shutdown
!
interface GigabitEthernet2/17
description Management port from Kasenna LR Server (Eth0)
switchport
switchport access vlan 10
switchport mode access
no ip address
load-interval 30
no cdp enable
spanning-tree portfast
spanning-tree bpduguard enable
service-policy input setDSCP
!
interface GigabitEthernet2/18
description Kasenna VoD Pump Management
switchport
switchport access vlan 10
switchport mode access
no ip address
load-interval 30
no cdp enable
spanning-tree portfast
spanning-tree bpduguard enable
service-policy input setDSCP
!
interface GigabitEthernet2/19
description Unicast video from Kasenna VoD Pump (HPN0)
switchport
switchport access vlan 60
switchport mode access
no ip address
load-interval 30
no cdp enable
spanning-tree portfast
spanning-tree bpduguard enable
service-policy input setDSCP
!
interface GigabitEthernet2/20
description Unicast video from Kasenna VoD Pump (HPN1)
switchport
switchport access vlan 60
switchport mode access
no ip address
load-interval 30
no cdp enable
spanning-tree portfast
spanning-tree bpduguard enable
service-policy input setDSCP
!
interface GigabitEthernet2/21
no ip address
shutdown
!
interface GigabitEthernet2/22
no ip address
shutdown
!
! <------ interfaces GigabitEthernet2/23 - 45 omitted ------->
!
interface GigabitEthernet2/46
no ip address
shutdown
!
interface GigabitEthernet2/47
no ip address
shutdown
!
interface GigabitEthernet2/48
description Backup DNS server
switchport
switchport access vlan 11
switchport mode access
no ip address
load-interval 30
no cdp enable
spanning-tree portfast
spanning-tree bpduguard enable
service-policy input setDSCP
!
interface GigabitEthernet5/1
no ip address
shutdown
!
interface GigabitEthernet5/2
description Primary DNS/DHCP/NTP/TFTP/Syslog servers
switchport
switchport access vlan 10
switchport mode access
no ip address
load-interval 30
media-type rj45
no cdp enable
spanning-tree portfast
spanning-tree bpduguard enable
service-policy input setDSCP
!
interface GigabitEthernet6/1
no ip address
shutdown
!
interface GigabitEthernet6/2
no ip address
shutdown
!
interface TenGigabitEthernet7/1
description Transport to/from AR1 (TenGig1/1)
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 90,800,900
switchport mode trunk
dampening
no ip address
load-interval 30
carrier-delay msec 0
wrr-queue bandwidth 64 255 0 0 0 0 0
wrr-queue queue-limit 40 50 0 0 0 0 0
wrr-queue threshold 1 100 100 100 100 100 100 100 100
wrr-queue threshold 2 45 85 100 100 100 100 100 100
wrr-queue random-detect min-threshold 1 75 100 100 100 100 100 100 100
wrr-queue random-detect max-threshold 1 100 100 100 100 100 100 100 100
no wrr-queue random-detect 2
wrr-queue cos-map 2 1 1
wrr-queue cos-map 2 2 2
wrr-queue cos-map 2 3 3 4 6 7
mls qos trust dscp
!
interface TenGigabitEthernet7/2
no ip address
shutdown
!
interface TenGigabitEthernet7/3
description Transport to/from AR3 (TenGig1/50)
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 90,824,924
switchport mode trunk
dampening
no ip address
load-interval 30
carrier-delay msec 0
wrr-queue bandwidth 64 255 0 0 0 0 0
wrr-queue queue-limit 40 50 0 0 0 0 0
wrr-queue threshold 1 100 100 100 100 100 100 100 100
wrr-queue threshold 2 45 85 100 100 100 100 100 100
wrr-queue random-detect min-threshold 1 75 100 100 100 100 100 100 100
wrr-queue random-detect max-threshold 1 100 100 100 100 100 100 100 100
no wrr-queue random-detect 2
wrr-queue cos-map 2 1 1
wrr-queue cos-map 2 2 2
wrr-queue cos-map 2 3 3 4 6 7
mls qos trust dscp
!
interface TenGigabitEthernet7/4
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
description Management VLAN (VoD signaling, Primary DNS, DHCP, etc)
ip address 192.168.10.1 255.255.255.0
no ip redirects
no ip unreachables
load-interval 30
!
interface Vlan11
description Management VLAN (Backup DNS)
ip address 192.168.11.1 255.255.255.0
no ip redirects
no ip unreachables
load-interval 30
!
interface Vlan60
description VoD server VLAN (Unicast Video)
ip address 192.168.60.1 255.255.255.0
no ip redirects
no ip unreachables
load-interval 30
!
interface Vlan70
description Broadcast video source VLAN (Multicast Video)
ip address 192.168.70.1 255.255.255.0
no ip redirects
no ip unreachables
ip pim sparse-mode
load-interval 30
!
interface Vlan80
description VoIP gateway VLAN
ip address 192.168.80.1 255.255.255.0
no ip redirects
no ip unreachables
load-interval 30
!
interface Vlan800
description VoIP transport to/from AR1
ip address 192.168.252.1 255.255.255.252
ip ospf network point-to-point
ip ospf hello-interval 1
load-interval 30
!
interface Vlan824
description VoIP transport to/from AR3
ip address 192.168.252.25 255.255.255.252
ip ospf network point-to-point
ip ospf hello-interval 1
load-interval 30
!
interface Vlan900
description Video transport VLAN to/from AR1
ip address 192.168.254.1 255.255.255.252
ip pim sparse-mode
ip ospf network point-to-point
ip ospf hello-interval 1
load-interval 30
!
interface Vlan924
description Video transport VLAN to/from AR3
ip address 192.168.254.25 255.255.255.252
ip pim sparse-mode
ip ospf network point-to-point
ip ospf hello-interval 1
load-interval 30
!
router ospf 100
router-id 1.1.1.1
log-adjacency-changes
timers throttle spf 10 100 1000
timers throttle lsa all 1 10 1000
timers lsa arrival 100
passive-interface Vlan10
passive-interface Vlan11
passive-interface Vlan60
passive-interface Vlan70
network 192.168.10.0 0.0.1.255 area 0
network 192.168.60.0 0.0.0.255 area 0
network 192.168.70.0 0.0.0.255 area 0
network 192.168.254.1 0.0.0.0 area 0
network 192.168.254.25 0.0.0.0 area 0
!
router ospf 101
router-id 1.1.1.2
log-adjacency-changes
timers throttle spf 10 100 1000
timers throttle lsa all 1 10 1000
timers lsa arrival 100
passive-interface Vlan80
network 192.168.80.0 0.0.0.255 area 0
network 192.168.252.1 0.0.0.0 area 0
network 192.168.252.25 0.0.0.0 area 0
!
ip classless
!
no ip http server
ip pim ssm default
!
ip access-list extended acl_HSD
remark Identify HSD traffic
permit ip 192.168.90.0 0.0.0.255 any
ip access-list extended acl_VoD_signaling
remark Identify VoD signaling traffic
permit ip host 192.168.10.102 any
permit ip host 192.168.10.103 any
ip access-list extended acl_VoIP
remark Identify VoIP traffic
permit ip 192.168.80.0 0.0.0.255 any
ip access-list extended acl_video_VoD_high
remark Identify high priority VoD traffic
permit udp 192.168.60.0 0.0.0.255 192.168.110.0 0.0.0.255 range 5000 9000
permit udp 192.168.60.0 0.0.0.255 192.168.120.0 0.0.0.255 range 5000 9000
permit udp 192.168.60.0 0.0.0.255 192.168.130.0 0.0.0.255 range 5000 9000
ip access-list extended acl_video_VoD_low
remark Identify low priority VoD traffic
permit udp 192.168.60.0 0.0.0.255 192.168.110.0 0.0.0.255 range 1000 4999
permit udp 192.168.60.0 0.0.0.255 192.168.120.0 0.0.0.255 range 1000 4999
permit udp 192.168.60.0 0.0.0.255 192.168.130.0 0.0.0.255 range 1000 4999
ip access-list extended acl_video_broadcast
remark Identify broadcast video traffic (multicast)
permit ip 192.168.70.0 0.0.0.255 232.0.0.0 0.255.255.255
!
logging event link-status default
logging trap debugging
logging source-interface Vlan10
logging 192.168.10.101
!
!
!
control-plane
!
!
!
dial-peer cor custom
!
!
!
!
line con 0
exec-timeout 0 0
password cisco123
logging synchronous
login
line vty 0 4
exec-timeout 0 0
password cisco123
logging synchronous
login
!
!
ntp clock-period 17179953
ntp update-calendar
ntp server 192.168.10.102 prefer
no cns aaa enable
end

Configuration for AR1

upgrade fpd auto
version 12.2
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
no service password-encryption
service counters max age 10
!
hostname AR1
!
boot system disk0:s72033-adventerprisek9_wan-mz.122-18.SXE1.bin
logging snmp-authfail
no logging console
enable password cisco123
!
no aaa new-model
clock timezone PST -8
clock summer-time PDT recurring
ip subnet-zero
!
!
!
ip cef load-sharing algorithm original
ip multicast-routing
ip igmp ssm-map enable
ip domain multicast coronado.net
no ip domain-lookup
ip name-server 192.168.10.101
ip name-server 192.168.11.101
ipv6 mfib hardware-switching replication-mode ingress
vtp mode transparent
mls ip cef load-sharing full
mls ip multicast flow-stat-timer 9
no mls flow ip
no mls flow ipv6
mls qos map dscp-cos 36 to 2
mls qos map dscp-cos 38 to 1
mls qos
no mls acl tcam share-global
mls cef error action freeze
no scripting tcl init
no scripting tcl encdir
!
!
!
!
!
!
!
!
!
!
redundancy
mode sso
main-cpu
auto-sync running-config
auto-sync standard
!
spanning-tree mode rapid-pvst
spanning-tree portfast bpduguard default
no spanning-tree optimize bpdu transmission
no spanning-tree vlan 800,808,900,908
diagnostic cns publish cisco.cns.device.diag_results
diagnostic cns subscribe cisco.cns.device.diag_commands
!
vlan internal allocation policy ascending
vlan access-log ratelimit 2000
!
vlan 90
name VLAN_90_HSD
!
vlan 110
name VLAN_110_Video
!
vlan 111
name VLAN_111_VoIP
!
vlan 800
name VLAN_800_VoIP_to/from_DER
!
vlan 808
name VLAN_808_VoIP_to/from_AR2
!
vlan 900
name VLAN_900_Video_to/from_DER
!
vlan 908
name VLAN_908_Video_to/from_AR2
!
class-map match-all class_VoIP
match access-group name acl_VoIP
class-map match-all class_VoD_signaling
match access-group name acl_VoD_signaling
class-map match-all class_HSD
match access-group name acl_HSD
!
!
policy-map setDSCP
description Mark DSCP values for ingress traffic
class class_VoIP
set dscp ef
class class_HSD
set dscp default
class class_VoD_signaling
set dscp cs3
!
!
!
interface TenGigabitEthernet1/1
description Transport to/from DER (TenGig7/1)
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 90,800,900
switchport mode trunk
dampening
no ip address
load-interval 30
carrier-delay msec 0
wrr-queue bandwidth 64 255 0 0 0 0 0
wrr-queue queue-limit 40 50 0 0 0 0 0
wrr-queue threshold 1 100 100 100 100 100 100 100 100
wrr-queue threshold 2 45 85 100 100 100 100 100 100
wrr-queue random-detect min-threshold 1 75 100 100 100 100 100 100 100
wrr-queue random-detect max-threshold 1 100 100 100 100 100 100 100 100
no wrr-queue random-detect 2
wrr-queue cos-map 2 1 1
wrr-queue cos-map 2 2 2
wrr-queue cos-map 2 3 3 4 6 7
mls qos trust dscp
!
interface TenGigabitEthernet1/2
no ip address
shutdown
!
interface TenGigabitEthernet1/3
description Transport to/from AR2 (TenGig1/1)
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 90,808,908
switchport mode trunk
dampening
no ip address
load-interval 30
carrier-delay msec 0
wrr-queue bandwidth 64 255 0 0 0 0 0
wrr-queue queue-limit 40 50 0 0 0 0 0
wrr-queue threshold 1 100 100 100 100 100 100 100 100
wrr-queue threshold 2 45 85 100 100 100 100 100 100
wrr-queue random-detect min-threshold 1 75 100 100 100 100 100 100 100
wrr-queue random-detect max-threshold 1 100 100 100 100 100 100 100 100
no wrr-queue random-detect 2
wrr-queue cos-map 2 1 1
wrr-queue cos-map 2 2 2
wrr-queue cos-map 2 3 3 4 6 7
mls qos trust dscp
!
interface TenGigabitEthernet1/4
no ip address
shutdown
!
interface GigabitEthernet2/1
description GigE trunk to/from DSLAM uplink GigE
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 90,110,111
switchport mode trunk
switchport block unicast
no ip address
load-interval 30
wrr-queue bandwidth 64 255
wrr-queue queue-limit 40 50
 wrr-queue random-detect min-threshold 1 75 100
 wrr-queue random-detect min-threshold 2 50 100
wrr-queue random-detect max-threshold 1 100 100
wrr-queue random-detect max-threshold 2 50 100
wrr-queue cos-map 1 1 0
wrr-queue cos-map 2 1 1
wrr-queue cos-map 2 2 2 3 4 6 7
no cdp enable
spanning-tree portfast trunk
service-policy input setDSCP
!
interface GigabitEthernet2/2
no ip address
shutdown
!
interface GigabitEthernet2/3
no ip address
shutdown
!
! <------ interfaces GigabitEthernet2/4 - 14 omitted ------->
!
interface GigabitEthernet2/15
no ip address
shutdown
!
interface GigabitEthernet2/16
no ip address
shutdown
!
interface GigabitEthernet5/1
no ip address
shutdown
!
interface GigabitEthernet5/2
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
interface Vlan110
description Video edge VLAN
ip address 192.168.110.1 255.255.255.0
no ip redirects
no ip unreachables
ip pim sparse-mode
ip igmp static-group 232.1.1.1 source ssm-map
ip igmp static-group 232.1.1.2 source ssm-map
ip igmp static-group 232.1.1.3 source ssm-map
ip igmp static-group 232.1.1.4 source ssm-map
ip igmp static-group 232.1.1.5 source ssm-map
ip igmp static-group 232.1.1.6 source ssm-map
ip igmp static-group 232.1.1.7 source ssm-map
ip igmp static-group 232.1.1.8 source ssm-map
ip igmp static-group 232.1.1.9 source ssm-map
ip igmp static-group 232.1.1.10 source ssm-map
load-interval 30
arp timeout 250
!
interface Vlan111
description VoIP edge VLAN
ip address 192.168.111.1 255.255.255.0
no ip redirects
no ip unreachables
load-interval 30
!
interface Vlan800
description VoIP transport VLAN to/from DER
ip address 192.168.252.2 255.255.255.252
ip ospf network point-to-point
ip ospf hello-interval 1
load-interval 30
!
interface Vlan808
description VoIP transport VLAN to/from AR2
ip address 192.168.252.9 255.255.255.252
ip ospf network point-to-point
ip ospf hello-interval 1
load-interval 30
!
interface Vlan900
description Video transport VLAN to/from DER
ip address 192.168.254.2 255.255.255.252
ip pim sparse-mode
ip ospf network point-to-point
ip ospf hello-interval 1
load-interval 30
!
interface Vlan908
description Video transport VLAN to/from AR2
ip address 192.168.254.9 255.255.255.252
ip pim sparse-mode
ip ospf network point-to-point
ip ospf hello-interval 1
load-interval 30
!
router ospf 100
router-id 2.2.2.1
log-adjacency-changes
timers throttle spf 10 100 1000
timers throttle lsa all 1 10 1000
timers lsa arrival 100
passive-interface Vlan110
network 192.168.110.0 0.0.0.255 area 0
network 192.168.254.2 0.0.0.0 area 0
network 192.168.254.9 0.0.0.0 area 0
!
router ospf 101
router-id 2.2.2.2
log-adjacency-changes
timers throttle spf 10 100 1000
timers throttle lsa all 1 10 1000
timers lsa arrival 100
passive-interface Vlan111
network 192.168.111.0 0.0.0.255 area 0
network 192.168.252.2 0.0.0.0 area 0
network 192.168.252.9 0.0.0.0 area 0
!
ip classless
!
no ip http server
ip pim ssm default
!
ip access-list extended acl_HSD
remark Identify HSD traffic
permit ip 192.168.90.0 0.0.0.255 any
ip access-list extended acl_VoD_signaling
remark Identify VoD signaling traffic
permit ip 192.168.110.0 0.0.0.255 192.168.10.102
permit ip 192.168.110.0 0.0.0.255 192.168.10.103
ip access-list extended acl_VoIP
remark Identify VoIP traffic
permit ip 192.168.111.0 0.0.0.255 any
!
logging event link-status default
logging trap debugging
logging source-interface Vlan110
logging 192.168.10.101
!
!
!
control-plane
!
!
!
dial-peer cor custom
!
!
!
line con 0
exec-timeout 0 0
password cisco123
logging synchronous
login
line vty 0 4
exec-timeout 0 0
password cisco123
logging synchronous
login
!
!
ntp clock-period 17180008
ntp update-calendar
ntp server 192.168.10.102 prefer
no cns aaa enable
end

Configuration for AR2

version 12.2
no service pad
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
no service password-encryption
service compress-config
!
hostname AR2
!
boot-start-marker
boot system bootflash:cat4000-i9s-mz.122-25.EWA.bin
boot-end-marker
!
!
redundancy
mode sso
enable password cisco123
!
no aaa new-model
clock timezone PST -8
clock summer-time PDT recurring
hw-module uplink select tengigabitethernet
qos map dscp 34 36 38 48 49 50 51 52 to tx-queue 2
qos map dscp 53 54 55 56 57 58 59 60 to tx-queue 2
qos map dscp 61 62 63 to tx-queue 2
qos map dscp 38 to cos 1
qos map dscp 36 to cos 2
qos
vtp mode transparent
ip subnet-zero
ip cef load-sharing algorithm include-ports destination
ip domain multicast coronado.net
no ip domain-lookup
ip name-server 192.168.10.101
ip name-server 192.168.11.101
!
ip multicast-routing
ip igmp ssm-map enable
!
no file verify auto
!
spanning-tree mode rapid-pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
no spanning-tree vlan 808,816,908,916
power redundancy-mode redundant
!
!
!
vlan internal allocation policy ascending
!
vlan 90
name VLAN_90_HSD
!
vlan 120
name VLAN_120_Video
!
vlan 121
name VLAN_121_VoIP
!
vlan 808
name VLAN_808_VoIP_to/from_AR1
!
vlan 816
name VLAN_816_VoIP_to/from_AR3
!
vlan 908
name VLAN_908_Video_to/from_AR1
!
vlan 916
name VLAN_916_Video_to/from_AR3
!
class-map match-all class_VoIP
match access-group name acl_VoIP
class-map match-all class_VoD_signaling
match access-group name acl_VoD_signaling
class-map match-all class_HSD
match access-group name acl_HSD
!
!
policy-map setDSCP
description Mark DSCP values for ingress traffic
class class_VoIP
set dscp ef
class class_HSD
set dscp default
class class_VoD_signaling
set dscp cs3
!
!
interface TenGigabitEthernet1/1
description Transport to/from AR1 (TenGig1/3)
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 90,808,908
switchport mode trunk
dampening
load-interval 30
carrier-delay msec 0
qos trust dscp
tx-queue 1
bandwidth percent 19
tx-queue 2
bandwidth percent 80
tx-queue 3
priority high
tx-queue 4
bandwidth percent 1
!
interface TenGigabitEthernet1/2
description Transport to/from AR3 (TenGig1/49)
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 90,816,916
switchport mode trunk
dampening
load-interval 30
carrier-delay msec 0
qos trust dscp
tx-queue 1
bandwidth percent 19
tx-queue 2
bandwidth percent 80
tx-queue 3
priority high
tx-queue 4
bandwidth percent 1
spanning-tree cost 10
!
interface GigabitEthernet1/3
!
interface GigabitEthernet1/4
!
interface GigabitEthernet1/5
!
interface GigabitEthernet1/6
!
interface GigabitEthernet5/1
description GigE trunk to/from DSLAM uplink GigE
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 90,120,121
switchport mode trunk
switchport block unicast
service-policy input setDSCP
load-interval 30
tx-queue 1
bandwidth percent 19
tx-queue 2
bandwidth percent 80
tx-queue 3
priority high
tx-queue 4
bandwidth percent 1
no cdp enable
spanning-tree portfast trunk
!
interface GigabitEthernet5/2
!
interface GigabitEthernet5/3
!
! <------ interfaces GigabitEthernet5/4 - 46 omitted ------->
!
interface GigabitEthernet5/47
!
interface GigabitEthernet5/48
!
interface Vlan1
no ip address
!
interface Vlan120
description Video edge VLAN
ip address 192.168.120.1 255.255.255.0
no ip redirects
no ip unreachables
ip pim sparse-mode
ip igmp static-group 232.1.1.1 source ssm-map
ip igmp static-group 232.1.1.2 source ssm-map
ip igmp static-group 232.1.1.3 source ssm-map
ip igmp static-group 232.1.1.4 source ssm-map
ip igmp static-group 232.1.1.5 source ssm-map
ip igmp static-group 232.1.1.6 source ssm-map
ip igmp static-group 232.1.1.7 source ssm-map
ip igmp static-group 232.1.1.8 source ssm-map
ip igmp static-group 232.1.1.9 source ssm-map
ip igmp static-group 232.1.1.10 source ssm-map
load-interval 30
arp timeout 250
!
interface Vlan121
description VoIP edge VLAN
ip address 192.168.121.1 255.255.255.0
no ip redirects
no ip unreachables
load-interval 30
!
interface Vlan808
description VoIP transport VLAN to/from AR1
ip address 192.168.252.10 255.255.255.252
ip ospf network point-to-point
ip ospf hello-interval 1
load-interval 30
!
interface Vlan816
description VoIP transport VLAN to/from AR3
ip address 192.168.252.17 255.255.255.252
ip ospf network point-to-point
ip ospf hello-interval 1
load-interval 30
!
interface Vlan908
description Video transport VLAN to/from AR1
ip address 192.168.254.10 255.255.255.252
ip pim sparse-mode
ip ospf network point-to-point
ip ospf hello-interval 1
load-interval 30
!
interface Vlan916
description Video transport VLAN to/from AR3
ip address 192.168.254.17 255.255.255.252
ip pim sparse-mode
ip ospf network point-to-point
ip ospf hello-interval 1
load-interval 30
!
router ospf 100
router-id 3.3.3.1
log-adjacency-changes
timers throttle spf 10 100 1000
timers throttle lsa all 1 10 1000
timers lsa arrival 100
passive-interface Vlan120
network 192.168.120.0 0.0.0.255 area 0
network 192.168.254.10 0.0.0.0 area 0
network 192.168.254.17 0.0.0.0 area 0
!
router ospf 101
router-id 3.3.3.2
log-adjacency-changes
timers throttle spf 10 100 1000
timers throttle lsa all 1 10 1000
timers lsa arrival 100
passive-interface Vlan121
network 192.168.121.0 0.0.0.255 area 0
network 192.168.252.10 0.0.0.0 area 0
network 192.168.252.17 0.0.0.0 area 0
!
!
no ip http server
!
ip pim ssm default
!
!
ip access-list extended acl_HSD
remark Identify HSD traffic
permit ip 192.168.90.0 0.0.0.255 any
ip access-list extended acl_VoD_signaling
remark Identify VoD signaling traffic
permit ip 192.168.120.0 0.0.0.255 192.168.10.102
permit ip 192.168.120.0 0.0.0.255 192.168.10.103
ip access-list extended acl_VoIP
remark Identify VoIP traffic
permit ip 192.168.121.0 0.0.0.255 any
!
logging trap debugging
logging source-interface Vlan120
logging 192.168.10.101
!
!
!
line con 0
exec-timeout 0 0
password cisco123
logging synchronous
login
stopbits 1
line vty 0 4
exec-timeout 0 0
password cisco123
logging synchronous
login
!
!
ntp clock-period 17180679
ntp update-calendar
ntp server 192.168.10.102 prefer
!
end

Configuration for AR3

version 12.2
no service pad
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
no service password-encryption
service compress-config
!
hostname AR3
!
boot-start-marker
boot system bootflash:cat4000-i5s-mz.122-25.EWA.bin
boot-end-marker
!
enable password cisco123
!
no aaa new-model
clock timezone PST -8
clock summer-time PDT recurring
qos map dscp 34 36 38 48 49 50 51 52 to tx-queue 2
qos map dscp 53 54 55 56 57 58 59 60 to tx-queue 2
qos map dscp 61 62 63 to tx-queue 2
qos map dscp 38 to cos 1
qos map dscp 36 to cos 2
qos
vtp mode transparent
ip subnet-zero
ip cef load-sharing algorithm original
ip domain multicast coronado.net
no ip domain-lookup
ip name-server 192.168.10.101
ip name-server 192.168.11.101
!
ip multicast-routing
ip igmp ssm-map enable
!
no file verify auto
!
spanning-tree mode rapid-pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
no spanning-tree vlan 816,824,916,924
power redundancy-mode redundant
!
!
!
vlan internal allocation policy ascending
!
vlan 90
name VLAN_90_HSD
!
vlan 130
name VLAN_130_Video
!
vlan 131
name VLAN_131_VoIP
!
vlan 816
name VLAN_816_VoIP_to/from_AR2
!
vlan 824
name VLAN_824_VoIP_to/from_DER
!
vlan 916
name VLAN_916_Video_to/from_AR2
!
vlan 924
name VLAN_924_Video_to/from_DER
!
class-map match-all class_VoIP
match access-group name acl_VoIP
class-map match-all class_VoD_signaling
match access-group name acl_VoD_signaling
class-map match-all class_HSD
match access-group name acl_HSD
!
!
policy-map setDSCP
description Mark DSCP values for ingress traffic
class class_VoIP
set dscp ef
class class_HSD
set dscp default
class class_VoD_signaling
set dscp cs3
!
!
interface GigabitEthernet1/1
description GigE trunk to/from DSLAM uplink GigE
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 90,130,131
switchport mode trunk
switchport block unicast
service-policy input setDSCP
load-interval 30
tx-queue 1
bandwidth percent 19
tx-queue 2
bandwidth percent 80
tx-queue 3
priority high
tx-queue 4
bandwidth percent 1
no cdp enable
spanning-tree portfast trunk
!
interface GigabitEthernet1/2
!
interface GigabitEthernet1/3
!
! <------ interfaces GigabitEthernet1/4 - 46 omitted ------->
!
interface GigabitEthernet1/47
!
interface GigabitEthernet1/48
!
interface TenGigabitEthernet1/49
description Transport to/from AR2 (TenGig1/2)
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 90,816,916
switchport mode trunk
dampening
load-interval 30
carrier-delay msec 0
qos trust dscp
tx-queue 1
bandwidth percent 19
tx-queue 2
bandwidth percent 80
tx-queue 3
priority high
tx-queue 4
bandwidth percent 1
!
interface TenGigabitEthernet1/50
description Transport to/from DER (TenGig7/3)
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 90,824,924
switchport mode trunk
dampening
load-interval 30
carrier-delay msec 0
qos trust dscp
tx-queue 1
bandwidth percent 19
tx-queue 2
bandwidth percent 80
tx-queue 3
priority high
tx-queue 4
bandwidth percent 1
!
interface Vlan1
no ip address
!
interface Vlan130
description Video edge VLAN
ip address 192.168.130.1 255.255.255.0
no ip redirects
no ip unreachables
ip pim sparse-mode
ip igmp static-group 232.1.1.1 source ssm-map
ip igmp static-group 232.1.1.2 source ssm-map
ip igmp static-group 232.1.1.3 source ssm-map
ip igmp static-group 232.1.1.4 source ssm-map
ip igmp static-group 232.1.1.5 source ssm-map
ip igmp static-group 232.1.1.6 source ssm-map
ip igmp static-group 232.1.1.7 source ssm-map
ip igmp static-group 232.1.1.8 source ssm-map
ip igmp static-group 232.1.1.9 source ssm-map
ip igmp static-group 232.1.1.10 source ssm-map
load-interval 30
arp timeout 250
!
interface Vlan131
description VoIP edge VLAN
ip address 192.168.131.1 255.255.255.0
no ip redirects
no ip unreachables
load-interval 30
!
interface Vlan816
description VoIP transport VLAN to/from AR2
ip address 192.168.252.18 255.255.255.252
ip ospf network point-to-point
ip ospf hello-interval 1
load-interval 30
!
interface Vlan824
description VoIP transport VLAN to/from DER
ip address 192.168.252.26 255.255.255.252
ip ospf network point-to-point
ip ospf hello-interval 1
load-interval 30
!
interface Vlan916
description Video transport VLAN to/from AR2
ip address 192.168.254.18 255.255.255.252
ip pim sparse-mode
ip ospf network point-to-point
ip ospf hello-interval 1
load-interval 30
!
interface Vlan924
description Video transport VLAN to/from DER
ip address 192.168.254.26 255.255.255.252
ip pim sparse-mode
ip ospf network point-to-point
ip ospf hello-interval 1
load-interval 30
!
router ospf 100
router-id 4.4.4.1
log-adjacency-changes
timers throttle spf 10 100 1000
timers throttle lsa all 1 10 1000
timers lsa arrival 100
passive-interface Vlan130
network 192.168.130.0 0.0.0.255 area 0
network 192.168.254.18 0.0.0.0 area 0
network 192.168.254.26 0.0.0.0 area 0
!
router ospf 101
router-id 4.4.4.2
log-adjacency-changes
timers throttle spf 10 100 1000
timers throttle lsa all 1 10 1000
timers lsa arrival 100
passive-interface Vlan131
network 192.168.131.0 0.0.0.255 area 0
network 192.168.252.18 0.0.0.0 area 0
network 192.168.252.26 0.0.0.0 area 0
!
no ip http server
!
ip pim ssm default
!
!
ip access-list extended acl_HSD
remark Identify HSD traffic
permit ip 192.168.90.0 0.0.0.255 any
ip access-list extended acl_VoD_signaling
remark Identify VoD signaling traffic
permit ip 192.168.130.0 0.0.0.255 192.168.10.102
permit ip 192.168.130.0 0.0.0.255 192.168.10.103
ip access-list extended acl_VoIP
remark Identify VoIP traffic
permit ip 192.168.131.0 0.0.0.255 any
!
logging trap debugging
logging source-interface Vlan130
logging 192.168.10.101
!
!
!
line con 0
exec-timeout 0 0
password cisco123
logging synchronous
login
stopbits 1
line vty 0 4
exec-timeout 0 0
password cisco123
logging synchronous
login
!
!
ntp clock-period 17180737
ntp update-calendar
ntp server 192.168.10.102 prefer
!
end


hometocprevnextglossaryfeedbacksearchhelp

Posted: Wed Sep 20 08:57:36 PDT 2006
All contents are Copyright © 1992--2006 Cisco Systems, Inc. All rights reserved.
Important Notices and Privacy Statement.