cc/td/doc/product/dsl_prod/ios_dsl/rel122
hometocprevnextglossaryfeedbacksearchhelp
PDF

Table Of Contents

E Through M Commands for Cisco DSLAMs with NI-2

encapsulation

exit-address-family

framing

hardware-address

host

ima active-links-minimum

ima clock-mode

ima differential-delay-maximum

ima frame-length

ima-group

ima test

ima version

import map

ip cef traffic-statistics

ip classless

ip default-gateway

ip dhcp conflict logging

ip dhcp database

ip dhcp excluded-address

ip dhcp ping packets

ip dhcp ping timeout

ip dhcp pool

ip dhcp relay information option

ip helper-address

ip local pool

ip route vrf

ip routing

ip subnet-zero

ip unnumbered

ip vrf

ip vrf forwarding

lbo

lease

linecode

loopback


E Through M Commands for Cisco DSLAMs with NI-2


This chapter documents commands that you use to configure Cisco DSLAMs with NI-2. Commands in this chapter are listed alphabetically. For information on how to configure DSL features, refer to the Configuration Guide for Cisco DSLAMs with NI-2.


Note Commands that are identical to those documented in the Cisco IOS Configuration Fundamentals Command Reference and the ATM and Layer 3 Switch Router Command Reference have been removed from this chapter.


This chapter discusses the following commands:

encapsulation

exit-address-family

framing

hardware-address

host

ima active-links-minimum

ima clock-mode

ima differential-delay-maximum

ima frame-length

ima-group

ima test

ima version

import map

ip cef traffic-statistics

ip classless

ip default-gateway

ip dhcp conflict logging

ip dhcp database

ip dhcp excluded-address

ip dhcp ping packets

ip dhcp ping timeout

ip dhcp pool

ip dhcp relay information option

ip helper-address

ip local pool

ip route vrf

ip routing

ip subnet-zero

ip unnumbered

ip vrf

ip vrf forwarding

lbo

lease

linecode

loopback

encapsulation

To set the encapsulation method that the interface uses , use the encapsulation interface configuration command.

encapsulation encapsulation-type

Syntax Description

encapsulation-type

Encapsulation type. See Table 4-1 for a list of supported encapsulation types.


Defaults

The default depends on the type of interface.

Command Modes

Interface configuration

Command History

Release
Modification

12.2(1b)DA

This command was introduced.


Usage Guidelines

For you to use SLIP or PPP, the router or access server must be configured with an IP routing protocol or with the ip host-routing command. This configuration is done automatically if you are using old-style SLIP address commands. However, you must configure manually if you configure SLIP or PPP with the interface async command.

Table 4-1 Supported Encapsulation Types

Keyword
Encapsulation Type

aal5ciscoppp

Cisco PPP over AAL5 encapsulation.

aa15mux

AAL5+MUX encapsulation.

aal5nlpid

AAL5+NLPID encapsulation.

Note AAL5+NLPID encapsulation is not applicable to configuring the DSLAM.

aa15snap

AAL5+LLC/SNAP encapsulation.


The following example enables aal5snap encapsulation on atm interface 1/1:

DSLAM#conf t DSLAM(config)#interface atm0/1 DSLAM(config-if)#atm pvc 0 100 interface atm 0/0 0 100 encap aal5snap

Related Commands

Command
Description

ppp authentication

Enables Challenge Handshake Authentication Protocol (CHAP) or Password Authentication Protocol (PAP) and enables an AAA authentication method on an interface.


exit-address-family

To exit from the address-family submode, use the exit-address-family address-family submode command.

exit-address-family

Syntax Description

This command has no arguments or keywords.

Defaults

No default behavior or values.

Command Modes

Address-family submode

Command History

Release
Modification

12.1(4)DA

This command was introduced.


Usage Guidelines

You can abbreviate this command to exit.

Examples

The following example shows how to exit the address-family command mode:

DSLAM# configure terminal DSLAM(config)# router bgp 100 DSLAM(config-router)# address-family ipv4 unicast vrf vrf2 DSLAM(config-router-af)# exit-address-family

Related Commands

Command
Description

address-family

Enters the address-family submode that you use to configure routing protocols.


framing

To select the frame type for the data link, use the framing interface configuration command. To restore the default values, use the no form of this command.

framing framingmode

Syntax Description

framingmode

Specify framingmode as follows:

For E1: pcm30 | crc4

For E3: g751adm | g751plcp | g832adm

For T1: esf | sf

For DS3: cbitadm | cbitplcp | m23adm | m23plcp


Defaults

For E1: pcm30

For E3: g832adm

For T1: esf

For DS3: cbitadm

Command Modes

Interface configuration

Command History

Release
Modification

12.1(4)DA

This command was introduced.


Usage Guidelines

In the E1 environment, the framing command allows selection of the E1 frame type to CRC4 enabled framing mode (crc4) or CRC4 disabled framing mode (pcm30).

In the E3 environment, the framing command allows the selection of the E3 frame type to g751 ADM, g751 PLCP, or g832 ADM.

In the T1 environment, the framing command allows selection of the T1 frame type to extended super frame (esf) or super frame (sf).

In the DS3 environment, the framing command allows the selection of the DS3 frame type to C-Bit ADM, C-Bit PLCP, M23 ADM, or M23 PLCP.


Note The framing type must match on both sides of a link.


Examples

The following example shows how to select m23plcp as the frame type:

DSLAM(config)# interface atm 0/1 DSLAM(config-if)# framing m23plcp

Related Commands

Command
Description

show controllers

Displays information about a physical port device.


hardware-address

To specify the hardware address of a Dynamic Host Configuration Protocol (DHCP) client, use the hardware-address DHCP pool configuration command. This command is valid for manual bindings only. Use the no form of this command to remove the hardware address.

hardware-address hardware-address type

no hardware-address

Syntax Description

hardware-address

Specifies the MAC address of the client hardware platform.

type

Indicates the protocol of the hardware platform. Strings and values are acceptable. The string options include:

ethernet

ieee802

The value options include:

1 10Mb Ethernet

6 IEEE 802

If no type is specified, the default protocol is Ethernet.


Defaults

Ethernet is the default type if if you do not specify one.

Command Modes

DHCP pool configuration

Command History

Release
Modification

12.2(1b)DA

This command was introduced.


Examples

The following example specifies b708.1388.f166 as the MAC address of the client:

DSLAM(config)# ip dhcp pool 1 DSLAM(dhcp-config)# hardware-address b708.1388.f166

Related Commands

Command
Description

client-identifier

Specifies a unique identifier for a DHCP client.

host

Specifies the IP address and network mask for a manual binding to a DHCP client.

ip dhcp pool

Configures a DHCP address pool on a Cisco IOS DHCP server and enters DHCP pool configuration mode.


host

To specify the IP address and network mask for a manual binding to a Dynamic Host Configuration Protocol (DHCP) client, use the host DHCP pool configuration command. Use the no form of this command to remove the client IP address.

host address [mask | /prefix-length]

no host

Syntax Description

address

Specifies the IP address of the client.

mask

(Optional) Specifies the network mask of the client.

/prefix-length

(Optional) Specifies the number of bits that make up the address prefix. The prefix is an alternative way of specifying the network mask of the client. The prefix length must be preceded by a forward slash (/).


Defaults

No default behavior or values.

Command Modes

DHCP pool configuration

Command History

Release
Modification

12.2(1b)DA

This command was introduced.


Usage Guidelines

If you do not specify the mask and prefix length, DHCP examines its address pools. If the software fails to find a mask in the pool database, it uses the Class A, B, or C natural mask. This command is valid for manual bindings only.

Examples

The following example specifies 10.12.1.99 as the client IP address and 255.255.248.0 as the subnet mask:

DSLAM#conf t DSLAM(config)#ip dhcp pool test DSLAM(dhcp-config)# host 10.12.1.99 255.255.248.0

Related Commands

Command
Description

client-identifier

Specifies a unique identifier for a DHCP client.

hardware-address

Specifies the hardware address of a DHCP client.

ip dhcp pool

Configures a DHCP address pool on a Cisco IOS DHCP server and enters DHCP pool configuration mode.

network (DHCP)

Configures the subnet number and mask for a DHCP address pool on a Cisco IOS DHCP server.


ima active-links-minimum

To configure the minimum number of active links required for an IMA group to function, use the ima active-links-minimum interface configuration command. To restore the default value, use the no form of this command.

ima active-links-minimum number

no ima active-links-minimum

Syntax Description

number

Minimum number (1 to 8) of active links for an IMA group to function.


Defaults

No minimum links is the default (no ima active-links-minimum or ima active-links-minimum 1).

Command Modes

Interface configuration

Command History

Release
Modification

12.1(4)DA

This command was introduced.


Usage Guidelines

This command sets the minimum number of links that must be in the active state before the IMA group interface becomes active. If at any time the number of active links is less than this value, the IMA group interface will no longer be active.

Examples

The following example uses the ima active-links-minimum command to configure the minimum number of active links that must be active for the IMA group to function correctly:

DSLAM(config)# interface atm 0/ima0 DSLAM(config-if)# ima active-links-minimum 2

Related Commands

Command
Description

show ima interface

Displays information about all IMA groups and the links in those groups.

show ima interface atm0/ima group-number

Displays information about a single IMA group and the links in that group.


ima clock-mode

To set the transmit clock mode for an ATM IMA group, use the ima clock-mode interface configuration command. To restore the default value, use the no form of this command.

ima clock-mode {common {2-9} | independent}

no ima clock-mode

Syntax Description

common

Group with a link number that is used as a common clock source for all other links in the IMA group. If the specified link is not available, another link in the group is used until the specified link is added.

independent

Group so that each link in the group is clocked independently based on its own clock source setting.


Defaults

By default, the first link added to the group is used as the common clock source (ima clock-mode common).

Command Modes

Interface configuration

Command History

Release
Modification

12.1(4)DA

This command was introduced.


Usage Guidelines

This command controls the clock for the IMA group as a whole. When you set the independent keyword, the clock source interface configuration command is used under each interface to determine clocking individually. When you set the common keyword, the clock source interface configuration command for the common link determines clocking for all the links in the group.


Note The IMA clock mode must match on both sides of an IMA link.


Examples

The following example uses the ima clock-mode command to configure the IMA group clocking mode as independent:

DSLAM(config)# interface atm 0/ima0 DSLAM(config-if)# ima clock-mode independent

Related Commands

Command
Description

clock source

Selects the transmit clock source for a link.


ima differential-delay-maximum

To specify a maximum differential timing delay among the links in an IMA group, use the ima differential-delay-maximum interface configuration command. If a link delay exceeds the specified maximum, the link drops; otherwise, the IMA feature, while multiplexing and demultiplexing, adjusts for differences in delays to align all links in a group. The no form of the command restores the default setting.

ima differential-delay-maximum {msecs}

no ima differential-delay-maximum

Syntax Descriptionn

msecs

Maximum differential delay in milliseconds as follows:

For T1 the range is 25 to 281 milliseconds.

For E1 the range is 25 to 225 milliseconds.


Defaults

The default is 25 milliseconds.

Command Modes

Interface configuration

Command History

Release
Modification

12.1(4)DA

This command was introduced.


Usage Guidelines

The transmitter on the T1/E1 IMA port adapter must align the transmission of IMA frames on all interfaces that are members of the IMA group. This alignment allows the receiver to adjust for differential link delays among the interfaces that are members of the IMA group. Based on this required behavior, the receiver can detect the differential delays by measuring the arrival times of the IMA frames on each link.

At the transmitting end, the cells transmit continuously. If no ATM layer cells need to transmit between IMA control protocol (ICP) cells with an IMA frame, then the transmit IMA sends filler cells to maintain a continuous stream of cells at the physical layer.

Examples

The following example configures the maximum allowable differential delay to 55 milliseconds for all interfaces assigned to the IMA group:

DSLAM(config)# interface atm 0/ima0 DSLAM(config-if)# ima differential-delay-maximum 55

Related Commands

Command
Description

show ima interface

Displays information about all IMA groups and the links in those groups.

show ima interface atm0/ima group-number

Displays information about a single IMA group and the links in that group.

show ima interface atm0/interface-number

Displays information for a single link in an IMA group including delay on that link.


ima frame-length

To set the IMA frame length in cells per frame, use the ima frame-length interface configuration command.

ima frame-length {32 | 64 | 128 | 256}

no ima frame-length

Syntax Description

32

Configure IMA frame length to 32 cells.

64

Configure IMA frame length to 64 cells.

128

Configure IMA frame length to 128 cells (default).

256

Configure IMA frame length to 256 cells.


Defaults

The default is 128 cells.

Command Modes

Interface configuration

Command History

Release
Modification

12.1(4)DA

This command was introduced.


Usage Guidelines

An IMA group uses the frame length parameter to set the insertion of the IMA control protocol (ICP) cells at the beginning of frames in the transmit direction. Normally, one ICP cell is sent per IMA frame. The larger the IMA frame, the less overhead there is at the expense of a decrease in allowable timing differences between the lengths.

Examples

The following example uses the ima frame-length command to configure the frame length that is transmitted as 64 cells for the IMA group:

DSLAM(config)# interface atm 0/ima0 DSLAM(config-if)# ima frame-length 64

Related Commands

Command
Description

show ima interface

Displays information about all IMA groups and the links in those groups.


ima-group

To assign a T1/E1 link to an IMA group, use the ima-group interface configuration command. The ima-group interface configuration command applies only to atm 0/2 through atm 0/9 (see Table 2-3 on page 2-26).To remove a link from an IMA group, use the no form of this command.

ima-group number

no ima-group

Syntax Description

number

IMA group number (0 to 3).


Defaults

The links do not belong to any IMA group by default.

Command Modes

Interface configuration

Command History

Release
Modification

12.1(4)DA

This command was introduced.


Usage Guidelines

Use the ima-group interface command to configure a T1/E1 port adapter interface as part of an IMA group. IMA allows you to aggregate multiple low-speed links into one larger virtual trunk or IMA group. This IMA group appears to your ATM switch router as one logical pipe. It also provides modular bandwidth for user access to ATM networks for connections between ATM network elements that are at rates between traditional multiplexing levels, such as between T1/E1, and DS3/E3.

IMA requires inverse multiplexing and demultiplexing of ATM cells in a cyclical fashion among links that are grouped to form a higher-bandwidth logical group with a rate of approximately the sum of the link rates. This grouping is called an IMA group.

Examples

The following example uses the ima-group command to assign link 0 to IMA group 0:

DSLAM(config)# interface atm 0/2 DSLAM(config-if)# ima-group 0

Related Commands

Command
Description

show controllers

Displays information about a physical port device.

show ima interface

Displays information about all IMA groups and the links in those groups.

show ima interface atm0/ima group-number

Displays information about a single IMA group and the links in that group.


ima test

To configure an IMA group test pattern transmitted in the ICP cells, use the ima test interface configuration command. To restore the default value, use the no form of this command.

ima test [link link-value] [pattern pattern-value]

no ima test

Syntax Description

link

Link that transmits the test pattern.

link-value

The IMA group member link (2 through 9) that transmits the test pattern.

pattern

Test pattern.

pattern-value

Test pattern (0 through 255) transmitted in the ICP cells.


Defaults

The link-value is 2.

The pattern-value is 166.

The default is no ima test.

Command Modes

Interface configuration

Command History

Release
Modification

12.1(4)DA

This command was introduced.


Usage Guidelines

The test pattern procedure verifies the connectivity of a link within an IMA group. The procedure uses a test pattern that it sends over one link to verify the connectivity to the other links in the IMA group. Ensure that the test pattern loops over all the other links in the group at the far end of the connection. The system performs all of the IMA test pattern procedures over the ICP cells that are exchanged between both ends of the IMA virtual links. After you configure the test on the IMA group, the test continues explicitly until you issue the no form of the command.

Examples

The following example uses the ima test command to configure the test pattern of 100 to transmit over ATM interface 0 of IMA group 0:

DSLAM(config)# interface atm 0/ima0 DSLAM(config-if)# ima test link 2 pattern 100

Related Commands

Command
Description

show ima interface

Displays information about all IMA groups and the links in those groups.


ima version

To set the operating mode of an IMA group, use the ima version interface configuration command. To restore the default value, use the no form of this command.

ima version {1.0 | 1.1}

no ima version

Syntax Description

1.0

The group runs in version 1.0 mode.

1.1

The group runs in version 1.1 mode.


Defaults

The default is version 1.0 mode.

Command Modes

Interface configuration

Command History

Release
Modification

12.1(4)DA

This command was introduced.


Examples

The following example uses the ima version command to set the IMA version to 1.1:

DSLAM(config)# interface atm 0/ima0 DSLAM(config-if)# ima version 1.1

Related Commands

Command
Description

show ima interface

Displays information about all IMA groups and the links in those groups.

show ima interface atm0/ima group-number

Displays information about a single IMA group and the links in that group.


import map

To configure an import route map for a VPN routing/forwarding instance (VRF), use the import map VRF submode command.

import map route-map

Syntax Description

route-map

Route map to use as an import route map for the VRF.


Defaults

There is no default. A VRF has no import route map unless you configure one by using the import map command.

Command Modes

VRF submode

Command History

Release
Modification

12.1(4)DA

This command was introduced.


Usage Guidelines

Use an import route map when you require control over the routes that you import into a VRF that is finer than the control provided by the import and export extended communities that are configured for the importing and exporting VRF.

The import map command associates a route map with the specified VRF. You can filter routes that are eligible for import into a VRF, based on the route target extended community attributes of the route, through the use of a route map.

Examples

The following example shows how to configure an import route map for a VRF:

DSLAM(config)# ip vrf vrf_blue DSLAM(config-vrf)# import map blue_import_map

Related Commands

Command
Description

ip vrf

Enters VRF configuration mode.

route-target

Configures import and export extended community attributes for the VRF.

show ip vrf

Displays information about a VRF or all VRFs.


ip cef traffic-statistics

To change the time interval that controls when Next Hop Resolution Protocol (NHRP) will set up or tear down a switched virtual circuit (SVC), use the ip cef traffic-statistics global configuration command. To restore the default values, use the no form of this command.

ip cef traffic-statistics [load-interval seconds] [update-rate seconds]

no ip cef traffic-statistics

Syntax Description

load-interval seconds

(Optional) Length of time (in 30-second increments) during which the average trigger-threshold and teardown-threshold are calculated before an SVC setup or teardown action is taken. The load-interval range is 30 to 300 seconds, in 30-second increments. The default value is 30 seconds.

update-rate seconds

(Optional) Frequency with which the port adapter sends the accounting statistics to the resolution protocol. When you use NHRP in distributed CEF switching mode, you must set this value to 5 seconds. The default value is 10 seconds.


Defaults

load-interval: 30 seconds

update-rate: 10 seconds

Command Modes

Global configuration

Command History

Release
Modification

12.2(1b)DA

This command was introduced.


Usage Guidelines

To change the interval, use the load-interval seconds argument of the ip cef traffic-statistics command.

Examples

In the following example, the triggering and teardown thresholds are calculated based on an average over 120 seconds:

DSLAM(config)# ip cef traffic-statistics load-interval 120

Related Commands

Command
Description

ip nhrp trigger-svc

Configures when NHRP will set up and tear down an SVC based on aggregate traffic rates.


ip classless

At times the router might receive packets destined for a subnet of a network that has no network default route. To have the Cisco IOS software forward such packets to the best supernet route possible, use the ip classless global configuration command. To disable this feature, use the no form of this command.

ip classless

no ip classless

Syntax Description

This command has no arguments or keywords.

Defaults

Enabled

Command Modes

Global configuration

Command History

Release
Modification

12.2(1b)DA

This command was introduced.


Usage Guidelines

This command allows the software to forward packets that are destined for unrecognized subnets of directly connected networks. The packets are forwarded to the best supernet route.

When this feature is disabled, the software discards the packets for a subnet that numerically falls within its subnetwork addressing scheme. If there is no such subnet number in the routing table, there is no network default route.

Examples

The following example prevents the software from forwarding packets that are destined for an unrecognized subnet to the best supernet possible:

DSLAM(config)# no ip classless

Related Commands

None.

ip default-gateway

To define a default gateway (router) when IP routing is disabled, use the ip default-gateway global configuration command. To disable this function, use the no form of this command.

ip default-gateway ip-address

no ip default-gateway ip-address

Syntax Description

ip-address

IP address of the router.


Defaults

Disabled

Command Modes

Global configuration

Command History

Release
Modification

12.2(1b)DA

This command was introduced.


Usage Guidelines

The Cisco IOS software sends any packets that need the assistance of a gateway to the address you specify. If another gateway has a better route to the requested host, the default gateway sends an ICMP Redirect message back. The ICMP Redirect message indicates which local router the Cisco IOS software should use.

Examples

The following example defines the router on IP address 192.168.7.18 as the default router:

DSLAM(config)# ip default-gateway 192.168.7.18

Related Commands

None.

ip dhcp conflict logging

To enable conflict logging on a Cisco IOS Dynamic Host Configuration Protocol (DHCP) server, use the ip dhcp conflict logging global configuration command. Use the no form of this command to disable conflict logging.

ip dhcp conflict logging

no ip dhcp conflict logging

Syntax Description

This command has no arguments or keywords.

Defaults

Conflict logging is enabled.

Command Modes

Global configuration

Command History

Release
Modification

12.2(1b)DA

This command was introduced.


Usage Guidelines

We recommend that you use a DHCP server database agent to store automatic bindings. If you decide not to use a DHCP server database agent to store automatic bindings, use the no ip dhcp conflict logging command to disable the recording of address conflicts. By default, the Cisco IOS DHCP server records DHCP address conflicts in a log file.

Examples

The following example disables the recording of DHCP address conflicts:

DSLAM(config)# no ip dhcp conflict logging

Related Commands

Command
Description

clear ip dhcp conflict

Clears an address conflict from the Cisco IOS DHCP server database.

ip dhcp database

Configures a DHCP server database agent and database agent parameters.

show ip dhcp conflict

Displays address conflicts that a Cisco IOS DHCP server finds when addresses are offered to the client.


ip dhcp database

You can configure a Cisco IOS Dynamic Host Configuration Protocol (DHCP) server to save automatic bindings on a remote host called a database agent. To configure a DHCP server database agent and database agent parameters, use the ip dhcp database global configuration command. Use the no form of this command to remove the database agent.

ip dhcp database url [timeout seconds | write-delay seconds]

no ip dhcp database url

Syntax Description

url

Specifies the remote file used to store the automatic bindings. The acceptable URL file formats include:

tftp://host/filename

ftp://user:password@host/filename

rcp://user@host/filename

timeout seconds

(Optional) Specifies how long, in seconds, the DHCP server should wait before ending a database transfer. Transfers that exceed the timeout period end. By default, DHCP waits 300 seconds before it ends a database transfer. Infinity is defined as 0 seconds.

write-delay seconds

(Optional) Specifies how soon the DHCP server should send database updates. By default, DHCP waits 300 seconds (5 minutes) before it sends database changes. The minimum delay is 60 seconds.


Defaults

DHCP waits 300 seconds for both a write delay and a timeout.

Command Modes

Global configuration

Command History

Release
Modification

12.2(1b)DA

This command was introduced.


Usage Guidelines

The administrator can configure multiple database agents. Transfer bindings by using the File Transfer Protocol (FTP), Trivial File Transport Protocol (TFTP), or Remote Copy Protocol (RCP).

Examples

The following example specifies the DHCP database transfer timeout value at 80 seconds:

DSLAM(config)# ip dhcp database ftp://user:password@172.16.1.1/router-dhcp timeout 80

The following example specifies the DHCP database update delay value at 100 seconds:

DSLAM(config)# ip dhcp database tftp://172.16.1.1/router-dhcp write-delay 100

Related Commands

Command
Description

show ip dhcp database

Displays Cisco IOS DHCP server database agent information.


ip dhcp excluded-address

To specify IP addresses that a Cisco IOS Dynamic Host Configuration Protocol (DHCP) server should not assign to DHCP clients, use the ip dhcp excluded-address global configuration command. Use the no form of this command to remove the excluded IP addresses.

ip dhcp excluded-address low-address [high-address]

no ip dhcp excluded-address low-address [high-address]

Syntax Description

low-address

The excluded IP address, or first IP address in an excluded address range.

high-address

(Optional) The last IP address in the excluded address range.


Defaults

All IP pool addresses are assignable.

Command Modes

Global configuration

Command History

Release
Modification

12.2(1b)DA

This command was introduced.


Usage Guidelines

The DHCP server assumes that it can assign all pool addresses to clients. Use this command to exclude a single IP address or a range of IP addresses.

Examples

The following example configures an excluded IP address range from 172.16.1.100 through 172.16.1.199:

DSLAM(config)# ip dhcp excluded-address 172.16.1.100 172.16.1.199

Related Commands

Command
Description

ip dhcp pool

Configures a DHCP address pool on a Cisco IOS DHCP server and enters DHCP pool configuration mode.

network (DHCP)

Configures the subnet number and mask for a DHCP address pool on a Cisco IOS DHCP server.


ip dhcp ping packets

To specify the number of packets that a Cisco IOS Dynamic Host Configuration Protocol (DHCP) server sends to a pool address as part of a ping operation, use the ip dhcp ping packets global configuration command. Use the no form of this command to prevent the server from pinging pool addresses.

ip dhcp ping packets count

no ip dhcp ping packets

Syntax Description

count

Indicates the number of ping packets that the DHCP server sends before the address is assigned to a requesting client. The default value is two packets.


Defaults

Two packets

Command Modes

Global configuration

Command History

Release
Modification

12.2(1b)DA

This command was introduced.


Usage Guidelines

The DHCP server pings a pool address before it assigns the address to a requesting client. If the ping is unanswered, the DHCP server assumes (with a high degree of probability) that the address is not in use and assigns the address to the requesting client.

Examples

The following example specifies five ping attempts by the DHCP server before the server ceases any further ping attempts:

DSLAM(config)# ip dhcp ping packets 5

Related Commands

Command
Description

clear ip dhcp conflicts

Clears an address conflict from the Cisco IOS DHCP server database.

ip dhcp ping timeout

Specifies how long a Cisco IOS DHCP server waits for a ping reply from an address pool.

show ip dhcp conflict

Displays address conflicts that a Cisco IOS DHCP server finds when addresses are offered to the client.


ip dhcp ping timeout

To specify how long a Cisco IOS Dynamic Host Configuration Protocol (DHCP) server waits for a ping reply from an address pool, use the ip dhcp ping timeout global configuration command. Use the no form of this command to restore the default number of milliseconds (500) for the timeout.

ip dhcp ping timeout milliseconds

no ip dhcp ping timeout

Syntax Description

milliseconds

The amount of time in milliseconds that the DHCP server waits for a ping reply before it stops attempting to reach a pool address for client assignment. The maximum timeout is 10,000 milliseconds (10 seconds). The default timeout is 500 milliseconds.


Defaults

500 milliseconds

Command Modes

Global configuration

Command History

Release
Modification

12.2(1b)DA

This command was introduced.


Usage Guidelines

This command specifies how long to wait for a ping reply in milliseconds.

Examples

The following example specifies that the DHCP server will wait 800 milliseconds for a ping reply before considering the ping a failure:

DSLAM(config)# ip dhcp ping timeout 800

Related Commands

Command
Description

clear ip dhcp conflicts

Clears an address conflict from the Cisco IOS DHCP server database.

ip dhcp ping packets

Specifies the number of packets that a Cisco IOS DHCP server sends to a pool address as part of a ping operation.

show ip dhcp conflict

Displays address conflicts that a Cisco IOS DHCP server finds when addresses are offered to the client.


ip dhcp pool

To configure a Dynamic Host Configuration Protocol (DHCP) address pool on a Cisco IOS DHCP server and enter DHCP pool configuration mode, use the ip dhcp pool global configuration command. Use the no form of this command to remove the address pool.

ip dhcp pool name

no ip dhcp pool name

Syntax Description

name

Can be either a symbolic string (such as "engineering") or an integer (such as 0).


Defaults

DHCP address pools are not configured.

Command Modes

Global configuration

Command History

Release
Modification

12.2(1b)DA

This command was introduced.


Usage Guidelines

During execution, the configuration mode changes to DHCP pool configuration mode, which is identified by the (config-dhcp)# prompt. In this mode, the administrator can configure pool parameters, such as the IP subnet number and default router list.

Examples

The following example configures pool1 as the DHCP address pool:

DSLAM(config)# ip dhcp pool pool1

Related Commands

This command is used by cable modem termination systems. By default, DHCP checks relay information. Invalid messages are dropped.

ip dhcp relay information option

To configure a Cisco IOS Dynamic Host Configuration Protocol (DHCP) server to insert the DHCP relay agent information option in forwarded BOOTREQUEST messages, use the ip dhcp relay information option global configuration command. Use the no form of this command to disable the insertion of relay information to forwarded BOOTREQUEST messages.

ip dhcp relay information option

no ip dhcp relay information option

Syntax Description

This command has no arguments or keywords.

Defaults

The DHCP server does not insert relay information.

Command Modes

Global configuration

Command History

Release
Modification

12.2(1b)DA

This command was introduced.


Usage Guidelines

This command is used by cable modem termination systems. By default, DHCP does not insert relay information.

Examples

The following example configures a DHCP server to insert the DHCP relay agent information option in forwarded BOOTREQUEST messages:

DSLAM(config)# ip dhcp relay information option

Related Commands

Command
Description

ip dhcp relay information check

Configures a Cisco IOS DHCP server to validate the relay agent information option in forwarded BOOTREPLY messages.

ip dhcp relay information policy

Configures DHCP relay agent information reforwarding policy (what a DHCP relay agent should do if a message already contains relay information).


ip helper-address

To have the Cisco IOS software forward User Datagram Protocol (UDP) broadcasts, including BOOTP, that are received on an interface, use the ip helper-address interface configuration command. To disable the forwarding of broadcast packets to specific addresses, use the no form of this command.

ip helper-address address

no ip helper-address address

Syntax Description

address

Destination broadcast or host address to be used when forwarding UDP broadcasts. There can be more than one helper address per interface.


Defaults

Disabled

Command Modes

Interface configuration

Command History

Release
Modification

12.2(1b)DA

This command was introduced.


Usage Guidelines

One common application that requires helper addresses is Dynamic Host Configuration Protocol (DHCP), which is defined in RFC 1531. DHCP protocol information is carried inside of BOOTP packets. To enable BOOTP broadcast forwarding for a set of clients, configure a helper address on the router interface that is closest to the client. The helper address should specify the address of the DHCP server. If you have multiple servers, you can configure one helper address for each server. Because BOOTP packets are forwarded by default, DHCP information can now be forwarded by the router. The DHCP server then receives broadcasts from the DHCP clients.


Note The ip helper-address command does not work on an X.25 interface on a destination router because the router is unable to determine whether the packet was intended as a physical broadcast.


Examples

In the following example, DHCP option 82 support is enabled on the DHCP relay agent using the ip dhcp relay agent information option command. The rbe nasip command configures the DSLAM to forward the IP address for Loopback0 to the DHCP server.

DSLAM(config)# ip dhcp relay information option DSLAM(config)# ip dhcp-server 10.0.0.202 DSLAM(config)# rbe nasip Loopback1 DSLAM(config)# interface Loopback1 DSLAM(config-if)# ip address 18.52.86.120 255.255.255.255 DSLAM(config-if)# interface Ethernet0/0 DSLAM(config-if)# ip address 10.0.0.40 255.0.0.0 DSLAM(config-if)# interface atm1/1 DSLAM(config-if)# ip address 11.0.0.1 255.0.0.0 DSLAM(config-if)# ip helper-address 10.0.0.202 DSLAM(config-if)# atm route-bridged ip DSLAM(config-if)# no atm ilmi-keepalive DSLAM(config-if)# pvc 1/1 DSLAM(config-if)# encapsulation aal5snap DSLAM(config-if)# interface ATM1/2 DSLAM(config-if)# ip address 12.0.0.1 255.0.0.0 DSLAM(config-if)# ip helper-address 10.0.0.202 DSLAM(config-if)# atm route-bridged ip DSLAM(config-if)# no atm ilmi-keepalive DSLAM(config-if)# pvc 1/1 DSLAM(config-if)# encapsulation aal5snap

Related Commands

None.

ip local pool

To configure a local IP address pool group, use the ip local pool configuration command with the group name. To disband the group, use the no form of this command.

ip local pool pool-name start-IP [end-IP] [group group-name] [cache-size size]

no ip local pool

Syntax Description

pool-name

User-defined name for the local address pool.

start-IP

IP address that defines the start of the group.

end-IP

IP address that defines the end of the contiguous addresses in the group.

group

Define a group that contains this pool.

group-name

User-defined name for the pool group.

cache-size

Specify the size of the cache.

size

Size of the cache.


Defaults

Any pool that you create without the optional group keyword is a member of the base system group.

Command Modes

Global configuration

Command History

Release
Modification

12.2(1b)DA

This command was introduced.


Usage Guidelines

All pool names must be unique. Use of a duplicate name extends that pool.

If you specify a (named) pool within a pool group, the software allows overlapping IP addresses to exist with pools in other groups and with pools in the "base system" pool. The software does not allow the overlapping IP address to exist among pools within a group. Otherwise, pool processing is not altered by pool membership in a group. That is, you can use these (named) pools anywhere that pools can be used in the current implementation.

Addresses return to the pool from which they were allocated.

Examples

DSLAM(config)# ip local pool p1_g1 10.1.1.1 10.1.1.50 group grp1 DSLAM(config)# ip local pool p2_g1 10.1.1.100 10.1.1.110 group grp1 DSLAM(config)# ip local pool p1_g2 10.1.1.1 10.1.1.40 group grp2 DSLAM(config)# ip local pool lp1 10.1.1.1 10.1.1.10 DSLAM(config)# ip local pool p3_g1 10.1.2.1 10.1.2.30 group grp1 DSLAM(config)# ip local pool p2_g2 10.1.1.50 10.1.1.70 group grp2 DSLAM(config)# ip local pool lp2 10.1.2.1 10.1.2.10

Related Commands

Command
Description

debug ip peer

This command contains additional output when pool groups are defined.


ip route vrf

To establish static routes for a VRF, use the ip route vrf global configuration command. To disable static routes, use the no form of this command.

ip route vrf vrf-name prefix mask {[next-hop-address] | [interface {interface-number}]} [global] [distance] [permanent] [tag tag]

no ip route vrf vrf-name prefix mask {[next-hop-address] | [interface {interface-number}]} [global] [distance] [permanent] [tag tag]

Syntax Description

vrf-name

Name of the VPN routing or forwarding instance (VRF) for the static route.

prefix

IP route prefix for the destination, in dotted-decimal format.

mask

Prefix mask for the destination, in dotted-decimal format.

next-hop-address

(Optional) IP address of the next hop (the forwarding router that can be used to reach that network).

interface

(Optional) Type of network interface to use: ATM, Ethernet, loopback, POS (packet over SONET), or null.

interface-number

Number that identifies the network interface to use.

global

The given next hop address is in the nonVRF routing table.

distance

(Optional) An administrative distance for this route.

permanent

(Optional) This route will not be removed, even if the interface shuts down.

tag tag

(Optional) Label value that can be used for controlling redistribution of routes through route maps.


Defaults

No default behavior or values.

Command Modes

Global configuration

Command History

Release
Modification

12.1(4)DA

This command was introduced.


Usage Guidelines

Use a static route if the Cisco IOS software cannot dynamically build a route to the destination.

If you specify an administrative distance when you set up a route, you are flagging a static route that can be overridden by dynamic information. For example, IGRP-derived routes are configured with a default administrative distance of 100. To set a static route to be overridden by an IGRP dynamic route, specify an administrative distance greater than 100. Static routes each have a default administrative distance of 1.

Static routes that point to an interface are advertised through RIP, IGRP, and other dynamic routing protocols, regardless of whether the routes are redistributed into those routing protocols. That is, static routes configured by specifying an interface lose their static nature when installed into the routing table.

However, if you define a static route to an interface that is not defined in a network command, no dynamic routing protocols advertise the route unless you specify a redistribute static command for these protocols.

Examples

The following command shows how to reroute packets addressed to network 137.23.0.0 in VRF vpn3 to router 131.108.6.6:

DSLAM(config)# ip route vrf vpn3 137.23.0.0 255.255.0.0 131.108.6.6

Related Commands

Command
Description

show ip route vrf

Displays the IP routing table associated with a VRF.


ip routing

To enable IP routing, use the ip routing global configuration command. To disable IP routing, use the no form of this command.

ip routing

no ip routing

Syntax Description

This command has no arguments or keywords.

Defaults

Enabled

Command Modes

Global configuration

Command History

Release
Modification

12.1(4)DA

This command was introduced.


Examples

The following example enables IP routing:

DSLAM(config)# ip routing

Related Commands

None.

ip subnet-zero

To enable the use of subnet zero for interface addresses and routing updates, use the ip subnet-zero global configuration command. To restore the default, use the no form of this command.

ip subnet-zero

no ip subnet-zero

Syntax Description

This command has no arguments or keywords.

Defaults

Disabled

Command Modes

Global configuration

Command History

Release
Modification

12.2(1b)DA

This command was introduced.


Usage Guidelines

The ip subnet-zero command enables you to configure and route to subnet-zero subnets.

We discourage subnetting with a subnet address of zero because of the confusion inherent when you have a network and a subnet with indistinguishable addresses.

Examples

The following example enables subnet-zero:

DSLAM(config)# ip subnet-zero

Related Commands

None.

ip unnumbered

To enable IP processing on an ATM interface without assigning an explicit IP address to the interface, use the ip unnumbered interface configuration command. To disable the IP processing on the interface, use the no form of this command.

ip unnumbered type number

Syntax Description

type number

Type and number of another interface on which the router has an assigned IP address. This number cannot be another unnumbered interface.


Defaults

Disabled

Command Modes

Interface configuration

Command History

Release
Modification

12.1(4)DA

This command was introduced.


Usage Guidelines

Whenever the unnumbered interface generates a packet (for example, for a routing update), it uses the address of the specified interface as the source address of the IP packet. The unnumbered interface also uses the address of the specified interface to determine which routing processes are sending updates over the unnumbered interface. Restrictions include the following:

Serial interfaces using High-Level Data Link Control (HDLC), PPP, Link Access Procedure, Balanced (LAPB), and Frame Relay encapsulations, as well as Serial Line Internet Protocol (SLIP) and tunnel interfaces, can be unnumbered. You cannot use this interface configuration command with X.25 or Switched Multimegabit Data Service (SMDS) interfaces.

You cannot use the ping EXEC command to determine whether the interface is up because the interface has no address. You can use Simple Network Management Protocol (SNMP) to remotely monitor interface status.

You cannot netboot a runnable image over an unnumbered serial interface.

You cannot support IP security options on an unnumbered interface.

The interface that you specify by the type and number arguments must be enabled (listed as "up" in the show interfaces command display).

If you are configuring IS-IS across a serial line, you should configure the serial interfaces as unnumbered. Doing so allows you to conform with RFC 1195, which states that IP addresses are not required on each interface.


Note The use of an unnumbered serial line between different major networks (majornets) requires special care. If at each end of the link different majornets are assigned to the interfaces that you specified as unnumbered, any routing protocol that is running across the serial line must not advertise subnet information.


Examples

In the following example, the first ATM interface is given the Ethernet 0/0 address:

DSLAM(config)# interface ethernet 0/0 DSLAM(config-if)# ip address 131.108.6.6 255.255.255.0 ! DSLAM(config)# interface atm 0/1 DSLAM(config-if)# ip unnumbered ethernet 0/0

Related Commands

None.


ip vrf

To configure a VPN routing/forwarding (VRF) routing table, use the ip vrf global configuration command. To remove a VRF routing table, use the no form of this command.

ip vrf vrf-name

no ip vrf vrf-name

Syntax Description

vrf-name

Name assigned to a VRF.


Defaults

No VRFs are defined. No import or export lists are associated with a VRF. No route maps are associated with a VRF.

Command Modes

Router configuration

Global configuration

Command History

Release
Modification

12.1(4)DA

This command was introduced.


Usage Guidelines

The ip vrf vrf-name command creates a VRF routing table and a CEF (forwarding) table, both named vrf-name. The default route distinguisher value route-distinguisher is associated with these tables.

Examples

The following example shows how to import a route map to a VRF:

DSLAM(router-config)# ip vrf vpn1 DSLAM(config-vrf)# rd 100:2 DSLAM(config-vrf)# route-target both 100:2 DSLAM(config-vrf)# route-target import 100:1

Related Commands

Command
Description

ip vrf forwarding

Associates a VRF with an interface or subinterface.


ip vrf forwarding

To associate a VRF with an interface or subinterface, use the ip vrf forwarding interface configuration command. To disassociate a VRF, use the no form of this command.

ip vrf forwarding vrf-name

no ip vrf forwarding vrf-name

Syntax Description

vrf-name

Name assigned to a VRF.


Defaults

The default for an interface is the global routing table.

Command Modes

Global configuration

Interface configuration

Command History

Release
Modification

12.1(4)DA

This command was introduced.


Usage Guidelines

Use this command to associate an interface with a VRF. Executing this command on an interface removes the IP address. You should reconfigure the IP address.

Examples

The following example shows how to link a VRF to ATM interface 1/1:

DSLAM(config)# interface atm1/1 DSLAM(config-if)# ip vrf forwarding vpn1

Related Commands

Command
Description

ip vrf

Defines a VRF.

ip route vrf

Establishes static routes for a VRF.


lbo

To set the line build-out to various lengths, use the lbo interface configuration command. To restore the default values, use the no form of this command.

lbo {short {133 | 266 | 399 | 533 | 655} | long {gain10 | gain36} {0db | -7.5db | -15db | -22.5db}}

no lbo

Syntax Description

short

Short cable length. Must be followed by a length value. The range mapping for each value is shown below:

Value        Range (feet)

133          0 to 133

266          134 to 266

399          267 to 399

533          400 to 533

655          534 to 655

long

Cable length line build out. The long setting must be followed by a gain and a margin value.


Defaults

The default setting is long haul with gain36 and 0 dB (lbo long gain36 0db).

Command Modes

Interface configuration

Command History

Release
Modification

12.1(4)DA

This command was introduced.


Usage Guidelines

This command is applicable to E1 and T1 links.

Examples

The following example shows how to select long as the cable length.

DSLAM(config)# interface atm 0/2 DSLAM(config-if)# lbo long gain36 -15db

The following example shows how to select short as the cable length.

DSLAM(config)# interface atm 0/2 DSLAM(config-if)# lbo short 266

Related Commands

Command
Description

show controllers

Displays information about a physical port device.


lease

To configure the duration of the lease for an IP address that is assigned from a Cisco IOS Dynamic Host Configuration Protocol (DHCP) server to a DHCP client, use the lease DHCP pool configuration command. Use the no form of this command to restore the default value.

lease {days [hours][minutes] | infinite}

no lease

Syntax Description

days

Specifies the duration of the lease in number of days.

hours

(Optional) Specifies the number of hours in the lease. You must supply a days value before you can configure an hours value.

minutes

(Optional) Specifies the number of minutes in the lease. You must supply a days value and an hours value before you can configure a minutes value.

infinite

Specifies that the duration of the lease is unlimited.


Defaults

One day

Command Modes

DHCP pool configuration

Command History

Release
Modification

12.2(1b)DA

This command was introduced.


Examples

The following example shows a 1-day lease:

DSLAM# configure terminal DSLAM(config)# ip dhcp pool test DSLAM(dhcp-config)# lease 1

The following example shows a 1-hour lease:

DSLAM# configure terminal DSLAM(config)# ip dhcp pool test DSLAM(dhcp-config)# lease 0 1

The following example shows a 1-minute lease:

DSLAM# configure terminal DSLAM(config)# ip dhcp pool test DSLAM(dhcp-config)# lease 0 0 1

The following example shows an infinite (unlimited) lease:

DSLAM# configure terminal DSLAM(config)# ip dhcp pool test DSLAM(dhcp-config)# lease infinite

Related Commands

Command
Description

ip dhcp pool

Configures a DHCP address pool on a Cisco IOS DHCP server and enters DHCP pool configuration mode.


linecode

To select the line code type of the T1/E1 link, use the linecode interface configuration command. To restore the default values, use the no form of this command.

linecode {ami | b8zs | hdb3}

no linecode {ami | b8zs | hdb3}

Syntax Description

ami

Alternate mark inversion (AMI) as the line code type. Valid for T1 or E1 controllers.

b8zs

B8ZS as the line code type. Valid for T1 controller.

hdb3

HDB3 as the line code type. Valid for E1 controller.


Defaults

T1 = b8zs

E1 = hdb3

Command Modes

Interface configuration

Command History

Release
Modification

12.1(4)DA

This command was introduced.


Usage Guidelines

Use this command to match the line code of the far end device.

Examples

The following example specifies AMI as the line code type:

DSLAM(config)# interface atm 0/3 DSLAM(config-if)# linecode ami

Related Commands

Command
Description

show controllers

Displays information about a physical port device.


loopback

To enable a loopback on a port, use the loopback interface configuration command. To disable the loopback, use the no form of the command.

loopback {diagnostic | line | payload}

loopback [diagnostic | line] [protection | working | <cr>]

no loopback

Syntax Description

diagnostic

Transmit data is looped to receive data at the physical (PHY) layer. This option is available on all ports.

line

Configures the link to loop the received signal (T1/E1, E3, OC-3, or DS3) back out the transmitter with no changes in framing, coding, and so forth.

payload

Configures the link to remove the user data from the received T1/E1, E3, or DS3, reframes the user data, and transmits it out.

protection

The fiber that is connected to the NI-2 card in slot 11.

working

The fiber that is connected to the NI-2 card in slot 10.

<cr>

Both protection and working fibers.


Defaults

Disabled

Command Modes

Interface configuration

Command History

Release
Modification

12.0(5)DA

This command was introduced.

12.1(7)DA

The keywords working and protection were added.


Usage Guidelines

If you enable or disable loopbacks, the port does not untrain or retrain. However, if you remove a loopback, the port retrains. The working and protection keywords are available only when you are configuring loopback on a SONET port.

Examples

This command enables ATM local loopback for port 1 of slot 20, then disables the loopback:

DSLAM# configure terminal DSLAM(config)# interface atm 20/1 DSLAM(config-if)# loopback diagnostic DSLAM(config-if)# no loopback diagnostic

This command enables a line loopback for the trunk port:

DSLAM# configure terminal DSLAM(config)# interface atm 0/1 DSLAM(config-if)# loopback line

The following example enables a loopback on atm 0/1, on the fiber local to the NI-2 card in slot 11:

DSLAM> enable DSLAM# configure terminal DSLAM(config)# interface atm 0/1 DSLAM(config-if)# loopback diagnostic protection

Related Commands

Command
Description

show controllers

Display information on working and protection fibers.



hometocprevnextglossaryfeedbacksearchhelp

Posted: Thu May 27 13:36:51 PDT 2004
All contents are Copyright © 1992--2004 Cisco Systems, Inc. All rights reserved.
Important Notices and Privacy Statement.