|HP-UX Reference > R
rlpdaemon(1M)HP-UX 11i Version 3: February 2007
rlpdaemon — daemon for queuing, displaying, removing and altering remote spool requests and writing remote messages
rlpdaemon is a LP daemon (spool area handler) for remote spool requests. rlpdaemon is normally invoked at boot time from the /sbin/rc file or started by inetd(1M), when necessary. rlpdaemon runs on a system that receives requests to be printed. rlpdaemon transfers files to the spooling area, displays the queue, removes jobs from the queue, or alters jobs in the queue.
rlpdaemon is also used as a server process to write a message on the user's terminal, upon receiving a request from a remote system.
When rlpdaemon is started by inetd(1M), access control is provided via the file /var/adm/inetd.sec to allow or prevent a host from making requests. When rlpdaemon is not started by inetd(1M), all requests must come from one of the machines listed in the file /etc/hosts.equiv or /var/spool/lp/.rhosts. When /var/spool/lp/.rhosts is used for access, the user name should be lp.
The following entry should exist in /etc/services for remote spooling:
Control File Processing
The lp subsystem expects that the control file associated with each request contain the datafile line entry (starting with a lower case letter) indicating the file to be printed, and an associated unlink datafile entry (U entry). The actual filename (N entry) for this datafile line entry can be above or below the datafile line entry. If multiple copies of a file has to be printed, for example n copies, then the datafile line entry should be repeated n times in succession. rlpdaemon may reorder or insert the U entries in the control file such that the datafile line entry and the U entry will be in succession for each file to be printed.
To start rlpdaemon from /sbin/rc, invoke the command:
To start rlpdaemon from inetd, the following line should be included in the file /etc/inetd.conf:
printer stream tcp nowait root /usr/sbin/rlpdaemon rlpdaemon -i
If the remote system is the same as the local system and rlpdaemon was not started by inetd(1M), the local system name must be included in file /etc/hosts.equiv.
/etc/hosts.equiv /etc/services /var/spool/lp/* /var/adm/lp/* /etc/lp/* /usr/lib/lp/* /var/adm/inetd.sec
enable(1), lp(1), lpstat(1), accept(1M), inetd(1M), lpadmin(1M), lpsched(1M), rcancel(1M), rlp(1M), rlpdaemon(1M), rlpstat(1M). hosts.equiv(4), inetd.conf(4), inetd.sec(4), services(4).
HP-UX System Administrator manuals