|HP-UX Reference > I
inetd.conf(4)HP-UX 11i Version 3: February 2007
inetd.conf — configuration file for inetd
On invocation, the inetd daemon reads its configuration information from the /etc/inetd.conf configuration file, and possibly at some later time in response to a SIGHUP signal (see inetd(1M)).
Each line in the file is treated either as a comment or as configuration information for a given service Comments are denoted by a # at the beginning of a line. Noncomment lines contain seven or nine required fields, depending on the service name specified in the first field. Fields are separated by tabs and/or spaces. A line can be continued if it terminates with a \. Each configuration line in the file contains the following fields in the order indicated:
Fields are constructed as follows:
If service name is rpc (NFS RPC services), two extra fields are required. They must appear between the server program field and the server program arguments field:
Built-in inetd Services
The inetd daemon provides several "trivial" services internally by use of built-in routines (see inetd(1M) for a list of these services). To configure an internal service, specify internal as the server program name, and omit the server program arguments field.
Configure the shell service to use TCP protocol, and run the server remshd as user root.
shell stream tcp nowait root /usr/lbin/remshd remshd
The above is an example of the remsh utility run in the IPv4 mode. To run the above utility in the IPv6 mode, the protocol tcp must be changed to tcp6. Thus the above configuration is re-written as below to run in IPv6 mode.
shell stream tcp6 nowait root /usr/lbin/remshd remshd
Configure the FTP server to timeout an inactive session after 75 seconds.
ftp stream tcp nowait root /usr/lbin/ftpd ftpd -t75
The above ftp service can be run in IPv6 mode using the configuration shown below:
ftp stream tcp6 nowait root /usr/lbin/ftpd ftpd -t75
Configure an RPC-based service. Note that the service name field contains rpc and two more fields are used: the program number (100008) and version number (1).
rpc dgram udp wait root /usr/lib/netsvc/rwall/rpc.rwalld 100008 1 rpc.rwalld
Configure inetd to use the built-in daytime TCP service.
daytime stream tcp nowait root internal
inetd.conf was developed by the University of California, Berkeley.
NFS was developed by Sun Microsystems, Inc.
inetd(1M), exec(2), fork(2), inetd.sec(4), protocols(4), services(4).