NAME
nwmgr_vlan: nwmgr — network interface management command for VLAN interface
SYNOPSIS
nwmgr
-a
-S vlan
[-c lanVPPA]
-A vlanid=vlanid,
ppa=PPA
[,attr=value]...
[--sc]
nwmgr -d -c lanVPPA
[--sc]
nwmgr -d -S vlan -c lanVPPA
--sa
[--sc]
nwmgr -d -S vlan
--sa
[--sc]
nwmgr -s -c lanVPPA
-A attr1=value1...
[--sc]
nwmgr -s -c lanVPPA
-A all
--sa
--fr cu
[--sc]
nwmgr -s -S vlan
-A all
--sa
--fr cu
[--sc]
nwmgr
[-g]
{ -c lanVPPA |
-S vlan }
[-v]
[--sc]
nwmgr
[-g]
-A
{ all |
attr1, attr2,...}
-c lanVPPA
[-v]
[--sc]
nwmgr
[-g]
--st
-c lanVPPA
[--sc]
nwmgr -r -c lanVPPA
[--sc]
nwmgr -r --st -c lanVPPA
[--sc]
nwmgr --cra -c lanVPPA
[--sc]
nwmgr --diag
[link]
-A dest=mac_addr
[--it
number]
[-A
pktsize=bytes]
[-A
timeout=seconds]
-c lanVPPA
[--sc]
nwmgr -h
-S vlan
[-v]
nwmgr -h
[ -a | -g |
-s | -d | -r
| --diag ]
{ -c lanVPPA |
-S vlan }
[-v]
Remark
The
lanadmin,
lanscan,
and
linkloop
commands are deprecated and
will be removed in a future HP-UX release.
HP recommends the use
of replacement command
nwmgr
to perform all network interface-related tasks.
DESCRIPTION
The
nwmgr
program is the unified command to administer all LAN and
RDMA-based interfaces of HP-UX.
General information about the command as
a whole can be found in the
nwmgr(1M)
manpage.
This
nwmgr_vlan(1M)
manpage describes
nwmgr
as applied to the VLAN subsystem.
VLANs are logical or "virtual" network segments that can span
multiple physical network segments.
A primary benefit of VLANs is that
they can isolate broadcast and multicast traffic by determining which
destinations should receive that traffic, thereby making better use of
switch and end-station resources.
The commands described here are for interactive administration of HP-UX
Virtual LAN (VLAN) interfaces.
The
nwmgr
command can be used on VLAN interfaces to display information
(with the
-g
option, which is the default), add VLAN interfaces (with the
-a
option), delete VLAN interfaces (with the
-d
option), modify settings (with the
-s
option), reset the interface or its statistics (with the
-r
option), obtain
the usage information (with the
--cra
option) and to diagnose link connectivity
(with the
--diag
option).
Operations other than
get
require
hpux.network.config
authorization.
For more information about authorizations and Role-based Access Control, see
rbac(5).
The settings of the VLAN interface on the system can be saved to the
configuration file
/etc/rc.config.d/vlanconf,
so that these settings will take effect across reboots.
The output in each case can be obtained in either human-readable format (which
is the default) or in a script-friendly parseable format (with the
--sc
or
--script
option).
The format for script-friendly output is described in the
nwmgr(1M)
manpage.
HP guarantees that any change in the scriptable
output across releases will contain only additions. The existing content
will not be modified or deleted.
The content of human-readable format can change across releases
though the changes can be expected to be incremental.
Operations
The
nwmgr
command provides the following operations for the
VLAN interface.
- -a | --add
Add/create VLAN interface.
- --cra
Perform Critical Resource Analysis on the VLAN interface.
- -d | --delete
Delete the VLAN interface.
- --diag | --diagnose
Diagnose/test link connectivity.
- -g | --get
Get/display VLAN interface settings.
This is the default operation when none is specified.
- -h | --help
Display help information.
- -r | --reset
Reset VLAN interface or the statistics on the VLAN interface.
- -s | --set
Set the attributes of the VLAN interface.
Options
Beside operations, these options
are valid for the VLAN interface:
- -A | --attribute
Specifies attributes for an operation.
For VLAN, this can be used with the
add,
set,
get,
and
diagnose
operations.
See
Attributes
section below
for valid attributes of VLAN interfaces.
- -c | --class_instance
Specifies the target interface on which the operation is to be performed.
For VLAN, the target interface is of the form:
lanVPPA
where
VPPA
is the VLAN physical point of attachment.
- -S | --subsystem
Specifies the target subsystem for the operation.
For the VLAN subsystem, the option
argument is always
vlan.
- --fr | --from
Specifies the configuration from which the operation will save
data.
For the VLAN subsystem,
current
is the only allowed argument for this option.
- --it | --iteration
Specifies the number of frames to be sent for diagnostics,
used with the diagnose operation.
- --sa | --saved
Specifies that the operation must be performed on the saved configuration
(persistent store).
- --sc | --script
Displays the output in script parseable format.
- --st | --stats
Specifies that the operation applies to the statistics of the target.
- -v | --verbose
Specifies verbose output to display more detail.
Attributes
The following attributes can be used with the
-A
(--attribute)
option
for VLAN interfaces.
Refer to the
USAGE
section below to see which attributes are valid for specific operations.
- dest=mac_addr
Ethernet MAC address of the remote interface. Used with the
diagnose
operation.
- mac
Ethernet MAC Address.
Only valid for the
get
operation.
- mtu
Displays the maximum Ethernet payload size (MTU), in bytes.
Only valid for the
get
operation.
- name=name
An optional name for the interface.
The default value of name is the
null string ("").
However,
nwmgr
displays this as UNNAMED.
- pktsize=bytes
Specifies the package size in bytes of each test frame.
The default is 100.
Only valid for the
diagnose
operation.
- ppa=PPA
Specifies
the physical point of attachment (PPA) of the interface where the VLAN
interface will be added.
Only valid for the
add
operation.
- pri=priority
Specifies
the 802.1p priority in the VLAN tag of the frame header.
Switches use the 802.1p priority.
The valid range is 0-7.
The default is 0.
- pri_override=level
Priority override provides a mechanism to convert IP level
precedence (IPV4 ToS octet) to link level 802.1p user priority.
Priority override applies to outbound frames only.
Priority override level strings are:
- CONF_PRI
Your specified priority value will be used.
This is the default value.
- IP_HEADER
IP header ToS will be converted to 802.1p priority.
- CONF_TOS
Your specified ToS value will be converted to 802.1 priority.
- speed
Speed and duplex of the related interface.
For 10 Mbps, 100 Mbps, and multiple
of 10 and 100 Mbps, the speed is displayed in Mbps.
For 1 Gbps and above, the speed is displayed in Gbps.
The duplexity can be either "half" or "full".
Only valid for the
get
operation.
- timeout=seconds
Specifies how many seconds to wait for acknowledgement of each
test frame for the
diagnose
operation.
The default is 5 seconds.
- tos=ToS_value
Specifies
the IP precedence in the IP header.
Switches ignore ToS.
Routers may use it.
The valid range is 0-255.
The default is 0.
- tos_override=level
ToS override provides a mechanism to override the IP level
precedence in the header of an inbound IP packet.
ToS override level strings are:
- IP_HEADER
ToS value in the IP header will be used.
This is the default value.
- ETHER_HEADER
Ether header 802.1p priority will be converted to a ToS value.
- CONF_TOS
Your specified ToS value will be used.
- CONF_PRI
Your specified 802.1 priority value will be converted to a ToS value.
- vlanid=vlanid
Uniquely identifies the VLAN to which
a frame belongs.
USAGE
The common usages of
nwmgr
for VLAN interfaces are described in this section.
Add a VLAN Interface
nwmgr
-a
-S vlan
[-c lanVPPA]
-A vlanid=vlanid,
ppa=PPA
[,attr=value...]
[--sc]
nwmgr
--add
--subsystem vlan
[--class_instance lanVPPA]
-A vlanid=vlanid,
ppa=PPA
[,attr=value...]
[--sc]
This command adds a VLAN interface over a VLAN capable interface.
If a VPPA (virtual PPA) is specified as a target with the
-c
option, the
VLAN interface added will be allocated that VPPA.
If the
-c
option is not specified, the VPPA is allocated by the system.
The valid attributes (specified with the
-A
option) for the
add
operation are:
ppa=PPA
vlanid=vlanid
pri=priority
tos=ToS_value
name=name
tos_override=level
pri_override=level
Delete a VLAN Interface
nwmgr -d -c lanVPPA
[--sc]
nwmgr --delete --class_instance lanVPPA
[--script]
This command deletes the VLAN interface if it is not in use.
Caution:
HP strongly advises you first run the Critical Resource Analysis (with the
--cra
option) to check usage information before deleting a VLAN interface.
Delete a VLAN Interface from the Configuration File
nwmgr -d -S vlan -c lanVPPA
--sa
[--sc]
nwmgr --delete --subsystem vlan --class_instance lanVPPA
--saved
[--script]
This command deletes the entries for the specified VLAN interface
from the configuration file
/etc/rc.config.d/vlanconf,
so that the VLAN interface will not be created during reboot.
Delete All the VLAN Interfaces from the Configuration File
nwmgr -d -S vlan
--sa
[--sc]
nwmgr --delete --subsystem vlan
--saved
[--script]
This command deletes the entries of all VLAN interfaces
from the configuration file
/etc/rc.config.d/vlanconf,
so that no VLAN interfaces will be created during reboot.
Set the Attributes of the VLAN Interface on the System
nwmgr -s -c lanVPPA
-A attr1=value1...
[--sc]
nwmgr --set --class_instance lanVPPA
-attribute attr1=value1...
[--script]
Attributes that can be set are:
vlanid=vlanid
pri=priority
tos=ToS_value
name=name
tos_override=level
pri_override=level
Save VLAN Interface Attributes to the Configuration File
nwmgr -s -c lanVPPA
-A all
--sa
--fr cu
[--sc]
nwmgr --set --class_instance lanVPPA
--attribute all
--saved
--from
current
[--script]
This command saves the current attribute values of the
specified VLAN interface to the configuration file,
/etc/rc.config.d/vlanconf,
so that the
interface configuration is preserved across boots.
You cannot
save individual attributes to the configuration file.
All attributes
must be saved together.
New entries will be created if they do not
already exist in the configuration file for the specified interface.
If there are entries with the same VLAN ID or VLAN name
for the related interface, the existing entries
will be deleted and a new entry will be created. If there are entries
with the same VPPA, the existing entries will be deleted and a new entry
will be created.
Save the Attributes of all VLAN interfaces to the Configuration File
nwmgr -s -S vlan
-A all
--sa
--fr cu
[--sc]
nwmgr --set --subsystem vlan
--attribute all
--saved
--from
current
[--script]
This command saves the attribute values of all the
VLAN interfaces on the system to the configuration file,
/etc/rc.config.d/vlanconf,
so that the
interface configuration is preserved across boots.
You cannot
save individual attributes to the configuration file.
All attributes
must be saved together. All the existing entries in the configuration file
will be deleted and new entries will be added for the VLAN interfaces
on the system.
View All Attributes of VLAN Interfaces
nwmgr
[-g]
{ -c lanVPPA |
-S vlan }
[-v]
[--sc]
nwmgr
[--get]
{--class_instance lanVPPA |
--subsystem vlan }
[--verbose]
[--script]
This command gets the attributes of one or all VLAN interfaces
on the system.
When the target is a VLAN interface, the attributes of the
specified VLAN interface are displayed.
When the target is the VLAN subsystem, attributes of all
the VLAN interfaces on the system are displayed.
When the
verbose
option is not provided,
the following attributes are displayed in a tabular format:
lan_instance,
ppa,
pri,
pri_override,
tos,
tos_override,
vlanid.
When the
verbose
option
is provided, more details about the interface
are displayed in a line-oriented format. The following additional attributes
are displayed with the
verbose
option:
- state : Interface State
Operational status of the interface.
The valid values are UP and DOWN.
- link_cause : Probable Cause for State
The cause for the link to be in UP or DOWN state.
- mac : MAC Address
Ethernet MAC Address.
The default value is the factory assigned MAC address.
- subsystem : Subsystem
The name of the subsystem.
For VLAN, it is displayed as
vlan.
- related_interface : Related Interface
The interface on which the VLAN interface is added.
- hw_path : Hardware Path
The hardware path of the VLAN interface.
- nmid : NMID
The network management ID of the VLAN interface.
- feature_cap : Feature Capabilities
The features supported by the VLAN interface.
The possible outputs are:
IPV4 Recv CKO - Driver supports inbound IPv4 CKO (Checksum offload).
IPV4 Send CKO - Driver supports outbound IPv4 CKO.
IPV4 Recv CKO - Driver supports inbound IPv6 CKO.
IPV4 Send CKO - Driver supports outbound IPv6 CKO.
VLAN Tag Offload - Underlying hardware capable of VLAN tagging.
64Bit MIB Support - 64 MIB statistics supported by driver.
IPV4 TCP Segmentation Offload - IPV4 TCP Segmentation supported by driver.
IPV4 TCP Segmentation Offload - IPV6 TCP Segmentation supported by driver.
UDP Multifrag CKO - CKO for UDP multifragmented packets supported by driver.
- feature_set : Feature Settings
The features set on the VLAN interface.
- mtu : MTU
Maximum Ethernet payload size, in bytes.
MTU above 1500 is allowed only when
the speed is 1 Gbps or above.
The valid range is 1024-9000.
The default is 1500.
- speed : Speed-Duplex
Speed and duplex of the related interface.
For 10 Mbps, 100 Mbps, and multiple
of 10 and 100 Mbps, the speed is displayed in Mbps.
For 1 Gbps and above, the speed is displayed in Gbps.
View All or Selected Attributes of a VLAN Interface
nwmgr
[-g]
-A
{ all |
attr1, attr2,...}
-c lanVPPA
[--sc]
nwmgr
[--get]
--attribute
{ all |
attr1, attr2,...}
--class_instance lanVPPA
[--script]
This command gets the value of individual attributes.
When
all
is provided as the argument to the
-A
(--attribute)
option, more details about the interface
are displayed in addition to the VLAN attributes.
The additional attributes
displayed are discussed under the section,
View All Attributes of VLAN Interfaces.
The following
attributes are valid for this command:
mac,
mtu,
name,
ppa,
pri,
pri_override,
speed,
tos,
tos_override,
vlanid.
View VLAN Interface Statistics
nwmgr
[-g]
--st
-c lanVPPA
[--sc]
nwmgr
[--get]
--stats
--class_instance lanVPPA
[--script]
This command displays the MIB statistics of the interface.
For the VLAN subsystem, 64 bit mib statistics are always displayed
regardless of the related interface.
Reset a VLAN Interface
nwmgr -r -c lanVPPA
[--sc]
nwmgr --reset --class_instance lanVPPA
[--script]
This command clears all previous state, including the interface
statistics.
Promiscuous mode and multicast addresses are preserved across the reset.
While the reset is in progress, data traffic through the interface
is interrupted.
Reset Statistics on a VLAN Interface
nwmgr -r --st -c lanVPPA
[--sc]
nwmgr --reset --stats --class_instance lanVPPA
[--script]
This command resets the statistics for an VLAN interface.
With this command, the data traffic statistics for an interface are
cleared to zero.
This includes the byte count and packet count for inbound and outbound traffic.
Other aspects of the interface are left unchanged.
Perform Critical Resource Analysis on the VLAN Interface
nwmgr --cra -c lanVPPA
[--sc]
nwmgr --cra --class_instance lanVPPA
[--script]
This command performs Critical Resource Analysis (CRA) on the VLAN interface
and displays the impact of performing a destructive action on the target.
HP recommends performing CRA to check usage before performing destructive
actions such as deleting a VLAN interface.
Diagnose Link Connectivity
nwmgr --diag
[link]
-A
dest=mac
[--it
number]
[-A
pktsize=bytes]
[-A
timeout=seconds]
-c lanVPPA
[--sc]
nwmgr --diagnose
[link]
--attribute
dest=mac
[--iteration
number]
[--attribute
pktsize=bytes]
[--attribute
timeout=seconds]
--class_instance lanVPPA
[--script]
This command diagnoses link connectivity at the data link layer
by sending IEEE XID test frames to the specified destination
MAC address and counting the replies.
The
--iteration
option specifies the number of test frames to be sent; the default is 1.
The
pktsize
attribute specifies the size in bytes of each test frame; the default is
100.
The
timeout
attribute specifies how many seconds to wait for
the acknowledgement of each test frame; the default is 5 seconds.
RETURN VALUES
- 0
Success.
- <>0
Failure. The command returns values described in
ERRORS
below.
ERRORS
- EACCES
Attempt to set a read-only attribute.
- EBUSY
Interface is presently inaccessible.
- EINVAL
One or more of the attributes or options is invalid for the task.
- EIO
IO error.
- ENOENT
File does not exist.
- ENOMEM
Memory allocation failed.
This could be a transient condition.
- ENOTSUP
Operation or feature is not supported.
- ENXIO
Interface could not be accessed.
- EPERM
User lacks the
hpux.network.config
authorization
required
for this operation.
- ERANGE
Specified values of one or more attributes were lower than the minimum or
greater than the maximum allowed.
- ENODEV
Device or interface not found.
- EEXIST
Device or interface already exists.
EXAMPLES
Help for all VLAN operations in terse mode:
Help for all VLAN operations in verbose mode:
Help for the
get
operation:
Add vlan with
vlanid
10 to
ppa 1:
nwmgr -a -S vlan -A vlanid=10,ppa=1
View attributes of all VLAN interfaces in tabular format:
View attributes of all VLAN interfaces in
name=value
format:
View attributes of all VLAN interfaces in scriptable format:
View attributes of
lan5000
in tabular format:
View attributes of
lan5000
in
name=value
format:
View attributes of
lan5000
in scriptable format:
nwmgr -g -c lan5000 -v --sc
View
vlanid
of
lan5000
in scriptable format:
nwmgr -g -c lan5000 -A vlanid --sc
View statistics of
lan5000
in scriptable format:
nwmgr -g -c lan5000 --st --sc
Set
vlanid
to 20 in
lan5000:
nwmgr -s -c lan5000 -A vlanid=20
Set
vlanid
to 25 in
lan5000
with output in scriptable format:
nwmgr -s -c lan5000 -A vlanid=25 --sc
Save all the attributes of
lan5000
to configuration file:
nwmgr -s -c lan5000 -A all --sa --fr cu
Save all the attributes of all VLAN interfaces on the system
to configuration file:
nwmgr -s -S vlan -A all --sa --fr cu
Delete
lan5000:
Delete
lan5000
from persistent store:
nwmgr -d -S vlan -c lan5000 --sa
Delete all VLAN interfaces
from the persistent store:
Delete
lan5000
with output in scriptable format:
Reset
lan5000:
Reset
lan5000
with output in scriptable format:
Reset/Clear statistics of
lan5000:
Reset/Clear statistics of
lan5000
with output in scriptable format:
nwmgr -r -c lan5000 --st --sc
Perform Critical Resource Analysis (CRA) of
lan5000:
Perform Critical Resource Analysis (CRA) of
lan5000
with output in scriptable format:
nwmgr --cra -c lan5000 --sc
Check connectivity between
lan5000
and MAC address
0xaabbccddeeff:
nwmgr --diag -c lan5000 -A dest=0xaabbccddeeff
COMPARISON WITH LANADMIN/LINKLOOP
The following table lists
nwmgr
commands and their equivalent
lanadmin/linkloop
commands.
AUTHOR
nwmgr
was developed by HP.
FILES
- /etc/rc.config.d/vlanconf
Contains the saved (persistent) configuration for vlan interfaces.
- /sbin/rc2.d/S337vlan
Startup script for the vlan driver, which applies the configuration
file to the running system.
It is executed automatically after each reboot,
and can also be executed by the user by providing the argument
start.