|HP-UX Reference > N
nwmgr(1M)HP-UX 11i Version 3: February 2007
nwmgr — network interface management command for LAN and RDMA interfaces
/usr/sbin/nwmgr [-h|--help |-?] [operation] [target] [operation-qualifiers] [target-qualifiers]
The nwmgr program is the unified command to administer all HP-UX LAN and RDMA interfaces.
This manpage describes command features that can be supported by nwmgr. However, each network interface driver (commonly referred to as a subsystem) might support a subset of these features. You can obtain information about features supported by a specific subsytem from the subsystem's individual manpage, named nwmgr_<subsystem>(1M).
To see the list of subsystems supported by nwmgr on the system, enter:
nwmgr -h -S all
You can use the nwmgr command on LAN or RDMA interfaces to:
All the operations other than display require the hpux.network.config authorization. For more information about authorizations and Role-Based Access Control, see rbac(5).
The nwmgr output for every operation is either in human-readable form (the default output form) or in a script-friendly parsable form (with the --sc or --script option). The format for human-readable and script-friendly output is described in the USAGE section below. Any change in the scriptable output across releases will contain only additions, never modifications or deletions, to ensure backward compatibility. The human-readable format can change across releases, including modifications and deletions.
The command usage is explained in greater detail below. The output format that is described is the human-readable one; references to the scriptable output are made as necessary.
The lanadmin, lanscan, and linkloop commands are deprecated. These commands will be removed in a future HP-UX release. HP recommends the use of replacement command nwmgr(1M) to perform all network interface-related tasks.
Structure of nwmgr Command Line
A nwmgr command line may contain the following options:
It is possible to specify multiple targets, target-qualifiers and operation-qualifiers in the same command line. In addition, you can also specify multiple arguments for these command options (when applicable) on a single command line. The target, target-qualifier, and operation-qualifier can appear in any order, but must follow the operation.
An operation is a key part of the command line. An operation is a way to specify how a subsystem has to be managed. The operation, if specified, must always be the first argument in the command line. The --get operation (to get/display interface information) is the default, when no operation option is specified.
The following operations are available:
The target is the object on which an operation is performed. You must specify a target for all operations except for --get and --help operations. The choice to support multiple targets in a command is subsystem specific.
The following target options are supported:
Operation qualifier is used to specify additional information to complete the requested operation.
The following operational qualifier options are supported:
The target qualifier provides additional information on the object(s) the operation will act on.
The following target qualifier options are supported:
The nwmgr command without any arguments displays all the network interfaces in the system, including physical LAN interfaces (NICs), virtual LAN interfaces (VLANs and APA aggregates and failover groups), and RDMA interfaces.
Use one of the following to view basic properties of one or more interfaces:
The human-readable form displays a table, with one row for each interface. If an interface is specified as a target with the -c option, only that interface is displayed. If the -S option is specified, all interfaces for the subsystem are displayed.
# nwmgr --get Name/ Interface Station Sub- Interface Related ClassInstance State Address system Type Interface ============== ========= ============== ======== ============== ========= lan0 UP 0x00306EF4E07C igelan 1000Base-T lan1 UP 0x000F202B92D4 igelan 1000Base-T lan2 UP 0x0010837BDE00 btlan 100Base-TX
The parsable (script-friendly) output contains the same data as the readable output for each subsystem. The format consists of four columns delimited with a number sign (#).
# nwmgr --get --script lan0#subsystem#current#igelan lan0#if_type#current#1000Base-T lan1#if_state#current#UP lan1#mac#current#0x000F202B92D4 lan1#subsystem#current#igelan lan1#if_type#current#1000Base-T lan2#if_state#current#UP lan2#mac#current#0x0010837BDE00 lan2#subsystem#current#btlan lan2#if_type#current#100Base-TX lan3#if_state#current#DOWN
Interface listing displays the following information about the LAN or RDMA device that has software support on the system:
Note that the --get operation is the default; you do not need to specify the -g option.
Use one of the following commands to view help for nwmgr or subsystem specific usage.
When used with -S all, it displays the list of subsystems supported by nwmgr.
All other features are subsystem specific. You can obtain information about features supported by a specific subsytem from the subsystem specific manpages, using the nwmgr_<subsystem>(1M) name format.
On success, nwmgr returns 0.
On failure, it returns one of the values described in the ERRORS section.
If nwmgr fails, it returns one of the following errors. The values of the error codes are described in <sys/errno.h>.
List all LAN and RDMA interfaces in the system:
Display usage information for nwmgr command:
Display the list of subsystems:
nwmgr --help -S all
Display subsystem specific usage:
nwmgr --help -S subsystem
nwmgr_btlan(1M), nwmgr_intl100(1M), nwmgr_vlan(1M), rbac(5).
Other subsystem manpages are available if the driver is installed on your system. See nwmgr_<subsystem>(1M).