Jump to content United States-English
HP.com Home Products and Services Support and Drivers Solutions How to Buy
» Contact HP
More options
HP.com home
HP-UX Reference > M

mount_nfs(1M)

HP-UX 11i Version 3: February 2007
» 

Technical documentation

» Feedback
Content starts here

 » Table of Contents

 » Index

NAME

mount_nfs: mount, umount — mount and unmount remote NFS resources

SYNOPSIS

/sbin/fs/nfs/mount [-F nfs | nfs3] [-drqOV] [-o specific_options] resource mount_point

/sbin/fs/nfs/umount -a [-df]

/sbin/fs/nfs/umount [-df] {resource|mount_point}

DESCRIPTION

The mount utility attaches a named resource to the file system hierarchy at the pathname location mount_point, which must already exist. If mount_point has any contents prior to the mount operation, the contents remain hidden until the resource is once again unmounted.

Only a superuser can mount file systems.

The umount utility unmounts mounted file systems.

Only a superuser can unmount file systems.

resource can be of the form:

host:pathname

Where host can be the name of the NFS server host, or an IPv4 or IPv6 address string. As IPv6 addresses already contain colons, enclose host in a pair of square brackets when specifying an IPv6 address string. Otherwise, the first occurrence of a colon can be interpreted as the separator between the host name and path; for example:

[1080::8:800:200C:417A]:tmp/file.

See IPv6(7P).

pathname is the path name of the directory on the server being mounted. The path name is interpreted according to the server's path name parsing rules and is not necessarily slash-separated, though on most servers, this is the case.

nfs://host[:port]/pathname

This is an NFS URL and follows the standard convention for NFS URL as described in NFS URL, RFC 2224. See the discussion of URL's and the public option under section NFS FILE SYSTEMS below for a more detailed discussion.

A comma-separated list of:

nfs://host[:port]/pathname or host:pathname. See the discussion on Replicated File Systems and Failover under NFS FILE SYSTEMS for a more detailed discussion.

A comma-separated list of:

hosts followed by a :pathname suffix. See the discussion on Replicated File Systems and Failover under NFS FILE SYSTEMS for a more detailed discussion.

Options (mount)

See mount(1M) for the description of the -rFV options. Note that the -F option only accepts either nfs or nfs3. nfs3 forces the use of NFSv3 unless the vers= option is used.

-d

Print debug messages to stderr. This option is to be used by HP support engineers.

-o specific_options

Set file system specific options according to a comma-separated list with no intervening spaces.

acdirmax=n

Hold cached attributes for no more than n seconds after directory update. The default value is 60.

acdirmin=n

Hold cached attributes for at least n seconds after directory update. The default value is 30.

acregmax=n

Hold cached attributes for no more than n seconds after file modification. The default value is 60.

acregmin=n

Hold cached attributes for at least n seconds after file modification. The default value is 3.

actimeo=n

Set min and max times for regular files and directories to n seconds. actimeo has no default; it sets cregmin, acregmax, acdirmin, and acdirmax to the value specified.

bg|fg

If the first attempt fails, retry in the background, or, in the foreground. The default is fg.

forcedirectio|noforcedirectio

If forcedirectio is specified, then for the duration of the mount, forced direct I/O is used. If the file system is mounted using forcedirectio, data is transferred directly between client and server, with no buffering on the client. If the file system is mounted using noforcedirectio, data is buffered on the client. forcedirectio is a performance option that is of benefit only in large sequential data transfers. The default behavior is noforcedirectio.

grpid

By default, the GID associated with a newly created file obeys the System V semantics; that is, the GID is set to the effective GID of the calling process. This behavior can be overridden on a per-directory basis by setting the set-GID bit of the parent directory; in this case, the GID of a newly created file is set to the GID of the parent directory (see open(2) and mkdir(2)). Files created on file systems that are mounted with the grpid option will obey BSD semantics independent of whether the set-GID bit of the parent directory is set; that is, the GID is unconditionally inherited from that of the parent directory.

hard|soft

Continue to retry requests until the server responds (hard) or give up and return an error (soft). The default value is hard.

intr|nointr

Allow (do not allow) keyboard interrupts to kill a process that is hung while waiting for a response on a hard-mounted file system. The default is intr, which makes it possible for clients to interrupt applications that can be waiting for a remote mount.

llock

By default, lock/unlock requests are sent to the server's rpc.lockd which enforces the requests. With this option set, the lock/unlock requests are not sent to the remote rpc.lockd and are enforced locally. These local locks are enforced much faster, but if other NFS clients access the same data on the server, there is a risk of data corruption. Consequently, this option must be used when only one NFS client accesses the data on the server.

noac

Suppress data and attribute caching. The data caching that is suppressed is the write-behind. The local page cache is still maintained, but data copied into it is immediately written to the server.

nocto

Do not perform the normal close-to-open consistency. When a file is closed, all modified data associated with the file is flushed to the server and not held on the client. When a file is opened the client sends a request to the server to validate the client's local caches. This behavior ensures a file's consistency across multiple NFS clients. When -nocto is in effect, the client does not perform the flush on close and the request for validation, allowing the possiblity of differences among copies of the same file as stored on multiple clients.

This option can be used where it can be guaranteed that accesses to a specified file system are made from only one client and only that client. Under such a condition, the effect of -nocto can be a slight performance gain.

port=n

The server IP port number. The default is NFS_PORT. If the port option is specified, and if the resource includes one or more NFS URLs, and if any of the URLs include a port number, then the port number in the option and in the URL must be the same.

posix

Request POSIX.1 semantics for the file system. Requires a mount Version 2 mountd(1M) on the server.

proto=netid

netid is a value of network_id field from entry in the /etc/netconfig file. By default, the transport protocol used for the NFS mount will be first available connection-oriented transport supported on both the client and the server. If no connection-oriented transport is found, then the first available connectionless transport is used. This default behavior can be overridden with the proto=netid option.

public

The public option forces the use of the public file handle when connecting to the NFS server. The resource specified might not have an NFS URL. See the discussion on URL's and the public Option under NFS FILE SYSTEMS for a more detailed discussion.

quota|noquota

Enable or prevent quota(1) to check whether the user is over quota on this file system; if the file system has quotas enabled on the server, quotas are still checked for operations on this file system.

remount

Remounts a read-only file system as read-write (using the rw option).

retrans=n

Set the number of NFS retransmissions to n. The default value is 5. For connection-oriented transports, this option has no effect because it is assumed that the transport performs retransmissions on behalf of NFS.

retry=n

The number of times to retry the mount operation. The default for the mount command is 1.

rw|ro

resource is mounted read-write or read-only. The default is rw.

rsize=n

Set the read buffer size to n bytes. The default value is 32768 when using Version 3 of the NFS protocol. The default can be negotiated down if the server prefers a smaller transfer size. When using Version 2, the default value is 8192.

sec=mode

Set the security mode for NFS transactions. If sec= is not specified, then the default action is to use AUTH_SYS over NFS Version 2 mounts, or to negotiate a mode over NFS Version 3 mounts. NFS Version 3 mounts negotiate a security mode when the server returns an array of security modes. The client picks the first mode in the array that is supported on the client. Only one mode can be specified with the sec= option. See nfssec(5) for the available mode options.

secure

This option is equivalent to sec=dh.

suid|nosuid

Setuid execution allowed or disallowed. The default is suid.

timeo=n

Set the NFS timeout to n tenths of a second. The default value is 11 tenths of a second for connectionless transports, and 600 tenths of a second for connection-oriented transports.

vers=NFS_version_number

By default, the version of NFS protocol used between the client and the server is the highest one available on both systems. If the NFS server does not support NFS Version 3 protocol, then the NFS mount will use NFS Version 2 protocol.

wsize=n

Set the write buffer size to n bytes. The default value is 32768 when using Version 3 of the NFS protocol. The default can be negotiated down if the server prefers a smaller transfer size. When using Version 2, the default value is 8192.

-q

When processing an unknown specific_option, the mount utility prints a warning message and processes the next one. This option prevents printing the warning message.

-O

Overlay mount. Allow the file system to be mounted over an existing mount point, making the underlying file system inaccessible. If a mount is attempted on a pre-existing mount point without setting this flag, the mount will fail, producing the error device busy.

Options (umount)

-a

Attempt to unmount all NFS file systems described in /etc/mnttab.

-d

Print debug messages to stderr. This option is to be used by HP support engineers.

-f

Forcibly unmount a file system. Without this option, the umount utility does not allow a file system to be unmounted if a file on the file system is busy. Using this option can cause data loss for open files; programs which access files after the file system has been unmounted will get an error (EIO).

NFS FILE SYSTEMS

Background versus Foreground

File systems mounted with the bg option indicate that mount is to retry in the background if the server's mount daemon does not respond. See mountd(1M). mount retries the request up to the count specified in the retry=n option. Once the file system is mounted, each NFS request made in the kernel waits timeo=n tenths of a second for a response. If no response arrives, the time-out is multiplied by 2 and the request is retransmitted. When the number of retransmissions has reached the number specified in the retrans=n option, a file system mounted with the soft option returns an error on the request; one mounted with the hard option prints a warning message and continues to retry the request.

Hard versus Soft

File systems that are mounted read-write or that contain executable files should always be mounted with the hard option. Applications using soft mounted file systems can incur unexpected I/O errors, file corruption, unexpected program core dumps, and delays in system reboot/shutdown. The soft option is not recommended.

Authenticated requests

The server can require authenticated NFS requests from the client. sec=dh authentication might be required. See nfssec(5).

URLs and the public Option

If the public option is specified, or if the resource includes an NFS URL, mount attempts to connect to the server using the public file handle lookup protocol. See WebNFS Client Specification, RFC 2054. If the server supports the public file handle, the attempt is successful; mount does not need to contact the server's rpcbind(1M) and the mountd(1M) daemons to get the port number of the mount server and the initial file handle of pathname, respectively. If the NFS client and server are separated by a firewall that allows all outbound connections through specific ports, such as NFS_PORT, then this enables NFS operations through the firewall. The public option and the NFS URL can be specified independently or together. They interact as specified in the following matrix:

 resource style
 host:pathnameNFS URL
public optionForce public file handle and fail mount if not supported. Use Native paths.Force public file handle and fail mount if not supported. Use Canonical paths.
defaultUse MOUNT protocol.Try public file handle with Canonical paths. Fall back to MOUNT protocol if not supported.

A Native path is a path name that is interpreted according to conventions used on the native operating system of the NFS server. A Canonical path is a path name that is interpreted according to the URL rules. See Uniform Resource Locators (URL), RFC 1738. See EXAMPLES for uses of Native and Canonical paths.

Replicated File Systems and Failover

resource can list multiple read-only file systems to be used to provide data. These file systems should contain equivalent directory structures and identical files. It is also recommended that they be created by a utility such as rdist(1). The file systems can be specified either with a comma-separated list of host:/pathname entries and/or NFS URL entries, or with a comma -separated list of hosts, if all file system names are the same. If multiple file systems are named and the first server in the list is down, failover uses the next alternate server to access files. If the read-only option is not chosen, mount fails. Note that the llock option is always used for replicated servers.

File Attributes

To improve NFS read performance, files and file attributes are cached. File modification times get updated whenever a write occurs. However, file access times can be temporarily out-of-date until the cache gets refreshed.

The attribute cache retains file attributes on the client. Attributes for a file are assigned a time to be flushed. If the file is modified before the flush time, then the flush time is extended by the time since the last modification (under the assumption that files that changed recently are likely to change soon). There is a minimum and maximum flush time extension for regular files and for directories. Setting actimeo=n sets flush time to n seconds for both regular files and directories.

Setting actimeo=0 disables attribute caching on the client. This means that every reference to attributes is satisfied directly from the server though file data is still cached. While this guarantees that the client always has the latest file attributes from the server, it has an adverse effect on performance through additional latency, network load, and server load.

Setting the noac option also disables attribute caching, but has the further effect of disabling client write caching. While this guarantees that data written by an application is written directly to a server, where it can be viewed immediately by other clients, it has a significant adverse effect on client write performance. Data written into memory-mapped file pages are not written directly to this server. See mmap(2).

ERRORS

If ECONFIG is returned, mount_nfs has reached the process thread limit. Increase the value of nkthread. See nkthread(5) for more details.

EXAMPLES

Example 1: Mounting an NFS File System

To mount an NFS file system:

mount serv:/usr/src /usr/src

Example 2: Mounting NFS File System Read-Only With No suid Privileges

To mount an NFS file system read-only with no suid privileges:

mount -r -o nosuid serv:/usr/src /usr/src

Example 3: Mounting NFS File System Over V2, with the UDP Transport

To mount an NFS file system over Version 2, with the UDP transport:

mount -o vers=2,proto=udp serv:/usr/src /usr/src

Example 4: Mounting NFS File System Using An NFS URL

To mount an NFS file system using an NFS URL (a canonical path):

mount nfs://serv/usr/man /usr/man

Example 5: Mounting With Forcing Use Of The Public File Handle

To mount an NFS file system and force the use of the public file handle and an NFS URL (a canonical path) that has a non 7-bit ASCII escape sequence:

mount -o public nfs://serv/usr/%A0abc /mnt/test

Example 6: Mounting an NFS File System Using a Native Path

To mount an NFS file system using a native path (where the server uses colons (:) as the component separator) and the public file handle:

mount -o public serv:C:doc:new /usr/doc

Example 7: Mounting a Replicated Set with Same Pathnames

To mount a replicated set of NFS file systems with the same pathnames:

mount -r serv-a,serv-b,serv-c:/usr/man /usr/man

Example 8: Mounting a Replicated Set with Different Pathnames

To mount a replicated set of NFS file systems with different pathnames:

mount -r srv-x:/usr/man,srv-y:/var/man,nfs://srv-z/man /usr/man

WARNINGS

If the directory on which a file system is to be mounted is a symbolic link, the file system is mounted on the directory to which the symbolic link refers, rather than being mounted on top of the symbolic link itself.

FILES

/etc/mnttab

Table of mounted file systems

/etc/dfs/fstypes

Default distributed file system type

/etc/fstab

Table of automatically mounted resources

SEE ALSO

quota(1), rdist(1), fstyp(1M), lockd(1M), mountall(1M), mountd(1M), statd(1M), mkdir(2), mmap(2), mount(2), open(2), umount(2), mnttab(4), nfssec(5), quota(5), inet(7F), IPv6(7P).

Callaghan, Brent, WebNFS Client Specification, RFC 2054, October 1996.

Callaghan, Brent, NFS URL Scheme, RFC 2224, October 1997.

Berners-Lee, Masinter & McCahill , Uniform Resource Locators, RFC 1738, December 1994.

Printable version
Privacy statement Using this site means you accept its terms Feedback to webmaster
© 1983-2007 Hewlett-Packard Development Company, L.P.