|
Use the commands in this chapter to configure and monitor Routing Information Protocol (RIP). For RIP configuration information and examples, refer to the "Configuring RIP" chapter of the Network Protocols Configuration Guide, Part 1.
To restore the default behavior of automatic summarization of subnet routes into network-level routes, use the auto-summary router configuration command. To disable this feature and transmit subprefix routing information across classful network boundaries, use the no form of this command.
auto-summaryThis command has no arguments or keywords.
Enabled (the software summarizes subprefixes to the classful network boundary when crossing classful network boundaries).
Router configuration
This command first appeared in Cisco IOS Release 10.0.
Route summarization reduces the amount of routing information in the routing tables.
In the following example, network numbers are not summarized automatically:
router rip
version 2
no auto-summary
To generate a default route into RIP, use the default-information originate router configuration command. To disable this feature, use the no form of this command.
default-information originate [route-map mapname]
route-map mapname | (Optional) Routing process will generate the default route if the route map is satisfied. |
Disabled
Router configuration
This command first appeared in Cisco IOS Release 11.1.
The following example originates a default route (0.0.0.0/0) over a certain interface when 172.68.0.0/16 is present. This is called "conditional default origination."
router rip
version 2
network 172.68.16.0
default-information originate route-map condition
!
route-map condition permit 10
match ip address 10
set interface s1/0
!
access-list 10 permit 172.68.16.0 0.0.0.255
!
To set default metric values for RIP, use this form of the default-metric router configuration command. To return to the default state, use the no form of this command.
default-metric number
number | Default metric value. |
Built-in, automatic metric translations, as appropriate for each routing protocol
Router configuration
This command first appeared in Cisco IOS Release 10.0.
The default-metric command is used in conjunction with the redistribute router configuration command to cause the current routing protocol to use the same metric value for all redistributed routes. A default metric helps solve the problem of redistributing routes with incompatible metrics. Whenever metrics do not convert, using a default metric provides a reasonable substitute and enables the redistribution to proceed.
The following example shows a router in autonomous system 109 using both the RIP and the OSPF routing protocols. The example advertises OSPF-derived routes using the RIP protocol and assigns the OSPF-derived routes a RIP metric of 10.
router rip
default-metric 10
redistribute ospf 109
You can use the master indexes or search online to find documentation of related commands.
redistribute
depth | Numerical value associated with the depth of the RIP input queue. The larger the numerical value, the larger the depth of the queue. The range is 0 to 1024. |
50
Router configuration
This command first appeared in Cisco IOS Release 11.0.
Consider using the input-queue command if you have a high-end router sending at high speed to a low-speed router that might not be able to receive at the high speed. Configuring this command will help prevent the routing table from losing information.
The following example sets the depth of the RIP input queue to 100:
input-queue 100
You can use the master indexes or search online to find documentation of related commands.
output-delay
name-of-chain | Enables authentication and specifies the group of keys that are valid. |
No authentication is provided for RIP packets.
Interface configuration
This command first appeared in Cisco IOS Release 11.1.
If no key chain is configured with the key-chain command, no authentication is performed on the interface (not even the default authentication).
The following example configures the interface to accept and send any key belonging to the key chain named trees:
ip rip authentication key-chain trees
You can use the master indexes or search online to find documentation of related commands.
key chain
To specify the type of authentication used in RIP Version 2 packets, use the ip rip authentication mode interface configuration command. Use the no form of this command to restore clear text authentication.
ip rip authentication mode {text | md5}
text | Clear text authentication. |
md5 | Keyed MD5 authentication. |
Clear text authentication is provided for RIP packets.
Interface configuration
This command first appeared in Cisco IOS Release 11.1.
RIP Version 1 does not support authentication.
The following example configures the interface to use MD5 authentication:
ip rip authentication mode md5
You can use the master indexes or search online to find documentation of related commands.
ip rip authentication key-chain
key chain
To specify a RIP version to receive on an interface basis, use the ip rip receive version interface configuration command. Use the no form of this command to follow the global version rules.
ip rip receive version [1] [2]
1 | (Optional) Accepts only RIP Version 1 packets on the interface. |
2 | (Optional) Accepts only RIP Version 2 packets on the interface. |
The software behaves according to the version command.
Interface configuration
This command first appeared in Cisco IOS Release 11.1.
Use this command to override the default behavior of RIP as specified by the version command. This command applies only to the interface being configured. You can configure the interface to accept both RIP versions.
The following example configures the interface to receive both RIP Version 1 and Version 2 packets:
ip rip receive version 1 2
The following example configures the interface to receive only RIP Version 1 packets:
ip rip receive version 1
You can use the master indexes or search online to find documentation of related commands.
To specify a RIP version to send on an interface basis, use the ip rip send version interface configuration command. Use the no form of this command to follow the global version rules.
ip rip send version [1] [2]
1 | (Optional) Sends only RIP Version 1 packets out the interface. |
2 | (Optional) Sends only RIP Version 2 packets out the interface. |
The software behaves according to the router version command.
Interface configuration
This command first appeared in Cisco IOS Release 11.1.
Use this command to override the default behavior of RIP as specified by the router version command. This command applies only to the interface being configured.
The following example configures the interface to send both RIP Version 1 and Version 2 packets out the interface:
ip rip send version 1 2
The following example configures the interface to send only RIP Version 2 packets out the interface:
ip rip send version 2
You can use the master indexes or search online to find documentation of related commands.
To enable the split horizon mechanism, use the ip split-horizon interface configuration command. To disable the split horizon mechanism, use the no form of this command.
ip split-horizonThis command has no arguments or keywords.
Varies with media
Interface configuration
This command first appeared in Cisco IOS Release 10.0.
For all interfaces except those for which either Frame Relay or SMDS encapsulation is enabled, the default condition for this command is ip split-horizon; in other words, the split horizon feature is active. If the interface configuration includes either the encapsulation frame-relay or encapsulation smds commands, then the default is for split horizon to be disabled. Split horizon is not disabled by default for interfaces using any of the X.25 encapsulations.
If split horizon has been disabled on an interface and you wish to enable it, use the ip split-horizon command to restore the split horizon mechanism.
The following simple example disables split horizon on a serial link. The serial link is connected to an X.25 network:
interface serial 0
encapsulation x25
no ip split-horizon
You can use the master indexes or search online to find documentation of related commands.
neighbor
To define a neighboring router with which to exchange routing information, use this form of the neighbor router configuration command. To remove an entry, use the no form of this command.
neighbor ip-address
ip-address | IP address of a peer router with which routing information will be exchanged. |
No neighboring routers are defined.
Router configuration
This command first appeared in Cisco IOS Release 10.0.
This command permits the point-to-point (nonbroadcast) exchange of routing information. When used in combination with the passive-interface router configuration command, routing information can be exchanged between a subset of routers and access servers on a LAN.
Multiple neighbor commands can be used to specify additional neighbors or peers.
In the following example, RIP updates are sent to all interfaces on network 131.108.0.0 except interface Ethernet 1. However, in this case a neighbor router configuration command is included. This command permits the sending of routing updates to specific neighbors. One copy of the routing update is generated per neighbor.
router rip
network 131.108.0.0
passive-interface ethernet 1
neighbor 131.108.20.4
You can use the master indexes or search online to find documentation of related commands.
passive-interface
To specify a list of networks for the Routing Information Protocol (RIP) routing process, use this form of the network router configuration command. To remove an entry, use the no form of this command.
network network-number
network-number | IP address of the network of directly connected networks. |
No networks are specified.
Router configuration
This command first appeared in Cisco IOS Release 10.0.
The network number specified must not contain any subnet information.There is no limit to the number of network commands used on the router. RIP routing updates will be sent and received only through interfaces on this network.
RIP sends updates to the interfaces in the specified networks. Also, if an interface's network is not specified, it will not be advertised in any RIP update.
The following example defines RIP as the routing protocol to be used on all interfaces connected to networks 128.99.0.0 and 192.31.7.0:
router rip
network 128.99.0.0
network 192.31.7.0
You can use the master indexes or search online to find documentation of related commands.
To add an offset to incoming and outgoing metrics to routes learned via RIP, use the offset-list router configuration command. To remove an offset list, use the no form of this command.
offset-list {access-list-number | name} {in | out} offset [type number]
access-list-number | name | Standard access list number or name to be applied. Access list number 0 indicates all access lists. If offset is 0, no action is taken. For IGRP, the offset is added to the delay component only. |
in | Applies the access list to incoming metrics. |
out | Applies the access list to outgoing metrics. |
offset | Positive offset to be applied to metrics for networks matching the access list. If the offset is 0, no action is taken. |
type | (Optional) Interface type to which the offset-list is applied. |
number | (Optional) Interface number to which the offset-list is applied. |
Disabled
Router configuration
This command first appeared in Cisco IOS Release 10.0. The type and number arguments first appeared in Cisco IOS Release 10.3. The name argument first appeared in Cisco IOS Release 11.2.
The offset value is added to the routing metric. An offset-list with an interface type and interface number is considered extended and takes precedence over an offset-list that is not extended. Therefore, if an entry passes the extended offset-list and the normal offset-list, the extended offset-list's offset is added to the metric.
In the following example, the router applies an offset of 10 to the router's delay component only to access list 21:
offset-list 21 out 10
In the following example, the router applies an offset of 10 to routes learned from Ethernet interface 0:
offset-list 21 in 10 ethernet 0
To change the interpacket delay for RIP updates sent, use the output-delay router configuration command. To remove the delay, use the no form of this command.
output-delay delay
delay | Delay, in milliseconds, between packets in a multiple-packet RIP update. The range is 8 to 50 milliseconds. The default is no delay. |
0 milliseconds
Router configuration
Consider using this command if you have a high-end router sending at high speed to a low-speed router that might not be able to receive at that fast a rate. Configuring this command will help prevent the routing table from losing information.
In the following example, the interpacket delay is set to 10 milliseconds:
output-delay 10
To configure the Routing Information Protocol (RIP) routing process, use the router rip global configuration command. To turn off the RIP routing process, use the no form of this command.
router ripThis command has no arguments or keywords.
No RIP routing process is defined.
Global configuration
This command first appeared in Cisco IOS Release 10.0.
The following example shows how to begin the RIP routing process:
router rip
You can use the master indexes or search online to find documentation of related commands.
To adjust RIP network timers, use the timers basic router configuration command. To restore the default timers, use the no form of this command.
timers basic update invalid holddown flush
update | Rate in seconds at which updates are sent. This is the fundamental timing parameter of the routing protocol. The default is 30 seconds. |
invalid | Interval of time in seconds after which a route is declared invalid; it should be at least three times the value of update. A route becomes invalid when there is an absence of updates that refresh the route. The route then enters holddown. The route is marked inaccessible and advertised as unreachable. However, the route is still used for forwarding packets. The default is 180 seconds. |
holddown | Interval in seconds during which routing information regarding better paths is suppressed. It should be at least three times the value of update. A route enters into a holddown state when an update packet is received that indicates the route is unreachable. The route is marked inaccessible and advertised as unreachable. However, the route is still used for forwarding packets. When holddown expires, routes advertised by other sources are accepted and the route is no longer inaccessible. The default is 180 seconds. |
flush | Amount of time in seconds that must pass before the route is removed from the routing table; the interval specified should be greater than the invalid value. If it is less than this sum, the proper holddown interval cannot elapse, which results in a new route being accepted before the holddown interval expires. The default is 240 seconds. |
update is 30 seconds
invalid is 180 seconds
holddown is 180 seconds
flush is 240 seconds
Router configuration
This command first appeared in Cisco IOS Release 10.0.
The basic timing parameters for RIP are adjustable. Since RIP is executing a distributed, asynchronous routing algorithm, it is important that these timers be the same for all routers and access servers in the network.
In the following example, updates are broadcast every 5 seconds. If a router is not heard from in 15 seconds, the route is declared unusable. Further information is suppressed for an additional 15 seconds. At the end of the suppression period, the route is flushed from the routing table.
router rip
timers basic 5 15 15 30
Note that by setting a short update period, you run the risk of congesting slow-speed serial lines; however, this is not a big concern on faster-speed Ethernets and T1-rate serial lines. Also, if you have many routes in your updates, you can cause the routers to spend an excessive amount of time processing updates.
To have the Cisco IOS software validate the source IP address of incoming routing updates for RIP and IGRP routing protocols, use the validate-update-source router configuration command. To disable this function, use the no form of this command.
validate-update-sourceThis command has no arguments or keywords.
Enabled
Router configuration
This command first appeared in Cisco IOS Release 10.0.
This command is only applicable to RIP and IGRP. The software ensures that the source IP address of incoming routing updates is on the same IP network as one of the addresses defined for the receiving interface.
Disabling split horizon on the incoming interface will also cause the system to perform this validation check.
For unnumbered IP interfaces (interfaces configured as ip unnumbered), no checking is performed.
In the following example, a router is configured to not perform validation checks on the source IP address of incoming RIP updates:
router rip
network 128.105.0.0
no validate-update-source
1 | Specifies RIP Version 1. |
2 | Specifies RIP Version 2. |
The software receives RIP Version 1 and Version 2 packets, but sends only Version 1 packets.
Router configuration
This command first appeared in Cisco IOS Release 11.1.
To specify RIP versions used on an interface basis, use the ip rip receive version and ip rip send version commands.
The following example enables the software to send and receive RIP Version 2 packets:
version 2
You can use the master indexes or search online to find documentation of related commands.
ip rip receive version
ip rip send version
show ip protocols
Posted: Mon Nov 27 20:45:47 PST 2000
Copyright 1989-2000©Cisco Systems Inc.