|
Use the commands in this chapter to configure and monitor Internet Gateway Routing Protocol (IGRP). For IGRP configuration information and examples, refer to the "Configuring IGRP" chapter of the Network Protocols Configuration Guide, Part 1.
To control the candidate default routing information between IGRP or Enhanced IGRP processes, use the default-information router configuration command. To suppress IGRP or Enhanced IGRP candidate information in incoming updates, use the no default-information in command. To suppress IGRP or Enhanced IGRP candidate information in outbound updates, use the no default-information out command.
default-information {in | out} {access-list-number | name}
in | Allows IGRP or Enhanced IGRP exterior or default routes to be received by an IGRP process. |
out | Allows IGRP or Enhanced IGRP exterior routes to be advertised in updates. |
access-list-number | name | Number or name of an access list. It can be a number in the range 1 to 99 or an access list name. |
Normally, exterior routes are always accepted and default information is passed between IGRP or Enhanced IGRP processes when doing redistribution.
Router configuration
This command first appeared in Cisco IOS Release 10.0. The access-list-number and name arguments first appeared in Cisco IOS Release 11.2.
The default network of 0.0.0.0 used by RIP cannot be redistributed by IGRP or Enhanced IGRP.
The following example allows IGRP exterior or default routes to be received by the IGRP process in autonomous system 23:
router igrp 23
default-information in
The following example allows IP Enhanced IGRP exterior or default routes to be received by the IP Enhanced IGRP process in autonomous system 23:
router eigrp 23
default-information in
To set metrics for IGRP or Enhanced IGRP, use this form of the default-metric router configuration command. To remove the metric value and restore the default state, use the no form of this command.
default-metric bandwidth delay reliability loading mtu
bandwidth | Minimum bandwidth of the route in kilobits per second. It can be 0 or any positive integer. |
delay | Route delay in tens of microseconds. It can be 0 or any positive number that is a multiple of 39.1 nanoseconds. |
reliability | Likelihood of successful packet transmission expressed as a number between 0 and 255. The value 255 means 100 percent reliability; 0 means no reliability. |
loading | Effective bandwidth of the route expressed as a number from 0 to 255 (255 is 100 percent loading). |
mtu | Minimum maximum transmission unit (MTU) size of the route in bytes. It can be 0 or any positive integer. |
Only connected routes and interface static routes can be redistributed without a default metric.
Router configuration
This command first appeared in Cisco IOS Release 10.0.
A default metric is required to redistribute a protocol into IGRP or Enhanced IGRP, unless you use the redistribute command. Automatic metric translations occur between IGRP and Enhanced IGRP. You do not need default metrics to redistributed IGRP or Enhanced IGRP into itself.
Metric defaults have been carefully set to work for a wide variety of networks. Take great care in changing these values.
Keeping the same metrics is supported only when redistributing from IGRP, Enhanced IGRP, or static routes.
The following example takes redistributed RIP metrics and translates them into IGRP metrics with values as follows: bandwidth = 1000, delay = 100, reliability = 250, loading = 100, and mtu =1500.
router igrp 109
network 131.108.0.0
redistribute rip
default-metric 1000 100 250 100 1500
You can use the master indexes or search online to find documentation of related commands.
redistribute
To enable the split horizon mechanism, use the ip split-horizon interface configuration command. To disable the split horizon mechanism, use the no form of this command.
ip split-horizonThis command has no arguments or keywords.
Varies with media
Interface configuration
This command first appeared in Cisco IOS Release 10.0.
For all interfaces except those for which either Frame Relay or SMDS encapsulation is enabled, the default condition for this command is ip split-horizon; in other words, the split horizon feature is active. If the interface configuration includes either the encapsulation frame-relay or encapsulation smds commands, then the default is for split horizon to be disabled. Split horizon is not disabled by default for interfaces using any of the X.25 encapsulations.
If split horizon has been disabled on an interface and you wish to enable it, use the ip split-horizon command to restore the split horizon mechanism.
The following simple example disables split horizon on a serial link. The serial link is connected to an X.25 network:
interface serial 0
encapsulation x25
no ip split-horizon
You can use the master indexes or search online to find documentation of related commands.
neighbor
To keep new IGRP routing information from being used for a certain period of time, use the metric holddown router configuration command. To disable this feature, use the no form of this command.
metric holddownThis command has no arguments or keywords.
Disabled
Router configuration
This command first appeared in Cisco IOS Release 10.0.
Holddown keeps new routing information from being used for a certain period of time. This can prevent routing loops caused by slow convergence. It is sometimes advantageous to disable holddown to increase the network's ability to quickly respond to topology changes; this command provides this function.
Use the metric holddown command if other routers or access servers within the IGRP autonomous system are not configured with no metric holddown. If all routers are not configured the same way, you increase the possibility of routing loops.
The following example disables metric holddown:
router igrp 15
network 131.108.0.0
network 192.31.7.0
no metric holddown
You can use the master indexes or search online to find documentation of related commands.
metric maximum-hops
metric weights
timers basic
To have the IP routing software to advertise as unreachable those routes with a hop count higher than is specified by the command (IGRP only), use the metric maximum-hops router configuration command. To reset the value to the default, use the no form of this command.
metric maximum-hops hops
hops | Maximum hop count (in decimal). The default value is 100 hops; the maximum number of hops that can be specified is 255. |
100 hops
Router configuration
This command first appeared in Cisco IOS Release 10.0.
This command provides a safety mechanism that breaks any potential count-to-infinity problems. It causes the IP routing software to advertise as unreachable routes with a hop count greater than the value assigned to the hops argument.
In the following example, a router in autonomous system 71 attached to network 15.0.0.0 wants a maximum hop count of 200, doubling the default. The network administrators decided to do this because they have a complex WAN that can generate a large hop count under normal (nonlooping) operations.
router igrp 71
network 15.0.0.0
metric maximum-hops 200
You can use the master indexes or search online to find documentation of related commands.
To allow the tuning of the IGRP or Enhanced IGRP metric calculations, use the metric weights router configuration command. To reset the values to their defaults, use the no form of this command.
metric weights tos k1 k2 k3 k4 k5
tos | Type of service. Currently, it must always be zero. |
k1-k5 | Constants that convert an IGRP or Enhanced IGRP metric vector into a scalar quantity. |
tos: 0
k1: 1
k2: 0
k3: 1
k4: 0
k5: 0
Router configuration
This command first appeared in Cisco IOS Release 10.0.
Use this command to alter the default behavior of IGRP routing and metric computation and allow the tuning of the IGRP metric calculation for a particular type of service (TOS).
If k5 equals 0, the composite IGRP or enhanced IGRP metric is computed according to the following formula:
metric = [k1 * bandwidth + (k2 * bandwidth)/(256 - load) + k3 * delay]
If k5 does not equal zero, an additional operation is done:
metric = metric * [k5 / (reliability + k4)]
Bandwidth is inverse minimum bandwidth of the path in bits per second scaled by a factor of 2.56 ¥ 1012. The range is from a 1200-bps line to 10 terabits per second.
Delay is in units of 10 microseconds. This gives a range of 10 microseconds to 168 seconds. A delay of all ones indicates that the network is unreachable.
The delay parameter is stored in a 32-bit field, in increments of 39.1 nanoseconds. This gives a range of 1 (39.1 nanoseconds) to hexadecimal FFFFFFFF (decimal 4,294,967,040 nanoseconds). A delay of all ones (that is, a delay of hexadecimal FFFFFFFF) indicates that the network is unreachable.
Table 25 lists the default values used for several common media.
Media Type | Delay | Bandwidth |
---|---|---|
Satellite | 5120 (2 seconds) | 5120 (500 Mbits) |
Ethernet | 25600 (1 ms) | 256000 (10 Mbits) |
1.544 Mbps | 512000 (20,000 ms) | 1,657,856 bits |
64 kbps | 512000 (20,000 ms) | 40,000,000 bits |
56 kbps | 512000 (20,000 ms) | 45,714,176 bits |
10 kbps | 512000 (20,000 ms) | 256,000,000 bits |
1 kbps | 512000 (20,000 ms) | 2,560,000,000 bits |
Reliability is given as a fraction of 255. That is, 255 is 100 percent reliability or a perfectly stable link.
Load is given as a fraction of 255. A load of 255 indicates a completely saturated link.
The following example sets the metric weights to slightly different values than the defaults:
router igrp 109
network 131.108.0.0
metric weights 0 2 0 2 0 0
You can use the master indexes or search online to find documentation of related commands.
bandwidth
delay
metric holddown
metric maximum-hops
To define a neighboring router with which to exchange routing information, use this form of the neighbor router configuration command. To remove an entry, use the no form of this command.
neighbor ip-address
ip-address | IP address of a peer router with which routing information will be exchanged. |
No neighboring routers are defined.
Router configuration
This command first appeared in Cisco IOS Release 10.0.
This command permits the point-to-point (nonbroadcast) exchange of routing information. When used in combination with the passive-interface router configuration command, routing information can be exchanged between a subset of routers and access servers on a LAN.
Multiple neighbor commands can be used to specify additional neighbors or peers.
In the following example, IGRP updates are sent to all interfaces on network 131.108.0.0 except interface Ethernet 1. However, in this case a neighbor router configuration command is included. This command permits the sending of routing updates to specific neighbors. One copy of the routing update is generated per neighbor.
router igrp 109
network 131.108.0.0
passive-interface ethernet 1
neighbor 131.108.20.4
You can use the master indexes or search online to find documentation of related commands.
passive-interface
To specify a list of networks for the Enhanced IGRP routing process, use this form of the network router configuration command. To remove an entry, use the no form of this command.
network network-number
network-number | IP address of the directly connected networks. |
No networks are specified.
Router configuration
This command first appeared in Cisco IOS Release 10.0.
The network number specified must not contain any subnet information. There is no limit to the number of network commands you can use on the router.
IGRP or Enhanced IGRP sends updates to the interfaces in the specified network(s). Also, if an interface's network is not specified, it will not be advertised in any IGRP or Enhanced IGRP update.
The following example configures a router for IGRP and assigns autonomous system 109. The network commands indicate the networks directly connected to the router.
router igrp 109
network 131.108.0.0
network 192.31.7.0
You can use the master indexes or search online to find documentation of related commands.
To add an offset to incoming and outgoing metrics to routes learned via IGRP, use the offset-list router configuration command. To remove an offset list, use the no form of this command.
offset-list {access-list-number | name} {in | out} offset [type number]
access-list-number | name | Standard access list number or name to be applied. Access list number 0 indicates all access lists. If offset is 0, no action is taken. For IGRP, the offset is added to the delay component only. |
in | Applies the access list to incoming metrics. |
out | Applies the access list to outgoing metrics. |
offset | Positive offset to be applied to metrics for networks matching the access list. If the offset is 0, no action is taken. |
type | (Optional) Interface type to which the offset-list is applied. |
number | (Optional) Interface number to which the offset-list is applied. |
Disabled
Router configuration
This command first appeared in Cisco IOS Release 10.0. The type and number arguments first appeared in Cisco IOS Release 10.3. The name argument first appeared in Cisco IOS Release 11.2.
The offset value is added to the routing metric. An offset-list with an interface type and interface number is considered extended and takes precedence over an offset-list that is not extended. Therefore, if an entry passes the extended offset-list and the normal offset-list, the extended offset-list's offset is added to the metric.
In the following example, the router applies an offset of 10 to the router's delay component only to access list 121:
offset-list 21 out 10
In the following example, the router applies an offset of 10 to routes learned from Ethernet interface 0:
offset-list 21 in 10 ethernet 0
To configure the Interior Gateway Routing Protocol (IGRP) routing process, use the router igrp global configuration command. To shut down an IGRP routing process, use the no form of this command.
router igrp autonomous-system
autonomous-system | Autonomous system number that identifies the routes to the other IGRP routers. It is also used to tag the routing information. |
No IGRP routing process is defined.
Global configuration
This command first appeared in Cisco IOS Release 10.0.
It is not necessary to have a registered autonomous system number to use IGRP. If you do not have a registered number, you are free to create your own. We recommend that if you do have a registered number, you use it to identify the IGRP process.
The following example configures an IGRP routing process and assign process number 109:
router igrp 109
You can use the master indexes or search online to find documentation of related commands.
network (IGRP and Enhanced IGRP)
To set the metric value for IGRP in a route-map, use the set metric route-map configuration command. To return to the default metric value, use the no form of this command.
set metric bandwidth delay reliability loading mtu
bandwidth | Metric value or IGRP bandwidth of the route in kilobits per second. It can be in the range 0 to 4294967295. |
delay | Route delay in tens of microseconds. It can be in the range 0 to 4294967295. |
reliability | Likelihood of successful packet transmission expressed as a number between 0 and 255. The value 255 means 100 percent reliability; 0 means no reliability. |
loading | Effective bandwidth of the route expressed as a number from 0 to 255 (255 is 100 percent loading). |
mtu | Minimum maximum transmission unit (MTU) size of the route in bytes. It can be in the range 0 to 4294967295. |
No metric will be set in the route-map.
Route-map configuration
This command first appeared in Cisco IOS Release 10.0.
Use the route-map global configuration command, and the match and set route-map configuration commands, to define the conditions for redistributing routes from one routing protocol into another. Each route-map command has a list of match and set commands associated with it. The match commands specify the match criteria--the conditions under which redistribution is allowed for the current route-map command. The set commands specify the set actions--the particular redistribution actions to perform if the criteria enforced by the match commands are met. The no route-map command deletes the route map.
In the following example, the bandwidth is set to 10,000, the delay is set to 10, the reliability is set to 255, the loading is set to 1, and the MTU is set to 1500:
set metric 10000 10 255 1 1500
To adjust IGRP network timers, use the timers basic router configuration command. To restore the default timers, use the no form of this command.
timers basic update invalid holddown flush [sleeptime]
update | Rate in seconds at which updates are sent. This is the fundamental timing parameter of the routing protocol. |
invalid | Interval of time in seconds after which a route is declared invalid; it should be at least three times the value of update. A route becomes invalid when there is an absence of updates that refresh the route. The route then enters holddown. The route is marked inaccessible and advertised as unreachable. However, the route is still used for forwarding packets. |
holddown | Interval in seconds during which routing information regarding better paths is suppressed. It should be at least three times the value of update. A route enters into a holddown state when an update packet is received that indicates the route is unreachable. The route is marked inaccessible and advertised as unreachable. However, the route is still used for forwarding packets. When holddown expires, routes advertised by other sources are accepted and the route is no longer inaccessible. |
flush | Amount of time in seconds that must pass before the route is removed from the routing table; the interval specified must be at least the sum of invalid and holddown. If it is less than this sum, the proper holddown interval cannot elapse, which results in a new route being accepted before the holddown interval expires. |
sleeptime | (Optional) Interval in milliseconds for postponing routing updates in the event of a flash update. The sleeptime value should be less than the update time. If the sleeptime is greater than the update time, routing tables will become unsynchronized. |
update is 90 seconds
invalid is 270 seconds
holddown is 280 seconds
flush is 630 seconds
sleeptime is 0 milliseconds
Router configuration
This command first appeared in Cisco IOS Release 10.0.
The basic timing parameters for IGRP are adjustable. Since this routing protocol is executing a distributed, asynchronous routing algorithm, it is important that these timers be the same for all routers and access servers in the network.
In the following example, updates are broadcast every 5 seconds. If a router is not heard from in 15 seconds, the route is declared unusable. Further information is suppressed for an additional 15 seconds. At the end of the suppression period, the route is flushed from the routing table.
router igrp 109
timers basic 5 15 15 30
Note that by setting a short update period, you run the risk of congesting slow-speed serial lines; however, this is not a big concern on faster-speed Ethernets and T1-rate serial lines. Also, if you have many routes in your updates, you can cause the routers to spend an excessive amount of time processing updates.
balanced | Distributes traffic proportionately to the ratios of the metrics. |
min | Uses routes that have minimum costs. |
Traffic is distributed proportionately to the ratios of the metrics.
Router configuration
This command first appeared in Cisco IOS Release 10.0.
This command applies to IGRP and Enhanced IGRP routing protocols only. With the default setting, routes that have higher metrics represent less-preferable routes and get less traffic. Configuring traffic-share min causes the Cisco IOS software to only divide traffic among the routes with the best metric. Other routes will remain in the routing table, but will receive no traffic.
In the following example, only routes of minimum cost will be used:
router igrp 5
traffic-share min
To have the Cisco IOS software validate the source IP address of incoming routing updates for RIP and IGRP routing protocols, use the validate-update-source router configuration command. To disable this function, use the no form of this command.
validate-update-sourceThis command has no arguments or keywords.
Enabled
Router configuration
This command first appeared in Cisco IOS Release 10.0.
This command is only applicable to RIP and IGRP. The software ensures that the source IP address of incoming routing updates is on the same IP network as one of the addresses defined for the receiving interface.
Disabling split horizon on the incoming interface will also cause the system to perform this validation check.
For unnumbered IP interfaces (interfaces configured as ip unnumbered), no checking is performed.
In the following example, a router is configured to not perform validation checks on the source IP address of incoming RIP updates:
router rip
network 128.105.0.0
no validate-update-source
Posted: Tue Aug 15 17:37:15 PDT 2000
Copyright 1989-2000©Cisco Systems Inc.