cc/td/doc/product/mels/15540
hometocprevnextglossaryfeedbacksearchhelp
PDF

Table Of Contents

Software Setup

Configuring Management Access

Configuring the Enable Password and Secret Password

Configuring IP Access on the NME interface

Configuring Host Name

Configuring IP on the OSC (Optional)

Configuring Transponder Module Interfaces

Configuring Patch Connections

Configuring SNMP


Software Setup


This chapter describes procedures for basic software configuration.

This chapter contains the following major sections:

Configuring Management Access

Configuring Transponder Module Interfaces

Configuring Patch Connections

Configuring SNMP

Before performing the procedures in this section, the Cisco IOS software must have booted and the Cisco IOS prompt must be in EXEC mode.

Use the data checklist forms to record such information as IP address and host name for each node. Refer to this information when performing the procedures in this section.

Refer to the Cisco ONS 15540 ESP Configuration Guide and Command Reference for more detailed configuration information.

Configuring Management Access

Perform the following procedures to configure the enable password and secret password, configure IP access on the NME interface, and configure the host name.

Configuring the Enable Password and Secret Password

You can configure both an enable password and an enable secret password. For maximum security, the enable password should be different from the enable secret password.

Configuring the Enable Password

The enable password is a nonencrypted password. It can contain any number of uppercase and lowercase alphanumeric characters. Give the enable password only to users permitted to make configuration changes.

Enter the following CLI command:

Switch(config)# enable password password

Configuring the Enable Secret Password

The enable secret password is a secure, encrypted password. By setting an encrypted password, you can prevent unauthorized configuration changes. On systems running Cisco IOS software, you must type in the enable secret password before you can access global configuration mode.You must type in the enable secret password to access boot ROM software.

An enable secret password contains from 1 to 25 uppercase and lowercase alphanumeric characters. The first character cannot be a number. Spaces are valid password characters. Leading spaces are ignored; trailing spaces are recognized.

Enter the following CLI command:

Switch(config)# enable secret password

Configuring IP Access on the NME interface

The Fast Ethernet interface, or NME (network management Ethernet), on the active processor card, named fastethernet 0, is the management interface that allows multiple, simultaneous Telnet or SNMP network management sessions.

You can remotely configure the Cisco ONS 15540 through the Fast Ethernet interface, but first you must configure an IP address so that the active processor card is reachable.


Note Before you begin to manually configure an NME interface, obtain its IP address and IP subnet mask. Also make sure the console cable is connected to the console port.



To configure IP access on the NME port fastethernet 0 from the CLI, perform these steps from the console interface:

 
Command
Purpose

Step 1 

Switch> enable

Switch#

Enters privileged EXEC mode.

Step 2 

Switch# configure terminal

Switch(config)#

Enters global configuration mode.

Step 3 

Switch(config)# interface fastethernet 0

Switch(config-if)#

Enters interface configuration mode on interface fastethernet 0, the NME port on the active processor card.

Step 4 

Switch(config-if)# ip address ip-address subnet-mask

Specifies the IP address and IP subnet mask for the management port interface.

Step 5 

Switch(config-if)# speed {10 | 100 | auto}

Specifies the transmission speed. The default is auto (autonegotiation).

Step 6 

Switch(config-if)# duplex {auto | full | half}

Specifies the duplex mode. The default is auto (autonegotiation).

Step 7 

Switch(config-if)# exit

Switch(config)#

Returns to global configuration mode.

Step 8 

Switch(config)# ip default-gateway ip-address

Specifies the address of the default IP gateway node.

Example

The following example shows how to configure IP access on the NME interface fastethernet 0:

Switch(config)# interface fastethernet0
Switch(config-if)# ip address 192.31.7.18 255.255.255.0
Switch(config-if)# exit
Switch(config)# ip default-gateway 192.31.7.1

Configuring Host Name

In addition to passwords and an IP address, you must configure the host name. To configure the host name, perform the following steps:

 
Command
Purpose

Step 1 

Switch# configure terminal

Switch(config)#

Enters global configuration mode.

Step 2 

Switch(config)# hostname name

Specifies a system name.

Step 3 

name(config)# end

name#

Returns to privileged EXEC mode. The prompt indicates that the host name has been set to the new name.

Step 4 

name# copy system:running-config nvram:startup-config

Saves your configuration changes to NVRAM.

Example

The following example shows how to configure the host name:

Switch# configure terminal
Switch(config)# hostname node1
node1(config)# end
node1(config)# copy system:running-config nvram:startup-config

Configuring IP on the OSC (Optional)

Configuring IP on the OSC allows you to use one Cisco ONS 15540 node in the network to monitor all the other Cisco ONS 15540 nodes in the network. The OSC is a point-to-point signal so any IP configuration valid for point-to-point interfaces is usable.

IP addressing on the OSC can be configured two ways:

An IP address for each OSC wave interface with each address on a separate subnet

An unnumbered address for the OSC wave interfaces which reference another numbered interface

The IP address of the reference interface is used as the IP packet source address. Use a loopback interface as the reference interface since it is always up. Configure the IP address for each node in a separate subnet.


Note You can alternatively use the IP address of the NME interface (fastethernet 0) for the reference address instead of the loopback interface.


To configure IP on an OSC wave interface, perform the following steps, beginning in global configuration mode:

 
Command
Purpose

Step 1 

Switch(config)# interface loopback 1

Switch(config-if)#

Selects the loopback interface to configure and enters interface configuration mode.

Step 2 

Switch(config-if)# ip address ip-address subnet-mask

Configures the IP address and subnet for the interface.

Step 3 

Switch(config-if)# exit

Switch(config)#

Exits interface configuration mode and returns to global configuration mode.

Step 4 

Switch(config)# interface fastethernet 0

Switch(config-if)#

Selects the NME interface to configure and enters interface configuration mode.

Step 5 

Switch(config-if)# ip address ip-address subnet-mask

Configures the IP address and subnet for the interface.

Step 6 

Switch(config-if)# exit

Switch(config)#

Exits interface configuration mode and returns to global configuration mode.

Step 7 

Switch(config)# interface wave 0

Switch(config-if)#

Selects the wave interface on slot 0.

Step 8 

Switch(config-if)# ip unnumbered loopback 1

Configures an unnumbered interface referencing the loopback interface.

Step 9 

Switch(config-if)# no shutdown

Configures the interface to a no shutdown state.

Step 10 

Switch(config-if)# exit

Switch(config)#

Exits interface configuration mode and returns to global configuration mode.

Step 11 

Switch(config)# interface wave 1

Switch(config-if)#

Selects the wave interface on slot 1.

Step 12 

Switch(config-if)# ip unnumbered loopback 1

Configures an unnumbered interface referencing the loopback interface.

Step 13 

Switch(config-if)# no shutdown

Configures the interface to a no shutdown state.

Step 14 

Switch(config-if)# exit

Switch(config)#

Exits interface configuration mode and returns to global configuration mode.

Step 15 

Switch(config)# ip route prefix prefix-mask interface

or

Switch(config)# router ospf process-id

Switch(config-router)# network network-address wildcard-mask area area-id

or

Switch(config)# router eigrp as-number

Switch(config-router)# network network-number [network-mask]

or

Switch(config)# router bgp as-number

Switch(config-router)# network network-number [mask network-mask]

Switch(config-router)# neighbor {ip-address | peer-group-name} remote-as number

Configures IP static routes for some or all destinations.

or

Configures OSPF as the routing protocol.


or

Configures EIGRP as the routing protocol.


or

Configures BGP as the routing protocol.

Example

The following example shows how to configure IP on an OSC wave interface:

Switch(config)# interface loopback 1
Switch(config-if)# ip address 192.31.7.18 255.255.255.0
Switch(config-if)# exit
Switch(config)# interface fastethernet0
Switch(config-if)# ip address 192.31.7.19 255.255.255.0
Switch(config-if)# exit
Switch(config)# interface wave0
Switch(config-if)# ip unnumbered loopback 1
Switch(config-if)# no shutdown
Switch(config-if)# exit
Switch(config)# interface wave1
Switch(config-if)# ip unnumbered loopback 1
Switch(config-if)# no shutdown
Switch(config-if)# exit
Switch(config)# router ospf 109
Switch(config-router)# network 131.108.20.0 0.0.0.255 area 10.9.50.0
Switch(config-router)# network 131.108.0.0 0.0.255.255 area 2
Switch(config-router)# network 131.109.10.0 0.0.0.255 area 3
Switch(config-router)# network 0.0.0.0 255.255.255.255 area 0

Note For detailed information about configuring routing protocols, refer to the
Cisco IOS IP and IP Routing Configuration Guide.


Configuring Transponder Module Interfaces

To configure transponder module interfaces, you must configure the signal transmission rate by specifying either the protocol encapsulation or the clock rate. You must then perform a no shutdown command on the interfaces.

If you are configuring extended range transponders, refer to Table 1-1 to configure the appropriate protocol for the transceiver.

To configure the transponder interfaces, perform the following steps, beginning in global configuration mode:

 
Command
Purpose

Step 1 

Switch(config)# interface transparent slot/subcard/0

Switch(config-if)#

Selects the interface to configure and enters interface configuration mode.

Step 2 

Switch(config-if)# encapsulation {fastethernet | fddi | gigabitethernet | escon}
or

Switch(config-if)# encapsulation sysplex clo


or

Switch(config-if)# encapsulation sysplex etr
or

Switch(config-if)# encapsulation sysplex isc {compatibility | peer [1g | 2g]}

or

Switch(config-if)# encapsulation ficon {1g | 2g}
or

Switch(config-if)# encapsulation sonet {oc3 | oc12 | oc48}

or

Switch(config-if)# encapsulation sdh {stm-1 | stm-4 | stm-16}

or

Switch(config-if)# encapsulation fibrechannel {1g | 2g} [ofc {enable | disable}]

or

Switch(config-if)# clock rate value

Specifies Fast Ethernet, FDDI, Gigabit Ethernet, or ESCON. OFC is disabled.

Specifies Sysplex CLO1 . OFC2  is disabled. Forward laser control is enabled on both the transparent and wave interfaces. OFC is disabled.

Specifies Sysplex ETR3 . OFC is disabled.

Specifies ISC4 compatibility mode (1 Gbps) or peer mode (1 Gbps or 2 Gbps). OFC is enabled for compatibility modeand disabled for peer mode.

Specifies FICON and rate. OFC is disabled.

Specifies SONET as the signal protocol and OC-3, OC-12, or OC-48 as the transmission rate. OFC is disabled.

Specifies SDH as the signal protocol and STM-1, STM-4, or STM-16 as the transmission rate. OFC is disabled.

Specifies Fibre Channel as the signal protocol and 1 Gbps or 2 Gbps as the transmission rate. Enables or disables OFC. OFC is disabled by default.

Specifies the signal transmission clock rate without an associated protocol. OFC is disabled.

Step 3 

Switch(config-if)# monitor enable

Enables protocol monitoring. Protocol monitoring is supported only for certain protocol encapsulations.

Step 4 

Switch(config-if)# topology neighbor {name node-name | ip-address node-ip-address | mac-address node-mac-address} {port {name port-name | ip-address port-ip-address | mac-address port-mac-address}}
[receive | transmit]

Configures the network topology information for the client equipment.

Step 5 

Switch(config-if)# topology neighbor agent ip-address ip-address

Specifies the address of the network topology agent on a neighboring node.

Step 6 

Switch(config-if)# no shutdown

Enables the interface.

Step 7 

Switch(config-if)# exit

Switch(config)#

Exits interface configuration mode and returns to global configuration mode.

Step 8 

Switch(config)# interface wave slot/subcard/0

Switch(config-if)#

Selects the interface to configure and enters interface configuration mode.

Step 9 

Switch(config-if)# laser frequency number

Selects the frequency for the laser to transmit to the trunk. Each transponder module can transmit one of two frequencies. The default is the lower channel frequency.

Step 10 

Switch(config-if)# no shutdown

Enables the interface.

Step 11 

Switch(config-if)# exit

Switch(config)#

Exits interface configuration mode and returns to global configuration mode.

Step 12 

Switch(config)# interface wavepatch slot/subcard/0

Switch(config-if)#

Perform this step for both splitter and non-splitter modules.

Step 13 

Switch(config-if)# no shutdown

Enables the interface.

Step 14 

Switch(config-if)# exit

Switch(config)#

Exits interface configuration mode and returns to global configuration mode.

Step 15 

Switch(config)# interface wavepatch slot/subcard/1

Switch(config-if)#

If you have a splitter interface module, perform this step.

Step 16 

Switch(config-if)# no shutdown

Enables the interface.

Step 17 

Switch(config-if)# end

Switch#

Returns to privileged EXEC mode.

Step 18 

Switch# copy system:running-config nvram:startup-config

Saves your configuration changes to NVRAM.

1 CLO = control link oscillator

2 OFC = open fiber control

3 ETR = external timer reference

4 ISC = Intersystem Channel Links

Example

The following example shows how to configure the transponder interfaces:

Switch# configure terminal
Switch(config)# interface transparent 2/0/0
Switch(config-if)# encapsulation sonet oc48
Switch(config-if)# monitor enable
Switch(config-if)# topology neighbor ip-address 192.31.7.11 port ip-address 192.31.7.13
Switch(config-if)# topology neighbor agent ip-address 192.31.7.20
Switch(config-if)# no shutdown
Switch(config-if)# exit
Switch(config)# interface wave 2/0
Switch(config-if)# no shutdown
Switch(config-if)# exit
Switch(config)# interface wavepatch 2/0/0
Switch(config-if)# no shutdown
Switch(config-if)# exit
Switch(config)# interface wavepatch 2/0/1
Switch(config-if)# no shutdown
Switch(config-if)# end
Switch# copy system:running-config nvram:startup-config

Configuring Patch Connections

To configure patch connections on the Cisco ONS 15540, perform the following steps:


Step 1 Configure the patch connections between the mux/demux modules (required).

Step 2 Configure the patch connections between the OSC (optical supervisory channel) interface on the mux/demux motherboards and the mux/demux modules (required if the OSC is present).

Table 3-1 describes the types of patch connections on the Cisco ONS 15540.

Table 3-1 Patch Connection Types 

Patch Connection
Description

Thru interface to wdm interface or
wdm interface to thru interface

Connection between two add/drop mux/demux modules in the same chassis slot

Thru interface to thru interface

Connection between two add/drop mux/demux modules in different chassis slots

Filterband interface to filtergroup interface or
filtergroup interface to filterband interface

Connection between the terminal mux/demux module supporting channels 1 through 16 and the terminal mux/demux module supporting channels 17 through 32 in the same chassis slot or in different chassis slots

OSC wave interface to OSC oscfilter interface or
OSC oscfilter interface to OSC wave interface

Connection between the OSC wave interface on the mux/demux motherboard and the OSC oscfilter interface on the mux/demux module in the same chassis slot



Figure 3-1 shows and example of interfaces and their relationships on the Cisco ONS 15540 ESP.

Figure 3-1 Optical Cross Connection Example on the Cisco ONS 15540 ESP

To configure patch connections between mux/demux modules within the same shelf, use the following global configuration commands:

Command
Purpose

patch thru slot/subcard1 wdm slot/subcard2

or

patch wdm slot/subcard1 thru slot/subcard2

Configures the patch connection between two add/drop mux/demux modules in the same chassis slot.

patch thru slot1/subcard1 thru slot2/subcard2

Configures the patch connection between two add/drop mux/demux modules in different chassis slots.

patch filterband slot1/subcard1/port1 filtergroup slot2/subcard2/port2

or

patch filtergroup slot1/subcard1/port1 filterband slot2/subcard2/port2

Configures the patch connection between a terminal mux/demux module supporting channels 1 through 16 and a terminal mux/demux module supporting channels 17 through 32 in the same chassis slot or in different chassis slots.

patch wave slot oscfilter slot/subcard

or

patch oscfilter slot/subcard wave slot

Configures the patch connection between the OSC wave interface on the mux/demux motherboard and the OSC oscfilter interface on the mux/demux module in the same chassis slot.



Note If you correctly patch your mux/demux modules, patch command configuration is not necessary for the signal to pass from the client to the trunk fiber. However, without correct patch command configuration, CDP is unable to locate the wdm interfaces that connect to the trunk fiber and discover the topology neighbors. For more information on network monitoring, refer to the Cisco ONS 15540 ESP Configuration and Command Reference Guide.


Example

The following example shows how to configure the patch connections between OSC interfaces and between mux/demux modules:

Switch# configure terminal
Switch(config)# patch thru 0/0 wdm 0/1
Switch(config)# patch thru 0/1 wdm 0/2
Switch(config)# patch thru 0/2 thru 1/0
Switch(config)# patch thru 1/1 wdm 1/0
Switch(config)# patch thru 1/2 wdm 1/1
Switch(config)# patch wave 0 oscfilter 0/0
Switch(config)# patch wave 1 oscfilter 1/2

Configuring SNMP

As a basic test of whether SNMP is functioning correctly, you will verify that you can receive a generic SNMP trap, the entity trap. Perform a shutdown command and no shutdown command on an interface to trigger entity traps. Verify that you receive the entity traps.

To configure and test SNMP functionality, perform the following commands:

 
Command
Purpose

Step 1 

Switch(config)# snmp-server community public RO

Defines the password-like community access string sent with the notification, and assigns read only permission for the MIB objects accessible to the community.

Step 2 

Switch(config)# snmp-server community private RW

Defines the password-like community access string sent with the notification, and assigns read and write permission for the MIB objects accessible to the community.

Step 3 

Switch(config)# snmp-server enable traps

Enables SNMP trap notifications.

Step 4 

Switch(config)# interface transparent slot/subcard/0

Switch(config-if)#

Selects the interface to configure and enters interface configuration mode.

Step 5 

Switch(config-if)# shutdown

Disables the interface.

Step 6 

Switch(config-if)# no shutdown

Enables the interface.

Example

The following example shows how to configure and test SNMP functionality:

Switch# configure terminal
Switch(config)# snmp-server community public RO
Switch(config)# snmp-server community private RW
Switch(config)# snmp-server enable traps
Switch(config)# interface transparent 2/2/0
Switch(config-if)# shutdown
Switch(config-if)# no shutdown

hometocprevnextglossaryfeedbacksearchhelp

Posted: Mon Dec 6 19:52:52 PST 2004
All contents are Copyright © 1992--2004 Cisco Systems, Inc. All rights reserved.
Important Notices and Privacy Statement.