This chapter describes how to use the Cisco IOS software command-line interface (CLI) to change the host name, password, and IP addresses used in the Cisco AccessPath-TS3 Model 531 Integrated Access System, in order to alter the standard configurations for your network. The following procedures are described:
Changing the host name and password
Understanding and assigning IP addresses to each AccessPath-TS3 component
Configuring for the following interfaces:
Ethernet
Fast Ethernet
Loopback
Bridge-Group Virtual Interface (BVI)
Sc0 interface of the Switch Shelf
Configuring local IP address pools
Configuring internal routing for either Enhanced Interior Gateway Routing Protocol (EIGRP) or Open Shortest Path First (OSPF) Autonomous System
Follow the procedures in this chapter to configure the components in the AccessPath-TS3 system manually. Many of these configurations can also be created automatically using the Cisco AccessPath Manager software. For more information, see the Installing Cisco AccessPath Manager document.
Note The Cisco AccessPath-TS3 Integrated Access System IP Address Map
quick reference guide can help you plan IP addressing for your AccessPath-TS3 system. This quick
reference guide, included with your AccessPath-TS3 system, contains a map and an explanation of
the map to plan IP addressing for your AccessPath-TS3 system.
This chapter does not describe every configuration possibleonly a small portion of the most commonly used configuration procedures. For advanced configuration topics, see the Cisco IOS configuration guide and command reference publications. These publications are available on the Documentation CD-ROM that shipped with your AccessPath-TS3 system, on the World Wide Web from Cisco's home page, or you can order printed copies separately.
If you are experienced using the Cisco IOS software, you might find Appendix A, "Sample Configurations," a useful reference for configuration.
Note If you did not read Chapter 1,
"Cisco IOS Software and the EXEC
Facility Fundamentals," and you are not experienced with Cisco router configuration, go to that
chapter and read it now. This chapter provides important information you will need to succeed with
the configuration.
Configuring the Host Name and Passwords
One of the first configuration tasks you might want to do is configure the host name and set an encrypted password. Configuring a host name allows you to distinguish multiple Cisco devices from each other. Setting an encrypted password allows you to prevent unauthorized configuration changes. Configuring line passwords allows you to prevent unauthorized access to a device.
Table 3-1 Changing the Host Name and Passwords
Step
Command
Purpose
1
Router>enable
Password: <password>
Router#
Enter enable mode.
Enter the password.
You have entered enable mode when the prompt changes to Router#.
2
Router#config term
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#
Enter global configuration mode. You have entered global configuration mode when the prompt changes to Router(config)#.
3
Router(config)#hostname CMS01
CMS01(config)#
Change the name of the device to a meaningful name. Substitute your host name for CMS01.
4
CMS01(config)#enable secret secret123
Enter an enable secret password. This password provides access to privileged EXEC mode. When a user types enable at the EXEC prompt (CMS01>), that user must enter the enable secret password to gain access to configuration mode. Substitute your enable secret for secret123.
5
CMS01(config)#line vty 0 4
CMS01(config-line)#password cisco
CMS01(config-line)#login
CMS01(config-line)#exit
CMS01(config)#
Enter line configuration mode to configure the virtual terminal ports. The parameter pair 0 4 refers to the range of virtual terminals from vty 0 to vty 63. (There might be a different number of vty lines configured.) When you enter line configuration mode, the prompt changes to CMS01(config-line)#.
Enter a vty password. This password is required to allow Telnet access to a Cisco router. When a user Telnets to the router, that user must enter the vty password to gain access to the EXEC prompt. Substitute your vty password for cisco.
Configure the specified range of vty lines to permit a login with the line password.
Exit back to global configuration mode.
Verifying the Host Name and Passwords
To verify that you configured the right host name and passwords:
Enter the show config command:
CMS01(config)# show config
Using 1888 out of 126968 bytes
!
version XX.X
.
.
.
!
hostname CMS01
!
enable secret 5 $1$60L4$X2JYOwoDc0.kqa1loO/w8/
.
.
.
line vty 0 4
password cisco
login
Check the host name and encrypted password displayed near the top of the command output.
Exit global configuration mode and attempt to reenter it using the new enable password:
CMS01# exit
.
.
.
CMS01 con0 is now available
Press RETURN to get started.
CMS01> enable
Password: secret123
CMS01#
If an interface is configured on the router, open a Telnet session to the router and attempt to enter it using the new vty password:
CMS01# telnet CMS01
Translating "CMS01"...domain server (172.22.5.253) [OK]
Trying CMS01.yourdomain.com (192.168.1.56)... Open
User Access Verification
Password: cisco
CMS01>
Tips
If you are having trouble:
Make sure that the whole range of vty lines is configured with the correct passwords.
Make sure Caps Lock is off.
Make sure you entered the correct passwords. Passwords are case sensitive.
Changing Interface IP Addresses on the Access Server Shelf
Configure the Ethernet 10BaseT Interface
Assign an IP address to the Ethernet 10BaseT interface of an Access Server Shelf so that it can be recognized as a device on the Ethernet LAN.
Table 3-2 Configuring Ethernet 10BaseTAccess Server Shelf
Step
Command
Purpose
1
AS01>enable
Password: <password>
AS01#
Enter enable mode.
Enter the password.
You have entered enable mode when the prompt changes to AS01#.
2
AS01#config term
Enter configuration commands, one per line. End with CNTL/Z.
AS01(config)#
Enter global configuration mode. You have entered the global configuration mode when the prompt changes to AS01(config)#.
Assign an IP address and subnet mask to the interface.
5
AS01(config-if)#end
AS01#
%SYS-5-CONFIG_I: Configured from console by console
Return to privileged EXEC mode.
This message is normal and does not indicate an error.
Verify the IP Address
To verify you have assigned the correct IP address:
Enter the show arp command:
AS01#show arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 192.168.1.1 _ 0800.207e.bead ARPA Ethernet0
AS01#
Tips
If you are having trouble:
Make sure the cable connections are not loose or disconnected.
Make sure you are using the correct IP address.
Use the debug arp command. For more information, see the Debug Command Reference.
Configure the Ethernet 100BaseT Interface
Assign an IP address to the Ethernet 100BaseT interface of an Access Server Shelf so that it can be recognized as a device on the Ethernet LAN. The Fast Ethernet interface supports 10- and 100-Mbps speeds with the 100BaseT and 10BaseT hubs and switches.
Table 3-3 Configuring Ethernet 100BaseTAccess Server Shelf
Step
Command
Purpose
1
AS01>enable
Password: <password>
AS01#
Enter enable mode.
Enter the password.
You have entered enable mode when the prompt changes to AS01#.
2
AS01#config term
Enter configuration commands, one per line. End with CNTL/Z.
AS01(config)#
Enter global configuration mode. You have entered global configuration mode when the prompt changes to AS01(config)#.
Encapsulation ARPA, loopback not set, keepalive set (10 sec), auto duplex,
100BaseTX/FX, 100Mb/s
Tips
If you are having trouble:
Make sure the cable connections are not loose or disconnected.
Make sure you are using the correct IP address.
Make sure the Switch Shelf is configured correctly.
Use the debug arp command. For more information, see the Debug Command Reference.
Note For more information on Switch configurations, see
Appendix A,
"Sample Configurations," and see the
Catalyst 5000 Series Software Configuration Guide.
Configure Loopback Interfaces
Assign an IP address to the loopback 0 and loopback 1 interfaces of your Access Server Shelf. Loopback 0 is used as the source address of the IP unnumbered interfaces. Loopback 1 is used as a management address.
Table 3-4 Configuring Loopback InterfacesAccess Server Shelf
Step
Command
Purpose
1
AS01>enable
Password: <password>
AS01#
Enter enable mode.
Enter the password.
You have entered enable mode when the prompt changes to AS01#.
2
AS01#config term
Enter configuration commands, one per line. End with CNTL/Z.
AS01(config)#
Enter global configuration mode. You have entered global configuration mode when the prompt changes to AS01(config)#.
3
AS01(config)#interface loopback 0
AS01(config-if)#
Enter loopback interface configuration mode.
4
AS01(config-if)# ip address 172.16.1.33 255.255.255.255
Assign an IP address and subnet mask to the interface.
5
AS01(config-if)#end
AS01#
%SYS-5-CONFIG_I: Configured from console by console
Return to privileged EXEC mode.
This message is normal and does not indicate an error.
Verify the IP Address
To verify the IP address:
Enter theshow interface loopback 0 command to verify the IP address:
Encapsulation ARPA, loopback not set, keepalive not set
Full-duplex, 100Mb/s, MII
If you have an AccessPath-TS3 system with the Switch Shelf, enter the show interface fastethernet 1/0 command to verify the configured speed, duplex mode, and media type:
RS01# show interface fastethernet 1/0
FastEthernet1/0 is up, line protocol is up
Hardware is DEC21140, address is 0010.543d.0420 (bia 0010.543d.0420)
Encapsulation ARPA, loopback not set, keepalive set (10 sec)
Full-duplex, 100Mb/s, 100BaseTX/FX
Tips
If you are having trouble:
Make sure the cable connections are not loose or disconnected.
Make sure you are using the correct IP addresses.
Make sure the Switch Shelf is configured correctly.
Use the debug arp command. For more information, see the Debug Command Reference.
Note For more information on Switch configurations, see
Appendix A,
"Sample Configurations," and the
Catalyst 5000 Series Software Configuration Guide.
Configure BVI
The AccessPath-TS3 system with the Router Shelf Switch Blade uses Integrated Routing and Bridging (IRB). A BVI is the interface from the secondary Switch Shelf to the Router Shelf.
Note This interface is not needed if your AccessPath-TS3 system has a Switch .
Table 3-6 Configuring BVIRouter Shelf
Step
Command
Purpose
1
RS01> enable
Password: <password>
RS01#
Enter enable mode.
Enter the password.
You have entered enable mode when the prompt changes to RS01#.
2
RS01#config term
Enter configuration commands, one per line. End with CNTL/Z.
RS01(config)#
Enter global configuration mode. You have entered global configuration mode when the prompt changes to RS01(config)#.
3
RS01(config)#interface BVI 2
RS01(config-if)#
Enter BVI configuration mode (for bridge-group 2).
4
RS01(config-if)# ip address 192.168.1.27 255.255.255.224
Assign an IP address and subnet mask to the interface.
5
RS01(config-if)#end
RS01#
%SYS-5-CONFIG_I: Configured from console by console
Return to privileged EXEC mode.
This message is normal and does not indicate an error.
Verify the IP Address
To verify the IP address:
Enter the show interface BVI 2 command to verify the configured IP address:
RS01# show interface BVI 2
BVI2 is up, line protocol is up
Hardware is BVI, address is 0010.543d.0450 (bia 0000.0000.0000)
Assign a name and a range of IP addresses to a local pool. Then, assign the pool to the ISDN D-channel interfaces and the asynchronous group interface to assign IP addresses to dial-in users from a local pool.
Table 3-10 Configuring Local IP Address PoolsAccess Server
Verify the Local IP Address Pool
To verify the local IP address pool:
Enter the show ip local pool command to verify the IP address range:
AS01# show ip local pool
Pool Begin End Free InUse
default 172.16.2.1 172.16.2.96 8 88
AS01#
Tips
If you are having trouble:
Make sure you are using the correct IP address ranges.
Remove the old local pool after configuring the new local pool.
Configuring the Internal OSPF Autonomous System
Configure OSPFAccess Server
Assign IP networks to an OSPF routing process.
Table 3-11 Configuring OSPFAccess Server
Step
Command
Purpose
1
AS01>enable
Password: <password>
AS01#
Enter enable mode.
Enter the password.
You have entered enable mode when the prompt changes to AS01#.
2
AS01#config term
Enter configuration commands, one per line. End with CNTL/Z.
AS01(config)#
Enter global configuration mode. You have entered global configuration mode when the prompt changes to AS01(config)#.
3
AS01(config)#router OSPF 4242
AS01(config-router)#
Enter OSPF routing process configuration mode for your internal OSPF process. Substitute your own process ID.
4
AS01(config-router)#network 172.16.1.0 0.0.0.63 area 1
AS01(config-router)#network 1.5.0.0 0.0.0.63 area 1