|
Table Of Contents
Sample NAS Configurations for the Cisco DialOut Utility
Sample Configuration File for Cisco AS2509-2512 Series Access Servers
Sample Configuration File for a Cisco AS2509 Access Server with Local AAA Security
Sample Configuration File for Cisco 5200 Series Access Servers
Sample Configuration File for an AS5200 (PRI) Access Server with AAA Local Security
Sample NAS Configurations for the Cisco DialOut Utility
This appendix contains sample configurations for the NAS you will be using with the Cisco DialOut Utility. The Cisco DialOut Utility can be used with any NAS that supports Class 2 faxing.
For more information on setting up and configuring your NAS, see the section Telnet Extensions for Dialout in your Cisco IOS documentation.
Sample Configuration File for Cisco AS2509-2512 Series Access Servers
Following is a sample configuration file for a Cisco AS2509, Cisco AS2510, Cisco AS2511, or Cisco AS2512 access server that you can use with Cisco DialOut Utility. Of course, you need to edit the example to reflect your own configuration.
!
version 11.3
service timestamps debug datetime msec localtime
no service udp-small-servers
service tcp-small-servers
!
hostname 2500-DialOut
!
enable secret 5 $1$WG3K$8ZhlhHUG6hx4U3U2KFPyW0
enable password abc
!
ip domain-name cisco.com
ip name-server 10.0.0.0
ip address-pool local
!
interface Ethernet0
ip address 10.0.0.1 255.255.255.0
no ip mroute-cache
no ip route-cache
no lat enabled
no mop enabled
!
interface Serial0
no ip address
no ip mroute-cache
no ip route-cache
shutdown
!
interface Serial1
no ip address
no ip mroute-cache
no ip route-cache
shutdown
!
interface Group-Async1
ip unnumbered Ethernet0
no ip mroute-cache
encapsulation ppp
no ip route-cache
async default routing
async dynamic address
async mode interactive
peer default ip address pool local
dialer in-band
no cdp enable
ppp authentication chap
group-range 1 8
!
interface Dialer0
no ip address
no ip mroute-cache
no ip route-cache
no cdp enable
!
router eigrp 109
network 10.2.0.0
no auto-summary
!
ip local pool local 10.1.1.1 10.1.1.5
ip default-gateway 10.1.1.2
no ip classless
ip route 10.2.2.2 255.255.255.224 10.1.1.1
ip route 10.3.3.3 255.255.255.224 10.4.4.4
!
line con 0
exec-timeout 0 0
line 1 8
no exec
refuse-message
Welcome to Rotary 1 - Pool of modems...
No modems available, please try again.
modem InOut
rotary 1
transport preferred telnet
transport input all
stopbits 1
rxspeed 115200
txspeed 115200
flowcontrol software
line aux 0
line vty 0 4
password abc
login
!
end
Sample Configuration File for a Cisco AS2509 Access Server with Local AAA Security
Following is a sample configuration file for a Cisco AS2509 access server using authorization, authentication, and accounting that you can use with Cisco DialOut Utility. Of course, you need to edit the example to reflect your own configuration.
version 11.3
service timestamps debug datetime msec localtime; Helpful for accurate debug based on timestamps
no service udp-small-servers
service tcp-small-servers
!
hostname 2500-DialOut
!
aaa new-model
aaa authentication local-override
aaa authentication login dialout local
aaa authentication enable default enable
aaa authentication ppp dialup local
enable password cisco
!
username admin password 7 02050D480809
username dialout password 7 110A1016141D4B4C44
ip address-pool localpool
!
interface Ethernet0
ip address 200.200.200.40 255.255.255.0
no ip mroute-cache
no ip route-cache
no lat enabled
no mop enabled
!
interface Serial0
no ip address
no ip mroute-cache
shutdown
!
interface Serial1
no ip address
shutdown
!
interface Group-Async1; Defines group for all asynchronous calls
ip unnumbered Ethernet0; Interface IP address definition
no ip mroute-cache; Disables high speed route caching
encapsulation ppp; Specifies type of WAN Encapsulation of IP
no ip route-cache; Enables RIP, OSPF, and IGRP routing
async default routing; Enables SLIP and PPP interactive mode
async dynamic address; Allows the IP address to be assigned when the protocol is initiated
async mode interactive; Returns the line to interactive mode
peer default ip address pool localpool; Specifies pool for dynamic IP allocation
dialer in-band; Enables dial-on-demand routing on the interface
dialer idle-timeout 15; Specifies the idle time before line is disconnected
no cdp enable; Disables CDP (Cisco Discovery Protocol)
ppp authentication chap dialup; Specifies type of ppp authentication protocol list
group-range 1 8; Specifies modems for above properties
!
interface Dialer0
no ip address
no ip mroute-cache
no ip route-cache
no cdp enable
!
router rip
network 200.200.200.0
!
ip local pool localpool 200.200.200.50 200.200.200.60; Specifies an IP range for dynamic allocation
no ip classless
!
line con 0
login authentication dialout
exec-timeout 0 0
line 1 4; Defines properties for modem lines 1 to 4
no exec; Disable EXEC processes
login authentication dialout; Enable AAA login authentication (local)
refuse-message ^C No modems available^C; Enable banner message for tty busy condition
modem InOut; Enable both incoming and outgoing calls
rotary 1; Adds lines 1 4 to the specified rotary group 1
transport preferred telnet; Specifies telnet as the preferred (default) protocol
transport input all; Defines all protocols for line
stopbits 1; Sets stopbits to 1
rxspeed 38400; Sets receive baud rate
txspeed 38400; Sets transmit baud rate
flowcontrol hardware; Sets flowcontrol to hardware
line 5 8
no exec
refuse-message ^CCC No modems available^C
modem InOut
rotary 1
transport preferred telnet
transport input all
stopbits 1
rxspeed 38400
txspeed 38400
flowcontrol hardware
line aux 0
line vty 0 4
password cisco
login authentication dialout
!
end
Sample Configuration File for Cisco 5200 Series Access Servers
Following is a sample configuration file for a Cisco AS5200 access server that you can use with Cisco DialOut Utility. Of course, you need to edit the example to reflect your own configuration.
version 11.3
service timestamps debug datetime msec localtime
service udp-small-servers
service tcp-small-servers
!
hostname 5200-DialOut
!
enable password cisco
!
username cisco password 7 123451234512
username alice password 7 123456789F12
username dogbert password 7 123456789A012345
modem startup-test
no ip domain-lookup
ip domain-name cisco.com
ip name-server 10.5.5.5
ip address-pool local
isdn switch-type primary-5ess
!
controller T1 0
framing esf
clock source line primary
linecode b8zs
pri-group timeslots 1-24
!
controller T1 1
!
interface Ethernet0
ip address 10.6.6.6 255.255.255.0
no ip mroute-cache
no ip route-cache
!
interface Serial0
no ip address
no ip mroute-cache
no ip route-cache
shutdown
no fair-queue
!
interface Serial1
no ip address
no ip mroute-cache
no ip route-cache
shutdown
!
interface Serial0:23
ip unnumbered Ethernet0
no ip mroute-cache
encapsulation ppp
no ip route-cache
no keepalive
isdn incoming-voice modem
dialer idle-timeout 400
dialer map ip 10.10.10.1 name pme_c1004
dialer-group 1
no cdp enable
ppp authentication chap
!
interface Group-Async1
ip unnumbered Ethernet0
no ip mroute-cache
encapsulation ppp
no ip route-cache
async default routing
async mode interactive
peer default ip address pool local
no cdp enable
ppp authentication chap
group-range 1 24
!
interface Dialer0
no ip address
no ip mroute-cache
no ip route-cache
dialer-group 1
no cdp enable
!
ip local pool local 10.1.1.10 10.1.1.5
ip local pool default 10.2.2.2 10.22.2.1
ip default-gateway 10.1.1.1
no ip classless
ip route 10.2.1.2 255.255.255.224 10.1.1.1
ip route 10.2.1.3 255.255.255.224 10.2.1.3
!
dialer-list 1 protocol ip permit
!
line con 0
exec-timeout 0 0
line 1 24
no exec
modem InOut
rotary 1
transport preferred telnet
transport input all
line aux 0
line vty 0 4
login
!
end
Sample Configuration File for an AS5200 (PRI) Access Server with AAA Local Security
Following is a sample configuration file for a Cisco AS5200 access server using authentication, authorization, and accounting security that you can use with Cisco DialOut Utility. Of course, you need to edit the example to reflect your own configuration.
version 11.3
service timestamps debug datetime msec localtime
service udp-small-servers
service tcp-small-servers
!
hostname 5200-DialOut
! aaa new-model
aaa authentication local-override
aaa authentication login dialout local
aaa authentication enable default enable
aaa authentication ppp dialup local
enable password cisco
!
username dialout password 7 04480E051A3349
username admin password 7 045802150C2E
modem startup-test
no ip domain-lookup
ip address-pool local
isdn switch-type primary-5ess
!
controller T1 0
framing esf
clock source line primary
linecode b8zs
pri-group timeslots 1-24
!
controller T1 1
shutdown
framing esf
clock source line secondary
linecode b8zs
pri-group timeslots 1-24
!
interface Loopback0
no ip address
no ip mroute-cache
no ip route-cache
!
interface Ethernet0
ip address 200.200.200.10 255.255.255.0
no ip mroute-cache
no ip route-cache
!
interface Serial0
no ip address
no ip mroute-cache
no ip route-cache
shutdown
no fair-queue
!
interface Serial1
no ip address
no ip mroute-cache
no ip route-cache
shutdown
!
interface Serial0:23
ip unnumbered Ethernet0
no ip mroute-cache
encapsulation ppp
no ip route-cache
no keepalive
isdn incoming-voice modem
no peer default ip address
dialer idle-timeout 400
dialer map ip 200.200.200.23 name pc4
dialer-group 1
no fair-queue
no cdp enable
ppp authentication chap
ppp multilink
!
interface Serial1:23
no ip address
no ip mroute-cache
no ip route-cache
shutdown
no cdp enable
!
interface Group-Async1
ip unnumbered Ethernet0
no ip mroute-cache
encapsulation ppp
no ip route-cache
async default routing
async mode interactive
peer default ip address pool dialout1
no cdp enable
ppp authentication chap dialout
group-range 1 24
!
interface Dialer0
no ip address
no ip mroute-cache
no ip route-cache
no keepalive
no fair-queue
dialer-group 1
no cdp enable
!
router rip
network 200.200.200.0
!
ip local pool dialout1 200.200.200.30 200.200.200.40
no ip classless
dialer-list 1 protocol ip permit
!
line con 0
exec-timeout 0 0
password cisco
login authentication dialout
line 1 13
no exec
rotary 1
exec-timeout 0 0
refuse-message ^CC No modems available^C
modem InOut
modem autoconfigure type microcom_hdms
rotary 1
transport preferred telnet
transport input all
line 14 24
exec-timeout 0 0
modem InOut
line aux 0
line vty 0 4
exec-timeout 0 0
password cisco
login authentication dialout
!
end
Posted: Tue Jun 8 17:37:05 PDT 2004
All contents are Copyright © 1992--2004 Cisco Systems, Inc. All rights reserved.
Important Notices and Privacy Statement.