|HP-UX Reference > M
maxfiles_lim(5)Tunable Kernel Parameters
HP-UX 11i Version 3: February 2007
maxfiles_lim — hard maximum number of file descriptors per process
The minimum value allowed is 32. The maximum value allowed is 1048576, or 1M. The value is further constrained in that it must be equal or greater than the soft limit, maxfiles.
Specify a positive integer value.
At runtime, a warning will be issued if the tunable is set to a value greater than 409600, or 400K. This is beyond the tested limit.
At runtime, a warning will be issued if the value is not a multiple of the file descriptor chunk (multiple of 8) size. This is not a serious warning, just an information message for the administrator.
maxfiles_lim specifies the system hard limit for the number of file descriptors that a process is allowed to have for open files at any given time. It is possible for a nonsuperuser process to increase its soft limit up to this hard limit.
Who Is Expected to Change This Tunable?
Anyone expecting to run applications using large numbers of file descriptors.
Restrictions on Changing
The maxfiles_lim tunable is dynamic (tuning will take effect immediately on the running system).
Dynamic changes affect all existing processes in the system except:
When Should the Value of This Tunable Be Raised?
The tunable should be increased when large numbers of file descriptors are expected to be open by several processes.
What are the Side Effects of Raising the Value?
There is no immediate effect of raising the value of maxfiles_lim. However, doing so allows any process to allocate more file descriptors, potentially consuming more system memory.
When Should the Value of This Tunable Be Lowered?
The value should be lowered to limit the number of open file descriptors per process on a system and reduce system memory consumption.
What are the Side Effects of Lowering the Value?
Lowering the value of maxfiles_lim bounds memory consumption due to file descriptors for processes that are not already over the new limit.
For values greater than 65535, compatibility for the obsolescent pstat_getfile() will be affected. For correct operation, all applications must use pstat_getfile2() instead of pstat_getfile(). If the system still has applications using pstat_getfile(), setting maxfiles_lim to 65535 or less will maintain compatibility, unless the process being queried has used setrlimit() to change its maximum limit of open files to a value greater than 65535.
All HP-UX kernel tunable parameters are release specific. This parameter may be removed or have its meaning changed in future releases of HP-UX.
Installation of optional kernel software, from HP or other vendors, may cause changes to tunable parameter values. After installation, some tunable parameters may no longer be at the default or recommended values. For information about the effects of installation on tunable values, consult the documentation for the kernel software being installed. For information about optional kernel software that was factory installed on your system, see HP-UX Release Notes at http://docs.hp.com.
kctune(1M), sam(1M), setrlimit(2), gettune(2), settune(2), pstat(2), ulimit(2), maxfiles(5).