|HP-UX Reference > M
maxfiles(5)Tunable Kernel Parameters
HP-UX 11i Version 3: February 2007
maxfiles — initial (soft) maximum number of file descriptors per process
The default value is computed at runtime and depends on the amount of physical memory on the system. For small memory systems (less than 1GB), the default is 512. For systems with more than 1GB of memory, the default is 2048, or 2K.
The minimum value is 32. The maximum value is 1048576, or 1M. The value is further constrained in that it must be equal to or less than the hard limit, maxfiles_lim.
Specify a positive integer value.
At runtime, a warning will be issued if the tunable is set to a value greater than 409600, or 400K. This is beyond the tested limit.
At runtime, a warning will be issued if the value is not a multiple of the file descriptor chunk (multiple of 8) size. This is not a serious warning, just an information message for the administrator.
maxfiles specifies the initial default number of file descriptors a process is allowed to have for open files at any given time. It is possible for a process to increase its soft limit and therefore open more than maxfiles files.
Nonsuperuser processes can increase their soft limit using setrlimit() or ulimit() until they reach the hard limit, maxfiles_lim.
Who Is Expected to Change This Tunable?
This value of this tunable rarely needs to be modified. However, this tunable may need to be modified on systems that will run applications using large numbers of file descriptors, or on systems where memory consumption needs to be reduced.
Restrictions on Changing
This tunable is static. To have changes to the value of this tunable take effect, a system reboot is required.
When Should the Value of This Tunable Be Raised?
This tunable may need to be raised on systems that will run applications using large numbers of file descriptors if the applications do not already increase their process soft limit, for example using setrlimit().
What are the Side Effects of Raising the Value?
The initial process memory footprint grows due to a larger per process file table.
When Should the Value of This Tunable Be Lowered?
The value should be lowered to limit the number of initial file descriptors per process on a system to reduce memory consumption.
What are the Side Effects of Lowering the Value?
The initial process memory footprint shrinks due to a smaller per process file table.
All HP-UX kernel tunable parameters are release specific. This parameter may be removed or have its meaning changed in future releases of HP-UX.
Installation of optional kernel software, from HP or other vendors, may cause changes to tunable parameter values. After installation, some tunable parameters may no longer be at the default or recommended values. For information about the effects of installation on tunable values, consult the documentation for the kernel software being installed. For information about optional kernel software that was factory installed on your system, see HP-UX Release Notes at http://docs.hp.com.
kctune(1M), sam(1M), gettune(2), settune(2), ulimit(2), setrlimit(2), maxfiles_lim(5).