|HP-UX Reference > I
ioinit(1M)HP-UX 11i Version 3: February 2007
ioinit — test and maintain consistency between the kernel I/O data structures and the ioconfig files
/sbin/ioinit -i [-r]
/sbin/ioinit -f infile [-r]
/sbin/ioinit -v ioconfig_file
/sbin/ioinit -rC class_name
Starting with HP-UX 11i Version 3, there are two ioconfig files, /etc/ioconfig which is the same as on prior releases and /etc/ext_ioconfig which contains additional agile entries (see intro(7) for information on agile addressing).
The ioinit command is invoked by the init process when the system is booted, based on the ioin entry in /etc/inittab:
where ioinitrc is a script to invoke ioinit with the -i and -r options. Given the -i option, ioinit checks consistency between the kernel I/O data structures and information read from /etc/ioconfig and /etc/ext_ioconfig. If these are consistent, ioinit invokes insf to install special files for all new devices.
If the kernel is inconsistent with /etc/ioconfig or /etc/ext_ioconfig, ioinit updates /stand/ioconfig from /etc/ioconfig, and /stand/ext_ioconfig from /etc/ext_ioconfig, and, if the -r option is given, reboots the system.
If /etc/ioconfig or /etc/ext_ioconfig is corrupted or missing when the system reboots, ioinitrc brings the system up in single-user mode. The user should then restore /etc/ioconfig or /etc/ext_ioconfig accordingly from backup or invoke the ioinit with the -c option to recreate /etc/ioconfig and /etc/ext_ioconfig from the kernel.
If the -f option is given, ioinit reassigns instance numbers to existing devices within a given class based on infile. If the driver associated with the given hardware path does not support online instance number reassignment, reboot is required. If ioinit finds no errors associated with the reassignment, and the -r option is given, the system is rebooted. (See the WARNINGS section.)
If the -c option is given, ioinit recreates /etc/ioconfig and /etc/ext_ioconfig from the existing kernel I/O data structures.
If the -v option is given, ioinit verifies if there is any corruption in the specified system ioconfig file.
If the -C option is given, the kernel is forced to reassign instance numbers, starting from 0, for existing devices with the given class_name on the next reboot. Note that this option must be used with the -r option, which reboots the system immediately, if the operation is successful.
ioinit recognizes the following options:
Most of the diagnostic messages from ioinit are self-explanatory. Listed below are some messages deserving further clarification. Errors cause ioinit to halt immediately.
To reassign an instance number to a device and class (specified in infile) and reboot the system:
/sbin/ioinit -f infile -r
where infile contains the following:
56.52 is the h/w_path, scsi is the class_name, and 2 is the instance_#.
64000/0xfa00/0x7 is the h/w_path, disk is the class_name, and 20 is the instance_#.
To achieve circular reassignment of instance numbers between two existing devices of a class (specified in infile), assuming the driver associated with the given hardware paths support online reassignment of instance numbers.
/sbin/ioinit -f infile
where infile contains the following:
64000/0xfa00/0x7 is the h/w_path, disk is the class_name, and 20 is the instance_#. The existing instance_# of this device is 30.
64000/0xfa00/0xa is the h/w_path, disk is the class_name, and 30 is the instance_#. The existing instance_# of this device is 20. After the successful completion of this operation, 64000/0xfa00/0x7 will have the new instance_# as 20 and 64000/0xfa00/0xa will have the new instance_# as 30.
Verify my_ioconfig file for corruptions and find if it is of type legacy or agile.
/sbin/ioinit -v /etc/back/my_ioconfig
Running rmsf or insf overwrites the effect of reassignment by ioinit before the system is rebooted.
init(1M), insf(1M), ioscan(1M), rmsf(1M), inittab(4), ioconfig(4), intro(7).