|HP-UX Reference > C
HP-UX 11i Version 3: February 2007
crontab — user job file scheduler
The crontab command manages a crontab file for the user. You can use a crontab file to schedule jobs that are executed automatically by cron (see cron(1M)) on a regular basis. The command has four forms:
Only a privileged user can use username following the -e, -l, or -r options, to edit, list, or remove the crontab file of the specified user.
The entries in a crontab file are lines of six fields each. The fields are separated by spaces or tabs. The lines have the following format:
minute hour monthday month weekday command
The first five are integer patterns that specify when the sixth field, command, should be executed. They can have the following ranges of values:
Each pattern can be either an asterisk (*), meaning all legal values, or a list of elements separated by commas. An element is either a number in the ranges shown above, or two numbers in the range separated by a hyphen (meaning an inclusive range). Note that the specification of days can be made in two fields: monthday and weekday. If both are specified in an entry, they are cumulative. For example,
0 0 1,15 * 1 command
runs command at midnight on the first and fifteenth of each month, as well as every Monday. To specify days in only one field, set the other field to asterisk (*). For example,
0 0 * * 1 command
runs command only on Mondays.
The sixth field, command (the balance of a line including blanks in a crontab file), is a string that is executed by the shell at the specified times. A percent character (%) in this field (unless escaped by a backslash (\)) is translated to a newline character, dividing the field into "lines". Only the first "line" (up to a % or end-of-line) of the command field is executed by the shell. Any other "lines" are made available to the command as standard input.
Blank lines and those whose first non-blank character is # will be ignored.
cron invokes the command from the user's HOME directory with the POSIX shell, (/usr/bin/sh). It runs in the c queue (see queuedefs(4)).
cron supplies a default environment for every shell, defining:
HOME=user's-home-directory LOGNAME=user's-login-id PATH=/usr/bin:/usr/sbin:. SHELL=/usr/bin/sh
Users who desire to have their .profile executed must explicitly do so in the crontab entry or in a script called by the entry.
You can execute crontab if your name appears in the file /usr/lib/cron/cron.allow. If that file does not exist, you can use crontab if your name does not appear in the file /usr/lib/cron/cron.deny. If only cron.deny exists and is empty, all users can use crontab. If neither file exists, only the root user can use crontab. The allow/deny files consist of one user name per line.
If the compartmentalization feature is enabled, cron and crontab invoke the jobs from the compartment that the jobs were created from. Note that crontab creates the job files in /var/spool/cron/crontabs. Hence, if the crontab command is invoked from a compartment which has no write access to this directory and which disallows the COMMALLOWED privilege, crontab fails to schedule the jobs. See compartments(5) and privileges(5) for more information.
LC_CTYPE determines the interpretation of text within file as single and/or multibyte characters.
LC_MESSAGES determines the language in which messages are displayed.
If LC_CTYPE or LC_MESSAGES is not specified in the environment or is set to the empty string, the value of LANG is used as a default for each unspecified or empty variable. If LANG is not specified or is set to the empty string, a default of "C" (see lang(5)) is used instead of LANG.
If any internationalization variable contains an invalid setting, crontab behaves as if all internationalization variables are set to "C". See environ(5). EDITOR determines the editor to be invoked when -e option is specified. The default editor is vi.
Be sure to redirect the standard output and standard error from commands. If this is not done, any generated standard output or standard error is mailed to the user.