|HP-UX Reference > C
cachefspack(1M)HP-UX 11i Version 3: February 2007
cachefspack — pack files and file systems in the cache
/usr/sbin/cachefspack [ -h ] [ -i | -p | -u | -s | -d ] [ -f packing-list ] [ -U cache-directory ] [ file ... ]
The cachefspack utility is used to set up and maintain files in the cache. This utility affords greater control over the cache, ensuring that the specified files will be in the cache whenever possible.
cachefspack recognizes the following options:
Pack the file projects in the cache.
cachefspack -p projects
Pack the files projects, updates and master_plan in the cache.
cachefspack -p projects updates master_plan
Unpack the file projects from the cache.
cachefspack -u projects
Unpack the files projects, updates and master_plan from the cache.
cachefspack -u projects updates master_plan
Unpack all files in the cache1 cache directory.
cachefspack -U /cache/cache1
Use the lists.pkg packing-list to specify files to be packed in the cache. The contents of lists.pkg are as follows:
IGNORE SCCS BASE /src/junk LIST *.c LIST *.h
This example will pack all files in the directory /src/junk with .c and .h extensions that do not contain the string SCCS in the file's path name.
cachefspack -f lists.pkg