This section lists some of the warning and error
messages reported by LVM. For each message, the cause is described
and an action is recommended.
Matching Error Messages to Physical Disks and Volume Groups |
 |
Often an error message contains the device number
for a device, rather than the device file name. For example, you might
see the following message in /var/adm/syslog/syslog.log:
SCSI: Request Timeout -- lbolt: 329741615, dev: 1f022000 |
To map this error message to a specific disk,
search under the /dev directory for a device
file with a device number that matches the printed value. That is,
search for a file with a minor number matching the lower six digits
of the number following dev:. The device number
in this example is 1f022000; its lower six digits are 022000, so search
for that value using the following command:
# ll /dev/*dsk | grep 022000
brw-r----- 1 bin sys 31 0x022000 Sep 22 2002 c2t2d0
crw-r----- 1 bin sys 188 0x022000 Sep 25 2002 c2t2d0 |
Use the pvdisplay command to determine
which volume group contains this physical volume as follows:
# pvdisplay /dev/dsk/c2t2d0 | grep "VG Name"
VG Name /dev/vg03 |
If
the pvdisplay command fails, search for the physical
volume in the LVM configuration files /etc/lvmtab and /etc/lvmtab_p as follows:
# lvmadm -l -V 1.0
--- Version 1.0 volume groups ---
VG Name /dev/vg00
PV Name /dev/disk/disk36_p2
VG Name /dev/vgtest
PV Name /dev/disk/disk43
PV Name /dev/disk/disk44
VG Name /dev/vg03
PV Name /dev/dsk/c2t2d0 |
If your version of lvmadm does not recognize the –l option, use the strings command
as follows:
# strings /etc/lvmtab | more
/dev/vg00
/dev/disk/disk36_p2
/dev/vgtest
/dev/disk/disk43
/dev/disk/disk44
/dev/vg03
/dev/dsk/c2t2d0 |
Based
on the output of these commands, the error message refers to physical
volume /dev/dsk/c2t2d0, which belongs to volume
group vg03.
Similarly, some LVM error messages in /var/adm/syslog/syslog.log contain the device number for
a volume group. For example:
LVM: VG 128 0x002000: Lost quorum. |
The major number 128 indicates that this is a
Version 2.x volume group. A Version 1.0 volume group has a major number
of 64. To map this error message to a volume group, search under the /dev directory for a volume group device file with a device
number that matches the major and minor numbers. In this example,
the major number is 128 and the minor number is 0x002000, so search
for those value using the following command:
# ll /dev/*/group | grep 128.0x002000
crw-r----- 1 root sys 128 0x002000 Jan 7 08:27 /dev/vgtest2/group |
The example error message refers to the Version
2.x volume group vgtest.
Messages For All LVM Commands |
 |
Message Text
vgcfgbackup: /etc/lvmtab is out of date with the running kernel:
Kernel indicates # disks for "/dev/vgname"; /etc/lvmtab has # disks.
Cannot proceed with backup. |
Cause
The number of current physical volumes (Cur PV) and active physical volumes (Act PV) are not the same. Cur PV and Act PV must always agree for the volume group. This error also indicates
that /etc/lvmtab or /etc/lvmtab_p, which is used to match physical volumes to a volume group, is out
of date with the LVM data structures in memory and on disk.
Recommended Action
Try to locate any missing disks. For each of the
disk in the volume group, use ioscan and diskinfo to confirm that the disk is functioning properly.
lvchange(1M) |
 |
Message Text
Cause
The system does not have HP MirrorDisk/UX installed.
Recommended Action
Install HP MirrorDisk/UX.
lvextend(1M) |
 |
Message Text
lvextend: Not enough free physical extents available.
Logical volume "/dev/vgname/lvname" could not be extended.
Failure possibly caused by strict allocation policy
|
Cause
There is not enough space in the volume group
to extend the logical volume to the requested size. This is typically
caused by one of the following situations:
There are not enough free
physical extents in the volume group. Run vgdisplay to confirm the number of available physical extents, and multiply
that number by the extent size to determine the free space in the
volume group. For example:
# vgdisplay vg00
--- Volume groups ---
VG Name /dev/vg00
VG Write Access read/write
VG Status available
Max LV 255
Cur LV 10
Open LV 10
Max PV 16
Cur PV 1
Act PV 1
Max PE per PV 4350
VGDA 2
PE Size (Mbytes) 4
Total PE 4340
Alloc PE 3740
Free PE 600
Total PVG 0
Total Spare PVs 0
Total Spare PVs in use 0
VG Version 1.0
VG Max Size 1082g
VG Max Extents 69248 |
In this example, the total free space is 600 physical
extents of 4 MB, or 2400 MB.
The logical volume is
mirrored with a strict allocation policy, and there are not enough
extents on a separate disk to comply with the allocation policy. To
confirm this, run lvdisplay to determine which
disks the logical volume occupies, and then check whether there is
sufficient space on the other disks in the volume group.
In a SAN environment,
one of the disks was dynamically increased in size. LVM did not detect
the asynchronous change in size.
Recommended Action
Choose a smaller size
for the logical volume, or add more disk space to the volume group.
Choose a smaller size
for the logical volume, or add more disk space to the volume group.
Alternatively, free up space on an available disk using pvmove.
Use the vgmodify command to detect the disk size change and incorporate the new space
into the volume group.
Message Text
Cause
The system does not have HP MirrorDisk/UX installed.
Recommended Action
Install HP MirrorDisk/UX.
lvlnboot(1M) |
 |
Message Text
lvlnboot: Unable to configure swap logical volume.
Swap logical volume size beyond the IODC max address. |
Cause
The boot disk firmware cannot access the entire
range of the swap logical volume. This happens with older host bus
adapters when primary swap is configured past 4 GB on the disk.
Recommended Action
Upgrade the system firmware or use a newer host
bus adapter that supports block addressing. If neither of these actions
succeeds, reduce the size of the primary swap logical volume so that
it does not exceed 4 GB.
pvchange(1M) |
 |
Message Text
Unable to detach the path or physical volume via the pathname provided.
Either use pvchange(1M) -a N to detach the PV using an attached path
or detach each path to the PV individually using pvchange(1M) –a n |
Cause
The specified path is not part of any volume group,
because the path has not been successfully attached to the otherwise
active volume group it belongs to.
Recommended Action
Check the specified path name to make sure it
is correct. If the error occurred while detaching a physical volume,
specify a different path. If it is not clear whether any path was
attached before, individually detach each path to the physical volume
using pvchange with the –a n option.
Message Text
Warning: Detaching a physical volume reduces the availability
of data within the logical volumes residing on that disk.
Prior to detaching a physical volume or the last available path to it,
verify that there are alternate copies of the data available on other
disks in the volume group. If necessary, use pvchange(1M) to reverse
this operation. |
Cause
This warning is advisory. It is generated whenever
a path or physical volume is detached.
Recommended Action
None.
vgcfgbackup(1M) |
 |
Message Text
Invalid LVMREC on Physical Volume pvname |
Cause
The LVM header on the disk is incorrect. This
can happen when an existing LVM disk is overwritten with a command
like dd or pvcreate. If the
disk is shared between two systems, one system might not be aware
that the disk is already in a volume group. The corruption can also
be caused by running vgchgid incorrectly when using
BC split volumes.
Recommended Action
Restore a known good configuration to the disk
using vgcfgrestore. Be sure to use a valid copy
dated before the first occurrence of the problem. For example:
# vgcfgrestore –n vgname pvname |
vgcfgrestore(1M) |
 |
Message Text
Cannot restore Physical Volume pvname
Detach the PV or deactivate the VG, before restoring the PV.
|
Cause
The vgcfgrestore command was
used to initialize a disk that already belongs to an active volume
group.
Recommended Action
Detach the physical volume or deactivate the volume
group before attempting to restore the physical volume. If the disk
may be corrupted, detach the disk and mark it using vgcfgrestore, then attach it again without replacing the disk. This causes LVM
to reinitialize the disk and synchronize any mirrored user data mapped
there.
vgchange(1M) |
 |
Message Text
vgchange: WARNING: The "lvmp" driver is not loaded. |
Cause
You are activating a Version 2.x volume group,
and the kernel driver for Version 2.x volume groups is not loaded.
Recommended Action
Load the lvmp driver, as follows:
# kcmodule lvmp=best
==> Update the automatic 'backup' configuration first? n
* Future operations will ask whether to update the backup.
* The requested changes have been applied to the currently
running configuration.
Module State Cause Notes
lvmp (before) unused loadable, unloadable
(now) loaded best
(next boot) loaded explicit
|
Message Text
vgchange: Warning: Couldn't attach to the volume group
physical volume "pvname":
Illegal byte sequence
vgchange: Couldn't activate volume group "vgname":
Quorum not present, or some physical volume(s) are missing. |
Cause
You are activating a Version 2.x volume group,
and your operating system release does not support Version 2.x volumes.
Recommended Action
Update your system to the March 2008 release of
HP-UX 11i Version 3 or a newer release.
Message Text
Warning: couldn't query physical volume "pvname":
The specified path does not correspond to physical volume
attached to this volume group
Couldn't query the list of physical volumes. |
Cause
This error has the following possible causes:
The disk was missing when
the volume group was activated, but was later restored. This typically
occurs when a system is rebooted or the volume group is activated
with a disk missing, uncabled, or powered down.
The disk LVM header was
overwritten with the wrong volume group information. If the disk is
shared between two systems, one system might not be aware that the
disk was already in a volume group. To confirm, check the volume group
information using the dump_lvmtab command (available
from your HP support representative) and look for inconsistencies.
For example:
# dump_lvmtab -s | more
SYSTEM : 0x35c8cf58
TIME : 0x3f9acc69 : Sat Oct 25 15:18:01 2003
FILE : /etc/lvmtab
HEADER : version:0x03e8 vgnum:7
VG[00] VGID:35c8cf58 3dd13164 (@0x00040c) pvnum:2 state:0 /dev/vg00
(00) VGID:35c8cf58 3dd13164 PVID:35c8cf58 3dd13164 /dev/dsk/c0t6d0
(01) VGID:35c8cf58 3dd13164 PVID:35c8cf58 3dda4694 /dev/dsk/c4t6d0
VG[01] VGID:065f303f 3e63f01a (@0x001032) pvnum:92 state:0 /dev/vg01
(00) !VGID:35c8cf58 3f8df316 PVID:065f303f 3e63effa /dev/dsk/c40t0d0
(01) !VGID:35c8cf58 3f8df316 PVID:065f303f 3e63effe /dev/dsk/c40t0d4
(02) !VGID:35c8cf58 3f8df316 PVID:065f303f 3e63f003 /dev/dsk/c40t1d0
... |
In this example, the VGIDs for the disks in /dev/vg01 are not consistent; inconsistencies are marked !VGID.
Recommended Action
Use ioscan and diskinfo to confirm that the disk is functioning
properly. Reactivate the volume group using the following command:
There are several methods
of recovery from this error. If you are not familiar with the commands
outlined in the following procedures, contact your HP support representative
for assistance.
Restore a known good configuration
to the disks using vgcfgrestore. Be sure to use
a valid copy dated before the first occurrence of the problem. For
example:
# vgcfgrestore –n vgname pvname |
Recreate the volume group
and its logical volumes, restoring the data from the most current
backup. See “Creating a Volume Group” and “Creating a Logical Volume”.
Export and reimport the
volume group, as described in “Exporting a Volume Group” and “Importing a Volume Group”. For example:
# vgexport -m vgname.map -v -f vgname.file /dev/vgname
# vgimport -m vgname.map -v -f vgname.file /dev/vgname |
Message Text
vgchange: Couldn't set the unique id for volume group "/dev/vgname" |
Cause
There are multiple LVM group files with the same
minor number.
Recommended Action
List the LVM group files. If there are any duplicate
minor numbers, export one of the affected volume groups, optionally
create a new group file with a unique minor number, and reimport the
volume group. If you are not familiar with this procedure, contact
your HP support representative for assistance.
# ll /dev/*/group
# vgexport -m vgname.map -v -f vgname.file /dev/vgname
# mkdir /dev/vgname
# mknod /dev/vgname/group c 64 unique_minor_number
# vgimport -m vgname.map -v -f vgname.file /dev/vgname |
vgcreate(1M) |
 |
Message Text
vgcreate: "/dev/vgname/group": not a character device. |
Cause
The volume group device file does not exist, and
this version of the vgcreate command does not automatically
create it.
Recommended Action
Create the directory for the volume group and
create a group file, as described in “Creating the Volume Group Device File”.
Message Text
vgcreate: Volume group "/dev/vgname" could not be created:
Error: The physical volume "pvname" contains BDRA.
It cannot be added into volume group "/dev/vgname" because
this version does not support bootable disks. |
Cause
The physical volume pvname is a bootable disk, and vgname is a Version
2.x volume group. Version 2.x volume groups do not support bootable
physical volumes.
Recommended Action
Use the pvcreate command without
the -B option to reinitialize the disk, as described
in “Initializing a Disk for LVM Use”.
For example:
Use the vgmodify command to convert the disk to a nonbootable disk, as described
in “Changing Physical Volume Boot Types”. Alternately,
use the pvcreate command without the -B option to reinitialize the disk, as described in “Initializing a Disk for LVM Use”. For example:
Message Text
vgcreate: Volume group "/dev/vgname" could not be created:
VGRA for the disk is too big for the specified parameters.
Increase the extent size or decrease max_PVs/max_LVs and try again. |
Cause
The volume group reserved area (VGRA) at the front
of each LVM disk cannot hold all the information about the disks in
this volume group. This error typically occurs if you use disks larger
than 100 GB.
Recommended Action
Adjust the volume group creation parameters. Use
the –s option of the vgcreate command to select an extent size larger than 4 MB, or use the –p option to select a smaller number of physical
volumes. For more information on these options, see vgcreate(1M). For recommendations on extent sizes, see Appendix C.
vgdisplay(1M) |
 |
Message Text
vgdisplay: Couldn't query volume group "/dev/vgname".
Possible error in the Volume Group minor number;
Please check and make sure the group minor number is unique.
vgdisplay: Cannot display volume group "/dev/vgname".
|
Cause
This error has the following possible causes:
There are multiple LVM
group files with the same minor number.
Serviceguard was previously
installed on the system and the /dev/slvmvg device
file still exists.
Recommended Action
List the LVM group files.
If there are any duplicate minor numbers, export one of the affected
volume groups, optionally create a new group file with a unique minor
number, and reimport the volume group. If you are not familiar with
this procedure, contact your HP support representative for assistance.
# ll /dev/*/group
# vgexport -m vgname.map -v -f vgname.file /dev/vgname
# mkdir /dev/vgname
# mknod /dev/vgname/group c 64 unique_minor_number
# vgimport -m vgname.map -v -f vgname.file /dev/vgname |
Remove the /dev/slvmvg device file and re-create the /etc/lvmtab and /etc/lvmtab_p files using the following commands:
# rm /dev/slvmvg
# mv /etc/lvmtab /etc/lvmtab.old
# mv /etc/lvmtab_p /etc/lvmtab_p.old
# vgscan –v |
Message Text
vgdisplay: /etc/lvmtab: No such file or directory
vgdisplay: No volume group name could be read from "/etc/lvmtab".
vgdisplay: /etc/lvmtab: No such file or directory
vgdisplay: No volume group name could be read from "/etc/lvmtab".
|
Cause
One of the LVM configuration files, either /etc/lvmtab or /etc/lvmtab_p, is
missing.
Recommended Action
Create the /etc/lvmtab and /etc/lvmtab_p files using the following command:
For additional information on the vgscan command and its option, see vgscan(1M).
Message Text
Warning: couldn't query physical volume "pvname":
The specified path does not correspond to physical volume
attached to this volume group
Couldn't query the list of physical volumes.
|
Cause
The possible causes of this error are described
under the “vgchange(1M)” error messages.
Recommended Action
See the recommended actions under the “vgchange(1M)” error
messages.
vgextend(1M) |
 |
Message Text
vgextend: Not enough physical extents per physical volume.
Need: #, Have: #. |
Cause
The disk size exceeds the volume group maximum
disk size. This limitation is defined when the volume group is created,
as a product of the extent size specified with the –s option of vgcreate and the maximum number of
physical extents per disk specified with the –e option. Typically, the disk is successfully added to the volume
group, but not all of the disk is accessible.
Recommended Action
Use the vgmodify command to
adjust the maximum number of physical extents per disk. Alternately,
you can re-create the volume group with new values for the –s and –e options.
vgimport(1M) |
 |
Message Text
vgimport: "/dev/vgname/group": not a character device. |
Cause
The volume group device files do not exist, and
this version of the vgimport command does not automatically
create them.
Recommended Action
Create the directory for the volume group, and
create a group file, as described in “Creating the Volume Group Device File”.
Message Text
Verification of unique LVM disk id on each disk in the volume group
/dev/vgname failed. |
Cause
There are two possible causes for this message:
The vgimport command used the –s option and two or more
disks on the system have the same LVM identifier; this can happen
when disks are created with BC copy or cloned with dd.
LVM was unable to read
the disk header; this can happen when you create new logical units
on a SAN array.
Recommended Action
Use vgimport without the –s option. Alternately, use vgchgid to change the LVM identifiers on copied or cloned
disks.
Retry the vgimport command.
/var/adm/syslog/syslog.log |
 |
Message Text
LVM: VG mm 0xnn0000:
Data in one or more logical volumes on PV nn 0x0nn000
was lost when the disk was replaced.
This occurred because the disk contained the only copy of the data.
Prior to using these logical volumes, restore the data from backup. |
Cause
LVM cannot synchronize the data on a replaced
disk automatically, for example, when LVM discovers an unmirrored
logical volume residing on a disk that was just replaced.
Recommended Action
Restore the contents of the logical volume from
backup.
Message Text
LVM: VG mm 0xnn0000: PVLink nn 0x0nn000 Detached. |
Cause:
This message is advisory. It is generated whenever
a disk path is detached.
Recommended Action
None.
Message Text
LVM: vg[nn] pv[nn] No valid MCR, resyncing all mirrored MWC LVs on the PV
|
Cause
This message appears when you import a volume
group from a previous release of HP-UX. The format of the MWC changed
at HP-UX 11i Version 3, so if the volume group contains mirrored logical
volumes using MWC, LVM converts the MWC at import time. It also performs
a complete resynchronization of all mirrored logical volumes, which
can take substantial time.
Recommended Action
None.
Message Text
LVM: vg 64 0xnnnnnn: Unable to register
for event notification on device 0xnnnnnnnn (1) |
Cause
This message can be displayed on the first system
boot after upgrading to HP-UX 11i Version 3. It is a transient message
caused by updates to the I/O configuration. Later in the boot process,
LVM registers for event notification again, and succeeds.
Recommended Action
None.