|
The communication server user interface provides several different command modes. Each command mode provides a group of related commands. Entering a question mark (?) at the system prompt allows you to obtain a list of commands available for each command mode.
The command interpreter is called the EXEC. The EXEC interprets the commands you type and carries out the corresponding operations. You must log into the communication server before you can enter an EXEC command. For security purposes, the EXEC has two levels of access to commands: user and privileged. The EXEC commands available at the user level are a subset of the EXEC commands available at the privileged level. From the privileged level, you can also access global configuration mode and six specific configuration modes: interface, subinterface, line, router, ipx router, and route map configuration.
If your communication server does not find a valid system image, or if its configuration file is corrupted at startup, the system might enter read-only memory (ROM) monitor mode. This command mode is also called bootstrap mode.
This chapter describes the commands specific to the user interface.
For user interface task information and examples, refer to the Communication Server Configuration Guide.
To manually boot the communication server, use the b ROM monitor command.
b [filename [address] ]filename | (Optional.) Name of the system image from which you want to netboot. |
address | (Optional.) IP address of the TFTP server on which the system image resides. If omitted, this value defaults to the IP broadcast address of 255.255.255.255. |
If you enter the b command and press Return, the communication server boots from ROM by default.
Use this command only when your communication server cannot find the configuration information needed in NVRAM. To get to the ROM monitor prompt, enter the reload EXEC command, and then press the Break key during the first 60 seconds of startup.
In the following example, the communication server is manually booted from ROM:
> b
F3:
(ROM Monitor copyrights)
In the following example, the file cstest is netbooted from IP address 131.108.15.112:
> b cstest 131.108.15.112
F3:
(ROM Monitor copyrights)
To exit to user EXEC mode from ROM monitor mode, use the c command.
cThere are no keywords or arguments for this command.
ROM monitor mode
In the following example, the c command is useto return to user EXEC mode from ROM monitor mode:
> c
cs >
To enter global configuration mode, use the configure privileged EXEC command. You must be in global configuration mode to enter global configuration commands.
configure {terminal | memory | network}terminal | Executes configuration commands from the terminal. |
memory | Executes the configuration commands stored in NVRAM. |
network | Retrieves the configuration commands stored in a file on a server. |
None
Privileged EXEC
If you do not specify terminal, memory, or network, the communication server prompts you for the source of configuration commands. After you enter the configure command, the system prompt changes from cs# to cs(config)#, indicating that you are in global configuration mode. To leave global configuration mode and return to the privileged EXEC prompt, press Ctrl-Z.
In the following example, the communication server is configured from the terminal:
cs
# configure
Configuring from terminal, memory, or network [terminal]?
Enter configuration commands, one per line. End with CNTL/Z.
communication server(config)#
In the following example, the communication server is configured from the file tokyo-confg at IP address 131.108.2.155:
cs1# configure network
Host or network configuration file [host]?
IP address of remote host [255.255.255.255]? 131.108.2.155
Name of configuration file [tokyo-confg]?
Configure using tokyo-confg from 131.108.2.155? [confirm] y
Booting tokyo-confg from 131.108.2.155:!! [OK - 874/16000 bytes]
The dagger (+) indicates that the command is documented in another chapter.
show configuration+
write memory+
write terminal+
To exit to user EXEC mode from privileged EXEC mode, use the disable command.
disableThere are no keywords or arguments for this command.
Privileged EXEC
In the following example, the disable command is useto return to the user EXEC level from privileged EXEC mode:
cs> enable
Password:
cs# disable
cs >
To enable enhanced editing mode for a particular line, use the editing line configuration command. To disable the enhanced editing mode, use the no form of this command.
editingThis command has no arguments or keywords.
Enabled
Line configuration
Table 1-1 provides a description of the keys used to enter and edit commands. Ctrl indicates the Control key. It must be pressed simultaneously with its associated letter key. Esc indicates the Escape key. It must be pressed first, followed by its associated letter key. Keys are not case sensitive.
Keys | Function |
---|---|
Tab | Completes a partial command name entry. When you enter a unique set of characters and press the Tab key, the system completes the command name. If you enter a set of characters that could indicate more than one command, the system beeps to indicate an error. Enter a question mark (?) immediately following the partial command (no space). The system will provide a list of commands that begin with that set of characters. |
Delete or Backspace | Erases the character to the left of the cursor. |
Return | At the command line, pressing the Return key performs the function of executing, or carrying out, a command. At the "---more---" prompt on a terminal screen, pressing the Return key scrolls down a line. |
Space bar | Scrolls down a page on the terminal screen. Press the space bar when you see the line "---more---" on the screen to display the next screen. |
Left arrow key1 | Moves the cursor one character to the left. When you enter a command that extends beyond a single line, you can continue to press the left arrow key at any time to scroll back towards the system prompt and verify the beginning of the command entry. |
Right arrow key1 | Moves the cursor one character to the right. |
Ctrl-A | Moves the cursor to the beginning of the line. |
Ctrl-B | Moves the cursor back one character. |
Ctrl-D | Deletes the character at the cursor. |
Ctrl-E | Moves the cursor to the end of the command line. |
Ctrl-F | Moves the cursor forward one character. |
Ctrl-K | Deletes all characters from the cursor to the end of the command line. |
Ctrl-L and Ctrl-R | Redisplays the system prompt and command line. |
Ctrl-T | Transposes the character to the left of the cursor with the character located at the cursor. |
Ctrl-U and Ctrl-X | Deletes all characters from the cursor back to the beginning of the command line. |
Ctrl-V and ESC-Q | Inserts a code to indicate to the system that the keystroke immediately following should be treated as a command entry, and not as an editing key. |
Ctrl-W | Deletes the word to the left of the cursor. |
Ctrl-Y | Recalls the most recent entry in the delete buffer. The delete buffer contains the last ten items you have deleted or cut. Ctrl-Y can be used in conjunction with Esc-Y. |
Ctrl-Z | Ends configuration mode and returns you to the privileged EXEC prompt. |
Esc-B | Moves the cursor back one word. |
Esc-C | Capitalizes the word at the cursor. |
Esc-D | Deletes from the cursor to the end of the word. |
Esc-F | Moves the cursor forward one word. |
Esc-L | Changes the word at the cursor to lowercase. |
Esc-U | Capitalizes from the cursor to the end of the word. |
Esc-Y | Recalls the next buffer entry. The buffer contains the last ten items you have deleted. Use Ctrl-Y first to recall the most recent entry. Then use Esc-Y up to nine times to recall the remaining entries in the buffer. If you bypass an entry, continue to use Esc-Y to cycle back to it. |
You can disable the enhanced editing mode with the no editing command. The editing keys and functions of the previous command editing mode are listed in Table 1-2.
Key | Function |
---|---|
Delete or Backspace | Erases the character to the left of the cursor. |
Ctrl-W | Erases a word. |
Ctrl-U | Erases a line. |
Ctrl-R | Redisplays a line. |
Ctrl-Z | Ends configuration mode and returns to the privileged EXEC prompt. |
Return | Executes single-line commands. |
In the following example, the enhanced editing mode is disabled on virtual terminal line 3:
line vty 03
no editing
terminal editing
To enter privileged EXEC mode, use the enable EXEC command.
enableThere are no keywords or arguments for this command.
EXEC
Because many of the privileged EXECcommands set operating parameters, privileged access should be password-protected to prevent unauthorized use. If the system administrator has set a password with the enable-password global configuration command, you are prompted to enter it before being allowed access to privileged EXEC mode. The password is case sensitive.
In the following example, the user enters the enable command and is prompted to enter a password. The password is not displayed on the screen. After entering the password, the system enters privileged command mode as indicated by the # symbol.
csr> enable
Password:
cs#
A dagger (+) indicates that the command is documented in another chapter.
enable password+
To exit global configuration mode, use the end global configuration command.
endThere are no keywords or arguments for this command.
Global configuration
You can also press Ctrl-Z to exit configuration mode.
In the following example, the communication server name is changed to alibaba using the hostname global configuration command. Entering the end command causes the system to exit configuration mode and return to EXEC mode.
csr(config)# hostname orange
orange(config)# end
orange#
To exit any configuration mode, enter the exit command at the system prompt.
exitThere are no keywords or arguments for this command.
Available in all command modes.
When you enter the exit command at the EXEC levels, the EXEC is ended. Enter the exit command in global configuration mode to return to privileged EXEC mode. Enter the exit command in interface, line, communication server, ipx-router, and route-map configuration modes to return to global configuration mode. Enter the exit command in subinterface configuration mode to return to interface configuration mode. You can also press Ctrl-Z from any configuration mode return to privileged EXEC mode.
In the following example, the user exits subinterface configuration mode to return to interface configuration mode:
cs(config-subif)# exit
cs(config-if)#
To obtain a list of the commands available in any command mode, enter the help command at the system prompt.
helpThis command has no arguments or keywords.
Available in all command modes
The help command provides a brief description of the context-sensitive help system. To obtain a list of commands that begin with a particular character set, enter the abbreviated command entry immediately followed by a question mark (?). To list all commands available for a particular command mode, enter a question mark (?) at the system prompt. To list a command's associated keywords, enter the command, a space, and then a question mark (?). To list a keyword's associated arguments, enter the command, the keyword, a space, and then a question mark (?).
Enter the help command at any time for a brief description of the help system:
cs1#
help
Help may be requested at any point in a command by entering
a question mark '?'. If nothing matches, the help list will
be empty and you must backup until entering a '?' shows the
available options.
Two styles of help are provided:
1. Full help is available when you are ready to enter a
command argument (e.g. 'show ?') and describes each possible
argument.
2. Partial help is provided when an abbreviated argument is entered
and you want to know what arguments match the input
(e.g. 'show pr?'.)
In the following example, the user enters the letters "co" at the system prompt immediately proceeded by a question mark (?) to verify the syntax of the configuration command. The system provides the commands that begin with those letters.
cs# co?
configure connect copy
In the following example, the user selects enters the access-list command, access list number, and deny argument. To recall the next command argument, the user enters a question mark (?):
cs(config)# access-list 99 deny ?
A.B.C.D Address to match
The user enters the IP address, a space, and a question mark (?) to list further options:
cs(config)# access-list 99 deny 131.108.134.234 ?
A.B.C.D Mask of bits to ignore
<cr>
The <cr> symbol in the previous example indicates that the mask argument is the final remaining option in the command syntax. The user enters the value for the mask argument and presses the Return key to execute the command.
cs(config)# access-list 99 deny 131.108.134.234 255.255.255.255
To change the command history buffer size for a particular line, use the history line configuration command. To disable the command history feature, use the no form of this command.
history size number-of-command-linesnumber-of-command-lines | Specifies the number of command lines that the system will record in its history buffer. The range is 0 through 256. |
10 lines
Line configuration
This feature is particularly useful to recall long or complex commands or entries, including access lists.
Table 1-3 lists the history command keys and functions.
Key | Function |
---|---|
Ctrl-P or Up Arrow. | Recall the most recent command in the history buffer. |
Ctrl-N or Down Arrow. | Recall remaining commands in the history buffer in a backward sequence. |
In the following example, virtual terminal line 4 is configured with a history buffer size of 35 lines:
line vty 4
history size 35
terminal history
To configure an interface type and enter interface configuration mode, use the interface global configuration command.
interface interface-type interface-numberTo configure a subinterface, use the interface global configuration command.
interface interface-type interface-number.subinterface-number [multipoint | point-to-point]
interface-type | Specifies the type of interface to be configured. See Table 1-4. |
interface-number | Specifies the port, connector, or interface card number. The numbers are assigned at the factory at the time of installation or when added to a system, and can be displayed with the show interfaces command. |
.subinterface-number | Specifies the subinterface number in the range 1 to 4294967293. The interface-number that precedes the period (.) must match the interface-number this subinterface belongs to. |
multipoint | point-to-point | Specifies a multipoint or point-to-point subinterface. Default is multipoint. |
The default mode for subinterfaces is multipoint.
Global configuration
Subinterfaces can be configured to support partially-meshed frame relay networks and multiple IPX encapsulations on LAN media (refer to the Communication Server Configuration Guide.)
In the following example, serial interface 0 is configured with PPP encapsulation:
interface serial 0
encapsulation ppp
The following example enables loopback mode and assigns an IP network address and network mask to the interface. The loopback interface established here will always appear to be up:
interface loopback 0
ip address 131.108.1.1 255.255.255.0
The following example shows how a partially-meshed frame relay network can be configured. In this example, subinterface serial 0.1 is configured as a multipoint subinterface with three frame relay PVCs associated, and subinterface serial 0.2 is configured as a point-to-point subinterface.
interface serial 0
encapsulation frame-relay
interface serial 0.1 multipoint
ip address 131.108.10.1 255.255.255.0
frame-relay interface-dlci 42 broadcast
frame-relay interface-dlci 53 broadcast
interface serial 0.2 point-to-point
ip address 131.108.11.1 255.255.0
frame-relay interface-dlci 59 broadcast
show interfaces
To enter IPX router configuration mode, enter the ipx routing global configuration command followed by the ipx router rip global configuration command:
router ipx riprip | Routing protocol. |
None
Global configuration
The novell and ipx commands and keywords are interchangeable. See the chapter,"Novell IPX Commands," for more information about Novell IPX commands.
In the following example, the user enters ipx router configuration mode:
cs(config)# ipx routing
cs(config)# ipx router rip
cs(config-ipx-router)# ?
Novell router configuration commands:
exit Exit from IPX routing protocol configuration mode
network Enable routing on an IPX network
no Negate or set default values of a command
cs(config-ipx-router)# network ?
<0-FFFFFFFF> IPX Network number
The dagger(+) indicates that the command is documented in another chapter.
ipx routing+
To identify a specific line for configuration and start the line command collection mode, use the line global configuration command.
line [type-keyword] line-number [ending-line-number]type-keyword | Specifies the type of line to be configured, it is one of the keywords listed in Table 1-5. |
line-number | Specifies the relative number of the terminal line (or the first line in a contiguous group) you want to configure when the line type is specified. Numbering begins with zero. The communication server displays an error message if you do not specify a line number. |
ending-line-number | Specifies the relative number of the last line in a contiguous group you want to configure. If you omit type-keyword, then line-number and ending-line-number are absolute rather than relative line numbers. |
Keywords | Line Command Mode |
---|---|
console | Console terminal line. |
aux | Auxiliary line. ASM-CS only. |
printer | Parallel printer line. |
tty | Standard asynchronous line. |
vty | A virtual terminal for remote console access. The communication server host can support five virtual terminals for access by incoming Telnet, LAT, or MOP connections. |
None
Global
You can display the absolute and relative line numbers by using the EXEC command show users all.
See the "Line Configuration and Terminal Settings Commands" chapter for more information about line configuration commands.
The following example starts configuration for the first five asynchronous terminal lines, 0 through 4.
line tty 0 4
The dagger (+) indicates that this command is documented in another chapter.
show users all+
To reload the operating system, use the reload EXEC command.
reloadThis command has no arguments or keywords.
EXEC
The reload command halts the system. If the system is set to restart on error, it reboots itself. The reload command is used after configuration information is entered into a file and saved into NVRAM.
The following example illustrates how to enter the reload command at the privileged EXEC prompt:
cs# reload
The dagger(+) indicates that the command is documented in another chapter.
write memory+
To enter route map configuration mode, use the route-map command:
route-map map-tag {permit | deny} sequence-numbermap-tag | Defines a meaningful name for the route map. The redistribute router configuration command uses this name to reference this route map. Multiple route maps may share the same map tag name. |
permit | If the match criteria are met for this route map, and permit is specified, the route is redistributed as controlled by the set actions. If the match criteria are not met, and permit is specified, the next route map with the same map-tag is tested. If a route passes none of the match criteria for the set of route maps sharing the same name, it is not redistributed by that set. |
deny | If the match criteria are met for the route map, and deny is specified, the route is not redistributed, and no further route maps sharing the same map tag name will be examined. |
sequence-number | Number that indicates the position a new route map is to have in the list of route maps already configured with the same name. If given with the no form of this command, it specifies the position of the route map that should be deleted. |
See the"IPRouting Protocol Commands" chapter for more information about the route-map command.
In the following example, a route map named arizona1 is configured at the global configuration prompt. The new prompt is (config-route-map)#. Enter a question mark (?) to list route-map configuration commands.
cs(config-ipx-router)# exit
cs(config)# route-map ?
WORD Route map tag
cs(config)# route-map arizona1
cs(config-route-map)# ?
Route Map configuration commands:
exit Exit from route-map configuration mode
help Description of the interactive help system
match Match values from routing table
no Negate or set default values of a command
set Set values in destination routing protocol
To configure IP routing protocols, use the router command:
router protocol autonomous systemSee the"IP Routing Protocols" chapter for more information about using this command to configure IP routing protocols.
This command takes you into router configuration mode, as shown in the following example:
cs(config)# router bgp 4
cs(config-router)#
To list the commands you have entered in the current EXEC session, use the show history EXEC command.
show historyThere are no keywords or arguments for this command.
EXEC
The number of commands the history buffer will record is determined by the terminal history EXEC command.
In the following example, the show history command lists the commands the user has entered in EXEC mode for this session:
cs# show history
help
where
show hosts
show history
cs#
terminal history
To enable the enhanced editing mode for the current terminal session, use the terminal editing command. To disable the enhanced editing mode for this session, use the no form of this command.
terminal editingThis command has no arguments or keywords.
Enabled
EXEC
Table 1-6 provides a description of the keys used to enter and edit commands. Ctrl indicates the Control key. It must be pressed simultaneously with its associated letter key. Esc indicates the Escape key. It must be pressed first, followed by its associated letter key. Keys are not case sensitive.
Keys | Function |
---|---|
Tab | Completes a partial command name entry. When you enter a unique set of characters and press the Tab key, the system completes the command name. If you enter a set of characters that could indicate more than one command, the system beeps to indicate an error. Enter a question mark (?) immediately following the partial command (no space). The system will provide a list of commands that begin with that set of characters. |
Delete or Backspace | Erases the character to the left of the cursor. |
Return | At the command line, pressing the Return key performs the function of executing, or carrying out, a command. At the "---more---" prompt on a terminal screen, pressing the Return key scrolls down a line. |
Space Bar | Scrolls down a page on the terminal screen. Press the space bar when you see the line "---more---" on the screen to display the next screen. |
Left Arrow key1 | Moves the cursor one character to the left. When you enter a command that extends beyond a single line, you can continue to press the left arrow key at any time to scroll back towards the system prompt and verify the beginning of the command entry. |
Right Arrow key1 | Moves the cursor one character to the right. |
Ctrl-A | Moves the cursor to the beginning of the line. |
Ctrl-B | Moves the cursor back one character. |
Ctrl-D | Deletes the character at the cursor. |
Ctrl-E | Moves the cursor to the end of the command line. |
Ctrl-F | Moves the cursor forward one character. |
Ctrl-K | Deletes all characters from the cursor to the end of the command line. |
Ctrl-L and Ctrl-R | Redisplays the system prompt and command line. |
Ctrl-T | Transposes the character to the left of the cursor with the character located at the cursor. |
Ctrl-U and Ctrl-X | Deletes all characters from the cursor back to the beginning of the command line. |
Ctrl-V and Esc-Q | Inserts a code to indicate to the system that the keystroke immediately following should be treated as a command entry, and not as an editing key. |
Ctrl-W | Deletes the word to the left of the cursor. |
Ctrl-Y | Recalls the most recent entry in the delete buffer. The delete buffer contains the last ten items you have deleted or cut. Ctrl-Y can be used in conjunction with Esc-Y. |
Ctrl-Z | Ends configuration mode and returns you to the privileged EXEC prompt. |
Esc-B | Moves the cursor back one word. |
Esc-C | Capitalizes the word at the cursor. |
Esc-D | Deletes from the cursor to the end of the word. |
Esc-F | Moves the cursor forward one word. |
Esc-L | Changes the word at the cursor to lowercase. |
Esc-U | Capitalizes from the cursor to the end of the word. |
Esc-Y | Recalls the next buffer entry. The buffer contains the last ten items you have deleted. Use Ctrl-Y first to recall the most recent entry. Then use Esc-Y up to nine times to recall the remaining entries in the buffer. If you bypass an entry, continue to use Esc-Y to cycle back to it. |
You can disable the enhanced editing mode with the no terminal editing command. The editing keys and functions of the previous command editing mode are listed in Table 1-7.
Key | Function |
---|---|
Delete or Backspace | Erases the character to the left of the cursor. |
Ctrl-W | Erases a word. |
Ctrl-U | Erases a line. |
Ctrl-R | Redisplays a line. |
Ctrl-Z | Ends configuration mode and returns to the privileged EXEC prompt. |
Return | Executes single-line commands. |
In the following example, enhanced mode editing is enabled for the current terminal session:
terminal editing
editing
To change the command history buffer size for the current terminal session, use the terminal history EXEC command. To disable the enhanced editing mode, use the no form of this command.
terminal history size number-of-command-linesnumber-of-command-lines | Specifies the number of command lines that the system will record in its history buffer. The range is 0 through 256. |
10 lines
EXEC
The command history feature provides a record of EXEC commands you have entered. This feature is particularly useful to recall long or complex commands or entries, including access lists. You can configure the number of commands, or lines, the system will record (the minimum is 1 line; the maximum is 255 lines).Table 1-8 lists the history command keys and functions.
Key | Function |
---|---|
Ctrl-P or Up Arrow. | Recall the most recent command in the history buffer. |
Ctrl-N or Down Arrow. | Recall remaining commands in the history buffer in a backward sequence. |
In the following example, the number of command lines recorded is set to 15 for the current terminal session:
terminal history 15
history
show history
|