cc/td/doc/product/software/ios124/124tcg
hometocprevnextglossaryfeedbacksearchhelp
PDF

Table Of Contents

Network Management, MIBs, and SNMP on the Home Agent

Operating and Maintaining the Cisco Mobile Wireless Home Agent

Statistics

Conditional Debugging

Monitoring and Maintaining the HA


Network Management, MIBs, and SNMP on the Home Agent


This chapter contains information pertaining to various aspects of Network Management on the
Cisco Mobile Wireless Home Agent.

This chapter includes the following sections:

• Operating and Maintaining the Cisco Mobile Wireless Home Agent

• Statistics

• SNMP, MIBs and Network Management

• Conditional Debugging

• Monitoring and Maintaining the HA

Operating and Maintaining the Cisco Mobile Wireless Home Agent

This section describes configuration details, statistics, and MIBs supported by the Home Agent. A definitive description of each Mobile IP command can be found at the following URL: http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fipras_r/1rfmobip.htm

The Home Agent can be managed using either the Cisco IOS CLI or using Cisco Works for Mobile Wireless.

Cisco's Mobile Wireless Home Agent has the following configurable parameters:

•Managing user profiles (local users)

•Configuring IP pools locally

•Configuring security associations with communicating nodes

•Configuring ingress/egress filtering

•Configuring mobile binding updates

•Configuring routing information

Statistics

The Mobile Wireless Home Agent maintains statistics on a global basis for the following parameters:

•Advertisements, received and sent

•Registrations, requests and replies

•Registrations, accepted and denied

•Bindings

•Binding Updates

•Gratuitous and Proxy ARPs

•Route Optimization Binding Updates

The Mobile Wireless Home Agent maintains statistics on a per FA-HA tunnel basis for the following parameters:

•Source and Destination IP address of the tunnel

•Tunnel Type, IPinIP or GRE

•Reverse Tunneling allowed

•Number of Users using that tunnel

•Traffic sent on the tunnel, packets and bytes

•Traffic received on the tunnel, packets and bytes

The Mobile Wireless Home Agent maintains statistics per host, identified by NAI or home IP address, for the following parameters:

•Lifetime

•Session duration

•Traffic transmitted to the host, packets and bytes

•Traffic received from the host on the reverse tunnel, packets and bytes


Note The statistics can be cleared from the CLI. The MIB counters are not cleared.


SNMP, MIBs and Network Management

The HA implements SNMPv2 as specified in the suite of protocols: RFC 1901 to RFC 1908. The Home Agent supports the MIB defined in "The Definitions of Managed Objects for IP Mobility Support UsingSMIv2," RFC 2006, October 1995. An additional Cisco MIB, CISCO- MOBILE-IP-MIB provides enhanced management capabilities. The RADIUS MIB, as defined in RADIUS Authentication Client MIB, RFC 2618, June 1999. A full list of MIBs that are supported on the Ciscco 7200 Internet Router, Cisco 7600 Switch and Cisco 6500 Catalyst series platforms can be found at the following URL: http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

Session counters maintained in the MIB cannot be reset using SNMP or the Cisco IOS CLI. Home Agent CPU and Memory Utilization counters are accessible using the CISCO-PROCESS-MIB.

Release 3.0 adds a Home Agent Version MIB Object.

Conditional Debugging

The HA supports conditional debugging based on NAI, as well as conditional debugging based on the MN's home address. Only AAA and Mobile IP components will support conditional debugging.

From the CLI, it is possible to trace activity of all or a particular user identified by NAI. Monitoring the activity of a particular user, called conditional debugging, will display the user activity related to Mobile IP messages and the RADIUS messages.

This release provides an option to display the condition (username/IMSI), along with each debug statement. This helps to match a debug statement to its condition. To enable this feature, use the following command:

ip mobile home-agent debug include username

The following MobileIP debugs are supported for conditional debugging:

•debug ip mobile

•debug ip mobile host

The following AAA debugs are supported for conditional debugging:

•debug aaa authentication

•debug aaa authorization

•debug aaa accounting

•debug aaa ipc

•debug aaa attr

•debug aaa id

•debug aaa subsys

The following RADIUS debugs are supported for conditional debugging:

•debug radius

•debug radius accounting

•debug radius authentication

•debug radius retransmit

•debug radius failover

•debug radius brief

Monitoring and Maintaining the HA

To monitor and maintain the HA, use the following commands in privileged EXEC mode:

Command
Purpose

Router# clear ip mobile binding


Removes mobility bindings.

Router# clear ip mobile host-counters


Clears the mobility counters specific to each mobile station.

Router#clear ip mobile secure

Clears and retrieves remote security associations.

Router#clear ip mobile traffic

Clears IP mobile traffic counters.

Router# debug ip mobile advertise

Displays advertisement information.

Router# debug aaa pod

Displays debug information for Radius Disconnect message processing at AAA subsystem level

Router# debug ip mobile

Displays IP mobility activities.

Router# debug ip mobile host

Displays mobility event information.

Router# debug ip mobile redundancy

Displays IP mobility events.

Router# debug radius

Displays information associated with RADIUS.

Router#debug tacacs

Displays information associated with TACACS.

Router# show ip mobile binding

Displays the mobility binding table.

Router# show ip mobile binding vrf

Displays all the bindings on the HA that are VRF-enabled.

Router#show ip mobile binding vrf realm

Displays all bindings for the realm that are VRF-enabled.

Router#show ip mobile globals

Displays global information for Mobile Agents.

Router# show ip mobile host

Displays mobile station counters and information.

Router# show ip mobile proxy

Displays information about a proxy Mobile IP host.

Router#show ip mobile secure


Displays mobility security associations for Mobile IP.

Router#show ip mobile traffic

Displays Home Agent protocol counters.

Router#show ip mobile tunnel

Displays information about the mobile IP tunnel.

Router#show ip mobile violation

Displays information about security violations.

Router#show ip route vrf

Displays the routing table information corresponding to a VRF.



hometocprevnextglossaryfeedbacksearchhelp

Posted: Fri Nov 17 00:44:19 PST 2006
All contents are Copyright © 1992--2006 Cisco Systems, Inc. All rights reserved.
Important Notices and Privacy Statement.