|
Use the commands in this chapter to configure and monitor the Internet Protocol (IP) enhanced IGRP on IP networks. For IP enhanced IGRP routing protocol configuration information and examples, refer to the "Configuring IP Enhanced IGRP" chapter in this publication. For a description of other IP configuration commands, refer to the Router Products Configuration Guide and the Router Products Command Reference publications. For historical background and a technical overview of IP, see the Internetworking Technology Overview publication.
To configure automatic summarization of subnet routes into network level routes, use the auto-summary router configuration command. To disable this feature, use the no form of this command.
auto-summaryThis command has no arguments or keywords.
Enabled
Router configuration
IP enhanced IGRP summary routes are given an administrative distance value of 5. You cannot configure this value.
The following example configures automatic summarization and sets the IP summary aggregate address for interface Ethernet 0:
router eigrp 109
auto-summary
ip summary-address eigrp
To delete entries from the neighbor table, use the clear ip eigrp neighbors EXEC command.
clear ip eigrp neighbors [ip-address | interface]ip-address | (Optional) Address of the neighbor. |
interface | (Optional) Interface type and number. Specifying this argument removes from the neighbor table all entries learned via this interface. |
EXEC
The following example removes the neighbor whose address is 160.20.8.3:
clear ip eigrp neighbors 160.20.8.3
show ip eigrp neighbors
To control the redistribution of routing information between IP enhanced IGRP processes, use the default-information allowed router configuration command. To suppress IP enhanced IGRP exterior or default routes when they are received by an IP enhanced IGRP process, use the no default-information allowed in command. To suppress IP enhanced IGRP exterior routes in updates, use the no default-information allowed out command.
default-information allowed {in | out} [route-map map-tag]in | Allows IP enhanced IGRP exterior or default routes to be received by an IP enhanced IGRP process. |
out | Allows IP enhanced IGRP exterior routes to be advertised in updates. |
route-map map-tag | (Optional) Indicates that the route map should be interrogated to filter the importation of routes from this source routing protocol to the current routing protocol. The argument map-tag is the identifier of a configured route map. If you specify route-map without specifying map-tag, no routes are imported. If you omit route-map, all routes are redistributed. |
Normally, exterior routes are always accepted and default information is passed between IP enhanced IGRP processes when doing redistribution.
Router configuration
The default network of 0.0.0.0 used by RIP cannot be redistributed by IP enhanced IGRP.
The following example allows IP enhanced IGRP exterior or default routes to be received by the IP enhanced IGRP process in autonomous system 23:
router eigrp 23
default-information allowed in
To set default metric values for the RIP, EGP, BGP, IGRP, and enhanced IGRP routing protocols, use this form of the default-metric router configuration command. To remove the metric value and return to the default state, use the no form of this command.
default-metric numbernumber | Default metric value appropriate for the specified routing protocol |
Built-in, automatic metric translations, as appropriate for each routing protocol
Router configuration
The default-metric command is used in conjunction with the redistribute router configuration command to cause the current routing protocol to use the same metric value for all redistributed routes. A default metric helps solve the problem of redistributing routes with incompatible metrics. Whenever metrics do not convert, using a default metric provides a reasonable substitute and enables the redistribution to proceed.
The following example shows a router in autonomous system 109 using both the RIP and the IGRP routing protocols. The example advertises IGRP-derived routes using the RIP protocol and assigns the IGRP-derived routes a RIP metric of 10.
router rip
default-metric 10
redistribute igrp 109
redistribute
To set metrics for IP enhanced IGRP, use this form of the default-metric router configuration command. To remove the metric value and return to the default state, use the no form of this command.
default-metric bandwidth delay reliability loading mtubandwidth | Minimum bandwidth of the route in kilobits per second. It can be 0 or any positive integer. |
delay | Route delay in tens of microseconds. It can be 0 or any positive number that is a multiple of 39.1 nanoseconds. |
reliability | Likelihood of successful packet transmission expressed as a number between 0 and 255. The value 255 means 100 percent reliability, and the value 0 means no reliability. |
loading | Effective bandwidth of the route in kilobits per second. It can be a number from 0 to 255. |
mtu | Minimum maximum transmission unit (MTU) size of the route in bytes. It can be 0 or any positive integer. |
Disabled
Router configuration
IP enhanced IGRP metric defaults have been carefully set to work for a wide variety of networks. Take great care in changing these values.
Automatic metric translations for enhanced IGRP are supported only when redistributing from IGRP, enhanced IGRP, or static routes.
The following example takes redistributed RIP metrics and translates them into IP enhanced IGRP metrics with values as follows: bandwidth of 1000 kbps, delay of 100 microseconds, reliability of 250, loading of 100 kbps, and MTU of 1500 bytes.
router eigrp 109
network 131.108.0.0
redistribute rip
default-metric 1000 10 250 100 1500
redistribute
To allow the use of two administrative distances--internal and external--that could be a better route to a node, use the distance eigrp router configuration command. To reset these values to their defaults, use the no form of this command.
distance eigrp internal-distance external-distanceinternal-distance | Administrative distance for IP enhanced IGRP internal routes. Internal routes are those that are learned from another entity within the same autonomous system. It can be a value from 1 to 255. |
external-distance | Administrative distance for IP enhanced IGRP external routes. External routes are those for which the best path is learned from a neighbor external to the autonomous system. It can be a value from 1 to 255. |
internal-distance: 90
external-distance: 170
Router configuration
An administrative distance is a rating of the trustworthiness of a routing information source, such as an individual router or a group of routers. Numerically, an administrative distance is an integer between 0 and 255. In general, the higher the value, the lower the trust rating. An administrative distance of 255 means the routing information source cannot be trusted at all and should be ignored.
Use the distance eigrp command if another protocol is known to be able to provide a better route to a node than was actually learned via external IP enhanced IGRP or if some internal routes should really be preferred by IP enhanced IGRP.
Table 6-1 lists the default administrative distances.
Route Source | Default Distance |
---|---|
Connected interface | 0 |
Static route | 1 |
Enhanced IGRP summary route | 5 |
External BGP | 20 |
Internal enhanced IGRP | 90 |
IGRP | 100 |
OSPF | 110 |
IS-IS | 115 |
RIP | 120 |
EGP | 140 |
External enhanced IGRP | 170 |
Internal BGP | 200 |
Unknown | 255 |
To display the default administrative distance for a specified routing process, use the show ip protocols EXEC command.
In the following example, the router eigrp global configuration command sets up IP enhanced IGRP routing in autonomous system number 109. The network router configuration commands specify IP enhanced IGRP routing on networks 192.31.7.0 and 128.88.0.0. The first distance router configuration command sets the default administrative distance to 255, which instructs the router to ignore all routing updates from routers for which an explicit distance has not been set. The second distance router configuration command sets the administrative distance for all routers on the Class C network 192.31.7.0 to 90. The third distance router configuration command sets the administrative distance for the router with the address 128.88.1.3 to 120.
router eigrp 109
network 192.31.7.0
network 128.88.0.0
distance 255
!
! use caution when executing the next two commands!
!
distance 90 192.31.7.0 0.0.0.255
distance 120 128.88.1.3 0.0.0.0
show ip protocols
To filter networks received in updates, use the distribute-list in router configuration command. To change or cancel the filter, use the no form of this command.
distribute-list access-list-number in [interface-name]access-list-number | Standard IP access list number. The list defines which networks are to be received and which are to be suppressed in routing updates. |
in | Applies the access list to incoming routing updates. |
interface-name | (Optional) Interface on which the access list should be applied to incoming updates. If no interface is specified, the access list will be applied to all incoming updates. |
Disabled
Router configuration
In the following example, the IP enhanced IGRP routing process accepts only two networks--network 0.0.0.0 and network 131.108.0.0:
access-list 1 permit 0.0.0.0
access-list 1 permit 131.108.0.0
access-list 1 deny 0.0.0.0 255.255.255.255
router eigrp
network 131.108.0.0
distribute-list 1 in
A dagger (+) indicates that the command is documented in the Router Products Command Reference publication.
access-list +
distribute-list out
redistribute
To suppress networks from being advertised in updates, use the distribute-list out router configuration command. To cancel this function, use the no form of this command.
distribute-list access-list-number out [interface-name | routing-process |access-list-number | Standard IP access list number. The list defines which networks are to be sent and which are to be suppressed in routing updates. |
out | Applies the access list to outgoing routing updates. |
interface-name | (Optional) Name of a particular interface. |
routing-process | (Optional) Name of a particular routing process, or the keyword static or connected. |
autonomous-system-number | Autonomous system number. |
Disabled
Router configuration
When redistributing networks, you can specify a routing process name as an optional trailing argument to the distribute-list out command. This causes the access list to be applied only to those routes derived from the specified routing process. After the process-specific access list is applied, any access list you specify by a distribute-list out command without a process name argument are applied. Addresses not specified in the distribute-list out command are not advertised in outgoing routing updates.
In the following example, the IP enhanced IGRP routing process advertises only one network--network 131.108.0.0.
access-list 1 permit 131.108.0.0
access-list 1 deny 0.0.0.0 255.255.255.255
router eigrp
network 131.108.0.0
distribute-list 1 out
In the following example, access list 1 is applied to outgoing routing updates and IS-IS is enabled on interface Ethernet 0. Only network 131.131.101.0 will be advertised in outgoing IS-IS routing updates.
router isis
redistribute ospf 109
distribute-list 1 out
interface Ethernet 0
ip router isis
access-list 1 permit 131.131.101.0 0.0.0.255
A dagger (+) indicates that the command is documented in the Router Products Command Reference publication.
access-list +
distribute-list in
redistribute
To configure the hello interval for the IP enhanced IGRP routing process designated by an autonomous system number, use the ip hello-interval eigrp interface configuration command. To restore the default value, use the no form of this command.
ip hello-interval eigrp autonomous-system-number secondsautonomous-system-number | Autonomous system number |
seconds | Hello interval, in seconds |
5 seconds
Interface configuration
The following example sets the hello interval for interface Ethernet 0 to 10 seconds:
interface ethernet 0
ip hello-interval eigrp 109 10
ip hold-time eigrp
To configure the hold time for the IP enhanced IGRP routing process designated by the autonomous system number, use the ip hold-time eigrp interface configuration command. To restore the default value, use the no form of this command.
ip hold-time eigrp autonomous-system-number secondsautonomous-system-number | Autonomous system number |
seconds | Hold time, in seconds |
15 seconds
Interface configuration
The hold time is three times the hello interval. If the current value for the hold time is less than two times the hello interval, the hold time is reset.
If a router does not receive a hello packet within the specified hold time, routes through the router are considered available.
Increasing the hold time delays route convergence across the network.
The following example sets the hold time for Ethernet interface 0 to 40 seconds:
interface ethernet 0
ip hold-time eigrp 109 40
ip hello-interval eigrp
To enable IP enhanced IGRP split horizon, use the ip split-horizon eigrp interface configuration command. To disable split horizon, use the no form of this command.
ip split-horizon eigrp autonomous-system-numberautonomous-system-number | Autonomous system number |
Enabled
Interface configuration
For networks that include links over X.25 PSNs, you can use the neighbor router configuration command to defeat the split horizon feature. As an alternative, you can explicitly specify the no ip split-horizon eigrp command in your configuration. However, if you do so, you must similarly disable split horizon for all routers in any relevant multicast groups on that network.
In general, it is recommended that you not change the default state of split horizon unless you are certain that your application requires the change in order to properly advertise routes. Remember that if split horizon is disabled on a serial interface and that interface is attached to a packet-switched network, you must disable split horizon for all routers in any relevant multicast groups on that network.
The following example disables split horizon on a serial link connected to an X.25 network:
interface serial 0
encapsulation x25
no ip split-horizon eigrp
A dagger (+) indicates that the command is documented in the Router Products Command Reference publication.
ip split-horizon +
neighbor +
To configure a summary aggregate address for a specified interface, use the ip summary-address eigrp interface configuration command. To disable a configuration, use the no form of this command.
ip summary-address eigrp autonomous-system-number address maskautonomous-system-number | Autonomous system number |
address | IP summary aggregate address to apply to an interface |
mask | Subnet mask |
No summary aggregate addresses are predefined.
Interface configuration
IP enhanced IGRP summary routes are given an administrative distance value of 5. You cannot configure this value.
The following example sets the IP summary aggregate address for Ethernet interface 0:
interface ethernet 0
ip summary-address eigrp 109 192.1.0.0 255.255.0.0
auto-summary
To distribute any routes that have their next hop out one of the interfaces specified, use the match interface route-map configuration command. To remove the match interface entry, use the no form of this command.
match interface type unit...type unitname unit | Interface name and number |
No match interfaces are defined.
Route-map configuration
Use the route-map global configuration command and the route-map configuration commands match and set to define the conditions for redistributing routes from one routing protocol into another. Each route-map command has a list of match and set commands associated with it. The match commands specify the match criteria--the conditions under which redistribution is allowed for the current route-map. The set commands specify the set actions--the particular redistribution actions to perform if the criteria enforced by the match commands are met. The no route-map command deletes the route map.
The match route-map configuration command has multiple formats. The match commands may be given in any order, and all match commands must "pass" to cause the route to be redistributed according to the set actions given with the set commands. The no forms of the match commands remove the specified match criteria.
A route map can have several parts. Any route that does not match at least one match clause relating to a route-map command will be ignored; that is, the route will not be advertised for outbound route maps and will not be accepted for inbound route maps. If you want o modify only some data, you must configure second route-map section with an explicit match specified.
In the following example, routes that have their next hop out Ethernet interface 0 are distributed:
route-map name
match interface ethernet 0
route-map
set
To distribute any routes that have a destination network number address that is permitted by a standard access list, use the match ip address route-map configuration command. To remove the match ip address entry, use the no form of this command.
match ip address access-list-number...access-list-numberaccess-list-number | Number of an access list. It can be an integer from 1 through 99. |
No access list numbers are specified.
Route-map configuration
Use the route-map global configuration command and the route-map configuration commands match and set to define the conditions for redistributing routes from one routing protocol into another. Each route-map command has a list of match and set commands associated with it. The match commands specify the match criteria--the conditions under which redistribution is allowed for the current route-map. The set commands specify the set actions--the particular redistribution actions to perform if the criteria enforced by the match commands are met. The no route-map command deletes the route map.
The match route-map configuration command has multiple formats. The match commands may be given in any order, and all match commands must "pass" to cause the route to be redistributed according to the set actions given with the set commands. The no forms of the match commands remove the specified match criteria.
A route map can have several parts. Any route that does not match at least one match clause relating to a route-map command will be ignored; that is, the route will not be advertised for outbound route maps and will not be accepted for inbound route maps. If you want o modify only some data, you must configure second route-map section with an explicit match specified.
In the following example, routes that have addresses specified by access list numbers 5 and 80 are distributed:
route-map name
match ip address 5 80
route-map
set
To redistribute any routes that have a next-hop router address passed by one of the access lists specified, use the match ip next-hop route-map configuration command. To remove the next-hop entry, use the no form of this command.
match ip next-hop access-list-number...access-list-numberaccess-list-number | Number of an access list. It can be an integer from 1 through 99. |
Routes are distributed freely, without being required to match a next-hop address.
Route-map configuration
Use the route-map global configuration command and the route-map configuration commands match and set to define the conditions for redistributing routes from one routing protocol into another. Each route-map command has a list of match and set commands associated with it. The match commands specify the match criteria--the conditions under which redistribution is allowed for the current route-map. The set commands specify the set actions--the particular redistribution actions to perform if the criteria enforced by the match commands are met. The no route-map command deletes the route map.
The match route-map configuration command has multiple formats. The match commands may be given in any order, and all match commands must "pass" to cause the route to be redistributed according to the set actions given with the set commands. The no forms of the match commands remove the specified match criteria.
A route map can have several parts. Any route that does not match at least one match clause relating to a route-map command will be ignored; that is, the route will not be advertised for outbound route maps and will not be accepted for inbound route maps. If you want o modify only some data, you must configure second route-map section with an explicit match specified.
In the following example, routes that have a next-hop router address passed by access list 5 or 80 are distributed:
route-map name
match ip next-hop 5 80
route-map
set
To redistribute routes that have been advertised by routers at the address specified by the access lists, use the match ip route-source route-map configuration command. To remove the route-source entry, use the no form of this command.
match ip route-source access-list-number...access-list-numberaccess-list-number | Number of an access list. It can be an integer from 1 through 99. |
No filtering on route source.
Route-map configuration
Use the route-map global configuration command and the route-map configuration commands match and set to define the conditions for redistributing routes from one routing protocol into another. Each route-map command has a list of match and set commands associated with it. The match commands specify the match criteria-- the conditions under which redistribution is allowed for the current route-map. The set commands specify the set actions--the particular redistribution actions to perform if the criteria enforced by the match commands are met. The no route-map command deletes the route map.
The match route-map configuration command has multiple formats. The match commands may be given in any order, and all match commands must "pass" to cause the route to be redistributed according to the set actions given with the set commands. The no forms of the match commands remove the specified match criteria.
A route map can have several parts. Any route that does not match at least one match clause relating to a route-map command will be ignored; that is, the route will not be advertised for outbound route maps and will not be accepted for inbound route maps. If you want o modify only some data, you must configure second route-map section with an explicit match specified.
There are situations in which a route's next hop and source router address are not the same.
In the following example, routes that have been advertised by routers at the addresses specified by access lists 5 and 80 are distributed:
route-map name
match ip route-source 5 80
route-map
set
To redistribute routes with the metric specified, use the match metric route-map configuration command. To remove the entry, use the no form of this command.
match metric metric-valuemetric-value | Route metric, which can be an IGRP five-part metric. It is a metric value from 0 through 4294967295. |
No filtering on a metric value.
Route-map configuration
Use the route-map global configuration command and the route-map configuration commands match and set to define the conditions for redistributing routes from one routing protocol into another. Each route-map command has a list of match and set commands associated with it. The match commands specify the match criteria--the conditions under which redistribution is allowed for the current route-map. The set commands specify the set actions--the particular redistribution actions to perform if the criteria enforced by the match commands are met. The no route-map command deletes the route map.
The match route-map configuration command has multiple formats. The match commands may be given in any order, and all match commands must "pass" to cause the route to be redistributed according to the set actions given with the set commands. The no forms of the match commands remove the specified match criteria.
A route map can have several parts. Any route that does not match at least one match clause relating to a route-map command will be ignored; that is, the route will not be advertised for outbound route maps and will not be accepted for inbound route maps. If you want o modify only some data, you must configure second route-map section with an explicit match specified.
In the following example, routes with the metric 5 are redistributed:
route-map name
match metric 5
route-map
set
To redistribute routes of the specified type, use the match route-type route-map configuration command. To remove the route-type entry, use the no form of this command.
match route-type {internal | external | level-1 | level-2}internal | OSPF intra-area and interarea routes or enhanced IGRP internal routes |
external | OSPF external type-1 or type-2 routes, or enhanced IGRP external routes |
level-1 | IS-IS Level 1 routes |
level-2 | IS-IS Level 2 routes |
Disabled
Route-map configuration
Use the route-map global configuration command and the route-map configuration commands match and set to define the conditions for redistributing routes from one routing protocol into another. Each route-map command has a list of match and set commands associated with it. The match commands specify the match criteria--the conditions under which redistribution is allowed for the current route-map. The set commands specify the set actions--the particular redistribution actions to perform if the criteria enforced by the match commands are met. The no route-map command deletes the route map.
The match route-map configuration command has multiple formats. The match commands may be given in any order, and all match commands must "pass" to cause the route to be redistributed according to the set actions given with the set commands. The no forms of the match commands remove the specified match criteria.
A route map can have several parts. Any route that does not match at least one match clause relating to a route-map command will be ignored; that is, the route will not be advertised for outbound route maps and will not be accepted for inbound route maps. If you want o modify only some data, you must configure second route-map section with an explicit match specified.
In the following example, internal routes are redistributed:
route-map name
match route-type internal
route-map
set
To redistribute routes in the routing table that match the specified tags, use the match tag command. To remove the tag entry, use the no form of this command.
match tag tag-value...tag-valuetag-value | List of one or more route tag values. Each can be an integer from 0 through 4294967295. |
No match tag values are defined.
Route-map configuration
Use the route-map global configuration command and the route-map configuration commands match and set to define the conditions for redistributing routes from one routing protocol into another. Each route-map command has a list of match and set commands associated with it. The match commands specify the match criteria--the conditions under which redistribution is allowed for the current route-map. The set commands specify the set actions--the particular redistribution actions to perform if the criteria enforced by the match commands are met. The no route-map command deletes the route map.
The match route-map configuration command has multiple formats. The match commands may be given in any order, and all match commands must "pass" to cause the route to be redistributed according to the set actions given with the set commands. The no forms of the match commands remove the specified match criteria.
A route map can have several parts. Any route that does not match at least one match clause relating to a route-map command will be ignored; that is, the route will not be advertised for outbound route maps and will not be accepted for inbound route maps. If you want o modify only some data, you must configure second route-map section with an explicit match specified.
In the following example, routes stored in the routing table with tag 5 are redistributed:
route-map name
match tag 5
route-map
set
To allow the tuning of the IP enhanced IGRP metric calculations, use the metric weights router configuration command. Use the no metric weights command to reset the values to their defaults.
metric weights tos k1 k2 k3 k4 k5tos | Type of Service. Currently, it must always be 0. |
k1, k2, k3, k4, k5 | Constants that convert an IP enhanced IGRP metric vector into a scalar quantity. |
k1: 1
k2: 0
k3: 1
k4: 0
k5: 0
Router configuration
Use the metric weights command to alter the default behavior of IP enhanced IGRP routing and metric computation and allow the tuning of the IP enhanced IGRP metric calculation for a particular Type of Service (TOS).
If k5 equals 0, the composite IP enhanced IGRP metric is computed according to the following formula:
metric = [k1 * bandwidth + (k2 * bandwidth)/(256 - load) + k3 * delay]
If k5 does not equal zero, an additional operation is done:
metric = metric * [k5 / (reliability + k4)]
Bandwidth is inverse minimum bandwidth of the path in bits per second scaled by a factor of 2.56 ¥ 1012. The range is from a 1200-bps line to 10 terabits per second.
The delay parameter is stored in a 32-bit field, in increments of 39.1 nanoseconds. This gives a range of 1 (39.1 nanoseconds) to hexadecimal FFFFFFFF (decimal 4,294,967,040 nanoseconds). A delay of all ones (that is, a delay of hexadecimal FFFFFFFF) indicates that the network is unreachable.
Table 6-2 lists the default values used for several common media.
Media Type | Delay | Bandwidth |
---|---|---|
Satellite | 5120 (2 seconds) | 5120 (500 Mbits) |
Ethernet | 25600 (1 ms) | 256000 (10 Mbits) |
1.544 Mbps | 512000 (20,000 ms) | 1,657,856 bits |
64 kbps | 512000 (20,000 ms) | 40,000,000 bits |
56 kbps | 512000 (20,000 ms) | 45,714,176 bits |
10 kbps | 512000 (20,000 ms) | 256,000,000 bits |
1 kbps | 512000 (20,000 ms) | 2,560,000,000 bits |
Reliability is given as a fraction of 255. That is, 255 is 100 percent reliability or a perfectly stable link.
Load is given as a fraction of 255. A load of 255 indicates a completely saturated link.
The following example sets the metric weights to slightly different values than the defaults.
router eigrp 109
network 131.108.0.0
metric weights 0 2 0 2 0 0
A dagger (+) indicates that the command is documented in the Router Products Command Reference publication.
bandwidth +
delay +
To specify a list of networks for the IP enhanced IGRP routing process, use the network router configuration command. To remove a network from the list, use the no form of this command.
network network-numbernetwork-number | IP address of the directly connected network |
Disabled
Router configuration
The network number must not contain any subnet information. You can specify multiple network commands.
IP enhanced IGRP sends updates to the interfaces in the specified network(s). Also, if you do not specify an interface's network, it will not be advertised in any IP enhanced IGRP updates.
The following example configures a router for IP enhanced IGRP and assigns autonomous system number 109. The network commands indicate the networks directly connected to the router.
router eigrp 109
network 131.108.0.0
network 192.31.7.0
router eigrp
To add or remove a positive offset to incoming and outgoing metrics for networks matching a specified access list, use the offset-list router configuration command. To remove an offset list, use the no form of this command.
offset-list {in | out} offset [access-list-number]in | Applies the access list to incoming metrics. |
out | Applies the access list to outgoing metrics. |
offset | Positive offset to be applied to metrics for networks matching the access list. If the offset is zero, no action is taken. |
access-list-number | (Optional) Access list to be applied. If omitted, the value of offset is applied to all metrics. If offset is zero, no action is taken. |
Disabled
Router configuration
The offset value is added to the routing metric.
The following example applies an offset of 10 to the router's delay component for all outgoing metrics:
offset-list out 10
In the following example, the router applies the same offset in the previous example only to access list 121:
offset-list out 10 121
To disable sending routing updates on an interface, use the passive-interface router configuration command. To reenable the sending of routing updates, use the no form of this command.
passive-interface type unittype unit | Interface type and number |
Disabled
Router configuration
If you disable the sending of routing updates on an interface, the particular subnet will continue to be advertised to other interfaces, and updates from other routers on that interface continue to be received and processed.
IP enhanced IGRP is disabled on an interface that is configured as passive although it advertises the route.
The following example sends IP enhanced IGRP updates to all interfaces on network 131.108.0.0 except Ethernet interface 1:
router eigrp 109
network 131.108.0.0
passive-interface ethernet 1
To redistribute routes from one routing domain into another, use the redistribute router configuration command. To disable this feature, use the no form of this command.
redistribute protocol autonomous-system-number [route-map map-tag]protocol | Source protocol from which routes are being redistributed. It can be one of the following keywords: bgp, egp, igrp, eigrp, isis, ospf, static [ip], connected, or rip.
Use the keyword static [ip] to redistribute IP static routes when redistributing into IS-IS. The keyword connected refers to routes that are established automatically by virtue of having an IP interface. For routing protocols such as OSPF and IS-IS, these routes are redistributed as external to the autonomous system. |
autonomous-system-number | For bgp, egp, igrp or eigrp, this is a 16-bit, decimal autonomous system number. For isis, this is an optional tag that names a routing process. You can specify only one IS-IS process per router. You then use the name when configuring routing. For ospf, this is an OSPF process ID from which routes are to be redistributed. This identifies the routing process. It is a nonzero decimal number. For rip, autonomous-system-number is not needed. |
route-map map-tag | (Optional) Identifies a route map to use to filter the importing of routes from this source routing protocol to the current routing protocol. The argument map-tag is the identifier of a configured route map. If you specify route-map with no map tags, no routes are imported. If you omit route-map, all routes are redistributed. |
See "Syntax Description" for the various defaults.
Router configuration
Changing or disabling one keyword will not affect the state of other keywords.
A router receiving a link-state protocol (LSP) with an internal metric will consider the cost of the route from itself to the redistributing router plus the advertised cost to reach the destination. An external metric considers only the advertised metric to reach the destination.
Redistributed routing information should always be filtered by the distribute-list out router configuration command. This ensures that only those routes intended by the administrator are passed along to the receiving routing protocol.
Whenever you use the redistribute or the default-information allowed router configuration commands to redistribute routes into an OSPF routing domain, the router automatically becomes an autonomous system boundary router. However, an autonomous system boundary router does not, by default, generate a default route into the OSPF routing domain.
The only connected routes affected by this redistribute command are the routes not specified by the network command.
You cannot use the default-metric router configuration command to affect the metric used to advertise connected routes.
The following example configuration causes IP enhanced IGRP routes to be redistributed into an OSPF domain:
router ospf 110
redistribute eigrp...
The following example illustrates the use of this form of the redistribute command, with the match keyword and its options enabled:
router igrp 108
redistribute ospf 109 match internal external 1 external 2
The following example causes the specified IP enhanced IGRP process routes to be redistributed into an OSPF domain. The IP enhanced IGRP-derived metric will be remapped to 100 and RIP routes to 200.
router ospf 109
redistribute eigrp 108 metric 100 subnets
redistribute rip metric 200 subnets
A dagger (+) indicates that the command is documented in the Router Products Command Reference publication.
default-information allowed +
default-metric
distribute-list out
network +
route-map
To define the conditions for redistributing routes from one routing protocol into another, use the route-map global configuration command and the route-map configuration commands match and set. To delete an entry, use the no route-map command.
route-map map-tag [[permit | deny] | [sequence-number]]map-tag | Defines a meaningful name for the route map. The redistribute router configuration command uses this name to reference this route map. Multiple route maps can share the same map tag name. |
permit | (Optional) If the match criteria are met for this route map, and permit is specified, the route is redistributed as controlled by the set actions. If the match criteria are not met, and permit is specified, the next route map with the same map-tag is tested. If a route passes none of the match criteria for the set of route maps sharing the same name, it is not redistributed by that set. |
deny | (Optional) If the match criteria are met for the route map, and deny is specified, the route is not redistributed, and no further route maps sharing the same map tag name will be examined. |
sequence-number | (Optional) Number that indicates the position a new route map is to have in the list of route maps already configured with the same name. If given with the no form of this command, it specifies the position of the route map that should be deleted. |
No default available.
Global configuration
Each route-map command has a list of match and set commands associated with it. The match commands specify the match criteria--the conditions under which redistribution is allowed for the current route-map. The set commands specify the set actions--the particular redistribution actions to perform if the criteria enforced by the match commands are met. The no route-map command deletes the route map.
Use route maps when you wish to have detailed control over how routes are redistributed between routing processes. The destination routing protocol is the one you specify with the router global configuration command. The source routing protocol is the one you specify with the redistribute router configuration command. See the following example as an illustration of how route maps are configured.
The following example redistributes all OSPF routes into IGRP:
router igrp 109
redistribute ospf 110
default metric 1000 100 255 1 1500
A dagger (+) indicates that the command is documented in the Router Products Command Reference publication.
match
redistribute
set
show route-map +
To configure the IP enhanced IGRP routing process, use the router eigrp global configuration command. To shut down the routing process on the specified autonomous system, use the no form of this command.
router eigrp autonomous-system-numberautonomous-system-number | Number of the autonomous system. It identifies the routes to the other IP enhanced IGRP routers and is used to tag the routing information. |
Disabled
Global configuration
The following example shows how to configure an IP enhanced IGRP routing process and assign autonomous system number 109:
router eigrp 109
network
To indicate where to import routes, use the set level route-map configuration command. To delete an entry, use the no form of this command.
set level {level-1 | level-2 | level-1-2 | stub-area | backbone}level-1 | Import into a Level-1 area |
level-2 | Import into Level-2 sub-domain |
level-1-2 | Import into Level-1 and Level-2 |
stub-area | Import into OSPF NSSA area |
backbone | Import into OSPF backbone area |
Disabled
Route-map configuration
Use the route-map global configuration command and the route-map configuration commands match and set to define the conditions for redistributing routes from one routing protocol into another. Each route-map command has a list of match and set commands associated with it. The match commands specify the match criteria--the conditions under which redistribution is allowed for the current route-map. The set commands specify the set actions--the particular redistribution actions to perform if the criteria enforced by the match commands are met. The no route-map command deletes the route map.
The set route-map configuration commands specify the redistribution set actions to be performed when all of a route map's match criteria are met. When all match criteria are met, all set actions are performed.
In the following example, routes are imported into the Level 1 area:
route-map name
set level level-l
route-map
match
To set the metric value for the destination routing protocol, use the set metric route-map configuration command. To return to the default metric value, use the no form of this command.
set metric metric-valuemetric-value | Metric value or IGRP bandwidth in kilobits per second. It can be an integer from 0 through 294967295. |
Default metric value.
Route-map configuration
Use the route-map global configuration command and the route-map configuration commands match and set to define the conditions for redistributing routes from one routing protocol into another. Each route-map command has a list of match and set commands associated with it. The match commands specify the match criteria--the conditions under which redistribution is allowed for the current route-map. The set commands specify the set actions--the particular redistribution actions to perform if the criteria enforced by the match commands are met. The no route-map command deletes the route map.
The set route-map configuration commands specify the redistribution set actions to be performed when all of a route map's match criteria are met. When all match criteria are met, all set actions are performed.
In the following example, the metric value for the destination routing protocol is set to 100:
route-map set-metric
set metric 100
match
route-map
To set the metric type for the destination routing protocol, use the set metric-type route-map command. To return to the default, use the no form of this command.
set metric-type {internal | external | type-1 | type-2}internal | IS-IS internal metric |
external | IS-IS external metric |
type-1 | OSPF external type 1 metric |
type-2 | OSPF external type 2 metric |
Disabled
Route-map configuration
Use the route-map global configuration command and the route-map configuration commands match and set to define the conditions for redistributing routes from one routing protocol into another. Each route-map command has a list of match and set commands associated with it. The match commands specify the match criteria--the conditions under which redistribution is allowed for the current route-map. The set commands specify the set actions--the particular redistribution actions to perform if the criteria enforced by the match commands are met. The no route-map command deletes the route map.
The set route-map configuration commands specify the redistribution set actions to be performed when all of a route map's match criteria are met. When all match criteria are met, all set actions are performed.
In the following example, the metric type of the destination protocol is set to OSPF external type 1:
route-map map-type
set metric-type type-1
match
route-map
To set a tag value of the destination routing protocol, use the set tag route-map configuration command. To delete the entry, use the no form of this command.
set tag tag-valuetag-value | Name for the tag. Integer from 0 through 4294967295. |
If not specified, the default action is to forward the tag in the source routing protocol onto the new destination protocol.
Route-map configuration
Use the route-map global configuration command and the route-map configuration commands match and set to define the conditions for redistributing routes from one routing protocol into another. Each route-map command has a list of match and set commands associated with it. The match commands specify the match criteria--the conditions under which redistribution is allowed for the current route-map. The set commands specify the set actions--the particular redistribution actions to perform if the criteria enforced by the match commands are met. The no route-map command deletes the route map.
The set route-map configuration commands specify the redistribution set actions to be performed when all of a route map's match criteria are met. When all match criteria are met, all set actions are performed.
In the following example, the tag value of the destination routing protocol is set to 5:
route-map tag
set tag 5
match
route-map
To display the neighbors discovered by IP enhanced IGRP, use the show ip eigrp neighbors EXEC command.
show ip eigrp neighbors [type unit]interface unit | (Optional) Interface name and number |
EXEC
Use the show ip eigrp neighbors command to determine when neighbors become active and inactive. It is also useful for debugging certain types of transport problems.
The following is sample output from the show ip eigrp neighbors command:
Router# show ip eigrp neighbors
IP-EIGRP Neighbors for process 77
Address Interface Holdtime Uptime Q Seq SRTT RTO
(secs) (h:m:s) Count Num (ms) (ms)
160.89.81.28 Ethernet1 13 0:00:41 0 11 4 20
160.89.80.28 Ethernet0 14 0:02:01 0 10 12 24
160.89.80.31 Ethernet0 12 0:02:02 0 4 5 20
Table 6-3 explains the fields in the output.
Field | Description |
---|---|
process 77 | Autonomous system number specified in the ipx router configuration command. |
Address | IP address of the enhanced IGRP peer. |
Interface | Interface on which the router is receiving hello packets from the peer. |
Holdtime | Length of time, in seconds, that the router will wait to hear from the peer before declaring it down. If the peer is using the default hold time, this number will be less than 15. If the peer configures a nondefault hold time, it will be reflected here. |
Uptime | Elapsed time, in hours, minutes, and seconds, since the local router first heard from this neighbor. |
Q Count | Number of IP enhanced IGRP packets (Update, Query, and Reply) that the router is waiting to send. |
Seq Num | Sequence number of the last update, query, or reply packet that was received from this neighbor. |
SRTT | Smooth round-trip time. This is the number of milliseconds it takes for an IP enhanced IGRP packet to be sent to this neighbor and for the local router to receive an acknowledgment of that packet. |
RTO | Retransmission timeout, in milliseconds. This is the amount of time the router waits before retransmitting a packet from the retransmission queue to a neighbor. |
To display the IP enhanced IGRP topology table, use the show ip eigrp topology EXEC command.
show ip eigrp topology [autonomous-system-number | [[ip-address]mask]]autonomous-system-number | (Optional) Autonomous system number. |
ip-address | (Optional) When specified with a mask, a detailed description of the entry is provided. |
mask | (Optional) Subnet mask. |
EXEC
Use the show ip eigrp topology command to determine DUAL states and to debug possible DUAL problems.
The following is sample output from the show ip eigrp topology command:
Router# show ip eigrp topology
IP-EIGRP Topology Table for process 77
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - Reply status
P 160.89.90.0 255.255.255.0, 2 successors, FD is 0
via 160.89.80.28 (46251776/46226176), Ethernet0
via 160.89.81.28 (46251776/46226176), Ethernet1
via 160.89.80.31 (46277376/46251776), Ethernet0
P 160.89.81.0 255.255.255.0, 1 successors, FD is 307200
via Connected, Ethernet1
via 160.89.81.28 (307200/281600), Ethernet1
via 160.89.80.28 (307200/281600), Ethernet0
via 160.89.80.31 (332800/307200), Ethernet0
Table 6-4 explains the fields in the output.
Field | Description |
---|---|
Codes | State of this topology table entry. Passive and Active refer to the enhanced IGRP state with respect to this destination; Update, Query, and Reply refer to the type of packet that is being sent. |
P - Passive | No enhanced IGRP computations are being performed for this destination. |
A - Active | Enhanced IGRP computations are being performed for this destination. |
U - Update | Indicates that an update packet was sent to this destination. |
Q - Query | Indicates that a query packet was sent to this destination. |
R - Reply | Indicates that a reply packet was sent to this destination. |
r - Reply status | Flag that is set when after the router has sent a query and is waiting for a reply. |
160.89.90.0 and so on | Destination IP network number. |
255.255.255.0 | Destination subnet mask. |
successors | Number of successors. This number corresponds to the number of next hops in the IP routing table. |
FD | Feasible distance. This value is used in the feasibility condition check. If the neighbor's reported distance (the metric after the slash) is less than the feasible distance, the feasibility condition is met and that path is a feasible successor. Once the router determines it has a feasible successor, it does not have to send a query for that destination. |
replies | Number of replies that are still outstanding (have not been received) with respect to this destination. This information appears only when the destination is in Active state. |
state | Exact enhanced IGRP state that this destination is in. It can be the number 0, 1, 2, or 3. This information appears only when the destination is Active. |
via | IP address of the peer who told the router about this destination. The first N of these entries, where N is the number of successors, are the current successors. The remaining entries on the list are feasible successors. |
(46251776/46226176) | The first number is the enhanced IGRP metric that represents the cost to the destination. The second number is the enhanced IGRP metric that this peer advertised. |
Ethernet0 | Interface from which this information was learned. |
To display the number of IP enhanced IGRP packets sent and received, use the show ip eigrp traffic EXEC command.
show ip eigrp traffic [autonomous-system-number]autonomous-system-number | (Optional) Autonomous system number |
EXEC
The following is sample output from the show ip eigrp traffic command:
Router# show ip eigrp traffic
IP-EIGRP Traffic Statistics for process 77
Hellos sent/received: 218/205
Updates sent/received: 7/23
Queries sent/received: 2/0
Replies sent/received: 0/2
Acks sent/received: 21/14
Table 6-5 describes the fields that might be shown in the display.
Field | Description |
---|---|
process 77 | Autonomous system number specified in the ip router command. |
Hellos sent/received | Number of hello packets that were sent and received. |
Updates sent/received | Number of update packets that were sent and received. |
Queries sent/received | Number of query packets that were sent and received. |
Replies sent/received | Number of reply packets that were sent and received. |
Acks sent/received | Number of acknowledgment packets that were sent and received. |
To display the parameters and current state of the active routing protocol process, use the show ip protocols EXEC command.
show ip protocolsThis command has no arguments or keywords.
EXEC
The show ip protocols command displays information that is useful in debugging routing operations. Information in the Routing Information Sources field of the show ip protocols output can help you identify a router suspected of delivering bad routing information.
The following is sample output from the show ip protocols command, showing IP enhanced IGRP processes:
Router# show ip protocols
Routing Protocol is "eigrp 77"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: eigrp 77
Automatic network summarization is in effect
Routing for Networks:
160.89.0.0
Routing Information Sources:
Gateway Distance Last Update
160.89.81.28 90 0:02:36
160.89.80.28 90 0:03:04
160.89.80.31 90 0:03:04
Distance: internal 90 external 170
Table 6-6 describes the fields that might be shown in the display.
Field | Description |
---|---|
Routing Protocol is "eigrp 77" | Name and autonomous system number of the currently running routing protocol. |
Outgoing update filter list for all interfaces... | Indicates whether a filter for outgoing routing updates has been specified with the distribute-list out command. |
Outgoing update filter list for all interfaces... | Indicates whether a filter for outgoing routing updates has been specified with the distribute-list in command. |
Redistributing: eigrp 77 | Indicates whether route redistribution has been enabled with the redistribute command. |
Automatic network summarization... | Indicates whether route summarization has been enabled with the auto-summary command. |
Routing for Networks: | Networks that the routing process is currently injecting routes for. |
Routing Information Sources: | Lists all the routing sources that the router is using to build its routing table. The following is displayed for each source: IP address, administrative distance, and time the last update was received from this source. |
Distance: internal 90 external 170 | Internal and external distances of the router. Internal distance is the degree of preference given to IP enhanced IGRP internal routes. External distance is the degree of preference given to IP enhanced IGRP external routes. |
To display the current state of the routing table, use the show ip route EXEC command.
show ip route [ip-address [mask] | protocol [process-id]]address | (Optional) Address about which to display routing information |
mask | (Optional) Subnet mask of the subnet about which to display routing information |
protocol | (Optional) Particular routing protocol, or the keyword static or connected |
process-id | (Optional) Identifier of the particular routing protocol process |
EXEC
The following is a sample display from the show ip route command when entered without an address:
Router# show ip route
Codes: I - IGRP derived, R - RIP derived, O - OSPF derived
C - connected, S - static, E - EGP derived, B - BGP derived
i - IS-IS derived, D - EIGRP derived
* - candidate default route, IA - OSPF inter area route
E1 - OSPF external type 1 route, E2 - OSPF external type 2 route
L1 - IS-IS level-1 route, L2 - IS-IS level-2 route
EX - EIGRP external route
Gateway of last resort is not set
160.89.0.0 is variably subnetted, 6 subnets, 2 masks
D 160.89.90.0 255.255.255.0
[90/46251776] via 160.89.80.28, 0:04:18, Ethernet0
[90/46251776] via 160.89.81.28, 0:04:18, Ethernet1
C 160.89.81.0 255.255.255.0 is directly connected, Ethernet1
C 160.89.80.0 255.255.255.0 is directly connected, Ethernet0
D 160.89.82.0 255.255.255.0
[90/307200] via 160.89.80.31, 0:04:18, Ethernet0
C 160.89.62.0 255.255.255.0 is directly connected, Serial0
S 160.89.0.0 255.255.0.0 [1/0] via 160.89.80.240
Table 6-7 describes the fields shown in the display.
Field | Description |
---|---|
Codes | Codes defining how the route was learned and the type of route. |
I | Route learned via IGRP. |
R | Route learned from a RIP update. |
O | Route learned from an OSPF update. |
C | Directly connected network. |
S | Statically defined route via the ip route command. |
E | Route learned from EGP. |
B | Route learned from BGP. |
i | Router learned from IS-IS. |
D | Route leaved via IP enhanced IGRP. |
* | Candidate default route. |
IA | OSPF interarea route. |
E1 | OSPF external type 1 route. |
E2 | OSPF external type 2 route. |
L1 | IS-IS Level 1 route. |
L2 | IS-IS Level 2 route. |
EX | External enhanced IGRP route. |
Gateway of last resort not set | Indicates whether a gateway of last resort has been specified. |
160.89.0.0 | Address of the remote network. |
[90/46251776] | The first number is the administrative distance of the information source. The second number is the metric for the route. |
via 160.89.80.28 | Address of the next router to the remote network. |
0:04:18 | Last time in hours:minutes:seconds that the route was updated. |
Ethernet0 | Interface through which the network can be reached. |
A dagger (+) indicates that the command is documented in the Router Products Command Reference publication.
show interfaces tunnel +
show ip route summary
To display the current state of the routing table, use the show ip route summary EXEC command.
show ip route summaryThis command has no arguments or keywords.
EXEC
The following is sample output from the show ip route summary command:
Router# show ip route summary
Route Source Networks Subnets Overhead Memory (bytes)
connected 0 3 126 360
static 1 2 126 360
igrp 109 747 12 31878 91080
internal 3 360
Total 751 17 32130 92160
router#
Table 6-8 describes the fields shown in the display.
Field | Description |
---|---|
Route Source | Routing protocol name, or the keyword connected, static or internal. Internal indicates those routes that are in the routing table that are not owned by any routing protocol. |
Networks | Number of Class A, B, or C networks that are present in the routing table for each route source. |
Subnets | Number of subnets that are present in the routing table for each route source, including host routes. |
Overhead | Any additional memory involved in allocating the routes for the particular route source other than the memory specified in the Memory field. |
Memory | Number of bytes allocated to maintain all the routes for the particular route source. |
show ip route
To control load balancing in an IP enhanced IGRP-based internetwork, use the variance router configuration command. To reset the variance to the default value, use the no form of this command.
variance multipliermultiplier | Metric value used for load balancing. It can be a value from 1 to 128. The default is 1, which means equal-cost load balancing. |
1 (equal-cost load balancing)
Router configuration
Setting a variance value lets the router determine the feasibility of a potential route. A route is feasible if the next router in the path is closer to the destination than the current router and if the metric for the entire path is within the variance. Only paths that are feasible can be used for load balancing and included in the routing table.
If the following two conditions are met, the route is deemed feasible and can be added to the routing table:
The following example sets a variance value of 4:
router eigrp 109
variance 4
|