cc/td/doc/product/atm/c8540/12_0/13_19
hometocprevnextglossaryfeedbacksearchhelp
PDF

Table of Contents

Configuring Tag Switching
Software Restrictions
Configuring Tag Switching on an ATM Switch Router
Configuring Tag Switching on a Router
Tag Switching Configuration Example

Configuring Tag Switching


This chapter describes how to configure tag switching, and includes the following sections:


Note      For more software configuration information about tag switching, refer to the ATM Switch Router Software Configuration Guide. Refer to the ATM Switch Router Command Reference publication for command syntax.


Software Restrictions

The software restrictions for tag switching follow:

Configuring Tag Switching on an ATM Switch Router

This section describes how to configure tag switching on an ATM switch router, and includes the following procedures:

Enabling Tag Switching on the ATM Interface


Note      Configure all parallel interfaces between switches for either IP unnumbered or with a specific IP address. Unnumbering some parallel interfaces and assigning specific IP addresses to others might cause Tag Distribution Protocol (TDP) sessions to restart on some parallel interfaces when another parallel interface is shut down. Therefore, we highly recommend that you unnumber all parallel interfaces to loopback.


Take these steps:

Step Command Purpose
1

Switch(config)# interface atm card/subcard/port

Switch(config-if)#

Enter interface configuration mode on the specified ATM interface.

2

Switch(config-if)# ip unnumbered type number

Enable IP unnumbered on the ATM interface and assign the unnumbered interface to an interface that has an IP address. We recommend enabling IP unnumbered because it allows you to conserve IP addresses and reduces the number of TVCs1 terminating on the switch.

or

or

Switch(config-if)# ip address ip-address mask

Assign an IP address and subnet mask to the ATM interface.

3

Switch(config-if)# tag-switching ip

Enable tag switching of IP packets on the interface.

4

Switch(config-if)# exit

Switch(config)#

Return to global configuration mode.

1TVCs = tag virtual channels.

Examples
Switch(config-if)# interface atm 1/0/1
Switch(config-if)# ip unnumbered loopback 0
Switch(config-if)# tag-switching ip
Switch(config-if)# exit
Switch(config)#
Switch(config)# interface atm 0/0/3
Switch(config-if)# ip address 1.3.11.3 255.255.0.0
Switch(config-if)# tag-switching ip
Switch(config-if)# exit
Switch(config)#
Verify
Switch# show tag-switching interfaces
Interface IP Tunnel Operational
ATM0/0/3 Yes No No (ATM tagging)
ATM1/0/1 Yes No No (ATM tagging)
Switch#

Configuring the Routing Protocol

Enable the routing protocol (OSPF) on the ATM switch router so that it can create routing tables, which identify routes through the network. Then add the addresses and associated routing areas to the routing process so that it can propagate the addresses to other ATM switches and routers.

Take these steps:

Step Command Purpose
1

Switch(config)# router ospf process_number

Enable the routing protocol and assign it a process number. The process number is any positive integer.

2

Switch(config-router)# network address wildcard-mask area area-id

Define the network prefix, a wildcard subnet mask, and the associated area number on which to run the routing protocol. An area number is an identification number for an address range.

Repeat this command for each additional area you want to add to the routing process.

Caution  Ethernet interface 0 on the processor card (CPU card) is used for system management only (for example, downloading system images or configuration files from a TFTP1 server). Do not add this interface to the routing process.

3

Switch(config-router)# exit

Switch(config)#

Return to global configuration mode.

1TFTP = Trivial File Transfer Protocol

Example

Note      An IP address of 1.1.1.1 with a subnet mask of 255.255.255.0 is entered as an IP network prefix of 1.1.1.0 with a subnet mask of 0.0.0.255. Likewise, an IP address of 1.2.1.1 with a subnet mask of 255.255.255.0 is entered as an IP network prefix of 1.2.1.0 with a subnet mask of 0.0.0.255.


Switch(config)# router ospf 10000
Switch(config-router)# network 1.1.1.0 0.0.0.255 area 0
Switch(config-router)# network 1.2.1.0 0.0.0.255 area 0
Switch(config-router)# network 1.3.0.0 0.0.255.255 area 0
Switch(config-router)# network 200.2.2.0 0.0.0.255 area 0
Switch(config-router)# network 1.0.1.0 0.0.0.255 area 0
Switch(config-router)# network 1.18.0.0 0.0.255.255 area 0
Switch(config-router)# exit
Switch(config)#
Verify
Switch# show ip ospf
Routing Process "ospf 10000" with ID 1.0.1.11
Supports only single TOS(TOS0) routes
SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
Number of DCbitless external LSA 0
Number of DoNotAge external LSA 0
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Area BACKBONE(0) (Inactive)
Number of interfaces in this area is 4
Area has no authentication
SPF algorithm executed 2 times
Area ranges are
Link State Update Interval is 00:30:00 and due in 00:14:42
Link State Age Interval is 00:20:00 and due in 00:14:10
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Switch#

Configuring Tag Switching on a Router

This section describes how to configure tag switching between a router and an ATM switch router.

Take these steps:

Step Command Purpose
1

Router# configure terminal

Router(config)#

Enter global configuration mode.

2

Router(config)# interface type port[/slot][.subinterface]

Router(config-subif)#

Select the subinterface to configure.

3

Router(config-subif)# ip address address subnet

Enter the IP address and subnet mask for the interface.

4

Router(config-subif)# tag-switching ip

Enable tag switching of IP packets on an interface.

5

Router(config-subif)# no shutdown

Enable the interface.

6

Router(config-subif)# exit

Router(config)#

Return to global configuration mode.

7

Router(config)# interface type port[/slot]

Router(config-if)#

Enter interface configuration on the main interface you selected in Step 2.

8

Router(config-if)# no shutdown

Enable the interface.

Example
Router# configure terminal
Router(config)# interface atm 2/0.1
Router(config-subif)# ip address 189.26.11.15 255.255.0.0
Router(config-subif)# tag-switching ip
Router(config-subif)# no shutdown
Router(config-subif)# exit
Router(config)# interface atm 2.0
Router(config-if)# no shutdown
Verify
Router# show tag-switching interface
Interface IP Tunnel Operational
ATM2/0.1 Yes No Yes          (ATM tagging)

Tag Switching Configuration Example

Figure 5-1 shows an example tag switching network.


Figure 5-1   Example Network for Tag Switching


Router 5-1 Configuration

The configuration of router R5-1, interface e0/1, follows:

router_R5-1# configure terminal
router_R5-2(config)# ip cef switch
router_R5-1(config)# tag-switching advertise-tags
router_R5-1(config)# interface e0/1
router_R5-1(config-if)# tag-switching ip
router_R5-1(config-if)# exit
router_R5-1#(config)#
Router 5-2 Configuration

The configuration between router R5-1, interface e0/1, and R5-2, interface e0/1, follows:

router_R5-2# configure terminal
router_R5-2(config)# ip cef switch
router_R5-2(config)# tag-switching advertise-tags
router_R5-2(config)# interface e0/1
router_R5-2(config-if)# tag-switching ip
router_R5-2(config-if)# exit
router_R5-2#(config)#

The configuration between router R5-2, interface e0/2, and R5-3, interface e0/2, follows:

route_R5-2(config)# interface e0/2
route_R5-2(config-if)# tag-switching ip
route_R5-2(config-if)# exit

The configuration of router R5-2, interface a2/0.1, follows:

router_R5-2(config-if)# interface a2/0.1
router_R5-2(config-subif)# ip address 189.26.11.15 255.255.0.0
router_R5-2(config-subif)# tag-switching ip
router_R5-2(config-subif)# no shutdown
router_R5-2(config-subif)# exit
router_R5-2(config)# interface a2/0
router_R5-2(config)# no shutdown
Router 5-3 Configuration

The configuration of router R5-3, interface e0/2, follows:

router_R5-3# configure terminal
router_R5-3(config)# ip cef switch
router_R5-3(config)# tag-switching advertise-tags
router_R5-3(config)# interface e0/2
router_R5-3(config-if)# tag-switching ip
router_R5-3(config-if)# exit

The configuration of router R5-3, interface e0/5 follows:

router_R5-3(config)# interface e0/5
router_R5-3(config-if)# tag-switching ip
router_R5-3(config-if)# exit

The configuration of router R5-3, interface a2/0.1, follows:

router_R5-3# configure terminal
router_R5-3(config)# interface a2/0.1
router_R5-3(config-if)# ip address 189.25.12.13 255.255.0.0
router_R5-3(config-if)# tag-switching ip
router_R5-3(config-if)# no shutdown
router_R5-3(config-if)# exit
router_R5-3(config-if)# interface a2/0
router_R5-3(config)# no shutdown
ATM Switch Router A5-4 Configuration

The configuration of ATM switch router A5-4, interfaces a0/1/1 and 0/0/3, follows:

atm_A5-4# configure terminal
atm_A5-4(config)# interface a0/1/1
atm_A5-4(config-if)# no shutdown
atm_A5-4(config-if)# ip address 189.24.15.12 255.255.0.0
atm_A5-4(config-if)# tag-switching ip
atm_A5-4(config-if)# exit
atm_A5-4(config)# tag-switching ip
atm_A5-4(config)# interface a0/0/3
atm_A5-4(config-if)# no shutdown
atm_A5-4(config-if)# ip address 189.25.15.11 255.255.0.0
atm_A5-4(config-if)# tag-switching ip
atm_A5-4(config-if)# exit
atm_A5-4(config)# tag-switching ip
Router 5-5 Configuration

The configuration of router R5-5, interface e0/2, follows:

router_R5-5# configure terminal
router_R5-5(config)# ip cef switch
router_R5-5(config)# tag-switching advertise-tags
router_R5-5(config)# interface e0/2
router_R5-5(config-if)# tag-switching ip
router_R5-5(config-if)# exit
ATM Switch Router A6-4 Configuration

The configuration of ATM switch router A6-4, interface a0/1/1, follows:

atm_A6-4# configure terminal
atm_A6-4(config)# interface a0/1/1
atm_A6-4(config-if)# no shutdown
atm_A6-4(config-if)# ip address 189.24.14.12 255.255.0.0
atm_A6-4(config-if)# tag-switching ip
atm_A6-4(config-if)# exit

The configuration of ATM switch router A6-4, interface a0/0/3, follows:

atm_A6-4# configure terminal
atm_A6-4(config)# interface a0/0/3
atm_A6-4(config-if)# no shutdown
atm_A6-4(config-if)# ip address 189.26.14.11 255.255.0.0
atm_A6-4(config-if)# tag-switching ip
atm_A6-4(config-if)# exit


hometocprevnextglossaryfeedbacksearchhelp
Posted: Mon Mar 3 11:40:28 PST 2003
All contents are Copyright © 1992--2002 Cisco Systems, Inc. All rights reserved.
Important Notices and Privacy Statement.