|
The Cisco 200 for Windows 95 can communicate with any Cisco Systems router that supports ISDN. This chapter contains guidelines for configuring the connecting router and sample configurations.
Before you install and configure your Cisco 200, you should verify that the connecting router is properly installed and configured. For more information on router installation and configuration, see the Cisco Connection Documentation, CiscoPro Solutions CD; the Cisco Connection Documentation, Enterprise Series CD; or the printed Cisco router documentation.
The following are general guidelines for configuring Cisco routers to communicate with the Cisco 200 for Windows 95:
Figure 1-1 illustrates the authentication configuration for the connecting router.
The following sections provide sample configuration files for a Cisco 2503 router. The configurations of other CiscoPro Access and Cisco Enterprise routers will be similar.
The following example illustrates a connecting router configuration using PPP multilink with PPP callback and the NI1 ISDN protocol. This example also includes Challenge Handshake Authentication Protocol (CHAP) and assumes that the NI1 switch is configured for call forward busy (CFB or hunt) and that the connecting router is also on an NI1 switch.
Configuration for Central Site (2503)
!
version 11.0
!
hostname
Headquarters !The connecting router name
!
username
MyHomeOffice
password 7 044F0E151B
!The Cisco 200 local system name
ipx routing 0000.0c07.ad01
isdn switch-type basic-ni1
!
interface Ethernet0
ip address
192.168.100.1 255.255.255.0
no keepalive
ipx network 50
!
interface BRI0
ip address
192.168.200.2 255.255.255.0
encapsulation ppp
no ip route-cache
no keepalive
ipx network 22
no ipx route-cache
ipx watchdog-spoof
isdn spid1
4085553000100 5553000
!SPID and Directory; required for NI1.
isdn spid2
4085553001200 5553001
!Second SPID and Directory; required for NI1.
no peer default ip address pool
!Disables IP address negotiation
!The following three lines are required for PPP callback.
dialer enable-timeout 2
dialer map ip
192.168.300.3 name
MyHomeOffice
class HOMEOFFICE
17145551001
dialer map ipx 22.0000.1234.5678 name
MyHomeOffice
class HOMEOFFICE
17145551001
!
dialer-group 1
no fair-queue !Required for PPP multilink
compress stac !Required for compression
ppp callback accept !Required for PPP callback
ppp multilink !Required for PPP multilink
ppp authentication chap
!Required for CHAP authentication
!For PAP authentication, replace the above line with "ppp authentication pap".
!
router rip
network
192.168.100.0
network
192.168.200.0
!
map-class dialer HOMEOFFICE !Required for PPP callback
dialer callback-server username
!Required for PPP callback
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
The following example illustrates a connecting router configuration using the PPP multilink with PPP callback and 5ESS Point-to-Point or Multipoint Protocol:
Configuration for Central Site (2503)
!
version 11.0
!
hostname Headquarters !The connecting router name
!
username MyHomeOffice
password 7 044F0E151B !The Cisco 200 local system name
ipx routing 0000.0c38.67bc
isdn switch-type basic-5ess
!
interface Ethernet0
ip address 192.168.100.1 255.255.255.0
no keepalive
ipx network 50
!
interface BRI0
ip address 192.168.200.2 255.255.255.0
encapsulation ppp
no ip route-cache
no keepalive
ipx network 22
no ipx route-cache
ipx watchdog-spoof
isdn spid1 0155530000 !SPID might be required for 5ESS
no peer default ip address pool !Default setting: No IP address negotiation
!The following three lines are required for PPP callback.
dialer enable-timeout 2
dialer map ip 192.168.300.3 name MyHomeOffice
class HOMEOFFICE
1714
5551001
dialer map ipx 22.0000.1234.5678
name MyHomeOffice
class HOMEOFFICE
1714
5551001
!
dialer-group 1
no fair-queue !Required for PPP multilink
compress stac !Required for compression
ppp callback accept !Required for PPP callback
ppp multilink !Required for PPP multilink
ppp authentication pap !Required for PAP authentication
!For CHAP authentication, replace the above line with "ppp authentication chap".
!
router rip
network
192.168.100.0
network
192.168.200.0
!
map-class dialer HOMEOFFICE !Required for PPP callback
dialer callback-server username
!Required for PPP callback
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
The following example illustrates a connecting router configuration using PPP multilink with PPP callback and the DSS1 (Basic-Net 3) protocol:
!
version 11.0
!
hostname Headquarters !The connecting router name
!
username MyHomeOffice
password 7 044F0E151B !The Cisco 200 local system name
ipx routing 0000.0c07.ad01
isdn switch-type basic-net3
isdn tei-negotiation first-call
!
interface Ethernet0
ip address 192.168.100.1 255.255.255.0
no keepalive
ipx network 50
!
interface BRI0
ip address 192.168.200.2 255.255.255.0
encapsulation ppp
no ip route-cache
no keepalive
ipx network 22
no ipx route-cache
ipx watchdog-spoof
!No SPID or Directory required for DSS1
no peer default ip address pool !Default setting: No IP address negotiation
!The following three lines are required for PPP callback.
dialer enable-timeout 2
dialer map ip 192.168.300.3 name MyHomeOffice
class HOMEOFFICE
492395551001
dialer map ipx 22.0000.1234.5678
name MyHomeOffice
class HOMEOFFICE
492395551001
!
dialer-group 1
no fair-queue
!Required for PPP multilink
compress stac
!Required for compression
ppp callback accept
!Required for PPP callback
ppp multilink
!Required for PPP multilink
ppp authentication chap
!Required for CHAP authentication
!for PAP authentication, replace the above line with "ppp authentication pap".
!
router rip
network 192.168.100.0
network 192.168.200.0
!
map-class dialer HOMEOFFICE
!Required for PPP callback
dialer callback-server username
!Required for PPP callback
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
The following example illustrates a connecting router configuration using PPP multilink and the DSS1 protocol. In addition, this example illustrates the commands required for IP address negotiation.
!
version 11.0
!
hostname Headquarters !The connecting router name
!
username MyHomeOffice
password 7 044F0E151B !The Cisco 200 local system name
ip address-pool local !Required for IP address negotiation
isdn switch-type basic-net3
isdn tei-negotiation first-call
!
interface Ethernet0
ip address 192.168.100.1 255.255.255.0
no keepalive
!
interface BRI0
ip address 192.168.200.2 255.255.255.0
encapsulation ppp
peer default ip address pool poolname !Required for IP address negotiation
no keepalive
!No SPID or Directory required for DSS1
!
dialer-group 1
no fair-queue
!Required for PPP multilink
compress stac
!Required for compression
ppp multilink
!Required for PPP multilink
ppp authentication chap
!Required for CHAP authentication
!for PAP authentication, replace the above line with "ppp authentication pap".
!
router rip
network 192.168.100.0
network 192.168.200.0
!
ip local pool poolname 192.168.1.1 192.168.1.10 !Required for IP address negotiation
dialer-list 1 protocol ip permit
Refer to your router manufacturer's documentation for instructions on communicating with other PPP-compliant routers.
|