|HP-UX Reference > Y
yppasswdd(1M)HP-UX 11i Version 3: February 2007
yppasswdd: rpc.yppasswdd — daemon for modifying Network Information Service passwd database
/usr/lib/netsvc/yp/rpc.yppasswdd passwd_file [-l log_file] [-nogecos] [-noshell] [-nopw] [-nohome] [-m [arg1 arg2 ...]]
/usr/lib/netsvc/yp/rpc.yppasswdd [-D directory] [-l log_file] [-nogecos] [-noshell] [-nopw] [-nohome] [-m [arg1 arg2 ...]]
The yppasswdd daemon handles password change requests from yppasswd (see yppasswd(1)). It changes a password entry in the passwd and shadow files. The passwd and shadow files provide the basis for the passwd.byname and passwd.byuid maps. Entries in the passwd or shadow files are changed only if the password presented by yppasswd matches the encrypted password of the entry. All password files are located in the PWDIR directory.
If the -D option is given, the passwd or shadow files are placed under the directory path that is the argument to -D.
yppasswdd should be executed only on the master Network Information Service (NIS) server for the passwd database (map). The yppasswdd daemon is not executed by default, nor can it be started by inetd (see inetd(1M)). To enable automatic startup of yppasswdd at boot time, the NIS_MASTER_SERVER variable should be set to 1 in file /etc/rc.config.d/namesvrs on the master NIS server.
The yppasswdd daemon in HP-UX 11i version 3 supports the shadow mode. The system can be converted to shadow mode by using pwconv and reverted by using pwunconv. The SHADOW_MODE variable must be set to 1 in file /etc/rc.config.d/namesvrs on the master NIS server to support the shadow mode in NIS.
The server does not insist on the presence of a shadow file unless there is no -D option present or the directory named with the -D option is /etc.
yppasswdd recognizes the following options and command-line arguments:
Assume the yppasswdd daemon is started on the master NIS server as follows:
/usr/lib/netsvc/yp/rpc.yppasswdd /var/yp/src/passwd \ -l /var/adm/yppasswdd.log \ -m passwd DIR=/var/yp/src /usr/lib/netsvc/yp/rpc.yppasswdd -D /opt \ -l /var/adm/yppasswdd.log \
This indicates that the ASCII file from which the NIS passwd database is built is /var/yp/src/passwd. When this file is updated by a request from yppasswd, the NIS passwd database is rebuilt and copied to all slave NIS servers in the master's NIS domain (see domainname(1)).
Log messages are written to the file /var/adm/yppasswdd.log.
yppasswdd uses lock file /var/adm/ptmp to get exclusive access to passwd_file when updating it. The file /var/adm/ptmp may persist if passwd_file is being updated and
File /var/adm/ptmp must be removed before yppasswdd can function properly again.
vipw also uses /var/adm/ptmp when updating /etc/passwd (see vipw(1M)). As a result, yppasswdd competes with vipw when it updates passwd_file if passwd_file is /etc/passwd.