|HP-UX Reference > S
snmpd.conf(4)HP-UX 11i Version 3: February 2007
snmpd.conf — configuration file for the SNMP agent
When invoked, the SNMP agent reads its configuration information from the /etc/SnmpAgent.d/snmpd.conf configuration file. The SNMP agent is either the snmpd(1M) (included with HP-UX) or the snmpd.ea (purchased with the HP OpenView product). The SNMP agent will not be able to reply if no values are configured in /etc/SnmpAgent.d/snmpd.conf, i.e., /etc/SnmpAgent.d/snmpd.conf is empty.
The /etc/SnmpAgent.d/snmpd.conf file contains the following configurable values:
The syntax for using v3 features of SNMP is as follows. The format is:
Where TAG is one of the following:
VALUE is a valid value for any give TAG. When the TAG is usmUserEntry, the format of the VALUE clause is as follows:
usmUserEngineID usmUserName usmUserAuthProtocol usmUserPrivProtocol \
When the TAG is vacmSecurityToGroupEntry, the format of the VALUE clause is as follows:
vacmSecurityModel vacmSecurityName vacmGroupName vacmSecurityToGroupStorageType
When the TAG is vacmAccessEntry the format of the VALUE clause is as follows:
vacmGroupName vacmAccessContextPrefix vacmAccessSecurityModel
vacmAccessSecurityLevel vacmAccessContextMatch vacmAccessReadViewName
vacmAccessWriteViewName vacmAccessNotifyViewName vacmAccessStorageType
When the TAG is vacmViewTreeFamilyEntry, the format of the VALUE clause is as follows:
When the TAG is snmpTargetAddrEntry, the format of the VALUE clause is as follows:
snmpTargetAddrName snmpTargetAddrTDomain snmpTargetAddrTAddress
snmpTargetAddrTimeout snmpTargetAddrRetryCount snmpTargetAddrTagList
snmpTargetAddrParams snmpTargetAddrStorageType snmpTargetAddrTMask
When the TAG is snmpNotifyEntry, the format of the VALUE clause is as follows:
snmpNotifyName snmpNotifyTag snmpNotifyType snmpNotifyStorageType
When the TAG is snmpTargetParamsEntry, the format of the VALUE clause is as follows:
Separate the fields by blanks or tabs. A # character indicates the beginning of a comment; characters from the # character to the end of the line are ignored.
Each line in the following example snmpd.conf file is preceded by a comment (beginning with #) that explains the entry.
# Restrict the agent to responding only to # SNMP GetRequests that have the # community name "secret" get-community-name: secret # Allow the agent to respond to SNMP Get and SetRequests with # either the community name "private" or "secret" set-community-name: private set-community-name: secret # Allow the agent to respond to SNMP Get and SetRequests # that have the community name "private" set-community-name: private # Send traps to system 220.127.116.11 trap-dest: 18.104.22.168 # Specify the agent is located on the first floor # near the mens room location: 1st Floor near Mens Room # Specify Bob Jones is responsible for this agent # and his phone number is 555-2000 contact: Bob Jones (Phone 555-2000)
# Create a SNMPv3 user 'v3usr' with No Authentication Protocol. usmUserEntry localSnmpID v3usr usmNoAuthProtocol 22.214.171.124.126.96.36.199.2.1 \ nonVolatile whereValidRequestsOriginate - # Create a SNMPv3 user 'v3usr' with Authentication enabled and # password as "passwd". usmUserEntry localSnmpID v3usr usmHMACMD5AuthProtocol 188.8.131.52.184.108.40.206.2.1 \ nonVolatile whereValidRequestsOriginate "passwd" # Create a group 'admin' and make the user 'v3usr' a part of the # same group. vacmSecurityToGroupEntry usm v3usr admin nonVolatile # Assign access control the group 'admin'. This group will have # security protocol as no authentication and no privacy vacmAccessEntry admin - usm noAuthNoPriv prefix All All - nonVolatile # 'All' is the name of the view that will define the access for the # group 'admin'. Give access to the view named 'All'. The access is # for the subtree `internet' i.e. .220.127.116.11 vacmViewTreeFamilyEntry All 18.104.22.168 - included nonVolatile # Create a target address entry for 192.168.40.40 with UDP port as 0. # If SNMP_TRAP_TEST_ENTRY or SNMP_TEST_PORT_ENTRY are not used, # default value of UDP port 162 will be used. snmpTargetAddrEntry stae2 22.214.171.124.6.1.1 192.168.40.40:0 0 0 \ whereValidRequestsOriginate - nonVolatile 255.255.255.255:0 2048
snmpd(1M), snmpd.ea(1M), RFC 1155, RFC 1157, RFC 1212, 2RFC 1213, RFC 1231, RFC 1398.