Jump to content United States-English
HP.com Home Products and Services Support and Drivers Solutions How to Buy
» Contact HP
More options
HP.com home
HP-UX Reference > R

restore(1M)

HP-UX 11i Version 3: February 2007
» 

Technical documentation

» Feedback
Content starts here

 » Table of Contents

 » Index

NAME

restore, rrestore — restore file system incrementally, local or across network

SYNOPSIS

/usr/sbin/restore key [name ...]

/usr/sbin/rrestore key [name ...]

DESCRIPTION

The restore and rrestore commands read tapes previously dumped by the dump or rdump command (see dump(1M) and rdump(1M)).

Actions taken are controlled by the key argument where key is a string of characters containing not more than one function letter and possibly one or more function modifiers. One or more name arguments, if present, are file or directory names specifying the files that are to be restored. Unless the h modifier is specified (see below), the appearance of a directory name refers to the files and (recursively) subdirectories of that directory.

Function Portion of key

The function portion of the key is specified by one of the following letters:

r

Read the tape and load into the current directory. r should be used only after careful consideration, and only to restore a complete dump tape onto a clear file system, or to restore an incremental dump tape after a full level zero restore. Thus,

/usr/sbin/newfs -F hfs /dev/rdisk/disk2 /usr/sbin/mount /dev/disk/disk2 /mnt cd /mnt restore r

is a typical sequence to restore a complete dump. Another restore or rrestore can then be performed to restore an incremental dump on top of this. Note that restore and rrestore leave a file restoresymtab in the root directory of the file system to pass information between incremental restore passes. This file should be removed when the last incremental tape has been restored. A dump or rdump followed by a newfs and a restore or rrestore is used to change the size of a file system (see newfs(1M)).

R

restore and rrestore request a particular tape of a multivolume set on which to restart a full restore (see r above). This provides a means for interrupting and restarting restore and rrestore.

x

Extract the named files from the tape. If the named file matches a directory whose contents had been written onto the tape, and the h modifier is not specified, the directory is recursively extracted. The owner, modification time, and mode are restored (if possible). If no file argument is given, the root directory is extracted, which results in the entire contents of the tape being extracted, unless h has been specified.

t

Names of the specified files are listed if they occur on the tape. If no file argument is given, the root directory is listed, which results in the entire content of the tape being listed, unless h has been specified.

s

The next argument to restore is used as the dump file number to recover. This is useful if there is more than one dump file on a tape.

i

This mode allows interactive restoration of files from a dump tape. After reading in the directory information from the tape, restore and rrestore provide a shell-like interface that allows the user to move around the directory tree selecting files to be extracted. The available commands are given below; for those commands that require an argument, the default is the current directory.

add [arg]

The current directory or specified argument is added to the list of files to be extracted. If a directory is specified, it and all its descendents are added to the extraction list (unless the h key is specified on the command line). File names on the extraction list are displayed with a leading * when listed by ls.

cd [arg]

Change the current working directory to the specified argument.

delete [arg]

The current directory or specified argument is deleted from the list of files to be extracted. If a directory is specified, it and all its descendents are deleted from the extraction list (unless h is specified on the command line). The most expedient way to extract files from a directory is to add the directory to the extraction list, then delete unnecessary files.

extract

All files named on the extraction list are extracted from the dump tape. restore and rrestore ask which volume the user wants to mount. The fastest way to extract a few files is to start with the last volume, then work toward the first volume.

help

List a summary of the available commands.

ls [arg]

List the current or specified directory. Entries that are directories are displayed with a trailing /. Entries marked for extraction are displayed with a leading *. If the verbose key is set, the inode number of each entry is also listed.

pwd

Print the full path name of the current working directory.

quit

restore and rrestore immediately exit, even if the extraction list is not empty.

set-modes

Set the owner, modes, and times of all directories that are added to the extraction list. Nothing is extracted from the tape. This setting is useful for cleaning up after a restore aborts prematurely.

verbose

The sense of the v modifier is toggled. When set, the verbose key causes the ls command to list the inode numbers of all entries. It also causes restore and rrestore to print out information about each file as it is extracted.

Function Modifiers

The following function modifier characters can be used in addition to the letter that selects the function desired:

b

Specify the block size of the tape in kilobytes. If the -b option is not specified, restore and rrestore try to determine the tape block size dynamically.

f

Specify the name of the archive instead of /dev/rmt/0m. If the name of the file is -, restore reads from standard input. Thus, dump and restore can be used in a pipeline to dump and restore a file system with the command

dump 0f - /usr | (cd /mnt; restore xf -)

When using rrestore, this key should be specified, and the next argument supplied should be of the form machine:device.

h

Extract the actual directory, rather than the files to which it refers. This prevents hierarchical restoration of complete subtrees from the tape, rather than the files to which it refers.

m

Extract by inode numbers rather than by file name. This is useful if only a few files are being extracted and one wants to avoid regenerating the complete path name to the file.

v

Type the name of each file restore and rrestore treat, preceded by its file type. Normally restore and rrestore do their work silently; the v modifier specifies verbose output.

y

Do not ask whether to abort the operation if restore and rrestore encounters a tape error. restore and rrestore attempt to skip over the bad tape block(s) and continue.

rrestore creates a server, either /usr/sbin/rmt or /etc/rmt, on the remote machine to access the tape device.

DIAGNOSTICS

restore and rrestore complain about bad key characters.

restore and rrestore complain if a read error is encountered. If the y modifier has been specified, or the user responds y, restore and rrestore attempt to continue the restore.

If the dump extends over more than one tape, restore and rrestore ask the user to change tapes. If the x or i function has been specified, restore and rrestore also ask which volume the user wants to mount. The fastest way to extract a few files is to start with the last volume and work towards the first volume.

There are numerous consistency checks that can be listed by restore and rrestore. Most checks are self-explanatory or can ``never happen''. Here are some common errors:

filename: not found on tape

The specified file name was listed in the tape directory but not found on the tape. This is caused by tape read errors while looking for the file, and from using a dump tape created on an active file system.

expected next file inumber, got inumber

A file not listed in the directory showed up. This can occur when using a dump tape created on an active file system.

Incremental tape too low

When doing an incremental restore, a tape that was written before the previous incremental tape, or that has too low an incremental level has been loaded.

Incremental tape too high

When doing an incremental restore, a tape that does not begin its coverage where the previous incremental tape left off, or that has too high an incremental level has been loaded.

Tape read error while restoring filename

Tape read error while skipping over inode inumber

Tape read error while trying to resynchronize

A tape read error has occurred. If a file name is specified, the contents of the restored files are probably partially wrong. If restore is skipping an inode or is trying to resynchronize the tape, no extracted files are corrupted, although files may not be found on the tape.

Resync restore, skipped num blocks

After a tape read error, restore and rrestore may have to resynchronize themselves. This message indicates the number of blocks skipped over.

WARNINGS

restore and rrestore can get confused when doing incremental restores from dump tapes that were made on active file systems.

A level zero dump (see dump(1M)) must be done after a full restore. Since restore runs in user code, it has no control over inode allocation; thus a full dump must be done to get a new set of directories reflecting the new inode numbering, even though the contents of the files are unchanged.

AUTHOR

restore and rrestore were developed by the University of California, Berkeley.

FILES

/dev/rmt/0m

Default tape drive.

/tmp/rstdr*

File containing directories on the tape.

/tmp/rstmd*

Owner, mode, and time stamps for directories.

./restoresymtab

Information passed between incremental restores.

Printable version
Privacy statement Using this site means you accept its terms Feedback to webmaster
© 1983-2007 Hewlett-Packard Development Company, L.P.