|HP-UX Reference > R
rbacdbchk(1M)HP-UX 11i Version 3: February 2007
rbacdbchk — Verifies the syntax of the Role-Based Access Control (RBAC) database files
rbacdbck verifies that there are no conflicting or inconsistent entries in and amongst the RBAC database files. rbacdbck also checks the syntax of the database files and prints messages indicating which lines contain errors. rbacdbchk returns zero output if no errors are present in the database files.
All the RBAC database files (/etc/rbac/roles, /etc/rbac/auths, /etc/rbac/user_role, /etc/rbac/role_auth, and /etc/rbac/cmd_priv) are verified. See rbac(5) for more information on these RBAC database files.
The following example finds an error that user John is an invalid user
# rbacdbchk [/etc/rbac/user_role] John: Administrator invalid user The value 'John' for the Username field is bad.
The following example finds a syntax error, an extra colon (:), at the end of a line:
# rbacdbchk [/etc/rbac/user_role] root: Administrator: invalid name: Not alphanumeric The value 'Administrator:' for the Rolename field is bad. [Role in role_auth DB with no assigned user in user_role DB] Administrator:(hpux.*, *)
The following example finds a field missing:
# rbacdbchk [/etc/rbac/roles] : my comment invalid name: <empty> The value '' for the Rolename field is bad.
The following example finds a bad role:
# rbacdbchk [Role in role_auth DB with no assigned user in user_role DB] blah:(hpux.*, *) [Invalid Role in role_auth DB. Role 'blah' does not exist in the roles DB] blah:(hpux.*, *)
The following example finds a bad group name:
# rbacdbchk [/etc/rbac/user_role] &blah: Administrator invalid group The value 'blah' for the Group name field is bad.