|HP-UX Reference > I
iobind(1M)HP-UX 11i Version 3: February 2007
iobind — bind a driver to a device
The iobind command may be used to perform online unbinding of a device LUN hardware path from its current driver and binding a new driver to it. As part of the binding operation, the specified driver will be bound to the LUN hardware path and also to its corresponding legacy hardware paths.
The hardware path specified as the argument to the -H option must be of the form 64000/0x/0x. The driver name specified with the -M option will be bound to the LUN and legacy hardware paths. The optional -I option specifies an instance number to be assigned to the device associated with the hardware path. If this option is not used, the device will be assigned a new instance number in the new driver's class. The optional -f forces the binding to occur at the next reboot if it cannot be done online.
The device must not be in use while the unbind operation is performed. The driver must support online unbinding and binding. If either of these requirements is false and the -f option is not given, the user will be asked if the binding can take effect at the next reboot. The user is given the option to proceed or not.
If a driver supports online unbinding and binding, then after iobind completes, a device will have one of the following software states as shown by the ioscan command:
iobind recognizes the following options:
Unbind the driver bound to the device at hardware path 64000/0xfa00/0xa and bind the device to esdisk. Use the default instance number of the driver's class.
iobind -H 64000/0xfa00/0xa -M esdisk
Unbind the driver bound to the device at hardware path 64000/0xfa00/0xb and bind the device to esdisk. Assign it the instance number 50.
iobind -H 64000/0xfa00/0xb -M esdisk -I 50
Do a forced binding. If the driver does not support online binding or the device is busy, the binding will be deferred till next reboot.
iobind -H 64000/0xfa00/0xc -M esdisk -f
The ioscan and iobind commands should not be run at the same time because both commands attempt to bind drivers. In particular, there may be a short window while iobind will leave a hardware path unbound. If ioscan runs during that window, it may bind a different driver to that hardware path. If this happens, iobind must be executed again to bind the desired driver.
iobind may be executed only by the superuser.