Jump to content United States-English
HP.com Home Products and Services Support and Drivers Solutions How to Buy
» Contact HP
More options
HP.com home
HP-UX Reference > H

hpux(1M)

PA-RISC Systems Only
HP-UX 11i Version 3: February 2007
» 

Technical documentation

» Feedback
Content starts here

 » Table of Contents

 » Index

NAME

hpux — HP-UX bootstrap

SYNOPSIS

hpux [-F] [-lm] [-vm] [-tm] [-lq] [-a[C|R |S|D] devicefile] [-f number] [-i string] [boot] [devicefile] [variable=value...]

hpux ll [devicefile] (same as hpux ls -aFln)

hpux ls [-aFiln] [devicefile]

hpux set autofile devicefile string

hpux show autofile [devicefile]

hpux -v

DESCRIPTION

hpux is the HP-UX specific secondary system loader (SSL) utility for bootstrap (see isl(1M) for the initial system loader). It supports the operations summarized below, as shown in the SYNOPSIS and detailed later in this DESCRIPTION section.

This hpux(1M) manpage only documents features on PA-RISC systems. For bootstrap information on Itanium(R)-based systems, see hpux.efi(1M).

Operations

The following operations are supported on PA-RISC systems:

boot

Loads an object file from an HP-UX file system or raw device and transfers control to the loaded image. (Note, the boot operation is position dependent).

ll

Lists the contents of HP-UX directories in a format similar to ls -aFln. (See ls(1); ls only works on a local disk with a HFS file system).

ls

Lists the contents of HP-UX directories. (See ls(1); ls only works on a local disk with a HFS file system).

show autofile

Displays the contents of the autoexecute file.

set autofile

Changes the contents of the autoexecute file to that specified by string.

-v

Displays the release and version numbers of the hpux utility.

hpux commands can be given interactively from the keyboard, or provided in an isl autoexecute file.

hpux is limited to operations on the interface initialized by pdc(1M). In most cases, operations are limited to the boot device interface.

Notation

hpux accepts numbers (numeric constants) in many of its options. Numbers follow the C language notation for decimal, octal, and hexadecimal constants. A leading 0 (zero) implies octal and a leading 0x or 0X implies hexadecimal. For example, 037, 0x1F, 0X1f, and 31 all represent the same number, decimal 31.

hpux boot, ll, ls, set autofile, and show autofile operations accept devicefile specifications, which have the following format:

manager(w/x.y.z;n)filename

The devicefiles specification is comprised of a device name and a file name. The device name (manager(w/x. y.z;n) ), consists of a generic name of an I/O system manager (device or interface driver) such as disc, a hardware path to the device, and minor number. The manager name can be omitted entirely if the default is used. w/x.y. z is the physical hardware path to the device. The n is the minor number that controls manager-dependent functionality and is typically 0 or omitted. The file name part, filename, is a standard HP-UX path name. Some hpux operations have defaults for particular components. A devicefile specification containing a device part only specifies a raw device. A devicefile specification containing a file name implies that the device contains an HP-UX file system, and that the filename resides in that file system.

A typical boot devicefile specification is

disc(0/5/1/2/4.0.0;0)/stand/vmunix

The manager is disc, the lunpath hardware path (see intro(7)) to the disk device is 0/5/1/2/4.0x0.0x0, and /stand/vmunix is the filename for the boot device.

hpux supports a consolidated list of managers: disc, tape, and lan. The manager disc manages all disk devices. The manager lan manages the LAN interface used during Ignite-UX system installs. The manager tape manages all tape drives.

Defaults

Default values chosen by hpux to complete a command are obtained through a sequence of steps. First, any components of the command specified explicitly are used. If the command is not complete, hpux attempts to construct defaults from information maintained by pdc (see pdc(1M)). If sufficient information to complete the command is unavailable, the autoexecute file is searched. If the search fails, any remaining unresolved components of the command are satisfied by hard-coded defaults.

There is no hard-coded default choice for a manager; if none can be chosen, hpux reports an error.

When the hardware path to the boot device is not specified, hpux defaults to information maintained by pdc. The hardware path element has no hard-coded default.

For the boot command, a devicefile specification without a file name indicates that the boot device does not contain an HP-UX file system. hpux interprets this as a NULL (instead of missing) file name and does not search for a default. If the entire devicefile specification is missing, hpux searches for a default; either the autoexecute file contents or the hard-coded default is chosen.

There are two possible hard-coded default devicefile specifications. One hard-coded default devicefile specification is /vmunix. The other hard-coded default devicefile specification is /stand/vmunix.

If you have a LVM or VxVM system where the boot volume and the root volume are on different logical volumes, the kernel would be /vmunix. This is because the boot volume will be mounted under /stand when the system is up.

For all other configurations, the kernel would be /stand/vmunix.

The search order for the hard-coded defaults is /stand/vmunix and then /vmunix.

boot Operation

The boot operation loads an object file from an HP-UX file system or raw device as specified by the optional devicefile. It then transfers control to the loaded image.

Any missing components in a specified devicefile are supplied with a default. For example, a devicefile of vmunix would actually yield:

disc(0/5/0/1.0.0;0)vmunix

and a devicefile of (0/5/0/1.0.0)/stand/vmunix, would yield

disc(0/5/0/1.0.0;0)/stand/vmunix

To boot a saved kernel configuration, specify a devicefile of /stand/configname/vmunix, where configname is the name of the saved configuration to boot. For more details on saved kernel configurations, see kconfig(5).

Regardless of how incomplete the specified devicefile may be, boot announces the complete devicefile specification used to find the object file. Along with this information, boot gives the sizes of the TEXT, DATA, and BSS, segments and the entry offset of the loaded image, before transferring control to it.

The boot operation accepts several options. Note that boot options must be specified positionally as shown in the syntax statement in the SYNOPSIS. Options for the boot operations are as follows:

-a[C|R|S|D] devicefile

Accept a new location (as specified by devicefile) and pass it to the loaded image. If that image is an HP-UX kernel, the kernel will erase its predefined I/O configuration, and configure in the specified devicefile. If the C, R, S, or D option is specified, the kernel configures the devicefile as the console, root, swap, or dump device, respectively. Note that -a can be repeated multiple times.

-fnumber

Use the number and pass it as the flags word to the loaded image.

-istring

Set the initial run-level for init (see init(1M)) when booting the system. The run-level specified will override any run-level specified in an initdefault entry in /etc/inittab (see inittab(4)).

-lm

Boot the system in LVM maintenance mode, configure only the root volume, and then initiate single user mode.

-vm

Boot the system in VxVM maintenance mode, configure only the root volume, and then initiate single user mode.

-tm

Boot the system in tunable maintenance mode, also known as "failsafe boot" mode. This option will disregard the tunable settings and module settings in the kernel configuration, and boot with known good settings instead. Note: some systems that have been updated from earlier versions of HP-UX have boot loaders that do not support this flag. On those systems, the flag -f0x40000 can be used instead.

-lq

Boot the system with quorum override option. This option is used in a scenario where a disk is removed from the system or is otherwise unavailable, but the corresponding entry for the physical volume has not yet been removed from the volume group using vgreduce.

variable=value

Set the specified variable to the specified value. (No whitespace is allowed.)

If variable is a kernel tunable parameter, this sets the value of that tunable, overriding the value in the kernel configuration being booted. value must be a decimal integer or a hexadecimal integer (with a 0x prefix).

boot places some restrictions on object files it can load. It accepts only the HP-UX magic numbers EXECMAGIC (0407), SHAREMAGIC (0410), and DEMANDMAGIC (0413). See magic(4). The object file must contain an Auxiliary Header of the HPUX_AUX_ID type and it must be the first Auxiliary Header (see a.out(4)).

ll and ls Operations

The ll and ls operations list the contents of the HP-UX directory specified by the optional devicefile. The output is similar to that of ls -aFl command.

The default devicefile is generated just as for boot, defaulting to the current directory.

set autofile Operation

The set autofile operation overwrites the contents of the autoexecute file, autofile, with the string specified (see autoexecute in the EXAMPLES section).

show autofile Operation

The show autofile operation displays the contents of the autoexecute file, autofile (see autoexecute in the EXAMPLES section).

DIAGNOSTICS

If an error is encountered, hpux prints diagnostic messages to indicate the cause of the error. These messages fall into the General, Boot, Copy, Configuration, and System Call categories. System Call error messages are described in errno(2). The remaining messages are listed below.

General

bad minor number in devicefile spec

The minor number in the devicefile specification is not recognized.

bad path in devicefile spec

The hardware path in the devicefile specification is not recognized.

no path in devicefile spec

The devicefile specification requires (but does not contain) a hardware path component.

panic (in hpuxboot): (display==number, flags==number) string

A severe internal hpux error has occurred. Report to your nearest HP Field Representative.

Boot

bad magic

The specified object file does not have a recognizable magic number.

bad number in flags spec

The flags specification in the -f option is not recognized.

Exec failed: Cannot find /stand/vmunix or /vmunix.

Neither /stand/vmunix or /vmunix could be found.

booting from raw character device

In booting from a raw device, the manager specified only has a character interface, which might cause problems if the block size is incorrect.

isl not present, please hit system RESET button to continue

An unsuccessful boot operation has overlaid isl in memory. It is impossible to return control to isl.

short read

The specified object file is internally inconsistent; it is not long enough.

would overlay

Loading the specified object file would overlay hpux.

Configuration

cannot add path, error number

An unknown error has occurred in adding the hardware path to the I/O tree. The internal error number is given. Contact your HP Field Representative.

driver does not exist

The manager specified is not configured into hpux.

driver is not a logical device manager

The manager named is not that of a logical device manager and cannot be used for direct I/O operations.

error rewinding device

An error was encountered attempting to rewind a device.

error skipping file

An error was encountered attempting to forward-space a tape device.

negative skip count

The skip count, if specified, must be greater than or equal to zero.

no major number

The specified manager has no entry in the block or character device switch tables.

path incompatible with another path

Multiple incompatible hardware paths have been specified.

path long

The hardware path specified contains too many components for the specified manager.

path short

The hardware path specified contains too few components for the specified manager.

table full

Too many devices have been specified to hpux.

EXAMPLES

As a preface to the examples which follow, here is a brief overview of HP-UX system boot-up sequences.

Automatic Boot

Automatic boot processes on various HP-UX systems follow similar general sequences. When power is applied to the HP-UX system processor, or the system Reset button is pressed, processor-dependent code (firmware) is executed to verify hardware and general system integrity (see pdc(1M)). After checking the hardware, pdc gives the user the option to override the autoboot sequence by pressing any key. At that point, a message resembling the following usually appears on the console.

Processor is starting the autoboot process. To discontinue, press any key within 10 seconds.

If no keyboard activity is detected, pdc commences the autoboot sequence by loading isl (see isl(1M)) and transferring control to it. Since an autoboot sequence is occurring, isl finds and executes the autoexecute file which, on an HP-UX system, requests that hpux be run with appropriate arguments. Messages similar to the following are displayed by isl on the console:

10 seconds expired. Proceeding... Booting... Boot IO Dependent Code (IODC) revision 8 HARD Booted. ISL Revision A.00.44 Mar 12, 2003 ISL booting hpux

hpux, the secondary system loader, then announces the operation it is performing, in this case boot, the devicefile from which the load image comes, and the TEXT size, DATA size, BSS size, and start address of the load image, as shown below, before control is passed to the image.

Boot : disk(0/5/1/0.1342185441.1342359545.1074003968.0.0.0;0)/stand/vmunix 17838080 + 4132864 + 10284088 start 0x3c0e8

The loaded image then displays numerous configuration and status messages.

Interactive Boot

To use hpux interactively, isl must be brought up in interactive mode by pressing any key during the interval allowed by pdc. pdc then displays the primary, alternate, and if applicale, HA boot devices and presents the pdc Main Menu. The bootpath may be chosen using

BOot [PRI|HAA|ALT|<path>].

such as

Main Menu: Enter command or menu >bo pri

or

Main Menu: Enter command or menu >bo 0/5/1/0.1

A search can also be done for boot devices:

Main Menu: Enter command or menu >search

Potential boot devices are then displayed:

Path# Device Path (dec) Device Type Rev ----- ----------------- ----------- ---- P0 0/0/0/1/0.15.1.135.118 LAN Module 6 P1 0/0/0/2/0.6 Random access media 4 P2 0/0/1/1/1.0 Fibre Channel Protocol 8

The boot path may be chosen by

Main Menu: Enter command or menu >bo p1

Although all of the operations and options of hpux can be used from isl interactively, they can also be executed from an autoexecute file. In the examples below, user input is the remainder of the line after each ISL> prompt shown. The remainder of each example is text displayed by the system. Before going over specific examples of the various options and operations of hpux, here is an outline of the steps taken in the automatic boot process. Although the hardware configuration and boot paths shown are for a single server machine, the user interfaces are consistent across all models. When the system Reset button is depressed, pdc executes self-test, and assuming the hardware tests pass, pdc announces itself, and gives the user 10 seconds to override the autoboot sequence by entering any character. Text resembling the following is displayed on the console:

Central Bus Speed (in MHz) : 200 Available Memory : 7340032 KB Good Memory Required : Not initialized. Defaults to 32 MB. Primary boot path: 0/5/1/0.1 Alternate boot path: 0/5/1/0.2 Console path: 0/0/1/1.0 Keyboard path: 0/0/4/0.0 Processor is starting the autoboot process. To discontinue, press any key within 10 seconds.

If no keyboard character is pressed within 10 seconds, pdc commences the autoboot sequence by loading isl and transferring control to it. Because an autoboot sequence is occurring, isl merely announces itself, finds and executes the autoexecute file which, on an HP-UX system, requests that hpux be run with appropriate arguments. The following is displayed on the console.

10 seconds expired. Proceeding ... Booting... Boot IO Dependent Code (IODC) revision 8 HARD Booted. ISL Revision A.00.44 Mar 12, 2003 ISL booting hpux

hpux then announces the operation it is performing, in this case boot, the devicefile from which the load image comes, and the TEXT size, DATA size, BSS size, and start address of the load image. The following is displayed before control is passed to the image.

Boot : disc(0/5/1/0.0;0)/stand/vmunix 3288076 + 323584 + 405312 start 0x11f3e8

Finally, the loaded image displays numerous configuration and status messages, then proceeds to init run-level 2 for multiuser mode of operation.

isl must be brought up in interactive mode to use the operations and options of hpux. To do this, simply enter a character during the 10 second interval allowed by pdc. pdc then asks if the primary boot path is acceptable. Answering yes (Y) is usually appropriate. pdc then loads isl and isl interactively prompts for commands. The following lines show the boot prompt, the Y response, subsequent boot messages, and finally the Initial System Loader (ISL) prompt that are sent to the display terminal:

Boot from primary boot path (Y or N)?> y Interact with IPL (Y or N)?> y Booting... Boot IO Dependent Code (IODC) revision 8 HARD Booted. ISL Revision A.00.44 Mar 12, 2003 ISL>

Although all of the operations and options of hpux can be used from isl interactively, they can also be executed from an autoexecute file. In the examples below, all user input follows the ISL> prompt on the same line. Subsequent text is resultant messages from the ISL.

Default Boot

Entering hpux initiates the default boot sequence. The boot path read from pdc is 0/5/1/0.0, the manager associated with the device at that path is disc, and the object file name is /stand/vmunix.

ISL> hpux Boot : disc(0/5/1/0.0;0)/stand/vmunix 3288076 + 323584 + 405312 start 0x11f3e8

Booting Another Kernel Configuration

In this example, hpux initiates a boot operation for the saved kernel configuration myconfig.

ISL> hpux myconfig/vmunix Boot : disc(0/5/1/0.0;0)/stand/myconfig/vmunix 3288076 + 323584 + 405312 start 0x11f3e8

Booting From Another Disk

Only the hardware path and file name are specified in this example. All other values are boot defaults. The object file comes from the file system on another disk.

ISL> hpux (52.5.0.0)/stand/vmunix Boot : disc(52.5.0.0)/stand/vmunix 966616+397312+409688 start 0x6c50

Booting From LAN

hpux supports booting over a local area network for the purpose of installing the HP-UX operating system using Ignite-UX. See ignite(5) for details on configuring an Ignite-UX server and client system installation.

This example shows how to boot a system from an Ignite-UX server to perform a cold-install of HP-UX. After turning the system on or pressing the Reset button, press a key to interrupt the autoboot process (if autoboot is enabled) and at the BCH prompt, enter:

Main Menu: Enter command or menu >boot lan.n.n.n.n install

where: n.n.n.n is the IP address of the Ignite-UX server. The client then begins to load the install kernel (ignite the client) from the network server.

To search for Ignite-UX servers, type the following ath the client console:

Main Menu: Enter command or menu >search lan install

The list of servers that you can boot the client from is displayed with the corresponding IP addresses and is similar to:

Search for potential boot devices(s)... on Path LAN This may take several minutes. To discontinue search, press any key (termination may not be immediate). Path Number Device Path Device Type ----------- ----------- ----------- P0 LAN.15.1.46.117.3.254 lp2 100/Full Dx P1 LAN.15.1.41.70.3.254 lp4 100/Full Dx

You may need to run the nslookup command on another system to determine which address corresponds to your Ignite-UX server. To boot from one of the above servers, you would then type:

Main Menu: Enter command or menu >boot P1

Booting to isl from a local disk and then requesting an image to be loaded from the LAN is not supported.

Booting To Single User Mode

In this example, the -i option is used to make the system come up in run-level s, for single user mode of operation.

ISL> hpux -is Boot : disc(0/5/1/0.0;0)/stand/vmunix 966616+397312+409688 start 0x6c50 (Kernel Startup Messages Omitted) INIT: Overriding default level with level 's' INIT: SINGLE USER MODE WARNING: YOU ARE SUPERUSER !! #

Booting With A Modified I/O Configuration

Here a new console and dump device with a lunpath hardware path (see intro(7)) of

0/5/1/0.0x50001fe15002c7f9.0x4004000000000000

are configured. Lunpath hardware paths cannot be directly used with the "-a" option. Instead, the output given by "ioscan -e" (ioscan(1m)) must be used.

ISL> hpux -aC 0/0/1/0 -aD 0/5/1/0.0x50001fe1.0x5002c7f9.0x40040000.0x0 (Additional Kernel Startup Messages Omitted)

Displaying The Autoexecute File

In this example, show autofile is used to print the contents of the autoexecute file residing in the boot LIF, on the device from which hpux was booted. Optionally, a devicefile can be specified in order to read the autoexecute file from the boot LIF of another boot device.

ISL> hpux show autofile Show autofile : AUTO file contains (hpux)

Changing The Autoexecute File

This example shows how to change the contents of the autoexecute file. Once done, the system can be reset, and the new command will be used during any unattended boot.

ISL> hpux set autofile "hpux /stand/myconfig/vmunix" Set autofile : disk(0/5/2/0/1.3.0.0.0.0.0;0) : AUTO file now contains "(hpux /stand/myconfig/vmunix)"

Listing Directory Contents

The contents of the directory (/stand) on the root disk are listed. The format shows the file protections, number of links, user id, group id, and size in bytes for each file in the directory. There are three available kernel configurations to boot: the default configuration (vmunix), the automatic backup configuration (backup), and one other saved configuration (good). Listing the files over the LAN is not supported.

ISL> hpux ll /stand Total 100570 dr-xr-xr-x 9 root bin 1024 Apr 24 18:24 ./ dr-xr-xr-x 14 bin bin 1024 Apr 24 18:24 ../ drwxr-xr-x 5 root sys 1024 Feb 16 01:03 backup/ -rw-r--r-- 1 root sys 19 Jan 12 08:45 bootconf drwxr-xr-x 3 root sys 1024 Apr 24 18:24 bootfs@ -> current/bootfs drwxr-xr-x 5 root sys 1024 Feb 16 01:04 current/ drwxr-xr-x 5 root sys 1024 Jan 04 09:42 good/ -rw-r--r-- 1 root sys 4376 Feb 24 13:42 ioconfig -r--r--r-- 1 root sys 82 Jan 12 19:17 kernrel drwxr-xr-x 2 root sys 1024 Apr 24 18:24 krs/ drwxr-xr-x 2 root root 65536 Jan 12 07:32 lost+found/ drwxr-xr-x 5 root sys 1024 Apr 24 18:24 nextboot@ -> current -rw------- 1 root root 12 Jan 12 08:13 rootconf -rw-r--r-- 1 root sys 1892 Feb 15 15:21 system -rwxr-xr-x 4 root sys 17163704 Feb 16 01:03 vmunix*

Getting The Version

The -v option is used to get the version numbers of hpux.

ISL> hpux -v HP-UX PA bootloader Revision 2.018 built Nov 23 2005 15:46:52

Printable version
Privacy statement Using this site means you accept its terms Feedback to webmaster
© 1983-2007 Hewlett-Packard Development Company, L.P.