Jump to content United States-English
HP.com Home Products and Services Support and Drivers Solutions How to Buy
» Contact HP
More options
HP.com home
HP-UX Reference > F

filecache_max(5)

Tunable Kernel Parameters
HP-UX 11i Version 3: February 2007
» 

Technical documentation

» Feedback
Content starts here

 » Table of Contents

 » Index

NAME

filecache_max, filecache_min — maximum or minimum amount of physical memory used for caching file I/O data

VALUES

Failsafe

filecache_min: approximately 5% of physical memory

filecache_max: approximately 5% of physical memory

Default

filecache_min: approximately 5% of physical memory

filecache_max: approximately 50% of physical memory

The defaults are computed and adjusted automatically, based on the amount physical memory on the system.

The current default value, when displayed by kctune, will be expressed as the current value used internally by the system (representing bytes). The displayed value will vary as the internal value is automatically adjusted.

Allowed values

Minimum filecache_min: not less than the equivalent of 1 megabyte

Minimum filecache_max: not less than the equivalent of 1 megabyte

Maximum filecache_min: not greater than the equivalent of 70% of physical memory

Maximum filecache_max: not greater than the equivalent of 90% of physical memory

See Restrictions on Changing below.

Values can be specified as:

1) Default

2) A percentage of total physical memory:

A positive whole number followed by a percent symbol (for example, 70%).

3) A constant value:

A positive whole number that represents number of bytes of physical memory, optionally followed by a multiplier suffix, where K=1000, KB=1024, M=1000000, MB=(1024*1024), and GB=(1024*1024*1024).

Recommended values

It is recommended that these tunables are left in the automatic (default) state, to allow the system to better balance the memory usage among filesystem I/O-intensive processes and other types of processes.

DESCRIPTION

These tunables control the amount of physical memory that can be used for caching file data during file system I/O operations.

The amount of physical memory that is specified by the filecache_min tunable is reserved and guaranteed to be available for file caching.

The amount of physical memory used for file caching can grow beyond filecache_min, up to filecache_max, depending on I/O load and competing requests for physical memory.

When these tunables are set to default, or set to a percent value, they automatically adjust with Online Addition or Deletion (OL*) of physical memory, as appropriate.

Who Is Expected to Change These Tunables?

The automatic (default) state should be appropriate for most environments.

You must set these tunables to a constant value (not default or percent) if you want to specify file cache limits with finer granularity than percent of physical memory (for example, a minimum size or fixed size of <1% of physical memory).

You must set these tunables to a constant value (not default or percent) if you do not want the limits of the file cache to adjust with OL* of physical memory.

To discriminate in favor of deterministic I/O on systems with large file I/O activity, or on the contrary, to discriminate in favor of better performance of non-I/O-intensive processes, you can consider changing the values of these tunables, keeping in mind the side effects as described below.

To determine a reasonable value for the cache size you should consider the file I/O-intensive applications on your system, and the size of their working set. Depending on the type of applications, the working set size can be based on the size of a transaction, or data size in given unit of time. For example, for a conservative value of filecache_min in megabytes, you can use the following formula:

  • MB = number-of-system-processes * largest-application-record-length-in-MB * number-of-records-in-working-set

Only those processes that actively use disk I/O for file data should be included in the calculation. All others can be excluded. Here are some examples of what processes should be included in or excluded from the calculation.

Include:

NFS daemons, text formatters, database management applications, text editors, compilers, and so on, that access or use source and/or output files stored in one or more file systems mounted on the system.

Exclude:

X-display applications, hpterm, rlogin, login shells, system daemons, telnet or uucp connections, and so on. These processes use very little, if any, disk I/O for file data.

Restrictions on Changing

These tunables are dynamic and automatic.

The system rounds the specified tunable value(s) down to the closest physical page boundary.

The amount of physical memory represented by filecache_min must be equal to or less than the memory represented by tunable filecache_max.

Setting these tunables to a constant value will de-couple them from OL* events.

Tuning up of the filecache_min parameter may fail if there is not enough free physical memory to satisfy the request.

These tunables, filecache_min and filecache_max, must both be set to a relative state (either default of percent state), or must both be set to a constant value. For example, the following are acceptable settings:

# kctune filecache_min=100MB filecache_max=100MB

# kctune filecache_min=15% filecache_max=65%

# kctune filecache_min=Default filecache_max=65%

The following will result in an error:

# kctune filecache_min=10% filecache_max=1GB

ERROR: The specified units for the values of filecache_min and filecache must be consistent: both as relative (percentage or default) or both as constant value.

If filecache_min is currently set to default, the following is acceptable:

# kctune filecache_max=Default

# kctune filecache_max=40%

But the following will result in an error:

# kctune filecache_max=1GB

See other restrictions in the Allowed values section above.

When Should the Value of These Tunables Be Raised?

Low system performance at initialization time and/or on a system with filesystem I/O-intensive processes may be an indication that the values of these tunables are too low. If there is a large number of processes actively and constantly using file data I/O, you should raise the value of filecache_min for more deterministic I/O. In most cases, especially when the file data I/O is expected to peak only occasionally, it is recommended that the value of the maximum limit, filecache_max, is raised instead.

What Are the Side Effects of Raising the Values?

The amount of memory reserved for the minimum file cache size, dictated by filecache_min, cannot be used on the system for other purposes. Be careful not to raise this value so high that it can eventually cause memory pressure and overall system performance degradation.

When Should the Values of These Tunables Be Lowered?

The value of the minimum limit, filecache_min, can be lowered to allow a larger percentage of memory to be used for purposes other than filesystem I/O caching, depending on competing requests. By lowering the value of filecache_max, a larger amount of memory is available for other purposes, without competing with file I/O requests.

What Are the Side Effects of Lowering the Values?

If there are many competing requests for physical memory, and the file cache tunables are set to too low a value, very high demand on file I/O operations can eventually cause filesystem I/O performance degradation.

EXAMPLES

Set the file cache minimum to 10% of physical memory:

# kctune filecache_min=10%

Set a fixed size file cache of 1 gigabyte:

# kctune filecache_min=1GB filecache_max=1GB

Set the file cache minimum to 15% of physical memory, and the maximum to 65% of the physical memory:

# kctune filecache_min=15% filecache_max=65%

WARNINGS

All HP-UX kernel tunable parameters are release specific. These parameters may be removed or have their meaning changed in future releases of HP-UX.

Other tunable parameters related to sizing the buffer cache that existed in previous HP-UX releases are now obsolete. The tunables filecache_min and filecache_max should be used to set limits to the file cache. Note that, on any given system, the optimum values of these two new tunables are not necessarily equivalent to the optimum values of the obsolete tunable values in the older systems. You should first determine if the new default values yield acceptable performance on your system, before attempting to change the values of the new file cache tunables.

Installation of optional kernel software, from HP or other vendors, may cause changes to tunable parameter values. After installation, some tunable parameters may no longer be at the default or recommended values. For information about the effects of installation on tunable values, consult the documentation for the kernel software being installed. For information about optional kernel software that was factory installed on your system, see HP-UX Release Notes at http://docs.hp.com.

AUTHOR

filecache_max and filecache_min were developed by HP.

Printable version
Privacy statement Using this site means you accept its terms Feedback to webmaster
© 1983-2007 Hewlett-Packard Development Company, L.P.