|HP-UX Reference > C
cplxmodify(1M)HP-UX 11i Version 3: February 2007
cplxmodify — modify an attribute of a system complex
cplxmodify [-N ComplexName] [ [ -u username [:] -h IPaddress|hostname ] | [ -g -h IPaddress|hostname ] ]
The cplxmodify command modifies attributes of the complex of a partitionable system. The command is the equivalent, at the complex level, of the parmodify command, which modifies attributes of an nPartition.
The complex to be modified defaults to the local complex, the one on which the command is run. A remote complex can be identified by specifying either the -u or -g option in combination with the -h option.
Superuser permission is required to run this command on the local partition. If the -u or -g option is used to access a remote partition or complex, superuser permission is not required on the local system, and the local system need not exist on an nPartition. If the -u option is specified, username on the remote host must have superuser permission or the command will fail.
By the nature of its operation, this command can modify the configuration of its target complex. Operation can be affected by the state of the target complex's nPartition Configuration Privilege. If this privilege is unrestricted (the default), or the complex is accessed using the -g option, all operations are allowed. Otherwise the command fails. The -g option is unaffected by the state of the nPartition Configuration Privilege. Note: This privilege state can only be changed at the service processor's Command menu.
Refer to the nPartition Administrator's Guide for a description of the partition management terms used in this man page.
Options and Arguments
cplxmodify recognizes the following command line options and arguments:
The cplxmodify command exits with one of the following values:
Change the name of the local complex to "Basingstoke".
cplxmodify -N Basingstoke
Change the name of a remote complex to "Ploverleigh". The command prompts for the password.
cplxmodify -N Ploverleigh -g -h RemoteComplex
This command uses the Web-Based Enterprise Management (WBEM) product and some of its configuration settings. If you encounter connection errors when using the -u option, check that the following two conditions are satisfied:
Refer to the WBEM documents specified in the SEE ALSO section below for further information.
fruled(1), parstatus(1), frupower(1M), parcreate(1M), parmgr(1M), parmodify(1M), parremove(1M), parunlock(1M), partition(5).
nPartition Administrator's Guide on http://docs.hp.com,
HP WBEM Services for HP-UX System Administrator's Guide on http://docs.hp.com,
HP WBEM Services for HP-UX 11i v2.0 on Integrity Servers Version A.01.05 Release Notes on http://docs.hp.com.