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About This Guide

This preface describes the objectives, audience, organization, and conventions of 
the Cisco Mobile Wireless Transport Manager User Guide. It refers you to related 
publications and describes online sources of technical information.

The Cisco Mobile Wireless Transport Manager (MWTM) is a network 
management software product that enables network administrators to discover, 
manage, and troubleshoot networks that include Cisco RAN-O devices. See the 
“MWTM Overview” section on page 1 for a more detailed description of SGM.

The following information is included in this preface:

• Document Objectives, page xxviii

• Document Audience, page xxviii

• Document Organization, page xxviii

• Document Conventions, page xxx

• Related Documentation, page xxxi

• Obtaining Documentation, page xxxii

• Documentation Feedback, page xxxiii

• Obtaining Technical Assistance, page xxxiii

• Obtaining Additional Publications and Information, page xxxv
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Document Objectives
Document Objectives
This guide describes the architecture, supporting hardware and software, and 
MWR management procedures for MWTM. Using the information provided in 
this guide, you can complete the tasks that are necessary to use MWTM in your 
RAN-O system environment.

Document Audience
This guide is for network administrators or operators who use the MWTM 
software to manage RAN-O installations. Network administrators or operators 
should have the following skills:

• Basic network management skills

• Basic Solaris system administrator skills

• Basic IP knowledge

Document Organization
This guide is divided into the following chapters:

• “MWTM Overview” provides brief descriptions of Cisco RAN-O network, 
MWTM, and MWTM’s client/server architecture, and an overview of how to 
use MWTM to manage your RAN-O installation.

• “Discovering Your RAN-O Networks Using MWTM” provides procedures 
for configuring SNMP settings, working with seed files, and running 
Discovery.

• “Getting Started with MWTM” provides basic information and procedures 
for using MWTM, with links to more detailed information and procedures in 
following chapters and appendixes.

• “Working with Views” provides information about using MWTM to create, 
change, and load views and subviews, and view basic and detailed 
information for views and subviews.
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Document Organization
• “Working with Events” provides information about using MWTM to view 
basic and detailed information for events, and change the way MWTM 
processes events.

• “Working with Nodes” provides information about using MWTM to view 
basic and detailed information for nodes, and change some aspects of nodes.

• “Working with Interfaces” provides information about using MWTM to view 
detailed information for interfaces.

• “Viewing the Topology of the Network” provides procedures for viewing the 
topology of your network, changing the way MWTM displays the topology, 
and saving customized topology displays.

• “Working with MWTM Statistics Reports” provides procedures for creating 
and viewing MWTM statistics reports.

• “Configuring MWTM Security” provides information about configuring 
MWTM security and limiting access to MWTM.

• “Configuring MWTM for Your Network” provides figures and detailed 
descriptions of how MWTM is configured on a variety of network 
configurations, and for operation with other NMS systems.

• “Troubleshooting MWTM and the Network” provides information for 
troubleshooting basic MWTM and network problems, including how to verify 
Discovery, clearing a locked-up MWTM display, and using MWTM to 
diagnose a typical RAN-O network problem.

• “Accessing MWTM Data from a Web Browser” describes how to access 
MWTM data from a Web browser.

• “MWTM Status Definitions” defines the default status settings for all 
MWTM network objects.

• “MWTM FAQs” provides a list of frequently asked questions and 
troubleshooting tips for MWTM.

• “MWTM Command Reference” describes the IOS Commands used to set up 
and operate MWTM.

• “MWTM MIB Reference” lists and describes the MIB variables that are 
polled by MWTM.

• “MWTM Trap Reference” lists and describes the traps that MWTM supports.
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Document Conventions
• “Configuring MWTM to Run with Various Networking Options” describes 
communication between the MWTM client and the MWTM server in 
different networking environments, including Virtual Private Network 
(VPN), Network Address Translation (NAT), firewall, port-forwarding, and 
Secure Sockets Layer (SSL).

• “MWTM Statistics Export File Formats” lists the formats for MWTM 
statistics export files. 

• “MWTM and Ports” lists MWTM services ports, port type and descriptions.

Document Conventions
This guide uses basic conventions to represent text and table information.

Command descriptions use the following conventions:

• Commands and keywords are in  font.

• Arguments for which you supply values are in italic font.

• Elements in square brackets ([ ]) are optional.

• Alternate but required keywords are grouped in braces ({ }) and separated by 
a vertical bar (|).

Examples use the following conventions:

• Terminal sessions and information that the system displays are printed in 
screen font.

• Information that you enter is in boldface screen font. Variables for which 
you enter actual data are printed in italic screen font.

• Nonprinting characters, such as passwords, are shown in angle brackets (< >).

• Information that the system displays is in screen font, with default responses 
in square brackets ([ ]).

This publication also uses the following conventions:

• Menu items and button names are in boldface font.

• Directories and filenames are in italic font.

• If items such as buttons or menu options are grayed out on application 
windows, it means that the items are not available either because you do not 
have the correct permissions or because the item is not applicable at this time.
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Related Documentation
Note Means reader take note. Notes contain helpful suggestions or 
references to materials not contained in the manual.

Caution Means reader be careful. You are capable of doing something that 
might result in equipment damage or loss of data.

Tip Means the following are useful tips.

Related Documentation
Additional information can be found in the following publications of the SGM 
documentation set:

• Cisco Mobile Wireless Transport Manager Installation Guide

• Cisco Mobile Wireless Transport Manager Release Note

• Cisco Mobile Wireless Transport Manager Online Help System

Information about Cisco IOS software-related functions can be found in the 
following publication:

• Cisco Management Information Base (MIB) User Quick Reference

Information about Cisco Mobile Wireless Router (MWR), including procedures 
for configuring MWR objects, can be found in the following publication:

• Cisco MWR 1941-DC-A Mobile Wireless Edge Router Software 
Configuration Guide 

Information about the Cisco MWRs can be found in the documentation that 
shipped with the MWR.

You can find answers to frequently asked questions about MWTM in the MWTM 
online help or in the Cisco Mobile Wireless Transport Manager User Guide.

MWTM includes a browser-based online help system that provides overviews, 
related information, procedures, and glossary terms for MWTM. You can select 
underlined text to access additional help topics that provide related information.
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Obtaining Documentation
When you access online help for MWTM the first time there might be a slight pause 
while your client browser loads the online help.

Obtaining Documentation
Cisco documentation and additional literature are available on Cisco.com. Cisco 
also provides several ways to obtain technical assistance and other technical 
resources. These sections explain how to obtain technical information from Cisco 
Systems.

Cisco.com
You can access the most current Cisco documentation on the World Wide Web at 
this URL:

http://www.cisco.com/univercd/home/home.htm

You can access the Cisco website at this URL:

http://www.cisco.com

International Cisco websites can be accessed from this URL:

http://www.cisco.com/public/countries_languages.shtml

Ordering Documentation
You can find instructions for ordering documentation at this URL:

http://www.cisco.com/univercd/cc/td/doc/es_inpck/pdi.htm

You can order Cisco documentation in these ways:

• Registered Cisco.com users (Cisco direct customers) can order Cisco product 
documentation from the Ordering tool:

http://www.cisco.com/en/US/partner/ordering/index.shtml

• Nonregistered Cisco.com users can order documentation through a local 
account representative by calling Cisco Systems Corporate Headquarters 
(California, USA) at 408 526-7208 or, elsewhere in North America, by 
calling 800 553-NETS (6387).
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Documentation Feedback
Documentation Feedback
You can submit e-mail comments about technical documentation to 
bug-doc@cisco.com.

You can submit comments by using the response card (if present) behind the front 
cover of your document or by writing to the following address:

Cisco Systems
Attn: Customer Document Ordering
170 West Tasman Drive
San Jose, CA 95134-9883

We appreciate your comments.

Obtaining Technical Assistance
For all customers, partners, resellers, and distributors who hold valid Cisco 
service contracts, the Cisco Technical Assistance Center (TAC) provides 
24-hour-a-day, award-winning technical support services, online and over the 
phone. Cisco.com features the Cisco TAC website as an online starting point for 
technical assistance. If you do not hold a valid Cisco service contract, please 
contact your reseller.

Cisco TAC Website
The Cisco TAC website provides online documents and tools for troubleshooting 
and resolving technical issues with Cisco products and technologies. The Cisco 
TAC website is available 24 hours a day, 365 days a year. The Cisco TAC website 
is located at this URL:

http://www.cisco.com/tac

Accessing all the tools on the Cisco TAC website requires a Cisco.com user ID 
and password. If you have a valid service contract but do not have a login ID or 
password, register at this URL: 

http://tools.cisco.com/RPF/register/register.do
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Obtaining Technical Assistance
Opening a TAC Case
Using the online TAC Case Open Tool is the fastest way to open P3 and P4 cases. 
(P3 and P4 cases are those in which your network is minimally impaired or for 
which you require product information.) After you describe your situation, the 
TAC Case Open Tool automatically recommends resources for an immediate 
solution. If your issue is not resolved using the recommended resources, your case 
will be assigned to a Cisco TAC engineer. The online TAC Case Open Tool is 
located at this URL:

http://www.cisco.com/tac/caseopen

For P1 or P2 cases (P1 and P2 cases are those in which your production network 
is down or severely degraded) or if you do not have Internet access, contact Cisco 
TAC by telephone. Cisco TAC engineers are assigned immediately to P1 and P2 
cases to help keep your business operations running smoothly.

To open a case by telephone, use one of the following numbers:

Asia-Pacific: +61 2 8446 7411 (Australia: 1 800 805 227) 
EMEA: +32 2 704 55 55 
USA: 1 800 553-2447

For a complete listing of Cisco TAC contacts, go to this URL:

http://www.cisco.com/warp/public/687/Directory/DirTAC.shtml

TAC Case Priority Definitions
To ensure that all cases are reported in a standard format, Cisco has established 
case priority definitions.

Priority 1 (P1)—Your network is “down” or there is a critical impact to your 
business operations. You and Cisco will commit all necessary resources around 
the clock to resolve the situation. 

Priority 2 (P2)—Operation of an existing network is severely degraded, or 
significant aspects of your business operation are negatively affected by 
inadequate performance of Cisco products. You and Cisco will commit full-time 
resources during normal business hours to resolve the situation.
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Obtaining Additional Publications and Information
Priority 3 (P3)—Operational performance of your network is impaired, but most 
business operations remain functional. You and Cisco will commit resources 
during normal business hours to restore service to satisfactory levels.

Priority 4 (P4)—You require information or assistance with Cisco product 
capabilities, installation, or configuration. There is little or no effect on your 
business operations.

Obtaining Additional Publications and Information
Information about Cisco products, technologies, and network solutions is 
available from various online and printed sources.

• Cisco Marketplace provides a variety of Cisco books, reference guides, and 
logo merchandise. Go to this URL to visit the company store:

http://www.cisco.com/go/marketplace/

• The Cisco Product Catalog describes the networking products offered by 
Cisco Systems, as well as ordering and customer support services. Access the 
Cisco Product Catalog at this URL:

http://cisco.com/univercd/cc/td/doc/pcat/

• Cisco Press publishes a wide range of general networking, training and 
certification titles. Both new and experienced users will benefit from these 
publications. For current Cisco Press titles and other information, go to Cisco 
Press online at this URL:

http://www.ciscopress.com

• Packet magazine is the Cisco quarterly publication that provides the latest 
networking trends, technology breakthroughs, and Cisco products and 
solutions to help industry professionals get the most from their networking 
investment. Included are networking deployment and troubleshooting tips, 
configuration examples, customer case studies, tutorials and training, 
certification information, and links to numerous in-depth online resources. 
You can access Packet magazine at this URL:

http://www.cisco.com/packet
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Obtaining Additional Publications and Information
• iQ Magazine is the Cisco bimonthly publication that delivers the latest 
information about Internet business strategies for executives. You can access 
iQ Magazine at this URL:

http://www.cisco.com/go/iqmagazine

• Internet Protocol Journal is a quarterly journal published by Cisco Systems 
for engineering professionals involved in designing, developing, and 
operating public and private internets and intranets. You can access the 
Internet Protocol Journal at this URL:

http://www.cisco.com/ipj

• Training—Cisco offers world-class networking training. Current offerings in 
network training are listed at this URL:

http://www.cisco.com/en/US/learning/index.html
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C H A P T E R 1

MWTM Overview

This chapter describes RAN-O, MWTM, and MWTM’s client/server architecture. 
It includes the following major sections:

• What is RAN-O?, page 1-1

• What is MWTM?, page 1-2

• What is Client/Server Architecture?, page 1-4

What is RAN-O?
Cisco's Radio Access Network Optimization (RAN-O) delivers standard-based, 
end-to-end, IP connectivity for GSM and UMTS RAN transport. Cisco's solution 
frames RAN voice and data frames into IP packets at the cell-site and transports 
them seamlessly over an optimized backhaul network. At the central site, the RAN 
frames are extracted from IP packets and the Abis or Iub data streams are rebuilt. 
The result is a transparent, radio vendor-agnostic, RAN IP transport and 
optimization solution that delivers nominal optimization efficiency of 50% 
without any impact on voice quality. 

In RAN-O, and in MWTM, a node is a Cisco RAN-O device (for example, a 
Cisco MWR 1941-DC-A router) or a legacy RAN device (BSC or RNC). Nodes 
are known as managed objects.

For more information about RAN-O, including procedures for configuring 
RAN-O objects, see the Cisco MWR 1941-DC-A Mobile Wireless Edge Router 
Software Configuration Guide.
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What is MWTM?
MWTM is a network management software product that enables network 
administrators to discover, manage, and troubleshoot networks that include 
Cisco RAN-O devices. MWTM provides the following key features:

• Uses client/server architecture. See the “What is Client/Server Architecture?” 
section on page 1-4 for more details.

• Runs on standard IP-connected networks, and transparently over Virtual 
Private Networks (VPNs). Also runs in Network Address Translation (NAT), 
firewall, port-forwarding, and Secure Sockets Layer (SSL) networking 
environments with minimal additional configuration. MWTM can run in each 
of these environments individually or in any combination.

• Provides a Java-based, easy-to-use graphical user interface (GUI) on the 
client with an easy-to-navigate “tree” display of all network objects as well 
as extensive Web-based online help.

Also provides a powerful command-line interface (CLI) on the server.

Also provides an extensive HTML-based Web interface with:

– Access to network and server status information

– Access to statistics summary reports for network objects

– Ability to export reports for use in spreadsheet and graphics programs

– Installation, message, command, report, and security logs

– Client downloads

– Product documentation

– Other information about MWTM. Most of the primary GUI client 
features are also available on the Web interface, with the exception of the 
topology map, real-time data charts and event management.

• Provides extensive security services, including:

– Management of SSL certificates via the GUI

– Multi-level password-protected access for multiple users

– Passwords that can be changed by users via the GUI

– Audit trails of all user actions and all access via the Web interface
1-2
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– Security logs

– Optional access via VPN, Secure Shell (SSH), and SSL

• Automatically discovers the RAN-O network from any RAN-O device, with 
links to non-RAN-O devices, and creates both topological (graphical) and 
tabular (text) views of the network.

– The topology view displays network objects as color-coded glyphs on a 
topology map, with right-click menus and layout, zoom, find, grid, hide, 
show, and save-as-JPEG functions. The topology map can be organized 
into one or more submaps, with groups of network objects represented by 
single objects on the main topology map.

– The tabular view displays detailed data in columns that can be resized, 
sorted, or hidden, depending on your preferences.

• Enables you to customize just about every aspect of the GUI, topology, and 
tabular views to meet your specific needs. Customized views and subviews 
can be saved for future use and reference, and shared with other users of the 
network.

• Automatically saves your preferences, such as the size of specific windows or 
the order of columns in a window, and automatically applies those 
preferences whenever you launch the MWTM client.

• Polls the RAN-O devices on demand, and at user-defined intervals, and 
reports the real-time status of all network objects and events, including the 
reason for any changes in status.

• Enables you to annotate network objects and events, attaching important 
information such as detailed descriptions, locations, service history, what 
triggered the event, how often it has occurred, and so on.

• Enables you to customize the displayed category, severity, color, and message 
associated with events. You can even have MWTM play unique sounds for 
different types of events.

• Enables you to automate events, calling UNIX scripts to drive automatic 
paging, e-mail, and so on, on the MWTM server.

• Receives SNMP traps natively or via HP OpenView, to drive alarms and 
accurate and up-to-date status displays.

• Enables you to forward SNMP traps, and MWTM events in the form of 
SNMP traps, to other hosts, such as the Cisco Info Center (CIC), HP 
OpenView, and Micromuse's Netcool suite of products.
1-3
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• Provides Web-based alarm viewing, sorting, filtering, archiving, metric 
calculations, and reason codes.

• Supports high server uptime with multiple server support, primary and 
secondary configurations, dynamic routing, automatic process management, 
and many debugging and customization tools, including real-time drill-down 
diagnostic applications.

• Can integrate with the entire suite of CiscoWorks products, including:

– Resource Manager Essentials, which provides network management for 
Cisco RAN-O devices.

– CiscoView Element Manager, which provides dynamic status, 
monitoring, and configuration information for a broad range of Cisco 
internetworking products.

You can launch the CiscoView Element Manager and the CiscoWorks Device 
Center directly from the topology map, for quick drill-down network 
analysis.

• Supports printing of windows to a file or to a PostScript printer.

What is Client/Server Architecture?
MWTM provides central services and database functions on an MWTM server, 
which communicates through a messaging interface with multiple MWTM 
clients.

MWTM recommends a maximum of 20 clients per MWTM server. If you connect 
more than 20 clients to a single server, the server requires additional memory and 
a more powerful CPU.

MWTM consists of server and client software components that can be installed on 
the same workstation or on different workstations. The MWTM server is currently 
available on Solaris or Linux. The MWTM client is available on Solaris, 
Windows 2000 Professional, and Windows XP Professional (Figure 1-1).
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Figure 1-1 MWTM Client/Server Architecture

Note The MWTM client is also available on Linux, but is not a supported feature of 
MWTM. Use it under advisement. 

The client/server architecture is cross-platform compatible, which allows you to 
run the client and server software in mixed operating system environments. For 
example, you can run the MWTM server on a Solaris or Linux workstation and 
access it from an MWTM client running on a Windows 2000 Professional or 
Windows XP Professional workstation.

The MWTM server software consists of a group of functional services that 
manage the data among the network, client workstations, and the centralized 
database. The MWTM server manages the exchange of data between the MWTM 
database and the network devices. The MWTM process manager launches and 
manages all of the MWTM server processes, providing a robust and reliable 
launching platform for MWTM.
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What is Client/Server Architecture?
The MWTM client software communicates with the MWTM server. You can 
install the MWTM client software on the same workstation as the MWTM server 
software, or on a different workstation on the same network as the MWTM server. 
After you install the MWTM server, you can download the MWTM client 
software from the Web, for easy distribution to users and easier access to 
important information.
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C H A P T E R 2

Discovering Your RAN-O Networks 
Using MWTM

This chapter provides details on using MWTM to discover your RAN-O networks. 
It includes the following sections:

• Discovery Overview, page 2-1

• Configuring SNMP Settings, page 2-3

• Launching the Discovery Dialog, page 2-10

• Loading Seed Nodes and Seed Files, page 2-12

• Running Discovery, page 2-21

• Verifying Discovery, page 2-30

Discovery Overview
MWTM uses a discovery process to populate the MWTM database, discovering 
the objects in your network. When a new node is discovered, it is added to the 
database. The node is set up to be polled if its SNMP access is defined as 
out-of-band. To prevent a node from being polled, right-click the node in a 
window, select Edit > RAN Properties, and change the SNMP access to in-band.

You can run Discovery if MWTM User-Based Access is disabled, or if it is 
enabled and you are a Network Administrator or System Administrator. (For more 
information about user authorization levels in MWTM, see the “Configuring 
MWTM User Authentication Levels (Server Only)” section on page 10-7.)
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Discovery Overview
To discover your network in MWTM:

Step 1 Start the MWTM client, as described in the “Starting the MWTM Client” section 
on page 3-4.

Step 2 If you want to change SNMP settings, do so before running Discovery. See the 
“Configuring SNMP Settings” section on page 2-3 for more information.

Step 3 Select Network > Network Discovery from the MWTM Main Menu. MWTM 
displays the Discovery Dialog. See the “Launching the Discovery Dialog” section 
on page 2-10 for more information.

Step 4 Select the Seed Settings tab, if it is not already selected. MWTM displays the 
Seed Settings panel of the Discovery Dialog, which enables you to create, save, 
load, and delete MWTM seed files. Load one or more seed nodes, or an existing 
seed file, using the procedures in the Loading Seed Nodes and Seed Files, 
page 2-12.

Step 5 Select the Discovery tab, or click Next. MWTM displays the Discovery panel of 
the Discovery Dialog, which enables you to discover the objects in your network. 
See the “Running Discovery” section on page 2-21 for more information.

• To specify the extent of the network discovery, use the Entire Network 
checkbox. See the description of the Entire Network checkbox in the 
“Running Discovery” section on page 2-21 for more information.

• To specify whether MWTM is to keep or delete the existing database when 
discovering the network, use the Delete Existing Data checkbox. See the 
description of the Delete Existing Data checkbox in the “Running 
Discovery” section on page 2-21 for more information.

• To specify the maximum number of hops for discovering objects in your 
network, enter a value in the Max. Hops text box. See the description of the 
Max. Hops text box in the “Running Discovery” section on page 2-21 for 
more information.

Step 6 When the “Discovery In Progress” message disappears, Discovery is complete. 
The Discovered Nodes section of the Discovery panel (Figure 2-6) lists all nodes 
that were discovered by MWTM (all nodes, including new and excluded nodes, 
not just the nodes in the current view). See the “Discovered Nodes” section on 
page 2-25 for more information.
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Configuring SNMP Settings
Step 7 Examine the Discovered Nodes table to verify that MWTM discovered all of the 
nodes in the network. If you suspect that MWTM did not discover all of the nodes, 
see the “Verifying Discovery” section on page 2-30 for troubleshooting 
information. You might need to add more seed nodes and run Discovery again.

Step 8 When you are satisfied that MWTM discovered all of the nodes in the network, 
save the list of seed nodes in a seed file. See the “Saving a Seed File” section on 
page 2-15 for more information.

Related Topics:

• Backing Up or Restoring MWTM Files (Server Only), page 11-40

• Investigating Data Problems, page 12-2

Configuring SNMP Settings

Note If you want to change SNMP settings, do so before running Discovery.

If MWTM User-Based Access is disabled, or if it is enabled and you are a 
Network Administrator or System Administrator, MWTM enables you to view 
and change some SNMP settings.

For more information about user authorization levels in MWTM, see the 
“Configuring MWTM User Authentication Levels (Server Only)” section on 
page 10-7.

For more information about SNMP, refer to “Configuring SNMP Support” in the 
Cisco IOS Release 12.2 Configuration Fundamentals Configuration Guide, 
Part 3, System Management.

To change SNMP settings in MWTM, start the MWTM client, as described in the 
“Starting the MWTM Client” section on page 3-4, then select Network > SNMP 
Configuration from the MWTM Main Menu. (If you have implemented MWTM 
User-Based Access, this option is available to users with authentication level 
Network Administrator [Level 4] and higher.)

MWTM displays the SNMP Configuration Dialog (Figure 2-1).
2-3
Cisco Mobile Wireless Transport Manager User Guide

OL-7637-01



 

Chapter 2      Discovering Your RAN-O Networks Using MWTM
Configuring SNMP Settings
Figure 2-1 SNMP Configuration Dialog

The SNMP Configuration Dialog is composed of the following sections:

• SNMP Configuration Menu, page 2-5

• SNMP Settings Table, page 2-6

• SNMP Configuration Table, page 2-7

• SNMP Configuration Buttons, page 2-8

MWTM also provides a set of commands that you can use to configure SNMP 
settings:

• SNMP Configuration Commands, page 2-9
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Configuring SNMP Settings
SNMP Configuration Menu
The menu on the SNMP Configuration Dialog provides the following options:

Menu Command Description

File > Save
(Ctrl-S)

Saves the SNMP configuration changes.

When you are satisfied with all of your changes to the SNMP settings, select 
the File > Save menu option. MWTM saves the changes, updates the SNMP 
information on the MWTM server in real time.

Note If another user modifies and saves the SNMP configuration before 
you save your changes, MWTM asks if you want to overwrite that 
user’s changes. If you choose to do so, the other user’s changes are 
overwritten and lost. If you choose not to do so, your changes are lost.

File > Close
(Ctrl-W)

Closes the current window.

Help > Topics
(F1)

Displays the table of contents for the MWTM online help.

Help > Window
(Shift-F1)

Displays online help for the current window.

Help > About
(F3)

Displays build date, version, SSL support, and copyright information about 
the MWTM application.
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Configuring SNMP Settings
SNMP Settings Table
The SNMP settings table displays current SNMP information for nodes in 
MWTM. You can edit these fields in the SNMP Configuration Table, page 2-7.

The SNMP configuration table contains the following columns:

Column Description

IP Address Range or 
Hostname

IP address or DNS name of a node or range of nodes. An asterisk (*) indicates 
a wildcard value.

Read Community SNMP community name used by the node for read access to the information 
maintained by the SNMP agent on the RAN-O device.

Timeout (secs) Time, in seconds, MWTM waits for a response from the node.

Retries Number of times MWTM attempts to connect to the node.

Poll Interval (mins) Time, in minutes, between polls for the node.
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Configuring SNMP Settings
SNMP Configuration Table
The SNMP configuration table enables you to change SNMP settings for a node.

The SNMP configuration table contains the following fields:

Field Description

IP Address 
Range or 
Hostname

IP address or DNS name of a node.

To change the IP address or DNS name of a node, select the node, enter the new 
address or name in the IP Address Range or Hostname field, then click Update.

IP addresses use the format x.x.x.x, where each x has one of the following values:

• An integer in the range 0 through 255.

• A range of integers separated by a dash (-), such as 10-60.

• An asterisk (*), which is equivalent to specifying 0-255.

Unlike IP addresses, you cannot specify a range of node names or use wildcards in 
node names. Each node name corresponds to a single node in the network.

The default value for this field is the IP address *.*.*.*, which MWTM uses for all 
nodes not covered by other IP address ranges or names.

Read 
Community

SNMP community name to be used by the node for read access to the information 
maintained by the SNMP agent on the RAN-O node. 

To change the SNMP community name for a node, select the node and enter the new 
name in the Read Community field, then click Update.

This new SNMP community name must match the name used by the node. The 
default name is public.

For information about exporting SNMP community names from CiscoWorks 
Resource Manager Essentials (RME), see the “Importing SNMP Community 
Names from CiscoWorks (Solaris Only)” section on page 11-2.

Timeout (secs) Time, in seconds, MWTM waits for a response from the node.

If you determine that MWTM waits too long for a response from a node, or does 
not wait long enough, you can change the timeout value. To change the time that 
MWTM waits for a response from a node, select the node and enter the new timeout 
value in the Timeout (secs) field, then click Update.

The valid range is 1 to 60 seconds. The default value is 1 second.
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Configuring SNMP Settings
SNMP Configuration Buttons
The SNMP Configuration Dialog contains the following buttons:

Retries Number of times MWTM attempts to connect to the node.

If you determine that MWTM retries a node too many times, or not enough times, 
you can change the number of retries. To change the number of times MWTM 
attempts to connect to a node, select the node and enter the new number in the 
Retries field, then click Update.

The valid range is 0 to 99. The default value is 2 retries.

Poll Interval 
(mins)

Time, in minutes, between polls for the node.

If you determine that MWTM polls a node too often, or not often enough, you can 
change the poll interval. To change the time, in minutes, between polls for a node, 
select the node and enter the new interval in the Poll Interval (mins) field, then 
click Update.

The valid range is 5 to 1440. The default value is 15 minutes.

Field Description

Button Description

Add Adds the new SNMP settings to the MWTM database.

To add a new node or range of nodes, enter the SNMP information in the appropriate fields 
and click Add. The new SNMP settings are added to the MWTM database.

Update Applies the values in the SNMP configuration fields to the selected node or range of 
nodes.

Delete Deletes the selected node or range of nodes.

To delete a node, select it and click Delete. MWTM deletes the node without asking for 
confirmation.
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Configuring SNMP Settings
SNMP Configuration Commands
MWTM also provides the following SNMP-related commands:

• To set a new default SNMP read community name, use the mwtm 
snmpcomm command.

• To change the file used for SNMP parameters, such as community names, 
timeouts, and retries, use the mwtm snmpconf command.

• To query a host using SNMP GetRequests, use the mwtm snmpget 
command.

• To query a host using SNMP GetNextRequests, use the mwtm snmpnext 
command.

• To query a host, using SNMP GetNextRequests to “walk” through the MIB, 
use the mwtm snmpwalk command.

For more information on the use of these commands, see the “MWTM Command 
Reference” section on page C-1.
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Launching the Discovery Dialog
Launching the Discovery Dialog
To launch the Discovery Dialog and begin the Discovery process, select Network 
> Network Discovery from the MWTM Main Menu. MWTM displays the 
Discovery Dialog (Figure 2-2).

Figure 2-2 Discovery Dialog with Seed Settings Displayed

The Discovery Dialog enables you to load and configure seed nodes, and use those 
seed nodes to discover the objects in your network.

If you start the MWTM client and the MWTM database is empty (including the 
very first time you start the MWTM client), MWTM automatically opens the 
Discovery Dialog so you can run Discovery and populate the database.

The Discovery Dialog is composed of the following sections:

• Discovery Dialog Menu, page 2-11

• Discovery Dialog Tabs, page 2-12
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Launching the Discovery Dialog
Discovery Dialog Menu
The menu on the Discovery Dialog provides the following options:

Menu Command Description

File > Load Seeds
(Ctrl-L)

Opens the Load File Dialog: Seed File List, enabling you to load a 
seed file into MWTM:

• Enter the name of the seed file, and click OK to load it.

• Click Cancel to return to the Seed Settings panel without 
loading a seed file.

File > Save Seeds
(Ctrl-S)

Opens the Save File Dialog: Seed File List, which enables you to 
save changes you have made to the selected seed file.

File > Save As Opens the Save File Dialog: Seed File List, which enables you to 
save changes you have made to the selected seed file with a new 
name, or overwrite an existing seed file.

File > Close
(Ctrl-W)

Closes the current window.

Edit > SNMP Configuration
(Ctrl-B)

Opens the SNMP Configuration Dialog.

If you have implemented MWTM User-Based Access, this option is 
available to users with authentication level Network Administrator 
(Level 4) and higher.

Help > Topics
(F1)

Displays the table of contents for the MWTM online help.

Help > Window
(Shift-F1)

Displays online help for the current window.

Help > About
(F3)

Displays build date, version, SSL support, and copyright 
information about the MWTM application.
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Loading Seed Nodes and Seed Files
Discovery Dialog Tabs
The Discovery Dialog contains the following tabs:

Loading Seed Nodes and Seed Files
MWTM enables you to load one or more new seed nodes, or to create, save, load, 
and delete existing MWTM seed files.

This section includes the following information:

• Loading a Seed Node, page 2-12

• Loading a Seed File, page 2-13

• Saving a Seed File, page 2-15

• Creating a New Seed File, page 2-18

• Creating a New Seed File, page 2-18

• Creating and Changing Seed Files Using a Text Editor, page 2-20

Loading a Seed Node
To load a seed node, enter the name or IP address of the seed node in the IP 
Address or DNS Hostname field, and click Add Node (or press Enter). MWTM 
displays details of the SNMP settings for the seed nodes in the right pane of the 
window.

Continue adding seed nodes until you are certain that MWTM will be able to 
discover the entire network.

Tab Description

Seed Settings Displays the Seed Settings panel in the Discovery Dialog.

Discovery Displays the Discovery panel in the Discovery Dialog.
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Loading a Seed File
If you have already created and saved one or more seed files, you can load a seed 
file, change the list of seed files, and select one seed file to be loaded 
automatically when the MWTM client is started or the Discovery Dialog is 
opened.

To load an existing seed file, select File > Load Seeds from the Discovery Dialog 
menu. SGM displays the Load File Dialog: Seed File List dialog (Figure 2-3).

Figure 2-3 Load File Dialog: Seed File List Dialog

The Load File Dialog: Seed File List contains the following fields and buttons:

Field or Button Description

Type Icon indicating whether the item in the table is a file or a folder.

Name Name of the seed file or folder.

Last Modified Date and time the seed file or folder was last modified.

Size (bytes) Size of the seed file or folder, in bytes.
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Make this my preferred start 
option

Specifies whether the selected seed file is to be loaded 
automatically whenever this MWTM client is started or the 
Discovery Dialog is opened.

By default, this checkbox is cleared for all seed files. That is, no 
seed file is loaded automatically when the MWTM client is 
started or the Discovery Dialog is opened.

Number of Files
(displayed in bottom left corner)

Total number of seed files and folders.

OK Loads the selected seed file, saves any changes you made to the 
list of files, and closes the dialog.

To load a seed file, double-click it in the list, select it in the list 
and click OK, or enter the name of the file and click OK.

MWTM saves any changes you made to the list of files, closes the 
Load File Dialog: Seed File List dialog, loads the seed file, and 
returns to the Discovery Dialog. MWTM lists all of the seed 
nodes in the seed file in the left pane of the window, and displays 
details of the SNMP settings for the seed nodes in the right pane.

Delete Deletes the selected file from the seed file list. MWTM issues an 
informational message containing the name and location of the 
deleted file.

Cancel Closes the dialog without loading a seed file or saving any 
changes to the seed file list.

Help Displays online help for the dialog.

Field or Button Description
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Saving a Seed File
MWTM enables you to save a specific seed file, change the list of seed files, and 
select one seed file to be loaded automatically when the MWTM client is started 
or the Discovery Dialog is opened.

When you are satisfied that MWTM has discovered all of the nodes in the 
network, save the list of seed nodes in a seed file, using one of the following 
procedures:

• To save the changes you have made to the seed file without changing the name 
of the file, select File > Save from the Discovery Dialog menu.

• To save the changes you have made to the seed file with a new name, select 
File > Save As from the Discovery Dialog menu. MWTM displays the Save 
File Dialog: Seed File List dialog (Figure 2-4).

MWTM stores the seed file in the seed file directory on the MWTM server:

• If you installed MWTM in the default directory, /opt, then the MWTM seed 
file directory is /opt/CSCOsgm/seeds.

• If you installed MWTM in a different directory, then the MWTM seed file 
directory is located in that directory.

Note If another user modifies and saves the seed file before you save your changes, 
MWTM asks if you want to overwrite that user’s changes. If you choose to do so, 
the other user’s changes are overwritten and lost. If you choose not to do so, your 
changes are lost, unless you save the seed file to a different filename.
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Figure 2-4 Save File Dialog: Seed File List Dialog

The Save File Dialog: Seed File List contains the following fields and buttons:

Field or Button Description

Type Icon indicating whether the item in the table is a file or a folder.

Name Name of the seed file or folder.

Last Modified Date and time the seed file or folder was last modified.

Size (bytes) Size of the seed file or folder, in bytes.

Filename Name by which you want to save the seed file.

If you create a new seed file name, you can use any letters, 
numbers, or characters in the name that are allowed by your 
operating system. However, if you include any spaces in the new 
name, MWTM converts those spaces to dashes. For example, 
MWTM saves file “a b c” as “a-b-c”.

Make this my preferred start 
option

Specifies whether the selected seed file is to be loaded 
automatically whenever this MWTM client is started or the 
Discovery Dialog is opened.

By default, this checkbox is cleared for all seed files. That is, no 
seed file is loaded automatically when the MWTM client is 
started or the Discovery Dialog is opened.
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Number of Files
(displayed in bottom left corner)

Total number of seed files and folders.

OK Saves the seed file and any changes you made to the seed file list 
and closes the dialog.

To save the seed file with a new name, use one of the following 
procedures:

• To save the file with a completely new name, enter the new 
name and click OK.

• To save the file with an existing name, overwriting an old 
seed file, select the name in the list and click OK.

MWTM saves the seed file with the new name, saves any changes 
you made to the list of files, closes the Save File Dialog: Seed File 
List dialog, and returns to the Discovery Dialog.

Delete Deletes the selected file from the seed file list. MWTM issues an 
informational message containing the name and location of the 
deleted file.

Cancel Closes the dialog without saving the seed file or saving any 
changes to the seed file list.

Help Displays online help for the dialog.

Field or Button Description
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Creating a New Seed File
To create a new seed file in MWTM, launch the Discovery Dialog, as described 
in the “Launching the Discovery Dialog” section on page 2-10, then select the 
Seed Settings tab, if it is not already selected. MWTM displays the Seed Settings 
panel (Figure 2-2).

The Seed Settings panel in the Discovery Dialog enables you to create, save, load, 
and delete MWTM seed files.

The Seed Settings panel on the Discovery Dialog contains the following fields and 
buttons:

Field or Button Description

Seed Nodes Lists the seed nodes currently defined in MWTM.

IP Address Range 
or Hostname

IP address of the seed node. The default is *.*.*.*.

Retries Number of times MWTM attempts to connect to the seed node. The valid range 
is 0 to 99. The default value is 2.

Timeout (sec) Time, in seconds, MWTM waits for a response from the seed node. The valid 
range is 0 (no timeout) to 9999. The default value is 1 second.

Read Community SNMP community name for read access to the information maintained by the 
SNMP agent on the RAN-O device. This value can be up to 32 characters in 
length. Do not include special characters such as ` @ $ ^ * ' '' & |. This value is 
usually set to public (the default).

Poll Interval 
(mins)

Time, in minutes, between polls. The valid range is 0 to 9999. The default value 
is 15 minutes.
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Changing an Existing Seed File
To change an existing seed file in MWTM, load the seed file as described in the 
“Loading a Seed File” section on page 2-13.

To add another seed node to the seed file, enter the name or IP address of the seed 
node in the IP Address or DNS Hostname field, and click Add Node.

To delete a seed node from the seed file, select the seed node and click Delete.

When you are ready to save the modified seed file, use the procedure described in 
the “Saving a Seed File” section on page 2-15.

IP Address, 
Address range, 
Subnet, CIDR, or 
DNS Hostname

Address or name of the selected seed node.

To create a new seed file, enter the name or address of a seed node in this field. 
Examples of acceptable input include:

• IP Address: 1.2.3.4

• Address Range: 1.2.3.2-15

• Subnet, CIDR: 1.2.3.0/24, 1.2.3.0/255.255.255.0

• DNS Hostname: mwtm.cisco.com

MWTM displays details of the SNMP settings for the seed node in the right pane 
of the window. 

Continue to add as many seed nodes as necessary to discover your entire network.

When you are ready to save the list of seed nodes in a new seed file, select File 
> Save As from the Discovery Dialog menu. MWTM displays the Save File 
Dialog: Seed File List dialog (Figure 2-4). See the “Saving a Seed File” section 
on page 2-15 for more information about saving seed files.

Add Node Adds a new seed node to MWTM.

Delete Node Deletes the selected seed node. MWTM deletes the seed node without asking for 
confirmation.

Next Displays the Discovery panel in the Discovery Dialog.

If you enter a seed node IP address or name in the IP Address or DNS Hostname 
field, then click Next, MWTM automatically adds the seed node before 
displaying the Discovery panel.

Field or Button Description
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Creating and Changing Seed Files Using a Text Editor
A seed file is simply an unformatted list of seed node names. To create a seed file 
using a text editor, simply create a file and list the seed node names, one on each 
line, with no other formatting:

new-york-a

new-york-b

chicago-c

When you save and name the seed file, keep the following considerations in mind:

• You can use any letters, numbers, or characters in the name that are allowed 
by your operating system, except blanks.

• MWTM saves the seed file with a .see file extension.

• MWTM saves the seed file in the MWTM server’s seed file directory, seeds:

– If you installed MWTM in the default directory, /opt, then the seed file 
directory is /opt/CSCOsgm/seeds/.

– If you installed MWTM in a different directory, then the seed file 
directory is located in that directory.

When MWTM loads the seed file, it verifies the syntax of the file, deleting blank 
lines and extraneous leading and trailing spaces as needed. MWTM also verifies 
that each seed node name resolves to a valid IP address. If a name does not resolve 
to a valid IP address, MWTM logs the erroneous entry and ignores it.

For example, given the following seed file:

new-york-a<space>

<space>new-york-b

zzzzzzzzzzzz

<blank line>

<tab>chicago-c<tab>
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MWTM loads the following entries:

new-york-a

new-york-b

chicago-c

Running Discovery
The Discovery panel in the Discovery Dialog enables you to discover the objects 
in your network.

To display the Discovery panel, launch the Discovery Dialog, as described in the 
“Launching the Discovery Dialog” section on page 2-10, then select the 
Discovery tab in the Discovery Dialog, or click Next in the Seed Settings panel. 
MWTM displays the Discovery panel (Figure 2-5). (If you enter a seed node IP 
address or name in the IP Address, Address range, Subnet, CIDR, or DNS 
Hostname field, then click Next, MWTM automatically adds the seed node 
before displaying the Discovery panel.) 
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Running Discovery
Figure 2-5 Discovery Panel Before Discovery

The Discovery panel is composed of the following sections:

• Discovery Settings, page 2-23

• Discovered Nodes, page 2-25

Related Topics:

• Discovery Overview, page 2-1

• Polling a Node, page 6-66
2-22
Cisco Mobile Wireless Transport Manager User Guide

OL-7637-01



 

Chapter 2      Discovering Your RAN-O Networks Using MWTM
Running Discovery
Discovery Settings
The Discovery Settings section of the Discovery panel contains the following 
fields and button:

Field or Button Description

Entire Network Checkbox used to specify the extent of the network discovery:

• To discover the entire network, select this checkbox. This is called recursive 
discovery, and it is the default setting.

With this checkbox selected, MWTM discovers all seed nodes and attempts to 
manage them; then attempts to discover and manage all RAN-O nodes that are 
adjacent to those seed nodes (unless the nodes are connected by serial links 
only); then attempts to discover and manage all RAN-O nodes that are adjacent 
to those nodes; and so on, until MWTM has discovered the entire network.

• To rediscover only seed nodes, clear this checkbox. This is called nonrecursive 
discovery.

With this checkbox cleared, MWTM discovers all seed nodes and attempts to 
manage them, then labels all nodes that are adjacent to those seed nodes 
Unmanaged.

Delete Existing 
Data

Checkbox used to keep or delete the existing MWTM database when discovering 
the network:

• To keep all existing network data in the MWTM database before rediscovering 
the network, clear this checkbox. This is the default setting.

• To delete all existing network data from the MWTM database before 
rediscovering the network, select this checkbox. Choose this option if you 
know that network elements have been deleted from your network since the last 
Discovery.

If you discover the network with Delete Existing Data selected, MWTM stops any 
real-time polls that are running and issues appropriate messages.

Max Hops The maximum number of hops from the seed node to search for other nodes to 
discover. Default is 3.
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Discover 
Network

Begins discovering the network.

Click Discover Network to begin Discovery.

If you have not defined at least one seed node in the Seed Settings panel, MWTM 
prompts you to do so.

When Discovery begins:

• The Discover Network button changes to Stop Discovery.

• The “Discovery In Progress” message is displayed in the title bar of all MWTM 
client windows.

Discovery progresses in bursts. You might see a number of updates, followed by a 
pause, followed by more updates. The information displayed in MWTM windows 
is not fully updated until Discovery is complete.

By default, Discovery times out after 600 seconds (10 minutes). To change the 
Discovery timeout, change the value of the DISCOVERY_TIMELIMIT entry in the 
Server.properties file:

• If you installed MWTM in the default directory, /opt, then the location of the 
Server.properties file is /opt/CSCOsgm/properties/Server.properties.

• If you installed MWTM in a different directory, then the Server.properties file 
is located in that directory.

Because MWTM is an asynchronous system, with the MWTM server contacting 
clients one at a time, and because clients might run at different speeds, the 
information displayed by MWTM clients during Discovery might not always be 
synchronized.

All other MWTM windows (Node, Topology, and so on) are also populated with 
the newly discovered network data.

Field or Button Description
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If you run Discovery with Entire Network cleared, then you run Discovery with 
Entire Network selected, any Unmanaged nodes in the first Discovery are not 
rediscovered by the second Discovery.

To recover from this situation and generate a new, complete, and reliable MWTM 
database, you must perform one of the following procedures:

1. Run Discovery again, with both Entire Network and Delete Existing Data 
selected.

2. Change the Unmanaged nodes to managed status. See the “Unmanaging and 
Managing a Node” section on page 6-64 for more information.

3. Poll the nodes that were Unmanaged in the first Discovery. See the “Polling 
a Node” section on page 6-66 for more information.

Discovered Nodes
The Discovered Nodes section of the Discovery panel (Figure 2-6) lists all nodes 
that have been discovered by MWTM (all nodes, including new and excluded 
nodes, not just the nodes in the current view). By default, this table is sorted by 
Status.

Stop Discovery Stops the Discovery process. For example, if you click Discover Network, then 
you realize that you loaded a seed node that you did not intend to load, you can 
click Stop Discovery to stop the Discovery process.

Note If you stop the Discovery process, the information in the MWTM database 
is incomplete and unreliable. To generate a new, complete, and reliable 
MWTM database, you must run Discovery again, with Delete Existing 
Data selected.

This button replaces the Discover Network button when the Discovery process 
begins, and changes back to the Discover Network button when the Discovery 
process ends.

Field or Button Description
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Figure 2-6 Discovery Panel After Discovery, with Discovered Nodes

To see mouse over help popup for each column in the table, place the cursor over 
a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the 
full data in a mouse over help popup.

You can resize each column, or sort the table based on the information in one of 
the columns. By default, MWTM displays all of the columns in the Discovered 
Nodes section except Internal ID, Router Uptime, Reboot Reason, Process 
Traps, and Last Status Change.

• To display hidden columns, right-click in the table header and select the 
checkboxes for the columns you want to display.

• To hide columns, right-click in the table header and clear the checkboxes for 
the columns you want to hide.

See the “Resizing, Sorting, and Hiding Table Columns” section on page 3-37 for 
more information about resizing, sorting, displaying, or hiding columns.
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The Discovered Nodes section contains the following columns and buttons:

Column or Button Description

Internal ID Internal ID of the event. The internal ID is a unique ID for every object, assigned 
by MWTM for its own internal use. It can also be useful when the TAC is 
debugging problems.

Name Name or IP address of the discovered node.

All discovered nodes are placed in a DEFAULT configuration view, which is 
stored on the MWTM server and shared by all MWTM clients. Initially, all 
clients use the DEFAULT view. Clients can then create their own views, which 
are subsets of the DEFAULT view, to meet their individual needs. However, the 
DEFAULT view stored on the MWTM server cannot be modified by the clients. 
It is always available, for users who need to view the entire network.

Primary SNMP 
Address

IP address of the node, used by SNMP to poll the node. (There might be other 
IP addresses on the node that are not the primary SNMP address.)

Device Type Device type of the node. Possible values are:

• CiscoMWR-1941-A—Cisco MWR-1941-DC-A series router

• CiscoMWR1900—Cisco Mobile Wireless Router 1900

• BSC—Base Station Controller

• BTS—Base Transceiver Station

• Node-B—Radio transmission/reception unit for communication between 
radio cells in UMTS network

• RNC—Radio Network Controller

• IPDevice—IP device, other than those listed above. You can assign this icon 
to an unknown node if you know that it is an IP device.

• Unknown—MWTM is unable to determine the device type.

IOS MIB Level MIB conformance level used by the RAN-O device.

Trap Polling Indicates whether trap polling is enabled or not. This checkbox is read-only. 

• If you want to enable trap polling for this node, set ipran-mib snmp-access 
to inBand on the device.

• If you want to disable trap polling for this node, set ipran-mib snmp-access 
to outOfBand on the device.
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Report Polling Indicates whether report polling is enabled or not. This checkbox is read-only. 

• If you want to enable report polling for this node, set ipran-mib location to 
aggSite on the device.

• If you want to disable report polling for this node, set ipran-mib location to 
cellSite on the device.

Router Uptime Time the RAN-O device has been up, in days, hours, minutes, and seconds.

Reboot Reason Reason for the last reboot of the RAN-O device.

Ignored Indicates whether the node is to be included when aggregating and displaying 
MWTM status information:

• Clear the checkbox to include the node. This is the default setting.

• Select the checkbox to exclude the node.

This field can be edited by users with authentication level Power User (Level 2) 
and higher.

Process Traps Indicates whether MWTM is to process traps from this node:

• Select the checkbox if you want MWTM to process traps from this node. 
This is the default setting.

• Clear the checkbox if you do not want MWTM to process traps from this 
node.

This field can be edited by users with authentication level Power User (Level 4) 
and higher.

Notes Indicates whether there is a note associated with the node.

Events Indicates whether there is a recent event associated with the node. (Even if the 
server purges all of the events associated with the node, MWTM continues to 
display the event icon in this field.)

During Discovery, MWTM might flag most nodes with an event icon (orange 
triangle). If the event icons are too distracting, select Edit > Clear All Events 
from the MWTM Main Menu to remove them.

Last Status 
Change

Date and time that the status of the node last changed.

Column or Button Description
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Status Current status of the node. Possible values are:

Active (green)

Discovering (cyan)

Polling (cyan)

Unknown (red)

Unmanaged (gray)

Waiting (gray)

Warning (yellow)

For detailed definitions of each status, see the “Status Definitions for Nodes” 
section on page A-5.

Status Reason Reason for the current status of the object.

For a full list of possible reasons, see the stateReasons.html file:

• If you installed MWTM in the default directory, /opt, then the file is located 
at /opt/CSCOsgm/apache/share/htdocs/eventHelp directory.

• If you installed MWTM in a different directory, then the help directory and 
file are located in that directory.

If the cell is too small to show all of the status reason, place the cursor over the 
cell to see the full status reason in a mouse over help popup.

The status reasons are listed in order of decreasing magnitude. If two or more 
reasons apply, the reason of greatest magnitude is displayed.

If the status reason is Unsupported Configuration, correct the configuration 
and enter the mwtm cleandiscover command to delete all current network data 
and begin a clean discovery of the RAN-O network. If the status reason is still 
Unsupported Configuration, enter the mwtm clean command to restore the 
MWTM server to a “clean” state, such as would exist after a new installation of 
MWTM. For more information on the use of these commands, see the “MWTM 
Command Reference” section on page C-1.

Back Displays the Seed Settings panel in the Discovery Dialog.

Column or Button Description
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Verifying Discovery
After you discover the network (see the “Discovery Overview” section on 
page 2-1), examine the Discovered Nodes table to verify that MWTM discovered 
all of the RAN-O nodes in the network. If you suspect that MWTM did not 
discover all of the RAN-O nodes, verify the following conditions:

• Verify that no nodes are excluded from your current view.

• Verify that the MWTM server can ping the nodes.

• Verify that the nodes are running images that are compatible with the MWTM 
server.

• Verify that SNMP is enabled on the nodes.

• Verify that MWTM is configured with the correct SNMP community name. 
See the “Configuring SNMP Settings” section on page 2-3 for details.

• Verify that you selected Entire Network when you ran Discovery. If you 
suspect that you did not, run Discovery again with Entire Network selected.

Delete Deletes the selected node or nodes from the Discovery database. MWTM deletes 
the nodes without asking for confirmation.

Poll Node Begins a poll of all nodes selected in the Discovered Nodes section of the 
Discovery panel.

You cannot poll a node with a Primary SNMP Address of N/A:

• If you select a node with a Primary SNMP Address of N/A, then the Poll 
button is grayed-out and cannot be selected.

• If you select more than one node, and even one of them has a Primary 
SNMP Address of N/A, then the Poll button is grayed-out and cannot be 
selected.

Column or Button Description
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C H A P T E R 3

Getting Started with MWTM

This chapter provides information about starting and stopping MWTM, and 
provides an overview of how to use MWTM to manage your Radio Access 
Network-Optimization (RAN-O) installation.

This chapter includes the following information:

• Becoming the Root User (Server Only), page 3-3

• Starting the MWTM Server (Server Only), page 3-3

• Starting the MWTM Client, page 3-4

• Viewing the MWTM Main Window, page 3-8

• Using the MWTM Main Menu, page 3-9

• Viewing Alarms, page 3-19

• Viewing Events, page 3-24

• Viewing a Summary of Network Objects, page 3-24

• Viewing Views, page 3-27

• Viewing Nodes, page 3-28

• Viewing the Topology of the Network, page 3-29

• Viewing MWTM Data on the Web, page 3-29

• Viewing Server Status Information, page 3-30

• Viewing Online Help, page 3-35

• Finding Information in a Window, page 3-35

• Resizing, Sorting, and Hiding Table Columns, page 3-37
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• Editing Object Properties, page 3-38

• Attaching Notes to Objects, page 3-38

• Printing MWTM Windows, page 3-39

• Loading and Saving MWTM Files, page 3-40

• Viewing Real-Time Data for a Node, page 3-41

• Changing Real-Time Poller and Counter Settings, page 3-41

• Connecting to a New Server, page 3-42

• Integrating MWTM with Other Products, page 3-44

• Exporting MWTM Data, page 3-47

• Using the Windows Start Menu, page 3-51

• Using the MWTM Command Line Interface, page 3-54

• Running Simultaneous MWTM Sessions, page 3-54

• Exiting the MWTM Client, page 3-54

For detailed information about MWTM’s supported platforms, and hardware and 
software requirements, see the Cisco Mobile Wireless Transport Manager 
Installation Guide.

Note The default directory for installing MWTM is /opt. In commands that call for the 
default directory, if you installed MWTM in a different directory, you must 
specify that directory instead of /opt.
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Becoming the Root User (Server Only)
Some MWTM procedures require you to be logged in as the root user.

Caution As the root user, you can adversely affect your operating environment if you are 
unaware of the effects of the commands you use. If you are a relatively 
inexperienced UNIX user, limit your activities as the root user to the tasks 
described in this manual.

If you are not logged in, log in as the root user:

> login: root

> Password: root-password 

If you are already logged in, but not as the root user, use the su command to 
change your login to root:

# su

# Password: root-password

Starting the MWTM Server (Server Only)
Before starting an MWTM server, verify the following prerequisite conditions:

• The RAN-O devices use supported IOS images

• The MWTM server has IP connectivity to the RAN-O devices

• SNMP is enabled on the RAN-O devices

• (Optional) Traps are enabled on the RAN-O devices

To enable traps on the RAN-O device, enter the following:

snmp-server enable traps snmp authentication linkdown linkup 
coldstart warmstart

snmp-server enable traps ipran
3-3
Cisco Mobile Wireless Transport Manager User Guide

OL-7637-01



 

Chapter 3      Getting Started with MWTM
Starting the MWTM Client
• (Optional) A trap host is defined in the RAN-O network

To receive the traps on a host, enter the following on the RAN-O device:

snmp-server host IP_address version 2c v2c

Because the MWTM application is comprised of a server component and a client 
component, you must start both components to run the application.

To start the MWTM server on a Solaris/Linux system, enter the following 
commands:

# cd /opt/CSCOsgm/bin

# ./mwtm start

Note To issue the mwtm start command, you must be logged in as the root user or as 
a super user, or your login must have administrator privileges. See the “Becoming 
the Root User (Server Only)” section on page 3-3 and the “Specifying a Super 
User (Server Only)” section on page 10-24 for more information.

Starting the MWTM Client
This section contains the following information:

• Before Starting the MWTM Client, page 3-5

• Starting the MWTM Client on Solaris/Linux, page 3-6

• Starting the MWTM Client on Windows, page 3-6

• Starting the MWTM Client for the First Time, page 3-6
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Before Starting the MWTM Client
When you start an MWTM client, the version and release of the client must match 
that of the MWTM server, and the patch level must be greater than or equal to that 
of the server. For example, the following MWTM client-server connections are 
allowed:

The following MWTM client-server connections are not allowed:

If there is a client-server mismatch, MWTM displays a warning message when 
you try to start the client. If you have a Web browser installed, MWTM optionally 
opens a Web page enabling you to download an allowed, matching client. See the 
“Downloading the MWTM Client from the Web” section on page 13-56 for more 
information about downloading the MWTM client.

Table 3-1 Allowed MWTM Client-Server Connections

Client Level Server Level

5.0.0 5.0.0

5.1.0 5.1.0

Table 3-2 Disallowed MWTM Client-Server Connections

Client Level Server Level

5.0.0 5.1.0

5.1.0 5.0.0
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Starting the MWTM Client on Solaris/Linux
To start the MWTM client on a Solaris/Linux system on which the MWTM server 
is installed, make sure the MWTM server is running, then enter the following 
commands:

# cd /opt/CSCOsgm/bin

# ./mwtm client

To start the MWTM client on a Solaris/Linux system other than the one on which 
the MWTM server is installed, make sure the MWTM server is running, then enter 
the following commands:

# cd /opt/CSCOsgmClient/bin

# ./mwtm client

To start the MWTM client on a Solaris/Linux system other than the one on which 
the MWTM server is installed, and connect to an MWTM server other than the 
default server, enter the following commands:

# cd /opt/CSCOsgmClient/bin

# ./mwtm client server_name_or_ip_address

where server_name_or_ip_address is the name or IP address of the Solaris/Linux 
system on which the MWTM server is running.

Starting the MWTM Client on Windows
To start the MWTM client on a Windows system, select Start > Programs > 
Cisco MWTM Client > Launch MWTM Client, or double-click the MWTM 
Client icon on the Windows desktop.

Starting the MWTM Client for the First Time
When you start MWTM for the first time, MWTM displays the Discovery Dialog 
(Figure 3-1) and the MWTM Main Window (Figure 3-2).
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Starting the MWTM Client
Figure 3-1 Discovery Dialog

Figure 3-2 MWTM Main Window

The MWTM Main Window is the primary MWTM window. It is the first window 
to appear when you launch the MWTM client. It displays basic information about 
the events and objects that MWTM discovers.
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Viewing the MWTM Main Window
When you start MWTM for the first time, if you did not configure the MWTM 
server to automatically discover your network the first time the server starts after 
installation, the MWTM database contains no information, and the MWTM Main 
Window is blank. The database is populated, and reflected in the MWTM Main 
Window, when you run Discovery for the first time; MWTM displays the 
Discovery Dialog to make it easier for you to do so. In fact, any time you start the 
MWTM client and the MWTM database is empty, MWTM automatically opens 
the Discovery Dialog so you can run Discovery and populate the database. For 
more information about Discovery, see the “Discovery Overview” section on 
page 2-1.

The events and objects that MWTM discovers are displayed in the left and right 
panes of the MWTM Main Window.

MWTM also uses the right pane of the MWTM Main Window when displaying 
more detailed information about your network, such as configuration details and 
real-time data.

Viewing the MWTM Main Window
The MWTM Main Window is the primary MWTM client window. It is the first 
window to appear when you launch the MWTM client. It displays basic 
information about the events and objects that MWTM discovers in the left and 
right panes. MWTM also uses the right pane of the MWTM Main Window when 
displaying more detailed information about your network, such as configuration 
details and real-time data.

For detailed descriptions of the information that is displayed in the MWTM Main 
Window, see the following sections:

• Using the MWTM Main Menu, page 3-9

• Viewing Alarms, page 3-19

• Viewing Events, page 3-24

• Viewing a Summary of Network Objects, page 3-24

• Viewing Views, page 3-27

• Viewing Nodes, page 3-28

• Viewing Interfaces, page 3-28
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Using the MWTM Main Menu
The MWTM Main Menu appears in the menu bar of most MWTM windows.

Some menu items do not appear on some windows. In addition, menu items that 
are grayed-out are not available on that window.

For detailed information about the menu options provided by other windows, see 
the descriptions of those windows.

The MWTM Main Menu provides the following menu options:

Menu Command Description

File > Load DEFAULT View
(Ctrl-D)

Loads the DEFAULT view, which is the view into 
which MWTM places all discovered objects when 
discovering the network. The DEFAULT view is stored 
on the MWTM server and shared by all MWTM 
clients, but it cannot be modified by the clients.

File > Load View
(Ctrl-L)

Loads an already existing view. MWTM prompts you 
for the name of the view you want to load:

• Select the name of the view, or accept the default 
view name, then click OK to load the view.

• Click Cancel to close the prompt window without 
loading a view.

File > Save View
(Ctrl-S)

Saves the current view:

• If you have not already saved the current view, 
opens the Save File Dialog: View List, which 
enables you to enter or select a file name under 
which to save the current view.

• If you have already saved the current view, saves 
the view to that file name.

If you have implemented MWTM User-Based Access, 
this option is available to users with authentication 
level Power User (Level 2) and higher.
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File > Save View As Opens the Save File Dialog: View List, which enables 
you to enter or select a file name under which to save 
the current view.

If you have implemented MWTM User-Based Access, 
this option is available to users with authentication 
level Power User (Level 2) and higher.

File > Connect to New Server
(Ctrl-O)

Connects to a new server. MWTM prompts you for the 
new server’s name or IP address, and UDP port 
number.

MWTM stops the MWTM client, then restarts the 
client connected to the new server.

File > Print
(Ctrl-P)

Enables you to:

• Specify options for printing

• Print the current window

• Save the current window to a file

The MWTM printing options require that you define a 
printer on your system. If you select File > Print and 
the Print window does not appear, make sure you have 
defined a printer on your system.

File > Exit
(Ctrl-Q)

Exits the MWTM application, after prompting you for 
confirmation.

If you are working in a custom view (that is, not the 
DEFAULT view), MWTM automatically saves any 
changes you made to the view.

Edit > Views
(Ctrl-M)

Opens the View Editor Window.

Edit > Find
(Ctrl-F)

Opens the Find dialog, which enables you to find a 
specific object, event, or text in the window.

If you select an object in the left pane of the MWTM 
Main Window, this option is grayed-out and cannot be 
selected.

Menu Command Description
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Edit > Clear All Events
(Ctrl-E)

Deletes the event icon (orange triangle) from MWTM 
displays for all known objects. The actual events are 
not deleted from MWTM, only the event icon for all 
known objects.

Note During Discovery, MWTM might flag most 
objects with an event icon. If the event icons 
are too distracting, use the Edit > Clear All 
Events menu option to remove them.

Edit > Delete
(Delete)

Deletes the currently selected element or elements 
from the MWTM database. MWTM displays the 
Confirm Deletion dialog:

• To delete the selected elements, click Yes. The 
items are deleted from the MWTM database and 
the Confirm Deletion dialog is closed.

• To retain the selected elements, click No. The 
items are kept in the MWTM database and the 
Confirm Deletion dialog is closed.

• To prevent MWTM from displaying the Confirm 
Deletion dialog, select the Do not show this again 
checkbox.

Note If you select the Do not show this again 
checkbox, and you later decide you want 
MWTM to begin displaying the Confirm 
Deletion dialog again, you must select the 
Confirm Deletions checkbox in the General 
GUI settings in the Preferences window. For 
more information, see the description of the 
Confirm Deletions checkbox in the 
“Startup/Exit Settings” section on page 11-7.

If you have implemented MWTM User-Based Access, 
this option is available to users with authentication 
level Network Administrator (Level 4) and higher.

Edit > Preferences
(Ctrl-H)

Opens the Preferences window.

Menu Command Description
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Network > SNMP Configuration
(Ctrl-B)

Opens the SNMP Configuration Dialog.

If you have implemented MWTM User-Based Access, 
this option is available to users with authentication 
level Network Administrator (Level 4) and higher.

Network > Network Discovery
(Ctrl-Y)

Opens the Discovery Dialog.

If you have implemented MWTM User-Based Access, 
this option is available to users with authentication 
level Network Administrator (Level 4) and higher.

Network > Poll Nodes > Normal Poll
(Alt-N)

Polls all selected RAN-O nodes.

If you have implemented MWTM User-Based Access, 
this option is available to users with authentication 
level Network Operator (Level 3) and higher.

Network > Poll Nodes > Clean Poll
(Alt-C)

Polls all selected RAN-O nodes and removes any 
Unknown objects after the completion of the poll.

If you have implemented MWTM User-Based Access, 
this option is available to users with authentication 
level Network Operator (Level 3) and higher.

View > Show Topology
(Ctrl-T)

Opens the Topology Window.

View > MWTM Server > Home Page Displays the MWTM Server Home Page in a Web 
browser.

View > MWTM Server > Telnet To
(Ctrl-N)

Opens a Telnet window to the server.

View > MWTM Server > Status 
Information

Opens the Server Status Information Window.

View > Network Status Dashboard Displays the MWTM Node Dashboard in a Web 
browser.

View > Event History > Status Changes Displays the MWTM Network Status Log for Status 
Change Messages in a Web browser, with messages 
displayed for all known objects.

View > Event History > SNMP Trap 
Messages

Displays the MWTM Network Status Log for SNMP 
Trap Messages in a Web browser, with messages 
displayed for all known objects.

Menu Command Description
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View > Event History > Status and Trap 
Messages

Displays the MWTM Network Status Log for Status 
Change Messages and SNMP Trap Messages in a Web 
browser, with messages displayed for all known 
objects.

View > Event History > Network Status 
Metrics

Displays the MWTM Network Status Log for Metrics 
in a Web browser, with metrics displayed for all known 
objects.

View > Event History > Network Status 
Archives

Displays all archived Status Change Messages and 
SNMP Trap Messages in a Web browser.

View > User Audit > User Actions Displays action messages in the system log, in a Web 
browser.

View > User Audit > User Accounts Displays information about all user accounts that have 
been defined for the MWTM server, in a Web browser.

View > User Audit > Security Log Displays the contents of the MWTM system security 
log file for the server to which you are connected, and 
which is currently running the MWTM server, in a 
Web browser.

View > User Audit > Command Log Displays the contents of the MWTM command log file 
for the server to which you are connected, and which 
is currently running the MWTM server, in a Web 
browser. The command log lists all mwtm commands 
that have been entered for the MWTM server, the time 
each command was entered, and the user who entered 
the command.

View > User Audit > Connected Clients Lists all MWTM clients that are currently connected to 
the MWTM server, in a Web browser. It also lists all 
Solaris/Linux users that are logged in to the MWTM 
server.

View > Message of the Day Opens the Message of the Day dialog.

View > Cisco.com Displays the Cisco.com Home Page in a Web browser.

Reports > Router Node IOS Versions Displays the RAN-O Node IOS Versions for the server 
to which you are connected, and which is currently 
running the MWTM server, in a Web browser.

Menu Command Description
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Go > Back
(Alt-Left)

Navigates back to the last window viewed in this 
session.

Go > Forward
(Alt-Right)

Navigates forward to the last window viewed in this 
session.

Go > Back > List of Windows Navigates back to a window viewed in this session.

MWTM maintains a list of up to 10 Back windows.

Go > Forward > List of Windows Navigates forward to a window viewed in this session.

MWTM maintains a list of up to 10 Forward 
windows.

Tools > Event Configurator
(Alt-E)

Launches the Event Configurator, which enables you 
to customize the displayed category, severity, color, 
and message associated with events; configure sounds 
for MWTM to play for different types of events; and 
load, save, and deploy customized event 
configurations.

If you have implemented MWTM User-Based Access, 
this option is available to users with authentication 
level Network Operator (Level 3) and higher.

Tools > Event Sounds
(Alt-U)

Opens the Event Sound Filters dialog, which enables 
you to define sounds that the MWTM client is to play 
when specific events are logged.

Menu Command Description
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Products > CiscoWorks > 
Device Center
(Ctrl-2)

Links to the CiscoWorks Device Center, which 
provides a number of Web-based functions, including 
reachability trends, response time trends, interface 
status, Syslog browsing, and detailed inventory. 
MWTM prompts you for a CiscoWorks user ID and 
password before linking to CiscoWorks.

The link to CiscoWorks has the following 
prerequisites:

• CiscoWorks must be installed somewhere in the 
network.

• The specific Cisco device must to be monitored by 
CiscoWorks.

This option is grayed-out if the selected node is not a 
RAN-O  node, or if the selected node is in Unmanaged 
status or has a Device Type of Unknown. 
(CiscoWorks cannot monitor a non-RAN-O, 
Unmanaged, or Unknown node.)

This option is not displayed if you did not specify a 
CiscoWorks server during installation. See the 
“Installing MWTM on Solaris” and “Installing 
MWTM on Windows” chapters of the Cisco Mobile 
Wireless Transport Manager Installation Guide for 
more information.

Menu Command Description
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Products > CiscoWorks >
CiscoView
(Ctrl-3)

Links to CiscoView, which provides a real-time, 
color-coded, graphical representation of Cisco 
devices. You can use CiscoView to quickly identify an 
incorrect status on a port or interface.

This option is grayed-out if the selected node is a 
non-RAN-O  node, or if the selected node is in 
Unmanaged status or has a Device Type of Unknown. 
(CiscoWorks cannot monitor a non-RAN-O , 
Unmanaged, or Unknown node.)

This option is not displayed if you did not specify a 
CiscoWorks server during installation. See the 
“Installing MWTM on Solaris” and “Installing 
MWTM on Windows” chapters of the Cisco Mobile 
Wireless Transport Manager Installation Guide for 
more information.

Help > Topics
(F1)

Displays the table of contents for the MWTM online 
help.

Help > Window
(Shift-F1)

Displays online help for the current window.

Help > About
(F3)

Displays build date, version, SSL support, and 
copyright information about the MWTM application.

Topology Tools > Zoom In
(Ctrl-=)

Makes the map twice as large.

Note This option is displayed only in the Topology 
Window (View > Show Topology).

Topology Tools > Zoom Out
(Ctrl-- or Ctrl-Minus)

Makes the map half as large.

Note This option is displayed only in the Topology 
Window (View > Show Topology).

Topology Tools > Zoom Area Zooms in on the selected area of the map.

Note This option is displayed only in the Topology 
Window (View > Show Topology).

Menu Command Description
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Topology Tools > Zoom Fit Adjusts the size of the map to fit in the window. This 
is the default setting the first time the map is displayed.

Note This option is displayed only in the Topology 
Window (View > Show Topology).

Topology Tools > Layout > Circular Displays the map in a circular layout.

Note This option is displayed only in the Topology 
Window (View > Show Topology).

Topology Tools > Layout > Spring Displays the map in a spring layout. That is, nodes 
with the most links are drawn closer to the center of the 
map, while nodes with fewer links are drawn farther 
away. This is the default setting the first time the map 
is displayed.

Note This option is displayed only in the Topology 
Window (View > Show Topology).

Topology Tools > Restore Positions Restores the view to the last saved view.

Note This option is displayed only in the Topology 
Window (View > Show Topology).

Topology Tools > Save As JPEG
(Ctrl-J)

Opens the Save as JPEG dialog, enabling you to save 
the topology map to a JPEG file.

Note This option is displayed only in the Topology 
Window (View > Show Topology).

Topology Tools > Magnetic Grid Opens the Magnetic Grid Settings dialog.

Note This option is displayed only in the Topology 
Window (View > Show Topology).

Topology Tools > Align Opens the Align Objects dialog, which enables you to 
align two or more objects on the topology map.

Note This option is displayed only in the Topology 
Window (View > Show Topology).

Menu Command Description
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Topology Tools > Exclude from View Excludes the selected node from the current view. See 
the “Creating a New View” section on page 4-42 for 
more information about excluding nodes.

Note This option is displayed only in the Topology 
Window (View > Show Topology).

This option is grayed-out if the selected node is not a 
RAN-O node.

Topology Tools > Open Parent View Opens the parent view of the currently displayed view 
in the Topology Window.

Note This option is displayed only in the Topology 
Window (View > Show Topology).

This option is grayed-out if the currently displayed 
view is the highest level parent view.

Topology Tools > Close View Closes the currently displayed view in the Topology 
Window.

Note This option is displayed only in the Topology 
Window (View > Show Topology).

This option is grayed-out if the currently displayed 
view is the highest level parent view.

Menu Command Description
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Viewing Alarms
MWTM enables you to view a summary of all currently active alarms in your 
network, including the current status of the associated network object. An active 
alarm is a network object with the following status:

• A node or interface that is Warning (yellow) or worse and is not Ignored.

• A node or interface that is Pending (red) or worse and is not Ignored.

To see a summary of all currently active alarms, click Alarms in the left pane. 
MWTM displays the Active Alarms Window in the right pane. For more 
information, see the “Viewing Alarms” section on page 3-19.

Right-click Alarms in the left pane to display the right-click menu for all alarms. 
For more information, see the “Right-Click Menu for All Alarms” section on 
page 3-23.

Right-click an alarm in the right pane to display the right-click menu for a specific 
alarm. For more information, see the “Right-Click Menu for a Specific Alarm” 
section on page 3-23.

Viewing Alarms
To view alarms, select Alarms in the left pane of the MWTM Main Window. 
MWTM displays the Active Alarms Window (Figure 3-3).
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Figure 3-3 Active Alarms Window

The Active Alarms Window provides basic information about all currently active 
alarms in your network, that are not excluded from your current view. MWTM 
updates the information in the window at least once every minute.

To see mouse over help popup for each column in the table, place the cursor over 
a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the 
full data in a mouse over help popup.

You can resize each column, or sort the table based on the information in one of 
the columns. By default, this table is sorted by Age, with the most recent alarms 
at the top, and MWTM displays all of the columns in the table except Last Status 
Change.

• To display hidden columns, right-click in the table header and select the 
checkboxes for the columns you want to display.

• To hide columns, right-click in the table header and clear the checkboxes for 
the columns you want to hide.

See the “Resizing, Sorting, and Hiding Table Columns” section on page 3-37 for 
more information about resizing, sorting, displaying, or hiding columns.

The active alarms table contains the following columns:
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Column Description

Type Type of network object associated with the selected alarm.

To see all higher-level alarms associated with the network object, select the 
turner beside the object. MWTM displays the higher-level alarms below the 
selected alarm. 

Name Name of the network object associated with the selected alarm.

Status Current status of the network object associated with the selected alarm. 
Possible values are:

Unknown (red)

Unavailable (red)

Inactive (red)

Failed (red)

Down (red)

Pending (red)

Warning (yellow)

Shutdown (blue)

Discovering (cyan)

Polling (cyan)

Waiting (gray)

Unmanaged (gray)

Active (green)

For detailed definitions of each status for each type of network object, see 
the “MWTM Status Definitions” section on page A-1.
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Status Reason Reason for the current status of the network object associated with the 
selected alarm.

For a full list of possible reasons, see the stateReasons.html file:

• If you installed MWTM in the default directory, /opt, then the file is 
located at /opt/CSCOsgm/apache/share/htdocs/eventHelp directory.

• If you installed MWTM in a different directory, then the help directory 
and file are located in that directory.

If the cell is too small to show all of the status reason, place the cursor over 
the cell to see the full status reason in a mouse over help popup.

The status reasons are listed in order of decreasing magnitude. If two or more 
reasons apply, the reason of greatest magnitude is displayed.

If the status reason is Unsupported Configuration, correct the 
configuration and enter the mwtm cleandiscover command to delete all 
current network data and begin a clean discovery of the RAN-O  network. If 
the status reason is still Unsupported Configuration, enter the mwtm clean 
command to restore the MWTM server to a “clean” state, such as would exist 
after a new installation of MWTM. For more information on the use of these 
commands, see the “MWTM Command Reference” section on page C-1.

Last Status Change Date and time that the status of the network object associated with the 
selected alarm last changed.

Age Age of the selected alarm, in days, hours, and minutes. 

Note For the most accurate age data, ensure that the client and server 
clocks are in sync by using Network Time Protocol (NTP) or a 
similar service. For more details, see “Why are the age of my alarms 
always 0 minutes?” section on page B-19.

Column Description
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Right-Click Menu for All Alarms
To see the right-click menu for all active alarms, select Alarms in the left pane 
and click the right mouse button. The active alarms right-click menu provides the 
following options:

Right-Click Menu for a Specific Alarm
The active alarms table provides a subset of the MWTM Main Menu as a 
right-click menu. To see this menu, select an alarm and click the right mouse 
button. The alarm right-click menu provides the same options as the right-click 
menu for the associated network object, plus the following additional options:

Caution The alarms displayed in the active alarms table are the actual network objects in 
MWTM. Options you select in the right-click menu affect the object in MWTM. 
For example, if you delete a node in the active alarms table, you delete that node 
from the MWTM database.

Menu Command Description

Show In New Window Opens the Active Alarms Window in a new window.

Sort Tree By Status Sorts the entire tree in the left pane by the status of each object.

Sort Tree By Name Sorts the entire tree in the left pane by the name of each object.

Back > List of Windows Navigates back to a window viewed in this session.

MWTM maintains a list of up to 10 Back windows.

Forward > List of 
Windows

Navigates forward to a window viewed in this session.

MWTM maintains a list of up to 10 Forward windows.

Menu Command Description

Expand All Displays all higher-level alarms associated with all network objects in the active 
alarms table.

Collapse All Does not display higher-level alarms in the active alarms table.
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Viewing Events
To see all events discovered by MWTM, click Events in the left pane. MWTM 
displays the Event Window in the right pane. For more information, see the 
“Working with Events” section on page 5-1.

Right-click Events in the left pane to display the right-click menu for all events. 
For more information, see the “Right-Click Menu for All Events” section on 
page 5-4.

Right-click an event in the right pane to display the right-click menu for a specific 
event. For more information, see the “Right-Click Menu for a Specific Event” 
section on page 5-5.

Viewing a Summary of Network Objects
MWTM enables you to view basic summary information about all discovered 
network objects, including their status and the number of each object with that 
status.

To see a summary of all network objects discovered by MWTM, click Summary 
Lists in the left pane. MWTM displays the Summary Statistics Window in the 
right pane. For more information, see the “Viewing the Summary Lists” section 
on page 3-25.

Right-click Summary Lists in the left pane to display the right-click menu for the 
summary lists. For more information, see the “Right-Click Menu for the Summary 
Lists” section on page 3-27.

Note If an object in the left pane is not associated with any objects of a given type, 
MWTM does not display that sub-folder. 
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Viewing the Summary Lists
To view the summary lists, select Summary Lists in the left pane of the MWTM 
Main Window. MWTM displays the Summary Statistics Window (Figure 3-4).

Figure 3-4 Summary Statistics Window

The Summary Statistics Window provides basic summary information about all 
discovered network objects that have been discovered by MWTM.

To see mouse over help popup for each column in the table, place the cursor over 
a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the 
full data in a mouse over help popup.

You can resize each column, or sort the table based on the information in one of 
the columns. By default, this table is sorted by Status, with failures (red statuses) 
at the top.

• To display hidden columns, right-click in the table header and select the 
checkboxes for the columns you want to display.

• To hide columns, right-click in the table header and clear the checkboxes for 
the columns you want to hide.

See the “Resizing, Sorting, and Hiding Table Columns” section on page 3-37 for 
more information about resizing, sorting, displaying, or hiding columns.
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The summary list table contains the following columns:

Column Description

Status Current status of the network objects. Possible values are:

Unknown (red)

Unavailable (red)

Inactive (red)

Failed (red)

Down (red)

Blocked (red)

Pending (red)

Warning (yellow)

Shutdown (blue)

Discovering (cyan)

Polling (cyan)

Waiting (gray)

Unmanaged (gray)

Active (green)

For detailed definitions of each status for each type of network object, see 
the “MWTM Status Definitions” section on page A-1.

Total Total number of network objects with the indicated status.

Objects in hidden columns are not included in the totals.

Nodes Total number of discovered nodes with the indicated status.
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Right-Click Menu for the Summary Lists
To see the right-click menu for the summary lists, select Summary Lists in the 
left pane and click the right mouse button. The summary lists right-click menu 
provides the following options:

Viewing Views
To see all views currently configured on this MWTM client, select the turner 
beside Summary Lists, then click Views in the left pane. MWTM displays the 
View Window in the right pane. For more information, see the “Viewing Basic 
Information for Views” section on page 4-4.

To display all views currently configured on this MWTM client in the left pane, 
select the turner beside Views. Then, you can select one of the views to display 
the View Details Window for that view in the right pane. For more information, 
see the “Viewing Detailed Information for a View” section on page 4-12.

To display the DEFAULT view, select the turner beside Views, then select 
DEFAULT to display the View Details Window for the DEFAULT view in the 
right pane. For more information, see the “Viewing Detailed Information for a 
View” section on page 4-12.

Right-click Views in the left pane to display the right-click menu for all views. 
For more information, see the “Right-Click Menu for All Views” section on 
page 4-5.

Menu Command Description

Show In New Window Opens the Summary Statistics Window in a new window.

Sort Tree By Status Sorts the entire tree in the left pane by the status of each object.

Sort Tree By Name Sorts the entire tree in the left pane by the name of each object.

Back > List of Windows Navigates back to a window viewed in this session.

MWTM maintains a list of up to 10 Back windows.

Forward > List of 
Windows

Navigates forward to a window viewed in this session.

MWTM maintains a list of up to 10 Forward windows.
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Right-click a view in the right pane to display the right-click menu for a specific 
view. For more information, see the “Right-Click Menu for a Specific View” 
section on page 4-6.

Viewing Nodes
To see all nodes discovered by MWTM, select the turner beside Summary Lists, 
then click Nodes in the left pane. MWTM displays the Node Window in the right 
pane. For more information, see the “Viewing Basic Information for Nodes” 
section on page 6-2.

To display all nodes discovered by MWTM in the left pane, select the turner 
beside Nodes. Then, you can select one of the nodes to display the Node Details 
Window for that node in the right pane. For more information, see the “Viewing 
Detailed Information for a Node” section on page 6-13.

Right-click Nodes in the left pane to display the right-click menu for all nodes. 
For more information, see the “Right-Click Menu for All Nodes” section on 
page 6-3.

Right-click a node in the right pane to display the right-click menu for a specific 
node. For more information, see the “Right-Click Menu for a Specific Node” 
section on page 6-4.

Viewing Interfaces
To see all interfaces discovered by MWTM, select the turner beside a node in the 
left pane. To see detailed information about an interface, select the interface in the 
left pane. MWTM displays the Interface Window in the right pane. For more 
information, see “Viewing Detailed Information for an Interface” section on 
page 7-1.

Right-click an interface in the left pane to display the right-click menu. For more 
information, see the “Interface Details: Right-Click Menu” section on page 7-3.
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Viewing the Topology of the Network
To see a topology (graphical) view of the objects in your network select View > 
Show Topology in the MWTM Main Menu. MWTM displays the Topology 
Window in a new window. For more information, see the “Viewing the Topology 
of the Network” section on page 8-1.

Viewing MWTM Data on the Web
MWTM enables you to access MWTM data from the MWTM Server Home Page, 
using a Web browser. To do so, select View > MWTM Server > Home Page in 
the MWTM Main Menu. MWTM displays the MWTM Server Home Page in a 
Web browser. For more information, see the “Accessing MWTM Data from a 
Web Browser” section on page 13-1.
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Viewing Server Status Information
MWTM enables you to view detailed information about the processes, pollers, 
tasks, and clients for the server to which you are connected, and which is currently 
running the MWTM server.

To display server status information, select View > MWTM Server > 
Status Information in the MWTM Main Menu. MWTM displays the Server 
Status Information window (Figure 3-5).

Figure 3-5 Server Status Information Window

The Server Status Information window is composed of the following sections:

• Server Status Information: Fields and Buttons, page 3-31

• Server Status Information: Processes, page 3-31

• Server Status Information: Pollers, page 3-32

• Server Status Information: Tasks, page 3-33

• Server Status Information: Clients, page 3-34
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Server Status Information: Fields and Buttons
The Server Status Information window contains the following fields and buttons:

Server Status Information: Processes
The Server Status Information: Processes section lists the processes that make up 
the MWTM server.

The Processes table contains the following columns:

Menu Command Description

Poll Interval Poll interval used to collect data for the table.

Last Poll Time the last poll was run.

This field initially displays the phrase Polling device. After the first 
polling cycle, MWTM populates this field with the actual time of the last 
poll.

Update Forces an immediate poll, and refreshes the Server Status Information 
window with the latest data.

Close Closes the Server Status Information window.

Help Displays online help for the Server Status Information Dialog.

Field Description

Name Name of the process, such as AppServer.

Process ID Number to uniquely identify the process.

Is Running Indicates whether the process is running (true) or not (false).
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Server Status Information: Pollers
The Server Status Information: Pollers table lists the detail and demand pollers 
that are currently being processed by the MWTM server.

The Server Status Information: Pollers table contains the following columns:

Field Description

Poller ID Number to uniquely identify each MWTM detail poller that is currently active.

MWTM detail pollers collect detailed data (such as real-time data, statistics, 
route detail, and so on) that is not collected by the regular MWTM poller.

Client Host Name of the MWTM client that started the detail poller.

Interval Poll interval for the detail poller, in hours, minutes, and seconds.

Iteration Number of times the detail poller is to poll. If this field displays Forever, the 
detail poller will never stop polling, until requested to stop by the MWTM 
client.

Next Poll Time until the next poll, in hours, minutes, and seconds.

Time Limit Time remaining, in hours, minutes, and seconds, until the poller times out. 
When the poller times out, MWTM automatically stops the poller to prevent 
unnecessary traffic on the network and sends an appropriate error message to 
the client.

By default, MWTM allows pollers to run up to 8 hours. To change that setting, 
see the description of the mwtm pollertimeout command in the “mwtm 
pollertimeout” section on page C-46.

Description Description of the detail poller.
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Server Status Information: Tasks
The Server Status Information: Tasks table lists long-running services being 
performed by the MWTM server.

The Server Status Information: Tasks table contains the following columns:

Field Description

Task ID Number to uniquely identify the task.

Interval Time between runs for the task, in hours, minutes, and seconds.

Iteration Number of times the task is to run. If this field displays Forever, the task will 
never stop polling.

Next Execution Time until the next run for the task, in hours, minutes, and seconds.

State Current state of the task. Valid values are:

• None—Task is stopped.

• Waiting—Task is waiting to transition to Ready or Running state.

• Ready—Task is ready to execute but is not yet in Running state.

• Running—Task has been started and is currently executing.

• Pending—Task was in Ready state when it was canceled by a user. The 
task is pending final removal from the scheduler.

• Error—Task encountered an error.

• Dying—Task was in Running state when it was canceled by a user. The 
task continues to run in Dying state until it completes, then it is removed 
from the scheduler.

Description Description of the task.
3-33
Cisco Mobile Wireless Transport Manager User Guide

OL-7637-01



 

Chapter 3      Getting Started with MWTM
Viewing Server Status Information
Server Status Information: Clients
The Server Status Information: Clients table contains the following columns:

Field Description

Process Name Name of an MWTM client that is currently connected to the server.

User Name If you have implemented MWTM User-Based Access, this field displays the 
name of an MWTM client user who is currently logged in and connected to the 
server.

If you have not implemented MWTM User-Based Access, this field displays the 
name of the device being used by the user.

Message Mask Mask that indicates which messages [1-81] are allowed to be sent to the client:

• For the MWTM client, this field displays [1-81]. That is, all messages are 
allowed to be sent to the MWTM client.

• For the Event Configurator, this field displays [14, 56, 67]. That is, only 
messages 14, 56, and 67 are allowed to be sent to the Event Configurator.

Sleeping? Indicates whether the thread that is responsible for delivering messages is 
sleeping (yes) or not (no). The normal setting for this field is no.

Sleep Time Time in seconds the thread that is responsible for delivering messages has been 
sleeping. The normal setting for this field is 0.

Queue Size Number of messages waiting to be sent to the MWTM client. The normal 
setting for this field is 0, but it could be higher if the MWTM server or client is 
very busy, as during Discovery.
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Viewing Online Help
MWTM provides the following online help options in the MWTM Main Menu:

• To display the table of contents for the MWTM online help in a Web browser, 
select Help > Topics.

• To display online help for the current window in a Web browser, click Help 
> Window.

• To display build date, version, SSL support, and copyright information about 
the MWTM application in a Web browser, click Help > About.

Related Topics:

• Viewing the MWTM Technical Documentation, page 13-55

Finding Information in a Window
Sometimes it can be difficult to find a specific piece of information, such as a node 
name or event text, in a window. MWTM enables you to search for a character 
string in a window.

To find and highlight a character string in a window, select Edit > Find from the 
MWTM Main Menu. MWTM displays the Find dialog (Figure 3-6).

Figure 3-6 Find Dialog

The Find dialog contains the following fields and buttons:
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Field or Button Description

What Character string for which MWTM is to search in the window. This can be any 
character string: all or part of a node name, event text, status, and so on.

Match Case Checkbox used to indicate whether MWTM is to search for only character 
strings that match the case of the text in the What field:

• To search with case-matching on, select this check box.

• To search with case-matching off, clear this check box. This is the default 
setting.

Search Forward Specifies whether MWTM is to search forward (down and to the right) in the 
window. This radio button is mutually exclusive with the Search Backward 
button. The default setting for this checkbox is selected.

Search Backward Specifies whether MWTM is to search backward (up and to the left) in the 
window. This radio button is mutually exclusive with the Search Forward 
button. The default setting for this checkbox is cleared.

Find Launches the search:

• If a matching character string is found in the window, MWTM highlights 
the first line that contains the string.

To find the next occurrence of the string, click Find again.

You can continue to click Find until there are no more matches in the 
window. At that time, MWTM displays an appropriate message in the 
dialog, such as Bottom of table reached.

• If no matching character string is found, MWTM displays an appropriate 
message in the dialog, such as Bottom of table reached.

Close Closes the Find dialog when you are done searching.
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Resizing, Sorting, and Hiding Table Columns
The columns in some tables in MWTM can be resized, sorted, or hidden to meet 
your specific needs. MWTM automatically saves your new settings and, 
thereafter, launches the client with the new settings.

• To make a column wider or narrower, click the column divider in the header 
and move the divider to the right or left while holding down the left or right 
mouse button.

Changes you make to an object’s Components or Recent Events table in the 
MWTM Main Window are reflected in all Components or Recent Events 
tables in the MWTM Main Window for all other objects. The changes are not 
reflected in Show In New Window windows or Real-Time Data and Charts 
windows.

Depending on your system, as well as other factors, MWTM windows can 
sometimes display so small that text is illegible, and columns and text entry 
fields are very narrow and unusable. If this happens, resize the window and 
widen the individual columns until the information is again legible and the 
columns and text entry fields are usable.

• By default, MWTM displays most of the columns in tables, but some columns 
may be hidden.

– To display hidden columns, right-click in the table header and select the 
checkboxes for the columns you want to display.

– To hide columns, right-click in the table header and clear the checkboxes 
for the columns you want to hide.

Changes you make to an object’s Components or Recent Events table in the 
MWTM Main Window are reflected in all Components or Recent Events 
tables in the MWTM Main Window for all other objects. The changes are not 
reflected in Show In New Window windows or Real-Time Data and Charts 
windows.

• To sort a table based on the data in a column, left-click in the column header. 
The table is sorted alphanumerically from top to bottom, based on the data in 
the selected column. To sort the table in reverse order, left-click in the column 
header a second time. If two entries in the selected column are identical, 
MWTM sorts those rows based on the data in the remaining table columns, 
moving left to right.
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• Many of the tables in MWTM Web pages display an icon in the column 
header to indicate the column on which the table is sorted, and the direction 
of the sort. The icon displays an upward-pointing arrow if the table is sorted 
in ascending order (1-9, A-Z), and a downward-pointing arrow if the table is 
sorted in descending order (Z-A, 9-1).

• If you sort a table in an MWTM Web page based on the Nodes column, by 
default the table is sorted based on the DNS names of the nodes, as discovered 
by MWTM. However, if you modified your preferences to identify nodes by 
their user-defined names, then the table is sorted based on the user-defined 
names of the nodes. For more information, see the “Node Name Settings” 
section on page 11-9.

• To customize the order in which status settings are sorted in the Status 
column of tables, use the Status settings section of the Preferences window. 
For more information, see the “Status Settings” section on page 11-20.

Editing Object Properties
MWTM enables you to quickly and easily edit some properties of nodes and 
views. For more information, see the following sections:

• Editing Node Properties, page 6-54

• Editing View Properties, page 4-34

Attaching Notes to Objects
MWTM enables you to quickly and easily attach notes to objects in the MWTM 
database. For more information, see the following sections:

• Attaching a Note to an Event, page 5-24

• Attaching a Note to a Node, page 6-58

• Attaching a Note to a View, page 4-37
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Printing MWTM Windows
You can print most MWTM windows, as well as the topology map, for those times 
when you need hardcopy.

To print an MWTM window, select File > Print from most MWTM windows (for 
example, the MWTM Main Window or Topology Window).

MWTM displays the Print dialog (Figure 3-7).

Figure 3-7 Print Dialog

The Print dialog enables you to specify print settings, such as which printer to 
print to, whether to send output to a file (the default location for the print file is 
your home directory), and whether to print duplex.

Note You can send output to a file only in the file formats supported by your printer 
drivers. Sending output to a file can also result in very large files.
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When you are satisfied with your print settings, click Print. MWTM prints the 
map.

To exit the Print dialog at any time without printing, click Cancel.

Loading and Saving MWTM Files
MWTM enables you to quickly and easily load and save MWTM files. The files 
are stored on the MWTM server and can be loaded on any connected MWTM 
client.

To display a Load File Dialog, use one of the following procedures:

• To display the Load File Dialog: Load Filter, click Load in the Event Filter 
dialog. For more information, see the “Loading an Existing Event Filter” 
section on page 5-17.

• To display the Load File Dialog: Preferences File List, select File > Load 
from the Preferences window. For more information, see the “Loading an 
Existing Preference Settings File” section on page 11-28.

• To display the Load File Dialog: Seed File List, select File > Load Seeds 
from the Discovery Dialog. For more information, see the “Loading Seed 
Nodes and Seed Files” section on page 2-12.

• To display the Load File Dialog: View List, select File > Load from the View 
Editor Window. For more information, see the “Loading a Client-Specific 
View” section on page 4-53.

• To load the DEFAULT network view, select File > Load DEFAULT View 
from the MWTM Main Menu. MWTM loads the DEFAULT view.

To display a Save File Dialog, use one of the following procedures:

• To display the Save File Dialog: Save Filter, click Save in the Event Filter 
dialog. For more information, see the “Saving an Event Filter File” section on 
page 5-19.

• To display the Save File Dialog: Preferences File List, select File > Save As 
from the Preferences window. For more information, see the “Saving the 
Preference Settings File” section on page 11-30.
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• To display the Save File Dialog: Seed File List, select File > Save As from 
the Discovery Dialog. For more information, see the “Saving a Seed File” 
section on page 2-15.

• To display the Save File Dialog: View List, select File > Save As from the 
View Editor window. For more information, see the “Closing the View Editor 
Window” section on page 4-52.

Viewing Real-Time Data for a Node
MWTM enables you to view detailed statistics for a selected node.

To display detailed statistics for one of these nodes, select the Shorthaul 
Performance or Backhaul Performance tab in the Node Details window. 

For more information, see the following sections:

• “Node Details: Shorthaul Performance” section on page 6-23

• “Node Details: Backhaul Performance” section on page 6-32

Changing Real-Time Poller and Counter Settings
MWTM provides three pollers for use in the MWTM client GUI and Web pages: 
a fast poller, a slow poller, and a status refresh poller. MWTM enables you to 
change settings for those pollers, and also enables you to specify how you want 
MWTM to aggregate displayed counter values.

To change MWTM poller refresh and counter display settings, use one of the 
following methods:

• The fast poller, slow poller, and status refresh poller have default minimum, 
maximum, and default settings specified in the MWTM System.properties 
file. To change those settings, see the “Changing MWTM System Poller 
Settings” section on page 11-32.

• To change MWTM poller refresh and counter display settings for the MWTM 
GUI using the MWTM Preferences window, see the “Poller Settings” section 
on page 11-10.
3-41
Cisco Mobile Wireless Transport Manager User Guide

OL-7637-01



 

Chapter 3      Getting Started with MWTM
Connecting to a New Server
Connecting to a New Server
MWTM enables you to connect the client to a new MWTM server. For example, 
you can monitor two or more networks from the same MWTM client, simply by 
switching servers. Or, if you have two MWTM servers monitoring the same 
network, and one server fails, the MWTM client automatically switches to the 
secondary server.

If you want to determine the default host name before you connect to the new 
server, it is contained in the SERVER_NAME entry in the System.properties file:

• If you installed MWTM in the default directory, /opt, then the location of the 
System.properties file is /opt/CSCOsgm/properties/System.properties.

• If you installed MWTM in a different directory, then the System.properties 
file is located in that directory.

To connect the client to a new server, select File > Connect to New Server from 
the MWTM Main Menu. MWTM displays the Connect to New Server Dialog 
(Figure 3-8).

Figure 3-8 Connect to New Server Dialog
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The Connect to New Server Dialog contains the following fields and buttons:

Field or Button Description

Server Name or IP Address Name or IP address of the new server. Enter the name of the new server, 
or its IP address, in the Server Name or IP Address field.

Name Server Port UDP port number for the new server. Enter the MWTM Naming Server 
UDP port number for the new server in the Name Server Port field.

The default value is 44742.

OK Stops the MWTM client, then restarts the client connected to the 
specified server.

When you have entered the name of the new server, or its IP address, 
and its UDP port number, click OK. MWTM stops the MWTM client, 
then restarts the client connected to the new server.

Cancel Closes the Connect to New Server Dialog without connecting to the 
new server.

Help Displays online help for the Connect to New Server Dialog.
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Integrating MWTM with Other Products
MWTM does not require either CiscoWorks or HP OpenView, but MWTM does 
integrate with those products to provide added value. See the following sections 
for more information:

• Integrating MWTM with HP OpenView, page 3-44

• Integrating MWTM with CiscoWorks, page 3-44

• Forwarding Traps to Other Hosts (Server Only), page 3-46

Integrating MWTM with HP OpenView
MWTM can integrate with HP OpenView during installation, registering to 
receive forwarded traps. See the “Installing MWTM on Solaris” chapter of the 
Cisco Mobile Wireless Transport Manager Installation Guide for more 
information.

You can also integrate MWTM with HP OpenView after installation, using the 
mwtm trapsetup command. See the “mwtm trapsetup” section on page C-87 for 
more information.

Integrating MWTM with CiscoWorks
MWTM can integrate with CiscoWorks during installation, registering with 
CiscoWorks as an installed application. See the “Installing MWTM on Solaris” 
and “Installing MWTM on Windows” chapters of the Cisco Mobile Wireless 
Transport Manager Installation Guide for more information.

You can also integrate MWTM with CiscoWorks after installation, using the 
mwtm cwsetup command. See the “mwtm cwsetup” section on page C-20 for 
more information.

When MWTM is integrated with CiscoWorks, you can launch the CiscoWorks 
Device Center and CiscoView from the MWTM Main Menu. See the following 
sections for more information:

• Launching the CiscoWorks Device Center, page 3-45

• Launching CiscoView, page 3-45
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Launching the CiscoWorks Device Center

The CiscoWorks Device Center provides a number of useful Web-based 
device-monitoring functions, including reachability trends, response time trends, 
interface status, Syslog browsing, and a detailed inventory.

To link MWTM to the Device Center:

Step 1 Make sure CiscoWorks is installed in the network.

Step 2 Select a node that you know CiscoWorks is monitoring in a window. If you select 
a non-RAN-O  node, or a node with a status of Unmanaged or a Device Type of 
Unknown, the CiscoWorks menu option is grayed-out.

Step 3 Select Products > CiscoWorks > Device Center from the MWTM Main Menu.

Step 4 At the prompt, enter a CiscoWorks user ID and password. MWTM links to 
CiscoWorks Device Center dashboard.

Launching CiscoView

CiscoView provides a real-time, color-coded, graphical representation of Cisco 
devices. You can use CiscoView to quickly identify an incorrect status on a port 
or interface. If you are running CiscoWorks on UNIX or Windows, you can access 
CiscoView through the link to the Web version of CiscoWorks.

To link MWTM to CiscoView:

Step 1 Select a node that you know CiscoWorks is monitoring in a window. If you select 
a non-RAN-O  node, or a node with a status of Unmanaged or a Device Type of 
Unknown, the CiscoWorks menu option is grayed-out.

Step 2 Select Products > CiscoWorks >CiscoView from the MWTM Main Menu.

Step 3 At the prompt, enter a CiscoWorks user ID and password. MWTM links to 
CiscoView.
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Forwarding Traps to Other Hosts (Server Only)
MWTM enables you to forward SNMP traps to other SNMP servers, or hosts. 
This enables MWTM to function as a trap multiplexer, integrating with high-level 
event- and alarm-monitoring systems such as the Cisco Info Center (CIC), HP 
OpenView, and Micromuse's Netcool suite of products. These systems can 
provide a single high-level view of all alarm monitoring in your network, making 
it easier to detect and resolve problems.

To enable MWTM to forward SNMP traps to other hosts, specify the list of hosts 
in the TrapForwarder.properties file. The default file is located in the MWTM 
properties directory:

• If you installed MWTM in the default directory, /opt, then the default file is 
located at /opt/CSCOsgm/properties/TrapForwarder.properties.

• If you installed MWTM in a different directory, then the default file is located 
in that directory.

In the TrapForwarder.properties file, begin all comment lines with a pound sign 
(#).

All other lines in the file are host definition lines, with the following format:

SERVERxx=dest-address[:portno]

where:

• xx is the user-defined server number.

• dest-address is the host name, or the IP address in dotted decimal format.

• portno is the optional port number. The default port number is 162.

For example, the following host definition line:

SERVER02=64.102.86.104:162

enables MWTM to forward traps to Server 02, with IP address 64.102.86.104, on 
port 162.
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Any changes you make to the TrapForwarder.properties file take effect when you 
restart the MWTM server. Thereafter, MWTM forwards all traps from the listed 
hosts except:

• Traps that MWTM cannot parse.

• Traps from hosts listed in the trapaccess.conf file. For more information, see 
the “Limiting Traps by IP Address (Server Only)” section on page 11-38.

Version 2c traps that do not have the agent IP address already specified in the 
varbind list are modified to include the agent IP address in the varbind list.

You can also forward MWTM events to other hosts, in the form of SNMP traps. 
For more information, see the “Forwarding Events as Traps to Other Hosts” 
section on page 5-50.

Exporting MWTM Data
MWTM enables you to export its data for use by other products, such as 
CiscoWorks or Microsoft Excel. This section includes the following information:

• Exporting Current MWTM Data for Network Objects, page 3-48

• Exporting Current MWTM Node Names and SNMP Community Names, 
page 3-50

• Viewing RAN Data Export Files, page 3-50
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Exporting Current MWTM Data for Network Objects
You can use the MWTM command line interface (CLI) to export all MWTM data, 
or to export only selected MWTM data.

To export all current MWTM data, with fields separated by vertical bars (|; this is 
the default setting), enter the mwtm export all command with the -d bar 
keywords:

mwtm export all -d bar

To export all MWTM data with fields separated by commas (,), specify the -d 
comma keywords:

mwtm export all -d comma

To export all MWTM data with fields separated by tabs, specify the -d tab 
keywords:

mwtm export all -d tab

To export only node-specific MWTM data, specify the node keyword:

mwtm export nodes

You can also specify the -d comma or -d tab keywords on any of these 
object-specific mwtm export commands.

Here is sample output for the mwtm export nodes command:

mwtm-sun24:2> ./mwtm export nodes
# v5.0.0.9
# t1122238712043|Sun Jul 24 16:58:32 EDT 2005
#
# Total 12 nodes
# name|displayname|sgmid|old_description|cllicode|ipaddress|
old_pointcode|old_secondary|old_capability|state|statetimestamp|
ioslevel|devicetype|usericonname|sysdescr|lastpolltimestamp|
lastpolltime|avgpolltime|old_lasterrormsg|
old_lasterrortime|notesexist|old_variant|sysuptime|rebootreason|
statereason|discoveredtime|eventRcvd|telnetTo|ignore|customDisplayname
|processTraps|nsoconfig|mtp3offload|rfpeerstate|trapPollingEnabled|
reportPollingEnabledRNC_to_ems1941kb|RNC_to_ems1941kb|1215|not_used|
not_used|null|not_used|not_used|not_used|Unmanaged|1121953480035|0|RNC
|null|null|-1|-1|-1|not_used|not_used|false|not_used|-1|null|0|
1121953480036|false|null|false|null|true|not_used|not_used|not_used|
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false|false|BSC_to_ems1941kb|BSC_to_ems1941kb|1219|not_used|not_used|
null|not_used|not_used|not_used|Unmanaged|1121953480044|0|BSC|null|
null|-1|-1|-1|not_used|not_used|false|not_used|-1|null|0|1121953480045
|false|null|false|null|true|not_used|not_used|not_used|false|false|
BSC_to_ems1941kb|BSC_to_ems1941kb|1223|not_used|not_used|null|not_used
|not_used|not_used|Unmanaged|1121953480050|0|BSC|null|null|-1|-1|-1|
not_used|not_used|false|not_used|-1|null|0|1121953480050|false|null|
false|null|true|not_used|not_used|not_used|false|false|
BSC_to_ems1941kb|BSC_to_ems1941kb|1227|not_used|not_used|null|not_used
|not_used|not_used|Unmanaged|1121953480055|0|BSC|null|null|-1|-1|-1|
not_used|not_used|false|not_used|-1|null|0|1121953480055|false|null|
false|null|true|not_used|not_used|not_used|false|false|
ems1941kb.cisco.com|ems1941kb.cisco.com|1182|not_used|not_used|
[172.18.156.21][20.1.1.254]|not_used|not_used|not_used|Unknown|
1122221399654|1|CiscoMWR-1941-DC|null|sysDescr|1122220550854|170|170|
not_used|not_used|false|not_used|22232166|reload|8|1121953480066|false
|null|false|null|true|not_used|not_used|not_used|false|false|
RNC_to_ems1941ka|RNC_to_ems1941ka|1291|not_used|not_used|null|not_used
|not_used|not_used|Unmanaged|1121953480230|0|RNC|null|null|-1|-1|-1|
not_used|not_used|false|not_used|-1|null|0|1121953480230|false|null|
false|null|true|not_used|not_used|not_used|false|false|
BSC_to_ems1941ka|BSC_to_ems1941ka|1294|not_used|not_used|null|not_used
|not_used|not_used|Unmanaged|1121953480231|0|BSC|null|null|-1|-1|-1|
not_used|not_used|false|not_used|-1|null|0|1121953480231|false|null|
false|null|true|not_used|not_used|not_used|false|false|
BSC_to_ems1941ka|BSC_to_ems1941ka|1297|not_used|not_used|null|not_used
|not_used|not_used|Unmanaged|1121953480233|0|BSC|null|null|-1|-1|-1|
not_used|not_used|false|not_used|-1|null|0|1121953480233|false|null|
false|null|true|not_used|not_used|not_used|false|false|
BSC_to_ems1941ka|BSC_to_ems1941ka|1300|not_used|not_used|null|not_used
|not_used|not_used|Unmanaged|1121953480234|0|BSC|null|null|-1|-1|-1|
not_used|not_used|false|not_used|-1|null|0|1121953480234|false|null|
false|null|true|not_used|not_used|not_used|false|false|
ems1941ka.cisco.com|ems1941ka.cisco.com|1233|not_used|not_used|
[172.18.156.20][20.1.1.253]|not_used|not_used|not_used|Warning|
1122221418932|1|CiscoMWR-1941-DC|null|sysDescr|1122238176675|312|314|
not_used|not_used|false|not_used|1752636|reload|60|1121953480235|false
|null|false|null|true|not_used|not_used|not_used|false|false|
JMX0710L3S9|JMX0710L3S9|1786|not_used|not_used|null|not_used|not_used|
not_used|Waiting|1121957445502|0|IPDevice|null|null|-1|-1|-1|not_used|
not_used|false|not_used|-1|null|0|1121957445502|false|null|false|null|
true|not_used|not_used|not_used|false|false|JMX0710L2YY|JMX0710L2YY|
3608|not_used|not_used|null|not_used|not_used|not_used|Waiting|
1121986548590|0|IPDevice|null|null|-1|-1|-1|not_used|not_used|false|
not_used|-1|null|0|1121986548590|false|null|false|null|true|not_used|
not_used|not_used|false|false|
#
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For more information about the use of the mwtm export command, see the 
“mwtm export” section on page C-27.

Exporting Current MWTM Node Names and SNMP Community 
Names

To export current MWTM node names and read and write SNMP community 
names, in CiscoWorks import format, with fields separated by commas (,), specify 
the cw keyword:

mwtm export cw

You can export this data to a file, then use the file to import the devices into 
the CiscoWorks database.

For more information about the use of the mwtm export cw command, see the 
“mwtm export cw” section on page C-27.

Viewing RAN Data Export Files
MWTM provides yearly, monthly, daily, and hourly RAN data export files for all 
nodes and interfaces known to MWTM.

To view RAN data files, select RAN Backhaul Utilization from the MWTM 
Server Home Page. This action opens the MWTM - RAN Backhaul Utilization 
Statistics page. Then select a year, month, day, or hour for a specific node. This 
action displays capacity planning and backhaul utilization statistics for the 
selected node and interval.

To export the RAN data, click RAN Data Export from the menu bar of the 
MWTM - RAN Backhaul Utilization Statistics page. This action opens the File 
Download window. Click Open to view the export data or Save to download the 
export file to your computer.
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Using the Windows Start Menu
This section includes the following information:

• Launching the MWTM Client, page 3-51

• Launching the MWTM Event Configurator, page 3-51

• Changing the Default MWTM Server Name, page 3-52

• Changing the Default MWTM Telnet Path, page 3-52

• Launching the MWTM DOS Prompt, page 3-53

• Launching the MWTM SSL Certificate Tool, page 3-53

• Uninstalling MWTM, page 3-53

• Viewing the MWTM README File, page 3-53

Launching the MWTM Client
To launch the MWTM Client, select Start > Programs > Cisco MWTM Client 
> Launch MWTM Client from the Windows Start menu, or double-click the 
MWTM icon on the desktop. MWTM launches the MWTM Client.

Launching the MWTM Event Configurator
To launch the MWTM Event Configurator, select Start > Programs > 
Cisco MWTM Client > Launch MWTM Event Configurator from the 
Windows Start menu. 
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Changing the Default MWTM Server Name
If there is a failure of the IP address or host name to which your MWTM client is 
bound, you can change the default MWTM server name from the Windows Start 
menu.

To change the default MWTM server name, use the following procedure:

Step 1 Close all open MWTM windows.

Step 2 Select Start > Programs > Cisco MWTM Client > 
Modify Default MWTM Server  Name. MWTM opens a DOS window, and asks 
you to enter the name of the new default MWTM server.

Step 3 Type the name of the new default MWTM server, and press Enter. MWTM sets 
the default server to the new name you entered.

See the “Connecting to a New Server” section on page 3-42 for more information 
about changing the default MWTM server name.

Changing the Default MWTM Telnet Path
MWTM provides a default Telnet interface for Telnet sessions, but you can also 
specify a path to a different Telnet application, if you prefer.

To specify the path to the new Telnet application, use the following procedure:

Step 1 Select Start > Programs > Cisco MWTM Client > 
Modify Default MWTM Telnet  Path. MWTM opens a DOS window, and asks 
you to enter the full Telnet executable pathname.

Step 2 Type the new pathname, and press Enter. If you do not enter a new pathname, 
MWTM uses the system default Telnet executable. MWTM asks you to enter any 
special parameters you want to pass to the new Telnet application. The default is 
n, for no special parameters.
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Step 3 Type the special parameters you want to pass to the new Telnet application, and 
press Enter. MWTM uses the new Telnet application for all Telnet sessions on the 
MWTM client, such as when you select View > MWTM Server > Telnet To.

Step 4 Close the DOS window.

Launching the MWTM DOS Prompt
To launch a DOS prompt for MWTM from the Windows Start menu, select Start 
> Programs > Cisco MWTM Client > MWTM DOS Prompt. MWTM opens a 
DOS window, starting in the bin directory:

• If you installed the MWTM client in the default directory, C:\Program Files, 
then the DOS prompt starts at C:\Program Files\SGMClient\bin.

• If you installed the MWTM client in a different directory, then the bin 
directory is located in that directory.

Launching the MWTM SSL Certificate Tool
To launch the MWTM SSL Certificate Tool from the Windows Start menu, select 
Start > Programs > Cisco MWTM Client > MWTM SSL Certificate Tool.

Uninstalling MWTM
You can uninstall MWTM from the Windows Start menu. For details, see the 
“Uninstalling MWTM” section of the Cisco Mobile Wireless Transport Manager 
Installation Guide.

Viewing the MWTM README File
The MWTM README file contains late-breaking information about MWTM 
that might not be found in the other product documentation. To open the MWTM 
README file from the Windows Start menu, select Start > Programs > 
Cisco MWTM Client > View README.
3-53
Cisco Mobile Wireless Transport Manager User Guide

OL-7637-01



 

Chapter 3      Getting Started with MWTM
Using the MWTM Command Line Interface
Using the MWTM Command Line Interface
MWTM provides a command line interface that enables you to interact with the 
MWTM and with the Cisco IOS software operating system by entering commands 
and optional arguments. For more information, see the “MWTM Command 
Reference” section on page C-1.

Running Simultaneous MWTM Sessions
MWTM uses a client/server architecture that allows you to run multiple sessions 
of the MWTM client simultaneously. Central services and database functions are 
provided on an MWTM server that communicates with multiple MWTM clients. 
You can install the MWTM client software on the same system as the MWTM 
server, or on a different system on the same network as the MWTM server.

Note Running more than one MWTM client on the same workstation can degrade the 
workstation’s performance.

MWTM recommends a maximum of 20 clients per MWTM server. If you connect 
more than 20 clients to a single server, the server requires additional memory and 
a more powerful CPU.

Exiting the MWTM Client
When you are finished monitoring network performance statistics, you can exit 
the MWTM client using the following procedure:

Step 1 From the MWTM Main Menu, select File > Exit. The Exit MWTM confirmation 
window is displayed.

Step 2 Click Yes to close the MWTM client application.
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Working with Views

When MWTM discovers your network, all discovered objects are placed in a 
DEFAULT configuration view, which is stored on the MWTM server and shared 
by all MWTM clients. The DEFAULT view that is stored on the MWTM server 
cannot be modified by the clients. It is always available, for users who need to 
view the entire network.

Initially, all clients use the DEFAULT view. However, MWTM enables you to 
create your own, client-specific views, which are subsets of the DEFAULT view, 
to meet your individual needs.

You can choose the nodes you are interested in managing, remove all other nodes 
from your view, and change the layout of the topology map in the Topology 
Window. You can save all of this customized information in a view, set that view 
as the default view for the MWTM client, and use the MWTM client from then on 
to manage only the part of the network you are interested in, with the settings you 
prefer. As soon as you modify the DEFAULT view in any way (except modifying 
the layout of the topology map in the Topology Window), MWTM prompts you 
to name the new, custom view.

You can also create many different views on a given MWTM client, with each 
view devoted to a different aspect of the network. You can then switch between 
views to manage different parts of the network, or switch to the DEFAULT view 
to see the entire network. For details on creating views, see Creating a New View, 
page 4-42.

If a given MWTM client is used by more than one person, each user can create his 
or her own personal view.
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To help you keep track of which view you are currently using, as well as other 
important information, most MWTM windows display the following information:

• In the title bar, the name of the system on which the MWTM server is running.

• Across the bottom of the window:

– A “locked padlock” symbol if the MWTM server has a security 
certificate. To see the certificate, click the symbol.

An “unlocked padlock” symbol if the MWTM server does not have a 
security certificate.

– The number of objects currently displayed in the window, if any.

– The number of files currently displayed in the load or save files dialog, 
if any.

– Status messages, as appropriate.

Informational messages, such as “Discovery running”, are displayed in 
black.

Messages that indicate successful actions, such as “View Saved”, are 
displayed in green.

Error messages, such as “Node does not have a note”, are displayed in 
red.

There are many fields in MWTM that enable you to enter information, 
such as a new node name or IP address. If you enter an incorrect value in 
the field, such as an IP address that contains letters or is too long, MWTM 
beeps and retains the current value of the field. Check the message bar at 
the bottom of the window for information and assistance.

– The text (Modified), if the view has been modified but not yet saved. You 
must save the view if you want to save your changes. See the “Working 
with Views” section on page 4-1 for more details.
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– A “New!” icon, if there is at least one newly discovered node in the 
network that has not been added to your current view. To add the node to 
your current view, see the “Viewing the Topology of the Network” 
section on page 8-1. To exclude the node from your current view, see the 
“Working with Views” section on page 4-1.

Clicking the “New!” icon in the Topology Window opens the New 
Objects panel in the left pane. Clicking the “New!” icon in any other 
window opens the Edit View tab of the View Editor Window.

– The name of the current view.

– The name of the current user, or the name of the device the user is using.

– If you have implemented MWTM User-Based Access, the authentication 
level of the user.

If your personal default view has been deleted, then the next time you launch the 
client MWTM informs you that your default view has been deleted and that your 
view has been reset to the DEFAULT view. To choose another view as your default 
view, use the Load File Dialog: View List. See the “Loading a Client-Specific 
View” section on page 4-53 for details.

This section includes the following information:

• Viewing Basic Information for Views, page 4-4

• Viewing Detailed Information for a View, page 4-12

• Editing a View, page 4-34

• Saving a View, page 4-38

• Viewing Notes for a View, page 4-41

• Creating a New View, page 4-42

• Loading the DEFAULT View, page 4-53

• Loading a Client-Specific View, page 4-53

• Ignoring a View, page 4-55

• Viewing Ignored Views, page 4-56
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Viewing Basic Information for Views
Related Topics:

• Discovery Overview, page 2-1

• Changing MWTM Client Preference Settings, page 11-3

• Changing the Message Display, page 11-34

• Viewing the Topology of the Network, page 8-1

Viewing Basic Information for Views
To view basic information for views, select Views in the left pane of the MWTM 
Main Window. MWTM displays the View Statistics Window (Figure 4-1).

Figure 4-1 View Statistics Window

The View Statistics Window provides information about all views that have been 
defined for this MWTM client, including their status and other important 
information.

The View Statistics Window is composed of the following sections:

• Right-Click Menu for All Views, page 4-5

• Right-Click Menu for a Specific View, page 4-6

• View Table, page 4-8
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Viewing Basic Information for Views
Related Topics:

• Viewing Detailed Information for a View, page 4-12

• Changing MWTM Client Preference Settings, page 11-3

• Resizing, Sorting, and Hiding Table Columns, page 3-37

• Using the MWTM Main Menu, page 3-9

• Viewing Notes for a View, page 4-41

Right-Click Menu for All Views
To see the right-click menu for all views, select Views in the left pane and click 
the right mouse button. The views right-click menu provides the following 
options:

Menu Command Description

Show In New Window Opens the View Statistics Window in a new window.

Sort Tree By Status Sorts the entire tree in the left pane by the status of each object.

Sort Tree By Name Sorts the entire tree in the left pane by the name of each object.

Back > List of Windows Navigates back to a window viewed in this session.

MWTM maintains a list of up to 10 Back windows.

Forward > List of 
Windows

Navigates forward to a window viewed in this session.

MWTM maintains a list of up to 10 Forward windows.
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Viewing Basic Information for Views
Right-Click Menu for a Specific View
The View Statistics Window provides a subset of the MWTM Main Menu as a 
right-click menu. To see this menu, select a view and click the right mouse button. 
The view right-click menu provides the following options:

Menu Command Description

Show In New Window Opens the View Details Window for the selected view in a new window.

Edit > Properties Opens the Edit Properties Dialog for the selected view.

If you have implemented MWTM User-Based Access, this option is 
available to users with authentication level Power User (Level 2) and 
higher.

Edit > Notes Opens the Edit Notes Dialog for the selected view.

If you have implemented MWTM User-Based Access, this option is 
available to users with authentication level Power User (Level 2) and 
higher.

Clear Event Icon Deletes the event icon (orange triangle) from MWTM displays for the 
selected view, for this MWTM client only. The actual events are not 
deleted from MWTM, only the event icon for the selected view for this 
MWTM client.

This option is grayed-out if the selected view has no associated event icon.
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Delete Deletes the currently selected view from the MWTM database. MWTM 
displays the Confirm Deletion dialog:

• To delete the selected view, click Yes. The view is deleted from the 
MWTM database and the Confirm Deletion dialog is closed.

• To retain the selected view, click No. The view is kept in the MWTM 
database and the Confirm Deletion dialog is closed.

• To prevent MWTM from displaying the Confirm Deletion dialog, 
select the Do not show this again checkbox.

Note If you select the Do not show this again checkbox, and you later 
decide you want MWTM to begin displaying the Confirm Deletion 
dialog again, you must select the Confirm Deletions checkbox in 
the General GUI settings in the Preferences window. For more 
information, see the description of the Confirm Deletions 
checkbox in the “Startup/Exit Settings” section on page 11-7.

If you have implemented MWTM User-Based Access, this option is 
available to users with authentication level Network Administrator (Level 
4) and higher.

Back > List of Windows Navigates back to a window viewed in this session.

MWTM maintains a list of up to 10 Back windows.

Forward > List of 
Windows

Navigates forward to a window viewed in this session.

MWTM maintains a list of up to 10 Forward windows.

View > Components Displays the Components panel for the selected view.

If there are no components associated with the selected view, this option 
is grayed-out.

View > Configuration 
Details

Displays the Configuration Data panel for the selected view.

View > Notes Displays the Notes panel for the selected view.

If there are no notes associated with the selected view, this option is 
grayed-out.

View > Events Displays the Recent Events panel for the selected application server 
process and its associated linksets and links.

Menu Command Description
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Viewing Basic Information for Views
View Table
The view table displays information about the views that have been defined for 
this MWTM client.

To see mouse over help popup for each column in the table, place the cursor over 
a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the 
full data in a mouse over help popup.

You can resize each column, or sort the table based on the information in one of 
the columns. By default, this table is sorted by Status, and MWTM displays all 
of the columns in the view table except Internal ID and Last Status Change.

• To display hidden columns, right-click in the table header and select the 
checkboxes for the columns you want to display.

• To hide columns, right-click in the table header and clear the checkboxes for 
the columns you want to hide.

See the “Resizing, Sorting, and Hiding Table Columns” section on page 3-37 for 
more information about resizing, sorting, displaying, or hiding columns.

The view table contains the following columns:

View > Center in Topo Opens the Topology Window, with the display zoomed to center on the 
selected view.

If more than one view contains the selected view, MWTM prompts you to 
choose one of the views.

View > Open in Topo Opens the selected view in the Topology Window.

Ignore Ignores the selected view at the next polling cycle.

If you have implemented MWTM User-Based Access, this option is 
available to users with authentication level Power User (Level 2) and 
higher.

Unignore Stops ignoring the selected view at the next polling cycle.

If you have implemented MWTM User-Based Access, this option is 
available to users with authentication level Power User (Level 2) and 
higher.

Menu Command Description
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Column Description

Internal ID Internal ID of the view. The internal ID is a unique ID for every object, 
assigned by MWTM for its own internal use. It can also be useful when the 
TAC is debugging problems.

Name Name of the view.

Subviews Number of subviews in the view.

Nodes Number of nodes in the view.

Ignored Indicates whether the view is to be included when aggregating and 
displaying MWTM status information:

• Clear the checkbox to include the view. This is the default setting.

• Select the checkbox to exclude the view.

This field can be edited by users with authentication level Power User 
(Level 2) and higher.

Notes Indicates whether there is a note associated with the view.
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Events Indicates whether there is a recent event associated with a network object in 
the view. (Even if the server purges all of the events associated with objects 
in the view, MWTM continues to display the event icon in this field.)

• To delete the event icon (orange triangle) from MWTM displays for a 
specific view, select the view and click the icon.

• To delete the event icon from MWTM displays for all views, select Edit 
> Clear All Events from the MWTM Main Menu.

Note During Discovery, MWTM might flag most views with an event 
icon. If the event icons are too distracting, use the Edit > Clear All 
Events menu option to remove them.

Changing a view (for example, by ignoring it or attaching a note to 
it) does not generate an event, and therefore does not cause an event 
icon to be displayed in this field.

Deleting an application server process, node, or signaling point with 
the Delete menu option does not generate an event, and therefore 
does not cause an event icon to be displayed in this field. However, 
if MWTM rediscovers a deleted application server process, node, or 
signaling point, events are generated and logged for both the deletion 
and the rediscovery, and the event icon is then displayed in this field.

Last Status Change Date and time that the status of the view last changed.

Column Description
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Status Current status of the view. Possible values are:

Active (green)

Unmanaged (gray)

Warning (yellow)

For detailed definitions of each status, see the “Status Definitions for Views” 
section on page A-6.

Status Reason Reason for the current status of the view.

For a full list of possible reasons, see the stateReasons.html file:

• If you installed MWTM in the default directory, /opt, then the file is 
located at /opt/CSCOsgm/apache/share/htdocs/eventHelp directory.

• If you installed MWTM in a different directory, then the help directory 
and file are located in that directory.

If the cell is too small to show all of the status reason, place the cursor over 
the cell to see the full status reason in a mouse over help popup.

The status reasons are listed in order of decreasing magnitude. If two or more 
reasons apply, the reason of greatest magnitude is displayed.

If the status reason is Unsupported Configuration, correct the 
configuration and enter the mwtm cleandiscover command to delete all 
current network data and begin a clean discovery of the RAN-O network. If 
the status reason is still Unsupported Configuration, enter the mwtm clean 
command to restore the MWTM server to a “clean” state, such as would exist 
after a new installation of MWTM. For more information on the use of these 
commands, see the “MWTM Command Reference” section on page C-1.

Column Description
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Viewing Detailed Information for a View
MWTM can display detailed information about a selected view, including its 
associated objects, status, and other information.

Updates for the view that are received from the MWTM server are reflected 
automatically in this window.

To display detailed information for a view, use one of the following procedures:

• Select Views in the left pane of the MWTM Main Window, right-click a view 
in the right pane, then select View > Configuration Details in the right-click 
menu.

• Select the turner beside Views in the left pane of the MWTM Main Window, 
then select a view.

MWTM displays the View Details Window (Figure 4-2).

Figure 4-2 View Details Window

The View Details Window is composed of the following sections:

• View Details: Right-Click Menu, page 4-13

• View Details: Components, page 4-15

• View Details: Configuration Data, page 4-22

• View Details: Notes, page 4-26
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• View Details: Recent Events, page 4-26

• View Details: Alarms, page 4-31

Related Topics:

• Viewing Basic Information for Views, page 4-4

View Details: Right-Click Menu
The View Details Window provides a right-click menu. To see this menu for a 
view, select a view in the left pane and click the right mouse button. The node 
details right-click menu provides the following options:

Menu Command Description

Show In New Window Opens the View Details Window for the selected view in a 
new window.

Edit > Properties Opens the Edit Properties Dialog for the selected view.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level Power 
User (Level 2) and higher.

Edit > Notes Opens the Edit Notes Dialog for the selected view.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level Power 
User (Level 2) and higher.

Clear Event Icon Deletes the event icon (orange triangle) from MWTM 
displays for the selected view, for this MWTM client only. 
The actual events are not deleted from MWTM, only the 
event icon for the selected view for this MWTM client.

This option is grayed-out if the selected view has no 
associated event icon.
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Delete Deletes the currently selected view from the MWTM 
database. MWTM displays the Confirm Deletion dialog:

• To delete the selected view, click Yes. The view is 
deleted from the MWTM database and the Confirm 
Deletion dialog is closed.

• To retain the selected view, click No. The view is kept 
in the MWTM database and the Confirm Deletion 
dialog is closed.

• To prevent MWTM from displaying the Confirm 
Deletion dialog, select the Do not show this again 
checkbox.

Note If you select the Do not show this again checkbox, 
and you later decide you want MWTM to begin 
displaying the Confirm Deletion dialog again, you 
must select the Confirm Deletions checkbox in the 
General GUI settings in the Preferences window. 
For more information, see the description of the 
Confirm Deletions checkbox in the “Startup/Exit 
Settings” section on page 11-7.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level 
Network Administrator (Level 4) and higher.

Back > List of Windows Navigates back to a window viewed in this session.

MWTM maintains a list of up to 10 Back windows.

Forward > List of Windows Navigates forward to a window viewed in this session.

MWTM maintains a list of up to 10 Forward windows.

View > Components Displays the Components panel for the selected view.

If there are no components associated with the selected 
view, this option is grayed-out.

View > Configuration Details Displays the Configuration Data panel for the selected 
view.

Menu Command Description
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View Details: Components
The View Details: Components section is composed of the following 
sub-sections:

• Subviews, page 4-16

• Nodes, page 4-18

Note If the view does not contain any objects of a given type, MWTM does not display 
that tab. 

View > Notes Displays the Notes panel for the selected view.

If there are no notes associated with the selected view, this 
option is grayed-out.

View > Events Displays the Recent Events panel for the selected 
application server process and its associated linksets and 
links.

View > Center in Topo Opens the Topology Window, with the display zoomed to 
center on the selected view.

If more than one view contains the selected view, MWTM 
prompts you to choose one of the views.

View > Open in Topo Opens the selected view in the Topology Window.

Ignore Ignores the selected view at the next polling cycle.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level Power 
User (Level 2) and higher.

Unignore Stops ignoring the selected view at the next polling cycle.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level Power 
User (Level 2) and higher.

Menu Command Description
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Subviews

The subview table displays information about the subviews that have been defined 
for this MWTM client. 

Note Subviews are created within the View Editor window, using the Edit > Create 
Subview menu option (for details, see Creating a New View, page 4-42). 

To see mouse over help popup for each column in the table, place the cursor over 
a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the 
full data in a mouse over help popup.

You can resize each column, or sort the table based on the information in one of 
the columns. By default, this table is sorted by Status, and MWTM displays all 
of the columns in the subview table.

• To display hidden columns, right-click in the table header and select the 
checkboxes for the columns you want to display.

• To hide columns, right-click in the table header and clear the checkboxes for 
the columns you want to hide.

See the “Resizing, Sorting, and Hiding Table Columns” section on page 3-37 for 
more information about resizing, sorting, displaying, or hiding columns.

The subview table contains the following columns:

Column Description

Internal ID Internal ID of the subview. The internal ID is a unique ID for every object, 
assigned by MWTM for its own internal use. It can also be useful when the 
TAC is debugging problems.

Name Name of the subview.

Subviews Number of subviews in the subview.

Nodes Number of nodes in the subview.
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Ignored Indicates whether the subview is to be included when aggregating and 
displaying MWTM status information:

• Clear the checkbox to include the subview. This is the default setting.

• Select the checkbox to exclude the subview.

This field can be edited by users with authentication level Power User 
(Level 2) and higher.

Notes Indicates whether there is a note associated with the subview.

Events Indicates whether there is a recent event associated with a network object in 
the subview. (Even if the server purges all of the events associated with 
objects in the subview, MWTM continues to display the event icon in this 
field.)

• To delete the event icon (orange triangle) from MWTM displays for a 
specific subview, select the subview and click the icon.

• To delete the event icon from MWTM displays for all subviews, select 
Edit > Clear All Events from the MWTM Main Menu.

Note During Discovery, MWTM might flag most subviews with an event 
icon. If the event icons are too distracting, use the Edit > Clear All 
Events menu option to remove them.

Changing a subview (for example, by ignoring it or attaching a note 
to it) does not generate an event, and therefore does not cause an 
event icon to be displayed in this field.

Deleting an application server process, node, or signaling point with 
the Delete menu option does not generate an event, and therefore 
does not cause an event icon to be displayed in this field. However, 
if MWTM rediscovers a deleted application server process, node, or 
signaling point, events are generated and logged for both the deletion 
and the rediscovery, and the event icon is then displayed in this field.

Last Status Change Date and time that the status of the subview last changed.

Column Description
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Nodes

The node table displays information about the nodes that are associated with the 
selected view.

To see mouse over help popup for each column in the table, place the cursor over 
a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the 
full data in a mouse over help popup.

Status Current status of the subview. Possible values are:

Active (green)

Unmanaged (gray)

Warning (yellow)

For detailed definitions of each status, see the “Status Definitions for Views” 
section on page A-6.

Status Reason Reason for the current status of the subview.

For a full list of possible reasons, see the stateReasons.html file:

• If you installed MWTM in the default directory, /opt, then the file is 
located at /opt/CSCOsgm/apache/share/htdocs/eventHelp directory.

• If you installed MWTM in a different directory, then the help directory 
and file are located in that directory.

If the cell is too small to show all of the status reason, place the cursor over 
the cell to see the full status reason in a mouse over help popup.

The status reasons are listed in order of decreasing magnitude. If two or more 
reasons apply, the reason of greatest magnitude is displayed.

If the status reason is Unsupported Configuration, correct the 
configuration and enter the mwtm cleandiscover command to delete all 
current network data and begin a clean discovery of the RAN-O network. If 
the status reason is still Unsupported Configuration, enter the mwtm clean 
command to restore the MWTM server to a “clean” state, such as would exist 
after a new installation of MWTM. For more information on the use of these 
commands, see the “MWTM Command Reference” section on page C-1.

Column Description
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You can resize each column, or sort the table based on the information in one of 
the columns. By default, this table is sorted by Status, and MWTM displays all 
of the columns in the node table except Internal ID, Router Uptime, Reboot 
Reason, and Last Status Change.

• To display hidden columns, right-click in the table header and select the 
checkboxes for the columns you want to display.

• To hide columns, right-click in the table header and clear the checkboxes for 
the columns you want to hide.

See the “Resizing, Sorting, and Hiding Table Columns” section on page 3-37 for 
more information about resizing, sorting, displaying, or hiding columns.

The node table contains the following columns:

Column Description

Internal ID Internal ID of the node. The internal ID is a unique ID for every object, 
assigned by MWTM for its own internal use. It can also be useful when the 
TAC is debugging problems.

Name Name of the node.

Primary SNMP 
Address

IP address of the node, used by SNMP to poll the node. (There might be other 
IP addresses on the node that are not the primary SNMP address.)

Device Type Device type of the node. Possible values are:

• CiscoMWR-1941-DC-A—Cisco MWR-1941-DC-A series router

• RNC—Radio Network Controller

• BSC—Base Station Controller

• BTS—Base Transceiver Station

• Node B—The radio transmission/reception unit for communication 
between radio cells

• IPDevice—IP device, other than those listed above. You can assign this 
icon to an unknown node if you know that it is an IP device.

• Unknown—MWTM is unable to determine the device type.

IOS MIB Level MIB conformance level used by the RAN-O device, such as GSM RAN.

Router Uptime Time the router has been up, in days, hours, minutes, and seconds.

Reboot Reason Reason for the last reboot of the router device.
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Ignored Indicates whether the node is to be included when aggregating and 
displaying MWTM status information:

• Clear the checkbox to include the node. This is the default setting.

• Select the checkbox to exclude the node.

This field can be edited by users with authentication level Power User 
(Level 2) and higher.

Process Traps Indicates whether MWTM is to process traps from this node:

• Select the checkbox if you want MWTM to process traps from this node. 
This is the default setting.

• Clear the checkbox if you do not want MWTM to process traps from this 
node.

This field can be edited by users with authentication level Power User 
(Level 4) and higher.

Notes Indicates whether there is a note associated with the node.

Events Indicates whether there is a recent event associated with the node. (Even if 
the server purges all of the events associated with the node, MWTM 
continues to display the event icon in this field.)

• To delete the event icon (orange triangle) from MWTM displays for a 
specific node, select the node and click the icon.

• To delete the event icon from MWTM displays for all nodes, select Edit 
> Clear All Events from the MWTM Main Menu.

Note During Discovery, MWTM might flag most nodes with an event 
icon. If the event icons are too distracting, use the Edit > Clear All 
Events menu option to remove them.

Last Status Change Date and time that the status of the node last changed.

Column Description
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Status Current status of the node. Possible values are:

Active (green)

Discovering (cyan)

Polling (cyan)

Unknown (red)

Unmanaged (gray)

Waiting (gray)

Warning (yellow)

For detailed definitions of each status, see the “Status Definitions for Nodes” 
section on page A-5.

Status Reason Reason for the current status of the node.

For a full list of possible reasons, see the stateReasons.html file:

• If you installed MWTM in the default directory, /opt, then the file is 
located at /opt/CSCOsgm/apache/share/htdocs/eventHelp directory.

• If you installed MWTM in a different directory, then the help directory 
and file are located in that directory.

If the cell is too small to show all of the status reason, place the cursor over 
the cell to see the full status reason in a mouse over help popup.

The status reasons are listed in order of decreasing magnitude. If two or more 
reasons apply, the reason of greatest magnitude is displayed.

If the status reason is Unsupported Configuration, correct the 
configuration and enter the mwtm cleandiscover command to delete all 
current network data and begin a clean discovery of the RAN-O network. If 
the status reason is still Unsupported Configuration, enter the mwtm clean 
command to restore the MWTM server to a “clean” state, such as would exist 
after a new installation of MWTM. For more information on the use of these 
commands, see the “MWTM Command Reference” section on page C-1.

Column Description
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View Details: Configuration Data
The View Details: Configuration Data section is composed of the following 
sub-sections:

• Naming Information, page 4-22

• Status Information, page 4-23

Naming Information

The Naming Information sub-section contains the following fields:

Field Description

Name Name of the view.

Is Ignored Indicates whether the view is Ignored (that is, whether the view is to be included 
when aggregating and displaying MWTM status information).

Last Status 
Change

Date and time that the status of the view last changed.
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Status Information

The Status Information table provides basic summary information about network 
objects in this view that have been discovered by MWTM.

To see mouse over help popup for each column in the table, place the cursor over 
a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the 
full data in a mouse over help popup.

Status Current status of the view. Possible values are:

Active (green)

Unmanaged (gray)

Warning (yellow)

For detailed definitions of each status, see the “Status Definitions for Views” 
section on page A-6.

Status Reason Reason for the current status of the view.

For a full list of possible reasons, see the stateReasons.html file:

• If you installed MWTM in the default directory, /opt, then the file is located at 
/opt/CSCOsgm/apache/share/htdocs/eventHelp directory.

• If you installed MWTM in a different directory, then the help directory and file 
are located in that directory.

If the cell is too small to show all of the status reason, place the cursor over the cell 
to see the full status reason in a mouse over help popup.

The status reasons are listed in order of decreasing magnitude. If two or more 
reasons apply, the reason of greatest magnitude is displayed.

If the status reason is Unsupported Configuration, correct the configuration and 
enter the mwtm cleandiscover command to delete all current network data and 
begin a clean discovery of the RAN-O network. If the status reason is still 
Unsupported Configuration, enter the mwtm clean command to restore the 
MWTM server to a “clean” state, such as would exist after a new installation of 
MWTM. For more information on the use of these commands, see the “MWTM 
Command Reference” section on page C-1.

Field Description
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You can resize each column, or sort the table based on the information in one of 
the columns. By default, this table is sorted by Status, and MWTM displays all 
of the columns in the Status Information table except Linksets and Links.

• To display hidden columns, right-click in the table header and select the 
checkboxes for the columns you want to display.

• To hide columns, right-click in the table header and clear the checkboxes for 
the columns you want to hide.

See the “Resizing, Sorting, and Hiding Table Columns” section on page 3-37 for 
more information about resizing, sorting, displaying, or hiding columns.

The Status Information table contains the following columns:
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Column Description

Status Current status of the network objects. Possible values are:

Unknown (red)

Unavailable (red)

Inactive (red)

Failed (red)

Down (red)

Blocked (red)

Pending (red)

Warning (yellow)

Shutdown (blue)

InhibitLoc (blue)

InhibitRem (blue)

Discovering (cyan)

Polling (cyan)

Waiting (gray)

Unmanaged (gray)

Active (green)

For detailed definitions of each status for each type of network object, see 
the “MWTM Status Definitions” section on page A-1.

Total Total number of discovered objects with the indicated status.

Nodes Total number of discovered nodes with the indicated status.
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View Details: Notes
The View Details: Notes section displays:

• Notes associated with the view.

• The date and time the notes associated with the view were last updated, or the 
phrase Not Set if there are no notes associated with the view.

• The phrase No Notes if there are no notes associated with the view.

Related Topics:

• Attaching a Note to a View, page 4-37

• Viewing Notes for a View, page 4-41

View Details: Recent Events
The View Details: Recent Events table displays about all recent events associated 
with the view, and enables you to perform event-related tasks, such as setting 
filters and acknowledging events.

To see mouse over help popup for each column in the table, place the cursor over 
a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the 
full data in a mouse over help popup.

You can resize each column, or sort the table based on the information in one of 
the columns. By default, MWTM displays all of the columns in the table except 
Internal ID, Note, Message Name, Ack By, Ack Time, and Node.

• To display hidden columns, right-click in the table header and select the 
checkboxes for the columns you want to display.

• To hide columns, right-click in the table header and clear the checkboxes for 
the columns you want to hide.

See the “Resizing, Sorting, and Hiding Table Columns” section on page 3-37 for 
more information about resizing, sorting, displaying, or hiding columns.

The View Details: Recent Events table contains the following toolbar buttons and 
columns:
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Toolbar Button or Column Description

Set Filter Opens the Event Filter dialog.

Apply Filter

or

Remove Filter

Activates and deactivates the event filter specified in the Event Filter 
dialog:

• If the filter is activated, MWTM displays only those events that pass 
the filter.

• If the filter is deactivated, MWTM displays all events.

• If you activate a filter in an object’s Recent Events table in the 
MWTM Main Window, the filter is activated in all Recent Events 
tables in the MWTM Main Window for all other objects. The filter 
is not activated in Recent Events tables in Show In New Window 
windows or Real-Time Data and Charts windows.

Pause

or

Resume

Pauses or resumes the table.

While the table is paused, MWTM does not display new events in the 
table (unless you apply an event filter or edit your event preferences). 
When the table is resumed, all new events since the table was paused are 
added to the display.

If events are deleted while the table is paused, they are not removed from 
the table. Instead, they are grayed-out and cannot be acknowledged or 
edited. Deleted events are removed from the table when you resume the 
table.

Acknowledge Makes the selected event or events acknowledged.

Unacknowledge Makes the selected event or events unacknowledged.

Event Properties Opens the Event Properties window.

Edit Notes Opens the Edit Event Dialog.

Time Difference Displays the difference in days, minutes, hours, and seconds between 
two events.

Find Finds specific text in the event table.

Create Sound Filter Opens the Event Sound Filters dialog and the Event Sound Filters List 
dialog, with fields populated based on the selected event.
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Adjust Row Height Adjusts the table row height and wraps the message text as follows:

• Click once to double the row height and wrap the message text.

• Click again to triple the row height and wrap the message text.

• Click again for single row height and no message text wrapping. 
This is the default setting.

This setting is saved automatically with your preferences.

Help for Event Displays context-sensitive help for the selected event in a separate Web 
browser.

Internal ID Internal ID of the event. The internal ID is a unique ID for every object, 
assigned by MWTM for its own internal use. It can also be useful when 
the TAC is debugging problems.

Ack Indicates whether the event has been acknowledged:

• To acknowledge an unacknowledged event, use the Acknowledge 
toolbar button.

• To make a previously acknowledged event unacknowledged, use the 
Unacknowledge toolbar button.

Toolbar Button or Column Description
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Category Type of the event. Default values are:

• Create—Creation event, such as the creation of a seed file.

• Delete—Deletion event, such as the deletion of an object or file.

• Discover—Discovery event, such as Discovery beginning.

• Edit—Edit event. A user has edited an object.

• Ignore—Ignore event. A user has Ignored a link or linkset.

• Login—Login event. A user has logged in to MWTM.

• LoginDisable—LoginDisable event. MWTM has disabled a user’s 
User-Based Access authentication as a result of too many failed 
attempts to log in to MWTM.

• LoginFail—LoginFail event. An attempt by a user to log in to 
MWTM has failed.

• Logout—Logout event. A user has logged out of MWTM.

• OverWrite—OverWrite event. An existing file, such as a seed file 
or route file, has been overwritten.

• Poll—Poll event, such as an SNMP poll.

• Purge—Purge event. A user has requested Discovery with Delete 
Existing Data selected, and MWTM has deleted the existing 
MWTM database.

• Status—Status change message generated.

• Trap—SNMP trap message generated.

You can customize this field. See the “Changing Event Categories” 
section on page 5-34 for more information.

Toolbar Button or Column Description
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Severity Severity of the event. Default values are:

• Critical—The default color is red.

• Indeterminate—The default color is aqua.

• Informational—The default color is white.

• Major—The default color is orange.

• Minor—The default color is yellow.

• Normal—The default color is green.

• Warning—The default color is blue.

You can customize this field. See the “Changing Event Severities and 
Colors” section on page 5-35 for more information.

Note Indicates whether there is a note associated with the event.

Time Date and time the event was logged.

Message Name User-specified message name for the event, used by MWTM for trap 
forwarding. The default message name is MWTM.

For more information about user-specified message names and trap 
forwarding, see the “Forwarding Events as Traps to Other Hosts” section 
on page 5-50.

Ack By If you have not implemented MWTM User-Based Access, name of the 
device that last acknowledged the event.

If you have implemented MWTM User-Based Access, name of the user 
who last acknowledged the event.

If no one has acknowledged the event, this field is blank.

Ack Time Date and time the event was last acknowledged or unacknowledged.

Node Name of the node associated with the event. If there is no node 
associated with the event, None is displayed.

Message Text of the message.

You can customize this field. See the “Changing the Way MWTM 
Processes Events” section on page 5-26 for more information.

Toolbar Button or Column Description
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View Details: Alarms
The View Details: Alarms table provides basic information about all currently 
active alarms in your network, that are not excluded from your current view. 
MWTM updates the information in the window at least once every minute.

To see mouse over help popup for each column in the table, place the cursor over 
a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the 
full data in a mouse over help popup.

You can resize each column, or sort the table based on the information in one of 
the columns. By default, this table is sorted by Age, with the most recent alarms 
at the top, and MWTM displays all of the columns in the table except Last Status 
Change.

• To display hidden columns, right-click in the table header and select the 
checkboxes for the columns you want to display.

• To hide columns, right-click in the table header and clear the checkboxes for 
the columns you want to hide.

See the “Resizing, Sorting, and Hiding Table Columns” section on page 3-37 for 
more information about resizing, sorting, displaying, or hiding columns.

The active alarms table contains the following columns:

Column Description

Type Type of network object associated with the selected alarm.

To see all higher-level alarms associated with the network object, select the 
turner beside the object. MWTM displays the higher-level alarms below the 
selected alarm. For example, if you select the turner beside a link, MWTM 
displays the alarms for the linkset, signaling point, and node associated with 
that link.

Name Name of the network object associated with the selected alarm.
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Status Current status of the network object associated with the selected alarm. 
Possible values are:

Unknown (red)

Unavailable (red)

Inactive (red)

Failed (red)

Down (red)

Blocked (red)

Pending (red)

Warning (yellow)

Shutdown (blue)

InhibitLoc (blue)

InhibitRem (blue)

Discovering (cyan)

Polling (cyan)

Waiting (gray)

Unmanaged (gray)

Active (green)

For detailed definitions of each status for each type of network object, see 
the “MWTM Status Definitions” section on page A-1.

Column Description
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Status Reason Reason for the current status of the network object associated with the 
selected alarm.

For a full list of possible reasons, see the stateReasons.html file:

• If you installed MWTM in the default directory, /opt, then the file is 
located at /opt/CSCOsgm/apache/share/htdocs/eventHelp directory.

• If you installed MWTM in a different directory, then the help directory 
and file are located in that directory.

If the cell is too small to show all of the status reason, place the cursor over 
the cell to see the full status reason in a mouse over help popup.

The status reasons are listed in order of decreasing magnitude. If two or more 
reasons apply, the reason of greatest magnitude is displayed.

If the status reason is Unsupported Configuration, correct the 
configuration and enter the mwtm cleandiscover command to delete all 
current network data and begin a clean discovery of the RAN-O network. If 
the status reason is still Unsupported Configuration, enter the mwtm clean 
command to restore the MWTM server to a “clean” state, such as would exist 
after a new installation of MWTM. For more information on the use of these 
commands, see the “MWTM Command Reference” section on page C-1.

Last Status Change Date and time that the status of the network object associated with the 
selected alarm last changed.

Age Age of the selected alarm, in days, hours, and minutes.

Column Description
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The active alarms table provides a subset of the MWTM Main Menu as a 
right-click menu. To see this menu, select an alarm and click the right mouse 
button. The alarm right-click menu provides the same options as the right-click 
menu for the associated network object, plus the following additional options:

Caution The alarms displayed in the active alarms table are the actual network objects in 
MWTM. Options you select in the right-click menu affect the object in MWTM. 
For example, if you delete a node in the active alarms table, you delete that node 
from the MWTM database.

Editing a View
MWTM enables you to edit the following aspects of a view:

• Editing View Properties, page 4-34

• Attaching a Note to a View, page 4-37

Editing View Properties
MWTM enables you to change the name and icon name associated with a view.

To edit a view’s properties, right-click the view in a window, then select Edit > 
Properties in the right-click menu. MWTM displays the Edit Properties Dialog 
for a View (Figure 4-3).

Menu Command Description

Expand All Displays all higher-level alarms associated with all network objects in the active 
alarms table.

Collapse All Does not display higher-level alarms in the active alarms table.
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Figure 4-3 Edit Properties Dialog for a View

The Edit Properties Dialog contains the following fields and buttons:

Field or Button Description

Name Name of the view.

You can also use this field to specify a new, more meaningful name for the view. 
The new name can be from 1 to 30 characters, and can contain any letters, 
numbers, or special characters.

When you click Save, all MWTM windows are updated automatically to reflect 
the new name.

Icon Name Name of the graphic icon to assign to this view in topology maps. MWTM 
automatically assigns an appropriate icon to each discovered Cisco device, and 
to Unknown nodes, but you can use this field to assign a different icon.

Valid values for RAN-O networks include:

• BSC—Base Station Controller

• BTS—Base Transceiver Station

• Building—Icon representing a collection of objects within a building

• CiscoMWR1900—Cisco Mobile Wireless Router 1900
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Related Topics:

• Editing a View, page 4-34

• Viewing Notes for a View, page 4-41

Icon Name
(continued)

• City—Icon representing a collection of objects within a city

• Cloud—Collection of objects, called a submap. A submap can also contain 
other submaps.

• Database—Icon representing a database object

• IPDevice—IP device, other than those listed above

• MSC—Mobile switching center

• Node-B—Radio transmission/reception unit for communication between 
radio cells in UMTS network

• RNC—Radio Network Controller used in UMTS network

• Tower—Icon representing a PC tower

• TrafficGenerator—Icon representing a device or emulator used to generate 
traffic, usually in a test environment

• Unknown—MWTM is unable to determine the node or signaling point type.

• Workstation—Icon representing a workstation

• Workstation2—Icon representing a different workstation

When you click Save, the Topology Window is updated automatically to reflect 
the new icon.

Save Saves changes you have made to the view information, updates all MWTM 
windows to reflect your changes, and exits the dialog.

Restore Restores changes you have made to the Name and Icon Name fields of the Edit 
Properties Dialog, and leaves the dialog open.

Cancel Exits the dialog without saving any changes.

Help Displays online help for the dialog.

Field or Button Description
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Attaching a Note to a View
MWTM enables you to annotate a view, attaching a descriptive string to it.

To attach a note to a view, right-click the view in a window, then select Edit > 
Notes in the right-click menu. MWTM displays the Edit Notes Dialog for a View 
(Figure 4-4).

Figure 4-4 Edit Notes Dialog for a View

If you add notes to the DEFAULT view, you are prompted to save the view under 
a different name, since customization to the DEFAULT view is not allowed (for 
more details on saving views, see Saving a View, page 4-38.)

The Edit Notes Dialog for a View contains the following fields and buttons:

Field or Button Description

Name Name of the view. You cannot edit this field.

Note Last Updated Date and time the Notes field for this view was last updated. If there is no note 
currently associated with this view, this field displays the value Not Set.

You cannot edit this field.

Notes Notes to associate with this view. In this field, you can enter any important 
information about the view, such as a detailed description, its history, and so on.
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Related Topics:

• Viewing Basic Information for Views, page 4-4

• Viewing Detailed Information for a View, page 4-12

• Viewing Notes for a View, page 4-41

Saving a View
MWTM enables you to save a specific view, change the list of views, and select 
one view to be loaded automatically when the associated preferences file is saved.

When you are satisfied with the changes you have made to a view, use one of the 
following procedures to save the view:

• To save the changes you have made to the view without changing the name of 
the file, select File > Save from the View Editor Window menu.

Note You cannot save changes to the DEFAULT view. If you are currently using 
the DEFAULT view and you select File > Save, MWTM displays the Save 
File Dialog: View List dialog (Figure 4-5).

• To save the changes you have made to the view with a new name, select File 
> Save As from the Discovery Dialog menu. MWTM displays the Save File 
Dialog: View List dialog (Figure 4-5).

Save Saves changes you have made to the view’s notes, updates all MWTM windows 
to reflect your changes, and exits the dialog.

When you annotate a view, the topology map in the Topology Window displays 
a note icon in the upper left corner of the view element.

Cancel Exits the dialog without saving any changes.

Help Displays online help for the dialog.

Field or Button Description
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MWTM stores the view in the view file directory on the MWTM server:

• If you installed MWTM in the default directory, /opt, then the MWTM view 
file directory is /opt/CSCOsgm/views.

• If you installed MWTM in a different directory, then the MWTM view file 
directory is located in that directory.

Note If another user modifies and saves the view before you save your changes, 
MWTM asks if you want to overwrite that user’s changes. If you choose to do so, 
the other user’s changes are overwritten and lost. If you choose not to do so, your 
changes are lost, unless you save the view to a different filename.

Figure 4-5 Save File Dialog: View List Dialog

The Save File Dialog: View List contains the following fields and buttons:

Field or Button Description

Type Icon indicating whether the item in the table is a file or a 
folder.

Name Name of the view file or folder.

Last Modified Date and time the view file or folder was last modified.
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Size (bytes) Size of the view file or folder, in bytes.

Filename Name by which you want to save the view. You must specify 
a name other than DEFAULT. You cannot save changes to the 
DEFAULT view.

When you create a new view file name, you can use any 
letters, numbers, or characters in the name that are allowed by 
your operating system. However, if you include any spaces in 
the new name, MWTM converts those spaces to dashes. For 
example, MWTM saves file “a b c” as “a-b-c”.

Make this my preferred startup 
option

Specifies whether the selected view is to be loaded 
automatically whenever the associated preferences file is 
loaded:

• To load the saved view, select the view, then select this 
checkbox.

• To load the last-used view, clear the checkbox. This is the 
default setting.

Number of Files
(displayed in bottom left corner)

Total number of view files and folders.

OK Saves any changes you made to the current named view or to 
the list of views and closes the dialog.

To save the view with a new name, use one of the following 
procedures:

• To save the file with a completely new name, enter the 
new name and click OK.

• To save the file with an existing name, overwriting an old 
view, select the name in the list and click OK.

MWTM saves the view with the new name, closes the Save 
File Dialog: View List dialog, and returns to the Discovery 
Dialog.

To save any changes you made to the list of files, click OK. 
MWTM saves the changes and closes the Load File Dialog: 
View List dialog.

Field or Button Description
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Related Topics:

• Working with Views, page 4-1

Viewing Notes for a View
MWTM enables you to view any notes that have been associated with a view.

To view a note for a view, right-click a view in a window, then select View > Notes 
in the right-click menu. (The Notes option is grayed-out if there is no note 
associated with the selected view.)

MWTM displays the Notes panel for the selected view, which displays:

• Notes associated with the view.

• The date and time the notes associated with the view were last updated, or the 
phrase Not Set if there are no notes associated with the view.

• The phrase No Notes if there are no notes associated with the view.

Related Topics:

• Editing a View, page 4-34

Delete Deletes the selected file from the view list. MWTM issues an 
informational message containing the name and location of 
the deleted file.

Cancel Closes the dialog without saving the view or any changes to 
the view list.

Help Displays online help for the dialog.

Field or Button Description
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Creating a New View
MWTM enables you to specify the nodes you want to see in MWTM displays. 
This is called a client-specific network view. All changes you make are reflected 
in topology tables and maps as soon as you make the changes.

Before creating a client-specific network view, make sure that Discovery has been 
run at least once, and there is data in the server’s MWTM database. See the 
“Discovery Overview” section on page 2-1 for details.

To create a client-specific network view, select Edit > Views from the MWTM 
Main Menu. MWTM displays the View Editor Window (Figure 4-6).

Figure 4-6 View Editor Window

The View Editor Window displays two tabs, Edit View and Import Views:

• The Edit View tab provides the following information:

– All objects that are in the current view.

– All objects that have been excluded from the current view.

– New objects that have been found by MWTM.

• The Import Views tab provides the following information:

– All views currently defined on this MWTM client.

– Data about the views.
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The View Editor Window also enables you to move objects into and out of the 
current view. All changes made in this window are reflected in the MWTM client 
and in the topology tables and maps as soon as you make the changes.

The View Editor Window is composed of the following sections:

• View Editor Window Menu, page 4-44

• Objects In Current View (Left Pane), page 4-46

• Excluded from View Panel, page 4-48

• New on the Network Panel, page 4-49

• Views List Panel, page 4-50

• View Data Panel, page 4-52

• Directory Listing Panel, page 4-52

• Closing the View Editor Window, page 4-52

Related Topics:

• Changing the Message Display, page 11-34

• Changing MWTM Client Preference Settings, page 11-3

• Viewing the Topology of the Network, page 8-1
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View Editor Window Menu
The menu on the View Editor Window provides the following options:

Menu Command Description

File > Load 
DEFAULT View

Loads the DEFAULT view, which is the view into which MWTM places all 
discovered objects when discovering the network. The DEFAULT view is stored 
on the MWTM server and shared by all MWTM clients, but it cannot be modified 
by the clients.

File > Load
(Ctrl-L)

Loads an already existing view.

If you have already saved a view and you want to change it, select the File > Load 
menu option. MWTM prompts you for the name of the view you want to load:

• Select the name of the view, or accept the default view name, then click OK 
to load the view.

• Click Cancel to close the prompt window without loading a view.

File > Save
(Ctrl-S)

Saves the current view:

• If you have not already saved the current view, opens the Save File Dialog: 
View List, which enables you to enter or select a file name under which to 
save the current view.

• If you have already saved the current view, saves the view to that file name.

If you have implemented MWTM User-Based Access, this option is available to 
users with authentication level Power User (Level 2) and higher.

File > Save As Opens the Save File Dialog: View List, which enables you to save changes you 
have made to the selected view with a new name, or overwrite an existing seed 
file. The view is updated immediately in the MWTM client.

If you have implemented MWTM User-Based Access, this option is available to 
users with authentication level Power User (Level 2) and higher.
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File > Close
(Ctrl-W)

Closes the View Editor Window.

If you have modified the view, MWTM asks if you want to save your changes.

• Click Yes to save your changes to the current view.

• Click No to keep the current view as-is, without applying any changes. 
MWTM closes the View Editor Window.

• Click Cancel to close the prompt window and return to the View Editor 
Window without applying any changes to the current view.

Edit > 
Create Subview
(Ctrl-N)

Creates a new subview for the selected view or subview. Enter a name for the new 
subview.

Edit > Rename 
View
(Ctrl-R)

Enables you to rename the selected view. The new name can be from 1 to 30 
characters, and can contain any letters, numbers, or special characters.

Edit > Include In 
View
(Ctrl-I)

Enables you to include the selected object in the view.

Edit > Exclude 
From View
(Alt-X)

Enables you to exclude the selected object from the view.

Edit > Delete View
(Ctrl-D)

Deletes the selected view.

Edit > Cut
(Alt-X)

Cuts the selected object from the view.

Edit > Copy
(Alt-C)

Copies the selected object or view.

Edit > Paste
(Alt-V)

Pastes a cut or copied object or view into the selected view.

Help > Topics
(F1)

Displays the table of contents for the MWTM online help.

Menu Command Description
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Objects In Current View (Left Pane)
The left pane of the View Editor Window lists the nodes that are in the current 
view.

To see the objects that are associated with a node, and that are in the current view, 
select the turner beside the node.

To exclude any of these objects from the current view, select them in the left pane, 
then select Edit > Exclude From View to move them to the Excluded From View 
panel of the View Editor Window.

Note If you are using an MWTM client with the DEFAULT view set, MWTM 
automatically adds all newly discovered objects to the left pane as soon as they 
are discovered.

If you delete an object, MWTM removes it from the left pane. If MWTM then 
discovers the object, MWTM places it in the New on the Network panel. To see 
this object again in your current view, you must move it into the left panel using 
Edit > Include In View from the View Editor Window.

The left pane of the View Editor Window provides the following right-click 
menus:

• Objects in Current View Right-Click Menu for a View, page 4-47

• Objects in Current View Right-Click Menu for a Subview, page 4-47

• Objects in Current View Right-Click Menu for an Object, page 4-48

Help > Window
(Shift-F1)

Displays online help for the current window.

Help > About
(F3)

Displays build date, version, SSL support, and copyright information about the 
MWTM application.

Menu Command Description
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Objects in Current View Right-Click Menu for a View

The right-click menu for a view in the left pane of the View Editor Window 
provides the following options:

Objects in Current View Right-Click Menu for a Subview

The right-click menu for a subview in the left pane of the View Editor Window 
provides the following options:

Menu Command Description

Create Subview Creates a new subview for the selected view. Enter a name for the new subview.

Rename View Enables you to rename the selected view. The new name can be from 1 to 30 
characters, and can contain any letters, numbers, or special characters.

Copy Copies the selected view.

Paste Pastes a cut or copied object or view into the selected view.

Menu Command Description

Create Subview Creates a new subview for the selected subview. Enter a name for the new 
subview.

Rename View Enables you to rename the selected subview. The new name can be from 1 to 30 
characters, and can contain any letters, numbers, or special characters.

Delete From View Deletes the selected subview from the view or subview.

Export View Opens the Save File Dialog: View List dialog (Figure 4-5), which enables you to 
save the subview as a unique view.

Copy Copies the selected subview.

Paste Pastes a cut or copied object or view into the selected subview.
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Objects in Current View Right-Click Menu for an Object

The right-click menu for an object in the left pane of the View Editor Window 
provides the following options:

Excluded from View Panel
The Excluded from View panel lists the objects that have been excluded from the 
current view. To add these objects to the current view, select them in the Excluded 
from View panel, then select Edit > Include In View to move them to the left 
pane of the View Editor Window.

The Excluded from View panel provides the following right-click options for an 
object:

Menu Command Description

Exclude From View Excludes the selected object, and any lower-level associated objects, from the 
view or subview.

Cut Cuts the selected object from the view or subview.

Copy Copies the selected object.

Menu Command Description

Include In View Includes the selected object, and any lower-level associated objects, in the 
selected view or subview.

Copy Copies the selected object.
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New on the Network Panel
The New on the Network panel displays newly discovered objects, based on the 
following criteria:

• If you are using an MWTM client with the DEFAULT view set, this table 
never contains any objects. In the DEFAULT view, MWTM adds all newly 
discovered objects to the left pane of the View Editor Window as soon as they 
are discovered.

• If you are using an MWTM client with a custom view set, this table contains 
all objects discovered since the View Editor Window was opened in this 
session, that have not been excluded in the Excluded from View panel, or that 
are not in the current view.

When MWTM discovers one or more new objects in the network, MWTM also 
takes the following actions:

• MWTM broadcasts the discovery of the new objects to all MWTM clients.

• MWTM displays a “New!” icon in the bottom of most MWTM windows. 
Clicking the “New!” icon in the Topology Window opens the New Objects 
panel in the left pane. Clicking the “New!” icon in any other window opens 
the Edit View tab of the View Editor Window.

• MWTM adds graphical elements for the newly discovered objects to the New 
Objects panel in the left pane of the Topology Window. For more information, 
see the “Displaying the Topology New Objects Panel” section on page 8-24.

To add a newly discovered object to the current view, select one or more objects 
in the New on the Network panel, then select Edit > Include In View to move 
them to the left pane of the View Editor Window.

To exclude a newly discovered object from the current view, select one or more 
objects in the New on the Network panel, then select Edit > Exclude From View 
to move them to the Excluded From View panel of the View Editor Window.
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The New on the Network panel provides the following right-click options for an 
object:

Views List Panel
The Views List panel is found under the Import Views tab of the View Editor 
window. The Views List panel lists all views that are currently defined on this 
MWTM client. Note that if you have no views defined, this list will be empty.

To see mouse over help popup for each column in the Views List panel, place the 
cursor over a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the 
full data in a mouse over help popup.

You can resize each column, or sort the table based on the information in one of 
the columns. By default, this table is sorted by Name, and MWTM displays all of 
the columns in the Views List panel.

• To hide columns, right-click in the table header and clear the checkboxes for 
the columns you want to hide.

• To display hidden columns, right-click in the table header and select the 
checkboxes for the columns you want to display.

See the “Resizing, Sorting, and Hiding Table Columns” section on page 3-37 for 
more information about resizing, sorting, displaying, or hiding columns.

Menu Command Description

Include In View Includes the selected object, and any lower-level associated objects, in the 
selected view or subview.

Exclude From View Excludes the selected object, and any lower-level associated objects, from the 
view or subview.

Copy Copies the selected object.
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The Views List panel contains the following columns:

The Views List panel provides the following right-click menu option for views:

The Views List panel provides the following right-click menu option for folders:

Column Description

Type Indicates whether the selected name is a directory or a file.

Name Name of the view.

Last Modified Date and time the view was last modified.

Size (bytes) Size of the view in bytes.

Menu Command Description

Import View Copies the selected view into the view or subview that is currently selected in the 
left pane of the View Editor Window.

Delete View Deletes the selected folder, view, or subview. (You can delete a folder only if it 
contains no views or subviews.)

Menu Command Description

Open View Opens the selected folder, displaying views contained in the folder in the Views 
List panel.
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View Data Panel
The View Data panel lists all subviews and objects that are in the view that is 
selected in the Views List panel. If you have not saved a view yet, and there are 
no views in the Views List panel, this panel does not appear.

The View Data panel provides the following right-click menu option for views and 
subviews:

Directory Listing Panel
The Directory Listing panel lists all subfolders that are in the folder that is 
selected in the Views List panel. If there are no views in the Views List panel, or 
if a folder (not a file) exists in the Views List panel, the Directory Listing panel is 
displayed. If there are only files in the Views List panel, the Directory Listing 
panel does not appear.

To see the Directory Listing panel, select a folder in the Views List panel.

Closing the View Editor Window
To close the View Editor Window at any time, click File > Close. If you have 
modified the view, MWTM asks if you want to apply the changes before leaving 
the window:

• Click Yes to apply the changes to the current view. MWTM applies the 
changes to all MWTM windows immediately. MWTM then asks if you want 
to make this the default view:

– Click Yes to make this view the new default view. In the future, when this 
client is started, this will be the default view.

– Click No to retain your old default view.

MWTM closes the View Editor Window.

Menu Command Description

Import View Copies the selected view or subview into the view or subview that is currently 
selected in the left pane of the View Editor Window.
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• Click No to keep the current view as-is, without applying any changes. 
MWTM closes the View Editor Window.

• Click Cancel to close the prompt window and return to the View Editor 
Window without applying any changes to the current view.

If you are working in a custom view (that is, not in the DEFAULT view) and you 
exit the MWTM client, MWTM automatically saves any changes you made to the 
view.

Loading the DEFAULT View
To load the DEFAULT network view, select File > Load DEFAULT View from 
the MWTM Main Menu. You may be prompted to save the view you are currently 
in. Once you have chosen whether or not to save your current view, MWTM loads 
the DEFAULT view. 

Note Any custom views are saved in the View Editor window (Import Views tab) found 
under the Edit > Views option in the MWTM Main window.

Loading a Client-Specific View
MWTM enables you to load a specific view, change the list of views, and select 
one view to be loaded automatically when the associated preferences file is 
loaded.

To load a client-specific network view, select Edit > Views from the MWTM 
Main Menu. MWTM displays the View Editor Window (Figure 4-6). Then select 
File > Load from the View Editor Window menu. MWTM displays the Load File 
Dialog: View List dialog (Figure 4-7).
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Figure 4-7 Load File Dialog: View List Dialog

The Load File Dialog: View List contains the following fields and buttons:

Field or Button Description

Type Icon indicating whether the item in the table is a file or a 
folder.

Name Name of the view file or folder.

Last Modified Date and time the view file or folder was last modified.

Size (bytes) Size of the view file or folder, in bytes.

Make this my preferred start option Specifies whether the selected view is to be loaded 
automatically whenever the associated preferences file is 
loaded:

• To load the selected view, select the view, then select this 
checkbox.

• To load the last-used view, clear the checkbox. This is the 
default setting.

Number of Files
(displayed in bottom left corner)

Total number of view files and folders.
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Related Topics:

• Working with Views, page 4-1

Ignoring a View
You can instruct MWTM to ignore a view when it aggregates and displays 
network data. Setting views to Ignored prevents known problems in the views 
from affecting MWTM displays for associated objects. In effect, you are 
preventing a known problem from distracting you from other, more urgent 
network problems.

For example, you can set a view to Ignored before shutting down objects in the 
view for maintenance.

OK Loads the selected view, saves any changes you made to the 
list of views, closes the dialog, and returns to the View Editor 
Window.

To load a view, double-click it in the list, select it in the list 
and click OK, or enter the name of the view and click OK. 
MWTM loads the view, saves any changes you made to the 
list of views, closes the Load File Dialog: View List dialog, 
loads the view, and returns to the View Editor Window.

Delete Deletes the selected file from the view list. MWTM issues an 
informational message containing the name and location of 
the deleted file.

Cancel Closes the dialog without loading a view or saving any 
changes to the view list.

Help Displays online help for the dialog.

Field or Button Description
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Note If you set a view to Ignored, the view is ignored for only the current MWTM 
client.

Also, if you set a view to Ignored, make a note of the change, and do not forget 
to reset the view when the problem is corrected or the maintenance is complete.

You cannot ignore the DEFAULT view.

To set a view to Ignored, select the Ignored checkbox in the View Window for 
the view you want MWTM to ignore.

Viewing Ignored Views
To display all views that are Ignored, display the View Window and click the 
Ignored column header. MWTM displays all ignored views at the top of the table.
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Working with Events

MWTM enables you to view information about all discovered events, including 
their associated network objects and other information.

This chapter includes the following information:

• Viewing Basic Information for All Events, page 5-2

• Viewing Events for a Specific Object, page 5-10

• Viewing Detailed Information for an Event, page 5-10

• Setting an Event Filter, page 5-10

• Loading an Existing Event Filter, page 5-17

• Saving an Event Filter File, page 5-19

• Viewing Event Properties, page 5-21

• Attaching a Note to an Event, page 5-24

• Viewing Notes for an Event, page 5-25

• Changing the Way MWTM Processes Events, page 5-26

• Forwarding Events as Traps to Other Hosts, page 5-50

• Setting Sounds for Events at an MWTM Client, page 5-51

Related Topics:

• Changing MWTM Client Preference Settings, page 11-3

• Viewing the Topology of the Network, page 8-1

• Working with Nodes, page 6-1
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Viewing Basic Information for All Events
To view basic information for all events, select Events in the left pane of the 
MWTM Main Window. MWTM displays the Event Window (Figure 5-1).

Figure 5-1 Event Window

The Event Window displays information about the events delivered by the 
MWTM event logger and event processor for all objects in the current network 
view.

Note You can display more than one Event Window at one time. This enables you to 
view multiple Event Windows at the same time, with different event filtering in 
each window or dialog.

The Event Window is composed of the following sections:

• Event Toolbar Buttons, page 5-3

• Right-Click Menu for All Events, page 5-4

• Right-Click Menu for a Specific Event, page 5-5

• Event Table, page 5-7
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Event Toolbar Buttons
The Event Window provides the following toolbar buttons:

Button Description

Set Filter Opens the Event Filter dialog.

Apply Filter

or

Remove Filter

Activates and deactivates the event filter specified in the Event Filter 
dialog:

• If the filter is activated, MWTM displays only those events that 
pass the filter.

• If the filter is deactivated, MWTM displays all events.

• If you activate a filter in an object’s Recent Events table in the 
MWTM Main Window, the filter is activated in all Recent Events 
tables in the MWTM Main Window for all other objects. The 
filter is not activated in Recent Events tables in Show In New 
Window windows or Real-Time Data and Charts windows.

Pause

or

Resume

Pauses or resumes the table.

While the table is paused, MWTM does not display new events in the 
table (unless you apply an event filter or edit your event preferences). 
When the table is resumed, all new events since the table was paused 
are added to the display.

If events are deleted while the table is paused, they are not removed 
from the table. Instead, they are grayed-out and cannot be 
acknowledged or edited. Deleted events are removed from the table 
when you resume the table.

Acknowledge Makes the selected event or events acknowledged.

Unacknowledge Makes the selected event or events unacknowledged.

Event Properties Opens the Event Properties window.

Edit Notes Opens the Edit Event Dialog.

Time Difference Displays the difference in days, minutes, hours, and seconds between 
two events.
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Right-Click Menu for All Events
To see the right-click menu for all events, select Events in the left pane and click 
the right mouse button. The events right-click menu provides the following 
options:

Find Finds specific text in the event table.

Create Sound Filter Opens the Event Sound Filters dialog and the Event Sound Filters List 
dialog, with fields populated based on the selected event.

Adjust Row Height Adjusts the table row height and wraps the message text as follows:

• Click once to double the row height and wrap the message text.

• Click again to triple the row height and wrap the message text.

• Click again for single row height and no message text wrapping. 
This is the default setting.

This setting is saved automatically with your preferences.

Help for Event Displays context-sensitive help for the selected event in a separate 
Web browser.

Button Description

Menu Command Description

Show In New Window Opens the Event Window in a new window.

Sort Tree By Status Sorts the entire tree in the left pane by the status of each object.

Sort Tree By Name Sorts the entire tree in the left pane by the name of each object.

Back > List of Windows Navigates back to a window viewed in this session.

MWTM maintains a list of up to 10 Back windows.

Forward > List of 
Windows

Navigates forward to a window viewed in this session.

MWTM maintains a list of up to 10 Forward windows.
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Right-Click Menu for a Specific Event
The Event Window provides a subset of the MWTM Main Menu as a right-click 
menu. To see this menu, select an event and click the right mouse button. The 
event right-click menu provides the following options:

Menu Command Description

Edit Notes Opens the Edit Event Dialog for the selected event.

Go To > Object Displays the Node Window for the node or Interface 
Window for the interface associated with the selected 
event.

If there is no object associated with the event, this option is 
not displayed.

View > Configuration Details Displays the Details window for the object associated with 
the selected event.

View > Notes Displays the Event Notes dialog for the selected event.

If there are no notes associated with this event, this option 
is grayed-out.

View > Center in Topo Opens the Topology Window, with the display zoomed to 
center on the object associated with the selected event.

If more than one view contains the object associated with 
the selected event, MWTM prompts you to choose one of 
the views.

Event History > Status Change 
Messages

Displays the MWTM Network Status Log for Status 
Change Messages in a Web browser, with messages 
displayed for only the object associated with selected 
event.

Event History > SNMP Trap Messages Displays the MWTM Network Status Log for SNMP Trap 
Messages in a Web browser, with messages displayed for 
only the object associated with selected event.

Event History > Status and Trap 
Messages

Displays the MWTM Network Status Log for Status 
Change Messages and SNMP Trap Messages in a Web 
browser, with messages displayed for only the object 
associated with selected event.
5-5
Cisco Mobile Wireless Transport Manager User Guide

OL-7637-01



 

Chapter 5      Working with Events
Viewing Basic Information for All Events
Event History > Network Status 
Metrics

Displays the MWTM Network Status Log for Metrics in a 
Web browser, with metrics displayed for only the object 
associated with selected event.

Node Drill-Down > Show Syslog 
Messages

Displays the Node Details: Syslog table, which polls the 
node associated with the selected event and displays all 
messages in its system log.

This option is not available if the node is in Unknown or 
Unmanaged status.

Node Drill-Down > Show CPU 
Processes

Opens the Node Details: CPU Processes panel, which polls 
the node associated with the selected event for information 
about its CPU processes.

This option is not available if the node is in Unknown or 
Unmanaged status.

Node Drill-Down > Show Trap 
Configuration

Opens the Node Details: Trap Configuration panel, which 
displays all trap settings for the node, as well as all hosts 
and port numbers to which the node sends traps.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level 
System Administrator (Level 5).

This option is not available if the node is in Unknown or 
Unmanaged status.

Acknowledge Makes the event acknowledged, which means that it has 
been received and processed.

Unacknowledge Makes a previously acknowledged event unacknowledged.

Event Properties Opens the Event Properties window.

Create Sound Filter Opens the Event Sound Filters dialog and the Event Sound 
Filters List dialog, with fields populated based on the 
selected event.

Help for Event Displays context-sensitive help for the selected event in a 
separate Web browser.

Menu Command Description
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Event Table
The event table displays information about events delivered by the MWTM event 
logger and event processor.

To see mouse over help popup for each column in the table, place the cursor over 
a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the 
full data in a mouse over help popup.

You can resize each column, or sort the table based on the information in one of 
the columns. By default, MWTM displays all of the columns in the event table 
except Internal ID, Note, Message Name, Ack By, Ack Time, Node, and 
Router Interface.

• To display hidden columns, right-click in the table header and select the 
checkboxes for the columns you want to display.

• To hide columns, right-click in the table header and clear the checkboxes for 
the columns you want to hide.

See the “Resizing, Sorting, and Hiding Table Columns” section on page 3-37 for 
more information about resizing, sorting, displaying, or hiding columns.

To see detailed information about an event, right-click the event in a window, then 
select Event Properties in the right-click menu.

The event table contains the following columns:

Column Description

Internal ID Internal ID of the event. The internal ID is a unique ID for every object, assigned by 
MWTM for its own internal use. It can also be useful when the TAC is debugging 
problems.

Ack Indicates whether the event has been acknowledged:

• To acknowledge an unacknowledged event, use the Acknowledge toolbar button.

• To make a previously acknowledged event unacknowledged, use the 
Unacknowledge toolbar button.
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Category Type of the event. Default values are:

• Create—Creation event, such as the creation of a seed file.

• Delete—Deletion event, such as the deletion of an object or file.

• Discover—Discovery event, such as Discovery beginning.

• Edit—Edit event. A user has edited an object.

• Ignore—Ignore event. A user has Ignored a link or linkset.

• Login—Login event. A user has logged in to MWTM.

• LoginDisable—LoginDisable event. MWTM has disabled a user’s User-Based 
Access authentication as a result of too many failed attempts to log in to MWTM.

• LoginFail—LoginFail event. An attempt by a user to log in to MWTM has failed.

• Logout—Logout event. A user has logged out of MWTM.

• OverWrite—OverWrite event. An existing file, such as a seed file or route file, 
has been overwritten.

• Poll—Poll event, such as an SNMP poll.

• Purge—Purge event. A user has requested Discovery with Delete Existing Data 
selected, and MWTM has deleted the existing MWTM database.

• Status—Status change message generated.

• Trap—SNMP trap message generated.

You can customize this field. See the “Changing Event Categories” section on 
page 5-34 for more information.

Column Description
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Severity Severity of the event. Default values are:

• Critical—The default color is red.

• Indeterminate—The default color is aqua.

• Informational—The default color is white.

• Major—The default color is orange.

• Minor—The default color is yellow.

• Normal—The default color is green.

• Warning—The default color is blue.

You can customize this field. See the “Changing Event Severities and Colors” section 
on page 5-35 for more information.

Note Indicates whether there is a note associated with the event.

Message 
Name

User-specified message name for the event, used by MWTM for trap forwarding. The 
default message name is MWTM.

For more information about user-specified message names and trap forwarding, see 
the “Forwarding Events as Traps to Other Hosts” section on page 5-50.

Time Date and time the event was logged.

Ack By If you have not implemented MWTM User-Based Access, name of the device that last 
acknowledged the event.

If you have implemented MWTM User-Based Access, name of the user who last 
acknowledged the event.

If no one has acknowledged the event, this field is blank.

Ack Time Date and time the event was last acknowledged or unacknowledged.

Node Name of the node associated with the event. If there is no node associated with the 
event, None is displayed.

Message Message associated with the event.

You can customize this field. See the “Changing the Way MWTM Processes Events” 
section on page 5-26 for more information.

Router 
Interface

Name of the router interface associated with the event. If there is no router interface 
associated with the event, None is displayed.

Column Description
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Viewing Events for a Specific Object
MWTM enables you to view events for only a selected object. To do so, right-click 
an object in a window, then select View > Events from the right-click menu. 
MWTM displays recent events for the selected object. For more information, see 
the following sections:

• Node Details: Recent Events, page 6-47

• View Details: Recent Events, page 4-26

Viewing Detailed Information for an Event
MWTM enables you to view detailed configuration information for the object 
associated with a specific event.

To display detailed information for an event, select Events in the left pane of the 
MWTM Main Window, right-click an event in a window, then select View > 
Configuration Details in the right-click menu. MWTM displays detailed 
information for the selected object. For more information, see the following 
sections:

• Viewing Detailed Information for a Node, page 6-13

• Viewing Detailed Information for a View, page 4-12

Setting an Event Filter
MWTM enables you to change the way it presents event information.

To change the way MWTM presents event information, select the Set Filter 
button at the top of the Event Window. MWTM displays the Event Filter dialog 
with the Properties tab selected (Figure 5-2).
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Figure 5-2 Event Filter Dialog, Showing Event Properties

The Event Filter dialog is composed of the following sections:

• Event Filter Buttons, page 5-12

• Properties Settings, page 5-12

• Selected Objects Settings, page 5-16

Related Topics:

• Loading an Existing Event Filter, page 5-17

• Saving an Event Filter File, page 5-19

• Viewing Event Properties, page 5-21
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Event Filter Buttons
The Event Filter dialog contains the following buttons:

Properties Settings
The Properties settings in the Event Filter dialog enable you to specify the types 
of event MWTM is to display in the Event Window, including the category and 
severity of event, whether the event is acknowledged, and other properties.

To display the Properties settings, select the Properties tab in the Event Filter 
dialog.

The Properties settings contain the following sections:

• Categories, page 5-13

• Severities, page 5-14

• Other, page 5-15

Button Description

OK Applies any changes you made to the event filter and closes the Event Filter dialog.

Load Opens the Load File Dialog: Load Filter, which enables you to load an already existing 
event filter file.

If you are viewing events for a specific object in the left pane of the MWTM Main 
Window, this button is not available.

Save Opens the Save File Dialog: Save Filter, which enables you to save the event filter file 
with a new name, or overwrite an existing event filter file.

If you are viewing events for a specific object in the left pane of the MWTM Main 
Window, this button is not available.

Cancel Closes the Event Filter dialog without applying any changes to the event filter.

Help Displays online help for the current dialog.
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Categories

Use the Categories section of the Properties settings to specify which event 
categories you want to display in the Event Window.

The Categories section contains the following default fields and buttons.

Note These are the default categories; there might be additional categories, as defined 
by the MWTM system administrator. For information about custom categories, 
see the “Changing Event Categories” section on page 5-34.

Field or Button Description

Status Checkbox used to indicate whether Status events are to be displayed in the Event 
Window. The default setting for this checkbox is selected.

Trap Checkbox used to indicate whether Trap events are to be displayed in the Event 
Window. The default setting for this checkbox is selected.

Create Checkbox used to indicate whether Create events are to be displayed in the Event 
Window. The default setting for this checkbox is selected.

Delete Checkbox used to indicate whether Delete events are to be displayed in the Event 
Window. The default setting for this checkbox is selected.

Discover Checkbox used to indicate whether Discover events are to be displayed in the Event 
Window. The default setting for this checkbox is selected.

Edit Checkbox used to indicate whether Edit events are to be displayed in the Event 
Window. The default setting for this checkbox is selected.

Ignore Checkbox used to indicate whether Ignore events are to be displayed in the Event 
Window. The default setting for this checkbox is selected.

Login Checkbox used to indicate whether Login events are to be displayed in the Event 
Window. The default setting for this checkbox is selected.

LoginDisable Checkbox used to indicate whether LoginDisable events are to be displayed in the 
Event Window. The default setting for this checkbox is selected.

LoginFail Checkbox used to indicate whether LoginFail events are to be displayed in the 
Event Window. The default setting for this checkbox is selected.

Logout Checkbox used to indicate whether Logout events are to be displayed in the Event 
Window. The default setting for this checkbox is selected.
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Severities

Use the Severities section of the Properties settings to specify which event 
severities you want to display in the Event Window.

The Severities section contains the following default fields.

Note These are the default severities; there might be additional severities, as defined by 
the MWTM system administrator. For information about custom severities, see 
the “Changing Event Severities and Colors” section on page 5-35.

OverWrite Checkbox used to indicate whether OverWrite events are to be displayed in the 
Event Window. The default setting for this checkbox is selected.

Poll Checkbox used to indicate whether Poll events are to be displayed in the Event 
Window. The default setting for this checkbox is selected.

Purge Checkbox used to indicate whether Purge events are to be displayed in the Event 
Window. The default setting for this checkbox is selected.

Select All Selects all event category checkboxes.

Deselect All Clears all event category checkboxes.

Field or Button Description

Field Description

Informational Checkbox used to indicate whether events of severity Informational are to be 
displayed in the Event Window. The default setting for this checkbox is selected.

Normal Checkbox used to indicate whether events of severity Normal are to be displayed in 
the Event Window. The default setting for this checkbox is selected.

Indeterminate Checkbox used to indicate whether events of severity Indeterminate are to be 
displayed in the Event Window. The default setting for this checkbox is selected.

Warning Checkbox used to indicate whether events of severity Warning are to be displayed in 
the Event Window. The default setting for this checkbox is selected.

Critical Checkbox used to indicate whether events of severity Critical are to be displayed in 
the Event Window. The default setting for this checkbox is selected.
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Other

Use the Other section of the Properties settings to further define the event filter 
for the Event Window. These settings are applied to all event displays in the 
current view.

The Other section contains the following fields:

Minor Checkbox used to indicate whether events of severity Minor are to be displayed in the 
Event Window. The default setting for this checkbox is selected.

Major Checkbox used to indicate whether events of severity Major are to be displayed in the 
Event Window. The default setting for this checkbox is selected.

Field Description

Field Description

Acknowledged Checkbox used to indicate whether only acknowledged events are to be 
displayed in the Event Window. The default setting for this checkbox is 
cleared.

Unacknowledged Checkbox used to indicate whether only unacknowledged events are to be 
displayed in the Event Window. The default setting for this checkbox is 
selected.

Time Before Checkbox used to indicate whether only events logged by MWTM prior to a 
specified date and time are to be displayed in the Event Window. The default 
setting for this checkbox is cleared.

Time Before Field Specifies the date and time prior to which events logged by MWTM are to be 
displayed in the Event Window. This field is grayed-out unless the Time 
Before checkbox is selected.

Time After Checkbox used to indicate whether only events logged by MWTM after a 
specified date and time are to be displayed in the Event Window. The default 
setting for this checkbox is cleared.

Time After Field Specifies the date and time after which events logged by MWTM are to be 
displayed in the Event Window. This field is grayed-out unless the Time After 
checkbox is selected.
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Selected Objects Settings
MWTM enables you to specify the object for which MWTM is to display events 
in the Event Window. To do so, select the Selected Objects tab in the Event Filter 
dialog. MWTM displays the Event Filter dialog with the Selected Objects tab 
highlighted (Figure 5-3).

Figure 5-3 Event Filter Dialog, Showing Event Selected Objects

Message Contains Checkbox used to indicate whether only events that contain the specified 
message text are to be displayed in the Event Window. The default setting for 
this checkbox is cleared.

Match Case Checkbox used to indicate whether only events that match the case of the text 
in the Message Contains field are to be displayed in the Event Window. This 
field is grayed-out unless the Message Contains checkbox is selected. If the 
Message Contains checkbox is selected, the default setting for this checkbox 
is cleared.

Field Description
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The Selected Objects settings contains the following fields and buttons:

Loading an Existing Event Filter
MWTM enables you to load a specific event filter file and change the list of event 
filter files.

To load an existing event filter, click Load in the Event Filter dialog. MWTM 
displays the Load File Dialog: Load Filter dialog (Figure 5-4).

Field or Button Description

Node Drop-down list box of all nodes that have been discovered by MWTM:

• If you want to filter events based on a node, select a node from the 
drop-down list box. The Rtr Interface drop-down list box appears.

• If you do not want to filter events based on a node, select None. MWTM 
grays-out the other object fields. This is the default setting.

Rtr Interface Drop-down list box of all interfaces associated with the selected router:

• If you want to filter events based on a router interface, select an interface 
from the drop-down list box.

• If you do not want to filter events based on a router interface, select None. 
This is the default setting.

Reset Restores Node to None, grays-out other object fields.

Selected Objects: 
Object Type

Indicates the type of object, if any, upon which the event filter is based.

Selected Objects: 
Node

Indicates the node, if any, upon which the event filter is based.

Selected Objects: 
Rtr Interface

Indicates the router interface, if any, upon which the event filter is based.
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Figure 5-4 Load File Dialog: Load Filter Dialog

The Load File Dialog: Load Filter contains the following fields and buttons:

Field or Button Description

Type Icon indicating whether the item in the table is a file or a folder.

Name Name of the event filter file or folder.

Last Modified Date and time the event filter file or folder was last modified.

Size (bytes) Size of the event filter file or folder, in bytes.

Number of Files
(displayed in bottom left corner)

Total number of event filter files and folders.

OK Loads the selected event filter, saves any changes you made to the 
list of files, and closes the dialog.

To load an event filter file, double-click it in the list, select it in 
the list and click OK, or enter the name of the file and click OK. 
MWTM loads the event filter file, saves any changes you made to 
the list of files, closes the Load File Dialog: Load Filter dialog, 
and returns to the Event Filter dialog.

Delete Deletes the selected file from the event filter file list. MWTM 
issues an informational message containing the name and location 
of the deleted file.
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Saving an Event Filter File
MWTM enables you to save a specific event filter file and change the list of event 
filter files.

When you are satisfied with the filter settings, click Save in the Event Filter 
dialog. MWTM displays the Save File Dialog: Save Filter dialog (Figure 5-5).

Figure 5-5 Save File Dialog: Save Filter Dialog

The Save File Dialog: Save Filter contains the following fields and buttons:

Cancel Closes the dialog without loading an event filter file or saving any 
changes to the event filter file list.

Help Displays online help for the dialog.

Field or Button Description

Field or Button Description

Type Icon indicating whether the item in the table is a file or a folder.

Name Name of the event filter file or folder.
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Last Modified Date and time the event filter file or folder was last modified.

Size (bytes) Size of the event filter file or folder, in bytes.

Filename Name by which you want to save the event filter file.

If you create a new event filter file name, you can use any letters, 
numbers, or characters in the name that are allowed by your 
operating system. However, if you include any spaces in the new 
name, MWTM converts those spaces to dashes. For example, 
MWTM saves file “a b c” as “a-b-c”.

Number of Files
(displayed in bottom left corner)

Total number of event filter files and folders.

OK Saves any changes you made to the current event filter file and 
closes the dialog.

To save the event filter file with a new name, use one of the 
following procedures:

• To save the file with a completely new name, enter the new 
name and click OK.

• To save the file with an existing name, overwriting an old 
event filter file, select the name in the list and click OK.

MWTM saves the event filter file with the new name, saves any 
changes you made to the list of files, closes the Save File Dialog: 
Save Filter dialog, and returns to the Event Filter dialog.

Delete Deletes the selected file from the event filter file list. MWTM 
issues an informational message containing the name and location 
of the deleted file.

Cancel Closes the dialog without saving the event filter file or saving any 
changes to the event filter file list.

Help Displays online help for the dialog.

Field or Button Description
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Viewing Event Properties
MWTM enables you to view detailed information about a selected event, 
including its associated object, status, and other information.

To view detailed information about an event, right-click the event in a window, 
then select Event Properties in the right-click menu.

MWTM displays the Event Properties Dialog (Figure 5-6).

Figure 5-6 Event Properties Dialog

The Event Properties dialog contains the following tabs, fields, and button:

Tab, Field, or Button Description

Properties Tab Displays detailed information about the selected event.

Message Message text for the event.

You can customize this field. See the “Changing the Way MWTM Processes 
Events” section on page 5-26 for more information.
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Category Type of the event. Default values are:

• Create—Creation event, such as the creation of a seed file.

• Delete—Deletion event, such as the deletion of an object or file.

• Discover—Discovery event, such as Discovery beginning.

• Edit—Edit event. A user has edited an object.

• Ignore—Ignore event. A user has Ignored a link or linkset.

• Login—Login event. A user has logged in to MWTM.

• LoginDisable—LoginDisable event. MWTM has disabled a user’s 
User-Based Access authentication as a result of too many failed attempts 
to log in to MWTM.

• LoginFail—LoginFail event. An attempt by a user to log in to MWTM has 
failed.

• Logout—Logout event. A user has logged out of MWTM.

• OverWrite—OverWrite event. An existing file, such as a seed file or route 
file, has been overwritten.

• Poll—Poll event, such as an SNMP poll.

• Purge—Purge event. A user has requested Discovery with Delete 
Existing Data selected, and MWTM has deleted the existing MWTM 
database.

• Status—Status change message generated.

• Trap—SNMP trap message generated.

You can customize this field. See the “Changing Event Categories” section on 
page 5-34 for more information.

Tab, Field, or Button Description
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Severity Severity of the event. Default values are:

• Critical—The default color is red.

• Indeterminate—The default color is aqua.

• Informational—The default color is white.

• Major—The default color is orange.

• Minor—The default color is yellow.

• Normal—The default color is green.

• Warning—The default color is blue.

You can customize this field. See the “Changing Event Severities and Colors” 
section on page 5-35 for more information.

Timestamp Date and time the event was logged.

Message Name User-specified message name for the event, used by MWTM for trap 
forwarding. The default message name is MWTM.

For more information about user-specified message names and trap 
forwarding, see the “Forwarding Events as Traps to Other Hosts” section on 
page 5-50.

Acknowledged Indicates whether the event has been acknowledged.

Acknowledged By Name of the device that last acknowledged the event. If no one has 
acknowledged the event, this field is blank.

Ack Timestamp Date and time the event was last acknowledged or unacknowledged.

Node Name of the node associated with the event. If there is no node associated with 
the event, None is displayed.

Notes Tab Displays notes associated with this event.

Last Update Date and time the Notes field for this event was last updated. If there is no note 
currently associated with this event, this field displays the value Not Set.

Notes Notes associated with this event. If there is no note currently associated with 
this event, this field displays the value No Notes.

Close Closes the Event Properties dialog.

Tab, Field, or Button Description
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Related Topic:

• Viewing Basic Information for All Events, page 5-2

Attaching a Note to an Event
MWTM enables you to annotate an event, attaching a descriptive string to the 
event.

To annotate an event, right-click an event in the Event Window, then select Edit 
Notes in the right-click menu.

MWTM displays the Edit Event Dialog (Figure 5-7).

Figure 5-7 Edit Event Dialog

The Edit Event Dialog contains the following fields and buttons:

Field or Button Description

Name Message text of the event.

Last Update Date and time the Notes field for this event was last updated. If there is no note 
currently associated with this event, this field displays the value Not Set.

You cannot edit this field.
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Related Topics:

• Viewing Basic Information for All Events, page 5-2

• Viewing Event Properties, page 5-21

• Viewing Notes for an Event, page 5-25

Viewing Notes for an Event
MWTM enables you to view the notes that have been associated with an event.

To view a note, right-click an event in a window, then select View > Notes in the 
right-click menu. (The Notes option is grayed-out if there is no note associated 
with the selected event.)

MWTM displays the Event Notes dialog (Figure 5-8).

Figure 5-8 Event Notes Dialog

Notes Notes to associate with this event. In this field, you can enter any important 
information about the event, such as its associated object, what triggered the event, 
how often it has occurred, and so on.

Save Saves changes you have made to the event information and exits the Edit Event 
Dialog.

Cancel Exits the Edit Event Dialog without saving any changes.

Help Displays online help for the current window.

Field or Button Description
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The Event Notes dialog contains the following fields and button:

Related Topics:

• Attaching a Note to an Event, page 5-24

Changing the Way MWTM Processes Events
There are three main types of events in MWTM:

• Trap events, which are incoming events that are not solicited by MWTM.

• Status events, which are status changes detected by MWTM.

• User Action events, which are events triggered by user actions.

Within those broad types, there are many subordinate types of events, each with a 
default category, severity, color, message text, and event help file. MWTM 
enables you to change the default characteristics of each type of event, tailoring 
them to meet your needs.

Note Changes you make to MWTM event processing can adversely affect your 
operating environment. In most environments, MWTM recommends that you use 
the default event processing settings without modification.

To change MWTM event processing, use one of the following procedures:

• Select Tools > Event Configurator from the MWTM Main Menu.

• Select Start > Programs > Cisco MWTM Client > Launch MWTM Event 
Configurator in Windows.

Field or Button Description

Name Message text of the event.

Last Updated Date and time the Notes field for this event was last updated.

Notes Notes associated with this event.

OK Closes the Event Notes dialog.
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• Enter the mwtm eventeditor command. See the “mwtm eventeditor” section 
on page C-25 for more information.

MWTM launches the MWTM Event Configurator (Figure 5-9).

Figure 5-9 MWTM Event Configurator

The Event Configurator enables you to customize the displayed category, severity, 
color, and message associated with events; and load, save, and deploy customized 
event configurations. You can also specify a list of SNMP server to which MWTM 
is to forward events in the form of traps.

The high-level MWTM event processing settings are displayed in the left pane of 
the MWTM Event Configurator window. The detailed settings for each high-level 
setting are displayed in the right pane.

The MWTM Event Configurator menu provides the following options:

Menu Command Description

File > Load Draft Loads the local copy of the event configuration that you saved.

File > Save Draft
(Ctrl-S)

Saves a local copy of the event configuration, including any changes you 
made using the Event Configurator. You can save only one local copy of the 
event configuration. You cannot specify a file name for the local copy.

File > Load Default Loads the default event configuration on this MWTM client.

The default event configuration is the standard event configuration used by 
MWTM when it is first installed. The default event configuration stored on 
the MWTM server and shared by all MWTM clients, but it cannot be modified 
by the clients.
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File > Load Running Loads the event configuration that is currently running on the MWTM server.

File > Load Backup Loads the backup event configuration from the MWTM server.

MWTM creates a backup event configuration every time the event 
configuration on the MWTM server is overwritten.

File > Revert Reverts to the last event configuration that was loaded on the MWTM client. 
This could be the draft, default, running, or backup event configuration.

File > Deploy Deploys the event configuration that is currently being edited on this MWTM 
client to the MWTM server.

The deployed event configuration does not take effect until you restart the 
MWTM server. When you restart the MWTM server, MWTM automatically 
reflects your changes to the event configuration on the MWTM server and on 
all MWTM clients that connect to that server, and reflects any new or changed 
categories, severities, and other event characteristics in its Web display 
navigation bars.

File > Exit Closes the Event Configurator window. If you have made any changes to the 
event configuration, MWTM asks if you want to save the changes before 
leaving the window:

• Click Save Draft to save the changes in a local copy of the event 
configuration. You can save only one local copy of the event 
configuration. You cannot specify a file name for the local copy.

• Click Deploy to deploy the event configuration, including any changes 
you made, to the MWTM server.

The deployed event configuration does not take effect until you restart 
the MWTM server. When you restart the MWTM server, MWTM 
automatically reflects your changes to the event configuration on the 
MWTM server and on all MWTM clients that connect to that server, and 
reflects any new or changed categories, severities, and other event 
characteristics in its Web display navigation bars.

• Click No or Cancel to close the prompt window and return to the Event 
Configurator window.

Help > Topics
(F1)

Displays the table of contents for the MWTM online help.

Menu Command Description
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This section provides the following information:

• Changing Event Limits, page 5-30

• Specifying a List of SNMP Servers for Trap Forwarding, page 5-32

• Changing Event Categories, page 5-34

• Changing Event Severities and Colors, page 5-35

• Changing Trap Events, page 5-37

• Changing Status Alarm Events, page 5-42

• Changing User Action Events, page 5-46

Help > Window
(Shift-F1)

Displays online help for the current window.

Help > About
(F3)

Displays build date, version, SSL support, and copyright information about 
the MWTM application.

Menu Command Description
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Changing Event Limits
To change limits for the MWTM event database, select the turner beside Event 
Configuration, then click Limits in the left pane. MWTM displays the Limits 
Configuration window in the right pane, which contains the following fields:

Field Description

MaxEventDbRecords Sets the maximum number of events the MWTM event database can 
hold.

By default, the MWTM event database can hold a maximum of 5000 
events. If the database exceeds 5000 events, MWTM deletes the oldest 
events until the database is reduced to 5000 events.

To change the size of the MWTM event database, enter the new size, 
in number of events, in this field. The valid range is 0 events (that is, 
no limit) to an unlimited number of events. The default setting is 
5000 events.

Note As you increase the size of the event database, the 
performance of the MWTM server and clients is impacted.

MaxEventTimeToLive Sets the maximum length of time, in days, MWTM is to retain an 
event in the database.

By default, the MWTM event database retains events a maximum of 
7 days. MWTM deletes events that are older than 7 days.

To change the maximum age for events, enter the new age, in days, in 
this field. The valid range is 0 days (events are purged at each 
maintenance interval) to an unlimited number of days. The default 
setting is 7 days.
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CompressEventDbInterval Sets the length of time, in minutes, between maintenance checks of the 
database.

By default, MWTM performs maintenance on the event database 
every 60 minutes, deleting all events in excess of 5000 and all events 
older than 7 days.

To change the maintenance interval, enter the new interval, in minutes, 
in this field. The valid range is 0 minutes (perform continual 
maintenance; not advised) to an unlimited number of minutes. The 
default setting is 60 minutes.

Note The shorter the maintenance interval, the greater the impact on 
the performance of the MWTM server and clients.

AutomationTimeout Sets the maximum length of time, in seconds, MWTM is to allow an 
event automation script to run.

By default, the MWTM event database allows an event automation 
script to run for 300 seconds (5 minutes) before canceling the script 
and moving on.

To change the event automation timeout interval, enter the new 
interval, in seconds, in this field. The valid range is 0 seconds (no 
automation) to an unlimited number of seconds. The default setting is 
300 seconds.

Note MWTM runs each automation script sequentially, not in 
parallel. Therefore, the longer the automation timeout 
interval, the greater the chance that a failed script can delay 
follow-on scripts.

ProcessUndiscovered Determines whether MWTM is to process events from undiscovered 
nodes:

• False—Do not process events from undiscovered nodes. This is 
the default setting.

• True—Begin processing events from undiscovered nodes.

Field Description
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Specifying a List of SNMP Servers for Trap Forwarding
MWTM enables you to specify a list of SNMP server, or hosts, to which MWTM 
is to forward events in the form of traps.

For more information about enabling MWTM trap forwarding, see the 
“Forwarding Events as Traps to Other Hosts” section on page 5-50.

To specify the list of hosts, select the turner beside Event Configuration, then 
click SNMP Servers in the left pane. MWTM displays the SNMP Servers 
Configuration window in the right pane, which contains the following fields and 
buttons:

Field or Button Description

Host Name of the host NMS device that is to receive traps from MWTM. The host 
must be IP-routable, and the name must be a valid IP address or DNS name.

Port Host port number to which MWTM is to forward traps.

Community SNMP community string that MWTM is to include in forwarded traps.

Version Trap version to forward. Valid values are 1 and 2c.

Trap Type Type of trap MWTM is to forward to this host. Valid trap types are:

• CISCO-SYSLOG: The CISCO-SYSLOG-MIB clogMessageGenerated 
trap.

• CISCO-EPM-NOTIFICATION: CISCO-EPM-NOTIFICATION-MIB 
ciscoEpmNotificationAlarm trap.

Add Adds a new host name to the bottom of the list. Type over the default values with 
the new values.

Delete Deletes the selected host name from the list.
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Send a trap for all 
events

Selects the Send Traps checkbox for all MWTM events. Select this button if you 
want MWTM to forward all events to the list of hosts.

If you select this button, and then you clear even a single Send Traps checkbox 
for any event, MWTM clears this button.

This radio button is mutually exclusive with the Send a trap for no events 
button.

Send a trap for no 
events

Clears the Send Traps checkbox for all MWTM events. Select this button if you 
do not want MWTM to forward any events to the list of hosts. This is the default 
setting.

If you select this button, and then you select even a single Send Traps checkbox 
for any event, MWTM clears this button.

This radio button is mutually exclusive with the Send a trap for all events 
button.

Field or Button Description
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Changing Event Categories
To change categories for the MWTM event database, select the turner beside 
Event Configuration, then click Categories in the left pane. MWTM displays 
the Categories Configuration window in the right pane, which contains the 
following field and buttons:

Field or Button Description

Category Name Lists the names of the currently defined MWTM event categories.

By default, MWTM provides the following event categories:

• Status—Status change message generated.

• Trap—SNMP trap message generated.

• Create—Creation event, such as the creation of a seed file.

• Delete—Deletion event, such as the deletion of an object or file.

• Discover—Discovery event, such as Discovery beginning.

• Edit—Edit event. A user has edited an event, linkset, or node.

• Ignore—Ignore event. A user has Ignored a link or linkset.

• Login—Login event. A user has logged in to MWTM.

• LoginDisable—LoginDisable event. MWTM has disabled a user’s 
User-Based Access authentication as a result of too many failed attempts to 
log in to MWTM.

• LoginFail—LoginFail event. An attempt by a user to log in to MWTM has 
failed.

• Logout—Logout event. A user has logged out of MWTM.

• OverWrite—OverWrite event. An existing file, such as a seed file or route 
file, has been overwritten.
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Changing Event Severities and Colors
To change severities or colors for the MWTM event database, select the turner 
beside Event Configuration, then click Severities in the left pane. MWTM 
displays the Severities Configuration window in the right pane, which contains 
the following fields and buttons:

Category Name
(continued)

• Poll—Poll event, such as an SNMP poll.

• Purge—Purge event. A user has requested Discovery with Delete Existing 
Data selected, and MWTM has deleted the existing MWTM database.

To change the name of an existing event category, highlight the category name 
and type over it with the new name. For example, you could replace every 
occurrence of LoginFail with BadLogin.

Add Adds a new category name to the bottom of the list. Type over the default 
category name with the new name.

Delete Deletes the selected category name from the list.

If there are events in the MWTM database that use the deleted category name, 
MWTM displays the Entry Substitution Dialog, which enables you to select a 
new category name to use in place of the deleted category name. Either select an 
existing category name from the drop-down list box, or enter a new category 
name. If you enter a new category name, it is added to the Category Name field.

Field or Button Description
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Field or Button Description

Severity Name Lists the names of the currently defined MWTM event severities.

By default, MWTM provides the following event severities:

• Informational

• Normal

• Indeterminate

• Warning

• Critical

• Minor

• Major

To change the name of an existing event severity, highlight the severity name and 
type over it with the new name. For example, you could replace every occurrence 
of Error with Problem.

Severity Color Lists the colors of the currently defined MWTM event severities.

By default, MWTM provides the following event colors:

• Informational—The default color is white.

• Normal—The default color is green.

• Indeterminate—The default color is aqua.

• Warning—The default color is blue.

• Critical—The default color is red.

• Minor—The default color is yellow.

• Major—The default color is orange.

To change the color associated with an existing severity, select the current color, 
then select a new color from the drop-down list box. For example, you can display 
Warning events in maroon instead of yellow.

Add Adds a new severity name to the bottom of the list. Type over the default severity 
name with the new name, then select a color from the drop-down list box. The 
default color is white.
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Changing Trap Events
Trap events are incoming events that are not solicited by MWTM.

To change traps for the MWTM event database, select the turner beside Event 
Configuration, then select the turner beside Traps. MWTM lists the currently 
defined traps in the left pane.

To add a trap, right-click Traps and select Add from the right-click menu. 
MWTM opens the Add Entry Dialog, which lists the traps that are supported by 
MWTM but not yet configured. If all traps are configured, the Add and Delete 
options in the right-click menu are grayed out. Select a trap and click Add. 
MWTM adds the selected trap to the list of configured traps in the left pane.

To list all events associated with a trap, select the turner beside the trap. MWTM 
lists the currently defined events for that trap in the left pane.

• To add an event to a trap, right-click the trap (or one of its existing events) 
and select Add from the right-click menu. MWTM adds a new event to the 
list of events for that trap and opens the Trap Event Configuration panel for 
the new event, which enables you to change all aspects of that event.

• To delete a trap from the list of configured traps, right-click the trap and select 
Delete from the right-click menu. MWTM deletes the selected trap from the 
list of configured traps in the left pane.

Delete Deletes the selected severity name from the list.

If there are events in the MWTM database that use the deleted severity name, 
MWTM displays the Entry Substitution Dialog, which enables you to select a new 
severity name to use in place of the deleted severity name. Either select an existing 
severity name from the drop-down list box, or enter a new severity name. If you 
enter a new severity name, it is added to the Severity Name field.

Move Up Moves the selected severity up in the list.

Move Down Moves the selected severity down in the list.

Field or Button Description
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• To delete an event from a trap, right-click the event and select Delete from 
the right-click menu. MWTM deletes the selected event from the list of events 
associated with the trap in the left pane.

• To change an event, select the event in the left pane. MWTM displays the 
Trap Event Configuration panel in the right pane, which enables you to 
change all aspects of that event.

The Trap Event Configuration panel contains the following fields and buttons:

Field or Button Description

Name Name of the trap. You cannot change this field.

Event Keys and 
Setting

Names of the event keys, such as RouteDestinationState, and their settings, 
such as False.

You cannot change the names of the event keys, but you can change their settings. 
To change an event key setting, select a new setting from the drop-down list box. 
For example, you can change the setting for RouteDestinationState from 
Accessible to Unknown.

Category Category of the trap event, such as Trap.

To change the category, select a new category from the drop-down list box. The 
default category for traps is Trap.

Severity Severity of the trap event, such as Normal.

To change the severity, select a new severity from the drop-down list box.

Note The order of the severities affects the sort order of the severities in 
MWTM client tables.

Message Name User-specified message name for the event, used by MWTM for trap forwarding.

If you want MWTM to forward this event in the form of a trap to another host, 
you can specify a new, more meaningful message name for the event. The new 
message name can be from 1 to 30 characters, and can contain any letters (upper- 
or lowercase), any numbers, and any special characters. If you do not specify a 
new message name, MWTM uses the default message name, MWTM.

For more information about trap forwarding, see the “Forwarding Events as 
Traps to Other Hosts” section on page 5-50.
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Message Message text associated with the trap event.

To change the message text, type over the message text.

You can also insert variable text in the message. To do so, right-click in the 
message text area. MWTM displays a popup menu of the valid substitution 
variables for this event. To insert a variable in the text area, select it in the popup 
menu.

Help File Help file associated with the trap.

By default, MWTM provides extensive type-specific help for traps. However, if 
you prefer to provide your own enterprise-specific instructions to operators in the 
help file, MWTM enables you to do so.

To change the help file, create a new HTML help file or change the default 
MWTM help file:

• If you installed MWTM in the default directory, /opt, then the default help 
files are in the /opt/CSCOsgm/apache/share/htdocs/eventHelp directory.

• If you installed MWTM in a different directory, then the default help 
directory and files are located in that directory.

If you use an MWTM help file as a basis for your help file, rename it when you 
save it; do not use the existing MWTM name. If you do so, then the next time you 
install MWTM, MWTM overwrites the file and you lose your changes.

When you have created your new help files, store them in the 
/opt/CSCOsgm/apache/share/htdocs/customHelp directory. This directory and 
its contents are preserved when you upgrade to a new MWTM release. If you do 
not store your new help files in the customHelp directory, the files are lost the 
next time you upgrade to a new MWTM release.

When you have created your new help files and stored them in the customHelp 
directory, enter the new help file path and file name in the Help File field.

After you deploy the new event settings and restart the MWTM server, whenever 
you display help for the trap, MWTM displays your new, custom help file.

Open Opens the help file associated with the trap.

To see the help file, click Open. MWTM displays context-sensitive help for the 
selected trap in a separate Web browser.

Field or Button Description
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Action: Run Automation command or script for the trap event, to be executed by a UNIX 
process.

MWTM enables you to automate events. That is, you can configure MWTM to 
call a UNIX script to drive automatic paging or e-mail, for example, whenever 
MWTM logs an event for which you have defined an automation script.

To configure automation for an event, enter a Run line with the following format:

UNIXCommand EventParameters

where:

• UnixCommand specifies either a binary command name or a shell script.

• EventParameters are information from the event that MWTM sends to 
UnixCommand as parameters. The set of EventParameters is the same as the 
set of Message element parameters, and they are specified the same way.

After you deploy the new event settings and restart the MWTM server, the 
specified event causes the automation script to run.

Action: Run
(continued)

When configuring automation for events, keep in mind the following 
considerations:

• Detailed information about event automation scripts, including the times 
they start and stop and any output produced by the scripts, is recorded in the 
MWTM system event automation log file. For more information, see the 
“Viewing the MWTM System Event Automation Log” section on 
page 13-45.

• MWTM event automation scripts run separately from all other MWTM 
processing.

• If MWTM logs more than one automated event in rapid succession, MWTM 
runs each automation script sequentially, not in parallel. MWTM spawns a 
new UNIX process for each script, and waits for it to complete before 
running the next script.

• By default, MWTM allows an event automation script to run for 300 seconds 
(5 minutes) before canceling the script and moving on to the next script. To 
change the maximum run-time for event automation scripts, see the 
“Changing Event Limits” section on page 5-30.

Field or Button Description
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Action: Poll Checkbox indicating whether MWTM is to poll the associated nodes:

• If you want MWTM to poll the nodes, select the checkbox. 

• If you do not want MWTM to poll the nodes, clear the checkbox.

Action: Send Trap Checkbox indicating whether MWTM is to forward the event as a trap to other 
systems:

• If you want MWTM to forward the event, select the checkbox.

• If you do not want MWTM to forward the event, clear the checkbox. This is 
the default setting.

Errors Error messages associated with the trap. Correct all errors before deploying the 
new event configuration.

Field or Button Description
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Changing Status Alarm Events
Status alarm events are status changes detected by MWTM.

To change status alarms for the MWTM event database, select the turner beside 
Event Configuration, then select the turner beside Status Alarms. MWTM lists 
the currently defined status alarms in the left pane.

To add a status alarm, right-click Status Alarms and select Add from the 
right-click menu. MWTM opens the Add Entry Dialog, which lists the status 
alarms that are supported by MWTM but not yet configured. Select a status alarm 
and click Add. MWTM adds the selected status alarm to the list of configured 
status alarms in the left pane.To list all status settings associated with a status 
alarm, select the turner beside the status alarm. MWTM lists the currently defined 
status settings for that status alarm in the left pane.

• To add a status setting to a status alarm, right-click the status alarm (or one 
of its existing status settings) and select Add from the right-click menu. 
MWTM adds a new status setting to the list of status settings for that status 
alarm and opens the Status Event Configuration panel for the new status 
setting, which enables you to change all aspects of that status setting.

• To delete a status alarm from the list of configured status alarms, right-click 
the status alarm and select Delete from the right-click menu. MWTM deletes 
the selected status alarm from the list of configured status alarms in the left 
pane.

• To delete a status setting from a status alarm, right-click the status setting and 
select Delete from the right-click menu. MWTM deletes the selected status 
setting from the list of status settings associated with the status alarm in the 
left pane.

• To change a status setting, select the status setting in the left pane. MWTM 
displays the Status Event Configuration panel in the right pane, which enables 
you to change all aspects of that status setting.
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The Status Event Configuration panel contains the following fields and buttons:

Field or Button Description

Name Name of the status alarm, such as RtrInterfaceStateChanged. You cannot 
change this field.

Status Key and 
Setting

Name of the status key, such as RtrInterfaceState, and its setting, such as 
Active.

You cannot change the name of the status key, but you can change its setting. To 
change a status key, select a new key from the drop-down list box. For example, 
you can change the setting for RtrInterfaceState from Active to Down.

Category Category of the status alarm, such as Status.

To change the category, select a new category from the drop-down list box. The 
default category for status settings is Status.

Severity Severity of the status alarm, such as Normal.

To change the severity, select a new severity from the drop-down list box.

Message Name User-specified message name for the event, used by MWTM for trap forwarding.

If you want MWTM to forward this event in the form of a trap to another host, 
you can specify a new, more meaningful message name for the event. The new 
message name can be from 1 to 30 characters, and can contain any letters (upper- 
or lowercase), any numbers, and any special characters. If you do not specify a 
new message name, MWTM uses the default message name, MWTM.

For more information about trap forwarding, see the “Forwarding Events as 
Traps to Other Hosts” section on page 5-50.

Message Message text associated with the status alarm.

To change the message text, type over the message text.

You can also insert variable text in the message. To do so, right-click in the 
message text area. MWTM displays a popup menu of the valid substitution 
variables for this event. To insert a variable in the text area, select it in the popup 
menu.
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Help File Help file associated with the status alarm.

By default, MWTM provides extensive type-specific help for status alarms. 
However, if you prefer to provide your own enterprise-specific instructions to 
operators in the help file, MWTM enables you to do so.

To change the help file, create a new HTML help file or change the default 
MWTM help file:

• If you installed MWTM in the default directory, /opt, then the default help 
files are in the /opt/CSCOsgm/apache/share/htdocs/eventHelp directory.

• If you installed MWTM in a different directory, then the default help 
directory and files are located in that directory.

If you use an MWTM help file as a basis for your help file, rename it when you 
save it; do not use the existing MWTM name. If you do so, then the next time you 
install MWTM, MWTM overwrites the file and you lose your changes.

When you have created your new help files, store them in the 
/opt/CSCOsgm/apache/share/htdocs/customHelp directory. This directory and 
its contents are preserved when you upgrade to a new MWTM release. If you do 
not store your new help files in the customHelp directory, the files are lost the 
next time you upgrade to a new MWTM release.

When you have created your new help files and stored them in the customHelp 
directory, enter the new help file path and file name in the Help File field.

After you deploy the new event settings and restart the MWTM server, whenever 
you display help for the status alarm, MWTM displays your new, custom help 
file.

Open Opens the help file associated with the status alarm.

To see the help file, click Open. MWTM displays context-sensitive help for the 
selected status alarm in a separate Web browser.

Field or Button Description
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Action: Run Automation command or script for the status setting, to be executed by a UNIX 
process.

MWTM enables you to automate events. That is, you can configure MWTM to 
call a UNIX script to drive automatic paging or e-mail, for example, whenever 
MWTM logs an event for which you have defined an automation script.

To configure automation for an event, enter a Run line with the following format:

UNIXCommand EventParameters

where:

• UnixCommand specifies either a binary command name or a shell script.

• EventParameters are information from the event that MWTM sends to 
UnixCommand as parameters. The set of EventParameters is the same as the 
set of Message element parameters, and they are specified the same way.

After you deploy the new event settings and restart the MWTM server, the 
specified event causes the automation script to run.

Action: Run
(continued)

When configuring automation for events, keep in mind the following 
considerations:

• Detailed information about event automation scripts, including the times 
they start and stop and any output produced by the scripts, is recorded in the 
MWTM system event automation log file. For more information, see the 
“Viewing the MWTM System Event Automation Log” section on 
page 13-45.

• MWTM event automation scripts run separately from all other MWTM 
processing.

• If MWTM logs more than one automated event in rapid succession, MWTM 
runs each automation script sequentially, not in parallel. MWTM spawns a 
new UNIX process for each script, and waits for it to complete before 
running the next script.

• By default, MWTM allows an event automation script to run for 300 seconds 
(5 minutes) before canceling the script and moving on to the next script. To 
change the maximum run-time for event automation scripts, see the 
“Changing Event Limits” section on page 5-30.

Field or Button Description
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Changing User Action Events
User action events are events triggered by user actions.

To change user actions for the MWTM event database, select the turner beside 
Event Configuration, then select the turner beside User Actions in the left pane. 
MWTM lists the currently defined user actions in the left pane.

To add a user action, right-click User Actions and select Add from the right-click 
menu. MWTM opens the Add Entry Dialog, which lists the user actions that are 
supported by MWTM but not yet configured. Select a user action and click Add. 
MWTM adds the selected user action to the list of configured user actions in the 
left pane.

To list all settings associated with a user action, select the turner beside the user 
action. MWTM lists the currently defined settings for that user action in the left 
pane.

• To add a setting to a user action, right-click the user action (or one of its 
existing settings) and select Add from the right-click menu. MWTM adds a 
new setting to the list of settings for that user action and opens the Status 
Event Configuration panel for the new setting, which enables you to change 
all aspects of that setting.

• To delete a user action from the list of configured user actions, right-click the 
user action and select Delete from the right-click menu. MWTM deletes the 
selected user action from the list of configured user actions in the left pane.

Action: Send Trap Checkbox indicating whether MWTM is to forward the event as a trap to other 
systems:

• If you want MWTM to forward the event, select the checkbox.

• If you do not want MWTM to forward the event, clear the checkbox. This is 
the default setting.

Errors Error messages associated with the status alarm.

Field or Button Description
5-46
Cisco Mobile Wireless Transport Manager User Guide

OL-7637-01



 

Chapter 5      Working with Events
Changing the Way MWTM Processes Events
• To delete a setting from a user action, right-click the setting and select Delete 
from the right-click menu. MWTM deletes the selected setting from the list 
of settings associated with the user action in the left pane.

• To change a setting, select the setting in the left pane. MWTM displays the 
Status Event Configuration panel in the right pane, which enables you to 
change all aspects of that setting.

The User Action Event Configuration panel contains the following fields and 
buttons:

Field or Button Description

Name Name of the user action, such as FileModification. You cannot change this field.

User Action Key 
and Setting

Name of the user action key, such as ModificationType, and its setting, such as 
Create.

You cannot change the name of the user action key, but you can change its setting. 
To change a user action key, select a new key from the drop-down list box. For 
example, you can change the setting for ModificationType from Create to 
OverWrite.

Category Category of the user action, such as Delete.

To change the category, select a new category from the drop-down list box.

Severity Severity of the user action, such as Normal.

To change the severity, select a new severity from the drop-down list box. The 
default severity for user actions is Normal.

Message Name User-specified message name for the event, used by MWTM for trap forwarding.

If you want MWTM to forward this event in the form of a trap to another host, 
you can specify a new, more meaningful message name for the event. The new 
message name can be from 1 to 30 characters, and can contain any letters (upper- 
or lowercase), any numbers, and any special characters. If you do not specify a 
new message name, MWTM uses the default message name, MWTM.

For more information about trap forwarding, see the “Forwarding Events as 
Traps to Other Hosts” section on page 5-50.
5-47
Cisco Mobile Wireless Transport Manager User Guide

OL-7637-01



 

Chapter 5      Working with Events
Changing the Way MWTM Processes Events
Message Message text associated with the user action.

To change the message text, type over the message text.

You can also insert variable text in the message. To do so, right-click in the 
message text area. MWTM displays a popup menu of the valid substitution 
variables for this event. To insert a variable in the text area, select it in the popup 
menu.

Help File Help file associated with the user action.

By default, MWTM provides extensive type-specific help for user actions. 
However, if you prefer to provide your own enterprise-specific instructions to 
operators in the help file, MWTM enables you to do so.

To change the help file, create a new HTML help file or change the default 
MWTM help file:

• If you installed MWTM in the default directory, /opt, then the default help 
files are in the /opt/CSCOsgm/apache/share/htdocs/eventHelp directory.

• If you installed MWTM in a different directory, then the default help 
directory and files are located in that directory.

If you use an MWTM help file as a basis for your help file, rename it when you 
save it; do not use the existing MWTM name. If you do so, then the next time you 
install MWTM, MWTM overwrites the file and you lose your changes.

When you have created your new help files, store them in the 
/opt/CSCOsgm/apache/share/htdocs/customHelp directory. This directory and 
its contents are preserved when you upgrade to a new MWTM release. If you do 
not store your new help files in the customHelp directory, the files are lost the 
next time you upgrade to a new MWTM release.

When you have created your new help files and stored them in the customHelp 
directory, enter the new help file path and file name in the Help File field.

After you deploy the new event settings and restart the MWTM server, whenever 
you display help for the user action, MWTM displays your new, custom help file.

Open Opens the help file associated with the user action.

To see the help file, click Open. MWTM displays context-sensitive help for the 
selected user action in a separate Web browser.

Field or Button Description
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Action: Run Automation command or script for the user action, to be executed by a UNIX 
process.

MWTM enables you to automate events. That is, you can configure MWTM to 
call a UNIX script to drive automatic paging or e-mail, for example, whenever 
MWTM logs an event for which you have defined an automation script.

To configure automation for an event, enter a Run line with the following format:

UNIXCommand EventParameters

where:

• UnixCommand specifies either a binary command name or a shell script.

• EventParameters are information from the event that MWTM sends to 
UnixCommand as parameters. The set of EventParameters is the same as the 
set of Message element parameters, and they are specified the same way.

After you deploy the new event settings and restart the MWTM server, the 
specified event causes the automation script to run.

Action: Run
(continued)

When configuring automation for events, keep in mind the following 
considerations:

• Detailed information about event automation scripts, including the times 
they start and stop and any output produced by the scripts, is recorded in the 
MWTM system event automation log file. For more information, see the 
“Viewing the MWTM System Event Automation Log” section on 
page 13-45.

• MWTM event automation scripts run separately from all other MWTM 
processing.

• If MWTM logs more than one automated event in rapid succession, MWTM 
runs each automation script sequentially, not in parallel. MWTM spawns a 
new UNIX process for each script, and waits for it to complete before 
running the next script.

• By default, MWTM allows an event automation script to run for 300 seconds 
(5 minutes) before canceling the script and moving on to the next script. To 
change the maximum run-time for event automation scripts, see the 
“Changing Event Categories” section on page 5-34.

Field or Button Description
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Forwarding Events as Traps to Other Hosts
MWTM enables you to forward MWTM events to other hosts, in the form of 
SNMP traps. This enables MWTM to integrate with high-level event- and 
alarm-monitoring systems such as the Cisco Info Center (CIC), HP OpenView, 
and Micromuse's Netcool suite of products. These systems can provide a single 
high-level view of all alarm monitoring in your network, making it easier to detect 
and resolve problems.

To forward MWTM events to other hosts, follow these steps:

Step 1 Specify the list of SNMP servers, or hosts, to which you want MWTM to forward 
traps. See the “Specifying a List of SNMP Servers for Trap Forwarding” section 
on page 5-32 for more information.

Step 2 Specify the events you want to forward, using one of the following procedures:

a. To forward all MWTM events, select the Send a trap for all events radio 
button in the SNMP Servers Configuration window of the MWTM Event 
Configurator. See the “Specifying a List of SNMP Servers for Trap 
Forwarding” section on page 5-32 for more information.

b. To forward only selected events, edit the events in the MWTM Event 
Configurator and select the Send Trap checkbox. For more information, see 
the description of the Send Trap field in one of the following sections:

– Changing Trap Events, page 5-37

– Changing Status Alarm Events, page 5-42

– Changing User Action Events, page 5-46

Action: Send Trap Checkbox indicating whether MWTM is to forward the event as a trap to other 
systems:

• If you want MWTM to forward the event, select the checkbox.

• If you do not want MWTM to forward the event, clear the checkbox. This is 
the default setting.

Errors Error messages associated with the user action.

Field or Button Description
5-50
Cisco Mobile Wireless Transport Manager User Guide

OL-7637-01



 

Chapter 5      Working with Events
Setting Sounds for Events at an MWTM Client
Step 3 (Optional) Specify new, more meaningful names for the events you want to 
forward. If you do not specify a new message name for an event, MWTM uses the 
default message name, MWTM. For more information, see the description of the 
Message Name field in one of the following sections:

• Changing Trap Events, page 5-37

• Changing Status Alarm Events, page 5-42

• Changing User Action Events, page 5-46

Step 4 Save your new event settings, deploy them to the MWTM server, and restart the 
MWTM server.

Setting Sounds for Events at an MWTM Client
MWTM enables you to create and change event sound filters for the MWTM 
client. Event sound filters determine the sounds that the MWTM client plays when 
specific events are logged. The MWTM client plays the sounds even if the Event 
Window is not currently displayed.

On Solaris/Linux, the root user can access the sound feature from a local or 
remote device. However, users other than the root user must use a local device, 
and must use a local client, not a remote Solaris/Linux MWTM client accessed 
using the xhost + UNIX command.

This section provides the following information:

• Listing Event Sound Filters, page 5-52

• Creating a New Event Sound Filter, page 5-54

• Adding a Sound File to MWTM, page 5-57

• Changing an Existing Event Sound Filter, page 5-57

• Deleting an Event Sound Filter, page 5-58

• Playing and Muting Event Sounds, page 5-58
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Listing Event Sound Filters
MWTM enables you to change the list of event sound filters that the MWTM 
client applies to events, or prevent the MWTM client from playing sounds for 
events.

To work with the list of event sound filters, select Tools > Event Sounds from the 
MWTM Main Menu. MWTM displays the Event Sound Filters List dialog 
(Figure 5-10).

Figure 5-10 Event Sound Filters List Dialog

The Event Sound Filters List dialog lists all event sound filters that have been 
defined, and contains the following fields and buttons:
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Related Topics:

• Setting Sounds for Events at an MWTM Client, page 5-51

• Working with Events, page 5-1

Field or Button Description

Sound filters 
applied in 
order:

Indicates the order in which sound filters are to be applied, from top to bottom. That 
is, if an event matches two or more filters in the list, the top-most filter determines 
the sound that the MWTM client plays.

This field is blank until you have created at least one new sound filter for events.

Move Up Moves the selected event sound filter up in the Sound filters applied in order: list.

Move Down Moves the selected event sound filter down in the Sound filters applied in order: 
list.

New Opens the Event Sound Filters dialog, which enables you to create a new event sound 
filter.

Edit Opens the Event Sound Filters dialog, which enables you to change an existing event 
sound filter in the Sound filters applied in order: list.

Delete Deletes the selected event sound filter from the Sound filters applied in order: list.

Mute Sounds Checkbox indicating whether the MWTM client is to play event sounds:

• To play event sounds, clear this checkbox. This is the default setting.

• To not play event sounds, select this checkbox.

OK Applies any changes you made to the event sound filters list and closes the Event 
Sound Filters List dialog. When you are satisfied with the changes you have made to 
the event sound filters list, click OK.

Apply Applies any changes you made to the event sound filters list without closing the Event 
Sound Filters List dialog.

Cancel Closes the Event Sound Filters List dialog without applying any changes to the event 
sound filters list.

Help Displays online help for the current window.
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Creating a New Event Sound Filter
MWTM enables you to create a new event sound filter. To do so, open the Event 
Sound Filters List dialog, as described in “Listing Event Sound Filters” section on 
page 5-52, then click New. MWTM displays the Event Sound Filters dialog 
(Figure 5-10).

Figure 5-11 Event Sound Filters Dialog

The Event Sound Filters dialog contains the following fields and buttons:
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Button Description

Filter Name Name of the event sound filter file.

Enter a name for the filter, then specify filter criteria for this event sound filter in the 
Event Sound Filter Criteria field.

Event Sound 
Filter Criteria

Table listing the filter criteria for this event sound filter. To add a criteria, select 
options from the drop-down list boxes:

• To filter based on message text:

a. Select Message Text from the first drop-down list box.

b. Select Contains, Equals, Does Not Contain, or Does Not Equal from the 
second drop-down list box.

c. Enter the message text in the character string field.

• To filter based on event severity:

a. Select Severity from the first drop-down list box.

b. Select Equals or Does Not Equal from the second drop-down list box.

c. Select a severity, such as Normal or Error, from the third drop-down list box.the 
message text.

Event Sound 
Filter Criteria
(continued)

• To filter based on event category:

a. Select Category from the first drop-down list box.

b. Select Equals or Does Not Equal from the second drop-down list box.

c. Select a category, such as Status or Purge, from the third drop-down list box.the 
message text.

• To filter based on the name of the node associated with the event:

a. Select Node from the first drop-down list box.

b. Select Equals or Does Not Equal from the second drop-down list box.

c. Select a node from the third drop-down list box. MWTM lists all nodes that have 
been discovered in the drop-down list box.

More Adds one or more additional filter criteria to the event sound filter.

To add a filter criteria to the event sound filter, click More. MWTM adds a new 
criteria to the bottom of the list.
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Related Topics:

• Listing Event Sound Filters, page 5-52

• Working with Events, page 5-1

Fewer Removes one or more filter criteria from the event sound filter.

To remove a filter criteria from the event sound filter, click Fewer. MWTM deletes 
the last criteria in the list.

Play this 
sound:

Drop-down list box indicating the sound to be played if an event matches this event 
sound filter.

MWTM client sound files are stored in the MWTM client’s sounds directory:

• If you installed the MWTM client for Solaris/Linux in the default directory, /opt, 
then the sound file directory is /opt/CSCOsgmClient/sounds.

• If you installed the MWTM client for Windows in the default directory, /Program 
Files, then the sound file directory is C:\Program Files\SGMClient\sounds.

• If you installed MWTM in a different directory, then the sound file directory is 
located in that directory.

To add a sound file to MWTM, add it to the sounds directory. See the “Adding a 
Sound File to MWTM” section on page 5-57 for more information.

Play Plays a sample of the sound selected in the Play this sound: drop-down list box.

OK Applies any changes you made to the event sound filter criteria and closes the Event 
Sound Filters dialog.

When you are satisfied with the changes you have made to the event sound filters, 
click OK.

Cancel Closes the Event Sound Filters dialog without applying any changes to the event 
sound filter criteria.

Help Displays online help for the current window.

Button Description
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Adding a Sound File to MWTM
You can add sound files to an MWTM client. MWTM clients can play the 
following sound file formats: AIFC, AIFF, AU, SND, and WAV.

MWTM client sound files are stored in the MWTM client’s sounds directory:

• If you installed the MWTM client for Solaris/Linux in the default directory, 
/opt, then the sound file directory is /opt/CSCOsgmClient/sounds.

• If you installed the MWTM client for Windows in the default directory, 
/Program Files, then the sound file directory is 
C:\Program Files\SGMClient\sounds.

• If you installed MWTM in a different directory, then the sound file directory 
is located in that directory.

If for some reason MWTM cannot play a specified sound file, MWTM plays a 
default beep. For example, MWTM cannot play a sound file if one of the 
following conditions exists:

• The file has been moved or deleted from the sounds directory

• The sounds directory has been deleted or cannot be found

• Some other application is using all of the sound resources

• There is no sound card present

Related Topics:

• Creating a New Event Sound Filter, page 5-54

• Working with Events, page 5-1

Changing an Existing Event Sound Filter
MWTM enables you to change an existing event sound filter. To do so, open the 
Event Sound Filters List dialog, as described in “Listing Event Sound Filters” 
section on page 5-52, select the filter in the Sound filters applied in order: list, 
then click Edit. MWTM displays the Event Sound Filters dialog (Figure 5-10), 
populated with the selected filter’s settings.

Change the settings as desired, then click OK. MWTM applies your changes and 
closes the Event Sound Filters dialog.
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Deleting an Event Sound Filter
MWTM enables you to delete an existing event sound filter. To do so, open the 
Event Sound Filters List dialog, as described in “Listing Event Sound Filters” 
section on page 5-52, select the filter in the Sound filters applied in order: list, 
then click Delete. MWTM deletes the selected filter.

Playing and Muting Event Sounds
MWTM enables you to specify whether you want the MWTM client to play event 
sounds. To do so, open the Event Sound Filters List dialog, as described in 
“Listing Event Sound Filters” section on page 5-52:

• To play event sounds, clear the Mute Sounds checkbox. This is the default 
setting.

• To not play event sounds, select the Mute Sounds checkbox.
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Working with Nodes

MWTM enables you to view information about all discovered nodes, including 
their IP addresses, status, and other important information.

This section includes the following information:

• Viewing Basic Information for Nodes, page 6-2

• Viewing Detailed Information for a Node, page 6-13

• Editing a Node, page 6-53

• Viewing Notes for a Node, page 6-61

• Deleting a Node, page 6-61

• Unmanaging and Managing a Node, page 6-64

• Polling a Node, page 6-66

• Allowing and Disallowing Trap Processing for a Node, page 6-67

• Excluding a Node from a View, page 6-68

• Ignoring a Node, page 6-68

• Viewing Ignored Nodes, page 6-69

• Viewing Node Information Using a Web Browser, page 6-69

Related Topics:

• Changing MWTM Client Preference Settings, page 11-3

• Resizing, Sorting, and Hiding Table Columns, page 3-37
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Viewing Basic Information for Nodes
To view basic information for nodes, select Nodes in the left pane of the MWTM 
Main Window. MWTM displays the Node Window (Figure 6-1).

Figure 6-1 Node Window

The Node Window provides information about all nodes that have been 
discovered by MWTM, including their IP addresses, status, and other important 
information.

The Node Window is composed of the following sections:

• Right-Click Menu for All Nodes, page 6-3

• Right-Click Menu for a Specific Node, page 6-4

• Node Table, page 6-9

Related Topics:

• Editing Node Properties, page 6-54

• Editing a Node, page 6-53

• Viewing Detailed Information for a Node, page 6-13

• Resizing, Sorting, and Hiding Table Columns, page 3-37
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• Using the MWTM Main Menu, page 3-9

• Viewing Notes for a Node, page 6-61

Right-Click Menu for All Nodes
To see the right-click menu for all nodes, select Nodes in the left pane and click 
the right mouse button. The nodes right-click menu provides the following 
options:

Menu Command Description

Show In New Window Opens the Node Window in a new window.

Sort Tree By Status Sorts the entire tree in the left pane by the status of each object.

Sort Tree By Name Sorts the entire tree in the left pane by the name of each object.

Back > List of Windows Navigates back to a window viewed in this session.

MWTM maintains a list of up to 10 Back windows.

Forward > List of 
Windows

Navigates forward to a window viewed in this session.

MWTM maintains a list of up to 10 Forward windows.
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Right-Click Menu for a Specific Node
The Node Window provides a subset of the MWTM Main Menu as a right-click 
menu. To see this menu, select a node and click the right mouse button. The node 
right-click menu provides the following options:

Menu Command Description

Edit > Properties Opens the Edit Properties Dialog for the selected node.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level Power 
User (Level 2) and higher. 

Edit > Notes Opens the Edit Notes Dialog for the selected node.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level Power 
User (Level 2) and higher.

Edit > SNMP IP Addresses Opens the Edit SNMP IP Addresses Dialog for a Node for 
the selected node.

This option is grayed-out if the selected node has no 
associated SNMP IP addresses.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level 
Network Administrator (Level 4) and higher.

Clear Event Icon Deletes the event icon (orange triangle) from MWTM 
displays for the selected node, for this MWTM client only. 
The actual events are not deleted from MWTM, only the 
event icon for the selected node for this MWTM client.

This option is grayed-out if the selected node has no 
associated event icon.
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Delete Deletes the currently selected node from the MWTM 
database. MWTM displays the Confirm Deletion dialog:

• To delete the selected node, click Yes. The node is 
deleted from the MWTM database and the Confirm 
Deletion dialog is closed.

• To retain the selected node, click No. The node is kept 
in the MWTM database and the Confirm Deletion 
dialog is closed.

Note If you delete all linksets to an Unmanaged node, 
MWTM does not automatically delete the node. 
Instead, you must manually delete the node. See the 
“Deleting a Node” section on page 6-61 for more 
information.

• To prevent MWTM from displaying the Confirm 
Deletion dialog, select the Do not show this again 
checkbox.

Note If you select the Do not show this again checkbox, 
and you later decide you want MWTM to begin 
displaying the Confirm Deletion dialog again, you 
must select the Confirm Deletions checkbox in the 
General GUI settings in the Preferences window. 
For more information, see the description of the 
Confirm Deletions checkbox in the “Startup/Exit 
Settings” section on page 11-7.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level 
Network Administrator (Level 4) and higher.

Back > List of Windows Navigates back to a window viewed in this session.

MWTM maintains a list of up to 10 Back windows.

Forward > List of Windows Navigates forward to a window viewed in this session.

MWTM maintains a list of up to 10 Forward windows.

View > Components Displays the Components panel for the selected node.

Menu Command Description
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View > Configuration Details Displays the Configuration Details panel for the selected 
node.

View > Notes Displays the Notes panel for the selected node.

If there are no notes associated with the selected node, this 
option is grayed-out.

View > Events Displays the Recent Events panel for the selected node and 
its associated network objects.

Event History > Status Change 
Messages

Displays the MWTM Network Status Log for Status 
Change Messages in a Web browser, with messages 
displayed for only the selected node.

Event History > SNMP Trap Messages Displays the MWTM Network Status Log for SNMP Trap 
Messages in a Web browser, with messages displayed for 
only the selected node.

Event History > Status and Trap 
Messages

Displays the MWTM Network Status Log for Status 
Change Messages and SNMP Trap Messages in a Web 
browser, with messages displayed for only the selected 
node.

Event History > Network Status 
Metrics

Displays the MWTM Network Status Log for Metrics in a 
Web browser, with messages displayed for only the 
selected node.

Ignore Ignores the selected node at the next polling cycle.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level Power 
User (Level 2) and higher.

Unignore Stops ignoring the selected node at the next polling cycle.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level Power 
User (Level 2) and higher.

Drill-Down > Show Syslog Messages Opens the Node Details: Syslog table, which polls the 
selected node and displays all messages in its system log.

This option is not available if the node is in Unknown or 
Unmanaged status.

Menu Command Description
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Drill-Down > Show CPU Processes Opens the Node Details: CPU Processes panel, which polls 
the selected node for information about its CPU processes.

This option is not available if the node is in Unknown or 
Unmanaged status.

Drill-Down > Show Trap Configuration Opens the Node Details: Trap Configuration panel, which 
displays all trap settings for the node, as well as all hosts 
and port numbers to which the node sends traps.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level 
System Administrator (Level 5).

This option is not available if the node is in Unknown or 
Unmanaged status.

Router > Home Page Displays the home page of the router in a new Web browser 
window.

This option is grayed-out if the selected node is not a 
RAN-O node.

Router > Telnet To Links to the router.

This option is grayed-out if the selected node has no IP 
addresses.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level 
Network Operator (Level 3) and higher.

Poll Node > Normal Poll Polls all selected nodes, retaining all currently known 
linksets.

Normal Poll retains all linksets associated with polled 
nodes, even linksets that have been deleted and are 
therefore in Unknown status.

This option is grayed-out if the selected node has no IP 
addresses.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level 
Network Operator (Level 3) and higher.

Menu Command Description
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Poll Node > Clean Poll Polls all selected nodes and removes any Unknown 
network objects after the completion of the poll.

Clean Poll removes all network objects from the node at 
the completion of the poll.

This option is grayed-out if the selected node has no IP 
addresses.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level 
Network Operator (Level 3) and higher.

Manage Removes the Unmanaged status from the selected node.

You cannot remove the Unmanaged status from a node 
with a Device Type of Unknown. If you select a node with 
a Device Type of Unknown, then this menu option is 
grayed-out and cannot be selected.

This option is grayed-out if the selected node has no IP 
addresses.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level 
Network Administrator (Level 4) and higher.

Unmanage Labels the selected node Unmanaged.

You cannot label a node Unmanaged if it has a Device 
Type of Unknown. If you select a node with a Device Type 
of Unknown, then this menu option is grayed-out and 
cannot be selected.

This option is grayed-out if the selected node has no IP 
addresses.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level 
Network Administrator (Level 4) and higher.

Exclude from View Excludes the selected node from the current view. See the 
“Creating a New View” section on page 4-42 for more 
information about excluding nodes.

Menu Command Description
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Node Table
The node table displays information about the nodes that have been discovered by 
MWTM.

To see mouse over help popup for each column in the table, place the cursor over 
a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the 
full data in a mouse over help popup.

You can resize each column, or sort the table based on the information in one of 
the columns. By default, this table is sorted by Status, and MWTM displays all 
of the columns in the node table except Internal ID, Router Uptime, Reboot 
Reason, Notes, and Status Reason.

• To display hidden columns, right-click in the table header and select the 
checkboxes for the columns you want to display.

• To hide columns, right-click in the table header and clear the checkboxes for 
the columns you want to hide.

See the “Resizing, Sorting, and Hiding Table Columns” section on page 3-37 for 
more information about resizing, sorting, displaying, or hiding columns.

The node table contains the following columns:

Column Description

Internal ID Internal ID of the node. The internal ID is a unique ID for every object, 
assigned by MWTM for its own internal use. It can also be useful when the 
TAC is debugging problems.

Name Name of the node.

Primary SNMP 
Address

IP address of the node, used by SNMP to poll the node. (There might be other 
IP addresses on the node that are not the primary SNMP address.)
6-9
Cisco Mobile Wireless Transport Manager User Guide

OL-7637-01



 

Chapter 6      Working with Nodes
Viewing Basic Information for Nodes
Device Device type of the node. Possible values are:

• CiscoMWR-1941-DC-A—Cisco MWR-1941-DC-A series router

• RNC—Radio Network Controller

• BSC—Base Station Controller

• BTS—Base Transceiver Station

• Node B—The radio transmission/reception unit for communication 
between radio cells

• IPDevice—IP device, other than those listed above. You can assign this 
icon to an unknown node if you know that it is an IP device.

• Unknown—MWTM is unable to determine the device type.

IOS MIB Level MIB conformance level used by the RAN-O device.

Router Uptime Time the router has been up, in days, hours, minutes, and seconds.

Reboot Reason Reason for the last reboot of the router.

Ignored Indicates whether the node is to be included when aggregating and 
displaying MWTM status information:

• Clear the checkbox to include the node. This is the default setting.

• Select the checkbox to exclude the node.

This field can be edited by users with authentication level Power User 
(Level 2) and higher.

Process Traps Indicates whether MWTM is to process traps from this node:

• Select the checkbox if you want MWTM to process traps from this node. 
This is the default setting.

• Clear the checkbox if you do not want MWTM to process traps from this 
node.

This field can be edited by users with authentication level Power User 
(Level 4) and higher.

Column Description
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Trap Polling Enabled Indicates whether trap polling is enabled for this node. This checkbox is 
read-only. 

• If you want to enable trap polling for this node, set ipran-mib 
snmp-access to inBand on the device.

• If you want to disable trap polling for this node, set ipran-mib 
snmp-access to outOfBand on the device.

Report Polling 
Enabled

Indicates whether report polling is enabled for this node. This checkbox is 
read-only. 

• If you want to enable report polling for this node, set ipran-mib 
location to aggSite on the device.

• If you want to disable report polling for this node, set ipran-mib 
location to cellSite on the device.

Notes Indicates whether there is a note associated with the node.

Events Indicates whether there is a recent event associated with the node. (Even if 
the server purges all of the events associated with the node, MWTM 
continues to display the event icon in this field.)

• To delete the event icon (orange triangle) from MWTM displays for a 
specific node, select the node and click the icon.

• To delete the event icon from MWTM displays for all nodes, select Edit 
> Clear All Events from the MWTM Main Menu.

Note During Discovery, MWTM might flag most nodes with an event 
icon. If the event icons are too distracting, use the Edit > Clear All 
Events menu option to remove them.

Last Status Change Date and time that the status of the node last changed.

Column Description
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Status Current status of the node. Possible values are:

Active (green)

Discovering (cyan)

Polling (cyan)

Unknown (red)

Unmanaged (gray)

Waiting (gray)

Warning (yellow)

For detailed definitions of each status, see the “Status Definitions for Nodes” 
section on page A-5.

Status Reason Reason for the current status of the node.

For a full list of possible reasons, see the stateReasons.html file:

• If you installed MWTM in the default directory, /opt, then the file is 
located at /opt/CSCOsgm/apache/share/htdocs/eventHelp directory.

• If you installed MWTM in a different directory, then the help directory 
and file are located in that directory.

If the cell is too small to show all of the status reason, place the cursor over 
the cell to see the full status reason in a mouse over help popup.

The status reasons are listed in order of decreasing magnitude. If two or more 
reasons apply, the reason of greatest magnitude is displayed.

If the status reason is Unsupported Configuration, correct the 
configuration and enter the mwtm cleandiscover command to delete all 
current network data and begin a clean discovery of the RAN-O network. If 
the status reason is still Unsupported Configuration, enter the mwtm clean 
command to restore the MWTM server to a “clean” state, such as would exist 
after a new installation of MWTM. For more information on the use of these 
commands, see the “MWTM Command Reference” section on page C-1.

Column Description
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Viewing Detailed Information for a Node
MWTM can display detailed information about a selected node, including its 
status and other information.

Updates for the node that are received from the MWTM server are reflected 
automatically in this window.

To display detailed information for a node, use one of the following procedures:

• Select Nodes in the left pane of the MWTM Main Window, right-click a node 
in the right pane, then select View > Configuration Details in the right-click 
menu.

• Select the turner beside Nodes in the left pane of the MWTM Main Window, 
then select a node.

MWTM displays the Node Details Window (Figure 6-2).
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Figure 6-2 Node Details Window

The Node Details Window is composed of the following sections:

• Node Details: Right-Click Menu, page 6-15

• Node Details: CPU Processes, page 6-21

• Node Details: Trap Configuration, page 6-22

• Node Details: Shorthaul Performance, page 6-23

• Node Details: Backhaul Performance, page 6-32

• Node Details: Components, page 6-38

• Node Details: Configuration Data, page 6-40

• Node Details: Notes, page 6-46
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• Node Details: Recent Events, page 6-47

• Node Details: Syslog, page 6-52

Related Topics:

• Viewing Basic Information for Nodes, page 6-2

Node Details: Right-Click Menu
The Node Details Window provides a right-click menu. To see this menu for a 
node, select a node in the left pane and click the right mouse button. The node 
details right-click menu provides the following options:

Menu Command Description

Show In New Window Opens the Node Details Window for the selected node in a 
new window.

Edit > Properties Opens the Edit Properties Dialog for the selected node.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level Power 
User (Level 2) and higher. 

Edit > Notes Opens the Edit Notes Dialog for the selected node.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level Power 
User (Level 2) and higher.

Edit > SNMP IP Addresses Opens the Edit SNMP IP Addresses Dialog for a Node for 
the selected node.

This option is grayed-out if the selected node has no 
associated SNMP IP addresses.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level 
Network Administrator (Level 4) and higher.
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Clear Event Icon Deletes the event icon (orange triangle) from MWTM 
displays for the selected node, for this MWTM client only. 
The actual events are not deleted from MWTM, only the 
event icon for the selected node for this MWTM client.

This option is grayed-out if the selected node has no 
associated event icon.

Delete Deletes the currently selected node from the MWTM 
database. MWTM displays the Confirm Deletion dialog:

• To delete the selected node, click Yes. The node is 
deleted from the MWTM database and the Confirm 
Deletion dialog is closed.

• To retain the selected node, click No. The node is kept 
in the MWTM database and the Confirm Deletion 
dialog is closed.

Note If the node has an associated peer, you will be 
prompted that the node cannot be deleted.

• To prevent MWTM from displaying the Confirm 
Deletion dialog, select the Do not show this again 
checkbox.

Note If you select the Do not show this again checkbox, 
and you later decide you want MWTM to begin 
displaying the Confirm Deletion dialog again, you 
must select the Confirm Deletions checkbox in the 
General GUI settings in the Preferences window. 
For more information, see the description of the 
Confirm Deletions checkbox in the “Startup/Exit 
Settings” section on page 11-7.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level 
Network Administrator (Level 4) and higher.

Back > List of Windows Navigates back to a window viewed in this session.

MWTM maintains a list of up to 10 Back windows.

Menu Command Description
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Forward > List of Windows Navigates forward to a window viewed in this session.

MWTM maintains a list of up to 10 Forward windows.

View > Components Displays the Components panel for the selected node.

View > Configuration Details Displays the Configuration Data panel for the selected 
node.

View > Notes Displays the Notes panel for the selected node.

If there are no notes associated with the selected node, this 
option is grayed-out.

View > Events Displays the Recent Events panel for the selected node and 
its associated network objects.

Event History > Status Change 
Messages

Displays the MWTM Network Status Log for Status 
Change Messages in a Web browser, with messages 
displayed for only the selected node.

Event History > SNMP Trap Messages Displays the MWTM Network Status Log for SNMP Trap 
Messages in a Web browser, with messages displayed for 
only the selected node.

Event History > Status and Trap 
Messages

Displays the MWTM Network Status Log for Status 
Change Messages and SNMP Trap Messages in a Web 
browser, with messages displayed for only the selected 
node.

Event History > Network Status 
Metrics

Displays the MWTM Network Status Log for Metrics in a 
Web browser, with messages displayed for only the 
selected node.

Ignore Ignores the selected node at the next polling cycle.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level Power 
User (Level 2) and higher.

Unignore Stops ignoring the selected node at the next polling cycle.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level Power 
User (Level 2) and higher.

Menu Command Description
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Drill-Down > Show Syslog Messages Opens the Node Details: Syslog table, which polls the 
selected node and displays all messages in its system log.

This option is not available if the node is in Unknown or 
Unmanaged status.

Drill-Down > Show CPU Processes Opens the Node Details: CPU Processes panel, which polls 
the selected node for information about its CPU processes.

This option is not available if the node is in Unknown or 
Unmanaged status.

Drill-Down > Show Trap Config Opens the Node Details: Trap Configuration panel, which 
displays all trap settings for the node, as well as all hosts 
and port numbers to which the node sends traps.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level 
System Administrator (Level 5).

This option is not available if the node is in Unknown or 
Unmanaged status.

Latest Reports > RAN Capacity 
Planning

Displays the RAN Capacity Planning Report for the node, 
in a Web browser.

This option is not available if the node is in Unknown or 
Unmanaged status.

Latest Reports > RAN Statistics Displays the RAN Backhaul 15 Minutes Statistics report 
associated with the node, in a Web browser.

This option is not available if the node is in Unknown or 
Unmanaged status.

Router > Home Page Displays the home page of the router in a new Web browser 
window.

This option is grayed-out if the selected node is not a 
RAN-O node.

Menu Command Description
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Router > Telnet To Links to the router.

This option is grayed-out if the selected node has no IP 
addresses.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level 
Network Operator (Level 3) and higher.

Poll Node > Normal Poll Polls all selected nodes, retaining all currently known 
linksets.

Normal Poll retains all linksets associated with polled 
nodes, even linksets that have been deleted and are 
therefore in Unknown status.

This option is grayed-out if the selected node has no IP 
addresses.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level 
Network Operator (Level 3) and higher.

Poll Node > Clean Poll Polls all selected nodes and removes any Unknown 
network objects after the completion of the poll.

Clean Poll removes all network objects from the node at 
the completion of the poll.

This option is grayed-out if the selected node has no IP 
addresses.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level 
Network Operator (Level 3) and higher.

Menu Command Description
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Manage Removes the Unmanaged status from the selected node.

You cannot remove the Unmanaged status from a node 
with a Device Type of Unknown. If you select a node with 
a Device Type of Unknown, then this menu option is 
grayed-out and cannot be selected.

This option is grayed-out if the selected node has no IP 
addresses.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level 
Network Administrator (Level 4) and higher.

Unmanage Labels the selected node Unmanaged.

You cannot label a node Unmanaged if it has a Device 
Type of Unknown. If you select a node with a Device Type 
of Unknown, then this menu option is grayed-out and 
cannot be selected.

This option is grayed-out if the selected node has no IP 
addresses.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level 
Network Administrator (Level 4) and higher.

Exclude from View Excludes the selected node from the current view. See the 
“Creating a New View” section on page 4-42 for more 
information about excluding nodes.

Menu Command Description
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Node Details: CPU Processes
The Node Details: CPU Processes panel is not available if the node is in 
Discovery, Polling, Unknown, or Unmanaged status.

The Node Details: CPU Processes panel displays one CPU Utilization Percentage 
table for each active Route Switch Processor (RSP) CPU.

Note This window polls your network periodically. To prevent unnecessary traffic on 
your network, close this window when you no longer need to refer to it.

The CPU Utilization Percentage table contains the following fields and buttons:

Field or Button Description

Poll Interval Poll interval used to collect data for the table.

Last Poll Time the last poll was run.

This field initially displays the phrase Polling device. After the first polling 
cycle, MWTM populates this field with the actual time of the last poll.

PID Process identifier.

Name Name of the process.

Time Created Total time since the process was created.

Total Runtime CPU time the process has used.

Times Invoked Number of times the process has been invoked.

Average Runtime Average CPU time for each process invocation.

5 Sec % Average CPU utilization percentage for the node over the last 5 seconds.

1 Min % Average CPU utilization percentage for the node over the last minute.

5 Min % Average CPU utilization percentage for the node over the last 5 minutes.

Priority Process queue priority. Possible values are:

• Low

• Normal

• High

• Critical
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Node Details: Trap Configuration
The Node Details: Trap Configuration table displays all trap settings for the 
selected node, as well as all hosts and port numbers to which the node sends traps.

If you have implemented MWTM User-Based Access, this option is available to 
users with authentication level System Administrator (Level 5).

Note This window polls your network periodically. To prevent unnecessary traffic on 
your network, close this window when you no longer need to refer to it.

The Node Details: Trap Configuration table displays the following information 
for the selected node:

Column Description

Poll Interval Poll interval used to collect data for the table.

Last Poll Time the last poll was run.

This field initially displays the phrase Polling device. After the first polling 
cycle, MWTM populates this field with the actual time of the last poll.

RAN Trap Settings Indicates whether the following GSM RAN trap settings are enabled:

• GSM State Change

• UMTS State Change

• Utilization Threshold Change

IP Address IP address of a host to which the node sends traps.

Port Port to which the node sends traps.

Trap Version Trap version sent to this IP address and port.

Community String SNMP community name used by the node for read access to the information 
maintained by the SNMP agent on the device.
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Node Details: Shorthaul Performance
Real-time statistics are displayed through the Shorthaul Performance tab of the 
Node Details window. 

Note This window polls your network periodically. To prevent unnecessary traffic on 
your network, close this window when you no longer need to refer to it.

MWTM enables you to view the following shorthaul real-time statistics:

• Change Poller, page 6-23

• Shorthaul Performance: Bytes, page 6-24

• Shorthaul Performance: Packets, page 6-26

• Shorthaul Performance: Sent Utilization, page 6-28

• Shorthaul Performance: Received Utilization, page 6-29

• Shorthaul Performance: Errors, page 6-31

Change Poller

To change the poll interval, click the Change Poller button in any Shorthaul 
Performance or Backhaul Performance window. MWTM displays the Poller 
Settings Window (Figure 6-3).

Figure 6-3 Poller Settings Window
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The Poller Settings window displays the following information for the selected 
node:

Shorthaul Performance: Bytes

To display real-time statistics for shorthaul bytes sent and received over time, 
click the Shorthaul Performance tab in the Node Details window, then click the 
Bytes tab.

The Shorthaul Performance: Bytes window displays the following information for 
the selected node:

Column/Button Description

Poll Interval 
(secs)

The poll interval, in seconds, for the selected node.

To set a new poll interval, click in the Poll Interval (secs) text box and enter a new 
value. The default value is 15 seconds. Valid values are between 15 and 60.

Current Poll 
Interval

Value of the poll interval currently in use.

Number of Polls 
Received

Number of polls received by the selected node.

Running Time Time in hours, minutes, and seconds that the poller has been running.

Change Changes the poll interval from the current setting to the value you have entered in 
the Poll Interval (secs) text box.

Close Closes the Poller Settings window.

Help Displays online help for the current window.

Column Description

Change Poller Opens the Poller Settings dialog to allow you to change the poll interval. For more 
information, see Change Poller, page 6-23.

Poll Interval 
(secs)

The poll interval, in seconds, for the selected node.

To set a new poll interval, click the Change Poller button. The default value is 15 
seconds.

Last Poll Date and time of the last poll of the node. 
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Interface Names of the RAN interfaces for which real-time statistics are collected:

Cumulative values for all the interfaces are shown in the Totals row. 

Averages of all the intefaces are displayed in the Averages row.

Received Number of bytes received on the interface.

Received Per 
Second

Rate at which bytes are received (per second).

Sent Number of bytes sent on the interface.

Sent Per Second Rate at which bytes are sent (per second).

Utilization 
Chart

Displays the number of bytes sent and received for the node’s interface as a 
function of time.

To see the exact time and data coordinates for a data point, left-click the data point. 
The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

• hh:mm:ss is the time for that data point in hours, minutes, and seconds.

• dd.dd is the utilization percentage for that data point.

New data points are added to the right side of the chart. When the chart reaches the 
end of the time window, new data points continue to be added to the right side of 
the chart, while old data points “drop off” the left side of the chart.

If a poll is missed (for example, as a result of an SNMP timeout), MWTM ignores 
the missing data point, stops drawing the line, and waits for the next valid data point 
to begin drawing the line again.

To zoom in on a section of the chart, drag the cursor while holding down Shift and 
the left mouse button.

To reset the chart to the default view and scaling, click Reset.

Time Average Displays color-coded icons, one for each of the following statistics:

• Total Sent Rate—Combined send rate for all the interfaces.

• Total Received Rate—Combined receive rate for all the interfaces.

• interface_name Sent—Send rate for the specified interface.

• interface_name Rcvd—Receive rate for the specified interface.

To remove the data for a given average from the chart, click the icon in this field. 
To return the data to the chart, click the icon again.

Column Description
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Shorthaul Performance: Packets

To display real-time statistics for shorthaul packets that are sent and received by 
the specified node over time, click the Shorthaul Performance tab in the Node 
Details window, then click the Packets tab.

The Shorthaul Performance: Packets window displays the following information 
for the selected node:

Reset If you scrolled or zoomed the chart, resets the chart to the default view and scaling.

Grid On Superimposes a graphic grid on the chart. The grid can make the data easier to read.

Grid Off Removes the graphic grid from the chart.

Help Displays online help for the current window.

Column Description

Column/Button Description

Change Poller Opens the Poller Settings dialog to allow you to change the poll interval. For more 
information, see Change Poller, page 6-23.

Poll Interval 
(secs)

The poll interval, in seconds, for the selected node.

To set a new poll interval, click the Change Poller button. The default value is 15 
seconds.

Last Poll Date and time of the last poll of the node. 

Interface Names of the RAN interfaces for which real-time statistics are collected:

Cumulative values for all the interfaces are shown in the Totals row. 

Averages of all the intefaces are displayed in the Averages row.

Received For GSM Abis interfaces, the number of samples received on the interface. For 
UMTS Iub interfaces, the number of packets received on the interface.

Received Per 
Second

Rate at which packets or samples are received (per second).

Sent For GSM Abis interfaces, the number of samples sent on the interface. For UMTS 
Iub interfaces, the number of packets sent on the interface.

Sent Per Second Rate at which packets or samples are sent (per second).
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Utilization 
Chart

Displays the number of packets sent and received for the node’s interface as a 
function of time.

To see the exact time and data coordinates for a data point, left-click the data point. 
The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

• hh:mm:ss is the time for that data point in hours, minutes, and seconds.

• dd.dd is the utilization percentage for that data point.

New data points are added to the right side of the chart. When the chart reaches the 
end of the time window, new data points continue to be added to the right side of 
the chart, while old data points “drop off” the left side of the chart.

If a poll is missed (for example, as a result of an SNMP timeout), MWTM ignores 
the missing data point, stops drawing the line, and waits for the next valid data point 
to begin drawing the line again.

To zoom in on a section of the chart, drag the cursor while holding down Shift and 
the left mouse button.

To reset the chart to the default view and scaling, click Reset.

Time Average Displays color-coded icons, one for each of the following statistics:

• Total Sent Rate—Combined send rate for all the interfaces.

• Total Received Rate—Combined receive rate for all the interfaces.

• interface_name Sent—Send rate for the specified interface.

• interface_name Rcvd—Receive rate for the specified interface.

To remove the data for a given average from the chart, click the icon in this field. 
To return the data to the chart, click the icon again.

Reset If you scrolled or zoomed the chart, resets the chart to the default view and scaling.

Grid On Superimposes a graphic grid on the chart. The grid can make the data easier to read.

Grid Off Removes the graphic grid from the chart.

Help Displays online help for the current window.

Column/Button Description
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Shorthaul Performance: Sent Utilization

To display real-time statistics for shorthaul sent utilization percentage over time, 
click the Shorthaul Performance tab in the Node Details window, then click the 
Sent Utilization tab. The real-time data shows the contribution of shorthaul 
interfaces toward the backhaul utilization as a percentage.

The Shorthaul Performance: Sent Utilization window displays the following 
information for the selected node:

Column Description

Change Poller Opens the Poller Settings dialog to allow you to change the poll interval. For more 
information, see Change Poller, page 6-23.

Poll Interval 
(secs)

The poll interval, in seconds, for the selected node.

To set a new poll interval, click the Change Poller button. The default value is 15 
seconds.

Last Poll Date and time of the last poll of the node. 

Utilization 
Chart

Displays the number of packets sent and received for the node’s interface as a 
function of time.

To see the exact time and data coordinates for a data point, left-click the data point. 
The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

• hh:mm:ss is the time for that data point in hours, minutes, and seconds.

• dd.dd is the utilization percentage for that data point.

New data points are added to the right side of the chart. When the chart reaches the 
end of the time window, new data points continue to be added to the right side of 
the chart, while old data points “drop off” the left side of the chart.

If a poll is missed (for example, as a result of an SNMP timeout), MWTM ignores 
the missing data point, stops drawing the line, and waits for the next valid data point 
to begin drawing the line again.

To zoom in on a section of the chart, drag the cursor while holding down Shift and 
the left mouse button.

To reset the chart to the default view and scaling, click Reset.
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Shorthaul Performance: Received Utilization

To display real-time statistics for shorthaul received utilization percentage over 
time, click the Shorthaul Performance tab in the Node Details window, then 
click the Received Utilization tab. The real-time data shows the contribution of 
shorthaul interfaces toward the backhaul utilization as a percentage.

The Shorthaul Performance: Received Utilization window displays the following 
information for the selected node:

Time Average Displays color-coded icons, one for each of the following statistics:

• interface_name—Displays the contribution of the specified shorthaul interface 
toward the backhaul utilization as a percentage.

• Total Utilization—Displays the contribution of the all the shorthaul interfaces 
toward the backhaul utilization as a percentage.

To remove the data for a given average from the chart, click the icon in this field. 
To return the data to the chart, click the icon again.

Reset If you scrolled or zoomed the chart, resets the chart to the default view and scaling.

Grid On Superimposes a graphic grid on the chart. The grid can make the data easier to read.

Grid Off Removes the graphic grid from the chart.

Help Displays online help for the current window.

Column Description

Column Description

Change Poller Opens the Poller Settings dialog to allow you to change the poll interval. For more 
information, see Change Poller, page 6-23.

Poll Interval 
(secs)

The poll interval, in seconds, for the selected node.

To set a new poll interval, click the Change Poller button. The default value is 15 
seconds.

Last Poll Date and time of the last poll of the node. 
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Utilization 
Chart

Displays the number of packets sent and received for the node’s interface as a 
function of time.

To see the exact time and data coordinates for a data point, left-click the data point. 
The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

• hh:mm:ss is the time for that data point in hours, minutes, and seconds.

• dd.dd is the utilization percentage for that data point.

New data points are added to the right side of the chart. When the chart reaches the 
end of the time window, new data points continue to be added to the right side of 
the chart, while old data points “drop off” the left side of the chart.

If a poll is missed (for example, as a result of an SNMP timeout), MWTM ignores 
the missing data point, stops drawing the line, and waits for the next valid data point 
to begin drawing the line again.

To zoom in on a section of the chart, drag the cursor while holding down Shift and 
the left mouse button.

To reset the chart to the default view and scaling, click Reset.

Time Average Displays color-coded icons, one for each of the following statistics:

• interface_name—Displays the contribution of the specified shorthaul interface 
toward the backhaul utilization as a percentage.

• Total Utilization—Displays the contribution of the all the shorthaul interfaces 
toward the backhaul utilization as a percentage.

To remove the data for a given average from the chart, click the icon in this field. 
To return the data to the chart, click the icon again.

Reset If you scrolled or zoomed the chart, resets the chart to the default view and scaling.

Grid On Superimposes a graphic grid on the chart. The grid can make the data easier to read.

Grid Off Removes the graphic grid from the chart.

Help Displays online help for the current window.

Column Description
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Shorthaul Performance: Errors

To display errors for shorthaul statistics, click the Shorthaul Performance tab in 
the Node Details window, then click the Errors tab.

The Shorthaul Performance: Errors window displays the following information 
for the selected node:

Column Description

Change Poller Opens the Poller Settings dialog to allow you to change the poll interval. For more 
information, see Change Poller, page 6-23.

Poll Interval 
(secs)

The poll interval, in seconds, for the selected node.

To set a new poll interval, click the Change Poller button. The default value is 15 
seconds.

Last Poll Date and time of the last poll of the node. 

Interface Names of the RAN interfaces for which error statistics are collected:

Total 
Decompression 
Failures

The total number of decompression failures that occurred on the shorthaul interface 
in the receive direction.

Total 
Compression 
Failures

The total number of compression failures that occurred on the shorthaul interface 
in the send direction.

No Packet 
Compression 
Failures

The number of No Packet errors.

No Interface 
Compression 
Failures

The number of No Interface errors.

Interface Down 
Compression 
Failures

The number of Interface Down errors.

Encapsulation 
Errors

The number of Encapsulation Errors.

QoS Drops The number of drops incurred because of QoS rules.

Help Displays online help for the current window.
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Node Details: Backhaul Performance
Real-time statistics are displayed through the Backhaul Performance tab of the 
Node Details window. Changes you make in this window might not be reflected 
throughout MWTM until the next poll (by default, every 15 seconds). 

Note This window polls your network periodically. To prevent unnecessary traffic on 
your network, close this window when you no longer need to refer to it.

MWTM enables you to view the following backhaul real-time statistics:

• Change Poller, page 6-32

• Backhaul Performance: Sent Utilization, page 6-32

• Backhaul Performance: Received Utilization, page 6-34

• Backhaul Performance: Errors, page 6-36

Change Poller

To change the poll interval, click the Change Poller button in any Shorthaul 
Performance or Backhaul Performance window. For more information on poller 
settings and how to change them, see Change Poller, page 6-23.

Backhaul Performance: Sent Utilization

To display real-time statistics for backhaul sent utilization percentage over time, 
click the Backhaul Performance tab in the Node Details window, then click the 
Sent Utilization tab.

The Backhaul Performance: Sent Utilization window displays the following 
information for the selected node:
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Column Description

Change Poller Opens the Poller Settings dialog to allow you to change the poll interval. For more 
information, see Change Poller, page 6-23.

Poll Interval 
(secs)

The poll interval, in seconds, for the selected node.

To set a new poll interval, click the Change Poller button. The default value is 15 
seconds.

Last Poll Date and time of the last poll of the node. 

Utilization 
Chart

Displays the utilization percentage for the node as a function of time.

To see the exact time and data coordinates for a data point, left-click the data point. 
The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

• hh:mm:ss is the time for that data point in hours, minutes, and seconds.

• dd.dd is the utilization percentage for that data point.

New data points are added to the right side of the chart. When the chart reaches the 
end of the time window, new data points continue to be added to the right side of 
the chart, while old data points “drop off” the left side of the chart.

If a poll is missed (for example, as a result of an SNMP timeout), MWTM ignores 
the missing data point, stops drawing the line, and waits for the next valid data point 
to begin drawing the line again.

To zoom in on a section of the chart, drag the cursor while holding down Shift and 
the left mouse button.

To reset the chart to the default view and scaling, click Reset.
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Backhaul Performance: Received Utilization

To display real-time statistics for backhaul received utilization percentage over 
time, click the Backhaul Performance tab in the Node Details window, then click 
the Received Utilization tab.

The Backhaul Performance: Received Utilization window displays the following 
information for the selected node:

Time Average Displays color-coded icons, one for each of the following statistics:

• Acceptable Threshold—Line that shows the threshold below which the 
backhaul utilization is considered acceptable. 

• Warning Threshold—Line that shows the threshold beyond which the backhaul 
utilization issues a warning. Subsequent warnings are issued only if the 
utilization goes below the Acceptable Threshold.

• Overloaded Threshold—Line that shows the threshold beyond which the 
backhaul utilization is considered overloaded. Subsequent overload messages 
are issued only if the utilization goes below the Acceptable Threshold.

• Total Utilization—Backhaul utilization percentage for all traffic types.

• Abis Utilization—Backhaul utilization percentage for GSM Abis traffic. 

• UMTS Utilization—Backhaul utilization percentage for UMTS Iub traffic.

• Other Utilization—Backhaul utilization percentage for traffic that is neither 
GSM nor UMTS traffic.

To remove the data for a given average from the chart, click the icon in this field. 
To return the data to the chart, click the icon again.

Reset If you scrolled or zoomed the chart, resets the chart to the default view and scaling.

Grid On Superimposes a graphic grid on the chart. The grid can make the data easier to read.

Grid Off Removes the graphic grid from the chart.

Help Displays online help for the current window.

Column Description
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Column Description

Change Poller Opens the Poller Settings dialog to allow you to change the poll interval. For more 
information, see Change Poller, page 6-23.

Poll Interval 
(secs)

The poll interval, in seconds, for the selected node.

To set a new poll interval, click the Change Poller button. The default value is 15 
seconds.

Last Poll Date and time of the last poll of the node. 

Utilization 
Chart

Displays the utilization percentage for the node as a function of time.

To see the exact time and data coordinates for a data point, left-click the data point. 
The coordinates are displayed in the format (hh:mm:ss, dd.dd), where:

• hh:mm:ss is the time for that data point in hours, minutes, and seconds.

• dd.dd is the utilization percentage for that data point.

New data points are added to the right side of the chart. When the chart reaches the 
end of the time window, new data points continue to be added to the right side of 
the chart, while old data points “drop off” the left side of the chart.

If a poll is missed (for example, as a result of an SNMP timeout), MWTM ignores 
the missing data point, stops drawing the line, and waits for the next valid data point 
to begin drawing the line again.

To zoom in on a section of the chart, drag the cursor while holding down Shift and 
the left mouse button.

To reset the chart to the default view and scaling, click Reset.
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Backhaul Performance: Errors

To display errors for backhaul statistics, click the Backhaul Performance tab in 
the Node Details window, then click the Errors tab.

The Backhaul Performance: Errors window displays the following information 
for the selected node:

Time Average Displays color-coded icons, one for each of the following statistics:

• Acceptable Threshold—Line that shows the threshold below which the 
backhaul utilization is considered acceptable. 

• Warning Threshold—Line that shows the threshold beyond which the backhaul 
utilization issues a warning. Subsequent warnings are issued only if the 
utilization goes below the Acceptable Threshold.

• Overloaded Threshold—Line that shows the threshold beyond which the 
backhaul utilization is considered overloaded. Subsequent overload messages 
are issued only if the utilization goes below the Acceptable Threshold.

• Total Utilization—Backhaul utilization percentage for all traffic types.

• Abis Utilization—Backhaul utilization percentage for GSM Abis traffic. 

• UMTS Utilization—Backhaul utilization percentage for UMTS Iub traffic.

• Other Utilization—Backhaul utilization percentage for traffic that is neither 
GSM nor UMTS traffic.

To remove the data for a given average from the chart, click the icon in this field. 
To return the data to the chart, click the icon again.

Reset If you scrolled or zoomed the chart, resets the chart to the default view and scaling.

Grid On Superimposes a graphic grid on the chart. The grid can make the data easier to read.

Grid Off Removes the graphic grid from the chart.

Help Displays online help for the current window.

Column Description
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Column Description

Change Poller Opens the Poller Settings dialog to allow you to change the poll interval. For more 
information, see Change Poller, page 6-23.

Poll Interval 
(secs)

The poll interval, in seconds, for the selected node.

To set a new poll interval, click the Change Poller button. The default value is 15 
seconds.

Last Poll Date and time of the last poll of the node. 

Interface Names of the RAN interfaces for which error statistics are collected:

Peer Not Ready 
Drops

Number of Peer Not Ready Drop errors. This error occurs when the backhaul peer 
is not ready for input.

Peer Not Active 
Drops

Number of Peer Not Active Drop errors. This error occurs when the backhaul peer 
is not active.

Invalid Packets Number of invalid backhaul packets received. 

Lost Received 
Packets

Number of lost backhaul packets received.

Lost Sent 
Packets

Number of lost backhaul packets sent.

Total Missed 
Packets

Total number of backhaul packets missed or dropped.

Missed Late Number of backhaul packets missed because they arrived late.

Missed Lost Number of backhaul packets missed because they were lost.

Missed No 
Memory

Number of backhaul packets missed because no particles were available (for 
example, getparticle () failure).

Missed Reset Number of backhaul packets missed because of xBufferRing reset.

Help Displays online help for the current window.
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Node Details: Components
The Node Details: Components section displays information about the interfaces 
that are associated with the selected node.

To see mouse over help popup for each column in the table, place the cursor over 
a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the 
full data in a mouse over help popup.

You can resize each column, or sort the table based on the information in one of 
the columns. By default, MWTM displays all of the columns except Internal ID.

• To display hidden columns, right-click in the table header and select the 
checkboxes for the columns you want to display.

• To hide columns, right-click in the table header and clear the checkboxes for 
the columns you want to hide.

See the “Resizing, Sorting, and Hiding Table Columns” section on page 3-37 for 
more information about resizing, sorting, displaying, or hiding columns.

The Signaling Point Table contains the following columns:

Column Description

Internal ID Internal ID of the router interface. The internal ID is a unique ID for every 
object, assigned by MWTM for its own internal use. It can also be useful 
when the TAC is debugging problems.

Name Name of the router interface.

Object Type Type of router interface associated with this node.

Ignored Indicates whether the router interface is to be included when aggregating and 
displaying MWTM status information:

• Clear the checkbox to include the router interface. This is the default 
setting.

• Select the checkbox to exclude the router interface.

This field can be edited by users with authentication level Power User 
(Level 2) and higher.

Notes Indicates whether there is a note associated with the router interface.
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Events Indicates whether there is a recent event associated with the router interface. 
(Even if the server purges all of the events associated with the router 
interface, MWTM continues to display the event icon in this field.)

Last Status Change Date and time that the status of the router interface last changed.

Status Current status of the router interface. Possible values are:

Active (green)

Unknown (red)

Unmanaged (gray)

Warning (yellow)

For detailed definitions of each status, see the “Status Definitions for Nodes” 
section on page A-5.

Status Reason Reason for the current status of the router interface.

For a full list of possible reasons, see the stateReasons.html file:

• If you installed MWTM in the default directory, /opt, then the file is 
located at /opt/CSCOsgm/apache/share/htdocs/eventHelp directory.

• If you installed MWTM in a different directory, then the help directory 
and file are located in that directory.

If the cell is too small to show all of the status reason, place the cursor over 
the cell to see the full status reason in a mouse over help popup.

The status reasons are listed in order of decreasing magnitude. If two or more 
reasons apply, the reason of greatest magnitude is displayed.

If the status reason is Unsupported Configuration, correct the 
configuration and enter the mwtm cleandiscover command to delete all 
current network data and begin a clean discovery of the RAN-O network. If 
the status reason is still Unsupported Configuration, enter the mwtm clean 
command to restore the MWTM server to a “clean” state, such as would exist 
after a new installation of MWTM. For more information on the use of these 
commands, see the “MWTM Command Reference” section on page C-1.

Column Description
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Node Details: Configuration Data
The Node Details: Configuration Details section is composed of the following 
sub-sections:

• Naming Information, page 6-41

• Descriptive Information, page 6-42

• Status Information, page 6-42

• Router Uptime Information, page 6-44

• Polling Information, page 6-44

• Threshold % Information, page 6-45

• IP Addresses for SNMP, page 6-46
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Naming Information

The Naming Information sub-section contains the following fields:

Field Description

Display Name Name of the node.

IP Address or 
DNS Hostname

IP address or DNS name of the node, as discovered by MWTM. However, if you 
modified your preferences to identify nodes by their IP addresses, then that is how 
the node is identified in this field. For more information, see the “Node Name 
Settings” section on page 11-9.

Device Type Device type of the node. Possible values are:

• CiscoMWR-1941-DC-A—Cisco MWR-1941-DC-A series router

• RNC—Radio Network Controller

• BSC—Base Station Controller

• BTS—Base Transceiver Station

• Node B—The radio transmission/reception unit for communication between 
radio cells

• IPDevice—IP device, other than those listed above. You can assign this icon 
to an unknown node if you know that it is an IP device.

• Unknown—MWTM is unable to determine the device type.

Serial Number Serial number of the node.

SNMP Access Whether the SNMP access is in-band (across the backhaul), out of band, or 
undefined.

Location The location of the SNMP settings, whether at the BSC or the BTS site.
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Descriptive Information

The Descriptive Information sub-section contains the following fields:

Status Information

The Status Information sub-section contains the following fields:

Field Description

MIB Level MIB conformance level used by the router, such as IP-RAN R0.

Note Router IOS Version and MIB Level might not have a one-to-one 
correspondence, because multiple router IOS versions can use the same 
MIB level if there are no changes to the MIBs between versions. 

Router IOS 
Version

Version of IOS that is installed on the router.

Field Description

Is Ignored Indicates whether the node is Ignored (that is, whether the node is to be 
included when aggregating and displaying MWTM status information).

Process Traps Indicates whether MWTM is to process traps from this node.

Last Status Change Date and time that the status of the node last changed.
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Status Current status of the node. Possible values are:

Active (green)

Discovering (cyan)

Polling (cyan)

Unknown (red)

Unmanaged (gray)

Waiting (gray)

Warning (yellow)

For detailed definitions of each status, see the “Status Definitions for Nodes” 
section on page A-5.

Status Reason Reason for the current status of the signaling gateway mated pair.

For a full list of possible reasons, see the stateReasons.html file:

• If you installed MWTM in the default directory, /opt, then the file is 
located at /opt/CSCOsgm/apache/share/htdocs/eventHelp directory.

• If you installed MWTM in a different directory, then the help directory and 
file are located in that directory.

If the cell is too small to show all of the status reason, place the cursor over the 
cell to see the full status reason in a mouse over help popup.

The status reasons are listed in order of decreasing magnitude. If two or more 
reasons apply, the reason of greatest magnitude is displayed.

If the status reason is Unsupported Configuration, correct the configuration 
and enter the mwtm cleandiscover command to delete all current network data 
and begin a clean discovery of the RAN-O network. If the status reason is still 
Unsupported Configuration, enter the mwtm clean command to restore the 
MWTM server to a “clean” state, such as would exist after a new installation 
of MWTM. For more information on the use of these commands, see the 
“MWTM Command Reference” section on page C-1.

Field Description
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Router Uptime Information

The Router Uptime Information sub-section contains the following fields:

Polling Information

The Polling Information sub-section contains the following fields:

Field Description

Router Uptime Time the router has been up, in days, hours, minutes, and seconds.

Reboot Reason Reason for the last reboot of the router.

Field Description

Process Traps Indicates whether traps are processed or not. To change this setting, 
select or clear the checkbox in the Process Traps column of the 
Nodes table.

Trap Polling Enabled Indicates whether trap polling is enabled or not. This checkbox is 
read-only. 

• If you want to enable trap polling for this node, set ipran-mib 
snmp-access to inBand on the device.

• If you want to disable trap polling for this node, set ipran-mib 
snmp-access to outOfBand on the device.

Report Polling Enabled Indicates whether report polling is enabled or not. This checkbox 
is read-only. 

• If you want to enable report polling for this node, set 
ipran-mib location to aggSite on the device.

• If you want to disable report polling for this node, set 
ipran-mib location to cellSite on the device.

First Discovered Date and time that the node was first discovered by MWTM.

Last Poll IP Address Last IP address that was polled for this node.

For a node that is not a RAN-O node, this field is left blank.
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Threshold % Information

The Threshold % Information sub-section contains the following fields:

Last Full Poll Time Date and time of the last full poll of the node for device-related 
MIBs (as opposed to a demand poll for just one linkset’s worth of 
data).

For a node that is not a RAN-O node, this field is left blank.

Last MWTM Poll Response 
(secs)

Time, in seconds, taken by this node to respond to the last MWTM 
poll request.

For a node that is not a RAN-O node, this field is left blank.

Avg. MWTM Poll Response 
(secs)

Average time, in seconds, taken by this node to respond to MWTM 
poll requests.

For a node that is not a RAN-O node, this field is left blank.

Field Description

Field Description

Acceptable The percentage threshold setting below which the backhaul 
utilization is considered acceptable. 

Warning The percentage threshold setting beyond which the backhaul 
utilization issues a warning. Subsequent warnings are issued only 
if the utilization goes below the Acceptable Threshold.

Overloaded The percentage threshold setting beyond which the backhaul 
utilization is considered overloaded. Subsequent overload 
messages are issued only if the utilization goes below the 
Acceptable Threshold.
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IP Addresses for SNMP

The IP Addresses for SNMP sub-section contains the following fields:

If there are no IP addresses defined for the node that are intended for SNMP, this 
field displays the phrase There are no other IP addresses defined for this node.

Node Details: Notes
The Node Details: Notes section displays:

• Notes associated with the node.

• The date and time the notes associated with the node were last updated, or the 
phrase Not Set if there are no notes associated with the node.

• The phrase No Notes if there are no notes associated with the node.

Field Description

IP Address IP addresses associated with this node, including the primary SNMP 
address and all backup IP addresses, that are intended for SNMP.

Last Regular Poll Time Date and time of the last full poll of the node for router-related MIBs.

If the IP address has never been polled, MWTM displays the phrase Never 
Polled.

SNMP Pollable Whether or not the node can be polled using SNMP.
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Node Details: Recent Events
The Node Details: Recent Events table (Figure 6-4) displays all recent events 
associated with the node, and enables you to perform event-related tasks, such as 
setting filters and acknowledging events.

Figure 6-4 Recent Events Table for a Node

To see mouse over help popup for each column in the table, place the cursor over 
a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the 
full data in a mouse over help popup.

You can resize each column, or sort the table based on the information in one of 
the columns. By default, MWTM displays all of the columns in the table except 
Internal ID, Note, Message Name, Ack By, Ack Time, Node, Router Interface.

• To display hidden columns, right-click in the table header and select the 
checkboxes for the columns you want to display.

• To hide columns, right-click in the table header and clear the checkboxes for 
the columns you want to hide.

See the “Resizing, Sorting, and Hiding Table Columns” section on page 3-37 for 
more information about resizing, sorting, displaying, or hiding columns.
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The Node Details: Recent Events table contains the following toolbar buttons and 
columns:

Toolbar Button or Column Description

Set Filter Opens the Event Filter dialog.

Apply Filter

or

Remove Filter

Activates and deactivates the event filter specified in the Event Filter 
dialog:

• If the filter is activated, MWTM displays only those events that pass 
the filter.

• If the filter is deactivated, MWTM displays all events.

• If you activate a filter in an object’s Recent Events table in the 
MWTM Main Window, the filter is activated in all Recent Events 
tables in the MWTM Main Window for all other network objects. 
The filter is not activated in Recent Events tables in Show In New 
Window windows or Real-Time Data and Charts windows.

Pause

or

Resume

Pauses or resumes the table.

While the table is paused, MWTM does not display new events in the 
table (unless you apply an event filter or edit your event preferences). 
When the table is resumed, all new events since the table was paused are 
added to the display.

If events are deleted while the table is paused, they are not removed from 
the table. Instead, they are grayed-out and cannot be acknowledged or 
edited. Deleted events are removed from the table when you resume the 
table.

Acknowledge Makes the selected event or events acknowledged.

Unacknowledge Makes the selected event or events unacknowledged.

Event Properties Opens the Event Properties window.

Edit Notes Opens the Edit Event Dialog.

Time Difference Displays the difference in days, minutes, hours, and seconds between 
two events.

Find Finds specific text in the event table.
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Create Sound Filter Opens the Event Sound Filters dialog and the Event Sound Filters List 
dialog, with fields populated based on the selected event.

Adjust Row Height Adjusts the table row height and wraps the message text as follows:

• Click once to double the row height and wrap the message text.

• Click again to triple the row height and wrap the message text.

• Click again for single row height and no message text wrapping. 
This is the default setting.

This setting is saved automatically with your preferences.

Help for Event Displays context-sensitive help for the selected event in a separate Web 
browser.

Internal ID Internal ID of the event. The internal ID is a unique ID for every object, 
assigned by MWTM for its own internal use. It can also be useful when 
the TAC is debugging problems.

Ack Indicates whether the event has been acknowledged:

• To acknowledge an unacknowledged event, use the Acknowledge 
toolbar button.

• To make a previously acknowledged event unacknowledged, use the 
Unacknowledge toolbar button.

Toolbar Button or Column Description
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Category Type of the event. Default values are:

• Create—Creation event, such as the creation of a seed file.

• Delete—Deletion event, such as the deletion of an object or file.

• Discover—Discovery event, such as Discovery beginning.

• Edit—Edit event. A user has edited an object.

• Ignore—Ignore event. A user has Ignored a link or linkset.

• Login—Login event. A user has logged in to MWTM.

• LoginDisable—LoginDisable event. MWTM has disabled a user’s 
User-Based Access authentication as a result of too many failed 
attempts to log in to MWTM.

• LoginFail—LoginFail event. An attempt by a user to log in to 
MWTM has failed.

• Logout—Logout event. A user has logged out of MWTM.

• OverWrite—OverWrite event. An existing file, such as a seed file 
or route file, has been overwritten.

• Poll—Poll event, such as an SNMP poll.

• Purge—Purge event. A user has requested Discovery with Delete 
Existing Data selected, and MWTM has deleted the existing 
MWTM database.

• Status—Status change message generated.

• Trap—SNMP trap message generated.

You can customize this field. See the “Changing Event Categories” 
section on page 5-34 for more information.

Toolbar Button or Column Description
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Severity Severity of the event. Default values are:

• Critical—The default color is red.

• Indeterminate—The default color is aqua.

• Informational—The default color is white.

• Major—The default color is orange.

• Minor—The default color is yellow.

• Normal—The default color is green.

• Warning—The default color is blue.

You can customize this field. See the “Changing Event Severities and 
Colors” section on page 5-35 for more information.

Note Indicates whether there is a note associated with the event.

Message Name User-specified message name for the event, used by MWTM for trap 
forwarding. The default message name is MWTM.

For more information about user-specified message names and trap 
forwarding, see the “Forwarding Events as Traps to Other Hosts” section 
on page 5-50.

Time Date and time the event was logged.

Ack By If you have not implemented MWTM User-Based Access, name of the 
device that last acknowledged the event.

If you have implemented MWTM User-Based Access, name of the user 
who last acknowledged the event.

If no one has acknowledged the event, this field is blank.

Ack Time Date and time the event was last acknowledged or unacknowledged.

Node Name of the node associated with the event. If there is no node 
associated with the event, None is displayed.

Message Text of the message.

You can customize this field. See the “Changing the Way MWTM 
Processes Events” section on page 5-26 for more information.

Toolbar Button or Column Description
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Node Details: Syslog
The Node Details: Syslog table displays all messages in the system log for the 
selected node.

Note This window polls your network periodically. To prevent unnecessary traffic on 
your network, close this window when you no longer need to refer to it.

The Node Details: Syslog table displays the following information for the selected 
node:

Column Description

Poll Interval Poll interval used to collect data for the table.

Last Poll Time the last poll was run.

This field initially displays the phrase Polling device. After the first polling cycle, 
MWTM populates this field with the actual time of the last poll.

Timestamp Date and time of the syslog message from the device.

Severity Severity of the syslog message. Possible values are:

• Alert—Messages that require immediate action.

• Critical—Critical conditions.

• Debug—Debug messages, log FTP commands, and WWW URLs.

• Emergency—System unusable messages.

• Error—Error messages.

• Info—Information messages.

• Notice—Normal but significant conditions.

• Warning—Warning messages.

Facility Name of the facility that generated the syslog message, such as SYS or SNMP.

Name Short text identifier for the message type. A facility name in conjunction with a 
message name uniquely identifies a syslog message type.

Message Text of the syslog message.
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Editing a Node
MWTM enables you to edit the following aspects of a node:

• Editing Node Properties, page 6-54

• Attaching a Note to a Node, page 6-58

• Editing SNMP IP Addresses for a Node, page 6-59

• Viewing Notes for a Node, page 6-61

Related Topics:

• Viewing Basic Information for Nodes, page 6-2

• Viewing Detailed Information for a Node, page 6-13

• Viewing Notes for a Node, page 6-61

• Viewing the Topology of the Network, page 8-1
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Editing Node Properties
The Edit Properties Dialog enables you to change the name, icon name, and Telnet 
address associated with a node.

To edit a node’s properties, right-click the node in a window, select Edit > 
Properties in the right-click menu. MWTM displays the Edit Properties Dialog 
for a Node (Figure 6-5).

Figure 6-5 Edit Properties Dialog for a Node
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The Edit Properties Dialog contains the following fields and buttons:

Field or Button Description

Name Name of the node.

By default, this field displays the node’s DNS name, as discovered by MWTM. 
However, if you modified your preferences to identify nodes by their IP addresses, 
then that is how the node is identified in this field. For more information, see the 
“Node Name Settings” section on page 11-9.

You can also use this field to specify a new, more meaningful name for the node or 
signaling point, keeping in mind the following considerations:

• You can change a RAN-O node name to a new name or IP address.

• A new name can be from 1 to 30 characters, and can contain any letters (upper- 
or lowercase) and any numbers, as well as blank spaces ( ), dashes (-), and 
underscores (_), but no periods (.). If you enter a name that is longer than 30 
characters, or if you enter any other special characters or periods, MWTM 
beeps and retains the current name.

• If you enter a name that includes a period, MWTM assumes that you are 
entering a new IP address. A new IP address must use the x.x.x.x format, where 
x is between 0 and 255, and must contain only numbers and periods, but no 
letters or special characters. If you enter an IP address that contains any 
letters or special characters, MWTM beeps and retains the current IP address.

• If you edit a node whose current name already contains invalid characters, 
MWTM beeps and replaces the name with blanks. Enter a new name that uses 
only valid characters, or click Cancel to keep the existing name. If you click 
Cancel, MWTM exits the Edit Properties Dialog without saving any changes 
to the Name, Telnet Address, or Icon Name field.
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Name
(continued)

• If you leave the Name field blank, MWTM reverts to the node’s default name 
(the DNS name for a RAN-O node).

• The new node name is used when launching context-based applications, such 
as CiscoWorks. Therefore, if the new name you enter is not the node’s DNS 
name, and the application knows the node by its DNS name, context links into 
the application for that node might not work.

When you click Save, all MWTM windows are updated automatically to reflect the 
new name.

Telnet Address Telnet IP address and optional port number, to pass to the Telnet command.

A new Telnet IP address must use the x.x.x.x format, where x is between 0 and 255, 
and must contain only numbers and periods, but no letters or special characters. 
If you enter a Telnet IP address that contains any letters or special characters, 
MWTM beeps and retains the current Telnet IP address.

If you specify a port number, separate the IP address from the port number with a 
space, such as: mwtm-sun8.cisco.com 2048.

Icon Name Name of the graphic icon to assign to this node in topology maps. MWTM 
automatically assigns an appropriate icon to each discovered Cisco RAN-O node, 
and to Unknown nodes, but you can use this field to assign a different icon (for 
example, if you know that a given Unknown node is a mobile switching center).

When MWTM discovers a single-instance node, it assigns the icon that 
corresponds to the node. When MWTM discovers a multi-instance node, it assigns 
a separate icon for each unique instance.

Valid values are:

• BSC—Base Station Controller

• BTS—Base Transceiver Station

• Building—Icon representing a collection of network objects within a building

• City—Icon representing a collection of network objects within a city

Field or Button Description
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(continued)

• Cloud—Collection of network objects, called a submap. A submap can also 
contain other submaps.

• Database—Icon representing a database object

• IPDevice—IP device, other than those listed above

• MSC—Mobile switching center

• Node B—The radio transmission/reception unit for communication between 
radio cells

• RNC—Radio Network Controller

• Tower—Icon representing a PC tower

• TrafficGenerator—Icon representing a device or emulator used to generate 
traffic, usually in a test environment

• Unknown—MWTM is unable to determine the node type.

• Workstation—Icon representing a workstation

• Workstation2—Icon representing a different workstation

When you click Save, the Topology Window is updated automatically to reflect the 
new icon.

Save Saves changes you have made to the node information, updates all windows to 
reflect your changes, and exits the dialog.

Cancel Exits the dialog without saving any changes.

Help Displays online help for the dialog.

Field or Button Description
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Attaching a Note to a Node
MWTM enables you to annotate a node, attaching a descriptive string to it.

To attach a note to a node, right-click the node in a window, then select Edit > 
Notes in the right-click menu. MWTM displays the Edit Notes Dialog for a Node 
(Figure 6-6).

Figure 6-6 Edit Notes Dialog for a Node

The Edit Notes Dialog for a Node contains the following fields and buttons:

Field or Button Description

Name Name of the node. You cannot edit this field.

Note Last Updated Date and time the Notes field for this node was last updated. If there is no note 
currently associated with this node, this field displays the value Not Set.

You cannot edit this field.

Notes Notes to associate with this node. In this field, you can enter any important 
information about the node, such as a detailed description, its location, its service 
history, and so on.

Save Saves changes you have made to the node’s notes, updates all MWTM windows 
to reflect your changes, and exits the dialog.

When you annotate a node, MWTM displays a note icon in the Notes column of 
all node tables for the annotated node, and the topology map in the Topology 
Window displays a note icon in the upper left corner of the node element.
6-58
Cisco Mobile Wireless Transport Manager User Guide

OL-7637-01



 

Chapter 6      Working with Nodes
Editing a Node
Editing SNMP IP Addresses for a Node
MWTM enables you to determine which IP addresses are to be used for SNMP 
polling.

To edit a node’s SNMP IP addresses, right-click a node in a window, select Edit 
> SNMP IP Addresses in the right-click menu. MWTM displays the Edit SNMP 
IP Addresses Dialog.

The Edit SNMP IP Addresses Dialog contains the following fields and buttons:

Cancel Exits the dialog without saving any changes.

Help Displays online help for the dialog.

Field or Button Description

Field or Button Description

Available 
Router IP 
Addresses

List of all IP addresses associated with this RAN-O node that users do not want 
MWTM to use for SNMP polling. MWTM does not send SNMP queries to IP 
addresses in this list.

This option is displayed only for RAN-O nodes.

IP Addresses for 
SNMP

List of all IP addresses associated with this RAN-O node that MWTM can use for 
SNMP polling:

• By default, MWTM places all discovered IP addresses in this list, in the order 
in which they are discovered. MWTM uses the IP address at the top of the list 
as the primary SNMP address for the node.

During SNMP polling of the node (both status polling and demand polling), 
MWTM first tries the primary SNMP address. If the primary is unavailable, 
MWTM tries the other IP addresses, one-by-one, in descending order.

• To assign a new primary SNMP address, or to change the order of the 
secondary IP addresses, use the Raise Priority and Lower Priority buttons to 
move the IP addresses up and down in the list.
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(continued)

• You can also select IP addresses that you do not want MWTM to use for SNMP 
polling. This is useful, for example, to separate management traffic from SMS 
traffic. To remove an IP address from the list, click Remove. The IP address is 
removed from the IP Addresses for SNMP list and appears in the Available 
Router IP Addresses list, and is no longer used by MWTM for SNMP polling.

To enable an IP address for SNMP polling again, select the address in the 
Available Router IP Addresses list and click Add. The IP address moves 
back into the IP Addresses for SNMP list and is again available for SNMP 
polling.

If you remove all IP addresses from the IP Addresses for SNMP list, the node 
is effectively removed from the network, and MWTM automatically labels the 
node Unmanaged in all windows.

When you click Save, all MWTM windows are updated automatically to reflect the 
changes.

This option is displayed only for RAN-O nodes.

Add Enables one or more selected IP addresses for SNMP polling. All selected 
IP addresses in the Available Router IP Addresses list are moved to the 
IP Addresses for SNMP list, and are again used by MWTM for SNMP polling.

Remove Disables one or more selected IP addresses for SNMP polling. All selected 
IP addresses in the IP Addresses for SNMP list are moved to the Available 
Router IP Addresses list, and are no longer used by MWTM for SNMP polling.

Raise Priority Moves the selected IP addresses up in the IP Addresses for SNMP list. If you 
move an IP address to the top of the list, MWTM uses that IP address as the new 
primary SNMP address for the node.

Lower Priority Moves the selected IP addresses down in the IP Addresses for SNMP list. If you 
remove an IP address from the top of the list, MWTM no longer uses that IP address 
as the primary SNMP address for the node.

Save Saves changes you have made to the node information and exits the dialog.

When you are satisfied with your changes, click Save. MWTM saves your changes 
and updates all MWTM windows to reflect your changes.

Cancel Exits the dialog without saving any changes.

At any time, you can click Cancel to exit the dialog without saving any changes.

Help Displays online help for the dialog.

Field or Button Description
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Viewing Notes for a Node
MWTM enables you to view any notes that have been associated with a node.

To view a note for a node, right-click a node in a window, then select View > 
Notes in the right-click menu. (The Notes option is grayed-out if there is no note 
associated with the selected node.)

MWTM displays the Notes panel for the selected node, which displays:

• Notes associated with the node.

• The date and time the notes associated with the node were last updated, or the 
phrase Not Set if there are no notes associated with the node.

• The phrase No Notes if there are no notes associated with the node.

Related Topics:

• Attaching a Note to a Node, page 6-58

Deleting a Node
After Discovery, the nodes in your network are known to MWTM and added to 
the MWTM database. Physically deleting nodes from your network is not the 
same as deleting them from the MWTM database. The following sections describe 
the differences between deleting nodes from your network, from the MWTM 
database, and from the MWTM Discovery database, and the procedures for doing 
so:

• Deleting a Node from Your Network, page 6-62

• Deleting a Node from the MWTM Database, page 6-62

• Deleting a Node from the MWTM Discovery Database, page 6-64
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Deleting a Node from Your Network
If you physically delete a known node from your network (for example, by 
powering down a router), it remains in the MWTM database, MWTM labels it 
Unknown, and it is the system administrator’s responsibility to delete it from the 
MWTM database, if you choose to do so. MWTM also labels all associated 
network objects Unknown because MWTM attempts to poll the node and gets no 
response.

Deleting a Node from the MWTM Database
Typically, you delete a node from the MWTM database for one of the following 
reasons:

• You have physically deleted the node from your network. This is the most 
common reason for deleting a node from the MWTM database.

• The node is Unknown or Unmanaged, you are aware of the reason, and you 
no longer want to see it in MWTM displays. For example, the node might be 
a test lab device.

If you have physically deleted a known node from your network, and you then 
delete it from MWTM, it is no longer in the MWTM database, it does not appear 
in MWTM windows, and it is not discovered when you run Discovery.

Be aware of the following special situations:

• If you have not physically deleted a known node from your network, and you 
delete it from MWTM, MWTM removes the node from the poll list, and at 
the next poll MWTM returns the node to the DEFAULT view, and labels the 
node as a new node if you are using a custom view.

• If a node is connected to a peer node, you cannot delete the node. If you try 
to do so, MWTM cancels the deletion.

If either of these situations occurs, do not delete the node again. Instead, perform 
one of the following actions:

• Label the node Unmanaged. See the “Unmanaging and Managing a Node” 
section on page 6-64 for more details.

• Remove the node from your view. See the “Working with Views” section on 
page 4-1 for more details.
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Note If you delete a node from the MWTM database, the node is deleted for all MWTM 
clients and views connected to that MWTM server.

To delete a node from the MWTM database, use one of the following procedures:

• Select one or more nodes in a window, then select Edit > Delete from the 
MWTM Main Menu.

• Right-click a node in a window, then select Delete in the right-click menu. 
(You cannot delete more than one node at a time from the right-click menu.)

MWTM asks you to confirm the deletion:

• Select Yes to delete the selected nodes. MWTM deletes the nodes from the 
MWTM database.

• Select No to return to the window without deleting any nodes from the 
MWTM database.

You can also use the mwtm delete node command to delete one or more nodes 
from the MWTM database. See the “mwtm delete” section on page C-21 for more 
information on the use of this command.

Note If you delete a node, MWTM removes it from the left pane of the View Editor 
Window. If MWTM then rediscovers the node, MWTM places it in the New on 
the Network panel of the View Editor Window. To restore the node to your current 
view, you must move it into the left pane using Edit > Include In View from the 
MWTM Main Menu. For more information, see the “Creating a New View” 
section on page 4-42.
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Deleting a Node from the MWTM Discovery Database
If you want to completely eliminate a given node from the MWTM database, you 
can delete it from the MWTM Discovery database, ensuring that it is never even 
discovered by MWTM.

Note If you delete a node from the MWTM Discovery database, the node is deleted for 
all MWTM clients and views connected to that MWTM server.

To delete a node from the MWTM Discovery database:

Step 1 Select Network > Network Discovery from the MWTM Main Menu. MWTM 
displays the Discovery Dialog (Figure 2-2).

Step 2 Select the Discovery tab. MWTM displays the Discovery panel (Figure 2-5).

Step 3 In the Discovered Nodes table, select the node or nodes you want to delete.

Step 4 Click Delete. MWTM deletes the nodes from the Discovery database, without 
asking for confirmation. The nodes will no longer be discovered by MWTM.

Unmanaging and Managing a Node
MWTM enables you to label a node Unmanaged, and to remove the Unmanaged 
status from a node.

In some situations, you might not want to see a given node or nodes in MWTM 
displays, but you might be unable to delete it from the MWTM database. For 
example:

• If you have not physically deleted a known node from your network, and you 
delete it from MWTM, MWTM removes the node from the poll list, and at 
the next poll MWTM returns the node to the DEFAULT view, and labels the 
node as a new node if you are using a custom view.

• If a node is connected to a peer node, you cannot delete the node. If you try 
to do so, MWTM cancels the deletion.
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If these situations, you can label the node Unmanaged. When you label a node 
Unmanaged, MWTM removes the node from the poll list.

Note If you label a node Unmanaged, the node is Unmanaged for all MWTM clients 
and views connected to that MWTM server.

To label a node Unmanaged:

Step 1 Select a node in a window.

You cannot label a node Unmanaged if it has a Device Type of Unknown:

• If you select a node with a Device Type of Unknown, then this menu option 
is grayed-out and cannot be selected.

• If you select more than one node, and at least one of them has a Device Type 
of Unknown, then this menu option is grayed-out and cannot be selected.

Step 2 Select Unmanage from the right-click menu. MWTM labels the selected node 
Unmanaged and removes it from the poll list.

You can also remove the Unmanaged status from a node, when you are ready to 
return the node to the MWTM poll list. To remove the Unmanaged status from a 
node:

Step 1 Select a node in a window.

You cannot remove the Unmanaged status from a node with a Device Type of 
Unknown:

• If you select a node with a Device Type of Unknown, then this menu option 
is grayed-out and cannot be selected.

• If you select more than one node, and at least one of them has a Device Type 
of Unknown, then this menu option is grayed-out and cannot be selected.

Step 2 Select Manage from the right-click menu. MWTM removes the Unmanaged 
status from the selected node, returns it to the poll list, and polls it immediately.
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Polling a Node
MWTM automatically polls nodes at specified intervals. However, you can also 
request an immediate poll for a node.

To poll a node from the Discovery Dialog, use the following procedure:

Step 1 Select Network > Network Discovery from the MWTM Main Menu. MWTM 
displays the Discovery Dialog (Figure 2-2).

Step 2 Select the Discovery tab. MWTM displays the Discovery panel (Figure 2-6). The 
Discovered Nodes section of the Discovery panel lists all discovered nodes (all 
nodes, including new and excluded nodes, not just the nodes in the current view).

Step 3 Select one or more nodes. You cannot poll a node with a Primary SNMP Address 
of N/A:

• If you select a node with a Primary SNMP Address of N/A, then the Poll 
Node button is grayed-out and cannot be selected.

• If you select more than one node, and even one of them has a Primary SNMP 
Address of N/A, then the Poll Node button is grayed-out and cannot be 
selected.

Step 4 Click Poll Node. MWTM begins a poll of the selected nodes. During polling, the 
Poll Node button is grayed-out, the “Selected nodes are being polled” message is 
displayed at the bottom of the Discovery Dialog, and individual nodes might 
display the Polling status.

• If the node has only one IP address for MWTM to poll, and the poll fails or 
times out, MWTM issues an error message.

• If the node has more than one IP address for MWTM to poll, and the polls of 
one or more IP addresses fail or time out, MWTM issues warning messages. 
If all polls fail or time out, MWTM issues an error message.

Step 5 When the “Selected nodes are being polled” message disappears and no nodes are 
in Polling status, polling is complete. The MWTM database immediately reflects 
any new or changed data for the selected nodes.
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To poll one or more nodes, retaining all associated components, use one of the 
following procedures:

• Select one or more nodes in a window, then select Network > Poll Nodes > 
Normal Poll in the MWTM Main Menu. MWTM polls all selected nodes.

• Select a RAN-O node or adjacent node in the Details Window, then select 
Network > Poll Nodes > Normal Poll in the MWTM Main Menu. MWTM 
polls that node.

• Right-click a node in a window, then select Poll Node > Normal Poll in the 
right-click menu. MWTM polls the node.

To poll one or more nodes, removing and then rediscovering all associated 
components, use one of the following procedures:

• Select one or more nodes in a window, then select Network > Poll Nodes > 
Clean Poll in the MWTM Main Menu. MWTM polls all selected RAN-O 
nodes.

• Right-click an RAN-O node in a window, then select Poll Node > Clean Poll 
in the right-click menu. MWTM polls the node.

Clean Poll removes all known network objects from the node at the completion 
of the poll.

Allowing and Disallowing Trap Processing for a 
Node

By default, MWTM processes traps from all discovered nodes. However, you can 
prevent MWTM from processing traps from one or more nodes. For example, if a 
node is experiencing many link changes and generating too many traps, you can 
disallow traps from that node until the situation stabilizes.

Note If you prevent MWTM from processing traps from a node, all MWTM clients and 
views connected to that MWTM server are prevented from processing traps from 
that node.
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Also, if you prevent MWTM from processing traps from a node, make a note of 
the change, and do not forget to reset the node when the problem is corrected or 
the maintenance is complete.

To prevent MWTM from processing traps from a node, clear the Process Traps 
checkbox for the node in a node table. If the Process Traps column is hidden, 
right-click in the table header and select the Process Traps checkbox.

To allow MWTM to process traps from a node, select the Process Traps checkbox 
for the node in a node table.

Excluding a Node from a View
To exclude a node from the current view, right-click the node in a window, then 
select Exclude from View in the right-click menu. MWTM excludes the node 
from the current view. See the “Creating a New View” section on page 4-42 for 
more information about excluding nodes from views.

Ignoring a Node
You can instruct MWTM to ignore a node when it aggregates and displays 
network data. Setting nodes to Ignored prevents known node problems from 
affecting MWTM displays for associated network objects. In effect, you are 
preventing a known problem from distracting you from other, more urgent 
network problems.

For example, you can set a node to Ignored before shutting down the node for 
maintenance.

Note If you set a node to Ignored, the node is ignored for all MWTM clients and views 
connected to that MWTM server.

Also, if you set a node to Ignored, make a note of the change, and do not forget 
to reset the node when the problem is corrected or the maintenance is complete.

To set a node to Ignored, right-click the node in the Node Details window 
(Figure 6-2), then select Ignore from the right-click menu.
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Viewing Ignored Nodes
To display all nodes that are Ignored, display the Node Window and click the 
Ignored column header. MWTM displays all ignored nodes at the top of the table.

Viewing Node Information Using a Web Browser
MWTM enables you to use a Web browser to view the following information 
about nodes:

• Viewing the Network Status Node Dashboard, page 6-69

• Viewing MWTM Node Status, page 6-70

• Viewing MWTM Node Details, page 6-74

• Viewing Node IOS Versions, page 6-80

• Viewing Node Information: CPU Processes, page 6-81

• Viewing Node Information: Syslog Messages, page 6-82

Viewing the Network Status Node Dashboard
The MWTM Node Dashboard page lists all discovered nodes, and provides links 
to messages and metrics for each node.

To access the MWTM Node Dashboard page, select Network Status Dashboard 
from the MWTM Server Home Page.
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The Node Dashboard table contains the following columns:

Viewing MWTM Node Status
The MWTM Node Status page displays information about all discovered nodes, 
including their names, events, status, and other important information.

To access the MWTM Node Status page, select Node Status from the MWTM 
Server Home Page. MWTM displays the MWTM Node Status page (Figure 6-7).

Column Description

Server Name
(in header)

Name of the MWTM server associated with the node.

Update Interval
(in header)

Time between automatic updates for the page. None means the page 
is not automatically updated.

Last Update
(in header)

Date and time the information on the page was last updated by 
MWTM.

Row Numerical index for the objects in the list.

Nodes Nodes discovered by MWTM.

You can sort the table based on the information in the Nodes 
column. See the “Resizing, Sorting, and Hiding Table Columns” 
section on page 3-37 for more details.

Drill-Down Links: Messages Opens the Network Status: Last X Status Change and Trap 
Messages Web page for the node.

Drill-Down Links: Metrics Opens the Network Status Messages: Metrics Web page for the 
node.

Drill-Down Links: Syslog Opens the MWTM Router Syslog Web page for the node.

Drill-Down Links: 
CPU Process

Opens the MWTM CPU Processes Web page for the node, in a Web 
browser.

Drill-Down Links: RAN Trap 
Configuration

Opens the RAN Trap Configuration Web page for the node, in a Web 
browser.

Latest Reports Displays the latest reports, in a Web browser.
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Figure 6-7 MWTM Node Status Page

You can sort the MWTM Node Status table based on the information in one of the 
columns. See the “Resizing, Sorting, and Hiding Table Columns” section on 
page 3-37 for more details.

The MWTM Node Status page displays the following information for each node:

Column Description

Server Name
(in header)

Name of the MWTM server associated with the node.

Update Interval
(in header)

Time between automatic updates for the page.

Last Update
(in header)

Date and time the information on the page was last updated by MWTM.
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Name DNS name of the node, as discovered by MWTM, or the new name that you 
specified for the node. For more information, see the “Editing a Node” section on 
page 6-53.

To see detailed information for the node, click the node name.

Status Current status of the node, with a color-coded background. Possible values are:

Active (green)

Discovering (cyan)

Polling (cyan)

Unknown (red)

Unmanaged (gray)

Waiting (gray)

Warning (yellow)

For detailed definitions of each status, see the “Status Definitions for Nodes” 
section on page A-5.

Column Description
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Status Reason Reason for the current status of the node.

For a full list of possible reasons, see the stateReasons.html file:

• If you installed MWTM in the default directory, /opt, then the file is located 
at /opt/CSCOsgm/apache/share/htdocs/eventHelp directory.

• If you installed MWTM in a different directory, then the help directory and 
file are located in that directory.

If the cell is too small to show all of the status reason, place the cursor over the 
cell to see the full status reason in a mouse over help popup.

The status reasons are listed in order of decreasing magnitude. If two or more 
reasons apply, the reason of greatest magnitude is displayed.

If the status reason is Unsupported Configuration, correct the configuration and 
enter the mwtm cleandiscover command to delete all current network data and 
begin a clean discovery of the RAN-O network. If the status reason is still 
Unsupported Configuration, enter the mwtm clean command to restore the 
MWTM server to a “clean” state, such as would exist after a new installation of 
MWTM. For more information on the use of these commands, see the “MWTM 
Command Reference” section on page C-1.

Device Device type of the node. Possible values are:

• CiscoMWR-1941-DC-A—Cisco MWR-1941-DC-A series router

• RNC—Radio Network Controller

• BSC—Base Station Controller

• BTS—Base Transceiver Station

• Node B—The radio transmission/reception unit for communication between 
radio cells

• IPDevice—IP device, other than those listed above. You can assign this icon 
to an unknown node if you know that it is an IP device.

• Unknown—MWTM is unable to determine the device type.

Column Description
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Viewing MWTM Node Details
The MWTM Node Details page displays detailed information about each 
discovered node, including its status and other information.

To access the MWTM Node Details page, click a node name in a Web page. 
MWTM displays the MWTM Node Details page (Figure 6-8).

Figure 6-8 MWTM Node Details Page
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The MWTM Node Details page displays the following information for the 
selected node:

Field Description

Node Name
(in header)

DNS name of the node, as discovered by MWTM.

Server Name
(in header)

Name of the MWTM server associated with the node.

Update Interval
(in header)

Time between automatic updates for the page.

Last Update
(in header)

Date and time the information on the page was last updated by 
MWTM.

IP Address or DNS Hostname DNS name of the node, as discovered by MWTM.

Drill-Down Links: Messages Opens the Network Status: Last X Status Change and Trap 
Messages Web page for the node.

Drill-Down Links: Metrics Opens the Network Status Messages: Metrics Web page for the 
node.

Drill-Down Links: Syslog Opens the MWTM Router Syslog Web page for the node.

Drill-Down Links: 
CPU Process

Opens the MWTM CPU Processes Web page for the node.

Drill-Down Links: RAN Trap 
Configuration

Opens the RAN Trap Configuration Web page for the node, in a Web 
browser.
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Status Current status of the node, with a color-coded background. Possible 
values are:

Active (green)

Discovering (cyan)

Polling (cyan)

Unknown (red)

Unmanaged (gray)

Waiting (gray)

Warning (yellow)

For detailed definitions of each status, see the “Status Definitions 
for Nodes” section on page A-5.

Last Status Change Date and time that the status of the link last changed.

Field Description
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Status Reason Reason for the current status of the node.

For a full list of possible reasons, see the stateReasons.html file:

• If you installed MWTM in the default directory, /opt, then the 
file is located at 
/opt/CSCOsgm/apache/share/htdocs/eventHelp directory.

• If you installed MWTM in a different directory, then the help 
directory and file are located in that directory.

If the cell is too small to show all of the status reason, place the 
cursor over the cell to see the full status reason in a mouse over help 
popup.

The status reasons are listed in order of decreasing magnitude. If 
two or more reasons apply, the reason of greatest magnitude is 
displayed.

If the status reason is Unsupported Configuration, correct the 
configuration and enter the mwtm cleandiscover command to 
delete all current network data and begin a clean discovery of the 
RAN-O network. If the status reason is still Unsupported 
Configuration, enter the mwtm clean command to restore the 
MWTM server to a “clean” state, such as would exist after a new 
installation of MWTM. For more information on the use of these 
commands, see the “MWTM Command Reference” section on 
page C-1.

Process Traps Indicates whether MWTM is to process traps from this node.

Display Name New name that you specified for the node. If the node has no display 
name, this field is blank. For more information, see the “Editing a 
Node” section on page 6-53.

First Discovered Date and time that the node was first discovered by MWTM.

Field Description
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Device Type Device type of the node. Possible values are:

• CiscoMWR-1941-DC-A—Cisco MWR-1941-DC-A series 
router

• RNC—Radio Network Controller

• BSC—Base Station Controller

• BTS—Base Transceiver Station

• Node B—The radio transmission/reception unit for 
communication between radio cells

• IPDevice—IP device, other than those listed above. You can 
assign this icon to an unknown node if you know that it is an IP 
device.

• Unknown—MWTM is unable to determine the device type.

MIB Level MIB conformance level used by the node, such as IP-RAN R0.

Note Router IOS Version and MIB Level might not have a 
one-to-one correspondence, because multiple IOS versions 
can use the same MIB level if there are no changes to the 
MIBs between versions. 

Router Uptime Time the node has been up, in days, hours, minutes, and seconds.

Reboot Reason Reason for the last reboot of the node.

IOS Version String Version of IOS that is installed on the router.

Primary SNMP Address IP address of the node, used by SNMP to poll the node. (There 
might be other IP addresses on the node that are not the primary 
SNMP address.)

Last Polled Address Last IP address that was polled for this node.

IP Address List List of all IP addresses associated with this node, including the 
primary SNMP address and all backup IP addresses.

Avg. Poll Response (secs) Average time, in seconds, taken by this node to respond to MWTM 
poll requests.

For a node that is not a RAN-O node, this field is left blank.

Field Description
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Last Poll Response (secs) Time, in seconds, taken by this node to respond to the last MWTM 
poll request.

For a node that is not a RAN-O node, this field is left blank.

Last Full Poll Date and time of the last full poll of the node for RAN-O related 
MIBs.

For a node that is not a RAN-O node, this field is left blank.

Note Timestamp Date and time the note associated with this node was last updated. 
If there is no note associated with this node, this field is blank.

Note Note associated with this node. If there is no note associated with 
this node, this field is blank.

Internal ID Internal ID of the node. The internal ID is a unique ID for every 
object, assigned by MWTM for its own internal use. It can also be 
useful when the Cisco TAC is debugging problems.

Field Description
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Viewing Node IOS Versions
The MWTM Node IOS Versions page displays the version of IOS installed on 
each router node.

To access the MWTM Node IOS Versions page, use one of the following 
procedures:

• Select Reports > Router Node IOS Versions from the MWTM Main Menu.

• Select Node IOS Versions from the MWTM Server Home Page.

You can sort the MWTM Node IOS Versions table based on the information in one 
of the columns. See the “Resizing, Sorting, and Hiding Table Columns” section 
on page 3-37 for more details.

The MWTM Node IOS Versions page displays the following information for each 
RAN-O node:

Column Description

Server Name
(in header)

Name of the MWTM server associated with the node.

Update Interval
(in header)

Time between automatic updates for the page. None means the page is not 
automatically updated.

Last Update
(in header)

Date and time the information on the page was last updated by MWTM.

Name DNS name of the node, as discovered by MWTM, or the new name that you 
specified for the node. For more information, see the “Editing a Node” section on 
page 6-53.

IOS Version 
String

Version of IOS installed on the node.

IOS MIB Level MIB conformance level used by the router.

Note IOS Version String and IOS MIB Level might not have a one-to-one 
correspondence, because multiple router versions can use the same MIB 
level if there are no changes to the MIBs between versions. 

Device Type Device type of the node. Possible values are:

• CiscoMWR-1941-DC-A—Cisco MWR-1941-DC-A series router
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Viewing Node Information: CPU Processes
The MWTM CPU Processes page displays detailed information about all CPU 
processes associated with the selected node.

To access the MWTM CPU Processes page:

From the MWTM Node Details page, select CPU Process from the Drill-Down 
Links drop-down menu and click Go! (this option is not available if the node is 
in Unknown or Unmanaged status.)

The MWTM CPU Processes table displays the following information for the 
selected node:

Column Description

Node Name
(in header)

Name of the node for which CPU processes are being displayed.

Server Name
(in header)

Name of the MWTM server associated with the node.

Update Interval
(in header)

Time between automatic updates for the page.

Last Update
(in header)

Date and time the information on the page was last updated by MWTM.

Node Name of the node for which CPU processes are being displayed.

To see detailed information for the node, click the node name.

CPU Number of the CPU for which processes are being displayed.

PID Process identifier.

Name Name of the process.

Time Created Total time since the process was created.

Total Runtime CPU time the process has used.

Times Invoked Number of times the process has been invoked.

Average 
Runtime

Average CPU time for each process invocation.

5 Sec % Average CPU utilization percentage for the node over the last 5 seconds.

1 Min % Average CPU utilization percentage for the node over the last minute.
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Viewing Node Information: Syslog Messages
From the MWTM Router Syslog page, you can view all messages in the system 
log for the selected node.

To access the MWTM Router Syslog page:

From the MWTM Node Details page, select Syslog from the Drill-Down Links 
drop-down menu and click Go! (this option is not available if the node is in 
Unknown or Unmanaged status.) MWTM displays the MWTM Router Syslog 
page, populated with the most recent syslog messages for the selected node.

The MWTM Router Syslog table displays the following information for the 
selected node:

5 Min % Average CPU utilization percentage for the node over the last 5 minutes.

Priority Process queue priority. Possible values are:

• Low

• Normal

• High

• Critical

Column Description

Column Description

Node Name
(in header)

Name of the node for which syslog messages are being displayed.

Server Name
(in header)

Name of the MWTM server associated with the node.

Update Interval
(in header)

Time between automatic updates for the page. None means the page is not 
automatically updated.

Last Update
(in header)

Date and time the information on the page was last updated by MWTM.

Node Name of the node for which syslog messages are being displayed.

To see detailed information for the node, click the node name.
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Viewing Node Information: RAN Trap Configuration
From the MWTM Router Syslog page, you can view all messages in the system 
log for the selected node.

To access the MWTM Router Syslog page:

From the MWTM Node Details page, select RAN Trap Configuration from the 
Drill-Down Links drop-down menu and click Go! (this option is not available if 
the node is in Unknown or Unmanaged status.) MWTM displays the MWTM 
Router Syslog page, populated with the most recent syslog messages for the 
selected node.

The MWTM Router Syslog table displays the following information for the 
selected node:

Timestamp Time since router reboot of the syslog message.

Severity Severity of the syslog message. Possible values are:

• Alert—Messages that require immediate action.

• Critical—Critical conditions.

• Debug—Debug messages, log FTP commands, and WWW URLs.

• Emergency—System unusable messages.

• Error—Error messages.

• Info—Information messages.

• Notice—Normal but significant conditions.

• Warning—Warning messages.

Facility Name of the facility that generated the syslog message, such as SYS or SNMP.

Name Short text identifier for the message type. A facility name in conjunction with a 
message name uniquely identifies a syslog message type.

Message Text of the syslog message.

Column Description
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Column Description

Node Name
(in header)

Name of the node for which RAN trap configuration is being displayed.

Server Name
(in header)

Name of the MWTM server associated with the node.

Update Interval
(in header)

Time between automatic updates for the page. None means the page is not 
automatically updated.

Last Update
(in header)

Date and time the information on the page was last updated by MWTM.

Node Name of the node for which RAN trap configuration is being displayed.

To see detailed information for the node, click the node name.

RAN Trap 
Settings

Trap settings for the node. These settings include:

• GSM State Change

• UMTS State Change

• Utilization Threshold Change

IP Address IP address of a host to which the node sends traps.

Port Port to which the node sends traps.

Trap Version Trap version sent to this IP address and port.

Community 
String

SNMP community name used by the node for read access to the information 
maintained by the SNMP agent on the device.
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Working with Interfaces

MWTM enables you to view information about all discovered interfaces, 
including their status and other important information.

This section includes the following information:

• Viewing Detailed Information for an Interface, page 7-1

• Attaching a Note to an Interface, page 7-19

• Viewing Notes for an Interface, page 7-20

• Deleting an Interface, page 7-20

• Ignoring an Interface, page 7-22

Related Topics:

• Changing MWTM Client Preference Settings, page 11-3

• Resizing, Sorting, and Hiding Table Columns, page 3-37

Viewing Detailed Information for an Interface
MWTM can display detailed information about a selected interface, including its 
status and other information.

Updates for the interface that are received from the MWTM server are reflected 
automatically in this window.

To display detailed information for an interface, select the turner beside Nodes in 
the left pane of the MWTM Main Window. Then select the turner beside a specific 
node to display its interfaces. Finally, select an interface.
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MWTM displays the Interface Details Window (Figure 7-1).

Figure 7-1 Interface Details Window

The Interface Details Window is composed of the following sections:

• Interface Details: Right-Click Menu, page 7-3

• Interface Details: Configuration Details, page 7-7

• Interface Details: Notes, page 7-13

• Interface Details: Recent Events, page 7-14

Related Topics:

• Viewing Detailed Information for a Node, page 6-13
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Interface Details: Right-Click Menu
The Interface Details Window provides a right-click menu. To see this menu, 
select an interface in the left pane and click the right mouse button. The interface 
details right-click menu provides the following options:

Menu Command Description

Show In New Window Opens the Interface Details Window for the selected 
interface in a new window.

Edit > Notes Opens the Edit Notes Dialog for the selected interface.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level Power 
User (Level 2) and higher.

Clear Event Icon Deletes the event icon (orange triangle) from MWTM 
displays for the selected interface, for this MWTM client 
only. The actual events are not deleted from MWTM, only 
the event icon for the selected interface for this MWTM 
client.

This option is grayed-out if the selected interface has no 
associated event icon.
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Delete Deletes the currently selected interface from the MWTM 
database. MWTM displays the Confirm Deletion dialog:

• To delete the selected interface, click Yes. The 
interface is deleted from the MWTM database and the 
Confirm Deletion dialog is closed.

• To retain the selected interface, click No. The interface 
is kept in the MWTM database and the Confirm 
Deletion dialog is closed.

• To prevent MWTM from displaying the Confirm 
Deletion dialog, select the Do not show this again 
checkbox.

Note If you select the Do not show this again checkbox, 
and you later decide you want MWTM to begin 
displaying the Confirm Deletion dialog again, you 
must select the Confirm Deletions checkbox in the 
General GUI settings in the Preferences window. 
For more information, see the description of the 
Confirm Deletions checkbox in the “Startup/Exit 
Settings” section on page 11-7.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level 
Network Administrator (Level 4) and higher.

Go to > Parent Node Navigates to the Node Details window of the parent node.

Back > List of Windows Navigates back to a window viewed in this session.

MWTM maintains a list of up to 10 Back windows.

Forward > List of Windows Navigates forward to a window viewed in this session.

MWTM maintains a list of up to 10 Forward windows.

View > Configuration Details Displays the Configuration Details panel for the selected 
interface.

View > Notes Displays the Notes panel for the selected interface.

If there are no notes associated with the selected interface, 
this option is grayed-out.

Menu Command Description
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View > Events Displays the Recent Events panel for the selected interface 
and its associated network objects.

View > Center in Topo Opens the Topology Window and displays the interface in 
the center of the topology map.

Event History > Status Change 
Messages

Displays the MWTM Network Status Log for Status 
Change Messages in a Web browser, with messages 
displayed for only the selected node.

Event History > SNMP Trap Messages Displays the MWTM Network Status Log for SNMP Trap 
Messages in a Web browser, with messages displayed for 
only the selected interface.

Event History > Status and Trap 
Messages

Displays the MWTM Network Status Log for Status 
Change Messages and SNMP Trap Messages in a Web 
browser, with messages displayed for only the selected 
interface.

Event History > Network Status 
Metrics

Displays the MWTM Network Status Log for Metrics in a 
Web browser, with messages displayed for only the 
selected interface.

Ignore Ignores the selected interface at the next polling cycle.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level Power 
User (Level 2) and higher.

Unignore Stops ignoring the selected interface at the next polling 
cycle.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level Power 
User (Level 2) and higher.

Menu Command Description
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Latest Reports > RAN Capacity 
Planning

Displays the RAN Capacity Planning Report for the 
interface, in a Web browser.

This option is not available if the interface is in Unknown 
or Unmanaged status.

Latest Reports > RAN Statistics Displays the RAN Backhaul 15 Minutes Statistics report 
associated with the interface, in a Web browser.

This option is not available if the interface is in Unknown 
or Unmanaged status.

Menu Command Description
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Interface Details: Configuration Details
The Interface Details: Configuration Details section is composed of the following 
sub-sections:

• Naming Information, page 7-7

• General Information, page 7-8

• Status Information, page 7-8

• RAN Information, page 7-13

Naming Information

The Naming Information sub-section contains the following fields:

Field Description

Name Name of the interface.

Node Name of the node to which the interface belongs.

Physical Address Physical address of the interface.

IF Index Interface index number.

IF Type Interface type.

RAN Connection 
To

Node to which the interface is connected.
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General Information

The General Information sub-section contains the following fields:

Status Information

The Status Information sub-section contains the following fields:

Field Description

Maximum Packet 
Size

Maximum packet size on the interface, in bytes.

Speed (Bits/Sec) Interface speed in bits per second.

Field Description

Is Ignored Indicates whether the interface is Ignored (that is, whether the interface is to 
be included when aggregating and displaying MWTM status information).

Admin Status Displays the administrative status of the interface. Status can be:

Unknown (red)—Unknown administrative status

Up (green)—Administratively up

Shutdown (blue)—Administratively down

Testing (blue)—Administrator is testing the interface

Operational Status Displays the operational status of the interface. Status can be:

Unknown (red)—Unknown operational status.

Up (green)—Interface is up.

Down (red)—Interface is down.

Testing (blue)—Interface is in test mode.

Dormant (red)—Interface is dormant.

Not Present (red)—An interface component is missing.

Lower Layer Down (red)—An interface is down because of a lower-layer 
interface.
7-8
Cisco Mobile Wireless Transport Manager User Guide

OL-7637-01



 

Chapter 7      Working with Interfaces
Viewing Detailed Information for an Interface
Connect State
(for GSM Abis)

Displays the connection state of a GSM interface. States can be:

Connected (green)—The device is monitoring local and remote alarm status.

Disconnected (red)—The system ignores the local alarm status. The local 
transmitter on the short-haul is disabled. Capabilitymessages are transmitted to 
the remote describing the provisioning. The system stays disconnected until 
the remote capabilities are known and the peer state is transitioned to 
connected.

Send Connect (yellow)—One or more attempts have been made to connect to 
remote peer.

Receive Connect (yellow)—The local-peer has received a connect request 
from the remote-peer.

Connect Rejected (yellow)—Connection was rejected.

ACK Connect (yellow)—The initial connect request was sent and 
acknowledged by remote-peer. The local-peer is now waiting for a connect 
request from the remote-peer.

Check Connect (yellow)—The local peer has reason to believe its remote peer 
has failed. Additional tests are being processed to verify peer's state.

Field Description
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Connect State 
(for UMTS Iub)

Displays the connection state of a UMTS interface. States can be:

Initialized (yellow)—The connection is starting initialization.

Starting (red)—The shorthaul interface is administratively active, but the 
backhaul interface is down.

Closed (blue)—The backhaul interface is active, but the shorthaul is 
administratively closed.

Stopped (red)—Unable to connect to peer in specified time interval. 
Additional attempts will be tried based on peer request or restart timers.

Closing (blue)—Connection closed by administration request.

Stopping (yellow)—Connection shut down by peer's Term-Request. Will 
transition to stopped state. 

Connect Sent (yellow)—Connection request sent to peer.

ACK Received (yellow)—Connection request sent and acknowledgement has 
been received from peer. Now waiting for peer's connection request.

ACK Sent (yellow)—Connection request received and acknowledgement has 
been sent to peer. Connection request sent and waiting for peer's 
acknowledgement.

Open (green)—Connection open and available for traffic.

Local Receive Alarm 
State

Local Transmit 
Alarm State

Remote Receive 
Alarm State

Remote Transmit 
Alarm State

Displays alarm states for UMTS Iub interface. States can be:

Remote Alarm (blue)—Indicates a problem at the remote end. The alarm 
generated by the remote interface in the E1/T1 data stream is sent and no other 
action is required. 

No Alarm (green)—No alarm is present. 

Local Alarm (red)—Indicates local interface problem. The interface has not 
received synchronization from the GSM device. Device stops transmitting 
backhaul samples.

Received Alarm (yellow)—Indicates receive problem in the local device. The 
remote device stops transmitting backhaul data and indicates a blue alarm.

Alarm State Unavailable (red)—Indicates the alarm state is not available. 
This state only applies to the remote and occurs when the peer connection is 
inactive.

Field Description
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Redundancy State Displays information about the GSM Abis or UMTS Iub interface redundancy 
state. States can be:

Active (green)—Active owner of interface.

Standby (green)—Active owner of interface.

Status Current status of the interface. Possible values are:

Active (green)

Discovering (cyan)

Down (red)

Polling (cyan)

Unknown (red)

Unmanaged (gray)

Waiting (gray)

Warning (yellow)

For detailed definitions of each status, see the “Status Definitions for Nodes” 
section on page A-5.

Field Description
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Last Status Change Date and time of last change to status.

Status Reason Reason for the current status of the interface.

For a full list of possible reasons, see the stateReasons.html file:

• If you installed MWTM in the default directory, /opt, then the file is 
located at /opt/CSCOsgm/apache/share/htdocs/eventHelp directory.

• If you installed MWTM in a different directory, then the help directory and 
file are located in that directory.

If the cell is too small to show all of the status reason, place the cursor over the 
cell to see the full status reason in a mouse over help popup.

The status reasons are listed in order of decreasing magnitude. If two or more 
reasons apply, the reason of greatest magnitude is displayed.

If the status reason is Unsupported Configuration, correct the configuration 
and enter the mwtm cleandiscover command to delete all current network data 
and begin a clean discovery of the RAN-O network. If the status reason is still 
Unsupported Configuration, enter the mwtm clean command to restore the 
MWTM server to a “clean” state, such as would exist after a new installation 
of MWTM. For more information on the use of these commands, see the 
“MWTM Command Reference” section on page C-1.

Field Description
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RAN Information

Note This sub-section appears only for configured RAN interfaces (GSM Abis and 
UMTS Iub interfaces).

The RAN Information sub-section contains the following fields:

Interface Details: Notes
The Interface Details: Notes section displays:

• Notes associated with the interface.

• The date and time the notes associated with the interface were last updated, 
or the phrase Not Set if there are no notes associated with the interface.

• The phrase No Notes if there are no notes associated with the interface.

Field Description

Protocol Protocol of the interface (GSM-Abis or UMTS-Iub).

Local IP Address IP address of the local device.

Local Port Local port used by the interface.

Remote IP Address IP address of the remote (peer) device.

Remote Port Remote port used by the interface.
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Interface Details: Recent Events
The Interface Details: Recent Events table (Figure 7-2) displays all recent events 
associated with the interface, and enables you to perform event-related tasks, such 
as setting filters and acknowledging events.

Figure 7-2 Recent Events Table for an Interface

To see mouse over help popup for each column in the table, place the cursor over 
a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the 
full data in a mouse over help popup.

You can resize each column, or sort the table based on the information in one of 
the columns. By default, MWTM displays the following columns: Act , Category, 
Severity, Time, and Message.
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• To display hidden columns, right-click in the table header and select the 
checkboxes for the columns you want to display.

• To hide columns, right-click in the table header and clear the checkboxes for 
the columns you want to hide.

See the “Resizing, Sorting, and Hiding Table Columns” section on page 3-37 for 
more information about resizing, sorting, displaying, or hiding columns.

The Interface Details: Recent Events table contains the following toolbar buttons 
and columns:

Toolbar Button or Column Description

Set Filter Opens the Event Filter dialog.

Apply Filter

or

Remove Filter

Activates and deactivates the event filter specified in the Event Filter 
dialog:

• If the filter is activated, MWTM displays only those events that pass 
the filter.

• If the filter is deactivated, MWTM displays all events.

• If you activate a filter in an object’s Recent Events table in the 
MWTM Main Window, the filter is activated in all Recent Events 
tables in the MWTM Main Window for all other network objects. 
The filter is not activated in Recent Events tables in Show In New 
Window windows or real-time data and charts windows.

Pause

or

Resume

Pauses or resumes the table.

While the table is paused, MWTM does not display new events in the 
table (unless you apply an event filter or edit your event preferences). 
When the table is resumed, all new events since the table was paused are 
added to the display.

If events are deleted while the table is paused, they are not removed from 
the table. Instead, they are grayed-out and cannot be acknowledged or 
edited. Deleted events are removed from the table when you resume the 
table.

Acknowledge Makes the selected event or events acknowledged.

Unacknowledge Makes the selected event or events unacknowledged.
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Event Properties Opens the Event Properties window.

Edit Notes Opens the Edit Event Dialog.

Time Difference Displays the difference in days, minutes, hours, and seconds between 
two events.

Find Finds specific text in the event table.

Create Sound Filter Opens the Event Sound Filters dialog and the Event Sound Filters List 
dialog, with fields populated based on the selected event.

Adjust Row Height Adjusts the table row height and wraps the message text as follows:

• Click once to double the row height and wrap the message text.

• Click again to triple the row height and wrap the message text.

• Click again for single row height and no message text wrapping. 
This is the default setting.

This setting is saved automatically with your preferences.

Help for Event Displays context-sensitive help for the selected event in a separate Web 
browser.

Internal ID Internal ID of the event. The internal ID is a unique ID for every object, 
assigned by MWTM for its own internal use. It can also be useful when 
the TAC is debugging problems.

Ack Indicates whether the event has been acknowledged:

• To acknowledge an unacknowledged event, use the Acknowledge 
toolbar button.

• To make a previously acknowledged event unacknowledged, use the 
Unacknowledge toolbar button.

Toolbar Button or Column Description
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Category Type of the event. Default values are:

• Create—Creation event, such as the creation of a seed file.

• Delete—Deletion event, such as the deletion of an object or file.

• Discover—Discovery event, such as Discovery beginning.

• Edit—Edit event. A user has edited an object.

• Ignore—Ignore event. A user has Ignored a link or linkset.

• Login—Login event. A user has logged in to MWTM.

• LoginDisable—LoginDisable event. MWTM has disabled a user’s 
User-Based Access authentication as a result of too many failed 
attempts to log in to MWTM.

• LoginFail—LoginFail event. An attempt by a user to log in to 
MWTM has failed.

• Logout—Logout event. A user has logged out of MWTM.

• OverWrite—OverWrite event. An existing file, such as a seed file 
or route file, has been overwritten.

• Poll—Poll event, such as an SNMP poll.

• Purge—Purge event. A user has requested Discovery with Delete 
Existing Data selected, and MWTM has deleted the existing 
MWTM database.

• Status—Status change message generated.

• Trap—SNMP trap message generated.

You can customize this field. See the “Changing Event Categories” 
section on page 5-34 for more information.

Toolbar Button or Column Description
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Viewing Detailed Information for an Interface
Severity Severity of the event. Default values are:

• Critical—The default color is red.

• Indeterminate—The default color is aqua.

• Informational—The default color is white.

• Major—The default color is orange.

• Minor—The default color is yellow.

• Normal—The default color is green.

• Warning—The default color is blue.

You can customize this field. See the “Changing Event Severities and 
Colors” section on page 5-35 for more information.

Note Indicates whether there is a note associated with the event.

Message Name User-specified message name for the event, used by MWTM for trap 
forwarding. The default message name is MWTM.

For more information about user-specified message names and trap 
forwarding, see the “Forwarding Events as Traps to Other Hosts” section 
on page 5-50.

Time Date and time the event was logged.

Ack By If you have not implemented MWTM User-Based Access, name of the 
device that last acknowledged the event.

If you have implemented MWTM User-Based Access, name of the user 
who last acknowledged the event.

If no one has acknowledged the event, this field is blank.

Ack Time Date and time the event was last acknowledged or unacknowledged.

Node Name of the node associated with the event. If there is no node 
associated with the event, None is displayed.

Message Text of the message.

You can customize this field. See the “Changing the Way MWTM 
Processes Events” section on page 5-26 for more information.

Toolbar Button or Column Description
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Attaching a Note to an Interface
Attaching a Note to an Interface
MWTM enables you to annotate an interface, attaching a descriptive string to it.

To attach a note to an interface, right-click the interface in a window, then select 
Edit > Notes in the right-click menu. MWTM displays the Edit Notes Dialog for 
an Interface (Figure 7-3).

Figure 7-3 Edit Notes Dialog for an Interface

The Edit Notes Dialog for an Interface contains the following fields and buttons:

Field or Button Description

Name Name of the interface. You cannot edit this field.

Note Last Updated Date and time the Notes field for this interface was last updated. If there is no 
note currently associated with this interface, this field displays the value Not Set.

You cannot edit this field.

Notes Notes to associate with this interface. In this field, you can enter any important 
information about the interface, such as a detailed description, its location, its 
service history, and so on.

Save Saves changes you have made to the interface’s notes, updates all MWTM 
windows to reflect your changes, and exits the dialog.

When you annotate a node, MWTM displays a note icon in the Notes column of 
all interface tables for the annotated interface.

Cancel Exits the dialog without saving any changes.

Help Displays online help for the dialog.
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Viewing Notes for an Interface
Viewing Notes for an Interface
MWTM enables you to view any notes that have been associated with an interface.

To view a note for an interface, right-click a node in a window, then select View 
> Notes in the right-click menu. (The Notes option is grayed-out if there is no note 
associated with the selected node.)

MWTM displays the Notes panel for the selected node, which displays:

• Notes associated with the interface.

• The date and time the notes associated with the interface were last updated, 
or the phrase Not Set if there are no notes associated with the interface.

• The phrase No Notes if there are no notes associated with the interface.

Related Topics:

• Attaching a Note to an Interface, page 7-19

Deleting an Interface
After Discovery, the interfaces in your network are known to MWTM and added 
to the MWTM database. Physically deleting interfaces from your network is not 
the same as deleting them from the MWTM database. The following sections 
describe the differences between deleting interfaces from your network, from the 
MWTM database, and from the MWTM Discovery database, and the procedures 
for doing so:

• Deleting an Interface from Your Network, page 7-20

• Deleting an Interface from the MWTM Database, page 7-21

Deleting an Interface from Your Network
If you physically delete a known interface from your network (for example, by 
powering down a router), it remains in the MWTM database, MWTM labels it 
Unknown, and it is the system administrator’s responsibility to delete it from the 
MWTM database, if you choose to do so.
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Deleting an Interface
Deleting an Interface from the MWTM Database
Typically, you delete an interface from the MWTM database because you have 
physically deleted the interface from your network. This is the most common 
reason for deleting an interface from the MWTM database.

If you have physically deleted an interface from your network, and you then delete 
it from MWTM, it is no longer in the MWTM database, it does not appear in 
MWTM windows, and it is not discovered when you run Discovery.

Note If you delete an interface from the MWTM database, the interface is deleted for 
all MWTM clients and views connected to that MWTM server. If the interface is 
still configured on the router, it will re-appear on the MWTM at the next poll.

To delete an interface from the MWTM database, use one of the following 
procedures:

• Select an interface in a window, then select Edit > Delete from the MWTM 
Main Menu.

• Right-click an interface in a window, then select Delete in the right-click 
menu. 

MWTM asks you to confirm the deletion:

• Select Yes to delete the selected interface. MWTM deletes the interface from 
the MWTM database.

• Select No to return to the window without deleting any interfaces from the 
MWTM database.
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Ignoring an Interface
Ignoring an Interface
You can instruct MWTM to ignore an interface. Setting interfaces to Ignored 
prevents known interface problems from affecting MWTM displays for associated 
network objects. In effect, you are preventing a known problem from distracting 
you from other, more urgent network problems.

Note If you set an interface to Ignored, the interface is ignored for all MWTM clients 
and views connected to that MWTM server.

Also, if you set an interface to Ignored, make a note of the change, and do not 
forget to reset the interface when the problem is corrected or the maintenance is 
complete.

To set an interface to Ignored, right-click the interface in the left panel, then 
select Ignore from the right-click menu.
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Viewing the Topology of the Network

In addition to tabular (text) views of your network, MWTM provides a topology 
(graphical) view of the objects in your network, including adjacent devices, and 
enables you to customize the view to meet your needs.

To view the topology of your network, use one of the following procedures:

• Select View > Show Topology from the MWTM Main Menu.

• Right-click an object, then select View > Center in Topo in the right-click 
menu.

MWTM displays the Topology Window (Figure 8-1).
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Figure 8-1 Topology Window

The Topology Window displays tabular information about MWTM objects in the 
left pane and the graphical topology map in the right pane.

The Topology Window is composed of the following sections:

• Topology Menu, page 8-4

• Topology Toolbar Buttons, page 8-4

• Topology View Table, page 8-7

• Topology New Objects Panel, page 8-10

• Topology Excluded Objects Panel, page 8-10

• Topology Map, page 8-11
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MWTM provides the following functions related to the topology map:

• Creating a Custom Layout, page 8-21

• Finding an Object, page 8-22

• Using the Selection Dialog, page 8-23

• Scrolling in the Topology Map, page 8-24

• Centering the Topology Map on an Object, page 8-24

• Displaying Detailed Information About a Topology Map Element, page 8-24

• Displaying the Topology New Objects Panel, page 8-24

• Displaying the Topology Excluded Objects Panel, page 8-25

• Printing the Topology Map, page 8-25

• Saving the Topology Map as a JPEG File, page 8-26

• Selecting a Directory for the JPEG File, page 8-28

• Activating a Magnetic Grid on the Topology Map, page 8-30

• Specifying a Color for the Magnetic Grid, page 8-32

• Specifying a Background Color for the Topology Map, page 8-35

• Aligning Objects on the Topology Map, page 8-37

• Hiding and Redrawing Lines When Redrawing, page 8-39

• Hiding and Showing Lines When Redrawing, page 8-39

• Locking and Unlocking the Position of an Icon, page 8-40

• Turning Off Antialiasing to Improve Performance, page 8-40

• Saving the Topology Map, page 8-41

• Restoring the Topology Map, page 8-41

Related Topics:

• Diagnosing a Typical Network Problem, page 12-6

• Changing MWTM Client Preference Settings, page 11-3

• Working with Views, page 4-1
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Topology Menu
Topology Menu
The Topology Window uses the MWTM Main Menu. See the “Using the MWTM 
Main Menu” section on page 3-9 for detailed descriptions of the options it 
provides.

Topology Toolbar Buttons
The Topology Window contains the following toolbar buttons:

Button Description

Close view tab Closes the currently displayed view in the Topology Window.

This option is grayed-out if the currently displayed view is the 
highest level parent view.

Open parent view Opens the parent view of the currently displayed view in the 
Topology Window.

This option is grayed-out if the currently displayed view is the 
highest level parent view.

Lay out nodes in a circle Displays the map in a circular layout.

Lay out nodes in a spring Displays the map in a spring layout. That is, nodes with the 
most links are drawn closer to the center of the map, while 
nodes with fewer links are drawn farther away. This is the 
default setting the first time the map is displayed.

Note You can change how far apart nodes are spaced when 
MWTM draws the spring layout. For details, see the 
“Topology Settings” section on page 11-11.

Zoom in by a factor of 200% Makes the map twice as large.

Zoom out by a factor of 50% Makes the map half as large.

Zoom by percentage Zooms the map by a selected percentage. Either select a 
percentage from the drop-down list box, or enter a percentage 
and click Enter. Valid values are integers in the range 
5 through 400.
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Topology Toolbar Buttons
Zoom in on an area Zooms in on the selected area of the map. Click the button, then 
click in the topology map and drag a rectangle around the area 
you want to zoom in on. MWTM expands the selected area to 
fill the topology map.

Zoom to fit window Adjusts the size of the map to fit in the window. This is the 
default setting the first time the map is displayed.

Find objects Opens the Find Objects dialog, which enables you to find and 
highlight an object in the Topology Window.

Set magnetic grid properties Opens the Magnetic Grid Settings dialog, which enables you to 
activate and deactivate the magnetic topology grid, and 
modifies how it is displayed. With the grid activated, when you 
move objects on the topology map they “snap” to align with the 
grid.

Align objects on map Opens the Align Objects dialog, which enables you to align two 
or more objects on the topology map.

Node Dragging Optimizer Turns the Node Dragging Optimizer on or off:

• When the Node Dragging Optimizer is On, MWTM hides 
connection lines as you drag an object around the topology 
map. MWTM draws the linkset lines when you drop the 
object in its final position. This is the default setting.

• When the Node Dragging Optimizer is Off, MWTM 
continually redraws connection lines as you drag an object 
around the topology map.

This setting, with the Node Dragging Optimizer on or off, is 
saved automatically with your preferences.

Button Description
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Topology Toolbar Buttons
Hiding/Showing Dangling 
Connections

Hides or shows nodes and lines that connect to objects that are 
not in the current view, called dangling connections:

• When the Hiding Dangling Connections is set to Hide, 
MWTM hides dangling connections. This is the default 
setting.

• When the Hiding Dangling Connections is set to Show, 
MWTM shows dangling connections, drawing the nodes 
and connections in shades of gray to distinguish them from 
actual objects in the current view.

This setting, with the Hiding Dangling Connections set to Show 
or Hide, is not saved when you save the view.

To include a dangling node and its connection in the current 
view, select the node, then select Include In View.

Lock position

or

Unlock position

Locks or unlocks the position of an icon on the topology map. 
Locking the position of an icon can be useful if you want to 
keep the icon in its position, and you want to make sure you do 
not move it inadvertently. Locked icons are not included in the 
circular or spring layouts.

• To lock the position of an icon, select an unlocked icon, 
then select Lock position.

• To unlock the position of an icon, select a locked icon, then 
select Unlock position. This is the default setting.

This setting, with icon positions locked or unlocked, is saved 
automatically with your view.

Button Description
8-6
Cisco Mobile Wireless Transport Manager User Guide

OL-7637-01



 

Chapter 8      Viewing the Topology of the Network
Topology View Table
Topology View Table
The topology view table in the left pane of the Topology Window displays 
information about the MWTM objects that are currently displayed in the topology 
map.

To display the topology view table, select the Tables tab in the left pane of the 
Topology Window. By default, this table is sorted by Status.

To redraw the topology map centered on a specific object, double-click the object 
in this table.

You cannot select more than one object at a time in this table.

To see mouse over help popup for each column in the table, place the cursor over 
a column header.

If a cell is too small to show all of its data, place the cursor over the cell to see the 
full data in a mouse over help popup.

You can resize each column, or sort the table based on the information in one of 
the columns. By default, MWTM displays only the Type, Name, Node Name, and 
Status columns in the topology view table.

• To display hidden columns, right-click in the table header and select the 
checkboxes for the columns you want to display.

• To hide columns, right-click in the table header and clear the checkboxes for 
the columns you want to hide.

See the “Resizing, Sorting, and Hiding Table Columns” section on page 3-37 for 
more information about resizing, sorting, displaying, or hiding columns.

The topology view table contains the following columns:
8-7
Cisco Mobile Wireless Transport Manager User Guide

OL-7637-01



 

Chapter 8      Viewing the Topology of the Network
Topology View Table
Column Description

Internal ID Internal ID of the object. The internal ID is a unique ID for every object, 
assigned by MWTM for its own internal use. It can also be useful when the 
TAC is debugging problems.

Type Type of object:

• MWRNode—A Mobile Wireless Router node

• Node—Any interconnecting node that is not an MWR node

• View—Custom view (if one exists)

Name Name of the object.

Node Name of the node associated with the object.

Notes Indicates whether there is a note associated with the object.

Events Indicates whether there is a recent event associated with the object. (Even if 
the server purges all of the events associated with the object, MWTM 
continues to display the event icon in this field.)

During Discovery, MWTM might flag most objects with an event icon 
(orange triangle). If the event icons are too distracting, select Edit > Clear 
All Events from the MWTM Main Menu to remove them.

Last Status Change Date and time that the status of the object last changed.

Status Current status of the object. Possible values are:

Active (green)

Unknown (red)

Unmanaged (gray)

Warning (yellow)

For detailed definitions of each status, see the “MWTM Status Definitions” 
section on page A-1.
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Topology View Table
Status Reason Reason for the current status of the object.

For a full list of possible reasons, see the stateReasons.html file:

• If you installed MWTM in the default directory, /opt, then the file is 
located at /opt/CSCOsgm/apache/share/htdocs/eventHelp directory.

• If you installed MWTM in a different directory, then the help directory 
and file are located in that directory.

If the cell is too small to show all of the status reason, place the cursor over 
the cell to see the full status reason in a mouse over help popup.

The status reasons are listed in order of decreasing magnitude. If two or more 
reasons apply, the reason of greatest magnitude is displayed.

If the status reason is Unsupported Configuration, correct the 
configuration and enter the mwtm cleandiscover command to delete all 
current network data and begin a clean discovery of the RAN-O network. If 
the status reason is still Unsupported Configuration, enter the mwtm clean 
command to restore the MWTM server to a “clean” state, such as would exist 
after a new installation of MWTM. For more information on the use of these 
commands, see the “MWTM Command Reference” section on page C-1.

Ignored Indicates whether the object is to be included when aggregating and 
displaying MWTM status information:

• Clear the checkbox to include the object. This is the default setting.

• Select the checkbox to exclude the object.

This field can be edited by users with authentication level Power User 
(Level 2) and higher.

Column Description
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Topology New Objects Panel
Topology New Objects Panel
The topology New Objects panel in the left pane of the Topology Window 
displays graphical elements for newly discovered objects, based on the following 
criteria:

• If you are using an MWTM client with the DEFAULT view set, this panel 
never contains any objects. In the DEFAULT view, MWTM adds all newly 
discovered objects to the topology map as soon as they are discovered.

• If you are using an MWTM client with a custom view set, this panel contains 
all objects discovered since the Topology Window was opened in this session 
that have not been excluded in the Excluded from View table of the View 
Editor Window, or that are not in the current view.

To display the topology New Objects panel, select the New Objects tab in the left 
pane of the Topology Window, or click the “New!” icon in the bottom of the 
window.

To add a newly discovered object to the topology map, select one or more objects 
and drag them to the map while holding down the left mouse button.

To exclude a newly discovered object, use the View Editor Window. See the 
“Creating a New View” section on page 4-42 for more details.

Topology Excluded Objects Panel
The topology Excluded Objects panel in the left pane of the Topology Window 
displays graphical elements for excluded objects. Excluded objects are objects 
that you have chosen not to manage, that you have moved to the Excluded from 
View table of the View Editor Window. (See the “Creating a New View” section 
on page 4-42 for more information about excluding objects from views.)

To display the topology Excluded Objects panel, select the Excluded Objects tab 
in the left pane of the Topology Window.

To add an excluded object to the topology map, select the object and drag it to the 
map while holding down the left mouse button. When you do so, the object is no 
longer excluded, and it is removed from the Excluded from View table of the View 
Editor Window.
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Topology Map
Topology Map
The topology map in the right pane of the Topology Window displays the objects 
and views in your network in an easy-to-read graphical format.

If you have defined custom views, you can view them in the topology map. 
MWTM displays a tab for each displayed view. Each tab displays a colored ball 
that indicates the current status of that view:

• Active (green)

• Warning (yellow)

For detailed definitions of each status, see the “Status Definitions for Views” 
section on page A-6.

See the “Creating a New View” section on page 4-42 for more information about 
excluding objects.

To see mouse over help popup, place the cursor over an object.

Note You can turn off mouse over help. For details, see the “Topology Settings” section 
on page 11-11.

To highlight an element in the topology view table or topology table in the left 
pane, click it:

• Click a node in the topology view table to display any associated interfaces 
in the topology table.

• Click a line, a diamond, or double-triangle to highlight the closest associated 
node in the topology view table. For example, if there is a line connecting 
node mwtm-1941a and node mwtm-1941b, and you click the line closer to 
node mwtm-1941a, then that node is highlighted in the topology view table.

To display detailed information about an element in the map, double-click it, then 
respond to MWTM’s prompts:

• Double-click a node to display the Details Window for that node.

• Double-click a line, a diamond, or double-triangle, to display the Details 
Window for that interface.

To scroll around in the topology map, click anywhere in the map, then click the 
arrow, Page Up, and Page Down keys.
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Topology Map
To redraw the topology map centered on a specific node or interface, double-click 
the node or interface in the topology view table.

To save the topology map as a JPEG file, use the Save as JPEG dialog. See the 
“Saving the Topology Map as a JPEG File” section on page 8-26 for more details.

To activate or change the magnetic topology grid, which can help you align nodes 
when you move them, use the Magnetic Grid Settings dialog. See the “Activating 
a Magnetic Grid on the Topology Map” section on page 8-30 for more details.

To align two or more objects on the topology map, use the Align Objects dialog. 
See the “Aligning Objects on the Topology Map” section on page 8-37 for more 
details.

To hide connections to objects that are not in the current view (called dangling 
connections), click the Hiding/Showing Dangling Connections button to set it 
to Hide. To show dangling connections, click the Hiding/Showing Dangling 
Connections button to set it to Show. MWTM draws the nodes in shades of gray 
to distinguish them from actual objects in the current view. This setting, with the 
Hiding Dangling Connections set to Show or Hide, is not saved.

To include a dangling connection in the current view, right-click the connection 
and select Include In View.

To lock the position of an icon on the topology map, select an unlocked icon, then 
select Lock position. Locking the position of an icon can be useful if you want to 
keep the icon in its position, and you want to make sure you do not move it 
inadvertently. Locked icons are not included in the circular or spring layouts.

To unlock the position of an icon on the topology map, select a locked icon, then 
select Unlock position.

The topology map might contain graphical elements for any of the following 
objects, which are assigned automatically by MWTM:

• BSC—Base Station Controller

• BTS—Base Transceiver Station

• Cloud— A collection of objects, called a submap. A submap can also contain 
other submaps.

• IP device, other than other than those listed above (if assigned by a user; see 
the “Editing a Node” section on page 6-53 for more details)

• A line indicates a single logical connection configured between two nodes:
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Topology Map
– A line that ends in a diamond indicates that the interface has been 
configured.

– A line that does not end in a diamond indicates that the interface is not 
configured on that node or cannot be displayed because MWTM is not 
managing that node.

– A line that ends in a double triangle indicates a connection that has 
multiple interfaces.

• A heavy line indicates the backhaul interface configured between two nodes.

In addition, users can assign graphical elements for the following objects:

• Building—Icon representing a collection of objects within a building

• City—Icon representing a collection of objects within a city

• Database—Icon representing a database object

• MSC—Mobile switching center

• Tower—Icon representing a PC tower

• TrafficGenerator—Icon representing a device or emulator used to generate 
traffic, usually in a test environment

• Workstation—Icon representing a workstation

• Workstation2—Icon representing a different workstation

The color of a graphical element indicates its current status. For detailed 
definitions of each status, see the “MWTM Status Definitions” section on 
page A-1.

A note icon in the upper left corner of an element means a user has attached a 
descriptive string to the element.

An event icon (orange triangle) in the upper right corner of an element means 
there is a recent event associated with the element.

The topology map also provides right-click menus for elements. For more 
information, see the following sections:

• Topology Right-Click Menu: Map, page 8-14

• Topology Right-Click Menu: View, page 8-16
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Topology Map
Topology Right-Click Menu: Map
The Topology Window provides a subset of the MWTM Main Menu as a 
right-click menu. To see this menu for a map, right-click in a blank area of the 
topology map. The topology map right-click menu provides the following 
options:

Menu Command Description

Zoom In
(Ctrl-=)

Makes the map twice as large.

Zoom Out
(Ctrl-- or Ctrl-Minus)

Makes the map half as large.

Zoom Area Zooms in on the selected area of the map.

Zoom Fit Adjusts the size of the map to fit in the window. This is the default setting the 
first time the map is displayed.

Layout > Circular Displays the map in a circular layout.

Layout > Spring Displays the map in a spring layout. That is, nodes with the most links are 
drawn closer to the center of the map, while nodes with fewer links are drawn 
farther away. This is the default setting the first time the map is displayed.

Find Opens the Find Objects dialog, which enables you to find and highlight an 
object in the Topology Window.

Restore Positions Restores the view to the last saved view.

Save As JPEG
(Ctrl-J)

Opens the Save as JPEG dialog, enabling you to save the topology map to a 
JPEG file.

Magnetic Grid Opens the Magnetic Grid Settings dialog.

Change Background 
Color

Opens the Select Background Color dialog, which enables you to select a 
color for the background of the topology map.

Align Opens the Align Objects dialog, which enables you to align two or more 
objects on the topology map.

Create Subview Opens the View Editor Window, which enables you to select a new view to 
display in the Topology Window.
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Topology Map
Open Parent View Opens the parent view of the currently displayed view in the Topology 
Window.

This option is grayed-out if the currently displayed view is the highest level 
parent view.

Close View Closes the currently displayed view in the Topology Window.

This option is grayed-out if the currently displayed view is the highest level 
parent view.

Menu Command Description
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Topology Map
Topology Right-Click Menu: View
The Topology Window provides a subset of the MWTM Main Menu as a 
right-click menu. To see this menu for a view, select a view in the topology map 
or topology view table, then click the right mouse button. The topology view 
right-click menu provides the following options:

Menu Command Description

Edit > Properties Opens the Edit Properties Dialog for the selected view.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level Power 
User (Level 2) and higher.

Edit > Notes Opens the Edit Notes Dialog for the selected view.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level Power 
User (Level 2) and higher.

Edit > SNMP IP Addresses Opens the Edit SNMP IP Addresses Dialog for a Node for 
the selected node.

This option is grayed-out if the selected node has no 
associated SNMP IP addresses.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level 
Network Administrator (Level 4) and higher.

Clear Event Icon Deletes the event icon (orange triangle) from MWTM 
displays for the selected view, for this MWTM client only. 
The actual events are not deleted from MWTM, only the 
event icon for the selected view for this MWTM client.

This option is grayed-out if the selected view has no 
associated event icon.
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Delete Deletes the currently selected view from the MWTM 
database. MWTM displays the Confirm Deletion dialog:

• To delete the selected view, click Yes. The view is 
deleted from the MWTM database and the Confirm 
Deletion dialog is closed.

• To retain the selected view, click No. The view is kept 
in the MWTM database and the Confirm Deletion 
dialog is closed.

• To prevent MWTM from displaying the Confirm 
Deletion dialog, select the Do not show this again 
checkbox.

Note If you select the Do not show this again checkbox, 
and you later decide you want MWTM to begin 
displaying the Confirm Deletion dialog again, you 
must select the Confirm Deletions checkbox in the 
General GUI settings in the Preferences window. 
For more information, see the description of the 
Confirm Deletions checkbox in the “Startup/Exit 
Settings” section on page 11-7.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level 
Network Administrator (Level 4) and higher.

Back > List of Windows Navigates back to a window viewed in this session.

MWTM maintains a list of up to 10 Back windows.

Forward > List of Windows Navigates forward to a window viewed in this session.

MWTM maintains a list of up to 10 Forward windows.

View > Components Displays the Components panel for the selected node.

View > Configuration Details Displays the Configuration Data window for the selected 
view.

View > Notes Displays the Notes dialog for the selected view.

If there are no notes associated with the selected view, this 
option is grayed-out.

Menu Command Description
8-17
Cisco Mobile Wireless Transport Manager User Guide

OL-7637-01



 

Chapter 8      Viewing the Topology of the Network
Topology Map
View > Events Displays the Recent Events table for the selected view and 
its associated objects.

View > Center in Topo Opens the Topology Window, with the display zoomed to 
center on the selected view.

If more than one view contains the selected view, MWTM 
prompts you to choose one of the views.

Event History > Status Change 
Messages

Displays the MWTM Network Status Log for Status 
Change Messages in a Web browser, with messages 
displayed for only the selected node.

Event History > SNMP Trap Messages Displays the MWTM Network Status Log for SNMP Trap 
Messages in a Web browser, with messages displayed for 
only the selected node.

Event History > Status and Trap 
Messages

Displays the MWTM Network Status Log for Status 
Change Messages and SNMP Trap Messages in a Web 
browser, with messages displayed for only the selected 
node.

Event History > Network Status 
Metrics

Displays the MWTM Network Status Log for Metrics in a 
Web browser, with messages displayed for only the 
selected node.

Ignore Ignores the selected view at the next polling cycle.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level Power 
User (Level 2) and higher.

Unignore Stops ignoring the selected view at the next polling cycle.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level Power 
User (Level 2) and higher.

Drill-Down > Show Syslog Messages Opens the Node Details: Syslog table, which polls the 
selected node and displays all messages in its system log.

This option is not available if the node is in Unknown or 
Unmanaged status.

Menu Command Description
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Drill-Down > Show CPU Processes Opens the Node Details: CPU Processes panel, which polls 
the selected node for information about its CPU processes.

This option is not available if the node is in Unknown or 
Unmanaged status.

Drill-Down > Show Trap Configuration Opens the Node Details: Trap Configuration panel, which 
displays all trap settings for the node, as well as all hosts 
and port numbers to which the node sends traps.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level 
System Administrator (Level 5).

This option is not available if the node is in Unknown or 
Unmanaged status.

Latest Reports > RAN Capacity 
Planning

Displays the RAN Capacity Planning Report for the node, 
in a Web browser.

This option is not available if the node is in Unknown or 
Unmanaged status.

Latest Reports > RAN Statistics Displays the RAN Backhaul 15 Minutes Statistics report 
associated with the node, in a Web browser.

This option is not available if the node is in Unknown or 
Unmanaged status.

Router > Home Page Displays the home page of the router in a new Web browser 
window.

This option is grayed-out if the selected node is not a 
RAN-O node.

Router > Telnet To Links to the router.

This option is grayed-out if the selected node has no IP 
addresses.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level 
Network Operator (Level 3) and higher.

Menu Command Description
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Poll Node > Normal Poll Polls all selected nodes, retaining all currently known 
interfaces.

Normal Poll retains all interfaces associated with polled 
nodes, even interfaces that have been deleted and are 
therefore in Unknown status.

This option is grayed-out if the selected node has no IP 
addresses.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level 
Network Operator (Level 3) and higher.

Poll Node > Clean Poll Polls all selected nodes and removes any Unknown 
network objects after the completion of the poll.

Clean Poll removes all network objects from the node at 
the completion of the poll.

This option is grayed-out if the selected node has no IP 
addresses.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level 
Network Operator (Level 3) and higher.

Manage Removes the Unmanaged status from the selected node.

You cannot remove the Unmanaged status from a node 
with a Device Type of Unknown. If you select a node with 
a Device Type of Unknown, then this menu option is 
grayed-out and cannot be selected.

This option is grayed-out if the selected node has no IP 
addresses.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level 
Network Administrator (Level 4) and higher.

Menu Command Description
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Creating a Custom Layout
MWTM enables you to create a custom layout for the topology map. To do so, 
move the nodes around, grouping them or isolating them to meet your needs.

To move a single node, click the left mouse button to select the node in the map 
and, while holding down the left mouse button, move the mouse to move the node 
to its new position.

Unmanage Labels the selected node Unmanaged.

You cannot label a node Unmanaged if it has a Device 
Type of Unknown. If you select a node with a Device Type 
of Unknown, then this menu option is grayed-out and 
cannot be selected.

This option is grayed-out if the selected node has no IP 
addresses.

If you have implemented MWTM User-Based Access, this 
option is available to users with authentication level 
Network Administrator (Level 4) and higher.

Exclude from View Excludes the selected node from the current view. See the 
“Creating a New View” section on page 4-42 for more 
information about excluding nodes.

Menu Command Description
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To move more than one node at the same time, use the following procedure:

Step 1 Press and hold down the Shift key on your keyboard.

Step 2 Still holding down Shift, click the left mouse button to select the nodes you want 
to move in the map.

Step 3 Still holding down Shift, select one of the nodes you want to move and hold down 
the left mouse button.

Step 4 Still holding down both Shift and the left mouse button, move the mouse to move 
the nodes to their new position. The moved nodes keep their positions relative to 
each other.

Step 5 Release both Shift and the left mouse button.

When you are satisfied with the new topology map layout, select File > Save View 
from the MWTM Main Menu. MWTM saves the changes you have made to the 
network view, including any changes you have made to the topology map layout.

Finding an Object
Some topology maps are so large and complex that it can be difficult to find a 
specific object.

If the object is listed in the tables in the left pane of the Topology Window, simply 
select the object, and MWTM highlights it in the topology map.

If the object is not listed in the tables in the left pane of the Topology Window, 
click the Find objects (binoculars) button in the Topology Window, or select Edit 
> Find from the MWTM Main Menu. MWTM displays the Find Objects dialog, 
which enables you to find and highlight an object in the Topology Window.
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The Find Objects dialog contains the following fields and buttons:

Using the Selection Dialog
If more than one object is found that matches the Search string in the Find 
Objects dialog, MWTM displays the Selection Dialog.

The Selection Dialog contains the following field and buttons:

Related Topics:

• Finding an Object, page 8-22

Field or Button Description

Search string Character string for which MWTM is to search.

OK Launches the search.

• If no matching object is found, MWTM displays an appropriate 
message.

• If exactly one object is found that matches the Search string, MWTM 
highlights the object in the Tables panel of the Topology Window, and 
zooms in on the selected object in the topology map.

• If more than one object is found that matches the Search string, 
MWTM displays the Choose dialog, enabling you to select from a list 
of the found objects. See the “Using the Selection Dialog” section on 
page 8-23 for further details.

Cancel Exits the Find Objects dialog without launching the search.

Field or Button Description

Select one in list Type, Name or Status of the found objects. Select the object you want 
to find.

Select Highlights the selected object in the left pane of the Topology Window, 
and zooms in on the selected object in the topology map.

Cancel Closes the Selection Dialog without selecting an object.
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Scrolling in the Topology Map
To scroll around in the topology map, use one of the following procedures:

• Use the scroll bar with your mouse.

• Click anywhere in the map, then click the arrow, Page Up, and Page Down 
keys on your keyboard.

Centering the Topology Map on an Object
To redraw the topology map centered on a specific node, double-click the object 
in a table in the left pane of the window.

Displaying Detailed Information About a Topology 
Map Element

To display detailed information about an element in the map, double-click it, then 
respond to MWTM prompts:

• Double-click a node to display the MWTM Main window details for that 
object.

• Double-click a single line, or a diamond, circle, or arrowhead at the end of a 
single line, to display the MWTM Main window details for that interface.

Displaying the Topology New Objects Panel
To display the topology New Objects panel, select the New Objects tab in the left 
pane, or click the “New!” icon in the bottom of the window. The topology New 
Objects panel displays graphical elements for newly discovered objects, based on 
the following criteria:

• If you are using an MWTM client with the DEFAULT view set, this panel 
never contains any objects. In the DEFAULT view, MWTM adds all newly 
discovered objects to the topology map as soon as they are discovered.
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• If you are using an MWTM client with a custom view set, this panel contains 
all objects discovered since the Topology Window was opened in this session 
that have not been excluded in the Excluded from View table of the View 
Editor Window, or that are not in the current view.

• To add a newly discovered object to the topology map, select one or more 
objects in the topology New Objects panel and drag them to the map while 
holding down the left mouse button.

• To exclude a newly discovered object from the topology New Objects panel, 
see the “Creating a New View” section on page 4-42.

Displaying the Topology Excluded Objects Panel
To display the topology Excluded Objects panel, select the Excluded Objects tab 
in the left pane. The topology Excluded Objects panel displays graphical elements 
for excluded objects. Excluded objects are objects that you have chosen not to 
manage, that you have moved to the Excluded from View table of the View Editor 
Window. (See the “Creating a New View” section on page 4-42 for more 
information about excluding objects from views.)

To add an excluded object to the topology map, select the object and drag it to the 
map while holding down the left mouse button. When you do so, the object is no 
longer excluded, and it is removed from the Excluded from View table of the View 
Editor Window.

Printing the Topology Map
To print the topology map, see the “Printing MWTM Windows” section on 
page 3-39.
8-25
Cisco Mobile Wireless Transport Manager User Guide

OL-7637-01



 

Chapter 8      Viewing the Topology of the Network
Saving the Topology Map as a JPEG File
Saving the Topology Map as a JPEG File
MWTM enables you to save the topology map to a JPEG file. You can save the 
entire topology map, or just the current window.

To save the topology map to a JPEG file, select Topology Tools > Save as JPEG 
from the MWTM Main Menu.

MWTM displays the Save as JPEG dialog (Figure 8-2).

Figure 8-2 Save as JPEG Dialog

The Save as JPEG dialog contains the following fields and buttons:

Field or Button Description

All Saves the entire topology map as a JPEG file. The default setting is for this 
checkbox to be selected.

Current Window Saves just the portion of the topology map displayed in the current window as 
a JPEG file. The default setting is for this checkbox to be cleared (that is, save 
the entire map, not just the current window).
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Quality Specifies the quality of the JPEG file, from 0 (lowest quality) to 1.0 (highest 
quality). The default setting is 0.7, which is sufficient for most JPEG files.

Max. Size Specifies the size of the JPEG file, in pixels. Choose a value from the 
drop-down list box. The valid range is 400 pixels to 2400 pixels. The default 
value is 400 pixels, which is sufficient for most JPEG files.

Name Enter a name for the JPEG file, or accept the default filename, out.jpg.

The default directory for the JPEG file is the directory in which you installed 
the MWTM client:

• In Solaris/Linux, the default installation directory for the MWTM client is 
/opt/CSCOsgmClient.

• In Windows, the default installation directory for the MWTM client is 
C:\Program Files\SGMClient\.

• If you installed the MWTM client in a different directory, then the 
installation directory is located in that directory.

If you do not want to save the JPEG file to the default directory, click Browse 
to select a different directory.

Browse Opens the Save dialog for a topology map (Figure 8-3), which enables you to 
specify or select a name when you save the JPEG file. If you do not want to 
save the JPEG file to the default directory, click Browse to select a different 
directory.

Save Saves the JPEG file and closes the Save as JPEG dialog.

Cancel Closes the Save as JPEG dialog without saving the JPEG file.

Field or Button Description
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Selecting a Directory for the JPEG File
MWTM enables you to specify or select a name or directory when you save a 
topology map to a JPEG file. You can save the entire topology map, or just the 
current window.

To specify a name or directory for the JPEG file, click Browse in the Save as 
JPEG dialog.

MWTM displays the Save dialog for a topology map (Figure 8-3).

Figure 8-3 Save Dialog for a Topology Map

The Save dialog for a topology map contains the following fields and buttons:

Field or Button Description

Save In Enables you to select the directory in which you want to save the topology map 
JPEG file. Either accept the default directory, or select a new directory from 
the drop-down list box.

File Name Enter a name for the JPEG file, or select a file from those listed in the Save In 
field.
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Related Topics:

• Saving the Topology Map as a JPEG File, page 8-26

Files of Type Specifies the type of file to save, and displays all files of that type in the 
selected directory. Select a file type from the drop-down list box:

• All files—Displays all files in the selected directory, and saves the 
topology map file as a JPEG file.

• jpg files—Displays only JPEG files in the selected directory, and saves the 
topology map file as a JPEG file. This is the default value.

Up One Level Displays the sub-folders and files that are in the folder that is up one level from 
the currently displayed folder.

Desktop Displays the sub-folders and files that are on your workstation desktop.

Create New Folder Creates a new sub-folder in the currently displayed folder.

List Displays only icons for sub-folders and files.

Details Displays detailed information for sub-folders and files, including their size, 
type, date they were last modified, and so on.

Save Saves the file and closes the Save dialog for a topology map.

When you are satisfied with the settings, click Save. MWTM closes the Save 
dialog for a topology map and populates the Name field in the Save as JPEG 
dialog with the new name and directory.

Cancel Closes the Save dialog for a topology map without saving the file.

Field or Button Description
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Activating a Magnetic Grid on the Topology Map
MWTM enables you to activate the magnetic topology grid, and change how it is 
displayed. With the grid activated, when you move objects on the topology map 
they “snap” to align with the grid.

Note Magnetic grid settings are not saved when you save the view.

To activate or change the magnetic topology grid, select Topology Tools > 
Magnetic Grid from the MWTM Main Menu. MWTM displays the Magnetic 
Grid Settings dialog (Figure 8-4).

Figure 8-4 Magnetic Grid Settings Dialog

The Magnetic Grid Settings dialog contains the following fields and buttons:
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Field or Button Description

Grid Activated Specifies whether the magnetic topology grid is activated:

• To activate the grid, select this checkbox.

• To deactivate the grid, clear this checkbox. This is the default setting.

Display Grid Specifies whether the grid is to be displayed on the topology map:

• To display the grid, select this checkbox. This is the default setting.

• To hide the grid, clear this checkbox.

If Grid Activated is not selected, this checkbox is grayed-out.

Grid Spacing Specifies the spacing between lines on the grid, in pixels.

To specify the spacing between lines on the grid, in pixels, select the Grid 
Activated checkbox, then select a Grid Spacing level. The valid range is 
0 pixels to 150 pixels. The default setting is 50 pixels, which is sufficient for 
most topology maps.

Grid Color Opens the Select Grid Color dialog.

To specify a color for the grid, select the Grid Activated checkbox, then click 
Change Color in the Grid Color field. MWTM opens the Select Grid Color 
dialog (Figure 8-5).

OK Sets the new grid settings and closes the Magnetic Grid Settings dialog.

When you are satisfied with the magnetic grid settings, click OK.

Cancel Closes the Magnetic Grid Settings dialog without changing any settings.
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Specifying a Color for the Magnetic Grid
MWTM enables you to customize the color of the magnetic topology grid.

Note The grid color is not saved when you save the view.

To specify a color for the grid, select the Grid Activated checkbox in the 
Magnetic Grid Settings dialog, then click Select in the Grid Color field.

MWTM opens the Select Grid Color dialog (Figure 8-5).

Figure 8-5 Select Grid Color Dialog

The Select Grid Color dialog is composed of the following sections:

• Swatches Panel (Recommended), page 8-33

• HSB Panel, page 8-33

• RGB Panel, page 8-34

• Select Grid Color Field and Buttons, page 8-34
8-32
Cisco Mobile Wireless Transport Manager User Guide

OL-7637-01



 

Chapter 8      Viewing the Topology of the Network
Specifying a Color for the Magnetic Grid
Related Topics:

• Activating a Magnetic Grid on the Topology Map, page 8-30

Swatches Panel (Recommended)
The Swatches panel of the Select Grid Color dialog enables you to select a grid 
color from a set of color swatches. This is the recommended method for selecting 
a grid color.

To display the Swatches panel, click the Swatches tab in the Select Grid Color 
dialog.

To select a grid color, select a swatch. The selected color is displayed in the 
Preview field. When you are satisfied with the color, click OK.

HSB Panel
The HSB panel of the Select Grid Color dialog enables you to select a grid color 
based on color hue, saturation, and brightness (HSB).

To display the HSB panel, click the HSB tab in the Select Grid Color dialog.

To select a grid color, use one of the following procedures:

• Select a color range on the vertical color bar, then select a specific color by 
moving the cursor around on the color square.

• Enter specific values in the hue (H), saturation (S), and brightness (B) fields.

The selected color is displayed in the Preview field. When you are satisfied with 
the color, click OK.
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RGB Panel
The RGB panel of the Select Grid Color dialog enables you to select a grid color 
based on the red, green, and blue (RGB) content of the color.

To display the RGB panel, click the RGB tab in the Select Grid Color dialog.

To select a grid color, select values for the Red, Green, and Blue fields. The 
selected color is displayed in the Preview field. When you are satisfied with the 
color, click OK.

Select Grid Color Field and Buttons
The Select Grid Color dialog contains the following field and buttons:

Field Description

Preview Displays a preview of the current selected grid color.

Whichever method you choose to select a grid color, the selected color is 
displayed in the Preview field. When you are satisfied with the color, click 
OK.

OK Sets the grid color as shown in the Preview field, and closes the Select Grid 
Color dialog.

Cancel Closes the Select Grid Color dialog without selecting a grid color.

Reset Resets the grid color to its initial setting.
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Specifying a Background Color for the Topology Map
MWTM enables you to customize the background color of the topology map.

Note The background color is not saved when you save the view.

To specify a background color for the topology map, right-click in a blank area of 
the topology map, then select Change Background Color from the right-click 
menu.

The Select Background Color dialog is composed of the following sections:

• Swatches Panel (Recommended), page 8-35

• HSB Panel, page 8-36

• RGB Panel, page 8-36

• Select Background Color Field and Buttons, page 8-37

Swatches Panel (Recommended)
The Swatches panel of the Select Background Color dialog enables you to select 
a background color from a set of color swatches. This is the recommended method 
for selecting a background color.

To display the Swatches panel, click the Swatches tab in the Select Background 
Color dialog.

To select a background color, select a swatch. The selected color is displayed in 
the Preview field. When you are satisfied with the color, click OK.
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HSB Panel
The HSB panel of the Select Background Color dialog enables you to select a 
background color based on color hue, saturation, and brightness (HSB).

To display the HSB panel, click the HSB tab in the Select Background Color 
dialog.

To select a grid color, use one of the following procedures:

• Select a color range on the vertical color bar, then select a specific color by 
moving the cursor around on the color square.

• Enter specific values in the hue (H), saturation (S), and brightness (B) fields.

The selected color is displayed in the Preview field. When you are satisfied with 
the color, click OK.

RGB Panel
The RGB panel of the Select Background Color dialog enables you to select a 
background color based on the red, green, and blue (RGB) content of the color.

To display the RGB panel, click the RGB tab in the Select Background Color 
dialog.

To select a background color, select values for the Red, Green, and Blue fields. 
The selected color is displayed in the Preview field. When you are satisfied with 
the color, click OK.
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Select Background Color Field and Buttons
The Select Background Color dialog contains the following field and buttons:

Aligning Objects on the Topology Map

Note To un-align objects, simply drag and drop the object to move it on the topology 
map. 

MWTM enables you to align two or more objects on the topology map. You can 
align the objects based on their left, right, top, or bottom edges, or you can center 
them in the map. The alignment is saved when you save the view.

To align objects, select the objects you want to align, then select Topology Tools 
> Align from the MWTM Main Menu. MWTM displays MWTM opens the Align 
Dialog (Figure 8-5).

Field Description

Preview Displays a preview of the current selected background color.

Whichever method you choose to select a background color, the selected color 
is displayed in the Preview field. When you are satisfied with the color, click 
OK.

OK Sets the background color as shown in the Preview field, and closes the Select 
Background Color dialog.

Cancel Closes the Select Background Color dialog without selecting a background 
color.

Reset Resets the background color to its initial setting.
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Figure 8-6 Align Dialog

The Align Dialog contains the following field and buttons:

Field Description

Vertically: None Does not align the selected objects vertically.

Vertically: Left Aligns the selected objects vertically, aligned with the left-most edge of 
the left-most selected object.

Vertically: Center Aligns the selected objects vertically, with centers aligned.

Vertically: Right Aligns the selected objects vertically, aligned with the right-most edge 
of the right-most selected object.

Vertically: Side by side Aligns the selected objects vertically, aligned side-by-side, with no 
horizontal space between the objects. (There might still be vertical space 
between the objects.)

Horizontally: None Does not align the selected objects horizontally.

Horizontally: Top Aligns the selected objects horizontally, aligned with the top-most edge 
of the top-most selected object.

Horizontally: Center Aligns the selected objects horizontally, with centers aligned.

Horizontally: Bottom Aligns the selected objects horizontally, aligned with the bottom-most 
edge of the bottom-most selected object.
8-38
Cisco Mobile Wireless Transport Manager User Guide

OL-7637-01



 

Chapter 8      Viewing the Topology of the Network
Hiding and Redrawing Lines When Redrawing
Hiding and Redrawing Lines When Redrawing
MWTM enables you to hide lines as you drag an object around the topology map, 
then draw the link lines when you drop the object in its final position. To do so, 
click the Node Dragging Optimizer button to turn it on. This is the default 
setting.

To have MWTM continually redraw lines as you drag an object around the 
topology map, click the Node Dragging Optimizer button to turn it off.

This setting, with the Node Dragging Optimizer on or off, is saved automatically 
with your preferences.

Hiding and Showing Lines When Redrawing
MTWM enables you to hide lines that connect to objects that are not in the current 
view, called dangling connections. To do so, click the Hiding/Showing Dangling 
Connections button to set it to Hide. This is the default setting.

To show dangling connections, click the Hiding/Showing Dangling Connections 
button to set it to Show. MWTM draws the lines in shades of gray to distinguish 
them from actual objects in the current view.

This setting, with the Hiding Dangling Connections set to Show or Hide, is not 
saved when you save the view.

Horizontally: Side by side Aligns the selected objects horizontally, aligned side-by-side, with no 
vertical space between the objects. (There might still be horizontal space 
between the objects.)

Apply Aligns the selected objects and keeps the Align Dialog open, enabling 
you to continue aligning objects.

OK Aligns the selected objects and closes the Align Dialog.

Cancel Closes the Align Dialog. Changes you applied are saved; other changes 
are not saved.

Help Opens the Help window for this object. 

Field Description
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To include a dangling connection in the current view, right-click the signaling 
point and select Include In View.

Locking and Unlocking the Position of an Icon
MWTM enables you to lock the position of an icon on the topology map. Locking 
the position of an icon can be useful if you want to keep the icon in its position, 
and you want to make sure you do not move it inadvertently. Locked icons are not 
included in the circular or spring layouts.

• To lock the position of an icon on the topology map, right-click an unlocked 
icon, then select Lock Position.

• To unlock the position of an icon on the topology map, right-click a locked 
icon, then select Unlock Position. This is the default setting.

This setting, with icon positions locked or unlocked, is saved when you save the 
view.

Turning Off Antialiasing to Improve Performance
Antialiasing, which is on by default, improves the appearance of the icons and 
connections in the topology map. However, antialiasing can impact the 
performance of the MWTM client on a remote workstation (that is, a 
Solaris/Linux workstation using xhost, or a Windows workstation using an 
X-Window system emulator such as eXceed or Reflection X).

MWTM enables you to turn off antialiasing to improve the performance of the 
MWTM client on a remote workstation. To do so, select the X Performance 
Enhancer (AntiAliasing Off) checkbox in the Topology settings in the 
Preferences window. For more information, see the “Topology Settings” section 
on page 11-11.

To turn antialiasing back on, clear the checkbox.

Keep in mind that performance is always better if you access MWTM by installing 
the MWTM client on the remote workstation.
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Saving the Topology Map
When you are ready to close the Topology Window, select File > Save View from 
the MWTM Main Menu. MWTM prompts you to save any changes you made to 
the network view, including any changes you have made to the topology map 
layout, and closes the window.

For more information, see the “Closing the View Editor Window” section on 
page 4-52.

Restoring the Topology Map
MWTM enables you to restore the topology map to the way it looked in the last 
saved view. To do so, select Topology Tools > Restore Positions from the 
MWTM Main Menu. MWTM restores the view.
8-41
Cisco Mobile Wireless Transport Manager User Guide

OL-7637-01



 

Chapter 8      Viewing the Topology of the Network
Restoring the Topology Map
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Working with MWTM Statistics 
Reports

Once every hour, MWTM gathers critical information from all known network 
objects. MWTM then uses that information to calculate statistics, and generates 
reports based on those statistics.

MWTM enables you to:

• View and export detailed RAN utilization statistics summary reports.

• Create, view, and export custom statistics reports.

• Change the way MWTM displays information in reports.

By default, MWTM stores all report data in the database.

Viewing RAN Backhaul Utilization Statistics Report
MWTM enables you to view the RAN Backhaul Utilization statistics report. You 
can also export the report.

To view the report, select RAN Backhaul Utilization from the MWTM Server 
Home Page.

The following table describes the additional menu options provided by the RAN 
Backhaul Utilization Statistics page:
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Viewing RAN Backhaul Utilization Statistics Report
The RAN Backhaul Utilization Statistics Report provides statistical data in two 
formats:

• Capacity Planning Report—Summary data that is derived from the raw data 
and provides summaries of GSM and UMTS traffic utilization on the 
backhaul links. This data can be displayed on a yearly, monthly, daily, and 
hourly basis and can be used for capacity planning.

• View 15 Minutes Statistics Report—Raw backhaul performance data 
collected in 15 minute intervals that can be displayed on a yearly, monthly, 
daily, or hourly basis. This data can be used for detailed analysis of traffic 
utilization on the backhaul links.

The RAN Backhaul Utilization Statistics Report table displays the following 
information:

Menu Command Description

Home Displays the MWTM Server Home Page.

RAN Backhaul 
Utilization

Displays the RAN Backhaul Utilization Statistics page.

RAN Data 
Export

Exports the RAN Backhaul Utilization summary data (for capacity planning) or the 
15-minute statistics data in Excel file format. 

Displays a File Download window to open the export file or save it to your 
computer. 

Help Displays the MWTM online help system.

Field or Column Description

Title Title of the MWTM report and the name of the server.

Node The node from which the data is collected. 

Clicking on the node name displays the summary data for the selected year 
for use in capacity planning.

Capacity Planning: 
Year

Displays the summary data for the selected year for use in capacity planning.

Capacity Planning: 
Month

Displays the summary data for the selected month for use in capacity 
planning.
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Capacity Planning Report
The Capacity Planning Report table has two sections:

• Capacity Planning Section—Displays summary data for all traffic, GSM 
traffic, and UMTS traffic on the backhaul interface.

• Backhaul Utilization Statistics Section—Displays summary data for a 
specific traffic protocol (GSM, UMTS, or All) on the backhaul interface.

Capacity Planning Section

The Capacity Planning section is at the top of the Capacity Planning report and 
displays the following information:

Capacity Planning: 
Day

Displays the summary data for the selected day for use in capacity planning.

Capacity Planning: 
Hour

Displays the summary data for the selected hour for use in capacity planning.

View 15 Minutes 
Statistics: Year

Displays raw data collected in 15-minute intervals for the selected year.

View 15 Minutes 
Statistics: Month

Displays raw data collected in 15-minute intervals for the selected month.

View 15 Minutes 
Statistics: Day

Displays raw data collected in 15-minute intervals for the selected day.

View 15 Minutes 
Statistics: Hour

Displays raw data collected in 15-minute intervals for the selected hour.

Field or Column Description

Field or Column Description

Title Title of the MWTM report, the name of the server, the name of the node, and 
whether the report is yearly, monthly, daily, or hourly.

Protocol: Interface The name of the backhaul interface for which statistics are displayed.

Protocol: Direction The direction of the traffic (send or receive) on the backhaul interface.
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Backhaul Utilization Statistics Section

The Backhaul Utilization Statistics section follows the Capacity Planning section 
of the Capacity Planning report and displays the following information:

Protocol: Available 
Bandwidth (KBits/sec)

The maximum available bandwidth on the backhaul interface.

All Click this link to display the Backhaul Utilization Statistics Section of the 
report for all protocols (GSM and UMTS). 

All: Peak Traffic 
(KBits/sec)

The peak traffic for all protocols on the backhaul interface.

All: % Peak 
Utilization

The percentage of peak traffic utilization for all protocols on the backhaul 
interface.

GSM Click this link to display the Backhaul Utilization Statistics Section of the 
report for GSM traffic. 

GSM: Peak Traffic 
(KBits/sec)

The peak GSM traffic on the backhaul interface.

GSM: % Peak 
Utilization

The percentage of peak GSM traffic utilization on the backhaul interface.

UMTS Click this link to display the Backhaul Utilization Statistics Section of the 
report for UMTS traffic. 

UMTS: Peak Traffic 
(KBits/sec)

The peak UMTS traffic on the backhaul interface.

UMTS: % Peak 
Utilization

The percentage of peak UMTS traffic utilization on the backhaul interface.

Field or Column Description

Field or Column Description

Interface The name of the backhaul interface for which statistics are displayed.

Protocol The protocol of the traffic on the backhaul interface. This value can be GSM, 
UMTS, or All.
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View 15 Minutes Statistics Report
The View 15 Minutes Statistics Report displays the following information:

Backhaul Utilization Displays 10 backhaul utilization percentage ranges from 00-09% to 
90-100%. 

Used with the Time in Range data, you can determine the length of time 
during which the backhaul utilization is between 0 and 9%, or between 10 
and 19%, and so on.

Send: Time in Range The length of time in which send traffic falls into a specific percentage range.

Send: % Time in 
Range

The percentage of the total time in which send traffic falls into a specific 
percentage range.

Receive: Time in 
Range

The length of time in which receive traffic falls into a specific percentage 
range.

Receive: % Time in 
Range

The percentage of the total time in which receive traffic falls into a specific 
percentage range.

Peak Utilization (%) The percentage of time that is utilized by peak traffic on the backhaul 
interface for send and receive traffic.

Peak Timestamp The timestamp (date and time) when the peak traffic occurred on the 
backhaul interface.

Field or Column Description

Field or Column Description

Title Title of the MWTM report, the name of the server, the name of the node, and 
whether the report is yearly, monthly, daily, or hourly.

Node The node from which the data is collected. 

Interface The name of the backhaul interface for which statistics are displayed.

Protocol The protocol of the traffic (GSM Abis, UMTS Iub, or All) on the backhaul 
interface.

Direction The direction of the traffic (receive or transmit) on the backhaul interface.

Percentage Ranges Ten backhaul utilization percentage ranges from 00-09% to 90-100%. 

Peak Util The percentage of peak traffic utilization on the backhaul interface.
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Peak Timestamp The timestamp (date and time) when the peak traffic occurred on the 
backhaul interface.

Bandwidth (KBits/sec) The maximum available bandwidth on the backhaul interface.

Field or Column Description
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Configuring MWTM Security

This chapter provides the following information about configuring MWTM 
security and limiting access to MWTM:

• Configuring MWTM User-Based Access, page 10-1

• Implementing SSL Support in MWTM (Solaris Only), page 10-27

• Limiting MWTM Client Access to the MWTM Server (Server Only), 
page 10-40

Configuring MWTM User-Based Access
MWTM enables you to control who is allowed to do what in MWTM, beyond 
simply specifying root and non-root users. MWTM calls this ability User-Based 
Access.

User-Based Access provides multi-level password-protected access to MWTM 
features. Each user can have a unique user name and password. Each user can also 
be assigned to one of five levels of access, which control the list of MWTM 
features accessible by that user.

To configure MWTM User-Based Access, perform the tasks in the following 
sections. Required and optional tasks are indicated.

• Implementing MWTM User-Based Access (Server Only), page 10-2 
(Required)

• Creating Secure Passwords, page 10-6 (Required)
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• Configuring MWTM User Authentication Levels (Server Only), page 10-7 
(Required)

• Automatically Disabling Users and Passwords (Server Only), page 10-10 
(Optional)

• Manually Disabling Users and Passwords (Server Only), page 10-14 
(Optional)

• Enabling and Changing Users and Passwords (Server Only), page 10-16 
(Optional)

• Displaying a Message of the Day (Server Only), page 10-18 (Optional)

• Manually Synchronizing Local MWTM Passwords (Server Only), 
page 10-21 (Optional)

• Listing All Currently Defined Users (Server Only), page 10-21 (Optional)

• Displaying the Contents of the System Security Log (Server Only), 
page 10-22 (Optional)

• Restoring Security-Related MWTM Data (Server Only), page 10-23 
(Optional)

• Disabling MWTM User-Based Access (Server Only), page 10-24 (Optional)

• Specifying a Super User (Server Only), page 10-24 (Optional)

Implementing MWTM User-Based Access (Server Only)
Before you can access MWTM’s full suite of security commands, you must enable 
MWTM User-Based Access, configure the type of security authentication you 
want to use, and begin adding users to your authentication lists.

To implement MWTM User-Based Access, use the following procedure:

Step 1 Log in as the root user, as described in the “Becoming the Root User (Server 
Only)” section on page 3-3, or as a super user, as described in the “Specifying a 
Super User (Server Only)” section on page 10-24.

Step 2 Enter the following commands:

# cd /opt/CSCOsgm/bin

# ./mwtm useraccess enable
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Configuring MWTM User-Based Access
MWTM User-Based Access is enabled the next time you restart the MWTM 
server.

Step 3 If you have already configured the type of MWTM security authentication you 
want to use, skip to Step 4.

Otherwise, configure the type of MWTM security authentication you want to use:

• Local authentication allows you to create user accounts and passwords local 
to the MWTM system. When using this method, you can use MWTM 
User-Based Access commands manage user names, passwords, and access 
levels.

To enable local authentication, enter the following command:

# ./mwtm authtype local

• Solaris/Linux authentication uses standard Solaris/Linux-based user 
accounts and passwords, as specified in the /etc/nsswitch.conf file. 
Authentication can be provided by the local /etc/passwd file or from a 
distributed Network Information Services (NIS) system. You can use all 
MWTM User-Based Access commands except the following commands:

– mwtm disablepass

– mwtm passwordage

– mwtm userpass

You must use Solaris/Linux commands, such as passwd, to manage 
passwords.

Users also cannot change their passwords using the MWTM client. Instead, 
they must manage their passwords on the external authentication servers, 
using Solaris/Linux commands, such as passwd.

All new passwords take effect the next time MWTM automatically 
synchronizes local MWTM passwords with Solaris/Linux, or you can 
manually synchronize passwords at any time using the mwtm syncusers 
command.

In addition, if you have enabled Solaris/Linux authentication, you must be 
logged in as the root user, not as a super user, to use the following MWTM 
commands:

– mwtm adduser

– mwtm disableuser
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– mwtm enableuser

– mwtm updateuser

To enable Solaris/Linux authentication, enter one of the following 
commands:

# ./mwtm authtype solaris

or

# ./mwtm authtype linux

depending upon which platform your MWTM server is running.

See the “MWTM Command Reference” section on page C-1 for more 
information on the use of each of the above MWTM commands.

Step 4 To add a user to your MWTM User-Based Access authentication list, use the 
following command:

# ./mwtm adduser username

where username is the name of the user.

Note If mwtm authtype is set to solaris or linux, you must be logged in as the root 
user, not as a super user, to enter this command.

MWTM also prompts you for the authentication level for the user. Valid levels are:

• 1—Basic User

• 2—Power User

• 3—Network Operator

• 4—Network Administrator

• 5—System Administrator

For more information about authentication levels, see the “Configuring MWTM 
User Authentication Levels (Server Only)” section on page 10-7.
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If mwtm authtype is set to local, MWTM also issues the following prompts:

• MWTM prompts you for the user’s password. When setting the password, 
follow the rules and considerations in the “Creating Secure Passwords” 
section on page 10-6.

• MWTM asks whether you want to force the user to change the password at 
the next login. The default is not to force the user to change the password.

(Whenever a user needs to change a password, MWTM issues an appropriate 
message and prompts for the user name and new password.)

Note If mwtm authtype is set to solaris or linux, users cannot change their 
passwords using the MWTM client. Instead, they must manage their 
passwords on the external authentication servers, using Solaris/Linux 
commands, such as passwd. All new passwords take effect the next time 
MWTM automatically synchronizes local MWTM passwords with 
Solaris/Linux, or you can manually synchronize passwords at any time 
using the mwtm syncusers command. See the “mwtm syncusers” section 
on page C-84 for more information.

At this point, you have implemented your basic MWTM User-Based Access. 
Users must now log in before using the MWTM client and MWTM Web-based 
functions. Use the remaining procedures in this section to customize your MWTM 
security system.

Note After you implement MWTM User-Based Access, if a user logs in on one MWTM 
client, then logs in on a second MWTM client, MWTM closes the first client and 
records the event in the system security log.
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Creating Secure Passwords
When setting passwords in MWTM, keep in mind the following rules and 
considerations:

• The password must be at least 6 characters, up to an unlimited number of 
characters. However, passwords longer than 15 characters are not 
recommended.

• The password cannot be identical to the user name.

• The new password cannot be the same as the old password.

• MWTM does not allow users to switch back-and-forth between two 
passwords.

• The password cannot be a common word. MWTM uses the dictionary located 
at /usr/lib/share/dict/words to determine whether a word is common. To 
override the MWTM dictionary, change the DICT_FILE entry in the 
System.properties file:

– To disable the MWTM dictionary and allow common words, change the 
DICT_FILE entry to:

DICT_FILE=/dev/null

– To use a custom dictionary, change the DICT_FILE entry to:

DICT_FILE=/new-dictionary

where new-dictionary is the path and filename of the custom dictionary 
file, such as /users/rolive/words. Each line in the custom dictionary must 
contain a single word, with no leading or trailing spaces.
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Configuring MWTM User Authentication Levels (Server Only)
This section describes the user authentication levels in MWTM, and the MWTM 
functions and Web displays available at each level:

• Basic User (Level 1) Access, page 10-7

• Power User (Level 2) Access, page 10-8

• Network Operator (Level 3) Access, page 10-9

• Network Administrator (Level 4) Access, page 10-9

• System Administrator (Level 5) Access, page 10-10

The authentication level that includes a function is the lowest level with access to 
that function. The function is also available to all higher authentication levels. For 
example, a System Administrator also has access to all Network Administrator 
functions.

Authentication levels are based on the function to be performed, not on the target 
object. Therefore, if a user can perform a function on one MWTM object (such as 
deleting a node), the user can perform the same function on all similar MWTM 
objects.

Note Access to MWTM information and downloads on Cisco.com is already protected 
by Cisco.com, and is not protected by MWTM.

To configure the authentication level for a user, use the mwtm adduser command, 
as described in the “Implementing MWTM User-Based Access (Server Only)” 
section on page 10-2, or the mwtm updateuser or mwtm newlevel command, as 
described in the “Enabling and Changing Users and Passwords (Server Only)” 
section on page 10-16.

Basic User (Level 1) Access

Basic Users can view MWTM data, load MWTM files, and use MWTM 
drill-down menus.

Basic Users have access to the following MWTM functions:

• Connecting to a new server

• Applying changes to views
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• Loading the DEFAULT view and existing views, but not saving them

• Editing, loading, and applying preferences files, but not saving them

• Viewing and manipulating the topology map, and saving it as a JPEG, but not 
saving icon locations

• Viewing network objects, events, details, and notes

• Viewing the MWTM home page

• Loading existing event filters, but not saving them

• Printing MWTM windows

• Launching CiscoWorks

Basic Users have access to the following MWTM Web displays:

• Server Home Page

• System README

• Network Status

• System Data Files

– Notes

– Views

– Preferences

• Viewing MWTM documentation

• Downloading client software

Power User (Level 2) Access

Power Users have access to all Basic User functions.

Power Users can change some aspects of the way MWTM works.

Power Users have access to the following MWTM functions:

• Editing network objects, events, and views

• Unignoring network objects and views

• Saving preferences files, event filters, and views

• Acknowledging events

• Viewing MWR real-time data and charts
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• Viewing the event configuration, but not editing it

Power Users have access to the following MWTM Web displays:

• System Status, excluding User Accounts and System Troubleshooting

• Network Statistics Reports

Network Operator (Level 3) Access

Network Operators have access to all Basic User and Power User functions.

Network Operators can make changes to MWTM network files.

Network Operators have access to the following MWTM functions:

• Ignoring network objects and views

• Polling nodes

• Telnetting to the MWR

Network Administrator (Level 4) Access

Network Administrators have access to all Basic User, Power User, and Network 
Operator functions.

Network Administrators have access to all MWTM client functions.

Network Administrators have access to the following MWTM functions:

• SNMP configuration

• Network Discovery

• Deleting network objects

• Managing and unmanaging nodes

• Using the Deployment Wizard

Network Administrators have access to the following MWTM Web displays:

• System Data Files: Discovery Seeds
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System Administrator (Level 5) Access

System Administrators have access to all Basic User, Power User, Network 
Operator, and Network Administrator functions.

System Administrators have access to all functions in MWTM.

System Administrators have access to the following MWTM Web displays:

• System Messages and Logs

• System Status, including User Accounts and System Troubleshooting

• Trap Configuration, including SNMP configuration information

• System Information

– System Command Log

– System Console Log

– System Event Automation Log

– System Install Log

– System Process Services

– System Properties

– System Root Variables

– System Security Log

– System Web Access Log

– System Web Error Log

Automatically Disabling Users and Passwords (Server Only)
After you have implemented the basic MWTM User-Based Access security 
system, you can customize the system to automatically disable users and 
passwords when certain conditions are met.

To automatically disable users and passwords, use the following procedures:

Step 1 Log in as the root user, as described in the “Becoming the Root User (Server 
Only)” section on page 3-3, or as a super user, as described in the “Specifying a 
Super User (Server Only)” section on page 10-24.
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Step 2 Enter the following command:

# cd /opt/CSCOsgm/bin

Step 3 (Optional) You can configure MWTM to generate an alarm after a specified 
number of unsuccessful login attempts by a user. To do so, enter the following 
command:

# ./mwtm badloginalarm number-of-attempts

where number-of-attempts is the number of unsuccessful login attempts allowed 
before MWTM generates an alarm.

The valid range is 1 unsuccessful attempt to an unlimited number of unsuccessful 
attempts. The default value is 5 unsuccessful attempts.

To disable this function (that is, to prevent MWTM from automatically generating 
an alarm after unsuccessful login attempts), enter the following command:

# ./mwtm badloginalarm clear

Step 4 (Optional) You can configure MWTM to disable a user’s security authentication 
automatically after a specified number of unsuccessful login attempts. To do so, 
enter the following command:

# ./mwtm badlogindisable number-of-attempts

where number-of-attempts is the number of unsuccessful login attempts allowed 
before MWTM disables the user’s authentication. MWTM does not delete the user 
from the authentication list, MWTM only disables the user’s authentication.

The valid range is 1 unsuccessful attempt to an unlimited number of unsuccessful 
attempts. The default value is 10 unsuccessful attempts.

To re-enable the user’s authentication, use the mwtm enableuser command.

To disable this function (that is, to prevent MWTM from automatically disabling 
a user’s authentication after unsuccessful login attempts), enter the following 
command:

# ./mwtm badlogindisable clear
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Step 5 (Optional) MWTM keeps track of the date and time each user last logged in. You 
can configure MWTM to disable a user’s security authentication automatically 
after a specified number of days of inactivity. To do so, enter the following 
command:

# ./mwtm inactiveuserdays number-of-days

where number-of-days is the number of days a user can be inactive before MWTM 
disables the user’s authentication. MWTM does not delete the user from the 
authentication list, MWTM only disables the user’s authentication.

The valid range is 1 day to an unlimited number of days. There is no default 
setting.

To re-enable the user’s authentication, use the mwtm enableuser command.

This function is disabled by default. If you do not specify the 
mwtm inactiveuserdays command, user accounts are never disabled as a result 
of inactivity.

If you have enabled this function and you want to disable it (that is, to prevent 
MWTM from automatically disabling user accounts as a result of inactivity), enter 
the following command:

# ./mwtm inactiveuserdays clear

Step 6 (Optional) If mwtm authtype is set to local, you can configure MWTM to force 
users to change their passwords after a specified number of days.

To configure MWTM to force users to change their passwords after a specified 
number of days, enter the following command:

# ./mwtm passwordage number-of-days

where number-of-days is the number of days allowed before users must change 
their passwords.

The valid range is 1 day to an unlimited number of days. There is no default 
setting.

This function is disabled by default. If you do not specify the 
mwtm passwordage command, users never need to change their passwords.

If you have enabled this function and you want to disable it (that is, prevent 
MWTM from forcing users to change passwords), enter the following command:
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# ./mwtm passwordage clear

Note If mwtm authtype is set to solaris or linux, you cannot use the mwtm 
passwordage command. Instead, you must manage passwords on the 
external authentication servers.

Step 7 (Optional) You can configure MWTM to disconnect an MWTM client 
automatically after a specified number of minutes of inactivity. To do so, enter the 
following command:

# ./mwtm clitimeout number-of-minutes

where number-of-minutes is the number of minutes an MWTM client can be 
inactive before MWTM disconnects the client.

The valid range is 1 minute to an unlimited number of minutes. There is no default 
value.

This function is disabled by default. If you do not specify the mwtm clitimeout 
command, clients are never disconnected as a result of inactivity.

If you have enabled this function and you want to disable it (that is, never 
disconnect a client as a result of inactivity), enter the following command:

# ./mwtm clitimeout clear
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Manually Disabling Users and Passwords (Server Only)
As described in the “Automatically Disabling Users and Passwords (Server 
Only)” section on page 10-10, you can customize MWTM to automatically 
disable users and passwords when certain conditions are met. However, you can 
also manually disable MWTM User-Based Access users and passwords when the 
need arises. To do so, use the following procedures:

Step 1 Log in as the root user, as described in the “Becoming the Root User (Server 
Only)” section on page 3-3, or as a super user, as described in the “Specifying a 
Super User (Server Only)” section on page 10-24.

Step 2 Enter the following command:

# cd /opt/CSCOsgm/bin

Step 3 (Optional) To delete a user entirely from the MWTM User-Based Access 
authentication list, enter the following command:

# ./mwtm deluser username

where username is the name of the user.

If you later decide to add the user back to the authentication list, you must use the 
mwtm adduser command.

Step 4 (Optional) If mwtm authtype is set to local, you can disable a user’s password. 
To do so, enter the following command:

# ./mwtm disablepass username

where username is the name of the user. MWTM does not delete the user from the 
authentication list, MWTM only disables the user’s password.

Note If mwtm authtype is set to solaris or linux, you cannot use the mwtm 
disablepass command. Instead, you must manage passwords on the 
external authentication servers.

The user must change his password the next time he logs in.
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You can also re-enable the user’s authentication with the same password, or with 
a new password:

• To re-enable the user’s authentication with the same password as before, use 
the mwtm enableuser command.

• To re-enable the user’s authentication with a new password, use the mwtm 
userpass command.

Step 5 (Optional) To disable a user’s authentication, but not the user’s password, use the 
following command:

# ./mwtm disableuser username

where username is the name of the user.

Note If mwtm authtype is set to solaris or linux, you must be logged in as 
the root user, not as a super user, to enter this command.

MWTM does not delete the user from the authentication list, MWTM only 
disables the user’s authentication. The user cannot log in until you re-enable the 
user’s authentication:

• To re-enable the user’s authentication with the same password as before, use 
the mwtm enableuser command.

• To re-enable the user’s authentication with a new password, use the mwtm 
userpass command.
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Enabling and Changing Users and Passwords (Server Only)
Of course, MWTM also enables you to re-enable users and passwords, and change 
user accounts. To enable and change users and passwords, use the following 
procedures:

Step 1 Log in as the root user, as described in the “Becoming the Root User (Server 
Only)” section on page 3-3, or as a super user, as described in the “Specifying a 
Super User (Server Only)” section on page 10-24.

Step 2 Enter the following command:

# cd /opt/CSCOsgm/bin

Step 3 (Optional) To re-enable a user’s authentication, which had been disabled either 
automatically by MWTM or by a super user, enter the following command:

# ./mwtm enableuser username

where username is the name of the user. MWTM re-enables the user’s 
authentication with the same password as before.

Note If mwtm authtype is set to solaris or linux, you must be logged in as 
the root user, not as a super user, to enter this command.

Step 4 (Optional) If mwtm authtype is set to local, you can change a user’s password, 
or re-enable the user’s authentication with a new password, if the user’s 
authentication had been disabled either automatically by MWTM or by a super 
user. To change a password or to re-enable a user’s authentication with a new 
password, enter the following command:

# ./mwtm userpass username

where username is the name of the user.

MWTM prompts you for the new password. When setting the password, follow 
the rules and considerations in the “Creating Secure Passwords” section on 
page 10-6.

If the user’s authentication has also been disabled, MWTM re-enables the user’s 
authentication with the new password.
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Note If mwtm authtype is set to solaris or linux, you cannot use the mwtm 
userpass command. Instead, you must manage passwords on the 
external authentication servers.

Step 5 (Optional) To change a user’s authentication level and password, enter the 
following command:

# ./mwtm updateuser username

where username is the name of the user.

Note If mwtm authtype is set to solaris or linux, you must be logged in as 
the root user, not as a super user, to enter this command.

MWTM prompts you for the new authentication level. Valid levels are:

• 1—Basic User

• 2—Power User

• 3—Network Operator

• 4—Network Administrator

• 5—System Administrator

For more information about authentication levels, see the “Configuring MWTM 
User Authentication Levels (Server Only)” section on page 10-7.

If mwtm authtype is set to local, MWTM also prompts you for the user’s new 
password. When setting the password, follow the rules and considerations in the 
“Creating Secure Passwords” section on page 10-6.
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Step 6 (Optional) To change a user’s authentication level, but not the user’s password, 
enter the following command:

# ./mwtm newlevel username

where username is the name of the user.

MWTM prompts you for the new authentication level. Valid levels are:

• 1—Basic User

• 2—Power User

• 3—Network Operator

• 4—Network Administrator

• 5—System Administrator

For more information about authentication levels, see the “Configuring MWTM 
User Authentication Levels (Server Only)” section on page 10-7.

Displaying a Message of the Day (Server Only)
MWTM enables you to display a user-specified MWTM system notice called the 
message of the day (Figure 10-1). You can use the message of the day to inform 
users of important changes or events in the MWTM system. The message of the 
day also gives users an opportunity to exit the MWTM client before launching.

If the message of the day is enabled, it is displayed whenever a user attempts to 
launch an MWTM client:

• If the user accepts the message, the client launches.

• If the user declines the message, the client does not launch.

To display the Message of the Day dialog, use one of the following procedures:

• Launch the MWTM client. If there is a message of the day, the Message of 
the Day dialog is displayed.

• Select View > Message of the Day from the MWTM Main Menu.
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• Select the MWTM server name in the bottom right corner of the MWTM 
Main Window.

• MWTM displays the Message of the Day dialog (Figure 10-1).

Figure 10-1 Message of the Day Dialog

The Message of the Day dialog contains the following fields and buttons:

Field or Button Description

Message of the Day 
Last Updated

Date and time the message of the day was last updated. If there is no message 
of the day, MWTM displays Unknown.

Message Field Text of the message of the day. If there is no message of the day, MWTM 
displays There is no message of the day.

Accept Closes the Message of the Day dialog and launches the client.

If you do not click Accept, you cannot launch the client.

This button is available when there is a message of the day and you launch the 
MWTM client.
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If you want to configure MWTM to display a message of the day, you must first 
enable the function. To do so, log in as the root user, as described in the 
“Becoming the Root User (Server Only)” section on page 3-3, or as a super user, 
as described in the “Specifying a Super User (Server Only)” section on 
page 10-24, then enter the following commands:

# cd /opt/CSCOsgm/bin

# ./mwtm motd enable

MWTM displays the following prompt:

Enter location of the message of the day file: [/opt/CSCOsgm/etc/motd]

To accept the default value, press Enter; or type a different location and press 
Enter. MWTM displays the following messages:

Setting Message of the Day File to: [/opt/CSCOsgm/etc/motd]

Message of the Day File set to: [/opt/CSCOsgm/etc/motd]

MWTM server must be restarted for changes to take effect.

Initially, the file is blank; enter the following command to specify the message 
text:

# ./mwtm motd edit

You can also use the mwtm motd edit command at any time to change the text of 
the message of the day.

Decline Closes the Message of the Day dialog and exits the client.

This button is available when there is a message of the day and you launch the 
MWTM client.

OK Closes the Message of the Day dialog without exiting the client.

This button is available if you displayed the Message of the Day dialog by 
selecting View > Message of the Day from the MWTM Main Menu.

Field or Button Description
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To display the contents of the message of the day file, enter the following 
command:

# ./mwtm motd cat

To disable this function (that is, to stop displaying the message of the day 
whenever a user attempts to launch an MWTM client), enter the following 
command:

# ./mwtm motd disable

Manually Synchronizing Local MWTM Passwords (Server Only)
If mwtm authtype is set to solaris or linux, MWTM automatically synchronizes 
local MWTM passwords with the operating system at 1:30 AM each night. 
However, you can also manually synchronize passwords at any time. To do so, log 
in as the root user, as described in the “Becoming the Root User (Server Only)” 
section on page 3-3, then enter the following commands:

# cd /opt/CSCOsgm/bin

# ./mwtm syncusers

MWTM synchronizes the passwords with Solaris.

Listing All Currently Defined Users (Server Only)
You can list all currently defined users in the MWTM User-Based Access 
authentication list. To do so, log in as the root user, as described in the “Becoming 
the Root User (Server Only)” section on page 3-3, or as a super user, as described 
in the “Specifying a Super User (Server Only)” section on page 10-24, then enter 
the following commands:

# cd /opt/CSCOsgm/bin

# ./mwtm listusers
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MWTM displays the following information for each user:

• User name

• Last time the user logged in

• User’s authentication access level

• User’s current authentication status, such as Account Enabled or Password 
Disabled

To list information for only a specific user, enter the following command:

# ./mwtm listusers username

where username is the name of the user.

Note You can also view user account information on the MWTM User Accounts Web 
page. For more information, see the “Viewing MWTM User Account 
Information” section on page 13-50.

Displaying the Contents of the System Security Log (Server Only)
You can display the contents of the system security log with PAGER. To do so, 
log in as the root user, as described in the “Becoming the Root User (Server 
Only)” section on page 3-3, or as a super user, as described in the “Specifying a 
Super User (Server Only)” section on page 10-24, then enter the following 
commands:

# cd /opt/CSCOsgm/bin

# ./mwtm seclog

The following security events are recorded in the log:

• All changes to system security, including adding users

• Login attempts, whether successful or unsuccessful, and logoffs

• Attempts to switch to another user's account, whether successful or 
unsuccessful

• Attempts to access files or resources of higher authentication level
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• Access to all privileged files and processes

• Operating system configuration changes and program changes, at the Solaris 
level

• MWTM restarts

• Failures of computers, programs, communications, and operations, at the 
Solaris level

To clear the log and restart the server, enter the following command:

# ./mwtm seclog clear

The default path and filename for the system security log file is 
/opt/CSCOsgm/logs/sgmSecurityLog.txt. If you installed MWTM in a directory 
other than /opt, then the system security log file is located in that directory.

Note You can also view the system security log on the MWTM System Security Log 
Web page. For more information, see the “Viewing the MWTM System Security 
Log” section on page 13-46.

Restoring Security-Related MWTM Data (Server Only)
If you inadvertently delete your user accounts, or make other unwanted changes 
to your mwtm security information, mwtm enables you to restore the 
security-related parts of the mwtm data files from the previous night’s backup.

To restore the files, log in as the root user, as described in the “Becoming the Root 
User (Server Only)” section on page 3-3, then enter the following commands:

# cd /opt/CSCOsgm/bin

# ./mwtm restore security

mwtm restores the files.
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Disabling MWTM User-Based Access (Server Only)
For some reason, you might want to completely disable MWTM User-Based 
Access. To do so, log in as the root user, as described in the “Becoming the Root 
User (Server Only)” section on page 3-3, or as a super user, as described in the 
“Specifying a Super User (Server Only)” section on page 10-24, then enter the 
following commands:

# cd /opt/CSCOsgm/bin

# ./mwtm useraccess disable

MWTM User-Based Access is disabled the next time you restart the MWTM 
server, using the following command:

# ./mwtm restart

Specifying a Super User (Server Only)
MWTM enables you to specify one or more super users. A super user can perform 
most functions that otherwise require the user to be logged in as the root user. (The 
root user can still perform those functions, too.) If you specify a super user, the 
server also runs as the super user and not as the root user.

Caution As a super user, you can adversely affect your operating environment if you are 
unaware of the effects of the commands you use. If you are a relatively 
inexperienced UNIX user, limit your activities as a super user to the tasks 
described in this document.

To specify a super user, log in as the root user, as described in the “Becoming the 
Root User (Server Only)” section on page 3-3, then enter the following 
commands:

# cd /opt/CSCOsgm/bin

# ./mwtm superuser username

where username is the name of the user.
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When you specify a super user, keep in mind the following considerations:

• The user must exist in the local /etc/passwd file. You cannot specify a user 
that is defined in a distributed Network Information Services (NIS) system.

• The super user does not have access to all MWTM commands. You must still 
be logged in as the root user to enter the following commands:

– mwtm backup

– mwtm browserpath

– mwtm certgui

– mwtm certtool

– mwtm clean

– mwtm cleanall

– mwtm cleandb

– mwtm cw2ksetup

– mwtm evilstop

– mwtm jspport

– mwtm keytool

– mwtm killclients

– mwtm reboot

– mwtm restore

– mwtm restoreprops

– mwtm setpath, if you are specifying a username

– mwtm ssl

– mwtm sslstatus

– mwtm stopclients

– mwtm superuser

– mwtm syncusers

– mwtm telnetpath

– mwtm trapsetup

– mwtm uninstall
10-25
Cisco Mobile Wireless Transport Manager User Guide

OL-7637-01



 

Chapter 10      Configuring MWTM Security
Configuring MWTM User-Based Access
– mwtm webport

– mwtm xtermpath

• If mwtm authtype is set to solaris, you must still be logged in as the root 
user to enter the following commands:

– mwtm adduser

– mwtm disableuser

– mwtm enableuser

– mwtm updateuser

• If the SNMP trap port number on the MWTM server is less than 1024, you 
cannot use the mwtm superuser command. To correct this situation, you 
must specify a new SNMP trap port number that is greater than 1024:

– To change the SNMP trap port number in the RAN-O devices in your 
network, use the snmp-server host command. By default, MWTM 
listens for traps from trap multiplexing devices and NMS applications on 
port 44750, so that is a good port number to choose. The SNMP trap port 
number must be the same on all RAN-O devices in your network.

– See the description of the snmp-server host command in the “RAN-O 
Requirements” section of the Cisco Signaling Gateway Manager 
Installation Guide for more information.

– Use the mwtm trapsetup command to change the SNMP trap port 
number in the MWTM server to match the port number in the RAN-O 
devices in your network. See the “mwtm trapsetup” section on page C-87 
for more information.
10-26
Cisco Mobile Wireless Transport Manager User Guide

OL-7637-01



 

Chapter 10      Configuring MWTM Security
Implementing SSL Support in MWTM (Solaris Only)
Implementing SSL Support in MWTM (Solaris Only)
You can implement Secure Sockets Layer (SSL) support in your MWTM system. 
When you do so, MWTM uses secure sockets to encrypt all communication 
between the MWTM clients and server.

This section includes the following information:

• Enabling SSL Support in MWTM, page 10-27

• Downloading the MWTM Server’s Self-Signed SSL Certificate, page 10-30

• Launching the MWTM Certificate Tool for SSL, page 10-31

• Importing an SSL Certificate to an MWTM Client, page 10-33

• Exporting an SSL Certificate, page 10-35

• Viewing Detailed Information About an SSL Certificate, page 10-37

• Managing SSL Support in MWTM, page 10-39

• Disabling SSL Support in MWTM, page 10-40

Enabling SSL Support in MWTM
To enable SSL support in MWTM, perform the following tasks:

Step 1 Obtain the SSL-enabled version of MWTM.

Due to US government restrictions on the export of SSL-enabled software, Cisco 
provides two versions of MWTM: Basic MWTM, which does not provide SSL 
support, and SSL-enabled MWTM, which does.

To obtain SSL-enabled MWTM, you must contact Cisco TAC or your Cisco 
Account Team. They will help you apply for an export licence and download and 
install SSL-enabled MWTM.
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Step 2 Install an SSL key/certificate pair in MWTM, using one of the following 
procedures:

• To install a new SSL key and a self-signed certificate, generate the key and 
certificate by logging in as the root user on the MWTM server and entering 
the mwtm keytool genkey command.

MWTM stops the MWTM server and issues the following prompts:

Country Name (2 letter code) []:
State or Province Name (full name) []:
Locality Name (eg, city) []:
Organization Name (eg, company) []:
Organizational Unit Name (eg, section) []:
Common Name (your hostname) []:
Email Address []:

Enter the requested information.

MWTM generates the following files:

– /opt/CSCOsgm/etc/ssl/server.key is the MWTM server’s private key. 
Ensure that unauthorized personnel cannot access this key.

– /opt/CSCOsgm/etc/ssl/server.cer is the self-signed SSL certificate.

– /opt/CSCOsgm/etc/ssl/server.csr is a certificate signing request (CSR). It 
is not used if you are using a self-signed SSL certificate.

• To install a new SSL key and a CA-signed certificate, generate the key and a 
CSR by logging in as the root user on the MWTM server and entering the 
mwtm keytool genkey command.

MWTM stops the MWTM server and issues the following prompts:

Country Name (2 letter code) []:
State or Province Name (full name) []:
Locality Name (eg, city) []:
Organization Name (eg, company) []:
Organizational Unit Name (eg, section) []:
Common Name (your hostname) []:
Email Address []:

Enter the requested information.

MWTM generates the following files:

– /opt/CSCOsgm/etc/ssl/server.key is the MWTM server’s private key. 
Ensure that unauthorized personnel cannot access this key.
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– /opt/CSCOsgm/etc/ssl/server.csr is a CSR.

– /opt/CSCOsgm/etc/ssl/server.cer is the self-signed SSL certificate. It is 
not used if you are using a CA-signed SSL certificate; the CA-signed 
certificate overrides the self-signed certificate.

Print the CSR in X.509 format, by logging in as the root user on the MWTM 
server and entering the mwtm keytool print_csr command.

Send the CSR to a certificate authority (CA) to be signed.

After the CA signs the certificate, log in as the root user on the MWTM server 
and enter the following command:

# ./mwtm keytool import_cert cert_filename

where cert_filename is the name of the signed certificate.

MWTM stops the MWTM server and imports the certificate in X.509 format.

• To use an existing signed key/certificate pair, log in as the root user on the 
MWTM server and enter the following command:

# ./mwtm keytool import_key key_filename cert_filename

where key_filename is the name of the existing SSL key and cert_filename is 
the name of the existing signed certificate.

MWTM stops the MWTM server and imports the SSL key in OpenSSL 
format and the signed SSL certificate in X.509 format.

Step 3 Enable SSL support in MWTM, by logging in as the root user on the MWTM 
server and entering the mwtm ssl enable command.

Step 4 Set up the MWTM client-side SSL certificate trust relationship, by downloading 
and importing the self-signed or CA-signed certificate on every remote MWTM 
client, Windows as well as Solaris, that connects to the MWTM server.

a. (Self-signed certificate only) Download the self-signed certificate 
(server.cer), using the procedure in the “Downloading the MWTM Server’s 
Self-Signed SSL Certificate” section on page 10-30.

b. Import the self-signed or CA-signed certificate, using the procedure in the 
“Importing an SSL Certificate to an MWTM Client” section on page 10-33.

Step 5 Restart the MWTM client.
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The MWTM clients can now connect to the MWTM server using SSL. All 
communication between the server and clients is encrypted.

If an MWTM client that is not SSL-enabled attempts to connect to an 
SSL-enabled MWTM server, MWTM displays an appropriate warning message 
and opens the MWTM client download page. The user can then download and 
install a new MWTM client to use to connect to that MWTM server.

If the client is SSL-enabled but does not have the correct certificate, MWTM 
displays an appropriate warning message and opens the MWTM Server SSL 
Certificate page. The user can then download the signed SSL certificate in X.509 
format to the client.

Downloading the MWTM Server’s Self-Signed SSL Certificate
If you have implemented Secure Sockets Layer (SSL) support in your MWTM 
system, you can download the MWTM server’s signed SSL certificate to all 
remote MWTM clients that connect to the server using SSL.

To download the certificate from the MWTM Server SSL Certificate page, use the 
following procedure on each remote MWTM client:

Step 1 Use one of the following procedures to access the MWTM Server Home Page:

• Select View > MWTM Server > Home Page from the MWTM Main Menu.

• Enter the following URL in a Web browser:

https://server_name:1774

where server_name is the name or IP address of the server on which the 
MWTM server is running and 1774 is the Web port being using by MWTM. 
(1774 is the default port number.) If you do not know the name or Web port 
of the MWTM Web Server, contact the system administrator who installed the 
MWTM server software.

MWTM displays the MWTM Server Home page.

Step 2 Select Server SSL Certificate from the MWTM Server Home Page. MWTM 
displays the MWTM Server SSL Certificate page.

Step 3 Right-click Download MWTM Server SSL Certificate.
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Step 4 Select Save Link As from the right-click menu.

Step 5 Select a directory in which to save the certificate (server.cer), and click Save. 
MWTM downloads the server.cer file into the specified directory.

Launching the MWTM Certificate Tool for SSL
If you have implemented Secure Sockets Layer (SSL) support in your MWTM 
system, you can launch the MWTM Certificate Tool for SSL. The MWTM 
Certificate Tool dialog lists all SSL certificates that have been imported by the 
MWTM client, and enables you to import, export, and display detailed 
information about SSL certificates.

To launch the MWTM SSL Certificate Tool, use one of the following procedures:

• In Solaris, log in as the root user and enter the following commands:

# cd /opt/CSCOsgm/bin

# ./mwtm certgui

See the “mwtm certgui” section on page C-11 for more information.

• In Windows, select Start > Programs > Cisco MWTM Client > MWTM 
SSL Certificate Tool.

MWTM displays the MWTM Certificate Tool dialog (Figure 10-2).
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Figure 10-2 MWTM Certificate Tool Dialog

The MWTM Certificate Tool dialog displays the following information about 
each SSL certificate:

Field or Button Description

Issued to Host name of the MWTM server to which the SSL certificate was issued.

Issued by Certificate authority (CA) that issued the SSL certificate.

Self-signed SSL certificates display the host name of the MWTM server.

Expiration Date Date on which the SSL certificate expires.

Import Displays the Open dialog for an SSL certificate, which enables you to import 
SSL certificates.

Export Displays the Save dialog for an SSL certificate, which enables you to export 
the selected SSL certificate.

Remove Removes the selected SSL certificate from the table.

Details Displays the Certificate Information dialog, which provides detailed 
information about the selected certificate.

Exit Closes the MWTM Certificate Tool dialog.

Help Displays online help for the current window.
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Importing an SSL Certificate to an MWTM Client
If you have implemented Secure Sockets Layer (SSL) support in your MWTM 
system, you can import the MWTM server’s self-signed SSL certificate, or a 
CA-signed SSL certificate, to all remote MWTM clients that connect to the server 
using SSL.

To import an SSL certificate, launch the MWTM SSL Certificate Tool, as 
described in the “Launching the MWTM Certificate Tool for SSL” section on 
page 10-31, then click Import. MWTM displays the Open dialog for SSL 
certificates (Figure 10-3).

Figure 10-3 Open Dialog for SSL Certificates

Use the Open dialog to locate the SSL certificate that you want to import. The 
Open dialog for an SSL certificate provides the following fields and buttons:
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Related Topics:

• Launching the MWTM Certificate Tool for SSL, page 10-31

Field or Button Description

Look In Enables you to select the directory in which you want to find the SSL 
certificate. Either accept the default directory, or select a new directory from 
the drop-down list box.

For a self-signed certificate, locate the directory in which you downloaded the 
certificate.

File Name Enter a name for the SSL certificate, or select a file from those listed in the 
Open field. MWTM displays the name of the certificate in the File Name field.

Files of Type Specifies the type of file to display, and displays all files of that type in the 
selected directory. For SSL certificates, this field displays All files, which 
means files of all types are displayed in the table.

Up One Level Displays the sub-folders and files that are in the folder that is up one level from 
the currently displayed folder.

Desktop Displays the sub-folders and files that are on your workstation desktop.

Create New Folder Creates a new sub-folder in the displayed folder.

List Displays only icons for sub-folders and files.

Details Displays detailed information for sub-folders and files, including their size, 
type, date they were last modified, and so on.

Open Imports the file, closes the Open dialog for an SSL certificate, and populates 
the MWTM Certificate Tool dialog with the SSL certificate’s information.

Cancel Closes the Open dialog for an SSL certificate without importing the file.
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Exporting an SSL Certificate
If you have implemented Secure Sockets Layer (SSL) support in your MWTM 
system, you can export SSL certificates that have been imported to the MWTM 
client.

To export an SSL certificate, launch the MWTM SSL Certificate Tool, as 
described in the “Launching the MWTM Certificate Tool for SSL” section on 
page 10-31, select a certificate from the list, then click Export. MWTM displays 
the Save dialog for SSL certificates (Figure 10-4).

Figure 10-4 Save Dialog for SSL Certificates

Use the Save dialog to export the SSL certificate to another directory. The Save 
dialog for an SSL certificate provides the fields and buttons:
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Related Topics:

• Launching the MWTM Certificate Tool for SSL, page 10-31

Field or Button Description

Save In Enables you to select the directory in which you want to save the SSL 
certificate. Either accept the default directory, or select a new directory from 
the drop-down list box.

For a self-signed certificate, locate the directory in which you downloaded the 
certificate.

File Name Enter a name for the SSL certificate, or select a file from those listed in the 
Save In field. MWTM displays the name of the certificate in the File Name 
field.

Files of Type Specifies the type of file to save, and displays all files of that type in the 
selected directory. For SSL certificates, this field displays All files, which 
means files of all types are displayed in the table.

Up One Level Displays the sub-folders and files that are in the folder that is up one level from 
the currently displayed folder.

Desktop Displays the sub-folders and files that are on your workstation desktop.

Create New Folder Creates a new sub-folder in the displayed folder.

List Displays only icons for sub-folders and files.

Details Displays detailed information for sub-folders and files, including their size, 
type, date they were last modified, and so on.

Save Saves the file, closes the Save dialog for an SSL certificate, and returns to the 
MWTM Certificate Tool dialog. Click Exit to close the MWTM Certificate 
Tool dialog and export the self-signed SSL certificate in X.509 format.

Cancel Closes the Save dialog for an SSL certificate without saving the file.
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Viewing Detailed Information About an SSL Certificate
If you have implemented Secure Sockets Layer (SSL) support in your MWTM 
system, you can view detailed information about SSL certificates that have been 
imported to the MWTM client.

To view detailed information about an SSL certificate, use one of the following 
procedures:

• Click the “locked padlock” symbol in the bottom left corner of any MWTM 
window.

• Launch the MWTM SSL Certificate Tool, as described in the “Launching the 
MWTM Certificate Tool for SSL” section on page 10-31, select an SSL 
certificate from the list and click Details.

MWTM displays the Certificate Information dialog (Figure 10-5).

Figure 10-5 Certificate Information Dialog
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The Certificate Information dialog displays the following detailed information for 
the selected SSL certificate:

Related Topics:

• Launching the MWTM Certificate Tool for SSL, page 10-31

Field or Button Description

Subject Device to which the SSL certificate was issued.

The Subject field always includes the Common Name (CN) of the subject, 
which must match the fully qualified host name of your MWTM server, such 
as mwtm-sun8.cisco.com.

The Subject field might also contain other information, such as the Country 
(C), Organizational Unit (OU), or Organization (O) of the subject.

Issuer CA that issued the SSL certificate.

The Issuer field might include the Common Name (CN) of the issuer, as well 
as the Country (C), Organizational Unit (OU), or Organization (O) of the 
issuer.

Version Version of the SSL certificate, such as V1.

Serial number Serial number associated with the SSL certificate.

Signature algorithm Asymmetric algorithm used to ensure that the digital signature is secure, 
such as MD5withRSA.

Valid from Date and time on which the SSL certificate was created or became valid.

Valid to Date and time on which the SSL certificate expires.

Public key Public key associated with the SSL certificate, used for encryption and for 
verifying signatures.

OK Closes the Certificate Information dialog.

When you are ready to close the dialog, click OK. MWTM closes the 
Certificate Information dialog. If necessary, click Exit to close the MWTM 
Certificate Tool dialog.
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Managing SSL Support in MWTM
MWTM enables you to perform the following tasks to make it easier to manage 
SSL support in MWTM:

• To display the current status of SSL support in MWTM, including whether 
SSL support is enabled or disabled and which SSL keys and certificates exist, 
use either the mwtm ssl status or mwtm sslstatus command.

• To print the MWTM server’s SSL certificate in X.509 format, use the 
mwtm keytool print_crt command.

• To list the SSL key/certificate pair on the MWTM server, use the 
mwtm keytool list command.

• To list all SSL certificates on the MWTM client, launch the MWTM SSL 
Certificate Tool. MWTM lists each imported certificate, including to whom 
the certificate was issued, who issued the certificate, and when the certificate 
expires.

See the “MWTM Command Reference” section on page C-1 for more information 
on the use of these commands.

See the “Importing an SSL Certificate to an MWTM Client” section on 
page 10-33 for more information on launching the MWTM SSL Certificate Tool.
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Disabling SSL Support in MWTM
MWTM enables you to disable SSL support in MWTM, and to remove SSL keys 
and certificates from the MWTM server and clients:

• To disable SSL support in MWTM, use the mwtm ssl disable command.

See the “mwtm ssl” section on page C-71 for more information.

• To remove all SSL keys and certificates from the MWTM server, use the 
mwtm keytool clear command. MWTM stops the MWTM server, if 
necessary, and removes the keys and certificates. Before restarting the server, 
you must either generate new SSL keys using the mwtm keytool genkey 
command, or you must completely disable SSL using the mwtm ssl disable 
command.

See the “MWTM Command Reference” section on page C-1 for more 
information on the use of these commands.

• To remove an SSL certificate from the MWTM client, launch the MWTM 
SSL Certificate Tool. MWTM lists each imported certificate. Select the 
certificate you want to remove, and click Remove. MWTM deletes the 
certificate from the list.

See the “Importing an SSL Certificate to an MWTM Client” section on 
page 10-33 for more information on launching the MWTM SSL Certificate 
Tool.

Limiting MWTM Client Access to the MWTM Server 
(Server Only)

By default, when you first install MWTM, all MWTM client IP addresses are 
allowed to connect to the MWTM server. However, MWTM enables you to limit 
client access to the server by creating and maintaining the ipaccess.conf file.

You can create the ipaccess.conf file and populate it with a list of MWTM client 
IP addresses that can connect to the MWTM server. MWTM allows connections 
from only those clients, plus the local host. If the file exists but is empty, MWTM 
allows connections only from the local host. (MWTM always allows connections 
from the local host.)
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When you first install MWTM, the ipaccess.conf file does not exist and MWTM 
allows all client IP addresses to connect to the MWTM server. To create the 
ipaccess.conf file and work with the list of allowed client IP addresses, use the 
following procedure:

Step 1 Log in as the root user, as described in the “Becoming the Root User (Server 
Only)” section on page 3-3, or as a super user, as described in the “Specifying a 
Super User (Server Only)” section on page 10-24.

Step 2 Enter the following command:

# cd /opt/CSCOsgm/bin

Step 3 Create the ipaccess.conf file:

• To create the ipaccess.conf file and add a client IP address to the list, enter 
the following command:

# ./mwtm ipaccess add

• To create the ipaccess.conf file and open the file to edit it directly, enter the 
following command:

# ./mwtm ipaccess edit

The default directory for the file is located in the MWTM installation directory:

• If you installed MWTM in the default directory, /opt, then the default 
directory is /opt/CSCOsgm/etc.

• If you installed MWTM in a different directory, then the default directory is 
located in that directory.

In the ipaccess.conf file, begin all comment lines with a pound sign (#).

All other lines in the file are MWTM client IP addresses, with one address per 
line.

Wildcards (*) are allowed, as are ranges (for example, 1-100). For example, the 
address *.*.*.* allows all clients to connect to the MWTM server.

After you create the ipaccess.conf file, you can use the full set of mwtm ipaccess 
keywords to work with the file:

• clear—Remove all client IP addresses from the ipaccess.conf file, and allow 
connections from any MWTM client IP address.
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• list—List all client IP addresses currently in the ipaccess.conf file. If no client 
IP addresses are listed (that is, the list is empty), connections from any 
MWTM client IP address are allowed.

• rem—Remove the specified client IP address from the ipaccess.conf file.

• sample—Print out a sample ipaccess.conf file.

See the “mwtm ipaccess” section on page C-30 for more information.

Any changes you make to the ipaccess.conf file take effect when you restart the 
MWTM server.

MWTM also enables you to limit the IP addresses that can send traps to the server 
by creating and maintaining the trapaccess.conf file. For more information, see 
the “Limiting Traps by IP Address (Server Only)” section on page 11-38.
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C H A P T E R 11

Configuring MWTM for Your Network

This chapter provides the following information about configuring MWTM to 
better suit your needs:

• Importing SNMP Community Names from CiscoWorks (Solaris Only), 
page 11-2

• Retaining Unknown Objects from the MWTM Database (Server Only), 
page 11-3

• Changing MWTM Client Preference Settings, page 11-3

• Changing MWTM System Poller Settings, page 11-32

• Changing the Message Display, page 11-34

• Enabling SNMP Traps (Server Only), page 11-35

• Limiting Traps by IP Address (Server Only), page 11-38

• Setting the DISPLAY Variable (Client Only), page 11-40

• Backing Up or Restoring MWTM Files (Server Only), page 11-40

• Removing MWTM Data from the MWTM Server, page 11-42

• Configuring a Backup MWTM Server (Server Only), page 11-43

• Configuring MWTM with IOS Server Load Balancing, page 11-44

• Configuring an MWTM Client Connection Timer, page 11-46

• Telnetting to a Router, page 11-47
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Importing SNMP Community Names from 
CiscoWorks (Solaris Only)

MWTM enables you to store all SNMP community names in a single database in 
CiscoWorks Resource Manager Essentials (RME), and to export those names for 
use by MWTM.

To export the database from CiscoWorks RME to MWTM, use the following 
procedure:

Step 1 Log into CiscoWorks and select Common Services > Device and Credentials > 
Device Management. Then click the Export button.

Step 2 In the Device Export window, choose the device from the Device Selector panel. 
Then choose the following settings:

File Name Field = mwtm

Format = CSV

Run Type = Immediate

Step 3 Click OK.

CiscoWorks creates the /opt/CSCOpx/objects/dmgt/mwtm file in the default 
directory.

Step 4 When you start the MWTM server, MWTM looks for this file. If the file exists, 
MWTM merges the file with its own community name database, the 
/opt/CSCOsgm/etc/communities.conf file.

For more information about SNMP, refer to “Configuring SNMP Support” in the 
Cisco IOS Release 12.2 Configuration Fundamentals Configuration Guide, 
Part 3, System Management.
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Retaining Unknown Objects from the MWTM 
Database (Server Only)

By default, MWTM deletes all Unknown objects from the MWTM database after 
7 days. To change the length of time unknown objects stay in the MWTM 
database, use the mwtm unknownage command. See the “mwtm unknownage” 
section on page C-89 for more information.

This method requires you to be logged in as the root user or as a super user. See 
the “Becoming the Root User (Server Only)” section on page 3-3 and the 
“Specifying a Super User (Server Only)” section on page 10-24 for more 
information.

Changing MWTM Client Preference Settings
When a user changes some aspect of the MWTM client, such as the size of a 
window or the order of columns in a window, MWTM makes note of the user’s 
preferences on the MWTM client and server. MWTM saves the user’s preferences 
to the MWTM server when the MWTM client exits.

Thereafter, whenever the user launches the MWTM client, MWTM searches for 
the user’s MWTM preferences. If MWTM finds the user’s preferences on the 
MWTM server, MWTM launches the MWTM client with those preferences. 
Otherwise, MWTM launches the MWTM client with the default MWTM 
preferences file.

In addition to the user preferences that are automatically saved, MWTM enables 
you to change many GUI, data, topology, and table settings that affect the way 
MWTM presents its information.

Note Anyone who uses this MWTM client can change its preference settings, and the 
changes affect all views running on this client.
11-3
Cisco Mobile Wireless Transport Manager User Guide

OL-7637-01



 

Chapter 11      Configuring MWTM for Your Network
Changing MWTM Client Preference Settings
This section includes the following information:

• Displaying the Preferences Window, page 11-4

• Customizing the Color of Event Severities, page 11-22

• Customizing the Color of Chart Data Series, page 11-24

• Restoring Default Preference Settings, page 11-28

• Loading an Existing Preference Settings File, page 11-28

• Saving the Preference Settings File, page 11-30

Related Topics:

• Viewing the Topology of the Network, page 8-1

• Working with Events, page 5-1

• Working with Nodes, page 6-1

Displaying the Preferences Window
When you change overall MWTM preference settings, you must first display the 
Preferences window. The Preferences window enables you to change the way 
MWTM presents information.

To display the Preferences window, select Edit > Preferences from the MWTM 
Main Menu. MWTM displays the Preferences window (Figure 11-1).
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Figure 11-1 Preferences Window

The Preferences window is composed of the following sections:

• Preferences Menu, page 11-6

• General GUI Settings, page 11-7

• Topology Settings, page 11-11

• Event Settings, page 11-13

• Charts Settings, page 11-18

• Status Settings, page 11-20

Related Topics:

• Working with Views, page 4-1
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Preferences Menu

The menu on the Preferences window provides the following options:

Menu Command Description

File > Load 
System Default 
Prefs

Restores all preference settings to the original system default settings.

File > Load
(Ctrl-L)

Loads an already existing set of preferences. MWTM prompts you for the name 
of the preferences file you want to load:

• Select the name of the preferences file, or accept the default filename, then 
click OK to load the preferences file. 

• Click Cancel to close the prompt window without loading a preferences file.

File > Save
(Ctrl-S)

Saves the preference changes.

File > Save As Opens the Save File Dialog: Preferences File List, which enables you to save the 
preferences file with a new name, or overwrite an existing preferences file.

File > Close
(Ctrl-W)

Closes the Preferences window.

To close the Preferences window at any time, click File > Close. If you have 
changed any preferences, MWTM asks if you want to apply the changes before 
leaving the window:

• Click Yes to apply the changes and close the prompt window and the 
Preferences window.

• Click No to close the prompt window and the Preferences window without 
applying or saving any changes.

• Click Cancel to close the prompt window without applying any changes. 
The Preferences window remains open.

Help > Topics
(F1)

Displays the table of contents for the MWTM online help.

Help > Window
(Shift-F1)

Displays online help for the current window.

Help > About
(F3)

Displays build date, version, SSL support, and copyright information about the 
MWTM application.
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General GUI Settings

The General GUI settings in the Preferences window enable you to change general 
display settings for MWTM, including which window to display first when 
starting MWTM, and whether to display values in bits or bytes.

To display the General GUI settings, select General GUI in the left pane of the 
Preferences window.

The General GUI settings contain the following sections:

• Startup/Exit Settings, page 11-7

• General Display Settings, page 11-8

• Node Name Settings, page 11-9

• Poller Settings, page 11-10

• Repaint Priority, page 11-11

Startup/Exit Settings

Use the Startup/Exit Settings section of the General GUI settings to specify 
whether you want to display the Topology Window when you launch the MWTM 
client, and whether you want MWTM to prompt you for confirmation when you 
exit the MWTM client.
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The Startup/Exit Settings section contains the following fields:

General Display Settings

Use the General Display section of the General GUI settings to specify whether 
MWTM is to:

• Display node domain names.

• Show details in bits instead of bytes.

• Show receive and send utilizations as percentages.

• Show the point code mask in bits instead of dotted notation.

The General Display settings contain the following fields:

Field Description

MWTM: Topology 
Window

Checkbox used to indicate whether the Topology Window is to be 
displayed when MWTM is started. The default setting for this checkbox 
is cleared.

Confirm Exit Checkbox used to indicate whether MWTM is to prompt you for 
confirmation when you exit the MWTM client. The default setting for 
this checkbox is selected.

Confirm Deletions Checkbox used to indicate whether MWTM is to prompt you for 
confirmation when you delete an object. The default setting for this 
checkbox is selected.

Note If you select the Do not show this again checkbox in a Confirm 
Deletion dialog, and you later decide you want MWTM to begin 
displaying the Confirm Deletion dialog again, you must select 
the Confirm Deletions checkbox to do so.
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Node Name Settings

Use the Node Name section of the General GUI settings to specify how MWTM 
is to display node names.

The Node Name settings contain the following radio buttons:

Field Description

Show Node Domain Names Checkbox used to indicate whether MWTM is to show node 
domain names in its displays. The default setting for this 
checkbox is cleared (do not show node domain names).

Show Details in Bits Instead of 
Bytes

Checkbox used to indicate whether you want MWTM to display 
data and data rates in bits or bytes:

• If you want MWTM to display data in bits, and data rates in 
bits per second, select this checkbox. This is the default 
setting.

• If you want MWTM to display data in bytes, and data rates in 
bytes per second, clear this checkbox.

Show Utilization as Percentage Checkbox used to indicate whether you want MWTM to display 
receive and send utilization for linksets and links as a percentage 
or in Erlangs:

• If you want MWTM to display utilization as a percentage, 
select this checkbox. This is the default setting.

• If you want MWTM to display utilization in Erlangs, clear 
this checkbox.

Radio Buttons Description

Show DNS or User-Defined 
Names

Radio button used to indicate whether MWTM is to identify nodes by 
their DNS or user-defined names. The default setting for this radio 
button is selected.

Show IP Addr in Name Field Radio button used to indicate whether MWTM is to identify nodes by 
their IP addresses. The default setting for this radio button is cleared.
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Poller Settings

Use the Poller section of the General GUI settings to change MWTM poller and 
counter settings.

The Poller settings contain the following fields and radio buttons:

Field or Radio Button Description

Fast Poller Default (secs) Default interval, in seconds, for the fast poller. The valid 
range is 15 seconds to 60 seconds. The default setting is 
15 settings.

The fast poller is used in the MWTM Real-Time Statistics: 
CPU Statistics Window

You can change the valid range and default setting in the 
System.properties file. For more information, see the 
“Changing MWTM System Poller Settings” section on 
page 11-32.

Slow Poller Default (secs) Default interval, in seconds, for the slow poller. The valid 
range is 60 seconds to 300 seconds. The default setting is 
15 settings.

The slow poller is used in all MWTM client windows 
except those listed above that use the fast poller.

You can change the valid range and default setting in the 
System.properties file. For more information, see the 
“Changing MWTM System Poller Settings” section on 
page 11-32.

Show Counters Since Reboot Radio button used to configure the MWTM client to clear 
all counters in MWTM Web pages whenever the ITP 
reboots. The default setting for this radio button is selected.

Show Counters Since Last Poll Radio button used to configure the MWTM client to clear 
all counters whenever an MWTM Web page is polled. The 
default setting for this radio button is cleared.

Show Counters Since User Reset Radio button used to configure the MWTM client to clear 
all MWTM counters whenever the user resets the counters 
on an MWTM Web page. The default setting for this radio 
button is cleared.
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Repaint Priority

Use the Repaint Priority section of the General GUI settings to balance the 
responsiveness versus efficiency of the MWTM client. This setting controls how 
quickly the MWTM client repaints its displays.

The Repaint Priority section contains the following sliding control:

Topology Settings

Use the Topology settings in the Preferences window to change default settings 
for the Topology Window.

To display the Topology settings, select Topology in the left pane of the 
Preferences window.

The Topology settings contain the following fields:

Field Description

Repaint Priority Balances the MWTM client’s responsiveness versus efficiency. The valid 
range is 0 through 10, with 0 representing a high repaint priority (high 
responsiveness, low efficiency) and 10 representing a high communication 
priority (high efficiency, low responsiveness):

• Slide the selector toward High Repaint Priority if you want to 
maximize repainting (responsiveness) over communication 
(efficiency).

• Slide the selector toward High Comm. Priority if you want to 
maximize communication (efficiency) over repainting 
(responsiveness).

• The default setting is 2 (the third mark from the left).
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Field Description

Spring Layout Spacing 
Factor (1-10)

Indicates how far apart nodes are to be spaced when MWTM draws the 
Spring Layout topology map. Valid values are 1 through 10, with 1 being 
closer together and 10 being farther apart. The default spacing factor is 
5.

Even if you apply preferences and close the Preferences window, the 
new spacing factor is not reflected in the topology map until you select 
Topology Tools > Layout > Spring, or click the Spring Layout button.

Show Mouse Overs Checkbox used to specify whether mouse over popups are enabled in 
topology maps. The default setting for this checkbox is selected.

Draw Connections When 
Dragging Node

Checkbox used to specify whether MWTM is to draw connection lines 
in the topology map as you move nodes:

• If you want MWTM to draw the associated connection lines 
dynamically as you move a node, select this checkbox.

• If you do not want MWTM to draw the associated connection lines 
until after you have finished moving a node, clear this checkbox. 
This is the default setting.

X Performance Enhancer 
(AntiAliasing Off)

Checkbox used to specify whether antialiasing is on in the topology 
map. Antialiasing, which is on by default, improves the appearance of 
the icons and connections in the map.

However, antialiasing can impact the performance of the MWTM client 
on a remote workstation (that is, a Solaris/Linux workstation using 
xhost, or a Windows workstation using an X-Window system emulator 
such as eXceed or Reflection X).

• If you want to turn on antialiasing in the topology map, clear this 
checkbox. This is the default setting.

• If you want to turn off antialiasing, select this checkbox.

Keep in mind that performance is always better if you access MWTM by 
installing the MWTM client on the remote workstation.
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Event Settings

Use the Event settings in the Preferences window to change the default 
background color for each type of event, to specify whether to display 
acknowledged events, and to specify the types of event MWTM is to display in 
the Event tables, including the category and severity of event, whether the event 
is acknowledged, and other properties.

To display the Event settings, select Events in the left pane of the Preferences 
window.

The Event settings contain the following sections:

• Event Colors, page 11-13

• Categories, page 11-14

• Severities, page 11-16

• Other, page 11-17

Event Colors

The Event Colors section of the Event settings contains the following fields and 
buttons:

Field Description

Informational Indicates the background color for Informational events. The default color is 
white.

Normal Indicates the background color for Normal events. The default color is light 
green.

Indeterminate Indicates the background color for Indeterminate events. The default color is 
cyan.

Warning Indicates the background color for Warning events. The default color is blue.

Critical Indicates the background color for Critical events. The default color is red.

Major Indicates the background color for Major events. The default color is orange.

Minor Indicates the background color for Minor events. The default color is yellow.
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Event Time Format

The Event Time Format section of the Event settings contains the following 
buttons:

Event Date Format

The Event Date Format section of the Event settings contains the following fields 
and buttons:

Categories

Use the Categories section of the Event settings to specify which event categories 
you want to display in the Event Window.

The Categories section contains the following default fields and buttons:

Button Description

12 hour format Select this radio button to configure event time stamps using 12 hour format 
(for example, 07:10:09).

24 hour format Select this radio button to configure event time stamps using 24 hour format 
(for example, 19:10:09).

Button Description

Month first Select this radio button to configure event date stamps with the month 
appearing first (for example, 8/16/05).

Day first Select this radio button to configure event date stamps with the day appearing 
first (for example, 16/8/05).

Field or Button Description

Status Checkbox used to indicate whether Status events are to be displayed in the Event 
Window. The default setting for this checkbox is selected.

Trap Checkbox used to indicate whether Trap events are to be displayed in the Event 
Window. The default setting for this checkbox is selected.
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Note These are the default categories; there might be additional categories, as defined 
by the MWTM system administrator. For information about custom categories, 
see the “Changing Event Categories” section on page 5-34.

Create Checkbox used to indicate whether Create events are to be displayed in the Event 
Window. The default setting for this checkbox is selected.

Delete Checkbox used to indicate whether Delete events are to be displayed in the Event 
Window. The default setting for this checkbox is selected.

Discover Checkbox used to indicate whether Discover events are to be displayed in the Event 
Window. The default setting for this checkbox is selected.

Edit Checkbox used to indicate whether Edit events are to be displayed in the Event 
Window. The default setting for this checkbox is selected.

Ignore Checkbox used to indicate whether Ignore events are to be displayed in the Event 
Window. The default setting for this checkbox is selected.

Login Checkbox used to indicate whether Login events are to be displayed in the Event 
Window. The default setting for this checkbox is selected.

LoginDisable Checkbox used to indicate whether LoginDisable events are to be displayed in the 
Event Window. The default setting for this checkbox is selected.

LoginFail Checkbox used to indicate whether LoginFail events are to be displayed in the 
Event Window. The default setting for this checkbox is selected.

Logout Checkbox used to indicate whether Logout events are to be displayed in the Event 
Window. The default setting for this checkbox is selected.

OverWrite Checkbox used to indicate whether OverWrite events are to be displayed in the 
Event Window. The default setting for this checkbox is selected.

Poll Checkbox used to indicate whether Poll events are to be displayed in the Event 
Window. The default setting for this checkbox is selected.

Purge Checkbox used to indicate whether Purge events are to be displayed in the Event 
Window. The default setting for this checkbox is selected.

Select All Selects all event category checkboxes.

Deselect All Clears all event category checkboxes.

Field or Button Description
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Severities

Use the Severities section of the Event settings to specify which event severities 
you want to display in the Event Window.

The Severities section contains the following default fields.

Note These are the default severities; there might be additional severities, as defined by 
the MWTM system administrator. For information about custom severities, see 
the “Changing Event Severities and Colors” section on page 5-35.

Field Description

Informational Checkbox used to indicate whether events of severity Informational are to be 
displayed in the Event Window. The default setting for this checkbox is selected.

Normal Checkbox used to indicate whether events of severity Normal are to be displayed in 
the Event Window. The default setting for this checkbox is selected.

Indeterminate Checkbox used to indicate whether events of severity Indeterminate are to be 
displayed in the Event Window. The default setting for this checkbox is selected.

Warning Checkbox used to indicate whether events of severity Warning are to be displayed in 
the Event Window. The default setting for this checkbox is selected.

Critical Checkbox used to indicate whether events of severity Critical are to be displayed in 
the Event Window. The default setting for this checkbox is selected.

Major Checkbox used to indicate whether events of severity Major are to be displayed in the 
Event Window. The default setting for this checkbox is selected.

Minor Checkbox used to indicate whether events of severity Minor are to be displayed in the 
Event Window. The default setting for this checkbox is selected.
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Other

Use the Other section of the Event settings to further define the event filter for the 
Event Window. These settings are applied to all event displays in the current view.

The Other section contains the following fields:

Field Description

Acknowledged Checkbox used to indicate whether only acknowledged events are to be 
displayed in the Event Window. The default setting for this checkbox is 
cleared.

Unacknowledged Checkbox used to indicate whether only unacknowledged events are to be 
displayed in the Event Window. The default setting for this checkbox is 
selected.

Time Before Checkbox used to indicate whether only events logged by MWTM prior to a 
specified date and time are to be displayed in the Event Window. The default 
setting for this checkbox is cleared.

Time Before Field Specifies the date and time prior to which events logged by MWTM are to be 
displayed in the Event Window. This field is grayed-out unless the Time 
Before checkbox is selected.

Time After Checkbox used to indicate whether only events logged by MWTM after a 
specified date and time are to be displayed in the Event Window. The default 
setting for this checkbox is cleared.

Time After Field Specifies the date and time after which events logged by MWTM are to be 
displayed in the Event Window. This field is grayed-out unless the Time After 
checkbox is selected.

Message Contains Checkbox used to indicate whether only events that contain the specified 
message text are to be displayed in the Event Window. The default setting for 
this checkbox is cleared.

Match Case Checkbox used to indicate whether only events that match the case of the text 
in the Message Contains field are to be displayed in the Event Window. This 
field is grayed-out unless the Message Contains checkbox is selected. If the 
Message Contains checkbox is selected, the default setting for this checkbox 
is cleared.
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Charts Settings

Use the Charts settings in the Preferences window to change default settings for 
the elements in real-time data charts.

To display the Charts settings, select Charts in the left pane of the Preferences 
window.

The Charts settings contain the following fields and button:
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Field or Button Description

Series Indicates the time series being defined. A time series is a set of data collected 
sequentially at a fixed interval of time.

The default values for series are:

• Series 0: Dot, Solid, Red

• Series 1: Box, Solid, Green

• Series 2: Triangle, Solid, Blue

• Series 3: Diamond, Solid, Black

• Series 4: Star, Solid, Pink

• Series 5: Cross, Solid, Orange

• Series 6: Circle, Solid, Gray

• Series 7: Square, Solid, Light Green

• Series 8: Vertical Line, Solid, Red

• Series 9: Horizontal Line, Solid, Green

• Series 10: Dot, Solid, Blue

• Series 11: Box, Solid, Black

• Series 12: Triangle, Solid, Pink

• Series 13: Diamond, Solid, Orange

• Series 14: Star, Solid, Gray

• Series 15: Cross, Solid, Light Green

• Series 16: Circle, Solid, Red
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Status Settings

MWTM enables you to customize the order in which status settings are sorted, as 
well as the color of each status setting.

When you change the sort order or the color of a status setting, most MWTM 
client windows reflect the new sort order or color immediately. All other windows 
reflect the new sort order or color at the next poll.

When you change the color of a status, most MWTM client windows reflect the 
new color immediately. All other windows reflect the new color at the next poll.

To display the Status settings, select Status in the left pane of the Preferences 
window.

Symbol Style Drop-down list box used to define the symbol associated with a series. To change 
the symbol for a series, select a new value: Dot, Box, Triangle, Diamond, Star, 
Vertical Bar, Horizontal Line, Cross, or Circle.

Line Style Drop-down list box used to define the style of line that connects data points in the 
chart. To change the line style for a series, select a new value: Solid, Long Dash, 
Long-Short-Long (LSL) Dash, Short Dash, Dash Dot, or None.

Color Indicates the current color for the series.

Change Color Opens the Select Series Color dialog, which enables you to select a color for a 
series. For more details, see the “Customizing the Color of Chart Data Series” 
section on page 11-24.

Field or Button Description
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The Status settings contain the following fields and button:

Field or Button Description

Status Sort Order Indicates the status setting being defined. The default status sort order 
and colors are:

• None: Black

• Unknown: Red

• Unavailable: Red

• Inactive: Red

• Failed: Red

• Down: Red

• Blocked: Red

• Pending: Red

• Warning: Yellow

• Shutdown: Blue

• Discovering: Cyan

• Polling: Cyan

• Waiting: Gray

• Unmanaged: Gray

• Active: Green

Move Up Moves the selected status setting up in the Status Sort Order list.

Change Color Opens the Select Status Color dialog, which enables you to select a color 
for a status. For more details, see the “Customizing the Color of Chart 
Data Series” section on page 11-24.

Move Down Moves the selected status setting down in the Status Sort Order list.

Color Indicates the current color for the Series.

Change Color Opens the Select Series Color dialog, which enables you to select a color 
for a Series. For more details, see the “Customizing the Color of Status 
Settings” section on page 11-26.
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Customizing the Color of Event Severities
MWTM enables you to customize the color of event severities.

To customize event severity colors, select Events in the left pane of the 
Preferences window (Figure 11-1), then click Change Color in the Event Colors 
section. MWTM displays the Select Event Color dialog.

The Select Event Color dialog is composed of the following sections:

• Swatches Panel (Recommended), page 11-22

• HSB Panel, page 11-22

• RGB Panel, page 11-23

• Select Event Color Field and Buttons, page 11-23

Related Topics:

• Event Settings, page 11-13

Swatches Panel (Recommended)

The Swatches panel of the Select Event Color dialog enables you to select an 
event severity color from a set of color swatches. This is the recommended 
method for selecting an event severity color.

To display the Swatches panel, click the Swatches tab in the Select Event Color 
dialog.

To select an event severity color, select a swatch. The selected color is displayed 
in the Preview field. When you are satisfied with the color, click OK.

HSB Panel

The HSB panel of the Select Event Color dialog enables you to select an event 
severity color based on color hue, saturation, and brightness (HSB).

Reset Order Restores the status settings to the default sort order.

Reset Colors Restores the status settings to the default colors.

Field or Button Description
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To display the HSB panel, click the HSB tab in the Select Event Color dialog.

To select an event severity color, use one of the following procedures:

• Select a color range on the vertical color bar, then select a specific color by 
moving the cursor around on the color square.

• Enter specific values in the hue (H), saturation (S), and brightness (B) fields.

The selected severity color is displayed in the Preview field. When you are 
satisfied with the color, click OK.

RGB Panel

The RGB panel of the Select Event Color dialog enables you to select an event 
severity color based on the red, green, and blue (RGB) content of the color.

To display the RGB panel, click the RGB tab in the Select Event Color dialog.

To select an event severity color, select values for the Red, Green, and Blue 
fields. The selected color is displayed in the Preview field. When you are satisfied 
with the color, click OK.

Select Event Color Field and Buttons

The Select Event Color dialog contains the following field and buttons:

Field or Button Description

Preview Displays a preview of the current selected event severity color.

Whichever method you choose to select an event severity color, the selected 
color is displayed in the Preview field. When you are satisfied with the color, 
click OK.

OK Sets the event severity color as shown in the Preview field, and closes the 
Select Event Color dialog.

Cancel Closes the Select Event Color dialog without selecting an event severity color.

Reset Resets the event severity color to its initial setting.
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Customizing the Color of Chart Data Series
MWTM enables you to customize the color of series in real-time data charts.

To customize series colors, select Charts in the left pane of the Preferences 
window (Figure 11-1), then click Change Color in the Series Colors section. 
MWTM displays the Select Series Color dialog.

The Select Series Color dialog is composed of the following sections:

• Swatches Panel (Recommended), page 11-24

• HSB Panel, page 11-24

• RGB Panel, page 11-25

• Select Series Color Field and Buttons, page 11-25

Related Topics:

• Charts Settings, page 11-18

Swatches Panel (Recommended)

The Swatches panel of the Select Series Color dialog enables you to select a series 
color from a set of color swatches. This is the recommended method for selecting 
a series color.

To display the Swatches panel, click the Swatches tab in the Select Series Color 
dialog.

To select a series color, select a swatch. The selected color is displayed in the 
Preview field. When you are satisfied with the color, click OK.

HSB Panel

The HSB panel of the Select Series Color dialog enables you to select a series 
color based on color hue, saturation, and brightness (HSB).

To display the HSB panel, click the HSB tab in the Select Series Color dialog.
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To select a series color, use one of the following procedures:

• Select a color range on the vertical color bar, then select a specific color by 
moving the cursor around on the color square.

• Enter specific values in the hue (H), saturation (S), and brightness (B) fields.

The selected color is displayed in the Preview field. When you are satisfied with 
the color, click OK.

RGB Panel

The RGB panel of the Select Series Color dialog enables you to select a series 
color based on the red, green, and blue (RGB) content of the color.

To display the RGB panel, click the RGB tab in the Select Series Color dialog.

To select a series color, select values for the Red, Green, and Blue fields. The 
selected color is displayed in the Preview field. When you are satisfied with the 
color, click OK.

Select Series Color Field and Buttons

The Select Series Color dialog contains the following field and buttons:

Field or Button Description

Preview Displays a preview of the current selected series color.

Whichever method you choose to select a series color, the selected color is 
displayed in the Preview field. When you are satisfied with the color, click 
OK.

OK Sets the series color as shown in the Preview field, and closes the Select Series 
Color dialog.

Cancel Closes the Select Series Color dialog without selecting a series color.

Reset Resets the series color to its initial setting.
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Customizing the Color of Status Settings
MWTM enables you to customize the color of status settings in the MWTM client.

To customize status setting colors, select Status in the left pane of the Preferences 
window (Figure 11-1), select a status setting, then click Change Color. MWTM 
displays the Select Status Color dialog.

The Select Status Color dialog is composed of the following sections:

• Swatches Panel (Recommended), page 11-26

• HSB Panel, page 11-26

• RGB Panel, page 11-27

• Select Status Color Field and Buttons, page 11-27

Related Topics:

• Status Settings, page 11-20

Swatches Panel (Recommended)

The Swatches panel of the Select Status Color dialog enables you to select a status 
color from a set of color swatches. This is the recommended method for selecting 
a status color.

To display the Swatches panel, click the Swatches tab in the Select Status Color 
dialog.

To select a status color, select a swatch. The selected color is displayed in the 
Preview field. When you are satisfied with the color, click OK.

HSB Panel

The HSB panel of the Select Status Color dialog enables you to select a status 
color based on color hue, saturation, and brightness (HSB).

To display the HSB panel, click the HSB tab in the Select Status Color dialog.
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To select a status color, use one of the following procedures:

• Select a color range on the vertical color bar, then select a specific color by 
moving the cursor around on the color square.

• Enter specific values in the hue (H), saturation (S), and brightness (B) fields.

The selected color is displayed in the Preview field. When you are satisfied with 
the color, click OK.

RGB Panel

The RGB panel of the Select Status Color dialog enables you to select a status 
color based on the red, green, and blue (RGB) content of the color.

To display the RGB panel, click the RGB tab in the Select Status Color dialog.

To select a status color, select values for the Red, Green, and Blue fields. The 
selected color is displayed in the Preview field. When you are satisfied with the 
color, click OK.

Select Status Color Field and Buttons

The Select Status Color dialog contains the following field and buttons:

Field or Button Description

Preview Displays a preview of the current selected status color.

Whichever method you choose to select a status color, the selected color is 
displayed in the Preview field. When you are satisfied with the color, click 
OK.

OK Sets the status color as shown in the Preview field, and closes the Select Status 
Color dialog.

Cancel Closes the Select Status Color dialog without selecting a status color.

Reset Resets the status color to its initial setting.
11-27
Cisco Mobile Wireless Transport Manager User Guide

OL-7637-01



 

Chapter 11      Configuring MWTM for Your Network
Changing MWTM Client Preference Settings
Restoring Default Preference Settings
If you decide you do not like your modified preference settings, MWTM enables 
you to restore all preference settings to the original system default settings. To do 
so, display the Preferences window, as described in “Displaying the Preferences 
Window” section on page 11-4, then select the File > Load System Default Prefs 
menu option. MWTM restores the default settings.

Loading an Existing Preference Settings File
MWTM enables you to load an existing preference settings file. To do so, display 
the Preferences window, as described in “Displaying the Preferences Window” 
section on page 11-4, then select the File > Load menu option. MWTM displays 
the Load File Dialog: Preferences File List dialog (Figure 11-2).

Figure 11-2 Load File Dialog: Preferences File List Dialog

The Load File Dialog: Preferences File List enables you to load a specific 
preferences file, change the list of preferences files, and select one preferences file 
to be loaded automatically when the MWTM client is started.

The Load File Dialog: Preferences File List contains the following fields and 
buttons:
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Related Topics:

• Changing MWTM Client Preference Settings, page 11-3

Field or Button Description

Type Icon indicating whether the item in the table is a file or a 
folder.

Name Name of the preferences file or folder.

Last Modified Date and time the preferences file or folder was last modified.

Size (bytes) Size of the preferences file or folder, in bytes.

Number of Files
(displayed in bottom left corner)

Total number of preferences files and folders.

OK Loads the selected preferences file and closes the dialog.

To load a preference settings file, double-click it in the list, 
select it in the list and click OK, or enter the name of the file 
and click OK. MWTM loads the preference settings file, 
closes the Load File Dialog: Preferences File List dialog, and 
returns to the Preferences window.

To save any changes you made to the list of files, click OK. 
MWTM saves the changes, closes the Load File Dialog: 
Preferences File List dialog, and returns to the Preferences 
window.

Delete Deletes the selected file from the preferences file list.

Select a file and click Delete. MWTM issues an 
informational message containing the name and location of 
the deleted file.

Cancel Closes the dialog without loading a preference settings file or 
saving any changes to the preferences file list.

Help Displays online help for the dialog.
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Saving the Preference Settings File
MWTM enables you to save a specific preferences file, change the list of 
preferences files, and select one preferences file to be loaded automatically when 
the MWTM client is started.

When you are satisfied with any changes you have made to your preference 
settings, select File > Save As from the Preferences window. MWTM displays the 
Save File Dialog: Preferences File List dialog (Figure 11-3).

Figure 11-3 Save File Dialog: Preferences File List Dialog

The Save File Dialog: Preferences File List contains the following fields and 
buttons:

Field or Button Description

Type Icon indicating whether the item in the table is a file or a folder.

Name Name of the preferences file or folder.

Last Modified Date and time the preferences file or folder was last modified.

Size (bytes) Size of the preferences file or folder, in bytes.
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Related Topics:

• Changing MWTM Client Preference Settings, page 11-3

Filename Name by which you want to save the preferences file.

To save the preference settings file with a new name, use one of 
the following procedures:

• To save the file with a completely new name, enter the new 
name and click OK.

• To save the file with an existing name, overwriting an old 
preference settings file, select the name in the list and click 
OK.

MWTM saves the preference settings file with the new name, 
closes the Save File Dialog: Preferences File List dialog, and 
returns to the Preferences window.

If you create a new preferences file name, you can use any letters, 
numbers, or characters in the name that are allowed by your 
operating system. However, if you include any spaces in the new 
name, MWTM converts those spaces to dashes. For example, 
MWTM saves file “a b c” as “a-b-c”.

Number of Files
(displayed in bottom left corner)

Total number of preferences files and folders.

OK Saves any changes you made to your preferences, or to the list of 
preference files, and closes the dialog.

Delete Deletes the selected file from the preferences file list. MWTM 
issues an informational message containing the name and location 
of the deleted file.

Cancel Closes the dialog without saving the preference settings file or 
any changes to the preference settings file list.

Help Displays online help for the dialog.

Field or Button Description
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Changing MWTM System Poller Settings
MWTM provides three pollers for use in the MWTM client GUI and Web pages: 
a fast poller, a slow poller, and a status refresh poller. Each poller has default 
minimum, maximum, and default settings, but MWTM also enables you to change 
those settings. To do so, use the following procedure:

Step 1 Edit the System.properties file:

• If you installed MWTM in the default directory, /opt, then the location of the 
System.properties file is /opt/CSCOsgm/properties/System.properties.

• If you installed MWTM in a different directory, then the System.properties 
file is located in that directory.

Step 2 To change fast poller settings, change one or more of the following lines in the 
file:

# Fast poller default polling interval in seconds

FAST_POLLER_DEFAULT = 15

# Fast poller minimum polling interval in seconds

FAST_POLLER_MIN = 15

# Fast poller maximum polling interval in seconds

FAST_POLLER_MAX = 60

For example, to change the fast poller default to 30 seconds, change the 
DEFAULT line to:

FAST_POLLER_DEFAULT = 30
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Step 3 To change slow poller settings, change one or more of the following lines in the 
file:

# Slow poller default polling interval in seconds

SLOW_POLLER_DEFAULT = 60

# Slow poller minimum polling interval in seconds

SLOW_POLLER_MIN = 60

# Slow poller maximum polling interval in seconds

SLOW_POLLER_MAX = 300

For example, to change the slow poller default to 180 seconds, change the 
DEFAULT line to:

SLOW_POLLER_DEFAULT = 180

Step 4 To change status refresh poller settings, change one or more of the following lines 
in the file:

# Status refresh default interval in seconds

STATE_REFRESH_DEFAULT = 180

# Status refresh minimum interval in seconds

STATE_REFRESH_MIN = 180

# Status refresh maximum interval in seconds

STATE_REFRESH_MAX = 900

For example, to change the status refresh poller default to 300 seconds, change the 
DEFAULT line to:

STATE_REFRESH_DEFAULT = 300

Step 5 Save your changes and restart the MWTM server.
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Any changes you make take effect when you restart the MWTM server, and are 
reflected throughout the MWTM client GUI and Web pages at that time.

For each of these pollers, keep the following considerations in mind:

• If you set the minimum interval for a poller to less than 0 seconds, MWTM 
overrides that setting and resets the minimum interval to 0 seconds.

• If you set the maximum interval for a poller to less than the minimum interval, 
MWTM overrides that setting and resets the maximum interval to be equal to 
the minimum interval.

• If you set the default interval for a poller to less than the minimum interval, 
MWTM overrides that setting and resets the default interval to be equal to the 
minimum interval.

• If you set the default interval for a poller to more than the maximum interval, 
MWTM overrides that setting and resets the default interval to be equal to the 
maximum interval.

Changing the Message Display
The following sections provide information about changing the way MWTM 
displays and stores messages:

• Changing the Location of MWTM Message Log Files, page 11-34

• Changing the Size of the MWTM Message Log File, page 11-35

• Changing the Time Mode for Dates in Log Files, page 11-35

• Changing the Age of the MWTM Message Log Files, page 11-35

Changing the Location of MWTM Message Log Files
By default, all MWTM system message log files are located on the MWTM server 
at /opt/CSCOsgm/logs. To change the location of the system message log 
directory, use the mwtm msglogdir command. See the “mwtm msglogdir” 
section on page C-40 for more information.
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Changing the Size of the MWTM Message Log File
To change the size of the message log file, use the mwtm msglogsize command. 
See the “mwtm msglogsize” section on page C-41 for more information.

Changing the Time Mode for Dates in Log Files
To change the time mode for dates in log files, use the mwtm logtimemode 
command. See the “mwtm logtimemode” section on page C-34 for more 
information.

Changing the Age of the MWTM Message Log Files
To change the number of days MWTM archives system message log files before 
deleting them from the MWTM server, use the mwtm msglogage command. See 
the “mwtm msglogage” section on page C-40 for more information.

Enabling SNMP Traps (Server Only)
By default, MWTM cannot receive SNMP traps. To use SNMP traps with 
MWTM, you must first configure MWTM to receive traps.

Related Topics:

• Integrating MWTM with Other Products, page 3-44

• Viewing Network Status Information for MWTM, page 13-5

To view the current trap reception configuration for MWTM, use the following 
procedure:

Step 1 Log in as the root user, as described in the “Becoming the Root User (Server 
Only)” section on page 3-3, or as a super user, as described in the “Specifying a 
Super User (Server Only)” section on page 10-24.

Step 2 Enter the following commands:

# cd /opt/CSCOsgm/bin
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# ./mwtm trapstatus

MWTM displays the current trap reception configuration for MWTM, including:

• SNMP trap integration type:

– native—MWTM receives traps natively on a UDP port.

– hpov—MWTM receives traps using HP OpenView.

• For native, MWTM also displays the UDP port number on which MWTM 
receives traps natively.

• For hpov, MWTM also displays the location of the HP OpenView home 
directory.

• Whether the trap listener is enabled or not.

To configure MWTM to receive traps, using the following procedure:

Step 1 Log in as the root user, as described in the “Becoming the Root User (Server 
Only)” section on page 3-3, or as a super user, as described in the “Specifying a 
Super User (Server Only)” section on page 10-24.

Step 2 Enter the following commands:

# cd /opt/CSCOsgm/bin

# ./mwtm trapsetup

MWTM displays the following message and prompt:

The MWTM server must also be stopped to perform this operation.

Do you wish to continue? [n]

Step 3 Type y and press Enter. MWTM stops the MWTM server and displays the 
following prompt:

Would you like to configure MWTM to receive SNMP traps? [yes]

Step 4 Press Enter. MWTM displays the following message and prompt:
11-36
Cisco Mobile Wireless Transport Manager User Guide

OL-7637-01



 

Chapter 11      Configuring MWTM for Your Network
Enabling SNMP Traps (Server Only)
MWTM can receive traps natively on a UDP port or receive traps via 
integration with HP OpenView.

Enter SNMP trap integration type: native or hpov? [native]

• If you want MWTM to receive traps natively, press Enter. The MWTM 
installation program displays the following messages and prompt:

MWTM can receive traps natively on the standard UDP port number 162 
or on any other UDP port chosen. If another application is already 
bound to the SNMP standard trap reception port of 162, an alternate 
port number for MWTM must be specified.

UDP port number 44750 is the default alternate port.

Enter trap port number? [162]

By default, network elements send traps to port 162. To accept the default 
value, press Enter.

If your network elements have been configured to send traps to a different 
port, type that port number and press Enter.

By default, MWTM listens for traps from trap multiplexing devices and NMS 
applications on port 44750. If you want MWTM to monitor that port, and port 
162 is not available on the MWTM server device, type 44750 and press 
Enter.

If trap multiplexing devices and NMS applications in your network have been 
configured to send traps to a different port, type that port number and press 
Enter.

If you are a super user, you must specify a port number that is greater than 
1024, then press Enter.

Do not enter a non-numeric port number. If you do, you are prompted to enter 
a numeric port number.

When you select an SNMP trap port number for the MWTM server, make sure 
your routers use the same SNMP trap port number. See the description of the 
snmp-server host command in the “RAN-O Requirements” section of the 
Cisco Mobile Wireless Transport Manager Installation Guide for more 
information.
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• If you want MWTM to receive traps using HP OpenView, type hpov and press 
Enter. The MWTM installation program displays the following prompt:

Please enter location of HP OpenView home directory: [/opt/OV]

To accept the default value, press Enter; or type a different location and press 
Enter.

Step 5 MWTM confirms your choices and restarts the MWTM server.

You can change all aspects of MWTM event processing, including the size of the 
MWTM event database, the maximum length of time MWTM is to retain events, 
and the default severity and color associated with each type of event. If a new trap 
becomes available that is of interest to MWTM, you can add it to the MWTM 
event database, enabling MWTM to recognize and process the new trap. For more 
information about changing MWTM event processing, see the “Changing the Way 
MWTM Processes Events” section on page 5-26.

Limiting Traps by IP Address (Server Only)
By default, when you first install MWTM, all IP addresses are allowed to send 
traps to the MWTM server. However, MWTM enables you to limit the IP 
addresses that can send traps to the server by creating and maintaining the 
trapaccess.conf file.

You can create the trapaccess.conf file and populate it with a list of IP addresses 
that can send traps to the MWTM server. MWTM receives traps from only those 
IP addresses, plus the local host. If the file exists but is empty, MWTM receives 
traps only from the local host. (MWTM always receives traps from the local host.)

When you first install MWTM, the trapaccess.conf file does not exist and MWTM 
allows all IP addresses to send traps to the MWTM server.
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To create the trapaccess.conf file and work with the list of allowed IP addresses, 
use the following procedure:

Step 1 Log in as the root user, as described in the “Becoming the Root User (Server 
Only)” section on page 3-3, or as a super user, as described in the “Specifying a 
Super User (Server Only)” section on page 10-24.

Step 2 Enter the following command:

# cd /opt/CSCOsgm/bin

Step 3 Create the trapaccess.conf file:

• To create the trapaccess.conf file and add a client IP address to the list, enter 
the following command:

# ./mwtm trapaccess add

Enter address to add: 1.2.3.4
IP Address 1.2.3.4 added.
MWTM server must be restarted for changes to take effect.
Use the following command to restart the server:
   mwtm restart
#

• To create the trapaccess.conf file and open the file to edit it directly, enter the 
following command:

# ./mwtm trapaccess edit

The default directory for the file is located in the MWTM installation directory:

• If you installed MWTM in the default directory, /opt, then the default 
directory is /opt/CSCOsgm/etc.

• If you installed MWTM in a different directory, then the default directory is 
located in that directory.

In the trapaccess.conf file, begin all comment lines with a pound sign (#).

All other lines in the file are MWTM client IP addresses, with one address per 
line.

Wildcards (*) are allowed, as are ranges (for example, 1-100). For example, the 
address *.*.*.* allows all clients to send traps to the MWTM server.
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After you create the trapaccess.conf file, you can use the full set of 
mwtm trapaccess keywords to work with the file. See the “mwtm trapaccess” 
section on page C-86 for more details.

Any changes you make to the trapaccess.conf file take effect when you restart the 
MWTM server.

Setting the DISPLAY Variable (Client Only)
The DISPLAY variable is set as part of your login environment on Solaris/Linux. 
However, if you Telnet into a remote workstation, you must set the DISPLAY 
variable to local display. To do so, enter the following command:

# setenv DISPLAY local_ws:0.0

where local_ws is your local workstation.

If your shell does not support the setenv command, enter the following command:

# export DISPLAY=local_ws:0.0

Backing Up or Restoring MWTM Files (Server Only)
MWTM automatically backs up all MWTM data files to the MWTM installation 
directory at 1:30 AM each night.

To change the time at which MWTM automatically backs up files, log in as the 
root user and change the root crontab file.

To manually back up the MWTM data files at any time, log in as the root user, as 
described in the “Becoming the Root User (Server Only)” section on page 3-3, 
and enter the following commands:

# cd /opt/CSCOsgm/bin

# ./mwtm backup

MWTM backs up the data files in the installation directory.
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If you installed MWTM in the default directory, /opt, then the default backup 
directory is also /opt. If you installed MWTM in a different directory, then the 
default backup directory is that directory.

To change the directory in which MWTM stores its nightly backup files, log in as 
the root user, as described in the “Becoming the Root User (Server Only)” section 
on page 3-3, or as a super user, as described in the “Specifying a Super User 
(Server Only)” section on page 10-24, then enter the following commands:

# cd /opt/CSCOsgm/bin

# ./mwtm backupdir directory

where directory is the new backup directory. If the new directory does not exist, 
MWTM does not change the directory, and issues an appropriate message.

To restore the MWTM data files from the previous night’s backup, log in as the 
root user, as described in the “Becoming the Root User (Server Only)” section on 
page 3-3, and enter the following commands:

# cd /opt/CSCOsgm/bin

# ./mwtm restore

MWTM restores the data files.

Warning Do not interrupt this command. Doing so can corrupt your MWTM data files.

The mwtm restore command provides optional keywords that enable you to 
restore only selected MWTM data files, such as log files, report files, or security 
files. For more information, see the “mwtm restore” section on page C-51.
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Removing MWTM Data from the MWTM Server
There might be times when you want to remove all MWTM data from the MWTM 
server, without uninstalling the product. There are two ways to do this, both of 
which restore the MWTM server to a “clean” state, such as would exist after a new 
installation of MWTM.

To remove all MWTM data from the MWTM server, excluding message log files, 
backup files, and report files, log in as the root user, as described in the 
“Becoming the Root User (Server Only)” section on page 3-3, then enter the 
following commands:

# cd /opt/CSCOsgm/bin

# ./mwtm clean

Data removed includes all MWTM data, notes, preferences, security settings, seed 
files, event filters, report control files, and views, as well as any user-created files 
stored in MWTM directories.

To remove all MWTM data from the MWTM server, including all view files, notes 
associated with objects, and event filters and preferences, excluding message log 
files, backup files, report files, configuration settings, and security settings, log in 
as the root user, as described in the “Becoming the Root User (Server Only)” 
section on page 3-3, then enter the following commands:

# cd /opt/CSCOsgm/bin

# ./mwtm cleandb

This command restores the MWTM server to a “clean” state, such as would exist 
after a new installation of MWTM, except for the presence of the retained files. 
Data removed includes all MWTM data, notes, preferences, route files, and views, 
as well as any user-created files stored in MWTM directories.
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To remove all MWTM data from the MWTM server, including message log files, 
backup files, and report files, log in as the root user, as described in the 
“Becoming the Root User (Server Only)” section on page 3-3, then enter the 
following commands:

# cd /opt/CSCOsgm/bin

# ./mwtm cleanall

Data removed includes all MWTM data, notes, preferences, security settings, seed 
files, event filters, report control files, views, message log files, backup files, and 
report files, as well as any user-created files stored in MWTM directories.

Configuring a Backup MWTM Server (Server Only)
MWTM enables you to configure a second MWTM server as a backup for the 
primary MWTM server. For best results, Cisco recommends that you configure 
the primary server and the backup server as backups for each other.

To configure a backup MWTM server, use the following procedure:

Step 1 Log in as the root user, as described in the “Becoming the Root User (Server 
Only)” section on page 3-3, or as a super user, as described in the “Specifying a 
Super User (Server Only)” section on page 10-24.

Step 2 Enter the following commands:

# cd /opt/CSCOsgm/bin

# ./mwtm secondaryserver hostname naming-port

where:

• hostname is the optional name of the host on which the backup MWTM server 
is installed.

• naming-port is the optional MWTM Naming Server port number for the 
backup MWTM server. The default port number is 44742.
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Note If you use the mwtm secondaryserver command to configure a backup 
MWTM server, but the primary MWTM server fails before you launch 
the MWTM client, then the MWTM client has no knowledge of the 
backup server.

Step 3 (Optional) To list the backup MWTM server that has been configured for this 
primary MWTM server, enter the following commands:

# cd /opt/CSCOsgm/bin

# ./mwtm secondaryserver list

Configuring MWTM with IOS Server Load Balancing
If a network failure causes MWTM to fail, you can no longer monitor your 
network. You can solve this potential problem by configuring a backup MWTM 
server, as detailed in the “Configuring a Backup MWTM Server (Server Only)” 
section on page 11-43. However, this solution requires a connection to the backup 
MWTM server, which might not mirror exactly the primary MWTM server.

A better solution is to use IOS Server Load Balancing (IOS SLB), which provides 
transparent failover of the MWTM client connection.

Use the following procedure to configure MWTM with IOS SLB:

Step 1 Make sure you have the following required hardware and software:

• Solaris/Linux server with at least two network interface cards (NICs)

• Cisco 7204VXR or 7206VXR series router

• IOS SLB release 12.1(11b)E or later

• MWTM release 5.0 or later

Step 2 Configure the Solaris/Linux server with at least two active NICs.
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Step 3 Configure a routing protocol on the Solaris/Linux server, such that if one network 
interface fails, the other interfaces can still contact the monitored networks and 
the MWTM client:

• Run in.routed on the Solaris/Linux server, with two RIP-based routers on 
two separate networks providing routing tables for the server. Refer to the 
in.routed man page for more information on this configuration.

• Use the GateD routing software developed by NextHop Technologies. Refer 
to the following URL for more information:

http://www.gated.org

Step 4 Configure the Cisco 7204VXR or 7206VXR series router, with the Solaris/Linux 
server network interfaces configured as real servers in the server farm. Refer to 
the IOS SLB feature module for more information on configuring the IOS SLB 
router.

Step 5 Configure a virtual interface, lo0:1 with the Internet address that matches the 
virtual IP address configured on the IOS SLB router:

ifconfig lo0:1 addif ip-address

Step 6 Install MWTM.

Step 7 Edit the /opt/CSCOsgm/properties/System.properties file, and replace the 
SERVER NAME variable with the DNS entry that matches the virtual IP address 
configured on the IOS SLB router. Save your changes and restart the MWTM 
server.

Step 8 Configure your MWTM clients to match the same DNS entry.

Step 9 Your configuration is complete.

Keep in mind the following considerations:

• Failover of the MWTM client is transparent to the user. There are no 
additional changes needed at that end.

• A failure of either interface, or of the surrounding networks, might cause the 
MWTM client to hang for a short period, depending on the convergence of 
the routing protocol used by the MWTM server. For example, with RIP, the 
MWTM client might hang for up to two minutes while RIP converges after a 
network failure. Faster protocols might result in shorter MWTM client hang 
times.
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Configuring an MWTM Client Connection Timer
MWTM enables you to specify how long an MWTM client is to wait for the 
MWTM server before exiting.

To configure an MWTM client connection timer, use the following procedure:

Step 1 Log in as the root user, as described in the “Becoming the Root User (Server 
Only)” section on page 3-3, or as a super user, as described in the “Specifying a 
Super User (Server Only)” section on page 10-24.

Step 2 Enter the following commands:

# cd /opt/CSCOsgm/bin

# ./mwtm cliconntimer number-of-seconds

where number-of-seconds is the time the MWTM client is to wait for a message 
from the MWTM server before exiting. The valid range is 10 seconds to an 
unlimited number of seconds. The default value is 60 seconds.

If the timer expires, the client pings the server and takes the following action:

• If the server responds to the ping, the client reconnects to the server.

• If the server does not respond to the ping, but there is a backup server 
configured, the client connects to the backup server.

• If the server does not respond to the ping, and there is no backup server 
configured, the client stops.

The timer takes effect when you restart the MWTM server.

Step 3 (Optional) To restore the default timeout of 60 seconds, enter the following 
command:

# ./mwtm cliconntimer clear

The timer is reset to 60 seconds when you restart the MWTM server.
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Telnetting to a Router
MWTM enables you to link to a router using Telnet.

To Telnet to a router, right-click a node in a window, then select Router > Telnet 
to from the right-click menu.

Note If your client workstation does not have network access to the IP address of the 
router (that is, if the router is behind a firewall or NAT device), you might be 
unable to Telnet to the router.

To specify the path to the Telnet application to use for Telnet sessions on the 
MWTM client, as well as any special parameters to pass to the Telnet application, 
use the mwtm telnetpath command.

To manage a Telnet proxy, use the mwtm tnproxy command.

See the “MWTM Command Reference” section on page C-1 for more information 
on the use of these commands.
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Troubleshooting MWTM and the 
Network

This chapter provides the following information for troubleshooting basic 
MWTM and network problems:

• Clearing a Locked-Up MWTM Display, page 12-2

• Investigating Data Problems, page 12-2

• Understanding MWTM Client Start Error Messages, page 12-2

• Checking MWTM Server Start Processes, page 12-4

• Viewing the MWTM Troubleshooting Log, page 12-5

• Viewing MWTM Data on the Web, page 12-6

• Viewing Detailed Troubleshooting Instructions for Events, page 12-6

• Diagnosing a Typical Network Problem, page 12-6
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Clearing a Locked-Up MWTM Display
In MWTM, events might cause message popups to remain in the background of 
your display, preventing you from interacting with other windows. If you suspect 
that your display has locked up, perform the following tasks:

• Make sure you are running MWTM on a supported operating system. For 
details on supported operating systems, see Chapter 1, “Preparing to Install 
MWTM” in the Cisco Mobile Wireless Transport Manager Installation 
Guide.

• Minimize windows and look for an MWTM message popup in the 
background.

Investigating Data Problems
If you suspect that there are problems with the data that MWTM is displaying, 
perform the following tasks:

• Enter equivalent show commands on the router. Is the data the same as that 
displayed by MWTM?

• Send SNMP queries to the nodes. Do all queries complete?

The results of these tasks can help you distinguish between a router problem and 
an MWTM problem.

Understanding MWTM Client Start Error Messages
If you encounter one of the following errors upon starting the MWTM client, 
follow the procedures below:

• DataModelMediatorService: Could not find service in RMI registry or the 
RMI Registry may be down.

• DemandPollerManagerService: Could not find service in RMI registry or the 
RMI registry may be down. Check the MWTM server and make sure it is 
running.
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Data Model Mediator Service Error
If you have received the following message: “DataModelMediatorService: Could 
not find service in RMI registry or the RMI Registry may be down” either you 
have specified an incorrect port number when installing MWTM, or the server or 
RMI registry is unavailable. 

To correct this problem, use the following procedure:

Step 1 Verify that you specified a correct port number.

Step 2 Enter the mwtm status command on the server to determine the status of all 
MWTM servers on the local host.

Step 3 Enter the mwtm restart command to restart any servers that are not running.

Demand Poller Manager Service Error
If you have received the following message: “DemandPollerManagerService: 
Could not find service in RMI registry or the RMI registry may be down. Check 
the MWTM server and make sure it is running” one or more of the MWTM server 
processes may not have started. 

To diagnose and correct this problem, use the following procedure:

Step 1 Enter the mwtm status command on the server to determine the status of all 
MWTM processes.

Check the output to see if the sgmDataServer and sgmTrapReceiver processes do 
not appear in the Ready state. They may appear as follows:

PROCESS STATE    PID Last Message

sgmDataServer Starting 2586 Starting EventModelMediatorService
sgmMsgLogServer Ready    2551 Running
sgmTrapReceiver Initial 

Step 2 If the processes are not all in a Ready state, search the following log file 
/opt/CSCOsgm/logs/messageLog.txt for the following error message:
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A java.IO.EOFException was encountered against the 
persisted.server.data file.

Step 3 Enter the mwtm cleandb command on the server, which will restore the 
persisted.server.data file to a valid state. The output should now show all 
processes running, as follows:

PROCESS STATE PID Last Message

sgmDataServer Ready 2586 Running
sgmMsgLogServer Ready 2551 Running
sgmTrapReceiver Ready 2600 Running

Step 4 Start the MWTM client, then re-discover the network (for details, see Chapter 2, 
“Discovering Your RAN-O Networks Using MWTM.”)

Checking MWTM Server Start Processes
When you run the mwtm start command, normal output appears as follows:

PROCESS STATE PID Last Message

sgmDataServer Ready 2586 Running
sgmMsgLogServer Ready 2551 Running
sgmTrapReceiver Ready 2600 Running

If the sgmDataServer and sgmTrapReceiver process do not appear in the Ready 
state, see the “Demand Poller Manager Service Error” section on page 12-3 for 
details on fixing this issue.
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Viewing the MWTM Troubleshooting Log
MWTM stores troubleshooting information in the 
/opt/CSCOsgm/tmp/cisco_sgm_tshoot.log file on the MWTM server. This log, 
which is updated each time the MWTM Server Troubleshooting page is accessed 
or the mwtm tac command is run, contains information that might be requested 
by Cisco customer support personnel.

If you want to view the MWTM troubleshooting log, Cisco strongly recommends 
that you do so in a Web browser. To view the log in a Web browser, select System 
Troubleshooting from the MWTM Server Home Page.

You can also view the log from the command line, but this method displays the 
entire log, which can contain thousands of lines of output, line-by-line on your 
workstation screen. Therefore, Cisco strongly recommends that you view the log 
from the Web, as indicated above. However, if you are viewing the log at the 
request of the Cisco Technical Assistance Center (TAC), it is best to view the log 
from the command line.

To view the log from the command line:

Step 1 Log in as the root user, as described in the “Becoming the Root User (Server 
Only)” section on page 3-3, or as a super user, as described in the “Specifying a 
Super User (Server Only)” section on page 10-24.

Step 2 Enter the following commands:

# cd /opt/CSCOsgm/bin

# ./mwtm tac

This command might take a minute or more to complete. When it completes, 
MWTM displays the following message and prompt:

Output is in /opt/CSCOsgm/tmp/cisco_sgm_tshoot.log

Would you like to view it? [y]

Step 3 Press Enter. MWTM displays the contents of the 
/opt/CSCOsgm/tmp/cisco_sgm_tshoot.log file.
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Viewing MWTM Data on the Web
MWTM provides an enormous amount of Web-based troubleshooting 
information. From the MWTM Server Home Page, you can access many Web 
pages containing MWTM data, including server status, network status, 
installation logs, message logs, product documentation, and other important 
troubleshooting information about MWTM. For full details, see the “Accessing 
MWTM Data from a Web Browser” section on page 13-1.

Viewing Detailed Troubleshooting Instructions for 
Events

MWTM provides extensive type-specific help and troubleshooting instructions 
for events. To see help and troubleshooting instructions for an event, right-click 
the event and select Help for Event.

You can also provide your own enterprise-specific instructions to operators in the 
event help. For more information, see the “Changing the Way MWTM Processes 
Events” section on page 5-26.

Diagnosing a Typical Network Problem
When you use MWTM to diagnose a problem in a RAN-O network, follow these 
basic steps:

1. Monitor the network using the MWTM Main Window and the Topology 
Window. For example, an object in the topology map that changes color from 
green to yellow or red indicates a problem in the network.

2. Use MWTM windows, especially the Details window, to begin investigating 
the problem.

3. As you identify the source of the problem, examine the messages logged by 
MWTM for more detailed information about the sequence of events that led 
to the problem.

4. Telnet to the problematic router, if necessary.
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The following real-life example provides detailed information about using 
MWTM to diagnose a problem in a RAN-O network:

Step 1 A network operator (we’ll call him Joe) is using MWTM to monitor a RAN-O 
network. Joe has customized his view, limiting it to only those nodes for which he 
is responsible. 

(For more information about customizing views, see the “Working with Views” 
section on page 4-1.)

Step 2 In the topology map, Joe notices a node that has changed color from green to 
yellow. Yellow indicates a status of Warning, which means that one or more 
interfaces associated with that node is in Unknown or Warning status and is not 
flagged as Ignored. 

(For more information about node status, see the “Node Table” section on 
page 6-9.)

Step 3 Joe single-clicks the node in the topology map.  

MWTM highlights the node in the topology map and in the topology view table 
in the left pane of the Topology Window.  With the node highlighted, Joe can 
easily see that the name of the node is BTS-1941a.  

MWTM also displays all associated interfaces in the topology Connections table. 

Joe clicks the node's name and the zoom button in the topology view table.  

MWTM redraws the topology map, centered on BTS-1941a, making it easier for 
Joe to see the relevant portion of the map. 

(For more information about the Topology Window and how to use it, see the 
“Viewing the Topology of the Network” section on page 8-1.)

Step 4 Joe notices that one of BTS-1941a’s diamonds is red, indicating that the 
associated interface is either Unavailable or Unknown.  Joe single-clicks the red 
diamond.  

MWTM highlights the connection in the topology map and in the topology 
Connections table.  The table entry indicates that the connection is Unavailable. 

Step 5 Joe right-clicks the connection in the topology map and selects View > 
Configuration Details in the right-click menu.  
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MWTM opens the Details window (in the main MWTM window), showing 
detailed information for the connection.  In the Details window, detailed 
information for the selected connection is displayed in the Configuration Data 
section.  

Immediately, Joe sees that the Operational Status is Down but notices that the 
Operational Status for E1 1/0 is Up.

Step 6 Joe selects the Recent Events tab and notices that a Critical Alarm for E1 1/0 was 
recently added.  

Joe logs into the BTS-1941a device (right-click on device name and select Router 
> Telnet To) and runs the show controller E1 1/0 command.  He learns that the 
device recently loss physical connectivity.

Step 7 Joe goes to the device and discovers that the cable is physically damaged.  He 
replaces the cable and returns to the MWTM server.

Step 8 Joe views the MWTM main window and observes that MWTM has already polled 
the device and changed the state color from yellow to green.  

Step 9 Joe looks at the MWTM topology window again and verifies the interface status 
has changed from yellow to green.
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Accessing MWTM Data from a 
Web Browser

This chapter provides information about accessing MWTM data from the MWTM 
Server Home Page, using a Web browser.

This chapter includes the following sections:

• Accessing MWTM Data from the MWTM Server Home Page, page 13-2

• Changing MWTM Web Output (Server Only), page 13-4

• Viewing Network Status Information for MWTM, page 13-5

• Viewing MWTM System Messages, page 13-30

• Viewing Statistics Reports, page 13-48

• Viewing System Status Information for MWTM, page 13-48

• Viewing System Data Files for MWTM, page 13-53

• Viewing System Information for MWTM, page 13-54

• Viewing the MWTM Technical Documentation, page 13-55

• Downloading the MWTM Client from the Web, page 13-56

• Downloading the MWTM Server’s SSL Certificate from the Web, page 13-56

• Accessing Software Updates and Additional Information, page 13-57
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Accessing MWTM Data from the MWTM Server 
Home Page

From the MWTM Server Home Page, you can access many Web pages containing 
MWTM data, including server status, network status, installation logs, message 
logs, product documentation, Cisco.com, and other information about MWTM. 
You can also download the MWTM clients.

To access the MWTM Server Home page, use one of the following procedures:

• Select View > MWTM Server > Home Page from the MWTM Main Menu.

• Enter the following URL in a Web browser:

http://server_name:1774

Where server_name is the name or IP address of the server on which the 
MWTM server is running and 1774 is the Web port being using by MWTM. 
(1774 is the default port number.) If you do not know the name or Web port 
of the MWTM Web Server, contact the system administrator who installed the 
MWTM server software.

• Select Home from the menu bar of any of the MWTM Web pages.

The MWTM Server Home Page (Figure 13-1) is displayed.
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Figure 13-1 MWTM Server Home Page

The rest of this chapter provides detailed information about the MWTM 
information you can access from the MWTM Server Home Page.
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Changing MWTM Web Output (Server Only)
MWTM enables you to change the following aspects of its Web output:

• To control how often, in seconds, MWTM updates certain Web output, use the 
mwtm weblogupdate command. The valid range is 1 second to an unlimited 
number of seconds. The default value is 300 seconds (5  minutes).

• To set the maximum number of rows for MWTM ASCII Web output, such as 
displays of detailed debugging information, use the mwtm maxasciirows 
command. The valid range is 1 row to an unlimited number of rows. The 
default value is 6000 rows.

• To set the maximum number of rows for MWTM to search in the event history 
logs, use the mwtm maxevhist command. The event history logs are the 
current and archived MWTM network status logs for status change and 
SNMP trap messages. MWTM sends the results of the search to the Web 
browser, where the results are further limited by the setting of the mwtm 
maxhtmlrows command. The valid range is 1 row to an unlimited number of 
rows. The default value is 15000 rows.

• To set the maximum number of rows for MWTM HTML Web output, such as 
displays of statistics reports, status change messages, or SNMP trap 
messages, use the mwtm maxhtmlrows command. The valid range is 1 row 
to an unlimited number of rows. The default value is 200 rows.

• To specify whether MWTM is to show real node names or display names in 
Web pages, enter the mwtm webnames command:

– To show the real DNS names of nodes, as discovered by MWTM, enter 
mwtm webnames real.

– To show display names, enter mwtm webnames display. Display names 
are new names that you specify for nodes. This is the default setting. For 
more information about display names, see the “Editing a Node” section 
on page 6-53.

• To specify whether MWTM is to display send and receive utilization for 
interfaces as percentages or in Erlangs in Web pages, enter the mwtm webutil 
command:

– To display utilization as a percentage, enter mwtm webutil percent. This 
is the default setting.

– To show display utilization in Erlangs, enter mwtm webutil erlangs.
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See the “Working with MWTM Statistics Reports” section on page 9-1 for 
more information on send and receive utilization for interfaces.

Each of these commands requires you to be logged in as the root user, as described 
in the “Becoming the Root User (Server Only)” section on page 3-3, or as a super 
user, as described in the “Specifying a Super User (Server Only)” section on 
page 10-24.

Viewing Network Status Information for MWTM
You can view the following MWTM network status information from the MWTM 
Server Home Page:

• Viewing Node Information Using a Web Browser, page 6-69

• Viewing Status Change and SNMP Trap Messages, page 13-5

• Viewing Network Status Metrics, page 13-23

Viewing Status Change and SNMP Trap Messages
MWTM enables you to view the following status change and SNMP trap 
messages:

• Viewing Status Change and SNMP Trap Messages for MWTM, page 13-6

• Viewing Status Change Messages for MWTM, page 13-11

• Viewing SNMP Trap Messages for MWTM, page 13-14

• Viewing All Archived Status Change and SNMP Trap Messages, page 13-18

• Viewing Archived Status Change and SNMP Trap Messages for a Specific 
Date, page 13-19

• Changing Network Status Message Colors, page 13-22
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Viewing Status Change and SNMP Trap Messages for MWTM

The Network Status: Last X Status Change and Trap Messages page displays 
status change messages and SNMP trap messages in the MWTM network log.

To access the Network Status: Last X Status Change and Trap Messages page and 
display all status change and trap messages, use one of the following procedures:

• Select View > Event History > Status and Trap Messages from the MWTM 
Main Menu.

• Select Status & SNMP Trap Messages from the MWTM Server Home Page.

To access the Network Status: Last X Status Change and Trap Messages page and 
display status change and trap messages for a specific object, right-click the 
object in a window, then select Event History > Status and Trap Messages from 
the right-click menu.

MWTM displays the Network Status: Last X Status Change and Trap Messages 
page (Figure 13-2).

Figure 13-2 Network Status: Last X Status Change and Trap Messages Page
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The Network Status: Last X Status Change and Trap Messages page is composed 
of the following sections:

• Last Status Change and Trap Messages Menus, page 13-7

• Last Status Change and Trap Messages Table, page 13-9

Related Topic

• Viewing Status Change and SNMP Trap Messages for MWTM

Last Status Change and Trap Messages Menus

The Network Status: Last X Status Change and Trap Messages page provides 
additional menu options. These additional menu options enable you to filter the 
information displayed on the page, including displaying only messages of a 
specific type in the Last Status Change and Trap Messages table. (By default, 
MWTM displays status change and SNMP trap messages of all types in the table.) 
The following table describes the additional menu options provided by the 
Network Status: Last X Status Change and Trap Messages page:

Menu 
Command Description

10/Page Displays 10 rows in the table.

20/Page Displays 20 rows in the table.

50/Page Displays 50 rows in the table.

100/Page Displays 100 rows in the table.

300/Page Displays 300 rows in the table.

500/Page Displays 500 rows in the table.

Max/Page Displays up to 15,000 rows in the table.

Note Depending on the number of rows, this could take up to 15 minutes.

DefPrefs Resets the /Page preferences for this Web page to the default settings for the MWTM 
server.

Pause

or

Resume

Pauses or resumes the table.

While the table is paused, MWTM does not display new events in the table (unless 
you apply an event filter or edit your event preferences). When the table is resumed, 
all new events since the table was paused are added to the display.
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Critical Displays only critical messages. MWTM displays administrative messages with a red 
background.

Major Displays only major messages. MWTM displays warning messages with an orange 
background.

Minor Displays only minor messages. MWTM displays normal messages with a yellow 
background.

Warning Displays only warning messages. MWTM displays administrative messages with a 
blue background.

Informational Displays only informational messages. MWTM displays error messages with an 
white background.

Admin Displays only administrative messages. MWTM displays administrative messages 
with a white background.

Error Displays only error messages. MWTM displays administrative messages with a cyan 
background.

Normal Displays only normal messages. MWTM displays administrative messages with a 
green background.

Indeterminate Displays only messages that do not fall into one of the above classifications. MWTM 
displays indeterminate messages with a white background.

All Displays all status change and SNMP trap messages.

Menu 
Command Description
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Last Status Change and Trap Messages Table

The list of messages displayed in the Last Status Change and Trap Messages table 
is continually refreshed as new messages are received.

• To pause the message display, select Pause from the menu bar.

• To resume the message display, select Resume from the menu bar.

The Last Status Change and Trap Messages table contains the following columns:

Column Description

Offset
(in title)

Displays the number of rows in the table, prior to the first displayed row. For 
example, if the first displayed row is 501, the Offset is 500.

Severity
(in header)

Message severity currently being displayed.

Update Interval
(in header)

Time between automatic updates for the page.

Timestamp
(in header)

Date and time the information on the page was last updated by MWTM.

Row Unique number identifying each entry in the table. You cannot edit this field.

Time Date and time the message was logged.

To sort the messages by time, click the Time header.

To see only messages for a specific date, click the year/month/date string in 
the timestamp.

To see only messages for a specific hour, click the hour string in the 
timestamp.

To see only messages for a specific hour and minute, click the minute string 
in the timestamp.

Type Type of message:

• Status—Status change message

• Trap—SNMP trap message

To sort the messages by type, click the Type header.

Message Text of the message.

To sort the messages alphabetically by message text, click the Message header.
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First
(at bottom of table)

Displays the first page of entries for the table.

For example, if the table is sorted by Time in descending order, clicking this 
field displays the newest entries.

You cannot click this field if the first page of entries is already displayed.

Previous (Rows)
(at bottom of table)

Displays the previous page of entries for the table.

You cannot click this field if the first page of entries is already displayed.

Next (Rows)
(at bottom of table)

Displays the next page of entries for the table.

You cannot click this field if the last page of entries is already displayed.

Last
(at bottom of table)

Displays the last page of entries for the table.

For example, if the table is sorted by Time in descending order, clicking this 
field displays the oldest entries.

You cannot click this field if the last page of entries is already displayed.

Total
(at bottom of table)

Displays the total number of entries in the table.

Column Description
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Viewing Status Change Messages for MWTM

The Network Status: Last X Status Change Messages page displays status change 
messages in the MWTM network log.

To access the Network Status: Last X Status Change Messages page and display 
all status change messages, use one of the following procedures:

• Select View > Event History > Status Changes from the MWTM Main 
Menu.

• Select Status Change Messages from the MWTM Server Home Page.

To access the Network Status: Last X Status Change Messages page and display 
status change messages for a specific object, right-click the object in a window, 
then select Event History > Status Change Messages from the right-click menu.

The Network Status: Last X Status Change Messages page is composed of the 
following sections:

• Last Status Change Messages Menus, page 13-11

• Last Status Change Messages Table, page 13-13

Last Status Change Messages Menus

The Network Status: Last X Status Change Messages page provides additional 
menu options. These additional menu options enable you to filter the information 
displayed on the page, including displaying only messages of a specific type in 
the Last Status Change Messages table. (By default, MWTM displays status 
change messages of all types in the table.) The following table describes the 
additional menu options provided by the Network Status: Last X Status Change 
Messages page:

Menu Command Description

10/Page Displays 10 rows in the table.

20/Page Displays 20 rows in the table.

50/Page Displays 50 rows in the table.

100/Page Displays 100 rows in the table.

300/Page Displays 300 rows in the table.

500/Page Displays 500 rows in the table.
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Max/Page Displays up to 15,000 rows in the table.

Note Depending on the number of rows, this could take up to 15 minutes.

DefPrefs Resets the /Page preferences for this Web page to the default settings for the 
MWTM server.

Pause

or

Resume

Pauses or resumes the table.

While the table is paused, MWTM does not display new events in the table (unless 
you apply an event filter or edit your event preferences). When the table is resumed, 
all new events since the table was paused are added to the display.

Critical Displays only critical messages. MWTM displays administrative messages with a 
red background.

Major Displays only major messages. MWTM displays warning messages with an orange 
background.

Minor Displays only minor messages. MWTM displays normal messages with a yellow 
background.

Warning Displays only warning messages. MWTM displays administrative messages with a 
blue background.

Informational Displays only informational messages. MWTM displays error messages with an 
white background.

Admin Displays only administrative messages. MWTM displays administrative messages 
with a white background.

Error Displays only error messages. MWTM displays administrative messages with a 
cyan background.

Normal Displays only normal messages. MWTM displays administrative messages with a 
green background.

Indeterminate Displays only messages that do not fall into one of the above classifications. 
MWTM displays indeterminate messages with a white background.

All Displays all status change and SNMP trap messages.

Menu Command Description
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Last Status Change Messages Table

The list of messages displayed in the Last Status Change Messages table is 
continually refreshed as new messages are received.

• To pause the message display, select Pause from the menu bar.

• To resume the message display, select Resume from the menu bar.

The Last Status Change Messages table contains the following columns:

Column Description

Offset
(in title)

Displays the number of rows in the table, prior to the first displayed row. For 
example, if the first displayed row is 501, the Offset is 500.

Severity
(in header)

Message severity currently being displayed.

Update Interval
(in header)

Time between automatic updates for the page.

Timestamp
(in header)

Date and time the information on the page was last updated by MWTM.

Row Unique number identifying each entry in the table. You cannot edit this field.

Time Date and time the message was logged.

To sort the messages by time, click the Time header.

To see only messages for a specific date, click the year/month/date string in 
the timestamp.

To see only messages for a specific hour, click the hour string in the 
timestamp.

To see only messages for a specific hour and minute, click the minute string 
in the timestamp.

Message Text of the message.

To sort the messages alphabetically by message text, click the Message header.

First
(at bottom of table)

Displays the first page of entries for the table.

For example, if the table is sorted by Time in descending order, clicking this 
field displays the newest entries.

You cannot click this field if the first page of entries is already displayed.
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Viewing SNMP Trap Messages for MWTM

The Network Status: Last X SNMP Trap Messages page displays SNMP trap 
messages in the MWTM network log.

To access the Network Status: Last X SNMP Trap Messages page and display all 
SNMP trap messages, use one of the following procedures:

• Select View > Event History > SNMP Trap Messages from the MWTM 
Main Menu.

• Select SNMP Trap Messages from the MWTM Server Home Page.

To access the Network Status: Last X SNMP Trap Messages page and display 
SNMP trap messages for a specific object, right-click the object in a window, then 
select Event History > SNMP Trap Messages from the right-click menu.

The Network Status: Last X SNMP Trap Messages page is composed of the 
following sections:

• Last SNMP Trap Messages Menus, page 13-15

• Last SNMP Trap Messages Table, page 13-16

Previous (Rows)
(at bottom of table)

Displays the previous page of entries for the table.

You cannot click this field if the first page of entries is already displayed.

Next (Rows)
(at bottom of table)

Displays the next page of entries for the table.

You cannot click this field if the last page of entries is already displayed.

Last
(at bottom of table)

Displays the last page of entries for the table.

For example, if the table is sorted by Time in descending order, clicking this 
field displays the oldest entries.

You cannot click this field if the last page of entries is already displayed.

Total
(at bottom of table)

Displays the total number of entries in the table.

Column Description
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Last SNMP Trap Messages Menus

The Network Status: Last X SNMP Trap Messages page provides additional menu 
options. These additional menu options enable you to filter the information 
displayed on the page, including displaying only messages of a specific type in 
the Last SNMP Trap Messages table. (By default, MWTM displays SNMP trap 
messages of all types in the table.) The following table describes the additional 
menu options provided by the Network Status: Last X SNMP Trap Messages 
page:

Menu Command Description

10/Page Displays 10 rows in the table.

20/Page Displays 20 rows in the table.

50/Page Displays 50 rows in the table.

100/Page Displays 100 rows in the table.

300/Page Displays 300 rows in the table.

500/Page Displays 500 rows in the table.

Max/Page Displays up to 15,000 rows in the table.

Note Depending on the number of rows, this could take up to 15 minutes.

DefPrefs Resets the /Page preferences for this Web page to the default settings for the 
MWTM server.

Pause

or

Resume

Pauses or resumes the table.

While the table is paused, MWTM does not display new events in the table (unless 
you apply an event filter or edit your event preferences). When the table is resumed, 
all new events since the table was paused are added to the display.

Critical Displays only critical messages. MWTM displays administrative messages with a 
red background.

Major Displays only major messages. MWTM displays warning messages with an orange 
background.

Minor Displays only minor messages. MWTM displays normal messages with a yellow 
background.

Warning Displays only warning messages. MWTM displays administrative messages with a 
blue background.
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Last SNMP Trap Messages Table

The list of messages displayed in the Last SNMP Trap Messages table is 
continually refreshed as new messages are received.

• To pause the message display, select Pause from the menu bar.

• To resume the message display, select Resume from the menu bar.

The Last SNMP Trap Messages table contains the following columns:

Informational Displays only informational messages. MWTM displays error messages with an 
white background.

Admin Displays only administrative messages. MWTM displays administrative messages 
with a white background.

Error Displays only error messages. MWTM displays administrative messages with a 
cyan background.

Normal Displays only normal messages. MWTM displays administrative messages with a 
green background.

Indeterminate Displays only messages that do not fall into one of the above classifications. 
MWTM displays indeterminate messages with a white background.

All Displays all status change and SNMP trap messages.

Menu Command Description

Column Description

Offset
(in title)

Displays the number of rows in the table, prior to the first displayed row. For 
example, if the first displayed row is 501, the Offset is 500.

Severity
(in header)

Message severity currently being displayed.

Update Interval
(in header)

Time between automatic updates for the page.

Timestamp
(in header)

Date and time the information on the page was last updated by MWTM.

Row Unique number identifying each entry in the table. You cannot edit this field.
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Time Date and time the message was logged.

To sort the messages by time, click the Time header.

To see only messages for a specific date, click the year/month/date string in 
the timestamp.

To see only messages for a specific hour, click the hour string in the 
timestamp.

To see only messages for a specific hour and minute, click the minute string 
in the timestamp.

Node Node that sent the trap.

To see only SNMP trap messages for that node, click the node name.

Message Text of the message.

First
(at bottom of table)

Displays the first page of entries for the table.

For example, if the table is sorted by Time in descending order, clicking this 
field displays the newest entries.

You cannot click this field if the first page of entries is already displayed.

Previous (Rows)
(at bottom of table)

Displays the previous page of entries for the table.

You cannot click this field if the first page of entries is already displayed.

Next (Rows)
(at bottom of table)

Displays the next page of entries for the table.

You cannot click this field if the last page of entries is already displayed.

Last
(at bottom of table)

Displays the last page of entries for the table.

For example, if the table is sorted by Time in descending order, clicking this 
field displays the oldest entries.

You cannot click this field if the last page of entries is already displayed.

Total
(at bottom of table)

Displays the total number of entries in the table.

Column Description
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Viewing All Archived Status Change and SNMP Trap Messages

The Network Status Daily Archives: Status and SNMP Trap Messages page 
displays all archived status change and SNMP trap messages.

To access the Network Status Daily Archives: Status and SNMP Trap Messages 
page, use one of the following procedures:

• Select View > Event History > Network Status Archives from the MWTM 
Main Menu.

• Select Network Status Daily Archives from the MWTM Server Home Page.

The Network Status Daily Archives: Status and SNMP Trap Messages page 
provides the following menu options:

On the Network Status Daily Archives: Status and SNMP Trap Messages page, 
messages are archived by timestamp. MWTM automatically archives the 
messages at 1:30 AM each night; each archived file contains messages from a 
single calendar day.

To view archived messages, click a timestamp. MWTM displays the Network 
Status Archive: Last X Status Change and Trap Messages Page for that timestamp. 
See the “Viewing Archived Status Change and SNMP Trap Messages for a 
Specific Date” section on page 13-19 for more information.

Menu Command Description

Home Opens the MWTM Server Home Page.

Current Status + Trap Opens the Network Status: Last X Status Change and Trap Messages Web 
page.

Current Status Opens the Network Status: Last X Status Change Messages Web page.

Current Trap Opens the Network Status: Last X SNMP Trap Messages Web page.

Archives Opens the Network Status Daily Archives: Status and SNMP Trap 
Messages Web page.

Metrics Opens the Network Status Messages: Metrics Web page.

Dashboard Opens the MWTM Network Status Log: Dashboard Web page.

Help Opens an online help window for the current Web page.
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Viewing Archived Status Change and SNMP Trap Messages for a Specific Date

From the Network Status Archive: Last X Status Change and Trap Messages page, 
you can view all archived status change and SNMP trap messages for a specified 
date.

To access the Network Status Archive: Last X Status Change and Trap Messages 
page, click a date on the Network Status Daily Archives: Status and SNMP Trap 
Messages page. MWTM displays the archived messages for that timestamp.

The Network Status Archive: Last X Status Change and Trap Messages page is 
composed of the following sections:

• Last Status Change and Trap Messages Menus, page 13-19

• Last Status Change and Trap Messages Table, page 13-21

Last Status Change and Trap Messages Menus

The Network Status Archive: Last X Status Change and Trap Messages page 
provides additional menu options. These additional menu options enable you to 
filter the information displayed on the page, including displaying only messages 
of a specific type in the Last Status Change and Trap Messages table. (By default, 
MWTM displays status change and SNMP trap messages of all types in the table.) 
The following table describes the additional menu options provided by the 
Network Status Archive: Last X Status Change and Trap Messages page:

Menu 
Command Description

10/Page Displays 10 rows in the table.

20/Page Displays 20 rows in the table.

50/Page Displays 50 rows in the table.

100/Page Displays 100 rows in the table.

300/Page Displays 300 rows in the table.

500/Page Displays 500 rows in the table.

Max/Page Displays up to 15,000 rows in the table.

Note Depending on the number of rows, this could take up to 15 minutes.
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DefPrefs Resets the /Page preferences for this Web page to the default settings for the MWTM 
server.

Pause

or

Resume

Pauses or resumes the table.

While the table is paused, MWTM does not display new events in the table (unless you 
apply an event filter or edit your event preferences). When the table is resumed, all new 
events since the table was paused are added to the display.

Critical Displays only critical messages. MWTM displays administrative messages with a red 
background.

Major Displays only major messages. MWTM displays warning messages with an orange 
background.

Minor Displays only minor messages. MWTM displays normal messages with a yellow 
background.

Warning Displays only warning messages. MWTM displays administrative messages with a 
blue background.

Informationa
l

Displays only informational messages. MWTM displays error messages with an white 
background.

Admin Displays only administrative messages. MWTM displays administrative messages 
with a white background.

Error Displays only error messages. MWTM displays administrative messages with a cyan 
background.

Normal Displays only normal messages. MWTM displays administrative messages with a 
green background.

Indeterminat
e

Displays only messages that do not fall into one of the above classifications. MWTM 
displays indeterminate messages with a white background.

All Displays all status change and SNMP trap messages.

Menu 
Command Description
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Last Status Change and Trap Messages Table

The Last Status Change and Trap Messages table contains the following columns:

Column Description

Offset
(in title)

Displays the number of rows in the table, prior to the first displayed row. For 
example, if the first displayed row is 501, the Offset is 500.

Date of the Archive
(in header)

Date the information in the table was archived.

Severity
(in header)

Message severity displayed in the table.

Timestamp
(in header)

Date and time the page was displayed.

Row Unique number identifying each entry in the table. You cannot edit this field.

Time Date and time the message was logged.

To sort the messages by time, click the Time header.

To see only messages for a specific date, click the year/month/date string in 
the timestamp.

To see only messages for a specific hour, click the hour string in the 
timestamp.

To see only messages for a specific hour and minute, click the minute string 
in the timestamp.

Type Type of message:

• Status—Status change message

• Trap—SNMP trap message

To sort the messages by type, click the Type header.

Message Text of the message.

To sort the messages alphabetically by message text, click the Message header.

First
(at bottom of table)

Displays the first page of entries for the table.

For example, if the table is sorted by Time in descending order, clicking this 
field displays the newest entries.

You cannot click this field if the first page of entries is already displayed.
13-21
Cisco Mobile Wireless Transport Manager User Guide

OL-7637-01



 

Chapter 13      Accessing MWTM Data from a Web Browser
Viewing Network Status Information for MWTM
Changing Network Status Message Colors

By default, MWTM displays network status messages with the following 
background colors:

• Informational—white background

• Normal—green background

• Indeterminate—cyan background

• Warning—blue background

• Critical—red background

• Minor—yellow background

• Major—orange background

• Unclassified—white background

For information about customizing the background colors for network status 
messages, see the “Changing Event Severities and Colors” section on page 5-35.

Previous (Rows)
(at bottom of table)

Displays the previous page of entries for the table.

You cannot click this field if the first page of entries is already displayed.

Next (Rows)
(at bottom of table)

Displays the next page of entries for the table.

You cannot click this field if the last page of entries is already displayed.

Last
(at bottom of table)

Displays the last page of entries for the table.

For example, if the table is sorted by Time in descending order, clicking this 
field displays the oldest entries.

You cannot click this field if the last page of entries is already displayed.

Total
(at bottom of table)

Displays the total number of entries in the table.

Column Description
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Viewing Network Status Metrics
The Network Status Messages: Metrics page displays a number of metrics for 
MWTM, based on the number of messages of each type and severity received by 
MWTM.

To access the Network Status Messages: Metrics page and display all metrics, use 
one of the following procedures:

• Select View > Event History > Network Status Metrics from the MWTM 
Main Menu.

• Select Network Status Metrics from the MWTM Server Home Page.

To access the Network Status Messages: Metrics page and display metrics for a 
specific object, right-click the object in a window, then select Event History > 
Network Status Metrics from the right-click menu.

The Network Status Messages: Metrics page is composed of the following 
sections:

• Message Types Table, page 13-24

• Message Severity Table, page 13-25

• Status Messages Table, page 13-26

• Trap Messages Table, page 13-27

• Messages/Day Table, page 13-28

• Status Change Messages/Day Table, page 13-28

• SNMP Trap Messages/Day Table, page 13-29

• Files Processed Table, page 13-29

• Date Range Table, page 13-29
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Message Types Table

The Message Types table contains the following columns:

Column Description

Message 
Types

Total number of messages of each type received by MWTM. Possible types are:

• Total Messages—Total number of messages of all types received by MWTM.

• Total Status—Total number of status change messages received by MWTM.

• Total Traps—Total number of SNMP trap messages received by MWTM.

Num Number of messages of each type received by MWTM.

Num/Total Number of messages of a given type received by MWTM, divided by the total number 
of messages received by MWTM, displayed as a percentage.
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Message Severity Table

The Message Severity table contains the following columns:

Column Description

Message 
Severity

Total number of messages (status change messages and SNMP trap messages) of each 
severity received by MWTM:

• Total Warning—Total number of Warning messages received by MWTM.

• Total Normal—Total number of Normal messages received by MWTM.

• Total Unclass—Total number of Unclass (unclassified) messages received by 
MWTM.

• Total Minor—Total number of Minor messages received by MWTM.

• Total Major—Total number of Major messages received by MWTM.

• Total Informational—Total number of Informational messages received by 
MWTM.

• Total Error—Total number of Error messages received by MWTM.

• Total Critical—Total number of Critical messages received by MWTM.

• Total Admin—Total number of Admin messages received by MWTM.

Num Number of messages of each severity received by MWTM.

Num/Total Number of messages of a given severity received by MWTM, divided by the total 
number of messages received by MWTM, displayed as a percentage.
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Status Messages Table

The Status Messages table contains the following columns:

Column Description

Message 
Types

Total number of status messages of each severity received by MWTM. Possible 
severities are:

• Status Informational—Total number of Informational status messages 
received by MWTM.

• Status Major—Total number of Major status messages received by MWTM.

• Status Normal—Total number of Normal status messages received by MWTM.

• Status Warning—Total number of Warning status messages received by 
MWTM.

• Status Minor—Total number of Minor status messages received by MWTM.

• Status Critical—Total number of Critical status messages received by MWTM.

• Status Unclass—Total number of Unclass (unclassified) status messages 
received by MWTM.

• Status Error—Total number of Error status messages received by MWTM.

• Status Admin—Total number of Admin status messages received by MWTM.

Num Number of status change messages of each severity received by MWTM.

Num/Status Number of status change messages of a given severity received by MWTM, divided 
by the total number of status change messages received by MWTM, displayed as a 
percentage.

Num/Total Number of status change messages of a given severity received by MWTM, divided 
by the total number of messages (status change messages and SNMP trap messages) 
received by MWTM, displayed as a percentage.
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Trap Messages Table

The Trap Messages table contains the following columns:

Column Description

Message 
Types

Total number of trap messages of each severity received by MWTM. Possible 
severities are:

• Trap Warning—Total number of Warning trap messages received by MWTM.

• Trap Unclass—Total number of Unclass trap messages received by MWTM.

• Trap Normal—Total number of Normal trap messages received by MWTM.

• Trap Minor—Total number of Minor trap messages received by MWTM.

• Trap Major—Total number of Major trap messages received by MWTM.

• Trap Informational—Total number of Informational trap messages received 
by MWTM.

• Trap Error—Total number of Error trap messages received by MWTM.

• Trap Critical—Total number of Critical trap messages received by MWTM.

• Trap Admin—Total number of Admin trap messages received by MWTM.

Num Number of trap messages of each severity received by MWTM.

Num/Trap Number of trap messages of a given severity received by MWTM, divided by the total 
number of trap messages received by MWTM, displayed as a percentage.

Num/Total Number of trap messages of a given severity received by MWTM, divided by the total 
number of messages (status change messages and trap messages) received by 
MWTM, displayed as a percentage.
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Messages/Day Table

The Messages/Day table contains the following columns:

Status Change Messages/Day Table

The Status Change Messages/Day table contains the following columns:

Column Description

Day Date for which metrics are calculated.

NumMsgs Total number of messages received by MWTM on a given day.

NumMsgs/TotalMsgs Number of messages received by MWTM on a given day, divided by the total 
number of messages (status change messages and SNMP trap messages) 
received by MWTM on all days, displayed as a percentage.

Column Description

Day Date for which metrics are calculated.

NumStatMsgs Total number of status change messages received by MWTM on a 
given day.

NumStatMsgs/TotalMsgs Number of status change messages received by MWTM on a given 
day, divided by the total number of messages (status change 
messages and SNMP trap messages) received by MWTM on all 
days, displayed as a percentage.

NumStatMsgs/TotalStatMsgs Number of status change messages received by MWTM on a given 
day, divided by the total number of status change messages received 
by MWTM on all days, displayed as a percentage.
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SNMP Trap Messages/Day Table

The Status Change Messages/Day table contains the following columns:

Files Processed Table

The Files Processed table lists all files that have been processed by MWTM.

Date Range Table

The Date Range table displays the date and time when MWTM began collecting 
metrics, and the date and time of the most recent metrics.

Column Description

Day Date for which metrics are calculated.

NumTrapMsgs Total number of SNMP trap messages received by MWTM on a 
given day.

NumTrapMsgs/TotalMsgs Number of SNMP trap messages received by MWTM on a given 
day, divided by the total number of messages (status change 
messages and SNMP trap messages) received by MWTM on all 
days, displayed as a percentage.

NumTrapMsgs/TotalTrapMsgs Number of SNMP trap messages received by MWTM on a given 
day, divided by the total number of SNMP trap messages received 
by MWTM on all days, displayed as a percentage.
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Viewing MWTM System Messages
You can view the following MWTM system messages from the MWTM Server 
Home Page.

Note These messages are all related to the MWTM system itself, not to your network.

• Viewing MWTM Error Messages, page 13-31

• Viewing MWTM Info Messages, page 13-32

• Viewing MWTM Action Messages, page 13-33

• Viewing MWTM Trace Messages, page 13-36

• Viewing MWTM Debug Messages, page 13-37

• Viewing MWTM Dump Messages, page 13-38

• Viewing MWTM SNMP Messages, page 13-39

• Viewing All Current MWTM Messages, page 13-40

• Viewing All Archived MWTM Messages, page 13-41

• Viewing the MWTM System Console Log, page 13-42

• Viewing All Archived MWTM System Console Log Messages, page 13-43

• Viewing the MWTM System Command Log, page 13-44

• Viewing the MWTM System Event Automation Log, page 13-45

• Viewing the MWTM System Security Log, page 13-46

• Viewing the MWTM System Web Access Log, page 13-47

• Viewing the MWTM System Web Server Error Log, page 13-47
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Viewing MWTM Error Messages
The System Messages: Last X Error Messages page displays error messages 
stored in the MWTM system log. These messages can be useful when diagnosing 
and correcting MWTM operational problems.

To access the System Messages: Last X Error Messages page, use one of the 
following procedures:

• Select System Error Messages from the MWTM Server Home Page.

• Select Error from the menu bar of any MWTM System Messages Web page.

The Last Error Messages table contains the following columns:

Column Description

Period
(in header)

Collection period of the table, such as Since Server Restart.

Timestamp
(in header)

Date and time the information on the page was last updated by MWTM.

Row Unique number identifying each entry in the table. You cannot edit this field.

Time Date and time the message was logged.

To sort the messages by time, click the Time header.

Source Source for the message, with the format process.host.id, where:

• process is the process that logged the message.

• host is the host name of the process that logged the message.

• id is an MWTM ID that uniquely identifies the process that logged the message, 
in the event that there are two or more clients running on the same device, 
connected to the same MWTM server.

Task Task, or thread, that logged the message.

Message Text of the message.

To sort the messages alphabetically by message text, click the Message header.
13-31
Cisco Mobile Wireless Transport Manager User Guide

OL-7637-01



 

Chapter 13      Accessing MWTM Data from a Web Browser
Viewing MWTM System Messages
Viewing MWTM Info Messages
The System Messages: Last X Info Messages page displays informational 
messages stored in the MWTM system log. These messages can be useful when 
diagnosing and correcting MWTM operational problems.

To access the System Messages: Last X Info Messages page, select System Info 
Messages from the MWTM Server Home Page, or Info from the Web page menu 
bar, if shown.

The Last Info Messages table contains the following columns:

Column Description

Period
(in header)

Collection period of the table, such as Since Server Restart.

Timestamp
(in header)

Date and time the information on the page was last updated by MWTM.

Row Unique number identifying each entry in the table. You cannot edit this field.

Time Date and time the message was logged.

To sort the messages by time, click the Time header.

Source Source for the message, with the format process.host.id, where:

• process is the process that logged the message.

• host is the host name of the process that logged the message.

• id is an MWTM ID that uniquely identifies the process that logged the message, 
in the event that there are two or more clients running on the same device, 
connected to the same MWTM server.

Task Task, or thread, that logged the message.

Message Text of the message.

To sort the messages alphabetically by message text, click the Message header.
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Viewing MWTM Action Messages
The System Messages: Last X Action Messages page displays action messages 
stored in the MWTM system log. These messages can be useful when diagnosing 
and correcting MWTM operational problems, and when monitoring audit trails of 
user actions.

To access the System Messages: Last X Action Messages page, use one of the 
following procedures:

• Select View > User Audit > User Actions from the MWTM Main Menu.

• Select System User Actions from the MWTM Server Home Page.

• Select Action from the menu bar of any MWTM System Messages Web page.

MWTM displays the System Messages: Last X Action Messages page 
(Figure 13-3).

Figure 13-3 System Messages: Last X Action Messages Page
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The System Messages: Last X Action Messages page is composed of the 
following sections:

• Last Action Messages Menu, page 13-34

• Last Action Messages Table, page 13-35

Last Action Messages Menu

By default, MWTM displays action messages of all classes on the System 
Messages: Last X Action Messages page. However, menu options are provided 
that enable you to display only messages of a specific class on the page.

The Last Action Messages menu contains the following options:

Column Description

Create Opens the System Messages: Last X Action: Create Messages Web page, which 
displays only Create action messages.

Delete Opens the System Messages: Last X Action: Delete Messages Web page, which 
displays only Delete action messages.

Discover Opens the System Messages: Last X Action: Discover Messages Web page, which 
displays only Discover action messages.

Edit Opens the System Messages: Last X Action: Edit Messages Web page, which 
displays only Edit action messages.

Ignore Opens the System Messages: Last X Action: Ignore Messages Web page, which 
displays only Ignore action messages.

OverWrite Opens the System Messages: Last X Action: OverWrite Messages Web page, which 
displays only OverWrite action messages.

Poll Opens the System Messages: Last X Action: Poll Messages Web page, which displays 
only Poll action messages.

Purge Opens the System Messages: Last X Action: Purge Messages Web page, which 
displays only Purge action messages.

LogInOut Opens the System Messages: Last X Action: LogInOut Messages Web page, which 
displays only Login and Logout action messages.

All Opens the System Messages: Last X Action Messages Web page, which displays all 
action messages.
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Last Action Messages Table

The Last Action Messages table contains the following columns:

Column Description

Period
(in header)

Collection period of the table, such as Since Server Restart.

Timestamp
(in header)

Date and time the information on the page was last updated by MWTM.

Row Unique number identifying each entry in the table. You cannot edit this field.

Time Date and time the message was logged.

To sort the messages by time, click the Time header.

Class Class of the message. Possible classes are:

• Create—Creation event, such as the creation of a seed file.

• Delete—Deletion event, such as the deletion of an object or file.

• Discover—Discovery event, such as Discovery beginning.

• Edit—Edit event. A user has edited an object.

• Ignore—Ignore event. A user has flagged a link or linkset as Ignored.

• Login—Login event. A user has logged in to MWTM.

• LoginDisable—LoginDisable event. MWTM has disabled a user’s User-Based 
Access authentication as a result of too many failed attempts to log in to MWTM.

• LoginFail—LoginFail event. An attempt by a user to log in to MWTM has failed.

• Logout—Logout event. A user has logged out of MWTM.

• OverWrite—OverWrite event. An existing file, such as a seed file or route file, 
has been overwritten.

• Poll—Poll event, such as an SNMP poll.

• Purge—Purge event. A user has requested Discovery with Delete Existing Data 
selected, and MWTM has deleted the existing MWTM database.

To sort the messages by class, click the Class header.

Message Text of the message.

To sort the messages alphabetically by message text, click the Message header.
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Viewing MWTM Trace Messages
The System Messages: Last X Trace Messages page displays trace messages 
stored in the MWTM system log. These messages can be useful when diagnosing 
and correcting MWTM operational problems.

To access the System Messages: Last X Trace Messages page, select System 
Error Messages from the MWTM Server Home Page, then select Trace from the 
menu bar.

The Last Trace Messages table contains the following information (without 
column headers):

Column Description

Period
(in header)

Collection period of the table, such as Since Server Restart.

Timestamp
(in header)

Date and time the information on the page was last updated by MWTM.

Index Message number, assigned to the message by MWTM.

Time Date and time the message was logged.

Source Source for the message, with the format process.host.id, where:

• process is the process that logged the message.

• host is the host name of the process that logged the message.

• id is an MWTM ID that uniquely identifies the process that logged the message, 
in the event that there are two or more clients running on the same device, 
connected to the same MWTM server.

Task Task, or thread, that logged the message.

Message Text of the message.
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Viewing MWTM Debug Messages
The System Messages: Last X Debug Messages page displays debug messages 
stored in the MWTM system log. These messages can be useful when diagnosing 
and correcting MWTM operational problems.

To access the System Messages: Last X Debug Messages page, select System 
Error Messages from the MWTM Server Home Page, then select Debug from the 
menu bar.

Note The Debug option is displayed only when enabled at the request of Cisco TAC.

The Last Debug Messages table contains the following information (without 
column headers):

Column Description

Period
(in header)

Collection period of the table, such as Since Server Restart.

Timestamp
(in header)

Date and time the information on the page was last updated by MWTM.

Index Message number, assigned to the message by MWTM.

Time Date and time the message was logged.

Source Source for the message, with the format process.host.id, where:

• process is the process that logged the message.

• host is the host name of the process that logged the message.

• id is an MWTM ID that uniquely identifies the process that logged the message, 
in the event that there are two or more clients running on the same device, 
connected to the same MWTM server.

Task Task, or thread, that logged the message.

Message Text of the message.
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Viewing MWTM Dump Messages
The System Messages: Last X Dump Messages page displays dump messages 
stored in the MWTM system log. These messages can be useful when diagnosing 
and correcting MWTM operational problems.

To access the System Messages: Last X Dump Messages page, select System 
Error Messages from the MWTM Server Home Page, then select Dump from the 
menu bar.

Note The Dump option is displayed only when enabled at the request of Cisco TAC.

The Last Dump Messages table contains the following information (without 
column headers):

Column Description

Period
(in header)

Collection period of the table, such as Since Server Restart.

Timestamp
(in header)

Date and time the information on the page was last updated by MWTM.

Index Message number, assigned to the message by MWTM.

Time Date and time the message was logged.

Source Source for the message, with the format process.host.id, where:

• process is the process that logged the message.

• host is the host name of the process that logged the message.

• id is an MWTM ID that uniquely identifies the process that logged the message, 
in the event that there are two or more clients running on the same device, 
connected to the same MWTM server.

Task Task, or thread, that logged the message.

Message Text of the message.
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Viewing MWTM SNMP Messages
The System Messages: Last X SNMP Messages page displays SNMP messages 
stored in the MWTM system log. These messages can be useful when diagnosing 
and correcting MWTM operational problems.

Note These are not SNMP trap messages. These are debugging messages from internal, 
low-level SNMP encoding and decoding routines.

To access the System Messages: Last X SNMP Messages page, select System 
Error Messages from the MWTM Server Home Page, then select SNMP from the 
menu bar.

Note The SNMP option is displayed only when enabled at the request of Cisco TAC.

The Last SNMP Messages table contains the following information (without 
column headers):

Column Description

Period
(in header)

Collection period of the table, such as Since Server Restart.

Timestamp
(in header)

Date and time the information on the page was last updated by MWTM.

Index Message number, assigned to the message by MWTM.

Time Date and time the message was logged.

To sort the messages by time, click the Time header.

Source Source for the message, with the format process.host.id, where:

• process is the process that logged the message.

• host is the host name of the process that logged the message.

• id is an MWTM ID that uniquely identifies the process that logged the message, 
in the event that there are two or more clients running on the same device, 
connected to the same MWTM server.
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Viewing All Current MWTM Messages
The System Messages: Last X All Messages page displays all current messages in 
the MWTM system log.

To access the System Messages: Last X All Messages page, select System Error 
Messages from the MWTM Server Home Page, then select All from the menu bar.

The Last All Messages table contains the following information (without column 
headers):

Task Task, or thread, that logged the message.

Message Text of the message.

To sort the messages alphabetically by message text, click the Message header.

Column Description

Column Description

Period
(in header)

Collection period of the table, such as Since Server Restart.

Timestamp
(in header)

Date and time the information on the page was last updated by MWTM.

Index Message number, assigned to the message by MWTM.

Time Date and time the message was logged.

Type Type of message. Possible types are:

• Action

• Debug

• Dump

• Error

• Info

• SNMP

• Trace
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Viewing All Archived MWTM Messages
The System Message Archives: All Messages page displays all archived messages 
in the MWTM system logs, including error messages, informational messages, 
trace messages, debug messages, dump messages, and SNMP messages.

To access the System Message Archives: All Messages page, use one of the 
following procedures:

• Select System Message Archives from the MWTM Server Home Page.

• Select Archives from the menu bar of any MWTM System Messages Web 
page.

On the System Message Archives: All Messages page, messages are archived by 
timestamp. Each archived file contains all MWTM system messages for a single 
session for the server to which you are connected, and which is currently running 
the MWTM server. (If you restart the server, MWTM creates a new file.)

To view archived messages, click a timestamp. MWTM displays the System 
Messages Archive: Last X All Messages page, which displays all messages that 
were in the ITP system log at the specified timestamp.

The Last All Messages table contains the following information (without column 
headers):

Source Source for the message, with the format process.host.id, where:

• process is the process that logged the message.

• host is the host name of the process that logged the message.

• id is an MWTM ID that uniquely identifies the process that logged the message, 
in the event that there are two or more clients running on the same device, 
connected to the same MWTM server.

Task Task, or thread, that logged the message.

Message Text of the message.

Column Description
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Viewing the MWTM System Console Log
The MWTM System Console Log page displays the contents of the MWTM 
system console log file for the server to which you are connected, and which is 
currently running the MWTM server. The console log file contains unexpected 
error and warning messages from the MWTM server, such as those that might 
occur if the MWTM server cannot start.

Column Description

Index Message number, assigned to the message by MWTM.

Time Date and time the message was logged.

Type Type of message. Possible types are:

• Action

• Debug

• Dump

• Error

• Info

• SNMP

• Trace

Source Source for the message, with the format process.host.id, where:

• process is the process that logged the message.

• host is the host name of the process that logged the message.

• id is an MWTM ID that uniquely identifies the process that logged the message, in 
the event that there are two or more clients running on the same device, connected to 
the same MWTM server.

Task Task, or thread, that logged the message.

Message Text of the message.
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To access the MWTM System Console Log page, use one of the following 
procedures:

• Select System Console Log from the MWTM Server Home Page.

• Select Console from the menu bar of any MWTM System Messages Web 
page.

Viewing All Archived MWTM System Console Log Messages
The MWTM System Console Archives: All Messages page displays all archived 
MWTM system console log messages for the server to which you are connected, 
and which is currently running the MWTM server. The archived console logs 
contain unexpected error and warning messages from the MWTM server, such as 
those that might occur if the MWTM server cannot start.

To access the MWTM System Console Archives: All Messages page, select 
Console Archives from the menu bar of any MWTM System Messages Web page.

On the MWTM System Console Archives: All Messages page, messages are 
archived by timestamp. Each archived file contains all MWTM system console 
log messages for a single session for the server to which you are connected, and 
which is currently running the MWTM server. (If you restart the server, MWTM 
creates a new file.)

To view archived messages, click a timestamp. MWTM displays the Console 
Archive: Last X All Messages page. This page displays the contents of the 
MWTM system console log file for the server to which you are connected, at the 
specified timestamp. The console log file contains unexpected error and warning 
messages from the MWTM server, such as those that might occur if the MWTM 
server cannot start.
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Viewing the MWTM System Command Log
The MWTM System Command Log: Last X Commands page displays the 
contents of the MWTM system command log file for the server to which you are 
connected, and which is currently running the MWTM server. The system 
command log lists all mwtm commands that have been entered for the MWTM 
server, the time each command was entered, and the user who entered the 
command.

To access the MWTM System Command Log: Last X Commands page, use one 
of the following procedures:

• Select View > User Audit > Command Log from the MWTM Main Menu.

• Select System Command Log from the MWTM Server Home Page.

MWTM displays the MWTM System Command Log: Last X Commands page 
(Figure 13-4).

Figure 13-4 MWTM System Command Log Page: Last X Commands Page
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The MWTM System Command Log: Last X Commands table contains the 
following columns:

Viewing the MWTM System Event Automation Log
The MWTM System Event Automation Log page displays the contents of the 
MWTM system event automation log file for the server to which you are 
connected, and which is currently running the MWTM server. The system event 
automation log lists all messages generated by scripts launched by event 
automation.

The default path and filename for the system event automation log file is 
/opt/CSCOsgm/logs/eventAutomationLog.txt. If you installed MWTM in a 
directory other than /opt, then the system event automation log file is located in 
that directory.

To access the MWTM System Event Automation Log page, use one of the 
following procedures:

• Select System Event Automation Log from the MWTM Server Home Page.

• Select EventAuto from the menu bar of any MWTM System Messages Web 
page.

Related Topic

• Changing the Way MWTM Processes Events, page 5-26

Column Description

Last Updated
(in header)

Date and time the information on the page was last updated by MWTM.

Row Command number, assigned to the command by MWTM.

Time Date and time the command was logged.

To sort the messages by time, click the Time header.

User User who entered the command.

To sort the commands by user, click the User header.

Command Text of the command.

To sort the messages alphabetically by command text, click the Command header.
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Viewing the MWTM System Security Log
The MWTM System Security Log: Last X Entries page displays the contents of 
the MWTM system security log file for the server to which you are connected, and 
which is currently running the MWTM server. The system security log lists all 
MWTM security events that have occurred for the MWTM server, the time each 
event occurred, the user and command that triggered the event, and the text of any 
associated message.

The default path and filename for the system security log file is 
/opt/CSCOsgm/logs/sgmSecurityLog.txt. If you installed MWTM in a directory 
other than /opt, then the system security log file is located in that directory.

To access the MWTM System Security Log: Last X Entries page, use one of the 
following procedures:

• Select View > User Audit > Security Log from the MWTM Main Menu.

• Select System Security Log from the MWTM Server Home Page.

The Last Security Entries table contains the following columns:

Related Topic

• Viewing All Current MWTM Messages

Column Description

Last Updated
(in header)

Date and time the information on the page was last updated by MWTM.

Row Entry number, assigned to the security event entry by MWTM.

Time Date and time the security event occurred.

To sort the entries by time, click the Time header.

User User who triggered the security event.

To sort the entries by user, click the User header.

Message Text of the security event message.

To sort the entries alphabetically by message text, click the Message header.

Command Text of the command that triggered the security event.

To sort the entries alphabetically by command text, click the Command header.
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Viewing the MWTM System Web Access Log
The MWTM System Web Access Log: Last X Messages page displays the 
contents of the MWTM system Web access log file for the server to which you are 
connected, and which is currently running the MWTM server. The system Web 
access log lists all MWTM system Web access messages that have been logged 
for the MWTM server. This provides an audit trail of all access to the MWTM 
server via the Web interface.

To access the MWTM System Web Access Log: Last X Messages page, select 
System Web Access Log from the MWTM Server Home Page, or enter the 
mwtm webaccesslog command. (You must be logged in as the root user or as a 
super user to use the mwtm webaccesslog command.)

Related Topic

• Viewing All Current MWTM Messages

The Last Web Access Messages table contains the following columns:

Viewing the MWTM System Web Server Error Log
The MWTM System Web Server Error Log: Last X Messages page displays the 
contents of the MWTM system Web server error log file for the server to which 
you are connected, and which is currently running the MWTM server. The system 
Web server error log lists all MWTM system Web error messages that have been 
logged for the MWTM Web server.

To access the MWTM System Web Server Error Log: Last X Messages page, 
select System Web Server Errors from the MWTM Server Home Page, or enter 
the mwtm weberrorlog command. (You must be logged in as the root user or as 
a super user to use the mwtm weberrorlog command.)

Column Description

Last Updated
(in header)

Date and time the information on the page was last updated by MWTM.

Row Unique number identifying each entry in the table. You cannot edit this field.

Message Text of the Web access message.
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Related Topic

• Viewing All Current MWTM Messages

The Last Web Server Error Messages table contains the following columns:

Viewing Statistics Reports
You can view the following MWTM statistics reports for network objects from the 
MWTM Server Home Page:

• Viewing RAN Backhaul Utilization Statistics Report, page 9-1

Viewing System Status Information for MWTM
You can view the following MWTM system status information from the MWTM 
Server Home Page:

• Viewing Status Information for MWTM, page 13-49

• Viewing Version Information for MWTM, page 13-49

• Viewing MWTM Client Information, page 13-49

• Viewing MWTM User Account Information, page 13-50

• Viewing MWTM Object Counts, page 13-52

• Viewing the Troubleshooting Log for MWTM (Server Only), page 13-52

Column Description

Last Updated
(in header)

Date and time the information on the page was last updated by MWTM.

Row Unique number identifying each entry in the table. You cannot edit this field.

Message Text of the Web server error message.
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Viewing Status Information for MWTM
The MWTM System Status page displays the status of all MWTM servers, local 
clients, and processes. To access the MWTM System Status page, select System 
Status from the MWTM Server Home Page, or from the menu bar of any System 
Status Web page. (MWTM might take a few seconds to display this page.)

Viewing Version Information for MWTM
The MWTM System Versions page displays version information for all MWTM 
servers, clients, and processes. To access the MWTM System Versions page, 
select System Versions from the MWTM Server Home Page, or from the menu 
bar of any System Status Web page. (MWTM might take a few seconds to display 
this page.)

Viewing MWTM Client Information
The MWTM System Connected Clients page lists all MWTM clients that are 
currently connected to the MWTM server. It also lists all Solaris/Linux users that 
are logged in to the MWTM server.

To access the MWTM System Connected Clients page, use one of the following 
procedures:

• Select View > User Audit > Connected Clients from the MWTM Main 
Menu.

• Select Connected Clients from the MWTM Server Home Page.

• Select Clients from the menu bar of any MWTM System Status Web page.
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Viewing MWTM User Account Information
The MWTM User Accounts page displays information about all user accounts 
that have been defined for the MWTM server. If no user accounts have been 
defined, MWTM displays the message, “User Database is Empty.”

To access the MWTM User Accounts page, use one of the following procedures:

• Select View > User Audit > User Accounts from the MWTM Main Menu.

• Select System User Accounts from the MWTM Server Home Page.

• Select Users from the menu bar of any MWTM System Status Web page.

To sort the MWTM User Accounts page based on the contents of any column, 
click the column header.

The MWTM User Accounts table contains the following columns:

Column Description

Server Name
(in header)

Name of the MWTM server for which user accounts are being displayed.

User MWTM user for whom a User-Based Access account has been set up.

To sort the entries by alphabetically user, click the User header.

Last Login Date and time the user last logged in to MWTM.

To sort the entries by last login time, click the Last Login header.

Level Name Authentication level for the user. Valid levels are:

• Basic User

• Power User

• Network Operator

• Network Administrator

• System Administrator

To sort the entries alphabetically by level name, click the Level Name header.
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Level Number Authentication level for the user, expressed as a number. Valid levels are:

• 1—Basic User

• 2—Power User

• 3—Network Operator

• 4—Network Administrator

• 5—System Administrator

To sort the entries numerically by level number, click the Level Number header.

Status Current status of the user’s account. Valid status settings are:

• Account Enabled—The account has been enabled and is functioning 
normally.

• Account Disabled—The account has been disabled for one of the following 
reasons:

– A System Administrator disabled the account. See the “mwtm 
disablepass” section on page C-22 and the “mwtm disableuser” section on 
page C-23 for more information.

– MWTM disabled the account as a result of too many failed attempts to log 
in using the account. See the “mwtm badlogindisable” section on 
page C-10 for more information.

– MWTM disabled the account because it was inactive for too many days. 
See the “mwtm inactiveuserdays” section on page C-29 for more 
information.

To sort the entries by status, click the Status header.

Column Description
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Viewing MWTM Object Counts
The MWTM Object Counts page displays counts of objects in the MWTM 
database.

To access the MWTM Object Counts page, select System Object Counts from 
the MWTM Server Home Page.

The MWTM Object Counts page displays the following counts:

• Nodes—Number of nodes that are in the following states: Active, Warning, 
Unmanaged, Unknown, Other, and Total.

Viewing the Troubleshooting Log for MWTM (Server Only)
Launching the MWTM System Troubleshooting page generates troubleshooting 
information, displays the information on this page, and stores the information in 
the /opt/CSCOsgm/tmp/cisco_sgm_tshoot.log file on the MWTM server. This log, 
which is updated each time the MWTM System Troubleshooting page is accessed 
or the mwtm tac command is run, contains information that might be requested 
by Cisco customer support personnel.

To access the MWTM System Troubleshooting page, select System 
Troubleshooting from the MWTM Server Home Page, or from the Web page 
menu bar, if shown.

Note MWTM might take several minutes to create and display the troubleshooting log, 
and the resulting log might be several MB, depending on the size of the network 
and system logs.
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Viewing System Data Files for MWTM
You can view the following MWTM system data files from the MWTM Server 
Home Page:

• MWTM System Data Files: Notes—Displays a list of the note files that have 
been created on this MWTM server. The notes are listed by the name of the 
network object, or by the internal ID of the event.

To access the MWTM System Files: Notes page, select Notes from the 
MWTM Server Home Page. Click an object name or ID to view the contents 
of the note. Click a directory to view the subdirectories and notes contained 
in that directory.

• MWTM System Data Files: Views—Displays a list of the network view files 
that have been created on this MWTM server. The file name includes 
directory information, if applicable.

To access the MWTM System Files: Network Views page, select Views from 
the menu bar of any MWTM System Files Web Page. Click a network view 
file to view its contents. Click a directory to view the subdirectories and 
network view files contained in that directory.

• MWTM System Data Files: Discovery Seeds—Displays a list of the seed 
files that have been created on this MWTM server. The file name includes 
directory information, if applicable.

To access the MWTM System Files: Discovery Seeds page, select Discovery 
Seeds from the MWTM Server Home Page. Click a seed file to view its 
contents. Click a directory to view the subdirectories and seed files contained 
in that directory.

• MWTM System Files: Server Event Automation Sounds—Displays a list 
of event automation sound files that have been created on this MWTM server.

Event automation sound files are stored in the server’s sounds directory:

– If you installed MWTM in the default directory, /opt, then the sound file 
directory is /opt/CSCOsgm/sounds.

– If you installed MWTM in a different directory, then the sound file 
directory is located in that directory.

To access the MWTM System Files: Server Event Automation Sounds page, 
select Sounds from the menu bar of any MWTM System Files Web Page, if 
shown. 
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Viewing System Information for MWTM
You can view the following MWTM system information from the MWTM Server 
Home Page:

• MWTM README—Contains late-breaking information about MWTM that 
might not be found in the other product documentation.

To access the MWTM System README page, select System README 
from the MWTM Server Home Page, or from the Web page menu bar, if 
shown.

• MWTM Install Log—Displays the contents of the MWTM system 
installation log. The installation log contains messages and other information 
recorded during installation, which can be useful when troubleshooting 
problems.

To access the MWTM System Install Log page, select System Install Log 
from the MWTM Server Home Page, or from the Web page menu bar, if 
shown.

• MWTM System Properties—Displays MWTM server and client properties 
that control various MWTM configuration parameters.

To access the MWTM System Properties page, select System Properties 
from the MWTM Server Home Page, or from the Web page menu bar, if 
shown.

• MWTM Root Variables—Displays the contents of the /etc/CSCOsgm.sh 
file, which determines the root location of the MWTM server and client 
installation.

To access the MWTM System Root Variables page, select System Root 
Variables from the MWTM Server Home Page, or from the Web page menu 
bar, if shown, or enter the mwtm rootvars command.
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Viewing the MWTM Technical Documentation
From the MWTM Server Home Page, you can view the following MWTM 
technical documentation:

• To view the entire Cisco Mobile Wireless Transport Manager Help System, 
select Help Home Page.

• To view the entire MWTM User Guide as a PDF file on the Web, using the 
Adobe Acrobat Reader, select User Guide (PDF).

• To view the entire MWTM Installation Guide as a PDF file on the Web, using 
the Adobe Acrobat Reader, select Installation Guide (PDF).

• To view the entire MWTM Release Notes as a PDF file on the Web, using the 
Adobe Acrobat Reader, select Release Notes (PDF).

• To view Frequently Asked Questions (FAQs) about MWTM, select 
Frequently Asked Questions.

• To view the syntax for every MWTM command, select Output of mwtm help 
command from the MWTM Server Home Page.

• To view a list of the MIBs on the server to which you are connected, and 
which is currently running the MWTM server, select SNMP MIBs from the 
MWTM Server Home Page.
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Downloading the MWTM Client from the Web
You can access the MWTM client installation software for Linux, Solaris, and 
Windows from the MWTM Server Home Page. This access is useful if you do not 
have the CD-ROM, or if you prefer to download the software using your Web 
browser. Once you have downloaded the MWTM client installation software to 
your workstation, you must install the software on your local system.

For more information about installing the MWTM client software using a Web 
server, see the “Installing MWTM on Solaris” and “Installing MWTM on 
Windows” chapters of the Cisco Mobile Wireless Transport Manager Installation 
Guide.

• To access the MWTM Client for Solaris page, select Download Solaris 
Client.

• To access the MWTM Client for Windows page, select Download Windows 
Client.

• To access the MWTM Client for Linux page, select Download Linux Client. 
(The MWTM client for Linux is not a supported feature of MWTM. Use it 
under advisement.)

Downloading the MWTM Server’s SSL Certificate 
from the Web

If you have implemented Secure Sockets Layer (SSL) support in your MWTM 
system, you can download the MWTM server’s signed SSL certificate to all 
remote MWTM clients that connect to the server using SSL.

To access the MWTM Server SSL Certificate page, select Server SSL Certificate 
from the MWTM Server Home Page.

For more information about downloading the certificate, or about enabling SSL in 
MWTM, see the “Implementing SSL Support in MWTM (Solaris Only)” section 
on page 10-27.
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Accessing Software Updates and Additional 
Information

You can access the following additional information about MWTM from the 
MWTM Server Home Page:

• To view information about MWTM or any other Cisco product available on 
Cisco.com (also known as Cisco Connection Online), use one of the 
following procedures:

– Select View > Cisco.com from the MWTM Main Menu.

– Select Cisco Home Page from the MWTM Server Home Page.

• To access software updates for MWTM from Cisco.com for FTP, select 
Engineering Software Updates (FTP). The Cisco Systems Engineering FTP 
server page is displayed.
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MWTM Status Definitions

This appendix defines the default status settings for all MWTM network objects.

This appendix includes the following information:

• Status Definitions for Interfaces, page A-1

• Status Definitions for Nodes, page A-5

• Status Definitions for Views, page A-6

Status Definitions for Interfaces
This section provides definitions for the following statuses:

• Admin Status, page A-2

• Operational Status, page A-2

• Connect State for GSM Abis, page A-2

• Connect State for UMTS Iub, page A-3

• Alarm States, page A-4

• Redundancy State, page A-4

• Status, page A-5
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Admin Status
Possible values for the administrative status of the interface are:

Unknown (red)—Unknown administrative status

Up (green)—Administratively up

Shutdown (blue)—Administratively down

Testing (blue)—Administrator is testing the interface

Operational Status
Possible values for the operational status of the interface are:

Unknown (red)—Unknown operational status.

Up (green)—Interface is up.

Down (red)—Interface is down.

Testing (blue)—Interface is in test mode.

Dormant (red)—Interface is dormant.

Not Present (red)—An interface component is missing.

Lower Layer Down (red)—An interface is down because of a lower-layer 
interface.

Connect State for GSM Abis
Possible values for the connect state of a GSM interface are:

Connected (green)—The device is monitoring local and remote alarm status.

Disconnected (red)—The system ignores the local alarm status. The local 
transmitter on the short-haul is disabled. Capabilitymessages are transmitted to 
the remote describing the provisioning. The system stays disconnected until the 
remote capabilities are known and the peer state is transitioned to connected.

Send Connect (yellow)—One or more attempts have been made to connect to 
remote peer.
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Receive Connect (yellow)—The local-peer has received a connect request from 
the remote-peer.

Connect Rejected (yellow)—Connection was rejected.

ACK Connect (yellow)—The initial connect request was sent and acknowledged 
by remote-peer. The local-peer is now waiting for a connect request from the 
remote-peer.

Check Connect (yellow)—The local peer has reason to believe its remote peer 
has failed. Additional tests are being processed to verify peer's state.

Connect State for UMTS Iub
Possible values for the connect state of a UMTS interface are:

Initialized (yellow)—The connection is starting initialization.

Starting (red)—The shorthaul interface is administratively active, but the 
backhaul interface is down.

Closed (blue)—The backhaul interface is active, but the shorthaul is 
administratively closed.

Stopped (red)—Unable to connect to peer in specified time interval. Additional 
attempts will be tried based on peer request or restart timers.

Closing (blue)—Connection closed by administration request.

Stopping (yellow)—Connection shut down by peer's Term-Request. Will 
transition to stopped state. 

Connect Sent (yellow)—Connection request sent to peer.

ACK Received (yellow)—Connection request sent and acknowledgement has 
been received from peer. Now waiting for peer's connection request.

ACK Sent (yellow)—Connection request received and acknowledgement has 
been sent to peer. Connection request sent and waiting for peer's 
acknowledgement.

Open (green)—Connection open and available for traffic.
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Alarm States
The alarm states for a UMTS Iub interface include the following:

• Local Receive Alarm State

• Local Transmit Alarm State

• Remote Receive Alarm State

• Remote Transmit Alarm State

Possible values for these alarm states are:

Remote Alarm (blue)—Indicates a problem at the remote end. The alarm 
generated by the remote interface in the E1/T1 data stream is sent and no other 
action is required. 

No Alarm (green)—No alarm is present. 

Local Alarm (red)—Indicates local interface problem. The interface has not 
received synchronization from the GSM device. Device stops transmitting 
backhaul samples.

Received Alarm (yellow)—Indicates receive problem in the local device. The 
remote device stops transmitting backhaul data and indicates a blue alarm.

Alarm State Unavailable (red)—Indicates the alarm state is not available. This 
state only applies to the remote and occurs when the peer connection is inactive.

Redundancy State
Possible values for the redundancy state of GSM Abis or UMTS Iub interfaces 
are:

Active (green)—Active owner of interface.

Standby (green)—Active owner of interface.
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Status
Possible values for the status of an interface are:

Active (green)

Discovering (cyan)

Down (red)

Polling (cyan)

Unknown (red)

Unmanaged (gray)

Waiting (gray)

Warning (yellow)

Status Definitions for Nodes
Possible values for the current status of the node are:

Active (green)—The node is currently fully functional.

Discovering (cyan)—The node is being discovered, and SNMP queries have been 
sent to the device.

Polling (cyan)—The node is being polled.

Unknown (red)—The node failed to respond to an SNMP request. MWTM sets 
all associated interfaces to Unknown.

Unmanaged (gray)—One of the following situations exists:

– The node is known indirectly by MWTM. In other words, MWTM knows 
the device exists but there is no known SNMP stack on the device for 
MWTM to query.

– An MWTM user has set the node to Unmanaged status to prevent 
MWTM from polling the node.

Waiting (gray)—The node is in the Discovery queue but is not currently being 
discovered.

Warning (yellow)—The node is active, but one or more interfaces is in Failed, 
Unavailable, Unknown, or Warning status and is not Ignored.
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Status Definitions for Views
Possible values for the current status of the view are:

Active (green)—All objects in the selected view are currently Active and fully 
functional.

Unmanaged (gray)—All objects in the selected view are currently Unmanaged.

Warning (yellow)—One or more objects in the selected view is currently not 
Active.
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MWTM FAQs

This appendix provides answers to the following frequently asked questions about 
MWTM:

• What is MWTM?, page B-2

• Does MWTM require any other NMS applications?, page B-3

• What workstation and network devices do I need to run MWTM?, page B-3

• Can RAN-O devices send traps to MWTM and to another process on the same 
device?, page B-4

• Can I run MWTM on my Windows PC?, page B-4

• How do I install the MWTM client?, page B-4

• What are the names of the MIBs used by MWTM?, page B-5

• Why can’t my remote workstation access MWTM on my local workstation?, 
page B-5

• What is a super user?, page B-6

• Why did MWTM not discover all of my RAN-O nodes?, page B-6

• I moved the server on which I had installed MWTM and now I can’t start the 
MWTM client or server. Why?, page B-7

• How often does MWTM poll the RAN-O nodes?, page B-8

• If I select the Clear Event Icon menu option, does that delete the event from 
the MWTM database?, page B-8

• How does “zoom in on an area” work in a topology map?, page B-9

• Can I add my own icons to the topology map?, page B-10
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• Why did I receive a “cannot connect to server” message?, page B-10

• Does the MWTM Java RMI use TCP or UDP?, page B-11

• What does this message mean: MessageLoggerProxy:setMessageLogger(): 
Could not resolve., page B-11

• What does a status of Deleted, Uninhibited, or NoShutdown mean?, 
page B-12

• Will the MWTM server processes restart automatically after a system 
reboot?, page B-12

• Some of my MWTM windows are showing up with small, unusable text entry 
fields. How can I correct this?, page B-13

• Sometimes my MWTM display seems to lock up. Why?, page B-13

• After a failed uninstall of the Windows client, I’m prompted to uninstall 
again, but the procedure does not work. Why?, page B-14

• Why do I see strange character strings when I install MWTM?, page B-15

• Why doesn’t my browser launch when I select a Web page menu option from 
the MWTM Main Menu?, page B-15

• What is the difference between in-band and out-of-band management?, 
page B-16

• How does the MWTM server communicate to the BTS MWR at the remote 
cell site?, page B-17

• How do I change the default status polling interval?, page B-18

• Why are the age of my alarms always 0 minutes?, page B-19

What is MWTM?
MWTM provides a powerful, easy-to-use solution that enables network 
administrators to manage and troubleshoot Radio Access Network—Optimized 
(RAN-O) networks. For a more detailed description of MWTM, see the “What is 
MWTM?” section on page 1-2.
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Does MWTM require any other NMS applications?
MWTM is functionally a standalone product and does not require any other 
products. However, you can integrate MWTM with other products to provide 
added value.

For example, you can integrate MWTM with CiscoWorks, which provides access 
to the full suite of CiscoWorks products, including the Device Center, the 
CiscoView Element Manager, Resource Manager Essentials (RME), the 
Internetwork Performance Monitor (IPM), and the Access Control List Manager.

You can also integrate MWTM with the HP OpenView SNMP manager to enable 
MWTM to receive traps via HP OpenView.

You can also forward MWTM events to other hosts, in the form of SNMP traps. 
This enables MWTM to integrate with high-level event- and alarm-monitoring 
systems such as the Cisco Info Center (CIC), HP OpenView, and Micromuse's 
Netcool suite of products. These systems can provide a single high-level view of 
all alarm monitoring in your network, making it easier to detect and resolve 
problems. For more information, see the “Forwarding Events as Traps to Other 
Hosts” section on page 5-50.

What workstation and network devices do I need to 
run MWTM?

MWTM comprises two distinct pieces of functionality.

• The MWTM server application runs on Solaris/Linux only.

• The MWTM client application, including the user interface, runs on 
Solaris/Linux, Windows 2000 Professional, and Windows XP Professional. 
For Solaris/Linux, the MWTM client can run on the same system as the 
MWTM server, or on a different system.

Note The Linux client is unsupported.

For further hardware and software requirements, see the “Preparing to Install 
MWTM” chapter of the Cisco Mobile Wireless Transport Manager Installation 
Guide.
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Can RAN-O devices send traps to MWTM and to another process on the same device?
Can RAN-O devices send traps to MWTM and to 
another process on the same device?

Yes. You can configure your RAN-O devices to send SNMP traps to more than 
one process (such as MWTM and HP OpenView) on a single device. Each process 
receives traps on a different port number. However, to do so, you must configure 
a different community string for each process.

For example, your RAN-O network configurations could include the following 
lines:

snmp-server host 1.2.3.4 public udp-port 162
snmp-server host 1.2.3.4 otherCommunity udp-port 44750

where:

• The first line configures the HP OpenView trap receiver, with community 
string public and UDP port number 162.

• The second line configures the MWTM trap receiver, with community string 
otherCommunity and UDP port number 44750.

You would then configure MWTM to receive traps on port number 44740. For 
information about how to configure the MWTM port number, see the “Enabling 
SNMP Traps (Server Only)” section on page 11-35.

Can I run MWTM on my Windows PC?
You can run the MWTM client on Windows 2000 Professional or 
Windows XP Professional on your PC. However, the MWTM server must run on 
a Solaris/Linux system.

How do I install the MWTM client?
You can install the MWTM client either from the CD distributed with MWTM, or 
by using a Web browser to download the MWTM client from an MWTM server. 
See the Cisco Mobile Wireless Transport Manager Installation Guide for full 
details.
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What are the names of the MIBs used by MWTM?
What are the names of the MIBs used by MWTM?
You can find the complete list of MIBs that MWTM configures and queries in the 
“MWTM MIB Reference” section on page D-1.

You can obtain the latest versions of these MIBs from one of the following 
locations:

• The Zip file mibs.zip, located at the top of the MWTM CD Image, contains 
these MIBs.

• You can download these MIBs from the Cisco Website:

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

Why can’t my remote workstation access MWTM on 
my local workstation?

Keep in mind that performance is always better if you access MWTM by installing 
the MWTM client on the remote workstation.

However, if you want to enable a remote Solaris/Linux workstation to access 
MWTM on a local workstation, enter the xhost + remote_workstation UNIX 
command on your local workstation, where remote_workstation is the remote 
device you are enabling to access your local workstation.

To enable a remote Windows workstation to access MWTM on a local 
workstation, you can use an X-Window system emulator such as eXceed or 
Reflection X, but be aware that there may be display problems. For example, the 
window borders might disappear, or the keyboard focus might be missing.

X Performance Enhancer (AntiAliasing Off)

Checkbox used to specify whether antialiasing is on in the topology map. 
Antialiasing, which is on by default, improves the appearance of the icons and 
connections in the map.

You can improve the performance of the MWTM client on a remote workstation 
by turning off antialiasing in the topology map. For more information, see the 
“Turning Off Antialiasing to Improve Performance” section on page 8-40.
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What is a super user?
What is a super user?
A super user is an MWTM user who has been enabled to perform most of the 
MWTM functions that otherwise require the user to be logged in as the root user.

For a complete description of the functions that a super user can and cannot 
perform, as well as instructions for enabling a super user, see the “Specifying a 
Super User (Server Only)” section on page 10-24.

Why did MWTM not discover all of my RAN-O 
nodes?

After you discover the network, examine the Discovered Nodes table to verify that 
MWTM discovered all of the nodes in the network. If you suspect that MWTM 
did not discover all of the nodes, verify the following conditions:

• Verify that the MWTM server can ping the nodes.

• Verify that the nodes are running IOS images that are compatible with the 
MWTM server.

• Verify that the SNMP is enabled on the nodes.

• Verify that MWTM is configured with the correct SNMP community name. 
See the “Configuring SNMP Settings” section on page 2-3 for details.

• Verify that you selected Entire Network when you ran Discovery. If you 
suspect that you did not, run Discovery again with Entire Network selected.
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I moved the server on which I had installed MWTM and now I can’t start the MWTM client or server. Why?
I moved the server on which I had installed MWTM 
and now I can’t start the MWTM client or server. 
Why?

If you change the IP address of the server on which you installed MWTM, or if 
you move the server to a new network, you must reboot the server to prevent 
MWTM connection problems.

To reboot the server, use the following procedure:

Step 1 Log in as the root user, as described in the “Becoming the Root User (Server 
Only)” section on page 3-3.

Step 2 Enter the following commands:

# cd /opt/CSCOsgm/bin

# ./mwtm reboot

If you change the server’s Solaris/Linux host name, you must reset the default 
host name on the MWTM server and client, using the following procedure:

Step 1 Log in as the root user, as described in the “Becoming the Root User (Server 
Only)” section on page 3-3.

Step 2 Enter the following commands:

# cd /opt/CSCOsgm/bin

# ./mwtm evilstop

MWTM stops all MWTM servers on the local host.
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How often does MWTM poll the RAN-O nodes?
Step 3 Enter the following command:

# ./mwtm servername hostname

where hostname is the new default host name. Make sure the new name is valid 
and is defined in your /etc/hosts file.

MWTM resets the default host name for the MWTM server and client and 
automatically restarts the MWTM server.

How often does MWTM poll the RAN-O nodes?
By default, MWTM polls the nodes in the network every 15 minutes. However, 
you can initiate a poll for one or more nodes at any time by selecting the nodes in 
the Discovery panel of the Discovery Dialog and clicking Poll Node.

You can also change the default poll interval for one or more nodes in the SNMP 
Configuration Dialog. You must be logged in as the root user or as a super user to 
access this dialog.

Finally, the Node Details Window polls the displayed node and its adjacent node 
every 15 seconds, but you can change that poll interval, too.

If I select the Clear Event Icon menu option, does that 
delete the event from the MWTM database?

No. When you select the Clear Event Icon menu option for an object, MWTM 
does not delete the actual event from its database. MWTM only deletes the event 
icon (an orange triangle) from its displays for the object, and only for the MWTM 
client on which you are currently working.
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Can I add my own sounds to the Event Sound Filter?
Can I add my own sounds to the Event Sound Filter?
Yes. You can add sound files to an MWTM client. MWTM clients can play the 
following sound file formats: AIFC, AIFF, AU, SND, and WAV.

MWTM client sound files are stored in the MWTM client’s sounds directory:

• If you installed the MWTM client for Solaris/Linux in the default directory, 
/opt, then the sound file directory is /opt/CSCOsgmClient/sounds.

• If you installed the MWTM client for Windows in the default directory, 
/Program Files, then the sound file directory is 
C:\Program Files\SGMClient\sounds.

• If you installed MWTM in a different directory, then the sound file directory 
is located in that directory.

If for some reason MWTM cannot play a specified sound file, MWTM plays a 
default beep. For example, MWTM cannot play a sound file if one of the 
following conditions exists:

• The file has been moved or deleted from the sounds directory

• The sounds directory has been deleted or cannot be found

• Some other application is using all of the sound resources

• There is no sound card present

How does “zoom in on an area” work in a topology 
map?

“Zoom in on an area” enables you to zoom in on a selected area of the topology 
map in the Topology Window. To do so, click the Zoom in on an area button, or 
select Topology Tools > Zoom > Area from the MWTM Main Menu, then click 
in the topology map and drag a rectangle around the area you want to zoom in on. 
MWTM expands the selected area to fill the topology map.
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Can I add my own icons to the topology map?
Can I add my own icons to the topology map?
No. To ensure that icons on the topology map can be resized cleanly, they are 
drawn as special vector-based images. Raster images, such as GIF files, do not 
resize cleanly.

Why did I receive a “cannot connect to server” 
message?

When you launch the MWTM client or the Event Configurator, or when you 
connect to a new server (whether manually or automatically as the result of a 
server failure), you might receive the following message:

This client is not allowed to connect to the server or the server is 
listening on a port the client does not know about or cannot reach. 
Click the help button for a more detailed explanation.

If you receive this message, one of the following situations has occurred:

1. An MWTM administrator has prevented your MWTM client from connecting 
to the MWTM server, using the mwtm ipaccess command.

To resolve this problem, contact the MWTM administrator and ask to have 
your client’s IP address added to the ipaccess.conf file. See the “Limiting 
MWTM Client Access to the MWTM Server (Server Only)” section on 
page 10-40 for more information.

2. The MWTM server has more than one IP address, but the MWTM server’s 
default host name is set to an IP address that your MWTM client cannot 
access.

To resolve this problem in Solaris/Linux, use the mwtm servername 
command to reset the MWTM server's default host name to an IP address that 
your client can access and restart the server. See the “mwtm servername” 
section on page C-55 for more information.

To resolve this problem in Windows, select Start > Programs > 
Cisco MWTM Client > Modify Default MWTM Server Name, then you 
can enter the mwtm servername command.
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Does the MWTM Java RMI use TCP or UDP?
Note Using the mwtm servername command to reset the MWTM server's 
default host name does not affect communication between the MWTM 
server and the RAN-O devices.

3. A firewall is installed between the MWTM server and your MWTM client 
that only allows traffic to pass through to the MWTM server's port numbers 
1774 (the MWTM Web Server port) and 44742 (the MWTM Naming Server 
port), but communication between MWTM servers and clients requires 
additional ports.

To resolve this problem, set up the firewall correctly. See the “Firewall 
Communication” section on page F-5 for details.

Does the MWTM Java RMI use TCP or UDP?
MWTM’s two-way RMI communication between Java-based GUI clients and 
Java-based server processes uses TCP sockets.

What does this message mean: 
MessageLoggerProxy:setMessageLogger(): Could 
not resolve.

One of the following conditions has occurred:

• The host or port number of the Message Log Server is configured incorrectly. 
Verify that the host or port number is valid.

• MWTM cannot reach the Message Log Server, probably because it is 
restarting. MWTM recovers the connection when the Message Log Server 
restarts.
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What does a status of Deleted, Uninhibited, or NoShutdown mean?
What does a status of Deleted, Uninhibited, or 
NoShutdown mean?

A status of Deleted, Uninhibited, or NoShutdown indicates a possible problem 
with MWTM. If you see one of these status settings, contact Cisco TAC or your 
Cisco Account Team.

Will the MWTM server processes restart 
automatically after a system reboot?

Yes. When you install the MWTM server, MWTM modifies your system startup 
scripts to ensure that the MWTM server processes start up again after a system 
reboot. To accomplish this, MWTM adds the following lines to your system 
startup scripts:

/etc/init.d/sgm

/etc/rc0.d/K99sgm

/etc/rc1.d/K99sgm

/etc/rc2.d/K99sgm

/etc/rc3.d/K99sgm

/etc/rc3.d/S99sgm

These lines ensure that the MWTM shutdown and startup scripts run in the correct 
order for each system initiation state.

Linux Only

Note that for Linux only, the following lines are modified as well:

/etc/rc5.d/S99sgm

/etc/rc6.d/K99sgm
B-12
Cisco Mobile Wireless Transport Manager User Guide

OL-7637-01



 

Appendix B      MWTM FAQs
Some of my MWTM windows are showing up with small, unusable text entry fields. How can I correct this?
Some of my MWTM windows are showing up with 
small, unusable text entry fields. How can I correct 
this?

Depending on your system, as well as other factors, MWTM windows can 
sometimes display so small that text is illegible, and columns and text entry fields 
are very narrow and unusable. If this happens, resize the window and widen the 
individual columns until the information is again legible and the columns and text 
entry fields are usable.

To make a column wider or narrower, click the column divider in the header and 
move the divider to the right or left while holding down the right mouse button.

Sometimes my MWTM display seems to lock up. 
Why?

In MWTM, events might cause message popups to remain in the background of 
your display, preventing you from interacting with other windows. If you suspect 
that your display has locked up, perform the following tasks:

• Make sure you are running MWTM on a supporrted operating system. For 
more information about supported operating systems, refer to “Preparing to 
Install MWTM” in the Cisco Mobile Wireless Transport Manager 
Installation Guide.

• Minimize windows and look for an MWTM message popup in the 
background.
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After a failed uninstall of the Windows client, I’m prompted to uninstall again, but the procedure does not work. Why?
After a failed uninstall of the Windows client, I’m 
prompted to uninstall again, but the procedure does 
not work. Why?

If for some reason the Windows MWTM client uninstall procedure fails before the 
client is completely uninstalled, MWTM prompts you to uninstall the client again. 
However, this might not be possible using the standard Add/Remove Programs 
icon in the Windows Control Panel, or from the Windows Start menu.

If you cannot uninstall the MWTM client using the standard procedure, use the 
following procedure:

Step 1 Delete the MWTM client installation directory and its contents:

• If you installed the MWTM client in the default directory, C:\Program Files, 
then the installation directory is C:\Program Files\SGMClient\.

• If you installed the MWTM client in a different directory, then the installation 
directory is located in that directory.

Step 2 Delete the following directory: \Program Files\InstallShield Installation 
Information\{FB2CF81B-4F3C-4326-8130-5270116372E2}.

Note This directory might be hidden.

Step 3 Delete the Cisco SGM Client registry key and its contents:

HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems, Inc.\
Cisco SGM Client

Step 4 Delete the MWTM Client entries from the Windows Start menu and desktop.
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Why do I see strange character strings when I install MWTM?
Why do I see strange character strings when I install 
MWTM?

The setting of the LANG environment variable can cause syntax errors in the 
MWTM setup scripts, which can result in messages that contain strange character 
strings such as ?y?d@O. To correct this problem, unset the LANG environment 
variable in the workstation from which you are installing MWTM, using one of 
the following commands:

• If you are running sh, enter the unset LANG command.

• If you are running csh, enter the unsetenv LANG command.

Then install MWTM again.

Why doesn’t my browser launch when I select a 
Web page menu option from the MWTM Main 
Menu?

If your browser is not already running on Solaris/Linux, and you select a menu 
option that displays a Web page, MWTM might not be able to launch the browser.

To avoid this problem, make sure the following conditions are met:

• You are running a supported browser (Netscape Navigator 7.1 or later; 
Microsoft Internet Explorer version 6.0 (SP1) or later; or Mozilla 1.6 or later, 
including Firefox 1.0).

• Your browser is already running before selecting a menu option that displays 
a Web page.

• The MWTM Web browser path is correct. For more information about setting 
the browser path, see the “mwtm browserpath” section on page C-11.
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What is the difference between in-band and out-of-band management?
What is the difference between in-band and 
out-of-band management?

Devices located at the cell site are usually accessible only over the same path that 
is used to transport voice traffic. Collecting management information over this 
path is called in-band management and has an impact on backhaul utilization.  

MWTM can reduce the amount and frequency of collecting mangement 
information when information is collected in-band.  MWTM does not create 
reports for in-band accessed routers.  Also, MWTM relies on the information in 
traps received from an in-band router instead of scheduling a poll to get the 
updated router status.

The following cell-site device configuration statements provide MWTM with 
information required to optimize data collection:

conf t
ipran-mib location cellSite
ipran-mib snmp-access inBand

Devices located at the aggregation site are managed using different paths than 
those used by voice traffic. Collecting management information in this 
configuration is called out-of-band management and has no impact on backhaul 
utilization. 

Statistical reports are created for routers that are managed out of band.  Also, 
when traps are received, the router is polled to get the latest information.

The following aggregation-site device configuration statements provide MWTM 
with information required to optimize data collection:

conf t
ipran-mib location aggSite
ipran-mib snmp-access outOfBand

The following example shows the range of options that are available for the 
ipran-mib command:

ems1941ka#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
ems1941ka(config)#ipran-mib ?

backhaul-notify-interval  Interval for backhaul utilization
location                  Location of device
snmp-access               Specify type snmp connectivity
threshold-acceptable      Acceptable utilization threshold
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How does the MWTM server communicate to the BTS MWR at the remote cell site?
threshold-overloaded      Overloaded utilization threshold
threshold-warning         Warning utilization threshold

ems1941ka(config)#ipran-mib location ?
aggSite    Located at BSC or RNC site
cellSite   Located at BTS or Node B site
undefined  Undefined location

ems1941ka(config)#ipran-mib snmp-access ?
inBand     In Band SNMP connectivity
outOfBand  Out of Band SNMP connectivity
undefined  Undefined connectivity

How does the MWTM server communicate to the 
BTS MWR at the remote cell site?

The MWTM server must communicate to the cell site (BTS) router using IP 
routing. If the BTS router is reachable only through the backhaul interface, add a 
static route on the MWTM server to point to the BTS router. Use the IP address 
of the BSC router IP address as the next-hop address. 

The following examples of static routing for Solaris and Linux platforms are 
based on the diagram in Figure B-1.

Figure B-1 Example of Static Routing
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How do I change the default status polling interval?
To create a static route on a Solaris MWTM server, use the following procedure:

Step 1 Log in as the root user, as described in the “Becoming the Root User (Server 
Only)” section on page 3-3.

Step 2 Enter the following command:

# /usr/sbin/route add host 10.1.1.1 20.1.1.1

To create a static route on a Linux MWTM server, use the following procedure:

Step 1 Log in as the root user, as described in the “Becoming the Root User (Server 
Only)” section on page 3-3.

Step 2 Enter the following command:

# route add -host 10.1.1.1 gw 20.1.1.1

How do I change the default status polling interval?
The MWTM polls the MWR node for status information (for example, interface 
up or down) every 15 minutes. The size of this poll depends on the number and 
type of interfaces that are enabled on the MWR. 

To change the default polling interval of 15 minutes, open the SNMP 
Configuration Dialog by selecting Network > SNMP Configuration from the 
MWTM Main Window. You can use this dialog to change the default polling 
interval to any number of minutes from 5 to 1440.

Note The status information in the GUI is only as good as the most recent poll.
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Why are the age of my alarms always 0 minutes?
Why are the age of my alarms always 0 minutes?
If the server clock is ahead of the client clock, the value will be 0 until the client 
clock catches up to the server clock. To get accurate values, use a time service 
such as Network Time Protocol (NTP) or similar, which keeps server and client 
clocks in sync.
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MWTM Command Reference

This appendix provides the format and a brief description of the following 
MWTM commands, listed alphabetically. Each command is available on the 
server only, server and Solaris clients only, or server and all clients (including 
Windows) as indicated.

• mwtm, page C-6

• mwtm adduser, page C-6

• mwtm authtype, page C-7

• mwtm backup, page C-8

• mwtm backupdir, page C-9

• mwtm badloginalarm, page C-9

• mwtm badlogindisable, page C-10

• mwtm browserpath, page C-11

• mwtm certgui, page C-11

• mwtm certtool, page C-12

• mwtm changes, page C-13

• mwtm clean, page C-13

• mwtm cleanall, page C-14

• mwtm cleandb, page C-14

• mwtm cleandiscover, page C-15

• mwtm cliconntimer, page C-16
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• mwtm client, page C-17

• mwtm clientlogs, page C-17

• mwtm clitimeout, page C-18

• mwtm cmdlog, page C-19

• mwtm console, page C-19

• mwtm countnodes, page C-20

• mwtm countobjects, page C-20

• mwtm cwsetup, page C-20

• mwtm delete, page C-21

• mwtm deluser, page C-22

• mwtm disablepass, page C-22

• mwtm disableuser, page C-23

• mwtm discover, page C-24

• mwtm enableuser, page C-24

• mwtm eventeditor, page C-25

• mwtm eventlog, page C-26

• mwtm evilstop, page C-26

• mwtm export, page C-27

• mwtm export cw, page C-27

• mwtm help, page C-28

• mwtm inactiveuserdays, page C-29

• mwtm installlog, page C-29

• mwtm iosinfo, page C-30

• mwtm ipaccess, page C-30

• mwtm jspport, page C-31

• mwtm keytool, page C-32

• mwtm killclients, page C-33

• mwtm listusers, page C-33

• mwtm logger, page C-34
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• mwtm logtimemode, page C-34

• mwtm maxasciirows, page C-35

• mwtm maxevhist, page C-36

• mwtm maxhtmlrows, page C-36

• mwtm mldebug, page C-37

• mwtm motd, page C-38

• mwtm msglog, page C-39

• mwtm msglogage, page C-40

• mwtm msglogdir, page C-40

• mwtm msglogsize, page C-41

• mwtm netlog, page C-42

• mwtm netlogger, page C-43

• mwtm newlevel, page C-43

• mwtm passwordage, page C-44

• mwtm patchlog, page C-45

• mwtm poll, page C-45

• mwtm pollertimeout, page C-46

• mwtm print, page C-47

• mwtm props, page C-47

• mwtm readme, page C-48

• mwtm reboot, page C-48

• mwtm repdir, page C-49

• mwtm rephelp, page C-50

• mwtm replog, page C-50

• mwtm restart, page C-51

• mwtm restore, page C-51

• mwtm restoreprops, page C-52

• mwtm rootvars, page C-53

• mwtm sechelp, page C-53
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• mwtm seclog, page C-53

• mwtm secondaryserver, page C-54

• mwtm servername, page C-55

• mwtm setpath, page C-56

• mwtm snmpcomm, page C-57

• mwtm snmpconf, page C-58

• mwtm snmpget, page C-59

• mwtm snmphelp, page C-62

• mwtm snmpnext, page C-63

• mwtm snmpwalk, page C-66

• mwtm sounddir, page C-70

• mwtm ssl, page C-71

• mwtm sslstatus, page C-72

• mwtm start, page C-72

• mwtm start client, page C-73

• mwtm start jsp, page C-73

• mwtm start pm, page C-74

• mwtm start web, page C-74

• mwtm statreps clean, page C-74

• mwtm statreps cleancustom, page C-75

• mwtm statreps custage, page C-75

• mwtm statreps dailyage, page C-76

• mwtm statreps diskcheck, page C-77

• mwtm statreps enable, page C-77

• mwtm statreps export, page C-78

• mwtm statreps hourlyage, page C-78

• mwtm statreps servratio, page C-79

• mwtm statreps status, page C-80

• mwtm statreps timemode, page C-80
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• mwtm statreps timer, page C-81

• mwtm statreps utilratio, page C-81

• mwtm status, page C-82

• mwtm stop, page C-82

• mwtm stopclients, page C-82

• mwtm stop jsp, page C-83

• mwtm stop pm, page C-83

• mwtm stop web, page C-83

• mwtm superuser, page C-84

• mwtm syncusers, page C-84

• mwtm tac, page C-85

• mwtm telnetpath, page C-85

• mwtm tnproxy, page C-86

• mwtm trapaccess, page C-86

• mwtm trapsetup, page C-87

• mwtm trapstatus, page C-88

• mwtm uninstall, page C-89

• mwtm unknownage, page C-89

• mwtm updateuser, page C-90

• mwtm useraccess, page C-91

• mwtm userpass, page C-91

• mwtm version, page C-92

• mwtm viewlog, page C-92

• mwtm wall, page C-93

• mwtm webaccesslog, page C-94

• mwtm weberrorlog, page C-94

• mwtm weblogupdate, page C-95

• mwtm webnames, page C-95

• mwtm webport, page C-96
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mwtm
• mwtm webutil, page C-97

• mwtm who, page C-97

• mwtm xtermpath, page C-98

mwtm
Server and Solaris/Linux Clients Only

Command Description

Displays the command syntax for the mwtm command and all of its options. The 
function of this command is identical to mwtm help.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm adduser
Server Only

Full Syntax

mwtm adduser [username]

Command Description

If MWTM User-Based Access is enabled, adds the specified user to the 
authentication list.

When you add a user, MWTM prompts you for the following information:

• User’s password. When setting the password, follow the rules and 
considerations in the “Creating Secure Passwords” section on page 10-6.

• Whether to force the user to change the password at the next login. The 
default is not to force the user to change the password.
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• Authentication level for the user. Valid levels are:

– 1—Basic User

– 2—Power User

– 3—Network Operator

– 4—Network Administrator

– 5—System Administrator

See the “Implementing MWTM User-Based Access (Server Only)” section on 
page 10-2 for more information on authentication levels, and on the use of this 
command.

You must be logged in as the root user or as a super user to use this command.

Note If you have enabled Solaris authentication, you must be logged in as the root user, 
not a super user, to use this command. See the “Implementing MWTM 
User-Based Access (Server Only)” section on page 10-2 for more information.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm authtype
Server Only

Full Syntax

mwtm authtype [local | solaris | linux]

Command Description

Configures MWTM security authentication, as follows:

• local—Allows creation of user accounts and passwords local to the MWTM 
system. When using this method, user names, passwords, and access levels 
are managed using MWTM commands.
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• solaris—Uses standard Solaris-based user accounts and passwords, as 
specified in the /etc/nsswitch.conf file. Authentication can be provided by the 
local /etc/passwd file or from a distributed Network Information Services 
(NIS) system.

• linux—Uses standard Linux-based user accounts and passwords, as specified 
in the /etc/nsswitch.conf file. Authentication can be provided by the local 
/etc/passwd file or from a distributed Network Information Services (NIS) 
system.

See the “Implementing MWTM User-Based Access (Server Only)” section on 
page 10-2 for more information on the use of this command.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm backup
Server Only

Command Description

Backs up MWTM data files to the MWTM installation directory. MWTM 
automatically backs up all data files at 1:30 AM each night, but you can use this 
command to back up the files at any other time.

• If you installed MWTM in the default directory, /opt, then the locations of the 
backup files are /opt/mwtm50-client-backup.tar.Z and 
/opt/mwtm50-server-backup.tar.Z.

• If you installed MWTM in a different directory, then the backup files are 
located in that directory.

To restore the MWTM data files from the previous night’s backup, use the mwtm 
restore command. Do not try to manually extract the backup files.

You must be logged in as the root user (not as a super user) to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.
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mwtm backupdir
mwtm backupdir
Server Only

Full Syntax

mwtm backupdir [directory]

Command Description

Enables you to change the directory in which MWTM stores its nightly backup 
files. The default backup directory is the directory in which MWTM is installed:

• If you installed MWTM in the default directory, /opt, then the default backup 
directory is also /opt.

• If you installed MWTM in a different directory, then the default backup 
directory is that directory.

If you specify a new directory that does not exist, MWTM does not change the 
directory, and issues an appropriate message.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm badloginalarm
Server Only

Full Syntax

mwtm badloginalarm [number-of-attempts | clear]

Command Description

If MWTM User-Based Access is enabled, number of unsuccessful login attempts 
allowed before MWTM generates an alarm.

The valid range is 1 unsuccessful attempt to an unlimited number of unsuccessful 
attempts. The default value is 5 unsuccessful attempts.
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MWTM records alarms in the system security log file. The default path and 
filename for the system security log file is 
/opt/CSCOsgm/logs/sgmSecurityLog.txt. If you installed MWTM in a directory 
other than /opt, then the system security log file is located in that directory.

To view the system security log file, enter mwtm seclog. You can also view the 
system security log on the MWTM System Security Log Web page. For more 
information, see the “Viewing the MWTM System Security Log” section on 
page 13-46.

To reset the valid range back to 5 attempts, enter mwtm badloginalarm clear.

See the “Automatically Disabling Users and Passwords (Server Only)” section on 
page 10-10 for more information on the use of this command.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm badlogindisable
Server Only

Full Syntax

mwtm badlogindisable [number-of-attempts | clear]

Command Description

If MWTM User-Based Access is enabled, number of unsuccessful login attempts 
by a user allowed before MWTM disables the user’s authentication. MWTM does 
not delete the user from the authentication list, MWTM only disables the user’s 
authentication. To re-enable the user’s authentication, use the mwtm enableuser 
command.

The valid range is 1 unsuccessful attempt to an unlimited number of unsuccessful 
attempts. The default value is 10 unsuccessful attempts.

To reset the valid range back to 5 attempts, enter mwtm badlogindisable clear.

See the “Automatically Disabling Users and Passwords (Server Only)” section on 
page 10-10 for more information on the use of this command.
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You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm browserpath
Server and Solaris/Linux Clients Only

Command Description

Sets a user-defined MWTM Web browser path, and verifies that the browser 
specified by the user exists.

You must be logged in as the root user (not as a super user) to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm certgui
Solaris Clients Only

Command Description

If Secure Sockets Layer (SSL) is implemented in your MWTM system, opens the 
MWTM Certificate Tool window, which enables you to manage SSL certificates 
on the MWTM client.

Note If you installed the MWTM server and client on the same workstation, this 
command is unnecessary. Instead, when you use the mwtm keytool command to 
manage SSL certificates on the server, MWTM automatically manages the 
certificates on the client.

You must be logged in as the root user (not as a super user) to use this command 
in Solaris.
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mwtm certtool
List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm certtool
Server and Solaris Clients Only

Full Syntax

mwtm certtool [clear | delete alias | export alias [-file filename] | 
import alias [-file filename] | list]

Command Description

If Secure Sockets Layer (SSL) is implemented in your MWTM system, enables 
you to manage SSL certificates on the MWTM client from the command line.

Note If you installed the MWTM server and client on the same workstation, this 
command is unnecessary. Instead, when you use the mwtm keytool command to 
manage SSL certificates on the server, MWTM automatically manages the 
certificates on the client.

Use the following keywords and arguments with this command:

• import alias [-file filename]—Imports a signed SSL certificate in X.509 
format. This is the most common use for this command.

The alias argument can be any character string; the host name of the server 
from which you are importing the certificate is a good choice.

To import the certificate from a file, specify the optional -file keyword and a 
filename.

• export alias [-file filename]—Exports the specified SSL certificate in X.509 
format.

To export the certificate to a file, specify the optional -file keyword and a 
filename.

• list—Lists all SSL certificates on the MWTM client.

• delete alias—Removes the specified SSL certificate from the MWTM client.
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• clear—Removes all SSL certificates from the MWTM client.

Solaris Only: You must be logged in as the root user (not as a super user) to use 
this command in Solaris.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm changes
Server Only

Command Description

Displays the contents of the MWTM CHANGES file. The CHANGES file lists all 
bugs that have been resolved in MWTM, sorted by release, from the current 
release back to Release 2.2.

• If you installed MWTM in the default directory, /opt, then the MWTM 
CHANGES file is located in the /opt/CSCOsgm/install directory.

• If you installed MWTM in a different directory, then the file is located in that 
directory.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm clean
Server Only

Command Description

Removes all MWTM data from the MWTM server, excluding message log files, 
backup files, and report files. This command restores the MWTM server to a 
“clean” state, such as would exist after a new installation of MWTM, except for 
the presence of the retained files.
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mwtm cleanall
Data removed includes all MWTM data, notes, preferences, security settings, 
route files, seed files, event filters, report control files, and views, as well as any 
user-created files stored in MWTM directories.

You must be logged in as the root user (not as a super user) to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm cleanall
Server Only

Command Description

Removes all MWTM data from the MWTM server, including message log files, 
backup files, report files, configuration settings, and security settings. This 
command restores the MWTM server to a “clean” state, such as would exist after 
a new installation of MWTM.

Data removed includes all MWTM data, notes, preferences, security settings, 
route files, seed files, event filters, report control files, views, message log files, 
backup files, and report files, as well as any user-created files stored in MWTM 
directories.

You must be logged in as the root user (not as a super user) to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm cleandb
Server Only

Command Description

Removes all MWTM data from the MWTM server, including the core data model 
database, all view files, notes associated with objects, and event filters, but 
excluding message log files, backup files, report files, configuration settings, 
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mwtm cleandiscover
security settings, and route files. This command restores the MWTM server to a 
“clean” state, such as would exist after a new installation of MWTM, except for 
the presence of the retained files.

Data removed includes all MWTM data, notes, event filters, and views, as well as 
any user-created files stored in MWTM directories.

You must be logged in as the root user (not as a super user) to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm cleandiscover
Server Only

Full Syntax

mwtm cleandiscover [seed-node] [seed-node]...

Command Description

Enables you to delete all current network data and begin a clean discovery of the 
network from the command line. Use the seed-node arguments to specify the 
DNS names or IP addresses of one or more seed nodes.
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mwtm cliconntimer
Note When you begin a clean discovery, MWTM stops any real-time polls that are 
running and issues appropriate messages.

Running this command does not remove any notes, preferences, views, message 
log files, backup files, or report files, nor any user-created files stored in MWTM 
directories.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm cliconntimer
Server Only

Full Syntax

mwtm cliconntimer [number-of-seconds | clear]

Command Description

Specifies how long, in seconds, an MWTM client is to wait for a message from 
the MWTM server before exiting. If the timer expires, the client pings the server 
and takes the following action:

• If the server responds to the ping, the client reconnects to the server.

• If the server does not respond to the ping, but there is a backup server 
configured, the client connects to the backup server.

• If the server does not respond to the ping, and there is no backup server 
configured, the client stops.

The valid range is 10 seconds to an unlimited number of seconds. The default 
value is 60 seconds.

To restore the default timeout of 60 seconds, enter the mwtm cliconntimer clear 
command.

Any changes you make take effect when you restart the MWTM server.
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mwtm client
You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm client
Solaris/Linux Clients Only

Full Syntax

mwtm client [hostname]

Command Description

Starts an MWTM client on the specified host. If no host name is specified, starts 
an MWTM client on the default host, as specified during installation. See the 
“Connecting to a New Server” section on page 3-42 for information about 
determining the default host.

If you Telnet into a remote workstation, the DISPLAY variable must be set to your 
local display, or you cannot use this command. If the DISPLAY variable is not set 
automatically, you must set it manually. See the “Setting the DISPLAY Variable 
(Client Only)” section on page 11-40 for details.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm clientlogs
Server Only

Command Description

Uses PAGER to display the MWTM client log files.

The MWTM client log files contain client console output for all MWTM clients, 
one file per local or remote client. The file for a client is created by MWTM 
automatically when the client starts.
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• If you installed MWTM in the default directory, /opt, then the MWTM client 
log file is located in the /opt/CSCOsgm/logs/clientLogs directory.

• If you installed MWTM in a different directory, then the file is located in that 
directory.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm clitimeout
Server Only

Full Syntax

mwtm clitimeout [number-of-minutes | clear]

Command Description

Specifies how long, in minutes, an MWTM client can be inactive before being 
disconnected automatically by MWTM.

This function is disabled by default. If you do not specify this command, clients 
are never disconnected as a result of inactivity.

If you enter the mwtm clitimeout command, the valid range is 1 minute to an 
unlimited number of minutes. There is no default value.

If you have enabled this function and you want to disable it (that is, never 
disconnect a client as a result of inactivity), enter the mwtm clitimeout clear 
command.

See the “Automatically Disabling Users and Passwords (Server Only)” section on 
page 10-10 for more information on the use of this command.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.
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mwtm cmdlog
Server Only

Full Syntax

mwtm cmdlog [clear | -r]

Command Description

Uses PAGER to display the contents of the system command log. The system 
command log lists all mwtm commands that have been entered for the MWTM 
server, the time each command was entered, and the user who entered the 
command.

To clear the log and restart the server, enter mwtm cmdlog clear.

To display the contents of the log in reverse order, with the most recent commands 
at the beginning of the log, enter mwtm cmdlog -r.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm console
Server Only

Command Description

Displays the contents of the console log file, sgmConsoleLog.txt. The console log 
file contains unexpected error and warning messages from the MWTM server, 
such as those that might occur if the MWTM server cannot start.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.
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mwtm countnodes
Server Only

Command Description

Displays a count of nodes in the current MWTM database.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm countobjects
Server Only

Command Description

Displays a count of all objects in the current MWTM database.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm cwsetup
Solaris Server Only

Full Syntax

mwtm cwsetup [install | uninstall]
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Command Description

Manages the integration of MWTM with CiscoWorks:

• install—Checks to see which CiscoWorks files are installed, and installs 
additional files as necessary. Use this command to integrate MWTM and 
CiscoWorks in the following instances:

– You installed CiscoWorks after you installed MWTM.

– MWTM and CiscoWorks are no longer integrated for some reason.

• uninstall—Removes MWTM files from the CiscoWorks area.

Always run mwtm cwsetup uninstall before uninstalling CiscoWorks from 
your system.

You must be logged in as the root user (not as a super user) to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm delete
Server Only

Full Syntax

mwtm delete node [all | node [node]...] 

Command Description

Deletes objects from the MWTM database.

• node all—Deletes all nodes from the MWTM database.

• node node [node]...—Deletes one or more nodes from the MWTM database. 
Use the node arguments to specify one or more nodes.

See the “Deleting a Node” section on page 6-61 for more information.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.
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mwtm deluser
Server Only

Full Syntax

mwtm deluser [username]

Command Description

If MWTM User-Based Access is enabled, deletes the specified user from the 
authentication list. To add the user back to the list, use the mwtm adduser 
command.

See the “Manually Disabling Users and Passwords (Server Only)” section on 
page 10-14 for more information on the use of this command.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm disablepass
Server Only

Full Syntax

mwtm disablepass [username]

Command Description

If MWTM User-Based Access is enabled and mwtm authtype is set to local, 
disables the specified user’s authentication and password. MWTM does not delete 
the user from the authentication list, MWTM only disables the user’s 
authentication and password.

• To re-enable the user’s authentication with the same password as before, use 
the mwtm enableuser command.

• To re-enable the user’s authentication with a new password, use the mwtm 
userpass command.
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If mwtm authtype is set to solaris, you cannot use this command. Instead, you 
must manage passwords on the external authentication servers.

See the “Manually Disabling Users and Passwords (Server Only)” section on 
page 10-14 for more information on the use of this command.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm disableuser
Server Only

Full Syntax

mwtm disableuser [username]

Command Description

If MWTM User-Based Access is enabled, disables the specified user’s 
authentication. MWTM does not delete the user from the authentication list, 
MWTM only disables the user’s authentication.

• To re-enable the user’s authentication with the same password as before, use 
the mwtm enableuser command.

• To re-enable the user’s authentication with a new password, use the mwtm 
userpass command.

See the “Manually Disabling Users and Passwords (Server Only)” section on 
page 10-14 for more information on the use of this command.

You must be logged in as the root user or as a super user to use this command.

Note If you have enabled Solaris authentication, you must be logged in as the root user, 
not a super user, to use this command. See the “Implementing MWTM 
User-Based Access (Server Only)” section on page 10-2 for more information.
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List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm discover
Server Only

Full Syntax

mwtm discover [seed-node] [seed-node]...

Command Description

Enables you to discover the network from the command line. Use the seed-node 
arguments to specify the DNS names or IP addresses of one or more seed nodes. 
For more information about seed nodes, see Loading Seed Nodes and Seed Files, 
page 2-12.

Note This command does not perform a clean discovery. To do so, see the 
mwtm cleandiscover command.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm enableuser
Server Only

Full Syntax

mwtm enableuser [username]
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Command Description

If MWTM User-Based Access is enabled, re-enables the specified user’s 
authentication, which had been disabled either automatically by MWTM or by a 
super user.

The user’s authentication is re-enabled with the same password as before.

See the “Enabling and Changing Users and Passwords (Server Only)” section on 
page 10-16 for more information on the use of this command.

You must be logged in as the root user or as a super user to use this command.

Note If you have enabled Solaris authentication, you must be logged in as the root user, 
not a super user, to use this command. See the “Implementing MWTM 
User-Based Access (Server Only)” section on page 10-2 for more information.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm eventeditor
Solaris/Linux Clients Only

Full Syntax

mwtm eventeditor [hostname]

Command Description

Starts an MWTM Event Configurator on the specified host. If no host name is 
specified, starts an MWTM Event Configurator on the default host, as specified 
during installation. See the “Connecting to a New Server” section on page 3-42 
for information about determining the default host.

For more information about the MWTM Event Configurator, see the “Changing 
the Way MWTM Processes Events” section on page 5-26.

If you Telnet into a remote workstation, the DISPLAY variable must be set to your 
local display, or you cannot use this command. If the DISPLAY variable is not set 
automatically, you must set it manually. See the “Setting the DISPLAY Variable 
(Client Only)” section on page 11-40 for details.
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mwtm eventlog
Server Only

Full Syntax

mwtm eventlog [clear | -r]

Command Description

Uses PAGER to display the contents of the MWTM event automation log. The 
event automation log lists all messages generated by scripts launched by event 
automation.

To clear the log and restart the server, enter mwtm eventlog clear.

To display the contents of the log in reverse order, with the most recent events at 
the beginning of the log, enter mwtm eventlog -r.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm evilstop
Server Only

Command Description

Forcefully stops all MWTM servers on the local host. This command can be 
useful if a normal mwtm stop does not stop the servers.

You must be logged in as the root user (not as a super user) to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.
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mwtm export
Server Only

Full Syntax

mwtm export [-d {bar | comma | tab}] [all | nodes ]

Command Description

Exports current MWTM data.

By default, MWTM separates data fields with vertical bars (|). However, you can 
specify commas (,) or tabs as the separator:

• -d bar—Separate data fields with vertical bars (|). This is the default setting.

• -d comma—Separate data fields with commas (,).

• -d tab—Separate data fields with tabs.

By default, MWTM exports all data. However, you can limit the data that MWTM 
exports:

• all—Export all current MWTM data. This is the default selection.

• nodes—Export only node data.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm export cw
Solaris Server Only

Full Syntax

mwtm export cw
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Command Description

Exports current MWTM node names and read and write SNMP community 
names, in CiscoWorks import format, with fields separated by commas (,). You 
can export this data to a file, then use the file to import the devices into the 
CiscoWorks database.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm help
Server and Solaris/Linux Clients Only

Full Syntax

mwtm help [keyword]

Command Description

Displays the command syntax for the mwtm command and all of its options. 

To see the command syntax for a specific keyword, enter mwtm help followed by 
that keyword. For example, if you enter mwtm help restart, MWTM displays:

mwtm restart     - Restarts all MWTM Servers on the local host.
mwtm restart web - Restarts Web servers on the local host.
mwtm restart jsp - Restarts JSP servers on the local host.
mwtm restart pm - Restarts Process Manager on the local host.

List of mwtm Commands

• MWTM Command Reference, page C-1.
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mwtm inactiveuserdays
Server Only

Full Syntax

mwtm inactiveuserdays [number-of-days | clear]

Command Description

If mwtm User-Based Access is enabled, number of days a user can be inactive 
before disabling that user account.

This function is disabled by default. If you do not specify this command, user 
accounts are never disabled as a result of inactivity.

If you enter the mwtm inactiveuserdays command, the valid range is 1 day to an 
unlimited number of days. There is no default setting.

If you have enabled this function and you want to disable it (that is, prevent 
MWTM from automatically disabling user accounts as a result of inactivity), enter 
mwtm inactiveuserdays clear.

To re-enable the user’s authentication, use the mwtm enableuser command.

See the “Automatically Disabling Users and Passwords (Server Only)” section on 
page 10-10 for more information on the use of this command.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm installlog
Server and Solaris/Linux Clients Only

Full Syntax

mwtm installlog [server | client]
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mwtm iosinfo
Command Description

Displays the latest install log for the server or client. If you do not specify server 
or client, displays the latest install log for both the server and client.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm iosinfo
Server Only

Command Description

Displays the versions of IOS with which MWTM is compatible.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm ipaccess
Server Only

Full Syntax

mwtm ipaccess [add [ip-addr] | clear | edit | list | rem [ip-addr] | sample]

Command Description

Enables you to create and manage a list of client IP addresses allowed to connect 
to the MWTM server.

The list of allowed client IP addresses is contained in the ipaccess.conf file. By 
default, when you first install MWTM, the ipaccess.conf file does not exist and 
MWTM allows all client IP addresses to connect to the MWTM server. To create 
the ipaccess.conf file and work with the list of allowed client IP addresses, specify 
one of the following keywords:
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mwtm jspport
• add—Add the specified client IP address to the ipaccess.conf file. If the 
ipaccess.conf file does not already exist, this command creates a file with the 
first entry.

• clear—Remove all client IP addresses from the ipaccess.conf file, and allow 
connections from any MWTM client IP address.

• edit—Open and edit the ipaccess.conf file directly. If the ipaccess.conf file 
does not already exist, this command creates an empty file.

• list—List all client IP addresses currently in the ipaccess.conf file. If no client 
IP addresses are listed (that is, the list is empty), connections from any 
MWTM client IP address are allowed.

• rem—Remove the specified client IP address from the ipaccess.conf file.

• sample—Print out a sample ipaccess.conf file.

Any changes you make take effect when you restart the MWTM server.

See the “Limiting MWTM Client Access to the MWTM Server (Server Only)” 
section on page 10-40 for more information about using this command.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm jspport
Server Only

Full Syntax

mwtm jspport [port-number]

Command Description

Sets a new port number for the JSP server, where port-number is the new, numeric 
port number. MWTM verifies that the new port number is not already in use.

This command is needed only if you must change the port number after you install 
MWTM, because another application must use the current port number.
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The new port number must contain only numbers. If you enter a port number that 
contains non-numeric characters, such as mwtm13, MWTM displays an error 
message and returns to the command prompt without changing the port number.

You must be logged in as the root user (not as a super user) to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm keytool
Solaris Server Only

Full Syntax

mwtm keytool [clear | genkey | import_cert cert_filename | 
import_key key_filename cert_filename | list | print_csr | print_crt]

Command Description

If SSL is implemented in your MWTM system, manages SSL keys and certificates 
on the MWTM server.

If you installed the MWTM server and client on the same workstation, also 
automatically manages the certificates on the client.

Use the following keywords and arguments with this command:

• clear—Stops the MWTM server, if necessary, and removes all SSL keys and 
certificates from the server. Before restarting the server, you must either 
generate new SSL keys using the mwtm keytool genkey command, or you 
must completely disable SSL using the mwtm ssl disable command.

• genkey—Stops the MWTM server, if necessary, and generates a new 
self-signed public/private SSL key pair on the MWTM server. The new keys 
take effect when you restart the server.

• import_cert cert_filename—Imports the specified signed SSL certificate in 
X.509 format. 

• import_key key_filename cert_filename—Imports the specified SSL key in 
OpenSSL format and the specified signed SSL certificate in X.509 format.

• list—Lists all SSL key/certificate pairs on the MWTM server.
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• print_csr—Prints a certificate signing request (CSR) in X.509 format.

• print_crt—Prints the MWTM server’s SSL certificate in X.509 format.

See the “Implementing SSL Support in MWTM (Solaris Only)” section on 
page 10-27 for more information on the use of this command.

You must be logged in as the root user (not as a super user) to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm killclients
Server Only

Command Description

Forcefully stops all MWTM clients, including Event Configurators, on the local 
host.

You must be logged in as the root user (not as a super user) to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm listusers
Server Only

Full Syntax

mwtm listusers [username]

Command Description

If MWTM User-Based Access is enabled, lists all currently defined users in the 
authentication list, including the following information for each user:
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mwtm logger
• User name

• Last time the user logged in

• User’s authentication access level

• User’s current authentication status, such as Account Enabled or Password 
Disabled

To list information for a specific user, use the username argument to specify the 
user.

See the “Listing All Currently Defined Users (Server Only)” section on 
page 10-21 for more information on the use of this command.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm logger
Server Only

Command Description

Displays the system messages messageLog.txt file with tail -f.

To stop the display, enter Ctrl-c.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm logtimemode
Server Only

Full Syntax

mwtm logtimemode [12 | 24]
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Command Description

Sets the time mode for dates in log files (except sgmCommandLog.txt and 
sgmSecurityLog.txt):

• 12—Use 12-hour time, with AM and PM. 1:00 in the afternoon is 1:00 PM.

• 24—Use 24-hour time, also called military time. 1:00 in the afternoon is 
13:00. This is the default setting.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm maxasciirows
Server Only

Full Syntax

mwtm maxasciirows [number-of-rows]

Command Description

Sets the maximum number of rows for MWTM ASCII Web output, such as 
displays of detailed debugging information.

If you enter this command without the number-of-rows argument, MWTM 
displays the current maximum number of rows. You can then change that value, 
or leave it as-is. The valid range is 1 row to an unlimited number of rows. The 
default value is 6000 rows.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.
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mwtm maxevhist
Server Only

Full Syntax

mwtm maxevhist [number-of-rows]

Command Description

Sets the maximum number of rows for MWTM to search in the event history logs. 
The event history logs are the current and archived MWTM network status logs 
for status change and SNMP trap messages. MWTM sends the results of the 
search to the Web browser, where the results are further limited by the setting of 
the mwtm maxhtmlrows command.

If you enter this command without the number-of-rows argument, MWTM 
displays the current maximum number of rows. You can then change that value, 
or leave it as-is. The valid range is 1 row to an unlimited number of rows. The 
default value is 15000 rows.

The default setting is sufficient in most MWTM environments. However, you 
might need to increase the setting if MWTM has archived a large number of event 
history logs, each log contains thousands of messages, and you want to search 
more than 15000 rows. However, be aware that increasing this setting can increase 
the search time.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm maxhtmlrows
Server Only

Full Syntax

mwtm maxhtmlrows [number-of-rows]
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Command Description

Sets the maximum number of rows for MWTM HTML Web output, such as 
displays of statistics reports, status change messages, or SNMP trap messages.

If you enter this command without the number-of-rows argument, MWTM 
displays the current maximum number of rows. You can then change that value, 
or leave it as-is. The valid range is 1 row to an unlimited number of rows. The 
default value is 200 rows.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm mldebug
Server Only

Full Syntax

mwtm mldebug [mode]

Command Description

Sets the mode for logging MWTM debug messages:

• normal—Logs all action, error, and info messages. Use 
mwtm mldebug normal to revert to the default settings if you accidentally 
enter the mwtm mldebug command.

• list—Displays the current settings for the mwtm mldebug command.

• all—Logs all messages, of any type.

• none—Logs no messages at all.

• minimal—Logs all error messages.

• action—Logs all action messages.

• debug—Logs all debug messages.

• dump—Logs all dump messages.

• error—Logs all error messages.
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• info—Logs all info messages.

• snmp—Logs all SNMP messages.

• trace—Logs all trace messages.

This command can adversely affect MWTM performance. Use this command 
only under guidance from the Cisco TAC.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm motd
Server Only

Full Syntax

mwtm motd [cat | disable | edit | enable]

Command Description

Manages the MWTM message of the day file, which is a user-specified MWTM 
system notice. You can use the message of the day to inform users of important 
changes or events in the MWTM system. The message of the day also gives users 
an opportunity to exit the MWTM client before launching.

If the message of the day is enabled, it is displayed whenever a user attempts to 
launch an MWTM client:

• If the user accepts the message, the client launches.

• If the user declines the message, the client does not launch.

Use the following keywords with this command:

• enable—Enables the message of the day function. Initially, the message of 
the day file is blank; use the mwtm motd edit command to specify the 
message text.

• edit—Enables you to change the message of the day.
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• cat—Displays the contents of the message of the day file.

• disable—Disables this function (that is, stops displaying the message of the 
day whenever a user attempts to launch an MWTM client).

See the “Displaying a Message of the Day (Server Only)” section on page 10-18 
for more information on the use of this command.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm msglog
Server Only

Full Syntax

mwtm msglog [clear | -r]

Command Description

Uses PAGER to display the contents of the system message log.

To save the current contents of the log, clear the log, and restart the server, enter 
mwtm msglog clear.

To display the contents of the log in reverse order, with the most recent messages 
at the beginning of the log, enter mwtm msglog -r.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.
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mwtm msglogage
Server Only

Full Syntax

mwtm msglogage [number-of-days]

Command Description

Sets the maximum number of days to archive system message log files before 
deleting them from the MWTM server.

If you enter this command without the number-of-days argument, MWTM 
displays the current maximum number of days. You can then change that value, 
or leave it as-is. The valid range is 1 day to an unlimited number of days. The 
default value is 31 days.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm msglogdir
Server Only

Full Syntax

mwtm msglogdir [directory]

Command Description

Changes the default location of all MWTM system message log files. By default, 
the system message log files are located on the MWTM server at 
/opt/CSCOsgm/logs.
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Note Do not set the new directory to any of the following: /usr, /var, /opt, or /tmp.

Do not set the new directory to the same directory in which you are storing report 
files (mwtm repdir).

After you change the directory, MWTM asks if you want to restart the MWTM 
server. The new directory takes effect when you restart the MWTM server.

You must be logged in as the root user or as a super user to use this command. If 
you are changing to a default location outside MWTM, you must have appropriate 
permissions for that location.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm msglogsize
Server Only

Full Syntax

mwtm msglogsize [number-of-lines]

Command Description

Sets the maximum number of messages to write to the message log file before 
starting a new file.

If you enter this command without the number-of-lines argument, MWTM 
displays the current maximum number of messages. You can then change that 
value, or leave it as-is.

The valid range is 1000 messages to an unlimited number of messages. The 
default value is 10000 messages (approximately 2 MB). Therefore, the default 
message log file and its copy require approximately 4 MB, combined. If you 
specify a larger message log file size, the message log file and its copy require 
proportionally more space.
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When changing the number of messages to display, keep in mind that every 
5000 messages require approximately 1 MB. You need to balance your need to 
refer to old messages against the amount of space they take up.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm netlog
Server Only

Full Syntax

mwtm netlog [clear | -r]

Command Description

Uses PAGER to display the contents of the network status log.

To save the current contents of the log, clear the log, and restart the server, enter 
mwtm netlog clear.

To display the contents of the log in reverse order, with the most recent network 
status messages at the beginning of the log, enter mwtm netlog -r.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.
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mwtm netlogger
Server Only

Command Description

Displays the current contents of the network status log file with tail -f.

To stop the display, enter Ctrl-c.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm newlevel
Server Only

Full Syntax

mwtm newlevel [username]

Command Description

If MWTM User-Based Access is enabled, changes the authentication level for the 
specified user. Valid levels are:

• 1—Basic User

• 2—Power User

• 3—Network Operator

• 4—Network Administrator

• 5—System Administrator

See the “Enabling and Changing Users and Passwords (Server Only)” section on 
page 10-16 for more information on the use of this command.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.
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mwtm passwordage
Server Only

Full Syntax

mwtm passwordage [number-of-days | clear]

Command Description

If MWTM User-Based Access is enabled and mwtm authtype is set to local, 
number of days allowed before forcing users to change passwords.

Note Change the password at least once for this command to properly age the password. 

This function is disabled by default. If you do not specify this command, users 
never need to change their passwords.

If you enter the mwtm passwordage command, the valid range is 1 day to an 
unlimited number of days. There is no default setting.

If you have enabled this function and you want to disable it (that is, prevent 
MWTM from forcing users to change passwords), enter mwtm passwordage 
clear.

Note If mwtm authtype is set to solaris, you cannot use this command. Instead, you 
must manage passwords on the external authentication servers.

See the “Automatically Disabling Users and Passwords (Server Only)” section on 
page 10-10 for more information on the use of this command.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.
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mwtm patchlog
Server Only

Full Syntax

mwtm patchlog

Command Description

Uses PAGER to display the contents of the patch log, which lists the patches that 
have been installed on the MWTM server.

The default path and filename for the patch log file is 
/opt/CSCOsgm/install/sgmPatch.log. If you installed MWTM in a directory other 
than /opt, then the patch log file is located in that directory.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm poll
Server Only

Full Syntax

mwtm poll [node] [node]...

Command Description

Enables you to poll one or more known nodes from the command line. Use the 
node arguments to specify the DNS names or IP addresses of one or more known 
nodes.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.
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mwtm pollertimeout
Server Only

Full Syntax

mwtm pollertimeout [number-of-seconds]

Command Description

Specifies how long, in seconds, MWTM clients that are connected to the MWTM 
server can run a demand poller, as in a real-time data window or Web page, before 
MWTM automatically stops the poller to prevent unnecessary traffic on the 
network. When the demand poller times out, MWTM stops the poller and sends 
an appropriate error message to the client.

The valid range is 1 second to an unlimited number of seconds. The default 
timeout is 8 hours (28800 seconds).

After you change the timeout, MWTM asks if you want to restart the MWTM 
server. The new poller timeout takes effect when you restart the MWTM server.

See the “Server Status Information: Pollers” section on page 3-32 for more 
information on demand pollers.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.
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mwtm print
Server Only

Full Syntax

mwtm print {all | data | snmp | task}

Command Description

Displays information about server internal data, SNMP settings, running tasks, or 
all three.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm props
Server and Solaris/Linux Clients Only

Command Description

Displays the contents of the System.properties files for both MWTM server and 
client installs.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.
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mwtm readme
Server and Solaris/Linux Clients Only

Command Description

Displays the contents of the README file for MWTM.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm reboot
Server Only

Command Description

Reboots the Solaris or Linux MWTM system.

Note Use this command with care. Rebooting the Solaris MWTM system disconnects 
all MWTM clients that are using the system. Before using this command, use the 
mwtm who command to list all current users, and the mwtm wall command to 
warn all current users that you are rebooting the system.

You must be logged in as the root user (not as a super user) to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.
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mwtm repdir
Server Only

Full Syntax

mwtm repdir [directory]

Command Description

Sets the directory in which MWTM stores report files. See the “Working with 
MWTM Statistics Reports” section on page 9-1 for information about MWTM 
reports.

The default directory for report files is located in the MWTM installation 
directory:

• If you installed MWTM in the default directory, /opt, then the default 
directory is /opt/CSCOsgm/reports.

• If you installed MWTM in a different directory, then the default directory is 
located in that directory.

Use this command if you want to use a different directory for report files, such as 
a Network File System location on another server.

Note This command copies all files in the current directory to the new directory. If you 
are not logged in as the super user, and you do not own the new directory, you 
might not be able to copy the files. If that is the case, you must specify a directory 
that you own, or you must log in as the root user.

Do not set the new directory to any of the following: /usr, /var, /opt, or /tmp.

Do not set the new directory to the same directory in which you are storing 
message log files (mwtm msglogdir) or route table files (mwtm routedir).

After you change the directory, MWTM asks if you want to restart the MWTM 
server. The new directory takes effect when you restart the MWTM server.

You must be logged in as the root user or as a super user to use this command.
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List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm rephelp
Server Only

Command Description

Displays help for all commands related to MWTM reports.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm replog
Server Only

Full Syntax

mwtm replog [clear | -r]

Command Description

Uses PAGER to display the contents of the system reports log. The reports log 
lists all messages related to the creation and maintenance of MWTM reports.

To clear the log and restart the server, enter mwtm replog clear.

To display the contents of the log in reverse order, with the most recent commands 
at the beginning of the log, enter mwtm replog -r.

The default path and filename for the system reports log file is 
/opt/CSCOsgm/logs/sgmReportLog.txt. If you installed MWTM in a directory 
other than /opt, then the system reports log file is located in that directory.

You must be logged in as the root user or as a super user to use this command.
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List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm restart
Server Only

Full Syntax

mwtm restart [jsp | pm | web]

Command Description

Restarts MWTM servers on the local host:

• jsp—Restarts the MWTM JSP Server.

• pm—Restarts the MWTM Process Manager and all managed processes.

• web—Restarts the MWTM Web Server.

• If you do not specify a keyword, mwtm restart restarts all MWTM servers.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm restore
Server Only

Full Syntax

mwtm restore [ logs | reports | security]

Command Description

Restores the MWTM data files from the previous night’s backup, stored in the 
MWTM installation directory:
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• If you installed MWTM in the default directory, /opt, then the locations of the 
backup files are /opt/mwtm50-client-backup.tar.Z and 
/opt/mwtm50-server-backup.tar.Z.

• If you installed MWTM in a different directory, then the backup files are 
located in that directory.

To restore only specific parts of the MWTM data files, use the following 
keywords:

• logs—Restores only MWTM log files, such as the message log files.

• reports—Restores only MWTM report files, such as the statistics report files.

• security—Restores only the security-related parts of the MWTM data files. 
This command is useful if you inadvertently delete your user accounts or 
make other unwanted changes to your MWTM security information.

To change the directory in which MWTM stores these backup files, use the mwtm 
backupdir command.

You must be logged in as the root user (not as a super user) to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm restoreprops
Server and Solaris/Linux Clients Only

Command Description

Restores the MWTM server and client System.properties files, and other 
important configuration files, to “clean” backup versions of the files.

You must be logged in as the root user (not as a super user) to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.
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mwtm rootvars
Server and Solaris/Linux Clients Only

Command Description

Displays the contents of the /etc/CSCOsgm.sh file, which determines the root 
location of the MWTM server and client installation.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm sechelp
Server Only

Command Description

Displays help for all commands related to MWTM security.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm seclog
Server Only

Full Syntax

mwtm seclog [clear | -r]

Command Description

Uses PAGER to display the contents of the system security log.

The following security events are recorded in the log:
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• All changes to system security, including adding users

• Login attempts, whether successful or unsuccessful, and logoffs

• Attempts to switch to another user's account, whether successful or 
unsuccessful

• Attempts to access files or resources of higher authentication level

• Access to all privileged files and processes

• Operating system configuration changes and program changes, at the Solaris 
level

• MWTM restarts

• Failures of computers, programs, communications, and operations, at the 
Solaris level

To clear the log and restart the server, enter mwtm seclog clear.

To display the contents of the log in reverse order, with the most recent security 
events at the beginning of the log, enter mwtm seclog -r.

The default path and filename for the system security log file is 
/opt/CSCOsgm/logs/sgmSecurityLog.txt. If you installed MWTM in a directory 
other than /opt, then the system security log file is located in that directory.

See the “Displaying the Contents of the System Security Log (Server Only)” 
section on page 10-22 for more information on the use of this command.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm secondaryserver
Server Only

Full Syntax

mwtm secondaryserver [hostname [naming-port] | list]
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Command Description

Configures a secondary MWTM server, where:

• hostname is the name of the host on which the secondary MWTM server is 
installed.

• naming-port is the MWTM Naming Server port number for the secondary 
MWTM server. The default port number is 44742.

For best results, Cisco recommends that you configure the primary server and the 
secondary server as secondaries for each other.

If you use the mwtm secondaryserver command to configure a secondary 
MWTM server, but the primary MWTM server fails before you launch the 
MWTM client, then the MWTM client has no knowledge of the secondary server.

To list the secondary MWTM server that has been configured for this primary 
MWTM server, enter the mwtm secondaryserver list command.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm servername
Server and Solaris/Linux Clients Only

Full Syntax

mwtm servername [hostname]

Command Description

Resets the MWTM server’ default host name, where hostname is the new default 
host name:

• Make sure the new default host name is valid and is defined in your /etc/hosts 
file. If it is not, you might not be able to start the MWTM server.

• If you are not logged in as the root user or as a super user when you enter this 
command from an MWTM client, the default host name is changed only for 
that MWTM client, and for the user who entered the command.
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• If you are logged in as the root user or as a super user when you enter this 
command, the default host name is changed for the MWTM server and for the 
client, and the MWTM server is restarted. The new default host name is used 
by the MWTM server to register RMI services, and by MWTM clients to 
connect to the server.

• If you are logged into a client-only installation as the root user or as a super 
user when you enter this command, the default host name is changed only for 
that MWTM client. The new default host name is used by the MWTM client 
to connect to the MWTM server.

Note Using the mwtm servername command to reset the MWTM server's default host 
name does not affect communication between the MWTM server and the network 
elements.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm setpath
Server and Solaris/Linux Clients Only

Full Syntax

mwtm setpath [username]

Command Description

Appends binary (bin) directories to the path for a user. This enables users to 
append the proper MWTM binary directories to their paths without manually 
editing the .profile and .cshrc files.

This command appends lines such as these to the user's .profile file:

PATH=$PATH:/opt/CSCOsgm/bin:/opt/CSCOsgmClient/bin # CiscoSGM

and appends lines such as these to the user's .cshrc file:

set path=($path /opt/CSCOsgm/bin /opt/CSCOsgmClient/bin) # CiscoSGM

Thereafter, you can enter MWTM commands like this:
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mwtm help

instead of like this:

/opt/CSCOsgm/bin/mwtm help

When entering this command, keep the following considerations in mind:

• If you enter this command and you do not specify a username, MWTM 
appends the bin directories to your path (that is, to the path for the user who 
is currently logged in and entering the mwtm setpath command).

• If you enter this command and you specify a username, MWTM appends the 
bin directories to the path for the specified user. To specify a username, the 
following conditions must all be true:

– You must be logged in as the root user.

– The specified username must exist in the local /etc/passwd file.

– You cannot specify a username that is defined in a distributed Network 
Information Services (NIS) system or in an Network File 
System-mounted (NFS-mounted) home directory.

• If you enter this command more than once for the same user, each command 
overwrites the previous command. MWTM does not append multiple bin 
directories to the same path.

• You might need to use the su - command when entering root-level commands. 
If you use the su command to become the root user, rather than logging in as 
the root user, then you must use the - option.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm snmpcomm
Server Only

Full Syntax

mwtm snmpcomm [name]
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Command Description

Enables you to set a new default SNMP read community name. MWTM 
automatically updates the name in the SNMP parameters file. The default path and 
filename for the SNMP parameters file is /opt/CSCOsgm/etc/communities.conf.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm snmpconf
Server Only

Full Syntax

mwtm snmpconf [filename]

Command Description

Sets the file used for SNMP parameters, such as community names, timeouts, and 
retries.

The default path and filename for the SNMP parameters file is 
/opt/CSCOsgm/etc/communities.conf. If you installed MWTM in a directory other 
than /opt, then the file is located in that directory.

When you specify a new path or filename, MWTM restarts the servers.

Note The SNMP parameters file uses the HP OpenView format. Therefore, you can set 
this path and filename to point to the HP OpenView ovsnmp.conf file in an existing 
OpenView system.

For information about exporting SNMP community names from CiscoWorks 
Resource Manager Essentials (RME), see the “Importing SNMP Community 
Names from CiscoWorks (Solaris Only)” section on page 11-2.

You must be logged in as the root user or as a super user to use this command.
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List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm snmpget
Server Only

Full Syntax

mwtm snmpget [-JJVM_ARG1 [-JJVM_ARG2]...] [-v snmp_version] 
[-c community_string] [-r retry] [-t timeout] [-d output_delimiter] 
[--header|--no-header] [--raw-octets|--no-raw-octets] 
[--str-octets|--no-str-octets] [--raw-timeticks|--no-raw-timeticks] 
[--resolve-integer|--no-resolve-integer] [--resolve-bits|--no-resolve-bits] 
[--get-sysuptime|--no-get-sysuptime] [--detect-mib-error] [--instance oids] 
[--int-instance integer] [--str-instance string] [hostname] [oid] [oid]...

Command Description

Queries the specified hostname using SNMP GetRequests. Use the following 
optional keywords and arguments with this command:

• -JJVM_ARG1—JVM options. The -J keyword and arguments must be 
specified before any other keywords and arguments.

For example, by default JVM uses a maximum of 64 MB of memory. 
However, if you are walking a large table, JVM might require more memory. 
To enable JVM to use a maximum of 256 MB of memory, use the following 
option:

-J-Xmx256m

• -v snmp_version—SNMP protocol version. Valid versions are 1 or 2c. The 
default version is 2c.

• -c community_string—SNMP community string. The default community 
string is specified in the SNMP parameters file, communities.conf.

• -r retry—SNMP retry count. The default retry count is specified in the SNMP 
parameters file, communities.conf.

• -t timeout—SNMP timeout, in seconds. The default timeout is specified in 
the SNMP parameters file, communities.conf.
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• -d output_delimiter—Output delimiter. The default output delimiter is a 
colon (:).

• --header|--no-header—Specifies whether to display variable names as table 
headers:

– Specify --header to display variable names as table headers for tabular 
output, or to display MIB variable OIDs with the value for non-tabular 
output. This is the default setting.

– Specify --no-header if you do not want to display variable names as table 
headers for tabular output, or MIB variable OIDs with the value for 
non-tabular output.

• --raw-octets|--no-raw-octets—Specifies whether to display octets as raw 
octets:

– Specify --raw-octets to display raw octets, such as 6c 69 6e 6b, for octet 
strings.

– Specify --no-raw-octets if you do not want to display raw octets for octet 
strings. This is the default setting.

The other option for displaying octets is --str-octets|--no-str-octets.

• --str-octets|--no-str-octets—Specifies whether to display octets as strings:

– Specify --str-octets to display octets as strings, such as link. This is the 
default setting.

– Specify --no-str-octets if you do not want to display octets as strings.

The other option for displaying octets is --raw-octets|--no-raw-octets.

• --raw-timeticks|--no-raw-timeticks—Specifies the time format:

– Specify --raw-timeticks to specify raw timeticks, such as 2313894.

– Specify --no-raw-timeticks to specify formatted timeticks, such as 
6 Hours 26 Mins 12 Secs. This is the default setting.
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• --resolve-integer|--no-resolve-integer—Specifies the time format:

– Specify --resolve-integer to display integers using the string description 
in the MIB, such as available or unavailable.

– Specify --no-resolve-integer to display integers as numbers. This is the 
default setting.

• --resolve-bits|--no-resolve-bits—Specifies the time format:

– Specify --resolve-bits to display bits using the string description in the 
MIB, such as continue or ruleset.

– Specify --no-resolve-bits to display bits as numbers, such as 1 or 14. 
This is the default setting.

• --get-sysuptime|--no-get-sysuptime—Specifies whether to retrieve the 
sysuptime:

– Specify --get-sysuptime to retrieve the sysuptime in the same packet as 
each SNMP operation.

– Specify --no-get-sysuptime if you do not want to retrieve the sysuptime 
in the same packet. This s the default setting.

• --detect-mib-error—Detects errors in returned MIB variables, such as 
noSuchInstance, noSuchObject, and endOfMibView. If any such errors are 
detected, an error message is printed and an error code is returned.

Sometimes multiple MIB variables are returned at the same time, some of 
which are in error, and some of which are not.

– If this occurs and you specified --detect-mib-error, none of the correct 
values are printed, only the error message, and an error code is returned.

– If this occurs and you did not specify --detect-mib-error, a return code 
of 0 is returned and all MIB variables are printed (even noSuchInstance 
is printed as a returned value). This is the default setting, with 
--detect-mib-error not specified.

• --instance oids—Appends instance OIDs to each polling MIB variable. For 
example, the following commands perform the same function:

mwtm snmpget --instance 172.18.16.10 router_1 ipAdEntIfIndex 
ipAdEntNetMask

mwtm snmpget router_1 ipAdEntIfIndex.172.18.16.10 
ipAdEntNetMask.172.18.16.10
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• --int-instance integer—Appends the specified integer instance OID to each 
polling MIB variable.

• --str-instance string—Appends string instance OIDs to each polling MIB 
variable. For example, the following commands perform the same function:

mwtm snmpget --str-instance link_1 router_1 cItpSpLinksetState

mwtm snmpget router_1 cItpSpLinksetState.6.108.115.110.97.109.101

• hostname—Name of the host to be queried.

• oid—One or more OIDs or variable names.

The default path for the SNMP parameters file, communities.conf, is 
/opt/CSCOsgm/etc/communities.conf. If you installed MWTM in a directory other 
than /opt, then the file is located in that directory. You can edit the file manually 
or using the MWTM client. See the “Configuring SNMP Settings” section on 
page 2-3 for more information.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm snmphelp
Server Only

Command Description

Displays help for all commands related to SNMP queries.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.
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mwtm snmpnext
Server Only

Full Syntax

mwtm snmpnext [-JJVM_ARG1 [-JJVM_ARG2]...] [-v snmp_version] 
[-c community_string] [-r retry] [-t timeout] [-d output_delimiter] 
[--header|--no-header] [--raw-octets|--no-raw-octets] 
[--str-octets|--no-str-octets] [--raw-timeticks|--no-raw-timeticks] 
[--resolve-integer|--no-resolve-integer] [--resolve-bits|--no-resolve-bits] 
[--get-sysuptime|--no-get-sysuptime] [--detect-mib-error] [--instance oids] 
[--int-instance integer] [--str-instance string] [hostname] [oid] [oid]...

Command Description

Queries the specified hostname using SNMP GetNextRequests. Use the following 
optional keywords and arguments with this command:

• -JJVM_ARG1—JVM options. The -J keyword and arguments must be 
specified before any other keywords and arguments.

For example, by default JVM uses a maximum of 64 MB of memory. 
However, if you are walking a large table, JVM might require more memory. 
To enable JVM to use a maximum of 256 MB of memory, use the following 
option:

-J-Xmx256m

• -v snmp_version—SNMP protocol version. Valid versions are 1 or 2c. The 
default version is 2c.

• -c community_string—SNMP community string. The default community 
string is specified in the SNMP parameters file, communities.conf.

• -r retry—SNMP retry count. The default retry count is specified in the SNMP 
parameters file, communities.conf.

• -t timeout—SNMP timeout, in seconds. The default timeout is specified in 
the SNMP parameters file, communities.conf.

• -d output_delimiter—Output delimiter. The default output delimiter is a 
colon (:).
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• --header|--no-header—Specifies whether to display variable names as table 
headers:

– Specify --header to display variable names as table headers for tabular 
output, or to display MIB variable OIDs with the value for non-tabular 
output. This is the default setting.

– Specify --no-header if you do not want to display variable names as table 
headers for tabular output, or MIB variable OIDs with the value for 
non-tabular output.

• --raw-octets|--no-raw-octets—Specifies whether to display octets as raw 
octets:

– Specify --raw-octets to display raw octets, such as 6c 69 6e 6b, for octet 
strings.

– Specify --no-raw-octets if you do not want to display raw octets for octet 
strings. This is the default setting.

The other option for displaying octets is --str-octets|--no-str-octets.

• --str-octets|--no-str-octets—Specifies whether to display octets as strings:

– Specify --str-octets to display octets as strings, such as link. This is the 
default setting.

– Specify --no-str-octets if you do not want to display octets as strings.

The other option for displaying octets is --raw-octets|--no-raw-octets.

• --raw-timeticks|--no-raw-timeticks—Specifies the time format:

– Specify --raw-timeticks to specify raw timeticks, such as 2313894.

– Specify --no-raw-timeticks to specify formatted timeticks, such as 
6 Hours 26 Mins 12 Secs. This is the default setting.

• --resolve-integer|--no-resolve-integer—Specifies the time format:

– Specify --resolve-integer to display integers using the string description 
in the MIB, such as available or unavailable.

– Specify --no-resolve-integer to display integers as numbers. This is the 
default setting.
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• --resolve-bits|--no-resolve-bits—Specifies the time format:

– Specify --resolve-bits to display bits using the string description in the 
MIB, such as continue or ruleset.

– Specify --no-resolve-bits to display bits as numbers, such as 1 or 14. 
This is the default setting.

• --get-sysuptime|--no-get-sysuptime—Specifies whether to retrieve the 
sysuptime:

– Specify --get-sysuptime to retrieve the sysuptime in the same packet as 
each SNMP operation.

– Specify --no-get-sysuptime if you do not want to retrieve the sysuptime 
in the same packet. This s the default setting.

• --detect-mib-error—Detects errors in returned MIB variables, such as 
noSuchInstance, noSuchObject, and endOfMibView. If any such errors are 
detected, an error message is printed and an error code is returned.

Sometimes multiple MIB variables are returned at the same time, some of 
which are in error, and some of which are not.

– If this occurs and you specified --detect-mib-error, none of the correct 
values are printed, only the error message, and an error code is returned.

– If this occurs and you did not specify --detect-mib-error, a return code 
of 0 is returned and all MIB variables are printed (even noSuchInstance 
is printed as a returned value). This is the default setting, with 
--detect-mib-error not specified.

• --instance oids—Appends instance OIDs to each polling MIB variable. For 
example, the following commands perform the same function:

mwtm snmpget --instance 172.18.16.10 router_1 ipAdEntIfIndex 
ipAdEntNetMask

mwtm snmpget router_1 ipAdEntIfIndex.172.18.16.10 
ipAdEntNetMask.172.18.16.10

• --int-instance integer—Appends the specified integer instance OID to each 
polling MIB variable.
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• --str-instance string—Appends string instance OIDs to each polling MIB 
variable. For example, the following commands perform the same function:

mwtm snmpget --str-instance link_1 router_1 cItpSpLinksetState

mwtm snmpget router_1 cItpSpLinksetState.6.108.115.110.97.109.101

• hostname—Name of the host to be queried.

• oid—One or more OIDs or variable names.

The default path for the SNMP parameters file, communities.conf, is 
/opt/CSCOsgm/etc/communities.conf. If you installed MWTM in a directory other 
than /opt, then the file is located in that directory. You can edit the file manually 
or using the MWTM client. See the “Configuring SNMP Settings” section on 
page 2-3 for more information.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm snmpwalk
Server Only

Full Syntax

mwtm snmpwalk [-JJVM_ARG1 [-JJVM_ARG2]...] [-v snmp_version] 
[-c community_string] [-r retry] [-t timeout] [-x maximum_rows] 
[-d output_delimiter] [--tabular|--no-tabular] [--getbulk|--no-getbulk] 
[--header|--no-header] [--raw-octets|--no-raw-octets] 
[--str-octets|--no-str-octets] [--raw-timeticks|--no-raw-timeticks] 
[--resolve-integer|--no-resolve-integer] [--resolve-bits|--no-resolve-bits] 
[--get-sysuptime|--no-get-sysuptime] [--detect-mib-error] [--instance oids] 
[--int-instance integer] [--str-instance string] [hostname] [oid] [oid]...
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Command Description

Queries the specified hostname, using SNMP GetNextRequests to “walk” through 
the MIB. Use the following optional keywords and arguments with this command:

• -JJVM_ARG1—JVM options. The -J keyword and arguments must be 
specified before any other keywords and arguments.

For example, by default JVM uses a maximum of 64 MB of memory. 
However, if you are walking a large table, JVM might require more memory. 
To enable JVM to use a maximum of 256 MB of memory, use the following 
option:

-J-Xmx256m

• -v snmp_version—SNMP protocol version. Valid versions are 1 or 2c. The 
default version is 2c.

• -c community_string—SNMP community string. The default community 
string is specified in the SNMP parameters file, communities.conf.

• -r retry—SNMP retry count. The default retry count is specified in the SNMP 
parameters file, communities.conf.

• -t timeout—SNMP timeout, in seconds. The default timeout is specified in 
the SNMP parameters file, communities.conf.

• -x maximum_rows—Maximum number of rows to be walked. If a table has 
more than the maximum number of rows, the mwtm snmpwalk command 
fails. You can use the -m keyword and argument to increase the maximum 
number of rows that can be walked. The default setting is 10,000 rows.

However, for every 10,000 rows walked, JVM requires an additional 10 MB 
of memory. You can use the -J keyword and argument to increase the memory 
available to JVM.

• -d output_delimiter—Output delimiter. The default output delimiter is a 
colon (:).

• --tabular|--no-tabular—Specifies whether to print the result of the query in 
tabular format:

– Specify --tabular to print the result in tabular format. This is the default 
setting.

– Specify --no-tabular if you do not want to print the result in tabular 
format.
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• --getbulk|--no-getbulk—(SNMP version 2c only) Specifies whether to use 
the getbulk command to walk the table:

– Specify --getbulk to use the getbulk command. This is the default 
setting.

– Specify --no-getbulk if you do not want to use the getbulk command.

• --header|--no-header—Specifies whether to display variable names as table 
headers:

– Specify --header to display variable names as table headers for tabular 
output, or to display MIB variable OIDs with the value for non-tabular 
output. This is the default setting.

– Specify --no-header if you do not want to display variable names as table 
headers for tabular output, or MIB variable OIDs with the value for 
non-tabular output.

• --raw-octets|--no-raw-octets—Specifies whether to display octets as raw 
octets:

– Specify --raw-octets to display raw octets, such as 6c 69 6e 6b, for octet 
strings.

– Specify --no-raw-octets if you do not want to display raw octets for octet 
strings. This is the default setting.

The other option for displaying octets is --str-octets|--no-str-octets.

• --str-octets|--no-str-octets—Specifies whether to display octets as strings:

– Specify --str-octets to display octets as strings, such as link. This is the 
default setting.

– Specify --no-str-octets if you do not want to display octets as strings.

The other option for displaying octets is --raw-octets|--no-raw-octets.

• --raw-timeticks|--no-raw-timeticks—Specifies the time format:

– Specify --raw-timeticks to specify raw timeticks, such as 2313894.

– Specify --no-raw-timeticks to specify formatted timeticks, such as 
6 Hours 26 Mins 12 Secs. This is the default setting.
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• --resolve-integer|--no-resolve-integer—Specifies the time format:

– Specify --resolve-integer to display integers using the string description 
in the MIB, such as available or unavailable.

– Specify --no-resolve-integer to display integers as numbers. This is the 
default setting.

• --resolve-bits|--no-resolve-bits—Specifies the time format:

– Specify --resolve-bits to display bits using the string description in the 
MIB, such as continue or ruleset.

– Specify --no-resolve-bits to display bits as numbers, such as 1 or 14. 
This is the default setting.

• --get-sysuptime|--no-get-sysuptime—Specifies whether to retrieve the 
sysuptime:

– Specify --get-sysuptime to retrieve the sysuptime in the same packet as 
each SNMP operation.

– Specify --no-get-sysuptime if you do not want to retrieve the sysuptime 
in the same packet. This s the default setting.

• --detect-mib-error—Detects errors in returned MIB variables, such as 
noSuchInstance, noSuchObject, and endOfMibView. If any such errors are 
detected, an error message is printed and an error code is returned.

Sometimes multiple MIB variables are returned at the same time, some of 
which are in error, and some of which are not.

– If this occurs and you specified --detect-mib-error, none of the correct 
values are printed, only the error message, and an error code is returned.

– If this occurs and you did not specify --detect-mib-error, a return code 
of 0 is returned and all MIB variables are printed (even noSuchInstance 
is printed as a returned value). This is the default setting, with 
--detect-mib-error not specified.

• --instance oids—Appends instance OIDs to each polling MIB variable. For 
example, the following commands perform the same function:

mwtm snmpget --instance 172.18.16.10 router_1 ipAdEntIfIndex 
ipAdEntNetMask

mwtm snmpget router_1 ipAdEntIfIndex.172.18.16.10 
ipAdEntNetMask.172.18.16.10
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• --int-instance integer—Appends the specified integer instance OID to each 
polling MIB variable.

• --str-instance string—Appends string instance OIDs to each polling MIB 
variable. For example, the following commands perform the same function:

mwtm snmpget --str-instance link_1 router_1 cItpSpLinksetState

mwtm snmpget router_1 cItpSpLinksetState.6.108.115.110.97.109.101

• hostname—Name of the host to be queried.

• oid—One or more OIDs or variable names.

The default path for the SNMP parameters file, communities.conf, is 
/opt/CSCOsgm/etc/communities.conf. If you installed MWTM in a directory other 
than /opt, then the file is located in that directory. You can edit the file manually 
or using the MWTM client. See the “Configuring SNMP Settings” section on 
page 2-3 for more information.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm sounddir
Server Only

Full Syntax

mwtm sounddir [directory]

Command Description

Sets the directory in which the MWTM server stores event automation sound files. 
See the “Changing the Way MWTM Processes Events” section on page 5-26 for 
information about sound files.
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The default directory for sound files is located in the MWTM installation 
directory:

• If you installed MWTM in the default directory, /opt, then the default 
directory is /opt/CSCOsgm/sounds.

• If you installed MWTM in a different directory, then the default directory is 
located in that directory.

Use this command if you want to use a different directory for MWTM server event 
automation sound files, such as a Network File System location on another server.

Note This command copies all files in the current directory to the new directory. If you 
are not logged in as the super user, and you do not own the new directory, you 
might not be able to copy the files. If that is the case, you must specify a directory 
that you own, or you must log in as the root user.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm ssl
Server Only

Full Syntax

mwtm ssl [enable | disable | status]

Command Description

If you have obtained the SSL-enabled version of MWTM and installed an SSL 
key/certificate pair in MWTM, you can use this command to manage SSL support 
in MWTM:

• enable—Enables SSL support. If you enter this command and SSL has not 
been implemented in your MWTM system, MWTM prompts you to contact 
Cisco TAC or your Cisco Account Team for help in implementing SSL.

• disable—Disables SSL support.
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• status—Displays the current status of SSL support in MWTM, including 
whether SSL support is enabled or disabled and which SSL keys and 
certificates exist.

See the “Implementing SSL Support in MWTM (Solaris Only)” section on 
page 10-27 for more information on the use of this command.

You must be logged in as the root user (not as a super user) to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm sslstatus
Server Only

Command Description

If SSL is implemented in your MWTM system, displays current status for SSL 
support in MWTM, including whether SSL support is enabled or disabled and 
which SSL keys and certificates exist.

See the “Implementing SSL Support in MWTM (Solaris Only)” section on 
page 10-27 for more information on the use of this command.

You must be logged in as the root user (not as a super user) to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm start
Server Only

Command Description

Starts all MWTM servers on the local host.

You must be logged in as the root user or as a super user to use this command.
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List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm start client
Server and all Clients

Full Syntax

mwtm start client [hostname]

Command Description

Starts an MWTM client on the specified host. If no host name is specified, starts 
an MWTM client on the default host, as specified during installation. See the 
“Connecting to a New Server” section on page 3-42 for information about 
determining the default host.

If you Telnet into a remote workstation, the DISPLAY variable must be set to your 
local display, or you cannot use this command. If the DISPLAY variable is not set 
automatically, you must set it manually. See the “Setting the DISPLAY Variable 
(Client Only)” section on page 11-40 for details.

This command has the same function as the mwtm client command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm start jsp
Server Only

Command Description

Starts the MWTM JSP Server on the local host.

You must be logged in as the root user or as a super user to use this command.
C-73
Cisco Mobile Wireless Transport Manager User Guide

OL-7637-01



 

Appendix C      MWTM Command Reference
mwtm start pm
List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm start pm
Server Only

Command Description

Starts the MWTM Process Manager and all managed processes on the local host.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm start web
Server Only

Command Description

Starts the MWTM Web Server on the local host.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm statreps clean
Server Only

Command Description

Removes all data from MWTM network statistics reports, restoring the reports to 
a “clean” state.
C-74
Cisco Mobile Wireless Transport Manager User Guide

OL-7637-01



 

Appendix C      MWTM Command Reference
mwtm statreps cleancustom
You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm statreps cleancustom
Server Only

Full Syntax

mwtm statreps cleancustom [tag]

Command Description

Removes all data from one or more MWTM custom statistics reports, restoring 
the reports to a “clean” state:

• To clean all custom reports, enter mwtm statreps cleancustom.

• To clean a single custom report, enter mwtm statreps cleancustom tag, 
where tag is the ID tag of the custom report you want to clean.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm statreps custage
Server Only

Full Syntax

mwtm statreps custage [number-of-days]

Command Description

Maximum number of days MWTM is to archive custom reports.
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If you enter this command without the number-of-days argument, MWTM 
displays the current maximum number of days. You can then change that value, 
or leave it as-is. The valid range is 1 day to an unlimited number of days. The 
default value is 10 days.

This command has the same function as the mwtm repcustage command.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm statreps dailyage
Server Only

Full Syntax

mwtm statreps dailyage [number-of-days]

Command Description

Maximum number of days MWTM is to archive daily network statistics reports.

If you enter this command without the number-of-days argument, MWTM 
displays the current maximum number of days. You can then change that value, 
or leave it as-is. The valid range is 1 day to an unlimited number of days. The 
default value is 90 days.

This command has the same function as the mwtm repdailyage command.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.
C-76
Cisco Mobile Wireless Transport Manager User Guide

OL-7637-01



 

Appendix C      MWTM Command Reference
mwtm statreps diskcheck
mwtm statreps diskcheck
Server Only

Full Syntax

mwtm statreps [diskcheck | nodiskcheck]

Command Description

Specifies whether MWTM is to verify that a disk has at least 10 MB of space 
remaining before generating network statistics reports:

• diskcheck—Verify the disk space. This is the default setting.

• nodiskcheck—Do not verify the disk space.

If your system does not return the necessary amount of free space, in a correct 
format that MWTM can parse, this command enables MWTM to disable checking 
to allow reporting to continue.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm statreps enable
Server Only

Full Syntax

mwtm statreps [disable | enable]

Command Description

Enables MWTM to generate network statistics reports:

• enable—Generate network statistics reports. This is the default setting.

• disable—Do not generate network statistics reports.

You must enter this command to enable MWTM to generate network statistics 
reports.
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You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm statreps export
Server Only

Full Syntax

mwtm statreps [export | noexport]

Command Description

Specifies whether MWTM is to generate network statistics reports in export 
format:

• export—Generate network statistics reports in export format. This is the 
default setting.

• noexport—Do not generate network statistics reports in export format.

Network statistics reports in export format are Zip files that contain 
comma-separated value (CSV) text files that you can download and unzip. 

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm statreps hourlyage
Server Only

Full Syntax

mwtm statreps hourlyage [number-of-days]
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Command Description

Maximum number of days MWTM is to archive hourly network statistics reports.

If you enter this command without the number-of-days argument, MWTM 
displays the current maximum number of days. You can then change that value, 
or leave it as-is. The valid range is 1 day to an unlimited number of days. The 
default value is 31 days.

This command has the same function as the mwtm rephourlyage command.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm statreps servratio
Server Only

Full Syntax

mwtm statreps servratio [factor]

Command Description

Displays a gray background in the InSrv cell in a network statistics report, if the 
following condition is met:

Current In-Service < factor * Long-Term In-Service

The default value for factor is 0.95.

You must be logged in as the root user or as a super user to use this command.
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mwtm statreps status
Server Only

Command Description

Displays the current status of all MWTM network statistics report parameters. 
These are the parameters that are set using the other mwtm statreps commands, 
such as mwtm statreps [disable | enable] and mwtm statreps 
[diskcheck | nodiskcheck].

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm statreps timemode
Server Only

Full Syntax

mwtm statreps timemode [12 | 24]

Command Description

Sets the time mode for dates in network statistics reports:

• 12—Use 12-hour time, with AM and PM. 1:00 in the afternoon is 1:00 PM.

• 24—Use 24-hour time, also called military time. 1:00 in the afternoon is 
13:00. This is the default setting.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.
C-80
Cisco Mobile Wireless Transport Manager User Guide

OL-7637-01



 

Appendix C      MWTM Command Reference
mwtm statreps timer
mwtm statreps timer
Server Only

Command Description

Displays the timer file for MWTM network statistics reports. The timer file is 
useful for identifying how much time MWTM spends gathering report data and 
generating reports.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm statreps utilratio
Server Only

Full Syntax

mwtm statreps utilratio [factor]

Command Description

Displays a gray background in the Send Utilization or Receive Utilization cell in 
a network statistics report, if the following condition is met:

Current Utilization > factor * Long-Term Utilization

The default value for factor is 1.50.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.
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mwtm status
Server Only

Command Description

Displays the status of all MWTM servers on the local host.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm stop
Server Only

Command Description

Stops all MWTM servers on the local host.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm stopclients
Server and Solaris/Linux Clients Only

Command Description

Forcefully stops all MWTM clients on the local host.

You must be logged in as the root user (not as a super user) to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.
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mwtm stop jsp
Server Only

Command Description

Stops the MWTM JSP Server on the local host.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm stop pm
Server Only

Command Description

Stops the MWTM Process Manager and all managed processes on the local host.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm stop web
Server Only

Command Description

Stops the MWTM Web Server on the local host.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.
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mwtm superuser
Server Only

Full Syntax

mwtm superuser [username]

Command Description

Enables the specified user to perform most functions that otherwise require the 
user to be logged in as the root user. (The root user can still perform those 
functions, too.) The specified user account must exist in the local /etc/passwd file. 
You cannot specify a user that is defined in a distributed Network Information 
Services (NIS) system.

Note As a super user, you can adversely affect your operating environment if you are 
unaware of the effects of the commands you use. If you are a relatively 
inexperienced UNIX user, limit your activities as a super user to the tasks 
described in this document.

For a complete list of the MWTM commands that a super user cannot use, as well 
as other super user considerations, see the “Specifying a Super User (Server 
Only)” section on page 10-24.

You must be logged in as the root user (not as a super user) to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm syncusers
Server Only

Command Description

If MWTM User-Based Access is enabled and mwtm authtype is set to solaris, 
synchronizes local MWTM passwords with Solaris.
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See the “Manually Synchronizing Local MWTM Passwords (Server Only)” 
section on page 10-21 for more information on the use of this command.

You must be logged in as the root user (not as a super user) to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm tac
Server Only

Command Description

Collects important troubleshooting information for the Cisco Technical 
Assistance Center, and writes the information to the 
/opt/CSCOsgm/tmp/cisco_sgm_tshoot.log file.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm telnetpath
Server and all Clients

Command Description

Specifies the path to the Telnet application to use for Telnet sessions on the 
MWTM client, as well as any special parameters to pass to the Telnet application.

• On Solaris, the default path is /usr/bin/telnet.

• On Windows, you do not need to specify a path. Windows detects and 
launches the Telnet application wherever it is located.

You must be logged in as the root user (not as a super user) to use this command.
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List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm tnproxy
Server Only

Full Syntax

mwtm tnproxy [disable | enable | status]

Command Description

Manages a Telnet proxy. A Telnet proxy resides on a server and forwards Telnet 
requests from clients to network elements that are accessible only from that 
server. A Telnet proxy is typically used to enable remote clients on desktop 
networks to Telnet to network elements that otherwise would be unreachable.

• disable—Disables MWTM Telnet proxy support. This is the default setting.

• enable—Enables MWTM to use a Telnet proxy, and prompts you to restart 
the MWTM server. When you restart the server, MWTM automatically starts 
the Telnet proxy process.

• status—Indicates whether MWTM Telnet proxy support is currently enabled 
or disabled.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm trapaccess
Server Only

Full Syntax

mwtm trapaccess [add [ip-addr] | clear | edit | list | rem [ip-addr] | sample]
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Command Description

Enables you to create and manage a list of network element IP addresses allowed 
to send traps to the MWTM server.

The list of allowed network element IP addresses is contained in the 
trapaccess.conf file. By default, when you first install MWTM, the 
trapaccess.conf file does not exist and MWTM allows all IP addresses to send 
traps to the MWTM server. To create the trapaccess.conf file and work with the 
list of allowed client IP addresses, specify one of the following keywords:

• add—Add the specified IP address to the trapaccess.conf file. If the file does 
not already exist, this command creates the file containing the first entry.

• clear—Remove all IP addresses from the trapaccess.conf file, and allow traps 
from any MWTM client IP address.

• edit—Open and edit the trapaccess.conf file directly. If the trapaccess.conf 
file does not already exist, this command creates an empty file.

• list—List all IP addresses currently in the trapaccess.conf file. If no IP 
addresses are listed (that is, the list is empty), traps from any MWTM IP 
address are allowed.

• rem—Remove the specified IP address from the trapaccess.conf file.

• sample—Print out a sample trapaccess.conf file.

Any changes you make take effect when you restart the MWTM server.

See the “Limiting Traps by IP Address (Server Only)” section on page 11-38 for 
more information about using this command.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm trapsetup
Server Only

Full Syntax

mwtm trapsetup [disable]
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Command Description

Stops the MWTM server, configures MWTM to receive SNMP traps (or prevents 
MWTM from receiving traps), then restarts the MWTM server. MWTM gives you 
the option to receive traps natively or using HP OpenView.

When you select an SNMP trap port number for the MWTM server, make sure 
your network elements use the same SNMP trap port number. See the description 
of the snmp-server host command in the “RAN-O Requirements” section of the 
Cisco Mobile Wireless Transport Manager Installation Guide for more 
information.

To prevent MWTM from receiving traps, enter the mwtm trapsetup disable 
command. MWTM restarts the MWTM server.

You must be logged in as the root user (not as a super user) to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm trapstatus
Server Only

Command Description

Displays the current trap reception configuration for MWTM, including:

• SNMP trap integration type:

– native—MWTM receives traps natively on a UDP port.

– hpov—MWTM receives traps using HP OpenView.

• For native, MWTM also displays the UDP port number on which MWTM 
receives traps natively.

• For hpov, MWTM also displays the location of the HP OpenView home 
directory.

• Status for the sgmTrapReceiver (such as Running or Stopped).

List of MWTM Commands

• MWTM Command Reference, page C-1.
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mwtm uninstall
Server and Solaris/Linux Clients Only

Command Description

Uninstalls MWTM.

You must be logged in as the root user (not as a super user) to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm unknownage
Server Only

Full Syntax

mwtm unknownage [number-of-days]

Command Description

Sets the maximum number of days to retain Unknown objects before deleting 
them from the MWTM database.

If you enter this command without the number-of-days argument, MWTM 
displays the current maximum number of days. You can then change that value, 
or leave it as-is. The valid range is 1 day to an unlimited number of days. The 
default value is 7 days. Setting this value to 0 days means that after one hour, 
Unknown objects will be deleted.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.
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mwtm updateuser
Server Only

Full Syntax

mwtm updateuser [username]

Command Description

If MWTM User-Based Access is enabled, changes the authentication level for the 
specified user. Valid levels are:

• 1—Basic User

• 2—Power User

• 3—Network Operator

• 4—Network Administrator

• 5—System Administrator

If mwtm authtype is set to local, this command also enables you to change the 
following settings:

• User’s password. When setting the password, follow the rules and 
considerations in the “Creating Secure Passwords” section on page 10-6.

See the “Enabling and Changing Users and Passwords (Server Only)” section on 
page 10-16 for more information on authentication levels, and on the use of this 
command.

You must be logged in as the root user or as a super user to use this command.

Note If you have enabled Solaris authentication, you must be logged in as the root user, 
not a super user, to use this command. See the “Implementing MWTM 
User-Based Access (Server Only)” section on page 10-2 for more information.

List of MWTM Commands

• MWTM Command Reference, page C-1.
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mwtm useraccess
Server Only

Full Syntax

mwtm useraccess [disable | enable]

Command Description

Enables or disables MWTM User-Based Access.

User-Based Access provides multi-level password-protected access to MWTM 
features. Each user can have a unique user name and password. Each user can also 
be assigned to one of five levels of access, which control the list of MWTM 
features accessible by that user.

You must enable MWTM User-Based Access in order to use the associated 
MWTM security commands.

See the “Implementing MWTM User-Based Access (Server Only)” section on 
page 10-2 for more information.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm userpass
Server Only

Full Syntax

mwtm userpass [username]

Command Description

If MWTM User-Based Access is enabled and mwtm authtype is set to local, 
changes the specified user’s MWTM security authentication password.
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mwtm version
If the user’s authentication has been disabled, either automatically by MWTM or 
by a super user, this command re-enables the user’s authentication with a new 
password.

If sgm authtype is set to solaris, you cannot use this command. Instead, you must 
manage passwords on the external authentication servers.

See the “Enabling and Changing Users and Passwords (Server Only)” section on 
page 10-16 for more information on the use of this command.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm version
Server and Solaris/Linux Clients Only

Command Description

Displays version information for MWTM servers and clients on the local host.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm viewlog
Server Only

Command Description

Uses PAGER to display the contents of the system message log.

To save the current contents of the log, clear the log, and restart the server, enter 
mwtm viewlog clear.

To display the contents of the log in reverse order, with the most recent messages 
at the beginning of the log, enter mwtm msglog -r.
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mwtm wall
This command has the same function as the mwtm msglog command.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm wall
Server Only

Full Syntax

mwtm wall message_string

Command Description

Sends a message to all clients connected to the server. For example:

./mwtm wall Server going down at 9:00 pm tonight.

sends the following message:

Server going down at 9:00 pm tonight.

MWTM ignores quotation marks in message_string. To include quotation marks, 
use the escape character (\) in combination with quotation marks. For example:

./mwtm wall Example of the \”mwtm wall\” command.

sends the following message:

Example of the “mwtm wall” command.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.
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mwtm webaccesslog
mwtm webaccesslog
Server Only

Full Syntax

mwtm webaccesslog [clear | -r]

Command Description

Uses PAGER to display the MWTM system Web access log file for the server to 
which you are connected, and which is currently running the MWTM server. The 
system Web access log lists all MWTM system Web access messages that have 
been logged for the MWTM server. This provides an audit trail of all access to the 
MWTM server via the Web interface.

To clear the log and restart the server, enter mwtm webaccesslog clear.

To display the contents of the log in reverse order, with the most recent Web 
access messages at the beginning of the log, enter mwtm webaccesslog -r.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm weberrorlog
Server Only

Full Syntax

mwtm weberrorlog [clear | -r]

Command Description

Uses PAGER to display the MWTM Web server error log file for the server to 
which you are connected, and which is currently running the MWTM server. The 
Web server error log lists all MWTM Web error messages that have been logged 
for the MWTM Web server.

To clear the log and restart the server, enter mwtm weberrorlog clear.
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mwtm weblogupdate
To display the contents of the log in reverse order, with the most recent Web error 
messages at the beginning of the log, enter mwtm weberrorlog -r.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm weblogupdate
Server Only

Full Syntax

mwtm weblogupdate [interval | disable]

Command Description

Controls how often, in seconds, MWTM updates certain Web output.

When you enter this command, MWTM displays the current interval. You can 
then change that value, or leave it as-is. The valid range is 1 second to an 
unlimited number of seconds. The default value is 300 seconds (5 minutes).

To disable the update interval, enter the mwtm weblogupdate disable command. 
This option lessens MWTM’s CPU usage on both the server and client.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm webnames
Server Only

Full Syntax

mwtm webnames [display | real]
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mwtm webport
Command Description

Specifies whether MWTM is to show real node names or display names in Web 
pages:

• real—Show the real DNS names of nodes in Web pages, as discovered by 
MWTM.

• display—Show display names in Web pages. Display names are new names 
that you specify for nodes. This is the default setting. For more information 
about display names, see the “Editing a Node” section on page 6-53.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm webport
Server Only

Full Syntax

mwtm webport [port-number]

Command Description

Sets a new port number for the Web server, where port-number is the new, 
numeric port number. MWTM verifies that the new port number is not already in 
use.

The new port number must contain only numbers. If you enter a port number that 
contains non-numeric characters, such as mwtm13, MWTM displays an error 
message and returns to the command prompt without changing the port number.

You must be logged in as the root user (not as a super user) to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.
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mwtm webutil
mwtm webutil
Server Only

Full Syntax

mwtm webutil [percent | erlangs]

Command Description

Specifies whether MWTM is to display send and receive utilization for linksets 
and links as percentages or in Erlangs, in Web pages:

• percent—MWTM displays utilization as a percentage. This is the default 
setting.

• erlangs—MWTM displays utilization in Erlangs.

See the “Working with MWTM Statistics Reports” section on page 9-1 for more 
information on the use of this command.

You must be logged in as the root user or as a super user to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.

mwtm who
Server Only

Command Description

Displays a list of all client user names and processes connected to the server.

List of MWTM Commands

• MWTM Command Reference, page C-1.
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mwtm xtermpath
mwtm xtermpath
Server or Solaris/Linux Clients Only

Command Description

Specifies the path to the xterm application to use for xterm sessions on the 
MWTM client, as well as any special parameters to pass to the xterm application.

The default path is /usr/openwin/bin/xterm.

If one of the special parameters that you pass to the xterm application is a title, 
the title can contain dashes (-) and underscores (_), but it cannot contain any 
spaces.

You must be logged in as the root user (not as a super user) to use this command.

List of MWTM Commands

• MWTM Command Reference, page C-1.
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MWTM MIB Reference

MWTM queries the following MIBs, listed in alphabetical order:

MIB Description

CISCO-ENVMON-MIB.my
(1.3.6.1.4.1.9.9.13) 

Provides environmental monitoring information on Cisco devices.

CISCO-EPM-NOTIFICATION-MIB.my
(1.3.6.1.4.1.9.9.311) 

Defines the trap structure that carries the identity and status info of 
the managed object. MWTM can send internal events as traps 
defined in this MIB to third-party NMS applications for further 
processing.

CISCO-HSRP-MIB.my
(1.3.6.1.4.1.9.9.106)

Provides a means to monitor and configure the Cisco IOS 
proprietary Hot Standby Router Protocol (HSRP). Cisco HSRP 
protocol is defined in RFC2281. 

CISCO-HSRP-EXT-MIB.my
(1.3.6.1.4.1.9.9.107)

Provides an extension to the CISCO-HSRP-MIB which defines 
Cisco's proprietary Hot Standby Routing Protocol (HSRP). The 
extensions cover assigning of secondary HSRP IP addresses and 
modifying an HSRP group's priority by tracking the operational 
status of interfaces. 

CISCO-IP-RAN-BACKHAUL-MIB.my
(1.3.6.1.4.1.9.9.483)

Provides information on the optimization of IP-RAN traffic 
between the Base Transceiver Station (BTS) and Base Station 
Controller (BSC).  It handles both GSM Abis and UMTS lub traffic. 

CISCO-PROCESS-MIB.my
(1.3.6.1.4.1.9.9.109) 

Displays estimated memory and CPU utilization on Cisco devices. 
CPU utilization gives a general idea of how busy the processor is. 
The numbers are a ratio of the current idle time divided by the 
longest idle time.
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CISCO-SMI.my
(no OID)
(1.3.6.1.4.1.9)

Defines the Structure of Management Information for the Cisco 
enterprise.

CISCO-SYSLOG-MIB.my
(1.3.6.1.4.1.9.9.41) 

Provides a means of gathering syslog messages generated by the 
Cisco IOS. MWTM can send internal events as traps defined in this 
MIB to third-party NMS applications for further processing.

CISCO-TC.my
(1.3.6.1.4.1.9.12.1)

Defines textual conventions used throughout Cisco enterprise 
MIBs.

ENTITY-MIB.my
(1.3.6.1.2.1.47)

Defines multiple logical entities supported by a single SNMP agent.

IANAifType-MIB.my
(no OID)
(1.3.6.1.2.1.30)

Defines the IANAifType Textual Convention, and thus the 
enumerated values of the ifType object defined in MIB-II's ifTable.

IF-MIB.my
(1.3.6.1.2.1.31)

Describes generic objects for network interface sub-layers. This 
MIB is an updated version of MIB-II's ifTable, and incorporates the 
extensions defined in RFC 1229.

INET-ADDRESS-MIB.my
(1.3.6.1.2.1.76)

Defines textual conventions for representing Internet addresses. An 
Internet address can be an IPv4 address, an IPv6 address, or a DNS 
domain name. This module also defines textual conventions for 
Internet port numbers, autonomous system numbers, and the length 
of an Internet address prefix.

MIB-II mib (RFC1213-MIB.my)
(1.3.6.1.2.1) 

Provides basic management information on the device (RFC 1213).

OLD-CISCO-INTERFACES-MIB.my
(1.3.6.1.4.1.9.2.2)

Defines interfaces for the Cisco enterprise.

OLD-CISCO-SYS-MIB.my
(1.3.6.1.4.1.9.2.1.1)

Provides a means of gathering basic information for a router.

SNMP-FRAMEWORK-MIB.my
(1.3.6.1.6.3.10)

Defines the SNMP Management Architecture.

SNMP-TARGET-MIB.my
(1.3.6.1.6.3.12)

Defines the MIB objects that provide mechanisms to remotely 
configure the parameters used by an SNMP entity for the generation 
of SNMP messages.

SNMPv2-CONF.my
(no OID)

Defines SNMPv2 conformance.

MIB Description
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You can obtain the latest versions of these MIBs from one of the following 
locations:

• The Zip file mibs.zip, located at the top of the MWTM DVD Image, contains 
these MIBs.

• You can download these MIBs from the Cisco Website:

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

SNMPv2-MIB.my
(1.3.6.1.6.3.1)

Defines SNMPv2 entities.

SNMPv2-SMI.my
(defines several high-level OIDs)

Defines the Structure of Management Information for SNMPv2.

SNMPv2-TC.my
(no OID)

Defines textual conventions for SNMPv2.

MIB Description
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MWTM Trap Reference

MWTM supports the following traps, listed in alphabetical order:

Trap Name Description

ciscoEnvMonFanNotification A ciscoEnvMonFanNotification trap is generated if any one 
of the fans in the fan array (where extant) fails. Since such a 
notification is usually generated before the shutdown state is 
reached, it can convey more data and has a better chance of 
being sent than does the ciscoEnvMonShutdownNotification.

AuthenticationFailure An AuthenticationFailure trap is generated when the server is 
accessed using a wrong SNMP community string.

ciscoEnvMonRedundantSupplyNotification A ciscoEnvMonRedundantSupplyNotification trap is 
generated if the redundant power supply (where extant) fails. 
Since such a notification is usually generated before the 
shutdown state is reached, it can convey more data and has a 
better chance of being sent than does the 
ciscoEnvMonShutdownNotification.

ciscoEnvMonShutdownNotification A ciscoEnvMonShutdownNotification trap is generated if the 
environmental monitor detects a testpoint reaching a critical 
state and is about to initiate a shutdown. This notification 
contains no objects so that it may be encoded and sent in the 
shortest amount of time possible. Even so, management 
applications should not rely on receiving such a notification 
as it may not be sent before the shutdown completes.
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ciscoEnvMonTemperatureNotification A ciscoEnvMonTemperatureNotification trap is generated if 
the temperature measured at a given testpoint is outside the 
normal range for the testpoint (that is, is at the warning, 
critical, or shutdown stage). Since such a Notification is 
usually generated before the shutdown state is reached, it can 
convey more data and has a better chance of being sent than 
does the ciscoEnvMonShutdownNotification.

ciscoEnvMonVoltageNotification A ciscoEnvMonVoltageNotification trap is generated if the 
voltage measured at a given testpoint is outside the normal 
range for the testpoint (that is, is at the warning, critical, or 
shutdown stage). Since such a notification is usually 
generated before the shutdown state is reached, it can convey 
more data and has a better chance of being sent than does the 
ciscoEnvMonShutdownNotification.

ciscoIpRanBackHaulGsmAlarm A ciscoIpRanBackHaulGsmAlarm trap is generated when the 
values of the following objects change: connect state, local 
alarm state, remote alarm state, and redundancy state.

ciscoIpRanBackHaulUmtsAlarm A ciscoIpRanBackHaulUmtsAlarm trap is generated when 
the values of the following objects change: connect state, 
received local state, received remote state, transmit local 
state, transmit remote state, and redundancy state.

ciscoIpRanBackHaulRcvdUtil A ciscoIpRanBackHaulRcvdUtil trap is generated when a 
received utilization state changes to a new state.

ciscoIpRanBackHaulSentUtil A ciscoIpRanBackHaulSentUtil trap is generated when a sent 
utilization state changes to a new state.

ciscoRFProgressionNotif A ciscoRFProgressionNotif trap is sent by the active 
redundant unit whenever its RF state changes or the RF state 
of the peer unit changes.

ciscoRFSwactNotif A ciscoRFSwactNotif trap is sent by the newly active 
redundant unit whenever a switch of activity (SWACT) 
occurs. In the case where a SWACT event may be 
indistinguishable from a reset event, a network management 
station should use this notification to differentiate the 
activity.

Trap Name Description
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coldStart A coldStart trap is generated when the SNMPv2 entity, acting 
in an agent role, is reinitializing itself and that its 
configuration may have been altered.

cpmCPUFallingThreshold A cpmCPUFallingThreshold trap is generated when CPU 
utilization is below the falling threshold.

cpmCPURisingThreshold A cpmCPURisingThreshold trap is generated when CPU 
utilization is above the rising threshold.

linkDown A linkDown trap is generated when a link goes down.

linkUp A linkUp trap is generated when a link comes up.

warmStart A warmStart trap is generated when the SNMPv2 entity, 
acting in an agent role, is reinitializing itself such that its 
configuration is unaltered.

Trap Name Description
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Configuring MWTM to Run with 
Various Networking Options

In addition to running on standard IP-connected networks, MWTM has the 
flexibility to adapt to a variety of different networking environments, including 
Virtual Private Network (VPN), Network Address Translation (NAT), firewall, 
port-forwarding, and Secure Sockets Layer (SSL). MWTM can run in each of 
these environments individually, or in any combination of networking 
environments.

This appendix describes communication between the MWTM client and the 
MWTM server. As shown in Figure F-1, this includes:

• Two-way RMI communication between a Java-based GUI client and 
Java-based server processes. The client can send requests to and receive 
responses from the server, and the server can send unsolicited notifications to 
the client. For example, if the server detects that an node’s state has changed, 
it sends a notification to all MWTM clients to update their Topology 
Windows.

• One-way HTTP communication between a Web browser and an 
MWTM-embedded Web server, using the request/response model.
F-1
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VPN Communication
Figure F-1 MWTM Communication

Note This appendix does not address communication between the MWTM server and 
the RAN-O node, which uses the SNMP protocol for network management.

This appendix includes the following sections:

• VPN Communication, page F-2

• NAT Communication, page F-3

• Firewall Communication, page F-5

• Port-Forwarding Communication, page F-9

• Additional Network Configurations, page F-11

• SSL Communication, page F-12

VPN Communication
MWTM client/server communication can run transparently through a VPN 
tunnel, which is a secure IP layer, without any user intervention. You can use VPN 
to connect to a corporate network, then start the MWTM client to connect through 
the VPN tunnel to an MWTM server in the corporate network.

When the client host establishes a VPN tunnel, the operating system (or system 
library) sees this as another virtual IP interface. The VPN tunnel does not affect 
HTTP communication between the Web browser and server, it only affects RMI 
communication between the MWTM client and server processes.
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Java-based
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processes
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NAT Communication
For HTTP communication, the virtual IP address is transparent to the upper layer. 
The operating system automatically chooses the correct IP address to send out the 
request packet. For RMI communication, the MWTM client needs to register with 
the MWTM server server using the correct IP address, so that the server can 
invoke RMI callbacks and send unsolicited notifications to the client. 

MWTM solves this problem by automatically detecting the local IP interface so 
that the MWTM server can send unsolicited notification to the correct IP address.

Figure F-2 shows a sample VPN network with the following characteristics:

• The MWTM client with IP address 192.168.0.1 is connected to the MWTM 
server network through a VPN tunnel.

• The MWTM client host has obtained VPN IP address 10.1.1.2, which is a 
virtual IP interface.

Figure F-2 VPN Communication

When connecting to the MWTM server, the MWTM client automatically 
recognizes its VPN IP address, 10.1.1.2, and uses that address to register with the 
MWTM server to receive RMI callbacks. This configuration is transparent to the 
user; no manual configuration is needed.

NAT Communication
MWTM client/server communication can run through one or more static 
NAT-connected networks. (MWTM does not support dynamic NAT or dynamic 
NAT pool overloading.)
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NAT Communication
In a static NAT network, the MWTM client and server are located on different 
sides of the NAT network, with no routes between the client network and the 
server network. The NAT device statically maps the client IP address to a NAT 
address in the server network, and the server IP address to a NAT address in the 
client network.

The NAT device translates packets between the MWTM client and server by 
replacing IP address headers when packets pass through. From the client's point 
of view, the server appears to be at a NAT IP address in the client network, and 
vice versa. For most protocols, this technique is sufficient to enable the client and 
server to communicate.

However, for RMI protocol, this is not sufficient. RMI protocol requires the client 
and server to keep remote object references by remote stubs. These remote stubs 
contain the remote objects' IP addresses, and are passed between the client and 
server using Java serialization. The NAT device only converts the IP addresses in 
the IP packet header, but the remote stub object is within the packet content. 
Therefore, the NAT device cannot recognize the IP address inside the packet, and 
fails to route it correctly.

MWTM solves this problem by creating a specialized NAT-aware socket factory. 
Some manual configuration on the part of the user is required to enable MWTM 
to “know” the network NAT configuration.

Figure F-3 shows a sample static NAT network with the following characteristics:

• A static NAT device connects Network A (192.168.*.*) to Network B 
(10.*.*.*), with no routes between Network A and Network B.

• The NAT device maps MWTM client IP address 192.168.0.1 in Network A to 
10.1.1.2 in Network B.

• The NAT device maps MWTM server IP address 10.0.0.1 in Network B to 
192.168.1.2 in Network A.

Figure F-3 Static NAT Communication
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Firewall Communication
To configure MWTM in this static NAT network, you must change the MWTM 
client's RMIOverNAT.properties file.

• In Solaris/Linux, if you installed MWTM in the default directory, /opt, then 
the location of the file is 
/opt/CSCOsgmClient/properties/RMIOverNAT.properties.

• In Windows, if you installed MWTM in the default directory, /opt, then the 
location of the file is 
C:\Program Files\SGMClient\properties\RMIOverNAT.properties.

• If you installed MWTM in a different directory, then the file is located in that 
directory.

For the example shown in Figure F-3, you must add the following line to the file:

10.0.0.1 = 192.168.1.2

This line maps the MWTM server's real IP address, 10.0.0.1 in Network B, to its 
NAT address, 192.168.1.2, in Network A, which is the server's IP address as seen 
by the client.

Note The MWTM server automatically detects the MWTM client's NAT address. No 
manual configuration on the part of the user is needed at the server side.

Firewall Communication
To enable MWTM client/server communication through a firewall, you need to set 
up the firewall so that it allows MWTM communication packets to pass through 
freely.

Note The MWTM client and server communicate using TCP sockets. All port numbers 
in this section are TCP ports.
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Firewall Communication
The port number used by MWTM is configured in the System.properties file:

• If you installed MWTM in the default directory, /opt, then the location of the 
file is /opt/CSCOsgm/properties/System.properties.

• If you installed MWTM in a different directory, then the file is located in that 
directory.

Set the following parameters on the server side of the file:

RMIREGISTRY_PORT = 44742

DATASERVER_PORT = 0

MLSERVER_PORT = 0

PMSERVER_PORT = 0

LOGINSERVER_PORT = 0

WEB_PORT = 1744

where:

• RMIREGISTRY_PORT is the port on which the RMI naming server listens. 
You must specify a port number; 0 is not allowed.

• DATASERVER_PORT is the port on which the sgmDataServer process 
listens. If you specify 0, MWTM uses any available port, 1024 and above.

• MLSERVER_PORT is the port on which the sgmMsgLogServer process 
listens. If you specify 0, MWTM uses any available port, 1024 and above.

• PMSERVER_PORT is the port on which the sgmProcMgrServer process 
listens. If you specify 0, MWTM uses any available port, 1024 and above.

• LOGINSERVER_PORT is the port on which the Login service in the 
sgmDataServer process listens. If you specify 0, MWTM uses any available 
port, 1024 and above.

• WEB_PORT is the port on which the MWTM Web server listens. You must 
specify a port number; 0 is not allowed. To change the WEB_PORT number, 
use the mwtm webport command. See the “mwtm webport” section on 
page C-96 for more information.

If any of these port numbers changes, you must restart the MWTM server before 
the changes take effect.
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Firewall Communication
Set the following parameters in the MWTM client’s RMIOverNAT.properties file:

RMIREGISTRY_PORT = 44742

CLIENT_PORT = 0

where:

• RMIREGISTRY_PORT is the port on which the server-side RMI naming 
server listens. This port number must match the one specified for the 
RMIREGISTRY_PORT on the server side.

• CLIENT_PORT is the port on which the MWTM client listens for RMI 
callbacks (unsolicited notifications):

– If you specify CLIENT_PORT = 0, MWTM uses any available port, 
1024 and above.

– If you specify CLIENT_PORT with a single value other than 0, such as 
CLIENT_PORT = 33459, MWTM uses that port, and you can run only 
one MWTM client process at a time.

– If you specify CLIENT_PORT with a range of values other than 0, such 
as CLIENT_PORT = 33459-33479, MWTM can use any of the ports in 
the range, including the beginning and ending ports, and you can run 
more than one MWTM client process at a time.

If any of these port numbers changes, you must restart the MWTM client before 
the changes take effect.

The MWTM client’s System.properties file is located in the properties directory:

• In Solaris/Linux, if you installed MWTM in the default directory, /opt, then 
the location of the file is /opt/CSCOsgmClient/properties/System.properties.

• In Windows, if you installed MWTM in the default directory, /opt, then the 
location of the file is 
C:\Program Files\SGMClient\properties\System.properties.

• If you installed MWTM in a different directory, then the file is located in that 
directory.
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Firewall Communication
Figure F-4 shows a sample firewall network with the following parameters set in 
the System.properties file:

• On the MWTM server side:

RMIREGISTRY_PORT = 44742

DATASERVER_PORT = 44751

MLSERVER_PORT = 44752

PMSERVER_PORT = 44753

LOGINSERVER_PORT = 44754

WEB_PORT = 1774

• On the MWTM client side:

RMIREGISTRY_PORT = 44742

CLIENT_PORT = 56173

Figure F-4 Firewall Communication

MWTM Client Firewall
device MWTM Server

192.168.1.1 192.168.2.2

Allow TCP connection from 192.168.1.1 to 192.168.2.2,
ports 44742, 44751, 44752, 44753, 44754, and 1774

Network A
192.168.1.*

Network B
192.168.2.*
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Allow TCP connection from 192.168.2.2 to 192.168.1.1,
port 56173
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Port-Forwarding Communication
Port-Forwarding Communication
To enable MWTM to operate in a TCP port-forwarding environment, perform the 
following configuration tasks:

Step 1 Configure the server hostname and port number mapping in the MWTM client’s 
RMIOverNAT.properties file, as described in the “NAT Communication” section 
on page F-3.

Step 2 Configure the port numbers used by the MWTM client and server in the 
System.properties file, as described in the “Firewall Communication” section on 
page F-5.

Step 3 Configure the port-forwarding tunnel to forward each side’s TCP connection to 
the other side.

Figure F-5 shows a sample network that uses Secure Shell (SSH) port-forwarding. 
Other port-forwarding configurations might use a single host with dual interfaces 
at the client’s and server's networks. While other port-forwarding configurations 
may differ from this example, the general rules to configure MWTM to operate in 
a port-forwarding environment are the same.

Figure F-5 Port-Forwarding Communication

MWTM Client

SSH tunnel

MWTM Server

192.168.0.1 10.0.0.1

Network A
192.168.*.*

Network B
10.*.*.*
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Port-Forwarding Communication
The port-forwarding network shown in Figure F-5 has the following parameters 
set;

• In the System.properties file, on the MWTM server side:

RMIREGISTRY_PORT = 44742

DATASERVER_PORT = 44751

MLSERVER_PORT = 44752

PMSERVER_PORT = 44753

LOGINSERVER_PORT = 44754

WEB_PORT = 1774

• In the System.properties file, on the MWTM client side:

RMIREGISTRY_PORT = 44742

CLIENT_PORT = 56173

• In the MWTM client's RMIOverNAT.properties file:

10.0.0.1/44742 = 127.0.0.1/25742

10.0.0.1/44751 = 127.0.0.1/25751

10.0.0.1/44752 = 127.0.0.1/25752

10.0.0.1/44753 = 127.0.0.1/25753

10.0.0.1/44754 = 127.0.0.1/25754

10.0.0.1/1774 = 127.0.0.1/8080

• In the port-forwarding network:

Local port 25751 => remote host 127.0.0.1, port 44742

Local port 25751 => remote host 127.0.0.1, port 44751

Local port 25752 => remote host 127.0.0.1, port 44752
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Additional Network Configurations
Local port 25753 => remote host 127.0.0.1, port 44753

Local port 25754 => remote host 127.0.0.1, port 44754

Local port 8080 => remote host 127.0.0.1, port 1774

Remote port 56173 => local host 127.0.0.1, port 56173

Note For port-forwarding setup, the backward-forwarding port numbers 
must match each other. In the above example, both are 56173. The 
forward-forwarding port numbers do not need to match each other.

If you want to run more than one MWTM client process at the same 
time on the same device, you must specify CLIENT_PORT with a 
range of values other than 0, such as CLIENT_PORT = 
33459-33479, in the MWTM client’s RMIOverNAT.properties file. 
See the “Firewall Communication” section on page F-5 for more 
information about specifying the CLIENT_PORT parameter. You 
must also set up the backward-forwarding port numbers to use a range 
of values.

Additional Network Configurations
There are numerous other network configurations that are not directly addressed 
here. The MWTM client and server can work with most of these networks, as long 
as the MWTM client and server can establish an SSH connection. 

A few examples of alternative network configurations are as follows:

• Dynamic NAT, where the MWTM client and server are on two different sides 
of the dynamic NAT network.

• A situation where the MWTM client is in a trusted network and the MWTM 
server is in a public network, but the firewall does not allow a direct TCP 
connection made from the MWTM server to the MWTM client.

• A situation wher e the MWTM server is in a trusted network and the MWTM 
client is in a public network, but the firewall does not allow a direct TCP 
connection made from MWTM client to MWTM server.
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SSL Communication
To allow MWTM client and server communication in these network 
environments, you can establish a SSH connection between the MWTM client and 
the MWTM server using SSH port-forwarding (for details, see Port-Forwarding 
Communication, page F-9). 

SSL Communication
If SSL is implemented and enabled in your MWTM system, MWTM uses secure 
socket communication for both RMI and HTTP communication between the 
MWTM client and server.

MWTM supports standard-based SSL encryption algorithms, including RSA, 
DSA public key algorithms, and 40-bit or 128-bit encryption. MWTM can 
generate an X.509 certificate and a certificate signing request (CSR), which is 
interoperable with most certificate authorities (CAs).

Both the MWTM Web server and the MWTM server processes share the same 
SSL key/certificate pair. Both the MWTM client and the Web browser can 
examine the server's certificate.

For more information, including descriptions of the MWTM commands and 
procedures used to implement, enable, manage, and monitor SSL support, see the 
“Implementing SSL Support in MWTM (Solaris Only)” section on page 10-27.

Figure F-6 shows a sample MWTM-over-SSL network with the following 
characteristics:

• A user-generated SSL key pair on the MWTM server.

• The server's certificate is trusted on the MWTM client.

• Communication between the client and server is RMI-over-SSL and HTTPS. 
Both protocols are encrypted and secure.
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SSL Communication
Figure F-6 SSL Communication
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SSL Communication
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MWTM Statistics Export File Formats

This appendix lists the formats for the following MWTM statistics export files:

• MWTM Capacity Planning Data Export, page G-1

• MWTM 15 Minutes Statistics Data Export, page G-2

MWTM Capacity Planning Data Export
Export files for MWTM capacity planning data export files use the following 
format:

# ====================================================================
# Format of Backhaul Utilization Summary Export File (Hourly/Daily/Monthly/Yearly)
#
#
 
# Field Variables Description
# 
------------------------------------------------------------------------------------------
# 1  Node Name of the Name
# 2  Interface Backhaul Interface
# 3  Protocol Traffic type, could be All, GSM or UMTS
# 4  Direction Direction of the traffic, send or receive
# 5  00-09% Percentage of traffic runs within 00-09% bandwidth 
# 6  10-19% Percentage of traffic runs within 10-19% bandwidth 
# 7  20-29% Percentage of traffic runs within 20-29% bandwidth 
# 8  30-39% Percentage of traffic runs within 30-39% bandwidth 
# 9  40-49% Percentage of traffic runs within 40-49% bandwidth 
# 10 50-59% Percentage of traffic runs within 50-59% bandwidth 
# 11 60-69% Percentage of traffic runs within 60-69% bandwidth 
# 12 70-79% Percentage of traffic runs within 70-79% bandwidth 
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MWTM 15 Minutes Statistics Data Export
# 13 80-89% Percentage of traffic runs within 80-89% bandwidth 
# 14 90-100% Percentage of traffic runs within 90-100% bandwidth 
# 15 Peak Util Peak Utilization
# 16 Peak Date Date when the first peak traffic occurs
# 17 Peak Time Time when the first peak traffic occurs
# 18 Bandwidth (Kbits/Sec) Total available bandwidth

MWTM 15 Minutes Statistics Data Export
Export files for MWTM 15 minutes statistics data export files use the following 
format:

# ======================================================================
#  Format of Backhaul Utilization 15 Minutes Raw Statistics Export File 
(Hourly/Daily/Monthly/Yearly)
#
#
 
# Field Variables Description
# 
------------------------------------------------------------------------------------------
# 1  Node Name of the Name
# 2  Interface Backhaul Interface
# 3  Date Date when the data is collected
# 4  Time Time when the data is collected
# 5  Protocol Traffic type, could be All, GSM or UMTS
# 6  Direction Direction of the traffic, send or receive
# 7  00-09% Percentage of traffic runs within 00-09% bandwidth 
# 8  10-19% Percentage of traffic runs within 10-19% bandwidth 
# 9  20-29% Percentage of traffic runs within 20-29% bandwidth 
# 10  30-39% Percentage of traffic runs within 30-39% bandwidth 
# 11  40-49% Percentage of traffic runs within 40-49% bandwidth 
# 12 50-59% Percentage of traffic runs within 50-59% bandwidth 
# 13 60-69% Percentage of traffic runs within 60-69% bandwidth 
# 14 70-79% Percentage of traffic runs within 70-79% bandwidth 
# 15 80-89% Percentage of traffic runs within 80-89% bandwidth 
# 16 90-100% Percentage of traffic runs within 90-100% bandwidth 
# 17 Peak Util Peak Utilization
# 18 Peak Date Date when the first peak traffic occurs
# 19 Peak Time Time when the first peak traffic occurs
# 20 Bandwidth (Kbits/Sec) Total available bandwidth
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MWTM and Ports

MWTM uses the following default ports to provide services:

Port Name or Number Port Type Description

1774 tcp Apache web server

1775 tcp TOMCAT JSP server

44742 tcp Java RMI naming service

dynamic port 1 tcp Java RMI service for Process Manager. A network or system 
administrator can specify a fixed port using the 
PMSERVER_PORT parameter in the System.properties file. 

Note If you installed MWTM in the default directory, /opt, 
then the location of the System.properties file is 
/opt/CSCOsgm/properties/System.properties. If you 
installed MWTM in a different directory, then the 
System.properties file is located in that directory.

dynamic port 2 tcp Java RMI service for Login Service. A network or system 
administrator can specify a fixed port using the 
LOGINSERVER_PORT parameter in the System.properties 
file.

Note If you installed MWTM in the default directory, /opt, 
then the location of the System.properties file is 
/opt/CSCOsgm/properties/System.properties. If you 
installed MWTM in a different directory, then the 
System.properties file is located in that directory.
H-1
ireless Transport Manager User Guide



 

Appendix H      MWTM and Ports
dynamic port 3 tcp Java RMI service for MWTM Data Server. A network or system 
administrator can specify a fixed port using the 
DATASERVER_PORT parameter in the System.properties file.

Note If you installed MWTM in the default directory, /opt, 
then the location of the System.properties file is 
/opt/CSCOsgm/properties/System.properties. If you 
installed MWTM in a different directory, then the 
System.properties file is located in that directory.

dynamic port 4 tcp Java RMI service for MWTM Message Logger. A network or 
system administrator can specify a fixed port using the 
MLSERVER_PORT parameter in the System.properties file.

Note If you installed MWTM in the default directory, /opt, 
then the location of the System.properties file is 
/opt/CSCOsgm/properties/System.properties. If you 
installed MWTM in a different directory, then the 
System.properties file is located in that directory.

dynamic port 5 tcp Java RMI service for MWTM Telnet Proxy. A network or 
system administrator can specify a fixed port using the 
TELNETPROXY_PORT parameter in the System.properties 
file.

Note This port is enabled only when the MWTM Telnet 
Proxy process is enabled. By default, the MWTM 
Telnet Proxy process is disabled in MWTM.

If you installed MWTM in the default directory, /opt, 
then the location of the System.properties file is 
/opt/CSCOsgm/properties/System.properties. If you 
installed MWTM in a different directory, then the 
System.properties file is located in that directory.

Port Name or Number Port Type Description
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162 udp SNMP trap listener

dynamic ports 1-5 udp SNMP request senders. These ports are used by the SNMP stack 
for sending SNMP requests. A maximum of 5 can be opened in 
MWTM. You can customize the number of ports by changing 
the SNMP_SOCKET_NUMBER parameter in the 
Server.properties file.

Note If you installed MWTM in the default directory, /opt, 
then the location of the Server.properties file is 
/opt/CSCOsgm/properties/Server.properties. If you 
installed SGM in a different directory, then the 
Server.properties file is located in that directory.

Port Name or Number Port Type Description
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G L O S S A R Y
This glossary contains MWTM-specific terms. For an online listing of other internetworking terms and 
acronyms, refer to the following URL:

• http://www.cisco.com/univercd/cc/td/doc/cisintwk/ita/index.htm

A

active alarm Network object with the following status:

• A link that is Warning (yellow) or worse and is not Ignored.

• A node that is Pending (red) or worse and is not Ignored.

adjacent node In MWTM, for a given pair of connected RAN-O nodes, the node that MWTM 
discovered second. See node.

aggregate site A Base Station Controller (BSC) or Radio Network Controller (RNC) site where 
traffic is collected for multiple cell sites. See cell site.

ANSI American National Standards Institute.

auto save Setting that enables MWTM to save changes automatically when you exit 
MWTM.

auto start Setting that enables MWTM to start a process automatically when the Process 
Manager is started. See Data Server, Message Log Server, Process Manager, 
Trap Receiver.
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B

browser GUI-based hypertext client application, such as Internet Explorer, Netscape 
Navigator, or Mozilla, used to access hypertext documents and other services 
located on innumerable remote servers throughout the World Wide Web (WWW) 
and Internet.

C

circle layout Topology map layout in which objects are arranged in a circle, connected by 
links. Contrast with spring layout. See topology map.

cell site A Base Transceiver Station (BTS) or Node B site, usually located at the remote 
site with limited connectivity. See aggregate site.

Cisco IOS software Cisco Internetwork Operating System software. Cisco system software that 
provides common functionality, scalability, and security for many Cisco 
products. The Cisco IOS software allows centralized, integrated, and automated 
installation and management of internetworks, while ensuring support for a wide 
variety of protocols, media, services, and platforms.

CLI Command line interface. An interface that allows the user to interact with the 
Cisco IOS software operating system by entering commands and optional 
arguments.

client Node or software program that requests services from a server. The MWTM user 
interface is an example of a client. See also server.

client view User-customized subset of the DEFAULT view. See also DEFAULT view, view.

command line 

interface

See CLI.

community name See community string.
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community string Text string that acts as a password and is used to authenticate messages sent 
between a management station and a RAN-O node containing an SNMP agent. 
The community string is sent in every packet between the manager and the agent. 
Also called community name, read community.

congestion Condition in which a link has too many packets waiting to be sent. This 
condition could be caused by the failure of an element in the network. Possible 
levels are None, Low, High, and Very High, which correspond roughly to 
equivalent ANSI, China standard, ITU, NTT, and TTC congestion levels.

console log Log containing unexpected error and warning messages from the MWTM server, 
such as those that might occur if the MWTM server cannot start.

current view View that is currently in use on an MWTM client. The view can be the 
DEFAULT view or a customized view. Also called current view. See client view, 
DEFAULT view.

D

Data Server Multi-threaded process that handles most of the work done by MWTM, 
including Discovery, polling, and scheduling. See also Message Log Server, 
Process Manager, Trap Receiver.

DEFAULT view View into which MWTM places all discovered objects when discovering the 
network. The DEFAULT view is stored on the MWTM server and shared by all 
MWTM clients, but it cannot be modified by the clients. See current view, view.

demand polling User-initiated poll of selected nodes. Contrast with status polling.

device See node.

device type In MWTM, the type of a discovered device, either a Cisco device or a BTS or 
BSC device. Also called system object ID. See legacy device.

diamond In topology maps, indicator for a link that is part of a configured interface, 
associated with the closest node. See topology.

discovered Object that has been discovered by MWTM. Also called known. Contrast with 
unknown.
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Discovery Process by which MWTM discovers objects in your network. See also 
nonrecursive Discovery, recursive Discovery.

display name User-specified name for a node. Contrast with DNS name. See also node name.

domain name The style of identifier—a sequence of case-insensitive ASCII labels separated by 
dots (“bbn.com.”)—defined for subtrees in the Internet Domain Name System 
[R1034] and used in other Internet identifiers, such as host names, mailbox 
names, and URLs.

Domain Name 

System

 See DNS.

double triangle In topology maps, indicator for a connection that has multiple interfaces. See 
topology map.

DNS Domain Name System. System used on the Internet for translating names of 
network nodes into addresses.

DNS name Initial name of a node, as discovered by MWTM. Contrast with display name. 
See also node name.

E

event forwarding See trap forwarding.

exclude Removing a network object from a view, while retaining the object in the 
MWTM data model.
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G

GSM ITU standard for defining the Global System for Mobile communications. 

graphical element Graphical representation of an object or view in the topology map. See topology 
map.

graphical user 

interface

See GUI.

GUI Graphical user interface. User environment that uses pictorial as well as textual 
representations of the input and output of applications and the hierarchical or 
other data structure in which information is stored. Conventions such as buttons, 
icons, and windows are typical, and many actions are performed using a pointing 
device (such as a mouse). Microsoft Windows and the Apple Macintosh are 
prominent examples of platforms utilizing a GUI.

H

host Computer system on a network. Similar to the term node except that host usually 
implies a computer system, whereas node generally applies to any network 
system, including access servers and RAN-O devices. See also node.

host address See host number.

host number Part of an IP address that designates which node on the subnetwork is being 
addressed. Also called a host address.

HTML Hypertext Markup Language. Simple hypertext document formatting language 
that uses tags to indicate how a given part of a document should be interpreted 
by a viewing application, such as a Web browser. See also hypertext and 
browser.
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hypertext Electronically-stored text that allows direct access to other texts by way of 
encoded links. Hypertext documents can be created using HTML, and often 
integrate images, sound, and other media that are commonly viewed using a 
browser. See also HTML and browser.

Hypertext Markup 

Language

See HTML.

I

ignore Exclude an object when aggregating and displaying MWTM status information. 
See also unignore.

IMSI International Mobile Subscriber Identity. A unique 15-digit code that identifies 
an individual user on a GSM network.

installation log Log containing messages and other information recorded during installation.

internal ID Unique identifier assigned by MWTM, for its own internal use, to every event, 
link, linkset, and node.

Internet Protocol See IP.

IP Internet Protocol. Network layer protocol in the TCP/IP stack offering a 
connectionless internetwork service. IP provides features for addressing, 
type-of-service specification, fragmentation and reassembly, and security. 
Documented in RFC 791.

IP address 32-bit address assigned to hosts using TCP/IP. An IP address belongs to one of 
five classes (A, B, C, D, or E) and is written as 4 octets separated by periods 
(dotted decimal format). Each address consists of a network number, an optional 
subnetwork number, and a host number. The network and subnetwork numbers 
together are used for routing, while the host number is used to address an 
individual host within the network or subnetwork. A subnet mask is used to 
extract network and subnetwork information from the IP address. CIDR provides 
a new way of representing IP addresses and subnet masks. See also IP.

ITU International Telecommunication Union.
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K

known See discovered.

L

legacy device In MWTM, a device that is not a Cisco RAN-O node. Legacy devices include 
BSCs and BTSs.

link In RAN-O networks, the connection between nodes. See node.

local authentication Type of MWTM security authentication that allows the creation of user accounts 
and passwords local to the MWTM system. When using this method, user 
names, passwords, and access levels are managed using MWTM commands. 
Contrast with Solaris authentication.

For more information on Solaris authentication, see the “Implementing MWTM 
User-Based Access (Server Only)” section on page 10-2.

local IP address IP address used by the MWTM client to connect to the MWTM server.

local VPN IP address IP address used by the MWTM client to connect to the MWTM server via VPN. 
See local IP address, VPN.

M

managed object Link or node that is being managed by MWTM.

Management 

Information Base

See MIB.

Message Log Server Multi-threaded service that logs messages from the Data Server, Process 
Manager, and MWTM client. See also Data Server, Process Manager, Trap 
Receiver.
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MIB Management Information Base. Database of network management information 
that is used and maintained by a network management protocol such as SNMP. 
The value of a MIB object can be changed or retrieved using SNMP commands, 
usually through a GUI network management system. MIB objects are organized 
in a tree structure that includes public (standard) and private (proprietary) 
branches.

mouse over help Popups that display information about objects and table entries.

N

name server Server connected to a network that resolves network names into network 
addresses.

network 

management 

system

See NMS.

network view See view.

new node Node that MWTM has newly discovered, and that has not yet been added to the 
current view.

NMS Network management system. System responsible for managing at least part of 
a network. An NMS is generally a reasonably powerful and well-equipped 
computer such as an engineering workstation. NMSes communicate with agents 
to help keep track of network statistics and resources.

node Endpoint of a network connection or a junction common to two or more lines in 
a network. Nodes can be processors, controllers, or workstations. Nodes, which 
vary in routing and other functional capabilities, can be interconnected by links, 
and serve as control points in the network.

In RAN-O networks, a node is a Cisco Mobile Wireless Router (MWR).

See legacy device.

node name Name of a node. This is either the DNS name of the node, or a user-specified 
name. See display name, DNS name.
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nonrecursive 

Discovery

Discovery of seed nodes only. MWTM discovers all seed nodes and attempts to 
manage them, then marks all nodes that are adjacent to those seed nodes as 
Unmanaged. Contrast with recursive Discovery.

note User-defined descriptive string attached to an object.

O

object Link or node that has been discovered by MWTM.

P

PAGER Environment variable that causes the terminal to display text output one 
screenful at a time. This variable is usually set to either /usr/bin/more or 
/usr/bin/less, which are two common pager executables.

ping Packet internet groper. ICMP echo message and its reply. Often used in IP 
networks to test the reachability of a network device.

polling Access method in which a primary network device inquires, in an orderly 
fashion, whether secondaries have data to transmit. The inquiry occurs in the 
form of a message to each secondary that gives the secondary the right to 
transmit.

poll interval Time between polls.

poll response Time taken by a node to respond to MWTM poll requests.

port In IP terminology, an upper-layer process that receives information from lower 
layers. Ports are numbered, and each numbered port is associated with a specific 
process. For example, SMTP is associated with port 25. A port number is also 
called a well-known address.

preferences Settings that enable a user to change the way MWTM presents information.
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primary SNMP 

address

IP address used by SNMP to poll the node. (There might be other IP addresses 
on the node that are not the primary SNMP address.) Contrast with secondary IP 
address.

process Internal component of MWTM. See Data Server, Message Log Server, Process 
Manager, Trap Receiver.

Process Manager Multi-threaded process that handles the management of registered MWTM 
services. See also Data Server, Message Log Server, Trap Receiver.

Q

QoS Quality of service. Measure of performance for a transmission system that 
reflects its transmission quality and service availability.

Quality of Service See QoS.

R

read community See community string.

recursive Discovery Discovery of the entire network. MWTM discovers all seed nodes and attempts 
to manage them; then attempts to discover and manage all RAN-O nodes that are 
adjacent to those seed nodes (unless the nodes are connected by serial links 
only); then attempts to discover and manage all RAN-O nodes that are adjacent 
to those nodes; and so on, until MWTM has discovered the entire network.

Contrast with nonrecursive Discovery.

route Path through an internetwork.
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S

secondary IP 

address

Alternate or backup IP address used by a node. Contrast with primary SNMP 
address.

seed file List of seed nodes. See seed node.

seed node Node used by MWTM to discover the other objects in your network.

serial Method of data transmission in which the bits of a data character are transmitted 
sequentially over a single channel.

server Node or software program that provides services to clients. See client.

Simple Network 

Management 

Protocol

See SNMP.

SMPP Short Message Peer-to-Peer Protocol. A messaging protocol meant to simplify 
integration of data applications with wireless mobile networks such as GSM.

SNMP Simple Network Management Protocol. Network management protocol used 
almost exclusively in TCP/IP networks. SNMP provides a means to monitor and 
control network devices, and to manage configurations, statistics collection, 
performance, and security.

Solaris 

authentication

Type of MWTM security authentication that uses standard Solaris-based user 
accounts and passwords, as specified in the /etc/nsswitch.conf file. 
Authentication can be provided by the local /etc/passwd file or from a distributed 
Network Information Services (NIS) system. Contrast with local authentication.

For more information on Solaris authentication, see the “Implementing MWTM 
User-Based Access (Server Only)” section on page 10-2.

spring layout Topology map layout in which objects are arranged in a spring layout. Objects 
with the most links are drawn closer to the center of the map, while objects with 
fewer links are drawn farther away. Contrast with circle layout. See topology 
map.

status Current condition, such as Active or Unknown, of a network object.
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status polling Regularly scheduled polling of nodes performed by MWTM. Contrast with 
demand polling.

super user User specified in MWTM to be able to perform most functions that otherwise 
require the user to be logged in as the root user.

For more information, see the “Specifying a Super User (Server Only)” section 
on page 10-24.

system object ID See device type.

T

TCP Transmission Control Protocol. Connection-oriented transport layer protocol 
that provides reliable full-duplex data transmission. TCP is part of the TCP/IP 
protocol stack. See also TCP/IP.

TCP/IP Transmission Control Protocol/Internet Protocol. Common name for the suite of 
protocols developed by the U.S. DoD in the 1970s to support the construction of 
worldwide internetworks. TCP and IP are the two best-known protocols in the 
suite. See also IP and TCP.

thread name Task name.

timeout Event that occurs when one network device expects to hear from another 
network device within a specified period of time, but does not. The resulting 
timeout usually results in a retransmission of information or the dissolving of the 
session between the two devices.

topology See topology map.

topology map Graphical representation by MWTM of the RAN-O network. Also called 
topology.

Transmission 

Control Protocol

See TCP.
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Transmission 

Control 

Protocol/Internet 

Protocol

See TCP/IP.

trap Unsolicited message sent by an SNMP agent to an NMS, console, or terminal to 
indicate the occurrence of a significant event, such as a specifically defined 
condition or a threshold that has been reached.

trap forwarding Forwarding MWTM events to other hosts, in the form of SNMP traps. This 
enables MWTM to integrate with high-level event- and alarm-monitoring 
systems such as the Cisco Info Center (CIC), HP OpenView, and Micromuse's 
Netcool suite of products. These systems can provide a single high-level view of 
all alarm monitoring in your network, making it easier to detect and resolve 
problems.

Trap Receiver Multi-threaded service that receives SNMP traps for MWTM. See also Data 
Server, Message Log Server, Process Manager.

U

UDP User Datagram Protocol. Connectionless transport layer protocol in the TCP/IP 
protocol stack. UDP is a simple protocol that exchanges datagrams without 
acknowledgments or guaranteed delivery, requiring that error processing and 
retransmission be handled by other protocols. UDP is defined in RFC 768.

unignore Stop ignoring the selected object at the next polling cycle. See also ignore.

unknown Device type for which MWTM is unable to determine the device type. If a node, 
the node failed to respond to an SNMP request. If a link, either the associated 
node failed to respond to an SNMP request, or MWTM found that the link no 
longer exists. Contrast with discovered.

unmanaged Node status in which the node is known indirectly by MWTM (MWTM knows 
the device exists but there is no known SNMP stack on the device for MWTM to 
query), or a user has set the node to this status to prevent MWTM from polling 
the node.
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User-Based Access MWTM security scheme that provides multi-level password-protected access to 
MWTM features. Each user can have a unique user name and password. Each 
user can also be assigned to one of five levels of access, which control the list of 
MWTM features accessible by that user.

For more information, see the “Configuring MWTM User-Based Access” 
section on page 10-1.

User Datagram 

Protocol

See UDP.

utilization Amount of an object’s send or receive capacity that is being used, expressed as 
a percentage or in Erlangs.

V

view View that is currently in use on an MWTM client. The current view can be the 
DEFAULT view or a customized view. See client view, current view, DEFAULT 
view.

Virtual Private 

Network

See VPN.

VPN Virtual Private Network. Enables IP traffic to travel securely over a public 
TCP/IP network by encrypting all traffic from one network to another. A VPN 
uses “tunneling” to encrypt all information at the IP level.

W

World Wide Web See WWW.

WWW World Wide Web. Large network of Internet servers providing hypertext and 
other services to terminals running client applications such as a browser. See 
also browser.
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