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Preface

This guide describes how to use the Netcool/OMNIbus desktop to manage events. It provides an overview 
of Netcool/OMNIbus components, as well as a description of the operator tasks related to using the desktop 
tools.

This preface contains the following sections:

• Audience on page 2

• About the Netcool/OMNIbus v7 User Guide on page 3

• Associated Publications on page 4

• Typographical Notation on page 5

• Operating System Considerations on page 8
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Preface 
Audience

This book is intended for anyone who needs to use Netcool/OMNIbus, including operators and 
administrators. It describes Netcool/OMNIbus and how to use the desktop tools. 

For more information about Netcool/OMNIbus, refer to the publications described in Associated 
Publications on page 4.
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About the Netcool/OMNIbus v7 User Guide
About the Netcool/OMNIbus v7 User Guide

This book is organized as follows:

• Chapter 1: Overview on page 9 provides an overview of Netcool/OMNIbus and an explanation of the 
terminology used to describe Netcool/OMNIbus components.

• Chapter 2: Conductor on page 19 describes how to log in to Netcool/OMNIbus and start the desktop 
tools from the Conductor. It includes information about changing the settings that affect the 
Conductor and other tools, and also how to change your password.

• Chapter 3: Using the Event List on page 33 contains information about how to start the event list and 
how to work with events.

• Chapter 4: Using the Filter Builder on page 67 describes how to use the Filter Builder to display only 
the events that you want to see in the event list.

• Chapter 5: Using the View Builder on page 85 describes how to use the View Builder to display only 
selected fields in the event list.

• Appendix A: Regular Expressions on page 97 describes how to use regular expressions.

• Appendix B: Desktop Reference on page 101 contains reference information for the 
Netcool/OMNIbus desktop.
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Associated Publications

 This section provides a description of the documentation that accompanies Netcool/OMNIbus.

Netcool®/OMNIbus™ Installation and Deployment Guide

This book is intended for Netcool administrators who need to install and deploy Netcool/OMNIbus. It 
includes installation, upgrade, and licensing procedures. In addition, it contains information about 
configuring security and component communications. It also includes examples of Netcool/OMNIbus 
architectures and how to implement them.

Netcool®/OMNIbus™ User Guide

This book is intended for anyone who needs to use Netcool/OMNIbus desktop tools on UNIX or Windows 
platforms. It provides an overview of Netcool/OMNIbus components, as well as a description of the 
operator tasks related to event management using the desktop tools.

Netcool®/OMNIbus™ Administration Guide

This book is intended for system administrators who need to manage Netcool/OMNIbus. It describes how 
to perform administrative tasks using the Netcool/OMNIbus Administrator GUI, command line tools, and 
process control. It also contains descriptions and examples of ObjectServer SQL syntax and automations. 

Netcool®/OMNIbus™ Probe and Gateway Guide

This guide contains introductory and reference information about probes and gateways, including probe 
rules file syntax and gateway commands. For more information about specific probes and gateways, refer to 
the documentation available for each probe and gateway on the Micromuse Support Site.

Online Help

Netcool/OMNIbus GUIs contain context-sensitive online help with index and search capabilities.
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Typographical Notation
Typographical Notation

Table 1 shows the typographical notation and conventions used to describe commands, SQL syntax, and 
graphical user interface (GUI) features. This notation is used throughout this book and other Netcool® 
publications.

Table 1: Typographical Notation and Conventions (1 of 2)

Example Description

Monospace The following are described in a monospace font:

• Commands and command line options

• Screen representations

• Source code

• Object names

• Program names 

• SQL syntax elements 

• File, path, and directory names

Italicized monospace text indicates a variable that the user must populate. For example, -password 
password.

Bold The following application characteristics are described in a bold font style:

• Buttons

• Frames

• Text fields

• Menu entries

A bold arrow symbol indicates a menu entry selection. For example, File→Save.

Italic The following are described in an italic font style:

• An application window name; for example, the Login window

• Information that the user must enter

• The introduction of a new term or definition

• Emphasized text
Netcool/OMNIbus v7 User Guide 5
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Many Netcool commands have one or more command line options that can be specified following a hyphen 
(-). 

Command line options can be string, integer, or BOOLEAN types: 

• A string can contain alphanumeric characters. If the string has spaces in it, enclose it in quotation 
(") marks. 

• An integer must contain a positive whole number or zero (0). 

• A BOOLEAN must be set to TRUE or FALSE.

SQL keywords are not case-sensitive, and may appear in uppercase, lowercase, or mixed case. Names of 
ObjectServer objects and identifiers are case-sensitive.

Note, Tip, and Warning Information

The following types of information boxes are used in the documentation:

[1] Code or command examples are occasionally prefixed with a line number in square brackets. For 
example:

[1] First command...
[2] Second command...
[3] Third command...

{ a | b } In SQL syntax notation, curly brackets enclose two or more required alternative choices, separated by 
vertical bars. 

[ ] In SQL syntax notation, square brackets indicate an optional element or clause. Multiple elements or 
clauses are separated by vertical bars. 

| In SQL syntax notation, vertical bars separate two or more alternative syntax elements.

... In SQL syntax notation, ellipses indicate that the preceding element can be repeated. The repetition is 
unlimited unless otherwise indicated.

,... In SQL syntax notation, ellipses preceded by a comma indicate that the preceding element can be 
repeated, with each repeated element separated from the last by a comma. The repetition is unlimited 
unless otherwise indicated. 

a In SQL syntax notation, an underlined element indicates a default option.

( ) In SQL syntax notation, parentheses appearing within the statement syntax are part of the syntax and 
should be typed as shown unless otherwise indicated. 

Table 1: Typographical Notation and Conventions (2 of 2)

Example Description
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 Note:  Note is used for extra information about the feature or operation that is being described. Essentially, 
this is for extra data that is important but not vital to the user.

 Tip:  Tip is used for additional information that might be useful for the user. For example, when describing 
an installation process, there might be a shortcut that could be used instead of following the standard 
installation instructions.

!!
 Warning:  Warning is used for highlighting vital instructions, cautions, or critical information. Pay close 
attention to warnings, as they contain information that is vital to the successful use of our products.

Syntax and Example Subheadings

The following types of constrained subheading are used in the documentation:

 

Syntax

Syntax subheadings contain examples of ObjectServer SQL syntax commands and their usage. For example:

CREATE DATABASE database_name;

 

Example

Example subheadings describe typical or generic scenarios, or samples of code. For example: 

[1] <body>
[2]    <img src="ChartView?template=barchart&format=PNG
[3]     &request=image&chart=quote&width=800&height=400" border="0" height="400" 
[4]     width="800" alt="Events by Severity"
[5]    >
[6] </body>
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Operating System Considerations

All command line formats and examples are for the standard UNIX shell. UNIX is case-sensitive. You must 
type commands in the case shown in the book.

Unless otherwise specified, command files are located in the $OMNIHOME/bin directory, where 
$OMNIHOME is the UNIX environment variable that contains the path to the Netcool/OMNIbus home 
directory.

On Microsoft Windows platforms, replace $OMNIHOME with %OMNIHOME% and the forward slash (/) 
with a backward slash (\).
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Chapter 1: Overview

This chapter contains an overview of the Netcool/OMNIbus system and desktop tools. Read this chapter if 
you are new to Netcool/OMNIbus.

This chapter contains the following sections:

• Introduction to Netcool/OMNIbus on page 10

• Netcool/OMNIbus Components on page 11

• Desktop Tools on page 15
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Chapter 1: Overview
1.1 Introduction to Netcool/OMNIbus

Netcool/OMNIbus is a service level management (SLM) system that collects enterprise-wide event 
information from many different network data sources and presents a simplified view of this information to 
operators and administrators.

This information can then be:

• Assigned to operators

• Passed to helpdesk systems

• Logged in a database

• Replicated on a remote Netcool/OMNIbus system

• Used to trigger automatic responses to certain alerts

Netcool/OMNIbus can also consolidate information from different domain-limited network management 
platforms in remote locations. By working in conjunction with existing management systems and 
applications, Netcool/OMNIbus minimizes deployment time and enables employees to use their existing 
network management skills.

Netcool/OMNIbus tracks alert information in a high-performance, in-memory database and presents 
information of interest to specific users through individually configurable filters and views. 
Netcool/OMNIbus automation functions can perform intelligent processing on managed alerts.
10 Netcool/OMNIbus v7 User Guide
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1.2 Netcool/OMNIbus Components

This section describes how Netcool/OMNIbus components work together to collect and manage network 
alert information. Figure 1 shows an overview of the Netcool/OMNIbus component architecture.

The components of Netcool/OMNIbus are:

• The ObjectServer, described on page 12

• Probes, described on page 12

• Gateways, described on page 12

• Desktop Tools, described on page 12

• Administration Tools, described on page 13

Figure 1: Netcool/OMNIbus Component Architecture

ObjectServer
NCOMS

Gateway

Probe

Event List

RDBMS
Gateway

Monitor

Alerts are replicated in an 
additional ObjectServer 
in a failover 
configuration.

Monitors and probes 
send alerts to the local 
ObjectServer.

Gateways forward 
alerts to other 
applications, such as 
a helpdesk system 
and an RDBMS.

ObjectServer
DENCO

Gateway

Probe

Probe

Netcool/OMNIbus
Administrator

Helpdesk/
CRM
Netcool/OMNIbus v7 User Guide 11



Chapter 1: Overview
The ObjectServer

The ObjectServer is the in-memory database server at the core of Netcool/OMNIbus. Alert information is 
forwarded to the ObjectServer from external programs such as probes, monitors, and gateways, stored and 
managed in database tables, and displayed in the event list.

Deduplication and Automation

A single device may generate the same error repeatedly until the problem is dealt with. The ObjectServer 
uses deduplication to ensure that alert information generated from the same source is not duplicated. 
Repeated alerts are identified and stored as a single alert to reduce the amount of data in the ObjectServer. 

You can use automation to detect changes in the ObjectServer and execute automated responses to these 
changes. This enables the ObjectServer to process alerts without requiring an operator to take action. 

Probes

Probes connect to an event source, detect and acquire event data, and forward the data to the ObjectServer 
as alerts. Probes use the logic specified in a rules file to manipulate the event elements before converting them 
into fields of an alert in the ObjectServer alerts.status table. 

Each probe is uniquely designed to acquire event data from a specific source. Probes can acquire data from 
any stable data source, including devices, databases, and log files.

Gateways

Netcool/OMNIbus gateways enable you to exchange alerts between ObjectServers and complementary 
third-party applications, such as databases and helpdesk or Customer Relationship Management (CRM) 
systems.

You can use gateways to replicate alerts or to maintain a backup ObjectServer. Application gateways enable 
you to integrate different business functions. For example, you can configure a gateway to send alert 
information to a helpdesk system. You can also use a gateway to archive alerts to a database. 

Once a gateway is correctly installed and configured, the transfer of alerts is transparent to operators.

Desktop Tools

The desktop is an integrated suite of graphical tools used to view and manage alerts and to configure how 
alert information is presented. Desktop tools are available on both UNIX and Windows platforms.

Alert information is delivered in a format that allows users to quickly determine the availability of services 
on a network. When an alert cause has been identified, desktop tools enable users to resolve problems 
quickly.
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Netcool/OMNIbus Components
For more information about desktop tools, see Desktop Tools on page 15.

Administration Tools

Netcool/OMNIbus includes tools that enable administrators to configure and manage the system. For 
detailed information about administration tools, see the Netcool/OMNIbus Administration Guide.

Netcool/OMNIbus Administrator

Netcool/OMNIbus Administrator is a graphical tool that you can use to configure and manage 
ObjectServers. Netcool/OMNIbus Administrator replaces the Configuration Manager from 
Netcool/OMNIbus versions 3.6 and prior.

SQL Interactive Interface

The ObjectServer provides a Structured Query Language (SQL) interface for defining and manipulating 
relational database objects such as tables and views. You can use the SQL interactive interface (called nco_
sql on UNIX and isql on Windows) to connect to an ObjectServer and use SQL commands to interact 
with and control the ObjectServer. The SQL interactive interface enables you to perform tasks such as 
creating a new database table or stopping the ObjectServer.

Import and Export Utility

You can use the nco_confpack utility to:

• Import and export Netcool/OMNIbus ObjectServer configurations to deploy duplicate 
Netcool/OMNIbus systems in your network

• Extract a subset of configuration items from Netcool/OMNIbus ObjectServers (for example, event 
list menus and automations) and import them into other ObjectServers

• Save Netcool/OMNIbus ObjectServer configuration data for backup purposes

Process Control

The process control system performs two primary tasks:

• Execution of external procedures specified in automations

• Management of local and remote processes

 Note:  On Windows systems, process control only executes external procedures specified in 
automations. You cannot use process control to manage processes on Windows.
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On UNIX systems, process control allows you to configure remote processes to simplify the management of 
Netcool/OMNIbus components such as ObjectServers, probes, and gateways. It consists of the following:

• Process control agents, which are programs installed on each host with the responsibility for 
managing processes

• A set of command line utilities to provide an interface to process management
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1.3 Desktop Tools

Desktop tools include the following:

• Conductor, described on page 15

• Event List, described on page 16

• Filter Builder, described on page 16

• View Builder, described on page 17

These applications retrieve information from an ObjectServer and allow you to view the current state of the 
database, which in turn reflects the status of the systems being managed.

Conductor

The Conductor is the desktop entry point for Netcool/OMNIbus. It allows you to open the other client 
applications. It also enables you to display configurations; for example, filter or view files for event lists.

Figure 2: UNIX and Windows Conductors

The Windows Conductor appears as a menu 
when you right-click the Conductor icon in 
the Windows task bar.
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Event List

The event list displays a filtered view of color-coded alerts in a scrolling list. You can set up multiple event 
list clients, each with different priorities and filters. You can also use the event list to reprioritize alerts and 
to assign or reassign problems to other users. When an alert has been assigned to a user, the user can 
acknowledge it, or deacknowledge it so that it can be picked up by another user. 

Filter Builder

Filters enable you to choose which alerts to display in the event list. The Filter Builder allows you to build 
simple or complex alert filters. For detailed information about the Filter Builder, see Using the Filter Builder 
on page 67.

Figure 3: Event List

Instant summaries of alert 
states are provided in monitor 
boxes. To display full details, 
click the View button.
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For example, Figure 4 shows a filter in the Filter Builder that only displays rows in the event list that match 
the criteria Manager not like '^.*Watch$' and SuppressEscl = Maintenance.

View Builder

You can use the View Builder to create event list views, which enable you to choose which fields to display 
in the event list. For detailed information about the View Builder, see Using the View Builder on page 85.

Figure 4: Filter Builder

Metrics provide 
summary 
information 
associated with 
each filter.

The filter is 
graphically 
represented by 
this tree.

The Filter 
Builder creates 
and displays the 
SQL queries.

The element 
inspector enables 
you to add regular 
expressions to 
conditions.
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By adding or removing fields, you can change the range of information displayed in the event list, as shown 
in Figure 5. 

Figure 5: View Builder

Modifications to the view are 
instantly visible.

You can set the width,
justification, and title 
separately for each field.

You can sort by any column.

You can restrict the rows 
displayed.
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Chapter 2: Conductor

This chapter contains information about how to manage the Netcool/OMNIbus desktop tools using the 
Conductor.

This chapter contains the following sections:

• Introduction to the Conductor on page 20

• Starting and Stopping the Conductor on page 21

• Running Tools from the Conductor on page 22

• Setting Global Preferences on page 25

• Changing Your Password on page 28

• Maintaining a Personal Library (UNIX Only) on page 29

• Using the Directory Browser (UNIX Only) on page 31
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2.1 Introduction to the Conductor

You can use the Conductor to manage the desktop tools. The Conductor allows you to:

• Run all the desktop tools without having to log in every time you start one

• Set preferences for all of the desktop tools

• Set up Netcool/OMNIbus component communications using the Server Editor

• Change your password

• Maintain a personal library of event list configurations, filters, and views

• Browse directories to select files to add to the personal library or the Conductor button bar
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2.2 Starting and Stopping the Conductor

This section describes how to start and stop the Conductor on UNIX and Windows platforms.

Starting the Conductor

To start the Conductor:

1. Do one of the following:

– On UNIX, at the command prompt, enter: $OMNIHOME/bin/nco &.

– On Windows, click the Start button and, from the top of the Start menu, select Netcool 
Conductor.

The Conductor login window appears.

2. Enter the user name and password that you use for the host running the ObjectServer. Any text 
entered into the Password field is replaced with asterisk (*) characters.

3. The Server option button defaults to NCOMS (Netcool/OMNIbus Master Server). If you want to 
connect to another ObjectServer, select it from the drop-down menu.

4. Click OK.

You are allowed three attempts to log in. On each attempt, the password field is cleared. If you fail to log in 
correctly at the third attempt, the program terminates.

Stopping the Conductor

To exit from the Conductor on UNIX, select File→Exit. Any tools that have been launched with the 
Conductor remain open.

To exit from the Conductor on Windows, right-click the bus icon on the task bar and select Exit. Any tools 
that have been launched with the Conductor remain open.
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2.3 Running Tools from the Conductor

This section describes how to run tools from the Conductor on UNIX and Windows platforms.

 Tip:  You can optionally start desktop tools individually from the command line in UNIX or from the 
Windows Start menu. However, using this method, every time you start a tool, you need to enter your user 
name and password.

Running Tools from the Conductor on UNIX 

The Conductor on UNIX displays all the desktop tools that have been installed and that are available to you.

To run a tool from the Conductor, click the button for the desired tool. The tool starts automatically; you 
do not need to enter a user name or password.

Figure 6: Conductor on UNIX

Status bar showing the 
status message, user 
name, and ObjectServer

Personal library

Configurable button. This 
example is linked to an event 
list configuration file 
(custom.elc). This event list 
configuration starts when the 
conductor starts.
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Conductor Button Bar

The Conductor button bar consists of six pre-configured buttons and one configurable button. Table 2 
describes the Conductor buttons.

Table 2: Conductor Buttons

Button Description

The Filter Builder button starts the Filter Builder with the default filter loaded. You can use the Filter 
Builder to create new filters or edit existing filters. The default filter contains no conditions.

The View Builder button starts the View Builder with the default view loaded. You can use the View 
Builder to create new views or edit existing views.

The Browser button opens a file browsing window, which allows you to navigate file systems, find files, 
and add them to your personal library. See Using the Directory Browser (UNIX Only) on page 31 for details. 

The Event List button starts the event list with a default configuration; that is, with a default view and 
default filter. If an event list has been launched from the Conductor, this button is grayed-out to prevent 
multiple event lists from being launched.

The Interfaces button starts the Server Editor, which is used to set up Netcool/OMNIbus component 
communications. For information about the Server Editor, see the Netcool/OMNIbus Installation and 
Deployment Guide.

The Properties button starts the Properties Editor, which enables you to edit the information in the 
properties files for ObjectServers, proxy servers, the nco_dbinit utility, and probes. For information 
about the Properties Editor, see the Netcool/OMNIbus Administration guide.

The configurable button allows you to start a custom event list configuration automatically whenever 
you start the Conductor. 

To configure this button, drag and drop an event list configuration (.elc) icon from the personal library 
or Browser window onto the button. This example has not been linked to an event list configuration. The 
personal library is described in Maintaining a Personal Library (UNIX Only) on page 29. The Browser 
window is described in Using the Directory Browser (UNIX Only) on page 31. 
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Running Tools from the Conductor on Windows

To use the Conductor on Windows, right-click the bus icon in the task bar. The Conductor menu appears, 
showing all the desktop tools that have been installed and are available to you. 

To run a tool from the Conductor, select an item from the menu. The tool starts automatically; you do not 
need to enter a user name or password. You can start a Conductor for each running ObjectServer. An icon 
appears in the task bar for each Conductor. Move the mouse pointer over the icon to display information 
about the Conductor as a tool tip.

Figure 7: The Conductor on Windows
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2.4 Setting Global Preferences

To display the Preferences window:

• On UNIX, double-click the prefs button in the Conductor personal library.

• On Windows, from the Conductor menu, select Preferences.

The Preferences window comprises the following tabs:

• Conductor

• Event List

• Notification

The Event List tab of the Preferences window is shown in Figure 8.

The following sections describe the preferences available on each tab.

Figure 8: Preferences Window
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Setting Conductor Preferences

On the Preferences window, click the Conductor tab. Table 3 describes the Conductor tab item.

Setting Event List Preferences

On the Preferences window, click the Event List tab. Table 4 describes the Event List tab items.

Table 3: Preferences Window Conductor Tab Item

Item Description

Timed Directory Update Updates the Conductor directory information at regular intervals. The interval is controlled 
by the value (in seconds) in the text field.

Table 4: Preferences Window Event List Tab Items

Item Description

Show Count Displays the number of alerts matching the filter on monitor boxes.

Show Highest Severity Displays the highest severity among the alerts that match the filter.

Show Lowest Severity Displays the lowest severity among the alerts that match the filter on monitor boxes.

Show Metric Displays the value of the filter’s metric component on monitor boxes. For information about 
metrics, see Parts of the Monitor Box on page 38.

Show Lavalamp Displays the distribution indicator as a horizontal bar on monitor boxes.

Show Histogram Displays the distribution indicator as a bar graph on monitor boxes.

Show Event List Colors Indicates the severity color of alerts in event list. You can select this option to change the 
event list to monochrome and not show the severity color.

Sort Information Details Sorts the detail fields in the event list window alphabetically by name of field. When it is not 
selected, the detail fields are displayed in an order determined by the ObjectServer.

Timed Refresh Updates alert information at a selected time rather than awaiting notification of updates 
from the ObjectServer. Select Timed Refresh and enter a time (in seconds) in the field. The 
most recent data from the ObjectServer is updated in the event list when the Timed Refresh 
activates.

Note: Timed Refresh forces the event list to reload all its data at a set interval. Do not set the 
refresh to a low value (for example, less than 60 seconds) as this has an impact on 
ObjectServer performance and network traffic.

Enable Flashing Enables flashing alerts on the event list. Use the sliders to set the flashing speed and 
brightness.
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Setting Notification Preferences

On the Preferences Window, click the Notification tab. Table 5 describes the Notification tab items.

 Note:  To activate these preferences, close and reopen any open event lists.

Applying and Saving Global Preferences

On the Preferences window, use the Apply button to apply changes without saving them. This enables you 
to test how your changes affect the desktop. If you make an incorrect change to the preference settings, you 
can close the Preferences window without saving and your changes are discarded.

Use the Save button to save any changes made to global preferences. To view any changes made to 
preferences in the event list, close and reopen any open event lists.

You can also use the Event List Preferences window to change your event list preferences. For more 
information, see Using the Event List Preferences Window on page 59.

Table 5: Preferences Window Notification Tab Items

Item Description

Notify when Iconized Receives a notification when an alert is new, changed, or deleted. Use the When and How 
options to set the notification method.

When Sends a notification when:

• A new alert has appeared in the event list.

• An existing alert changes in the event list.

• An existing alert is deleted from the event list.

How Selects a notification method:

• Ring Bell sounds the workstation bell once.

• Alert Icon flashes an exclamation mark over the event list icon on UNIX or flashes the 
minimized event list on Windows.

• Open Window opens the event list on the screen. If you use a window manager with 
interactive placement, the event list opens as the active window.

• Run External Command runs a command. Enter the command name in the text field 
below the Run External Command toggle button. This must only be used for simple 
desktop notification, and is not designed for handling paging applications.
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2.5 Changing Your Password

To display the Change Password window:

• On UNIX, from the Conductor, select File→Change Password.

• On Windows, from the Conductor menu, select Change Password.

To change your password:

1. In the Current field, enter the current password. Any text entered is replaced with asterisk (*) 
characters.

2. In the New field, enter the new password.

3. In the Verify field, enter the new password again.

4. Click OK.

If you enter an invalid current password, or if the entries in the New and Verify fields do not match, an error 
message appears. In both cases, you can dismiss the error message window and correct the error.

 Note:  The Change Password menu option on UNIX platforms is grayed-out if your organization uses 
external authorization. If external authorization is used, the password is not stored in the ObjectServer. For 
information about Netcool/OMNIbus security, see the Netcool/OMNIbus Installation and Deployment 
Guide.
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2.6 Maintaining a Personal Library (UNIX Only)

The personal library provides an easily accessible location from which to open frequently used 
Netcool/OMNIbus files (for example, filters and views). You can double-click icons in the personal library 
to open their associated applications.

The personal library also contains a prefs icon, which you double-click to select global Netcool/OMNIbus 
preferences. See Setting Global Preferences on page 25.

Using the Personal Library with the Browser Window

You can drag and drop all icons from the directory browser into the personal library, except for icons 
representing directories. You can also drag and drop icons from the personal library into the directory 
browser. See Using the Directory Browser with the Personal Library on page 32.

Viewing the Personal Library Contents

Use the following instructions to view the contents of the personal library:

Personal Library Icons

Table 7 describes the Conductor personal library icons.

Table 6: Viewing Personal Library Contents

To... Select...

Refresh the contents of the personal library View→Refresh

View hidden files (files with names beginning with a 
period)

View→Show Hidden Files

View backup files (files with names ending in .bak) View→Show Backup Files

Table 7: Personal Library Icons (1 of 2)

Icon Description

This icon represents the repository of your Netcool/OMNIbus preferences. When you change your tool 
preferences, the changes are made in this file.

To display the Preferences window, described in Setting Global Preferences on page 25, double-click the 
preferences icon.
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This icon represents an event list configuration.

To start an event list with a specific configuration, double-click an event list configuration icon (.elc 
files), or right-click the icon and select Start Event List from the popup menu. 

To delete an event list configuration from the personal library, right-click the icon and select Delete.

This icon represents an event list filter.

To start the Filter Builder with a filter loaded, double-click a Filter icon (.elf files), or right-click the icon 
and select Start Filter Builder.

To delete a filter from the personal library, right-click the icon and select Delete.

This icon represents an event list view.

To start the View Builder with a view loaded, double-click a View icon (.elv files), or right-click the icon 
and select Start View Builder.

To delete a view from the personal library, right-click the icon and select Delete.

The event list configuration, filter, and view icons may appear covered by a chain link. This indicates that 
the file is not actually in the personal library, but there is a symbolic link to the file.

These icons are created by linking the actual file into the personal library from the browser. All the 
functions in this table work as if linked icons are the actual files; however, when you delete a linked icon 
from the personal library, only the reference to the file is removed. The actual file is not deleted.

The example icons to the left show linked filter and view icons.

For information about creating linked filter and view icons, see Creating Symbolic Links in the Personal 
Library on page 32.

Table 7: Personal Library Icons (2 of 2)

Icon Description
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2.7 Using the Directory Browser (UNIX Only)

You can use the directory browser to view the contents of a directory on your local system. To display the 
directory browser, on the Conductor, click the Browser button. Figure 9 shows the directory browser.

You can drag and drop files from the directory browser into your personal library. See Maintaining a Personal 
Library (UNIX Only) on page 29.

Navigating with the Directory Browser

All icons that appear in the personal library can appear in the directory browser (with the exception of the 
prefs icon). The full path name of the current directory is displayed in the Directory field. To change the 
directory, do one of the following:

• Enter the full path in the Directory field, then press Enter.

• Double-click any directory icon.

A parent directory is labelled with two periods. To move to the directory above the current directory, 
double-click the parent directory icon.

Figure 9: Directory Browser
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Using the Directory Browser with the Personal Library

You can drag and drop all icons from the directory browser into the personal library, except for icons 
representing directories. You can also drag and drop all icons in the personal library into the directory 
browser, except for the prefs icon. For information about the personal library, see Maintaining a Personal 
Library (UNIX Only) on page 29.

Creating Symbolic Links in the Personal Library

To create a symbolic link in your personal library to a file in the directory browser:

1. Hold the Shift and Control keys.

2. From the directory browser, use the middle mouse button to click and drag the file for which you 
want to create a symbolic link to the personal library.

A symbolic link is created. The icon for the symbolic link has a chain over the icon image.
32 Netcool/OMNIbus v7 User Guide



event_list.fm October 11, 2004 3:40 pm

Chapter 3: Using the Event List

This chapter describes how to manage events using the event list. It contains the following sections:

• Introduction to the Event List on page 34

• Starting the Event List on page 35

• Using the Monitor Box Window on page 36

• Using the Event List on page 43

• Using the Event List Preferences Window on page 59

• Netcool/Internet Service Monitors in the Event List on page 63
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3.1 Introduction to the Event List

The event list enables you to view and manage alerts. An alert is created when the ObjectServer receives an 
event, alarm, message, or data item. Each alert comprises fields of information held in a row of the 
ObjectServer alerts.status table. 

Information about alerts is displayed in the event list according to filters and views. Filters enable you to 
display a subset of alerts based on specific criteria. Views enable you to choose which alert fields to display.

When you start an event list, a window containing one or more monitor boxes appears. The monitor box 
window is described in Using the Monitor Box Window on page 36. The number of monitor boxes that 
appear depends on how your system administrator has configured your system. A monitor box represents a 
filter and view that has been created for the event list. It also displays statistics about the state of all alerts 
that match the filter.

From monitor boxes, you can display event list windows and choose different views. The event list window 
is described in Using the Event List on page 43.
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3.2 Starting the Event List

This section describes how to start the event list on UNIX and Windows platforms.

You can start the event list using the default event list configuration, or your own customized event list 
configuration. Customized configurations can be specified at the command line or using the File→Open 
dialog. These customized configurations may be on your file system or located on a remote server accessible 
using the http or ftp protocol.

For further information, see Using Event List Configurations on page 39.

For information about event list command line options, see Appendix B: Desktop Reference on page 101.

On UNIX

To start the event list on a UNIX platform, click the Event List button on the Conductor.

Alternatively, you can start the event list from the command line as follows:

$OMNIHOME/bin/nco_event &

On Windows

To start the event list on a Windows platform:

• Select Event List from the Conductor menu.

• Select Start→Programs→Netcool OMNIbus→Event List

Alternatively, you can start the event list from the command line as follows:

%OMNIHOME%\desktop\NCOEvent.exe

Failover Login

If the event list loses its connection to the primary ObjectServer and a secondary (failover) ObjectServer 
exists, you are prompted to log in to the secondary ObjectServer. When the primary ObjectServer becomes 
available again, a message appears indicating that the event list is reconnecting to the primary ObjectServer. 
You do not need to log in again to the primary ObjectServer.
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3.3 Using the Monitor Box Window

When you run the event list, the monitor box window appears, as shown in Figure 10.

 The monitor box window has the following sections:

• The title bar, which displays the current event list configuration name

• The monitor box area, described in Monitor Box Overview on page 38

• The status bar, which displays messages, the current user name, the ObjectServer to which you are 
currently connected, and whether the ObjectServer is the primary (PRI) or backup (BAK)

The monitor box area displays the default monitor boxes. The monitor boxes that appear on your system 
may differ, depending on how your system administrator has configured your system. For information about 
the default monitor boxes, see Default Monitor Boxes on page 37.

Figure 10: Monitor Box Window

Monitor box area

Status bar

Title bar
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Default Monitor Boxes

The default monitor box window contains the following monitor boxes, each with its own filter. These are 
described in Table 8.

Table 8: Default Monitor Boxes

Monitor Box Filter Description

Last 10 Min. Identical to the Default filter described below, except this displays only those events that 
occurred in the last ten minutes.

Escalated Displays those alerts that have been escalated by the operator. For information about 
escalating alerts, see Escalating and De-escalating Alerts on page 47.

Task List Displays those events that have been added to the operator’s task list. For information 
about adding events to the task list, see Adding an Alert to the Task List on page 50.

Default Displays all events except ProbeWatch, TSMWatch, and ConnectionWatch events. 

In Maintenance Displays those events that have been indicated as “in maintenance” by the operator. For 
information about indicating events as “in maintenance”, see Indicating that an Alert Is in 
Maintenance on page 48.

Information Displays those events that have been identified as Information events. Information events 
are those that:

• Have been indicated as Information events by probes

• Are not ProbeWatch, TSMWatch, and ConnectionWatch events

• Have an escalation level set (see Escalating and De-escalating Alerts on page 47)

Netcool Status Displays only ProbeWatch, TSMWatch, and ConnectionWatch events. 

All Events Displays all events.
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 Monitor Box Overview

A single monitor box is shown in Figure 11: 

The parts of the monitor box are described inTable 9. 

Figure 11: Monitor Box

Number of alerts 
matching the filter

Distribution indicator

Filter name

Filter metric

View event list button Select view button

Table 9: Parts of the Monitor Box (1 of 2)

Item Description

Filter name Displays the name of the current filter. Click this button to start the Filter Builder.

For more information about using the Filter Builder, see Chapter 4: Using the Filter Builder on 
page 67.

Number of alerts 
matching the filter

Displays the number of alerts that match the filter.

Filter metric Displays summary information derived from the alerts that match the filter. See Types of 
Measurement for the Metric Panel on page 83 for more information.

You can configure additional fields to show other metrics, such as the severity of the highest 
severity alert that matches the filter. You can choose which information to display, as described 
in Using the Event List Preferences Window on page 59.

Distribution indicator The colored segments are proportional to the number of alerts at particular severity levels. For 
example, if half the alerts were at critical level, half the distribution indicator would display the 
color red.

You can display this information as either a lavalamp or a histogram, as described in Using the 
Event List Preferences Window on page 59.

View event list 
button

Click the View button to display an event list window for the currently selected monitor box 
filter and view.
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 Note:  You can optionally display a colored border around the monitor box. The border color changes 
according to the highest severity among the alerts that match the filter. See Setting Monitor Box Preferences 
on page 59.

Using Event List Configurations

Event list configurations enable you to save all of the monitor boxes on the current monitor box window, 
with their associated filters and views, into a configuration file. You can create as many different 
configuration files as you need and you can load a different configuration file at any time.

Opening a Local Event List Configuration File

To open a local event list configuration file, select File→Open.

A file selection window appears where you can select a configuration file to use for the event list (indicated 
by the file name extension .elc). The selected configuration file name is displayed in the title bar of the 
event list.

Opening a Remote Event List Configuration File

You can open a remote event list configuration file from the file selection window. A remote event list 
configuration file must be located on a remote server accessible using the http or ftp protocol.

To do this, select File→Open; then, in the File name: field, enter a URL for the remote file. The URL must 
be of one of the following forms:

http://servername[:port]/path/filename.elc
http://username:password@servername[:port]/path/filename.elc
ftp://servername[:port]/path/filename.elc
ftp://username:password@servername[:port]/path/filename.elc

The optional port number [:port] only needs to be specified if the server is not using the default port.

Select view button Displays the name of the current view. Click the button to select a different view for the filter.

Note: You can use this button to select the X.733 view, which displays X.733-compliant alert 
information in the event list.

For information about creating and modifying views using the View Builder, see Creating a View 
on page 89.

Table 9: Parts of the Monitor Box (2 of 2)

Item Description
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A copy of the remote file is written to a local cache. On Windows systems, when you specify a remote file 
that you have previously opened, the cached copy is used.

If the remote file cannot be retrieved, an error message is displayed.

Saving Event List Configurations

To save the current group of monitor boxes with their associated files and views as an event list 
configuration, select File→Save from the monitor box window.

This saves the current event list configuration into the file displayed in the title bar. If the title bar displays 
[None] as the file name, this option operates as the File→Save As option, allowing you to name and create 
a new .elc file.

To save the current event list configuration with another file name, select File→Save As. A file selection 
window appears where you can select another directory and file name.

You should save event list configuration files with a .elc extension.

Saving Remote Event List Configurations

If you have opened an event list configuration from a remote server on the network, you are not permitted 
to save it onto that server. If you attempt to use File→Save to save the event list configuration file, an error 
message is displayed. Then the Save As dialog is displayed, allowing you to save a local copy. The default 
location to save the file is as follows:

• UNIX - The working directory from which you started the event list.

• Windows - Your temporary internet files folder. 

Creating a New Event List Configuration

To create a new event list configuration:

1. Clear the current event list configuration and set the configuration to the default settings. To do this, 
from the monitor box window, select File→New.

2. Select Windows→Configuration. The Event List Configuration window appears.

3. Use the Event List Configuration window to create the event list configuration. For a description of 
this window, see Event List Configuration Window Items on page 41.

4. Click Close. The event list configuration is applied to the current event list.

5. To save the event list configuration, on the monitor box window, select File→Save As.
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Event List Configuration Window Items

Table 10 contains descriptions of the Event List Configuration window items. 

 Note:  The order in which filters and views appear in the Event List Configuration window determines the 
order in which the event list popup menus and drop-down lists display the filter and view lists.

Table 10: Event List Configuration Window Items

Window item Description

Name The event list configuration name.

Columns The number of monitor box columns that are allowed in a monitor box window.

Filters/Views Switches between the views and filters that are part of this event list configuration.

New Opens the Filter Builder or View Builder to create a new filter or view.

If you use a filter or view name that already exists in the event list configuration, the existing filter or 
view is replaced.

Edit Opens the Filter Builder or View Builder to edit the currently selected filter or view. 

Any changes are applied to the filter or view. If you change the name of the filter or view to a name that 
does not exist in the event list configuration, a new filter or view is created. If you change the name to 
one that already exists, the new filter or view replaces the existing filter or view in the event list 
configuration.

For information about using the Filter Builder see Using the Filter Builder on page 67. For information 
about using the View Builder see Using the View Builder on page 85.

Load Loads an existing filter or view into the event list configuration. Filters have an .elf extension. Views 
have an .elv extension.

Delete Deletes the selected filter or view from the event list configuration.

Top Moves the selected filter or view to the top of the list.

Up Moves the selected filter or view up one position in the list.

Down Moves the selected filter or view down one position in the list.

Bottom Moves the selected filter or view to the bottom of the list.
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Refreshing the Event List

The event list refreshes automatically at regular intervals to show all incoming alerts. However, you can 
refresh the event list between the intervals to ensure that you have all the latest alerts. To update all 
information in event list windows, select View→Refresh All.

Resynchronizing the Event List

If your system administrator makes any changes to the Netcool/OMNIbus configuration, you must 
resynchronize the event list. To resynchronize the event list, select File→Resync All.

Resynchronizing works differently on UNIX and Windows event lists. On UNIX event lists, currently 
selected views are not resynchronized; however, any columns added to the selected views using the View 
Builder will reflect resynchronized values.

On Windows event lists, only the views that are currently selected in monitor boxes are resynchronized. If 
you use a monitor box to select a different view after resynchronizing, it will not be resynchronized.

Freezing the Event List

To freeze the event list so that updates are not displayed, select View→Freeze All. To restart automatic 
updates from the ObjectServer, select View→Freeze All again.

Displaying the Severity Colors

The Event List Colors window provides a reference for the severity colors. To display the Event List Colors 
window, select Windows→Colors. 

You can keep this window open for reference while you use the event list.

Closing All Event List Windows

To close all event list windows, select Windows→Close All Event Windows.

Using Tools

The systems administrator can define tools (for example, to issue a ping or telnet command) to use from the 
monitor box window. To use these tools, select the appropriate option from the Tools menu.
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3.4 Using the Event List

The event list displays alerts in a scrollable list. Figure 12 shows an event list.

The parts of the event list are described in Table 11.

Figure 12: Event List 

Status line

Title bar

Alerts

Distribution 
status bar

Menu and Toolbar

Table 11: Parts of the Event List (1 of 2)

Item Description

Title bar The title bar displays the names of the view and filter currently in use for this event list. It also 
indicates whether you are using a dual server desktop (DSD). For information about dual 
server desktops, see the Netcool/OMNIbus Installation and Deployment Guide.

Menu and Toolbar Provides access to the menus and toolbar buttons. The toolbar buttons enable you to:

• Refresh, freeze, and print the event list

• Select all or deselect all alerts

• Apply filters and views

• Start the Filter Builder and View Builder

• Restrict the number of rows displayed

Alerts The event list alerts area is made up of rows and columns:

• The columns are the alert fields. The selection of columns is controlled by the currently 
selected view. 

• The rows are alerts that match the currently selected filter.
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Event List Security

All Netcool/OMNIbus users belong to one or more user groups. Roles granted to a group determine the 
group permissions. The desktop tools that a user can access and the tasks that a user can perform with the 
tools depend on the group to which the user belongs and the roles assigned to the group. For information 
about groups, roles, and Netcool/OMNIbus security, see the Netcool/OMNIbus Installation and 
Deployment Guide.

The Normal, Administrator, and System groups provide group row level security in the event list. 
The AlertSecurityModel ObjectServer property determines whether group row level security is 
enforced in the event list. By default the AlertSecurityModel property is disabled, and group row 
level security is not enforced. In this case:

• A member of the Normal group can modify a row that is assigned to themselves or the nobody 
user. When an alert is received from the ObjectServer, it is assigned by default to a the nobody user.

• A member of the Administrator group can modify a row that is assigned to themselves, the 
nobody user, or a member of the Normal group.

If the AlertSecurityModel property is enabled, only users in the group that owns the row can modify 
the row. In this case, a member of the Normal or Administrator group can modify a row that is 
assigned to a group of which they are a member.

A member of the System group can always modify any row.

Distribution status bar The distribution status bar displays the number of alerts that match the indicated severity 
color. This is the same information as shown on the distribution indicator on the monitor box.

You can click one of the severity level colors to display only those alerts that match the 
selected severity (see Severity Filtering on page 55).

Status line The status line displays:

• Messages about the event list, such as how many items match the current filter condition 
or were processed by an operation

• The current date and time

• The current user

• The name of the ObjectServer to which the event list is connected, and whether this is the 
primary (PRI) or backup (BAK) ObjectServer

Table 11: Parts of the Event List (2 of 2)

Item Description
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Resizing Columns

To resize the columns in the event list:

1. On UNIX only, press and hold the Shift and Control keys.

2. Click the mouse button on a column divider.

3. Drag the mouse to change the width of the column.

Sorting Columns

The titles of the columns in the event list are active buttons. For example, you can click the title button over 
a column to sort all alerts by that column in ascending order.

Click the title button over the same column to clear the sorting on that column.

Secondary Sorting

To make a column a secondary sort, click the title button on another column after sorting the first column. 
For example, if you click the title button on Severity, then click the title button on Node, this will sort the 
event list by ascending severity and ascending node name.

Sorting in Descending Order

To set a column to be sorted in descending order:

1. On UNIX only, press the Shift key.

2. Click the title button to select the sorting column.

Any column being used in a sort is marked with a plus (+) or minus (-). Plus indicates ascending order; and 
minus indicates descending order. The sorting created is temporary and is not retained in the saved view.

Working with Alerts

This section contains information about how you can work with alerts in the event list.

Selecting Alerts

To work an alert, you must first select it. Once you have selected the alert, you can use the options available 
from the Alerts menu.
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 Note:  If you right-click an alert, a popup Alerts menu appears. The Alerts menu is configured by your 
system administrator.

Alert selection methods are described in Table 12.

Deselecting Alerts

To deselect all alerts in the event list, select Edit→Deselect All.

To deselect an alert in a selection of multiple rows, hold the Control key and click the alert.

Acknowledging an Alert

To acknowledge all selected alerts, select Alerts→Acknowledge.

The status line displays the number of acknowledged alerts and alerts that could not be acknowledged 
because they are not assigned to you.

 Note:  You can only acknowledge an alert if you have permission to do so. See Event List Security on page 44.

Deacknowledging an Alert

To deacknowledge all selected alerts, select Alerts→Deacknowledge.

Table 12: Alert Selection Methods

To select... Do this...

One alert and deselect all other alerts Click the mouse button on the alert.

Multiple, nonsequential alerts Hold the Control key and click each alert.

Multiple, sequential alerts Click (Shift-click on Windows), hold the mouse button, and 
drag the pointer up or down the list.

All alerts Select Edit→Select All.

All alerts that match a particular field value (smart 
matching)

Press the Shift key (Control+Alt on Windows) and click the 
left mouse button over the field to be matched.

For example, to select all alerts where the status field is 
“closed”, find an alert that displays the status field as 
“closed”, move the mouse pointer over that field, then 
Shift-click the mouse button.
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The status line displays the number of deacknowledged alerts and alerts that could not be deacknowledged 
because they are not assigned to you.

 Note:  You can only deacknowledge an alert if you have permission to do so. See Event List Security on 
page 44.

Prioritizing Alerts

You can prioritize alerts by:

• Changing the alert severity

• Escalating/de-escalating the alert

• Suppressing the alert

• Hiding the alert

• Indicating the alert is “in maintenance”

 Note:  You can only prioritize an alert if you have permission to do so. See Event List Security on page 44.

Each prioritization method is described below.

 

Changing the Severity of an Alert

Each alert in the event list has an associated severity, which is indicated by the color in the display. For 
example, all critical severity alerts are red by default.

To change the severity of selected alerts, select Alerts→Prioritize→Change Severity. Select a priority setting 
from the sub-menu.

The status line displays the number of alerts that have had their severity set and alerts whose severity could 
not be set because they are not assigned to you.

 

Escalating and De-escalating Alerts

You can escalate alerts if, for example, you need to call attention to the alerts so that different levels of 
support staff can manage them. Escalating and de-escalating alerts works in conjunction with the Escalated 
event list filter (see Default Monitor Boxes on page 37). The escalation levels are:

• Normal

• Escalated
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• Escalated-Level 2

• Escalated-Level 3

To escalate or de-escalate selected alerts, select Alerts→Prioritize→Suppress/Escalate. Select an escalation 
level from the sub-menu. Escalated alerts appear in the Escalated monitor box.

To remove the escalated status from selected alerts, select Alerts→Prioritize→Suppress/Escalate→Normal.

 

Suppressing Alerts

You can suppress alerts that do not need any direct action taken. For example, you may receive secondary 
alerts that are related to the actual alert that needs to be dealt with.

When you suppress an alert it is suppressed in all operators’ event lists.

To suppress selected alerts, select Alerts→Prioritize→Suppress/Escalate→Suppress.

To remove the suppressed status from selected alerts, select 
Alerts→Prioritize→Suppress/Escalate→Normal.

 

Hiding Alerts

You can hide alerts that you no longer want to view in the event list. Hidden alerts do not appear in any 
monitor boxes or event lists, except for those using the All Events filter (see Default Monitor Boxes on 
page 37).

When you hide an alert it is hidden in all operators’ event lists.

To hide selected alerts, select Alerts→Prioritize→Suppress/Escalate→Hidden.

To remove the hidden status from alerts, open an event list that uses the All Events filter; then, select the 
alerts and select Alerts→Prioritize→Suppress/Escalate→Normal.

 

Indicating that an Alert Is in Maintenance

The Maintenance priority works in conjunction with the Maintenance event list filter (see Default Monitor 
Boxes on page 37). If the problem that caused an alert is being dealt with, you can indicate an alert is “in 
maintenance”.

To indicate that selected alerts are “in maintenance”, select 
Alerts→Prioritize→Suppress/Escalate→Maintenance. The alerts appear in the In Maintenance monitor 
box.

To remove the “in maintenance” status from selected alerts, select 
Alerts→Prioritize→Suppress/Escalate→Normal.
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Assigning Alerts

You can assign alerts to another user, another group, or yourself.

 Note:  The users or groups to which you can assign alerts depends on your security permissions. See Event 
List Security on page 44.

 

Assigning an Alert to Another User

To assign selected alerts to another user, select Alerts→Ownership→Assign to User and select a user from 
the sub-menu.

 

Assigning an Alert to Another Group

To assign selected alerts to another group, select Alerts→Ownership→Assign to Group and select a group 
from the sub-menu.

When you assign an alert to another group, the alert is owned by the nobody user in that group.

 

Assigning an Alert to Yourself

To assign selected alerts to yourself, either select your name from the Alerts menu or select 
Alerts→Ownership→Take Ownership.

Deleting an Alert

To delete all currently selected alerts, select Alerts→Delete.

 Note:  You can only delete an alert if you have permission to do so. See Event List Security on page 44.

Resolving Alerts

To display a list of known resolutions, which are determined by the class of the alert, select Alerts→Resolve.

This option is normally grayed-out due to the dynamic nature of the Alerts menu.

Displaying Alert Information

To display additional information about a selected alert, double-click the alert or select Alert→Information.
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This displays the Event Information window, which contains the full details of the alert. There are three tabs 
on the Event Information window, described in Table 13.

Use the Next and Previous buttons to display detail information for the next or previous selected item in 
the event list. This can fail if alerts have been deleted elsewhere in the system.

 

Copying Alert Information

To copy alert information from the Event Information window to the clipboard:

1. Select the information that you want to copy.

2. Right-click the selected text and select Copy to Clipboard from the popup menu.

Adding an Alert to the Task List

The Task List enables you to identify those alerts that require special attention. Adding alerts to the Task 
List works in conjunction with the Task List event list filter (see Default Monitor Boxes on page 37).

To add selected alerts to the Task List, select Alerts→Task List→Add to Task List. The alerts appear in the 
Task List monitor box.

To remove selected alerts from the Task List, select Alerts→Task List→Remove from Task List.

Table 13: Event Information Window Tabs

Tab Description

Alert Fields Contains information about each alert field, which is stored in the ObjectServer alerts.status table.

Alert Details Provides details about the alert, which are stored in the ObjectServer alerts.details table. 

Journal Shows the journal details for the alert, which are stored in the ObjectServer alerts.journal table.

The Add To Journal button on the Journal tab opens the full Journal window for the currently selected 
alert. See Viewing and Adding to the Journal on page 52.
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Viewing Related Events

The event list contains tools that can help you locate related events on the network. To view events that are 
related to the currently selected alert, select one of the menu options in Table 14. Each of these tools opens 
a separate event list window containing any related events.

Restricting the Number of Rows Displayed

Your system administrator can use the View Builder to restrict the number of rows that are visible to you in 
the event list. See Using the View Builder on page 85 for more information. Your system administrator may 
give you the ability to change the number of rows displayed between specified limits.

Table 14: Related Events Tools

Menu Option Description

Alerts→Near-End Events→Entire Node Locates events that are on the same node as the node 
indicated by the selected alert.

Alerts→Near-End Events→Managed Object Instance Locates events that are on the same node and for the same 
local root object indicated by the selected alert.

Alerts→Far-End Events→Entire Node Locates:

• Events for a node that is indicated as the remote node by 
the selected alert.

• All events that indicate the node from the selected alert 
as a remote node.

Alerts→Far-End Events→Managed Object Instance Locates:

• Events for a node that is indicated as the remote node by 
the selected alert and for which its local root object 
matches the remote root object of the selected alert.

• All events which indicate the node from the selected 
alert as a remote node and which indicate a remote root 
object that matches the local root object the selected 
alert.
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Figure 13 shows an event list where the system administrator has permitted the user to display between 10 
and 30 alerts, with 20 alerts currently displayed.

To change the number of rows displayed, enter the required number in the Top [Min-Max] text box.

If the text box label reads Top [FIXED], you are not permitted to change the number of alerts displayed.

If the text box label reads Top [OFF], there is no restriction on the number of alerts displayed.

Viewing and Adding to the Journal

To view the journal for a selected alert, select Alerts→Journal or, on the Event Information window, click 
the Add to Journal button. This displays the Journal window, where you can enter and store alert history 
information. Figure 14 shows the Journal window.

Figure 13: Restricting Rows Displayed in the Event List - the Top [Min-Max] Text Box

Figure 14: Journal Window

Read-only display

Text area
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The Journal window is made up of two text areas. The top area is read-only and displays the existing journal 
history text, complete with the time it was entered and the name of the user who entered it. 

You can enter text to be added to the journal in the lower text area. Once you have completed the text entry, 
click OK to add the new text to the end of the journal, automatically time-stamping it. There is a limit of 
4096 characters for each journal entry.

To apply journal text to all selected alerts, not just the alert whose serial number is displayed at the top of 
the window, click the Apply to All Selected check box. When you click OK, the journal text is added to all 
selected alerts and the window closes.

Use the Next and Previous buttons in the Journal window to move to the journal entry for the next or 
previous selected alert in the event list.

You can use the Alerts menu in this window by right-clicking the top text window. For information about 
the Alerts menu, see Using the Event List on page 43.

 Finding Fields in the Event List

To find a field that matches a particular value in the event list:

1. Select View→Find. The Find window appears.

2. Select a field name from the list.

3. Enter the value you wish to match in the Value field. 

4. Select the type of match from the Options frame:

– Exact Match finds a row where the selected field exactly matches the entered value.

– Regular Expression finds a row where the selected field matches the entered regular expression. 
For information about regular expressions, see How to Use Regular Expressions on page 98.

– Sub String finds a row where the selected field contains the entered value somewhere in it.

When you click the Find button, if a matching row is found, any currently selected rows are deselected and 
the matching row is selected. Click the Next button to show the next match in the event list.

Using Drag and Drop With the Find Window

You can quickly define your search criteria by dragging and dropping event information from the event list 
into the Find window. Click the middle mouse button on a field in the event list and drag it to the list of 
fields in the Find window. The Options frame is set to Exact Match by default.
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Quick Filtering

Quick filtering enables you to easily display alerts on the event list that match your selected criteria. For 
example, you can quickly display only those alerts that occurred at the same time as, or before, the selected 
alert.

To quick filter:

1. In the event list, select an alert field on which to base the quick filter.

2. Select Alerts→Quick Filter. A quick filter menu appears, which contains the following options:

– Equals

– Not Equals

– Greater Than

– Greater Than or Equals

– Less Than

– Less Than or Equals

– Like

– Not Like

– Off

3. Select the quick filtering option. The event list displays only those alerts that match the filter criteria 
based on the selected alert field.

To remove quick filtering, select Alerts→Quick Filter→Off or click the All Events button on the 
distribution status bar.

 Note:  The All Events button on the distribution status bar is only enabled when using quick filtering or 
severity filtering. On UNIX platforms, this button flashes to indicate filtering is active.
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Severity Filtering

Severity filtering enables you to quickly display only those alerts that match a particular severity. To use 
severity filtering, click the desired severity color on the event list distribution status bar. Figure 15 shows an 
event list with no severity filtering.

To see only those alerts with a severity level of minor (yellow), click the yellow section of the distribution 
status bar, as shown in Figure 16. 

Figure 15: Event List with No Severity Filtering

Figure 16: Severity Filtering with the Distribution Status Bar
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The event list is filtered so that only alerts with a severity level of minor are displayed, as shown in 
Figure 17. 

 Note:  The All Events button on the distribution status bar is only enabled when using quick filtering or 
severity filtering. On UNIX platforms, this button flashes to indicate filtering is active.

Using Jump to Top

Jump to Top controls how the event list scrolls when an update occurs. When Jump to Top is enabled, the 
event list automatically jumps to the top row when an update occurs. If you disable Jump to Top, the event 
list does not jump when updates occur. Jump to Top can help you quickly review updated alerts.

To enable or disable Jump to Top, select View→Jump To Top.

 Note:  To ensure that Jump to Top is enabled every time you open an event list, on the event list monitor 
box window, select Windows→Preferences. On the Misc tab, enable the Jump Button on By Default 
option.

Figure 17: Event List with Severity Filtering
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Copying from the Event List

You can copy information from an alert on the event list to the clipboard for use in other applications. To 
do this:

1. Select an alert field. A black box surrounds the field.

2. Select Edit→Copy to Clipboard.

You can also copy alert information from the Event Information window. See Displaying Alert Information 
on page 49.

Selecting a Different Filter

To select a different filter to use in the event list, click the filter drop-down list on the toolbar and select from 
the list of available filters.

Selecting a Different View

To select a different view for the event list, click the view drop-down list on the toolbar and select from the 
list of available views.

Editing the Current Filter

To edit the current filter used by the event list, select Edit→Edit Filter. The Filter Builder appears, which 
you can use to edit the filter.

See Chapter 4: Using the Filter Builder on page 67 for more information.

Editing the Current View

To edit the current event list view, select Edit→Edit View. The View Builder appears, which you can use to 
edit the view.

See Using the View Builder on page 85 for more information.

Printing an Event List

To print the current view of an event list, select File→Print. The Print window appears.
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Printing the UNIX Event List

On UNIX platforms you can control the formatting of the output using the Print window. Table 15 
describes the Print window items. 

Printing the Windows Event List

When you print an event list on Windows, the standard Print window appears. Complete the window 
options and click OK to print the event list.

Using Tools

Your system administrator can define tools to be used on selected alerts in the event list. Select Alerts→Tools 
to display the sub-menu of tools.

Table 15: UNIX Print Window Items

Window item Description

Printer Sends the alert information to a printer. Enter the name of the printer in the Printer field.

File Sends the alert information to a file. Enter the name of a file in the File field, or select the File 
button to display a file selection dialog.

All Alerts In View Prints all the alerts in the current event list.

Selected Alerts Prints only selected alerts.

Row Separators Inserts row separators into the output; for example, a dashed line between each row.

Row Numbers Adds the row number to each row output.

Column Separators Inserts column separators into the output; for example, a | character at the start and end of fields.

Column Headings Adds the name of the column to the top of the output file.
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3.5 Using the Event List Preferences Window

To display the Event List Preferences window, on the monitor box window, select Windows→Preferences.

The Event List Preferences window contains the following tabs:

• Monitors

• Refresh

• Notification

• Flashing

• Misc

Each tab is described in the following sections.

Setting Monitor Box Preferences

Use the Monitors tab to select the types of information displayed by monitor box indicators on the event 
list. Table 16 describes the Monitors tab items.

Table 16: Event List Preferences Window Monitors Tab Items

Window Item Description

Show Count Displays the number of alerts matching the filter on monitor boxes.

Show Highest Severity Displays the highest severity among the alerts that match the filter on monitor boxes.

Show Lowest Severity Displays the lowest severity among the alerts that match the filter on monitor boxes.

Show Metric Displays the selected filter metric value on monitor boxes. See Setting the Filter Metric on 
page 83.

Show Severity Border Displays a colored border around monitor boxes. The border color changes according to the 
highest severity among the alerts that match the filter.

Show Lavalamp Display the distribution indicator as a horizontal bar.

Show Histogram Display the distribution indicator as a bar graph.
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Setting Refresh Preferences

Use the Refresh tab to configure the event list to update at a selected time interval rather than awaiting 
notification of updates from the ObjectServer. Table 17 describes the Refresh tab item.

 Note:  Timed Refresh forces the event list to reload all its data at a set interval. Do not set the refresh to a 
low value (for example, less than 60 seconds) as this has an impact on ObjectServer performance and 
network traffic.

Setting Notification Preferences

Use the Notification tab to set notification options when the event list is iconized (minimized). Table 18 
describes the Notification tab items.

Table 17: Event List Preferences Window Refresh Items

Window Item Description

Timed Refresh Select the check box to enable timed refresh. In the field, enter the refresh interval (in seconds). 

All the latest data from the ObjectServer will be sent to the event list at the selected time interval.

Note: If the AllowTimedRefresh ObjectServer property, described in the Netcool/OMNIbus 
Administration Guide, is set to FALSE, refresh timers are disabled and updates occur based on 
notification from the ObjectServer. 

Table 18: Event List Preferences Window Notification Tab Items (1 of 2)

Window Item Description

Notify When Iconised Select to activate event list notification.

When Indicate when to notify:

• New when a new alert has appeared.

• Change when an existing alert has changed.

• Delete when an existing alert has been deleted.
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Setting Flash Preferences

Use the Flashing tab to indicate flashing event list options. Table 19 describes the Flashing tab items.

Setting Miscellaneous Preferences

Use the Misc tab to set other event list preferences. Table 20 describes the Misc tab items.

How Indicate how to notify:

• Ring Bell to sound the workstation/terminal bell once.

• Alert Icon to flash an exclamation mark over the event list icon (UNIX) or flash the 
minimized event list (Windows).

• Open Window to open the event list on the screen. If you use a window manager with 
interactive placement, the event list opens as the active window.

• Run External Command to run a command. Enter the command name in the text field 
below the Run External Command toggle button. This must only be used for simple 
desktop notification, and is not designed for handling paging applications.

Table 18: Event List Preferences Window Notification Tab Items (2 of 2)

Window Item Description

Table 19: Event List Preferences Window Flash Tab Items

Window Item Description

Enable Flashing Select to enable event list flashing.

Fast/Slow Use the slider to indicate how quickly the event list flashes.

Bright/Dark Use the slider to indicate the brightness of the flashing.

Table 20: Event List Preferences Window Misc Tab Items (1 of 2)

Window Item Description

Show Colors Indicate the severity color of alerts in event list. You can deselect this option to change 
the event list to monochrome and not show the severity color.

Show Distribution Summary Display the distribution summary bar in the event list.

Show Toolbars Make the toolbars available on the event list.

Jump Button On by Default Enable the Jump To Top feature by default. See Using Jump to Top on page 56.
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Sort Information Details Sort the detail fields in the Event Information window alphabetically by name of field. 
When this is not selected, the detail fields are displayed in an order determined by the 
ObjectServer.

Table 20: Event List Preferences Window Misc Tab Items (2 of 2)

Window Item Description
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3.6 Netcool/Internet Service Monitors in the Event List

Netcool/Internet Service Monitors (ISMs) work in conjunction with the rest of the Netcool/OMNIbus 
product suite. Events generated by both monitors and probes can be forwarded to the same ObjectServer 
and you can manipulate these events using the same desktop.

When you install Netcool/ISMs, the installation program makes two changes to the standard 
Netcool/OMNIbus desktop:

• Two new buttons and a drop-down list are added to the event list window

• A new Services window is added

These are described in the following sections.

Event List Window with Netcool/ISMs Installed

When Netcool/ISMs is installed, two new buttons and a drop-down list are added to the event list, as shown 
in Figure 18. 

Table 21 contains descriptions of the event list buttons for Netcool/ISMs.

Figure 18: The Event List Window with Netcool/ISMs Installed

Show Services button

Services View button Services drop-down list

Table 21: Event List Buttons for Netcool/ISMs (1 of 2)

Button Description

Click the Services View button to display service alerts in the event list window. You can change the service 
type using the Services drop-down list, described in this table.

Click the Show Services button, to start the Services window from the event list.
Netcool/OMNIbus v7 User Guide 63



Chapter 3: Using the Event List
Viewing Services in the Event List

When Netcool/ISMs is installed, the Services window is installed automatically as part of the event list.

To view services information:

1. From the Conductor, open the event list. The monitor box window and the Services window are 
displayed. The Services window contains a list of the different service types available.

2. In the Services window, double-click the service type you want to view. An event list is displayed 
containing a list of events for that service type. You can manipulate the service alerts in the list in the 
same way as alerts received from probes.

Use the Services drop-down list to change the type of service status events displayed in the event list 
window. For example, selecting a monitor type from the list displays all the service status events from that 
type of monitor.

Table 21: Event List Buttons for Netcool/ISMs (2 of 2)

Button Description
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Using the Services Window

When Netcool/ISMs is installed, the Services window shown in Figure 19 is opened automatically whenever 
you access the monitor box window from the Conductor.

Each line in the Services window indicates a different service. Double-click any row in the Services window 
to open an event list window containing events of that type. Table 22 contains descriptions of the Service 
window items. 

Figure 19: Services Window

Table 22: Services Window Items (1 of 2)

Window Item Description

Colored symbols The colored symbols to the left of each line indicate the status of the last alert the ObjectServer 
received from that service. They are color-coded, as follows:

• Red - The service level agreement is not being met

• Amber - There are some problems with the service

• Green - There are no problems with the service

• Black - The status of the service is unknown

Service Name of the service being monitored.

Last Change Last time the service status changed.
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Last Good Last time the service was good.

Last Bad Last time the service was bad.

Last Marginal Last time the service was marginal.

Last Reported Last time a report was generated for the service.

Table 22: Services Window Items (2 of 2)

Window Item Description
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Chapter 4: Using the Filter Builder

You can use filters to display only those alerts that you want to see in the event list. You can use the Filter 
Builder to create, edit, and manage filters.

This chapter contains the following sections:

• Introduction to the Filter Builder on page 68

• Creating a Filter on page 69

• Saving Filters on page 81

• Dragging and Dropping Filters on page 82

• Setting the Filter Metric on page 83

• Direct SQL Editing on page 84
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4.1 Introduction to the Filter Builder

You can use filters to define SQL queries of the ObjectServer alerts database tables in order to display 
custom alert information in monitor boxes and event lists. You can use the Filter Builder to create and edit 
filters.

Starting the Filter Builder

Start the Filter Builder in one of the following ways:

Figure 20 shows the UNIX Filter Builder.

Table 23: Starting the Filter Builder

From... Do this...

the event list Click the Filter Builder button on the event list toolbar.

a monitor box Click the filter name button.

the UNIX Conductor Click the Filter Builder button on the Conductor or double-click a saved filter (.elf) file in the 
personal library.

Figure 20: Filter Builder on UNIX

SQL display

Filter display

Element 
inspector

Element 
buttons
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4.2 Creating a Filter

To create a filter in the Filter Builder:

1. In the Name field, enter a name for the filter. This name is used to select the filter in event list menus.

2. If you have permission to do so, use the Editable check box to indicate whether users are able to edit 
this filter.

3. Build the filter using filter elements. The next sections contain information about types of filter 
elements and how to create them.

Types of Filter Elements

A filter is made up of elements. The elements are displayed as blocks on the filter display and are arranged in 
a tree showing how the elements relate. Table 24 contains descriptions of the available element types.

Creating Condition Elements

To create a condition element in the Filter Builder:

1. Click the Condition button.

2. Click the Expression Type drop-down list and choose either Simple or Complex. 

For more information, see Selecting the Expression Type on page 70.

3. Click the Column drop-down list and select a field. For example, select Acknowledged. 

For more information, see Selecting the Field on page 70.

4. Click the Operator drop-down list and select an operator. 

For more information, see Selecting the Operator on page 70.

5. In the field below the Operator drop-down list, enter a comparison value.

The following sections describe in detail how to edit the field, operator, and value attributes in the element 
inspector.

Table 24: Filter Element Types

Element type Description

Condition A comparison made between fields and values. This is the most basic filter element.

Logical An AND, OR, or NOT operator. It allows you to build filters with multiple conditions.

Subquery A query in a condition using the alerts.status, alerts.journal, or alerts.details tables.
Netcool/OMNIbus v7 User Guide 69



Chapter 4: Using the Filter Builder
Selecting the Expression Type

Click the Expression Type drop-down list to select either simple or complex expressions to be used in the 
condition element. 

If you select a complex expression type, you can click the Edit button to display the Filter SQL Edit window. 
Any expressions entered in the Filter SQL Edit window are automatically parsed and added to the condition 
element.

See Direct SQL Editing on page 84 for more information about using the Filter SQL Edit window. 

Selecting the Field

To display a menu of all the available fields to be used in the comparison, click the Column drop-down list. 

The Filter Builder automatically determines which fields are available. By default, the list contains the names 
of the fields in the alerts.status database table. There are situations where this list will be different; 
these special cases are described in Creating Subquery Elements on page 78.

Selecting the Operator

To display the comparison operation to be used for the condition element, click the Operator drop-down 
list. 

The range of comparisons available is determined by the field selected on the Column drop-down list. Some 
comparisons are unavailable for certain fields. For example, it is not possible to have a LIKE operation on 
a numeric field such as Severity.

Entering the Value Field

There are three data types for value fields:

• String

• Integer

• Date/time

These types are described in the following sections.

You can also enter a list of values, rather than a single value, using In or Not in. Depending on the data type 
of the Value field, a different element inspector is displayed.
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String Value Fields

String values are displayed as text fields. Enter a string into the field; surrounding quotation marks are not 
required. For example, Figure 21 shows the element inspector for the Agent field.

Some characters in the string can be escaped with a back slash (\) in the SQL text where they would 
otherwise have unintended effects on the operation of the filter. For example, single and double quotation 
marks are automatically escaped.

 

Integer Value Fields

For integer values, the drop-down list is only active where a numeric field has conversions set up for it. If 
there are no conversions available, the drop-down list is grayed out.

In the UNIX Filter Builder, the value field is split into three parts: the value drop-down list, the numeric 
value field, and arrow buttons. 

Figure 22 shows the element inspector from the UNIX Filter Builder for the Severity field.

Figure 21: Element Inspector for the Agent Field

Figure 22: Integer Values on UNIX

Value field
Value 
drop-down list
Netcool/OMNIbus v7 User Guide 71



Chapter 4: Using the Filter Builder
In the Windows Filter Builder, select a value from the Value drop-down list, as shown in Figure 23.

In the above example, the Severity field is stored internally as an integer value, but has a set of 
conversions to map those numbers to various severity strings; for example, 0 means Closed, and 5 means 
Critical. Where conversions like this exist for a field, the string names are displayed in the drop-down 
list. 

Select an entry on the drop-down list to place the numeric value in the field next to the drop-down list. If 
you are setting a comparison with Severity and select Major from the drop-down list, 4 is entered into 
the numeric field. 

On UNIX, you can also enter a numeric value directly into the text field.

 

Date and Time Value Fields

Date and time value fields have the following modes of operation:

• Absolute, which is an exact moment in time

• Relative, which is a time relative to the present

Figure 23: Integer Values on Windows
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Figure 24 shows the element inspector for the FirstOccurrence field in absolute mode on the UNIX 
Filter Builder.

The six fields that follow the drop-down list represent day, month, and year (top row) and hour, minutes, 
and seconds (bottom row). You can enter a date directly into these fields or increase and decrease the values 
by using the arrow buttons to the right of each field. The date and time displayed is always initialized to the 
current date when an element is created.

Figure 25 shows the element inspector for the FirstOccurrence field in absolute mode on the 
Windows Filter Builder.

Figure 26 shows the element inspector for the FirstOccurrence field in relative mode on UNIX.

Figure 24: Date/Time Values on UNIX

Click to select 
absolute or relative 
mode

Figure 25: Date/Time Values on Windows

Click to select 
relative mode

Figure 26: Relative Mode Values on UNIX
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Figure 27 shows the element inspector for the FirstOccurrence field in relative mode on Windows.

The getdate function is an ObjectServer SQL function that returns the current date and time. You can 
use this in a calculation to establish a time relative to the present. The calculation is made in seconds, so 300 
represents 300 seconds or 5 minutes. For example, to represent the time 10 minutes previous, enter 
getdate - 600.

 

In and Not In Operators

The In and Not In comparison uses a list of values, rather than a single value. When you select In or Not In 
as an operator, a value list appears.

Figure 28 shows the element inspector value list on UNIX.

To add a value to the list, enter the value and click the Add button or press Enter. To remove a value from 
the list, select the value in the list and click the Remove button.

Figure 27: Relative Mode Values on Windows

Figure 28: Value List for In and Not In Fields on UNIX
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Figure 29 shows the element inspector value list on Windows.

To add a value in the list, enter the value and click the Plus button or press Enter. To remove a value from 
the list, select the value in the list and click the Minus button.

Creating Logical Elements

When you use a single condition element, you are limited to simple comparisons.

Logical elements allow two elements to be combined for more complex comparisons. A logical element has 
one of the following boolean operators:

• AND

• OR

• NOT

Creating a Logical Element on UNIX

There are two ways to insert the AND and OR logical elements: the Leading Logical and Trailing Logical 
buttons.

To create a logical element:

1. Select an existing element; for example, a condition.

2. Click either the Leading Logical or Trailing Logical button.

Figure 29: Value List for In and Not In Fields on Windows
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3. Select the boolean operator.

4. Click the Condition button to add another condition branch.

Table 25 shows what happens if you select either a conditional or logical element and then click one of the 
logical buttons.

Creating a Logical Element on Windows

To create a logical element:

1. Select an existing element; for example, a condition.

2. Select either the And condition button or the Or condition button.

3. Change the condition attributes on the new condition.

4. Click the Apply button to save the changes.

Example Logical Comparison

This example uses the logical AND element. To find all alerts that have been acknowledged and are greater 
than major severity, use two condition elements: Acknowledged = Yes and Severity > Major.

The translates to the SQL condition:

(Acknowledged = 1) and (Severity > 4)

Acknowledged is an integer value for which 0 equates to No and 1 equates to Yes. Severity names map to 
integer numbers 0-5. Integers are used rather than string values because the Filter Builder manages the 
translations between names and values.

Table 25: Logical Filter Element Buttons

Element Leading Logical button used Trailing Logical button used

Condition Element Creates a logical element as the child of the 
parent of the condition element. The condition 
element becomes the child of the logical 
element.

Disabled: Condition elements cannot have 
children.

Logical Element Creates a logical element as the child of the 
parent of the logical element. The condition 
element becomes the child of the logical 
element.

The logical element is added as a child of 
the existing logical element. If the insertion 
point already has two children, this button 
is disabled.

No Element Selected Creates a single logical element. Creates a single logical element.
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When a logical element is selected, the element inspector displays two buttons: And and Or. Logical 
elements are created by default as AND elements. To use an OR element, select the element and then select 
Or in the element inspector.

Figure 30 shows this example as displayed in the UNIX Filter Builder.

Negate Element

The negate element is a logical element, but unlike the AND and OR logical elements, it can only have one 
parent and one child. 

The negate element is always inserted before the current insertion point. The negate element inverts the 
result of what follows it in the tree.

Although a negate element has only one child in the tree, it can generally be manipulated as a logical element.

 

Negate Example on UNIX

You can enter a conditional element that finds all the alerts that have a severity of warning, as shown in the 
Filter Builder on UNIX in Figure 31.

Figure 30: Example Logical Comparison in the UNIX Filter Builder

Figure 31: Example Negate Filter Condition on UNIX (Part 1)
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To negate the condition, select the element; then, click the Negate button, as shown in Figure 32.

 Note:  It is not possible to insert a negate logical element before an existing negate logical element; however, 
when editing a filter, it is possible to delete a section of a tree to leave two negate elements one after another. 
You must delete one of these to create a valid filter.

 

Negate Example on Windows

To negate a condition, select the element; then, click the Negate button. For example, you can enter a 
conditional element that finds all the events that have a severity of warning, as shown in Figure 33.

To negate the condition, click the Negate button, as shown in Figure 34.

Creating Subquery Elements

A subquery allows you to make a query in a condition. For example, you might want to look for alerts that 
have journal entries in the alerts.journal table, or look for alerts that have a particular detail attribute 
in the alerts.details table.

To create a subquery element:

1. Click the Sub Query button.

2. From the Column drop-down list, select the field to be used in the search.

Figure 32: Example Negate Filter Condition on UNIX (Part 2)

Figure 33: Example Negate Filter Condition on Windows (Part 1)

Figure 34: Example Negate Filter Condition on Windows (Part 2)
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3. From the Operator drop-down list, select either:

– In to search for the contents of the field

– Not in to search for the absence of the contents of the field

4. From the Select drop-down list, select the field to be used when building the list, against which the In 
or Not In operation is to be performed. The options in this list are determined by the From button.

5. From the From drop-down list, select the table from which to derive the information. This can be 
alerts.details, alerts.journal, or alerts.status.

 

Example Subquery Element

Figure 35 shows a subquery element that compares the Identifier fields of the alerts.status table and 
the alerts.details tables. 

Using Subquery Elements with Other Elements

A subquery element can be followed by conditional, logical, and subquery elements. These elements allow 
you to specify selection criteria for the information from another table. For example, you can select only 
alerts that have a particular detail attribute.

Figure 36 shows how the subquery element is displayed in the UNIX Filter Builder.

Figure 37 shows how this subquery element is displayed in the Windows Filter Builder.

Figure 35: Example Subquery Element on UNIX

Figure 36: Example Subquery Element with Other Elements on UNIX

Figure 37: Example Subquery Element with Other Elements on Windows
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This example element compares the Identifier fields in the alerts.status table and the 
alerts.details table, where the records in the alerts.details table also contain a Name field 
with the value SpecialValueAlert. The elements that follow the subquery element also refer to the same table 
as the subquery.

Deleting Elements

To remove only the currently selected element, click the Delete Element button or select Edit→Cut.

To delete an element tree, click the Delete Tree button. This removes the currently selected element and all 
child elements.

When you delete filter elements, the Filter Builder attempts to link the child elements into the filter. This 
does not work if you try to remove a logical element with two children or a subquery that has children.

Copying and Pasting Elements

To copy the selected element tree, select Edit→Copy.

When you paste elements elsewhere into the filter, the Filter Builder attempts to insert them relative to the 
currently selected element.
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4.3 Saving Filters

You must save filters with an .elf file extension.

You can apply changes to the filter without saving it by using the Apply button. Click Close to close the 
window and discard the changes.

 Note:  On the UNIX Filter Builder, the Apply button does not appear when it is run from the Conductor. 
When run from the Conductor, all filters must be saved using the File→Save or File→Save As menu items.
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4.4 Dragging and Dropping Filters

You can create filters using drag and drop on UNIX platforms. You can drag and drop from:

• One Filter Builder to another

• An event list window into the Filter Builder

Dragging and Dropping from One Filter Builder to Another

To use drag and drop from one Filter Builder to another:

1. Move the mouse pointer over the drag point icon (to the right of the Editable check box).

2. Click and hold the middle mouse button over the icon.

3. Drag the mouse to another Filter Builder. When the cursor is over a valid drop area, it changes color 
to green.

4. Release the mouse button to drop the filter.

If the filter is not valid or is incomplete, a red cross appears on the drag point icon and you cannot 
drag and drop.

Dragging and Dropping from the Event List to the Filter Builder

You can create condition elements in filters by dragging and dropping alert information from the event list 
into the Filter Builder. The condition element is created using the value of the column from where the drag 
and drop was started.

For example, if you click the middle mouse button over the event list in the Severity column on an alert that 
has a Critical value, and then drop this into the Filter Builder, a condition element is created and set to 
Severity=Critical(5).

Repeat this process to create more condition elements joined to the existing tree with logical elements. 
Logical elements are discussed in Creating Logical Elements on page 75.

Figure 38: Filter Builder - Drag Point Icon

Figure 39: Filter Builder - Invalid Drag Position
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4.5 Setting the Filter Metric

All filters can have a metric associated with them. A metric is a measurement that can be applied to the filter 
so that it calculates a useful figure. You can select the type of metric used when you are creating the filter. 
Metrics can be displayed in monitor boxes. For example, a metric could be an average, count, or sum of all 
the alerts.

The Metric panel consists of two drop-down lists, as shown in Figure 40.

The first drop-down list allows you to choose the measurement to be used. The types of measurement are 
described in Table 26.

The second drop-down list allows you to select a field to which the measurement is applied. Only the integer 
and time fields in an alert are available for the metric calculation.

Figure 40: Filter Metric

Table 26: Types of Measurement for the Metric Panel

Option Type of Measurement

Average Returns the average value of the selected field for all alerts that match the filter.

Count Returns a count of all the alerts that match the filter. The selected field is not used for this 
calculation.

Sum Returns the sum of the selected field for all alerts that match the filter.

Minimum Returns the lowest value of the selected field in alerts that match the filter.

Maximum Returns the highest value of the selected field in alerts that match the filter.
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4.6 Direct SQL Editing

If you want to edit ObjectServer SQL directly in the Filter Builder, click the Edit SQL button. A window 
is displayed in which you can enter the SQL text.

Figure 41 shows the Filter SQL Edit window.

When you click the OK button, the Filter Builder attempts to parse the SQL text and build a filter tree. If 
there are any SQL errors, a dialog appears and you must correct the errors before you can continue.

Figure 41: Filter SQL Edit Window
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Chapter 5: Using the View Builder

You can use views to display a selection of alert fields in the event list. You can use the View Builder for 
creating, editing, and managing views.

This chapter contains the following sections:

• Introduction to the View Builder on page 86

• Creating a View on page 89

• Saving Views on page 95

• Dragging and Dropping Views (UNIX Only) on page 96
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5.1 Introduction to the View Builder

Views define the type and formatting of information that appears in event lists. For each view, you can 
specify:

• Fields to include in the event list

• Field titles

• Field formatting

• How information is sorted

• Whether to restrict the number of rows displayed in the event list

You can use the View Builder to create and edit views.

Starting the View Builder

You can start the View Builder in the following ways:

Table 27: Starting the View Builder

From... Do this...

the event list Click the View Builder button on the event list toolbar.

the UNIX Conductor Click the View Builder button on the Conductor or double-click a saved view (.elv) file in the 
personal library.
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Figure 42 shows the UNIX View Builder.

Figure 43 shows the Windows View Builder.

Figure 42: View Builder on UNIX
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Netcool/OMNIbus v7 User Guide 87



Chapter 5: Using the View Builder
Figure 43: View Builder on Windows
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5.2 Creating a View

To create a view in the View Builder:

1. In the Name field, enter a name for the view. This name is used in the event list.

2. If you have permission to do so, use the Editable check box to indicate whether users are able to edit 
this view.

3. You can now:

– Add columns to the view

– Remove columns from the view

– Change the appearance of a view column

– Change the view column sort order

– Restrict the number of rows to display in the event list

The following sections contain descriptions for each of the above tasks.

Adding a Column to a View

To add a column to a view:

1. In the Display Columns area, select a field from the list.

2. Click the Add button (right arrow button on Windows).

On UNIX, the field is added to the view as the right-most column. If necessary, use the horizontal 
scroll bar to view the new column. On Windows, the field is added to the Event List View list.

Using Drag and Drop (UNIX only)

On UNIX, you can also add a column with drag and drop:

1. Select a field from the field list.

2. Click and hold the middle mouse button.

3. Drag the pointer over the sample display columns.

4. Release the mouse button. The field is added to the view as the right-most column.
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Removing a Column from a View

To remove a column from a view:

1. In the Display Columns area (Event List View list on Windows), select the column to remove.

2. Click the Remove button (left arrow button on Windows). The column is removed from the view 
and appears back in the Available Fields list.

Using Drag and Drop (UNIX only)

On UNIX, you can also remove a field with drag and drop:

1. In the Display Columns area, click and hold the middle mouse button on the column to remove.

2. Drag the pointer over the field list.

3. Release the mouse button. The column is removed and placed back in the Available Fields list.

Changing the Order of View Columns

To change the order of the view columns, in the Display Columns area (Event List View list on Windows), 
select a column. You can now change its position using the buttons in Table 28.

Table 28: View Column Order Selection Buttons

UNIX button Windows button Description

First Moves the selected column to the first (left-most) column of the view.

Left Moves the selected column one position to the left in the view.

Right Moves the selected column one position to the right in the view.

Last Moves the selected column to the last (right-most) column of the view.
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Changing the Appearance of a View Column

In the View Builder Display Columns area (Event List View list on Windows), click the column to change. 
Use the Column Details fields to change how the column will appear in the event list. The Column Details 
fields are described in Table 29.

Changing the View Column Sort Order

You can use the Sort Columns area to configure the sort order of rows for an event list view. Figure 44 shows 
the Sort Columns area in the UNIX View Builder. The rows are sorted by the Serial field. 

Table 29: View Builder Column Details

Window item Description

Column

Field Name (Windows)

Displays the name of the currently selected database field. Use the Justify 
drop-down list to the right of this field to select the alignment of the data as it will 
appear in the event list.

Title

Column Title (Windows)

The title for this database field as it will appear in the event list. Use the Justify 
drop-down list to the right of this field to select the alignment of the title.

Width

Column Width (Windows)

Select the column width as it will appear in the event list.

Fixed Columns (UNIX only) You can have a number of fixed columns on the left-hand side of the event list. Fixed 
columns do not move off the screen if you scroll across the columns in the view. This 
slider allows you to fix up to one less than the total number of columns in the view.

Figure 44: Sort Columns Area in the UNIX View Builder
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Adding Sort Fields

To add a field to the sort list:

1. In the Sort Columns list, select the field to add.

2. Click the Add button (right arrow button in Windows). The field is added to the bottom of the sort 
list.

 

Using Drag and Drop (UNIX only)

On UNIX, you can use drag and drop to add a field. To add a field using drag and drop:

1. In the Sort Columns list, select the field to add.

2. Click and hold the middle mouse button over the field.

3. Drag the pointer over the list of sorting fields.

4. Release the mouse button. The field is added to the bottom of the sort list and is removed from the 
Sort Columns list.

Removing Sort Fields

To remove a field from the sort list:

1. In the sort list, select the field to remove.

2. Click the Remove button (left arrow button in Windows). The field is removed from the sort list.

 

Using Drag and Drop (UNIX only)

On UNIX, you can use drag and drop to remove a field:

1. In the sort list, select the field to remove.

2. Click and hold the middle mouse button over the field.

3. Drag the pointer to the Sort Columns list.

4. Release the mouse button. The field is removed from the sort list and returned to the Sort Columns 
list.

Changing the Sort Direction

In the sort list, an arrow appears next to each entry. By default, this arrow points upwards, indicating the 
field will be sorted in ascending alphabetic order.

To change the order to descending order, double-click the arrow.
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Changing the Sort Precedence

The field at the top of the sort list has the highest precedence when sorting. If you add a second field to the 
list, and the first field is identical for a number of entries, the second field is used to sort in those entries.

To raise or lower a field’s sort precedence, select the field in the sort list and use the following buttons:

These buttons are not available if the operation is inappropriate. For example, if you select the top entry in 
the list, the Top and Up buttons are unavailable because the entry is already at the top and cannot be moved 
up.

 

Popup Menus in the Sort List

Alternatively, you can use a popup menu to:

• change the sort order of a field

• change the precedence of a field

• remove a field

To display the popup menu, click the right mouse button over an entry in the sort list.

Table 30: View Column Order Selection Buttons

UNIX button Windows button Description

Top Moves the selected entry to the top of the list.

Up Moves the selected entry up one place in the list.

Down Moves the selected entry down one place in the list.

Bottom Moves the selected entry to the bottom of the list.
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Restricting the Number of Rows Displayed in the Event List

You can use the Restrict Rows area to restrict the number of rows displayed in the event list. 

From the View Builder:

1. In the Restrict Rows area, select the Restrict rows [1-100] check box. The Minimum, Maximum, 
and Default number entry fields are enabled.

2. Enter the desired values for the fields.

3. Select the Set from Event List if you want event list view users to be able to choose the number of 
events to display in their event list view.

If you select Set from Event List, the number of events that users can choose to view using the event list 
controls is constrained by the Minimum and Maximum values specified in the View Builder. 

If you do not select Set from Event List, the number of events displayed will always be the specified Default 
value.

 Note:  If you select the Restrict rows [1-100] check box, and save the configuration as an .elv file, the 
.elv file is not compatible with Netcool/OMNIbus version 3.6 and earlier.

Figure 45: Restrict Rows Area in the UNIX View Builder
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5.3 Saving Views

You must save views with an .elv file extension.

You can apply changes to the view without saving it by using the Apply button. Click Close to close the 
window and discard the changes.
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5.4 Dragging and Dropping Views (UNIX Only)

You can use drag and drop with views on UNIX platforms. You can drag and drop from:

• One View Builder to another

• The View Builder to an Event List Configuration window

To drag and drop a view:

1. Move the mouse pointer over the drag point icon (to the right of the Editable check box).

2. Click and hold the middle mouse button.

3. Drag the mouse to another View Builder or an Event List Configuration window. When the cursor is 
over a valid drop area, it changes color to green.

4. Release the mouse button to drop the view.

Figure 46: View Builder - Drag Point Icon
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Appendix A: Regular Expressions

This appendix explains how to use regular expressions. It contains the following section:

• How to Use Regular Expressions on page 98
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A.1 How to Use Regular Expressions
Regular expressions are made up of normal characters and metacharacters. Normal characters include upper 
and lowercase letters and numbers. Regular expression pattern matching can be performed with either a 
single character or a pattern of one or more characters in parentheses, called a character pattern. 
Metacharacters have special meanings, described in Table A1. 

Table A1: Pattern Matching Metacharacters (1 of 2)

Pattern Matching 
Metacharacter

Description Example

* Matches zero or more instances of the 
preceding character or character 
pattern.

The pattern ‘goo*’ matches ‘my godness’, 
‘my goodness’, and ‘my gooodness’, but not 
‘my gdness’.

+ Matches one or more instances of the 
preceding character or character 
pattern.

The pattern ‘goo+’ matches ‘my goodness’ 
and ‘my gooodness’, but not ‘my godness’.

? Matches zero or one instance of the 
preceding character or character 
pattern.

The pattern ‘goo?’ matches ‘my godness’ and 
‘my goodness’, but not ‘my gooodness’ or 
‘my gdness’.

$ Matches the end of the string. The pattern ‘end$’ matches ‘the end’, but not 
‘the ending’.

^ Matches the beginning of the string. The pattern ‘^severity’ matches ‘severity 
level 5’, but not ‘The severity is 5’.

. Matches any single character. The pattern ‘b.at’ matches ‘baat’, ‘bBat’, and 
‘b4at’, but not ‘bat’ or ‘bB4at’. 

[abcd] Matches any characters in the square 
brackets or in the range of characters 
separated by a hyphen (-), such as 
[0-9].

^[A-Za-z]+$ matches any string that contains 
only upper or lowercase letter characters. 

[^abcd] Matches any character except those in 
the square brackets or in the range of 
characters separated by a hyphen (-), 
such as [0-9].

[^0-9] matches any string that does not 
contain any numeric characters.

() Indicates that the characters within the 
parentheses should be treated as a 
character pattern.

A(boo)+Z matches ‘AbooZ’, ‘AboobooZ’, and 
‘AbooboobooZ’, but not ‘AboZ’ or ‘AboooZ’.
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| Matches one of the characters or 
character patterns on either side of the 
vertical bar.

A(B|C)D matches ‘ABD’ and ‘ACD’, but not 
‘AD’, ‘ABCD’, ‘ABBD’, or ‘ACCD’.

\ The backslash escape character 
indicates that the metacharacter 
following should be treated as a 
regular character. The metacharacters 
in this table require a backslash before 
them if they appear in a regular 
expression.

To match an opening square bracket, 
followed by any digits or spaces, followed by 
a closed bracket, use the regular expression 
\[[0-9 ]*\].

Table A1: Pattern Matching Metacharacters (2 of 2)

Pattern Matching 
Metacharacter

Description Example
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Appendix B: Desktop Reference

This appendix contains reference information for the Netcool/OMNIbus desktop, including:

• Event List Command Line Options on page 102

• Using the Transient Event List (nco_elct) on page 106

• SQL Commands and Variable Expressions in Tools, Automations, and Transient Event Lists on page 112

• Changing the Date Format in the Event List on UNIX on page 115
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B.1 Event List Command Line Options
The nco_event command opens an event list. You can use the following options when starting the event 
list from the command line.

 Tip:  On Windows, the name and location of the executable file is 
%OMNIHOME%\desktop\NCOEvent.exe.

If an instance of the event list (nco_event) is running, the nco_event command opens a new event 
list window. If there is no running instance of nco_event, the nco_event command starts one and 
displays the monitor box window.

UNIX Command Line Options

The command line options for the UNIX event list are shown in Table B1.

Table B1: UNIX Event List (nco_event) Command Line Options (1 of 2)

Command Line Option Description

-cmap Specifies a private color map. You cannot abbreviate this command line option.

-config string | URL

or

-elc string | URL

Initial configuration file to use. 

string specifies a path to an .elc file. 

URL specifies an .elc file located on a remote server accessible using the http or ftp 
protocol. The URL must be of one of the following forms:

• http://servername[:port]/path/filename.elc

• http://username:password@servername[:port]/path/filename.elc

• ftp://servername[:port]/path/filename.elc

• ftp://username:password@servername[:port]/path/filename.elc

The optional port number :port only needs to be specified if the server is not using 
the default port.

For information about event list configurations, see Using Event List Configurations on 
page 39.

-diagnostic Displays extended diagnostic messages. 

This option is only useful for detecting problems with the event list. Do not use this 
command line option unless you are advised by Micromuse Technical Support.
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 Tip:  The command line options for the event list can be abbreviated to their shortest unique abbreviation. 
For example, -uneditable can be abbreviated to -un. 

-dualwrite integer In a desktop ObjectServer architecture, indicates whether to enable or disable 
dual-write mode. Valid options are:

• 0—Disable dual-write mode

• 1—Enable dual-write mode

The -dualwrite command line option overrides the DualWrite field entry in the 
desktop ObjectServer master.national table.

For information about desktop ObjectServer architectures, see the Netcool/OMNIbus 
Installation and Deployment Guide.

-help Displays help for this command and exits.

-masterserver string In a desktop ObjectServer architecture, indicates the master ObjectServer to use.

The -masterserver command line option overrides the MasterServer field entry 
in the desktop ObjectServer master.national table.

For information about desktop ObjectServer architectures, see the Netcool/OMNIbus 
Installation and Deployment Guide.

-nlw Suppresses the of display license expiry warnings.

-password string Password to log in to the event list.

-server string Name of the ObjectServer to which you are connecting.

-uneditable Does not allow the event list configuration to be edited. When this option is used, the 
Filter Builder and View Builder buttons and the Save and Save As menu items are 
disabled.

-username string User name to log in to the event list.

-version Displays version information and exits.

Table B1: UNIX Event List (nco_event) Command Line Options (2 of 2)

Command Line Option Description
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Windows Command Line Options

The command line options for the Windows event list are shown in Table B2.

Table B2: Windows Event List (NCOEvent) Command Line Options (1 of 2)

Command Line Option Description

-config string | URL

or

-elc string | URL

Initial configuration file to use. 

string specifies a path to an .elc file. 

URL specifies an .elc file located on a remote server accessible using the http or ftp 
protocol. The URL must be of one of the following forms:

• http://servername[:port]/path/filename.elc

• http://username:password@servername[:port]/path/filename.elc

• ftp://servername[:port]/path/filename.elc

• ftp://username:password@servername[:port]/path/filename.elc

The optional port number :port only needs to be specified if the server is not using 
the default port.

For information about event list configurations, see Using Event List Configurations on 
page 39.

-diagnostic Displays extended diagnostic messages. 

This option is only useful for detecting problems with the event list. Do not use this 
command line option unless you are advised by Micromuse Technical Support.

-dualwrite integer In a desktop ObjectServer architecture, indicates whether to enable or disable 
dual-write mode. Valid options are:

• 0—Disable dual-write mode

• 1—Enable dual-write mode

The -dualwrite command line option overrides the DualWrite field entry in the 
desktop ObjectServer master.national table.

For information about desktop ObjectServer architectures, see the Netcool/OMNIbus 
Installation and Deployment Guide.

-help Displays help for this command and exits.

-masterserver string In a desktop ObjectServer architecture, indicates the master ObjectServer to use.

The -masterserver command line option overrides the MasterServer field entry 
in the desktop ObjectServer master.national table.

For information about desktop ObjectServer architectures, see the Netcool/OMNIbus 
Installation and Deployment Guide.
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-networktimeout 
integer

Specifies a time in seconds after which a login attempt or connection to the 
ObjectServer will time out, should a network failure occur. After the specified timeout 
period, the event list attempts to reconnect to the ObjectServer. If the connection is 
unsuccessful after a second timeout period, the event list will attempt to connect to a 
backup ObjectServer, where available. The default is 20 seconds.

-password string Password to log in to the event list.

-server string Name of the ObjectServer to which you are connecting.

-username string User name to log in to the event list.

-version Displays version information and exits.

Table B2: Windows Event List (NCOEvent) Command Line Options (2 of 2)

Command Line Option Description
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B.2 Using the Transient Event List (nco_elct)
The nco_elct utility enables you to open a customized, transient event list. You can use nco_elct:

• Directly from the command line

• In a script

• As part of an event list tool

For example, you can use nco_elct to open an event list and apply a filter to view all critical alerts 
from a particular ObjectServer.

 Tip:  On Windows, the name and location of the executable file is 
%OMNIHOME%\desktop\NCOelct.exe.

If an instance of the event list (nco_event) is running, the nco_elct utility opens a new event list 
window. If there is no running instance of nco_event, the nco_elct utility starts one and displays the 
monitor box window and an event list window using the filter specified at the command line.

UNIX Command Line Options

The command line options for the UNIX nco_elct utility are shown in Table B3.

Table B3: nco_elct Command Line Options (1 of 2)

Command Line Option Description

-cmap Specifies a private color map. 

-diagnostic Displays extended diagnostic messages. 

-dualwrite 1 | 0 In a desktop ObjectServer architecture, indicates whether to enable or disable 
dual-write mode. Valid options are:

• 0—Disable dual-write mode

• 1—Enable dual-write mode

The -dualwrite command line option overrides the DualWrite field entry in the 
desktop ObjectServer master.national table.

For information about desktop ObjectServer architectures, see the Netcool/OMNIbus 
Installation and Deployment Guide.
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-ffile string | URL Specifies the filter file to use for the transient event list. Event list filters have a .elf 
extension.

Note: You can also retrieve remote .elf files using http and ftp protocols, as 
described for the -config command line option in Table B1 on page 102.

-fmetric string Specifies a filter metric for the transient event list. This is ignored if you have specified 
an existing event list filter file using the -ffile.

-fname string Specifies a name for the filter. This is ignored if you have specified an existing event 
list filter file using the -ffile option. 

-ftext string The SQL statement to use for filtering events. This is ignored if you have specified an 
existing event list filter file using the -ffile option.

-help Displays help for this command and then exits.

-masterserver string In a desktop ObjectServer architecture, indicates the master ObjectServer to use.

The -masterserver command line option overrides the MasterServer field 
entry in the desktop ObjectServer master.national table.

For information about desktop ObjectServer architectures, see the Netcool/OMNIbus 
Installation and Deployment Guide.

-nlw Suppresses the of display license expiry warnings.

-password string The password for the selected user name. The nco_elct utility only accepts 
alphanumeric characters in the password. Special characters such as #, /, >, @, and ! 
are not permitted.

-server string Name of the ObjectServer to which you are connecting.

-username string User name to log in to the event list.

-version Displays version information and exits. 

-vfile string | URL Opens a transient event list using a specified event list view. Event list views have an 
.elv file extension.

Note: You can also retrieve remote .elv files using http and ftp protocols, as 
described for the -config command line option in Table B1 on page 102.

Table B3: nco_elct Command Line Options (2 of 2)

Command Line Option Description
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Windows Command Line Options

The command line options for the Windows NCOelct.exe utility are shown in Table B4.

Table B4: NCOelct.exe Command Line Options (1 of 2)

Command Line Option Description

-diagnostic Displays extended diagnostic messages. 

-dualwrite 1 | 0 In a desktop ObjectServer architecture, indicates whether to enable or disable 
dual-write mode. Valid options are:

• 0—Disable dual-write mode

• 1—Enable dual-write mode

The -dualwrite command line option overrides the DualWrite field entry in the 
desktop ObjectServer master.national table.

For information about desktop ObjectServer architectures, see the Netcool/OMNIbus 
Installation and Deployment Guide.

-elf string | URL Specifies the filter file to use for the transient event list. Event list filters have an .elf 
file extension.

This is a required option.

You can use the -params command line option to specify filter parameters in 
addition to those specified in the .elf file. See -params, in this table.

Note: You can also retrieve remote .elv files using http and ftp protocols, as 
described for the -config command line option in Table B1 on page 102.

-elv string | URL Specifies the event list view file to use for the transient event list. Event list views have 
an .elv file extension.

Note: You can also retrieve remote .elv files using http and ftp protocols, as 
described for the -config command line option in Table B1 on page 102.

-help Displays help for this command and then exits.

-masterserver string In a desktop ObjectServer architecture, indicates the master ObjectServer to use.

The -masterserver command line option overrides the MasterServer field 
entry in the desktop ObjectServer master.national table.

For information about desktop ObjectServer architectures, see the Netcool/OMNIbus 
Installation and Deployment Guide.
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Using nco_elct Example - Command Line or Script

The following examples show nco_elct commands for both UNIX and Windows platforms. These 
examples can be run directly from the command line or from a script.

 

Example nco_elct Command on UNIX

The following command creates a transient event list from the NCOMS ObjectServer using the 
default.elv view file. Only events from the node wombat will appear in the event list.

$OMNIHOME/bin/nco_elct -server NCOMS -username root -password "" -vfile 
"$OMNIHOME/desktop/default.elv" -ftext "( Node = \'wombat\' )"

 

Example nco_elct Command on Windows

The following command creates a transient event list from the NYC ObjectServer using the lview.elv 
view file and the filter file tool.elf.

%OMNIHOME%\desktop\NCOelct.exe -server NYC -username root -password "" -elv 
"%OMNIHOME%\ini\lview.elv" -elf "%OMNIHOME%\ini\tool.elf" -params "wombat"

-networktimeout 
integer 

Specifies a time in seconds after which a login attempt or connection to the 
ObjectServer will time out, should a network failure occur. After the specified timeout 
period, the event list attempts to reconnect to the ObjectServer. If the connection is 
unsuccessful after a second timeout period, the event list will attempt to connect to a 
backup ObjectServer, where available. The default is 20 seconds.

-params string Use to specify a string to replace a single placeholder in the filter_text 
parameter of the filter file. This placeholder must begin with the @ symbol (for 
example, @FilterText).

See Using nco_elct Example - Command Line or Script on page 109 and Using nco_elct 
Example - In a Tool on page 110.

-password string The password for the selected user name. The nco_elct utility only accepts 
alphanumeric characters in the password. Special characters such as #, /, >, @, and ! 
are not permitted.

-server string The ObjectServer to which you are connecting.

-username string The user name to connect as.

-version Displays version information and exits. 

Table B4: NCOelct.exe Command Line Options (2 of 2)

Command Line Option Description
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The tool.elf file referenced in the above nco_elct command is shown below:

filter_name = 'ToolFilter';
filter_text = '( Node = \'@NodeName\')';
filter_metric = 'avg(Severity)';
# End of file

When you run the command or script, the string wombat that follows -params option replaces the 
@NodeName placeholder in the tool.elf file, so that only events from the node wombat appear in the 
event list.

Using nco_elct Example - In a Tool

The following examples show how nco_elct is used in the Show Related FE Node and Show Related 
FE Node (Windows) tools, which are shipped with Netcool/OMNIbus. For information about creating 
tools, see the Netcool/OMNIbus Administration Guide.

 

Example nco_elct Command Used In the Show Related FE Node Tool

$OMNIHOME/bin/nco_elct -server "%server" -username "%username" -password "%password" 
-vfile "$OMNIHOME/desktop/default.elv" -ftext "( RemoteNodeAlias != '' and 
RemoteNodeAlias = '@LocalNodeAlias' ) or ( LocalNodeAlias != '' and  LocalNodeAlias = 
'@RemoteNodeAlias') or Node = '@RemoteNodeAlias' or RemoteNodeAlias = '@Node'"

 

Example nco_elct Command Used In the Show Related FE Node Tool (Windows)

"$(OMNIHOME)/desktop/NCOelct.exe" -server "%server" -username "%username" -password 
"%password" -vfile "$(OMNIHOME)/ini/default.elv" -elf "$(OMNIHOME)/ini/tool.elf" 
-params "( RemoteNodeAlias != \\'\\' and RemoteNodeAlias = \\'@LocalNodeAlias\\' ) or 
( LocalNodeAlias != \\'\\' and  LocalNodeAlias = \\'@RemoteNodeAlias\\') or Node = 
\\'@RemoteNodeAlias\\' or RemoteNodeAlias = \\'@Node\\'"

The tool.elf file referenced in the above nco_elct command is shown below:

filter_name = 'ToolFilter';
filter_text = '@FilterText';
filter_metric = 'avg(Severity)';
# End of file

The OMNIHOME environment variable for Windows is expressed differently in a tool than the normal usage 
(%OMNIHOME%). This is because the variable is interpreted and resolved by the built-in tools parser and not 
by the Windows operating system.
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When you run the tool from the event list, the entire string that follows -params option replaces the 
@FilterText placeholder in the tool.elf file. The @LocalNodeAlias, 
@RemoteNodeAlias, and @Node placeholders are replaced in the -params string by values from the 
currently selected event in the event list.
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B.3 SQL Commands and Variable Expressions in Tools, 
Automations, and Transient Event Lists
You can use the following SQL commands and variable expressions to retrieve information from a running 
event list, the current event, or the operating system environment. You can use these expressions when 
creating a tool, trigger, or SQL procedure, or in parameters passed to a transient event list.

Table B5: SQL Commands and Variable Expressions in Tools, Triggers, Procedures, and the Transient Event List (1 of 3)

Command/Variable Expression Button Usage

select_command

insert_command

update_command

delete_command

use_command

service_command

Click this button to select an SQL command from the pop-up menu. 
After selecting a command, the statement window is displayed. 
The available fields on the statement window change depending 
on the selected command, as described below:

Select—In the From area, select the database and table on which 
to execute the command. Then, choose the table columns to select.

Insert—In the From area, select the database and table on which 
to execute the command. Then, select the table columns in which 
to insert values. For each selected column, enter the value to insert. 
For insert statements, you must include the primary key. Primary 
keys are indicated with an asterisk (*).

Update—In the From area, select the database and table on which 
to execute the command. Then, select the table columns to update. 
For each selected column, enter the new value. For update 
statements, you must exclude the primary key. Primary keys are 
indicated with an asterisk (*).

Note: For inserts and updates to the alerts.status table, any 
existing conversions appear in the drop-down lists.

Delete—Select the table to delete.

Use—Select the database to use.

Service—Select a service name and a value. Values can be Good, 
Marginal, or Bad.

column_name

@column_name

Click this button to select a table column name. 

When prefaced with the @ symbol, the column name is substituted 
with the corresponding event list row value during execution. This 
can be used in an SQL query or restriction filter, such as:

RemoteNodeAlias = '@LocalNodeAlias'

conversion_name Click this button to select from a list of available conversions. For 
information about conversions, see the Netcool/OMNIbus
Administration Guide.
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N/A Click this button to check the validity of SQL syntax.

%internal_value Click this button to select from a list of internal values known to the 
current instance of the event list. 

For example, to run transient event list and specify the 
ObjectServer to connect to using the -server command line 
option, specify: 

-server "%server"

The following internal values are available:

%display—The current display running the application (UNIX 
only).

%password—The password of the user running the application.

%encrypted_password—The encrypted password of the user 
running the application (UNIX only).

%server—The name of the ObjectServer to which the tool is 
currently connected.

%desktopserver—The name of the desktop ObjectServer to 
which the tool is currently connected.

%uid—The ObjectServer user identifier of the user running the 
application.

%username—The ObjectServer user name of the user running the 
application.

You can use internal values in tools and as a parameter to the 
transient event list.

$prompt.prompt_name Click this button to select the name of the prompt to use when 
querying the user. 

For example, to run the transient event list and prompt the user to 
enter their password using the Password prompt, specify:

-password $prompt.Password 

You can use prompts in tools and as a parameter to the transient 
event list.

Table B5: SQL Commands and Variable Expressions in Tools, Triggers, Procedures, and the Transient Event List (2 of 3)

Command/Variable Expression Button Usage
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 Tip:  You can click the To Clipboard button to copy the command in a text format to the clipboard.

$selected_rows.column_name N/A List of values of column_name for all selected alerts. For example:

update alerts.status set TaskList = 0 where 
Serial in ($selected_rows.serial) 

Do not use this syntax if you select the Execute for each selected 
row check box. Instead, select the check box if the change is 
different for each alert. 

$(environment_variable) N/A Indicates an environment variable. For example, when you run a 
transient event list, you can specify the filter file using the -elf 
command line option, such as:

-elf "$(OMNIHOME)/ini/tool.elf

To run the tool on Windows, enclose the environment variable, 
such as $(OMNIHOME), in double quotes. If there is space in the 
path name, it will not be interpreted correctly.

Table B5: SQL Commands and Variable Expressions in Tools, Triggers, Procedures, and the Transient Event List (3 of 3)

Command/Variable Expression Button Usage
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B.4 Changing the Date Format in the Event List on UNIX
The date format in the event list is defined by the NCO_TIME environment variable. The default format is 
mm/dd/yy hh:mm:ss; for example, 11/12/03 20:13:36. This format is determined by the 
POSIX strptime function.

To set the default format, using csh, enter the following command:

setenv NCO_TIME %m/%d/%y %H:%M:%S

To set the default format, using ksh or sh, enter the following command:

NCO_TIME=%m/%d/%y %H:%M:%S;export NCO_TIME 

See the man page for strptime for details of the conversion specifiers that are available.

 Note:  Changing the date format in the event list does not affect the alert timestamp.
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Contact Information
Corporate

Region Address Telephone Fax World Wide Web

USA Micromuse Inc. (HQ)
139 Townsend Street
San Francisco
CA 94107
USA

1-800-Netcool (638 2665) 

+1 415 538 9090

+1 415 538 9091 http://www.micromuse.com

EUROPE Micromuse Ltd.
Disraeli House
90 Putney Bridge Road
London SW18 1DA
United Kingdom

+44 (0) 20 8875 9500 +44 (0) 20 8875 9995 http://www.micromuse.co.uk

ASIA-PACIFIC Micromuse Ltd.
Level 2
26 Colin Street
West Perth
Perth WA 6005
Australia

+61 (0) 8 9213 3400 +61 (0) 8 9486 1116 http://www.micromuse.com.au

Technical Support

Region Telephone Fax

USA 1-800-Netcool (800 638 2665) 

+1 415 538 9090 (San Francisco)

+1 415 538 9091

EUROPE +44 (0) 20 8877 0073 (London, UK) +44 (0) 20 8875 0991

ASIA-PACIFIC +61 (0) 8 9213 3470 (Perth, Australia) +61 (0) 8 9486 1116

E-mail World Wide Web

GLOBAL support@micromuse.com http://support.micromuse.com

License Generation Team

E-Mail World Wide Web

licensing@micromuse.com http://support.micromuse.com/helpdesk/licenses
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