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This chapter provides information on the use of CiscoView in the following sections:

• Understanding the CiscoView Main Window

• Understanding Configuration

• Starting CiscoView and Displaying a Device

• Changing CiscoView Operating Characteristics

• Finding Devices

• Using the Dashboard Monitor

• Using CiscoView Tables

• Using Online Help

Note For additional information on CiscoView, see the context-sensitive online help
system. This comprehensive online help system provides procedures, overview mat
and links to related information.
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Understanding the CiscoView Main Window
When you first open CiscoView, a small window appears as shown in Figure 4-1:

Figure 4-1 CiscoView Main Menu

Many of the menu items are grayed out because you have not opened a device. Onc
device is open, a larger window appears showing the front or rear panel of the device.
following figure shows the main CiscoView window displaying an AS5200 device. Th
elements of this window are shown in Figure 4-2:

Figure 4-2 CiscoView Displaying an AS5200 Device
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Title bar—provides the CiscoView application name and the name of the currently
connected device.

Menu bar—allows you to perform CiscoView tasks, including displaying configuration a
performance information for devices, cards, and ports; displaying different device
representations; and controlling some of the operating characteristics of CiscoView.

Tool bar—provides a shortcut for entering important CiscoView commands such as P
or Help, Configuration, Monitoring information and access to Telnet.

System information area—displays information about the type of device, the Cisco de
software that is running, and additional system information. For some devices, CPU
utilization is displayed.

Graphical device representation— displays a graphical representation of the back or
panel of the device. Click on this area to display information about different parts of t
device. For example, to display information regarding the configuration of an Ethernet
on an AS5200 device rear panel, double-click the port or do the following:

• Click and hold down the right mouse button to display the port popup window. Se
theSelect Port>Configure option.

• For more information on a particular device, press F1 with the mouse button positio
over the display for that device. All devices may not support the use of F1.

Status bar—provides a brief description of the currently selected device, interface, or
and provides an ongoing operational status, including polling and error message
information. For port status details, refer to Table 4-1.

Device status legend—Provides port status as follows:

Table 4-1 CiscoView Port Status Legend

Color Indicates

Cyan or greenish blue dormant or waiting for an external event, such as having
packets to transmit or dialing a remote site

Brown administratively down

Red operational failure

Yellow minor alarm
 Using CiscoView 4-3
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Popup menus—go to the configuration and monitor information for the device, a card,
port. For more information on popup menus, see “Displaying a Device,” later in this
chapter.

Menus may vary depending on the device you are using. If an option is grayed out, it is
applicable to that device. Table 4-2 and Table 4-3 describe menu items found in the
CiscoView File menu and the View menu.

Table 4-2 CiscoView File Menu Items

Table 4-3 CiscoView View Menu Items

Magenta testing

Green up

Item Explanation

Open Device Displays the back panel of a new device.

Open Previous Reviews a list of devices that you have already displayed without
specifying the IP address or other information.

Print Prints the physical view of the device.

Print Setup Displays and allows you to change printer parameters.

Exit Exits CiscoView.

Item Explanation

Refresh Refreshes the current display by checking that all information is
current.

50% Toggles the size of the device display between 50 and 100 percen

Stack Displays the devices in sequence of their physical order. It is graye
out if the device does not support the stack feature.

Front View Displays the front panel of a device on selected devices only.

Color Indicates
4-4 CiscoWorks Windows Getting Started Guide
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The Configure menu varies depending on the device you are using and what you ha
selected on the device to configure: the device itself, a card or a port. For more informa
on displaying a device, see “Displaying a Device” later in this chapter. Table 4-4 descr
the Configure menu items.

Table 4-4 CiscoView Configure Menu Items

Rear Displays the real panel of the device.

Logical Displays the logical modem connections on an AS5200 only.

Item Explanation

Device Displays device configuration information. If nothing is selected,
the device configuration is displayed.

Card Displays card configuration information for a selected card. To
view the card information, select a specific card first, then click on
Configure>Card.

Port Displays port configuration information for a selected port. To view
the port information, select a specific port first, then click on
Configure>Port. The types of ports that can be selected are modem
port, port_tty, or port_con depending on the type of device you are
using.

Item Explanation
 Using CiscoView 4-5
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The Monitor menu varies depending on the device you are using and what you have
selected on the device to monitor: the device itself, a card or a port. For more informa
on displaying a device, see “Displaying a Device” later in this chapter. Table 4-5 descr
the Monitor menu items.

Table 4-5 CiscoView Monitor Menu Items

The Options menu allows you to change the presentation and the operating characte
of CiscoView. For example, if you wanted to display the Toolbar or change the pollin
frequency, you do it through the Options menu. Table 4-6 describes the Options men
items.

Table 4-6 CiscoView Options Menu Items

Item Explanation

Device Displays the monitoring information for a selected device. The
monitoring information describes the various performance aspects
of a device, card or port. The monitor window is a collection of
graphical displays presented as dials or stripcharts, known as a
dashboard. For more information on monitoring information, see
“Using the Dashboard Monitor.”

Card Displays the monitoring information for a selected card.

Port Displays the monitoring information for a selected port.

Item Explanation

Show Toolbar Display or hide the Toolbar to access shortcut commands.

Show Legend Display or hide the legend.

Show System Information Display or hide system information.

Properties Set various operating characteristics, including polling frequency,
the number of retries, the timeout interval, the Read and Write
community string, MIB labels displayed as descriptors or an alias,
and where to launch CiscoView either in the same window or a
separate one.
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The Admin menu appears on specific devices that have administrative option feature
Refer to online help for more information.

Understanding Configuration
Configuration is a process that establishes the characteristics of the devices and servi
the network and records this information in the appropriate files. Configuring a device
management means supplying information about the specific device. Once the spec
aspects of the device are entered into the system, the system can then identify the d
and monitor its performance and you can manage the device using CiscoView.

You configure devices through CiscoView. See the online help for details on how to
configure specific devices.

Starting CiscoView and Displaying a Device
There are several ways to display a CiscoView device including:

• Using CiscoWorks

• Using other network management platforms

• Using the Command line

The CiscoView Open Device window allows you to display a device in CiscoView or 
change the currently displayed device. To display information, you need to know the R
Community Name and the Write Community Name. The community string is a Simp

Debug Displays troubleshooting information and should be used only with
Cisco support personnel. Writes the trace for device discovery and
status polling to the/tmp/.cvlog.

Debug SNMP Displays all the SNMP traffic in encoded form to and from the
device and should be used only with Cisco support personnel.

Item Explanation
 Using CiscoView 4-7
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Network Management Protocol (SNMP) security feature that requires a password to ac
SNMP features on a host, such as a Cisco router. Community strings can be set to read
or read-write permission. To display the device, do the following:

Step 1 Enter the name or IP address of the device in the Host field that you want to v

Step 2 Enter the Read Community string in the Read Community field.

Step 3 Enter the Write Community string in the Write Community field.

Step 4 Click OK .

CiscoView displays a front or rear panel of the device. To display informati
change configurations, and change community string information at the
management window, you need to enter the Read/Write All password in th
Read Community and Write Community name fields in this window. If you op
the device without a Write Community string, and need to change device
information, you can use theOption>Properties window to reset the
community string information.

Understanding the Display
The display you see when you first enter CiscoView is of the front or rear panel of th
device. Click on various parts of this graphic to see what it contains. For example, th
AS5200 rear panel is shown in the figure below, and there are numbered callouts. If 
click on these numbers, you select different things.

Once you have made a selection on the panel, select Configure or Monitor to configu
monitor the device, card, or port.

You can also use the right mouse button to get to a popup menu that allows you to confi
or monitor a device, card, or port. For example, if you are using an AS5200 card and n
port information, select a port on the display and click the right mouse button. The
following popup menu appears:

Select one of the options,Configure, Monitor , orReset.

Port
Configure...
Monitor...
Reset
4-8 CiscoWorks Windows Getting Started Guide
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Printing a Display
You can print the CiscoView Main window and specify certain printing options. To pri
the main window, selectFile>Print .

To print the main window, and specify printing options, do the following:

Step 1 SelectFile>Print Setup.

The CiscoView Print Setup window is displayed.

Step 2 In the Printer Name field, select a printer from the scrolling list, or enter the
name of a printer.

Step 3 In the Copies field, enter the number of copies you want to print.

Step 4 In the Orientation field, select the paper orientation for printing by clicking o
the radio button next to the appropriate orientation format: portrait or landsca

Step 5 In the Format field, select your printer format type by clicking on the radio
button next to the appropriate option: Ljet or PostScript. Ljet or LaserJet pri
the CiscoView Main window in PCL. PostScript prints the window is PostScrip
For most low-end printers, use the Ljet option.

Step 6 Click OK  to close this window

Step 7 Click File>Print to print the window display.

Changing CiscoView Operating Characteristics
You can change some CiscoView operating characteristics, such as the polling frequ
or the number of retries, from within the CiscoView application. To change the opera
characteristics, do the following:

Step 1 SelectOptions>Properties.

The CiscoView Properties window appears.

Step 2 Enter a value in the Polling Frequency field to change the polling frequency. T
default value varies by device. A typical value is every 60 seconds. To disa
polling frequency, set the value to zero. If you set the polling frequency bel
 Using CiscoView 4-9
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60 seconds for a number of devices, it may slow down your network. It is
advisable to use low polling frequencies in specific testing situations and cha
them back when done. Do not poll faster than every 5 seconds.

Step 3 Enter a new value in the Retries field to change the number of retries. The de
value is 3. The retries value indicates how many times CiscoView retries a
unresponsive device. In busy networks, SNMP datagrams can get discarded
Retries value allows the application to continue operation during network
problems. A setting of 3 is considered a reasonable value. The value can b
increased if the network is slow.

Step 4 Enter a new value in the Timeout field to change the timeout interval. A timeo
indicates the amount of time it takes to reach a device. If it takes longer than
time specified, the device is considered either unreachable or down. The inte
value is specified in seconds. The default is 3.

As a guideline, the timeout value should be set to twice the average end-to-
delay in your network. If you have a network with several slow links, you m
need to set the timeout to a higher value. If you have only LAN links in you
network, a value of 2 seconds is reasonable to account for processing delay
timer accuracy.

In high traffic situations, you may experience timeouts. You should not red
the polling frequency since this may cause a general error. Increase the tim
interval if you consistently experience timeouts.

Step 5 Click the radio button next to MIB Label translation field to display MIB
descriptors instead of displaying textual labels,. Textual labels are the defa
MIB descriptors are actual variable names used to manage devices, for exa
locIfOutBitsSec and MIB textual labels are user-friendly aliases of the MIB
descriptor. For example the MIB textual label for locIfOutBitsSec is Output
BPS.

Step 6 Enter the string in the appropriate field to enter the Read or Write Commun
string. This option allows you to enter the write community string for a devi
after you display the device.

This is useful, for example, if you want to make changes to a device or por
setting but did not specify the write community string when you first opened t
device display. You can enter the write community string in the Write
Community field without exiting and reopening the window.
4-10 CiscoWorks Windows Getting Started Guide
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Step 7 Select the window where you want to launch CiscoView, from the same wind
or from a separate window. The default is Separate.

Note Multiple instances of CiscoView may slow down your machine because higher
RAM requirements are needed for this usage.

This option allows the user to keep the desktop from being cluttered by reus
the existing CiscoView window to display devices.

Step 8 Click OK  to have the changes you have made on the Properties window ta
effect.

Finding Devices
Sometimes finding a device on a large network can pose a problem but you can find de
in CiscoView easily once you understand how the information is organized. Topics cov
are:

• Organization of Management Information

• Categories of Information

Organizing Management Information
CiscoView displays two primary types of information. Configuration information includ
data such as information about a device chassis. Performance information includes 
such as the number of Ethernet errors during a given period.

Configuration information is displayed in CiscoView Configuration windows. Performan
information is displayed in CiscoView Monitor windows, which are sometimes referred
as dashboards.

Configuration and performance information is displayed for devices, cards, and ports
 Using CiscoView 4-11
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Categorizing Information
CiscoView displays different categories of information for each device, card, and port
see the categories of information that can be displayed for each component type, look
CATEGORY popup menu on the Configuration or Monitor windows. To display a
particular type of information, select the category type.

Displaying Configuration Information
CiscoView displays configuration information through the Configuration menu on the
CiscoView main window, or by selecting Configure from a component popup menu.
CiscoView displays configuration information in the Configuration windows that inclu
either a list of fields for a single port or a table that includes fields for multiple ports.

Displaying Performance Information
CiscoView displays performance information using the Monitor menu on the main wind
or by selecting Monitor from a component popup menu. Performance information is
displayed in a dashboard made up of a collection of small graphical displays in one win
For more information on the dashboard monitor, seeUsing the Dashboard Monitor, later in
this chapter.

Using the Dashboard Monitor
The dashboard monitor displays various types of network performance information, 
as poll utilization errors. The display varies, depending on the type of type of device 
whether or not is a device or a port, but the display consists of dials or stripcharts as sh
in Figure 4-3.
4-12 CiscoWorks Windows Getting Started Guide
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Figure 4-3 Dashboard Monitor

Each display represents information provided by a MIB variable, with the common
meaning indicated above the display.

Using the Grapher Tool
Within the dashboard monitor, there is a grapher tool that you can use to depict perform
in graph form. To start the graphing tool for the network management platform, you se
a graphical display in the dashboard and click on the Grapher button. You can use all o
features of the graphing tool when you are troubleshooting performance problems. T
network management platform graphing tool cannot support the graphing of multiple M
variables in one data set. If the graphical display selected is composed of such formula
following error message appears:

Sorry, can’t graph formulas.
 Using CiscoView 4-13
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Using CiscoView Tables
For some devices, CiscoView allows you to select multiple ports. You can display
configuration or performance information for multiple ports or port groups in one windo
The entries that can be modified are displayed in pink. Figure 4-4 shows the table for t
of the ports for an AS5200 card.

Figure 4-4 CiscoView Tables

To get a CiscoView table:

Step 1 Select multiple ports by clicking on them as you hold down the Shift key.

Step 2 Click onConfigure or Monitor .

A CiscoView Table with all the ports you selected listed in the first column
appears and the information for all of them displayed in tabular format.

You can add, delete, or modify entries from the table. Table 4-7 describes how to make
to CiscoView Tables.
4-14 CiscoWorks Windows Getting Started Guide
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Table 4-7 Edits to CiscoView Tables

Using Online Help
Context-sensitive online help provides you with step-by-step instructions on how to u
CiscoWorks Windows applications. The online help system also provides a glossary
keyword search capability. The following table provides a quick guideline to access h
from a number of vantage points:

Changes to a Table Action

Add an entry Select Create.

Modify an entry 1. Select the table column entry that you want to modify.

2. View the possible values, if available, by displaying the popup
menu next to the entry.

3. Select or enter the new value in the table column.

4. SelectModify .

5. SelectOK .

Remove an entry 1. Select any column in the table row that you want to delete.

2. SelectDelete.

3. SelectOK .

For Information About Do This

The help system for specific products SelectHelp>Contents

How to use the help system SelectHelp>Using Help

How to use CiscoView features SelectHelp>Using CiscoView

Current CiscoView versions SelectHelp>About CiscoView

The current device package version SelectHelp>About CiscoView

How to view configuration and
performance, dashboard windows and
field descriptions

Click the Help button in the dialog
window

How to change a component value Press the Help button over the field

How to use help view SelectHelp>On Help
 Using CiscoView 4-15
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Note Report any online help or documentation bugs tocs-ciscoworks@cisco.com or
bug-doc@cisco.com .

Jumps and Popups
Two key concepts in using the help system are jumps and popups. Click on a highlig
underlined topic to jump to a help window specific to that topic. When you jump to anot
topic, you have to click Back on the Menu Bar to go back to the previous help topic. C
on a dotted underlined term to open a popup help window, which provides a definitio
that term. When you go to a popup, hit return to return to your previous help topic.

Help Contents Tab
The Help Contents Tab has three functional tabs:

• Contents tab—links CiscoView device, application and help topics and subtopics.

• Index tab—searches keywords in the help system.

• Find tab—searches the help system and indexes every help word.

For information on how to use this table selectHelp>On Help.

Help Window Menu and Button Bars
Each help window has a menu bar and a button bar. The menu bar provides standar
functions for printing help topics, copying and pasting text from help topics, making onl
notes about particular help topics, and placing bookmarks.

The button bar provides the following buttons:

• Contents—Opens the current help table of contents. Help topics are highlighted a
underlined. Select a help topic to open a help window specific to the underlined to
Some topics open popup windows that contain a list of subtopics. Select a help sub
to open a help window specific to the underlined subtopic.

• Back—Moves you back sequentially to previously opened help windows.
4-16 CiscoWorks Windows Getting Started Guide
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• Print—Prints current help topic window.

• Browse—Allows you to browse through sets of related help screens, providing qu
access to overviews of particular help topics.

OverView and See Also Links
Many help windows have Overview and See Also links in the help window topics. You c
select the Overview link to obtain background information for the procedure describe
the current help window. Select the See Also link to view a list of related topics and g
directly to those topics from the current help window.

Exit Help
SelectFile>Exit  on the Menu Bar in the Help window to exit Help.
 Using CiscoView 4-17
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