
g

or

hat
e

rk

es.
r

let
CiscoView 4.2(1) Installation Instructions
for AIX

This instruction book provides information about installing and runnin
CiscoView on your network management station. You can install
CiscoView on an AIX workstation, either as a standalone application
on top of the network management platform NetView for AIX. You
should be familiar with Motif window management system and
(optionally) NetView for AIX.

CiscoView is a GUI-based device management software application t
enables you to access dynamic status, statistics, and comprehensiv
configuration information for Cisco internetworking products.

CiscoView lets you display a graphical representation of each netwo
device, display configuration and performance information, perform
minor troubleshooting tasks, and control and configure specific devic
There are also device-specific applications that further enhance you
network management capabilities.

Table 1 explains where to find the procedures described in this book
and when you should perform them.
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Table 1 Upgrading CiscoView on AIX

Installing or upgrading CiscoView installs only the CiscoView engine
You also need to configure CiscoView and install device packages bef
it is ready to use. This booklet includes procedures for installing and
configuring CiscoView. It also includes limited information about
ongoing tasks that you might perform with CiscoView, including

If you have this product
installed You need to

CiscoView 3.x, 4.0, 4.11

1 If you are upgrading CiscoView 4.0 or 4.1 to CiscoView 4.2(1) and/usr/nms
or /usr/nms/CVapp is a symbolic link, the link is removed by SMIT (an
installation utility). To prevent the removal of the symbolic link, remove the
link and mount the directory to/usr/nms/CVapp to perform the upgrade.
You can also remove the previous version of CiscoView and do a fresh
installation of the latest version of CiscoView. Refer to the CiscoView
4.2(1) Release Notes for more information.

Upgrade to CiscoView 4.2(1)

CiscoWorks 3.2 or later Upgrade to or install
CiscoView 4.2(1)

CiscoWorks for Switched
Internetworks (CWSI) 1.1.1

Upgrade to CWSI 1.3 and then
upgrade to CiscoView 4.2(1)

CWSI 1.3 Upgrade to CiscoView 4.2(1)
4



incrementally installing device packages, using and maintaining the
software, and getting product support.

System Requirements

Before you install CiscoView, make sure your workstation meets the
requirements shown in Table 2 and the hardware and software
recommendations shown in Table 3.

Table 2 CiscoView Typical System Requirements

Operating System Available Disk Space RAM

AIX 4.1.5, 4.2, and 4.31

1 See the “Verifying AIX Version” section for details about verifying the operating
system level.

1 MB in the/ directory,
5 MB in /tmp directory, and
100 MB in the/usr directory2

2 See the “Verifying Hard Disk Space” section for instructions on determining the
amount of disk space available on your workstation.

32 MB3

3 See the “Verifying RAM Size” section for details on determining the amount of
available RAM on your workstation.
5
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Table 3 CiscoView Hardware and Software Recommendations

Hardware Software

Any IBM RISC
System/6000 workstation
with Power architecture

Color monitor

PostScript-compatible
printer (for printing
window images)

CD-ROM drive on the
host workstation, or
CD-ROM drive on an
accessible remote host

X Window System Version 11, Release 5; Motif Version 1,
Release 2.

Netview for AIX 4.1 or 5.0 (optional)1

Cisco IOS—Managed Cisco devices must be running
specific versions of the Cisco IOS software. See the
CiscoView 4.2(1) Release Note.

1 CiscoView can operate without NetView for AIX as described under “Starting
CiscoView from the Command Line,” so NetView for AIX is optional. Without
NetView for AIX, however, you cannot graph information. (See the “Verifying Syste
Software” section for instructions.)
6
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Verifying AIX Version

To verify that you are running a supported version of AIX, perform th
following steps:

1 Log in asroot by enteringsuand theroot password at the prompt, or
log in asroot. The prompt changes to the pound sign (#).

2 Enter the following command:

# oslevel

Output similar to the following appears:

4.2.0.0

This output shows that AIX Version 4, Release 2 is installed.

Verifying System Software

If you use CiscoView with NetView for AIX, you need to verify that you
are running a supported version of NetView.

To determine which version of NetView is installed, log in asroot and
enter the following command:

# lslpp -l nv6000.base.obj
7
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Output similar to the following appears:

Fileset Level State Description
-------------------------------------------------

Path: /usr/lib/objrepos 4.2.2.0 COMMITTED NetView
for AIX Server-Base

This output shows that NetView 4.2 is installed and committed on th
AIX workstation.

Verifying RAM Size

CiscoView requires a minimum of 32 MB of RAM. To verify that you
have enough RAM available on your workstation, log in asroot and enter
the following command at the AIX prompt:

# lscfg | grep mem

Output similar to the following appears:

+ mem0        00-0B        32 MB Memory Card
+ mem1        00-0C        32 MB Memory Card

If your workstation does not have at least 32 MB of RAM, upgrade it
memory.
8
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Verifying Hard Disk Space

CiscoView requires 1 MB of disk space in the root directory, 100 MB o
disk space in the/usr directory, and 5 MB of disk space in the/tmp
directory.

To verify that you have enough disk space on your workstation, enter
following command at the prompt:

% df -Ik

Output similar to the following appears:

Filesystem Total KB used free %used Mounted
on
/dev/hd4         16384   10008    6376   61% /
/dev/hd2       1003520  871324  132196   86% /usr
/dev/hd3         16384     732   15652    4% /tmp

The amount of disk space available in each filesystem appears in the
column.

Note . If you do not have sufficient space in the filesystem mounted
the/usrdirectory (1,000 KB is approximately 1 MB), you must create
filesystem mounted on the/usr/nms/CVapp directory.
9
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Caution CiscoView can be installed only in the/usr/nms/CVapp
directory. If you create a filesystem, its mount point must be either
/usr/nmsor usr/nms/CVapp. If /usr/nms/CVapp already exists on your
workstation,back up all data in that directory before installing
CiscoView. Installation of CiscoView overwrites existing data.

To create a filesystem, we recommend that you contact a knowledgea
system administrator and use the System Management Interface
Tool (SMIT).

Mounting the CD-ROM

This section describes how to mount the CiscoView CD-ROM on the
local filesystem from a local or remote CD-ROM drive.

You can install CiscoView from a CD-ROM drive attached to your
workstation or from a drive connected to a remote host. You must fir
use SMIT to mount the local or remote device on the local AIX
workstation.

Note SMIT and this booklet refer to the software product as
CiscoView 4.2(1).
10
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Mounting from a Local CD-ROM Drive

To mount the CD-ROM on the filesystem from a local CD-ROM drive
use SMIT to perform the following steps on the local host:

1 Place the CD-ROM into its caddy and insert it into the CD-ROM
drive.

2 Log in asroot.

3 Start SMIT by entering the following command:

# smit

4 From the SMIT System Management menu, selectSystem Storage
Management (Physical & Logical Storage).

5 SelectFile Systems.

6 SelectAdd/Change/Show Delete File Systems.

7 SelectCDROM File Systems.

8 SelectAdd a CDROM File System.

9 Click the “DEVICE name”List  button, and select the device name
(such as/dev/cd0) from the list that appears.
11
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10 Enter the name of a mount point directory (such as/cdrom) in the
Mount point field.

11 Click OK  and read the output.

If you have already performed this procedure, or if another device
already mounted on the mount point, the process fails.

12 Click Done.

13 Terminate SMIT by pressingF12or clickingExit SMIT on the Exit
menu.

14 Enter the following at the command prompt:

# smit mountfs

15 Click the FILE SYSTEM nameList button, and select a device name
(such as/dev/cd0) from the list that appears.

16 In the DIRECTORY over which to mount field, enter the name of 
mount point directory (for example,/cdrom).

17 Click the TYPE of file systemList  button, and selectcdrfs as the
filesystem type.

18 Set the Mount as Read-Only System field toyes.
12
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19 Click OK , read the output, and then clickDone.

20 Click Cancel to exit SMIT.

The CD-ROM is ready to be installed. Continue with the “Installing
CiscoView” section.

Mounting from a Remote CD-ROM Drive

To mount the CD-ROM on the local filesystem from a remote CD-ROM
drive, first perform the following steps on theremote workstation:

1 Perform all steps exactly as described in “Mounting from a Local
CD-ROM Drive” on theremote workstation.

2 Enter the following command:

# smit mknfsexp

3 Enter the PATHNAME of directory to export (such as/cdrom).

4 Use the arrow keys to change the Mode to Export Directory field 
read-only.

5 Enter the appropriate information, if necessary, into the other field

6 Click OK , read the output, and then clickDone.
13



7 Click Cancel to exit SMIT.

After working on theremoteworkstation, perform the following steps on
the local workstation:

1 Log in asroot.

2 Enter the following command:

# mount  \
remote_hostname:remote_exported_filesystem_name \
local_mount_point

For example, to mount the/cdrom remote filesystem from the
workstation zen to the local/cdrom directory, enter

# mount zen:/cdrom /cdrom

The CD-ROM is ready to install the software.
14
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Installing CiscoView

To install CiscoView from a mounted CD-ROM drive, perform the
following steps.

Note If you have CiscoWorks 3.03 for AIX or CiscoWorks 4.0 installed
on your system, during CiscoView configuration you will be asked if yo
want CiscoView to be controlled by CiscoWorks. This is an applicati
that provides security for managed devices. For additional informatio
on the application, refer toCiscoWorks User Guide.

Caution CiscoView can be installed only in the/usr/nms/CVapp
directory. If/usr/nms/CVapp already exists,back up all data in the
directory because the installation process overwrites existing files.

1 Log in asroot.

2 Mount the CD-ROM as described in the previous section.
15
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3 Set the I_CDROM_PATH environment variable to the path where t
CD-ROM is mounted. For example, if you are using Bourne shell
Korn shell, enter

# I_CDROM_PATH=/cdrom; export I_CDROM_PATH

Or, if you are using C shell, enter

# setenv I_CDROM_PATH /cdrom

4 Start SMIT by entering the following command:

# smit

5 From the System Management menu, selectSoftware Installation
and Maintenance.

6 Click Install and Update Software.

7 If you have AIX 4.1.5, selectInstall and Update Selectable
Software (Custom Install), then selectInstall Software Products at
Latest Level, then selectInstall New Products at Latest Level. The
Install New Products at Latest Level dialog box appears.

If you have AIX 4.2, selectInstall and Update from LATEST
Available Software. The Install and Update from Latest Available
Software dialog box appears.
16
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If you have AIX 4.3, selectInstall and Update from LATEST
Available Software. The Install and Update from Latest Available
Software dialog box is displayed.

8 In the dialog box, enter the name of the directory where the CD-RO
is mounted (for example,/cdrom), or clickList  to see the local
devices.

9 Click OK .

The Install Software Products at Latest Available Level dialog box
displays additional fields.

10 Click List next to the SOFTWARE to install field. After a brief delay,
the Multi-Select List dialog box appears.

11 In the Multi-Select List dialog box, click the CiscoView module
namedCiscoView.base.obj.

12 Click OK .

13 In response to the ARE YOU SURE? prompt, clickOK to install the
module you just highlighted.

While the animated man is running, SMIT installs CiscoView in th
/usr/nms/CVappdirectory, and CiscoView modifies SMIT to allow
subsequent configuration and uninstallation of CiscoView.
17
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If the animated man raises his hands and SMIT displays OK, the
installation has succeeded. If the man falls down, installation has
failed. If the reason for failure is not apparent, read the installation l
file $HOME/smit.log, then contact the Cisco Technical Assistance
Center (TAC), if necessary.

14 Click Done, thenCancel.

15 If the installation in Step 13 was successful, selectReturn To>
System Managementand go to the section “Configuring
CiscoView.”

If the installation failed, terminate SMIT by pressingF12or selecting
Exit>Exit SMIT .

Configuring CiscoView

After installing CiscoView, follow these steps to configure the produc

1 Start SMIT if you have not already done so by entering the followin
command:

# smit
18
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2 On the initial SMIT menu, clickCommunications Applications and
Services.

3 Click Cisco Network Management Applications for AIX.

4 Click CiscoView.

5 From the CiscoView dialog box, selectProduct Configuration.

6 From the Product Configuration dialog box, accept the defaults, o
enter values into each of the following fields.

Product Group Name—Name of the AIX group that owns the
CiscoView files. The default is bin. Click List  to select one or more
names from a list.

Product User Name—AIX username of the individual assigned to t
CiscoView files. The default is bin.

Integrate with Netview—The default isNo. If you want to integrate
CiscoView with NetView, clickList to select Yes.

Load MIBs Into NetView—The default isNo. If you want to monitor
MIBs through NetView, clickList  to selectYes. This option applies
only when CiscoView is integrated with NetView.
19
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Loading MIBs takes a significant amount of time, depending on th
number of MIBs being loaded.

Control CiscoView through CiscoWorks—The default isNo. If you
want CiscoView to be controlled by CiscoWorks, clickList to select
Yes. This option applies only when CiscoWorks is installed in you
system.

7 Click OK , wait for the process to complete, and read the output.

If the animated man raises his hands and SMIT displays OK, the
process has succeeded. If the man falls down, the configuration 
failed. If the configuration fails, contact the TAC.

8 Click Done, then clickCancel.

9 Terminate SMIT by pressingF12 or selectingExit>Exit SMIT .

Now you need to install the device packages using the procedures in
sections “Installing Device Packages Incrementally” and “Performing
CiscoView Maintenance Functions.” If you are installing packages fro
CD-ROM, unmount the CD-ROM after you have installed the necessa
device packages.
20
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Incremental Device Package Installation

To install device packages incrementally, you can use either of the
following methods:

• Install device packages from the CiscoView CD-ROM, as explain
in the “Installing CiscoView” section.

or

• Install device packages from Cisco Connection Online (CCO). Re
to the section “Downloading Device Packages” for a quick referen
to downloading device packages from CCO.

Setting Up Incremental Device Package Installation

To install device packages incrementally, you first need to set up the
incremental installation by following these steps:

1 Start SMIT if you have not already done so by entering the followin
command:

# smit

2 On the initial SMIT menu, clickCommunications Applications and
Services.
21
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3 Click Cisco Network Management Applications for AIX.

4 Click CiscoView.

5 On the CiscoView menu, clickDevice Package Install Setup.

6 In the Directory Containing Device Packages field, enter the path
where the device packages reside.

7 In the Load MIBs into NetView field, the default isNo. If you want to
load MIBs, clickList .

8 If you checkedList in Step 8, clickYesin the Single Select List dialog
box to load MIBs into NetView.

Note Loading MIBs can take a significant amount of time depending o
the number of MIBs being loaded.

9 Click OK , wait for the process to complete, and read the output.

If the animated man raises his hands and SMIT displays OK, the
process has succeeded. If the man falls down, incremental installa
of the device packages has failed. If the incremental installation fa
contact a TAC representative.
22
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10 Click Done, then clickCancel.

This procedure registers the directory containing the device package
and the options to load MIBs into NetView.

Installing Device Packages Incrementally

To install device package files from a directory on a workstation, follo
these steps:

1 Start SMIT if you have not already done so by entering the followin
command:

# smit

2 On the initial SMIT menu, clickCommunications Applications and
Services.

3 Click Cisco Network Management Applications for AIX.

4 Click CiscoView.

5 In the CiscoView dialog box, clickDevice Package Installation.

6 In the Select Device Packages to Install field, clickList .
23
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7 In the Multi-Select List dialog box, select the device packages yo
want to install, then clickOK . Wait for the process to complete, and
read the output.

If the animated man raises his hands and SMIT displays OK, the
process has succeeded. If the man falls down, the device packag
installation has failed. If the installation fails, contact the TAC.

8 Click Done, thenCancel.

Device Package Deinstallation

To deinstall device packages from CiscoView on AIX, perform the
following steps:

1 If you have not already done so, start SMIT by entering the followin
command:

# smit

2 On the initial SMIT menu, clickCommunications Applications and
Services.

3 Click Network Management Applications for AIX.

4 Click CiscoView.
24
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5 In the CiscoView dialog box, clickDevice Package Deinstallation.

6 Click List  next to the Select Device Packages to Deinstall field. T
Multi-Select List dialog box appears.

7 In the dialog box, click the package you want to deinstall.

8 Click OK .

While the animated man is running, SMIT deinstalls the device
package you selected. If the man falls down, the deinstallation faile
If the device package deinstallation fails, contact the Cisco Techni
Assistance Center (TAC).

9 Click Done, thenCancel.

10 Terminate SMIT by pressingF12 or by selectingExit SMIT  on the
Exit menu.
25
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Unmounting the CD-ROM Drive

To unmount the CD-ROM drive, log in asroot and perform the following
steps:

1 At the local or remote workstation where the CD-ROM is mounte
enter the following command:

# cd /
# umount /cdrom

AIX unmounts the CD-ROM device from the /cdrom directory.

2 Remove the CD-ROM caddy from the drive.
26
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Performing CiscoView Maintenance
Functions

You can perform the following routine maintenance functions:

• Loading MIBs into NetView

• Rebuilding All CiscoView Files

• Uninstalling CiscoView

Loading MIBs into NetView

If you experience any corruption of your MIB database or the MIBs a
not usable, you might want to consider reloading MIBs into NetView
The amount of time it takes to load MIBs into NetView depends on t
number of MIBs being loaded.

To load MIBs into NetView, perform the following steps:

1 Start SMIT by performing steps 1 through 4 in the “Configuring
CiscoView” section.

2 In the CiscoView dialog box, clickMaintenance.

3 In the Maintenance dialog box, clickLoad all MIBs into NetView.
27
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4 In response to the confirmation dialog box, clickOK .

While the animated man is running, the MIB files are being loaded.
the man raises his hands and SMIT displays OK, the MIB files ar
loaded. If the man falls down, loading of the MIB files has failed. 
loading fails, contact the TAC.

5 Terminate SMIT by pressingF12 or by clickingExit SMIT  on the
Exit menu.

Rebuilding All CiscoView Files

You can rebuild all CiscoView on AIX configuration files if

• You are not sure which device packages or files reside on your
workstation.

• You want to troubleshoot and rebuild existing CiscoView files
because of suspected corruption or deletion of CiscoView
configuration files.

To rebuild all CiscoView files, perform the following steps:

1 Start SMIT by performing steps 1 through 4 in the “Configuring
CiscoView” section.

2 In the CiscoView dialog box, clickMaintenance.
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3 In the Maintenance dialog box, clickRebuild all CiscoView config
files.

4 In response to the confirmation dialog box, clickOK .

While the animated man is running, the CiscoView device packag
files are rebuilt. If the man raises his hands and SMIT displays O
the rebuilding of configuration files has succeeded. If the man fal
down, rebuilding has failed, and you should contact the TAC.

5 Terminate SMIT by pressingF12or clickingExit SMIT on the Exit
menu.

Uninstalling CiscoView

To uninstall CiscoView, perform these steps:

1 Log in asroot.

2 Start SMIT by entering the following command:

# smit

3 On the System Management menu, selectCommunications
Applications and Services.

4 SelectCisco Network-Management Applications for AIX.
29
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5 SelectCiscoView.

6 SelectMaintenance.

7 SelectRemove CiscoView for AIX program.

8 In response to the ARE YOU SURE? prompt, clickOK .

While the animated man is running, SMIT uninstalls the CiscoVie
product. If the man raises his hands and SMIT displays OK, the
uninstallation process has succeeded. If the man falls down,
uninstallation has failed, and you should contact the TAC.

9 Terminate SMIT by pressingF12 or selectingExit>Exit SMIT .

Getting Started with CiscoView

This section contains information on CVSecurity and the two startup
methods for the first-time CiscoView user.

For details on CiscoView features, refer to the online help.
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CiscoView Security

If you have CiscoWorks 3.03 or 4.0 on your system and you answer
yes to installing the CVSecurity application, you will be prompted for
login when you start up CiscoView. Enter your CiscoWorks usernam
and password, and then select a domain.

There are three levels of security:

• A user cannot launch CiscoView.

• A user is restricted to viewing the configuration or monitoring
devices.

• A user can view the configuration, monitor devices, and configure
devices.

The restrictions can be changed using the nmadmin utility in
CiscoWorks. For information on the utility, refer toCiscoWorks Users
Guide.

To see whether a device is managed by CiscoWorks and what the leve
accessibility is, selectSecurity>Show Device Security.
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Starting CiscoView from the Command Line

To start CiscoView from the AIX command line and monitor a Cisco
device, follow these steps:

1 For C shell, enter the following command:

$ source /usr/nms/CVapp/etc/CVinstall.cshrc

For Bourne shell or Korn shell, enter the following command:

% . /usr/nms/CVapp/etc/CVinstall.kshrc

2 Start CiscoView by entering the following at the command line:

% nmcview

To view the usage of thenmcview command, enter

% nmcview -help

3 Specify a Cisco device to monitor.

SelectFile>Open Device and enter a host name or IP address in th
Host field, then clickOK . The default password for the Read and
Write community strings ispublic.

A graphical image of the device’s back panel appears.
32
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Starting CiscoView from NetView for AIX

To start CiscoView from NetView for AIX, perform the following steps

1 Start NetView for AIX by entering the following command:

% nv6000

2 Click the IP Internet symbol on NetView’s root map. NetView
displays all devices running IP, including Cisco devices.

3 To see an image of a device’s control panels, highlight a Cisco dev
on the network map and selectMonitor>CiscoView.

If the CiscoView application is not visible on the NetView Monitor
menu (and the configuration steps were successful), look for the
ciscoview.regfile in the/usr/OV/registration/Cdirectory. If the file is
missing, contact the TAC.

Discovering New or Changed IP Devices

The default IP Internet map includes all IP devices connected to NetVi
when NetView is started. To discover newly added or modified IP
devices, use the NetViewOptions>Manage Objectscommand as
follows:

1 Click a device symbol on the default IP Internet map.
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2 SelectOptions>Manage Objects. NetView displays a submap of the
selected device’s children that are reachable in one hop. Newly
appearing children could have been added to the network or explic
unmanaged by a previous user. All newly appearing children devic
are now accessible by CiscoView.

3 SelectFile>Save Map Asto save the database of devices you create

Displaying a Device with CiscoView

After you start CiscoView, you see the CiscoView main window.

To display a device, perform the following steps:

1 SelectFile>Open Device.

The File - Open Device window is displayed.

2 Complete the fields in the File - Open Device window as follows:

In the Host field, enter the host name or IP address of the device y
want to display.

In the Read Community field, enter the read community string
specified by your network administrator (public is the default).
34



e

ges

ted

,

,

In the Write Community field, enter the write community string
specified by your network administrator (public is the default). The
correct write community string allows you to change certain devic
settings.

3 Click OK  to display the panel of the specified device.

Downloading Device Packages

This section provides a quick reference to downloading device packa
from CCO.

If you do not have Internet access, skip this section. To receive upda
packages, you can order the Cisco Network Management Support
CD-ROM.

For the detailed description of downloading from CCO or additional
information about the Cisco Network Management Support CD-ROM
see the “Downloading Device Packages” chapter inOverview for
CiscoView.

Note You need to beroot or the owner (as specified in the installation)
to perform the download.
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To download device packages from CCO, perform the following step

1 Verify that you are running CiscoView Version 4.2(1) or later by
enteringnmcview from any directory on your workstation.

2 SelectHelp>About CiscoView.

3 Close CiscoView by selectingFile>Exit .

4 Create a directory to store thecv_pkgs by entering the following
commands:

# mkdir /usr/nms/cv_pkgs
# cd /usr/nms/cv_pkgs

5 Access CCO.

You can access CCO as a registered user or as a guest.

To access as a registered user, do the following:

(a) Access the Software Center by entering the following URL in
your Web browser: http://www.cisco.com/kobayashi/sw-cent

(b) At the prompts, enter your CCO user ID and password.
36
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To be granted special file access as a guest do the following:

(a) Call the Technical Assistance Center (TAC) at 1-800-553-244
or 1-408-526-7209, state the name of the product you are
downloading, and you are transferred to the appropriate pers
to obtain your special access code.

(b) Enter the following URL in your Web browser:
http://www.cisco.com/public/library

(c) Enter your special access code in the Other Software
Products/Special Files section.

(d) Select the device tar file and a download option.

6 Download the device tar file into thecv_pkgs directory.

There are two methods for downloading: from CCO and by FTP. F
information on downloading by FTP, see the Software Library We
page or theOverview for CiscoView.

(a) In the Network Management Products section, select the
CiscoView Upgrade Planner pointer to the CiscoView package
To review the packageREADME, click on theREADME
filename and select a download option. To select a device tar fi
click on the device filename and select a download option.
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(b) Reenter your password, if required.

(c) If required, clickSave File or File>Save As, depending on the
browser you are using.

(d) If a filter window appears, enter the complete destination
pathname in the Selection section of the filter window for the
downloaded device, for example,
/usr/nms/cv_pkgs/device_name.

(e) Close the Web browser.

7 Unzip the device tar file.

CiscoView packages are saved on CCO as tar files. You can open
tar files using WinZip, which is also available on CCO.

(a) Entertar -xvf file_name in thecv_pkgs directory, where
file_name is the name of your device package.

(b) Add the package file to CiscoView.

(c) Check the environment variable by enteringenv . It should
include NMSROOT.
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(d) If NMSROOT does not appear, set it by entering

setenv NMSROOT install_directory

whereinstall_directoryis the name of the directory where CiscoView
is installed,/usr/nms/CVapp.

Entersu root to log in asroot and enter the following command to
add the package file to CiscoView in thecv_pkgs directory:

$NMSROOT/bin/cvinstall /usr/nms/cv_pkgs/device_name.pkg

The downloading is complete. If there are any problems, check the
cvinstall.log file in your install directory for an explanation of errors o
see theOverview for CiscoViewfor more detail.
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Troubleshooting

If you cannot open the specified device in CiscoView, you receive a
message that the device is unmanageable. This message indicates o
the following conditions:

• The SNMP server is not set in the device. You can still ping the devi
from the management station.

• You have entered an incorrect community string in the File - Ope
Device window.

• The management station cannot reach the device and cannot
successfully ping the device. This could be because the request tim
out or because there was a noName condition.

If the request timed out, try one of the following: select
Options>Propertiesand increase the timeout value; verify the write
community string; or make sure that the device is reachable.

If there is a noName condition, verify the write community string.

• The device package is not up to date. Check your device package
compare the date to the CCO device package version. Upgrade 
device package to the latest version, if required.
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Service and Support

This section describes how to contact Cisco Systems to order
documentation products and receive service and support.

Cisco Connection Documentation

Cisco documentation and additional literature are available in a
CD-ROM package, which ships with your product. The Documentatio
CD-ROM, a member of the Cisco Connection Family, is updated
monthly. Therefore, it might be more current than printed
documentation. To order additional copies of the Documentation
CD-ROM, contact your local sales representative or call customer
service. The CD-ROM package is available as a single package or a
annual subscription. You can also access Cisco documentation on t
World Wide Web at http://www.cisco.com, http://www-china.cisco.com
or http://www-europe.cisco.com.

If you are reading Cisco product documentation on the World Wide We
you can submit comments electronically. ClickFeedbackin the toolbar
and selectDocumentation. After you complete the form, clickSubmit
to send it to Cisco. We appreciate your comments.
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Cisco Connection Online

Cisco Connection Online (CCO) is Cisco Systems’ primary, real-tim
support channel. Maintenance customers and partners can self-regi
on CCO to obtain additional information and services.

Available 24 hours a day, 7 days a week, CCO provides a wealth of
standard and value-added services to Cisco’s customers and busine
partners. CCO services include product information, product
documentation, software updates, release notes, technical tips, the 
Navigator, configuration notes, brochures, descriptions of service
offerings, and download access to public and authorized files.

CCO serves a wide variety of users through two interfaces that are
updated and enhanced simultaneously: a character-based version a
multimedia version that resides on the World Wide Web (WWW). Th
character-based CCO supports Zmodem, Kermit, Xmodem, FTP, an
Internet e-mail, and it is excellent for quick access to information ove
lower bandwidths. The WWW version of CCO provides richly formatte
documents with photographs, figures, graphics, and video, as well a
hyperlinks to related information.
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You can access CCO in the following ways:

• www: http://www.cisco.com

• www: http://www-europe.cisco.com

• www: http://www-china.cisco.com

• Telnet: cco.cisco.com

• Modem: From North America, 408 526-8070; from Europe,
33 1 64 46 40 82. Use the following terminal settings: VT100
emulation; databits: 8; parity: none; stop bits: 1; and connection ra
up to 28.8 kbps.

For a copy of CCO’s Frequently Asked Questions (FAQ), contact
cco-help@cisco.com. For additional information, contact
cco-team@cisco.com.

Note If you are a network administrator and need personal technica
assistance with a Cisco product that is under warranty or covered by
maintenance contract, contact Cisco’s Technical Assistance Center
(TAC) at 800 553-2447, 408 526-7209, or tac@cisco.com. To obtain
general information about Cisco Systems, Cisco products, or upgrad
contact 800 553-6387, 408 526-7208, or cs-rep@cisco.com.
43



44


	CiscoView 4.2(1) Installation Instructions for AIX
	Table�1 Upgrading CiscoView on AIX

	System Requirements
	Table�2 CiscoView Typical System Requirements
	Table�3 CiscoView Hardware and Software Recommendations
	Verifying AIX Version
	1 Log in as root by entering su and the root password at the prompt, or log in as root. The promp...
	2 Enter the following command:

	Verifying System Software
	Verifying RAM Size
	Verifying Hard Disk Space

	Mounting the CD-ROM
	Mounting from a Local CD-ROM Drive
	1 Place the CD-ROM into its caddy and insert it into the CD-ROM drive.
	2 Log in as root.
	3 Start SMIT by entering the following command:
	4 From the SMIT System Management menu, select System Storage Management (Physical & Logical Stor...
	5 Select File Systems.
	6 Select Add/Change/Show Delete File Systems.
	7 Select CDROM File Systems.
	8 Select Add a CDROM File System.
	9 Click the “DEVICE name” List button, and select the device name (such as /dev/cd0) from the lis...
	10 Enter the name of a mount point directory (such as /cdrom) in the Mount point field.
	11 Click OK and read the output.
	12 Click Done.
	13 Terminate SMIT by pressing F12 or clicking Exit SMIT on the Exit menu.
	14 Enter the following at the command prompt:
	15 Click the FILE SYSTEM name List button, and select a device name (such as /dev/cd0) from the l...
	16 In the DIRECTORY over which to mount field, enter the name of a mount point directory (for exa...
	17 Click the TYPE of file system List button, and select cdrfs as the filesystem type.
	18 Set the Mount as Read-Only System field to yes.
	19 Click OK, read the output, and then click Done.
	20 Click Cancel to exit SMIT.

	Mounting from a Remote CD-ROM Drive
	1 Perform all steps exactly as described in “Mounting from a Local CD-ROM Drive” on the remote wo...
	2 Enter the following command:
	3 Enter the PATHNAME of directory to export (such as /cdrom).
	4 Use the arrow keys to change the Mode to Export Directory field to read-only.
	5 Enter the appropriate information, if necessary, into the other fields.
	6 Click OK, read the output, and then click Done.
	7 Click Cancel to exit SMIT.
	1 Log in as root.
	2 Enter the following command:


	Installing CiscoView
	1 Log in as root.
	2 Mount the CD-ROM as described in the previous section.
	3 Set the I_CDROM_PATH environment variable to the path where the CD-ROM is mounted. For example,...
	4 Start SMIT by entering the following command:
	5 From the System Management menu, select Software Installation and Maintenance.
	6 Click Install and Update Software.
	7 If you have AIX 4.1.5, select Install and Update Selectable Software (Custom Install), then sel...
	8 In the dialog box, enter the name of the directory where the CD-ROM is mounted (for example, /c...
	9 Click OK.
	10 Click List next to the SOFTWARE to install field. After a brief delay, the Multi-Select List d...
	11 In the Multi-Select List dialog box, click the CiscoView module named CiscoView.base.obj.
	12 Click OK.
	13 In response to the ARE YOU SURE? prompt, click OK to install the module you just highlighted.
	14 Click Done, then Cancel.
	15 If the installation in Step 13 was successful, select Return To> System Management and go to t...

	Configuring CiscoView
	1 Start SMIT if you have not already done so by entering the following command:
	2 On the initial SMIT menu, click Communications Applications and Services.
	3 Click Cisco Network Management Applications for AIX.
	4 Click CiscoView.
	5 From the CiscoView dialog box, select Product Configuration.
	6 From the Product Configuration dialog box, accept the defaults, or enter values into each of th...
	7 Click OK, wait for the process to complete, and read the output.
	8 Click Done, then click Cancel.
	9 Terminate SMIT by pressing F12 or selecting Exit>Exit SMIT.

	Incremental Device Package Installation
	Setting Up Incremental Device Package Installation
	1 Start SMIT if you have not already done so by entering the following command:
	2 On the initial SMIT menu, click Communications Applications and Services.
	3 Click Cisco Network Management Applications for AIX.
	4 Click CiscoView.
	5 On the CiscoView menu, click Device Package Install Setup.
	6 In the Directory Containing Device Packages field, enter the path where the device packages res...
	7 In the Load MIBs into NetView field, the default is No. If you want to load MIBs, click List.
	8 If you checked List in Step 8, click Yes in the Single Select List dialog box to load MIBs into...
	9 Click OK, wait for the process to complete, and read the output.
	10 Click Done, then click Cancel.

	Installing Device Packages Incrementally
	1 Start SMIT if you have not already done so by entering the following command:
	2 On the initial SMIT menu, click Communications Applications and Services.
	3 Click Cisco Network Management Applications for AIX.
	4 Click CiscoView.
	5 In the CiscoView dialog box, click Device Package Installation.
	6 In the Select Device Packages to Install field, click List.
	7 In the Multi-Select List dialog box, select the device packages you want to install, then click...
	8 Click Done, then Cancel.

	Device Package Deinstallation
	1 If you have not already done so, start SMIT by entering the following command:
	2 On the initial SMIT menu, click Communications Applications and Services.
	3 Click Network Management Applications for AIX.
	4 Click CiscoView.
	5 In the CiscoView dialog box, click Device Package Deinstallation.
	6 Click List next to the Select Device Packages to Deinstall field. The Multi-Select List dialog ...
	7 In the dialog box, click the package you want to deinstall.
	8 Click OK.
	9 Click Done, then Cancel.
	10 Terminate SMIT by pressing F12 or by selecting Exit SMIT on the Exit menu.


	Unmounting the CD-ROM Drive
	1 At the local or remote workstation where the CD-ROM is mounted, enter the following command:
	2 Remove the CD-ROM caddy from the drive.

	Performing CiscoView Maintenance Functions
	Loading MIBs into NetView
	1 Start SMIT by performing steps 1 through 4 in the “Configuring CiscoView” section.
	2 In the CiscoView dialog box, click Maintenance.
	3 In the Maintenance dialog box, click Load all MIBs into NetView.
	4 In response to the confirmation dialog box, click OK.
	5 Terminate SMIT by pressing F12 or by clicking Exit SMIT on the Exit menu.

	Rebuilding All CiscoView Files
	1 Start SMIT by performing steps 1 through 4 in the “Configuring CiscoView” section.
	2 In the CiscoView dialog box, click Maintenance.
	3 In the Maintenance dialog box, click Rebuild all CiscoView config files.
	4 In response to the confirmation dialog box, click OK.
	5 Terminate SMIT by pressing F12 or clicking Exit SMIT on the Exit menu.

	Uninstalling CiscoView
	1 Log in as root.
	2 Start SMIT by entering the following command:
	3 On the System Management menu, select Communications Applications and Services.
	4 Select Cisco Network-Management Applications for AIX.
	5 Select CiscoView.
	6 Select Maintenance.
	7 Select Remove CiscoView for AIX program.
	8 In response to the ARE YOU SURE? prompt, click OK.
	9 Terminate SMIT by pressing F12 or selecting Exit>Exit SMIT.


	Getting Started with CiscoView
	CiscoView Security
	Starting CiscoView from the Command Line
	1 For C shell, enter the following command:
	2 Start CiscoView by entering the following at the command line:
	3 Specify a Cisco device to monitor.

	Starting CiscoView from NetView for AIX
	1 Start NetView for AIX by entering the following command:
	2 Click the IP Internet symbol on NetView’s root map. NetView displays all devices running IP, in...
	3 To see an image of a device’s control panels, highlight a Cisco device on the network map and s...
	Discovering New or Changed IP Devices
	1 Click a device symbol on the default IP Internet map.
	2 Select Options>Manage Objects. NetView displays a submap of the selected device’s children that...
	3 Select File>Save Map As to save the database of devices you created.



	Displaying a Device with CiscoView
	1 Select File>Open Device.
	2 Complete the fields in the File - Open Device window as follows:
	3 Click OK to display the panel of the specified device.

	Downloading Device Packages
	1 Verify that you are running CiscoView Version 4.2(1) or later by entering nmcview from any dire...
	2 Select Help>About CiscoView.
	3 Close CiscoView by selecting File>Exit.
	4 Create a directory to store the cv_pkgs by entering the following commands:
	5 Access CCO.
	(a) Access the Software Center by entering the following URL in your Web browser: http://www.cisc...
	(b) At the prompts, enter your CCO user ID and password.
	(a) Call the Technical Assistance Center (TAC) at 1-800-553-2447 or 1-408-526-7209, state the nam...
	(b) Enter the following URL in your Web browser: http://www.cisco.com/public/library
	(c) Enter your special access code in the Other Software Products/Special Files section.
	(d) Select the device tar file and a download option.

	6 Download the device tar file into the cv_pkgs directory.
	(a) In the Network Management Products section, select the CiscoView Upgrade Planner pointer to t...
	(b) Reenter your password, if required.
	(c) If required, click Save File or File>Save As, depending on the browser you are using.
	(d) If a filter window appears, enter the complete destination pathname in the Selection section ...
	(e) Close the Web browser.

	7 Unzip the device tar file.
	(a) Enter tar -xvf file_name in the cv_pkgs directory, where file_name is the name of your device...
	(b) Add the package file to CiscoView.
	(c) Check the environment variable by entering env. It should include NMSROOT.
	(d) If NMSROOT does not appear, set it by entering
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