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Getting Started with CVDM-CSM

The CiscoView Device Manager for the Cisco Content Switching Module (CSM
enables users easily to configure content load-balancing services on their CS
It is a task-based tool that allows users to control the versatility of their Cisc
CSM by offering configuration based on recommended practices in tasks, suc
setting up virtual servers, creating server farms, and applying advanced polic
CiscoView Device Manager is a free embedded manager that resides in the C
Catalyst 6500 Series supervisor engine Flash memory.

The CiscoView Device Manager for the Cisco CSM manages several CSM
features and helps users accomplish these tasks with ease.

For enterprises and service providers to offer accelerated content delivery
services in their data centers, an easy-to-use, web based, device-managemen
is required for CVDM-CSM. The CVDM-CSM Device Manager is an embedde
device manager targeted at single chassis setup, feature and service configur
and monitoring of the Catalyst 6500/7600 series of products.

CiscoView Device Manager for the CSM supports server load balancing
configuration on the CSM, including:

1. Configuring virtual servers.

2. Configuring server farms and attaching real servers to them.

3. Configuring client and server VLANs.

4. Configuring Layer 4 through Layer 7 policies, including maps and sticky
groups.

5. Monitoring the health of servers
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This section contains the following topics:

• Key Features in CVDM-CSM, page 1-2

• Navigating in CVDM-CSM, page 1-3

• Editing Preferences, page 1-10

• Viewing the Running Configuration Information for a Device, page 1-12

• CVDM-CSM Home Page, page 1-12

• Setup Page, page 1-18

• Delivering CLI Commands to the Switch/Module, page 1-19

Key Features in CVDM-CSM
The following table describes the key features of CVDM-CSM.

Feature Description

Dual Mode Setup Wizard Allows users to customize deployment in two modes, using either a b
or an advanced wizard.

VLAN Setup Client and Server side VLAN setup.

Virtual Server Setup Advertise active (required for route health injection), Restricts clients
access to virtual servers, Performance/load configuration,
Enabling/disabling of connection persistence, Sticky configuration,
Default/backup server farm policy setup, URL-hash prefix.

Server Farm
configuration

Possible to set prediction algorithm, In-band health monitoring, NAT,
Associating probes, Fail action—action taken on real server failure
(purge/reassign), Configuring a set of real servers, Taking real servers
in/out of service.

Real Server
configuration

Server farm name and real IP address, Load parameters
(maximum/minimum connections and threshold load), Health monitorin
parameters (probe), Port translation, Weight.

Policy configuration Configuring and associating Cookie map, Header map, URL map, Cli
group (access control lists), Sticky group, and Associate server farm a
backup server farm.
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Navigating in CVDM-CSM
Before you begin using CVDM-CSM, you must understand the basic operation
the user interface, including the login procedure and user interface elements.
the following sections for more information:

• Starting CVDM-CSM, page 1-4

• Understanding the CVDM-CSM Desktop, page 1-5

Map configuration Map types such as Cookie map, Domain Name System map, Header m
URL map.

Sticky Group
configuration

Sticky group types such as Cookie, CVDM-CSM, Header, Netmask.

Health Monitoring

Configuration Probes

Probe types such as FTP, HTTP, Internet Control Message Protocol,
Simple Mail Transfer Protocol, TCP, Telnet.

Fault Tolerant Group Allows users to set Group identification, Fault tolerant VLAN, Failove
time, Heartbeat time, Preempt, Priority.

XML Configuration Allows users to set Client group, Credentials, VLAN, Port, XML service
status.

Feature Description
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Starting CVDM-CSM

Step 1 In your browser, enter the IP address or DNS hostname of the device. The E
Network Password dialog box appears.

Step 2 Enter your device username and password.

Step 3 Click OK . The CVDM-CSM Device Manager Home Page appears.

Step 4 Enter your device username and password. The SSH Credentials dialog box
appears.

Step 5 Enter your SSH username and password. The Enter Enable Password dialog
appears.

Step 6 Enter Enable Password.

Step 7 Click OK . The application starts.
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Understanding the CVDM-CSM Desktop
This section describes the main GUI elements of the CVDM-CSM applicatio

Figure 1-1 CVDM-CSM GUI Elements
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Figure 1-1
Reference Location Description

1 Menu bar Provides File, Edit, View, and Help buttons.

• File

– File > Save to Startup—Saves the configuration running on the
device as the startup configuration.

– Deliver to Device…—Send the configuration to the device.

– File > Exit—Logs you out of CVDM-CSM and closes the
window. A warning appears if any configuration have not been
applied. Based on your preference, the configurations are eithe
applied or discarded before the application closes.

• Edit > Preferences—Edit your global user preferences.

• View

– View > Home—Displays the home page.

– View > Setup—Displays the features page.

– View > Running Configuration—Displays the configuration
running on theSupervisor and theCSM.

– View > Refresh—Collects the most recent device information and
updates CVDM-CSM with it.

• Tools > Ping —Checks the connection with the server and opens a
dialog box showing the status.

• Help

– Help > Help Topics—Displays online help.

– Help > About—Displays CVDM-CSM version information.
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2 Task bar Provides access to CVDM functionality.

• Home—Displays the home page.

• Setup—Displays the features page.

• Refresh—Collects the most recent device information and updates
CVDM-CSM with it.

• Deliver—Sends CVDM-CSM data to the device.

• Help—Displays context-sensitive help.

3 Page CVDM-CSM working area in which you perform tasks.

4 Pane One part of a divided page or dialog box.

5 Status bar Provides the following information:

• Message describing the current status of the application.

• Icon showing a table of users logged in to the device.

• Application user and privilege level.

• Icon showing the list of pending CLIs to be delivered to the device.

• Icon showing the security level of the connection.

• Time stamp showing the application startup time.

6 Selector Hierarchy of the groups and objects available in the Switch or Service
page that allows you to access specific functions for a Switch or Servic
object. See the“Selector” section on page 1-8 for more information.

7 Left-most
pane

Contains buttons, under the Switch or Services page, that allow you to
access switch or services functions.

Figure 1-1
Reference Location Description
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Selector

Figure 1-2 shows the selector;Table 1-1 describes the selector elements.

Figure 1-2 Selector
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Note Figure 1-2shows what the selector looks like when there are folders, subfolde
and objects displayed. Some selectors do not contain all of these elements.

Understanding the Action Buttons
This section describes the action buttons that appear in CVDM-CSM dialog bo
and wizards.

• For a description of the wizard action buttons, seeTable 1-2 on page 1-9.

• For a description of the dialog box action buttons, seeTable 1-3 on page 1-10.

Table 1-1 Selector Elements

Figure 1-2
Reference Location Description

1 Group folder Displays a group of objects. Click the plus
(+) symbol to see the contents of this folder.

2 Selector handle Click the handle to open and close the
selector, or click the handle and drag it to
resize it.

3 Subgroup folder Displays a subgroup of objects. Click the
plus (+) symbol to see the contents of this
folder.

4 Object Displays the individual entity contained in
the group or subgroup. Click an object to
open the page for that object.

Table 1-2 Wizard Action Buttons

Button Action

Back Takes you to the previous page.

Next Takes you to the next page.

Finish Takes you to the wizard summary page.
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Editing Preferences

Step 1 SelectEdit > Preferences. The Preferences dialog box appears.

Step 2 Modify the appropriate values:

Cancel Exits the wizard without making any
changes.

Help Displays context-sensitive online help.

Table 1-3 Dialog Box Action Buttons

Button Action

OK Saves your changes.

Cancel Exits the dialog box without making
any changes.

Help Displays context-sensitive online help.

Table 1-2 Wizard Action Buttons

Button Action
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GUI Element Action

Show CLI Preview for
Wizards check box

Select this checkbox if you want CVDM to display
the CLI commands to be delivered to the device
after you have completed a wizard.

When this checkbox is selected, when you click
Finish in a wizard, the Deliver Configuration to
the Switch/Module(s) dialog box opens and
displays the CLI commands. For more
information, see the ““Delivering CLI Commands
to the Switch/Module” section on page 1-19”.

Show CLI Preview on
Delivery checkbox

Click this checkbox if you want CVDM to display
the CLI commands to be delivered to the device.

When this checkbox is selected, if you click
Deliver, then the Deliver Configuration to
Switch/Module(s) dialog box opens and displays
the CLI commands. For more information, see the
“Delivering CLI Commands to the
Switch/Module” section on page 1-19.

Save to Startup checkbox Click this checkbox to save your CVDM setting
as the device startup configuration.

Confirm before Exiting
checkbox

Click this checkbox if you want CVDM to ask you
to confirm that you want to exit the application.

When this checkbox is selected, CVDM displays a
dialog box asking you if you want to exit CVDM.
From this dialog box, you can select the Always
display this dialog box before exiting checkbox if
you always want CVDM to confirm that you want
to exit CVDM.
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Viewing the Running Configuration Information for a
Device

Step 1 SelectView > Running Config, then select one of the following:

• Supervisor...

• CSM: Slot X...

Note Only options for installed service modules are available to be selecte

Step 2 The Show Running Configuration dialog box appears. Information about the
running configuration for the selected component is displayed.

You can click theSave to Filebutton to save this information as a text file.

CVDM-CSM Home Page
The Home page is the first screen that comes up when CVDM-CSM is started.
home page provides an overview of CVDM-CSM.

The home page displays the following information:
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Figure 1-3 Homepage CVDM-CSM
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Table 1-4 Home Page Description

Reference Field Description

1 System Overview

Model Type Model Type of the CSM.

Overflow errors Number of overflow errors for
the system.

Serial Number Serial number of the card.

Slot Number Slot number of the CSM for
which the application is open.

Software Version Software version of the CSM
module.

Hardware Version Hardware version of the CSM
module.

Redundancy

Status Displays if the module is active
or Standby.

FT VLAN ID Displays the VLAN over which
heartbeat messages are sent.
Both CSMs must have the same
VLAN ID.

Network Processor Utilization Displays the utilization of the
network processor in percentage
for IXP1-Session, IXP2-TCP,
IXP3-Layer7, IXP4-
Load-Balancing, and IXP5-NAT.
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2 Connection Dashboard

Graphs Select this button to view the
Connection Dash Board details
as graphs. The graphs are
indicated in units of Kilo
connections.

Actual Values Select this button to view all
fields as actual connections
values.

Cumulative Connections

Created Connections Number of connections at the
specified moment. The units are
Kilo Connections.

Destroyed Connections Number of connections
destroyed. The units are Kilo
Connections.

Failed Connection Number of connections that
failed. The units are Kilo
Connections.

Timed Out Connections Number of connections that were
timed out. The units are Kilo
Connections.

L4 and L7 Connections

L4 Decision Number of layer 4 load
balancing decisions taken. The
units are Kilo Connections.

L7 Decision Number of layer 4 load
balancing decisions taken. The
units are Kilo Connections.

Table 1-4 Home Page Description

Reference Field Description
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L4 Rejections Number of Layer 4
load-balancing rejections taken.
The units are Kilo Connections.

L7Rejections Number of Layer 7
load-balancing rejections taken.
The units are Kilo Connections.

3 Service Dashboard

Virtual Servers

Inservice Number of virtual servers that
are operational.

Out of Service Number of Virtual Servers that
are not operational.

Policy Associated Number of Virtual Servers that
have associated policies.

Default Policy Number of Virtual Servers that
have only the default policy.

Policies

Configured Policies Number of policies that are
configured in the CSM module.

Policies without conditions Number of policies that are
without conditions.

Policy without action Number of policies that are
without actions.

Server Farms

Total Number of server farms
configured in the CSM Module.

Available Number of server farms with
atleast one operational real
server.

Real Servers Displays the admin status of the
real servers.

Table 1-4 Home Page Description

Reference Field Description
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My Virtual Servers
My Virtual Servers page is a part of the Homepage under theServer Dashboard.

Step 1 Click My Virtual Servers  link. The page appears and the following fields are
displayed.

Named Reals Number of Named Real Server
configured on the CSM.

Unnamed Reals Number of Unnamed Real
Server configured on the CSM.

4 Server Dashboard

My Virtual Server Selected virtual servers that are
used in emergencies as critical
servers. For more details see
“My Virtual Servers” section on
page 1-17.

Name Name of the Virtual Server.

IP Address IP address of the Virtual Server.

Operational Status Virtual Servers that are out of
service.

Table 1-4 Home Page Description

Reference Field Description

Field Description

Virtual Server Name A list of Virtual Server names.

Select Select the check box against the
respective virtual server to count them
as My Virtual Servers.
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Setup Page
The setup page allows you to access the features in CVDM-CSM. You can lau
wizards from this page or you can start using the VLANs, Virtual Servers, Ser
Farms, Real Servers, and Policies features from this page.

On selecting the Setup, the following GUI elements are displayed in an outlo
bar on the left side of the content window:

GUI Element Description

Wizard Click to launch wizards that will help you to configure and manage Clien
and VLAN server setup, Virtual Server, and associate default policies.

VLAN Setup Allows you to set client-side and server-side VLAN setup.

Virtual Server Setup Allows you to advertise active (required for route health injection),
Restricts clients access to virtual servers, Performance/load configuratio
Enabling/disabling of connection persistence, Sticky configuration,
Default/backup server farm policy setup, and URL-hash prefix.

Server Farm
Configuration

Allows you to set prediction algorithm, In-band health monitoring, NAT,
Associate probes, Fail action—action taken on real server failure
(purge/reassign), Configure a set of real servers, Taking real servers in/o
of service.

Real Server Configuration Allows you to create and manage Server farm name and real IP add
Load parameters (maximum/minimum connections and threshold load
Health monitoring parameters (probe), Port translation, and Weight.

Policy Configuration Allows you to configure and associate Cookie map, Header map, URL
map, Client group (access control lists), Sticky group, and Associate
server farm and backup server farm.

Fault Tolerance Allows you to set Group identification, Fault tolerant VLAN, Failover
time, Heartbeat time, Preempt, and Priority.

XML Configuration Allows you to set Client group, Credentials, VLAN, Port, and XML
service status.
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Delivering CLI Commands to the Switch/Module
You must deliver accumulated CLI commands to the device before any chan
you make in CVDM-CSM will be applied.

Step 1 Click theDeliver button at the top of the page. The Deliver Configuration to
Switch/Module(s) dialog box appears if you have configured CVDM to displa
the accumulated CLI commands when you click the Deliver button.

Note The Deliver Configuration to Switch/Module(s) dialog box also appears when y
click theFinish button in a wizard if you have configured CVDM to display th
accumulated CLI commands after you have completed a wizard.

Step 2 Modify the appropriate values:

GUI Element Action/Description

Page Displays the accumulated CLI commands to be
delivered to the device.

Save to Startup checkbox Click the checkbox to save the running
configuration, generated by CVDM, as the device
startup configuration.

Deliver button Click to send the accumulated CLI commands to th
device.

Save to File... button Click to save the CLI commands as a text file.

Close button1

1. This button is available only in the Deliver Configuration to Switch/Module(s) dialog box that
displayed after you clickDeliver at the top of the window.

Close the dialog box without delivering any CLI
commands.

Deliver Later button2

2. This button is available only in the Deliver Configuration to Switch/Module(s) dialog box that
displayed after you clickFinish in a wizard.

Click to deliver the wizard CLI commands to the
device at a later time.
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Note The Deliver Configuration to Switch/Module(s) dialog box displaysall
accumulated CLI commands that will be delivered to the device; therefore, a
previous CLI commands that were not sent to the device are shown in this dia
box, as well as the CLI commands you have generated in this session.
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