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Preface

This manual describes Cisco Unified Provisioning Manager (Provisioning Manager) and provides 
instructions for using and administering it.

Audience
The audience for this document is for network administrators and operators who monitor, maintain, and 
configure the status of the IP telephony systems and applications.

Conventions
This document uses the following conventions:

Note Means reader take note. Notes contain helpful suggestions or references to material not covered in the 
publication. 

Tip Means reader take note. Notes contain helpful suggestions or references to material not covered in the 
publication. 

Item Convention

Commands and keywords boldface font

Variables for which you supply values italic font

Displayed session and system information screen font

Information you enter boldface screen font

Variables you enter italic screen font

Menu items and button names boldface font

Selecting a menu item in paragraphs Option> Network Preferences

Selecting a menu item in tables Option > Network Preferences
ix
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Preface
Product Documentation
Caution Means reader be careful. In this situation, you might do something that could result in equipment 
damage or loss of data.

Product Documentation

Note We sometimes update the printed and electronic documentation after original publication. Therefore, 
you should also review the documentation on Cisco.com for any updates.

Table 1 describes the product documentation that is available.

Obtaining Documentation, Obtaining Support, and Security 
Guidelines

For information on obtaining documentation, obtaining support, providing documentation feedback, 
security guidelines, and also recommended aliases and general Cisco documents, see the monthly 
What’s New in Cisco Product Documentation, which also lists all new and revised Cisco technical 
documentation, at:

http://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html

Table 1 Product Documentation

Document Title Available Formats

Supported Devices Table for Cisco Unified 
Provisioning Manager 1.1

On Cisco.com at the following URL: 

http://www.cisco.com/en/US/products/ps7125/products_device_support_tables
_list.html

Release Notes for Cisco Unified 
Provisioning Manager 1.1

• In PDF on the product CD-ROM

• On Cisco.com at the following URL: 
http://www.cisco.com/en/US/products/ps7125/prod_release_notes_list.html

Installation Guide for Cisco Unified 
Provisioning Manager 1.1

• In PDF on the product CD-ROM

• On Cisco.com at the following URL: 
http://www.cisco.com/en/US/products/ps7125/prod_installation_guides_lis
t.html

User Guide for Cisco Unified Provisioning 
Manager 1.1 

• In PDF on the product CD-ROM

• On Cisco.com at the following URL: 
http://www.cisco.com/en/US/products/ps7125/products_user_guide_list.ht
ml
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C H A P T E R 1

Introduction

What Is Provisioning Manager?
Cisco Unified Provisioning Manager (Provisioning Manager) provides a scalable web-based solution to 
manage a company’s next-generation communication services. Provisioning Manager manages IP 
communication services in an integrated IP telephony, voicemail, and unified messaging environment 
that includes Cisco Unified Communications Manager, Cisco Unified Communications Manager 
Express, Cisco Unity, Cisco Unity Express, and Cisco Unity Connection systems.

Note Starting with versions 4.3, 5.1, and 6.0, the product we formerly referred to as Cisco Unified 
CallManager will be called Cisco Unified Communications Manager. Versions earlier than 4.3  and 5.1 
retain the Cisco Unified CallManager name. Throughout this document/online help, any reference to 
Cisco Unified Communications Manager can also be understood to refer to Cisco Unified CallManager, 
unless explicitly noted.

Provisioning Manager is a product from the Cisco Unified Communications Management Suite. It 
provides provisioning for Cisco Unified Communications initial deployments and implementations, and 
then remains deployed to provide ongoing operational provisioning and activation services for individual 
subscriber changes. Provisioning Manager provides a single, consolidated view of subscribers across the 
organization. It provides a set of business-level management abstractions, which are policy-driven 
through the use of automation, for managing subscriber services across the Cisco Unified 
Communications infrastructure.

A template capability permits defining standard configurations that can be reused for new sites or 
location deployments. Batch provisioning permits the rollout of large numbers of subscribers at the same 
time.

Administrators can configure policy at various levels to determine who can do delegated management, 
for whom that delegation applies, how business-level services apply to Cisco Unified Communications 
voice and messaging applications, and which types of end users (subscribers) are permitted to order 
which standard services. Through the use of this policy and standard configuration approach, 
provisioning and activating subscriber services is greatly simplified, while retaining the overall ability 
to manage and provide services that make use of the underlying Cisco Unified Communications 
applications. 
1-1
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Provisioning Manager Architecture
Provisioning Manager is a web-based application based on the J2EE architecture. It resides on a separate 
Windows-based computer and uses various interfaces to connect with Cisco Unified Communications 
applications (see Figure 1-1). It does not need to deploy any agent software onto those applications’ 
platforms. Provisioning Manager uses open interfaces such as HTTP, HTTPS, AVVID XML Layer 
(AXL)–Simple Object Access Protocol (SOAP), SSH, and Telnet to remotely configure or query the 
applications being managed. Different levels of user access can be configured by the administrator.

Figure 1-1 Cisco Unified Provisioning Manager Interoperability

Provisioning Manager Features and Functions
Provisioning Manager permits standard services (for example a phone, line, or voicemail) to be ordered 
for a subscriber (the owner of the individual phone, line, or voicemail). Provisioning Manager processes 
all changes to the underlying Cisco Unified Communications applications as a service requests or orders. 
An order may be created to make a subscriber-level change (to a phone, a line and so on), or an IP 
communications-level infrastructure change (such as provisioning a new calling search space or route 
pattern). All orders in the system are tracked and viewable, both across orders and by subscriber name 
or ID. The order records show who initiated the order, the times of various process steps, and what the 
order contained. Provisioning Manager allows delegation of the order management capability so that 
requests for service additions, changes, or cancellations can be done without requiring an underlying 
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knowledge of the voice applications that are delivering those services. Provisioning Manager provides 
the same ordering experience regardless of the technology delivering the Cisco Unified Communication 
services.

These topics briefly describe Provisioning Manager functions that will be used frequently:

• What Are Processors?, page 1-3

• What Are Domains?, page 1-3

• What Are Service Areas?, page 1-3

• What Are Provisioning Attributes?, page 1-4

• What Are Infrastructure Configuration Templates?, page 1-4

• What Is Batch Provisioning?, page 1-4

• What Is Role-Based Access?, page 1-4

• What Is Inventory Tracking?, page 1-5

What Are Processors?

In Provisioning Manager, you create Call Processors and Unified Message Processors. Call Processors 
are proxies for each instance of Cisco Unified Communications Manager or Cisco Unified 
Communications Manager Express. Unified Message Processors are proxies for each instance of Cisco 
Unity, Cisco Unity Express, or Cisco Unity Connection.

You synchronize the data in the Cisco Unified Communications Manager and Cisco Unity systems with 
the Call Processors and Unified Message Processors, and then synchronizing with the Domains, which 
populates Provisioning Manager with the existing active users and services, and provides a consolidated 
view of all of the infrastructure and subscriber information.

For more information about Service Areas, see Configuring Processors, page 5-1.

What Are Domains?

Domains are groupings of subscribers. For each grouping, one or more system users can be authorized 
to manage services for subscribers within that Domain. In addition, rules or policies may be set on a 
Domain. Those rules and policies will apply to services for subscribers in that Domain. Common 
policies can also be applied on operations within a Domain.

For more information about Domains, see Working with Provisioning Manager Domains, page 5-10.

What Are Service Areas?

Service areas are groupings within a Domain that are used to structure and manage IP telephony and 
messaging services. The Service Area typically acts as a service offering location and provides a 
template mechanism that determines provisioning attribute values used during order processing. 
Administrative users may configure Service Areas. This helps ensure that service orders follow company 
policies and best practices for configuring subscribers. A Service Area also handles Cisco Unified 
Communications Manager partitioning and class of service by directing which location, device pool, 
calling search space, and route partition assignments to use for any user provisioned into that Service 
Area.

For more information about Service Areas, see Working with Service Areas, page 5-16.
1-3
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What Are Provisioning Attributes?

Provisioning attributes are configuration settings that are applied to services on an order during 
activation. The system administrator can assign and configure provisioning attributes throughout 
different levels within the system (at the Domain, Service Area, or Subscriber type levels, or on an 
individual order basis). At order time the system takes into account the configured provisioning attribute 
assignments in addition to the Service Area settings to determine the final product configuration to be 
provisioned. The combination of Service Area settings and provisioning attributes gives administrators 
the flexibility to customize the provisioning policies for subscriber services.

For more information about provisioning attributes, see Configuring Provisioning Attributes, page 6-13.

What Are Infrastructure Configuration Templates?

Configuration Templates enable you to consistently auto-configure the Cisco Unified Communications 
voice infrastructure. In Provisioning Manager, you can create templates to initially configure or 
reconfigure Cisco Unified Communications Manager, Cisco Unified Communications Manager Express, 
and Cisco Unity Express. Templates can contain an unlimited number of objects. This is limited only by 
the time required to execute (push to a device) the template. 

Provisioning Manager templates can contain up to twenty different types of objects, such as device 
pools, route partitions, calling search spaces, route lists, route groups, or route patterns. Objects placed 
in a template may have embedded keywords within their attributes. When pushing a template to a device, 
you may specify an optional keyword, which defines the values of the keywords to be used (replaced) 
during the provisioning operation. Templates may contain subtemplates as well, permitting reuse of 
common types of configuration information across higher level templates. Cisco Unified 
Communications Manager Express and Cisco Unity Express templates contain Cisco IOS software text 
or CLI text with keywords. Configuration Templates enable you to define a standard set of configurations 
that you can use in multiple situations, such as rolling out new offices, locations, remote sites, or 
organizational overlays.

For more information about provisioning attributes, see Using Templates—Infrastructure Configuration, 
page 5-23.

What Is Batch Provisioning?

You may order subscriber services on an individual basis for a single subscriber. But when deploying a 
large number of services, you should combine them into a single batch. Batch provisioning enables you 
to create a single batch that contains multiple types of orders (Add, Change, or Cancel orders). You can 
also combine multiple types of services into a single batch operation. For example, a batch can contain 
a combination of phone and voicemail additions or changes.

Batches can be run immediately upon uploading to Provisioning Manager, or they can be scheduled to 
run at a later time.

For more information about provisioning attributes, see Using Batch Provisioning, page 5-42.

What Is Role-Based Access?

Provisioning Manager provides two dimensions to roles, depending on whether you are a system user or 
a service subscriber. User roles define access to certain functions available to Provisioning Manager 
users. The subscriber role refers to the role that a subscriber will have within an organization. This role 
dictates the services for which the subscriber is entitled. User roles are pre-defined in the system. 
Subscriber roles are configured by the administrator.
1-4
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For more information about provisioning attributes, see the following:

• Managing Subscribers, page 2-1

• Managing Users, page 2-9

What Is Inventory Tracking?

Provisioning Manager tracks the information about all services and subscribers in an internal asset 
management inventory system. This information can be viewed by an administrator, who can create and 
save advanced searches that permit producing report templates in HTML or Microsoft Excel format. 
Sample reports for configuration and phone information are provided.

For more information about provisioning attributes, see Searching Inventory, page 7-13.

How Will I Use Provisioning Manager?
This topic describes some common scenarios for using Cisco Unified Provisioning Manager. This is not 
an all-inclusive list.

You can use Provisioning Manager for the following:

• Managing Existing Voice Services, page 1-5

• Deploying a New Voice Infrastructure, page 1-6

• Managing Subscriber Services, page 1-6

• Deploying a New Site on an Existing Voice Infrastructure, page 1-6

Also, you may want to perform several advanced activities to meet the needs of your Cisco Unified 
Communications deployment.

Some of these activities are described in the following:

• Customizing Provisioning Manager to Meet Your Needs, page 1-6

• Performing Large Provisioning Activities, page 1-7

• Working with Provisioning Manager Resources, page 1-7

• Administering Provisioning Manager, page 1-7

Managing Existing Voice Services 
If you have existing Cisco Unified Communications devices (Cisco Unified Communications Manager, 
Cisco Unified Communications Manager Express, Cisco Unity, Cisco Unity Connection, or Cisco Unity 
Express) that you are managing through their respective interfaces, but want to delegate management of 
a subset of these voice services to other users, see the following:

• Creating Call Processors, page 5-2

• Synchronizing Call Processors, page 5-4

• Creating Unified Message Processors, page 5-6

• Synchronizing Unified Message Processors, page 5-8

• Creating a Domain, page 5-11

• Creating Service Areas, page 5-17
1-5
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• Synchronizing Domains, page 5-13

• Managing Orders, page 3-1 

Deploying a New Voice Infrastructure 
If you are adding a new Cisco Unified Communications Manager or Cisco Unified Communications 
Manager Express and related voicemail systems, and you want to use a standardized approach that can 
be applied to every deployment, see the following:

• Using Templates—Infrastructure Configuration, page 5-23

• Configuring a Domain, page 5-12

• Configuring Service Areas, page 5-18

• Synchronizing Domains, page 5-13 

• Managing Orders, page 3-1

• Using Batch Provisioning, page 5-42

Managing Subscriber Services 
If you will manage services for subscribers in your office, see the following: 

• Managing Subscribers, page 2-1

• Viewing Orders, page 3-1

• Ordering Products and Services, page 3-2

• Processing Orders, page 3-17

• Canceling Products, page 3-19

Deploying a New Site on an Existing Voice Infrastructure 
If you have an existing Cisco Unified Communications Manager to which you want to add a new location 
or site, see the following:

• Configuring a Domain, page 5-12

• Configuring Service Areas, page 5-18

• Synchronizing Domains, page 5-13

• Managing Orders, page 3-1

• Using Batch Provisioning, page 5-42

Customizing Provisioning Manager to Meet Your Needs
If you want to change the default setting for how Provisioning Manager applies various policies, see the 
following: 

• Business Rules, page 6-2

• Configuring Provisioning Attributes, page 6-13
1-6
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• Configuring Phone Button Templates, page 6-1

• Working with Subscriber Roles, page 2-6

Performing Large Provisioning Activities
If you are deploying a large number of services, you may want to combine these activities into a single 
batch. See the following: 

• Using Batch Provisioning, page 5-42

Working with Provisioning Manager Resources
When you need to manage Provisioning Manager resources, see the following: 

• Managing Phone Inventory, page 4-1

• Managing Directory Inventory, page 4-4

• Searching Inventory, page 7-13

• Viewing System Reports, page 7-21

Administering Provisioning Manager
For information on performing administrative activities, see the following: 

• Viewing Licensing Information, page 7-1

• Managing Users, page 2-9

• Maintaining Data, page 7-5

• Scheduling Synchronizations, page 7-12

• Managing Log Files, page 7-4

Starting Provisioning Manager
You can access Provisioning Manager on the system where Provisioning Manager is installed, or 
remotely from a client system. 

• To start Provisioning Manager on the server, from the Windows desktop select Start > Programs > 
Cisco Unified Provisioning Manager > Log in to Cisco Unified Provisioning Manager. 

• To start Provisioning Manager on a client system, in a browser enter the following URL: 
http://<system name>/cupm/Login.

Note If Enhanced Security is enabled on the Windows 2003 system, you must add the Provisioning Manager 
home page to the Internet Explorer Trusted Sites Zone. You will not be able to access the Cisco Unified 
Provisioning Manager home page until it is added to the trusted sites. (See Adding the Provisioning 
Manager Home Page to the Internet Explorer Trusted Sites Zone, page 1-8.)
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Logging Out of Provisioning Manager
In the top right corner of the Provisioning Manager home page, click Log Out.

Adding the Provisioning Manager Home Page to the Internet Explorer Trusted 
Sites Zone

If Enhanced Security is enabled on the Windows 2003 system, you must perform the following 
procedure before you can access the Provisioning Manager’s home page.

Step 1 Open Provisioning Manager, select Start > Programs > Cisco Unified Provisioning Manager > Log 
in to Cisco Unified Provisioning Manager. 

Step 2 In the File menu, click Add this site to.

Step 3 Click Trusted Sites Zone.

Step 4 In the Trusted Sites dialog box, click Add to move the site to the list.

Step 5 Click Close.

Step 6 Refresh the page to view the site from its new zone.

Step 7 Check the Status bar of the browser to confirm that the site is in the trusted sites zone.

Accessing the Provisioning Manager User Guide
On the Provisioning Manager home page, click the Help button in the top right corner. A PDF version 
of User Guide for Cisco Unified Provisioning Manager opens.
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Managing Subscribers and Users

These topics describe how to use subscriber and user management:

• Managing Subscribers, page 2-1

• Working with Subscriber Roles, page 2-6

• Managing Users, page 2-9

Managing Subscribers
A subscriber is a person who has active IP Telephony services. Provisioning Manager treats the 
subscriber as the owner of all active services in the voice network. All services are tied to subscribers.

This section describes the following:

• Creating Subscribers, page 2-1

• Updating Subscriber Information, page 2-2

• Resetting Subscriber Passwords, page 2-4

• Managing Authorization Roles, page 2-5

• Synchronizing a Subscriber, page 2-5

• Removing a Subscriber, page 2-5

• Accessing Subscriber Records, page 2-6

Creating Subscribers

Step 1 Select Provisioning Dashboard > Manage Subscribers > Add Subscriber. The Manage Subscriber 
page appears. 

Tip The Provisioning Dashboard page provides a direct link to the Manage Subscriber page. In the 
Manage Subscriber pane, click Add Subscriber.
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Step 2 Do the following:

• Select a Domain.

• Enter a subscriber ID. This is a unique ID and is not case sensitive.

• Enter the subscriber’s name. 

Note Remember the following when entering the subscribers name:

• For Cisco Unified Communications Manager Express and Cisco Unity Express, enter only 
alphabetical characters in the First Name and Last Name fields. If you use other types of characters, 
orders for the subscriber will fail. 

• For Call Processors, the combination of characters for First Name and Last Name cannot exceed 30 
characters. If this limit is exceeded, when you place an order, the Call Processor sends an error.

• (Optional) Enter the subscriber’s phone number.

• (Optional) Enter the subscriber’s email address.

• (Optional) Enter the subscriber’s department.

• (Optional) Select roles for the subscriber. 

Note The default or Employee subscriber role should be configured to match the typical setup of 
employees in your organization. If you do not configure the default or Employee subscriber role 
to meet your needs, you may not see all the desired options in the employee subscriber record. 
The DefaultUserType rule (see DefaultUserType, page 6-5) controls which subscriber role is set 
as the default. Provisioning Manager comes with the Employee subscriber role configured as the 
default subscriber role.

Step 3 Click Create. The subscriber is created. You can now update any of the subscriber information.

Tip In the Manage Subscriber page, you can access a particular subscriber’s Subscriber Record Details page. 
Click either View Subscriber Services or Order Subscriber Services. 

Updating Subscriber Information
Once a subscriber is created you can use the Manage Subscriber page to do the following:

• Change subscriber’s name.

Note Remember the following when entering the subscribers name:

• For Cisco Unified Communications Manager Express and Cisco Unity Express, enter only 
alphabetical characters in the First Name and Last Name fields. If you use other types of characters, 
orders for the subscriber will fail. 
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• For Cisco Unified Communications Manager, the combination of characters for First Name and Last 
Name cannot exceed 30 characters. 

• Change subscriber’s phone number.

• Change subscriber’s email.

• Change subscriber’s department.

• Change roles.

• View subscriber services.

• Order subscriber services.

• Manage passwords.

• Manage authorization roles.

• Synchronize subscriber. Appears only after an order is placed for the subscriber.

Note When synchronizing subscribers, remember the following:

• The username and phone number fields may display Unknown for subscribers who were initially 
created on Cisco Unified Communications Manager Express and then later synchronized to 
Provisioning Manager.

You can update the subscriber information through Provisioning Manager, but be aware that this 
information will be pushed to the Cisco Unified Communications Manager Express system, and will 
overwrite any existing information for the user in the ephone description field. 

• If a Cisco Unified Communications Manager Express is the only device present in a Domain and 
Service Area , during Domain synchronization subscribers are not created in Provisioning Manager 
if the ephone username command is not configured in Cisco Unified Communications Manager 
Express. Make sure the ephone username command is configured in Cisco Unified Communications 
Manager Express for all subscribers.

Step 1 Select Provisioning Dashboard > Manage Subscribers > Add Subscriber. The Manage Subscriber 
page appears. 

Step 2 Click the Chooser icon ( ) next to the Subscriber ID field. The Choose a Subscriber dialog box appears. 

Tip The Provisioning Dashboard page provides a direct link to the Choose a Subscriber dialog box. 
In the Manage Subscriber pane, click View Subscribers.

Step 3 Select the subscriber that you require. The user information is populated in the Manage Subscriber page.

Step 4 Change the desired information.

Step 5 Click Update.
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Resetting Subscriber Passwords
You can reset passwords only if you have the correct privileges (see Managing Authorization Roles, page 
2-5). You can reset the following:

• Provisioning Manager login password

• Cisco Unified Communications Manager password

• Cisco Unified Communications Manager PIN

• Cisco Unity Subscriber password

Note The Cisco Unified Communications Manager password cannot be modified when the Cisco Unified 
Communications Manager is configured to use external authentication. Provisioning Manager indicates 
that the password is updated, even though it is not. 

You can either reset the password to the Provisioning Manager system default, or specify a new 
password. You can obtain the default values for the user passwords on these systems from your 
Provisioning Manager administrator, Managed Service Provider, or corporate IT department. 

The following rules control the default passwords:

• SelfcareAccountsDefaultPassword

• DefaultCallManagerPassword

• DefaultCallManagerPIN

• DefaultUnitySubscriberPassword

For more information about rules, see Business Rules, page 6-2.

Note After you reset a subscriber’s password, you must inform the subscriber of the default value that is 
required to change their password.

Step 1 Open the Manage Subscriber page for the desired subscriber (see Updating Subscriber Information, page 
2-2). 

Step 2 Click Manage Password. The Password Management page appears.

Step 3 In the Password to Modify field, select the password to be changed.

Do one of the following:

• To set the password to the default, click Reset to Default. 

• Specify a new password (and confirm it) and then click Set to New Value.

A message appears, asking you to confirm.

Step 4 Click Done.
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Managing Authorization Roles 
Table 2-1 lists the authorizations roles that are available in Provisioning Manager.

Step 1 Open the Manage Subscriber page for the desired subscriber (see Updating Subscriber Information, page 
2-2). 

Step 2 Click Manage Authorization Roles. The Assign User Authorization Roles page appears.

Step 3 Select the roles that you want to apply to the subscriber.

Step 4 Click Update.

Step 5 Click Done.

Synchronizing a Subscriber 
You can synchronize a single subscriber. The subscriber’s data in Provisioning Manager is synchronized 
with the subscriber’s data in the Call Processor. For more information about synchronizing, see 
Synchronizing Domains, page 5-13.

Note If a Cisco Unified Communications Manager Express is the only device present in a Domain and Service 
Area , during Domain synchronization subscribers are not created in Provisioning Manager if the ephone 
username command is not configured in Cisco Unified Communications Manager Express. Make sure 
the ephone username command is configured in Cisco Unified Communications Manager Express for all 
subscribers.

Step 1 Open the Manage Subscriber page for the desired subscriber (see Updating Subscriber Information, page 
2-2). 

Step 2 Click Synchronize Subscriber. A confirmation dialog box appears. The Synchronize Subscriber option 
does not appear for a subscriber until an order is placed for the subscriber.

Step 3 Click OK.

Removing a Subscriber
A subscriber cannot be removed if there are products or services in their subscriber record. The products 
or services must be canceled first.

Step 1 Open the Manage Subscriber page for the desired subscriber (see Updating Subscriber Information, page 
2-2). 

Step 2 Click Remove. 
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Accessing Subscriber Records

Step 1 Select Provisioning Dashboard > Manage Subscribers > Search Subscribers. The Search page for 
subscribers appears.

Note When searching for subscribers using a subscriber’s phone number, the Subscriber Search Result 
page only displays the contact number for a subscriber. This might not be the the number that 
was used in the search. Also, if the subscriber is assigned multiple numbers that match the 
search, a record for each number is displayed.

Tip The Provisioning Dashboard page provides a direct link to the Search page for subscribers. In 
the Manage Subscriber pane, click Search Subscribers.

Step 2 Enter the subscriber information to use for searching and click Search. The Subscriber Search Results 
page appears.

Tip Clicking the information icon ( ) opens the Manage Subscriber page for the subscriber. 

Step 3 Select the subscriber that you require. The Subscriber Record Details page appears for the subscriber. 

Working with Subscriber Roles
Subscriber roles control which products and services a subscriber can order. The subscriber role also 
dictates which Service Areas a subscriber is entitled to access. 

Note Do not confuse subscribers with users. These two roles have different meanings in Provisioning 
Manager. For a description of a user, see Managing Users, page 2-9.

The default subscriber types are: 

• Employee—Default role assigned to new subscribers 

Note The Employee subscriber role should be configured to match the typical setup of employees 
in your organization. If you do not configure the employee subscriber role to meet your 
needs, you may not see all the desired options in the employee subscriber record.

• Contractor

• Manager 

• Senior Manager 
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• Executive

• Operator 

These subscriber types exist in each Domain in Provisioning Manager. Each set of subscriber types may 
be customized in each Domain by adding, removing, or changing these predefined subscriber types. 

Creating a New Subscriber Role Type

Step 1 Select Advanced Setup > Policies > Subscriber Roles. The Subscriber Role Configuration page 
appears.

Step 2 Click New Subscriber Role.

Step 3 Do the following:

a. Enter a name for the new subscriber role.

b. Select the appropriate Domain.

c. Click Save.

The subscriber role is created, and the View Subscriber Role Type page appears.

Note After creating a role, you should associate products to the role (see Associating Products to a Subscriber 
Role Type, page 2-7).

Updating a Subscriber Role Type
The following sections describe what you can do to a subscriber role type:

• Associating Products to a Subscriber Role Type, page 2-7

• Assigning Provisioning Attribute Precedence, page 2-8

• Changing the Name of a Subscriber Role Type, page 2-8

• Editing Provisioning Attributes for a Subscriber Role Type, page 2-8

• Removing a Subscriber Role Type, page 2-9

Associating Products to a Subscriber Role Type

When products are associated to a subscriber role, the subscribers with that role can order the associated 
products (for information on ordering products, see Ordering Products and Services, page 3-2).

Step 1 Select Advanced Setup > Policies > Subscriber Roles. The Subscriber Role Configuration page 
appears.

Step 2 In the Domain field, select the Domain where the subscriber role type exists.

Step 3 Click Choose Role to View. The Choose a Subscriber Role Type dialog box appears.

Step 4 Click the desired subscriber role type. The View Subscriber Role Type page appears.
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Step 5 Click Associate Products. The Associate Products page appears.

Step 6 Click the check box next to the products that you want to associate to the subscriber role type.

Step 7 Click Save.

Assigning Provisioning Attribute Precedence

When a subscriber belongs to multiple subscriber role types, the precedence setting determines which 
subscriber type’s provisioning attribute settings to use.

Step 1 Select Advanced Setup > Policies > Subscriber Roles. The Subscriber Role Configuration page 
appears.

Step 2 In the Domain field, select the Domain where you want to change provisioning attribute precedence.

Step 3 Click Assign Provisioning Attribute Precedence. The Assign Precedence page appears.

Step 4 Click the arrows next to a subscriber role type to move it up or down in the order of precedence.

Step 5 Click Save.

Changing the Name of a Subscriber Role Type

Step 1 Select Advanced Setup > Policies > Subscriber Roles. The Subscriber Role Configuration page 
appears.

Step 2 In the Domain field, select the Domain where the subscriber role type exists.

Step 3 Click Choose Role to View. The Choose a Subscriber Role Type dialog box appears.

Step 4 Click the desired subscriber role type. The View Subscriber Role Type page appears.

Step 5 Click Update. The Update Subscriber Role Type page appears.

Step 6 Change the subscriber role type name.

Step 7 Click Save.

Editing Provisioning Attributes for a Subscriber Role Type

Step 1 Select Advanced Setup > Policies > Subscriber Roles. The Subscriber Role Configuration page 
appears.

Step 2 In the Domain field, select the Domain where the subscriber role type exists.

Step 3 Click Choose Role to View. The Choose a Subscriber Role Type dialog box appears.

Step 4 Click the desired subscriber role type. The View Subscriber Role Type page appears.

Step 5 Click Edit Provisioning Attributes. The Provisioning Attribute Management page appears.
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Step 6 Click the plus sign next to the attribute heading that you want to edit.

• To edit an attribute’s information, click the Edit icon ( ) next to the attribute and make the desired 
changes.

• To remove the attribute, click the Clear icon ( ) next to the attribute.

Step 7 Click Done.

Removing a Subscriber Role Type

Step 1 Select Advanced Setup > Policies > Subscriber Roles. The Subscriber Role Configuration page 
appears.

Step 2 In the Domain field, select the Domain where the subscriber role type exists.

Step 3 Click Choose Role to View. The Choose a Subscriber Role Type dialog box appears.

Step 4 Click the desired subscriber role type. The View Subscriber Role Type page appears.

Step 5 Click Remove. A confirmation dialog box appears.

Step 6 Click OK. The subscriber role type is removed.

Managing Users
Users in Provisioning Manager represent logins to the system for people who can access Provisioning 
Manager to perform various activities. Users can be permitted to perform various roles within 
Provisioning Manager. These roles can be system-wide (for example, administrators), or they can be 
associated to a single Domain, which limits the scope of changes that the user can make.

Note A user can also be a subscriber.

This section describes the following:

• Creating Users, page 2-10

• Updating User Information, page 2-10

• Resetting User Passwords, page 2-11

• Managing Authorization Roles, page 2-11

• Synchronizing Users, page 2-13

• Removing a User, page 2-13

• Accessing Subscriber Records for a User, page 2-13
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Creating Users

Step 1 Select System Administration > Manage Users. The Manage User page appears. 

Step 2 Do the following:

• Select a Domain.

• Enter a user ID.

• Enter the user’s name.

• (Optional) Enter the user’s phone number.

• (Optional) Enter the user’s email address.

• (Optional) Enter the user’s department.

Step 3 Click Create. The user is created. You can now update any of the user information.

Updating User Information
Once a user is created you can use the Manage User page to change the following information:

• User’s name.

• User’s phone number.

• User’s email.

• User’s department.

• Roles.

Also, you can do the following:

• View subscriber’s record.

• Order services for the subscriber.

• Set or modify passwords.

• Manage authorization roles.

• Synchronize subscribers. This option does not appear until an order is placed for the user.

Step 1 Select System Administration > Manage Users. The Manage User page appears. 

Step 2 Click the Chooser icon ( ) next to the User ID field. The Choose a User dialog box appears. 

Step 3 Select the user that you require. The user information is populated in the Manage User page.

Step 4 Change the desired information.

Step 5 Click Update.
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Resetting User Passwords
You can reset passwords only if you have the correct privileges (see Managing Authorization Roles, page 
2-5). You can reset the passwords for the following:

• Provisioning Manager login

• Cisco Unified Communications Manager 

• Cisco Unified Communications Manager PIN

• Cisco Unity subscriber 

Note The Cisco Unified Communications Manager password cannot be modified when the Cisco Unified 
Communications Manager is configured to use external authentication. Provisioning Manager indicates 
that the password is updated, even though it is not. 

You can either reset the password to the Provisioning Manager system default, or specify a new 
password. You can obtain the default values for the user passwords on these systems from your 
Provisioning Manager administrator, Managed Service Provider, or corporate IT department. 

The default user passwords are controlled by the following rules (see Business Rules, page 6-2):

• SelfcareAccountsDefaultPassword

• DefaultCallManagerPIN

• DefaultCallManagerPassword

• DefaultUnitySubscriberPassword

Note After resetting a user’s password, you must inform the user of the new value that was set.

Step 1 Open the Manage User page for the desired user (see Updating User Information, page 2-10). 

Step 2 Click Manage Password. The Password Management page appears.

Step 3 In the Password to Modify field, select the password to be changed.

Do one of the following:

• To set the password to the default, click Reset to Default. 

• Specify a new password (and confirm it) and then click Set to New Value.

A message appears, asking you to confirm.

Step 4 Click Done.

Managing Authorization Roles 
Table 2-1 lists the authorization roles that are available in Provisioning Manager.

Note Global roles apply system-wide and Domain roles only apply to the Domains the user belongs to.
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Step 1 Open the Manage User page for the desired user (see Updating User Information, page 2-10). 

Step 2 Click Edit next to the assigned role field. The Assign User Authorization Roles page appears.

Tip To access the Assign User Authorization Roles page, you can also click Manage Authorization 
Roles.

Step 3 Select the roles that you want to apply to the user.

Table 2-1 Authorization Roles

Authorization Role Description

Global

Administration Has access to all Provisioning Manager functionality.

Maintenance Authorized to configure system cleanup activities.  See Maintaining Data, page 
7-5.

Domain

Policy Authorized to modify phone button templates and subscriber roles, and add or 
update phone inventory. 

Ordering Roles Users assigned these roles are allowed to place orders for other subscribers and 
themselves.

Ordering Authorized to:

• Add, delete, or update a subscriber within a Domain.

• Add, delete, or update a subscriber role within a Domain (if the rule for that 
Domain permits it).

• Add, delete, or update phones in the inventory within a Domain (if the rule 
for that Domain permits it).

• Search and view detailed subscriber information within a Domain.

• Place an order for a subscriber within a Domain.

Advanced 
Ordering

Authorized to access all the functionality specified by the Ordering role; can also 
access Advance Order Options in the Order Entry page.

Advanced 
Assignment

Authorized to access all the functionality specified by the Ordering role, and to 
assign the MAC address for a phone product at the time of order entry.

Activity Roles Users assigned one of these roles can perform activities assigned to the group 
during order processing.

Approval Authorized to accept and complete the approval for orders.

Assignment Authorized to accept the user activity for assigning the MAC address. 

Shipping Authorized to accept and complete shipping of orders. 

Receiving Authorized to accept and complete receiving of orders. 
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Step 4 Click Update.

Step 5 Click Done.

Synchronizing Users 
If the user is also a subscriber, you can synchronize the user. The user’s data in Provisioning Manager is 
synchronized with the user’s data in the Call Processor. For more information about synchronizing, see 
Synchronizing Domains, page 5-13.

Step 1 Open the Manage User page for the desired user (see Updating User Information, page 2-10). 

Step 2 Click Synchronize Subscriber. A confirmation dialog box appears. The Synchronize Subscriber option 
does not appear for a user until an order is placed for the user.

Step 3 Click OK.

Removing a User 

Step 1 Open the Manage User page for the desired user (see Updating User Information, page 2-10). 

Step 2 Click Remove. A confirmation dialog box appears.

Step 3 Click OK.

Accessing Subscriber Records for a User

Step 1 Open the Manage User page for the desired user (see Updating User Information, page 2-10). 

Step 2 Click View Subscriber Services. The Subscriber Record Details page for the user appears.
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Managing Orders

This chapter provides details on creating orders for Provisioning Manager products and services, 
processing orders, and changing and canceling existing products and services.

All changes to the underlying systems are made through a two-stage process of creating an order and 
then processing the order. You can set policies for both of these stages. For example, you can configure 
the system so that one group of users can only create and submit orders, while another group of users 
can view and perform processing-related activities. Provisioning Manager contains an automation 
engine which performs the order processing, including service activation and business flow based on 
how Provisioning Manager is configured.

Order management is described in the following sections:

• Viewing Orders, page 3-1

• Ordering Products and Services, page 3-2

• Processing Orders, page 3-17

• Canceling Products, page 3-19

Viewing Orders
Orders for a subscriber are displayed in the Subscriber Record page for that subscriber.

Accessing a Subscriber Record
If you are assigned the Ordering authorization role, you can access your own subscriber record, and the 
subscriber records of other users. 

Step 1 Select Provisioning Dashboard > Manage Subscribers > Search Subscriber. The Search page 
appears. 

Step 2 Click the desired subscriber. The Subscriber Record page for the selected subscriber appears.

Tip The Provisioning Dashboard page provides a direct link to the Search page. In the Manage 
Subscriber pane, click Search Subscribers.
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Ordering Products and Services
Using Order Manager, you can create orders for telephone equipment and services. You can create orders 
for individual products, or you can order bundled products and services. 

The length of time it takes to provision an order can vary. To verify if the order has successfully 
completed, go to the subscriber record of the user (see Accessing a Subscriber Record, page 3-1). The 
products are listed in the Subscriber Record Details section, and the View Orders section shows the order 
with the status as Complete. Also, you can perform an order search for the order number.

Note Users assigned the Ordering authorization role can add, change, or cancel their own orders or those of 
other subscribers. 

Table 3-1 describes the various Provisioning Manager products and services that you can order. 

Table 3-1 Provisioning Manager Products and Services

Product or Service Description

Enable CUPC License Enables a subscriber with a Cisco Unified Personal Communicator and 
Cisco Unified Presence Server license on the currently selected Call 
Processor. This product can be ordered only once per subscriber on the 
same Call Processor.

Cisco Unified Personal Communicator enables users to use their PCs 
to make phone calls, provides presence information, and can control 
desktop phones.

When ordering softphone support, you must specify a device name that 
is unique on the Call Processor. The device name can be up to twelve 
letters (A-Z) or numbers (0-9) long. Lowercase letters will be 
converted to uppercase.

To order Cisco Unified PersonalCommunicator, you must order a 
physical Phone product, and select Cisco Unified 
PersonalCommunicator as the type of phone. After the order completes 
successfully, the user account will be synchronized to the Cisco 
Unified Presence Server from the Cisco Unified Communications 
Manager.

Note This product is available only for Cisco Unified 
Communications Manager 6.0.x and later.

Enable Mobility Support Enables Mobility for the selected subscriber on the currently selected 
Call Processor.

When ordering using default parameters, the following provisioning 
attributes are used:

Enable Mobility: True

Enable Mobile Voice Access: True

Max Desk Pickup Wait Time: 1000ms

Remote Destination Limit: 4

Note This product is available only for Cisco Unified 
Communications Manager 6.0.x and later.
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Enable SoftPhone Support Softphone support enables users to use their PCs either in conjunction 
with a physical phone (both would ring at the same time), or to run a 
CTI port, which is a virtual phone (one that is defined on the Cisco 
Unified Communications Manager but does not physically exist).

Note Cisco Unified Communications Manager Express does not 
support SoftPhone. You will not be able to order this product 
when placing orders on a Call Processor based on a Cisco 
Unified Communications Manager Express.

Note If you already have softphone support on all your available Call 
Processors, the Enable SoftPhone Support product will not 
appear in your product list. If there is a Call Processor available 
to you, then a list of valid Service Areas appears for the specific 
Call Processor.

When ordering softphone support, you must specify the server name or 
IP address of the user’s computer in the Associated PC field.

Although you enable softphone support based on Service Area, you can 
enable SoftPhone support only once per Cisco Unified 
Communications Manager, even if there are more Service Areas 
associated with the Cisco Unified Communications Manager.

Note The SoftPhone Support product applies to a Cisco Softphone 
that uses a CTI port. Cisco IP Communicator is another type of 
softphone application that does not use CTI ports to 
communicate with the Cisco Unified Communications 
Manager, but acts as a regular hard phone with a MAC address. 
To order Cisco IP Communicator, you must order a physical 
Phone product, and select IP Communicator as the type of 
phone.

Enhanced Phone Service Includes a phone, phone line, and voicemail. The line is automatically 
associated with the phone that you ordered, and the voicemail is 
automatically associated with the line.

Note When placing an order for Enhanced Phone Service on a Cisco 
Unified Communications Manager Express, you must enter the 
call-forward provisioning attributes. When entering an order, 
click the Advanced Orders Option button and in the Voicemail 
Configuration Template provisioning attribute, enter the 
following commands:

 call-forward busy <voice mail port/dn>
 call-forward noan <voice mail port/dn>  timeout 
<seconds>

Note For a Cisco Unity Express Service Area, enter only 
alphabetical characters in the Voice Mail Display Name field. 
If you use other types of characters, orders for the subscriber 
will fail. 

Table 3-1 Provisioning Manager Products and Services (continued)

Product or Service Description
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Extension Mobility Access or 
Access with Line

Enables users to log into a specific phone type and have their phone 
device profile applied to it. This product is available either by itself, or 
bundled with a line.

Note Extension Mobility is available for ordering only if the optional 
extension mobility details are entered for a Call Processor 
when it is added to Provisioning Manager.

Note Extension Mobility is not supported on Cisco Unified 
Communications Manager Express or Cisco Unified 
Communications Manager 4.0.

Extension Mobility Line The directory number/line ordered for a device profile on a Cisco 
Unified Communications Manager. It can be ordered as an upgrade 
when the user already has Extension Mobility Access.

Note Extension Mobility is not supported on Cisco Unified 
Communications Manager Express or Cisco Unified 
Communications Manager 4.0.

Line You can create an order to add a line or directory number for a user who 
already has a phone. No shipping, assignment, receipt, or tracking (for 
returns) steps are required for provisioning a new Line product. 

Note The Upgrade designation next to the Line product indicates that 
a line is being ordered for an existing phone.

Note For Call Processors the display for a line cannot exceed 30 
characters. Make sure that the combination of characters for 
First Name and Last Name does not exceed 30 characters. If 
this limit is exceeded, when you place an order, the Call 
Processor sends an error.

Line on a Shared Phone You order a Line on a Shared Phone when users require their own 
separate lines on the same physical phone. When this product is 
provisioned, the phone and all lines on it are displayed in each of the 
user’s subscriber record.

The Shared icon ( ) appears next to the phone that is shared in the 
subscriber record. 

Messaging Service Consists of a phone, phone line, voicemail, and email. 

Phone You can order a phone that does not have a line or a directory number 
associated with it. 

Phone Service Consists of a phone and a phone line. 

Phone Service with Extra 
Line

The same as Phone Service with an additional line.

Table 3-1 Provisioning Manager Products and Services (continued)

Product or Service Description
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Voicemail and Email (bundle) You can create orders for additional Voicemail and Email products if 
the user already has a line. 

Note The Upgrade designation next to the Voicemail and Email 
Service product indicates that the line product is being 
upgraded to include voicemail and email. 

Note When placing an order for voicemail on Cisco Unified 
Communications Manager Express, you must enter the 
call-forward provisioning attributes. When entering an order, 
click the Advanced Orders Option button and in the Voicemail 
Configuration Template provisioning attribute, enter the 
following commands:

 call-forward busy <voice mail port/dn>
 call-forward noan <voice mail port/dn>  timeout 
<seconds>

Voicemail (individually) You can create orders for additional Voicemail products if the user 
already has a line.

Note The Upgrade designation next to the voicemail product 
indicates that the Line product is being upgraded to include 
voicemail. 

Note When placing an order for voicemail on a Cisco Unified 
Communications Manager Express, you must enter the 
call-forward provisioning attributes. When entering an order, 
click the Advanced Orders Option button and in the Voicemail 
Configuration Template provisioning attribute, enter the 
following commands:

 call-forward busy <voice mail port/dn>
 call-forward noan <voice mail port/dn>  timeout 
<seconds>

Email (individually) You can create orders for additional Email products if the user already 
has a line and voicemail.

Note The Upgrade designation next to the Email product indicates 
that the Line product is being upgraded to include email. 

Table 3-1 Provisioning Manager Products and Services (continued)

Product or Service Description
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Note When placing orders for products and services on a Unified Message Processor based on Cisco Unity 
devices (Cisco Unity, Cisco Unity Connection, and Cisco Unity Express), not all the products and 
services are available. This is because the devices do not support all products and services. Table 3-2 
lists the orderable and nonorderable voice products and services for Cisco Unity devices.

Unified Messaging You can create an order to add the Unified Messaging feature if you 
already have email and voicemail. The Unified Messaging feature 
allows the retrieval of email from your voicemail, and the retrieval of 
voicemail from your email. In Cisco Unity, you will be enabling the 
Text-to-Speech (TTS) capability. In Cisco Unity Connection, you will 
be enabling the TTS and Internet Mail Access Protocol (IMAP) 
capability.

Note The Upgrade designation next to the Unified Messaging 
product indicates that the existing email and voicemail are 
being upgraded to include the Unified Messaging feature. 

Unified Messaging Service A Unified Messaging Service order includes the Line, Phone, 
Voicemail and Email, and Unified Messaging products.

The list of products and services that are available to users is based on 
user roles and Provisioning Manager system configuration. To modify 
this list to include the products and services you require, contact your 
Provisioning Manager administrator. 

Table 3-1 Provisioning Manager Products and Services (continued)

Product or Service Description
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Example Order Procedure

Creating orders for all products and services follows the same basic procedure. This example shows the 
procedure for ordering Unified Messaging Service. 

A user might not have access to all products and services. The list of products and services that appear 
in a given user’s subscriber record depends on the following:

• User role assigned to the user, and the Domains and Service Areas available to the user.

• Availability of resources to support delivery within the Service Areas (for example, a Cisco Unity 
or Cisco Unity Connection system must be available to provide Unified Messaging).

• Provisioning Manager system configuration.

• Product dependencies:

– Line requires an existing Phone.

Table 3-2 Supported Cisco Unity Products and Services

Cisco Unity Device Products and Services

Cisco Unity Orderable:

• Voicemail and Email (bundle)

• Unified Messaging

• Unified Messaging Service

• Messaging Service

Not orderable:

• Voicemail or Email individually 

• Enhanced Phone Service

Cisco Unity Connection Orderable:

• Voicemail and Email (bundle)

• Voicemail or Email individually 

• Enhanced Phone Service 

• Unified Messaging 

• Unified Messaging Service

• Messaging Service

Cisco Unity Express Orderable:

• Enhanced Phone Service 

• Voicemail

Not orderable:

• Unified Messaging 

• Unified Messaging Service 

• Voicemail and Email (bundle)

• Email individually

• Messaging Service
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– Voicemail and Email require an existing Line.

– Unified Messaging requires Email.

– Extension Mobility Line requires Extension Mobility Access.

Table 3-3 describes the various fields for ordering products and services. When these fields appear 
during the order process, they are always required.

.
Table 3-3 Order Entry Fields

Field/Button Description

Associated PC The name (DNS resolvable) or IP address of the computer to be used with 
the SoftPhone support.

Email ID Enter the email ID. It cannot contain spaces.

Display Name (Email) Enter the name to be used in the From field of the email.

Enable Extension Mobility Select Yes or No.

Extension Mobility Line Select one of the following:

Auto-assigned—System automatically assigns a directory number.

Chosen Line—User specifies a directory number. The directory number 
cannot include dashes or spaces.

Line Select one of the following:

Auto-assigned—System automatically assigns a directory number.

Chosen Line—User specifies a directory number. The directory number 
cannot include dashes or spaces.

Directory Number Enter a directory number for the line.

Line Position The possible line positions appear, indicating whether lined are occupied 
or available.

If you select an occupied position (for example, position 2), Provisioning 
Manager shuffles the existing positions according to the following:

• If there is an available position (for example, position 5), after a 
position is selected, all the occupied lines from the selected position 
to the last occupied position are pushed one position down (for 
example, 2 is pushed to 3, 3 is pushed to 4; 4 is pushed to 5). The new 
line is added into the selected position (position 2).

• If there is not an available position after the selected position, and 
there is an available position before the selected position (for 
example, position 1), the new line is added into position 1. The 
existing lines do not shuffle.

Note Line position is not supported on Cisco Unified Communications 
Manager Express or Extension Mobility Access Lines.

MAC Address (Optional) Select a MAC address or enter one.

Phone Type Select a phone type from the list.

Target Phone Select a target phone from the list.

Phone Button Template List of available Phone Button Templates.

Service Area List of available Service Areas.
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Step 1 Select Provisioning Dashboard > Manage Orders > Order Subscriber Services. The Search 
Subscribers for Ordering Services page appears. 

Tips

• You can choose a subscriber from the Choose a Subscriber dialog box. The dialog box appears when 
you click Order Subscriber Services in the Manage Orders pane of the Provisioning Dashboard 
page (appears when you click the Provisioning Dashboard tab). 

• You can start a new order from the Subscriber Record page by clicking New Order.

Step 2 Enter subscriber information to search on, then click Search. The results of your search appear.

Step 3 Click the desired subscriber. The product catalog appears.

Step 4 Click the product that you want to order. You may need to scroll down to locate the desired product.

The Order Entry wizard appears in the bottom pane.

Step 5 Follow the Order Entry wizard, entering the required information for the product.

When placing orders, note the following:

• If more than one Service Area is available, the system provides a drop-down list for you to choose 
from.

• The Advance Order Options button enables you to access provisioning attributes for the ordered 
service or product. Only users assigned the Advanced Order or Administrator authorization role can 
access the Advanced Order options. For information on provisioning attributes, see Configuring 
Provisioning Attributes, page 6-13.

Step 6 Click Confirm to start the order process.

Step 7 After you click Done, the order number appears in the View Orders section of the subscriber record.

Unified Messaging List of available emails to enable Unified Messaging for.

Voicemail Alias Enter an alias for the voicemail.

Voicemail Display Name Enter a display name for the voicemail.

Advanced Order Options Clicking this button opens the Provisioning Attribute Management page 
for the ordered service or product. This allows you to set provisioning 
attributes when placing an order (for more details on provisioning 
attributes, see Configuring Provisioning Attributes, page 6-13). 

Note The Advanced Order Options button is available only to users who 
are assigned the Advanced Ordering authorization role. 

Table 3-3 Order Entry Fields (continued)

Field/Button Description
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Ordering Shared Phones and Lines
You can configure both shared phones and lines within Provisioning Manager. The following scenarios 
are possible:

• Common shared line—Multiple users share the same line from different phones.

• Primary shared line—Multiple users share the same line from different phones, but one user’s line 
display is used for all users (for example, a help desk). Users can also have their own lines separate 
from the shared line.

• Shared phone—Multiple users share the same phone, but have separate lines from that phone.

Note When ordering shared lines and phones, remember the following:

• If the second subscriber orders a line on a shared phone that already has a line with voicemail, email, 
and unified messaging, he will not see these products for the first line in his subscriber record. This 
also occurs when a shared line is ordered.

• If the second subscriber deletes a shared phone, it is still displayed in the subscriber record for the 
first subscriber, and it is still present in Cisco Unified Communications Manager. But if the second 
subscriber deletes any lines on the shared phone, those lines are deleted from the subscriber record 
for the first subscriber and from Cisco Unified Communications Manager.

• If the second subscriber deletes a shared line, it is deleted from the second subscriber's phone on 
Cisco Unified Communications Manager. But it is still displayed in the subscriber record for the first 
subscriber, and is still present in the first subscriber's phone on Cisco Unified CallMananger. 

• The first subscriber should not order a new voicemail for the second subscriber's line (which 
displays a voicemail in its own customer record). This second voicemail will fail on Cisco Unity 
because a voicemail already exists with the same directory number.

• Provisioning Manager does not use the directory number provisioning attributes that are set for the 
shared line. Even though, these provisioning attributes can be entered through the Advanced Order 
Options, they will be ignored. The Directory Number attributes for the existing line are applied to 
the new shared line. 

The directory number attributes available for a line are:

– AAR Group

– Auto Answer

– Call Pickup Group

– Calling Search Space

– Forward All

– Forward Busy Internal

– Forward Busy External

– Forward No Answer Internal

– Forward No Answer External

– Forward No Coverage Internal

– Forward No Coverage External

– Unregistered Internal

– Unregistered External 
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– MLPP Calling Seach Space

– MLPP No Answer Ring Duration

– MLPP Target

– Network Hold Audio Source

– No Answer Ring Duration 

– Route Partition 

– User Hold Audio Source 

– Voicemail Profile 

Setting Up a Common Shared Line

You can configure a scenario where multiple users share the same directory number by using lines on 
their own phones:

• Each user’s name is displayed on the shared line on their own phone.

• Caller ID displays the user’s name when they call other people.

• Each user’s own phone and the shared line are displayed in their own subscriber record.

Example Procedure for Setting Up a Common Shared Line

Step 1 Select Provisioning Dashboard > Manage Orders > Order Subscriber Services. The Search 
Subscribers for Ordering Services page appears. 

Tip You can choose a subscriber from the Choose a Subscriber dialog box. The dialog box appears 
when you click Order Subscriber Services in the Manage Orders pane of the Provisioning 
Dashboard page (appears when you click the Provisioning Dashboard tab).

Step 2 Enter subscriber information to search on, then click Search. The results of your search appear.

Step 3 Click the desired subscriber. The product catalog appears.

Step 4 Click Line Upgrade.

Note You may need to scroll down to find the product you want.

The Order Entry wizard appears in the bottom pane.

Step 5 Click Continue to start the order process.

Step 6 Do the following:

• Select Chosen Line.

• Specify the directory number for the shared line.

• Select the Line Position for the line.
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Step 7 Click Confirm.

Step 8 Repeat for each of the remaining users.

Setting Up Primary Shared Lines

You can configure a scenario where multiple subscribers share the same line from their own phones, but 
the primary subscriber’s line display takes precedence over the others:

• One primary user, and one or more secondary users, can all share the same line.

• The primary user’s line display appears on the shared line on all the subscriber’s phones.

• When a secondary subscriber makes calls using the shared line, the caller ID displays the primary 
subscriber’s line display.

• Subscriber records for secondary subscribers display the shared line as well as their own individual 
lines.

• Subscriber records for the primary subscriber display all three shared phones and all three lines as 
well as the lines of the individual subscribers.

Example Procedure for Setting Up a Primary Shared Line

In this scenario, the Help Desk is the primary user that shares a line with secondary users 1 and 2.

.

Note For all phones, ensure that you choose a phone model that has capacity for the shared line.

Step 1 Select Provisioning Dashboard > Manage Orders > Order Subscriber Services. The Search 
Subscribers for Ordering Services page appears. 

Tip You can choose a subscriber from the Choose a Subscriber dialog box. The dialog box appears 
when you click Order Subscriber Services in the Manage Orders pane of the Provisioning 
Dashboard page (appears when you click the Provisioning Dashboard tab).

Step 2 Enter subscriber information to search on, then click Search. The results of your search appear.

Step 3 Click User 1. The product catalog appears.

Step 4 Click Phone Service and specify the directory number as 321 (see Ordering Products and Services, page 
3-2). 

Step 5 Repeat Step 1 through Step 4 for User 2, but specify the directory number as 345.

Step 6 Repeat Step 1 through Step 4 for Primary User (Help Desk), but specify the destination number as 123. 

Step 7 Repeat Step 1.

User Line Display Destination Number

Primary User Help Desk 123

User 1 User 1 321

User 2 User 2 345
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Step 8 Click Primary User.

Step 9 Select a new Line on Shared Phone, making sure to do the following:

• Select Chosen Line.

• Specify 123 for the directory number.

• Select the MAC address for User 1’s phone.

Step 10 Repeat Step 8, making sure to do the following:

• Select Chosen Line.

• Specify 123 for the directory number.

• Select the MAC address for User 2’s phone.

Setting Up a Shared Phone

You can configure a scenario where two or more subscribers share the same phone, but have their own 
lines and line display information:

• Each subscriber’s line display shows up on their line on the shared phone.

• Caller ID displays the appropriate subscriber’s line display when they call other people.

• Each subscriber’s subscriber record lists the shared phone, their own line, and the other subscriber’s 
line.

Step 1 Select Provisioning Dashboard > Manage Orders > Order Subscriber Services. The Search 
Subscribers for Ordering Services page appears. 

Tip Alternatively, you can choose a subscriber from the Choose a Subscriber dialog box. The dialog 
box appears when you click Order Subscriber Services in the Manage Orders pane of the 
Provisioning Dashboard page (appears when you click the Provisioning Dashboard tab).

Step 2 Enter subscriber information to search on, then click Search. The results of your search appear.

Step 3 Click the desired subscriber. The product catalog appears.

Step 4 Click Phone Service (see Ordering Products and Services, page 3-2). Make note of the MAC address of 
the phone.

Note You must order a phone that supports two lines.

Step 5 Repeat Step 1 and Step 3 for the second subscriber.

Step 6 Click Line on Shared Phone. In the Target Phone field, select the MAC address of the first subscriber’s 
phone.

In the subscriber record a Shared icon ( ) appears next to the shared phone.
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Changing Existing Phones
You can submit an order to replace an existing phone for a subscriber. You can pick the same phone type, 
or choose from a list of other available phone types for the subscriber. The phone types that subscribers 
have access to are determined by their subscriber role, and the number of lines on the phone that you are 
replacing. Phones that do not support the required number of lines are not available during the change 
order process. 

When a phone is changed, all of its lines are transferred to the new phone. The Service Area assigned to 
the new phone is the same as for the original phone. 

Note Users with the ordering authorization role can change their own phones, or those of other subscribers.

Note When placing a change phone order, remember the following:

• Any attributes that are not supported by Provisioning Manager and exist on the phone before placing 
a change phone order will either be reset to their default values or dropped from the phone. For a 
list of supported attributes in Provisioning Manager, see Table 6-1, Provisioning Attribute 
Descriptions.

• Only services that are configured for the Domain will be kept after a phone change order is 
performed. If any other services existed on the phone, they will be dropped. For a description of the 
service’s business rules, see DefaultServiceName<1-5>, page 6-5 and DefaultServiceURL<1-5>, 
page 6-5.

Tip You can also use this process to change phone attributes (for example, provisioning attributes through 
the Advance Order Options) if you select the same phone type and the same MAC address.

Step 1 Select Provisioning Dashboard > Manage Subscribers > Search Subscriber. The Search page 
appears. 

Tip You can access the Search page by clicking Search Subscribers in the Manage Subscribers pane 
of the Provisioning Dashboard page (appears when you click the Provisioning Dashboard tab).

Step 2 Enter subscriber information to search on, then click Search. The results of your search appear.

Step 3 Click the desired subscriber. The Subscriber Record page for the selected subscriber appears.

Step 4 In the Products pane, click the phone that you want to change. The option buttons appear. 

Step 5 Click Change. The Order Entry pane appears, displaying a description of the original order. 

Step 6 Click Continue. The Configure Product pane appears. 

Step 7 From the Phone Type list, select the new phone. Depending on the type of phone, a picture and/or other 
phone options are displayed. 

Step 8 Click Continue. The Order Entry Order Confirmation pane appears. 

Step 9 Click Confirm. The Confirmation of Order message appears. 
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Step 10 Click Done. The order appears in the View Orders pane of the subscriber record.   

Note In the Products column, an information icon ( ) appears next to the product that you have 
changed. It indicates that the product has an order running against it. When the order has been 
processed, the information icon disappears. 

Changing Owners of Phones
You can change the ownership of a phone from one subscriber to another subscriber in the same Domain. 
When you change ownership of a phone, all products associated to the phone (Line, Email, Voicemail, 
Unified Messaging, and so on) are also changed. You can enter different values for the Email ID and 
Display Name, if applicable (users with the Advanced Ordering role can make these changes, either to 
their own phones, or to those of other subscribers). The Service Area assigned to the new owner is the 
same as the original owner.

Note If you do not change the email ID, email display name, voicemail alias, or voicemail display name, the 
services on the Call Processor and Unified Message Processor do not change. Only the subscriber 
records in Provisioning Manager for the old and new owner are changed. But if any of these settings are 
changed, the voicemail and email accounts on the Call Processor and Unified Message Processor are 
deactivated and then reactivated.

Note If a phone is shared, you cannot change owners of the phone. The Change Owner button is not displayed.

Step 1 Select Provisioning Dashboard > Manage Subscribers > Search Subscriber. The Search page for 
subscribers appears. 

Step 2 Enter the search information. Click Search.

Step 3 Click the desired subscriber. The Subscriber Record page for the selected subscriber appears.

Step 4 In the Products pane, click the phone that you want to change. The product options appear. 

Step 5 Click Change Owner. The Review Products pane appears, displaying a list of the associated products. 

Step 6 Click Continue. The Choose a New Owner pane appears. 

Note If there are open orders against any of the associated products, a warning message appears, and 
you cannot continue.

Step 7 In the Choose New Owner field, click the Chooser icon ( ). The Choose a User dialog box appears. 

Step 8 Select a user. The user ID of the new user appears in the Choose New Owner field.

Step 9 If the phone has voicemail or email associated with it, you can change the following:

• Voicemail alias

• Voicemail display name
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• Email ID

• Email display name

Step 10 Click Continue. The Change Owner Confirmation pane appears. 

Step 11 Click Submit. The Confirmation of Order message appears. 

Step 12 Click Done. The order appears in the View Orders section of the new owner’s subscriber record. 

Searching for an Order
You can search for orders using any of the following information:

• Order information:

– Order number

– Author—Person who placed the order

– Order status

– Extended status—The state that the order is in (for example, being provisioned, waiting for 
approval, or waiting to ship)

• Subscriber information:

– Login

– First or last name

– Phone number

– Email

– Department

– Domain

• Order date

• Requested delivery date

Step 1 Select Provisioning Dashboard > Manage Orders > Search Order. The Search page appears.

Step 2 Enter the search information.

Step 3 Click Search.

Ordering Bulk Services
If you are deploying a large number of services, you may want to combine these activities into a single 
activity. The batch provisioning functionality of Provisioning Manager enables you to create a single 
batch that contains multiple types of orders. You can also combine multiple types of services into a single 
batch operation. 
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You can access the Batch Provisioning page through the Provisioning Dashboard 
(Provisioning Dashboard > Manage Orders > Order Bulk Services).

For detailed information on batch provisioning, see Using Batch Provisioning, page 5-42.

Processing Orders
After you have submitted orders for subscribers, they are approved and then shipped. Depending on how 
your Provisioning Manager system has been configured, these steps may be automatic or may require 
processing by users. 

There are four possible activities that can be assigned to users during the order processing stage. The 
activities are assigned based on the rules set for the Domain. For more information on rules, see Business 
Rules, page 6-2. 

The four activities are described in the following:

Note A Provisioning Manager administrator can change this behavior.

• Approve orders—Approves orders before provisioning can occur, and can also reject orders. This 
user must be assigned the Approval authorization role. This is controlled by the following rules:

– IsAuthorizationRequiredForAddOrder

– IsAuthorizationRequiredForChangeOrder 

– IsAuthorizationRequiredForCancelOrder

• Assignment—Assigns phones to a phone order by providing the MAC address. This user must be 
assigned the Assignment authorization role. This is controlled by the rule 
PhoneAssignmentDoneBy.

• Shipping—Ships the order. This user must be assigned the Shipping authorization role. This is 
controlled by the rule PhoneShippingDoneBy.

• Receiving—Done by the user who has the Receiver user role. Indicates that an ordered phone has 
been received. This is controlled by the rule PhoneReceiptDoneBy.

Approving Orders
If your administrator has enabled approval, orders must be approved. To approve orders, you must be 
assigned the Approval authorization role (see Managing Authorization Roles, page 2-5).

After an order is approved or rejected, an email will be sent to the subscriber for whom the order was 
placed. The following business rules must be enabled for the email to be sent (see Business Rules, page 
6-2):

• EmailSender 

• MailHost

• OrderProvisionedEmailTemplate

• OrderRejectedEmailTemplate
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The email will be sent to the email account configured for the subscriber (see Updating User 
Information, page 2-10).

Note If an order is rejected, the order status is set to Cancel in the subscriber record, and no provisioning is 
performed. If the order encounters a problem and the user chooses to abort the remainder of the order in 
the error handling workflow step, then the order status is set to Hold.

Step 1 Select Provisioning Dashboard > Manage Activities > My Activities. The My Activities page appears. 

Step 2 Click the order that you want to process. The Viewing Activity page appears. 

Step 3 Click Accept. The Viewing Activity page appears with the Add a Note field added.

Note You can also decline the order, or delegate it to another user or group. If you delegate the activity, 
the new user or group is assigned the activity.

Step 4 If required, in the Add a Note field, type any additional information that you want to add to the order.

Step 5 Click Approve. The My Activities page appears.

Shipping Phones
Depending on how your Provisioning Manager system is configured, this step may not be required. If 
your administrator has enabled shipping, you must be assigned the Shipping authorization role to 
perform this procedure (see Managing Authorization Roles, page 2-5). Shipping phones consists of two 
parts: assigning MAC addresses and shipping.

Step 1 Select Provisioning Dashboard > Manage Activities > My Activities. The My Activities page appears. 

Step 2 Select the order that you want to ship. The Viewing Activity screen appears. 

Step 3 Click Accept. The Viewing Activity Phone Assignment page appears with the MAC Address field 
active. 

Step 4 In the MAC Address field, type a hexadecimal value. Valid characters are 0-9, A-F, and a-f. The value 
must be 12 characters in length.

Note The MAC address is available on a sticker on the phone set, and on the phone setting display on 
the handset.

Step 5 After you have added the required information, click Step Complete. The My Activities page appears.

Step 6 Click the Refresh icon ( ). The order appears in the My Activities page. 

Step 7 Click the same order. The Viewing Activities Form page appears. 

Step 8 Click Accept. The Viewing Activity Form page changes. 

Step 9 Click Step Complete. If you did not create the order, the order no longer appears on the My Activities 
page. 
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Receiving Phones
If your administrator has enabled receiving, you must be assigned the Receiving authorization role to 
perform this procedure (see Managing Authorization Roles, page 2-5). 

Step 1 Select Provisioning Dashboard > Manage Activities > My Activities. The My Activities page appears. 

Step 2 Click the order that you require. The Viewing Activity Form page appears. 

Step 3 Click Accept. The Viewing Activity page appears. 

Step 4 Click Step Complete. The My Activities page appears with the order no longer in the list. 

Canceling Products
To cancel products, you submit a cancel order. When you cancel a product, all products associated with 
it are also canceled.

Table 3-4 lists the individual products that are associated with an orderable product.

 

Step 1 In the Products pane of the subscriber record (see Accessing a Subscriber Record, page 3-1) select the 
product that you want to cancel. The product’s options become available. 

Step 2 Click Cancel. The Order Cancel Form pane appears. 

Step 3 In the Order Cancel Form pane, click Submit. The Confirmation of Order message appears. 

Table 3-4 Orderable Products

Product Associated Products

Voicemail Email, Unified Messaging.

Email Voicemail, Unified Messaging.

Note For Cisco Unity Connection, Voicemail remains even when Email is 
canceled.

Line Email, Voicemail, Unified Messaging.

Phone Line, Email, Voicemail, Unified Messaging.

Note Cancelling a phone removes the associated directory numbers from the 
Cisco Unified Communications Manager.

Unified Messaging None.
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Step 4 Click Done. The order appears in the View Orders pane. 

Note In the Products section, an information icon ( ) appears next to the product to indicate that the 
product has an order running against it. When the order has finished processing, the information 
icon disappears.

After the order has been processed, the canceled products are no longer displayed in the Subscriber 
Record Details pane. 
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Managing Inventory

Managing products and inventory is described in the following sections:

• Managing Phone Inventory, page 4-1

• Managing Directory Inventory, page 4-4

Managing Phone Inventory
Users assigned the Ordering authorization role can perform the following tasks to manage their phone 
inventory:

• Add phones—You can add phones that are available to all subscribers, or you can designate phones 
for specific subscribers.

• Update phone information—You can change phone information.

• Remove phones—You can delete phones from the inventory list.

• Clear expired reservations—If required, you can clear from the inventory all phones whose 
reservation time has expired. 

• View a report—You can view the phone inventory report based on the Domain. 

Note The Provisioning Manager administrator can designate which phones are available in the phone 
inventory.

The procedures described in this section are for tracking the phone assets in inventory only. No 
provisioning or activation is performed during these activities. To activate a phone, see Ordering 
Products and Services, page 3-2.

The Phone Inventory Management page is where you add or change phone information. Table 4-1 
describes the fields that appear on the Phone Inventory Management page.

Table 4-1 Phone Inventory Management Page Field Descriptions

Field Description

Phone Search function that shows the list of MAC address es of phones available to 
update. 

Model List of phone types.
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Adding a Phone to Inventory

Step 1 Select Advanced Setup > Phone. The Phone Inventory Management page appears. 

Step 2 Complete the fields as required (see Table 4-1).

Step 3 Click Add. The phone is added to the inventory. 

Updating Phone Information
You can change phone information. You cannot change a phone that is currently being used (its status is 
In-use). 

Step 1 Select Advanced Setup > Phone. The Phone Inventory Management page appears. 

Step 2 In the Phone field, click the Chooser icon ( ). The Choose a Phone dialog box appears. 

MAC Address Hexadecimal value that identifies the phone. The MAC address must be 12 
characters in length. Valid characters are 0-9, A-F, and a-f. 

The MAC address is available on a sticker on the phone sets, and on the phone 
setting display on the handset.

Status The status of the phone. Possible values are the following:

• In-use—The phone is being used by a subscriber.

• Reserved—The phone is booked for a specific subscriber.

• Available—The phone is available, and can be manually or automatically 
assigned to a subscriber.

• Returned—The phone is returned to inventory, but its arrival is not 
confirmed.

• Provisioning—The phone is currently being provisioned.

Reserved For 
(optional)

Specific user that the phone is reserved for. 

Reserved On 
(optional)

Date that the phone was reserved on. It automatically appears once the phone 
information has been added or updated.

Reservation 
Timeout (optional)

Period of time, in days, that a phone will stay reserved in the system. Your 
Provisioning Manager administrator sets the reservation timeout, therefore this 
field is not editable. 

The rule PhoneReservationTimeout determines the phone reservation timeout for 
a Domain (see Business Rules, page 6-2).

Table 4-1 Phone Inventory Management Page Field Descriptions (continued)

Field Description
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Note You can search for the phone based on a complete or partial MAC address. You can use an asterisk (*) 
as a wildcard character at the beginning and/or end of the MAC address, but not in the middle. Do not 
specify SEP in the search criteria.

Step 3 Select the phone that you require. The phone information is displayed. 

Step 4 Change the phone information as required (see Table 4-1). 

Step 5 Click Update. The phone information is updated. 

Clearing Expired Phone Reservations
You can clear reservations for phones that have expired, which changes the status of the phones from 
Reserved to Available. 

Step 1 Select Advanced Setup > Phone. The Phone Inventory Management page appears. 

Step 2 Click Clear Expired Reservations. All expired reservations for phones are cleared. 

Removing Phones from Inventory
You can remove phones from your inventory. You cannot delete a phone that is currently being used (the 
phone’s status is In-use). 

Step 1 Select Advanced Setup > Phone. The Phone Inventory Management page appears. 

Step 2 In the Phone field, click the Chooser icon ( ). The Choose a Phone dialog box appears. 

Step 3 Select the phone that you require. The phone information is displayed.

Step 4 Click Remove. A confirmation message appears, indicating that the phone was removed. 

Viewing the Phone Inventory Report
You can view a report that provides the following details about the phone inventory in your Domain:

• Phone

• Type

• MAC address

• Status

• Reserved for

• Reserved on
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Step 1 Select Advanced Setup > Phone. The Phone Inventory Management page appears. 

Step 2 In the for domain field, select the Domain for which you want to view the report.

Step 3 Click Search Phone. The Phone Inventory Report appears. 

Note In the Phone Inventory Report, when you click Edit next to the phone, the Phone Inventory 
Management page appears, populated with the phone information.

The Phone Inventory search wil be executed only if the logged in your loginb elong to a Policy 
or Administrator group.

Managing Directory Inventory
In most cases, Service Area Directory Number Blocks (DNBs) are used to allocate directory numbers. 
However, you can explicitly track (store and manage) directory numbers that are associated with each 
Service Area in Provisioning Manager inventory. You can add and update directory numbers, reserve 
them for specific users, and clear directory numbers whose designated length of time in the Reserved 
state has been exceeded. 

Note To change the length of time that a directory number can remain in the Reserved state, you can modify 
the DNReservationTimeout rule. For more information, see Business Rules, page 6-2.

Directory numbers can be in the following states:

• In-use—The directory number is in use by a subscriber.

• Reserved—The directory number is booked for a specific subscriber for a specific period of time.

• Available—The directory number is available, and can be assigned to a subscriber.

When a line is added, Provisioning Manager allocates directory numbers in using the following process:

1. Checks if a directory has been reserved for the subscriber.

2. Checks for a directory number in the Available state.

3. Checks the Service Area DNB for next available directory number.

In the Service Area component of the Domain, you can create DNBs, not individual directory numbers. 
After a directory number has been allocated to a subscriber, Provisioning Manager tracks the individual 
directory number. 

Adding Directory Numbers
You can add directory numbers in Provisioning Manager. When you add a directory number, you can 
specify a status for it and/or reserve it for a particular subscriber. 

The same directory number can exist in different Call Processors. When you add a directory number, you 
must specify both the Call Processor and route partition. 

Table 4-2 describes the fields for adding directory numbers.
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Adding a Directory Number to Inventory

Step 1 Select Advanced Setup > Directory Number. The Directory Number Inventory Management page 
appears. 

Step 2 Click Add New Directory Number. The fields in the right pane become editable.

Step 3 Complete the fields as required (see Table 4-2). 

Step 4 Click Save. A message appears, confirming that the directory number was added. 

Updating Directory Number Information
You can search for and select a directory number to update. The same directory number can exist in 
different Call Processors, therefore you are specifying the Call Processor and route partition for the 
directory number that you require. 

Note You cannot change the status of a directory number that is in the In-use state.

Step 1 Select Advanced Setup > Directory Number. The Directory Number Inventory Management page 
appears. 

Table 4-2 Directory Number Inventory Management Page Fields

Field Description

Directory 
Number

Directory number.

Call 
Processor/Route 
Partition

The Call Processor and route partition that the 
directory number is added to.

Note The directory number is not added at this time. 
It is reserved for adding to the Call Processor 
once an order that requires one is received.

Status The status of the number. Possible values are:

In-use—The directory number is currently being used 
by a subscriber.

Reserved—The directory number is booked for a 
specific subscriber for a specific period of time.

Available—The directory number is available, and can 
be assigned to any subscriber.

(Optional) 
Reserved For 

Specific user that the directory number is reserved for. 

(Optional) 
Reserved On

Date that the directory number was reserved on. It 
automatically appears after the phone information has 
been added or updated.
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Step 2 In the Directory Number field, do one of the following:

• If you know the directory number, enter it and then click Search. 

• Search for the directory number, using an asterisk (*) as a wildcard. From the Choose a Directory 
Number dialog box, click the required directory number. 

The directory number information appears. 

Step 3 Click Update Current Directory Number. The fields in the right pane become editable. 

Step 4 Complete the fields as required (see Table 4-2).

Step 5 Click Save. The directory number information is updated. 

Clearing Expired Reserved Directory Numbers
You can clear reservations for directory numbers that have expired, which places the directory numbers 
back into the available pool. 

To set the number of days that the directory number is reserved for, see Business Rules, page 6-2. 

Step 1 Select Advanced Setup > Directory Number. The Directory Number Inventory Management page 
appears. 

Step 2 Click Clear Expired Reservations. A message appears, confirming the number of reserved directory 
numbers that have been returned to the available pool. 

Deleting Directory Numbers
You can remove directory numbers from inventory. 

Note You cannot delete a directory number that is in use.

Step 1 Select Advanced Setup > Directory Number. The Directory Number Inventory Management page 
appears. 

Step 2 In the Directory Number field, do one of the following:

• If you know the directory number, enter it and then click Search. 

• Search for the directory number, using an asterisk (*) as a wildcard. From the Choose a Directory 
Number dialog box, click the required directory number. 

The directory number information appears. 

Step 3 Click Remove. A message appears, confirming that the directory number has been removed. 
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Administering Infrastructure

Overview
Through its partitioning capabilities, Provisioning Manager provides a secure environment wherein 
enterprises can deliver services to multiple geographical or organizational segments of their company.

Enterprises can delegate operational control to administrators and/or subscribers. In some cases, a 
company may be regionally distributed and require a secure environment for each region. 

In Provisioning Manager, you can partition a shared environment using Domains. Domains contain 
information on Call Processors, Unified Message Processors, and Service Areas. Service areas contain 
information such as route partitions, calling search spaces, device groups, and directory numbers. The 
combination of these components determines the dial plans that are available to individual subscribers. 

When a customer and related phones, lines, and directory numbers are configured in a specific Domain, 
Provisioning Manager ensures that the associated Route Partition and calling search spaces are used.

You can configure Provisioning Manager so that only customers and subscribers within a given Domain 
and Service Area have access to a specific subset of operational capabilities. You can further control 
access by limiting it to services that are available within a Domain, and to the users and resources (for 
example, Cisco Unified Communications Managers) that are used to deliver the services. An individual 
company can have multiple Domains depending on its business requirements. 

For more information, see the following sections:

• Configuring Processors, page 5-1

• Working with Provisioning Manager Domains, page 5-10

• Working with Service Areas, page 5-16

• Using Templates—Infrastructure Configuration, page 5-23

• Using Batch Provisioning, page 5-42

Configuring Processors
This section provides information on how to create and synchronize Call Processors and Unified 
Message Processors.

This section contains the following sections:

• Creating Call Processors, page 5-2

• Changing Call Processor Information, page 5-4
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• Synchronizing Call Processors, page 5-4

• Creating Unified Message Processors, page 5-6

• Changing Unified Message Processor Information, page 5-8

• Synchronizing Unified Message Processors, page 5-8

In Provisioning Manager, you create Call Processors and Unified Message Processors. Call Processors 
are proxies for each instance of a Cisco Unified Communications Manager or Cisco Unified 
Communications Manager Express. Unified Message Processors are proxies for each instance of a Cisco 
Unity, Cisco Unity Express, or Cisco Unity Connection.

Synchronizing the data in the Cisco Unified Communications Manager and Cisco Unity systems with 
the Call Processors and Unified Message Processors, and then synchronizing with the Domains, 
populates Provisioning Manager with the existing active users and services, and provides a consolidated 
view of all of the infrastructure and subscriber information. After a Domain synchronization, you can 
use Provisioning Manager to directly manage the individual user account. You no longer have to use the 
underlying Cisco Unified Communications Manager or Cisco Unity systems.

Note Once a Call Processor or Unified Message Processor is created and synchronized, do not change the type 
of device or version of the device for the processor. For example, if you create a Call Processor for Cisco 
Unified Communications Manager version 4.1, do not change the Call Processor type to Cisco Unified 
Communications Manager Express, or the version of Cisco Unified Communications Manager to version 
4.2. 

Creating Call Processors
A Call Processor is a proxy within Provisioning Manager for a single instance of Cisco Unified 
Communications Manager or Cisco Unified Communications Manager Express.

Table 5-1 describes the fields for creating a Call Processor. 

Table 5-1 Call Processor Fields

Field Description

Name Call Processor name.

Type Cisco Unified Communications Manager or Cisco Unified Communications 
Manager Express.

IP Address IP address of the Cisco Unified Communications Manager or Cisco Unified 
Communications Manager Express.

Version Cisco Unified Communications Manager or Cisco Unified Communications 
Manager Express version number.

Device Protocol Protocol used to communicate with the device.

User Name Username based on the protocol selected.

Password (and 
confirm)

Password for the Cisco Unified Communications Manager or Cisco Unified 
Communications Manager Express user name.

Enable Password (and 
confirm)

The enable password configured on Cisco Unified Communications Manager 
Express.

Extension Mobility Details (Optional)
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Note After you have created a Call Processor, you cannot delete it.

Step 1 Select Infrastructure Configuration > Set Up Devices > Call Processors. The Call Processor 
Configuration page appears. 

Step 2 Click New Call Processor. 

Step 3 Enter the following information for the Call Processor:

• Name

• Type

• IP address

• Version

• Device protocol

• LDAP directory integration— available only for Cisco Unified Communications Manager versions 
5.0 and later.

Note This value must exactly match the value configured in the Cisco Unified Communications 
Manager. If Cisco Unified Communications Manager is integrated with an external LDAP, 
subscribers are not created through Provisioning Manager; instead they are synchronized 
through Cisco Unified Communications Manager. When placing an order, if a subscriber is not 
available on Cisco Unified Communications Manager, the workflow subsystem waits for a 
pre-defined period of time (24 hours by default) for the subscriber to be available on Cisco 
Unified Communications Manager and then continues processing the order. The 24-hour period 
can be configured on Provisioning Manager in the ipt.properties file. Change the following two 
settings:

• dfc.oem.extdir.retries: 24 

• dfc.oem.extdir.retry_interval: 3600

• Username

• Password (and confirm)

• Enable password (and confirm)—only available for Cisco Unified Communications Manager 
Express

• Extension mobility (if available)—only available for Cisco Unified Communications Manager

• Service name

Service Name The name of the Extension Mobility Service configured on a Call Processor.

Service URL The URL of the Extension Mobility Service configured on the Call Processor:

http://<IPAddress>/emapp/EMAppServlet?device=#DEVICENAME#

Where <IPAddress> is the name or the IP address of the server where 
Extension Mobility is installed.

Table 5-1 Call Processor Fields (continued)

Field Description
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• Service URL

Step 4 Click Save.

Changing Call Processor Information
After a Call Processor is created, you can update its information. 

Note Once a Call Processor is created and synchronized, do not change the type of device or version of the 
device for the Call Processor. For example, if you create a Call Processor for a Cisco Unified 
Communications Manager version 4.1, do not change the Call Processor type to a Cisco Unified 
Communications Manager Express, or the version of the Cisco Unified Communications Manager to 
version 4.2. 

Step 1 Select Infrastructure Configuration > Set Up Devices > Call Processors. The Call Processor 
Configuration page appears. 

Step 2 Click View Call Processor. The Choose a Call Processor dialog box appears.

Step 3 Select the Call Processor that you require. The View Call Processor page appears. 

Step 4 In the Options pane, click Update. The Update Call Processor page appears.

Step 5 Edit the fields as required. (For explanations of the fields, see Creating Call Processors, page 5-2.)

Step 6 Click Save. 

Synchronizing Call Processors
To synchronize a Call Processor, you synchronize the infrastructure and subscribers. The infrastructure 
data are the configurations that are required to exist on Call Processor before Provisioning Manager can 
configure subscriber services. 

You use the infrastructure synchronization to synchronize the infrastructure data with the Call Processor 
infrastructure data. The infrastructure synchronization retrieves Call Processor information that is used 
across multiple subscribers. 

Examples of the type of infrastructure data stored are described in the following:

• DevicePool—A device pool in Cisco Unified Communications Manager. Listed as 
VoiceDeviceGroup in the inventory browser.

• CallSearchSpaces—A Calling Search Space (CSS) in Cisco Unified Communications Manager.

• RoutePartitions—A partition in Cisco Unified Communications Manager.

You use the subscriber synchronization to synchronize the subscriber data in Provisioning Manager with 
the Call Processor subscriber data. 

Examples of the type of subscriber data stored are described in the following:

• Directory Number—Directory numbers in Cisco Unified Communications Manager.

• VoiceTerminal—A phone that is not a CTI port in Cisco Unified Communications Manager.
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• VoIPInfo—Users must be subscribers in Provisioning Manager. However, this information is not 
synchronized from a Call Processor.

You can execute the synchronizations independently and in any order. However, to preserve the integrity 
of the data, it is recommended that you run the synchronizations one immediately after another, and in 
the following order:

1. Infrastructure synchronization.

2. Subscriber synchronization.

Note After a new Provisioning Manager installation, the infrastructure synchronization must be executed first.
You should not run more than one synchronization at a time (Processor or Domain synchronization). Run 
all synchronizations sequentially.

Step 1 Select Infrastructure Configuration > Set Up Devices > Call Processors. The Call Processor 
Configuration page appears. 

Step 2 Click View Call Processor. The Choose a Call Processor dialog box appears.

Step 3 Select the Call Processor that you require. The View Call Processor page appears. 

Note If the Call Processor was synchronized previously, the details are displayed in the Synchronization 
section.

Step 4 In the Options pane, click Synchronize.

Step 5 You can run an infrastructure or subscriber synchronization. Click Start under the synchronization that 
you desire.

After the synchronization has completed, the Synchronization section displays the synchronization 
information.

Step 6 Click Done.

Deleting a Call Processr
Before a call processor can be deleted, the following conditions must be met:

• No active released orders, including unrecoverable or recoverable errors.

• No active batch projects.

• No synchronizations in progress.

If these conditions are not met, a dialog box will appear when you attempt to delete a call processor, 
telling you the operation will not start. The system must be in maintenance mode before the delete option 
is available.

While the call processor deletion is in progress, avoid performing any activities until the call processor 
deletion is complete.

Step 1 Put Provisioning Manager in maintenance mode (see Maintenance Mode, page 7-6).
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Step 2 Select Infrastructure Configuration > Set Up Devices > Call Processors. The Call Processor 
Configuration page appears.

Step 3 Click View Call Processor. The Choose a Call Processor dialog box appears.

Step 4 Select the Call Processor that you require. The View Call Processor page appears. 

Step 5 In the Options pane, click Delete. A confirmation dialog appears asking you to confirm the call processor 
deletion. 

Note The system must be in maintenance mode for the Delete command to appear in the Options pane.

Step 6 Click OK. The call processor deletion begins, with a progress bar displaying the status of the deletion 
in the Options pane.

Creating Unified Message Processors 
A Unified Message Processor is a proxy within Provisioning Manager for each instance of Cisco Unity, 
Cisco Unity Express, and Cisco Unity Connection. Table 5-2 describes the fields for creating a Unified 
Message Processor. 

Note The fields that are displayed in the Configure a New Unified Message Processor page depend on the 
Cisco Unity type you select in the Type field. Not all fields will appear.

Table 5-2 Configuring Unified Message Processor Fields

Field Description

Name Name provided by the user.

Type Type of Cisco Unity (Cisco Unity, Cisco Unity Connection, or Cisco 
Unity Express).

IP Address Cisco Unity, Cisco Unity Connection, or Cisco Unity Express system IP 
address.

Version The version of the device.

User Name This field is case sensitive. The user name supplied in this field should 
match the following:

• Cisco Unity or Cisco Unity Connection 1.1: database username.

• Cisco Unity Connection 2.0: Administrator user name provided 
during Cisco Unity Connection installation.

Password (and confirm) This field is case sensitive. The password supplied in this field should 
match the following:

• Cisco Unity or Cisco Unity Connection 1.1: database password.

• Cisco Unity Connection 2.0: Administrator password provided 
during Cisco Unity Connection installation.

Host Router IP Address IP address of the router where Cisco Unity Express is installed.
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Step 1 Select Infrastructure Configuration > Set Up Devices > Unified Message Processors. The Unified 
Message Processor Configuration page appears. 

Step 2 Click New Unified Message Processor. The Configure a New Unified Message Processor page appears.

Step 3 Enter a name for the Unified Message Processor.

Step 4 Select the type of Unified Message Processor.

Step 5 The information that you must enter varies, depending on which type of device you are adding (for 
explanations of the fields, see Table 5-2):

• If you are adding a Cisco Unity or Cisco Unity Connection, enter the following:

– IP address

– Version

– Username

– Password (and confirm)

• If you are adding a Cisco Unity Express, enter the following:

– Host router IP address

– Version

– Protocol

– Host router username

– Host router password (and confirm)

– Host router enable mode password (and confirm)

– Cisco Unity Express line username

Protocol Protocol used to connect to the device.

(Optional) Host Router 
User Name

Username of the router where Cisco Unity Express is installed.

(Optional) Host Router 
Password (and confirm)

Password for the router where Cisco Unity Express is installed.

Host Router Enable Mode 
Password (and confirm)

Enable mode password for the router where Cisco Unity Express is 
installed.

(Optional) CUE Line User 
Name

Username for the Cisco Unity Express module.

(Optional) CUE Line 
Password (and confirm)

Password for the Cisco Unity Express module.

Service Engine Interface 
Number

The interface number of the Cisco Unity Express service engine on the 
router.

Table 5-2 Configuring Unified Message Processor Fields (continued)

Field Description
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– Cisco Unity line password (and confirm)

– Service engine interface number

Step 6 Click Save.

Changing Unified Message Processor Information
You can update the Unified Message Processor information. 

Note Once a Unified Message Processor is created and synchronized, do not change the type of device or 
version of the device for the Unified Message Processor. For example, if you create a Unified Message 
Processor for a Cisco Unity version 4.1, do not change the Unified Message Processor type to a Cisco 
Unity Connection, or the version of the Cisco Unity to version 4.2. 

Step 1 Select Infrastructure Configuration > Set Up Devices > Unified Message Processors. The Unified 
Message Processor Configuration page appears. 

Step 2 Click View Unified Message Processors. The Choose a Unified Message Processor dialog box appears.

Step 3 Select the Unified Message Processor that you require. The View Unified Message Processor page appears. 

Step 4 In the Options pane, click Update. The Update Unified Message Processor page appears.

Step 5 Edit the fields as required. (For explanations of the fields, see Table 5-2.)

Step 6 Click Save. 

Synchronizing Unified Message Processors
To synchronize a Unified Message Processor, you synchronize the infrastructure and subscribers. The 
infrastructure data are the configurations that are required to exist on Unified Message Processors before 
Provisioning Manager can configure subscriber services.

You use the infrastructure synchronization to synchronize the unified messaging infrastructure data in 
Provisioning Manager with the Unified Message Processor. 

The infrastructure data consists of the following:

• SubscriberTemplate—A Subscriber Template in Cisco Unity, Cisco Unity Connection, and the email 
message processor.

• UnifiedMessagingFeatureSpecification—A class of service in Cisco Unity, Cisco Unity 
Connection, and the email message processor.

You use the subscriber synchronization to synchronize the unified messaging subscriber data in 
Provisioning Manager with the Unified Message Processor. 

The subscriber data consists of the following:

• UMInfo—A subscriber in Cisco Unity, Cisco Unity Connection, and Cisco Unity Express in 
conjunction with the subscriber’s voicemail and email information.
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• VoiceMailInfo—A subscriber in Cisco Unity, Cisco Unity Connection, and Cisco Unity Express in 
conjunction with UMInfo and EmailInfo.

• EmailInfo—A subscriber in Cisco Unity and Cisco Unity Connection in conjunction with 
VoiceMailInfo and UMInfo.

You can execute the synchronizations independently and in any order. However, to preserve the integrity 
of the data, it is recommended that you run the synchronizations together, and in the following order:

1. Infrastructure synchronization.

2. Subscriber synchronization. 

Note After a new Provisioning Manager installation, the infrastructure synchronization must be executed first.

Note You should not run more than one synchronization at a time (Processor or Domain synchronization). Run 
all synchronizations sequentially. 

Step 1 Select Infrastructure Configuration > Set Up Devices > Unified Message Processors. The Unified 
Message Processor Configuration page appears. 

Step 2 Click View Unified Message Processor. The Choose a Unified Message Processor dialog box appears.

Step 3 Select the Unified Message Processor that you require. The View Unified Message Processor page 
appears. 

Note If the Unified Message Processor was synchronized previously, the details will be displayed in the 
Synchronization sections.

Step 4 In the Options pane, click Synchronize.

Step 5 You can run an infrastructure or subscriber synchronization. Click Start under the synchronization that 
you desire.

After the synchronization has completed, the Synchronization section displays the synchronization 
information.

Note If during the synchronization of a Cisco Unity Express you encounter device connection errors, close all 
telnet sessions on the Cisco Unity Express system and restart the synchronization. Cisco Unity Express 
only allows one telnet session at a time. Provisioning Manager will not be able to synchronize with a 
Cisco Unity Express device that has another telnet session open.

Step 6 Click Done.

Deleting a Unified Message Processr
Before a Unified Message processor can be deleted, the following conditions must be met:

• No active released orders, including unrecoverable or recoverable errors.
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• No active batch projects.

• No synchronizations in progress.

If these conditions are not met, a dialog box will appear when you attempt to delete a Unified Message 
processor, telling you the operation will not start. The system must be in maintenance mode before the 
delete option is available.

While the Unified Message processor deletion is in progress, avoid performing any activities until the 
Unified Message processor deletion is complete.

Step 1 Put Provisioning Manager in maintenance mode (see Maintenance Mode, page 7-6).

Step 2 Select Infrastructure Configuration > Set Up Devices > Unified Message Processors. The Unified 
Message Processor Configuration page appears.

Step 3 Click View Unified Message Processor. The Choose a Unified Message Processor dialog box appears.

Step 4 Select the Unified Message Processor that you require. The View Unified Message Processor page 
appears. 

Step 5 In the Options pane, click Delete. A confirmation dialog appears asking you to confirm the Unified 
Message processor deletion. 

Note The system must be in maintenance mode for the Delete command to appear in the Options pane.

Step 6 Click OK. The Unified Message processor deletion begins, with a progress bar displaying the status of 
the deletion in the Options pane.

Working with Provisioning Manager Domains
Provisioning Manager introduces the concept of Domains and Service Areas. Domains are groupings of 
subscribers. For each grouping, one or more system users can be authorized to manage services for 
subscribers within that Domain. In addition, rules or policies may be set on a Domain; those rules and 
policies will apply to services for subscribers in that Domain. Common policies can also be applied on 
operations within a Domain.

To use Domains in Provisioning Manager, you must do the following:

• Create and configure the Domain—Includes assigning a Call Processor and Unified Message 
Processor (optional). 

• Create and configure Service Areas—Includes selecting call search spaces, route partitions and 
device pool; specifying user types that have access to the Service Area; and configuring Directory 
Number Blocks.
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Figure 5-1 Domain Configuration

Using the Customer Domain Template
If your implementation will have more than one Domain, you can configure the Customer Domain 
Template according to the default business rules and user types that you require for your implementation. 

When you create new Domains, they inherit the standard set of business rules and user types from the 
Customer Domain Template. You can then change the business rules and user types as required for each 
new Domain. Changes made to the Customer Domain Template affect only new Domains created after 
that point.

The Customer Domain Template is created by default when you install Provisioning Manager. You 
configure it by specifying business rules and subscriber roles for it the same way that business rules and 
subscriber roles are specified for new Domains.

Creating a Domain
Table 5-3 describes the fields required for creating a Domain.
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Table 5-3 Fields for Creating Domains

Field Description

Domain ID ID of the Domain. Valid values are alphanumeric 
characters (A-Z, a-z, 0-9), underscore (_), hyphen (-), 
asterisk (*), and period (.).

(Optional) 
Description

Description of the Domain.
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Step 1 Select Infrastructure Configuration > Set Up Deployment > Domains. The Domain Configuration 
page appears. 

Step 2 In the Options pane, click New Domain. The Configure a New Domain page appears. 

Step 3 Complete the fields as required.

Step 4 Click Save. The Update Domain page appears. For configuring a Domain, see Configuring a Domain, 
page 5-12.

Configuring a Domain
After you have created a Domain, you must select one or more Call Processors for it. You can also select 
one or more Unified Message Processors. The Domain information includes Service Areas, and 
subscriber roles that have access to your new Domain. 

Note You must create the Call Processor and Unified Message Processor before you can add them to a 
Domain. Call Processors and Unified Message Processors can be shared across Domains.

Table 5-4 describes the fields required for configuring a Domain. 

Step 1 Select Infrastructure Configuration > Set Up Deployment > Domains. The Domain Configuration 
page appears. 

Step 2 Click View Domain. The Choose a Domain dialog box appears. 

Step 3 Select the Domain that you require. The View Domain page appears. 

Step 4 In the Options pane, click Update. The Update Domain page appears.

Step 5 Do the following:

• (Optional) Enter a description.

• Select a Call Processor. 

• (Optional) Select a Unified Message Processor.

Table 5-4 Domain Configuration Fields

Field Description

Domain ID ID of the Domain. Valid characters are: A-Z, a-z, 
0-9, . _ - *.

Description Description of the Domain.

Call Processor Call Processors for the Domain. 

Unified Message 
Processor

Unified Message Processors for the Domain. 

Subscriber Roles Includes the default Provisioning Manager subscriber roles.

Service Area Geographic, organizational, or technology boundaries for the Domain.
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• (Optional) Create a new Service Area for the Domain or edit the selected Service Area.

Step 6 Click Save.

Synchronizing Domains
During a Domain synchronization, Provisioning Manager does the following:

• Associates the voicemail, email, and unified messaging data in the Unified Message Processor with 
the user information in Provisioning Manager.

• Synchronizes the assigned voice mail directory numbers in the Unified Message Processor to those 
in the Call Processor.

• Synchronizes subscribers and their ordered products with the Provisioning Manager inventory, 
creates new subscribers, and updates their subscriber records.

• Synchronizes user accounts and updates Provisioning Manager so that users can log in (logins are 
created only if the self-care rule is enabled; see CreateSelfCareAccounts, page 6-4).

To fully synchronize a Domain, you must perform the following:

1. For each Call Processor in the Domain, perform an infrastructure and subscriber synchronization.

2. For each Unified Message Processor in the Domain, perform an infrastructure and subscriber 
synchronization.

3. Perform a Domain synchronization.

Note If a Call Processor or a Unified Message Processor in the Domain is synchronized, it is recommended 
that a Domain synchronization also be done.

Note When running Domain synchronization, remember the following:

• If you use a subscriber synchronization on a Cisco Unified Communications Manager Express to 
add subscribers to Provisioning Manager, the first name, last name, phone number, and department 
data is not obtained by Provisioning Manager. The Manage Subscriber page displays Unknown in 
these fields."

You can update the subscriber information through Provisioning Manager, but be aware that this 
information will be pushed to the Cisco Unified Communications Manager Express system, and will 
overwrite any existing information for the user in the ephone description field. 

• You should not run more than one synchronization at a time (Domain or Processor synchronization). 
Run all synchronizations sequentially. 

• If a Cisco Unified Communications Manager Express is the only device present in a Domain and 
Service Area , during Domain synchronization subscribers are not created in Provisioning Manager 
if the ephone username command is not configured in Cisco Unified Communications Manager 
Express. Make sure the ephone username command is configured in Cisco Unified Communications 
Manager Express for all subscribers.
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• If more than one matching Service Area is found for a Phone, Soft Phone, Line, EM Line and Device 
Profile, Provisioning Manager will assign them to the first matching Service Area and give the 
following warning in the Domain Synchronization: More than one matching service area found for 
Device Profile/Phone/Line/EM Line/Soft phone, , put it to the first matching service area. (See 
Viewing a Domain’s Synchronization Log, page 5-15)

• Device profiles are added to a subscriber's customer record as an Extension Mobility Access 
product, even if the the device profile is not subscribed to the extension mobility service in Cisco 
Unified Communications Manager.

Step 1 Select Infrastructure Configuration > Set Up Deployment > Domains. The Domain Configuration 
page appears. 

Step 2 Click View Domain. The Choose a Domain dialog box appears. 

Step 3 Select the Domain that you require. The View Domain page appears. 

Note If the Domain was synchronized previously, the details are displayed in the Last Synchronization 
section.

Step 4 In the Options pane, click Synchronize.

Step 5 Click Start.

After the synchronization has completed, the Last Synchronization section displays the synchronization 
information.

Step 6 Click Done.

Note After the Domain synchronization completes, a log is created, listing the objects that could not be 
assigned; see Viewing a Domain’s Synchronization Log, page 5-15.

Configuring Business Rules for Domain Synchronization

For the Domain synchronization to work properly, you must configure at least one of the following rules:

• AssociateAllUsersInCallProcessor—If enabled, all user accounts in all of the Call Processors in the 
Domain are assigned to the Domain being synchronized. This rule overrides the 
AssociateUsersByDeptCode rule.

• AssociateUsersByDeptCode—If enabled, the Domain synchronized associates only the Call 
Processor user accounts whose department code matches one in the list specified in the rule 
configuration.

• AssociateAllUsersInUMProcessor—If enabled, all user accounts in a given Unified Message 
Processor are associated to a Domain, including those accounts without a corresponding Call 
Processor user account. If disabled, only user accounts in the given Unified Message Processor that 
have a matching Call Processor user account are associated.
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Note By default, none of these rules are configured. If none of the rules are enabled and a Domain 
synchronization is run, Provisioning Manager only associates the Call Processor accounts where the 
department code is the same as the name of the Domain.

Editing a Domain’s Provisioning Attributes
You can set provisioning attribute at the Domain level. All provisioning attributes set at other levels 
(Service Area, subscriber type, Advanced Order) take precedence over provisioning attributes set at the 
Domain level. For more information on provisioning attributes, see Configuring Provisioning Attributes, 
page 6-13.

Step 1 Select Infrastructure Configuration > Set Up Deployment > Domains. The Domain Configuration 
page appears. 

Step 2 Click View Domain. The Choose a Domain dialog box appears. 

Step 3 Select the Domain that you require. The View Domain page appears. 

Step 4 In the Options pane, click Edit Provisioning Attributes. The Provisioning Attribute Management page 
appears.

Step 5 Update attributes as desired, then click Done. (For descriptions of the provisioning attributes, see 
Configuring Provisioning Attributes, page 6-13.)

Viewing a Domain’s Synchronization Log
When a Domain synchronization occurs, a log is created. The log lists the products that could not be 
assigned to a Service Area during a Domain synchronization. This log is replaced each time a Domain 
synchronization occurs.

Step 1 Select Infrastructure Configuration > Set Up Deployment > Domains. The Domain Configuration 
page appears. 

Step 2 Click View Domain. The Choose a Domain dialog box appears. 

Step 3 Select the Domain that you require. The View Domain page appears. 

Step 4 In the Options pane, click Synchronize.

Step 5 Click View Detailed Synchronization Log at the bottom of the page. The log appears.

Deleting a Domain
When a domain is deleted, subscribers, rules, Service Areas, directory number blocks, and subscriber 
roles are removed.Voice terminal instances and directory number instances in IM are moved to the 
Global Resources namespace. Before a Domain can be deleted, the following conditions must be met:

• No active released orders, including unrecoverable or recoverable errors.
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• No active batch projects.

• No Domain synchronizations in progress.

• No Processor synchronizations in progress.

If these conditions are not met, a dialog box will appear when you attempt to delete a Domain, telling 
you the operation will not start. The system must be in maintenance mode before the delete option is 
available.

While the Domain deletion is in progress, avoid performing any activities until the Domain deletion is 
complete.

Step 1 Put Provisioning Manager in maintenance mode (see Maintenance Mode, page 7-6).

Step 2 Select Infrastructure Configuration > Set Up Deployment > Domains. The Domain Configuration 
page appears. 

Step 3 Click View Domain. The Choose a Domain dialog box appears. 

Step 4 Select the Domain that you require. The View Domain page appears. 

Step 5 In the Options pane, click Delete Domain. A confirmation dialog appears asking you to confirm the 
domain deletion. 

Note The system must be in maintenance mode for the Delete Domain command to appear in the Options 
pane.

Step 6 Click OK. The domain deletion begins, with a progress bar displaying the status of the deletion in the 
Options pane.

Working with Service Areas
You use Service Areas to structure and manage the required IP telephony and messaging services across 
geographic, organizational, or technology boundaries. The Service Area determines the mappings from 
the business view of the service to the technology delivering those services.  For example, on a Service 
Area associated to a Cisco Unified Communications Manager, a Service Area defines the device group, 
route partition, calling search spaces, location, external phone number mask that the products will use 
within Cisco Unified Communications Manager. 

In this case, when you configure a Service Area, you have a list of route partitions that can be assigned 
to it based on the selected Call Processor for the Service Area. If the Service Area does not have any 
associated route partition, then the directory numbers and lines are created in the default route partition 
in Cisco Unified Communications Manager. 

For Cisco Unity and Cisco Unity Connection Unified Message Processors, if you assign a Unified 
Message Processor to a Service Area, the Subscriber Template (with or without the TTS feature) and 
Subscriber CoS (with or without the TTS feature) can be configured. These templates can be used for 
voicemail provisioning of subscribers in the Service Area.

Note For Service Areas with Call Processors based on Cisco Unified Communications Manager Express, only 
device groups are available for selection. Calling search spaces and route partitions are not available.
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Figure 5-2 shows how the associations with Service Area to route partition, device group, calling search 
spaces, and Domain are established when you create and configure the Service Area. Service areas also 
determine the key voicemail settings and call forwarding behaviors.

Figure 5-2 Service Area Configuration

Creating Service Areas
Table 5-5 describes the fields for creating a Service Area.

Step 1 Select Infrastructure Configuration > Set Up Deployment > Service Areas. The Service Area 
Configuration page appears. 
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Table 5-5 Fields for Creating a Service Areas

Field Description

Service Area ID Name of the Service Area. Valid values are alphanumeric characters (A-Z, a-z, 
0-9), underscore (_), hyphen (-), asterisk (*), and period (.).

Domain The Domain that the Service Area belongs to.
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Step 2 Click New Service Area.

Step 3 In the Service Area ID field, type the name of the new Service Area. 

Step 4 Select the Domain that you want the Service Area to belong to. 

Step 5 Click Save. The Edit Service Area page appears. For configuring a Service Area, see Configuring 
Service Areas, page 5-18.

Configuring Service Areas
When configuring a Service Area, you can do the following:

• Map the Service Area to the corresponding Call Processor objects by specifying its Call Processors 
and related objects (for a Cisco Unified Communications Manager, some examples are call search 
space, route partition, device pool) and Unified Message Processor.

• Specify the subscriber types for the Service Area (only users within a Service Area can order 
products from it).

Note The Employee subscriber role is the default based on the Domain rule DefaultUserType.

• Create directory number blocks for the Service Area users.

• Set a default phone number mask and/or call forward settings for new lines ordered within the 
Service Area.

Note Once a Service Area is assigned to a Domain, it cannot be changed. Further, once a Call Processor or 
Unified Message Processor is assigned to a Service Area, it cannot be changed.

Table 5-6 describes the fields for configuring a Service Area. 

Table 5-6 Service Area Configuration Fields

Field Description

Service Area ID Name of the Service Area.

Domain Domain that the Service Area belongs to.

Call Processor Settings You will have different settings available to you, depending on the type 
of device that your Call Processor is.

Name Call processor for the Service Area (read-only).

Phone Protocol The protocol to be configured when phones are ordered. You will have an 
option of either SIP or SCCP for Cisco Unified Communications 
Manager versions which support SIP. Otherwise SCCP is displayed.

Note This field only appears if you selected a Cisco Unified 
Communications Manager 5.0.

Call Search Space 
(phone)

Call search space to be assigned to phones and extension mobility 
profiles. It can be left blank. It only applies to Cisco Unified 
Communications Manager. 
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Call Search Space 
(line)

Call search space to be assigned to lines on a phone or extension mobility 
profile. It can be left blank. It only applies to Cisco Unified 
Communications Manager.

Common Device 
Configuration

Configuration of common device settings for the Service Area. It only 
applies to Cisco Unified Communications Manager. The following 
settings are controlled by Common Device Configuration:

Softkey template

User Hold MOH Audio Source

Network Hold MOH Audio Source

User Locale

MLPP Indication

MLPP Preemption

MLPP Domain

Note This field only appears if you selected a Cisco Unified 
Communications Manager 6.0.

Location Location to be assigned to a device. It only applies to Cisco Unified 
Communications Manager.

Route Partition Route partition for the Service Area. It only applies to Cisco Unified 
Communications Manager. This is the same as a partition in Cisco 
Unified Communications Manager.

Device Pool Device pool for the Service Area. 

External Phone 
Number Mask

Indicate phone number (or mask) that is used to send caller ID 
information when a call is placed from the Service Area. 

You can enter a maximum of 30 characters. The Xs represent the 
directory number and must appear at the end of the pattern. For example, 
if you specify a mask of 972813XXXX, an external call from extension 
1234 displays a caller ID number of 9728131234. 

Unified Message Processors You will have different settings available to you, depending on the type 
of device that your Unified Message Processor is.

Name Unified Message Processor for the Service Area (if applicable).

Email Processors Available only for Cisco Unity Connection and it is integrated with an 
external Exchange Server for IMAP Client support.

Subscriber Template 
with TTS Enabled

Subscriber Template to be used to enable unified messaging for a 
subscriber in the Unified Message Processor.

Subscriber Template 
without TTS Enabled

Subscriber Template to be used to disable unified messaging for a 
subscriber in the Unified Message Processor.

Subscriber CoS with 
TTS Enabled

Class of Service Template to be used to enable unified messaging for a 
subscriber in the Unified Message Processor. It applies to Cisco Unity 
and Cisco Unity Connection and is used in conjunction with the 
Subscriber Template.

Table 5-6 Service Area Configuration Fields (continued)

Field Description
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It is recommended that you specify the following for a Service Area before you synchronize the Domain 
that it belongs to:

• Call Processors

• Call search space

• Route partition

• Device group

• Unified Message Processor

• Location

Note Once a Call Processor or Unified Message Processor is assigned to a Service Area, it cannot be removed.

Step 1 Select Infrastructure Configuration > Set Up Deployment > Service Areas. The Service Area 
Configuration page appears. 

Step 2 Click View Service Area. The Choose a View Service Area dialog box appears.

Step 3 Select the Service Area that you require. The View Service Area page appears. 

Step 4 In the Options pane, click Update. The Edit Service Area page appears.

Step 5 During the initial configuration, you can select a Call Processor. After a Call Processor is configured to 
a Service Area, it cannot be changed.

Step 6 Update the desired information. For a description of the fields, see Table 5-6.

Step 7 Click Save.

Editing a Service Area’s Provisioning Attributes
You can set provisioning attribute at the Service Area level. Any provisioning attributes set at the Service 
Area level take precedence over provisioning attributes set at either the subscriber type or Domain level. 
For more information on provisioning attributes, see Configuring Provisioning Attributes, page 6-13.

Step 1 Select Infrastructure Configuration > Set Up Deployment > Service Areas. The Service Area 
Configuration page appears. 

Step 2 Click View Service Area. The Choose a Service Area dialog box appears. 

Subscriber CoS 
without TTS Enabled

Class of service template to be used to disable unified messaging for a 
subscriber in the Unified Message Processor. It only applies to Cisco 
Unity and Cisco Unity Connection and is used in conjunction with the 
Subscriber Template.

Subscriber Roles Subscriber roles that have access to the Service Area.

Directory Number Blocks DNBs for the Service Area (see Creating Directory Number Blocks, page 
5-22).

Table 5-6 Service Area Configuration Fields (continued)

Field Description
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Step 3 Select the Service Area that you require. The View Service Area page appears. 

Step 4 In the Options pane, click Edit Provisioning Attributes. The Provisioning Attribute Management page 
appears.

Step 5 Update attributes as desired, then click Done. (For descriptions of the provisioning attributes, see 
Configuring Provisioning Attributes, page 6-13.)

Deleting a Service Area
Before a Service Area can be deleted, the following conditions must be met:

• No active released orders, including unrecoverable or recoverable errors.

• No active batch projects.

• No Domain synchronizations in progress.

• No Processor synchronizations in progress.

If these conditions are not met, a dialog box will appear when you attempt to delete a service area, telling 
you the operation will not start. The system must be in maintenance mode before the delete option is 
available.

While the service area deletion is in progress, avoid performing any activities until the service area 
deletion is complete.

Step 1 Put Provisioning Manager in maintenance mode (see Maintenance Mode, page 7-6).

Step 2 Select Infrastructure Configuration > Set Up Deployment > Service Areas. The Service Area 
Configuration page appears. 

Step 3 Click View Service Area. The Choose a Service Area dialog box appears. 

Step 4 Select the Service Area that you require. The View Service Area page appears. 

Step 5 In the Options pane, click Delete Service Area. A confirmation dialog appears asking you to confirm 
the service area deletion. 

Note The system must be in maintenance mode for the Delete Service Area command to appear in the Options 
pane.

Step 6 Click OK. The service area deletion begins, with a progress bar displaying the status of the deletion in 
the Options pane.
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Creating Directory Number Blocks
Table 5-7 describes the fields for creating a block of directory numbers.

 

Numbers within a directory number block are relative to the Cisco Unified Communications Manager 
on which they are being created. Therefore, the prefix portion of a directory number block may or may 
not map to an NPA/NXX. Also, the prefix portion may or may not reflect e164 DialPlans. Routing via 
various gateways will ultimately determine how the directory numbers on a specific Cisco Unified 
Communications Manager are interpreted during a call setup. 

For example, if prefix = 408, first number = 0, last number = 100, and minumum length = 4 then the 
range of the directory number block would be 4080000 through 4080100.

Provisioning Manager handles directory numbers the same way as they are handled by Cisco Unified 
Communications Manager and Cisco Unified Communications Manager Express. Various models for 
Direct or Auto-attendant Inward Dialing are also supported.

If a subscriber tries to order a service from a Service Area that does not have a directory number block, 
the order is paused in the workflow until that directory number block has been added and a Provisioning 
Manager administrator progresses the activity in the workflow. The order is then allowed to continue. 
You can also set up individual directory numbers using the Directory Number Inventory component. For 
more information, see Managing Directory Inventory, page 4-4. 

Step 1 Select Infrastructure Configuration > Set Up Deployment > Service Areas. The Service Area 
Configuration page appears. 

Step 2 Click View Service Area. The Choose a View Service Area dialog box appears.

Step 3 Select the Service Area that you require. The View Service Area page appears. 

Step 4 In the Options pane, click Update. The Edit Service Area page appears.

Step 5 In the Directory Number Block(s) field, click the Add icon ( ). The Add a New Directory Number 
Block screen appears. 

Step 6 Complete the fields as required.

Step 7 Click Add. A message appears on the Edit Service Area screen that confirms it has been updated. 

Table 5-7 Directory Number Blocks Field Description

Field Description

Prefix Directory number prefix.

First Number Starting number for the block of directory 
numbers.

Last Number Last directory number in the block.

Minimum Length The minimum length (number of digits) that a 
directory number can be before the prefix is 
added. Used by the system to pad numbers with 
zeros.
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Viewing the Directory Number Block Assigned to a Service Area or to the Same Call Processor 

Step 1 Select Infrastructure Configuration > Set Up Deployment > Service Areas. The Service Area 
Configuration page appears. 

Step 2 Click View Service Area. The Choose a View Service Area dialog box appears.

Step 3 Select the Service Area that you require. The View Service Area page appears. 

Step 4 In the Directory Number Block field do one of the following:

• To view the Directory Number Block assigned to the Service Area:

a. Click the Assigned to this Service Area drop-down list.

b. Select the Directory Number Block. The details of the Directory Number Block appear. 

• To view the Directory Number Blocks assigned to the same Call Processor:

a. Click the Assigned to the Same Call Processor drop-down list.

b. Select the Directory Number block. The details of the Directory Number Block appear.

Specifying Default Call Forward Settings
You can set call forward default settings for new phone lines ordered in a Service Area. For example, 
you can specify a common rollover number, or that all calls be forwarded to the voice mail number that 
has been configured on the corresponding Cisco Unified Communications Manager. 

The following call forward settings are available:

• Forward All—Forwards all calls.

• Forward Busy—Forwards calls that are not answered because the line is busy.

• Forward No Answer—Forwards calls that are not answered.

Step 1 In the Edit Service Area page (for information on accessing this page, see Configuring Service Areas, 
page 5-18), click Update Default Settings. The Update Default Forwarding Options screen appears.

Step 2 To forward calls to voice mail, check the box in the Voice Mail column. 

Step 3 To forward calls to another phone number:

• In the Destination field, type the phone number.

• From the Calling Search Space list, select the calling search space.

Step 4 Click Update. The settings are displayed in the Edit Service Area screen.

Using Templates—Infrastructure Configuration
The following topics described the auto-configuration feature of Provisioning Manager:

• Working with Configuration Templates, page 5-24

• Creating Configuration Templates, page 5-35
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• Updating an Existing Template, page 5-39

• Renaming Configuration Templates, page 5-41

• Creating Copies of Configuration Templates, page 5-41

• Deleting Configuration Templates, page 5-41

• Generating a Configuration Using a Template, page 5-42

Working with Configuration Templates
Provisioning Manager enables you to configure Cisco Unified Communications Manager, Cisco Unified 
Communications Manager Express, and Cisco Unity Express in a consistent way through the use of 
Configuration Templates. You can use these templates to do the following:

• Configure a new Cisco Unified Communications Manager, Cisco Unified Communications Manager 
Express, or Cisco Unity Express.

• Performing an incremental rollout on an existing Cisco Unified Communications Manager, Cisco 
Unified Communications Manager Express, or Cisco Unity Express (for example, deploying a new 
site or location).

• Roll out a new service across existing customers.

To create Cisco Unified Communications Manager Express and Cisco Unity Express Configuration 
Templates, you must know the appropriate Cisco IOS configuration commands.

To create Cisco Unified Communications Manager Configuration Templates you add Cisco Unified 
Communications Manager infrastructure data objects to the Configuration Template. Table 5-8 lists the 
infrastructure data objects that are available in Provisioning Manager.

Note Not all fields in an infrastructure configuration template are applicable on all Cisco Unified 
Communications Manager versions.

Figure 5-3 displays an example of a Cisco Unified Communications Manager Configuration Template.
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Figure 5-3 Cisco Unified Communications Manager Configuration Template

Table 5-8 Infrastructure Data Objects

Infrastructure Data Object

Cisco Unified Communications Manager Release

4.0.1 4.1.x 4.2.x 5.0.x 5.1.x 6.0.x

Unified CM group Y Y Y Y Y Y

Call park Y Y Y Y Y Y

Call pickup group Y Y Y Y Y Y

Call search space Y Y Y Y Y Y

Common Device Config N N N N N Y

H323 gateway Y Y Y Y Y Y

Hunt list Y Y Y Y Y Y

Hunt pilot N Y Y Y Y Y

Line group N Y Y Y Y Y

Location Y Y Y Y Y Y

Media resource group Y Y Y Y Y Y

Media resource list Y Y Y Y Y Y

Route group Y Y Y Y Y Y

Route list Y Y Y Y Y Y

Route partition Y Y Y Y Y Y

Route pattern Y Y Y Y Y Y

Translation pattern Y Y Y Y Y Y

Device pool Y Y Y Y Y Y
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Table 5-9 through Table 5-26 describe the fields for each infrastructure data object of the Provisioning 
Manager Configuration Templates.

Note Many of the infrastructure data object fields allow you to add items to the lists and let you move the items 
up and down in the lists. For information on these operations, see the following:

• Adding Items to Lists, page 5-39

• Changing the Order of Items, page 5-40

Note All the data object fields, where you manually enter text, are case sensitive.

Voicemail pilot Y Y Y Y Y Y

Voicemail profile N N Y Y Y Y

Voice region Y Y Y Y Y Y

Table 5-8 Infrastructure Data Objects (continued)

Infrastructure Data Object

Cisco Unified Communications Manager Release

4.0.1 4.1.x 4.2.x 5.0.x 5.1.x 6.0.x

Table 5-9 Unified CM Group Infrastructure Data Object Fields

Field Description

Name Name.

Unified CMs List of available Cisco Unified Communications Managers.

Auto-Registration 
CallManager Group

Select Yes if you want this Cisco Unified Communications Manager 
group to be the default Cisco Unified Communications Manager group 
when auto-registration is enabled.

Table 5-10 Call Park Group Infrastructure Data Object Fields

Field Description

Number/Range Enter the call park extension number or a range of numbers. 

Description Optional description.

Route Partition List of available route partitions. 

Unified CM List of available Cisco Unified Communications Managers.

Table 5-11 Call Pickup Group Infrastructure Data Object Fields

Field Description

Name Name.

Number Unique directory number (integers). 
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Description Optional description.

Route Partition List of available route partitions. 

Available Member Call 
Pickup Groups

List of available Call Pickup Groups.

Table 5-12 Call Search Space Infrastructure Data Object Fields

Field Description

Name Name.

Description Optional description.

Available Route Partitions List of available route partitions. The route partitions list is not strictly 
required, but you should provide at least one value. You must reference 
a route partition that already exists on the Cisco Unified 
Communications Manager, or define one in the same Configuration 
Template prior to this call search space.

Table 5-13 Common Device Config Infrastructure Data Object Fields

Field Description

Name Name.

Softkey Template Softkey template that determines the configuration of the softkeys on 
Cisco IP Phones.

User Hold MOH Audio 
Source

The audio source that plays Music On Hold when the user initiates a 
hold action.

Network Hold Audio Source The audio source that plays when the network initiates a hold action.

User Locale User location associated with the phone user. The user locale identifies 
a set of detailed information to support users, including language, font, 
date and time formatting, and alphanumeric keyboard text information.

MLPP Indication User location associated with the phone user. The user locale identifies 
a set of detailed information to support users, including language, font, 
date and time formatting, and alphanumeric keyboard text information.

MLPP Preemption Specifies whether devices in the device pool that are capable of 
preempting calls in progress will use the capability when the devices 
place an MLPP precedence call.

MLPP Domain Multilevel Precedence and Preemption (MLPP) domain that is 
associated with this device.

Table 5-11 Call Pickup Group Infrastructure Data Object Fields (continued)

Field Description
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Table 5-14 H323 Gateway Infrastructure Data Object Fields

Field Description

Name Device name.

Description Optional description.

Device Pool List of available device pools. The device pool specifies a collection of 
properties for this device including Unified CM Group, Date/Time 
Group, Region, and Calling Search Space for auto-registration of 
devices. 

Common Device Config Configuration of common device settings, such as the softkey template 
and user locale.

Call Classification Determines whether an incoming call that is using this gateway is 
considered off the network (OffNet) or on the network (OnNet). 

Media Resource Group List Provides a prioritized grouping of media resource groups. 

Location Location for this device. 

Media Termination Point 
Required

If Media Termination Point is used to implement features that H.323 
does not support (such as hold and transfer), select Yes. 

Retry Video Call As Audio Applies to video endpoints that receive calls. 

Wait for Far End H.245 
Terminal Capability Set

Specifies that Cisco Unified Communications Manager needs to 
receive the far-end H.245 Terminal Capability Set before it sends its 
H.245 Terminal Capability Set. 

MLPP Domain Multilevel Precedence and Preemption (MLPP) Domain to associate 
with this device. 

Significant Digits Value Represents the number of final digits that are retained on inbound calls.

Calling Search Spaces Specifies the collection of Route Partitions that are searched to 
determine how a collected (originating) number should be routed. 

AAR Calling Search Space Specifies the collection of route partitions that are searched to 
determine how to route a collected (originating) number that is 
otherwise blocked due to insufficient bandwidth. 

Prefix DN The prefix digits that are appended to the called party number on 
incoming calls. 

Redirecting Number IE 
Delivery - Inbound

Selecting Yes accepts the Redirecting Number IE in the incoming 
SETUP message to the Cisco Unified Communications Manager. 

Calling Party Selection Any outbound call on a gateway can send directory number 
information. Choose which directory number is sent.

Calling Party Presentation Choose whether you want the Cisco Unified Communications Manager 
to allow or restrict the display of the calling party phone number. 

Called Party IE Number Type 
Unknown

Choose the format for the number type in called party directory 
numbers. 

Calling Party IE Number 
Type Unknown

Choose the format for the number type in calling party directory 
numbers. 

Called Numbering Plan Choose the format for the numbering plan in called party directory 
numbers. 
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Calling Numbering Plan Choose the format for the numbering plan in calling party directory 
numbers. 

Caller ID DN Enter the pattern that you want to use for calling line ID, from 0 to 24 
digits.

Display IE Delivery Enables delivery of the display IE in SETUP, CONNECT, and NOTIFY 
messages for the calling and called party name delivery service. 

Redirecting Number IE 
Delivery - Outbound

Includes the Redirecting Number IE in the outgoing SETUP message 
from the Cisco Unified Communications Manager to indicate the first 
redirecting number and the redirecting reason of the call when the call 
is forwarded. 

Packet Capture Mode Configure this field if you need to troubleshoot encrypted signaling 
information for the H.323 gateway. 

Packet Capture Duration Configure this field if you need to troubleshoot encrypted signaling 
information for the H.323 gateway. 

SRTP Allowed Select Yes if you want Cisco Unified Communications Manager to 
allow secure and nonsecure calls over the gateway. 

Version Stamp Not used

CTI Not used.

Table 5-15 Hunt Pilot Infrastructure Data Object Fields

Field Description

Pattern The hunt pilot, including numbers and wildcards (do not use spaces). 

Route Partition If you want to use a partition to restrict access to the hunt pilot, choose 
the desired partition.

Description Optional description.

Numbering Plan Choose a numbering plan. 

Route Filter If your hunt pilot includes the @ wildcard, you may choose a route 
filter.

MLPP Precedence MLPP precedence setting.

Hunt List Choose the hunt list for which you are adding a hunt pilot.

Urgent Priority Select Yes to interrupt interdigit timing when Cisco Unified 
Communications Manager must route a call immediately. 

Block Enabled Enable or disable block.

Release Cause Dependant on the Block Enabled field.  If a release cause is selected, 
then Block Enabled must be set to True.

Use Calling Party’s External 
Phone Number Mask

Select Yes if you want the full, external phone number to be used for 
calling line identification (CLID) on outgoing calls.

Calling Party Transformation 
Mask

Enter a transformation mask value.

Table 5-14 H323 Gateway Infrastructure Data Object Fields (continued)

Field Description
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Calling Party Prefix Digits 
(Outgoing Calls)

Enter the prefix digits. 

Calling Line Presentation Used as a supplementary service to allow or restrict the originating 
caller's phone number on a call-by-call basis.

Calling Name Presentation Used as a supplementary service to allow or restrict the originating 
caller's name on a call-by-call basis. 

Connected Line Presentation Used as a supplementary service to allow or restrict the called party's 
phone number on a call-by-call basis. 

Connected Name 
Presentation

Used as a supplementary service to allow or restrict the called party's 
name on a call-by-call basis. 

Called Party Discard Digits Select the discard digits instructions that you want to associate with this 
hunt pilot.

Called Party Transformation 
Mask

Enter a transformation mask value. 

Called Party Prefix Digits 
(Outgoing Calls)

Enter the prefix digits.

Table 5-16 Line Group Infrastructure Data Object Fields

Field Description

Name Name.

RNA Reversion Timeout Enter a time, in seconds, after which Cisco Unified Communications 
Manager will distribute a call to the next available or idle member of 
this line group or to the next line group if the call is not answered and 
if the first hunt option, “Try next member; then, try next group in Hunt 
List” is chosen.

Distribution Algorithm Select a distribution algorithm, which applies at the line group level.

Hunt Algorithm No Answer For a given distribution algorithm, select a hunt option for Cisco 
Unified Communications Manager to use if a call is distributed to a 
member of a line group that does not answer.

Hunt Algorithm Busy For a given distribution algorithm, select a hunt option for Cisco 
Unified Communications Manager to use if a call is distributed to a 
member of a line group that is busy.

Hunt Algorithm Not 
Available

For a given distribution algorithm, select a hunt option for Cisco 
Unified Communications Manager to use if a call is distributed to a 
member of a line group that is not available.

Directory Numbers Enter Directory numbers. This must be a Directory Number that 
already exist in Provisioning Manager.

Table 5-15 Hunt Pilot Infrastructure Data Object Fields (continued)

Field Description
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Table 5-17 Location Infrastructure Data Object Fields

Field Description

Name Name.

Audio Kilobits Enter the maximum amount of audio bandwidth (in kbps) that is 
available for all audio calls on the link between this location and other 
locations.

Video Kilobits Enter the maximum amount of video bandwidth (in kbps) that is 
available for all video calls on the link between this location and other 
locations. Use 0 for Unlimited and -1 for None. 

Table 5-18 Media Resource Group Infrastructure Data Object Fields

Field Description

Name Name.

Description Optional description.

Available Devices The available media resources that can be selected. 

Is Multicast for MOH Audio Click Yes to use multicast for Music On Hold Audio. 

Table 5-19 Media Resource List Infrastructure Data Object Fields

Field Description

Name Name.

Description Optional description.

Clause Not Used.

Available Media Resource 
Group Names

The available media resource groups that can be selected.

Table 5-20 Route Group Infrastructure Data Object Fields

Field Description

Name Name.

Available Members The available devices that can be chosen.

Ports If the device supports individually configurable ports, choose the port.

Table 5-21 Route Partition Infrastructure Data Object Fields

Field Description

Name Name.

Description Optional description.
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Table 5-22 Route Pattern Infrastructure Data Object Fields

Field Description

Pattern The route pattern, including numbers and wildcards. Must be a valid 
route pattern.

Route Partition If you want to use a partition to restrict access to the route pattern, 
select the desired partition.

Description Optional description.

Numbering Plan Numbering plan. The default setting is NANP.

Route Filter If your route pattern includes the @ wildcard, you may choose a route 
filter. 

MLPP Precedence MLPP precedence setting.

Gateway or Route List Choose the gateway or route list for which you are adding a route 
pattern. 

Is Gateway Destination Type 
Gateway

Indicates whether the destination device is a gateway.

Urgent Priority If Yes is selected, the interdigit timing is interrupted when Cisco 
Unified Communications Manager must route a call immediately.

Block Enabled Enables or disables block.

Release Cause Dependant on the Block Enabled field.  If a release cause is selected, 
then Block Enabled must be set to True.

Call Classification Indicates whether the call that is routed through this route pattern is 
considered either off (OffNet) or on (OnNet) the local network.

Allow Device Override If Yes is selected, the system uses the Call Classification setting that is 
configured on the associated gateway or trunk to consider the outgoing 
call as OffNet or OnNet. 

Provide Outside Dial Tone If Yes is selected, outside dial tone is provided.

Use Calling Party's External 
Phone Number Mask

Select Yes if you want the full, external phone number to be used for 
calling line identification (CLID) on outgoing calls. 

Calling Party Transformation 
Mask

Transformation mask value. 

Calling Party Prefix Digits 
(Outgoing Calls)

Prefix digits. 

Calling Line ID Presentation Determines whether you want Cisco Unified Communications 
Manager to allow or restrict the display of the calling party's phone 
number on the called party's phone display for this route pattern. 

Calling Name Presentation Determines whether you want the Cisco Unified Communications 
Manager to allow or restrict the display of the calling party's name on 
the called party's phone display for this route pattern. 

Connected Line ID 
Presentation

Determines whether you want Cisco Unified Communications 
Manager to allow or restrict the display of the connected party's phone 
number on the calling party's phone display for this route pattern. 
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Connected Name 
Presentation

Determines whether you want Cisco Unified Communications 
Manager to allow or restrict the display of the connected party's name 
on the calling party's phone display for this route pattern. 

Called Party Discard Digits 
(Outgoing Calls)

Determines the discard digits instructions that you want to associate 
with this route pattern.

Called Party Transformation 
Mask

Transformation mask value.

Called Party Prefix Digits 
(Outgoing Calls)

Prefix digits.

Table 5-23 Translation Pattern Infrastructure Data Object Fields

Field Description

Translation Pattern Translation pattern, including numbers and wildcards.

Route Partition Available route partitions.

Description Optional description.

Dial Plan Numbering plan.

Route Filter Optional route filter.

MLPP Precedence MLPP precedence settings.

Call Search Space Available calling search spaces.

Block Enabled Enables or disables block.

Release Cause Dependant on the Block Enabled field.  If a release cause is selected, 
then Block Enabled must be set to True.

Use Calling Party Transform 
Mask

Determines whether or not to use the calling party’s transformation 
mask.

Calling Party Transform 
Mask

Transformation mask value. 

Calling Party Prefix Digits 
(Outgoing Calls)

Prefix digits.

Calling Line ID Presentation Determines whether you want Cisco Unified Communications 
Manager to allow or restrict the display of the calling party's phone 
number on the called party's phone display for this translation pattern. 

Calling Name Presentation Determines whether you want Cisco Unified Communications 
Manager to allow or restrict the display of the calling party's name on 
the called party's phone display for this translation pattern. 

Connected Line ID 
Presentation

Determines whether you want Cisco Unified Communications 
Manager to allow or restrict the display of the connected party's phone 
number on the calling party's phone display for this translation pattern. 

Connected Name 
Presentation

Determines whether you want Cisco Unified Communications 
Manager to allow or restrict the display of the connected party's name 
on the calling party's phone display for this translation pattern. 

Table 5-22 Route Pattern Infrastructure Data Object Fields (continued)

Field Description
5-33
User Guide for Cisco Unified Provisioning Manager

OL-13116-01



 

Chapter 5      Administering Infrastructure
Using Templates—Infrastructure Configuration
Called Party Discard Digits The discard digits instructions that you want to be associated with this 
translation pattern.

Called Party Transform Mask Transformation mask value.

Called Party Prefix Digits 
(Outgoing Calls)

Prefix digits.

Table 5-24 Voicemail Pilot Infrastructure Data Object Fields

Field Description

Number Voicemail pilot number.

Description Optional description.

Calling Search Space Available calling search spaces.

Is Default Indicates whether this pilot number is the default Voice Mail Pilot for 
the system. 

Table 5-25 Voicemail Profile Infrastructure Data Object Fields

Field Description

Name Name.

Description Optional description.

Voicemail Pilot Available voicemail pilots.

Voicemail Box Mask The mask that is used to format the voice mailbox number for 
auto-registered phones.

Is Default Indicates whether this voicemail profile is the default for the system.

Table 5-26 Voice Region Infrastructure Data Object Fields

Field Description

Name Name.

Default Codec Codec setting.

Note For Cisco Unified Communications Manager 4.1 and earlier, 
the Default Codec field is set to G.711 no matter what selection 
is made. For later versions of Cisco Unified Communications 
Manager the value is set to the option selected.

Table 5-23 Translation Pattern Infrastructure Data Object Fields (continued)

Field Description
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Creating Configuration Templates

Step 1 Select Infrastructure Configuration > Provision Network > Configuration Templates. The View 
Configuration Template page appears.

Step 2 Click the New icon ( ). A prompt appears. 

Step 3 Enter a name for the Configuration Template, then click OK. The Set up Configuration Template page 
appears. Now you can add items to the template (see Adding Items to a Configuration Template, page 
5-35).

Adding Items to a Configuration Template

This section describes how to add items to a Configuration Template. The items that you add can be 
either individual objects or existing Configuration Templates.

You can specify unique names for these infrastructure objects based on the Domain and/or Service Area 
that they belong to by incorporating the variables DOMAIN and SERVICEAREA in the infrastructure 
object names. When the Configuration Template is pushed, Provisioning Manager replaces DOMAIN and 
SERVICEAREA with the name of the Domain and Service Area, respectively, so that new objects are 
automatically assigned unique names. This provides the infrastructure elements required for 
Provisioning Manager partitioning on Cisco Unified Communications Manager, Cisco Unified 
Communications Manager Express, or Cisco Unity Express. 

Configuration is performed in the order that is defined in the Configuration Template. The same 
dependencies exist for configuring these objects automatically that exist for configuring them manually. 
Therefore you must ensure that objects are defined in the Configuration Template in the appropriate 
order. For more information regarding these dependencies and other requirements, refer to the 
appropriate Cisco Unified Communications Manager, Cisco Unified Communications Manager Express, 
or Cisco Unity Express documentation.

Note Many of the infrastructure data object fields allow you to add items to the lists and let you move the items 
up and down in the lists. For information on these operations, see the following:

• Adding Items to Lists, page 5-39

• Changing the Order of Items, page 5-40

Step 1 Open the Set up Configuration Template page (see Creating Configuration Templates, page 5-35).

Step 2 Click the Choose an Existing Configuration Template icon ( ). The Choose a Configuration dialog box 
appears.

Step 3 Click the desired Configuration Template. The template appears.

Step 4 Click Add a new item. The Add a Configuration Template Item page appears. 

Step 5 In the Add field, do one of the following:

• If you want to create a new item, click New Item and go to Step 6.
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• If you want to add an existing Configuration Template to this template, click Existing 
Configuration Template then complete the following:

a. In the page that appears, select the desired Configuration Template.

b. Click Save. The Configuration Template is added.

c. Go to Step 7.

Step 6 In the Device Type field, select a device type. Your options are Cisco Unified Communications Manager, 
Cisco Unified Communications Manager Express, or Cisco Unity Express.

• If you select either CallManager Express or Unity Express, the Commands field appears. Do the 
following:

a. Enter the appropriate Cisco IOS commands. Cisco IOS commands are applied to the device in 
Configuration Terminal mode for Cisco Unified Communications Manager Express. For Cisco 
Unity Express, if you want to execute commands in Configuration Terminal mode, you will 
need to add the command conf t to the template first.

Note If your device requires you to enter any submodule mode commands, you must enter the 
commands to enter and exit the submodule modes. Also, Provisioning Manager does not 
check the syntax of your commands.

b. Click Save. The item is added to the Configuration Template.

• If you select CallManager, do the following:

a. In the Item Type list, select an infrastructure data object. The screen refreshes, displaying the 
options for the object selected. The options will very depending on the object selected (for 
descriptions of the fields for each infrastructure data object, see Table 5-9 through Table 5-26).

b. Complete the fields as required. If any drop-down list does not contain an item that you require, 
see Adding Items to Lists, page 5-39.

c. Click Save. The item is added to the Configuration Template.

Step 7 You can do one or more of the following:

• Add another item to the Configuration Template; go to Step 4 of this procedure.

• Change the order of the items in the Configuration Template (see Changing the Order of Items, page 
5-40).

• Create a copy of an item in the Configuration Template (see Creating Copies of Items, page 5-40). 

• Exit from the Configuration Template; click Exit.

Working with Keyword Substitution

If you are creating Configuration Templates that use the same defined parameter multiple times, you can 
set up a keyword substitution to simplify the process. Keyword substitution allows you to create a string, 
and wherever that string appears in a Configuration Template, it is replaced by the value that is associated 
with it.

Adding a Keyword

Step 1 Open the Set up Configuration Template page (see Creating Configuration Templates, page 5-35).
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Step 2 Do one of the following:

• If you want to add a keyword to a new list, click the New icon ( ) next to Keyword Substitution 
List. 

A new keyword list is created. 

• If you want to add a keyword to an existing list, select the list, then click the Edit icon ( ). 

The Keyword List page appears. You can change the keyword list name by clicking the name of the 
list and in the dialog box that opens, enter a new name, then click OK.

Step 3 Enter a string in the Keyword field. The string must start with a dollar sign ($). 

Tip It is also recommended that you place brackets {} around the variable. Keyword replacement 
fails if additional characters are added to the end of the keyword. The brackets prevent you from 
mistakenly placing characters at the end of the keyword.

The string should look like the following:

${Region}

Step 4 Enter a corresponding value in the Value field. For an example, enter San Jose.

Step 5 Click Update.

Step 6 Click Done.

Now, in this example, whenever you enter the string $(Region), the value San Jose will be substituted 
for the string. 

Figure 5-4 shows an example of a Configuration Template that uses keyword substitution. This example 
creates route partitions and call search spaces with keywords, with a keyword list named San Jose that 
has one keyword (Site = SJ).
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Figure 5-4 Configuration Template Using Keyword Substitution

Editing a Keyword

Step 1 Open the Set up Configuration Template page (see Creating Configuration Templates, page 5-35).

Step 2 In the Keyword Substitution List field, select the keyword list that contains the keyword that you want 
to edit. 

Step 3 Click the Edit icon ( ). The Keyword List page appears.

Step 4 Change the value as needed.

Step 5 Click Update.

Step 6 Click Done.

Deleting a Keyword

Step 1 Open the Set up Configuration Template page (see Creating Configuration Templates, page 5-35).

Step 2 In the Keyword Substitution List field, select the keyword list that contains the keyword that you want 
to delete. 

Step 3 Click the Edit icon ( ). The Keyword List page appears.

Step 4 Select the box in the Remove column for the keyword you want to delete.

Step 5 Click Update.

Step 6 Click Done.
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Deleting a Keyword List

Step 1 Open the Set up Configuration Template page (see Creating Configuration Templates, page 5-35).

Step 2 In the Keyword Substitution List field, select the keyword list that you want to delete. 

Step 3 Click the Edit icon ( ). The Keyword List page appears.

Step 4 Click the Delete icon ( ).

Step 5 In the confirmation box, click OK.

Updating an Existing Template

Step 1 Select Infrastructure Configuration > Provisioning Network > Configuration Templates. The Set 
up Configuration Template page appears.

Step 2 Click the Chooser icon ( ). The Choose a Configuration Template dialog box appears.

Step 3 Select the Configuration Template that you require. The Set up Configuration Template page appears 
with the information for the template displayed.

Step 4 Update the information as required.

Adding Items to Lists

The lists in the infrastructure data object fields display the items that already exist on the Cisco Unified 
Communications Managers only. You can also define items in a Configuration Template that are created 
when the Configuration Template is pushed. The new items will only exist ounce the Configuration 
Template is pushed. These items may be requirements for other items in the same Configuration 
Template.

For this reason, Provisioning Manager provides the ability to manually add options to the lists. For 
example, you can define a route partition and a call search space in the same Configuration Template. 
To define the call search space item in the Configuration Template, you must specify a route partition, 
but the route partition will not appear as an option in the Configuration Template because it has not been 
created.

This procedure demonstrates how you could add the name of the route partition to the list in the 
Configuration Template for the call search space.

Step 1 In the Add a Configuration Template page (see Updating an Existing Template, page 5-39), click the “+” 
beside the list. A prompt appears. 

Step 2 Enter a name for the option, then click OK. The option appears in the list. 
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Changing the Order of Items

The order of items in a Configuration Template defines the order that they will be auto-configured in 
when the template is pushed. By clicking the up and down arrows beside the item number, you can 
change the order of the following:

• Template items.

• Items in infrastructure data object fields—Not all items can be reordered. If the items in a field can 
be reordered, up and down arrows appear next to the field. 

Changing the Order of Template Items

Step 1 In the Set up Configuration Template page (see Updating an Existing Template, page 5-39), click the Up 
or Down arrow beside the appropriate item. The item is moved.

Changing the Order of Items in the Infrastructure Data Object Fields

Step 1 In the Add a Configuration Template page (see Updating an Existing Template, page 5-39), select the 
item to move.

Note The item must reside in a reorderable infrastructure data object field.

Step 2 Click the up or down arrows beside the field. The item is moved.

Editing Items

You can edit an item after it is added to a Configuration Template.

Step 1 In the Set up Configuration Template page (see Updating an Existing Template, page 5-39), click the 
Edit icon ( ) for the item you want to edit. The Edit a Configuration Template Item page appears. 

Step 2 Make the appropriate changes.

Step 3 Click Update.

Creating Copies of Items

You can create a duplicate of a template item on a Configuration Template and then edit it. This allows 
you to create multiple versions of the same item.

Step 1 In the Set up Configuration Template page (see Updating an Existing Template, page 5-39), click the 
Copy icon ( ) for the item you want to copy.

A copy of the item is added to the Configuration Template. You can edit the copy as required.
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Deleting Items

You can delete items from a Configuration Template.

Step 1 In the Set up Configuration Template page (see Updating an Existing Template, page 5-39), click the 
Delete icon ( ) beside the item that you want to delete.

A message appears, asking you to confirm.

Step 2 Click OK. The item is deleted.

Renaming Configuration Templates

Step 1 In the Set up Configuration Template page (see Updating an Existing Template, page 5-39), click the 
Configuration Template name. A dialog box appears.

Step 2 Type the new name and then click OK. The name is changed.

Creating Copies of Configuration Templates
You can create a copy of an entire Configuration Template and then edit it as required.

Step 1 In the Set up Configuration Template page (see Updating an Existing Template, page 5-39), click the 
Copy icon ( ) beside the Configuration Template name. 

A copy of the Configuration Template is created with _copy added to the name.

Step 2 Rename and edit the Configuration Template as required.

Deleting Configuration Templates
You can delete Configuration Templates.

Step 1 In the Set up Configuration Template page (see Updating an Existing Template, page 5-39), click the 
Delete icon ( ) beside the Configuration Template name. A message appears, asking you to confirm.

Step 2 Click OK. The Configuration Template is deleted.
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Generating a Configuration Using a Template
You apply Configuration Templates by pushing them to the appropriate Domain, Service Area, and/or 
device.

Step 1 Open the Set up Configuration Template page (see Updating an Existing Template, page 5-39) for the 
template.

Step 2 Select a Domain. The Service Areas and devices lists are populated with the Service Areas and devices 
that belong to the selected Domain.

Step 3 Select a Service Area and/or device. Selecting a Service Area updates the device list, only showing 
devices that belong to the selected Service Area. 

Note After selecting a Service Area or device, each template item displays Supported or Unsupported. 
If an item is unsupported, it is not a valid template item for the device selected or devices in the 
Service Area. The template item will not be added to the generated template. 

Step 4 (Optional) select Keyword List. This is only required if the template contains keywords.

Step 5 Click Generate Configuration. A message appears, asking you to confirm.

Step 6 Click OK. The configuration is generated and the Batch Project page appears. For information on 
scheduling the provisioning of the configuration, see Working with Batch Projects, page 5-45.

Using Batch Provisioning
Provisioning Manager enables you to create users and provision their services automatically through 
batch provisioning. Batch provisioning enables you to easily roll out a new office, or transition from 
legacy systems. 

To complete batch provisioning, you must do the following:

1. Create a spreadsheet of users and the services to be provisioned (this typically includes phones and 
lines), then convert the spreadsheet to a tab-delimited text file called a batch action file. 

2. Upload the batch action file into a Provisioning Manager batch project.

3. Run the batch project or schedule it to run later. Provisioning Manager creates the users and 
provisions the lines and phones based on the data in the file.

You can also view a list of scheduled projects, and the details of the projects that are in progress.

Creating Batch Action Files
Batch action files must contain a single row of column headers. The data columns can be in any order, 
but must be in a tab-delimited text file. You can compile the data in any text editor, provided that the 
resulting file conforms to these guidelines. For example, you can create batch files in Microsoft Excel 
and then export them as tab-delimited files.

Provisioning Manager provides sample files that contain most of the commonly used actions. The sample 
files are located in the <Installation Directory>/sep/ipt/config/sample/batchProvisioning folder.
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Required Columns

Table 5-27 describes the columns that are required for every batch action file.

Table 5-28 lists the additional columns that are required when new users are being created.

Guidelines for Creating Batch Action Files

Note Sample batch files are provided for you. They are located on the Provisioning Manager system in the 
<installation directory>/sep/ipt/config/sample/batchProvisioning folder. You can add additional 
columns to the sample batch files as required.

When creating batch action files, keep in mind the following guidelines:

• If you want the users that will be created to have self-care accounts, you must enable the 
CreateSelfCareAccounts rule for all applicable Domains.

• MAC Address is required when ProductName is Phone (or a bundle containing a Phone) and Phone 
Type is not a virtual phone (for example, CTI Port). 

Table 5-27 Batch Action File Required Columns

Column Description

Order Type The order type. Valid options are: 

• Add

• Cancel

• Change (change only applies for phones) 

User ID Provisioning Manager user ID to provision the order for.

Product Name The product name. Note that the input varies depending on the order type:

• Add orders—Must be an orderable product (including bundles), but cannot be a 
subtype (for example, you would use “Phone” instead of “Cisco 7960”).

• Cancel—Can be any product name that appears in the user’s subscriber record. 
Note that this does not include bundles. Dependent objects are automatically 
deleted when their parent is deleted.

• Change—Phone. 

Service Area Name of the Service Area to order against.

Table 5-28 Batch Action File Columns for New Users

Column Description

First Name User’s first name. 

Last Name User’s last name.

Domain (Optional) Domain to place the new user in.

Phone Number (Optional) Phone number for the new user. 

Email (Optional) Email address for the new user. 

Department (Optional) Department for the new user.
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• New MAC Address is required when changing phones. 

• Object Name is required when cancelling products.

• Cisco Unity devices (Cisco Unity, Cisco Unity Connection, and Cisco Unity Express) do not support 
all products and services. If the batch action file is configured for a product which is not supported 
by the device in the specified Service Area, batch provisioning will fail. For a list of supported 
products and services, see Table 3-2.

• Product attributes that require user input during the manual order entry process are required to 
successfully complete the equivalent order in a batch project. Examples include:

– Phone Type—Type of phone (for example, Cisco 7960, Cisco 7912) if ordered product is a 
Phone or a bundle that contains a Phone.

– Line Type—Type of line (for example, Auto-Assigned Line or Chosen Line) if ordered product 
is a Line or a bundle that contains a Line.

– Directory Number—Required when ProductName is Line and Type is Chosen Line. 
Additionally, ordering a product with a dependency that is not met by the order itself (for 
example, ordering a single Line) requires a column specifying the dependent object. Examples 
include: 

• If the product being ordered has a dependency that is not met by the order itself (for example, a 
single Line), a column specifying the dependent object is required. Examples include: 

– SelectedPhone—MAC Address of phone to add the line to.

– SelectedLine—Directory number of the line to add voicemail.

– SelectedVoicemail—Directory number of the voicemail to add unified messaging to.

– SelectedEM_Access—Name of the EM_Access (device profile) to add the EM_Line to.

Bundles that contain more than one instance of a base product (for example, phone service with extra 
line) require their attributes to be specified with a (1), (2), and so on, at the end of the column name. 
For example, Line Type(1), Directory Number(1).

Speed dial information can be provided directly or indirectly. If provided directly, the expected 
format is index=number=label, repeated for each speed dial, semicolon delimited, where index is 
the position of the speed dial (for example; 1, 4, 5, and so on), number is the phone number, and 
label is the speed dial name (for example, 1=8675306=Jenny;4=888=Voicemail). Alternatively, 
speed dials can be provided as one set of fields called Speed Dial n (where n is the speed dial 
position), and a matching set of fields called Speed Dial n Name. 

Creating Batch Projects
After you create a batch action file, you must create the batch project that it belongs to. When you upload 
a batch action file, its contents are converted to batch actions, and the columns that are common to all 
batch actions in the batch action file are displayed.

Note You must upload batch action files in the correct order according to any dependencies that exist between 
the batch actions. For more information about these dependencies, see Guidelines for Creating Batch 
Action Files, page 5-43.

Step 1 Select Infrastructure Configuration > Provisioning Network > Batch Provisioning. The Configure 
a Batch Project page appears.
5-44
User Guide for Cisco Unified Provisioning Manager

OL-13116-01



 

Chapter 5      Administering Infrastructure
Using Batch Provisioning
Step 2 Click the New icon ( ). The Create a New Batch Project page appears.

Step 3 Type a name and notes for the batch project and then click Create. The batch project is created. 

You can now upload one or more batch action files to the batch project. 

Step 4 In the Configure a Batch Project screen, click Upload a Batch Action File. The Upload a Batch Action 
file page appears.

Step 5 Do one of the following

• In the File to Upload field, type the full directory path and file name of the file to be uploaded.

• Click Browse and then locate and click the file to be uploaded.

Step 6 Click Add. The file is uploaded and its contents are displayed on the Configure a Batch Project page.

Step 7 You can do one or more of the following:

• Upload another batch action file (repeat this procedure).

• Run the batch project immediately (see Running a Batch Project, page 5-46).

• Schedule the batch project to be run later (see Scheduling or Rescheduling a Batch Project, page 
5-46).

Editing Batch Projects

It is currently not possible to edit batch projects or batch action files in Provisioning Manager. Instead, 
you can update the batch action files manually and then upload them into a new batch project, and delete 
the batch projects that you no longer require.

Deleting Batch Projects

You can delete batch projects that you no longer require.

Step 1 Select Infrastructure Configuration > Provisioning Network > Batch Provisioning. The Configure 
a Batch Project page appears.

Step 2 Click the Chooser icon ( ). The Choose a Batch Project dialog box appears.

Step 3 Select the batch project that you require. The Configure a Batch Project page appears.

Step 4 Click the Delete icon ( ) beside the batch project name. A message appears, asking you to confirm.

Step 5 Click OK. The batch project is deleted.

Working with Batch Projects
You can run a batch project immediately, or schedule it to run at a specific time. You can pause a batch 
project that is currently running, and then restart it or cancel it. After a project has been scheduled, you 
can pause it, or cancel it entirely. You can also schedule a project to be paused at a later time, for 
example, if you want to ensure that a project is paused before a scheduled maintenance down-time.
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Running a Batch Project

Step 1 Select Infrastructure Configuration > Provisioning Network > Batch Provisioning. The Configure 
a Batch Project page appears.

Step 2 Click the Chooser icon ( ). The Choose a Batch Project dialog box appears.

Step 3 Select the batch project that you require. The Configure a Batch Project page appears.

Step 4 In the Project Schedule pane, next to Project Start Date/Time, click Now. A message appears, asking you 
to confirm.

Step 5 Click OK. The batch project is started and the status changes to In Progress. (To refresh the screen, click 
the Refresh icon ( ). When the batch project has completed, the status changes to Complete. 

Scheduling or Rescheduling a Batch Project

Step 1 Select Infrastructure Configuration > Provisioning Network > Batch Provisioning. The Configure 
a Batch Project page appears.

Step 2 Click the Chooser icon ( ). The Choose a Batch Project dialog box appears.

Step 3 Select the batch project that you require. The Configure a Batch Project page appears.

Step 4 In the Project Schedule pane, next to Project Start Date/Time, click the Chooser icon ( ). A message 
appears, asking you to confirm.

Step 5 Click OK. The Select Date and Time dialog box appears.

Step 6 Specify a date and time, as well as a UTC Offset or Location (if required), and then click Select. A clock 
icon ( ) appears in the Status section to indicate that the batch project has been scheduled. 

Canceling a Batch Project

You can cancel (abort) a batch project that is in progress. Provisioning Manager completes any actions 
that are in progress, but does not submit any further actions.

Step 1 Select Infrastructure Configuration > Provisioning Network > Batch Provisioning. The Configure 
a Batch Project page appears.

Step 2 Click the Chooser icon ( ). The Choose a Batch Project dialog box appears.

Step 3 Select the batch project that you require. The Configure a Batch Project page appears.

Step 4 In the Project Schedule pane, click Abort. A warning message appears, asking you to confirm.

Step 5 Click OK. The batch project is canceled. 

Pausing a Batch Project

When you pause a batch project, Provisioning Manager completes actions that are in progress, but does 
not submit any more.
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Step 1 Select Infrastructure Configuration > Provisioning Network > Batch Provisioning. The Configure 
a Batch Project page appears.

Step 2 Click the Chooser icon ( ). The Choose a Batch Project dialog box appears.

Step 3 Select the batch project that you require. The Configure a Batch Project page appears.

Step 4 In the Project Schedule pane, next to Project Pause Date/Time, click Pause. A message appears, asking 
you to confirm.

Step 5 Click OK. A message appears, indicating that the batch project has been paused.

Step 6 Click the Refresh icon ( ). The status of the project is changed to Paused. 

Step 7 You have the following options:

• To restart the batch project, click Restart. The batch project is restarted.

• To cancel the batch project, click Abort. The batch project is canceled.

Scheduling a Batch Project to Pause

You can schedule a pause in a batch project, for example, if you have scheduled a batch project to start 
at a later time, but you want to ensure that it stops before a scheduled maintenance down-time.

Step 1 Select Infrastructure Configuration > Provisioning Network > Batch Provisioning. The Configure 
a Batch Project page appears.

Step 2 Click the Chooser icon ( ). The Choose a Batch Project dialog box appears.

Step 3 Select the batch project that you require. The Configure a Batch Project page appears.

Step 4 In the Pause Execution section, next to Project Pause Date/Time, click the Chooser icon ( ). A message 
appears, asking you to confirm.

Step 5 Click OK. The Select Date and Time dialog box appears.

Step 6 Specify a date and time, as well as a UTC Offset or Location, (if required), and then click Select. A date 
and time appear next to Pause Execution, to indicate that the batch project has been scheduled to pause.

Canceling a Scheduled Batch Project

You can cancel a scheduled batch project provided that it has not started processing.

Step 1 Select Infrastructure Configuration > Provisioning Network > Batch Provisioning. The Configure 
a Batch Project page appears.

Step 2 Click the Chooser icon ( ). The Choose a Batch Project dialog box appears.

Step 3 Select the batch project that you require. The Configure a Batch Project page appears.

Step 4 In the Project Schedule pane, next to Project Start Date/Time, click the Clear icon ( ). A message 
appears, asking you to confirm. 

Step 5 Click OK. The schedule is cleared. 
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Canceling a Scheduled Pause for a Batch Project

You can cancel a scheduled pause for a batch project.

Step 1 Select Infrastructure Configuration > Provisioning Network > Batch Provisioning. The Configure 
a Batch Project page appears.

Step 2 Click the Chooser icon ( ). The Choose a Batch Project dialog box appears.

Step 3 Select the batch project that you require. The Configure a Batch Project page appears.

Step 4 In the Project Schedule section, click the Clear icon ( ). A message appears, asking you to confirm. 

Step 5 Click OK. The scheduled pause for the batch project is cleared. 

Viewing the Current Status of a Batch Project

You can view the status of batch projects that are in progress. As a batch project is being run, 
Provisioning Manager updates the status of the batch actions. You can identify at a glance the actions 
that are being processed and their status.

Step 1 Select Infrastructure Configuration > Provisioning Network > Batch Provisioning. The Configure 
a Batch Project page appears.

Step 2 Click the Chooser icon ( ). The Choose a Batch Project dialog box appears.

Note To see details of a single running order within a batch project, administrators can also use My 
Activities (Provisioning Dashboard > Manage Activities > My Activities) to view each order as 
it is executed in the workflow.

Step 3 Select the batch project that you require. The Configure a Batch Project page appears.

The Batch Project Actions pane displays the status of each batch action project. 

Note After a batch project has completed, you can check the Subscriber Records of the users to verify 
that orders have been processed.

Viewing Batch Project Details

You can view the details of a batch project by viewing the details of the batch project actions.

Step 1 Select Infrastructure Configuration > Provisioning Network > Batch Provisioning. The Configure 
a Batch Project page appears.

Step 2 Click the Chooser icon ( ). The Choose a Batch Project dialog box appears.

Step 3 Select the batch project that you require. The Configure a Batch Project page appears. 
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Step 4 In the Batch Project Actions pane, click View in the details column. The View Batch Action Details page 
appears. This page displays all configured information for the batch project action.
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Advanced Setup

This chapter described the following advanced setup activities:

• Configuring Phone Button Templates, page 6-1

• Business Rules, page 6-2

• Configuring Provisioning Attributes, page 6-13

Configuring Phone Button Templates
The maximum number of lines allowed on a particular phone type is configured by using the phone 
button templates. 

A phone button template in Cisco Unified Communications Manager specifies the number of lines and 
speed dials that a phone can have, and where they appear on the phone. Older phone models have fixed 
templates, meaning the lines map directly to specific buttons on the phone. Newer phone models have 
more dynamic button structures. For example, the Cisco 7960 has six buttons, each of which can be 
either a line or a speed dial.

During a Cisco Unified Communications Manager infrastructure synchronization, Provisioning 
Manager retrieves all phone button templates that have been defined in Cisco Unified Communications 
Manager. There is always a set of standard phone button templates, therefore every phone type has at 
least one template.

Viewing the Maximum Number of Lines on Phone Button Templates
You can view the maximum number of lines for each phone button template of a Call Processor. Blank 
or negative values are treated as unlimited.

Step 1 Select Advanced Setup > Policies > Phone Button Templates. The Phone Button Template 
Configuration page appears.

Step 2 Select a Call Processor. 

Step 3 Click View Maximum Line Information. The Phone Button Template Maximum Line Information 
Form appears. 
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Specifying a Default Phone Button Template for a Phone Type

Step 1 Select Advanced Setup > Policies > Phone Button Templates. The Phone Button Template 
Configuration page appears.

Step 2 Select a Call Processor. The page refreshes. 

Step 3 Select a phone type. The phone type information is displayed. 

Step 4 Click Update Template List. The Phone Button Template Configuration Edit Form appears. 

Step 5 Select a template and then click Update. 

Displaying the Phone Button Template Option on Orders
You can specify whether or not the option to choose a phone button template is displayed to users when 
ordering phones by enabling the ChoosePhoneButtonTemplates business rule. If you enable this rule, the 
system provides users with the option to choose a phone button template when placing an order for a 
phone. If the rule is disabled, then no option is presented to users during the order process and the default 
templates as defined in Cisco Unified Communications Manager are used. For more information, see 
Business Rules, page 6-2.

Business Rules 
This section provides details on the standard Provisioning Manager business rules and how to modify 
them.

It contains the following sections:

• Business Rule Descriptions, page 6-3

• Using Business Rules, page 6-10

• Configuring Business Rules, page 6-12

Provisioning Manager contains a predefined set of business rules that determine how components within 
Provisioning Manager are used. These business rules control the processing of orders, the behavior of 
the synchronization processes, and the default values for various objects in the system. 

Business rules are applied at a domain level. When you install Provisioning Manager, you configure the 
business rules in the Customer Domain Template according to your business processes. When you create 
a new domain, it inherits the standard set of business rules from the Customer Domain Template. You 
can then change the business rules as required for each new domain. Changes made to the Customer 
Domain Template affect only new domains created after that point.

In addition to business rules, new domains inherit the default Subscriber Type information, and folders 
are automatically created in the Inventory Manager Instance Browser for the users, Service Areas, and 
Voice Terminals that will be placed into that Domain.
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Business Rule Descriptions
This section lists and describes the standard business rules in alphabetical order, and provides the default 
Data and Enabled settings. Rules can be data driven (Provisioning Manager uses the Data field), enabled 
or disabled driven, or both. The descriptions of the rules indicate which applies.

Note For some business rules, the Data or Enabled field is not applicable, which is indicated by N/A. All user 
input in fields marked as N/A is disregarded by the system.

AssignSoftPhoneName

Assigns a unique name to a softphone that workflow is provisioning. The Call Processor automatically 
generates the name using the value in the Data field as the prefix, then adds the CTI port counter number 
+ 1. The Call Processor checks if the combination of prefix + CTI port counter number is in use, and if 
it is, it adds 1 to the CTI port counter number until a unique combination is found.

Data SoftPhone_

Enabled true (n/a)

AssociateAllUsersInCallProcessor

If enabled, during a domain synchronization, all of the user accounts in all of the Call Processors in the 
domain will be assigned to the domain being synchronized. If disabled, only users whose department is 
the same as the domain will be assigned to the domain.

Data <blank>

Enabled false

AssociateAllUsersInUMProcessor

If this rule is enabled, all user accounts in a given Unified Message Processor are assigned to a 
Provisioning Manager Domain. Otherwise, only user accounts in the given Unified Message Processor 
with a matching Call Processor user account are assigned. 

Data <blank>

Enabled false

AssociateUsersByDeptCode

If enabled, Call Processor user accounts are associated to this Provisioning Manager Domain based on 
their department code value matching one in the specified list of values. The list of department code 
values should be enclosed in double quotes (") and separated by the delimiter (;). Department code values 
may contain wildcards (* or %).

For example, if you specify the following in the Data field:

"Dept 1";"";"Dept 2"

The Call Processor user accounts that belong to Dept 1 or Dept 2, or have no department code set, will 
be associated to the domain. 
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If the rule AssociateAllUsersInCall Processor is enabled, it takes precedence over this rule.

Data <blank>

Enabled false

ChoosePhoneButtonTemplates

If enabled, the system provides users with the option to choose a phone button template when placing 
an order. If disabled, then no option is presented to users during the order process and the default 
templates as defined in the Cisco Unified Communications Manager will be used.

Data <blank>

Enabled true

CreateSelfCareAccounts

If enabled, the system automatically creates login accounts for new subscribers so that they can submit 
their own orders. When the rule is disabled, the system still creates login accounts, but those accounts 
will not have the capability to place orders for themselves.

Data <blank>

Enabled false

DefaultCallManagerPassword

Sets the default password for new Cisco Unified Communications Manager accounts, which are created 
when a phone or line is ordered for a user for the first time. You can also use this password with a Cisco 
SoftPhone to gain access to the user-assigned lines. Minimum length is five characters.

Data admin123

Enabled true (n/a)

DefaultCallManagerPIN

Sets the default PIN to be used when a user is activated in Cisco Unified Communications Manager. A 
user is activated in Cisco Unified Communications Manager the first time a line or phone is ordered for 
the user. Beyond initially setting the PIN, this rule is not used in Provisioning Manager. Minimum length 
is 5 characters.

Data 12345

Enabled true

DefaultDeviceProfile

Used for Extension Mobility-enabled phones. The default setting of NONE (or left empty) causes the 
rule not to be used.

Data NONE

Enabled true (n/a)
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DefaultServiceName<1-5>

This rule, paired with the matching numbered DefaultServiceURL4, describes a Cisco Unified 
Communications Manager service to which all new phones/device profiles will be subscribed. You must 
specify both in a pair (the DefaultServiceName4 and the matching DefaultServiceURL4), otherwise they 
will be ignored by the system. You can specify up to 5 pairs. The system always checks for all 5 pairs.

Data <blank>

Enabled false (n/a)

DefaultServiceURL<1-5>

This rule, paired with the matching numbered DefaultServiceName1, describes a Cisco Unified 
Communications Manager service to which all new phones/device profiles will be subscribed. You must 
specify both in a pair (the DefaultServiceName1 and the matching DefaultServiceURL1), otherwise they 
will be ignored by the system. You can specify up to 5 pairs. The system always checks for all 5 pairs.

Data <blank>

Enabled false (n/a)

DefaultUnitySubscriberPassword

Sets the default password for new voicemail accounts on the Cisco Unity system. The workflow uses the 
Data value as the initial password. In Cisco Unity, this value must be an integer. Cisco Unity rejects 
trivial values, for example, 12345.

Data 53421

Enabled true (n/a)

DefaultUserType

Specifies the user type that new users are assigned by default. The value of the Data field must contain 
the name of a valid user type.

Note This rule should be set to the subscriber role that makes up most of the organization. This will ensure 
that during domain synchronization most of the users will be set up correctly.

Data Employee

Enabled true (n/a)

DescriptionString

Default description string used on new phones, new user device profiles (EM_Access), and new users. 
FIRSTNAME, LASTNAME, and EXTENSION are keywords that will be replaced with the users first 
name, last name, and their extension, respectively.

Data FIRSTNAME LASTNAME EXTENSION

Enabled true (n/a)
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DNAutoReservation

If enabled, and if the line is being moved within the same Call Processor, the directory number associated 
with a canceled line will be automatically reserved for the original owner. Directory numbers can also 
be selected manually during the order process. 

Data <blank>

Enabled false

DNAutoReservationTimeout

Specifies the period of time (days:hours) that the directory number will remain in the Reserved state. 

Data 7:0

Enabled true

EmailSender

Contains the email address to use for the From address in Provisioning Manager emails. 

Note This rule must be enabled in order to send emails from Provisioning Manager.

Data shipper@sample.com

Enabled true

ExternalNumberMasks

When enabled, the External Number mask associated with the service area of an order will be used as 
the External Phone Number Mask value on the line display for lines ordered against this Service Area. 
For change phone orders, the value for this rule is taken from the previous phone service order. But if 
the value was not set in the previous order, the Service Area value is used.

Note This rule accepts the same values as Cisco Unified Communications Manager does for external phone 
masks.

Data <blank>

Enabled true

IsAuthorizationRequiredForAddOrder

If enabled, an Approver must approve Add orders before provisioning can occur. If disabled, the system 
automatically approves Add orders.

Data <blank>

Enabled false
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IsAuthorizationRequiredForCancelOrder

If enabled, an Approver must approve Cancel orders before provisioning can occur. If disabled, the 
system automatically approves Cancel orders.

Data <blank>

Enabled false

IsAuthorizationRequiredForChangeOrder

If enabled, an Approver must approve Change orders before provisioning can occur. If disabled, the 
system automatically approves Change orders.

Data <blank>

Enabled false

LineDisplayString

Template string used to construct the Internal Caller ID display format for the phone line. If disabled, 
the system will default to FIRSTNAME LASTNAME. 

Note For Call Processors, the combination of characters for First Name and Last Name cannot exceed 30 
characters. If this limit is exceeded, when you place an order, the Call Processor sends an error.

Data FIRSTNAME LASTNAME

Enabled true

MailHost

Contains the name of the SMTP server that is used for sending Provisioning Manager emails. 

Note This rule must be enabled in order to send emails from Provisioning Manager.

Data mail.sample.com

Enabled true

MonitorPhoneReturnEnabled

If enabled, tracks whether phones have been returned by implementing an additional workflow activity 
that is assigned to the user group specified in the Data field. 

Data Shipping

Enabled false
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NameDialingInfo

This string is used to construct the auto-attendant name dialing string. FIRSTNAME LASTNAME are 
replaced, but not the extension.

Note This feature is available for Cisco Unified Communications Manager version 3.3.3 only. 

Data FIRSTNAME LASTNAME

Enabled true

OrderProvisionedEmailTemplate

If enabled, an automated email is sent to the subscriber for whom the order was placed, stating that the 
order was provisioned. 

Note For this rule to work, the EmailSender and MailHost rules must also be enabled. The value in the data 
field of this rule, which specifies the template script to use when the email is generated, should not be 
changed.

Data java://dfc.ipt.im.OrderProvisionedEmailTemplate:buildEmailTemplate 

Enabled false

OrderRejectedEmailTemplate

If enabled, an automated email is sent to the subscriber for whom the order was placed, stating that the 
order was rejected. 

Note For this rule to work, the EmailSender and MailHost rules must also be enabled. The value in the data 
field of this rule, which specifies the template script to use when the email is generated, should not be 
changed.

Data java://dfc.ipt.im.OrderProvisionedEmailTemplate:buildRejectionEmailTemplate 

Enabled false

PhoneAssignmentDoneBy

Specifies the user group that is responsible for completing the Assignment step of the workflow for a 
Phone order.

The following are the valid options:

• Receiving

• Shipping

• Assignment
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• OrderOwner (the user who initiates the order)

• None (workflow automatically assigns the phone and MAC address)

Data None

Enabled true (n/a)

PhoneReceiptDoneBy

Specifies the user or group of users that is responsible for completing the Receipt step of the workflow 
for a Phone order. The Receipt step indicates that the user has actually received the phone. 

The following are the valid options: 

• Receiving

• Shipping

• Assignment

• OrderOwner (the user who initiates the order)

• None (step is skipped)

Data None

Enabled true (n/a)

PhoneReservationTimeout

Specifies the period (in days) that a phone will stay reserved in the system. If disabled, then the phone 
will be reserved indefinitely.

Data 10

Enabled true (n/a)

PhoneShippingDoneBy

Specifies the user that is responsible for completing the Shipping step of the workflow for a Phone order. 
The following are the valid options:

• Receiving

• Shipping

• Assignment

• OrderOwner (the user who initiates the order)

• None (step is skipped)

Data None

Enabled true (n/a)
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PurgeUponUmRemoval

If enabled, a user’s email and voicemail are purged from the system when their Cisco Unity account is 
removed.

Note You enable or disable this rule by specifying true or false in the Data field. 

Data false

Enabled true (n/a)

SelfCareAccountsDefaultPassword

Specifies the default password for self-care accounts. By default, the user password is the same as the 
user ID. If you want to specify a different default password, you must specify a default password in the 
Data field and set Enabled to true.

Data <blank>

Enabled true

TakePrimaryUserInfoFromUMProcessor

If enabled, user and subscriber information is updated from the associated Unified Message Processor 
account; otherwise it is updated from the Call Processor. When the rule is enabled, you can also specify 
the Unified Message Processor ID, which takes precedence if a user has accounts on multiple Unified 
Message Processors. This value can also be left blank to indicate no preference.

Data <blank>

Enabled false

Using Business Rules
When you configure Provisioning Manager, it is critical that you plan how you will use your business 
rules. This section provides details on the business rules that you must consider depending on how you 
want the Provisioning Manager components to work. At a minimum, you must consider the following 
rules:

• AssociateAllUsersInCallProcessor

• CreateSelfCareAccounts

• EmailSender

• IsAuthorizationRequiredForAddOrder

• IsAuthorizationRequiredForCancelOrder

• IsAuthorizationRequiredForChangeOrder

• MailHost

• OrderProvisionedEmailTemplate

• OrderRejectedEmailTemplate

• PhoneAssignmentDoneBy
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• PhoneReceiptDoneBy

• PhoneShippingDoneBy

Configuring User Access

When a user cancels a line, do you want to automatically reserve that number for the specific user?

• DNAutoReservation—Toggles the reservation

• DNReservationTimeout—How long to reserve the numbers for

Do you want users to have self-care accounts?

• CreateSelfCareAccounts

• SelfCareAccountsDefaultPassword

What user type should new users get by default?

• DefaultUserType

Do you want the users of a specific domain to manage Phone Inventory?

• DomainPhoneManagement

• PhoneReservationTimeout

Do you want users to manage User Types?

• DomainUserTypeConfiguration

Configuring Domain Synchronization

During synchronization, which domain should Provisioning Manager put Cisco Unified 
Communications Manager users in? 

• AssociateUsersByDeptCode

During a domain synchronization, do you want all of the subscriber accounts in all of the Call Processors 
in the domain assigned to the domain being synchronized?

• AssociateAllUsersInCallProcessor 

During synchronization, do you want all the subscriber accounts in a given Unified Message Processor 
assigned to a domain?

• AssociateAllUsersInUMProcessor 

Configuring Products

What name do you want the CTI ports to have in Cisco Unified Communications Manager?

• AssignSoftPhoneName—See rule for default value

Do you need to reserve directory numbers?

•  DNReservationTimeout

Do you need to track if phones have been returned after having been canceled?

• MonitorPhoneReturnEnabled
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Configuring Orders

What are the default passwords you want to use for Cisco Unity or Cisco Unified Communications 
Manager accounts?

• DefaultCallManagerPassword

• DefaultCallManagerPIN

• DefaultUnitySubscriberPassword

Do you want emails sent when an order is rejected or completed? You have the option of not sending any 
emails.

Note You must enable both EmailSender and MailHost for email features to work in Provisioning Manager.

• EmailSender

• MailHost

• OrderProvisionedEmailTemplate

• OrderRejectedEmailTemplate

Is authorization required for any type of order?

• IsAuthorizationRequiredForAddOrder

• IsAuthorizationRequiredForCancelOrder

• IsAuthorizationRequiredForChangeOrder

How do you handle phone assignment, shipping, and receiving?

• PhoneAssignmentDoneBy

• PhoneReceiptDoneBy

• PhoneShippingDoneBy

When a voicemail and/or email account is canceled, should messages in the canceled voicemail and/or 
email accounts be removed as well?

• PurgeUponUmRemoval

Configuring Business Rules 
When you change business rules, you must first select the domain. You can change the values for the 
rules and whether they are enabled. You cannot change the rule names or descriptions. 

All business rules have the following properties. You can modify the Data and Enabled fields.

Property Description

Rule Name Name of the rule

Description Detailed description of the rule

Data Value to be specified for the rule

Enabled Specifies if the rule is applied. Valid values are true or 
false. 
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Note You must review the documentation for each business rule carefully to ensure that you set the Data and 
Enabled properties appropriately. 

Caution Provisioning Manager does not have a default reset capability for business rules. If you change a 
business rule’s settings and later want to return to the default settings, you will have to manually change 
the settings.

The following procedure uses the AssignSoftPhoneName rule as an example of how to change rule 
properties. 

Step 1 Select Advanced Setup > Policies > Rules. The Rule Configuration page appears. 

Step 2 Select the domain that you want to change the rule for. The Select Rule list appears. 

Step 3 Select the rule. The rule information is displayed. 

Step 4 Click the Edit icon ( ) .The Data and Enabled fields become active. 

Step 5 Make the required changes.

Step 6 Click Save. The changes are added to the AssignSoftPhoneName rule.

Configuring Provisioning Attributes
Provisioning Manager enables you to configure product attribute settings using provisioning attributes. 
Provisioning attributes are configuration settings that are applied to a product during activation. You can 
assign and configure provisioning attributes throughout different levels within Provisioning Manager. 
At order time Provisioning Manager will take into account the configured provisioning attribute 
assignments in addition to the service area settings to determine the final product configuration to be 
provisioned.

Provisioning attributes are assigned at three levels, in the following order:

• Service area

• Subscriber type

• Domain

This means that the provisioning attributes that are defined for a service area will override the 
provisioning attributes defined for a subscriber type, which override the attributes defined for a domain. 
You can override the order of precedence by using the Advance Order Options on the Order Entry page 
(see Ordering Products and Services, page 3-2). Any provisioning attribute changes you make using 
Advance Order Options take precedence over the provisioning attributes set for service area, subscriber 
type, or Domain (to use the Advance Order Options, you must be assigned the advance order role; see 
Managing Authorization Roles, page 2-11).

Note You must have administration privileges to configure the content of the provisioning attributes (see 
Managing Authorization Roles, page 2-11).
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Table 6-1 describes all possible provisioning attributes. Depending on your Provisioning Manager setup, 
all attributes may not be available to you.

Table 6-2 describes at which level (domain, subscriber type, or service area) each provisioning attribute 
can be assigned. 

Step 1 Select Advanced Setup > Policies > Provisioning Attributes. The Launching Provisioning Attributes 
Management page appears.

Step 2 Do one of the following:

• Click Domain; then, from the Choose a Domain dialog box, select the domain for which you want 
to configure the provisioning attributes. 

• Click Service Area; then, from the Choose a Service Area dialog box, select the service area for 
which you want to configure the provisioning attributes.

• Choose a subscriber role:

a. From the Subscriber Role list, choose the domain or domain template where the subscriber 
exists.

b. Click Choose Subscriber Role. The Choose a Subscriber Role dialog box appears.

c. Click the desired subscriber role.

A Provisioning Attribute Management page appears. The specific page that appears depends on which 
option you chose. Table 6-1 list all possible provisioning attributes. Depending on your Provisioning 
Manager setup, and the version of your Call Processor or Unified Message Processors, all attributes may 
not be available to you. Table 6-3 and Table 6-4 list which attributes are available for each version of the 
Call Processors and Unified Message Processors, respectively.

Note The Provisioning Attribute Management page for each object (domain, service area, and subscriber 
role), also can be accessed when configuring the respective object. For more information, see the 
following:

• Editing Provisioning Attributes for a Subscriber Role Type, page 2-8

• Editing a Domain’s Provisioning Attributes, page 5-15

• Editing a Service Area’s Provisioning Attributes, page 5-20

Step 3 Click the plus sign next to the attribute headings that contain the provisioning attributes that you want 
to configure. The attributes are displayed.

Step 4 Do one of the following:

• If you want to change the attribute settings, click the Edit icon ( ) and make the appropriate 
changes.

• If you want to delete the attribute, click the Delete icon ( ).

Step 5 When finished, click Done.
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Table 6-1 Provisioning Attribute Descriptions

Attribute Description

AAR Calling Search Space Automated alternate routing (AAR) calling search space.

AAR Group Automated alternate routing (AAR) group.

Authentication Server URL The URL that the phone uses to validate requests that are 
made to the phone web server.

Auto Answer Set auto-answer options.

Auto Line Select Enable automatic line selection.

Busy Trigger The maximum number of calls to be presented at the line 
before incurring a busy signal or being sent to call 
forwarding.

Built in Bridge Enable or disable the built-in conference bridge for the barge 
feature.

Call Pickup Group Directory number that allows users to pick up incoming calls 
within their own group.

Forward All Forward all calls.

Forward Busy External Forwards the calls when the line is in use and the busy trigger 
setting is reached. This is for external calls.

Forward No Answer External Forwards the call when the phone is not answered and it 
reaches the configured no answer ring duration. Also, if the 
destination is unregistered. This is for external calls.

Forward Busy Internal Forwards the calls when the line is in use and the busy trigger 
setting is reached.

Forward No Answer Internal Forwards the call when the phone is not answered and it 
reaches the configured no answer ring duration. Also, if the 
destination is unregistered.

Forward No Coverage External Forwards the call when either it exhausts or times out, and the 
associated hunt-pilot for coverage specifies Use Personal 
Preferences for its final forwarding. This is for External calls.

Forward No Coverage Internal Forwards the call when either it exhausts or times out, and the 
associated hunt-pilot for coverage specifies Use Personal 
Preferences for its final forwarding. This is for internal calls.

Forward Unregistered External Reroutes calls placed to a temporarily unregistered 
destination. This is for External calls.

Forward Unregistered Internal Reroutes calls placed to a temporarily unregistered 
destination. This is for internal calls.

Calling Search Space Specifies the partitions that devices can search when 
attempting to complete a call.

CME Line Configuration Template Free-form text field to input Cisco IOS commands that will 
be executed in Line configuration mode on the Cisco Unified 
Communications Manager Express.

CME Phone Configuration Template Free-form text field to input Cisco IOS commands that will 
be executed in Phone configuration mode on the Cisco 
Unified Communications Manager Express.
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Common Device Configuration Configuration of common device settings, such as the softkey 
template and user locale.

Note This attribute is not available when using the Edit 
Provisioning Attributes link (see Editing a Service 
Area’s Provisioning Attributes, page 5-20) or through 
the Provisioning Attribute Management page . You 
can only update it in the Update Service Area page 
(see Configuring Service Areas, page 5-18).

CUE User Configuration Template Free-form text field to input CLI commands for the EXEC 
and configuration modes for Cisco Unity Express. Include 
the appropriate CLI commands to enter and exit the 
configuration mode. 

CUE Voicemail Configuration 
Template

Free-form text field to input CLI commands for the mailbox 
configuration mode for Cisco Unity Express.

Description Description to identify the purpose of device.

Device Pool Device pool to be used by device.

Device Security Mode The security mode (authentication or encryption) to be used 
between the device and the Cisco Unified Communications 
Manager.

Directory URL URL of the server from which the phone obtains directory 
information.

Disable Speakerphone Disable device speakerphone.

Disable Speakerphone And Headset Disable device speakerphone and headset.

Forward All - Calling Search Space1 Call-forward all call search space.

Enable Mobile Voice Access Enable mobile voice access for the subscriber on the 
currently selectedCallProcessor. 

Enable Mobility Enable mobility feature for the subscriber on the currently 
selected CallProcessor. 

Forwarded Call Information - Caller 
Name

Causes the caller name to display upon call forward.

Forwarded Call Information - Dialed 
Number

Causes the number that was redirected to display upon call 
forward.

Forwarded Call Information - Dialed 
Number

Causes the caller number to display upon call forward.

Forwarded Call Information - 
Redirected Number

Causes the original dialed number to display upon call 
forward.

Forwarding Delay Indicates whether the internal switch begins forwarding 
packets between the PC port and the switch port on the phone 
when the phone becomes active.

Idle URL The URL that the phone displays when the phone has not 
been used for the time specified in the Idle URL timer.

Table 6-1 Provisioning Attribute Descriptions (continued)

Attribute Description
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Generic CLI Commands Free-form text field to input CLI commands that will be 
executed on the applicable processor.

Generic IOS Commands Free-form text field to input Cisco IOS commands that will 
be executed on the applicable processor.

Gratuitous ARP Disable the acceptance of Gratuitous ARP packets, which 
devices use to announce the presence of the device on the 
network.

Idle Timer Amount of time, in seconds, that elapses before the URL 
specified in the Idle URL option appears.

Information URL The URL of the help text that appears on the phone.

Location Location to use. Specifies the total bandwidth that is 
available for calls to and from this location.

Max Desk Pickup Wait Time Maximal desk pickup wait time.

Maximum Number of Calls Determines the maximum number of calls to be presented at 
the line.

Media Resource Group List Media Resource Group List to use, otherwise phone defaults 
to that specified in device pool. A Media Resource Group 
List comprises a prioritized grouping of media resource 
groups. An application chooses the required media resource, 
such as a Music On Hold server, from the available media 
resources according to the priority order that is defined in a 
Media Resource Group List.

Message Lamp Waiting Policy Configures the handset lamp illumination policy.

Messages Configures the messages URL.

MLPP Calling Search Space The calling search space to associate with the alternate party 
target (destination) number.

MLPP Domain Multilevel Precedence and Preemption (MLPP) domain that 
is associated with this device.

MLPP Indication Specifies whether a device that is capable of playing 
precedence tones will use the capability when it places an 
MLPP precedence call.

MLPP No Answer Ring Duration Alternate-party no-answer ring duration.

MLPP Preemption Specifies whether devices in the device pool that are capable 
of preempting calls in progress will use the capability when 
the devices place an MLPP precedence call.

MLPP Target Alternate-party no-answer target.

Module 1 Expansion module to use with device.

Module 1 Load Name Expansion module 1 load name.

Module 2 Expansion module to use with device.

Module 2 Load Name Expansion module 2 load name.

Network Hold Audio Source The audio source that plays when the network initiates a hold 
action.

Table 6-1 Provisioning Attribute Descriptions (continued)

Attribute Description
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Network Locale Network location associated with the phone user. The 
network location identifies a set of detailed information that 
supports the phone in a specific location, including 
definitions of the tones and cadences used by the phone.

PC Port Indicates whether the PC port on the phone is enabled or 
disabled.

PC Voice VLAN Access Indicates whether the phone allows a device attached to the 
PC port to access the voice VLAN. Setting this option to No 
(disabled) prevents the attached PC from sending and 
receiving data on the voice VLAN.

Phone Load Name The custom software for the Cisco IP Phone. Value overrides 
the default value for the current model.

Port Ranges for IP Communicator Port ranges for IP Communicator.

Privacy Enable or disable the capability of users with phones that 
share the same line to view call status and to interrupt the 
call.

Proxy Server URL URL used to proxy HTTP requests for access to non-local 
host addresses from the phone HTTP client.

Remote Destination Limit Maximal number of remote destinations for the subscriber on 
the currently selectedCallProcessor. 

Retry Video Call As Audio Applies only to video endpoints that receive a call. If this 
phone receives a call that does not connect as video, the call 
tries to connect as an audio call.

Ring Setting (Phone Active) The ring setting that is used when a phone has another active 
call on a different line.

Ring Setting (Phone Idle) The ring setting that is used when a phone has another active 
call on a different line.

Route Partition The partition to which the directory number belongs.

Note This attribute is not available when using the Edit 
Provisioning Attributes link (see Editing a Service 
Area’s Provisioning Attributes, page 5-20) or through 
the Provisioning Attribute Management page . You 
can only update it in the Update Service Area page 
(see Configuring Service Areas, page 5-18). 

Services URL URL for Cisco IP Phone Services.

Settings Access Device settings access.

Softkey Template Softkey template that determines the configuration of the 
softkeys on Cisco IP Phones.

Speed Dial Info Speed dial settings on device.

Subscriber CoS without TTS enabled Class of service template used when disabling Unified 
Messaging on subscriber account in the Unified Message 
Processor.

Table 6-1 Provisioning Attribute Descriptions (continued)

Attribute Description
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Subscriber CoS with TTS Enabled Class of service template used when enabling Unified 
Messaging subscriber account in the Unified Message 
Processor.

Subscriber Template without TTS 
Enabled

Subscriber template used when disabling Unified Messaging 
on subscriber account in the Unified Message Processor.

Subscriber Template with TTS Enabled Subscriber template used when enabling Unified Messaging 
on subscriber account in the Unified Message Processor.

User Hold Audio Source The audio source that plays when a user initiates a hold 
action.

User Locale User location associated with the phone user. The user locale 
identifies a set of detailed information to support users, 
including language, font, date and time formatting, and 
alphanumeric keyboard text information.

Video Capabilities Indicates whether the phone can participate in video calls 
when connected to an appropriately equipped PC.

Voicemail Profile Voicemail profiles assigned to a directory number.

Web Access Indicates whether the phone's internal web server is enabled 
(Yes) or disabled (No). When disabled, you cannot access a 
phone's web pages.

1. This attribute is not available when using the Edit Provisioning Attributes link (see Editing a Service Area’s Provisioning 
Attributes, page 5-20) or through the Provisioning Attribute Management page. You can use the Update Default Settings 
button on the Service Area Configuration page (see Configuring Service Areas, page 5-18) to configure the attribute, or you 
can use the Advanced Order Options button when placing an order (see Ordering Products and Services, page 3-2).

Table 6-2 Provisioning Attribute Assignment Levels

Products Provisioning Attributes Domain User Type Service Area

Enable Mobility Support Enable Mobile Voice Access x x x

Enable Mobility x x x

Max Desk Pickup Wait Time x x x

Remote Destination Limit x x x

Table 6-1 Provisioning Attribute Descriptions (continued)

Attribute Description
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Extension Mobility Line AAR Group x

Auto Answer x x x

Busy Trigger x x x

Call Pickup Group x

Calling Search Space

Display (Internal Caller ID)

External Phone Number Mask x x

Forward All - Calling Search Space x

Forward All - Destination x x x

Forward All - Voicemail x x x

Forward Busy - Calling Search Space x

Forward Busy - Destination x x x

Forward Busy - Voicemail x x x

Forward No Answer - Calling Search Space x

Forward No Answer - Destination x x x

Forward No Answer - Voicemail x x x

Forwarded Call Information - Caller Name x

Forwarded Call Information - Caller Number x

Forwarded Call Information - Dialed Number x

Forwarded Call Information - Redirected Number x

Line Text Label

Maximum Number of Calls x x x

Message Waiting Policy x x x

MLPP Calling Search Space x

MLPP No Answer Ring Duration x x x

MLPP Target x x x

Network Hold Audio Source x

No Answer Ring Duration x x x

Ring Setting (Phone Active) x

Ring Setting (Phone Idle) x

User Hold Audio Source x

Voicemail Profile x

Route Partition

Network Locale x x x

Settings Access x x x

User Hold Audio Source x

Table 6-2 Provisioning Attribute Assignment Levels (continued)

Products Provisioning Attributes Domain User Type Service Area
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Extension Mobility Access MLPP Domain x x x

MLPP Indication x x x

MLPP Preemption x x x

Expansion Module 1 x x x

Expansion Module 2 x x x

Privacy x x x

Softkey Template x

Speed Dial Info x x x

User Hold Audio Source x

User Locale x x x

Table 6-2 Provisioning Attribute Assignment Levels (continued)

Products Provisioning Attributes Domain User Type Service Area
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Line AAR Group x

Auto Answer x x x

Busy Trigger x x x

Call Pickup Group x

Calling Search Space

Display (Internal Caller ID)

External Phone Number Mask x x

Forward All x

Forward All - Calling Search Space x

Forward All - Destination x x x

Forward All - Voicemail x x x

Forward Busy - External x

Forward Busy - Calling Search Space x

Forward Busy - Destination x x x

Forward Busy - Voicemail x x x

Forward No Answer - External x

Forward No Answer - Calling Search Space x

Forward No Answer - Destination x x x

Forward No Answer - Voicemail x x x

Forwarded Call Information - Caller Name x

Forwarded Call Information - Caller Number x

Forwarded Call Information - Dialed Number x

Forwarded Call Information - Redirected Number x

Generic Line IOS Commands x x x

Line Text Label

Maximum Number of Calls x x x

Message Waiting Policy x x x

MLPP Calling Search Space x

MLPP No Answer Ring Duration x x x

MLPP Target x x x

Network Hold Audio Source x

No Answer Ring Duration x x x

Ring Setting (Phone Active) x

Ring Setting (Phone Idle) x

User Hold Audio Source x

Voicemail Profile x

Route Partition x

Table 6-2 Provisioning Attribute Assignment Levels (continued)

Products Provisioning Attributes Domain User Type Service Area
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Phone AAR Calling Search Space x

Authentication Server URL x x x

Auto Line Select x x x

Built in Bridge x x x

Calling Search Space

Common Device Configuration x

Description

Device Pool

Device Security Mode x

Directory URL x x x

Disable Speakerphone x x x

Disable Speakerphone and Headset x

Enable Extension Mobility Feature x x x

Expansion Module 1 x x x

Expansion Module 2 x x x

Forwarding Delay x x x

Gratuitous ARP x x x

Generic Phone IOS Commands x x x

Idle URL x x x

Idle Timer x x x

Information x x x

Location

Media Resource Group List x

Messages x x x

MLPP Domain x x x

MLPP Indication x x x

MLPP Preemption x x x

Module 1 Load Name x x x

Module 2 Load Name x x x

Network Hold Audio Source x

Network Locale x

PC Port x x x

PC Voice VLAN Access x x x

Table 6-2 Provisioning Attribute Assignment Levels (continued)

Products Provisioning Attributes Domain User Type Service Area
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Phone (continued) Phone Load Name x x x

Port Ranges for IP Communicator x x x

Privacy x x x

Proxy Server URL x x x

Retry Video Call as Audio x x x

Settings Access x x x

Softkey Template x

Speed Dial Info x x x

User Hold Audio Source x

User Locale x x x

Video Capabilities x x x

Web Access x x x

Voice Mail CUE User Configuration Template x

CUE Voicemail Configuration Template x

Unified Messaging UM Disabling Class Of Service Template x

UM Enabling Class Of Service Template x

UM Disabling Subscriber Template x

UM Enabling Subscriber Template x

Table 6-3 Supported Call Processor Provisioning Attributes

Products Provisioning Attributes

Cisco Unified 
Communications 
Manager Express

Cisco Unified Communications Manager 

4.0.x 4.1.x  4.2.x 5.0.x 5.1.x 6.0.x

Extension Mobility
Line

AAR Group N/A Y Y Y Y Y Y

Auto Answer N/A Y Y Y Y Y Y

Busy Trigger N/A Y N Y Y Y Y

Call Pickup Group N/A Y Y Y Y Y Y

Calling Search Space N/A Y Y Y Y Y Y

Display (Internal Caller ID) N/A Y Y Y Y Y Y

External Phone Number Mask N/A Y Y Y Y Y Y

Forward All - Calling Search Space N/A Y Y Y Y Y Y

Forward All - Destination N/A Y Y Y Y Y Y

Forward All - Voicemail N/A Y Y Y Y Y Y

Table 6-2 Provisioning Attribute Assignment Levels (continued)

Products Provisioning Attributes Domain User Type Service Area
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Extension Mobility 
Line (continued)

Forward Busy - Calling Search 
Space

N/A Y Y Y Y Y Y

Forward Busy - Destination N/A Y Y Y Y Y Y

Forward Busy - Voicemail N/A Y Y Y Y Y Y

Forward No Answer - Calling 
Search Space

N/A Y Y Y Y Y Y

Forward No Answer - Destination N/A Y Y Y Y Y Y

Forward No Answer - Voicemail N/A Y Y Y Y Y Y

Forwarded Call Information - Caller 
Name

N/A N Y Y Y Y Y

Forwarded Call Information - Caller 
Number

N/A N Y Y Y Y Y

Forwarded Call Information - 
Dialed Number

N/A N Y Y Y Y Y

Forwarded Call Information - 
Redirected Number

N/A N Y Y Y Y Y

Maximum Number of Calls N/A Y Y Y Y Y Y

Message Waiting Policy N/A Y Y Y Y Y Y

MLPP Calling Search Space N/A N N N Y Y Y

MLPP No Answer Ring Duration N/A N N N Y Y Y

MLPP Target N/A N N N Y Y Y

Network Hold Audio Source N/A Y Y Y Y Y Y

No Answer Ring Duration N/A Y Y Y Y Y Y

Route Partition N/A Y Y Y Y Y Y

Ring Setting (Phone Active) N/A Y Y Y Y Y Y

Ring Setting (Phone Idle) N/A Y Y Y Y Y Y

User Hold Audio Source N/A Y Y Y Y Y Y

Voicemail Profile N/A Y Y Y Y Y Y

Expansion Module 1 N/A Y Y Y Y Y Y

Expansion Module 2 N/A Y Y Y Y Y Y

MLPP Domain N/A Y Y Y Y Y Y

MLPP Indication N/A Y Y Y Y Y Y

MLPP Preemption N/A Y Y Y Y Y Y

Network Locale N/A Y Y Y Y Y Y

Privacy N/A N N N Y Y Y

Settings Access N/A Y Y Y Y Y Y

Speed Dial Info N/A Y Y Y Y Y Y

Table 6-3 Supported Call Processor Provisioning Attributes (continued)

Products Provisioning Attributes

Cisco Unified 
Communications 
Manager Express

Cisco Unified Communications Manager 

4.0.x 4.1.x  4.2.x 5.0.x 5.1.x 6.0.x
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Extension Mobility 
Line (continued)

Softkey Template N/A N Y Y Y Y Y

User Hold Audio Source N/A Y Y Y Y Y Y

User Locale N/A N Y Y Y Y Y

Table 6-3 Supported Call Processor Provisioning Attributes (continued)

Products Provisioning Attributes

Cisco Unified 
Communications 
Manager Express

Cisco Unified Communications Manager 

4.0.x 4.1.x  4.2.x 5.0.x 5.1.x 6.0.x
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Line AAR Group N/A Y Y Y Y Y Y

Auto Answer N/A Y Y Y Y Y Y

Busy Trigger N/A Y N Y Y Y Y

Call Pickup Group N/A Y Y Y Y Y Y

Calling Search Space N/A Y Y Y Y Y Y

Display (Internal Caller ID) N/A Y Y Y Y Y Y

External Phone Number Mask N/A Y Y Y Y Y Y

Forward All N/A Y Y Y Y Y Y

Forward All - Calling Search Space N/A Y Y Y Y Y Y

Forward All - Destination N/A Y Y Y Y Y Y

Forward All - Voicemail N/A Y Y Y Y Y Y

Forward Busy - Calling Search 
Space

N/A Y Y Y Y Y Y

Forward Busy - External N/A Y Y Y Y Y Y

Forward Busy - Destination N/A Y Y Y Y Y Y

Forward Busy - Voicemail N/A Y Y Y Y Y Y

Forward No Answer - Calling 
Search Space

N/A Y Y Y Y Y Y

Forward No Answer - External N/A Y Y Y Y Y Y

Forward No Answer - Destination N/A Y Y Y Y Y Y

Forward No Answer - Voicemail N/A Y Y Y Y Y Y

Forwarded Call Information - Caller 
Name

N/A N Y Y Y Y Y

Forwarded Call Information - Caller 
Number

N/A N Y Y Y Y Y

Forwarded Call Information - 
Dialed Number

N/A N Y Y Y Y Y

Forwarded Call Information - 
Redirected Number

N/A N Y Y Y Y Y

CME Line Configuration Template Y N/A N/A N/A N/A Y Y

Maximum Number of Calls N/A N N N N Y Y

Message Waiting Policy N/A Y Y Y Y Y Y

MLPP Calling Search Space N/A Y Y Y Y Y Y

MLPP No Answer Ring Duration N/A Y Y Y Y Y Y

MLPP Target N/A Y Y Y Y Y Y

Network Hold Audio Source N/A Y Y Y Y Y Y

No Answer Ring Duration N/A Y Y Y Y Y Y

Table 6-3 Supported Call Processor Provisioning Attributes (continued)

Products Provisioning Attributes

Cisco Unified 
Communications 
Manager Express

Cisco Unified Communications Manager 

4.0.x 4.1.x  4.2.x 5.0.x 5.1.x 6.0.x
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Line (contined) Route Partition N/A Y Y Y Y Y Y

Ring Setting (Phone Active) N/A Y Y Y Y Y Y

Ring Setting (Phone Idle) N/A Y Y Y Y Y Y

User Hold Audio Source N/A Y Y Y Y Y Y

Voicemail Profile N/A Y Y Y Y Y Y

Table 6-3 Supported Call Processor Provisioning Attributes (continued)

Products Provisioning Attributes

Cisco Unified 
Communications 
Manager Express

Cisco Unified Communications Manager 

4.0.x 4.1.x  4.2.x 5.0.x 5.1.x 6.0.x
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Phone AAR Calling Search Space N/A Y Y Y Y Y Y

Authentication Server URL N/A Y Y Y Y Y Y

Auto Line Select N/A Y Y Y Y Y Y

Built in Bridge N/A Y Y Y Y Y Y

Calling Search Space N/A Y Y Y Y Y Y

CME Phone Configuration 
Template

Y N/A N/A N/A N/A N/A N/A

Common Device Configuration N/A N N N N N Y

Description N/A Y Y Y Y Y Y

Device Pool N/A Y Y Y Y Y Y

Device Security Mode N/A Y Y Y N Y Y

Directory URL N/A Y Y Y Y Y Y

Disable Speakerphone N/A Y Y Y Y Y Y

Disable Speakerphone and Headset N/A Y Y Y Y Y Y

Expansion Module 1 N/A Y Y Y Y Y Y

Expansion Module 2 N/A Y Y Y Y Y Y

Forwarding Delay N/A Y Y Y N Y Y

Generic IOS Commands Y N/A N/A N/A N/A N/A N/A

Gratuitous ARP N/A Y Y Y Y Y Y

Idle URL N/A Y Y Y Y Y Y

Idle Timer N/A Y Y Y Y Y Y

Information N/A Y Y Y Y Y Y

Location N/A Y Y Y Y Y Y

Media Resource Group List N/A Y Y Y Y Y Y

Messages N/A Y Y Y Y Y Y

MLPP Domain N/A Y Y Y Y Y Y

MLPP Indication N/A Y Y Y Y Y Y

Module 1 Load Name N/A Y Y Y Y Y Y

Module 2 Load Name N/A Y Y Y Y Y Y

MLPP Preemption N/A Y Y Y Y Y Y

Network Hold Audio Source N/A Y Y Y Y Y Y

Network Locale N/A N N Y Y Y Y

Table 6-3 Supported Call Processor Provisioning Attributes (continued)

Products Provisioning Attributes

Cisco Unified 
Communications 
Manager Express

Cisco Unified Communications Manager 

4.0.x 4.1.x  4.2.x 5.0.x 5.1.x 6.0.x
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Note Unless certain Phone provisioning attributes are configured when placing an order, they will display 
Not Set. But when you view the phone in the Cisco Unified Communications Manager user interface, the 
attributes will appear as being set to a default value. This occurs because the Cisco Unified 
Communications Manager AXL interface does not return default values to Provisioning Manager for 
these attributes when provisioning a phone.

Phone (continued) PC Port N/A Y Y Y Y Y Y

PC Voice VLAN Access N/A Y Y Y Y Y Y

Phone Load Name N/A Y Y Y Y Y Y

Port Ranges for IP Communicator N/A Y Y Y Y Y Y

Privacy N/A Y Y Y Y Y Y

Proxy Server URL N/A Y Y Y Y Y Y

Retry Video Call as Audio N/A Y Y Y Y Y Y

Services N/A Y Y Y Y Y Y

Settings Access N/A Y Y Y Y Y Y

Softkey Template N/A Y Y Y Y Y Y

Speed Dial Info Y Y Y Y Y Y Y

User Hold Audio Source N/A Y Y Y Y Y Y

User Locale N/A N Y Y Y Y Y

Video Capabilities N/A Y Y Y Y Y Y

Web Access N/A Y Y Y Y Y Y

Table 6-4 Supported Unified Message Processor Provisioning Attributes

Product Group Provisioning Attribute

Cisco Unity Express Cisco Unity Unity 
Connection2.1.x 2.2.x 2.3.x 4.0.x 4.1.x  5.0.x

Voicemail CUE User Configuration Template Y Y Y N/A N/A N/A N/A

CUE Voicemail Configuration 
Template

Y Y Y N/A N/A N/A N/A

Unified Messaging UM Disabling Class Of Service 
Template

N/A N/A N/A Y Y Y Y

UM Enabling Class Of Service 
Template

N/A N/A N/A Y Y Y Y

UM Disabling Subscriber Template N/A N/A N/A Y Y Y Y

UM Enabling Subscriber Template N/A N/A N/A Y Y Y Y

Table 6-3 Supported Call Processor Provisioning Attributes (continued)

Products Provisioning Attributes

Cisco Unified 
Communications 
Manager Express

Cisco Unified Communications Manager 

4.0.x 4.1.x  4.2.x 5.0.x 5.1.x 6.0.x
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This applies to the following provisioning attributes:

• Auto Line Select

• Disable Speakerphone

• Disable Speakerphone and Headset

• Forwarding Delay

• Gratuitous ARP

• PC Port

• PC Voice VLAN Access

• Port Ranges for IP Communicator

• Retry Video Call as Audio

• Settings Access

• Video Capabilities

• Web Access
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C H A P T E R 7

Administering Provisioning Manager

This chapter includes the following topics:

• Viewing Licensing Information, page 7-1

• Launching Cisco Unified Operations Manager IP Phone Details, page 7-3

• Managing Log Files, page 7-4

• Maintaining Data, page 7-5

• Scheduling Synchronizations, page 7-12

• Searching Inventory, page 7-13

• Viewing System Reports, page 7-21

Viewing Licensing Information
The License Status Information page displays the following:

• Unavailable features—Any features in Provisioning Manager that you do not have access to, 
because you do not have the appropriate license or because you have reach the limit for the use of 
the feature.

• Features in overdraft state—Any features that you are using that have exceeded their allowable use 
limit.

• All valid features—List of features and their corresponding use limit (Available), overuse allowed 
(Overdraft), current use (Used) and date of expiration (Expiry).

Step 1 Select System Administration > License Information. The License Status Information page appears.

Licensing Process
The Provisioning Manager license file includes support for at least 1,000 phones. You can purchase 
incremental licenses for additional phone support and register up to 30,000 phones with a single 
Provisioning Manager. For each incremental license that you purchase, you will receive a PAK, and you 
must use that PAK to obtain a license file.
7-1
User Guide for Cisco Unified Provisioning Manager



 

Chapter 7      Administering Provisioning Manager
Viewing Licensing Information
This process applies to new installations and license upgrades.

1. Obtain a Product Authorization Key (PAK)—The PAK is used to register Provisioning Manager, and 
any additional device support that you might purchase for Provisioning Manager, on Cisco.com, and 
it contains resource limitations. See Obtaining a PAK, page 7-2.

2. Obtain a license file—A license file is sent to you after you register the PAK on Cisco.com. See 
Obtaining a License File, page 7-2.

3. Copy the license file to the server where Provisioning Manager is to be installed. If Provisioning 
Manager is already installed and you are upgrading your license file, you must register the license 
file with Provisioning Manager. See Registering a License File with Provisioning Manager, page 
7-2.

Obtaining a PAK

The PAK is located on the software claim certificate that is shipped with theProvisioning Manager 
product CD.

Obtaining a License File

Step 1 Register the PAK and the MAC address of the system where Provisioning Manager is installed with 
Cisco.com at http://www.cisco.com/go/license. You will be asked to log in. You must be a registered user 
of Cisco.com to log in.

Note The MAC address is required because licensing uses node-locking technology. The license file can only 
be used with the MAC address that you supply. The license file will be emailed to you. After you obtain 
a license file, register the license with the Provisioning Manager server.

The license file will be emailed to you. After you obtain a license file, register the license with the 
Provisioning Manager server. 

Registering a License File with Provisioning Manager

Step 1 Copy the license file to the Provisioning Manager server, in the folder <Installation directory>\license.

The system validates the license file and updates the license. The updated licensing information appears 
on the Licensing Status Information page.

Step 2 The license should automatically take effect in a few minutes. If it does not, select System 
Administration > License Information. 

Step 3 Click PERFORM AUDIT. You will see the phones that you are licensed to update. 

Step 4 If you purchased more than one license, repeat Step 1 to install each additional license.
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Launching Cisco Unified Operations Manager IP Phone Details
If you have purchased Cisco Unified Operations Manager (Operations Manager) and are running it, you 
can setup Provisioning Manager to launch the IP Phone Details dialog box from Operations Manager. 
The IP Phone Details dialog box is launched from a subscriber record.

Before using this feature, you must first configure Provisioning Manager (see Configuring Provisioning 
Manager to Open Cisco Unified Operations Manager IP Phone Details, page 7-3).

After performing the configuration procedure, a Details button appears on the subscriber record. The 
Details button launches the IP Phone Details dialog box from Operations Manager (see Opening the 
Cisco Unified Operations Manager IP Phone Details Dialog Box, page 7-3).

Configuring Provisioning Manager to Open Cisco Unified Operations Manager IP Phone Details

Step 1 On the Provisioning Manager system, go to the <Installation directory>/sep folder.

Note If you accepted the default location during installation, the installation directory is C:\CUPM.

Step 2 Open the ipt.properties file.

Step 3 In the ipt.properties file change the following properties:

• dfc.ipt.operationsmanager.host: <hostname>—Enter the Operations Manager system host 
name or IP address.

• dfc.ipt.operationsmanager.port: <port>—Enter the port number that Operations Manager 
uses.

Step 4 Save and close the file.

Step 5 Stop Provisioning Manager. On the Provisioning Manager system, select Start > All Programs > Cisco 
Unified Provisioning Manager > Stop Cisco Unified Provisioning Manager.

Step 6 Start Provisioning Manager (Start > All Programs > Cisco Unified Provisioning Manager > Start 
Cisco Unified Provisioning Manager).

Opening the Cisco Unified Operations Manager IP Phone Details Dialog Box

Step 1 Open the subscriber record for the desired subscriber (see Accessing a Subscriber Record, page 3-1).

Step 2 Click the Phone that you want to see the details for. The Details button is one of the buttons displayed.

Step 3 Click the Details button. The Operations Manager login page appears. Valid Operations Manager 
credentials are required to view the IP Phone Details dialog box.

Step 4 Log into Operations Manager. The IP Phone Details dialog box from Operations Manager appears.
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Managing Log Files
Provisioning Manager writes application log files for the Service Enabling Platform (SEP) module 
(sep.log) and the Network Interface and Configuration Engine (NICE) service (nice.log). The log files 
are located in the <Installation Directory>/sep/logs folder.

You cannot disable logging. However, you can:

• Collect more data when needed by increasing the logging level

• Return to the default logging level (NORMAL)

Following are the available logging levels:

• DETAIL (provides the most information)

• LOW

• NORMAL

• HIGH

• EMERGENCY

Log files are backed up every hour, or when they reach their maximum log size limit. The default size 
limit is 20 Mb (see Changing the Maximum Log File Size, page 7-5). The files are saved in the format 
sep.log.<date stamp>-<timestamp>. 

Tip The log files are not automatically purged. To save space, it is recommended that you periodically delete 
the old log files.

Changing the Log Level

Step 1 On the Provisioning Manager system, go to the <Installation directory>/sep folder.

Note If you accepted the default location during installation, the installation directory is C:\CUPM.

Step 2 Open the dfc.properties file.

Step 3 Change the dfc.log.level property to the desired level. Following are the available logging levels:

• DETAIL

• LOW

• NORMAL

• HIGH

• EMERGENCY

Step 4 Save the changes.

Step 5 Restart the Provisioning Manager services. Changes will not take effect until Provisioning Manager is 
restarted.

a. On the Windows desk top, select Start > Control Panel > Administrative Tools > Services the 
Services window appears.
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b. Right-click the following services and select Start.

• cupm JBossService

• cupm NiceService

Changing the Maximum Log File Size

Step 1 On the Provisioning Manager system, go to the <Installation directory>/sep folder.

Note If you accepted the default location during installation, the installation directory is C:\CUPM.

Step 2 Open the dfc.properties file.

Step 3 Change the dfc.log.maxsize property to the desired size (default is 20 Mb).

Step 4 Save the changes.

Step 5 Restart the Provisioning Manager services. Changes will not take effect until Provisioning Manager is 
restarted.

a. On the Windows desk top, select Start > Control Panel > Administrative Tools > Services the 
Services window appears.

b. Right-click the following services and select Start.

• cupm JBossService

• cupm NiceService

Maintaining Data

Enabling Data Purging
You can configure Provisioning Manager to purge data at a scheduled interval.

Provisioning Manager retains the following types of data:

• Order—When an order is placed for any product provisioning (for example; phone, line, voicemail 
or any bundle), an order data object is created and stored in the system. 

• ServiceAction—Are objects that get created during when the application communicate with the 
device for product provisioning. 

• Workflow—After an order is placed for a product, it goes through a workflow (approval, shipping, 
and receiving) before going to the service activator.

Note Data will be purged when the retention time or retention count criteria is met. For example, if the data 
is older than the retention time it will be removed. Also, if the data amount exceeds the retention count, 
it will be removed. 
7-5
User Guide for Cisco Unified Provisioning Manager

OL-13116-01



 

Chapter 7      Administering Provisioning Manager
Maintaining Data
Step 1 Select System Administration > Data Maintenance. The Data Maintenance Configuration page 
appears.

Step 2 Select the checkbox in the row for the data you want to schedule for purging.

Step 3 In the Retention Time column, change the number of days for which you want to retain the data (default 
is seven days).

Step 4 In the Retention Count column, select the amount of data that you want to retain. 

Note Retention count is the number of objects that you want Provisioning Manager to keep and not 
purge. For example, if there are 1000 total orders and the retention count is 100, Provisioning 
Manager will purge 900 orders and keep the latest 100 orders.

The default settings for the Retention Count are:

• Orders—100

• ServiceAction—100

• Workflow—50

Step 5 (Optional) If you want to export the purged data to a file before it is removed, in the Export Before Purge 
field select Yes, then enter a directory location at which to store the data.

Note Only Orders and Workflow data is exported. ServiceAction data cannot be exported.

Step 6 Select a purge interval (the default is 24 hours).

The Purging Information pane displays the time of the next scheduled purge and the last purge.

Step 7 Click Update.

Maintenance Mode
You can put the Provisioning Manager into maintenance mode to perform user-impacting actions that 
are not available in normal mode, such as deleting domains, processors and service areas.

Step 1 Select System Administration > Maintenance Mode. The Application Mode page appears.

Step 2 Click Enter Maintenance Mode. All users except users with administrative rights will be logged out. 
A warning will appear on the login page notifying users that system use is limited to users with 
administrative privileges. Maintenance options that are not available in normal mode, such as deleting 
domains, will become available in the Provisioning Manager.

Step 3 Perform any maintenance activities, such as deleting a domain.

Step 4 When you have completed maintenance activities, select System Administration > Maintenance 
Mode. The Application Mode page appears.

Step 5 Click Enter Normal Mode. The warning on the login page will be removed and users can now login as 
usual. Maintenance options such as deleting domains will no longer be available in the Provisioning 
Manager.
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Provisioning Manager Database Backup and Restore
There are two backup and restore scenarios; select the set of procedures that matches your scenario:

• Backup and restore on a single machine, with the same install or a new install. For this scenario, see 
Backing up the Single Machine Provisioning Manager Database, page 7-7 and Restoring the Single 
Machine Provisioning Manager Database, page 7-8.

• Backup and restore for a distributed database scenario, for the same install, a new install with the 
same IP address, or a new install with a new IP address. For this scenario, see Backing up 
Provisioning Manager for a Distributed Database, page 7-9 and Restoring Provisioning Manager for 
a Distributed Database, page 7-10.

Note When backing up files, you should place the files on a different file server. Also, you should burn the 
backup data onto a CD.

Backing up the Single Machine Provisioning Manager Database

Note This procedure requires postgres administrator level access.

Step 1 On the Provisioning Manager system, stop the following services:

• Apache

• cupm JBossService

• cupm NiceService

a. On the Windows desktop, select Start > Control Panel > Administrative Tools > Services.

b. Right-click each of the services and click Stop.

Step 2 On the Windows desktop, select Start > All Programs > PostgreSQL8.2 > Command Prompt. A 
command prompt opens in the <Install directory>\pgsql\bin directory.

Note If you accepted the default location during installation, the installation directory is C:\CUPM.

Step 3 In the command prompt, run the following command and enter the postgres admin password when 
prompted.

pg_dumpall -o -U<username> >[path and fileForBackup]

Where <username> is the username of the postgres administrator. If you accepted the default, the 
administrator username is postgres.

Note Enter the password each time that you are prompted. 

This command is used to backup the database, by storing the database information in a file.

Step 4 If you are backing up on the same install, proceed to the next step. If you are backing up for a new install, 
make backup copies as described in this step.

a. In a backup folder, make copies of the following files and directories:

• <installLocation>/install.log
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• <installLocation>/sep/dfc.properties

• <installLocation>/sep/dfc.keystore

• <installLocation>/jboss-4.0.3SP1/server/cupm/conf/login-config.xml

Step 5 Start the following services:

• Apache

• cupm JBossService

• cupm NiceService

a. On the Windows desktop, select Start > Control Panel > Administrative Tools > Services.

b. Right-click each of the services and click Start.

Restoring the Single Machine Provisioning Manager Database

If you are restoring to a new install, have the system with the new install up and running before beginning 
this procedure.

Note This procedure requires postgres administrator level access.

Step 1 Stop Provisioning Manager services (for information on which services to stop, see Step 1, On the 
Provisioning Manager system, stop the following services:).

Step 2 On the Windows desktop, select Start > All Programs > PostgreSQL8.2 > Command Prompt. 

A command prompt opens in folder <Install directory>\pgsql\bin.

Note If you accepted the default location during installation, the installation directory is C:\CUPM.

Step 3 To enter the postgres prompt, run the following command and enter the postgres administrator password 
for the current install when prompted:

psql.exe -U<username>

Where <username> is the username of the postgres administrator. If you accepted the default, the 
administrator username is postgres.

Step 4 Before restoring the database, you must drop the database name and role. In the command prompt, run 
the following commands exactly as shown, one at a time in the following order:

• DROP DATABASE cupm;

Where cupm is the database name to be removed. 

Expected output: DROP DATABASE

• DROP ROLE <rolemame>;

Where <rolename> is the username for the SEP database user. If you accepted the default, the username 
is cupm.

Expected output: DROP ROLE

• ALTER ROLE <username> WITH PASSWORD ‘<password>’;
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Where username is the username of the postgres administrator user, and password should be the 
password set for the postgres administrator with backed up data. If you accepted the default 
administrator username, the username is postgres.

Expected output: ALTER ROLE

Step 5 Enter \q to quit the postgres promt.

Step 6 From the command line, run the following command, entering the password set in the previous step for 
the postgres user when prompted:

psql.exe -U<username> -d postgres < [path and fileToRestoreFrom] 

Where <username> is the username of the postgres administrator. If you accepted the default, the 
administrator username is postgres.

This command restores the database.

Step 7 If you are restoring to the same install, proceed to the next step. If you are restoring to a new install, 
complete the following step to copy the backed up files.

a. Copy back the following backed up files:

• <installLocation>/install.log

• <installLocation>/sep/dfc.properties

• <installLocation>/sep/dfc.keystore

• <installLocation>/jboss-4.0.3SP1/server/cupm/conf/login-config.xml

Step 8 Start the following services:

• Apache

• cupm JBossService

• cupm NiceService

a. On the Windows desktop, select Start > Control Panel > Administrative Tools > Services.

b. Right-click each of the services and click Start.

Backing up Provisioning Manager for a Distributed Database

Note This procedure requires postgres administrator level access.

Step 1 On the system where Provisioning Manager is running, stop the following services:

• Apache

• cupm JBossService

• cupm NiceService

a. On the Windows desktop where Provisioning Manager is running, select Start > Control Panel > 
Administrative Tools > Services.

b. Right-click each of the services and click Stop.

Step 2 On the Windows desktop where the Provisioning Manager database is running, select Start > All 
Programs > PostgreSQL8.2 > Command Prompt. A command prompt opens in the <Install 
directory>\pgsql\bin directory.
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Note If you accepted the default location during installation, the installation directory is C:\CUPM.

Step 3 In the command prompt, run the following command and enter the postgres admin password when 
prompted.

pg_dumpall -o -U<username> > [path and fileForBackup]

Where <username> is the username of the postgres administrator. If you accepted the default, the 
administrator username is postgres.

Note Enter the password each time that you are prompted. 

This command is used to backup the database, by storing the database information in a file.

Step 4 If you are backing up on the same install, proceed to the next step. If you are backing up for a new install, 
either with the same or new IP address, make backup copies as described in this step.

a. On the machine where Provisioning Manager is running, in a backup folder, make copies of the 
following files and directories:

• <installLocation>/install.log

• <installLocation>/sep/dfc.properties

• <installLocation>/sep/dfc.keystore

• <installLocation>/jboss-4.0.3SP1/server/cupm/conf/login-config.xml

Step 5 Start the following services:

• Apache

• cupm JBossService

• cupm NiceService

a. On the Windows desktop, select Start > Control Panel > Administrative Tools > Services.

b. Right-click each of the services and click Start.

Restoring Provisioning Manager for a Distributed Database

If you are restoring to a new install, either with the same or a new IP address, have the system with the 
new install up and running before beginning this procedure.

Note This procedure requires postgres administrator level access.

Step 1 On the system where Provisioning Manager is running, stop the Provisioning Manager services (for 
information on which services to stop, see Step 1, On the system where Provisioning Manager is 
running, stop the following services:).

Step 2 On the Windows desktop where the Provisioning Manager database is running, select Start > All 
Programs > PostgreSQL8.2 > Command Prompt. 

A command prompt opens in folder <Install directory>\pgsql\bin.
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Note If you accepted the default location during installation, the installation directory is C:\CUPM.

Step 3 To enter the postgres prompt, run the following command and enter the postgres administrator password 
for the current install when prompted:

psql.exe -U<username>

Where <username> is the username of the postgres administrator. If you accepted the default, the 
administrator username is postgres.

Step 4 Before restoring the database, you must drop the database name and role. In the command prompt, run 
the following commands exactly as shown, one at a time in the following order:

• DROP DATABASE cupm;

Where cupm is the database name to be removed. 

Expected output: DROP DATABASE

• DROP ROLE <rolemame>;

Where <rolename> is the username for the SEP database user. If you accepted the default, the username 
is cupm.

Expected output: DROP ROLE

• ALTER ROLE <username> WITH PASSWORD ‘<password>’;

Where <username> is the username of the postgres administrator, and password is the password set for 
the postgres administrator with backed up data. If you accepted the default administrator username, the 
username is postgres.

Expected output: ALTER ROLE

Step 5 Enter \q to quit the postgres promt.

Step 6 From the command line, run the following command, entering the password set in the previous step for 
the postgres user when prompted:

psql.exe -U<username> -d postgres < [path and fileToRestoreFrom]

Where <username> is the username of the postgres administrator. If you accepted the default, the 
administrator username is postgres.

This command restores the database.

Step 7 If you are restoring to the same install, proceed to the Step 9. If you are restoring to a new install, either 
with the same or new IP address, complete the following step to copy the backed up files.

a. Copy back the following backed up files on the machine where Provisioning Manager is running:

• <installLocation>/install.log

• <installLocation>/sep/dfc.properties

• <installLocation>/sep/dfc.keystore

• <installLocation>/jboss-4.0.3SP1/server/cupm/conf/login-config.xml

Step 8 If you are restoring to the same IP address, proceed to Step 9. If you are restoring to a new install with 
a new IP address, complete this step.
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a. On the system where Provisioning Manager is running, in the file 
<installLocation>\sep\dfc.properties, find the property dfc.postgres.host, and change it to:

dfc.postgres.host=<New DB Server IP Address>

a. On the Windows desktop of the machine where the database is running, go to Start > Programs > 
PostgresSQL 8.2 > pgAdmin III.

b. Double click on cupmPostgresSQL and login using the postgres administrator password.

c. Click on the SQL menu item at the top of the query window, and in the top right window pane enter 
the following command:

delete from nicesyseng where host='<Old NICE Server IP Address>'

d. Click on the Execute Query button at the top of the query window.

e. In the Output Pane at the bottom of the screen, confirm that the result message says the query was 
returned successfully.

f. Exit the query window.

g. Exit the pgAdminIII window.

h. Restart Postgres on the machine where the database is running. 

– On the Windows desktop, select Start > Control Panel > Administrative Tools > Services.

– Right-click the service cupmPostgreSQL and click Start.

Step 9 On the system where Provisioning Manager is running, start the following services:

• Apache

• cupm JBossService

• cupm NiceService

a. On the Windows desktop, select Start > Control Panel > Administrative Tools > Service.

b. Right-click each of the services and click Start.

Scheduling Synchronizations
Besides running synchronizations on demand through the appropriate Provisioning Manager functional 
area, you can set up scheduled synchronizations. You schedule synchronizations for the following:

• Call Processors (see Synchronizing Call Processors, page 5-4)

• Unified Message Processors (see Synchronizing Unified Message Processors, page 5-8)

• Domains (see Synchronizing Domains, page 5-13)

You do not use Provisioning Manager to set up scheduled synchronizations. You must use the Scheduled 
Tasks functionality that comes with your Windows system.

Step 1 On the Windows desktop, select Start > Programs > Accessories > System Tools > Scheduled Tasks. 
The Scheduled Tasks window opens.

Step 2 Double-click Add Scheduled Task. The Scheduled Task wizard appears.

Step 3 Click Next.

Step 4 In the next page, click Browse. 
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Step 5 Browse to the file C:\CUPM\sep\build\bin\sync.bat (this is the correct location if you accepted the 
default location during installation).

Step 6 Select how often you want the synchronization to run. Click Next.

Step 7 Select the time and day when you want the synchronization task to start. Click Next.

Note You should run synchronizations during off-peak network usage periods.

Step 8 Enter the password (and confirm) for the system’s administrator user. Click Next.

Step 9 Click Finish. The new scheduled task appears in the Scheduled Tasks window.

Step 10 Right-click the new scheduled task and select Properties.

Step 11 In the Run field, at the end of the string (after sync.bat), enter one or more of the following commands:

• callprocessor—Runs infrastructure and subscriber synchronizations for all Call Processors in the 
system.

• messageprocessor—Runs infrastructure and subscriber synchronizations for all Unified Message 
Processors in the system.

• domain—Runs synchronizations for all the domains in the system. The order of Domains 
synchronizations depends on the value set on the syncPrecedence property for the corresponding 
domain instances.

• all—Runs infrastructure and subscriber synchronizations for all Call Processors and Unified 
Message Processors. The order of synchronizations is callprocessor, messageprocessor, and domain.

Note You can also use these commands in a command prompt to start a synchronization. Run the 
commands at the following location: <CUPM_DIR>/sep/build/bin/sync.bat.

Step 12 Click OK.

Searching Inventory
If you are assigned the Administration authorization role you can browse the Provisioning Manager 
network and service inventory. You can view different types of network or service related data in a 
tree-base selector. 

The following objects appear in the selector:

• Global Resources—List infrastructure data stored in Provisioning Manager. Some examples are, 
Route Partition, Call Search Space, Call Pickup Group. 

• Product Catalog—Lists the products present in Provisioning Manager. 

• Subscribers—List all subscribers and their locations in Provisioning Manager.

• Domain specific directory numbers, phones, rules and Services Areas. 

This section provides information for browsing and searching Provisioning Manager inventory, using the 
Instance Browser and search functionality of the Inventory Manager.

• Using Inventory Search, page 7-14
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• Creating Search Reports, page 7-20

Figure 7-1 shows an example of the Inventory Search page.

Figure 7-1 Inventory Search

Step 1 Select System Administration > Inventory. A new page appears.

Step 2 Do one of the following:

• If you want to browse Provisioning Manager’s inventory, click Browse. The Instance Browser 
appears. For information on the Instance Browser, see Using Inventory Search, page 7-14.

• If you want to perform a search of Provisioning Manager’s inventory, click Search. The Search 
Reports page appears. In this page you can do the following:

– Perform a search using a sample report.

– Create a new Search report to perform a search.

Using Inventory Search
You can search for inventory objects using basic or advanced searches. You use basic searches to find 
instances of an object based on its properties. Advanced searches are used to specify more detailed 
search criteria. You can include multiple constraints, such as customers, properties, associations, and 
namespaces, to limit the search results. You can also specify what properties you want the search to 
return. You can save advanced searches as reports, and organize them into categories. Reports can be 
created only by Administrators.

The following sections describe how to run basic and advanced searches:

• Performing Basic Searches, page 7-15

• Performing Advanced Searches, page 7-15

• Return Values, page 7-19
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Performing Basic Searches

Using the Instance Browser, you can run a basic search for instances of a particular object. In a basic 
search, the search parameters are based on the properties of the class.

The first step to searching for an instance is specifying the class that it is based on. You can specify 
search criteria and how the results are displayed by:

• Specifying a keyword or partial keyword. You can use asterisks (*) as wildcards.

• Specifying whether the results are displayed according to the class name or label property.

• Restricting the search to a particular domain.

• Including and/or excluding abstract, association, and interface classes.

After you have located the class that the instance is based on, you can narrow your search by specifying 
search criteria based on the class properties. The number of searchable properties varies from class to 
class.

Step 1 Select System Administration > Inventory. A new page appears.

Step 2 Click Browse. The Instance Browser appears. 

Step 3 Click the Search icon ( ). The Class Search dialog box appears.

Step 4 Either enter a class or choose a class from the list. The Instance Search screen appears.

Step 5 Complete the fields if you have search parameters you want to specify.

Step 6 Click Search. The results appear in the Found matches section.

Performing Advanced Searches

You can perform advanced searches to find inventory instances within a specified object class. An 
advanced search can be saved for future use.

Performing advanced searches consists of the following steps:

Step 1 Select System Administration > Inventory. A new page appears.

Step 2 Do one of the following:

• Click Browse, select a class using a basic search, then click Advanced.

• Click Search, click the New icon ( ), and then select a class.

Step 3 Add any applicable constraints. You can constrain searches using properties, associations, namespaces, 
or customers. 

Step 4 Create a list of properties to return in the search from a list of available properties. The search results 
include only those instances that contain the selected properties.

Step 5 Specify associated properties to return in the search, if applicable, by building the path to the properties. 
The search results will include only those instances with the selected properties.

Step 6 Specify associated objects to return in the search, if applicable, by building the path to the objects. The 
search results will include only those instances with the selected objects.
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Step 7 Specify whether to include or exclude Namespaces and Object Classes in the search results.

Step 8 Run the search. The search results are displayed.

Detailed instructions for selecting the above constraints and return objects and properties can be found 
in the following sections:

• Constraints, page 7-16

• Defining Property Constraints, page 7-16

• Defining Association Constraints, page 7-17

• Defining Namespace Constraints, page 7-18

• Associated Properties to Return, page 7-19

• Associated Objects to Return, page 7-20

Constraints

Use the Add Constraint section to define the constraints for the search. 

The following constraints are available for advanced searches:

• Properties—To restrict the results to objects that meet specified property criteria. You can set the 
properties constraint to be case sensitive or case insensitive. You can specify that either all or part 
of the value must be matched to return results.

• Associations—To restrict the results to objects that are (or are not) associated with other objects 
using a specified association path. Association paths allow the relation between the source object 
and the queried objects to span multiple association classes.

• Namespaces—To restrict the results to objects contained (or not contained) in specified namespaces.

• Customers—To restrict the results to objects that are associated with specific customers.

Defining Property Constraints

You can define searches to select only the objects that meet specified property constraints. For example, 
you can define a constraint in which only instances that have a specific model number are included in 
the search results. In this case, the property constraint acts as a filter when searching for a specific object 
property.

When defining property constraints, the following conditions are available:

• Equals—To specify a value that is equivalent in value to the selected property.

• Contains—To specify a value that is contained within the value of the selected property.

• Not equal to—To specify a value that is not equivalent in value to the selected property.

• Does not contain—To specify a value that is not contained within the value of the selected property.

• In range—To specify a value that has a Date property that is within the specified range. This operator 
can only be used when Date properties have been specified for an object, and where 
reportable=true is set in the class definition properties. 

After you select the operator, you can either specify a value, or leave the field blank. If you specify a 
value, it becomes the default value, although users who execute the search can change the value if 
required. Leaving the field blank allows a user who is executing the search at a later time to specify a 
value for that property constraint.
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To define property constraints:

Step 1 In the advanced Instance Search screen, select a property from the Add Constraint list.

Step 2 Click Add. The available conditions appear in a list.

Step 3 From the available conditions list, select the appropriate operator and click Add. The Property list 
appears in the Add Constraint section. 

Step 4 Select the appropriate property. The Value field appears in the Add Constraint section.

Step 5 In the Value field, do one of the following:

• Specify a default value for the constraint.

• Leave the field blank so that users can specify their own constraints.

Step 6 If you want the search to be case-insensitive, enable Ignore Case.

Step 7 Click Add. The constraint appears in the Selected Constraints section.

Step 8 Repeats Steps 1 through 7 to add additional constraints.

Step 9 If you have defined multiple constraints, specify the and or or operands as required in the Operand 
column.

Defining Association Constraints

You can define searches to select objects that are, or are not, associated with other objects. For example, 
you can define a search for Lines that are associated with Voice Terminals of a certain type, excluding 
Voice Terminals of another type. Additionally, you can sort within a range; for example, you can search 
for all Phones with 2 to 6 Lines. 

When defining association constraints, the following conditions are available:

• Associated with—Used to specify the object instance and association path associating the search 
class with another object instance.

• Not associated with—Used to specify the object instance to not associate with for the search class.

• Associated with range—Used to specify the range of object instances to associate with the search 
class. If you select this condition, you must complete the appropriate association, condition, and 
quantity information.

After the operator is selected, you must select an object instance for the constraint. Each operator has a 
different procedure for selecting object instances to associate with.

To define constraints using the associated with operator:

Step 1 From the Add Constraint list, select Associations.

Step 2 Click Add. The available conditions appear in a list.

Step 3 From the available conditions list, select Associated with. 

Step 4 Click Add. The constraint is added to the Add Constraint section.

Step 5 In the Add Constraint section, in the Instance field, click the Search icon ( ). The Instance and 
Association Path dialog box appears.

Step 6 In the To Class list, select the class that the object instance is associated with, and click Apply. 
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Step 7 In the By Association list, select the appropriate association, and then click Apply. The Participating As 
list appears.

Step 8 Select the appropriate role for the class, and then click Apply. To Class appears.

Step 9 To specify another class in the To Class field, repeat Steps 6 through 8.

Step 10 To restrict the constraint to a specific object instance, click the Search icon ( ) and search for that 
instance. By default, the constraint is not restricted to a particular instance.

Step 11 Click Add to save your selections. The selected path is displayed.

Step 12 To add the constraint as defined, click Add. The Selected Constraints section displays the Instance and 
Association Path information.

Step 13 If you have defined multiple constraints, select the and or or operands as required in the Operand 
column.

To define constraints using the associated with range operator:

Step 1 From the Add Constraint list, select Associations.

Step 2 Click Add. The available conditions appear in a list.

Step 3 From the available conditions list, select the Associated with range condition, then click Add. The 
constraint is added to the Add Constraint section. 

Step 4 From the Association list, select the association class that you want to search with.

Step 5 From the Condition list, select the condition to satisfy in the search.

Step 6 In the Quantity field, enter the number of instances the condition must meet, then click Add. The 
constraint is displayed in the Selected Constraints section.

Step 7 Repeat Steps 1 through 6 to add additional constraints.

Step 8 If you have defined multiple constraints, select the and or or operands as required in the Operand 
column.

Defining Namespace Constraints

Use namespace constraints to restrict the search to or exclude specific namespaces.

Step 1 From the Add Constraint list, select namespace, then click Add. Namespace appears in the Add 
Constraint section.

Step 2 Do one of the following:

• To specify a namespace to search in, select Equals.

• To exclude a namespace from the search, select Not Equal To.

Step 3 The Value list appears, displaying the available namespaces.

Step 4 From the Value list, select the namespace, then click Add. The constraint appears in the Selected 
Constraints section.
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Step 5 Repeats Steps 1 through 4 to add additional constraints.

Step 6 If you have defined multiple constraints, select the and or or operands as required in the Operand 
column.

Return Values

By default, the namespace, object class, and object values for each instance are displayed in the results 
of an advanced search. In addition to the default values, you can select other values for the advanced 
search to display.

Properties to Return

The Properties to Return section lists the available properties of the object class being searched, and 
those properties that you want the search to return. Using the Properties to Return section, you can 
expand the search to display a list of property values.

Step 1 In the Properties to Return section, from the Available list, select a property then click Add. These 
properties are displayed in the Selected list.

Step 2 After adding all the desired properties, click Apply.

Associated Properties to Return

The Associated Properties to Return section identifies the associated object class properties that you 
want the search to return. Using the Associated Properties to Return section, you can extend the search 
to include a list of associated object property values.

Step 1 In the Associated Properties section, click Add. The Associated Property Path screen appears.

Step 2 In the To Class list, select the object class.

Step 3 Click Apply. The By Association list appears.

Step 4 Select the appropriate association. Click Apply. The Participating as list appears.

Step 5 Select the appropriate role for the class. Click Apply. The Select Property of lists appear.

Step 6 Do one of the following:

• From the To Class list, select the object class. Click Apply. Repeat Steps 2 and 3 after you have 
added the classes that you require.

• From the Select Property of list, select the properties of the class that you chose in Step 2. Click 
Apply.

The Associated Property Path screen appears with the selected path displayed.

Step 7 Click Add. The new associated property is displayed in the search screen.

Tip To remove a property, select the Remove checkbox, then click the Remove button.
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Associated Objects to Return

The Associated Objects to Return section identifies the associated object classes that you want the search 
to return. Using the Associated Objects to Return section, you can extend the search to include a list of 
associated objects of a specific class.

Step 1 Click Add in the Associated Objects section. The Associated Object Class Path window appears.

Step 2 In the To Class list, select the object class, then click Apply. The By Association list appears.

Step 3 Select the appropriate association, then click Apply. The Participating as list appears.

Step 4 Select the appropriate role for the class, then click Apply. The To Class list appears.

Step 5 Do one of the following:

• If you need to continue the path, repeat Steps 2 through 4.

• If you are done, click Add.

The new associated property is displayed in the search screen.

Tip To remove a property, select the Remove checkbox, then click the Remove button.

Creating Search Reports
You can save advanced searches (see Performing Advanced Searches, page 7-15) for future use. These 
are called Search Reports. Also, Provisioning Manager provides you with sample search reports that you 
can use, or you can create your own. The sample search reports are not editable.

You can save an advanced search at any time.

Step 1 Select System Administration > Inventory > Search. The Search Reports page appears.

Step 2 Click the New icon ( ). The Class Search dialog box appears.

Step 3 Either enter a class in the search field or click one of the displayed classes. The Instance Search page 
appears.

Step 4 Enter the desired search criteria. For instructions on using the Instance Search page, see Performing 
Advanced Searches, page 7-15.

Step 5 Click Save. The Save Search page appears.

Step 6 Enter a name for the report and choose a category for it.

Step 7 Click Save. You are returned to the Advanced Search page, where you can initiate the search.
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Running Search Reports

Once you have saved a search as a Search report, you can run it. Before running a Search report , you 
can choose to have the search results displayed in the current browser window or in a new window.

Step 1 Select System Administration > Inventory > Search. The Search Reports page appears.

Step 2 Click the report that you want to run. Either one of the sample search reports, or a search report that you 
created. The Inventory Search page appears, displaying the constraints that have been defined.

Step 3 Change the constraint values if required.

Step 4 To display the search results in a separate browser window, select Open results in a new window.

Step 5 Do one of the following:

• To execute the search and display the search results, click Search.

• To execute the search and write the search results to an Excel spreadsheet, click Excel.

The search results are displayed as specified.

Editing Search Reports

Step 1 Select System Administration > Inventory > Search. The Search Reports page appears.

Step 2 Click the Edit icon ( ) next to the Search report that you want to edit. The Instance Search for the report 
appears.

Step 3 Make the appropriate changes. For instructions on using the Instance Search page, see Performing 
Advanced Searches, page 7-15.

Deleting Search Reports

Step 1 Select System Administration > Inventory > Search. The Search Reports page appears.

Step 2 Click the Edit icon ( ) next to the Search report that you want to delete. The Instance Search for the 
report appears.

Step 3 In the Search Options section, click Delete.

Step 4 In the confirmation box, click OK.

Viewing System Reports
Provisioning Manager contains a set of preconfigured reports. Following are the available reports:

• Service Area Report

• Resource Configuration Report 

• Service Configuration Report
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• Directory Number Inventory Report

Step 1 Select System Administration > Reports.

Step 2 Click one of the following available reports:

• Service Area Report

• Resource Configuration Report 

• Service Configuration Report

• Directory Number Inventory Report

A report is displayed.
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keyword substitution. See keywords

L

launching Cisco Unified Operations Manager IP phone 
details 7-3

LDAP directory integration 5-3

license information, viewing 7-1

LineDisplayString 6-7

line group 5-30

lines

common shared, setting up 3-11

primary shared, setting up 3-12

lists

adding items 5-39

reordering 5-40

See also infrastructure data objects

location 5-31, 7-4

log file 7-4

debugging 7-4

maximum size, changing 7-5

naming 7-4

logging into

Provisioning Manager 1-7

logging out of

Provisioning Manager 1-8

log level, updating 7-4
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MailHost 6-7

maintaining data 7-5

maintenance authorization role 2-12

manager subscriber role 2-6

media resource

group 5-31

list 5-31

MonitorPhoneReturnEnabled 6-7

N

NameDialingInfo 6-8

O

opening the Cisco Unified Operations Manager IP phone 
details dialog box 7-3

operator subscriber role 2-6

order

adding, in batch action file 5-42

approving 3-17

canceling 3-19

configuring business rules for 6-12

phone button template option 6-2

placing 3-9

procedure, example 3-7

processing 3-17

approval 3-17

receiving 3-19

shipping 3-18

searching for 3-16

viewing 3-1

order entry fields 3-8

ordering authorization role 2-12

OrderProvisionedEmailTemplate 6-8

OrderRejectedEmailTemplate 6-8
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partitioning. See domains

password

subscriber, resetting 2-4

Cisco Unified Communications Manager 2-4

Cisco Unity 2-4

Provisioning Manager login 2-4

user, resetting 2-11

pattern

route 5-32

translation 5-33

pausing batch project 5-46

phone

activating 3-2

ownership, changing 3-15

provisioning attributes

assignment levels 6-19

call processor support 6-24

replacing 3-14

setting up 3-13

shared 3-13

PhoneAssignmentDoneBy 6-8

phone button template

default for phone type 6-2

maximum lines, viewing 6-1

option on orders 6-2

synchronization, retrieval during 6-1

phone inventory

adding phones to 4-2

clearing expired reservations 4-3

phone information, updating 4-1, 4-2

removing phones from 4-3

report, viewing 4-3

phone inventory report 4-3

phone line

provisioning attributes

assignment levels 6-19

call processor support 6-24
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PhoneReservationTimeout 6-9

PhoneShippingDoneBy 6-9

phone type, default phone button template for 6-2

policy authorization role 2-12

primary shared line 3-12

processors, configuring 5-1

product

business rules, configuring 6-11

provisioning attributes 6-15

products and services 3-2

canceling 3-19

Cisco Unity 3-7

Cisco Unity Connection 3-7

Cisco Unity Express 3-7

ordering 3-2

Provisioning Manager 3-2

provisioning attributes

about 6-13

descriptions 6-15

editing

domain 5-15

service area 5-20

subscriber role type 2-8

levels

domain 6-13

service area 6-13

subscriber type 6-13

precedence 6-13

Provisioning Manager

about 5-1

products and services 3-2

subscriber login 2-4

PurgeUponUmRemoval 6-10

purging data, enabling 7-5

R

receiving authorization role 2-12
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replacing phones 3-14

reports

directory number inventory 7-21

phone inventory 4-3

resource configuration 7-21

service area 7-21

service configuration 7-21

rescheduling batch project 5-46

reservation, phone

expired 4-3

status 4-1

resetting passwords

subscriber 2-4

user 2-11

resource configuration report 7-21

restarting batch project 5-46

restore database 7-7

roles

authorization 2-11

subscriber 2-6

route

group 5-31

partition 5-31

pattern 5-32

rules See business rules

running batch project 5-46

S

scheduling

batch project 5-46

synchronization 7-12

searching inventory 7-13

search reports

creating 7-20

deleting 7-21

security

Internet Explorer and Provisioning Manager 1-8
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SelfCareAccountsDefaultPassword 6-10

senior manager subscriber role 2-6

service area

adding 5-17

call forward settings 5-23

configuring 5-18

definition 5-16

directory number block for 5-23

provisioning attributes, configuring 5-20, 6-13

report 7-21

SERVICE AREA variable 5-26

service configuration report 7-21

shared 3-13

line, setting up

common 3-11

primary 3-12

phone, setting up 3-13

shipping authorization role 2-12

starting

Provisioning Manager from a client system 1-7

Provisioning Manager from the server 1-7

subscriber

authorization roles, applying 2-5

creating 2-1

definition 2-1

deleting 2-5

records

finding 2-6, 2-13

synchronizing 5-4

viewing 3-1

services, ordering 3-9

synchronizing 2-5

updating 2-2

See also subscriber role type

subscriber role type

adding 2-7

deleting 2-9

precedence 2-8
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provisioning attributes for 2-8, 6-13

updating 2-7

synchronization, scheduling 7-12

synchronizing

call processors 5-4

domains 5-13

log file for 5-15

purpose 5-13

recommended order 5-4, 5-8, 5-13

subscriber 2-5

unified message processors 5-8

users 2-13

system reports 7-21

T

TakePrimaryUserInfoFromUMProcessor 6-10

templates

configuration 5-24

customer domain 5-11

phone button 6-1

tracking assets. See inventory

translation pattern 5-33

typographical conventions in this document ix

U

Unified CM group 5-26

unified message processors

adding 5-6

definition 5-1

synchronizing 5-8

updating 5-8

Unified Messaging

provisioning attributes

assignment levels 6-19

call processor support 6-24
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updating

call processor 5-4

configuration template 5-39

directory numbers 4-5

items 5-40

subscriber 2-2

subscriber role type 2-7

unified message processor 5-8

user 2-10

usage scenarios 1-5

configuration templates 5-24

deployment

additional site 1-6

initial 1-6

subscriber services, managing 1-6

voice services, enabling others to manage 1-5

user guide, accessing 1-8

users

access

configuring 6-11

example 3-7

adding, in batch action file 5-42

creating 2-10

synchronizing 2-13

V

viewing license information 7-1

voice mail

pilot 5-34

profile 5-34

provisioning attributes

assignment levels 6-19

call processor support 6-24

voice region 5-34

voice services, managing 1-5
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