Service/Subscriber Provisioning

The Cisco 6400 SCM allows you to make and manage network connections through a set of menu options available by right clicking on an appropriate card in MapViewer. They allow you to create and configure Subscribers and Services, and to manage the subsequent connection of Subscribers to Services.

This chapter details the tasks you may need to use during day to day Service Connection Management, the name we provide to combined subscriber and service provisioning.

Accessing SCM Windows

The tasks and windows that are required in Service Connection Management are accessed from the Chassis map in MapViewer.

Tasks and windows can also be accessed from the Objects manager, and from different objects and more than one containment tree when required. Refer to Table 6-1 for further details.

<table>
<thead>
<tr>
<th>Tasks</th>
<th>NSP</th>
<th>NRP</th>
<th>NRP ATM Port</th>
<th>Line Card</th>
<th>Line Card ATM Port</th>
<th>DSLAM</th>
<th>Service Instance</th>
<th>Subscriber</th>
<th>Subscriber QoS</th>
<th>Connection</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configure Service Profiles</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>Configure QoS Profiles</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>Configure Services</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Configure Subscribers</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Configure Subscriber QoS</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Connect Subscribers</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>Disconnect Subscribers</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Deploy DSLAM</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>Deploy Subscriber and QoS</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>Deploy Subscriber QoS</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>Tasks</td>
<td>NSP</td>
<td>NRP</td>
<td>NRP ATM Port</td>
<td>Line Card</td>
<td>ATM Port</td>
<td>DSLAM</td>
<td>Service Instance</td>
<td>Subscriber</td>
<td>Subscriber QoS</td>
<td>Connection</td>
</tr>
<tr>
<td>------------------------</td>
<td>-----</td>
<td>-----</td>
<td>--------------</td>
<td>-----------</td>
<td>----------</td>
<td>-------</td>
<td>------------------</td>
<td>------------</td>
<td>----------------</td>
<td>------------</td>
</tr>
<tr>
<td>Deploy Service Instance</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>No</td>
</tr>
</tbody>
</table>
Defining Policies For Service Provisioning

Many service providers and telecommunications carriers now offer tiered service levels to their customers and/or subscribers. These service levels are generally defined by the marketing policy of the carrier or service provider.

Configuration of the 6400 SCM service and subscriber provisioning involves the definition of a large number of parameters that are common across these policies.

The 6400 SCM utilizes the concept of a configuration profile to simplify the definition of both service parameters and subscriber QoS parameters.

A configuration profile is therefore a set of configuration parameters (or attributes) that can be set up in advance before the actual configuration operation. These profiles are saved in the CEMF database. The 6400 SCM profiles therefore speeds up both subscriber provisioning and service provisioning.

Without the use of profiles, you would have to enter a repetitive definition of the same (or similar) information for service or subscriber provisioning operations.

For example, you may wish to define “bronze” (low data rate, inexpensive), “silver” and “gold” (high data rate, expensive) profiles for subscriber QoS. This provides a simple method for use during the subscriber provisioning operation and saves retyping all of the QoS parameters individually for each new subscriber.

A typical work flow is described in this section, you can use this example as a tutorial.

This section describes how to use the 6400 SCM profile definition windows. The precise parameter values that you select for each service or subscriber QoS are dependent upon your network topology and market service offerings.

Refer to the “Service Profile Configuration Window” section on page 7-1 for further information on the meaning of each service topology and service parameter.
Creating Service Profiles (for PPP-IP, PPP-L2TP, Bridged-Bridged, and Bridged-Routed Services)

This section describes the use of service profiles to simplify 6400 SCM service provisioning. There are two methods for accessing the various Cisco 6400 SCM Service Profile windows:

1. Select the **Cisco 6400 UAC, Profiles, Configure Service Profiles** option from an NSP object using the MapViewer application (for service types PPP-IP, PPP-L2TP, Bridged-Bridged, and Bridged-Routed).

OR

2. Select the **Cisco 6400 UAC, Profiles, Configure <Service> Profiles** option from an NSP object using the MapViewer application (for service types RBE, PTA-MD, and RFC1483 Routing. Where **<Service>** is service type RBE, PTA-MD, or RFC1483 Routing.

Service profiles are used to define configuration parameters for the uplink from the 6400 UAC to the service provider.

---

**Note**  Service profiles cannot be set up for pure ATM services.

---

You can set up profiles and apply them or, alternatively, you can configure a service manually. The services available on the 6400 UAC have a number of parameters to configure. It is worth setting up a number of service profiles with at least some of the values complete (that can be applied later) to save time.

**Step 1**  Select the **Cisco 6400 UAC, Profiles, Configure Service Profiles** option from any card type (that is NSP, NRP or Line Card). Profiles are “globally” obtained within the 6400 SCM.

The Service Profile Configuration window appears with the **General** tab displayed:
Creating Service Profiles (for PPP-IP, PPP-L2TP, Bridged-Bridged, and Bridged-Routed Services)

**Figure 6-2** Service Profile Configuration Window (General Tab)

Step 2 Select Create Profile.
A Prompt window appears.

**Figure 6-3** Prompt Window

Step 3 Enter a name for the profile in the Enter profile name data entry box. Premium Profile was entered in the example shown in Figure 6-3.

**Note** Each service profile must have a unique name.

The Service Profile Configuration window reappears with the new profile name displayed in the left-hand-side of the window.

Step 4 Select the General tab (shown in Figure 6-2) if it is not already selected.
Note Select the Copy and Copy Page Configuration options in the Edit menu to cut and paste between different profiles. This is useful when you wish to copy profile information from one to the next.

Step 5 Enter a description into the Service Description data entry box in the Service Details frame.

Step 6 Select a Service Type from the drop down list. This Service Type is a range of options you can use to configure the uplink from the 6400 UAC to the upstream service provider.

Note Refer to the “Service Profile Configuration Window” section on page 7-1 for details of the parameters displayed on each of the tabs in the Service Profile Configuration window.

As an example, the PPP-IP Service Type is selected.

Note When a Service Type is selected the service tabs that do not relate to this service are greyed out and cannot be selected. For example, when the PPP-IP service is selected the PPP-L2TP, Bridged-Bridged and Bridged-Routed tabs are greyed out.
Creating Service Profiles (for PPP-IP, PPP-L2TP, Bridged-Bridged, and Bridged-Routed Services)

Figure 6-4  Service Profile Configuration (PPP-IP Tab)

Step 7  Edit the parameters into the Virtual Template Parameters frame, as required. The Virtual Template Parameters describe the PPP characteristics used to terminate the incoming PPP traffic. You should set the parameters appropriate to your network topology and services to be offered.

Note  If you enable Peer DHCP, it is assumed that you are using an external DHCP Server for IP address allocation and any values entered into the IP Address Pool frame are ignored.

Step 8  Edit the parameters in the IP Address Pool frame, as required. The IP Address Pool set the range of IP addresses available to a subscriber.

Step 9  Select the Encapsulation Type in the VC Class Parameters frame. The VC Class Parameters define the characteristics of the incoming ATM traffic.

Step 10  Select Save from the File menu to save the parameters you have selected for your service profile.

Step 11  Select Close from the File menu to close the window.

Editing Existing PPP-IP, PPP-L2TP, Bridged-Bridged or Bridged-Routed Service Profiles

To edit an existing service profile, proceed as follows:

Step 1  Select the Cisco 6400 UAC, Profiles, Configure Service Profiles option from an NRP Card on the MapViewer.
The Service Profile Configuration window appears with the **General** tab displayed. Existing service profiles are displayed at the left-hand-side of the window.

Figure 6-5  Service Profile Configuration Window (General Tab)

---

Step 2  Select the profile you wish to edit from the list of profiles displayed. The **Premium Profile** is selected in the example shown in Figure 6-5.

Step 3  Select the **General** tab (shown in Figure 6-2) if it is not already selected.

Step 4  Edit the parameters in the **General** tab as required.

Step 5  Select the appropriate service tab for the **Service Type** selected.

Note  When a **Service Type** is selected the service tabs that do not relate to this service are greyed out and cannot be selected. For example, when the **PPP-IP** service is selected the **PPP-L2TP**, **Bridged-Bridged** and **Bridged-Routed** tabs are greyed out.

Step 6  Edit the parameters in the appropriate service tab as required.

Step 7  Select **Save** from the **File** menu to save the configuration.

Step 8  Select **Close** from the **File** menu to close the window and save the changes made.

Deleting Existing PPP-IP, PPP-L2TP, Bridged-Bridged or Bridged-Routed Service Profiles

To delete an existing service profile, proceed as follows:
To edit an existing subscriber QoS profile, proceed as follows:

**Step 1** Select the **Cisco 6400 UAC, Profiles, Configure Service Profiles** option from an NRP Card.

The Service Profile Configuration window appears with the **General** tab displayed. Existing service profiles are displayed at the left-hand-side of the window.

**Figure 6-6 Service Profile Configuration Window**

Step 2 Select the existing service profile that you wish to delete. In the example (shown in Figure 6-21) the **Premium Profile** is selected.

Step 3 Right click and select **Delete object(s)** option.

The Deletion Summary Screen appears.
Figure 6-7  Deletion Summary Screen

Step 4  Check the details in the Deletion Summary Screen.

Step 5  Select **Finish** to delete the selected profile. The delete operation is initiated.

Step 6  Select **Dismiss** to close the Deletion Summary Screen.
Creating Service Profiles for a PTA-MD Service

Service profiles are used to define configuration parameters for the uplink from the 6400 UAC to the service provider.

You can set up profiles and apply them or, alternatively, you can configure a service manually. The services available on the 6400 UAC have a number of parameters to configure. It is worth setting up a number of service profiles with at least some of the values complete (that can be applied later) to save time.

Step 1  Select the Cisco 6400 UAC, Profiles, Configure PTA-MD Profiles option from any card type (that is NSP, NRP or Line Card) using the MapViewer application.

The PTA-MD Service Profile Window (PTA-MD Tab) appears. The PTA-MD Service Profile window has two tabbed sections: PTA-MD and Local Service Profiles.

Figure 6-8  PTA-MD Service Profile Window (PTA-MD Tab)

Step 2  Select Create Profile.

A Prompt window appears.
Defining Policies For Service Provisioning

Figure 6-9  Prompt Window

Step 3  Enter a name for the profile in the Enter profile name data entry box. Premium Profile was entered in the example shown in Figure 6-9.

Note  Each service profile must have a unique name.

The PTA-MD Service Profile window reappears with the new profile name displayed in the left-hand-side of the window.

Step 4  Select the PTA-MD tab (shown in Figure 6-8) if it is not already selected.

Note  Select the Copy and Copy Page Configuration options in the Edit menu to cut and paste between different profiles. This is useful when you wish to copy profile information from one to the next.

Step 5  Edit the parameters in the QoS Parameters and Sub-Interface Parameters frames as required.

Note  Refer to the “PTA-MD Service Configuration Window” section on page 7-32 for details of the parameters displayed on each of the tabs in the PTA-MD Service Profile window.

Step 6  Select the Local Service Profile tab.
Creating Service Profiles for a PTA-MD Service

Step 7 Enter parameters into the General, DNS Redirection/Fault Tolerance, and the Remote RADIUS Configuration frames.

Note Refer to the “Local Service Profile Tab” section on page 7-12 for details of the parameters displayed on each of the tabs in the PTA-MD Service Profile window. “Local Service Profile” on the PTA-MD windows refer to the 6400 NRP-SSG profiles, as hosted on the (selected) NRP. RADIUS-based service profiles are not supported by this 6400 SCM release.

Step 8 Select Save from the File menu to save the parameters you have selected for your service profile.

Step 9 Select Close from the File menu to close the window.

Editing an Existing PTA-MD Service Profile

Step 1 Select the Cisco 6400 UAC, Profiles, Configure PTA-MD Profiles option from any card type (that is NSP, NRP or Line Card).

The PTA-MD Service Profile Window (PTA-MD Tab) appears. The PTA-MD Service Profile window (shown in Figure 6-8) has two tabbed sections: PTA-MD and Local Service Profiles.

Step 2 Select the profile you wish to edit from the list of profiles displayed on the left-hand-side of the window.
Defining Policies For Service Provisioning

Step 3  Edit the parameters in the **PTA-MD** and **Local Service Profiles** tabs as required.

---

**Note**: Refer to the “PTA-MD Service Configuration Window” section on page 7-32 for details of the parameters displayed on each of the tabs in the PTA-MD Service Profile window.

---

Step 4  Select **Save** from the **File** menu to save the configuration.
Step 5  Select **Close** from the **File** menu to close the window and save the changes made.

Deleting an Existing PTA-MD Service Profile

Step 1  Select the **Cisco 6400 UAC, Profiles, Configure PTA-MD Profiles** option from any card type (that is NSP, NRP or Line Card).

The PTA-MD Service Profile Window (PTA-MD Tab) appears. The PTA-MD Service Profile window (shown in Figure 6-8) has two tabbed sections: **PTA-MD** and **Local Service Profiles**.

Step 2  Select the profile you wish to edit from the list of profiles displayed on the left-hand-side of the window.
Step 3  Right click and select **Delete object(s)** option.

The Deletion Summary Screen appears.

**Figure 6-11  Deletion Summary Screen**

Step 4  Check the details in the Deletion Summary Screen.
Step 5  Select **Finish** to delete the selected profile. The delete operation is initiated.
Step 6  Select **Dismiss** to close the Deletion Summary Screen.
Creating Service Profiles for an Route Bridge Encapsulation (RBE) Service

Service profiles are used to define configuration parameters for the uplink from the 6400 UAC to the service provider.

You can set up profiles and apply them or, alternatively, you can configure a service manually. The services available on the 6400 UAC have a number of parameters to configure. It is worth setting up a number of service profiles with at least some of the values complete (that can be applied later) to save time.

Step 1 Select the **Cisco 6400 UAC, Profiles, Configure RBE Profiles** option from any card type (that is NSP, NRP or Line Card) using the **MapViewer** application.

**Figure 6-12 RBE Service Profile Window (Route Bridge Encapsulation Tab)**

Step 2 Select **Create Profile**.

A Prompt window appears.
Defining Policies For Service Provisioning

Figure 6-13 Prompt Window

Step 3 Enter a name for the profile in the Enter profile name data entry box. Premium Profile was entered in the example shown in Figure 6-13.

Note Each service profile must have a unique name.

The RBE Service Profile window reappears with the new profile name displayed at the left-hand-side of the window.

Note Select the Copy and Copy Page Configuration options in the Edit menu to cut and paste between different profiles. This is useful when you wish to copy profile information from one to the next.

Step 4 Edit the parameters in the QoS Parameters and Sub-Interface Parameters frames as required.

Note Refer to the “Route Bridge Encapsulation (RBE) Service Configuration Window” section on page 7-36 for details of the parameters displayed on each of the tabs in the RBE Service Profile window.

Step 5 Select Save from the File menu to save the parameters you have selected for your service profile.

Step 6 Select Close from the File menu to close the window.

Editing an Existing RBE Service Profile

Step 1 Select the Cisco 6400 UAC, Profiles, Configure RBE Profiles option from any card type (that is NSP, NRP or Line Card).

The RBE Service Profile Window appears.

Step 2 Select the profile you wish to edit from the list of profiles displayed on the left-hand-side of the window.

Step 3 Edit the parameters in the QoS Parameters and Sub-Interface Parameters frames as required.

Note Refer to the “Route Bridge Encapsulation (RBE) Service Configuration Window” section on page 7-36 for details of the parameters displayed on each of the tabs in the RBE Service Profile window.
Creating Service Profiles for an Route Bridge Encapsulation (RBE) Service

**Step 4** Select **Save** from the **File** menu to save the configuration.

**Step 5** Select **Close** from the **File** menu to close the window and save the changes made.

**Deleting an Existing RBE Service Profile**

**Step 1** Select the **Cisco 6400 UAC, Profiles, Configure RBE Profiles** option from any card type (that is NSP, NRP or Line Card).

The RBE Service Profile Window (RBE Tab) appears.

**Step 2** Select the profile you wish to edit from the list of profiles displayed on the left-hand-side of the window.

**Step 3** Right click and select **Delete object(s)** option.

The Deletion Summary Screen appears.

**Figure 6-14 Deletion Summary Screen**

**Step 4** Check the details in the Deletion Summary Screen.

**Step 5** Select **Finish** to delete the selected profile. The delete operation is initiated.

**Step 6** Select **Dismiss** to close the Deletion Summary Screen.
Creating Service Profiles for an RFC1483 Service

Service profiles are used to define configuration parameters for the uplink from the 6400 UAC to the service provider.

You can set up profiles and apply them or, alternatively, you can configure a service manually. The services available on the 6400 UAC have a number of parameters to configure. It is worth setting up a number of service profiles with at least some of the values complete (that can be applied later) to save time.

Step 1  
Select the **Cisco 6400 UAC, Profiles, Configure RFC1483 Profiles** option from any card type (that is NSP, NRP or Line Card) using the **MapViewer** application.

![RFC1483 Service Profile Window (RFC1483 Tab)](image)

Step 2  
Select **Create Profile**.

A Prompt window appears.
Creating Service Profiles for an RFC1483 Service

Step 3 Enter a name for the profile in the Enter profile name data entry box. Premium Profile was entered in the example shown in Figure 6-16.

Note Each service profile must have a unique name.

The RFC1483 Service Profile window reappears with the new profile name displayed in the left-hand-side of the window.

Note Select the Copy and Copy Page Configuration options in the Edit menu to cut and paste between different profiles. This is useful when you wish to copy profile information from one to the next.

Step 4 Edit the parameters in the QoS Parameters and Sub-Interface Parameters frames as required.

Note Refer to the “RFC1483 Service Configuration Window” section on page 7-38 for details of the parameters displayed on each of the tabs in the PTA-MD Service Profile window.

Step 5 Select Save from the File menu to save the parameters you have selected for your service profile.

Step 6 Select Close from the File menu to close the window.

Editing an Existing RFC1483 Service Profile

Step 1 Select the Cisco 6400 UAC, Profiles, Configure RFC1483 Profiles option from any card type (that is NSP, NRP or Line Card).

The RBE Service Profile Window (shown in Figure 6-15) appears.

Step 2 Select the profile you wish to edit from the list of profiles displayed on the left-hand-side of the window.

Step 3 Edit the parameters in the QoS Parameters and Sub-Interface Parameters frames as required.

Note Refer to the “RFC1483 Service Configuration Window” section on page 7-38 for details of the parameters displayed on each of the tabs in the RBE Service Profile window.
Defining Policies For Service Provisioning

Step 4 Select **Save** from the **File** menu to save the configuration.
Step 5 Select **Close** from the **File** menu to close the window and save the changes made.

Deleting an Existing RFC1483 Service Profile

Step 1 Select the **Cisco 6400 UAC, Profiles, Configure RFC1483 Profiles** option from any card type (that is NSP, NRP or Line Card).

The RFC1483 Service Profile Window appears.

Step 2 Select the profile you wish to edit from the list of profiles displayed on the left-hand-side of the window.

Step 3 Right click and select **Delete object(s)** option.

The Deletion Summary Screen appears.

**Figure 6-17 Deletion Summary Screen**

Step 4 Check the details in the Deletion Summary Screen.
Step 5 Select **Finish** to delete the selected profile. The delete operation is initiated.
Step 6 Select **Dismiss** to close the Deletion Summary Screen.
Creating Subscriber QoS Profiles

A QoS profile is a method of defining a set of QoS parameters in advance that can be applied to a number of subscriber QoS objects without having to enter the same information each time.

The subscriber QoS profile applies to the subscriber traffic incoming to the Cisco 6400 UAC, for example, from the DSLAM to the 6400 UAC.

To create a subscriber QoS profile, proceed as follows:

Step 1  Start MapViewer and select the Chassis map.

Step 2  Select the Cisco 6400 UAC, Profiles, Configure Subscriber QoS Profiles option from a Line Card.

The Subscriber QoS Profiles window appears.

Figure 6-18  Subscriber QoS Profiles Window

Note  The profile list (displayed above the Create Profile button) is initially empty, as shown in Figure 6-18.

Step 3  Select the Create Profile button.

A Prompt window appears.

Figure 6-19  Prompt Window

Step 4  Enter a name for the QoS profile in the Enter profile name data entry box.
In the example (shown in Figure 6-19) `Gold-QoS-Profile` is entered as an example. Typical names are `Gold`, `Silver` or `Bronze` profile.

**Step 5** Click `Ok` to accept the profile name. The new profile name appears in the profile list (displayed above the `Create Profile` button) in the Subscriber QoS Profiles window.

**Step 6** Enter a description in the `QoS Description` entry box. This is an optional parameter that allows you to add additional relevant information.

**Step 7** Enter/select values in the `QoS Parameters` frame. Select `ubr` as the `QoS Category`, enter `900` for the `Peak Cell Rate` and leave the remaining fields blank.

The values entered into the `QoS Parameters` frame are normally defined in the Service Providers policy.

---

**Note** You do not need to set all the values in the `QoS Parameters` tab as these values can be added to or updated later.

---

**Step 8** Select the `Save` option from the `File` menu to save the parameters you have selected for your QoS profile.

---

**Note** The profiles can be changed at any time. So you can set up a general profile, change the parameters and then save it with an appropriate name.

---

**Step 9** Select the `Close` option from the `File` menu to close the Subscriber QoS Profiles window.

---

**Editing an Existing Subscriber QoS Profile**

To edit an existing subscriber QoS profile, proceed as follows:

**Step 1** Start `MapViewer` and select the Chassis map.

**Step 2** Select the `Cisco 6400 UAC, Profiles, Configure Subscriber QoS Profiles` option from a Line Card.

The Subscriber QoS Profiles window appears.
Creating Subscriber QoS Profiles

Figure 6-20  Subscriber QoS Profiles Window

Step 3  Select the existing QoS profile that you wish to edit. In the example (shown in Figure 6-20) the silver profile is selected.

Note  Select the Copy and Copy Page Configuration options in the Edit menu to cut and paste between different profiles. This is useful when you wish to copy profile information from one to the next.

Step 4  Edit the description in the QoS Description entry box (if required).
Step 5  Enter/select values in the QoS Parameters frame as required.
Step 6  Select the Save option from the File menu.
Step 7  Select the Close option from the File menu to close the Subscriber QoS Profiles window.

Deleting an Existing Subscriber QoS Profile

To delete an existing subscriber QoS profile, proceed as follows:

Step 1  Start MapViewer and select the Chassis map.
Step 2  Select the Cisco 6400 UAC, Profiles, Configure Subscriber QoS Profiles option from a Line Card.

The Subscriber QoS Profiles window appears.
Step 3 Select the existing QoS profile that you wish to delete. In the example (shown in Figure 6-21) the silver profile is selected.

Step 4 Right click and select Delete object(s) option.

The Deletion Summary Screen appears.

Step 5 Check the details in the Deletion Summary Screen.

Step 6 Select Finish to delete the selected QoS profile.

Step 7 Select Dismiss to close the Deletion Summary Screen.
Service Provisioning

One of the most important aspects of the Cisco 6400 SCM application is Service Connection Management. The Cisco 6400 UAC contains multiple network elements, an ATM switch, multiple router cards (NRPs), and multiple line cards. Services are deployed across these network elements, a multistage process involving both SNMP and Cisco IOS management commands. The Cisco 6400 SCM application enables point-and-click connection of end subscribers to 6400-based services with all of the underlying IOS and SNMP operation hidden.

This section describes service subscriber management using a number of work flows to describe how to connect services to subscribers.

Setting Up Services on the Cisco 6400 UAC

The 6400 SCM software is designed to help simplify Cisco 6400 UAC service configuration. A typical work flow is described in this section, you can use this example as a tutorial.

Figure 6-23 Setting Up Services on the Cisco 6400 UAC

Create a Service Instance

OR

Apply the Service Profile to the Service Instance

Configure Service Instance Manually

Some manual configuration is always required (for example, uplink VPI/VCI)

Commission a Service Instance

Note The “Commissioning a Service Instance” section on page 6-33 is the only section that involves direct configuration of the 6400 UAC hardware.
Creating a Service Instance

A service instance is an object that holds all the information related to that service. Service Instances are deployed from different launch points (depending on the type of service instance you wish to deploy).

Step 1 Select the **Deploy, Cisco 6400, Service Instance** option from the egress ATM line card object using the MapViewer application for the pure ATM switching service.

OR

Select the **Deploy, Cisco 6400, Service Instance** option from an NSP object using the MapViewer application for all other NRP based service types (that is, PPP-IP, PPP-L2TP, Bridged-Bridged, Bridged-Routed, PTA-MD, RBE, and RFC1483 routing).

The Deployment Selector Screen appears.

Figure 6-24  Deployment Selector Screen

Step 2 Select the **Create Service Instance(s)** option (if not already selected).

Step 3 Select **Forward**.

The Deployment Details Screen appears.

Step 4 Enter the **Number of Service Instances** to create. Enter “1” for this example.

Step 5 Select **Forward**.

Step 6 Enter a **Service Instance Name**. Enter **Premium** as an example.

Step 7 Select **Forward**.

Note Proceed to Step 14 when deploying a service instance for a pure ATM switching service.

Step 8 Select the **NRP ATM Port** the Service Instance is to reside on in the serviceInstanceContainment window.

Step 9 Select **Apply**.
Step 10  Select the **NRP ATM Port** that the Service Instance is to reside on in the mgmtContainment window.

Step 11  Select **Apply**.

Step 12  Repeat steps 6 to 11 for the **Number of Service Instances** entered in step 4.

Step 13  Click **Forward**. The Deployment Summary screen appears.

   The **Deployment Summary** details appear in the Deployment Summary Screen.

Step 14  Click **Finish** (if the **Deployment Summary** information is correct) to commit the deployment and create the Service Instance.

Note  If the **Deployment Summary** information is incorrect, click **Back** until the screen showing the incorrect information is displayed. Correct the information and click **Forward** until the correct **Deployment Summary** information re-appears.

Step 15  Click **Dismiss** to close the Deployment Summary Screen.
Applying a Service Profile to a Service Instance

Step 1 Select the **Cisco 6400 UAC, Service, Configure Services** option from an NRP Card (for all services except pure ATM switching). You cannot apply a profile to the pure ATM switching service.

The Service Instance Configuration window appears.

**Figure 6-25 Service Instance Configuration Window**

Step 2 Select the appropriate **NSP, ATM Port** and **Service Instance** from the appropriate list displayed at the left-hand-side of the window.

Step 3 Select **Apply Profile** from the **Edit** menu. The profile parameters are copied to the appropriate service instance parameters.

Step 4 Select the appropriate profile from the list of profiles displayed.

Step 5 Add or modify parameter options, if required.

Step 6 Select **Save** to save the Service Instance.

Step 7 Commission the Service Instance after a Service Profile has been applied. To configure a service instance, you can either apply a pre-defined service profile or directly edit the service parameters.

Step 8 Select **Close** from the **File** menu to close the Service Instance Configuration window.
Step 9  Proceed to the “Commissioning a Service Instance” section on page 6-33. You should select the ATM port upon which you previously created (that is, deployed) a service instance.
Configuring a Service Instance Manually

Service Instances are deployed from different launch points (depending on the type of service instance you wish to deploy).

Step 1 Select the **Deploy, Cisco 6400, Configure Service** option from the egress ATM line card object using the MapViewer application for the pure ATM switching service.

OR

Select the **Deploy, Cisco 6400, Configure Service** option from an NSP object using the MapViewer application for all other NRP based service types (that is, PPP-IP, PPP-L2TP, Bridged-Bridged, and Bridged-Routed).

Note You must have a service instance already created for that port. Existing service instances for the selected port are displayed in the **Service Instance** list box at the bottom left-hand corner of the window.

The Service Instance Configuration window appears.

**Figure 6-26 Service Instance Configuration Window (General Tab)**

Step 2 Select the appropriate **NSP, ATM Port** and **Service Instance** from the appropriate list displayed at the left-hand-side of the window.
Note  You can apply a service profile at this stage containing some of the parameters required for the service instance, and then add or edit the parameters as appropriate. Refer to the “Applying a Service Profile to a Service Instance” section on page 6-28 for details of how to apply a service profile to a service instance.

Step 3  Select the **General** tab (shown in Figure 6-26) if it is not already selected.

Step 4  Enter a description into the **Service Description** data entry box in the **Service Details** frame.

Step 5  Select whether to **Allow** or **Prevent** oversubscription.

The **Oversubscription** option is set to **Allow** by default and an unlimited number of subscribers can be connected to the service. Selecting to **Prevent Oversubscription** ensures that the SCM limits the number of subscribers connected such that the sum of the subscriber’s peak cell rates never exceeds the peak cell rate reserved for the service on the uplink. **Oversubscription** functionality is not applicable to the PPP-IP and ATM services.

Step 6  Select a **Service Type** from the drop down list. This **Service Type** is a range of options you can use to configure the uplink from the 6400 UAC to the upstream service provider.

Note  Refer to the appropriate section in the “Cisco 6400 SCM Services” section on page 2-22 for further details on the selected **Service Type**.

As an example, the **ATM** service type is selected.

Note  When a **Service Type** is selected the service tabs that do not relate to this service are greyed out and cannot be selected. For example, when the **ATM** service is selected the **PPP-IP**, **PPP-L2TP**, **Bridged-Bridged** and **Bridged-Routed** tabs are greyed out.
Step 7 Enter/select values for each of the parameters displayed in the selected service tab, as appropriate.

Step 8 Select **Save** from the **File** menu to save the configuration.

Step 9 Select **Close** from the **File** menu to close the window.

---

**Note** Proceed to the “Commissioning a Service Instance” section on page 6-33. You should select the ATM port upon which you previously created (that is, deployed) a service instance.
Commissioning a Service Instance

This is the first stage at which you actually “roll” the selected service configuration onto the 6400 UAC hardware.

Commissioning the ATM Service

Note  Service profiles are not applicable to the pure ATM switching service as there are no generic service parameters for this type of service.

The ATM service is set up by configuring the parameters displayed in the Service Instance Configuration window, shown in Figure 6-28.

To configure the pure ATM switching service, proceed as follows:

Step 1  Select the line card (from MapViewer) upon which you wish to deploy the ATM service instance.

Step 2  Select the Cisco 6400 UAC, Services, Configure Services option.

   The Service Instance Configuration window (General tab) appears.

Figure 6-28  Service Instance Configuration Window (General Tab)

Step 3  Enter a Service Description in the Service Details frame, if required.
Service Provisioning

Step 4 Select a Service Type (ATM option) in the Service Details frame.

When a Service Type is selected the service tabs that do not relate to this service are greyed out and cannot be selected. For example, when the ATM service is selected the PPP-IP, PPP-L2TP, Bridged-Bridged and Bridged-Routed tabs are greyed out.

Step 5 Select the ATM tab. The Service Instance Configuration Window (ATM Tab) is displayed.

Figure 6-29 Service Instance Configuration Window (ATM Tab)

Step 6 Enter values into the Egress Port Parameters frame, as required.

Refer to the “Service Instance Configuration Window” section on page 7-22 for details on each of the parameters displayed on the ATM tab.

Step 7 Select Commission Service to roll the service onto the 6400 UAC.

A pop up window appears for you to confirm that you wish to commission the selected service.
Commissioning a Service Instance

Commissioning the PPP-IP Service

The PPP-IP service is set up by configuring the various parameters displayed in the Service Instance Configuration window (PPP-IP tab), shown in Figure 6-33.

To commission the PPP-IP service, proceed as follows:

Step 1 Select the NRP (from MapViewer) upon which you wish to deploy the PPP-IP service instance.

Step 2 Select the Cisco 6400 UAC, Services, Configure Services option at an NRP. The Service Instance Configuration Window (General Tab) appears.

Step 8 Select Yes to commission the service (or No to return to the Service Instance Configuration window).

The Action Report window appears.

Step 9 Check the details in the Action Report window to ensure that the service was commissioned successfully.

Step 10 Select Save to save the Action Report, if required.

Step 11 Select Close to close the Action Report window and return to the Service Instance Configuration window.

Step 12 Select Close from the File menu to close the Service Instance Configuration window.
Step 3 Select the **Apply Profile** option from the **Edit** menu, if applicable. Select the profile you wish to apply from the list of profiles displayed. When a profile is applied the parameters are copied and saved automatically.

Refer to the “Creating Service Profiles (for PPP-IP, PPP-L2TP, Bridged-Bridged, and Bridged-Routed Services)” section on page 6-4 for details of how to create service profiles.

Refer to the “Service Instance Configuration Window” section on page 7-22 for details on each of the parameters displayed on the **PPP-IP** tab.

Step 4 Enter a **Service Description** in the **Service Details** frame, if required.

Step 5 Select the **PPP-IP** option as the **Service Type** in the **Service Details** frame.

When a **Service Type** is selected the service tabs that do not relate to this service are greyed out and cannot be selected. For example, when the **PPP-IP** service is selected the **ATM, PPP-L2TP, Bridged-Bridged and Bridged-Routed** tabs are greyed out.

Step 6 Select the **PPP-IP** tab.
Commissioning a Service Instance

Figure 6-33  Service Instance Configuration Window (PPP-IP Tab)

Step 7  Enter values into the Virtual Template Parameters, IP Address Pool, and VC Class Parameters frames, as required.

Refer to the “Creating Service Profiles (for PPP-IP, PPP-L2TP, Bridged-Bridged, and Bridged-Routed Services)” section on page 6-4 for details of how to create service profiles.

Step 8  Refer to the “Service Instance Configuration Window” section on page 7-22 for details on each of the parameters displayed on the PPP-IP tab.

Step 9  Select Commission Service to roll the service onto the 6400 UAC.

A pop up window appears for you to confirm that you wish to commission the selected service.

Figure 6-34  About to Change Service State Confirmation Window

Step 10  Select Yes to commission the service (or No to return to the Service Instance Configuration window).

The Action Report window appears.
Step 11 Check the details in the Action Report window to ensure that the service was commissioned successfully.

Step 12 Select Save to save the Action Report, if required.

Step 13 Select Close to close the Action Report window and return to the Service Instance Configuration window.

Step 14 Select Close from the File menu to close the Service Instance Configuration window.

Additional IOS Configuration For the PPP-IP Service

For the PPP-IP service to pass traffic to a designated trunk port, Cisco IOS must be used (to route traffic via layer 3 to a destination network). One way of doing this is to create a PVC on the NRP to support the routing of traffic to the trunk port and then create the required entries in the IP Routing Table.

Execute (on the selected NRP) the following IOS commands to configure a PPP-IP service to pass traffic to a designated trunk port:

```
NRP(config)#interface atm0/0/0.<Sub-Interface Number> point-to-point
NRP(config-if)#ip address <IP Address> <Subnet Mask>
NRP(config-if)#pvc <NRP-Interface-vpi>/<NRP-Interface-vci>
NRP(config-if-vc)#class <vc-class-name>
NRP(config-if-vc)#protocol ip <Dest IP Address> no broadcast
```

where,

- `<Sub-Interface Number>` is a number for the sub-interface
- `<IP Address>` is the IP Address of the sub-interface
- `<Subnet Mask>` is the Subnet Mask of the sub-interface
<NRP-Interface-vpi> is the same VPI value as used when a PVC is created on the NSP

<NRP-Interface-vci> is the same VPI value as used when a PVC is created on the NSP

<Dest IP Address> is the destination IP Address mapped to the PVC

<vc-class-name> is the name of the vc-class created previously

Now create the required entries in the IP Routing Table:

NRP(config)#ip route <Dest IP Address> 255.255.255.255 atm0/0/0.<Sub-Interface Number>

where,

<Dest IP Address> is as configured previously

<Sub-Interface Number> is as configured previously.
Commissioning the PPP-L2TP Service

The PPP-L2TP service is set up by configuring the various parameters displayed in the Service Instance Configuration window (PPP-L2TP tab), shown in Figure 6-37.

To commission the PPP-L2TP service, proceed as follows:

Step 1 Select the NRP (from MapViewer) upon which you wish to deploy the service instance.

Step 2 Select the Cisco 6400 UAC, Services, Configure Services option at an NRP. The Service Instance Configuration Window (General Tab) appears.

Figure 6-36 Service Instance Configuration Window (General Tab)

Step 3 Select the Apply Profile option from the Edit menu, if applicable. Select the profile you wish to apply from the list of profiles displayed. When a profile is applied the parameters are copied and saved automatically.

Refer to the “Creating Service Profiles (for PPP-IP, PPP-L2TP, Bridged-Bridged, and Bridged-Routed Services)” section on page 6-4 for details of how to create service profiles.

Refer to the “Service Instance Configuration Window” section on page 7-22 for details on each of the parameters displayed on the PPP-L2TP tab.

Step 4 Enter a Service Description in the Service Details frame, if required.

Step 5 Select the PPP-L2TP option as the Service Type in the Service Details frame.
When a Service Type is selected the service tabs that do not relate to this service are greyed out and cannot be selected. For example, when the PPP-L2TP service is selected the ATM, PPP-IP, Bridged-Bridged and Bridged-Routed tabs are greyed out.

**Step 6** Select the PPP-L2TP tab.

**Figure 6-37** Service Instance Configuration Window (PPP-L2TP Tab)

**Step 7** Enter values into the Egress Port Parameters, Egress Port QoS Parameters, Sub-Interface Parameters, NSP/NRP Interface PVC Parameters, Tunnel Parameters, VC Class Parameters, and Virtual Template Parameters frames, as required.

Refer to the “Creating Service Profiles (for PPP-IP, PPP-L2TP, Bridged-Bridged, and Bridged-Routed Services)” section on page 6-4 for details of how to create service profiles.

Refer to the “Service Instance Configuration Window” section on page 7-22 for details on each of the parameters displayed on the PPP-IP tab.

**Step 8** Select Commission Service to roll the service onto the 6400 UAC.

A pop up window appears for you to confirm that you wish to commission the selected service.
Step 9  Select **Yes** to commission the service (or **No** to return to the Service Instance Configuration window).

The Action Report window appears.

The Action Report window details the IOS commands executed when the service is commissioned. Invalid IOS commands result in a failure to commission the service.

Step 10  Check the details in the Action Report window to ensure that the service was commissioned successfully.

Step 11  Select **Save** to save the Action Report, if required.

Step 12  Select **Close** to close the Action Report window and return to the Service Instance Configuration window.

Step 13  Select **Close** from the **File** menu to close the Service Instance Configuration window.

**Commissioning the Bridged-Bridged Service**

The Bridged-Bridged service is set up by configuring the various parameters displayed in the Service Instance Configuration window (Bridged-Bridged tab), shown in Figure 6-41.

To commission the Bridged-Bridged service, proceed as follows:

Step 1  Select the NRP (from **MapViewer**) upon which you wish to deploy the service instance.

Step 2  Select the **Cisco 6400 UAC, Services, Configure Services** option at an NRP. The Service Instance Configuration Window (General Tab) appears.
Figure 6-40  Service Instance Configuration Window (General Tab)

Step 3  Select the **Apply Profile** option from the **Edit** menu, if applicable. Select the profile you wish to apply from the list of profiles displayed. When a profile is applied the parameters are copied and saved automatically.

Refer to the “Creating Service Profiles (for PPP-IP, PPP-L2TP, Bridged-Bridged, and Bridged-Routed Services)” section on page 6-4 for details of how to create service profiles.

Refer to the “Service Instance Configuration Window” section on page 7-22 for details on each of the parameters displayed on the **Bridged-Bridged** tab.

Step 4  Enter a **Service Description** in the **Service Details** frame, if required.

Step 5  Select the **Bridged-Bridged** option as the **Service Type** in the **Service Details** frame.

When a **Service Type** is selected the service tabs that do not relate to this service are greyed out and cannot be selected. For example, when the **Bridged-Bridged** service is selected the ATM, PPP-IP, PPP-L2TP, **Bridged-Bridged** and **Bridged-Routed** tabs are greyed out.

Step 6  Select the **Bridged-Bridged** tab.
Figure 6-41 Service Instance Configuration Window (Bridged-Bridged Tab)

Step 7 Enter values into the **Egress Port Parameters**, **Egress Port QoS Parameters**, **Bridge Parameters**, **NSP/NRP Interface PVC Parameters**, **Subscriber Policy**, and **VC Class Parameters** frames, as required.

Refer to the “Creating Service Profiles (for PPP-IP, PPP-L2TP, Bridged-Bridged, and Bridged-Routed Services)” section on page 6-4 for details of how to create service profiles.

Refer to the “Service Instance Configuration Window” section on page 7-22 for details on each of the parameters displayed on the **Bridged-Bridged** tab.

Step 8 Select **Commission Service** to roll the service onto the 6400 UAC.

A pop up window appears for you to confirm that you wish to commission the selected service.
Step 9  Select **Yes** to commission the service (or **No** to return to the Service Instance Configuration window).

The Action Report window appears.

The Action Report window details the IOS commands executed when the service is commissioned. Invalid IOS commands result in a failure to commission the service.

Step 10  Check the details in the Action Report window to ensure that the service was commissioned successfully.

Step 11  Select **Save** to save the Action Report, if required.

Step 12  Select **Close** to close the Action Report window and return to the Service Instance Configuration window.

Step 13  Select **Close** from the **File** menu to close the Service Instance Configuration window.

**Commissioning the Bridged-Routed Service**

The Bridged-Routed service is set up by configuring the various parameters displayed in the Service Instance Configuration window (Bridged-Routed tab), shown in Figure 6-45.

To commission the Bridged-Routed service, proceed as follows:

Step 1  Select the NRP (from **MapViewer**) upon which you wish to deploy the service instance.

Step 2  Select the **Cisco 6400 UAC, Services, Configure Services** option at an NRP. The Service Instance Configuration Window (General Tab) appears.
Step 3 Select the **Apply Profile** option from the **Edit** menu, if applicable. Select the profile you wish to apply from the list of profiles displayed. When a profile is applied the parameters are copied and saved automatically.

Refer to the “Creating Service Profiles (for PPP-IP, PPP-L2TP, Bridged-Bridged, and Bridged-Routed Services)” section on page 6-4 for details of how to create service profiles.

Refer to the “Service Instance Configuration Window” section on page 7-22 for details on each of the parameters displayed on the **Bridged-Routed** tab.

Step 4 Enter a **Service Description** in the **Service Details** frame, if required.

Step 5 Select the **Bridged-Routed** option as the **Service Type** in the **Service Details** frame.

When a **Service Type** is selected the service tabs that do not relate to this service are greyed out and cannot be selected. For example, when the **Bridged-Routed** service is selected the **ATM**, **PPP-IP**, **PPP-L2TP**, **Bridged-Bridged** and **Bridged-Bridged** tabs are greyed out.

Step 6 Select the **Bridged-Routed** tab.
Step 7 Enter values into the Egress Port Parameters, Egress Port QoS Parameters, Bridge Parameters, NSP/NRP Interface PVC Parameters, Subscriber Policy, VC Class Parameters, and Sub-Interface Parameters frames, as required.

Refer to the “Creating Service Profiles (for PPP-IP, PPP-L2TP, Bridged-Bridged, and Bridged-Routed Services)” section on page 6-4 for details of how to create service profiles.

Refer to the “Service Instance Configuration Window” section on page 7-22 for details on each of the parameters displayed on the Bridged-Routed tab.

Step 8 Select Commission Service to roll the service onto the 6400 UAC.

A pop up window appears for you to confirm that you wish to commission the selected service.
Step 9  Select Yes to commission the service (or No to return to the Service Instance Configuration window).

The Action Report window appears.

The Action Report window details the IOS commands executed when the service is commissioned. Invalid IOS commands result in a failure to commission the service.

Step 10  Check the details in the Action Report window to ensure that the service was commissioned successfully.

Step 11  Select Save to save the Action Report, if required.

Step 12  Select Close to close the Action Report window and return to the Service Instance Configuration window.

Select Close from the File menu to close the Service Instance Configuration window.

Commissioning the PTA-MD Service

The PTA-MD service is set up by configuring the parameters displayed in the PTA-MD Service Configuration window (PTA-MD tab), shown in Figure 6-48.

To commission the PTA-MD service, proceed as follows:

Step 1  Select the NRP (from MapViewer) upon which you wish to deploy the PTA-MD service instance.

Step 2  Select the Cisco 6400 UAC, Services, Configure PTA-MD Service option at an NRP to display the PTA-MD Service Instance Configuration window.
Step 3 Select the **Apply Profile** option from the **Edit** menu, if applicable. Select the profile you wish to apply from the list of profiles displayed. When a profile is applied the parameters are copied and saved automatically.

Refer to the “Creating Service Profiles for a PTA-MD Service” section on page 6-11 for details of how to create service profiles.

Step 4 Enter values into the **QoS Parameters**, **Sub-Interface Parameters**, **Egress Port Parameters**, and **PVC Configuration** frames, as required.

Refer to the “PTA-MD Service Configuration Window” section on page 7-32 for details on each of the parameters displayed on the **PTA-MD** tab.

Step 5 Select the **Local Service Profile** tab.
Step 6  Enter values into the **General**, **DNS Redirection/Fault Tolerance**, and **Remote RADIUS Configuration** frames, as required.

The **Remote RADIUS Configuration** parameters are only available when **Proxy** is selected as the service **Type**.

Refer to the “Local Service Profile Tab” section on page 7-34 for details on each of the parameters displayed on the **Local Service Profile** tab.

Step 7  Select **Commission Service** to roll the service onto the 6400 UAC.

A pop up window appears for you to confirm that you wish to commission the selected service.

**Figure 6-50**  About to Change Service State Confirmation Window

Step 8  Select **Yes** to commission the service (or **No** to return to the Service Instance Configuration window).

The Action Report window appears.
Commissioning a Service Instance

Figure 6-51  Action Report Window

The Action Report window details the IOS commands executed when the service is commissioned. Invalid IOS commands result in a failure to commission the service.

Step 9  Check the details in the Action Report window to ensure that the service was commissioned successfully.

Step 10  Select Save to save the Action Report, if required.

Step 11  Select Close to close the Action Report window and return to the Service Instance Configuration window.

Step 12  Select Close from the File menu to close the Service Instance Configuration window.

Commissioning the RBE Service

The RBE service is set up by configuring the parameters displayed in the RBE Service Configuration window (Route Bridge Encapsulation tab), shown in Figure 6-52.

To commission the RBE Service Configuration window (Route Bridge Encapsulation tab), proceed as follows:

Step 1  Select the NRP (from MapViewer) upon which you wish to deploy the RBE service instance.

Step 2  Select the Cisco 6400 UAC, Services, Configure RBE Service option at an NRP to display the RBE Service Configuration window.

The RBE Service Configuration window (Route Bridge Encapsulation Tab) appears.
Step 3 Select the **Apply Profile** option from the **Edit** menu, if applicable. Select the profile you wish to apply from the list of profiles displayed. When a profile is applied the parameters are copied and saved automatically.

Refer to the “Creating Service Profiles for an Route Bridge Encapsulation (RBE) Service” section on page 6-15 for details of how to create service profiles.

Step 4 Enter values into the **QoS Parameters**, **Sub Interface Parameters**, **Egress Port Parameters**, **PVC Configuration**, and **Next Hop** frames, as required.

Refer to the “Route Bridge Encapsulation (RBE) Service Configuration Window” section on page 7-36 for details on each of the parameters displayed on the **Route Bridge Encapsulation** tab.

Step 5 Select **Commission Service** to roll the service onto the 6400 UAC.

A pop up window appears for you to confirm that you wish to commission the selected service.

Step 6 Select **Yes** to commission the service (or **No** to return to the Service Instance Configuration window).
The Action Report window appears.

Figure 6-54  Action Report Window

The Action Report window details the IOS commands executed when the service is commissioned. Invalid IOS commands result in a failure to commission the service.

Step 7  Check the details in the Action Report window to ensure that the service was commissioned successfully.

Step 8  Select Save to save the Action Report, if required.

Step 9  Select Close to close the Action Report window and return to the Service Instance Configuration window.

Step 10  Select Close from the File menu to close the Service Instance Configuration window.

Commissioning the RFC1483 Service

The RFC1483 service is set up by configuring the parameters displayed in the RBE Service Configuration window (Route Bridge Encapsulation tab), shown in Figure 6-52.

To commission the RFC1483 service, proceed as follows:

Step 1  Select the NRP (from MapViewer) upon which you wish to deploy the RBE service instance.

Step 2  Select the Cisco 6400 UAC, Services, Configure RFC1483 Service option at an NRP to display the RFC1483 Service Configuration window.

The RFC Service Configuration window (RFC1483 Routed tab) appears.
Step 3 Select the **Apply Profile** option from the **Edit** menu, if applicable. Select the profile you wish to apply from the list of profiles displayed. When a profile is applied the parameters are copied and saved automatically.

Refer to the “Creating Service Profiles for an RFC1483 Service” section on page 6-18 for details of how to create service profiles.

Step 4 Enter values into the **QoS Parameters**, **Sub Interface Parameters**, **VC Class Parameters**, **Egress Port Parameters**, and **PVC Configuration** frames, as required.

Refer to the “RFC1483 Service Configuration Window” section on page 7-38 for details on each of the parameters displayed on the **RFC1483 Routed** tab.

Step 5 Select **Commission Service** to roll the service onto the 6400 UAC.

A window appears for you to confirm that you wish to commission the selected service.

Step 6 Select **Yes** to commission the service (or **No** to return to the Service Instance Configuration window).

The Action Report window appears.
Commissioning a Service Instance

Figure 6-57  Action Report Window

The Action Report window details the IOS commands executed when the service is commissioned. Invalid service parameter options result in a failure to commission the service.

Caution   The 6400 SCM will roll-back configuration changes applied if an error is detected in the execution of the IOS command sequence with your selected parameters. This insures that the 6400 UAC remains in a consistent state, even when errors are made entering parameters.

Step 7    Check the details in the Action Report window to ensure that the service was commissioned successfully.

Step 8    Select Save to save the Action Report, if required. This may be useful for troubleshooting purposes.

Step 9    Select Close to close the Action Report window and return to the Service Instance Configuration window.

Step 10   Select Close from the File menu to close the Service Instance Configuration window.
Subscriber Provisioning

Figure 6-58 shows a typical work flow example that describes how to set up (provision) a subscriber (that is, the end customer). You can use this work flow as a tutorial.

The first step is to create DSLAMs and subscribers using the deployment wizard. Each subscriber created must have at least one Quality of Service (QoS) object. They can have multiple QoS objects. One subscriber may be connected to many different types of service, and each of these may have a different subscriber QoS. You can either configure the subscriber QoS at runtime or you can create QoS profiles in advance.

The final step of the work flow is to apply the QoS profile or configure the subscriber QoS or manually at runtime. This option is available through the CEMF maps.
Creating a DSLAM Object

Subscribers within the 6400 SCM application are modeled in relation to the network. First of all you have to define a connectivity point (that is, a DSLAM).

Note The DSLAM object is simply a “placeholder” object. It may represent an actual DSLAM in your network, or alternatively a POP or other type of network element.

To create DSLAM objects, proceed as follows:

Step 1 Select the Deploy, Cisco 6400 UAC, DSLAM option from a Line Card.

The Deployment wizard launches.

Figure 6-59 Deployment Selector Screen

Step 2 Select Create DSLAM(s) in the Deployments frame (if it not already selected).

Step 3 Select Forward.

Step 4 Enter the Number of DSLAMs: to create. Enter 1 as an example.

Step 5 Select Forward.

Step 6 Enter a DSLAM Name. Enter DSLAM-1 as an example.

Step 7 Select Forward.

The Containment Details window appears.

Step 8 Click Select.

The subscriberContainment window appears.
Step 9  Select a **Port** to deploy the DSLAM onto. Only ports with a “green” color icon are valid. In the example shown in Figure 6-60, **Port-8-0-0** is selected.

Step 10  Select **Apply**.

The Containment Details window reappears.

Step 11  Select **Forward**.

---

**Note**  You must repeat steps 6 to 11 for each DSLAM object, if you entered more than one DSLAM object in step 4.

The Deployment Summary window appears.

Step 12  Select **Finish** to commit the deployment.

Step 13  Select **Dismiss** to close the Deployment wizard.

You have just created a DSLAM object connected to a selected line card port. You can now view the DSLAM object created through **Objects** manager on the CEMF Launchpad.
Creating a Subscriber and Associated Subscriber QoS

Subscriber’s hold information related to the end subscriber. Subscribers are created by deploying onto a selected Line Card and connecting them to appropriate ports in the DSLAM.

To create subscribers, proceed as follows:

Step 1 Select the **Deploy, Cisco 6400 UAC, Subscriber and QoS** option from a Line Card.

The Deployment Selector screen appears.

Figure 6-61 Deployment Selector Screen

![Deployment Selector Screen](image)

Step 2 Select the **Create Subscribers and associated QoSs** option from the list of deployments (if not already selected).

Step 3 Click **Forward**.

Step 4 Enter the **Number of Subscribers** to create.

Step 5 Click **Forward**.

Step 6 Enter the **Subscriber Name**.

Step 7 Click **Forward**.

The Containment Details Screen appears.

Step 8 Click **Select**.

The subscriberContainment window appears.
Step 9  Select a DSLAM to deploy the subscriber onto. The DSLAM objects were deployed earlier in this work flow. DSLAM-1 is selected in the example shown in Figure 6-62.

Step 10 Select Apply. The Containment Details window reappears.

Step 11 Select Forward.

Note  Repeat steps 6 to 11 if more than one subscriber was entered in step 4.

The Object Details window appears.

Step 12 Enter the Subscriber QoS name.

Step 13 Select Finish to commit the deployment and create the Subscriber.

Step 14 Select Dismiss to close the Deployment Summary window.
Creating Additional Subscriber QoS (Optional)

Note: This step is not essential as a Subscriber QoS is associated with a subscriber during subscriber creation.

You may wish to create more than one subscriber QoS. It is possible that a subscriber will subscribe to multiple services and may require or may be prepared to pay for different subscriber QoS. For example, the subscriber may have a bridge service that is used for work purposes and is paid for by their employer. This service is probably quite high-value. The subscriber may also have their own personal Internet link that would probably be a lower grade service. So this type of subscriber would need multiple subscriber QoS objects created.

To create a new subscriber QoS, proceed as follows:

Step 1 Select the **Deploy, Cisco 6400 UAC, Subscriber QoS** option from a Line Card.

   The Deployment wizard launches.

**Figure 6-63** Deployment Selector Screen

Step 2 Select the **Create Subscriber QoS(s)** option from the list of deployments (if not already selected).

Step 3 Select **Forward**.

Step 4 Enter the **Number of Subscriber QoSs** to create. Enter “1” as an example.

Step 5 Select **Forward**.

   The Object Details screen appears.

Step 6 Enter the **Subscriber QoS Name** in the Attributes frame.

Step 7 Select **Forward**.

Step 8 Click **Select** in the **Containments** frame. The subscriberContainment window appears.

Step 9 Select the **Subscriber from the object map**.

Step 10 Select **Apply**.
Step 11  Select **Forward**.

Note  Repeat steps 6 to 11 if more than one subscriber was entered in step 4.

Step 12  Select **Finish** to commit the deployment and create the Subscriber QoS.

Step 13  Select **Dismiss** to close the Deployment Summary window.
Configuring a Subscriber QoS

The Subscriber QoS Configure window allows you to configure existing Subscriber QoS parameters.

Step 1 Select the **Cisco 6400 UAC, Subscriber, Configure Subscriber QoS** option at a Line Card.

The Subscriber QoS Configuration window appears.

**Figure 6-64 Subscriber QoS Configuration Window**

![Subscriber QoS Configuration Window](image)

Step 2 Select the appropriate **NSP, DSLAM** and **Subscriber** to display the **QoS Parameters** associated with the selected **Subscriber**.

Step 3 Configure the parameters in the **QoS Parameters** frame, as required, or alternatively apply a QoS profile. Refer to the “Applying a QoS Profile to a Subscriber QoS” section on page 6-65 for further details.

Step 4 Select the **Save** option from the **File** menu to save the information.

Step 5 Select the **Close** option from the **File** menu to close the Subscriber QoS Configuration window.

Deleting a Subscriber QoS

Step 1 Start **MapViewer** and select the Chassis map.

---

Note: Alternatively you can start in **Objects** manager and select subscriberContainment
Step 2  Select a Line Card.
Step 3  Select the **Cisco 6400 UAC. Subscriber. Configure Subscriber QoS** option.
Step 4  Select the Subscriber QoS and right click.
Step 5  Select **Delete Objects**.
Step 6  Check the details in the Deletion Summary window.
Step 7  Click **Finish**.
Step 8  Click **Dismiss**.
Applying a QoS Profile to a Subscriber QoS

You can apply an existing QoS profile or configure the QoS Parameters individually.

Note QoS profiles are available from the Edit menu (assuming they have already been defined in advance). Refer to the “Creating Subscriber QoS Profiles” section on page 6-21 for further details.

To apply a QoS profile to a subscriber QoS, proceed as follows:

Step 1 Select the Cisco 6400 UAC, QoS, Configure Subscriber QoS option from a Line Card.
Step 2 Select the Apply Profile option from the Edit menu.
Step 3 Select the profile from the list of profiles displayed.
Step 4 The QoS Profile parameters are now copied into the QoS Parameters frame and saved automatically.
Step 5 Click Dismiss.
Subscriber Connection Management

Subscriber Connection Management is the process of configuring the subscriber PVC incoming to the Cisco 6400 UAC, and connecting the subscriber to the required service.

Note It is assumed that the required service has already been configured and commissioned.

Creating a Subscriber and Associated Subscriber QoS

Refer to the “Creating a Subscriber and Associated Subscriber QoS” section on page 6-59 for further details.

Configuring an Existing Subscriber

Step 1 Start MapViewer and select the Chassis map.

Note Alternatively you can start in Objects manager and select subscriberContainment.

Step 2 Select a Line Card.

Step 3 Select the Cisco 6400 UAC, Subscriber, Configure Subscribers option.

The Subscriber Configuration window appears.
Figure 6-66  Subscriber Configuration Window (Subscriber Details Tab)

Step 4  Select the **Subscriber Details** tab (if not already selected).

**Note**  Select the **Copy** and **Copy Page Configuration** options in the **Edit** menu to cut and paste between different profiles. This is useful when you wish to copy profile information from one to the next.

Step 5  Select an **NSP**, **DSLAM** and **Subscriber** from the appropriate lists at the left-hand-side of the window.

Step 6  Enter a **Contact Name** and **Contact Address** into the **Contact Name & Address** frame for the selected subscriber, as required.

Step 7  Enter a **Subscriber Name** and **Subscriber Address** into the **Subscriber Name & Address** frame, as required.

**Note**  Entering information into the **Subscriber Details** tab is optional. You can enter any information you like into the **Subscriber Details** tab. For example, you may decide to enter a subscriber identification in the **Subscriber Name** box and an e-mail address in the **Subscriber Address** box.

Step 8  Select the **Connections** tab.
Figure 6-67   Subscriber Configuration Window (Connections Tab)

Step 9   Select **Activate Polling** or **Deactivate Polling** (as required) in the **Bandwidth Utilization** frame.

The **Bandwidth Utilization** frame enables you to switch on/off, on an individual subscriber PVC basis, bandwidth utilization monitoring. Activate utilization polling using the **Activate Polling** button (shown in Figure 6-67). The **Receive/Transmit Utilization** gauges indicate the utilized bandwidth as a percentage of the Peak Cell Rate specified for the connection. The 6400 UAC permits the subscriber to exceed their allocated bandwidth. The gauge shows 100% when a user exceeds their peak cell rate.

**Note**   **Receive/Transmit Utilization** gauges are displayed from a subscriber’s point of view, that is, the **Transmit Utilization** value shows the number of cells per second the subscriber is transmitting and the **Receive Utilization** value shows the number of cells per second the subscriber is receiving.

Step 10   Select the **Save** option from the **File** menu to save the subscriber information.

Step 11   Select the **Close** option from the **File** menu to close the Subscriber Configuration window.
Deleting a Subscriber

Step 1 Start MapViewer and select the Chassis map.

Note Alternatively you can start in Objects manager and select subscriberContainment.

Step 2 Select a Line Card.
Step 3 Select the Cisco 6400 UAC, Subscriber, Configure Subscribers option.
Step 4 Select the Subscriber and right click.
Step 5 Select Delete Objects.
Step 6 Check the Deletion Summary details.
Step 7 Select Finish.

Connecting a Subscriber to a Service Instance

Step 1 Select the Cisco 6400 UAC, Subscriber, Connect Subscribers option from an NSP card.

The Service/Subscriber Connection window (shown in Figure 6-68) appears.

Figure 6-68 Service/Subscriber Connection Window

The Service/Subscriber Connection window is divided into four tabbed sections, Connect, RFC1483 Routed, PTA-MD and RBE.
Step 2 Select the **Subscriber** and the **Subscriber QoS**.

Note You can select one or more **Subscriber QoS** for each subscriber. You must have at least one configured with appropriate parameters.

Step 3 Select the **ATM Port** that the **Service Instance** resides on.

Step 4 Select a **Service Instance**.

Note The **Service Instance** is a service object, that is, a single service deployed on the 6400 UAC. It contains all the configuration information required for a service to run, for example, PPP-IP services or PPP-L2TP services. The **Service Instance** object is associated with a particular ATM port. So that will be on one of the NRP ATM ports for NRP-based services such as tunnelling or bridge-routed. For the ATM, pure ATM switching service, that will reside on one of the ATM line card ports. Inappropriate tabs are greyed out when a **Service Instance** is selected. For example, when a **Service Instance** relating to an RBE service is selected, the **RFC1483 Routed** and **PTA-MD** tabs are greyed out.

Step 5 Select and the appropriate tab and enter relevant information when connecting to **RFC1483 Routed**, **PTA-MD** or **RBE** services. Refer to the “Service Configuration Windows” section on page 7-21 for further details on the parameters contained in the **RFC1483 Routed**, **PTA-MD** and **RBE** tabs.

Step 6 Enter a **Username** and **Password** in the **Authentication (PPP-IP only)** frame.

Step 7 Select the **Automatic VPI/VCI Allocation** in the **Internal PVC Parameters** frame.

Step 8 Click **Connect**. A pop up window appears displaying the IOS transaction log as connection occurs.

Note The **Connect** button is greyed out when the Service Instance is in a commissioned state.

If the **Connect** operation fails the service instance remains in the **Decommissioned** state (that is, no configuration will have been applied to the Cisco 6400 UAC). Failure diagnostics information can be located by examining the IOS log.

Common failure causes include:

- Specifying duplicate (already utilized) incoming PVC details.
- Forgetting to configure the subscriber **QoS Parameters**.
- Specifying invalid **Ingress PVC** details.
- Selecting the **Manual** option for **Internal PVC Parameters** allocation and selecting a PVC that is already allocated.
Disconnecting a Subscriber from a Service Instance

Step 1  Select the **Cisco 6400 UAC, Subscriber, Disconnect Subscribers** option from an NSP card.

The Service/Subscriber Disconnection window appears.

**Figure 6-69  Service/Subscriber Disconnection Window**

Step 2  Select the **Subscriber**.

Step 3  Select the connection object that connects the Subscriber to the **Premium Service** Service Instance.

Step 4  Click **Disconnect**.

A pop up window appears to warn you that the selected subscriber is about to be disconnected.

**Figure 6-70  About to Disconnect Subscriber**

Step 5  Click **Yes** to disconnect the subscriber. The Action Report window appears confirming that the subscriber has been disconnected.
Figure 6-71    Action Report Window

Click Close to close the Action Report window or click Save to save the Action Report. The Action Report can be saved and used for diagnostic purposes. The “*** No errors encountered ***” message appears to show that disconnection was successful.
Administration

Editing a Commissioned Service

This may be used, if for example, you wish to alter the upstream data rate.

To edit a commissioned service, proceed as follows:

Step 1  Select Configure Services from an NRP
Step 2  Select the service instance you require.
Step 3  Decommission the service (beware, this will cause subscriber service interruption).
Step 4  Edit the service as required.
Step 5  Commission the service.

Editing a Currently Connected Subscriber

This operation can be performed without disconnecting the subscriber.

Step 1  Select the Configure Subscribers option from a line card.
Step 2  Select the NSP, DSLAM and Subscriber to display the subscribers details.
Step 3  Enter the contact and subscriber details and then save your changes.

Moving Subscribers between Services (or NRPs)

Step 1  From a line card select disconnect subscribers.
Step 2  Select the subscriber to disconnected.
Step 3  Press the Disconnect button.
Step 4  Select a new service.
Step 5  Connect the subscriber to a new service instance (and NRP, if appropriate).