|HP-UX Reference > S
HP-UX 11i Version 3: February 2007
shmget() — get shared memory segment
shmget() returns the shared memory identifier associated with key.
A shared memory identifier and associated data structure and shared memory segment of size size bytes (see glossary(9)) are created for key if one of the following is true:
Upon creation, the data structure associated with the new shared memory identifier is initialized as follows:
Specifying IPC_GLOBAL in a call to shmget(), along with IPC_CREAT, forces the shared memory segment to be allocated from the global quadrant and not from the local quadrants. If this is not possible, shmget() will fail. Refer to setmemwindow(1M) for more information.
Specifying IPC_RELAXED_ISOLATION in a call to shmget(), along with IPC_CREAT, can improve the performance of co-operating processes in cases where these processes are accessing a large number of shared memory segments. This flag is treated as a hint.
The flags IPC_MEM_INTERLEAVED, IPC_MEM_LOCAL, and IPC_MEM_FIRST_TOUCH involve the placement of physical memory. This is important only on Cache Coherent Non-Uniform Memory Architecture (ccNUMA) systems. They will have no effect otherwise. For more information regarding ccNUMA and locality domains, see mpctl(2). These flags are hints to the system. If memory of the desired type is not available, the next most suitable memory is returned instead.
If IPC_MEM_INTERLEAVED is set in shmflg, physical memory will come from interleaved memory. Interleaved memory is a hardware construct which combines the memory from several locality domains into one region of memory. This memory is striped together with a very fine granularity. Interleaved memory is a good place to put shared objects, the kernel, and objects that could be accessed from any part of the system. This is the default behavior for shared memory segments created with this call.
If IPC_MEM_LOCAL is set in shmflg, physical memory for this mapping will always be allocated from the locality domain where the call to shmget() was made. Note that this flag implicitly uses the current locality domain, so the caller should be aware of locality domain configurations and bindings. See mpctl(2).
If IPC_MEM_FIRST_TOUCH is set in shmflg, physical memory will come from the locality domain of the first processor to read or write that memory. If the shared memory is paged out and then back in again, physical memory will come from the locality domain of the processor bringing in that memory.
System V Shared Memory Under Adaptive Address Space
Itanium-based platforms have the capability to create two types of processes: MGAS (Mostly Global Address Space), which is the default, and MPAS (Mostly Private Address Space). See ld(1) and chatr(1).
If 64-bit MPAS and 64-bit MGAS processes want to share a mapping among themselves without incurring the cost of aliasing, then (shmflg & IPC_GLOBAL) should be "true", but (shmflg & IPC_SHARE32) should be "false". 64-bit MPAS processes should also specify the IPC_GLOBAL flag to the shmat(2) call. Such a mapping cannot be shared with 32-bit MGAS processes.
See the Adaptive Address Space Whitepaper for details.
The following call to shmget() returns a unique shmid for the newly created shared memory segment of 4096 bytes:
Upon successful completion, a non-negative integer, namely a shared memory identifier, is returned. Otherwise, a value of -1 is returned and errno is set to indicate the error.
shmget() fails if any of the following conditions are encountered:
Adaptive Address Space Whitepaper in http://www.hp.com/products1/unix/operating/infolibrary/.