|HP-UX Reference > A
acct(1M)HP-UX 11i Version 3: February 2007
acct: acctdisk, acctdusg, accton, acctwtmp, closewtmp, utmp2wtmp — overview of accounting and miscellaneous accounting commands
/usr/sbin/acct/acctdusg [-u file] [-p file]
/usr/sbin/acct/acctwtmp [-X] reason
Accounting software is structured as a set of tools (consisting of both C programs and shell procedures) that can be used to build accounting systems. The shell procedures, described in acctsh(1M), are built on top of the C programs.
Connect time accounting is handled by various programs that write records into the utmps database. The programs described in acctcon(1M) convert this file into session and charging records which are then summarized by acctmerg (see acctmerg(1M)).
Process accounting is performed by the HP-UX system kernel. Upon termination of a process, one record per process is written to a file (normally /var/adm/pacct). The programs in acctprc(1M) summarize this data for charging purposes; acctcms is used to summarize command usage (see acctcms(1M)). Current process data can be examined using acctcom (see acctcom(1M)).
Process accounting and connect time accounting (or any accounting records in the format described in acct(4)) can be merged and summarized into total accounting records by acctmerg (see the tacct format in acct(4)). prtacct is used to format any or all accounting records (see acctsh(1M)).
acctdisk reads lines that contain user ID, login name, and number of disk blocks, and converts them to total accounting records that can be merged with other accounting records.
acctdusg reads its standard input (usually from find -print) and computes disk resource consumption (including indirect blocks) by login. Only files found under login directories (as determined from the password file) are accounted for. All files under a login directory are assumed to belong to that user regardless of actual owner. If -u is given, records consisting of those file names for which acctdusg charges no one are placed in file (a potential source for finding users trying to avoid disk charges). If -p is given, file is the name of the password file. This option is not needed if the password file is /etc/passwd. (See diskusg(1M) for more details.)
accton turns process accounting off if the optional file argument is omitted. If file is given, it must be the name of an existing file, to which the kernel appends process accounting records (see acct(2) and acct(4)).
acctwtmp writes a utmp record to its standard output if the -X option is not used. If the -X option is used, acctwtmp writes a wtmps-like record to stdout. The record contains the current time and a string of characters that describe the reason for writing the record. A record type of ACCOUNTING is assigned (see utmp(4) and utmps(4)). The string argument reason must be 11 or fewer characters, numbers, $, or spaces if -X option is not used. Otherwise, it must be 63 or fewer characters, numbers, $, or spaces. For example, the following are suggestions for use in reboot and shutdown procedures, respectively:
closewtmp writes a DEAD_PROCESS record, for each user currently logged in, to the file /var/adm/wtmps. This program is invoked by runacct to close the existing wtmp file before creating a new one.
utmp2wtmp writes a USER_PROCESS record, for each user currently logged in, to the file /var/adm/wtmps. This program is invoked by runacct to initialize the newly created wtmps file.
acctcms(1M), acctcom(1M), acctcon(1M), acctmerg(1M), acctprc(1M), acctsh(1M), diskusg(1M), fwtmp(1M), runacct(1M), acct(2), acct(4), utmp(4). utmps(4), wtmps(4).