United States-English |
|
|
HP-UX Reference > EEvmConnection(5)HP-UX 11i Version 3: February 2007 |
|
NAMEEvmConnection — connection to the EVM (Event Management) daemon DESCRIPTIONAn EVM connection is the context through which data is passed to and from the EVM daemon. A connection has the following attributes:
These attributes are described in the following sections. An EVM client is any program that processes events through the EVM daemon. EVM supports three distinct types of client: posting clients, subscribing (listening) clients, and service clients. Regardless of type, all clients connect to the EVM daemon in the same way. Connection TypeThe type of connection established determines the client type. There are associated constants to be used when the connection is created.
Response ModeThe response mode associated with a connection determines the manner in which certain API functions will deal with the daemon's responses to request messages. See the EvmConnCreate(3) reference page for full details of each mode. The modes are:
Transport TypeThe transport type specifies the type of connection to be made to the daemon. The only valid connection that can be made is:
CallbackThis attribute specifies the function you want to handle any incoming responses resulting from activity on the connection. Callbacks are discussed in more detail in the EvmCallback(5) reference page. This attribute is valid only when the Response Mode is EvmRESPONSE_CALLBACK. Connection ContextThis attribute is a handle to a connection returned when a connection is created. You must pass this handle to all other functions you call which need to access the connection. Connection MonitoringOnce you have established a connection, the API functions will take care of all communication activity with the daemon. However, you must make sure that these functions get an opportunity to do their work when activity occurs. EVM provides several ways for you to do this. The method you choose depends on the model of your program.
Destroying a ConnectionWhen you are finished with the connection, use EvmConnDestroy() to disconnect from the daemon. It is important to check the return status for any failure each time you call a connection function and destroy the connection if a failure occurred. The file descriptor associated with the connection remains open until you destroy the connection even if I/O errors have been detected on the connection. SEE ALSORoutinesEvmConnControl(3), EvmConnCreate(3), EvmConnFdGet(3), EvmConnCheck(3), EvmConnWait(3), EvmConnDispatch(3), EvmConnDestroy(3). |
Printable version | ||
|