Jump to content United States-English
HP.com Home Products and Services Support and Drivers Solutions How to Buy
» Contact HP
More options
HP.com home
Software Distributor Administration Guide: HP-UX 11i v1, 11i v2, and 11i v3 > Chapter 7 Remote Operations Overview

Remote Operations from the Command Line

» 

Technical documentation

Complete book in PDF
» Feedback
Content starts here

 » Table of Contents

 » Glossary

 » Index

Running remote operations from the command line is almost identical to those for local operations. Key differences are:

Target Selections

By definition, you must specify a remote target for a remote operation. Unlike local operations, in which a target could be a directory on the local host system, you must specify remote systems as targets for remote operations.

swinstall -s sw_server cc pascal @ hostA hostB hostC

(This installs the C and Pascal products onto three remote hosts.)

Syntax

Software and source depot selections are followed by target selections. These operands are separated by the “@” (at) character. This syntax implies that the command operates on selections at targets.

The target_selections syntax is identical for all Software Distributor commands that require it:

@ [­host][­:­]­[­/directory]

  • Only one @ character is needed.

  • You can specify the host by its host name, domain name, or internet address. A directory must be specified by an absolute path.

  • The : (colon) is required if you specify both a host and directory.

  • On some systems, the @ character is used as the kill function. Type stty on your system to see if the @ character is mapped to any other function on your system. If it is, remove the mapping, change the mapping, or use \@.

Target Files

You can also use an input file to specify targets. To keep the command line shorter, target selection input files let you specify long lists of targets. With a target selection file, you only have to specify the single file name.

The -t command-line option lets you specify a target file. For example:

swinstall -f mysoft -s /mnt/cd -t mytargs

In this example, the file mytargs (which resides in the default directory) contains a list of target selections for the depot /mnt/cd.

In the target file, blank lines and comments (lines beginning with #) are ignored. Each target selection must be specified on a separate line and must consist of a host name or network address, optionally followed by a colon and a full path:

host[:/directory]

Examples

swacl

To list the global product template ACL on remote host gemini:

swacl -l global_product_template @ gemini

swask

To run all request scripts from depot /var/spool/sw on the remote system swposix and write a response file back to the same depot:

swask -s swposix:/var/spool/sw \*

swconfig

To configure the C and Pascal products on three remote hosts:

swconfig cc pascal @ hostA hostB hostC

swcopy

To copy the C and Pascal products to one local and two remote depots:

# swcopy -s sw_server cc pascal @ /var/spool/sw \        hostA:/tmp/sw hostB

swinstall

To install the C and Pascal products to three remote hosts:

# swinstall -s sw_server cc pascal @ hostA hostB hostC

swjob

The swjob command lets you monitors jobs from the command line. For more information about jobs, see Chapter 6: “Using Jobs and the Job Browser” and “Monitoring Jobs from the Command Line”.

To list the agent log of remote system TargetA for job hostA-0001:

# swjob -a log hostA-0001 @ targetA :/

swlist

To list the C product on three remote hosts:

# swlist cc @ hostA hostB hostC

swreg

To unregister the default depots on three remote hosts:

# swreg -u -l depot /var/spool/sw @ hostA hostB hostC

swremove

To remove the C and Pascal products from three remote hosts:

# swremove cc pascal @ hostA hostB hostC

swverify

To verify the C and Pascal products on three remote hosts:

# swverify cc pascal @ hostA hostB hostC
Printable version
Privacy statement Using this site means you accept its terms Feedback to webmaster
© 1997, 2000-2003, 2006, 2007, 2008 Hewlett-Packard Development Company, L.P.