background image
Scenario 11-3 Answers 365
!declare the translations
ip nat outside source list 1 pool XYZ-in
ip nat inside source list 1 pool ABC-out
!declare the static translation so the servers can be reached
!these lines give an constant `known' translation to the
!server addresses
ip nat inside source static 10.1.0.1 192.168.1.1
ip nat outside source static 10.1.0.18 192.168.2.1
!specify which addresses will use the pool
access-list 1 permit 10.1.0.0 0.0.255.255
!specify the interfaces
interface serial 0
ip address 172.16.4.1 255.255.255.0
ip nat outside
!
interface ethernet 0
ip address 10.1.0.2 255.255.255.0
ip nat inside
3
The primary consideration, other than NAT, is the sharing of the server address
information between the two entities. The static NAT declarations provide the capability
for the two companies to have unique addresses in each other's space for their servers;
however, it would be necessary to provide a DNS service for the users to be able to contact
the other side easily.
4
The long-term recommendation would be to implement some sort of IP renumbering and
then remove the translation between the companies.