background image
348 Chapter 11: Scaling IP Addresses with NAT
Figure 11-7
Overlapped Networks
Example 11-4 accomplishes the double translation on Router A.
Example 11-4
Overlapping Network NAT Implementation
!declare the address pools
ip nat pool coming-in 133.3.3.1 133.3.3.254 prefix-length 24
ip nat pool going-out 222.2.2.1 222.2.2.254 prefix-length 24
!declare the translations
ip nat outside source list 1 pool coming-in
ip nat inside source list 1 pool going-out
!specify which addresses will use the pool
access-list 1 permit 10.1.0.0 0.0.255.255
!specify the interfaces
interface serial 0
ip address 172.16.4.1 255.255.255.0
ip nat outside
!
interface ethernet 0
ip address 10.1.1.1 255.255.255.0
ip nat inside
!
interface ethernet 1
ip address 10.1.2.1 255.255.255.0
ip nat inside
!
interface ethernet 2
ip address 10.1.3.1 255.255.255.0
ip nat inside
Company A is translated to the 222.2.2.0/24 Network
Company B is translated to the 133.3.3.0/24 Network
Inside Network
Company A
222.2.2.0/24
Outside Network
Company B
Router A handles both translations.
A
B
10.1.1.0/24
10.1.1.0/24
10.1.2.0/24
10.1.2.0/24
10.1.3.0/24
10.1.3.0/24
172.16.4.0/24
133.3.3.0/24